DriveGUI Online Hilfe

Contents

Figures

title

general

installation

start

wizard

basic

parameter

units

can

asynchron

mot_fdbk

feedback

fb_ws

fb_test

motor

mot_feld

motor_cog

current

velocity

position

position_erw

posdata

posreg

gearing

encoder

ana_io

digi_io

mservice

status

monitor

homing

mtasktab

scope

bode

terminal

io_opt

sercos

profi

ethercat

Autotuning

safetycard

sd_card

Antriebsberechnung

Makroprogrammierung

Motorsetup

SW-Upgrade

appendix


ASCII English ACC

ASCII - Command | ACC |
Syntax Transmit | ACC [Data] |
Syntax Receive | ACC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3501 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1601 (dec) IND = 1 (dec)
Range | 3 ..126000 | DPR | 1 (dec)
Default | 31400 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Acceleration ramp

Description

This variable defines the acceleration ramp for the velocity control loop. The acceleration ramp is only used for command changes resulting in a velocity increase (acceleration). DEC is used for braking (deceleration).

See also ACCUNIT


ASCII English ACC_X

ASCII - Command | ACC_X |
Syntax Transmit | ACC_X [Data] |
Syntax Receive | ACC_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3877 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1687 (dec) IND = 33 (dec)
Range | 3 ... 126000 | DPR | 887 (dec)
Default | 3150 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 3.07 |
Configuration | Yes | Last Change of this Object | 2.0
Function Group | velocity loop | EEPROM | Yes
Short Description | acceleration ramp velocity controller 2. Set

Description

see PARCNFG


ASCII English ACCR

ASCII - Command | ACCR |
Syntax Transmit | ACCR [Data] |
Syntax Receive | ACCR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3502 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1602 (dec) IND = 1 (dec)
Range | 3 ..126000 | DPR | 2 (dec)
Default | 3150 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Acceleration ramp for homing/jog modes

Description

This variable defines the acceleration ramp used for jogging and homing with the internal position control loop.
The entry is made in ACCUNIT. If ACCUNIT =0 (acceleration in ms) ACCR is defined to PVMAX.
When starting the homing or jog mode, the ACCR acceleration ramp can (in some circumstances) be limited by the minimum acceleration time PTMIN.


ASCII English ACCUNIT

ASCII - Command | ACCUNIT |
Syntax Transmit | ACCUNIT [Data] |
Syntax Receive | ACCUNIT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3659 (hex)
DIM | - | PROFIBUS PNU | 1945 (dec) IND = 1 (dec)
Range | 0,1, ... , 30 | DPR | 345 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | digital I/O | EEPROM | Yes
Short Description | Type of acceleration setpoint for the system

Description

Using this command, the systemwide acceleration type is defined. This function is used for ramps of the trajectory generator (internal motion tasks OPMODE 8) and also for the ramps of the speed controller.

ACCUNIT = 0 in ms up to VLIM or PVMAX
ACCUNIT = 1 Acceleration is defined in rad/sec²
ACCUNIT = 2 Acceleration is defined in rpm/sec
ACCUNIT = 3 Acceleration is defined in PUNIT/sec²
ACCUNIT = 4 Acceleration is defined in 1000*PUNIT/sec²
ACCUNIT = 5 Acceleration is defined 1000000*PUNIT/sec²

If ACCUNIT=1 is selected, this Bit is ignored, this means the ramps are calculated in rad/sec².

If ACCUNIT is changed, all acc/dec parameters are calculated in a different way to get the right unit. Affected are ACC, ACCR, DEC, DECR, DECSTOP, DECDIS.

The motion tasks are not affected. So, before defining a motion task ACCUNIT has to be set in right manner. If ACCUNIT is changed later, all motion tasks have to be proofed or changed !!!!

The accdec-ramps of the motion tasks are limited bei PTMIN.

Attention!
High acceleration corresponds to small values of PTMIN at ACCUNIT=0. If ACCUNIT is > 0, PTMIN is small if the acceleration is high.


ASCII English ACTFAULT

ASCII - Command | ACTFAULT |
Syntax Transmit | ACTFAULT [Data] |
Syntax Receive | ACTFAULT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3503 (hex)
DIM | - | PROFIBUS PNU | 1603 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 3 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.8
Function Group | drive configuration | EEPROM | Yes
Short Description | Active fault mode

Description

The ACTFAULT command is used to specify the response of the drive if a fault occurs.
ACTFAULT=0: If a fault occurs, the output stage is immediately inhibited, the drive coasts down.
ACTFAULT=1: If a fault occurs, an Emergency Stop procedure is initiated, that consists of the following steps.
1. Switch over the controller mode to velocity control (OPMODE=0)
2. Change the braking ramp for the velocity control loop (DEC) to the emergency stop ramp (DECSTOP)
3. Set the internal velocity setpoint to 0 (before the ramp generator).
4. Start a timer (with time-out = 5 seconds)

As soon as the internal velocity setpoint (after the ramp generator) has reached 0, the output stage is inhibited and the original controller mode is re-activated. This will also happen if the time-out occurs before the velocity setpoint has reached 0.

comments:
In some critical error situations, the output stage is disabled immediately. Then the setting ACTFAULT = 1 has no function (see description ERRCODE *).

With the parameter ERRCNFG can be enforced on individual fault the immediate blocking of the amplifier. The setting ACTFAULT = 1 then has no function.


ASCII English ACTIVE

ASCII - Command | ACTIVE |
Syntax Transmit | ACTIVE |
Syntax Receive | ACTIVE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3504 (hex)
DIM | - | PROFIBUS PNU | 1604 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 4 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Output stage active/inhibited

Description

The ACTIVE command returns the present status of the output stage.
ACTIVE=1 output stage is active/enabled
ACTIVE=0 output stage is inhibited/disabled

The following conditions must be met to enable the output stage, depending on the controller configuration:

1. Standard configuration (no active MainsBTB function)
- software enable set
- hardware enable set
- BTB is present

2. With active MainsBTB function (O1MODE or O2MODE=3)
- Software enable set
- hardware enable set
- BTB is present
- MainsBTB (Mains supply BTB) is present
- DC-link (DC-bus) voltage > undervoltage threshold


ASCII English ACTRS232

ASCII - Command | ACTRS232 |
Syntax Transmit | ACTRS232 [Data] |
Syntax Receive | ACTRS232 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3655 (hex)
DIM | - | PROFIBUS PNU | 1941 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 341 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | RS232 | EEPROM | No
Short Description | Activate RS232 watchdog

Description

The ACTRS232 command activates or deactivates the monitoring of the serial interface (RS232-watchdog).

ACTRS232=0 no monitoring of serial communication
ACTRS232=1 the RS232-watchdog is activated. The watchdog timer can be set in msec through the RS232T command. The watchdog must be triggered by every serial command. When the timer runs out, all movement is stopped and the warning n04 is displayed. The warning must be cancelled by the “Acknowledge fault” function.
ACTRS232=2 the RS232-watchdog is activated. The watchdog timer can be set in msec through the RS232T command. The watchdog must be triggered by every serial command. When the timer runs out, the present movement is stopped and ACTRS232 is set to 0. No warning is given out.

After switching on the amplifier, the RS232-watchdog is always deactivated (ACTRS232=0). When a service function is initiated via the serial interface, the PC program (or external controls) should ensure that the monitoring of the serial interface is switched on. In this way, you can be sure that if communication is interrupted or the PC crashes, the service function will be automatically terminated.


ASCII English ADC0_15

ASCII - Command | ADC0_15 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type |  | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.9
Function Group | analog I/O | EEPROM |
Short Description | internal offset values

Description

internal offset values??. It's not(!) allowed to change this parameters by the user


ASCII English ADDR

ASCII - Command | ADDR |
Syntax Transmit | ADDR [Data] |
Syntax Receive | ADDR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Unsigned8 | CANBus Object Number | 3505 (hex)
DIM | - | PROFIBUS PNU | 1605 (dec) IND = 1 (dec)
Range | 0 .. 127 | DPR | 5 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Unsigned8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Multidrop address

Description

This variable defines the station address (0 to 63) for the amplifier. This address is required by the fieldbus (CANBUS, PROFIBUS, SERCOS, etc.) and for the parameter setting of the servo amplifier in a multi-axis system for an unambiguous identification of the servo amplifier within the system. You can use the keys on the front panel of the servo panel to set the station address (refer to the Installation Manual). After changing the address, all parameters should be stored in the EEPROM (see SAVE) and the amplifier should be switched off and on again.


ASCII English AENA

ASCII - Command | AENA |
Syntax Transmit | AENA [Data] |
Syntax Receive | AENA <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3506 (hex)
DIM | - | PROFIBUS PNU | 1606 (dec) IND = 1 (dec)
Range | 0 ,1 | DPR | 6 (dec)
Default | 0 |
Opmode | 0, 2, 4, 5, 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Software auto-enable

Description

This variable defines the state of the software enable when the amplifier is switched on. In order to enable the output stage, both the hardware enable and the software enable must be set (series AND configuration). The software enable gives an external control the option of enabling or disabling the output stage by software control, via a bus interface (CANBUS, PROFIBUS, SERCOS, RS232) or an expansion card in a slot.
0 = inactive
1 = active
When using an analog setpoint (OPMODE=1, 3), the software enable is automatically set when the amplifier is switched on, so that these instruments are instantly ready for operation (provided that the hardware enable is already present). When using a digital setpoint (OPMODE=0, 2, 4 through 8), the software enable is set to the same state as AENA at power-on.
For faults that can be reset in software after the fault has been cleared (digital input 1 or CLRFAULT), the software enable is set to the state of AENA. In this way, the response of the amplifier to a software reset is analogous to the power-on behavior.


ASCII English ALIAS

ASCII - Command | ALIAS |
Syntax Transmit | ALIAS [Data] |
Syntax Receive | ALIAS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 8 ASCII Characters | DPR | No
Default | DRIVE0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Drive name

Description

The ALIAS command is used to assign a symbolic name to an amplifier. If the PC setup software is used, this name appears in the title bar of all open parameter windows.
In Multi-Drive mode (parameterizing several amplifiers that are grouped through the CAN bus) the ALIAS name can be used to give a clear assignment of the parameter window to the corresponding amplifier.


ASCII English AN1TRIG

ASCII - Command | AN1TRIG |
Syntax Transmit | AN1TRIG [Data] |
Syntax Receive | AN1TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3880 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 33 (dec)
Range | Long Int | DPR | 896 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | No | Last Change of this Object | 2.1
Function Group | analog I/O | EEPROM | Yes
Short Description | Scaling of the analog output 1

Description

With the parameter AN1TRIG, the analog value of the monitor output 1 can be scaled to a specified ratio.
Irrespective of the function that has been configured with ANOUT1 for output 1, the output voltage is multiplied
by the factor AN1TRIG. This corresponds to the following formula:

Output voltage = Output of the function ANOUT1 * (AN1TRIG/100%)

Example:
ANOUT1 = 1 : output of the current velocity, scaling: 10V for VLIM

AN1TRIG = 100% - output=10V for velocity=VLIM
AN1TRIG = 50% - output=5V for velocity=VLIM (this corresponds to a voltage of 10V for velocity=2*VLIM)
AN1TRIG = 200% - output=20V for velocity=VLIM (this corresponds to a voltage of 10V for velocity = VLIM/2)

have a look to ANOUT1, VLIM


ASCII English AN2TRIG

ASCII - Command | AN2TRIG |
Syntax Transmit | AN1TRIG [Data] |
Syntax Receive | AN2TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3881 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 33 (dec)
Range | Long Int | DPR | 897 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | No | Last Change of this Object | 2.1
Function Group | analog I/O | EEPROM | Yes
Short Description | Scaling of the analog output 2

Description

With the parameter AN2TRIG, the analog value of the monitor output 2 can be scaled to a specified ratio.
Irrespective of the function that has been configured with ANOUT2 for output 2, the output voltage is multiplied
by the factor AN2TRIG. This corresponds to the following formula:

Output voltage = Output of the function ANOUT2 * (AN2TRIG/100%)

Example:
ANOUT2 = 1 : output of the current velocity, scaling: 10V for VLIM

AN2TRIG = 100% - output=10V for velocity=VLIM
AN2TRIG = 50% - output=5V for velocity=VLIM (this corresponds to a voltage of 10V for velocity=2*VLIM)
AN2TRIG = 200% - output=20V for velocity=VLIM (this corresponds to a voltage of 10V for velocity = VLIM/2)

have a look to ANOUT2, VLIM


ASCII English AN11NR

ASCII - Command | AN11NR |
Syntax Transmit | AN11NR [Data] |
Syntax Receive | AN11NR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3699 (hex)
DIM | - | PROFIBUS PNU | 2009 (dec) IND = 1 (dec)
Range | 0, 1, 2, 3, 4 | DPR | 409 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.01
Function Group | analog I/O | EEPROM | Yes
Short Description | No. of INxTRIG variable, that is changed analog

Description

The parameter AN11NR defines the number (x) of the auxiliary variable IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG, which can be changed by the analog input 2: This parameter has effect only with ANCNFG=11 and ANCNFG=12.


ASCII English AN11RANGE

ASCII - Command | AN11RANGE |
Syntax Transmit | AN11RANGE [Data] |
Syntax Receive | AN11RANGE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 369A (hex)
DIM | - | PROFIBUS PNU | 2010 (dec) IND = 1 (dec)
Range | -262144 .. 262143 | DPR | 410 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Range of the analog change of INxTRIG

Description

The parameter AN11RANGE gives the change of IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG, that is caused by an analog input 2 step from 0V to 10V. The function is supported using ANCNFG=11 and ANCNFG=12.

Example:

ANCNFG=11
AN11NR=1
IN1TRIG=1000
AN11RANGE=500

at Analog input2 = 0V IN1TRIG = 1000
at Analog input2 = 10V IN1TRIG = 1500
at Analog input2 = -10V IN1TRIG = 500


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Analog I/O

einheiten

Assign predefined functions to the analog inputs/outputs of the servo amplifier. Analog outputs are available only at S700 with installed extension card PosI/O-Monitor.

Screen text | ASCII parameter
Analog Inputs | ANCNFG
Offset Input 1 | ANOFF1
Current Scale Input 1 | ISCALE1
Velocity Scale Input 1 | VSCALE1
Offset Input 2 | ANOFF2
Current Scale Input 2 | ISCALE2
Velocity Scale Input 2 | VSCALE2
Filter Input 1 | AVZ1
Velocity command deadband | ANDB
Analog Output 1 | ANOUT1
Scaling Output 1 | depends on the selected function ANOUT1
D/A Offset Output 1 | DAOFFSET1
Analog Output 2 | ANOUT2
Scaling Output 2 | depends on the selected function ANOUT2
D/A Offset Output 2 | DAOFFSET2


ASCII English ANCNFG

ASCII - Command | ANCNFG |
Syntax Transmit | ANCNFG [Data] |
Syntax Receive | ANCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3507 (hex)
DIM | - | PROFIBUS PNU | 1607 (dec) IND = 1 (dec)
Range | -1 .. 14 | DPR | 7 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | analog I/O | EEPROM | Yes
Short Description | Configuration of analog input

Description

The ANCNFG command is used to configure the function of the analog inputs. Since the ANCNFG variable is used for the configuration of the instrument, the controller must be switched off and then on again after the variable has been changed (use SAVE first).
Status |  | Description
ANCNFG=0 | (Xcmd=Analog In 1) | Analog IN1 is used as velocity setpoint or current setpoint depending on the status of OPMODE (velocity in OPMODE =1; current in OPMODE=3). If one of the digital inputs is selected for (IN1MODE, IN2MODE, IN3MODE or IN4MODE=8) (switch-over between Analog In 1 and Analog In 2), Analog In 1 (input=low) or Analog In 2 (input=high) have the functionality. Scaling : Analog In 1 velocity Setpoint VSCALE1 (OPMODE=1) Analog In 1 Current Setpoint ISCALE1 (OPMODE=3) Analog In 2 velocity Setpoint VSCALE2 (OPMODE=1) Analog In 2 Current Setpoint ISCALE2 (OPMODE=3)
ANCNFG=1 | v_cmd=Analog In 1, Icmd=Analog In 2 | Analog In 1 is used as velocity setpoint if OPMODE = 1 (scaling factor VSCALE1) Analog In 2 is used as current setpoint if OPMODE = 3 (scaling factor ISCALE2)
ANCNFG=2 | Analog In 1 = nsoll, Analog In 2 = Isoll | Analog In 1 velocity setpoint Analog In 2 current feedforward scaling factor ISCALE2
ANCNFG=3 | Xcmd=Analog In 1, Ipeak1=Analog In 2 | Analog In 1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of Analog In 2 limits the current of the drive 10V 100% of IPEAK 5V 50% of IPEAK This current limit has effect to all used OPMODE
ANCNFG=4 | Xcmd=Analog In 1+Analog In 2 | The sum of Analog In 1 and Analog In 2 is used for velocity or current setpoint, depending on OPMODE. OPMODE 1 velocity setpoint OPMODE 3 current setpoint
ANCNFG=5 | Xcmd=Analog In 1*Analog In 2 | The multiplikation of Analog In 1 and Analog In 2 is used for velocity or current setpoint, depending on OPMODE. OPMODE 1 velocity setpoint OPMODE 3 current setpoint Analog In 1 VSCALE1/ISCALE1 Analog In 2 10V means 100% -10V means -100%
ANCNFG=6 | Electronic Gearing | Analog In 1 is used as velocity or current setpoint, depending on OPMODE Analog In 2 is used as scaling factor for electronic gearing (OPMODE=4). VSCALE2 is used to define a correction factor in %. e.g. VSCALE2=20 (means 20%) Analog In 2= +10V GEAROeff=GEARO * 1.2 Analog In 2= -10V GEAROeff=GEARO * 0.8 Analog In 2= 0V GEAROeff=GEARO
ANCNFG=7 | Analog In 1 = Isoll, Analog In 2 = Nmax | Analog In 1 is used as current setpoint (ISCALE1) (OPMODE has to be set to 3). Analog In 2 limits the velocity of the motor Analog In 2=10V, Nmax=(VSCALE2) If the velocity of the motor is greater than Nmax, the velocity is limited.
ANCNFG=8 | Analog In 1 = Psoll | Analog In 1 is used as a analog position setpoint (only available in OPMODE=5). The working distance is defined by SRND and ERND. Analog In 1 = 0V Position = SRND Analog In 1= +/-10V Position = ERND When the drive is switched on, the reference point is not set and the drive does not move. The OPMODE can be set to 5. The a reference move can be starte bs digital input. After that, when the homing move is finished, the input can be set to zero again and then the drive moves automatically to the given analog position. POSCNFG has to be "0" (linear axes type).
ANCNFG=10 | Reserved |
ANCNFG=11 |  | Change of an IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG variable via the Analog In 2. The corresponding Number (x) of the trigger variable is set by AN11NR. The range of the parameter change is defined by AN11RANGE. The change of the analog in 2 acts directly (update time 1 to 10ms), see also AN11NR and AN11RANGE.
ANCNFG=12 |  | Internal change of an IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG variable via the Analog In 2. The corresponding number (x) of the trigger variable is set by AN11NR. The range of the parameter change is defined by AN11RANGE. The change of the analog in 2 actsafter a rising edge at digital inputx, see also AN11NR and AN11RANGE.
ANCNFG=13 | Xcmd=Analog In 1, Ipeak1=Analog In 2 | Analog In 1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of Analog In 2 limits the positive current of the drive 10V 100% of IPEAK 5V 50% of IPEAK The negative current is not effected. In the positive direction, the acceleration current is limited and in the negative direction the deceleration current. This current limit has effect to all used OPMODE
ANCNFG=14 | Xcmd=Analog In 1, Ipeak1=Analog In 2 | Analog In 1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of Analog In 2 limits the negative current of the drive 10V 100% of IPEAK 5V 50% of IPEAK The positive current is not effected. In the negative direction, the acceleration current is limited and in the negative direction the deceleration current. This current limit has effect to all used OPMODE


ASCII English ANDB

ASCII - Command | ANDB |
Syntax Transmit | ANDB [Data] |
Syntax Receive | ANDB <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3508 (hex)
DIM | mV | PROFIBUS PNU | 1608 (dec) IND = 1 (dec)
Range | 0.0 .. 10000.0 | DPR | 8 (dec)
Default | 0 |
Opmode | 1, 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Dead band of the analog velocity input signal

Description

This variable suppresses small analog input signals by setting a dead band zone in which signals are ignored. This function is useful with OPMODE=1 (without higher-level position control). Depending on the operating mode, this parameter applies to analog input 1 or analog input 2 (depending on which setpoint input is used as the source for the velocity value). See ANCNFG for additional information.


ASCII English ANHFACT1

ASCII - Command | ANHFACT1 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English ANHFACT2

ASCII - Command | ANHFACT2 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English ANIN1

ASCII - Command | ANIN1 |
Syntax Transmit | ANIN1 [Data] |
Syntax Receive | ANIN1 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3509 (hex)
DIM | mV | PROFIBUS PNU | 1609 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 9 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | No
Short Description | Voltage at analog input 1

Description

The ANIN1 command returns the present value of the voltage at the analog input analog input 1.


ASCII English ANIN2

ASCII - Command | ANIN2 |
Syntax Transmit | ANIN2 |
Syntax Receive | ANIN2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 350A (hex)
DIM | mV | PROFIBUS PNU | 1610 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 10 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | No
Short Description | Voltage at analog input 2

Description

The ANIN2 command returns the present value of the voltage at the analog input SW2.


ASCII English ANIN3

ASCII - Command | ANIN3 |
Syntax Transmit | ANIN3 [Data] |
Syntax Receive | ANIN3 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38A0 (hex)
DIM | mV | PROFIBUS PNU | 1728 (dec) IND = 33 (dec)
Range | -10000 .. 10000 | DPR | 928 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | No
Short Description | Voltage at analog input 3 (POS I/O)

Description

Only S700

The ANIN3 command returns the present value of the voltage at the analog input analog input 3.


ASCII English ANIN4

ASCII - Command | ANIN4 |
Syntax Transmit | ANIN4 [Data] |
Syntax Receive | ANIN4 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38A1 (hex)
DIM | mV | PROFIBUS PNU | 1729 (dec) IND = 33 (dec)
Range | -10000 .. 10000 | DPR | 929 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.12
Function Group | analog I/O | EEPROM | No
Short Description | Voltage at analog input 4

Description

The ANIN4 command returns the present value of the voltage at the analog input analog input 4.


ASCII English ANOFF1

ASCII - Command | ANOFF1 |
Syntax Transmit | ANOFF1 [Data] |
Syntax Receive | ANOFF1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 350B (hex)
DIM | mV | PROFIBUS PNU | 1611 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 11 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog offset for analog input 1

Description

This variable compensates for the offset voltages of CNC controls and the analog input 1 ANIN1 . It can also correct an analog offset from external controls.


ASCII English ANOFF2

ASCII - Command | ANOFF2 |
Syntax Transmit | ANOFF2 [Data] |
Syntax Receive | ANOFF2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 350C (hex)
DIM | mV | PROFIBUS PNU | 1612 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 12 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog offset for analog input 2

Description

This variable compensates for the offset voltages of CNC controls and the analog input 2 ANIN2 . It can also correct an analog offset from external controls.


ASCII English ANOFF3

ASCII - Command | ANOFF3 |
Syntax Transmit | ANOFF3 [Data] |
Syntax Receive | ANOFF3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38A2 (hex)
DIM | mV | PROFIBUS PNU | 1730 (dec) IND = 33 (dec)
Range | -10000..10000 | DPR | 930 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog offset for analog input 3 (POS I/O)

Description

Only S700

This variable compensates for the offset voltages of CNC controls and the analog input 3 ANIN3 . It can also correct an analog offset from external controls.


ASCII English ANOFF4

ASCII - Command | ANOFF4 |
Syntax Transmit | ANOFF4 [Data] |
Syntax Receive | ANOFF4 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38A3 (hex)
DIM | mV | PROFIBUS PNU | 1731 (dec) IND = 33 (dec)
Range | -10000..10000 | DPR | 931 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog offset for analog input 4 (POS I/O)

Description

Only S700

This variable compensates for the offset voltages of CNC controls and the analog input 4 ANIN4 . It can also correct an analog offset from external controls.


ASCII English ANOUT1

ASCII - Command | ANOUT1 |
Syntax Transmit | ANOUT1 [Data] |
Syntax Receive | ANOUT1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 387E (hex)
DIM |  | PROFIBUS PNU | 1694 (dec) IND = 33 (dec)
Range | 0 .. 9 | DPR | 894 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | Yes | Last Change of this Object | 2.9
Function Group | analog I/O | EEPROM | Yes
Short Description | Configuration of the Analog Output 1

Description

Only S700 Configuration of analog output 1. The actual value is read via MONITOR1. The output provides various analog command values or actual values, depending on the selection in the operator software. Output resistor 2.2kOhm.
Status | function | description
0 | off | no output at monitor output 1
1 | n_actual | output of actual speed value (10 V = VLIM)
2 | I_actual | output of actual current value (10V = IPEAK)
3 | n_cmd | output of speed setpoint (10V = VLIM)
4 | I_cmd | output of current command value (10V = IPEAK)
5 | PE | output of position error (10V = PEMAX)
6 | slot | output of the DPR-value throuht the monitor 1 (with DPR-Slotkarte). ab FW >= 5.38
7 | PFB | the actual position is set to the analog output. The scaling refers to the modulo-value ERND-SRND. the output value is calculated by: ANOUTx = 10V * (PFB-SRND)/(ERND-SRND) if SRND is 0, the range of ERND is +/-10V. If SRND is unequal 0, the range is output is asymmetric. with PFB=SRND the output value is = 0 and PFB=ERND the output vale is = 10V.
8 | U_const=x | the constant value of AN1TRIG (in mV) is set to analog output 1
9 | I2T | output of I2T (10V = 100%)


ASCII English ANOUT2

ASCII - Command | ANOUT2 |
Syntax Transmit | ANOUT2 [Data] |
Syntax Receive | ANOUT2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 387F (hex)
DIM |  | PROFIBUS PNU | 1695 (dec) IND = 33 (dec)
Range | 0 .. 9 | DPR | 895 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | Yes | Last Change of this Object | 2.9
Function Group | analog I/O | EEPROM | Yes
Short Description | Configuration of the Analog Output 2

Description

Only S700 Configuration of analog output 2. The actual value is read via MONITOR2. The output provides various analog command values or actual values, depending on the selection in the operator software. Output resistor 2.2kOhm.
Status | function | description
0 | off | no output at monitor output 2
1 | n_actual | output of actual speed value (10 V = VLIM)
2 | I_actual | output of actual current value (10V = IPEAK)
3 | n_cmd | output of speed setpoint (10V = VLIM)
4 | I_cmd | output of current command value (10V = IPEAK)
5 | PE | output of position error (10V = PEMAX)
6 | slot | output of the DPR-value throuht the monitor 2 (with DPR-Slotkarte). ab FW >= 5.38
7 | PFB | the actual position is set to the analog output. The scaling refers to the modulo-value ERND-SRND. the output value is calculated by: ANOUTx = 10V * (PFB-SRND)/(ERND-SRND) if SRND is 0, the range of ERND is +/-10V. If SRND is unequal 0, the range is output is asymmetric. with PFB=SRND the output value is = 0 and PFB=ERND the output vale is = 10V.
8 | U_const=x | the constant value of AN2TRIG (in mV) is set to analog output 2
9 | I2T | output of I2T (10V = 100%)


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Application Notes

More application notes can be found in the KDN.

Drive calculation

The drive calculation tools AnyDim can be found on the product CDROM and on KDN page Tools).

For full functionality you must open the file with MS-Excel (not via a Web Browser). In the table you'll get additional information in the cell comments (click on red triangle in the cell).

Servo Pump

In the firmware version 5.82, the functionality of the S700 has been expanded to include the module “servo pump”. Together with the servo pump functionality, an S700 servo amplifier can be used to power a hydraulic cylinder. The entire system usually consists of a servo amplifier, a motor with position feedback unit, and a hydraulic cylinder with pressure feedback unit. The cascaded pressure/volume regulation in S700 ensures compliance with a specified cylinder pressure or flow profile.


ASCII English ANZERO1

ASCII - Command | ANZERO1 |
Syntax Transmit | ANZERO1 |
Syntax Receive | ANZERO1 | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 350F (hex)
DIM | - | PROFIBUS PNU | 1615 (dec) IND = 1 (dec)
Range | - | DPR | 15 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | No
Short Description | Zero analog input 1

Description

This command can be used to start the automatic offset correction for the analog input 1. The setpoint at analog input 1 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF1 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.

The function can adjust an offset of max. 75 mV.


ASCII English ANZERO2

ASCII - Command | ANZERO2 |
Syntax Transmit | ANZERO2 |
Syntax Receive | ANZERO2 | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3510 (hex)
DIM | - | PROFIBUS PNU | 1616 (dec) IND = 1 (dec)
Range | - | DPR | 16 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | No
Short Description | Zero analog input 2

Description

This command can be used to start the automatic offset correction for the analog input 2. The setpoint at analog input 2 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF2 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.

The function can adjust an offset of max. 75 mV.


ASCII English ANZERO3

ASCII - Command | ANZERO3 |
Syntax Transmit | ANZERO3 |
Syntax Receive | ANZERO3 | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 38A4 (hex)
DIM |  | PROFIBUS PNU | 1732 (dec) IND = 33 (dec)
Range | - | DPR | 932 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | No
Short Description | Zero analog input 3 (POS I/O)

Description

Only S700

This command can be used to start the automatic offset correction for the analog input 3. The setpoint at analog input 3 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF3 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.

The function can adjust an offset of max. 75 mV.


ASCII English ANZERO4

ASCII - Command | ANZERO4 |
Syntax Transmit | ANZERO4 |
Syntax Receive | ANZERO4 | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 38A5 (hex)
DIM |  | PROFIBUS PNU | 1733 (dec) IND = 33 (dec)
Range | - | DPR | 933 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 3.75 / 5.02 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | No
Short Description | Zero analog input 4 (POS I/O)

Description

Only S700

This command can be used to start the automatic offset correction for the analog input 4. The setpoint at analog input 4 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF4 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.

The function can adjust an offset of max. 75 mV.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Appendix

Glossary

B | Bode Plot | Resonance analysis function
C | Clock | clock signal
 | Counts | internal count pulses, 1 pulse = 1/220 turn-1
 | Current controller | regulates the difference between the current setpoint and the actual current to 0. Output: power-output voltage
D | DC-link (bus) voltage | rectified and smoothed power voltage
 | Disable | removal of the ENABLE signal (see Enable)
E | EEPROM | electrically erasable memory in the servo amplifier, data that are stored in the EEPROM are not lost if the auxiliary voltage is switched off
 | Enable | Enable signal for the servo amplifier, Hardware-Enable with 24V signal to X3, Software-Enable command by setup Software, fieldbus or permanently set. Both are required for enabling the amplifier.
F | speed limit | maximal value for the speed normalization at ±10 V
G | GRAY-code | a special way of representing binary numbers
H | Holding brake | a brake in the motor, that can only be applied when the motor is at standstill
I | I²t threshold | monitoring of the r.m.s. current that is actually drawn
 | Ipeak, peak current | the r.m.s. value of the pulse current
 | Irms, r.m.s. current | the r.m.s. value of the continuous current
K | KP, P-gain | proportional gain of a control loop
L | Limit-switch | to limit the range of movement of the machine; implemented as an n.c. (break) contact
M | Machine | the total assembly of parts or devices connected together, of which at least one is movable.
 | Monitor output | output of an analog measurement
 | Motion block | a packet of data containing all the position parameters required for a motion task
P | P controller | a control loop that has purely proportional response
 | Phase shift | compensation for the lag between the electromagnetic and the magnetic field in the motor
 | PID controller | control loop with proportional, integral and differential response
 | Position controller | regulates the difference between the position setpoint and the actual position to 0. Output: speed setpoint
R | RAM | volatile memory in the servo amplifier. Data that are stored in the RAM are lost when the auxiliary voltage is switched off.
 | Regen circuit | converts regenerative energy that is fed back by the motor, during braking, into heat in the regen resistor.
 | Reset | new start of the microprocessor
 | Reversing mode | operating with a periodic change of direction
 | ROD interface | incremental position output (A quad B)
S | Speed controller | regulates the difference between the speed setpoint SW and the actual speed to 0. Output: current setpoint
 | SSI interface | cyclically absolute, serial position output
 | Setpoint ramps | limiting of the rate of change of the speed setpoint value
T | Tn, integration time | integral component of the control loop
Z | Zero pulse/mark | is produced by incremental encoders, once per turn, used to zero the machine

Related Documents

All the documents listed below can be found on the Product CDROM and downloaded from the File Selector.

Manuals

  • Instructions Manual (assembly, installation, setup)
  • CANopen manual
  • PROFIBUS manual
  • SERCOS manual
  • DeviceNet manual
  • EtherCAT manual
  • Manuals for several motor series
  • Accessories manual

Errors

Any errors that occur are shown in coded form by an error number (see ERRCODE) in the LED display on the front panel. Additional information coded with "ixx" are shown for faults with an asterix "*" in the table below (ERRCODE2).

The servo amplifier reaction depends on the fault and on the setting of parameter ACTFAULT.
Faults can be reset by hardware reset of the servo amplifier or depending on the fault (see ERRCODE) by ASCII command CLRFAULT.

Notes for cause and remedy see Trouble Shooting.

Code | Explanation |
E | Status Message | DC-Link voltage ok. Amplifier is enabled.
P | Status Message | DC-Link voltage ok. Amplifier is disabled.
. . . | Status Message | Amplifier is updating the startup configuration
- | Status Message | Status message, no error, programming mode
- S - | Status Message | STO-Enable input is 0V (with disabled drive only)
888 | Status Message | FPGA program not loaded
nd0 | Status Message | Non Dual Use Firmware (labelled with “_ND0") is used.
nd1 | Status Message | An AL-3A225 (ECCN 3A225) export classified Dual Use Firmware (labelled with “_ND1") is used.
CCC | Memory Card | Access problems memory card
dUF | Dual Use Firmware | An AL-3A225 (ECCN 3A225) export classified firmware cannot be uploaded to a non Dual Use amplifier. A firmware labelled with “_ND0" must be used.
F01 | Heat Sink Temperature | Heat sink temperature too high (default: 80°C)
F02 | Overvoltage | Overvoltage in DC bus link. Limit depends on the electrical supply voltage
F03 | Following Error | Message from the position controller
F04* | Feedback | Cable break, short-circuit, short to ground
F05 | Undervoltage | Undervoltage in DC bus link (default: 100 V)
F06 | Motor Temperature | Motor temperature too high or temp. sensor defect
F07* | Internal Voltages | Internal supply voltages not ok
F08 | Overspeed | Motor runs away, speed is too high
F09 | EEPROM | Checksum error
F10 | Reserved | Reserved
F11 | Brake | Cable break, short-circuit, short to ground
F12 | Motor Phase | Motor phase missing (cable break or similar), in process
F13 | Ambient Temperature | Ambient temperature too high
F14* | Output Stage | Fault in the power output stage, also with wrong motor cable or insufficient cable shielding
F15 | I²t max. | I²t maximum value exceeded
F16 | Mains BTB/RTO | 2 or 3 phases missing in the mains supply feed
F17 | A/D Converter | Error in the analog-digital conversion, normally caused by extreme electromagnetic interference
F18* | Brake Circuit | Brake circuit faulty or incorrect setting
F19 | DC Bus Link | DC bus link breakdown
F20* | Slot Error | Slot error, depends on the type of expansion card (see ASCII object reference, ERRCODE)
F21 | Handling Error | Handling error on the expansion card
F22 | Reserved | Reserved
F23 | CAN-Bus Off | Severe CAN bus communication error
F24 | Warning | Warning is displayed as fault
F25* | Commutation Error | Commutation error
F26 | Limit Switch | Hardware limit switch error on homing move
F27 | STO | Operational error with STO , input for STO-Enable and ENABLE have been set at the same time
F28 | Fieldbus Error | Synchronization error (see ASCII command reference, ERRCODE)
F29* | Fieldbus Error | Communication expansion card / fieldbus disturbed (see ASCII command reference, ERRCODE)
F30 | Emergency Timeout | Timeout emergency stop
F31 | Safety Card Error | Safety Errorcode (see file "Safety Card Error Codes" from Download page File Selector): oXX : Safety error number iYY : Safety error subindex
F32* | System Error | System software not responding correctly

Warnings

Faults which occur, but which do not cause a switch-off of the amplifier output stage (BTB/RTO contact remains closed), are indicated in the LED display on the front panel by a coded warning number.

Some warning messages result in a controlled shut-down of the drive (braking by emergency stop ramp).
The servo amplifier reaction depends on the warnin(see STATCODE).

Notes for cause and remedy see Trouble Shooting.

Number | Designation | Explanation
E | Status Message | DC-Link voltage ok. Amplifier is enabled.
P | Status Message | DC-Link voltage ok. Amplifier is disabled.
. . . | Status Message | amplifier is updating the startup configuration
- | Status Message | status message, no error, programming mode
- S - | Status Message | STO-Enable input is 0V (with disabled drive only)
888 | Status Message | FPGA Programm nicht geladen
nd0 | Status Message | Non Dual Use Firmware (labelled with “_ND0") is used.
nd1 | Status Message | An AL-3A225 (ECCN 3A225) export classified Dual Use Firmware (labelled with “_ND1") is used.
n01 | I²t | I²t threshold exceeded
n02 | regen power | reached preset regen power limit
n03 | S_fault | exceeded preset following error limit
n04 | response monitoring | response monitoring (fieldbus) has been activated
n05 | supply phase | mains supply phase missing
n06 | SW limit switch 1 | passed software limit switch 1
n07 | SW limit switch 2 | passed software limit switch 2
n08 | motion task error | a faulty motion task was started
n09 | no reference point | no reference point (Home) set at start of motion task
n10 | PSTOP | PSTOP limit-switch activated
n11 | NSTOP | NSTOP limit-switch activated
n12 | motor default values loaded | only for ENDAT or HIPERFACE® : discrepancy between motor number saved in the encoder and the amplifier, motor default values loaded
n13 | expansion card | 24V DC supply for I/O expansion card not ok
n14 | SinCos feedback | SinCos commutation (wake & shake) not completed, will be canceled when amplifier is enabled and wake & shake carried out
n15 | Reserve | Reserve
n16 | summarized warning | summarized warning for n17 to n31
n17 | fieldbus-sync | CAN sync is not logged in
n18 | multiturn overflow | max. number of motor turns exceeded
n19 | motion task ramps are limited | range overflow on motion task data
n20 | invalid motion task | invalid motion task
n21 | PLC program error | for details see PLC code
n22 | max. motor temperatur reached | the user can shut down the process before the motor temperature error will interrupt the process immediately
n23 | Sin Cos feedback | warning level reached
n24 | Digital I/O | configuration is not logical
n25-n31 | Reserve | Reserve
n32 | firmware beta version | firmware is an unreleased beta version

Trouble Shooting

There may be a wide variety of reasons for the fault, depending on the conditions in your installation.
In multi-axis systems there may be further hidden causes of a fault.

Eliminate errors and faults in compliance with work safety rules. Troubleshooting only by qualified and trained staff.

Our customer service will assist in case of issues not listed below.

Help with Faults

Display | Meaning | Possible causes | Measures/ explanation
HMI message: Communication fault |  | Wrong cable used | Use null-modem cable
 |  | Cable plugged into wrong position on servo amplifier or PC | Plug cable into the correct sockets on the servo amplifier and PC
 |  | Wrong PC interface selected | Select correct interface
F01 | Heat Sink Temperature | Heat sink temperature too high | Max. value MAXTEMPH adjusted by manufacturer to 80°C. Decrease ambient temperature.
 |  | Amplifier contaminated | Check / blow out ventilation slots. Use air filters.
 |  | Fan defective / non-contacted | Check the air flow / fan noise; if defective, send the amplifier to the manufacturer for repair.
 |  | Value MAXTEMPH too small | Range 20 .. 85°C, default 80°C
 |  | No air flow due to restricted installation | Conversion of the switchgear cabinet. Install an air-conditioning unit.
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
F02 | Overvoltage in DC Bus Link Max. value depends on the set mains voltage | Regen energy too high | "n02" displayed beforehand. Possibly use an external braking resistor or, in the case of multiple amplifiers, connect DC links.
 |  | Mains voltage set too low | Set the mains voltage correctly on the Basic Setup screen page
 |  | Regen resistor configured incorrect | Set the details for the internal or external braking resistor correctly on the Basic Setup screen page
 |  | Regen resistor wired incorrect | Check the wiring (see Instructions Manual). Internal braking resistor: Bridge must be present on the connector! External braking resistor: Bridge must be removed from the connector!
 |  | Fuse in regen resistor defect | Replace fuse
 |  | Braking ramps too short | Extend the braking ramps on the Velocity Loop screen page
 |  | DC Bus not linked to other amplifiers | In the case of multiple amplifiers from the same family, connect the DC links (see Instructions Manual)
F03 | Following error message of the position controller (in OPMODE 5 or 6 only) | Axis is mechanically tight or blocked | Check the mechanical system
 |  | Inadequate torque for the ramps set | Travel along flatter ramps (ACC, DEC)
 |  | Ramps in the speed controller are longer than ramps in the position controller | Lower the acceleration ramp (ACC) and braking ramp (DEC) in the speed controller
 |  | Amplifications set too low. Axis is too undynamic | Adjust the amplification. Velocity Loop and possibly Position Loop screen pages
 |  | Amplifications set too high. Axis oscillates. | Adjust the amplification. Velocity Loop and possibly Position Loop, screen pages, insert a filter
 |  | IPEAK (maximum current) too low | Enlarge the following error window (Position Data screen page) or use a larger amplifier / motor, increase IPEAK .
F04 | Feedback | Short circuit, short to ground | Check the feedback cable
 |  | Encoder defective | Exchange encoder / motor
 |  | Contacts in connector not OK | Check contacts
 |  | Incorrect feedback set | See FBTYPE
 |  | Incorrect / defective feedback cable | Check cable (particularly critical in the cable trailing device)
 |  | Incompatible feedback | See FBTYPE
 |  | Poorly shielded cables | Use suitable cables (see Instructions Manual)
 |  | Feedback cable is too long | Adhere to the max. permissible cable length (see Instructions Manual)
 |  | Coupling fault signals | Check shielding, ensure compliance with the minimum spacing between the power cables and the signal connections (see Instructions Manual)
F05 | Undervoltage | Mains contactor not connected | Wiring / Emergency stop / Control logic / ...
 |  | Switch-on sequence not complied with | First of all switch on the power contactor which is connected via the BTB contact. Then switch the enable signal on approx. 0.5s later
 |  | Emergency stop has cut off the mains voltage | Operator information
 |  | VBUSMIN parameter set too low. | Adjustment of the parameter, e.g. in 48VDC applications.
 |  | The monitor has to be switched off in some applications with UVLTMODE | Example: Positioning the axis in the event of mains failure.
F06 | Motor Temperature | Motor overheating | Incorrect motor parameters / Poor cooling
 |  | Defective temperature sensor | Measure the sensor resistance. Switch: low temperature: switch closed high temperature: switch open. PTC thermistor: low temperature: low resistance high temperature: high resistance
 |  | Connector on the feedback unit loose or feedback cable interrupted | Connector / cable control
 |  | Motor without a temperature sensor | Installation of a bridge in the connector
 |  | Cutoff threshold for the temperature sensor is set too low | Set the MAXTEMPM parameter (to the cutoff threshold, see parameter description)
 |  | Amplifier defective | Bridge the temperature contact for testing at the resolver or SinCos interface
 |  | Unused thermostatic switch / element | Contact Customer Support
F07 | Internal Voltages faulty | External short circuit or overload on a power supply voltage | Disconnect all the connectors apart from 24V and check whether the error occurs again when you switch on
 |  | 24V undershot for amplifier logic | Adhere to the tolerance criteria for the 24V voltage supply (see Instructions Manual)
 |  | Motor brake with excess current consumption. | Adhere to the maximum motor brake current (see Instructions Manual); supply brake with external voltage.
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
 |  | Feedback system with excess current consumption. | Contact Customer Support
F08 | Overspeed | Speed in excess of permissible limit | Check the VOSPD (limit speed) and raise it, if necessary.
 |  | Speed in excess of permissible limit | Reduce overswing by assigning amplification parameters
 |  | Feedback cable is defective | (Possibly check by shaking the cable) Replace the cable
 |  | VLIM too low | When a new motor is loaded, quicker motors with a max. of only 3,000 rpm are also entered. The end speed and overspeed have to be adapted for higher speeds.
 |  | Motor vibrates. | Parameter adaptation
 |  | Tables of motion tasks with a time base which is too low. | Increase target times or use a motor with a higher nominal speed
 |  | Feedback on the incorrect motor inserted. | Check and correct assignment
 |  | Motor phases inverted | Check the pin assignment
 |  | Feedback incorrectly set | Set angle offset correctly (MPHASE)
F09 | EEPROM Checksum Error | Amplifier switched off during the storage process | Re-enter parameters and save them
 |  | Manually changed parameter record loaded with lower-case lettering. | Change the lower-case lettering to upper case
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
F10 | Cable brake at X5 | Connector / cable problem | Check connectors / cables.
 |  | Monitor in the slave responds too soon after a restart | Set the parameter SDLY to 8,000. (FW 1.31 or higher)
 |  | No differential-mode voltage signals used | Signal sources must switch between –5V and 5 V, not between 0V and 5V.
F11 | Cable brake motor brake | Short circuit, short to ground | Replace the cable
 |  | Motor cable without brake wires | Connect the right motor cable
 |  | Motor without a brake | Set MBRAKE to 0
 |  | Motor brake current consumption too low. | Raise current consumption to a minimum of 150mA (e.g. through parallel resistors).
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
F12 | Motor Phase | Shield on the motor cable is badly attached or missing | Check the shield connections
 |  | Strong external EMC interference | Additional design of motor shields on the mounting plate of the switchgear cabinet.
 |  | Motor cable capacity is too high | Use a motor choke / Shorten the cable / Use cables
 |  | Installed motor contactor does not switch on time. | Check contactor
 |  | Installed motor contactor has burnt contacts. | Check contactor
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
 |  | Motor connector not plugged in the servo amplifier or motor. | Check connector
F13 | Ambient Temperature too high | Ambient Temperature too high | Use a cooling device
 |  | Detection faulty (usually combined with F17) | Return the servo amplifier to manufacturer for repair
 |  | Cutoff threshold is too low | Increase TEMPE
 |  | Switchgear cabinet is too warm. | Use a cooling device
F14 | Output Stage | Short circuit in the motor cable | Replace motor cable
 |  | Output stage faulty | Return the servo amplifier to manufacturer for repair
 |  | Insulation fault in the motor | Conduct measurements with an ohmmeter between the motor phases: must be symmetrical. Measure the motor phases to the PE; it must be unending. If there is a high-voltage tester available, use it to measure the motor phases to PE.
 |  | Motor contactor does not switch on time. | Check the switching sequence
 |  | Motor contactor has burnt contacts. | Replace motor contactor.
F15 | I²t maximum value exceeded | Drive is mechanically tight | Check mechanical system, use a larger amplifier/motor
 |  | Sine² ramps | Extend the acceleration/braking ramps (ACC, DEC)
 |  | Incorrect design | Contact Customer Support
 |  | Incorrect phase angle between feedback and magnet elements in the motor. | Correct the MPHASE , possibly reset with ZERO.
 |  | Ramps are too steep | Extend the acceleration/braking ramps (ACC, DEC)
 |  | Intervals are too short | Extend the recovery intervals between motion tasks (Motion Tasks screen page)
 |  | Vibration in the current controller | Adjust the amplification of the MLGQ and the KTN reset time
 |  | Motor has an inter-turn fault (only in the case of a partial short circuit) | Replace motor
F16 | Mains BTB - 1, 2 or 3 phases of the in-feed missing | Three-phase operation is set in the case of a single-phase in-feed. | Check setting on screen page Basic Setup
 |  | Phases missing from in-feed. | Check wiring/fuses/main contactor
 |  | Special settings are required for a DC in-feed. | Contact Customer Support
 |  | Amplifier enabled even though they was no mains voltage | Amplifier only enabled when the mains voltage is switched on (comply with switch-on sequence)
F17 | A/D converter error | Strong electromagnetic interference | Reduce EMC interference; check shielding and earthing. Mount devices which generate electrical fields further away from the amplifier.
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair
F18 | Regen Circuit | Regen resistor extern selected, but the internal one is used. | Check setting on screen page Basic Setup
 |  | Destroyed regen transistor | Return the servo amplifier to manufacturer for repair
F19 | DC Bus Link (can be switched off for operation with two phases mains) | There is no voltage at the power terminals. | Check and switch on power supply
 |  | Voltage level is incorrectly configured. | Adapt VBUSMIN
 |  | Excessive load on the DC link during acceleration in combination with a soft voltage source (isolation transformer) | Adapt parameters or hardware
F20 | Slot Error | Hardware error and the expansion card | In the case of expansion card I/O-14/08, check the card's external power supply unit
 |  | Incorrect PROFIBUS card | Contact Customer Support
 |  | Firmware does not support the card which is inserted. | Contact Customer Support
 |  | Card is not inserted correctly | Remove the card and insert a new one and tighten it, following the instructions in the Instructions Manual.
 |  | Power consumption of the plug-in card is too high. | Contact Customer Support
 |  | POS I/O card not initialized | Terminal: enter CALCPOSIO
F21 | Handling Error | Software error on the expansion card | Contact Customer Support
 |  | Plug-in card not permitted | Contact Customer Support
F22 | Reserved | Reserved |
F23 | CAN Bus | Severe CAN bus communication error. | Check CAN cable and controller
F24 | Warning | Warning is displayed as fault | With the WMASK parameter you can read out which warning(s) are evaluated as errors. On the basis of this information, refer to the list of warning messages. The LASTWMASK parameter indicates which warning last led to F24.
F25 | Commutation error (motor may have oversped) Power vector and motion are in reverse. | Wiring error in motor phases | Test motor cable fully – Adapt DIR
 |  | Wiring error on feedback cable | Check direction of rotation in the monitor window, test feedback cable fully – Adapt DIR
 |  | Internal clearance / oscillation of the mechanical system | Examine mechanical system and align it, if necessary
 |  | Monitor is too sensitive | Raise VCOMM (VCOMM = MSPEED means minimum sensitivity)
 |  | Motor cable / feedback cable from another motor plugged in. | Check and correct amplifier-motor assignment.
 |  | Offset too high | Check resolver pole number (MRESPOLES), motor pole number (MPOLES) and offset (MPHASE)
 |  | Wake&Shake failed | Perform Wake&Shake
F26 | Limit switch Homing error Hardware Limit Switch reached (defined by REFLS) | Cable brake (limit switches) | Check cable
 |  | Limit switches connected do not belong to the axis. | Check and correct limit switch-axis assignment.
 |  | No limit switches connected. | Disable input functions (Digital I/O screen page)
 |  | Limit switches inverted. | Assign PSTOP and NSTOP correctly to the inputs (Digital I/O screen page)
F27 | STO error | The STO-enable was switched at the same time as or later than the amplifier-enable. | Consider Switch-On sequence (see Instructions Manual)
 |  | Cable fault (STO wiring) | Check wiring, measure cable-resistance.
F28 | Fieldbus, ext. trajectory | "External trajectory" error is generated if the setpoint jump exceeds the maximum permissible value when the external position trajectory is specified. | Adaptation of the specified values (VLIM / PVMAX)
 |  | EtherCAT: The "synchronization" error is generated if the drive cannot be synchronized during phase ramp-up or if the drive loses its synchronization in EtherCAT "Operational" state. | Check EtherCAT system.
F29 | Expansion card | Software Enable set without Hardware Enable | Set Hardware Enable first
 |  | Software Enable set but mains voltage switched off | Switch on mains voltage first
 |  | Expansion card not supported by firmware (e.g. customer specific firmware). | Upgrade firmware
 |  | Feldbus synchronization via expansion card not successful | Check performance of fieldbus master
 | EtherCAT | CLRFAULT although fault requires a COLDSTART. This is an error only, if parameter SERCSET bit 0x00080000 is "1". | Enter COLDSTART in the terminal screen
 |  | Selected mapping number not valid. | Select valid mapping number
 |  | Mapping length faulty | Check mapping length
 | SYNQNET | Set point applied while n14 - Wake&Shake is present | Apply set point after W&S procedure has ended
 |  | Phase Start Time Out finished (between Phases 3 and 4) | Check network structure
 |  | „Upcount Lifetime counter“ finished |
 |  | Peercop Timeout finished |
 | SERCOS | Fiber optic cable broken | Replace fiber optic cable
 |  | MST error | Check SERCOS Master
 |  | Not allowed interrupt | Check programming
 |  | Internal SERCOS error (unknown ASIC version) | Check hardware
 |  | Invalid SERCOS mode |
F30 | Emergency Stop Timeout Default 5.000ms Motor doesn't stop in the set time. | Brake ramp too long | Decrease DECSTOP
 |  | Peak current set too small | Increase IPEAK
 |  | Brake time too short | Increase EMRGTO
 |  | Amplifier too small | Select servo amplifier with higher rated/peak current
F31 | Safety Card Error | Safety card response supervision Safety Errorcode (see file Safety Card Error Codes on our download page File Selector): oXX : Safety Error Number iYY : Safety Error Subindex | Check error code of the safety card (see file Safety Card Error Codes on our download page File Selector)
F32 | System error, System software doesn't work correctly | Processor overloaded | Too many stations in the network/Baud rate too high/Functions too complex (PLC)
 |  | Hardware faulty | Return the servo amplifier to manufacturer for repair

Help with Warnings

Display | Meaning | Possible causes | Measures/ explanation
n01 | I²t treshold exceeds the set limit value I2TLIM. | Mechanical system is tight | Check the mechanical system
 |  | Amplifier dimensions too low | Use an amplifier with a higher current
 |  | Motor dimensions too low | Use a motor with a higher current
 |  | Driving profile is too aggressive | Define recovery times
n02 | Brake power exceeds the set limit value PBALMAX. | Incorrect brake power set | Check setting
 |  | Internal brake resistance too low | Use external brake resistance, extend braking ramps (DEC / DECSTOP )
n03 | Following error exceeds the set limit value PEMAX. | Mechanical system is tight | Check the mechanical system
 |  | Amplifier dimensions too low | Use an amplifier with a higher current
 |  | Driving profile is too aggressive | Define recovery times, extend ramps
 |  | Following error set too low | Check setting
n04 | Fieldbus communication monitor has responded (EXTWD). | During commissioning: no fieldbus connected | Disable watchdog temporarily (EXTWD = 0)
 |  | In operation: communication problem | Check bus installation
n05 | One of the three mains phases is missing |  | Check the mains connection, fuses and mains contactor
n06 | Position setting for software limit switch 1 (SWE1 ) has been undershot | Axis has been moved beyond the position which has been configured as the end position | Check the position of the axis and setting of the software limit switch
n07 | Position setting for software limit switch 2 (SWE2) has been exceeded | Axis has been moved beyond the position which has been configured as the end position | Check the position of the axis and setting of the software limit switch
n08 | Defective motion task | Commenced motion task does not exist (checksum is defective) | Create a new motion task
 |  | Target position lies outside the permissible range | Check software limit switches and target positions
 |  | Defective acceleration values | Check units and numerical values
 |  | OPMODE does not support the function | Set correct OPMODE
n09 | No reference point | No reference point set when a motion task is started. | Perform homing or set reference point
n10 | Hardware Limit Switch PSTOP | Positive limit switch has responded | Move the axis in a negative direction from the limit switch
 |  | Limit switch not connected | Change the parameterization of digital I/Os or connect the limit switch
 |  | Limit switch sensor has incorrect logic. | Insert break contacts as limit switches (instead of make contacts).
n11 | Hardware Limit Switch NSTOP | Negative limit switch has responded | Move the axis in a positive direction from the limit switch
 |  | Limit switch not connected | Change the parameterization of digital I/Os or connect the limit switch
 |  | Limit switch sensor has incorrect logic. | Insert break contacts as limit switches (instead of make contacts).
n12 | Motor default values loaded | Motor numbers stored in the encoder and amplifier do not match the parameters that have been set | SAVE motor number to the EEPROM and with HSAVE to the encoder.
n13 | Expansion card | 24V supply for the I/O expansion card missed | Check wiring and 24V power supply
n14 | SinCos-Feedback | SinCos commutation (wake&shake) not completed | ENABLE the amplifier
n16 | Summarized Warning | Summarized warning for n17 to n31 | See warning #
n17 | Feldbus Sync | CAN sync is activated, but is not sent synchronously from the controller, if at all. | Check fieldbus settings
n18 | Multiturn overflow | More than +/-2048 revolutions counted with the multiturn encoder connected | Ignore or disable monitoring with DRVCNFG Bit7=1
 |  |  | Move motor to encode position 0 prior to installation
n19 | Motion task ramps have been limited | Permissible value range exceeded by the process block data | Check the process block data
n20 | Invalid motion task |  | Check the data from the last process block started. Also determine the process block number with MOVE.
n21 | Warning by PLC Program | Only in the macro program in the servo amplifier | Application-specific
n22 | Max. motor temperature reached | Alarm threshold setting exceeded, motor overloaded | Check the motor temperature.
 |  | Mechanical system is tight/blocked | Check the mechanical system
n23 | Sine-Cosine Encoder | Signal amplitude is too low | Check the signal amplitude, possibly re-measure with an oscilloscope
n24 | Digital Inputs | Illogical configuration | Undo the last configuration change
n32 | Firmware Beta Version | For testing reasons only | No warranty by the manufacturer for error free functionality

Help with other problems

The situations listed below are not necessarily monitored by a message.

Problem | Possible causes | Measures
Motor does not rotate | Servo amplifier not enabled | Apply ENABLE signal
 | Software enable not set | Set software enable
 | Break in setpoint cable | Check setpoint cable
 | Motor phases swapped | Correct motor phase sequence
 | Brake not released | Check brake control
 | Drive is mechanically blocked | Check mechanism
 | Motor pole no. set incorrectly | Set motor pole no.
 | Feedback set up incorrectly | Set up feedback correctly
Motor oscillates | Gain is too high (speed controller) | Reduce Kp~GV (speed controller)
 | Feedback cable shielding broken | Replace feedback cable
 | AGND not wired up | Join AGND to CNC-GND
Drive too soft | Kp~GV (speed controller) too low | Increase Kp~GV (speed controller)
 | Tn~GVTN (speed controller) too high | Use motor default value for Tn~GVTN (speed controller)
 | ARLPF / ARHPF too high | Reduce ARLPF / ARHPF
 | ARLP2 too high | Reduce ARLP2
Drive runs roughly | Kp~GV (speed controller) too high | Reduce Kp~GV (speed controller)
 | Tn~GVTN (speed controller) too low | Use motor default value for Tn~GVTN (speed controller)
 | ARLPF / ARHPF too low | Increase ARLPF / ARHPF
 | ARLP2 too low | Increase ARLP2
Axis drifts at setpoint = 0V | Offset not correctly adjusted for analog setpoint provision | Adjust offset (analog I/O)
 | AGND not joined to the controller-GND of the controls | Join AGND and controller-GND


ASCII English ARHPD

ASCII - Command | ARHPD |
Syntax Transmit | ARHPD [Data] |
Syntax Receive | ARHPD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3607 (hex)
DIM |  | PROFIBUS PNU | 1863 (dec) IND = 1 (dec)
Range | 0 ... 10 | DPR | 263 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Float 32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Damping high pass filter

Description

ARHPD is the high-pass damping of the velocity-loop filter.

For a detailed description of how to set up the velocity-loop filter, see BQMODE.


ASCII English ARHPF

ASCII - Command | ARHPF |
Syntax Transmit | ARHPF [Data] |
Syntax Receive | ARHPF [Data] | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3608 (hex)
DIM |  | PROFIBUS PNU | 1864 (dec) IND = 1 (dec)
Range | 0 ... 4000 | DPR | 264 (dec)
Default | 1000 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Frequency limit high pass filter

Description

ARHPF is the high-pass frequency of the velocity-loop filter.

For a detailed description of how to set up the velocity-loop filter, see BQMODE.


ASCII English ARLP2

ASCII - Command | ARLP2 |
Syntax Transmit | ARLP2 [Data] |
Syntax Receive | ARLP2 [Data] | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3609 (hex)
DIM | Hz | PROFIBUS PNU | 1865 (dec) IND = 1 (dec)
Range | 0 ... 1500 | DPR | 265 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Low pass filter

Description

ARLP2 is the cut-off frequency of an additional 1st-order low-pass filter for the velocity loop. If If ARLP2 is set to a value > 0, the filter is activated, otherwise it is turned off.

Low-pass filters are used to suppress signals of higher frequencies (e.g. resonances and noise). Applying a low-pass filter to the velocity loop leads to an undesired phase lag above the filter's cut-off ferquency besides the desired signal attenuation. This leads to a degradation of phase margin. Thus, the velocity-loop bandwidth is always < 0.5 times the low-pass cutt-off frequency.

For a detailed description of how to set up the velocity-loop filter,see BQMODE.


ASCII English ARLPD

ASCII - Command | ARLPD |
Syntax Transmit | ARLPD [Data] |
Syntax Receive | ARLPD [Data] | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 360A (hex)
DIM |  | PROFIBUS PNU | 1866 (dec) IND = 1 (dec)
Range | 0 ... 10 | DPR | 266 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Damping low pass filter

Description

ARLPD is the low-pass damping of the velocity-loop filter.

For a detailed description of how to set up the velocity-loop filter,see BQMODE.


ASCII English ARLPF

ASCII - Command | ARLPF |
Syntax Transmit | ARLPF [Data] |
Syntax Receive | ARLPF [Data] | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 360B (hex)
DIM |  | PROFIBUS PNU | 1867 (dec) IND = 1 (dec)
Range | 0 ... 4000 | DPR | 267 (dec)
Default | 160 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Frequency limit low pass filter

Description

ARLPF is the low-pass frequency of the velocity-loop filter.

For a detailed description of how to set up the velocity-loop filter, see BQMODE.


ASCII object reference

Your web browser is not sufficient. Please install a modern browser.


ASCII English ASMWAIT

ASCII - Command | ASMWAIT |
Syntax Transmit | ASMWAIT [Data] |
Syntax Receive | ASMWAIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3868 (hex)
DIM | ms | PROFIBUS PNU | 1672 (dec) IND = 33 (dec)
Range | 0 .. 2000 | DPR | 872 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Forced delay of the velocity command value for induction machines

Description

Forced delay of the velocity command value for induction machines.
An induction machine has to be magnetized before it can generate torque.
ASMWAIT sets a forced delay time, during which the velocity command value is kept at 0 after the drive is enabled. When the machine is completely magnetized, it can start with full torque.

Operation without brake (MBRAKE = 0):
Q-current is allowed directly after enabling the drive, to keep the shaft from moving too much.

Operation with brake (MBRAKE = 1):
TBRAKE0 inhibits Q-current, to prevent machine from working against the brake, before it is lifted completely.
ASMWAIT < TBRAKE0: After enable, velocity command and Q-current are kept ant 0 for the duration of TBRAKE0. The brake is lifted immediately. Magnetization begins before the end of TBRAKE0 (defined by ASMWAIT).
ASMWAIT > TBRAKE0: After enable, velocity command and Q-current are kept ant 0 for the duration of ASMWAIT. Magnetization begins immediately. The brake is being lifted before the end of ASMWAIT (defined by TBRAKE0).


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

V/f Control

uf

This screen page only appears if the setup wizard "Asynchron Motor (V/f Control)" is selected. All required parameters for the operation of an induction machine (asynchron motor) can be set here.

Screen text | ASCII parameter
Speed 1 | SKIP1SP
Width 1 | SKIP1W
Speed 2 | SKIP2SP
Width 2 | SKIP2W
Io | MICONT
Iomax | MIPEAK
Acc. Ramp | ACC
Dec. Ramp | DEC
No. of Poles | MPOLES
Rated Voltage | MUR
Minimum Voltage | VSTART
Rated Velocity | MVR
Gain | IQFILTK
Power Factor | MCOSPHI
LP Time Constant | IQFILTTAU
Rated Frequency | MFR
Deceleration/Disable Behavior (Error) | ACTFAULT
Dec.Ramp (Error) | DECSTOP
Deceleration/Disable Behaviorn (Disable Command) | STOPMODE
Dec.Ramp (Disable) | DECDIS

Hints for sensorless operation of asynchron motors: see application note Asynchron machine - V/f Control.


ASCII English AUTOHOME

ASCII - Command | AUTOHOME |
Syntax Transmit | AUTOHOME [Data] |
Syntax Receive | AUTOHOME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D7 (hex)
DIM |  | PROFIBUS PNU | 1671 (dec) IND = 17 (dec)
Range | 0,1 | DPR | 471 (dec)
Default | 0 |
Opmode | 8, 4 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Automatic homing

Description

The Command AUTOHOME selects, if the homing procedure will be started automatic.

AUTOHOME=0 no automatic homing prcedure started

AUTOHOME=1 After the drive is enabled the homing procedure MH is started automatic

FW > 1.31
AUTOHOME=2 After the drive is enabled the homing procedure MH is started automatic, in case it was not already set .


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Autotuning

The tuning functions adjust the manufacturer’s default values to the load conditions in order to keep tracking errors to a minimum. You must optimize the control loops for highly dynamic or high-precision applications manually.

Autotuning can be initiated multiple times, because the results are cumulated (Initial Quality).

During the tuning functions, the servo amplifier is enabled and the load can move. Risk of injury. To avoid dangerous situations, take note of the following information:

  • For vertical axes: Move the load manually to bottom dead center and set the direction of motion to “negative only” or “positive only” (depending on the application) before you begin the test or tuning functions.
  • For feedback without commutation: Perform a Wake and Shake first.
  • Release the parking brake.
  • Perform autotuning in 4 steps (see screenshot). All functions enable the output stage and result in motor axis motions:
    1- Current Tuning
    2 - Observer Tuning
    3 - Test Step Speed for Autotuning
    4 - Autotuning

The setup software automatically checks whether autotuning is implemented in the firmware and activates the functions. If the firmware does not support autotuning, the relevant page is still shown although the control elements will be deactivated.

Profibus1

Prerequisite:

  • The motor and feedback settings must be correct. In the case of feedback systems without commutation, Wake and Shake must have been performed.
  • The load must be connected.
  • The drive parking brake must not be on.

Current and Observer Tuning

Start Current Tuner | This button starts the tuning function for the current controller. For this to occur, OPMODE must be set to 2.
Start Observer Tuner | This button starts an optimization function for the VLO parameter. VLO is a parameter of the Luenberger speed observer. Reducing VLO excessively may compromise the stability of the speed control loop.

Test Step Speed

The axis is now preset to the extent that an initial motion test can take place. To perform this, switch to the „Oscilloscope“ page.

Under „Motion Service“, you can select the operating function and enter the motion parameters.

Horizontal/Rotary Axes: | Move the axis to the central position. Use the reverse operation function for an initial test run. Set the parameters to safe values. ATTENTION: Stop the motion manually (Stop button or F11).
Vertical Axes: | Move the axis to bottom dead center. Use the Select Speed (Velocity) function for an initial test run. Set the parameters to safe values. ATTENTION: Stop the motion manually (Stop button or F11).

If the axis does not move with the default speed controller parameters, you may increase the proportional amplification “GV” until a motion can be observed. During service operation, you can change the parameters on the Oscilloscope page, under „Tuning“.

During test mode, start a Recording and save the image as a reference recording so that you can compare and evaluate the results after autotuning. For this purpose, save the recordings in a file.

Now you can proceed with autotuning. Go back to the Autotuning page.

Velocity Loop Tuning

TIP: The slew rate of the jumps is defined by ACC and DEC. To ensure reliable results, the highest possible slew rate should be selected (observing the limitations of the machinery).

Time

In this field, enter the time in ms during which the axis should move at the speed specified below. This value is used in both positive and negative directions, provided that the direction of motion is not restricted. High moments of inertia require more time.

Velocity

In this field, enter the speed at which the axis should move. The unit of speed is dependent upon the settings that have been made. The speed is used in both positive and negative directions, provided that the direction of motion is not restricted.

Motion Direction

Here you can specify whether the axis may move in both directions or just in one particular direction.
Do not use reverse mode for vertical axes!

Please note that the direction of rotation is dependent upon the parameter „DIR“, which is used to define the direction.

Application

The filter strategy is adapted to the relevant target application using the application selection. If filter parameters are selected manually, the application is automatically set to user-defined.
Def. System: PIDT2 filter (frequencies initially set to def.)
Direct Drive: All filters deactivated
Oszillierendes System: BIQUAD filter (frequencies and attenuation are

initially set to def.). Not currently implemented!
User-defined: Only manually selected filters are tuned

Additional Setting

Fieldbus: Select this check box if the position/speed specifications of the target application are set using a fieldbus. If this is the case, a modified tuning strategy is used.
Vertical Axis: When dealing with a vertical axis or an axis which is subjected to a constant level of force (such as a spring), this function must be activated. With this kind of axis, the integral component (GVTN) is not deactivated during the tuning process.

Tuning increment

You can use this slide control to limit the maximum step width. This enables sensitive superstructures to be protected, as only small step widths are used to modify the parameters. However, reducing the step width of the tuning algorithm increases the algorithm run time.

Desired Stiffness

The lower the integral component (GVTN) setting, the more rigid the axis.

The slider sets the value range for GVTN:
Left : 0 £ GVTN £ 2000ms Right: 0 £ GVTN £ 10ms

Tuned Variable

For experienced users: You can exclude individual parameters from the tuning process or tune particular parameters only. This also applies to the filter parameters. If the filter parameters are selected manually, the target application is automatically set to user-defined.

ASCII parameter | Description
GV | Proportional gain
MRESBW | Feedback Bandwidth
VLO | Observer feed forward
GVTN | Integral Time
ARLPF | Filter low pass frequency
ARHPF | Filter high pass frequency
ARLPD | Filter low pass damping
ARHPD | Filter high pass damping

Autotuning lowers GV by around 20% below the determined maximum value in order to provide resilient settings. With highly dynamic applications, GV can be raised by 20% again.

Save the determined values in the EEPROM.


ASCII English AVZ1

ASCII - Command | AVZ1 |
Syntax Transmit | AVZ1 [Data] |
Syntax Receive | AVZ1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3511 (hex)
DIM | ms | PROFIBUS PNU | 1617 (dec) IND = 1 (dec)
Range | 0.2 .. 100.0 | DPR | 17 (dec)
Default | 1 |
Opmode | 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | filter | EEPROM | Yes
Short Description | Filter time constant for analog input 1

Description

Filter time constant for analog input 1. (62.5µs Update Rate)


ASCII English AVZ2

ASCII - Command | AVZ2 |
Syntax Transmit | AVZ2 [Data] |
Syntax Receive | AVZ2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 387A (hex)
DIM | ms | PROFIBUS PNU | 1690 (dec) IND = 33 (dec)
Range | 0.2 .. 100.0 | DPR | 890 (dec)
Default | 1 |
Opmode | 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 3.07 |
Configuration | No | Last Change of this Object | 2.1
Function Group | filter | EEPROM | Yes
Short Description | Filter time constant for analog input 2

Description

Only S700

Filter time constant for analog input 2. (62.5µs Update Rate)


ASCII English \

ASCII - Command | \ |
Syntax Transmit | \ [Data] |
Syntax Receive | \ <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Unsigned8 | CANBus Object Number | 362B (hex)
DIM | - | PROFIBUS PNU | 1899 (dec) IND = 1 (dec)
Range | 0(=Master) .. 63 | DPR | 299 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Unsigned8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Selection of remote address

Description

For a CAN network with several amplifiers, there is an option for using a serial connection to one of the devices (master) to communicate with all the other amplifiers. To do this, the SCAN command is initiated on the master device, which performs an automatic detection of all the drivess that are connected. The response to the SCAN command contains a list of the addresses of all the drives devices that have been detected.

Typing the backslash character followed by a drive address (\ addr) in the range of 0 to 63 selects the addressed drive for communications. Further commands sent via the serial interface are ignored by the master device, and passed on directly across the CAN bus to the activated device. The response that this device outputs to the CAN bus is diverted to the serial interface. The command, \ 0, deselects the slave device and re-activate the master.

The setting MDRV = 0 disables the multi link functionality.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Basic Setup

basis

Brake resistor* (regen resistor*), mains voltage and the behavior in case of input power loss must be customized here.

Master data of the servo amplifier are monitored (e.g., serial number, run time). You can give the servo amplifier a name (up to 8 chars).

Screen text | ASCII parameter
Regen Resistor internal/external* | PBALRES
Regen Resistor value* | PBALRES
max. Regen Power* | PBALMAX
Mains Voltage | VBUSBAL
Response to Loss of Input Phase | PMODE
Name | ALIAS
Command Delay | CMDDLY
Set Software-Enable on Bootup | AENA
Controller Settings | Several PWM, Current and Position controller frequency setting are selectable.
DRVCNFG Settings for Experts | DRVCNFG, DRVCNFG2, DRVCNFG3, DRVCNFG4 These settings should only be changed by experts. Clicking the “Settings” button will open comprehensive lists containing servo amplifier functions that can be activated or deactivated.

* = Doesn't appear in the "Quick Motor/Drive Setup Mode" of the Setup Wizard


ASCII English BCC

ASCII - Command | BCC |
Syntax Transmit | BCC |
Syntax Receive | BCC <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 363A (hex)
DIM | - | PROFIBUS PNU | 1914 (dec) IND = 1 (dec)
Range | - | DPR | 314 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | EEPROM check sum

Description

The BCC variable returns a checksum for the parameter area of the serial EEPROM.
When a SAVE command is carried out, all the internal parameters of the amplifier are saved in this area, in ASCII format. The checksum is obtained by summing all the stored bytes, and is recalculated with every LOAD or SAVE command. It is only intended for the detection of EEPROM errors.
But it can also be used to detect whether the data set that is present in the controls matches the data set that is stored in the servo amplifier.


ASCII English BCCOT

ASCII - Command | BCCOT |
Syntax Transmit | BCCOT [Data] |
Syntax Receive | BCCOT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3895 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 33 (dec)
Range | - | DPR | 917 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.14 |
Configuration | No | Last Change of this Object | 2.2
Function Group | drive configuration | EEPROM | No
Short Description | EEPROM check sum without life time counter

Description

The BCCOT variable returns a checksum for the parameter area of the serial EEPROM without operation hour counter data.
When a SAVE command is carried out, the internal parameters of the amplifier are saved in this area, in ASCII format. This checksum is obtained by summing the stored bytes, and is recalculated with every LOAD or SAVE command. This variable can be used to detect changes of drive parameters.


ASCII English BISSCNFG

ASCII - Command | BISSCNFG |
Syntax Transmit | BISSCNFG [Data] |
Syntax Receive | BISSCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38B7 (hex)
DIM | - | PROFIBUS PNU | 1751 (dec) IND = 33 (dec)
Range | -32768 .. 32767 | DPR | 951 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.06 |
Configuration | Yes | Last Change of this Object | 2.8
Function Group | feedback | EEPROM | Yes
Short Description | configuration parameter for BiSS-C

Description

This parameter is used together with FBTYPE = 33. It defines how many bits are used for the position (or resolution) of the unidirectional communication of the BiSS-C feedback. Furthermore it defines the ative level of the error and warn bits in the frame.

From the BiSS spezification the error and warn bits were activ at ‚0’. If it's necessary to inverse the bits you should add the followings bits.

Error – Bit
0x40 (64) active ‚1’

Warn – Bit
0x80 (128) active ‚1’


ASCII English BISSREVOL

ASCII - Command | BISSREVOL |
Syntax Transmit | BISSREVOL [Data] |
Syntax Receive | BISSREVOL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3922 (hex)
DIM | - | PROFIBUS PNU | 1858 (dec) IND = 33 (dec)
Range | 0 ... 32 | DPR | 1058 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 6.02 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | Yes
Short Description | Number of multiturn bits for a BISS-C encoder

Description

This parameter defines the number of multiturn bits for BISS-C encoder

BISSREVOL=0 single turn


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Bode Plot

This function is reserved for engineers and technicians who are experienced in control technology. As soon as the confirmation query is confirmed, movement immediately starts automatically using the internal setpoint provision !
Appropriate training is available on request.

bode1

With the help of the Bode plot, you can analyze and optimize the speed controller, taking into account the mechanical characteristics of the machine.

The Bode plot draws the frequency response of the speed controller. The system is stimulated by a sinusoidal input variable. The output variable has the same frequency, but a different amplitude and some degree of phase shift.

The relationship between the amplitude as a function of frequency (amplitude response) and the phase shift as a function of frequency (phase response) provides a complete description of the dynamic characteristics of the control loop.

Amplitude response
The amplitude response is the frequency-dependent amplitude characteristic (gain), shown on a logarithmic scale.

Phase response
The phase response is the frequency-dependent phase-shift characteristic.

The following characteristic data are used for a qualitative description of the open loop frequency response:

Phase reserve (open loop)
The spacing between the phase characteristic curve and the -180° phase-shift line at the cut-off frequency, i.e. the frequency at which the amplitude characteristic (gain) has fallen to 0 dB.

Amplitude reserve (open loop)
The spacing between the amplitude characteristic (gain) and the 0 dB level at a phase shift of -180°.

The characteristics of the closed control loop are evaluated with the aid of the Bode plot, using the expressions "bandwidth" and "peaking":

Bandwidth (closed loop)
Bandwidth is the range of frequencies limited by the frequencies where the logarithmic amplitude characteristic (gain) falls off by -3 dB.

Peaking (closed loop)
The expression "peaking" describes an overshoot of the closed control loop, corresponding to the maximum in the amplitude response.

Bode Plot
Starts recording the data.

Parameter…
Call up the screen page "Bode Plot Parameter". This page is used to define the frequency range and the number of steps.

bodeparameter

Switch Open Loop / Closed Loop or Filter Function
“Open Loop / Closed Loop”
Amplitude and phase response of the open and closed loop are displayed.

“Open Loop / Filter Function”
Displayed are amplitude and phase response
- of the open loop
- of the filter
- of the open loop incl. filter (resulting curve)

This function can be used for filter simulation.

Configure (with Filter Function only)
Select the desired filter function. The filter parameters must be configured with the terminal screen.

PID-T2 Filter
PID-T2 filters can be used effectively to reduce the torque ripple and resonances from the motor, gearbox and a coupled load.
ASCII parameters for this filter:
BQMODE = 2
ARLPF - LowPass-Frequency
ARHPF - HighPass-Frequency

1. Order Low Pass
Low-pass filters are used to suppress signals of higher frequencies (e.g. resonances and noise).
ASCII parameters for this filter:
ARLP2

2. Order Low Pass
Low-pass filters are used to suppress signals of higher frequencies (e.g. resonances and noise).
ASCII parameters for this filter:
ARLPF - LP Frequency
ARLPD - LP Damping

Bi-Quad
Bi-quad filters can be used effectively to compensate resonances in a two-mass servo system. ASCII parameters for this filter:
BQMODE = 3
ARLPF - LowPass-Frequency
ARLPD - LowPass-Damping
ARHPF - HighPass-Frequency
ARHPD - HighPass-Damping

bodefilter

Save
Saves the measurements that were recorded to a data medium in CSV format (can be evaluated by MS-Excel).

Load
Loads a CSV file and displays the curves in a diagram.

Update
Loads and display the latest set of recorded data.

Cursor Function
When a set of data is displayed (from a file, or by starting a recording), a mouse click in the coordinate system displays the measured values for the signals at the selected time. A click outside the coordinate system sets the display values back to 0.

Example
bode


ASCII English BQMODE

ASCII - Command | BQMODE |
Syntax Transmit | BQMODE [Data] |
Syntax Receive | BQMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3666 (hex)
DIM | - | PROFIBUS PNU | 1958 (dec) IND = 1 (dec)
Range | 0...4 | DPR | 358 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.3
Function Group | filter | EEPROM | Yes
Short Description | Filter selection

Description

Status | Short Description | Description
BQMODE=0 | filter turned off |
BQMODE=1 | compatibility mode | In this mode, the filter is selected due to the settings of ARLPF, ARHPF, ARLPD and ARHPD. The filter is selected as follows: ARLPF > 0,ARHPF > 0,ARLPD = ARHPD = 0 : PID-T2 filter (1st-order lag compensator) ARLPF > 0, ARHPF > 0, ARLPD > 0, ARHPD = 0 : notch /bi-quad ARLPF > 0, ARLPD > 0, ARHPD = ARHPD = 0 : 2nd-order low-pass (n/a) ARLPF = ARHPF = ARLPD = ARHPD = 0 : filter turned off
BQMODE=2 | PID-T2 filter (1st-order lag compensator) | The PID-T2 filter is only activated if the following conditions are met: ARLPF > 0, ARHPF > 0. PID-T2 filters can be used effectively to reduce the torque ripple and resonances from the motor, gearbox and a coupled load. The transfer function is TF
BQMODE=3 | notch / bi-quad filter | The notch / bi-quad filter is only activated if the following conditions are met: ARLPF > 0, ARHPF > 0, ARLPD > 0, ARHPD = 0. Notch filters an be used to suppress single resonances because they offer a high attenuation for a small frequeny range. However, even small deviations between filter frequency and resonance frequency degrade the effect of this filter type dramatically. This high paramter sensitivity makes notch filters difficult to set up. Bi-quad filters can be used effectively to compensate for resonances in a two-mass servo system. If set up properly, this filter type helps to increase the stability margins which allows for a higher gain and thus a higher bandwidth of the velocity loop. The transfer function is TF Note: If ARLPF = ARHPF, ARLPD > 0 and ARHPD = 0, the filter acts as a notch filter, otherwise it acts as a bi-quad filter.
BQMODE=4 | 2nd-order low-pass filter | The 2nd-order low-pass filter is only activated if the following conditions are met: ARLPF > 0, ARLPD > 0. For general examples of low-pass filter usage, see ARLP2. If a 1st-order low-pass filter exhibits too much phase lag below the cutt-off frequency or too little signal attenuation above the cutt-off frequency, a 2nd-order low-pass filters can be used to improve the behavior. The transfer function is TF


ASCII English BTIME

ASCII - Command | BTIME |
Syntax Transmit | BTIME [Data] |
Syntax Receive | BTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | ms | PROFIBUS PNU | -
Range | 63 .. 2046 | DPR | No
Default | 512 |
Opmode | all | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Discharge time of the DC link at INxMODE 62

Description

Discharge time of the DC link at INxMODE = 62


ASCII English BUILDRK

ASCII - Command | BUILDRK |
Syntax Transmit | BUILDRK [Data] |
Syntax Receive | BUILDRK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3850 (hex)
DIM |  | PROFIBUS PNU | 1648 (dec) IND = 33 (dec)
Range | 0, 1 | DPR | 848 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | -
Short Description | calculation of RK

Description

SO = location
S = memory (where the standard controller parameters are stored)
SF = System Flash
OG = upper limit of RK (16384 + 500 = 16884)
UG = Lower limit of RK (16384 - 500 = 15884)

BUILDRK = 0
- automatic determination of RK is deactivated
- the RK value from S will be used

BUILDRK = 1
- automatic determination of RK is activated
- the RK value is used in SF (if valid)
- if the RK value is not valid in the SF, then RK from S is used as the start value and optimized
- the calculated RK value is stored in the SF every 60 minutes.
- RK value is always only changed in small steps and approximated to the optimum.
An automatic determination of RK is carried out only at 1000 rpm revolutions, i. The acceleration and deceleration phase is used for optimization.
- Automatic determination of RK is started as soon as the motor has rotated at least 360 °.

Important:
For an RK determination to be performed, the motor must be able to rotate at least one rotation.

Note:
RK value in the SF does not override the RK value in S


ASCII English BUILDRP

ASCII - Command | BUILDRP |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 3851 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 33 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English BUSP0

ASCII - Command | BUSP0 |
Syntax Transmit | BUSP0 [Data] |
Syntax Receive | BUSP0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 385B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 33 (dec)
Range | -2147483648 .. 2147483647 | DPR | 859 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

SERCOS:
IDN 97 lower 16 BIT
IDN 98 upper 16 BIT

CAN: (Firmware >=2.51)
The Bits 0 ..7 are used to enable different warnings. Default state is no warning message on the bus communicaion.

Bedeutung der Bits:
Bit 0: Emergency if Hardware-disable is set when CANopen - satus is OPERATION ENABLE, Error Code 0x7181
Bit 1: Warnung n06 (software-limit switch 1 active), Error Code 0x8683
Bit 2: Warnung n07 (software-limit switch 1 active), Error Code 0x8684
Bit 3: Warnung n08 (bad motion task used), Error Code 0x8681
Bit 4: Warnung n09 (no referencepoint set), Error Code 0x8685
Bit 5: Warnung n10 (PSTOP reached), Error Code 0x8686
Bit 6: Warnung n11 (NSTOP reached), Error Code 0x8687


ASCII English BUSP1

ASCII - Command | BUSP1 |
Syntax Transmit | BUSP1 [Data] |
Syntax Receive | BUSP1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E5 (hex)
DIM | - | PROFIBUS PNU | 1685 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 485 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable (CAN or Sercos)

Description

Configuartion for CANopen/EtherCAT:

Bit 0: Firmware >= 2.51
The Bit 30 of setting COB-IDs for Tx-PDOs are checked. The drive sets the bit and waits for write zyklus of COB - Identifier withset Bit 30.

If a drive (with Firmware < 2.51) has been replaced, the warning n17 ( STATCODE *) is displayed after the exchange. A synchronized fieldbus is guaranteed again, after saving the parameter BUSP1 = 1.

Configuartion for Sercos:

BUSP1 gives the status of the drive. The bit 3 can be written by the drive and can be saved. If the bit is set, Modbus+ network errors are indicated at the drive.

default: T3 = 450µs ati 500µs cycletime

T3 = T2 + 50 us fix at 250us cycletime!
Priority for T3 at 500 us:
1. BUSP1 Bits 16 - 27
2. BUSP1 Bits 8 - 12
3. T3 from controller

Configuration for CANopen - behavior:

Bit definition:
Bit 0: Firmware >= 2.51
The Bit 30 of setting COB-IDs for Tx-PDOs are checked. The drive sets the bit and waits for write zyklus of COB - Identifier withset Bit 30.


ASCII English BUSP2

ASCII - Command | BUSP2 |
Syntax Transmit | BUSP2 [Data] |
Syntax Receive | BUSP2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E6 (hex)
DIM | 10 ms | PROFIBUS PNU | 1686 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 486 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

This parameter defines the time-out of the Modbus communication in 10ms steps. If the drive gets no interrupt from the board in that time, the drive is disabled and the communication in BUSP1 is displayed as faulty.

SERCOS:
IDN 15 Telegram typ in Byte 0
IDN 32 Main operation mode in Byte 2


ASCII English BUSP3

ASCII - Command | BUSP3 |
Syntax Transmit | BUSP3 [Data] |
Syntax Receive | BUSP3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E7 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 487 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

This parameter defines the direction of the address selection of the Modbus+ board in the initialization phase.
BUSP3 = 0 The address is given by the Modbus board.
BUSP3 = 1 The address is given by the drive and it's address in ADDR.

SERCOS:
IDN 121 Gearing input stage with data defined on motor side


ASCII English BUSP4

ASCII - Command | BUSP4 |
Syntax Transmit | BUSP4 [Data] |
Syntax Receive | BUSP4 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E8 (hex)
DIM | - | PROFIBUS PNU | 1688 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 488 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

This parameter defines the number of data words (command), which are updated cyclic. Data, which is enabled as process data, cannot be written by the SDO channel (messaging).

SERCOS:
IDN 122 Gearing output stage with data defined on motor side


ASCII English BUSP5

ASCII - Command | BUSP5 |
Syntax Transmit | BUSP5 [Data] |
Syntax Receive | BUSP5 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E9 (hex)
DIM | - | PROFIBUS PNU | 1689 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 489 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

This parameter gives the address of the Modbus-Master for this drive. While initializing, this parameter is send from the drive to the Modbus board. The board then transmits only data to the drive, that was send from this master.

SERCOS:
IDN 123


ASCII English BUSP6

ASCII - Command | BUSP6 |
Syntax Transmit | BUSP6 [Data] |
Syntax Receive | BUSP6 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36EA (hex)
DIM | - | PROFIBUS PNU | 1690 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 490 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

This parameter defines the number of cyclic updated actual values in 16 bit data words, which are updated every cycle between the drive and the Modbus board.

SERCOS:
IDN 79

CAN:
Testparameter for individual bus timing - settings. In case <> 0, the setting for CBAUD isn't active
Value - range: -2^31 .. 2^31 - 1


ASCII English BUSP7

ASCII - Command | BUSP7 |
Syntax Transmit | BUSP7 [Data] |
Syntax Receive | BUSP7 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36EB (hex)
DIM | - | PROFIBUS PNU | 1691 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 491 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

SERCOS:

IDN117 - resolution external encoder


ASCII English BUSP8

ASCII - Command | BUSP8 |
Syntax Transmit | BUSP8 [Data] |
Syntax Receive | BUSP8 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36EC (hex)
DIM | - | PROFIBUS PNU | 1692 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 492 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus configurationsvariable

Description

BUSP8 = IDN 138


ASCII English BUSP9

ASCII - Command | BUSP9 |
Syntax Transmit | BUSP9 [Data] |
Syntax Receive | BUSP9 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36ED (hex)
DIM | - | PROFIBUS PNU | 1693 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 493 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | debug fieldbus variable for EtherCAT

Description

The parameter BUSP9 displays the actual control (bit 0...7) and status word (bit 8...16)

please have a look to BUSP11


ASCII English BUSP10

ASCII - Command | BUSP10 |
Syntax Transmit | BUSP10 [Data] |
Syntax Receive | BUSP10 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36EE (hex)
DIM | - | PROFIBUS PNU | 1694 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 494 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | debug fieldbus variable for EtherCAT

Description

The parameter BUSP10 displays the actual valid mapping-numbers (Bits 0...7 Sollwert, Bits 8..16 Istwerte).


ASCII English BUSP11

ASCII - Command | BUSP11 |
Syntax Transmit | BUSP11 [Data] |
Syntax Receive | BUSP11 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36EF (hex)
DIM | - | PROFIBUS PNU | 1695 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 495 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | debug fieldbus variable for EtherCAT

Description

The parameter BUSP11 displays the actual value of CoE control Bits 0...7) und status word (Bits 8...16).

please have a look to BUSP9


ASCII English BUSP12

ASCII - Command | BUSP12 |
Syntax Transmit | BUSP12 [Data] |
Syntax Receive | BUSP12 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F0 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 496 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | fieldbus configurationsvariable

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English BUSP13

ASCII - Command | BUSP13 |
Syntax Transmit | BUSP13 [Data] |
Syntax Receive | BUSP13 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F1 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 497 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | fieldbus configurationsvariable

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English BUSP14

ASCII - Command | BUSP14 |
Syntax Transmit | BUSP14 [Data] |
Syntax Receive | BUSP14 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F2 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 498 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | fieldbus configurationsvariable

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English BUSP15

ASCII - Command | BUSP15 |
Syntax Transmit | BUSP15 [Data] |
Syntax Receive | BUSP15 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F3 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 499 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | fieldbus configurationsvariable

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English BUSP16

ASCII - Command | BUSP16 |
Syntax Transmit | BUSP16 [Data] |
Syntax Receive | BUSP16 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F4 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 17 (dec)
Range | 0 .. 15 | DPR | 500 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | No
Short Description | fieldbus configurationsvariable

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English CALCCOG

ASCII - Command | CALCCOG |
Syntax Transmit | CALCCOG [Data] |
Syntax Receive | CALCCOG <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enable | Weighting |
Start Firmware | 2.21 |
Configuration | No | Last Change of this Object | 2.0
Function Group | drive configuration | EEPROM | No
Short Description | Generate lookup table for cogging compensation

Description

Syntax:
CALCCOG [velocity] (Rotary Motors)
CALCCOG [velocity] [distance] [start position] (Linear Motors)

The CALCCOG command is used to generate a current feed-forward lookup table for the cogging compensation. The pre-requisites for rhe CALCCOG command are:
Since a motion task is used to generate motion, the drive must be in OPMODE 8
The reference point must be set.
The drive must be enabled.
No homing procedure, motion task or jog mode may be active.

For rotary motors (MTYPE ? 2), only one optional parameter is accepted. This parameter specifies the velocity at which the motor turns when the lookup-table entries are recorded. Only positive values are allowed for this parameter. The default velocity is 5 rpm. The recording always starts at the current position, and the traversing range is always a single revolution.
For linear motors (MTYPE = 2), three optional parameters are accepted. The first parameter specifies the velocity at which the motor moves when the lookup-table entries are recorded. Only positive values are allowed for this parameter. The default velocity corresponds to 5 pole-pair pitches per minute. The second parameter specifies the distance the motor moves along while the lookup-table entries are recorded. This is exactly therange that will be compensated when the cogging compensation is activated. The distance must be set to either of 1/4, 1/2, 1, 2, 4, .., 2^m pole-pair pitches, where m is any positive integer number. The default value is one pole-pair pitch.The optional parameter start position specifies the position from which the recording of the current feed-forward table is started. The default start position is the current position. If this parameter is given and differs from the current position, a motion task is generated to move to the designated start position at velocity VREF.

Note: Parameters can only be omitted in right-to-left order, i.e. valid command lines are:
CALCCOG [velocity] [distance] [start position]
CALCCOG [velocity] [distance]
CALCCOG [velocity]
CALCCOG


ASCII English CALCHP

ASCII - Command | CALCHP |
Syntax Transmit | CALCHP [Data] , [Data] |
Syntax Receive | CALCHP | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 3512 (hex)
DIM | rpm | PROFIBUS PNU | 1618 (dec) IND = 1 (dec)
Range | 0 .. 200 | DPR | 18 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | No
Short Description | Determining the Hiperface/ENDAT parameters

Description

This command can be used to start the automatic determination of the sine cosine parameters. To do this, the output stage must be enabled and the drive must be able to move freely. While this command is being carried out, the motor makes a full turn at the predefined velocity. During this phase, the offset parameters (HISOFFS/HICOFFS) and the sine/cosine gain factor (HIFACT1) are calculated. After this function has been completed, the newly determined parameters can be stored in the encoder, using the HSAVE command for EnDAT-, BiSS- or Hiperface feedback and also using the command SAVE for sine/cosine feedback.

The CALCHP function is only available when a Hiperface (FBTYPE=2), an EnDAT (FBTYPE=5 bis 8), a BiSS-(FBTYPE=23, 24) or a sine/cosine-feedback (FBTYPE=1, 3, 5 6, 7, 8, 26) is selected.

The first is to select a certain speed in rpm and the second the angle of the motor that should be moved.

E.g.: CALCHP 5 10, start CALCHP with 5 rpm and move the motor 10 degrees.


ASCII English CALCMP

ASCII - Command | CALCMP |
Syntax Transmit | CALCMP |
Syntax Receive | CALCMP <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 388F (hex)
DIM | - | PROFIBUS PNU | 1711 (dec) IND = 33 (dec)
Range | 0 .. 10000000 | DPR | 911 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.53 |
Configuration | No | Last Change of this Object | 2.0
Function Group | drive configuration | EEPROM | No
Short Description | Cycles for commutation alignment by PID control loop

Description

CALCMP [count] command starts “count” times the commutation alignment procedure executed with the help of the PID position loop.


ASCII English CALCPOSIO

ASCII - Command | CALCPOSIO |
Syntax Transmit | CALCPOSIO |
Syntax Receive | CALCPOSIO <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 38A6 (hex)
DIM |  | PROFIBUS PNU | 1734 (dec) IND = 33 (dec)
Range |  | DPR | 934 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.75 - 5.02 |
Configuration | No | Last Change of this Object | 2.4
Function Group | drive configuration | EEPROM | No
Short Description | Initialisation of the POS I/O card

Description

Initialisation of the POS I/O card. This command has to be done once (with no X3C connector plugged in) after error F20 “POSIO data bcc error” occurred.

Only for S700: FW 3.75/5.02


ASCII English CALCRK

ASCII - Command | CALCRK |
Syntax Transmit | CALCRK [Data] |
Syntax Receive | CALCRK | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 3513 (hex)
DIM | rpm | PROFIBUS PNU | 1619 (dec) IND = 1 (dec)
Range | 0 .. 200 | DPR | 19 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.11
Function Group | drive configuration | EEPROM | No
Short Description | Calculate resolver parameters

Description

This command can be used to start the automatic determination of the resolver parameter RK (sine/cosine gain factor). To do this, the output stage must be enabled and the drive must be able to move freely. While this command is being carried out, the motor makes approx. 2.5 turns at the given velocity. If CALCRK is started without parameter, the default value is used. After this function has been completed, the newly determined RK parameter can be stored in the EEPROM, using the SAVE command. This command can be used to reduce the current ripple of the motor at high velocity. It can only be used with resolver feedback.

Therefore the value of RK is: 12.000 = RK = 19.000

A value of 16384 is the amplification of 1.0

example:
RK=18000 -> amplification of 1.098
RK=16000 -> amplification of 0.976


ASCII English CALCRP

ASCII - Command | CALCRP |
Syntax Transmit | CALCRP |
Syntax Receive | CALCRP | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 3514 (hex)
DIM | - | PROFIBUS PNU | 1620 (dec) IND = 1 (dec)
Range | - | DPR | 20 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | drive configuration | EEPROM | No
Short Description | Calculate resolver phase

Description

This command can be used to start the automatic determination of the resolver parameter RESPHASE ( resolver phase shift ).

Before starting this command in the hyper Terminal, switch off the power and disable the drive. At the same time, set MSG = 2. After starting this command, the value of RESPHASE will be then automatically identified. If the process finishes, in the Hyper Terminal shows the value of RESPHASE and the information “ERR 4 feedback !”. This is normal and you can ignore it. Now, type SAVE to store the value of RESPHASE permanently and execute the COLDSTART.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

CAN- / Fieldbus Settings

einheiten

Station address and baud rate in the fieldbus network is customized here.

Screen text | ASCII parameter
Address | ADDR
External Watchdog (Fieldbus) | EXTWD
CAN Bus Settings |
Baud Rate | CBAUD
Heartbeat Guard: Consumer CANopen Object 1016h sub1 | CANSDO
Heartbeat Guard: Producer CANopen Object 1017h sub0 | CANSDO
Node Guarding: Lifetime factor CANopen Object 100Dh sub0 | CANSDO
Node Guarding: Guard Time CANopen Object 100Ch sub0 | CANSDO
Save fieldbus mapping data to EEPROM | DRVCNFG

Save current Guarding/Mappings to Drive (CCSAVE)

The set communication parameters are saved to the servo amplifier.

Write Guarding/Mapping Defaults to Drive (CCSAVE)

The CANopen communication parameters are reset to the default values. These values are active after rebooting the servo amplifier (COLDSTART).

Heartbeat

The Heartbeat Protocol defines an Error Control Service without need for remote frames. A Heartbeat Producer transmits a Heartbeat message cyclically. One or more Heartbeat Consumer receive the indication. The Heartbeat Consumer guards the reception of the Heartbeat within the Heartbeat Consumer Time. If the Heartbeat is not received within the Heartbeat Consumer Time a Heartbeat Event will be generated. The consumer heartbeat time defines the expected heartbeat cycle time and has to be higher than the corresponding producer heartbeat time configured on the device producing this heartbeat. If the consumer heartbeat time is 0 the corresponding entry is not used. The time is defined in milliseconds.

Nodeguard

The Node Guarding protocol is a functional monitoring for the drive. It requires that the drive is accessed at regular intervals by the CANopen master. The product of Guard Time and Life Time Factor gives the life time for the nodeguarding protocol. If one of these values set to zero, then the response monitoring is inactive. If the drive is not accessed within the response monitoring time, then Warning n04 appears on the drive

Mapped PDOs...

Click the button "Mapped PDOs..."

There are distinguished two types of PDOs: Receive PDOs (RxPDOs) and transmit PDOs (TxPDOs).
The content of the PDOs is pre-defined. If the data content is not appropriate for a special application the data objects in the PDOs can be remapped freely. Select the required PDO with the corresponding register tab.
Further information on PDO Mapping can be found in the CANopen Manual.

Adding or editing opens an additional edit window:

A table with all available mapping parameters can be found in the CANopen Manual.

You can adjust important communication parameters for the data transmission:

Screen text | ASCII parameter
COB-ID | CANSDO
Transmission Type | CANSDO
Inhibit Time (with TxPDOs only) | CANSDO
Event Time (with TxPDOs only) | CANSDO

Apply Changes: The changed mappings are transmitted to the servo amplifier. Now the data will be checked.

Reload Settings: Communication parameters are reloaded from the servo amplifier.


ASCII English CANDUMP

ASCII - Command | CANDUMP |
Syntax Transmit | CANDUMP |
Syntax Receive | CANDUMP <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.15 |
Configuration | No | Last Change of this Object | 1.6
Function Group | fieldbus | EEPROM | No
Short Description | List with CANopen communication parameter

Description

Description

The command is used to get a list with the CANopen communication parameter.


ASCII English CANSDO

ASCII - Command | CANSDO |
Syntax Transmit | CANSDO [Data] |
Syntax Receive | CANSDO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode |  | Data Type Bus/DPR | INT32
Drive State |  | Weighting |
Start Firmware | 2.15 |
Configuration | No | Last Change of this Object | 1.5
Function Group | fieldbus | EEPROM | No
Short Description | Access to a CAN Service Data Object

Description

The ASCII-command CANSDO <object> <value>, where object gives index, subindex and length of a CAN-object dictionary entry, gives read and write access to a CAN-SDO.

Examples:

Write access:
CANSDO 0x2F001802 1 means object 1800 sub 2 shall be written with a value of 1 and has 1 Byte=8 Bit length. The length must be according to the type of the entry given in the object dictionary (2F = 1 byte, 2B = 2 bytes, 27 = 3 bytes, 23 = 4 bytes)

Read access:
CANSDO 0x40416000 reads object 6041 subindex 0.

For further information to SDO access refer to the CAN manual.


ASCII English CARDDEL

ASCII - Command | CARDDEL |
Syntax Transmit | CARDDEL |
Syntax Receive | CARDDEL | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 3.60 |
Configuration | No | Last Change of this Object |
Function Group | SD-Card | EEPROM | No
Short Description | deletes a file from the root diretory

Description

CARDDEL „Name“

Deletes the file „Name“ from the root directory of the card.


ASCII English CARDDIR

ASCII - Command | CARDDIR |
Syntax Transmit | CARDDIR |
Syntax Receive | CARDDIR | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 3.60 |
Configuration | No | Last Change of this Object |
Function Group | SD-Card | EEPROM | No
Short Description | display of the root directory

Description

CARDDIR

The root directory of the card is displayed with file size in brackets. Sub directories are marked with <DIR>.


ASCII English CARDINFO

ASCII - Command | CARDINFO |
Syntax Transmit | CARDINFO |
Syntax Receive | CARDINFO | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 3.60 |
Configuration | No | Last Change of this Object |
Function Group | SD-Card | EEPROM | No
Short Description | information about the SD card

Description

CARDINFO

Card information is displayed, e.g. the card type (MMC or SD) and the memory space.


ASCII English CARDSAVE

ASCII - Command | CARDSAVE |
Syntax Transmit | CARDSAVE |
Syntax Receive | CARDSAVE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 3.60 |
Configuration | No | Last Change of this Object |
Function Group | SD-Card | EEPROM | No
Short Description | save data from the drive to the SD memory card

Description

CARDSAVE <Option> “name"

Saves firmware/data component of the S700 to the card with filename "name". CARDSAVE concern the amplifier's firmware, and must therefore be operated with disabled output stage. When the command is finished, the amplifier is restarted automatically. Save and load of amplifier parameters (option PARAM) or Safety parameters (option SAFETY) can be operated with enabled output stage. Nearly all data which have been saved with the command CARDSAVE are binary coded, except the parameter file saved by CARDSAVE PARAM, that is saved as ASCII file. This file can be read and edit with the setup software DriveGUI.


ASCII English CARDUPDATE

ASCII - Command | CARDUPDATE |
Syntax Transmit | CARDUPDATE |
Syntax Receive | CARDUPDATE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 3.60 |
Configuration | No | Last Change of this Object |
Function Group | SD-Card | EEPROM | No
Short Description | load data from the SD memory card to the drive

Description

CARDUPDATE <Option> “name"

Loads a firmware/data component from the card to the flash Eeprom of the S700. CARDUPDATE concerns the amplifier's firmwareand must therefore be operated with disabled output stage only. When the command is finished, the amplifier is restarted automatically. Save and load of amplifier parameters (option PARAM) can be operated with enabled output stage. The command „CARDUPDATE <option> <name>“ expects for the "name" either a binary file or an S- Record file. Binary data have been usually saved before with the command CARDSAVE. S- Record files are for example the firmware file, that has been downloaded from our website.


ASCII English CBAUD

ASCII - Command | CBAUD |
Syntax Transmit | CBAUD [Data] |
Syntax Receive | CBAUD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3515 (hex)
DIM | kBaud | PROFIBUS PNU | 1621 (dec) IND = 1 (dec)
Range | 10,20,50,100,125,250,333,500,666,800,1000 | DPR | 21 (dec)
Default | 500 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | Baud Rate CAN Bus

Description

The transmission rate is required by the fieldbus (CANopen) and for the parameter setting of the servo amplifier in multi-axis systems (see the Installation Manual). You can also use the keys on the front panel of the servo amplifier to set the baud rate (see the Installation Manual).


ASCII English CCSAVE

ASCII - Command | CCSAVE |
Syntax Transmit | CCSAVE [Data] |
Syntax Receive | CCSAVE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 , 1 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.15 |
Configuration | No | Last Change of this Object | 2.14
Function Group | drive configuration | EEPROM | No
Short Description | Save / reset CANopen communication parameter

Description

Description

CCSAVE ist used to save the CANopen communiaction parameter in object area 1000h – 1FFFh into the drive or to reset the values to default.

Es sind zwei Werte zulässig:

0 – CANopen-communication parameter are set to default. The CAN COB ID's are recalculated for the set CAN address ADDR. The new data are active after drive restart.

1 – CANopen-communication parameter are saved into the drive.


ASCII English CINPOS

ASCII - Command | CINPOS |
Syntax Transmit | CINPOS [Data] |
Syntax Receive | CINPOS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 386C (hex)
DIM | - | PROFIBUS PNU | 1676 (dec) IND = 33 (dec)
Range | 0 .. 3280 | DPR | 876 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.51 |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | current loop | EEPROM | Yes
Short Description | Current “In Position” or “Target reached” message

Description

The CINPOS command defines the size of the Current In Position windows for the CINPOS state message (Bit 2 in DRVSTAT2).
As long as the difference between the last commanded current (ICMD) and the actual current (I) is within the width of the current In-Position window (CINPOS) , a 1 is signaled, otherwise a 0. The signal change is not signaled before the new state was valid at least INPT0 milliseconds.


ASCII English CLRFAULT

ASCII - Command | CLRFAULT |
Syntax Transmit | CLRFAULT |
Syntax Receive | CLRFAULT | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3518 (hex)
DIM | - | PROFIBUS PNU | 1624 (dec) IND = 1 (dec)
Range | - | DPR | 24 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Clear drive fault

Description

The CLRFAULT command cancels the fault status of an amplifier. A hardware or software reset of the amplifier is carried out, depending on the type of fault that is present.
After a software reset the amplifier is immediately ready for operation, after a hardware reset the complete initialization phase must be gone through first (as for power-on).
As well as amplifier faults (display Fxx), the following warnings are also deleted.
- contouring/following error
- threshold monitoring

With the selection CLRWARN=1 (separate cancellation of warnings) this command will delete all warnings that are present.
A listing of all possible fault/error messages, with information on the hardware/software reset required, can be found in the description of the ERRCODE command.

The CLRFAULT command can either be implemented through the ASCII channel (CLRFAULT command ) or via the CAN/PROFIBUS (with the “cancel fault” bit in the control word), or through a digital input (“Controller reset” function).


ASCII English CLRHR

ASCII - Command | CLRHR |
Syntax Transmit | CLRHR |
Syntax Receive | CLRHR | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3519 (hex)
DIM | - | PROFIBUS PNU | 1625 (dec) IND = 1 (dec)
Range | - | DPR | 25 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Bit 5 of status register STAT is cleared

Description

After every start-up or hardware reset of the drive, BIT 5 (0x20) of the STAT register is set to high. This bit is cleared by CLRHR.
Possible usage:
The Software User Interface uploads all the data stored in the drive, if the hardware reset Bit5 in the STAT register is set too high. When the parameter are completely uploaded, the Bit5 is set to low using the command CLRHR. The STAT register is monitored form the Software User Interface all the time and is checked, if it is low. When it becomes high again (drive had a reset) the Software User Interface uploads the data again.


ASCII English CLRORDER

ASCII - Command | CLRORDER |
Syntax Transmit | CLRORDER |
Syntax Receive | CLRORDER | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 351A (hex)
DIM | - | PROFIBUS PNU | 1626 (dec) IND = 1 (dec)
Range | 0;1 ..180; 192 .. 255 | DPR | 26 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Enabled (only RAM) / Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Deleting a Motion Task

Description

The command CLRORDER is used to delete a motion task given by the variable (e.g. CLRORDER 10, means: motion task 10 is deleted).


ASCII English CLRWARN

ASCII - Command | CLRWARN |
Syntax Transmit | CLRWARN [Data] |
Syntax Receive | CLRWARN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Unsigned8 | CANBus Object Number | 351B (hex)
DIM | - | PROFIBUS PNU | 1627 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 27 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Unsigned8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.18 |
Configuration | Yes | Last Change of this Object | 2.1
Function Group | drive configuration | EEPROM | Yes
Short Description | Warning mode

Description

The CLRWARN configuration variable can be used to control the response of the drive if a warning occurs.

CLRWARN=0 Warnings will be displayed until the cause of the warning has been removed.
Warnings cannot be cancelled (exceptions: - contouring/following error, threshold detection).
CLRWARN=1 A warning is only displayed at the moment when it occurs (transition).
All warnings can be cancelled by the CLRFAULT command, or through the digital input (“Controller reset” function).

The listing of the possible warnings can be found in the description of the STATCODE * command.


ASCII English CMDDLY

ASCII - Command | CMDDLY |
Syntax Transmit | CMDDLY [Data] |
Syntax Receive | CMDDLY <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3670 (hex)
DIM | ms | PROFIBUS PNU | 1968 (dec) IND = 1 (dec)
Range | 0 ... 160 | DPR | 368 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.1
Function Group | RS232 | EEPROM | Yes
Short Description | Command delay time for RS232

Description

The parameter CMDDLY defines a minimum delay time for answers from the drive via RS232 (ASCII). This enables the possibility for slower controller to communicate with the Drive.
The delay time CMDDLY defines the time between the last character of a ASCII string send to the drive to the first character of the answer.
The time between the characters cannot be changed, they are defined by the baud rate and the internal calculation times.
This time defines only the minimum delay time between the ASCII strings. The time can be longer, depending on the internal calculation time


ASCII English COGFILT

ASCII - Command | COGFILT |
Syntax Transmit | COGFILT [Data] |
Syntax Receive | COGFILT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36D3 (hex)
DIM | - | PROFIBUS PNU | 1667 (dec) IND = 17 (dec)
Range | 0...1 | DPR | 467 (dec)
Default | 0.1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 2.21 |
Configuration | No | Last Change of this Object | 2.3
Function Group | motor | EEPROM | Yes
Short Description | Bandwidth factor for cogging-compensation filter

Description

The COGFILT parameter represents a bandwidth factor that is used to set up the filter that is applied to the current q-component command values recorded during generation of the cogging-compensation feed-forward table using CALCCOG. This parameter can have values in between 0 and 1. A value of 0 means that all frequency components are removed from the spectrum, a value of 1 means that no filtering is applied at all.

For more details please see the application note “Cogging Suppression” on our Wiki page.


ASCII English COGMODE

ASCII - Command | COGMODE |
Syntax Transmit | COGMODE [Data] |
Syntax Receive | COGMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36CF (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 17 (dec)
Range | 0 .. 3 | DPR | 463 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 2.21 |
Configuration | No | Last Change of this Object | 2.14
Function Group | motor | EEPROM | Yes
Short Description | Cogging-compensation mode

Description

The COGMODE parameter is used to activate (value=1) / de-activate (value=0) the cogging compensation which compensates for the force / torque ripple that is caused by cogging.

since FW 5.38
COGMODE = 2 cogging operation runs in the velocity mode
COGMODE = 3 cogging operation runs in the velocity mode, it is a high-resolution cogging table created (higher accuracy).

The compensation is achieved through a position-dependent current feed-forward signal that is fetched from a table and added to the current q-component command signal. Before the cogging compensation can be used, a current feed-forward table has to be generated using the CALCCOG command.
Since the current feed-forward signal is related to the position-feedback PFB, the cogging compensation can only be used if the reference point has been set. In order for the cogging compensation to work properly, either it has to be ensured that the reference point is always located at the same position or the current feed-forward table has to be re-calculated using CALCCOG each time the reference point is set.

Please have a look:
DRVCNFG3 = 0x80 (bit 7) PRD position (commutation) is used to calculate the cogging table and not PFB (position control). This setting is useful for all rotary axes.


ASCII English COGRED

ASCII - Command | COGRED |
Syntax Transmit | COGRED [Data] |
Syntax Receive | COGRED <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0.01 ... 1 | DPR | No
Default | 0.1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 2.51 |
Configuration | No | Last Change of this Object | 2.12
Function Group | motor | EEPROM | Yes
Short Description | Factor for GV reduction during cogging measurement

Description

During generation of a new cogging-compensation table via CALCCOG, GV is reduced in order to prevent the current from oscillating. By default, during cogging measurement, GV is reduced to 10% of its regular value. For small GV values, this maybe insufficient to measure the cogging properly. Therefore, the parameter COGRED can be used to adjust the reduction of GV during the cogging measurement, ranging from 0.01 to 1. If the resulting reduced GV is below 0.05, it is internally limited to 0.05.


ASCII English COLDSTART

ASCII - Command | COLDSTART |
Syntax Transmit | COLDSTART |
Syntax Receive | COLDSTART | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3632 (hex)
DIM | - | PROFIBUS PNU | 1906 (dec) IND = 1 (dec)
Range | - | DPR | 306 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Drive reset

Description

Software reset (warm boot) of the servo amplifier. The servo amplifier must be disabled. The current faults are cancelled, the servo amplifier software is initialized and communications are re-established. This command has the same effect as turning the drive power off and then back on.


ASCII English CONTINUE

ASCII - Command | CONTINUE |
Syntax Transmit | CONTINUE |
Syntax Receive | CONTINUE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 351D (hex)
DIM | - | PROFIBUS PNU | 1629 (dec) IND = 1 (dec)
Range | - | DPR | 29 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Continue last position order

Description

The CONTINUE command can be used to continue (and complete) a motion block that was previously interrupted by the STOP command. This is especially important for a motion block with relative paths.


ASCII English CPHASE

ASCII - Command | CPHASE |
Syntax Transmit | CPHASE [Data] |
Syntax Receive | CPHASE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 358B (hex)
DIM |  | PROFIBUS PNU | 1739 (dec) IND = 1 (dec)
Range | 0 .. 0x7FFF | DPR | 139 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.3 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | drive configuration | EEPROM | Yes
Short Description | configuration of fault monitoring

Description

The parameter CPHASE configurates the error monitoring of the motor phases, I/O optioncard, feedback amplitudes (SinCos and resolver) as well the regen fault. Have a look to STATCODE *
Bit | value | description
0 | 0x0001 | =0 motor cable break supervision =1 no motor cable break supervision
1 | 0x0002 | =0 amplitude supervision is active =1 no amplitude supervision
2 | 0x0004 | =0 I/O card error/Warning are displayed =1 no I/O card error/Warning (since FW 5.45)
3 | 0x0008 | =0 regen error supervision is active =1 no regen error supervision (since FW 5.67)
4 | 0x0010 | =0 old resolver error supervision =1 extended resolver error supervision (since FW 5.78)
5 | 0x0020 | =0 no resolver gradient check =1 resolver gradient check active (only when extended resolver error supervision active) (since FW 5.78)
6 | 0x0040 | reserved
7 | 0x0080 | = 1 no monitoring of the bus-off fault (F23)


ASCII English CSCNFG

ASCII - Command | CSCNFG |
Syntax Transmit | CSCNFG [Data] |
Syntax Receive | CSCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38CA (hex)
DIM |  | PROFIBUS PNU | 1770 (dec) IND = 33 (dec)
Range | -2147483648 .. 2147483647 | DPR | 970 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.9
Function Group | safety | EEPROM | Yes
Short Description | Configuration Variable for safety card

Description

The CSCNFG command returns the configuration options of the safety card in the form of a bit-variable.

Bit Beschreibung
0 =1 deactivates the setpoint monitoring in OPMODE 2+3 (otherwise OPMODE 2+3 is not possible with safety card!)
1 =1 deactivates the setpoint monitoring in all OPMODE
2 reserved
3 reserved
4 =1 status of motorbrake is send to the safety optioncard
5 =1 status of motorbrake is send to the safety optioncard and the drive is disabled
6..30 reserved
31 =1 CLRFAULT doesn't reset the safety optioncard, if there is no safety fault


ASCII English CSENID

ASCII - Command | CSENID |
Syntax Transmit | CSENID [Data] |
Syntax Receive | CSENID <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 38CB (hex)
DIM |  | PROFIBUS PNU | 1771 (dec) IND = 33 (dec)
Range | 0 / 1 | DPR | 971 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.00 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | safety | EEPROM | Yes
Short Description | reactive current impression

Description

CSENID enables the impression of an reactive current (Id) if the active current portion (Iq) is not sufficient for the safety card.

The maximum value for the reactive current can be set via CSIDMAX. Id will be automatically reduced if Iq increases. Id is zero if Iq reaches CSIDMAX.

CSENID =1 will activate the reactive current impression (only if a safety card is installed).

Note: If the safety card is removed, the value for CSENID must reset to 0, otherwise a slot fault (F20) will be generated.


ASCII English CSERR

ASCII - Command | CSERR |
Syntax Transmit | CSERR [Data] |
Syntax Receive | CSERR <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3892 (hex)
DIM |  | PROFIBUS PNU | 1714 (dec) IND = 33 (dec)
Range | -2147483648 .. 2147483647 | DPR | 914 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.7
Function Group | safety | EEPROM | No
Short Description | Actual error values of the safety card

Description

The CSERR command returns the actual errors of the safety card in the form of a bit-variable.
Bit | Display | Description
0 | o01 | SS1, error at safety function 'Safe Stop 1'
1 | o02 | SS2, error at safety function 'Safe Stop 2'
2 | o03 | SOS, error at safety function 'Safe Operating Stop'
3 | o04 | SLS, error at safety function 'Safely Limited Speed'
4 | o05 | SSR, error at safety function 'Safe Speed Range'
5 | o06 | SDI, error at safety function 'Safe Direction'
6 | o07 | SBT, error at safety function 'Safe Brake Test'
7 | o08 | reserved
8 | o09 | reserved
9 | o10 | reserved
10 | o11 | reserved
11 | o12 | Digital Input, error wiring digital inputs
12 | o13 | Digital Output, error wiring/read back digital outputs
13 | o14 | Reference Voltage, error voltage monitoring
14 | o15 | Watchdog Test, error at watchdog test
15 | o16 | Memory Test, error at memory test (Flash/RAM)
16 | o17 | Timing Error (monitoring interrupt)
17 | o18 | Plausibility Position (Current), monitoring position via current signal
18 | o19 | Plausibility Position (Encoder), monitoring position via sensor signal (internal, external, target value)
19 | o20 | Plausibility Parameter, wrong drive parameter
20 | o21 | Plausibility Input/Config, input conditions do not match configuration
21 | o22 | Mismatch Data A-B, error data comparison channel A-B
22 | o23 | reserved
23 | o24 | reserved
24 | o25 | Flash Memory Error, error on erasing/writing flash memory
25 | o26 | Synchronization CPU A-B, error at chronological synchronization with channel A and B
26 | o27 | Watchdog, watchdog was fired
27 | o28 | Check Data / Parameter, check data/parameter (data communication, configuration)
28 | o29 | Timeout Data Transfer, timeout while transferring data/configuration
29 | o30 | Error CRC Calculation
30 | o31 | Check Device Data (serial number, version)
31 | 032 | Error System Software (fatal)


ASCII English CSIDMAX

ASCII - Command | CSIDMAX |
Syntax Transmit | CSIDMAX [Data] |
Syntax Receive | CSIDMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38CC (hex)
DIM |  | PROFIBUS PNU | 1772 (dec) IND = 33 (dec)
Range |  | DPR | 972 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.7
Function Group | safety | EEPROM | Yes
Short Description | Maximum value for reactive current command

Description

A value of 328 is equivalent to 10% DIPEAK.

See also CSENID.


ASCII English CSIOSTAT

ASCII - Command | CSIOSTAT |
Syntax Transmit | CSIOSTAT [Data] |
Syntax Receive | CSIOSTAT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3894 (hex)
DIM |  | PROFIBUS PNU | 1713 (dec) IND = 33 (dec)
Range | -2147483648 .. 2147483647 | DPR | 913 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.7
Function Group | safety | EEPROM | No
Short Description | Input and output states of the safety card

Description

The CSIOSTAT command returns the input and output states of the safety card in the form of a bit-variable.
Bit Description
0 state input 'SS1 Activate'
1 state input 'SS2 Activate'
2 state input 'SOS Activate'
3 state input 'SLS Activate'
4 state input 'SSR Activate'
5 state input 'SDI Left Activate'
6 state input 'SDI Right Activate'
7 state input 'SBT Activate'
8 state output 'Ready'
9 staten output 'STO Acknowledge'
10 state output 'SOS Acknowledge'
11 state output 'SDI Acknowledge'
12 state output 'Safe Range Acknowledge'
13 state output 'SBT Acknowledge'
14 state two-pole output 'Safe Brake Control' (external brake)
15 state output 'STO SIL3' (second shutdown path)
16 state input 'SS1 SIL3/Reset'
29 brake ramp control SS2 (0=drive controlled, 1=controller controlled)
30 brake ramp control SS1 (0=drive controlled, 1=controller controlled)
31 emergency stop brake ramp at SS1 (0=not active, 1=active)


ASCII English CSSTAT

ASCII - Command | CSSTAT |
Syntax Transmit | CSSTAT [Data] |
Syntax Receive | CSSTAT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3890 (hex)
DIM |  | PROFIBUS PNU | 1712 (dec) IND = 33 (dec)
Range | 0 .. 2147483647 | DPR | 912 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.7
Function Group | safety | EEPROM | No
Short Description | Status information of safety card

Description

The CSSTAT command returns the internal status information of the safety card in the form of a bit-variable.

Bit Description
0 LED POWER, Status LED 'POWER' on the front panel of the safety card
1 LED RUN, Status LED 'RUN' on the front panel of the safety card
2 LED CONFIG, Status LED 'CONFIG' on the front panel of the safety card
3 LED FAULT, Status LED 'FAULT' on the front panel of the safety card
4 STO, internal state 'STO' (0 = STO inactive, 1 = STO active)
5 Download OK, successful download of the configuration file
8 STARTUP, bit is set if internal state of the safety card is 'STARTUP'
9 RUN, bit is set if internal state of the safety card is 'RUN'
10 STOP, bit is set if internal state of the safety card is 'STOP'
11 CONFIG, bit is set if internal state of the safety card is 'CONFIG'


ASCII English CTUNE

ASCII - Command | CTUNE |
Syntax Transmit | CTUNE |
Syntax Receive | CTUNE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | Hz | PROFIBUS PNU | -
Range | 500 ... 2500 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Calculate current parameters

Description

This command calculates current parameters. Set the OPMODE = 2 before starting.

An optional parameter for the bandwidth can be set for the tuning process.
The default data is with FILTMODE = 2 1800 Hz else 1200 HZ


ASCII English CUPDATE

ASCII - Command | CUPDATE |
Syntax Transmit | CUPDATE |
Syntax Receive | CUPDATE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 351F (hex)
DIM | - | PROFIBUS PNU | 1631 (dec) IND = 1 (dec)
Range | - | DPR | 31 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Program update (CAN bus)

Description

The CUPDATE command activates a function that can receive data through a CAN bus interface and save them in the program memory of the amplifier. After this function has been activated, no more commands will be accepted through the serial interface.
The program PRGDOWN.EXE should be used for downloading data on the PC side. This program operates with the hardware in a handshaking procedure, and prepares the data for CAN transmission.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Current Loop

einheiten

Parameters for tuning the current loop. Usually changes are not necessary, if the motor dataset is correct.

Screen text | ASCII parameter
Ipeak (pos.) | IPEAKP
Ipeak (neg.) | IPEAKN
Homing Ipeak | REFIP
I²t Warning | I2TLIM
Proportional Gain (Kp_i) | MLGQ
Integral Time (Tn_i) | KTN


ASCII English DAOFFSET1

ASCII - Command | DAOFFSET1 |
Syntax Transmit | DAOFFSET1 [Data] |
Syntax Receive | DAOFFSET1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 387C (hex)
DIM | mV | PROFIBUS PNU | 1692 (dec) IND = 33 (dec)
Range | -500 .. 500 | DPR | 892 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting | 1000
Start Firmware | 3.14 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog Offset Output 1

Description

This is an offset that is applied to the D/A converter for analog output 1. The offset value is given in internal units (counts). Scaling is as follows:

DAOFFSET1 = 2058 -10V
DAOFFSET1 = 1250 0V
DAOFFSET1 = 442 10V

FW > 5.00


ASCII English DAOFFSET2

ASCII - Command | DAOFFSET2 |
Syntax Transmit | DAOFFSET2 [Data] |
Syntax Receive | DAOFFSET2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 387D (hex)
DIM | mV | PROFIBUS PNU | 1693 (dec) IND = 33 (dec)
Range | -500 .. 500 | DPR | 893 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting | 1000
Start Firmware | 3.14 |
Configuration | No | Last Change of this Object | 2.3
Function Group | analog I/O | EEPROM | Yes
Short Description | Analog Offset Output 2

Description

This is an offset that is applied to the D/A converter for analog output 2. The offset value is given in internal units (counts). Scaling is as follows:

DAOFFSET2 = 2058 -10V
DAOFFSET2 = 1250 0V
DAOFFSET2 = 442 10V

FW > 5.00


ASCII English DEC

ASCII - Command | DEC |
Syntax Transmit | DEC [Data] |
Syntax Receive | DEC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3522 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1634 (dec) IND = 1 (dec)
Range | depending on ACCUNIT | DPR | 34 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.7
Function Group | velocity loop | EEPROM | Yes
Short Description | Deceleration rate

Description

The DEC command defines the deceleration ramp for the velocity control loop. The DEC deceleration/braking ramp is only used for setpoint step changes that result in a velocity decrease (braking). The ACC parameter is used for acceleration.

The DEC braking ramp applies to all setpoint changes, whether they are provided in analog or digital form. Separate braking ramps (DECSTOP/DECDIS) are used for setpoint changes that are generated internally in emergency stop situations (e.g. amplifier fault, or removal of the amplifier enable).

See also ACCUNIT


ASCII English DEC_X

ASCII - Command | DEC_X |
Syntax Transmit | DEC_X [Data] |
Syntax Receive | DEC_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3878 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1688 (dec) IND = 33 (dec)
Range | depending on ACCUNIT | DPR | 888 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 3.07 |
Configuration | No | Last Change of this Object | 2.0
Function Group | velocity loop | EEPROM | Yes
Short Description | Deceleration ramp velocity controller 2. Set

Description

see PARCNFG


ASCII English DECDIS

ASCII - Command | DECDIS |
Syntax Transmit | DECDIS [Data] |
Syntax Receive | DECDIS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3523 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1635 (dec) IND = 1 (dec)
Range | depending on ACCUNIT | DPR | 35 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | Deceleration used on disable output stage

Description

When the output stage is disabled (removal of the hardware or software enable), the internal velocity setpoint is set to 0, using the preset DECDIS ramp. The output stage is only disabled when the actual velocity has fallen below the standstill threshold (VEL0).
The DECDIS ramp only has an effect for motors with a configured brake (MBRAKE=1) or with the selection STOPMODE=1.
With STOPMODE=0 the output stage is immediately disabled, and the drive coasts down.

See also ACCUNIT


ASCII English DECR

ASCII - Command | DECR |
Syntax Transmit | DECR [Data] |
Syntax Receive | DECR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3524 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1636 (dec) IND = 1 (dec)
Range | depending on ACCUNIT | DPR | 36 (dec)
Default |  |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Deceleration ramp for homing/jog modes

Description

The DECR command defines the braking ramp for jog mode or homing with the internal position control loop. The entry is made in ACCUNIT. If ACCUNIT=0 (acceleration in ms) DECR is defined to PVMAX.
When starting the homing/jog mode, the DECR deceleration ramp can, in some circumstances, be limited by the minimum acceleration time PTMIN (see description of the PTMIN parameter).

Details are shown at parameter ACCUNIT .


ASCII English DECSTOP

ASCII - Command | DECSTOP |
Syntax Transmit | DECSTOP [Data] |
Syntax Receive | DECSTOP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3525 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1637 (dec) IND = 1 (dec)
Range | depending on ACCUNIT | DPR | 37 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | Quick stop – braking ramp for emergency situations

Description

In emergency stop situations, the internal setpoint goes to 0 using the preset DECSTOP ramp. The output stage is only disabled when the actual velocity has fallen below the standstill threshold (VEL0).
An emergency stop situation exists in the following cases:
- amplifier fault (with ACTFAULT=1)
- contouring/following error
- threshold monitoring (fieldbus devices)
- hardware/software limit switch activated
- quick stop function through the digital input (INxMODE=27)
- quick stop function through the fieldbus (control word)

see also ACCUNIT


DriveGUI Online Hilfe

general

helpscreen

Frame 6574 (4)

Frame73 (13)

Frame73 (12)

Frame73 (11)

Frame73 (14)

warning_r_autostart

Frame 6573 (5)

Frame 6573 (6)

Frame 6573 (7)

Frame 6573 (8)

installation

warning_r_general1

qssystem

warning_r_general11

S700system

warning_r_general12

S748system

Frame 6574 (7)

start

icon_drivegui

screen001

SI029f

comnet

screen005

screen003

screen004

screen006

Frame24

Frame11

Frame17

Frame12

Frame18

Frame13

Frame19

Frame14

Frame20

Frame15

Frame21

Frame16

Frame22

Frame10 (2)

Frame23

Frame28 (2)

opmode

navigation

main

help

hilfeicon1

wizard

setupwizard

basic

basis

parameter

basis

units

einheiten

Frame61 (2)

calc_leadscrew1

calc_leadscrew2

calc_leadscrew

calc_leadscrew4

calc_leadscrew5

calc_leadscrew3

calc_leadscrew7

calc_leadscrew8

calc_leadscrew6

calc_leadscrew9

can

einheiten

can_pdo

can_param

asynchron

uf

mot_fdbk

einheiten

Frame 6574 (5)

kamera

einheiten6

enclines

feedback

warning_r_general

einheiten

Frame 6573 (6)

einheiten7

fb_ws

einheiten

warning_r_general

Frame 6573 (7)

fb_test

warning_r_general

Frame 6573 (5)

einheiten

endat22_d

HDSL_d

motor

einheiten

einheiten5

einheiten51

einheiten4

mot_feld

einheiten

motor_cog

einheiten

Frame61 (2)

current

einheiten

velocity

einheiten

position

einheiten

position_erw

einheiten

posdata

einheiten

A0243-26

posreg

einheiten

gearing

einheiten

encoder

einheiten

einheiten1

ana_io

einheiten

digi_io

einheiten

incmd2

incmd

incmd21

incmd1

incmd11

incmd111

mservice

Frame 6573 (4)

einheiten

plus

minus

Frame1 (4)

Frame1 (5)

status

status

basis-fehler-f24

basis-fehler-f241

monitor

monitor

homing

einrichten

Frame 6574 (2)

Frame 6574 (3)

Frame 6574 (4)

Frame 6574 (6)

Frame 6573 (4)

A0243-15

A0243-28

A0243-17

A0243-281

A0243-19

Frame 6573 (5)

A0243-2811

A0243-21

A0243-28111

A0243-23

Frame 6574 (7)

A0243-281111

A0243-25

Frame 6573 (6)

A0243-2811111

A0243-27

Frame 6573 (7)

A0243-28111111

A0243-30

mtasktab

fahrsatz1

Frame 6574 (4)

einheiten2

profil0

profil1

profil2

profil3

scope

oszilloskop

oszilloskop_kanal

makro

einheiten3

einheiten31

Frame 6573 (4)

einheiten32

Frame 6573 (5)

service2

einheiten33

einheiten331

farben

einheiten3312

einheiten3311

oszilloskop_record

bode

Frame 6573 (4)

bode1

bodeparameter

bodefilter

bode

terminal

terminal

io_opt

ioerweiterung

ioconfig

sercos

Sercos

profi

Profibus1

Frame3

Frame2

ethercat

Profibus1

Autotuning

Frame2 (5)

Profibus1

Frame 6573 (7)

safetycard

Profibus1

sd_card

Profibus1

Frame 6573 (4)

sd-card_load

sd-card_load1

Antriebsberechnung

anydim

ServoPumpe_e

Motorsetup

Frame2 (5)

Frame 6573 (6)

SW-Upgrade

screen300

upgrade2

appendix

Frame88 (2)


DriveGUI Online Hilfe

Contents

  • Online Help for Setup Software DriveGUI.exe
  • Contents
  • General
    • Introduction
    • How to use the Online-Help
      • Navigation
      • Full text search
    • Used Symbols
    • Safety
      • You should pay attention to this
      • Use as directed
      • Prohibited use
    • ASCII Object Reference Guide
    • Servo System Overview
      • Feedback Device
      • The Motion Profile
      • Limits and Ranges of Operation
      • Acceleration and Deceleration
  • Installation
    • Hardware Installation
      • Minimum Wiring S300
      • Minimum Wiring S701-724 (STO dual channel)
      • Minimum Wiring S748/772
    • Software Installation
    • Firmware Upgrade
    • Switch-On the Amplifier
  • Use
    • Start the Software
    • Online/Offline
      • Online
      • Offline
    • Screen layout
      • Title bar
      • Menu bar
      • Tool bar
      • Status bar
      • Navigation frame
      • Main frame
    • Help functions
  • Screen pages
    • Setup Wizard
    • Basic Setup
    • Switch Parameter Configuration
    • Units / Mechanical
      • Calculation of resolution
    • CAN- / Fieldbus Settings
      • Mapped PDOs...
    • V/f Control
    • Motor / Feedback
      • Rotatory Motors
      • Linear Motors
    • Feedback
      • Calculate Offset
      • Example: Resolver
      • Example: SinCos with Hall
    • Wake and Shake - Expert
    • Test and Diagnosis
      • Test Feedback/Motor
      • Endat 2.2 Diagnosis
      • HIPERFACE DSL Diagnosis
    • Motor
      • Select Motor from Database
      • Custom Motor Parameters
      • KTY Support
    • Field Weakening
    • Cogging torque compensation
    • Current Loop
    • Velocity Loop
    • Position Loop
    • Position Loop Extension
    • Position Data
    • Position Registers
    • Electronic Gearing
    • Encoder Emulation
      • Incremental Encoder (ROD, A QUAD B)
      • Absolute Position Encoder (SSI)
    • Analog I/O
    • Digital I/O
      • OPMODE Configuration (INxMODE 24)
      • Configure Velocity Time (INxMODE 39)
      • Configure Command Buffer (INxMODE 30)
      • Configure Mask for TRJSTAT (OxMODE 38/39/50/51)
      • Configure Mask for DRVSTAT (OxMODE 36/37/48/49)
      • Configure Mask for POSRSTAT (OxMODE 40/41)
    • Motion Service
    • Status (Faults/Warnings)
    • Monitor
    • Homing
      • Homing type 0
      • Homing type 1
      • Homing type 2
      • Homing type 3
      • Homing type 4
      • Homing type 5
      • Homing type 6
      • Homing type 7
      • Homing type 8
      • Homing type 9
    • Motion Task
      • Overview
      • Edit
      • Next Motion Task
    • Oscilloscope
      • Handling notes
      • Channels
      • Trigger
      • Recording / Scope File
      • Motion Service
      • Tuning
      • Settings
      • Extended Channels
      • WS Tuning
      • Recording
    • Bode Plot
    • Terminal
    • I/O Expansion Card
    • SERCOS Expansion Card
    • PROFIBUS Expansion Card
      • Important amplifier configuration parameters
      • Instrument Control
    • EtherCAT Expansion Card
    • Autotuning
      • Current and Observer Tuning
      • Test Step Speed
      • Velocity Loop Tuning
    • Safety Card
    • SD Card
      • Delete File
      • Load
      • Save
      • Used ASCII parameters
  • Application Notes
    • Drive calculation
    • Servo Pump
    • Macro Programming
    • Setup of an unknown motor
    • Asynchron machine - V/f Control
    • DC Motor Setup
    • Firmware Upgrade
  • Appendix
    • Glossary
    • Related Documents
    • Errors
    • Warnings
    • Trouble Shooting
      • Help with Faults
      • Help with Warnings
      • Help with other problems


ASCII English DENA

ASCII - Command | DENA |
Syntax Transmit | DENA [Data] |
Syntax Receive | DENA <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362D (hex)
DIM | - | PROFIBUS PNU | 1901 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 301 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | DPR software disable reset mode

Description

With external DPR-SLOT cards, it is possible to cancel existing instrument faults by removing the DPR software enable. This function can be activated or inhibited by using the DENA variable.

DENA=0 Removing the software enable causes a hardware/software reset of the amplifier.
The reset only takes place when a fault occurs, or the warning “contouring error” or “threshold monitoring activated” is present. (customer-specific protocol: Beckhoff).

DENA=1 Removing the software enable causes a hardware/software reset of the amplifier.
The reset only takes place when a fault occurs, or the warning “contouring error” or “threshold monitoring activated” is present.

DENA=2 No reset if the software enable is removed.


ASCII English DI2T

ASCII - Command | DI2T |
Syntax Transmit | DI2T [Data] |
Syntax Receive | DI2T <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer 8 | CANBus Object Number | 3559 (hex)
DIM | % | PROFIBUS PNU | 1689 (dec) IND = 1 (dec)
Range | 0 ... 100 | DPR | 89 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer 8
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Drive I2T load

Description

This variable returns the average current as a percentage of the continuous current (see DICONT). The average current is filtered with a time constant of 16 seconds.


ASCII English DICONT

ASCII - Command | DICONT |
Syntax Transmit | DICONT |
Syntax Receive | DICONT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3527 (hex)
DIM | A | PROFIBUS PNU | 1639 (dec) IND = 1 (dec)
Range | 1.5 .. 20.0 | DPR | 39 (dec)
Default | Hardware Defined |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Drive continuous current

Description

The continuous current rating of the drive. DICONT is depending on VBUSBAL for drive 403, 406, 614 and 670.


ASCII English DIFVAR

ASCII - Command | DIFVAR |
Syntax Transmit | DIFVAR |
Syntax Receive | DIFVAR <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | List variables with values

Description

This command produces a list of parameters with settings that differ from the default values. The list contains entries in the following form:

PARAMETER Value (Default) PARAMETER = Parameter name
Value = the actual parameter setting
Default = the default value for the parameter


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Digital I/O

einheiten

Assign predefined functions to the digital inputs and outputs of the servo amplifier.
Depending on the function, you can input a value or there is an additional button for an extended input screen.
Inputs 21/22 are available with S700 only. This servo amplifier offers two bi-directional interfaces, which can be used as input or output dependant on the selected function.The setting of these inputs are bolted with the correspondent outputs.

Screen text | ASCII parameter
Input | IN1MODE (Sample for Input 1)
Value | IN1TRIG (Sample for Input 1)
Output | O1MODE (Sample for Input 1)
Value | O1TRIG (Sample for Input 1)
Invert | DIRIN inverts the selected output function DIROUT inverts the selected output function

OPMODE Configuration (INxMODE 24)

Configure Velocity Time (INxMODE 39)

incmd2

Screen text | ASCII parameter
Jog | IN1TRIG (Sample for Input 1), bit 0...15
for time | IN1TRIG (Sample for Input 1), bit 16...31

Configure Command Buffer (INxMODE 30)

incmd

Input of the ASCII command list for execution. Depending on the edge of the input signal, the command lists can be different.
Application examples for using INxMODE30 can be found in the KDN.

Screen text | ASCII parameter
Command list, positive transition | IN1HCMD (Sample for Input 1)
Command list, negative transition | IN1LCMD (Sample for Input 1)

Configure Mask for TRJSTAT (OxMODE 38/39/50/51)

incmd1

The TRJSTAT command returns the internal status information in the form of a bit-variable.

The status information 3...15 and 27...31 are primarily used for internal functions. Bits 0...2 and 16...26 can be used for external functions (control system). Select the information in the bit mask that you want to observe. The bit mask is compared with the bit variable contents according to the selected logic (AND, OR, NAND, NOR). The digital output is set if the result is a logical 1.

Configure Mask for DRVSTAT (OxMODE 36/37/48/49)

incmd11

The DRVSTAT command returns the internal status information in the form of a bit-variable. Select the information in the bit mask that you want to observe. The bit mask is compared with the bit variable contents according to the selected logic (AND, OR, NAND, NOR). The digital output is set if the result is a logical 1.

Configure Mask for POSRSTAT (OxMODE 40/41)

incmd111

The POSRSTAT command returns the actual status of the fast position registers. Select the information in the bit mask that you want to observe. The bit mask is compared with the bit variable contents according to the selected logic (AND, OR). The digital output is set if the result is a logical 1. An example for using position registers can be found in the KDN (Camming).

The functionality of the position registers can be setup on the screen page POSITION REGISTERS.


ASCII English DILIM

ASCII - Command | DILIM |
Syntax Transmit | DILIM [Data] |
Syntax Receive | DILIM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362C (hex)
DIM | - | PROFIBUS PNU | 1900 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 300 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | DPR current limit

Description

With external DPR-SLOT cards it is possible to limit the drive current through the DPR (RAM interface to the SLOT card). This function must be enabled through the DILIM configuration variable.


ASCII English DIPEAK

ASCII - Command | DIPEAK |
Syntax Transmit | DIPEAK |
Syntax Receive | DIPEAK <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3529 (hex)
DIM | A | PROFIBUS PNU | 1641 (dec) IND = 1 (dec)
Range | 3.0 .. 70.0 | DPR | 41 (dec)
Default | Hardware Defined |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Drive peak rated current

Description

The peak rated current of the drive.


ASCII English DIR

ASCII - Command | DIR |
Syntax Transmit | DIR [Data] |
Syntax Receive | DIR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 352A (hex)
DIM | - | PROFIBUS PNU | 1642 (dec) IND = 1 (dec)
Range | 0 ... 2047 | DPR | 42 (dec)
Default | 21 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 0.87 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | drive configuration | EEPROM | Yes
Short Description | Direction of different actuall values

Description

The DIR variable defines the count direction for feedback information
The DIR variable can be considered as a 16-bit variable, whereby the single bits define the count direction
for different feedback units.
Bit=1 means a positive direction (cw), Bit=0 a negative direction (ccw)

Bit 0 (0x01) count direction for FBTYPE unit (=1 positive direction)
Bit 1 (0x02)
Bit 2 (0x04) count direction for EXTPOS unit (=1 positive direction)
Bit 3 (0x08)
Bit 4 (0x10) count direction for GEARMODE unit (=1 positive direction)
Bit 5 (0x20)
Bit 6 (0x40) =1 inverse commutation
Bit 7 (0x80) =1 inverse encoder absolute position (ENDAT,HYPERFACE, BISS)
Bit 8 (0x100) = 1 inverse counting direction for analog Hall via ANIN1/ANIN2
Bit 9 (0x200) = 1 inverse counting direction for analog Hall via X1 (sinus+/sinus-)


ASCII English DIRIN

ASCII - Command | DIRIN |
Syntax Transmit | DIRIN [Data] |
Syntax Receive | DIRIN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 389D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 33 (dec)
Range | 0...2147483647 | DPR | 925 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.66 |
Configuration | Yes | Last Change of this Object | 2.4
Function Group | digital I/O | EEPROM | Yes
Short Description | polarity of the digital inputs

Description

Defines the polarity of the digital inputs of the drive
DIRIN is a bit parameter. A single bit x of this variable is assigned to the digital input INx.
A bit state of 1 inverts the corresponding digital input.

This function is available only for the inputs IN1,IN2,IN3,IN4 (IN21,IN22 for S700)


ASCII English DIROUT

ASCII - Command | DIROUT |
Syntax Transmit | DIROUT [Data] |
Syntax Receive | DIROUT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 385F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 33 (dec)
Range |  | DPR | 863 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.05 |
Configuration | Yes | Last Change of this Object | 2.0
Function Group | digital I/O | EEPROM | Yes
Short Description | polarity of the digital outputs

Description

Defines the polarity of the digital outputs. DIROUT is a bit parameter. A single bit x of this variable is assigned to the digital output OUTPUTx.A bit state of 1 inverts the corresponding digital output.

Outputs main device 2 (O1 - O2)
Outputs option card 8 (O3 – O10)
virtual outputs 8 (O11 - O18)


ASCII English DIS

ASCII - Command | DIS |
Syntax Transmit | DIS |
Syntax Receive | DIS | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 352B (hex)
DIM | - | PROFIBUS PNU | 1643 (dec) IND = 1 (dec)
Range | - | DPR | 43 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Software-Disable

Description

The DIS command sets the software enable for the output stage to 0. Depending on the configuration (see MBRAKE, STOPMODE), the drive will coast down, or be run down under control.


ASCII English DISDPR

ASCII - Command | DISDPR |
Syntax Transmit | DISDPR [Data] |
Syntax Receive | DISDPR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3673 (hex)
DIM | - | PROFIBUS PNU | 1971 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 371 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | -
Short Description | Disable DPR access

Description

DISDPR=1 disables the write access of e.g. Lightbus option boards to the drive. Read access is still possible. This enables the service functionality via PC even if the Bus is running.

DISDPR=0 Full access from the controller side.
DISDPR=1 Only read access.

This parameter is not stored in the EEPROM.


ASCII English DNBAUD

ASCII - Command | DNBAUD |
Syntax Transmit | DNBAUD [Data] |
Syntax Receive | DNBAUD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 369F (hex)
DIM | kBaud | PROFIBUS PNU | 2015 (dec) IND = 1 (dec)
Range | 125,250,500 | DPR | No
Default | 125 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | Yes
Short Description | DeviceNet baud rate

Description

The baud rate switch on the DeviceNet option card may be set to 0 (125 KBaud), 1 (250 KBaud) or
2 (500 KBaud). If the switch is set to a value greater than 2, the baud rate is configurable through
the terminal parameter DNBAUD and through DeviceNet. If the switch is set from 0 to 2, the baud
rate cannot be controlled with DNBAUD or DeviceNet.


ASCII English DNDUMP

ASCII - Command | DNDUMP |
Syntax Transmit | DNDUMP [Data] |
Syntax Receive | DNDUMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | fieldbus | EEPROM | -
Short Description | Debugging information DeviceNet

Description

DNDUMP prints out debugging information with the status of the DeviceNet connection.


ASCII English DNMACID

ASCII - Command | DNMACID |
Syntax Transmit | DNMACID [Data] |
Syntax Receive | DNMACID <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36A0 (hex)
DIM | - | PROFIBUS PNU | 2016 (dec) IND = 1 (dec)
Range | 0...63 | DPR | No
Default | 63 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | MACID (Adress) for DeviceNet card

Description

The MACID (address) switches on the DeviceNet option card may be set to a valid address from 0 to 63. If the switches are set to a value greater than 63, the MACID is configurable through the terminal parameter DNMACID and through DeviceNet. If the switches are set from 0 to 63, the MACID cannot be controlled with DNMACID or DeviceNet.


ASCII English DOVRIDE

ASCII - Command | DOVRIDE |
Syntax Transmit | DOVRIDE [Data] |
Syntax Receive | DOVRIDE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36B6 (hex)
DIM | - | PROFIBUS PNU | 2038 (dec) IND = 1 (dec)
Range | 0 .. 8192 | DPR | 438 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Digital override factor

Description

If the digital Override function is selected (see OVRIDE=3), DOVRIDE gives the possibility to change the digital scaling.

The scaling is:

DOVRIDE=0 Motion task speed is 0 %
DOVRIDE=8192 Motion task speed is 100 %


ASCII English DPRILIMIT

ASCII - Command | DPRILIMIT |
Syntax Transmit | DPRILIMIT [Data] |
Syntax Receive | DPRILIMIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3658 (hex)
DIM | - | PROFIBUS PNU | 1944 (dec) IND = 1 (dec)
Range | 0 .. 3280 | DPR | 344 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | other commands | EEPROM | No
Short Description | Digital Limiting of the peak Current via DPR

Description

Digiatl Limiting of the peak current via DPR.

The scaling is:
DPRILIMIT=3280 Current limited to DIPEAK
DPRILIMIT=0 Current limited to 0 A

If the drive is switched on, DPRILIMIT is set to 3280 (no current limit). DPRILIMIT is not stored in EEPROM. So to enable the limit, write the data to the variable via fieldbus, RS232 or I/O command buffer.

To enable this function, DILIM has to be set to "1".

Attention: for EtherCAT SDO communication please use the object 0x2061 SubIndex 0


ASCII English DPRSTATE

ASCII - Command | DPRSTATE |
Syntax Transmit | DPRSTATE [Data] |
Syntax Receive | DPRSTATE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | other commands | EEPROM | No
Short Description | DPR state

Description

The parameter DPRSTATE is used to get debug information of the DPR based interfaces. e.g. DPRSTATE is used for phase startup and SDO communication.


ASCII English DPRVAR1_16

ASCII - Command | DPRVAR1_16 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | -2147483648 .. 2147483647 | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.9
Function Group | other commands | EEPROM | Yes
Short Description | macro temp variable

Description

DPRVAR1 Object No = 422 CAN-Objekt 36A6 (hex) PROF-PNU 2022 (dec) IND = 1 (dec)
DPRVAR2 Object No = 423 CAN-Objekt 36A7 (hex) PROF-PNU 2023 (dec) IND = 1 (dec)
DPRVAR3 Object No = 424 CAN-Objekt 36A8 (hex) PROF-PNU 2024 (dec) IND = 1 (dec)
DPRVAR4 Object No = 425 CAN-Objekt 36A9 (hex) PROF-PNU 2025 (dec) IND = 1 (dec)
DPRVAR5 Object No = 426 CAN-Objekt 36AA (hex) PROF-PNU 2026 (dec) IND = 1 (dec)
DPRVAR6 Object No = 427 CAN-Objekt 36AB (hex) PROF-PNU 2027 (dec) IND = 1 (dec)
DPRVAR7 Object No = 428 CAN-Objekt 36AC (hex) PROF-PNU 2028 (dec) IND = 1 (dec)
DPRVAR8 Object No = 429 CAN-Objekt 36AD (hex) PROF-PNU 2029 (dec) IND = 1 (dec)
DPRVAR9 Object No = 430 CAN-Objekt 36AE (hex) PROF-PNU 2030 (dec) IND = 1 (dec)
DPRVAR10 Object No = 431 CAN-Objekt 36AF (hex) PROF-PNU 2031 (dec) IND = 1 (dec)
DPRVAR11 Object No = 432 CAN-Objekt 36B0 (hex) PROF-PNU 2032 (dec) IND = 1 (dec)
DPRVAR12 Object No = 433 CAN-Objekt 36B1 (hex) PROF-PNU 2033 (dec) IND = 1 (dec)
DPRVAR13 Object No = 434 CAN-Objekt 36B2 (hex) PROF-PNU 2034 (dec) IND = 1 (dec)
DPRVAR14 Object No = 435 CAN-Objekt 36B3 (hex) PROF-PNU 2035 (dec) IND = 1 (dec)
DPRVAR15 Object No = 436 CAN-Objekt 36B4 (hex) PROF-PNU 2036 (dec) IND = 1 (dec)
DPRVAR16 Object No = 437 CAN-Objekt 36B5 (hex) PROF-PNU 2037 (dec) IND = 1 (dec)


ASCII English DPV17_64

ASCII - Command | DPV17_64 |
Syntax Transmit | DPV17_64 [Data] |
Syntax Receive | DPV17_64 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | -2147483648 .. 2147483647 | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | other commands | EEPROM | Yes
Short Description | variable for macro or PLC program

Description

variable for macro or PLC program

DPV17 Objekt Nr = 700 CAN-Objekt 0x37BC (hex) PROF-PNU 1900 (dec) IND = 17
DPV18 Objekt Nr = 701 CAN-Objekt 0x37BD (hex) PROF-PNU 1901 (dec) IND = 17
DPV19 Objekt Nr = 702 CAN-Objekt 0x37BE (hex) PROF-PNU 1902 (dec) IND = 17
DPV20 Objekt Nr = 703 CAN-Objekt 0x37BF (hex) PROF-PNU 1903 (dec) IND = 17
DPV21 Objekt Nr = 704 CAN-Objekt 0x37C0 (hex) PROF-PNU 1904 (dec) IND = 17
DPV22 Objekt Nr = 705 CAN-Objekt 0x37C1 (hex) PROF-PNU 1905 (dec) IND = 17
DPV23 Objekt Nr = 706 CAN-Objekt 0x37C2 (hex) PROF-PNU 1906 (dec) IND = 17
DPV24 Objekt Nr = 707 CAN-Objekt 0x37C3 (hex) PROF-PNU 1907 (dec) IND = 17
DPV25 Objekt Nr = 708 CAN-Objekt 0x37C4 (hex) PROF-PNU 1908 (dec) IND = 17
DPV26 Objekt Nr = 709 CAN-Objekt 0x37C5 (hex) PROF-PNU 1909 (dec) IND = 17
DPV27 Objekt Nr = 710 CAN-Objekt 0x37C6 (hex) PROF-PNU 1910 (dec) IND = 17
DPV28 Objekt Nr = 711 CAN-Objekt 0x37C7 (hex) PROF-PNU 1911 (dec) IND = 17
DPV29 Objekt Nr = 712 CAN-Objekt 0x37C8 (hex) PROF-PNU 1912 (dec) IND = 17
DPV30 Objekt Nr = 713 CAN-Objekt 0x37C9 (hex) PROF-PNU 1913 (dec) IND = 17
DPV31 Objekt Nr = 714 CAN-Objekt 0x37CA (hex) PROF-PNU 1914 (dec) IND = 17
DPV32 Objekt Nr = 715 CAN-Objekt 0x37CB (hex) PROF-PNU 1915 (dec) IND = 17
DPV33 Objekt Nr = 716 CAN-Objekt 0x37CC (hex) PROF-PNU 1916 (dec) IND = 17
DPV34 Objekt Nr = 717 CAN-Objekt 0x37CD (hex) PROF-PNU 1917 (dec) IND = 17
DPV35 Objekt Nr = 718 CAN-Objekt 0x37CE (hex) PROF-PNU 1918 (dec) IND = 17
DPV36 Objekt Nr = 719 CAN-Objekt 0x37CF (hex) PROF-PNU 1919 (dec) IND = 17
DPV37 Objekt Nr = 720 CAN-Objekt 0x37D0 (hex) PROF-PNU 1920 (dec) IND = 17
DPV38 Objekt Nr = 721 CAN-Objekt 0x37D1 (hex) PROF-PNU 1921 (dec) IND = 17
DPV39 Objekt Nr = 722 CAN-Objekt 0x37D2 (hex) PROF-PNU 1922 (dec) IND = 17
DPV40 Objekt Nr = 723 CAN-Objekt 0x37D3 (hex) PROF-PNU 1923 (dec) IND = 17
DPV41 Objekt Nr = 724 CAN-Objekt 0x37D4 (hex) PROF-PNU 1924 (dec) IND = 17
DPV42 Objekt Nr = 725 CAN-Objekt 0x37D5 (hex) PROF-PNU 1925 (dec) IND = 17
DPV43 Objekt Nr = 726 CAN-Objekt 0x37D6 (hex) PROF-PNU 1926 (dec) IND = 17
DPV44 Objekt Nr = 727 CAN-Objekt 0x37D7 (hex) PROF-PNU 1927 (dec) IND = 17
DPV45 Objekt Nr = 728 CAN-Objekt 0x37D8 (hex) PROF-PNU 1928 (dec) IND = 17
DPV46 Objekt Nr = 729 CAN-Objekt 0x37D9 (hex) PROF-PNU 1929 (dec) IND = 17
DPV47 Objekt Nr = 730 CAN-Objekt 0x37DA (hex) PROF-PNU 1930 (dec) IND = 17
DPV48 Objekt Nr = 731 CAN-Objekt 0x37DB (hex) PROF-PNU 1931 (dec) IND = 17
DPV49 Objekt Nr = 732 CAN-Objekt 0x37DC (hex) PROF-PNU 1932 (dec) IND = 17
DPV50 Objekt Nr = 733 CAN-Objekt 0x37DD (hex) PROF-PNU 1933 (dec) IND = 17
DPV51 Objekt Nr = 734 CAN-Objekt 0x37DE (hex) PROF-PNU 1934 (dec) IND = 17
DPV52 Objekt Nr = 735 CAN-Objekt 0x37DF (hex) PROF-PNU 1935 (dec) IND = 17
DPV53 Objekt Nr = 736 CAN-Objekt 0x37E0 (hex) PROF-PNU 1936 (dec) IND = 17
DPV54 Objekt Nr = 737 CAN-Objekt 0x37E1 (hex) PROF-PNU 1937 (dec) IND = 17
DPV55 Objekt Nr = 738 CAN-Objekt 0x37E2 (hex) PROF-PNU 1938 (dec) IND = 17
DPV56 Objekt Nr = 739 CAN-Objekt 0x37E3 (hex) PROF-PNU 1939 (dec) IND = 17
DPV57 Objekt Nr = 740 CAN-Objekt 0x37E4 (hex) PROF-PNU 1940 (dec) IND = 17
DPV58 Objekt Nr = 741 CAN-Objekt 0x37E5 (hex) PROF-PNU 1941 (dec) IND = 17
DPV59 Objekt Nr = 742 CAN-Objekt 0x37E6 (hex) PROF-PNU 1942 (dec) IND = 17
DPV60 Objekt Nr = 743 CAN-Objekt 0x37E7 (hex) PROF-PNU 1943 (dec) IND = 17
DPV61 Objekt Nr = 744 CAN-Objekt 0x37E8 (hex) PROF-PNU 1944 (dec) IND = 17
DPV62 Objekt Nr = 745 CAN-Objekt 0x37E9 (hex) PROF-PNU 1945 (dec) IND = 17
DPV63 Objekt Nr = 746 CAN-Objekt 0x37EA (hex) PROF-PNU 1946 (dec) IND = 17
DPV64 Objekt Nr = 747 CAN-Objekt 0x37EB (hex) PROF-PNU 1947 (dec) IND = 17


ASCII English DPWM

ASCII - Command | DPWM |
Syntax Transmit | DPWM [Data] |
Syntax Receive | DPWM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3676 (hex)
DIM | - | PROFIBUS PNU | 1974 (dec) IND = 1 (dec)
Range | 0 .. 4 | DPR | 374 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.13 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | drive configuration | EEPROM | Yes
Short Description | PWM/current loop/position loop configuration

Description

The configuration parameter DPWM defines the PWM, current and position loop frequency.
Following settings are possible:

DPWM=0 PWM frequency 8 KHz, current loop 16 KHz, position loop 4 KHz
DPWM=1 PWM frequency 16 KHz, current loop 32 KHz, position loop 4 KHz (only ARM7, FW 3.xx)
DPWM=2 PWM frequency 16 KHz, current loop 16 KHz, position loop 4 KHz
DPWM=3 PWM frequency 8 KHz, current loop 16 KHz, position loop 8 KHz
DPWM=4 PWM frequency 4 KHz, current loop 16 KHz, position loop 4 KHz (since FW >= 5.39)

attention:
for DPWM = 1 or 2 (16kHz) the current is limited as follows:
IPEAK is limited to 60% of DIPEAK
for 230V devices rated current is limited to 80% of DICONT
for 400V devices rated current is limited to 60% of DICONT


ASCII English DR_TYPE

ASCII - Command | DR_TYPE |
Syntax Transmit | DR_TYPE |
Syntax Receive | DR_TYPE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 352E (hex)
DIM | - | PROFIBUS PNU | 1646 (dec) IND = 1 (dec)
Range | 1 .. 8 | DPR | 46 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Gives the Output Stage Indentification

Description

This command can be used to read the drive type.


ASCII English DREF

ASCII - Command | DREF |
Syntax Transmit | DREF [Data] |
Syntax Receive | DREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 352C (hex)
DIM | - | PROFIBUS PNU | 1644 (dec) IND = 1 (dec)
Range | 0...34 | DPR | 44 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Direction for Homing

Description

The DREF parameter can be used to define the preferred direction of motion for a homing operation and for positioning with a modulo-axes. Bits 0..3 are used for homing, Bits 4..7 for modulo-axis (POSCNFG=1). The possible combinations are shown in the table. If a homing mode with zero puls is selected DREF should be set to 2,18 or 34. See also POSCNFG
 | Homing - Direction | Modulo - Direction
DREF = 0 | negative | negative
DREF = 1 | positive | negative
DREF = 2 | shortest distance | negative
DREF =4 | negative movement without reversing | >= version 1.30 DREF =4 homing direction negativ (like DREF=0),no positive movement on reference switch or limit switch This setting is only usefull for NREF=1,3.
DREF = 5 | potitive movement without reversing | >= version 1.30 DREF =5 homing direction positive (like DREF=0),no negative movement on reference switch or limit switch This setting is only usefull for NREF=1,3.
DREF = 16 | negative | positive
DREF = 17 | positive | positive
DREF = 18 | shortest distance | positive
DREF = 32 | negative | shortest distance
DREF = 33 | positive | shortest distance
DREF = 34 | shortest distance | shortest distance


ASCII English DRIVE

ASCII - Command | DRIVE |
Syntax Transmit | DRIVE |
Syntax Receive | DRIVE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3677 (hex)
DIM | - | PROFIBUS PNU | 1975 (dec) IND = 1 (dec)
Range | 32Bit | DPR | 375 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 0.71 |
Configuration | No | Last Change of this Object | 2.11
Function Group | drive configuration | EEPROM | No
Short Description | type of the servo drive (drive family

Description

The variable DRIVE returns the type of the servo drive (drive family).

S700/S300(ARM9) only
Bit 0…7 reserved
Bit 8 = 1 230V-layout
= 0 400V-layout
Bit 9 = 1 P-layout (12A/24A)
Bit 10 = 1 ARM9 (S300)
Bit 11 = 1 support the servo pump functionality through firmware
Bit 16…31 amplifier description e.g. 712

With the parameter VER * or SDO-Objekt 0x1009 (for CAN or EtherCAT) the layout version in the format year/calendar week can be queried

layout-version older than 1007: S700/HW2.0/FW 3.xx.
layout-version higher/equal to 1007: S700/HW2.1/FW 5.xx.


ASCII English DRVCNFG

ASCII - Command | DRVCNFG |
Syntax Transmit | DRVCNFG [Data] |
Syntax Receive | DRVCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3672 (hex)
DIM | - | PROFIBUS PNU | 1970 (dec) IND = 1 (dec)
Range | long int | DPR | 370 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.13 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | drive configuration | EEPROM | Yes
Short Description | Configuration parameter for additional drive functionality

Description

The configuration parameter offers the possibility to change/correct the behaviour of the servo amplifier via setting of configuration bits. A resetted bit results in the default or old behaviour of the drive. The chosen bit combination has to be given as decimal number. Example: If bit 2 and 5 are set the number is 2^2+2^5 = 4 + 32 = 36
Bit | significance | Description
0 | 0x1 | reserved
1 | 0x2 | reserved
2 | 0x4 | reserved
3 | 0x8 | reserved
4 | 0x10 | reserved
5 | 0x20 | reserved
6 | 0x40 | reserved
7 | 0x80 | reserved
8 | 0x100 | = 1 A single turn absolute sine encoder is executed as a multi turn encoder. On power up the absolute position of the single turn absolute encoder is read and stored in PFB. Homing is not required. This setting is also used for analog hall feedbacks with setting ENCLINES = 1
9 | 0x200 | reserved
10 | 0x400 | reserved
11 | 0x800 | reserved
12 | 0x1000 | reserved
13 | 0x2000 | = 1 Configuration for following tasks: At start of the following task it's checked if the planed moving distance is smaller than the deceleration distance. In case the result is positive the deceleration ramp of the active motion task is used. = 0 The following task is always started. The braking ramp can be very fast.
14 | 0x4000 | reserved
15 | 0x8000 | = 1 Endat-position will be read only once = 0 Endat-position will be read multiple times (up to 5). THE absolute position will be taken only if value is equal every time. see also FBTYPE=4
16 | 0x1 0000 | = 1 With following tasks the acceleration ramp of it will be taken always = 0 One of the following ramps is taken: - Is the velocity of the following task greater and in the same direction, the acceleration ramp of the following task is taken - Is the velocity of the following task less and in the same direction, the braking ramp of the former task is taken - Is the velocity of the following task is in the opposite direction, the braking ramp of the first is taken and the acceleration ramp of the following task
17 | 0x2 0000 | reserved
18 | 0x4 0000 | reserved
19 | 0x8 0000 | = 1 The external position PFB0 won't be reset at end of homing = 0 The external position PFB0 will be set to ROFFS at end of homing
20 | 0x10 0000 | reserved
21 | 0x20 0000 | = 1 no checksum verification of EQI feedback = 0 checksum verification of EQI feedback activated see also FBTYPE = 4
22 | 0x40 0000 | = 1 no encoder-pulses with disabled power stage = 0 encoder-pulses also with disabled power stage
23 | 0x80 0000 | reserved
24 | 0x100 0000 | = 1 If bit 13 is set, the drive moves back to its target position = 0 No return
25 | 0x200 0000 | reserved
26 | 0x400 0000 | reserved
27 | 0x800 0000 | reserved
28 | 0x1000 0000 | reserved
29 | 0x2000 0000 | reserved
30 | 0x4000 0000 | = 1 Enhanced surveillance of SinCos amplitude. It isn't just the sum of the squares monitored but also the simple sum of the signals. Upon any breach MAXDIFFI the variable is incremented. Once MAXDIFFI exceeds MAXDIFF, a warning is generated n23. The variable MAXDIFFI is set to 0 every 8 minutes. When enabled, the value MAXDIFFI is a statement about the quality of SinCos signals.
31 | 0x8000 0000 | reserved


ASCII English DRVCNFG2

ASCII - Command | DRVCNFG2 |
Syntax Transmit | DRVCNFG2 [Data] |
Syntax Receive | DRVCNFG2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36E4 (hex)
DIM |  | PROFIBUS PNU | 1684 (dec) IND = 17 (dec)
Range | 32 Bit | DPR | 484 (dec)
Default | 268435456 (0x1000 0000) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | Yes
Short Description | Configuration parameter for additional drive functionality

Description

The variable is used to activate different additional functions of the drive.
Bit | significance | description
0 | 0x1 | reserved
1 | 0x2 | = 0 Latchfunction at digital input 1 is always activ = 1 Latchfunction at digital input has to be enabled by the controller or PLC programm with the variable ENA1P / ENA1N have a look to: IN1MODE=26
2 | 0x4 | = 0 Latchfunction at digital input 2 is always activ = 1 Latchfunction at digital input 2 has to be enabled by the controller or PLC programm with the variable ENA2P / ENA2N have al look to: IN2MODE=26
3 | - | 1 = the assumption of the current pre-control of the external slot card (DPR) is activated. 0 = not accept of the current feedforward control of the external card
4..7 | - | reserved
8 | 0x100 | = 0 ROFFSABS – value saved in the drive EEPROM is used = 1 ROFFSABS is saved to the drive an read at startup.
9..13 | - | reserved
14 | 0x4000 | = 0 all warnings without n32 and n14 are reset by CLRFAULT = 1 all warnings without n14 and n23 and n32 are reset by CLRFAULT
15 | 0x8000 | no drift, only available for OPMODE = 4 = 0 No drift function on master slave applications inactive = 1 No drift function is active Warning ! In case of emergency stop situations (harware, software limit switch or INxMODE=27 ...) reset on enabled drives the the motor can speed up automatic to maximum.
16 | 0x10000 | = 0 At the end of homing (multiturn-feedback) the ROFFSABS is calculated and saved to EEPROM. = 1 No effect to ROFFSABS at the end of homing with multiturn feedback.
17 | 0x20000 | = 0 flying change of the sine profile is set immediately = 1 forcing flying switching from sine motion tasks deceleration to 0 before following task can start
18 | 0x40000 | FW >= 2.14 = 0 scope samplerate with 250 µs (4 kHz) the actual velocity value of the observer is used for the bode plot = 1 scope samplerate with 62.5 µs (16 kHz) In case of motor encoder feedback the sine cosine signal is used direct after the differentiation for the bode plot
19 | 0x80000 | FW >=3.07 = 0 function ANCNFG=8 uses the absolut value of SW1-voltage.This -/+ 10V takes the range SRND...ERND. = 1 function ANCNFG=8 uses the value and the sign of SW1-voltage.This -/+ 10V takes the range SRND - (ERND-SRND)...ERND.
20 | 0x100000 | FW >= 3.07 = 0 Monitoring of the SENSE-voltage aktiv (In case anexternal feedback is powered via X1) = 1 Monitoring of SENSE-voltage switched off. Turning off the monitor can be useful when an encoder is supplied externally and the internal power supply is not required. have a look to: FBTYPE
21 | 0x200000 | FW >= 3.08 = 0 if at "STO disable" software-enable is set, by set of "AS-Option enable" the software-enable will be set automatically. = 1 at activate of "STO enable" the software-enable remains at 0 no matter of the status "AS-Option disable".
22 | 0x400000 | S300/S700: This function may be used only from the FW >= 3.70/5.00 = 0 no cyclical storage of the upper 32 of the 64 potion bits = 1 save the upper 32 bits of the 64 bit position in the EEPROM. This function corresponds to the function POSCNFG == 2, but can also be used without modulo functionality. Attention: Due to the cyclic storage of the position values in Flash/EEPROM, the life of the memory can be shortened. Caused by saving of the 64-position every 1024 revolutions by a rotating with 3000 rpm drive, this results a cycle time of 20 seconds. The max. Number of write cycles is in continuous operation at 3000RPM: S300 with FW 3.xx: approximately 240 days S300/S700 with FW 5.xx: approximately 8800 days Activate this function with an older firmware can damage the internal flash memory.
23 | 0x800000 | reserved
24 | 0x1000000 | FW >= 3.06 = 0 FBTYPE=23,24 by switch on the absolute BISS-Position is read in sensor-mode. = 1 bei FBTYPE=23,24 wird beim Einschalten die absolute BISS-Position im Register-Mode eingelesen Diese Einstellung kann benutzt werden, falls es Probleme beim Einlesen des BISS-Gebers geben sollte.
25 | 0x2000000 | = 0 in functions INxMODE = 43...46 the value of the compensating section is expected in INxTRIG = 1 in functions INxMODE = 43...46 the number of compensatory motion task in INxTRIG is expected.
26 | 0x4000000 | = 0 the SinCos position detection using the digital information of the hardware counter and the "analog" information from the FPGA module. = 1 the SinCos position detection using only the information from the FPGA-detection module (debug purposes).
27 | 0x8000000 | = 0 asynchron controlled motor field weakening = 1 asynchron controlled motor field weakening by voltage controller
28 | 0x10000000 |
29 | - | reserved
30 | 0x40000000 | = 0 In case of error F04 or F25 an error reset will effect a hardware-reset. = 1 Every "ERROR-Reset"-Command resets a F04 or F25 error by software. For Resolver Fault, this bit has only effect on FBTYPE = 0 setting.
31 | 0x80000000 | = 0 object chanel functions are executed by reading = 1 object chanel functions are executed by writing


ASCII English DRVCNFG3

ASCII - Command | DRVCNFG3 |
Syntax Transmit | DRVCNFG3 [Data] |
Syntax Receive | DRVCNFG3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 386F (hex)
DIM |  | PROFIBUS PNU | 1679 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 879 (dec)
Default | 24 (0x18) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.57 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | drive configuration | EEPROM | Yes
Short Description | Configuration parameter for additional drive functionality

Description

The configuration parameter DRVCNFG3 offers the possibility to change/correct the behaviour of the servo amplifier via setting of configuration bits.
Bit | significance | description
0 | 0x1 | =1 old BISS format is activated (with 24 bits/revolution). This setting should be used with BISS encoders manufactured before 5/5/2006. =0 the position format is read out from the encoder
1 | 0x2 | reserved
2 | 0x4 | 0 = reading of the digital input with 4 KHz 1 = reading of the digital input with 16 KHz
3 | 0x8 | 0 = current offset measurement starts after switch on the DC-bus voltage 1 = current offset measurement starts at power up the drive since FW 5.40
4 | 0x10 | 1 = software-reset for some "hard" faults without COLDSTART
5 | 0x20 | reserved
6 | 0x40 | 1 = by using the latch function over EtherCat the DC is used instead the position
7 | 0x80 | 1 = using of PRD for cogging table (instead of PFB)
8 | 0x100 | 1 = motion task delay until brake off can be enabled by setting this bit.
9 | 0x200 | reserved
10 | 0x400 | reserved
11 | 0x800 | reserved
12 | 0x1000 | reserved
13 | 0x2000 | reserved
14 | 0x4000 | 1 = motion task start in 4 KHz routine
15 | 0x8000 | reserved
16 | 0x10000 | 1 = EtherCat XML Version 2 (motion tasks, free mapping)
17 | 0x20000 | 1 = Sercos: command break acknowledged by STAT=1
18 | 0x40000 | 1 = 6083/6084 only for position tasks
19 | 0x80000 | 1 = temeparture depending increase (10%) of rated current
20 | 0x100000 | 1 = position set point via ROD output
21 | 0x200000 | 1 = S300 no ROD-supervision
22 | 0x400000 | 0 = no analysis of INPOS-window by switch of the OPMODE's 1 = analysis of INPOS-window by switch to OPMODE=4 (jump of position is possible)
23 | 0x800000 | 1 = torque setpoint via object 6071 is taken directly, not in 1 ms task
24 | 0x1000000 | 1 = switches off the weakening operation (available since FW 5.17 and 3.80)
25 | 0x2000000 | 1 = by switch to OPMODE = 4 (Master/Slave)the internal velocity set point VCMD is not set to 0. (avalible since FW 5.17 and 3.80)
26 | 0x4000000 | 1 = activates a ramp correction for the table motion task stop procedure (until now active only for trapeze motion tasks). This ensures that the target position of the motion task cannot be exceeded when the motion task has been cancelled
27 | 0x8000000 | 1 = no automatic reset of the encoder-warning
28 | 0x100000000 | 1 = Activate encoder emulation output based on external encoder (PFB0)
29 | 0x200000000 | reserved
30 | 0x400000000 | 1 = Activate cyclic EtherCAT commands with power stage disabled
31 | 0x800000000 | 1 = Allow 90° phase shift (instead of 45°) for field weakening


ASCII English DRVCNFG4

ASCII - Command | DRVCNFG4 |
Syntax Transmit | DRVCNFG4 [Data] |
Syntax Receive | DRVCNFG4 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38CE (hex)
DIM |  | PROFIBUS PNU | 1774 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 974 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.40 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | Yes
Short Description | Configuration parameter for additional drive functionality

Description

The configuration parameter DRVCNFG4 offers the possibility to change/correct the behaviour of the servo amplifier via setting of configuration bits.
Bit | value | description
0 | 0x1 | 1 = no reverse to the base position at wake&shake
1 | 0x2 | 1 = switch off the corrected calculation of PVMAX for SERCOS. The "old" calculation only works if PGEARI = 2^PRBASE, the new calculation solves this problem. When there is compatibility problems, this can be reversed through setting the bit.
2 | 0x4 | 1 = Enable the automatic reset for the SinCos module in the FPGA. By very disturbed SinCos signals, it may cause problems in the position detection. If this bit is set, the FPGA position is monitored by the help of the hardware counter. If required, the FPGA module is reset.
3 | 0x8 | 1 = monitoring by the software of the output stage fault F14. If this monitoring is active, F14 will be reported befor the hardware monitoring indicates this fault. This is a protection of the drive if the value of the current loop is worthly wrong! see also ERRCODE *
4 | 0x10 | reserved
5 | 0x20 | no monitoring of feedback fault F04 by using a digital encoder (ENDAT2.2 or BISS-C) for the second feedback
6 | 0x40 | 1 = no raise of the threshold at high regen power. To keep the regen in the DC-bus connection evenly, the threshold is increased with increasing power. This causes the regen resistor to be switched on after a delay. For drives that are not connected with the DC link, this effect can be undesirable.
7 | 0x80 | 1 = CAN/EtherCAT: the output stage is not enabled in the DS402 status "Switched On".
8 | 0x100 | 1 = EtherCAT state "Operation Enable" is only reported when the command values are accepted. This state isn't reported when the power stage is enabled (message only after the settling time has expired for the power stage).
9 | 0x200 | 1 = instead of using the zero crossing of the external feedback, the zero crossing of theprimary feedback (resolver) is used at the homing.
10 | 0x400 | 1 = no reset of the integral component of velocity controll loop if stage is inhibited. This setting can be useful to minimize slippage of suspended loads when brake control.
11 | 0x800 | 1 = improved calculation of the actual value of the speed in "hall-only mode". This function is currently not active by default (for compatibility reasons) but should be used with the new "hall-only" -applications.
12 | 0x1000 | 1 = "flying synchronization" with a rotating motor. In the initialization phase/releasing the final stage of the speed controller is synchronized to the current speed of the motor. This means that once the velocity setpoint is set to the actual value of velocity in releasing the final stage. As long as no new setpoint has been received (e.g. fieldbus, analogue or RS232) the velocity is constant. Caution: If the function is active, it can lead to drifting of the motorshaft.
13 | 0x2000 | 1 = X1 initialization for SSI reading. This function is only useful in conjunction with a macro program, if the SSI interface is to be read in the macro program without appropriate FBTYPE/GEARMODE/EXTPOS settings.
14 | 0x4000 | 1 = X5 initialization for SSI reading. This function is only useful in conjunction with a macro program, if the SSI interface is to be read in the macro program without appropriate FBTYPE/GEARMODE/EXTPOS settings.
15....31 | - | reserved


ASCII English DRVSTAT

ASCII - Command | DRVSTAT |
Syntax Transmit | DRVSTAT |
Syntax Receive | DRVSTAT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 352D (hex)
DIM | - | PROFIBUS PNU | 1645 (dec) IND = 1 (dec)
Range | 0 .. 0xFFFFFFFF | DPR | 45 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | internal Status information

Description

The DRVSTAT command returns the internal status information in the form of a bit-variable.
Bit/Display/Level | Bit combination | Description
1 / n02 / 0 | 0x00000002 | =1 Regen message. Is high, if the actual regen power exceeds the adjusted threshold PBALMAX, otherwise low.
2 / n03 / 1 | 0x00000004 | =1 following error. Is set, if the distance between the actual position and the target position of the trajectory generator is greater than the contouring error window PEMAX. Is cleared by the command CLRFAULT or by an digital input with INxMODE=14. Note: Running the position modes (OPMODE = 4 or 8) a position following error will cause "n03".
3 / n04 / 1 | 0x00000008 | =1 Node guarding (watch dog). Is set, if the Bus (PROFIBUS or CAN) or the Slotcard has no communication to the master for the adjusted time EXTWD. Is cleared by the command CLRFAULT or by an digital input with INxMODE=14.
4 / n05 / 0 | 0x00000010 | =1 Line phase missing. Is high, if one or all of the three input line phase are lost, otherwise low.
5 / n06 / 1 | 0x00000020 | =1 Software limit switch 1 (SWE1) underrun. Is set if: - the position is lower than SWE1 - a motion task is started which has a target position lower than SWE1. At the same time the bit "faulty motion task" is set. the bit is cleared if: - the actual position overruns SWE1 and a positive velocity is given - a motion task is started which has a target position greater than SWE1.
6 / n07 / 1 | 0x00000040 | =1 Software limit switch 2 (SWE2) overrun. Is set if: - the position is higher than SWE2 - a motion task is started which has a target position higher than SWE2. At the same time the bit "faulty motion task" is set. the bit is cleared if: - the actual position underruns SWE2 and a negative velocity is given - a motion task is started which has a target position smaller than SWE2.
7 / n08 / 0 | 0x00000080 | =1 Faulty motion task was started Is set, if a faulty motion task (wrong checksum) is started. Is cleared, if a valid motion task is started.
8 / n09 / 0 | 0x00000100 | =1 No reference point. Is set, is a motion task is started without starting a refernce move before. Is cleared, if a refernce move is started.
9 / n10 / 1 | 0x00000200 | = 1 PSTOP active. Is high, if the hardware limit switch PSTOP is active, otherwise low.
10 / n11 / 1 | 0x00000400 | = 1 NSTOP active. Is high, if the hardware limit switch NSTOP is active, otherwise low.
11 / n12 / 0 | 0x00000800 | =1 Default motor data loaded. Is set, if the motor number stored in the EEPROM of the drive is not the same as the motor number stored in the feedback system (EnDAT or Hiperface). By saving the drive parameter (SAVE) and restart the drive, the warning disappears.
12 / n13 / 1 | 0x00001000 | =1 Slot warning (I/-expansion board). Is high, if the external 24V supply of the I/O expansion board is missing, otherwise low.
13 / n14 / 0 | 0x00002000 | =1 Scanning for MPHASE (FBTYPE=7) Is set while start-up of the drive and is cleared after the drive was enabled and MPHASE was determined.
14 / n15 / 0 | 0x00004000 | reserved
15 / n16 / 0 | 0x00008000 | Is active, if one or more of the warnings n17...n31 are active.
16 | 0x00010000 | =1 Motion task active. Is set, if a motion task is started (motion task, jog or homing move). Is cleared, if the action is finished or a STOP - command is executed.
17 | 0x00020000 | =1 Reference point is set. Is set, if the homing move was done or a absolute encoder feedback device is used. Is cleared if a homing move is started.
18 | 0x00040000 | =1 Home switch. Is high, if the homing switch is closed, otherwise low.
19 | 0x00080000 | =1 In-Position. Is high, if the distance between the target position and the actual position is smaller than PEINPOS, otherwise low. When several motion tasks are tied together, only the last motion task enables this bit.
20 | 0x00100000 | =1 Position latch occurred (positive edge). Is set, if a positive edge at the latch input (Input2 with IN2MODE=26) was detected. Is cleared, if the lachted position was read (example: LATCH1N16/ LATCH1N32).
21 | 0x00200000 | reserved
22 | 0x00400000 | reserved
23 | 0x00800000 | reserved
24 | 0x01000000 | reserved
25 | 0x02000000 | reserved
26 | 0x04000000 | =1 Initialization phase finished. Is set, if the initialization phase of the drive is finished (takes about 15s).
27 | 0x08000000 | reserved
28 | 0x10000000 | =1 Motor stand still message. Is high, if the actual motor velocity is lower than the threshold VEL0, otherwise low.
29 | 0x20000000 | =1 Safety relais selected. Is high, if the safety relay of the option -AS- is switched on, otherwise low.
30 | 0x40000000 | = Output stage enabled. Is high, if the soft- and the hardware enable is present, otherwise low.
31 | 0x80000000 | =1 Drive has an error state. Is set, if the drive has a fault (output stage is disabled, error number is displayed). The command ERRCODE gives the error in plain text. The bit is cleared, if the drive is reset or the command CLRFAULT is send


ASCII English DRVSTAT2

ASCII - Command | DRVSTAT2 |
Syntax Transmit | DRVSTAT2 [Data] |
Syntax Receive | DRVSTAT2 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | - | CANBus Object Number | 375B (hex)
DIM | - | PROFIBUS PNU | 1803 (dec) IND = 17 (dec)
Range | - | DPR | 603 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 1.3
Function Group | actual values | EEPROM | No
Short Description | internal status information

Description

The ASCII parameter DRVSTAT2 extends the parameter DRVSTAT and returns the internal status information in the form of a bit-variable
Bit | significance | description
0 | 0x00000001 | result of the VINPOS function As long as the difference between the last target velocity VCMD and the actual velocity V is within the width of the velocity In-Position window VINPOS, a 1 is signalled, otherwise a 0. The signal change is not signaled before the new state was valid at least INPT0 msec.
1 | 0x00000002 | =1 slave synchronised to the master This function is only available for following settings: INxMODE=42,43,51,53 or ENGAGE>0


ASCII English DUMP

ASCII - Command | DUMP |
Syntax Transmit | DUMP |
Syntax Receive | DUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | List All EEPROM Variables with Values

Description

This command produces a list of all the parameters that can be stored in the EEPROM, together with their present values. All the amplifier-specific parameters (e.g. A/D-offset values) start with a “;”(semicolon).


ASCII English DUMPEMAP

ASCII - Command | DUMPEMAP |
Syntax Transmit | DUMPEMAP [Data] |
Syntax Receive | DUMPEMAP <Data> | Available in |
Type | -- | MMI | No
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 5.17 |
Configuration | No | Last Change of this Object | 2.4
Function Group | Fieldbus | EEPROM | No
Short Description | Control of the free mapping of EtherCat

Description

With this paramter the free EtherCat mapping can be checked

DUMPEMAP dump of the actual free mapping
DUMPEMAP * dump of all parameter which can used for the free mapping

For the free mapping totaly 64 byte can be used. The maximal number of mapped objects is 16 fast (250 µsec) + 16 slow (1 msec) per transmition direction.

S700: FW 5.17


ASCII English DUMPSLNO

ASCII - Command | DUMPSLNO |
Syntax Transmit | DUMPSLNO [Data] |
Syntax Receive | DUMPSLNO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 35FA (hex)
DIM |  | PROFIBUS PNU | 1850 (dec) IND = 1 (dec)
Range | write 0 read 0 ... Integer16 | DPR | 250 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | other commands | EEPROM | No
Short Description | Listing of the numerical EEProm-parameters

Description

With the command DUMPSLNO a list of the object numbers which are stored in the EEProm can be fetched step by step. The parameters are ordered the same way as in the parameter files stored by the GUI, the priorities of parameters are considered.

With “DUMPSLNO 0” the list can be resetted.

The command can be used to get all relevant for storing and restoring a parameter list of the drive.

Example:

-->DUMPSLNO

343 ; FW command

-->DUMPSLNO

194 ; PBALRES command

-->DUMPSLNO

209 ; PRBASE command

At the end of this lsit a 0 is reported.


ASCII English ECATCSA

ASCII - Command | ECATCSA |
Syntax Transmit | ECATCSA [Data] |
Syntax Receive | ECATCSA <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 65535 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.65 |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | fieldbus | EEPROM | Yes
Short Description | holds the Configured Station Alias address

Description

The parameter ECATCSA holds the configured station alias address of the EtherCAT filedbus.


ASCII English EGEARI

ASCII - Command | EGEARI |
Syntax Transmit | EGEARI [Data] |
Syntax Receive | EGEARI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 350D (hex)
DIM | - | PROFIBUS PNU | 1613 (dec) IND = 1 (dec)
Range | 1 ... long Integer | DPR | 13 (dec)
Default | 1 |
Opmode | 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | Disable | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Ratio external feedback

Description

In case an external feedback system is used the ratio can be set by EGEARI and EGEARO. The feedbackturn are set by EGEARI the motor turn by EGEARO

This setting affects only to generation of command velocity.
It has no effect on the emulated respectively acquired position (ROD/SSI).


ASCII English EGEARO

ASCII - Command | EGEARO |
Syntax Transmit | EGEARO [Data] |
Syntax Receive | EGEARO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 350E (hex)
DIM | - | PROFIBUS PNU | 1614 (dec) IND = 1 (dec)
Range | 0 ... Long Integer | DPR | 14 (dec)
Default | 1 |
Opmode | 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | Disable | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Ratio external feedback

Description

In case an external feedback system is used the ratio can be set by EGEARI and EGEARO. The feedbackturn are set by EGEARI the motor turn by EGEARO

This setting affects only to generation of command velocity.
It has no effect on the emulated respectively acquired position (ROD/SSI).


ASCII English EMRGTO

ASCII - Command | EMRGTO |
Syntax Transmit | EMRGTO [Data] |
Syntax Receive | EMRGTO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36DC (hex)
DIM | - | PROFIBUS PNU | 1676 (dec) IND = 17 (dec)
Range | 0 ... 2147483647 | DPR | 476 (dec)
Default | 5000 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | defines the emergency time out

Description

EMRGTO defines the emergency time out for the ACTFAULT=1 and STOPMODE=1 operations.

After the ACTFAULT (drive error) or STOPMODE (power stage enable) conditions the drive tries
To reduce the velocity to zero. If this fails, the power stage will be disable after the EMRGTO time at the latest.
F 30 is reported.

EMRGTO = 0 then the F30 function is switched off.

New since FW 0.80:

If in 0.25 of EMRGTO time the velocity is not decrease by 0.125 the drive create an F30. This is because the default of 5 seconds could be very long if for what ever reason no speed deceleration is done.

EMRGTO can be set to 0 or values >= 10


ASCII English EN

ASCII - Command | EN |
Syntax Transmit | EN |
Syntax Receive | EN | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3530 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 1 (dec)
Range | - | DPR | 48 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Software-Enable

Description

The EN command sets the software enable for the output stage.
If the software enable and the hardware enable are set and no fault is present (the BTB contact is closed), then the output stage is enabled.
If the MAINS BTB function is activated (OxMODE=3), then the output stage will only be enabled when the supply power has been switched on and the charging circuit has charged up the DC bus. If the supply power is removed from an enabled instrument, then it remains enabled until the DC bus voltage has fallen below the undervoltage limit (VBUSMIN).


ASCII English EN22A1CNT

ASCII - Command | EN22A1CNT |
Syntax Transmit | EN22A1CNT |
Syntax Receive | EN22A1CNT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 390D (hex)
DIM | - | PROFIBUS PNU | 1837 (dec) IND = 33 (dec)
Range | 0 .. 65535 | DPR | 1037 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 status of additional information 1

Description

This parameter is a bit variable. When the bit is set, the associated additional information 1 is available. If the bit isn't, the corresponding information is not supported by the ENDAT2.2 encoder.

The individual bits are assigned the following information:

Bit 0 position value 2
Bit 1 - test value
Bit 2 - Temperature sensor 1 (external)
Bit 3 - Temperature sensor 2 (on board)
Bit 4 - additional sensors
Bit 5 ... 15 free


ASCII English EN22A2CNT

ASCII - Command | EN22A2CNT |
Syntax Transmit | EN22A2CNT |
Syntax Receive | EN22A2CNT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 390E (hex)
DIM | - | PROFIBUS PNU | 1838 (dec) IND = 33 (dec)
Range | 0 .. 65535 | DPR | 1038 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 Status of additional information 2

Description

This parameter is a bit variable. When the bit is set, the associated additional information 2 is available. If the bit isn't set, the corresponding information is not supported by the ENDAT2.2 encoder.

The individual bits are assigned the following information:

Bit 0 - commutation
Bit 1 - Acceleration
Bit 2 - limit signal
Bit 3 - asynchronous position value
Bit 4 - Operating status error sources
Bit 5 - reserved
Bit 6 - Position value 2
Bit 7 - Time stamp
Bit 8 ... 15 is free


ASCII English EN22AI1

ASCII - Command | EN22AI1 |
Syntax Transmit | EN22AI1 |
Syntax Receive | EN22AI1 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | 16 x Integer16 | CANBus Object Number | 2055 (hex)
DIM | - | PROFIBUS PNU | -
Range | 0 .. 65535 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | 16 x Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 act. values of additional information 1

Description

The command EN22AI1 provides 16 numbers (separated by <space>) which are assigned to the 16 additional information 1. The value 0 is transferred for the additional information which is not supported by the encoder. With the help of the parameter EN22A1CNT, the valid additional information can be extracted.

from FW>= 6.05, this parameter can be querried with SDO object no. throught CAN/EtherCAT.


ASCII English EN22AI2

ASCII - Command | EN22AI2 |
Syntax Transmit | EN22AI2 |
Syntax Receive | EN22AI2 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | 16 x Integer16 | CANBus Object Number | 2056 (hex)
DIM | - | PROFIBUS PNU | -
Range | 0 .. 65535 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | 16 x Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 act. values of additional information 2

Description

The command EN22AI2 provides 16 numbers (separated by <space>) which are assigned to the 16 additional information 2. The value 0 is transferred for the additional information which is not supported by the encoder. With the help of the parameter EN22A2CNT, the valid additional information can be extracted.

from FW>= 6.05, this parameter can be querried with SDO object no. throught CAN/EtherCAT.


ASCII English EN22CNFG

ASCII - Command | EN22CNFG |
Syntax Transmit | EN22CNFG [Data] |
Syntax Receive | EN22CNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 390F (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 33 (dec)
Range | 0 .. 3 | DPR | 1039 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.91 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | Yes
Short Description | Config.parameter for ENDAT 2.2 additional information

Description

This parameter is a bit variable. Setting a bit activates the reading of the corresponding ENDAT2.2 additional information.

Bit 0 = 1 Reading in the diagnostic information (evaluation values)
Bit 1 = 1 Reading the additional information 1
Bit 2 = 1 Reading the additional information 2

Setting a bit to 0 inhibits the reading of the associated additional information


ASCII English EN22DCNT

ASCII - Command | EN22DCNT |
Syntax Transmit | EN22DCNT |
Syntax Receive | EN22DCNT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3910 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 33 (dec)
Range | 0 .. 65535 | DPR | 1040 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 status of the diagnostic information

Description

This parameter is a bit variable. If the bit is set, the associated diagnostic information is available. If the bit isn't set, the corresponding information is not supported by the ENDAT2.2 encoder.

The individual bits are assigned the following information:

Bit 0 - Evaluation number 1
Bit 1 - Evaluation number 2
Bit 2 - Evaluation number 3
Bit 3 - Rating number 4
Bit 4 - Evaluation number 5
Bit 5 - Evaluation number 6
Bit 6 ... 14 is free
Bit 15 - system specific data


ASCII English EN22DIAG

ASCII - Command | EN22DIAG |
Syntax Transmit | EN22DIAG |
Syntax Receive | EN22DIAG <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | 16 x Integer16 | CANBus Object Number | 2054 (hex)
DIM | - | PROFIBUS PNU | -
Range | 0 .. 65535 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | 16 x Integer16
Drive State | - | Weighting |
Start Firmware | 5.91 |
Configuration | No | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | No
Short Description | Endat 2.2 actual values of the diagnostic information

Description

The EN22DIAG command provides 16 numbers (separated by <space>) that are assigned to the 16 diagnostic information. The value 0 is transferred for the diagnostic information which is not supported by the encoder. Using the parameter EN32DCNT, the valid diagnostic values can be extracted.

from FW>= 6.05, this parameter can be querried with SDO object no. throught CAN/EtherCAT.


ASCII English ENCDIV

ASCII - Command | ENCDIV |
Syntax Transmit | ENCDIV [Data] |
Syntax Receive | ENCDIV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 38D6 (hex)
DIM |  | PROFIBUS PNU | 1782 (dec) IND = 33 (dec)
Range |  | DPR | 982 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.87 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | Yes
Short Description | Divisor for the decimal places of ENCLINES

Description

Parameter ENCFIX/ENCDIV define the decimal places for the parameter ENCLINES.
Thus the linear motors are supported, which have no integer number of sinus priods cycles per polpitch. The decimal places are defined as a divisor / dividend.

Example 1: 2048.45 periods per polpitch, following settings are necessary:
ENCLINES 2048
ENCFIX 45
ENCDIV 100

Example 2: 1000.33333 (3) periods per polpitch, following settings are necessary:
ENCLINES 1000
ENCFIX 1
ENCDIV 3


ASCII English ENCDIVD

ASCII - Command | ENCDIVD |
Syntax Transmit | ENCDIVD [Data] |
Syntax Receive | ENCDIVD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3909 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 33 (dec)
Range | 1 ... 2147483647 | DPR | 1033 (dec)
Default | 100000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.87 |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | feedback | EEPROM | Yes
Short Description | Divisor for the decimal places of ENCIN

Description

The parameter ENCFIXD/ENCDIVD define the decimal places for the parameter ENCLINES. Thus supported linear motors, which have no integer number of sinus cycles per polpitch.

The decimal places are defined as a divisor/dividend.

Example 1: following settings are necessary for 2048.45 periods per polpitch
ENCIN 2048
ENCFIXD 45
ENCDIVD 100

Example 2: following settings are necessary for 1000.33333(3) periods per polpitch
ENCIN 1000
ENCFIXD 1
ENCDIVD 3


ASCII English ENCFIX

ASCII - Command | ENCFIX |
Syntax Transmit | ENCFIX [Data] |
Syntax Receive | ENCFIX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 38D3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 33 (dec)
Range | 0 .. 2147483647 | DPR | 979 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.86 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | Yes
Short Description | Decimal places for the ENCLINES parameter

Description

The parameter ENCFIX/ENCDIVD define the decimal places for the parameter ENCLINES. Thus supported linear motors, which have no integer number of sinus cycles per polpitch.

The decimal places are defined as a divisor/dividend.

Example 1: following settings are necessary for 2048.45 periods per polpitch
ENCLINES 2048
ENCFIX 45
ENCDIV 100

Example 2: following settings are necessary for 1000.33333(3) periods per polpitch
ENCLINES 1000
ENCFIX 1
ENCDIV 3


ASCII English ENCFIXD

ASCII - Command | ENCFIXD |
Syntax Transmit | ENCFIX [Data] |
Syntax Receive | ENCFIXD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 390A (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 33 (dec)
Range | 0 .. 2147483647 | DPR | 1034 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.86 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | Yes
Short Description | Decimal places for the ENCIN parameter

Description

The parameter ENCFIX/ENCDIVD define the decimal places for the parameter ENCIN. Thus supported linear motors, which have no integer number of sinus cycles per polpitch.

The decimal places are defined as a divisor/dividend.

Example 1: following settings are necessary for 2048.45 periods per polpitch
ENCLINES 2048
ENCFIXD 45
ENCDIVD 100

Example 2: following settings are necessary for 1000.33333(3) periods per polpitch
ENCLINES 1000
ENCFIXD 1
ENCDIVD 3


ASCII English ENCIN

ASCII - Command | ENCIN |
Syntax Transmit | ENCIN [Data] |
Syntax Receive | ENCIN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3532 (hex)
DIM | - | PROFIBUS PNU | 1650 (dec) IND = 1 (dec)
Range | 16 ... 8388608 | DPR | 50 (dec)
Default | 1024 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 0.87 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | digital feedback resolution

Description

ENCIN sets the resolution (number of square pulses) of the encoder input channel using a digital encoder as feedback unit. In case of Rotary Motors it is the number of pulses per revolution, in case of linear Motors it is the number of pulses per pole pitch.

This parameter is used for following feedback settings: EXTPOS = 1…4 or FBTYPE =12…19

FW >= 2.17
Max. ENCIN value = 8 388 608


ASCII English ENCLINES

ASCII - Command | ENCLINES |
Syntax Transmit | ENCLINES [Data] |
Syntax Receive | ENCLINES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer24 | CANBus Object Number | 3533 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 1 (dec)
Range | 65535 | DPR | 51 (dec)
Default | 1000 |
Opmode | All | Data Type Bus/DPR | Integer24
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | SinCos Encoder Resolution

Description

ENCLINES sets the resolution (number of lines) of the sine encoder input channel .. In case of rotary Motors it is the number of lines per revolution, in case of linear motors it is the number of lines per pole pitch. The ENCLINES data is stored in an ENDAT or Hiperface Encoder if this feedback is used. In this case during power up process the ENCLINES data is read automatically .

Example to the ENCLINES setting on a linear motor >>> 1

In case an external feedbacksystem is used for the position loop ENCLINES has to correspond with this measurement system.

ENCLINES are not saved into EnDat-Linearfeedbacks and they are also not set automatic.


ASCII English ENCMODE

ASCII - Command | ENCMODE |
Syntax Transmit | ENCMODE [Data] |
Syntax Receive | ENCMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3534 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 1 (dec)
Range | 0..13 | DPR | 52 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.3
Function Group | encoder emulation | EEPROM | Yes
Short Description | Selection of Encoder Emulation

Description

Status | interface | description
ENCMODE=0 | X5 - (input) | Encoder Emulation swiched off - X5 is used like as input
ENCMODE=1 | X5 - ROD (output) | EEO digital encoder output (RS422) output resolutions = ENCOUT per motor revolution (rotary motor). output resolutions = ENCOUT per motor pole pitch (linear motor).
ENCMODE=2 | X5 - SSI (output) | SSI output also used for SSI input see also GEARMODE = 7 SSIREVOL
ENCMODE=3 | X5 - ROD (output) | EEO digital encoder interpolation mode This mode is available with high resolution sincos feedback device . output resolutions = ENCOUT * ENCLINES lines per motor rev. (rotary motor). output resolutions = ENCOUT * ENCLINES per motor pole pitch (linear motor). Following settings are possible: 4,8,16,32,64,128
ENCMODE=4 | X5 - SSI (output) | Output of the command value of the position loop over SSI interface. The position is issued in 16/16 format (16 Bit/revolution + 16 Bit for number of revolution). see also SSIREVOL
ENCMODE=5 | X5 - SSI (output) | Output of the actual value of the position loop over SSI interface. The position is issued in 16/16 format (16 Bit/revolution + 16 Bit for number of revolution).
ENCMODE=6 | - | reserved
ENCMODE=7 | - | reserved
ENCMODE=8 | - | reserved
ENCMODE=9 | X1 - ROD (output) | ROD-output X1 (Emulation) like ENCMODE=1
ENCMODE=10 | X1 - SSI (output) | SSI-output X1 (Emulation) like ENCMODE=2 see also SSIREVOL
ENCMODE=11 | - | -
ENCMODE=12 | X1 - SSI (output) | SSI-output 32Bit-Position command like ENCMODE=4 see also SSIREVOL
ENCMODE=13 | X1 - SSI (output) | SSI-output 32Bit-actual-position like ENCMODE=5 see also SSIREVOL


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Encoder Emulation

With S700 this function is available only if the expansion card "PosI/O" or "PosI/O-Monitor" is installed.

Incremental Encoder (ROD, A QUAD B)

einheiten

Select the encoder emulation (position output, A quad B in the sample).

Screen text | ASCII parameter
Encoder Emulation | ENCMODE
Resolution | ENCOUT
Zero Pulse Offset | ENCZERO

Absolute Position Encoder (SSI)

einheiten1

Select the encoder emulation (position output, SSI in the sample).

Screen text | ASCII parameter
Encoder Emulation | ENCMODE
Transmit Timeout SSI | SSITOUT
No. of Bits (Multi / Single Turn) | SSIREVOL
SSI Code | SSIGRAY


ASCII English ENCOUT

ASCII - Command | ENCOUT |
Syntax Transmit | ENCOUT [Data] |
Syntax Receive | ENCOUT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3535 (hex)
DIM | CPR | PROFIBUS PNU | 1653 (dec) IND = 1 (dec)
Range | -524288 ... +524288 | DPR | 53 (dec)
Default | 1024 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | encoder emulation | EEPROM | Yes
Short Description | Resolution Encoder Emulation (ROD)

Description

The resolution of the digital encoder output emulation (ROD)

ENCOUT defines the number of lines that are given out by the EEO (digital encoder) interfacer for one turn of a rotary motor or one pole pitch for a linear motor. The output of the following ENCMODE values are generated by the FPGA: 32, 64, 128, 256, 512, 1024, 2048, 4096 - All other values are generated by the firmware. Starting with firmware 4.94 all integer numbers between 256 and 4096 are also available (256,257....... 4095,4096).

Note: The output from the FPGA is more accurate than the output from firmware. The range of values from the FPGA should be preferred to all other permissible numbers.

FW >= version 0.87 negative values are possible.
Negative values are used to invert the output direction.

If multispeed resolver are used there is more than one zero pulse within 360° . There is a zero pulse to each resolver pole pair. Example. 6 pole resolver >> 3 zero pulses

If multispeed resolver are used there is more than one zero pulse within 360° . There is a zero pulse to each resolver pole pair. Example. 6 pole resolver >> 3 zero pulses

The zero pulse is only to resolutions of 4096 counts output.

See REFMODE and ENCMODE for information.


ASCII English ENCTO

ASCII - Command | ENCTO |
Syntax Transmit | ENCTO [Data] |
Syntax Receive | ENCTO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3543 (hex)
DIM | ms | PROFIBUS PNU | 1667 (dec) IND = 1 (dec)
Range | 100 .. 12000 | DPR | 67 (dec)
Default | 2000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 0.73 |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Encoder supply delay

Description

This parameter defines the time between the “encoder power supply on” and the reading of the encoder parameter channel.


ASCII English ENCVON

ASCII - Command | ENCVON |
Syntax Transmit | ENCVON [Data] |
Syntax Receive | ENCVON <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 3546 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 1 (dec)
Range | 0 ... 2 | DPR | 70 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 0.73 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | -
Short Description | power supply for the external encoder (connector X1

Description

The command ENCVON switches the power supply for the external encoder on/off (connector X1).ENCVON=1 means 5V power supply, ENCVON=2 have to be used for 12V power supply.These settings can only be used when no external encoder was configured (ENDAT or HIPERFACE with FBTYPE/GEARMODE/EXTPOS). In case of encoder configuration the power supply required by this encoder has a higher priority as the setting ENCVON. The setting ENCVON=2 (12V power supply) is only possible when the SENSE wire was not recognized.


ASCII English ENCZERO

ASCII - Command | ENCZERO |
Syntax Transmit | ENCZERO [Data] |
Syntax Receive | ENCZERO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3537 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 1 (dec)
Range | 0 .. ENCOUT-1 | DPR | 55 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | encoder emulation | EEPROM | Yes
Short Description | Zero Pulse Offset EEO (ROD)

Description

The ENCZERO command can be used to shift the output of the encoder emulation digital encoder zero pulse over the range of one turn. The shift is made in the clockwise direction, e.g.
ENCOUT 1024
ENCZERO 256
The zero pulse is given out at the 90° position.

This is also effective for SSI outputs.


ASCII English ENGAGE

ASCII - Command | ENGAGE |
Syntax Transmit | ENGAGE [Data] |
Syntax Receive | ENGAGE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36CD (hex)
DIM |  | PROFIBUS PNU | 1653 (dec) IND = 17 (dec)
Range | 0...8 | DPR | 461 (dec)
Default | 0 |
Opmode | 4 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.38 |
Configuration | Yes | Last Change of this Object | 1.9
Function Group | drive configuration | EEPROM | Yes
Short Description | Master -slave switch on / off

Description

The ENGAGE command is used to switch the master - slave mode on or off (synchronise)

ENGAGE= 0 Master/Slave-mode active in case of OPMODE=4

ENGAGE= 1 Master/Slave-mode active in case of OPMODE=4 and given synchronisation command ENGEDGE.

After drive switch on and ENGAGE=1 the master - slave-mode is inactive (ENGEDGE=0). To start the master - slave-mode the internal variable ENGEDGE has to be set via field bus, internal plc- program or command M ENGEDGE.

ENGEDGE can be set to different modes:

ENGEDGE = 0 No synchronisation,
Master/Slave inactive, Slave will fix the actual position

ENGEDGE = 1 Synchronisation via velocity.
The slave accelerates to the master velocity via ramp ACCR. If the master speed is reached ENGEDGE is set to 5 (running sync to master). The following error is without effect to ENGEDGE). This function is activated also by a going edge on for example digital input 3 with setting IN3MODE =42.

ENGEDGE = 2 Declutch
The slave decelerates via DECR. If the slave is standing still ENGEDGE is set to 0. This function is activated also by a falling edge on for example digital input3 with setting IN3MODE =42, 43 or 51.

ENGEDGE = 3 1 Synchronisation via velocity.
The master position is latched within the synchronisation start. The slave accelerates to the master velocity via ramp ACCR and eliminates the position difference. When the master speed is reached, ENGEDGE is set to 4 (position compensation) and by raising the setpoint the position difference is cancelled. If this procedure is finished ENGEDGE is set to 5. This function is activated also, if a going edge is for example at digital input 3 with configuration IN3MODE = 43.

ENGEDGE = 4 see ENGEDGE=3

ENGEDGE = 5 see ENGEDGE=1

ENGEDGE = 6 synchronisation via position with constant acceleration (linear).
The slave speeds up to the master velocity within a defined distance, that is given in variable M IN51MERK. It relates to the slave distance and is defined in counts (20 bit/turn => 2^20). After master position and speed are reached, ENGEDGE is set to 5 (running sync to master). This function can also be executed by a going edge on for example digital input 3 and configuration IN3MODE =51.

ENGEDGE = 7 synchronisation via position with customer defined profile.
The slave speeds up to the master velocity within a defined distance, that is given in variable M IN51MERK. It relates to the slave distance and is defined in counts (20 bit/turn => 2^20). The synchronisation profile is fixed within the first lookup-table (sinus2 in case of standard-table). Nachdem die Position und Geschwindigkeit des Masters erreicht wurden, wird ENGEDGE automatisch auf 5 gesetzt (Fahren synchron zum Master). This function can also be executed by a going edge on for example digital input 3 and configuration IN3MODE =53.

ENGEDGE = 8…11 reserved

ENGEDGE = 12 declutching, the slave slows down via a customer given profile.
The synchronisation profile is fixed within the first lookup-table (sinus2 in case of standard-table).

If standstill is reached, ENGEDGE is set to 0 (standstill at slave).
This function can also be executed by a going edge on for example digital input 3 and configuration IN3MODE =53


ASCII English ERESMASK

ASCII - Command | ERESMASK |
Syntax Transmit | ERESMASK [Data] |
Syntax Receive | ERESMASK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3755 (hex)
DIM | - | PROFIBUS PNU | 1797 (dec) IND = 17 (dec)
Range |  | DPR | 597 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 0.86 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Failure reset setting

Description

The command ERESMASK describes the kind of fault reset for error messages Fxx.If the bit xx of ERESMASK is set to 1, the fault reset of the corresponding error Fxx+1 causes a hardware reset of the drive (bit=0 means a software reset of the error).
See also ERRCODE


ASCII English ERND

ASCII - Command | ERND |
Syntax Transmit | ERND [Data] |
Syntax Receive | ERND <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3638 (hex)
DIM | - | PROFIBUS PNU | 1912 (dec) IND = 1 (dec)
Range | - | DPR | 312 (dec)
Default | 2^31-1 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | End position of modulo axes

Description

The ERND parameter is used to define the end of the range of movement for a modulo axes (POSCNFG=2). The start of the range can be set by the SRND command. All positioning operations are made in the positioning range <SRND...ERND-1>.
The entry for ERND is made in SI units (taking account of PGEARI, PGEARO).


ASCII English ERRCNFG

ASCII - Command | ERRCNFG |
Syntax Transmit | ERRCNFG [Data] |
Syntax Receive | ERRCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3884 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 33 (dec)
Range | -2147483648 .. 2147483647 | DPR | 900 (dec)
Default | 83894274 (0x50002002) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.8
Function Group | other commands | EEPROM | Yes
Short Description | behavior of the drive in the case of error

Description

The command ERRCNFG defines the behavior of the drive in the case of error massage Fxx.
If the bit number xx of the ERRCNFG parameter is set to 1, then the corresponding error message FXX+1
generates an immediately power stage disable (no matter what is the setting of ACTFAULT).

Example:
The default value 83894274 (-> 0x0500 2002) disables immediately the output stage in case of error:
F02 Fault over voltage
F14 Output stage fault
F25 Commutation Error
F27 „AS-Option“ Error

In some critical error situations, the output stage is disabled immediately. Then the setting ACTFAULT = 1 has no function.

See also command ERRCODE, ERRCODE *


ASCII English ERRCODE

ASCII - Command | ERRCODE |
Syntax Transmit | ERRCODE |
Syntax Receive | ERRCODE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | String
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Activated Fault Messages

Description

The ERRCODE command returns the clear text information about any existing faults.

See also ERRCODE *


ASCII English ERRCODE2

ASCII - Command | ERRCODE2 |
Syntax Transmit | ERRCODE2 |
Syntax Receive | ERRCODE2 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3862 (hex)
DIM | - | PROFIBUS PNU | 1666 (dec) IND = 33 (dec)
Range | 0..55 | DPR | 866 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.45 |
Configuration | No | Last Change of this Object | 2.12
Function Group | other commands | EEPROM | No
Short Description | Additional error code info

Description

In case of an error ERRCODE !=0 this variable gets an additional information about the errcor cause. At the drive the ERRCODE2 is displayed with an i followed by the number.
Status | Error | description
ERRCODE2 = 0 | - | no additional information
ERRCODE2 = 1 | F32 | system fault software watchdog
ERRCODE2 = 2 | F32 | system fault: wrong order oth the commandtable
ERRCODE2 = 3 | F32 | system fault: macro conversion fault
ERRCODE2 = 4 | - | reserved
ERRCODE2 = 5 | F25 | commutation fault: velocity control
ERRCODE2 = 6 | F25 | commutation fault: current control
ERRCODE2 = 7 | F25 | commutation fault: wrong segment of the Hall feedback
ERRCODE2 = 8 | F25 | commutation fault: W&S contouring error
ERRCODE2 = 9 | F25 | commutation fault: amplitude of W&S to high
ERRCODE2 = 10 | F25 | commutation fault: amplitude of W&S to small
ERRCODE2 = 11 | F25 | commutation fault: W&S IQ to high
ERRCODE2 = 12 | F25 | commutation fault: W&S wrong average
ERRCODE2 = 13 | F07 | The gate voltage of the IGBT drivers is missing (internal hardware error).
ERRCODE2 = 14 | F07 | The 15V power supply voltage is missing (internal hardware error).
ERRCODE2 = 15 | F32 | The firmware version is not suitable for the plugged in option card.
ERRCODE2 = 16 | F04 | Error while reading the BISS-position in regsiter mode.
ERRCODE2 = 17 | - | reserved
ERRCODE2 = 18 | F04 | BISS communication fault.
ERRCODE2 = 19 | - | reserved
ERRCODE2 = 20 | F25 | Sine/Cosine amplitude is too large
ERRCODE2 = 21 | F07 | 15V power-supply is missing (only for 748/772)
ERRCODE2 = 22 | F04 | Reading the encoder data via slow data access was not possible (communication problem with the encoder)
ERRCODE2 = 23 | F04 | Reading the encoder data via fast data access was not possible (communication problem with the encoder)
ERRCODE2 = 24 | - | reserved
ERRCODE2 = 25 | F20 | Reading data from the POSIO option-card was not possible. see also CALCPOSIO
ERRCODE2 = 26 | - | reserved
ERRCODE2 = 27 | F32 | Corrupted flash data for the amplifier identification number.
ERRCODE2 = 28 | F04 | Determination of the BISS-C frame length has failed.
ERRCODE2 = 29 | F29 | The plugged in option card does not match with the software version of the drive.
ERRCODE2 = 30 | F29 | A software enable command coming from the option-card failed since the hardware enable signal is missing or the DC bus voltage is too low.
ERRCODE2 = 31 | F29 | The hardware enable signal has been removed while the option-card was in operation and has enabled the drive. Hardware enable signal is lost or the bus voltage is too low.
ERRCODE2 = 32 | F29 | Either the drive was not able to get synchronized with the cyclic command values from the fieldbus during the phase run-up procedure or the synchronization was getting lost while the option card was in operational mode.
ERRCODE2 = 33 | F29 | The option-card requested a CLRFAULT (clear faults) command during a pending fault. This CLRFAULT command command would lead to a software reset of the drive. This monitoring needs to be activated via the command SERCSET and is only available for specific option-cards.
ERRCODE2 = 34 | F29 | The EtherCAT master requested a state transition from the Operational state to another state although the drive has been enabled (software enable = true). The drive has lost the synchronization with the EtherCAT cyclic command values if this fault comes along with a F28 fault.
ERRCODE2 = 35 | F29 | The mapping number of the command-value mapping, which has been previously transmitted to the drive via SDO, is unknown.
ERRCODE2 = 36 | F29 | The mapping number of the actual-value mapping, which has been previously transmitted to the drive via SDO, is unknown.
ERRCODE2 = 37 | F29 | The length of the command-value mapping in bytes assumed by the EtherCAT master does not match with the length of the mapping assumed by the drive.
ERRCODE2 = 38 | F29 | The length of the actual-value mapping in bytes assumed by the EtherCAT master does not match with the length of the mapping assumed by the drive.
ERRCODE2 = 39 | F29 | The option card indicates a card error or network fault. This status message is only indicated by specific option-cards.
ERRCODE2 = 40 | F29 | The SynqNet master has selected an invalid resolution of the velocity scaling/unit via direct commands.
ERRCODE2 = 41 | F29 | The mode of operation selected by the Sercos master does not match the mode of operation in the drive (OPMODE)..
ERRCODE2 = 42 | F29 | The Sercos interrupt function detected a broken network cable.
ERRCODE2 = 43 | F29 | The drive has detected several consecutive missing MTS (master synchronization telegrams).
ERRCODE2 = 44 | F29 | The drive has detected an unknown/invalid Sercos interrupt type.
ERRCODE2 = 45 | F29 | The drive identified a Sercos ASIC with an unknown/invalid version number.
ERRCODE2 = 46 | F29 | The drive has identified an error condition in the object IDN14.
ERRCODE2 = 47 | F29 | The FireWire option card has not updated the watchdog counter value.
ERRCODE2 = 48 | F29 | The Modbus+ card has stopped generating interrupt signals
ERRCODE2 = 49 | F29 | The EtherNet card has stopped its SDO transfer.
ERRCODE2 = 50 | F14 | overflow of the current measurement
ERRCODE2 = 51 | F18 | regen fault (hardware)
ERRCODE2 = 52 | F18 | max. mechnaic power of the regen reached
ERRCODE2 = 53 | F04 | min. resolver amplitude (threshold) undershot
ERRCODE2 = 54 | F04 | max. amplitude jump of the resolver signals
ERRCODE2 = 55 | F04 | phase deviation between sinus/cosinus of the resolver


ASCII English ERRCODE *

ASCII - Command | ERRCODE * |
Syntax Transmit | ERRCODE * |
Syntax Receive | ERRCODE * <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 385D (hex)
DIM | - | PROFIBUS PNU | 1661 (dec) IND = 33 (dec)
Range | 0 .. 0xFFFFFFFF | DPR | 861 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | actual values | EEPROM | No
Short Description | Output Error Register

Description

The ERRCODE* command returns the internal status information in the form of a bit-variable. A bit is set for as long as the corresponding error/fault is detected. The bit is deleted by the hardware reset of the amplifier.
Faults that are designated by the SW label can also be deleted by a software reset (function CLRFAULT – clear fault).

Level gives an information about the error handling in the drive.

Level 2:
A fault causes an emergency stop. The stop of the motor is done in velocity control using the emergency stop ramp (DECSTOP). When the motor reaches the zero velocity level (VEL0) (limited by max. 5 sec), the power stage is disabled. The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

Level 3:
A fault causes an emergency stop. The stop of the motor is done without feedback device (sensorless). When the motor has stopped, the power stage is disabled. The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

Level 4:
A fault causes an directly disable of the power stage. The motor has no torque (coast). The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

If the faults are at the same time assigned to the levels 2/3 and 4, decide the parameters ACTFAULT and MBRAKE on the membership of the state levels.

ACTFAULT=1 or MBRAKE=1 LEVEL 2 or 3 (Default-Setting)
ACTFAULT=0 and MBRAKE=0 LEVEL 4

Attention, please have a lookt to ERRCNFG:
The command ERRCNFG defines the behavior of the drive in the case of error massage Fxx. If the bit number xx of the ERRCNFG parameter is set to 1, then the corresponding error message FXX+1 generates an immediately power stage disable (no matter what is the setting of ACTFAULT). In some critical errors, the output stage is disabled immediately. This happens regardless of the settings of ACTFAULT and ERRCNFG. The error messages are separately identified in the following table.

For more information, please have a look to ERRCODE2
Bit/Displ./Reset/Level | Bit | Description
00/F01/SW/2,4 0x00000001 =1 Heatsink overtemperature
is set, if the heatsink temperature TEMPH exceeds the max allowed threshold MAXTEMPH.
01/F02/SW/2,4 0x00000002 =1 DC-link overvoltage
Is set, if the DC-link voltage exceeds the max threshold selected by VBUSBAL.

This error leads to an immediate disable of the output stage.
02/F03/SW/2 0x00000004 =1 Contouríng error of the external trajectory (OPMODE=6/SERCOS)
Is set, if the target speed which is given by the extrnal trajectory is higher than VLIM/VLIMN.
03/F04/HW/3,4 0x00000008 =1 Feedback error
Is set, if a feedback error was detected.

The drive decelerates by current controller.
04/F05/SW/2,4 0x00000010 =1 Undervoltage protection
Is set, if the DC-link voltage is lower than VBUSMIN (only if the drive is enabled).
05/F06/HW/2,4 0x00000020 =1 Motor overtemperature
is set, if the heatsink temperature TEMPM exceeds the max allowed threshold MAXTEMPM.

FW >= 2.27 the failure is reset by software.
06/F07/HW/2,4 0x00000040 =1 if the internal electronic supply is faulty.

This error leads to an immediate disable of the output stage.
07/F08/SW/3,4 0x00000080 =1 Overspeed
Is set, if the velocity of the motor exceeds the overspeed threshold (VOSPD).

The drive decelerates by current controller.
08/F09/HW/4 0x00000100 =1 EEPROM Checksum error
Is set, if the data read/written from the EEPROM is not valid.
There are two possibilities, that can cause this error. First is a defect EEPROM and the second is a wrong checksum in the EEPROM. In the second case, a SAVE can solve the problem.
09/F10/HW 0x00000200 Signal failure digital encoder input

see also SDLY
10/F11/HW/2,4 0x00000400 =1 Brake error
Is set, if the brake switch detects a fault (e.g. Brake is selected, but no brake is connected).
11/F12/HW | 0x00000800 | motorphase is missing (e.g. broken line)
12/F13/SW/2,4 0x00001000 =1 Ambient overtemperature
is set, if the ambient temperature TEMPE exceeds the max allowed threshold MAXTEMPE.
13/F14/HW/2,4 0x00002000 =1 Output stage fault
This fault can be caused by:
Earth short circuit of the motor
Short circuit of the motor phases
Short circuit of the regen.

This error leads to an immediate disable of the output stage.
14/F15/SW/2,4 | 0x00004000 | =1 I²tmax override.
15/F16/SW/2,4 | 0x00008000 | =1 Mains BTB
16/F17/HW/2,4 | 0x00010000 | =1 A/D converter error
17/F18/HW/2,4 0x00020000 =1 Regen error
destroyed regen transistor
regen resistor extern selected, but the internal one is used.
18/F19/SW/2,4 0x00040000 =1 DC bus breakdown (net phase missing?)
(see also VBUSLIM, PMODE and VBUSMAX
19/F20/HW/2,4 0x00080000 =1 Slot error
Error depends on the type of Slot board:

1. I/O expansion board The error is caused by a short at the output at the I/O board.

2. DPR Slot board
(Beckhoff, L&B, Sigmatek)
The error is generated, if the DPR interrupt fails to appear. The watch-dog time can be selected by EXTWD.

3. PROFIBUS
Error in the initialization time.

4. S700/safety: F20 is generated if the parameter CSENID is set to 1 and no safety card has been detected by the firmware. There may be two cases:
1. The amplifier has a safety card. In this case, it should be checked whether the card is inserted correctly.
2. The amplifier has no safety card. In this case, the parameter CSENID should be set to 0 and the change should be saved.
The error message F20 should disappear the next time the amplifier is switched on.

Attention: Setting CSENID, but without an installed safety card, can lead to unnecessary heating of the motor!
20/F21/HW/2,4 0x00100000 =1 PROFIBUS handling error
If the OPMODE is changed by another communication channel than PROFIBUS, when the drive is under control of the PROFIBUS, this error is generated.
Exception: Working mode -126 for PROFIBUS. This is the safe opmode when the drive is switched on.
21/F22/HW/2,4 | 0x00200000 | reserved
22/F23/HW/2,4 0x00400000 =1 CANopen Bus-Off
Fault in CAN communication.
The communication fault BUSOFF is generated by layer 2 (CAN controller). This fault can have several resons. Some examples are:
Drive tries to establish communication, but there is no other node.
CAN nodes have different baud rates, Bus cable defekt, reflections because of missing or wrong bus terminations, etc.

A BUSOFF is displayed by the drive, if another CAN node is connected and minimum one errorfree object is generated. If the BUSOFF is generated and the drive is moving the motor, the motor is stopped using the emergency ramp and then the drive is disabled.
23/F24/SW/2,4 | 0x00800000 | Warning generates a error message (defined by WMASK)
24/F25/HW/3,4 0x01000000 Commutation Error (Run-away of the motor)

The drive will be directly disabled.

see also VCOMM
25/F26/SW/2,4 | 0x02000000 | Hardware limit switch error at homing move
26/F27/HW/4 0x04000000 =1 "-AS-Option" error
If the ENABLE signal of the drive is high and the -AS-option is activated, this error is generated.

This error leads to an immediate disable of the output stage.
27/F28/SW/2 0x08000000 =1
EtherCAT
Error synchronisation
is activated
if the drive during the start up procedure isn't able to be synchronized or
if the drive is in EtherCAT status „Operational“ and loose synchronize.
28/F29/SW/2 0x10000000 =1
Slotcard Error ( SERCOS)

is activated if
the communication is disturbed or
a SW enable is set via slotcard without a set HW Enable.

DPR-card ( EtherCAT)

is activated if
the communication is switched to a lower level while the drive is enabled
a not supported mapping of cyclic data is refined or a SW enable is set via slotcard without a set HW Enable.
29/F30/SW 0x20000000 Emergency stop time out

See also EMRGTO
30/F31/SW | 0x40000000 | Reserved
31/F32/HW/4 0x80000000 =1 System error
Is set, if an error occurred in the system check of the initialization phase or a watch-dog error in the working phase.
Following reasons are possible:
1. Wrong program data in the FLASH (e.g. interrupted program download)
2. Macro error (the macros could not be compiled)
3. Software watch-dog activated
4. Error with the EEPROM (read or write).
5. Macro RAM (the compilation of the MACROs detect too less RAM)

When the drive is switched on, a detailed message is send via RS232.

In case of F32 error try a SAVE command. When this procedure is finnished reset the drive.


ASCII English ERRMASK

ASCII - Command | ERRMASK |
Syntax Transmit | ERRMASK [Data] |
Syntax Receive | ERRMASK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 355E (hex)
DIM | - | PROFIBUS PNU | 1694 (dec) IND = 1 (dec)
Range | -2147483648 .. 2147483647 | DPR | 94 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | - |
Configuration | No | Last Change of this Object | 2.8
Function Group | drive configuration | EEPROM | Yes
Short Description | mask for activate the error timer

Description

The parameter ERRMASK choose the errors, which were activate after the error delay time (ERRTIME).

Have a look to ERRCODE * and ERRTIME


ASCII English ERRPARAM

ASCII - Command | ERRPARAM |
Syntax Transmit | ERRPARAM |
Syntax Receive | ERRPARAM <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 375A (hex)
DIM |  | PROFIBUS PNU | 1802 (dec) IND = 17 (dec)
Range |  | DPR | 602 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 1.3
Function Group | drive configuration | EEPROM | No
Short Description | Objectnumber of the incorrect parameter (warning n24)

Description

The ASCII parameter ERRPARAM gets the object number of the incorrect parameter that caused the warning n24.
During the initialisation phase the drive performs a plausibility check of the configuration parameters. In case of
Unreasonable settings (for example: reference limit switch configured for more than one digital input), the warning n24 (s. STATCODE) is generated. The parameter number of the faulty parameter is stored in the ERRPARAM. The ASCII name of the faulty parameter can be detemined with the command IDDUMP.

There are following plausibility checks:

Function INxMODE=2,3,4,5 possible only for x=3 or 4
Function INxMODE=6,7 only for x=3
Function INxMODE=19 only for x=2
Function INxMODE=26 only for x=1 and 2
Function INxMODE=30,33 only possible for x=1..4,19,20
Functions INxMODE=2,3,4,5,6,7,8,10,11,12,13,14,15,19,21,22,25,29,32,38,42 are possible for all digital inputs but every function can be used only once.


ASCII English ERRTIME

ASCII - Command | ERRTIME |
Syntax Transmit | ERRTIME [Data] |
Syntax Receive | ERRTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 355F (hex)
DIM | ms | PROFIBUS PNU | 1695 (dec) IND = 1 (dec)
Range | 0 .. 20000 | DPR | 95 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 2.11 |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Error handling delay time

Description

The command ERRTIME defines the value of the error handling delay time for the delay function defined with ERRMASK.

See: ERRCODE and ERRMASK


ASCII English ESPEED

ASCII - Command | ESPEED |
Syntax Transmit | - |
Syntax Receive | ESPEED <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 3675 (hex)
DIM | rpm | PROFIBUS PNU | 1973 (dec) IND = 1 (dec)
Range | 0 .. 16000 | DPR | 373 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | No
Short Description | Maximum velocity corresponding to the Feedback Type

Description

The command ESPEED gives the maximum velocity of the motor corresponding to the selected feedback type (FBTYPE).


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

EtherCAT Expansion Card

This screen is avalable only if an EtherCAT expansion card is inserted into the servo amplifier.

Profibus1

This screen monitors:
- the current communication phase in the communication state
- the selected cyclic actual and command mapping
- the status of the CAN-over-EherCAT state machine

You can set several EtherCAT specific settings (see SERCSET). The current communication cycle time can be set/read in steps of 250µs. The cycle time is usually set by the EtherCAT control during the phase start (see PTBASE).


ASCII English ETHMODE

ASCII - Command | ETHMODE |
Syntax Transmit | ETHMODE [Data] |
Syntax Receive | ETHMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3778 (hex)
DIM | - | PROFIBUS PNU | 1832 (dec) IND = 17 (dec)
Range | 0..2 | DPR | 632 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.07 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | fieldbus | EEPROM | Yes
Short Description | Select on-board field bus interface

Description

only S700: only S300 FW >= 5.00: Selects the on-board field bus interface that is activated on boot-up. With multidrive MDRV ETHMODE must set to 2
0 | CAN | On-Board-CAN is permanent activated
1 | auto-detect | while booting the drive an EtherCAT-connection is detected, the on-board EtherCAT will be activated else CAN will be activated.
2 | EtherCAT | On-Board-EtherCAT is permanent activatet Multidrive MDRV with EtherCAT: ETHMODE must set to 2 note: with this setting, the EtherCAT state machine is activated immediately. As long as it is in the Init-state and no communication takes place, only digital demand values are possible. Once OPMODE is set to 1 or 3, the power stage is disabled. The background is as long as the control was not raised and no communication has been established to drive, no motor movement may occur. This is to avoid that an analog mode is stored in the EEPROM and the axis moves during power up.


ASCII English EWH

ASCII - Command | EWH |
Syntax Transmit | EWH [Data] |
Syntax Receive | EWH <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38BE (hex)
DIM | Wattstunde | PROFIBUS PNU | 1758 (dec) IND = 33 (dec)
Range | 0 .. 2147483647 | DPR | 958 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | actual values | EEPROM | Yes
Short Description | consumed electric energy in watt-hours

Description

The variable EWH provides the consumed electric energy in watt-hours. It corresponds to the value of the integral Ud*Id + Uq*Iq.
The value is saved every 8 minutes in the flash, and by frequent switching the amplifier a larger measurement errors can occurs.

A write access of this variable can be set to arbitrary starting values.

The display is indeed in watt-hours, but the date is stored internally in watt seconds. The exact value can be queried via the variable EWS ("M EWS") macro variable.


ASCII English EXTBRAKE

ASCII - Command | EXTBRAKE |
Syntax Transmit | EXTBRAKE [Data] |
Syntax Receive | EXTBRAKE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 385C (hex)
DIM |  | PROFIBUS PNU | 1660 (dec) IND = 33 (dec)
Range | 0..3 | DPR | 860 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.37 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | motor | EEPROM | Yes
Short Description | software brake on/off software configuration

Description

The external break control means, that the brake control is linked to the internal macro variable EXTBRAKEC.
This variable can be used by fieldbus or PLC program to control the state of the motor brake.

EXTBRAKE=0 no external brake control, brake controlled exclusively by the drive (default setting)
EXTBRAKE=1 external brake control allowed only when power stage disabled (this is S300/S700 standard procedure for external brake control).

since FW 5.53/3.89
EXTBRAKE=2 external brake control allowed only when drive enabled
EXTBRAKE=3 external brake control allowed only when drive enabled and no emergency stop ramp is active

since FW 5.77
EXTBRAKE=4 external brake control is alway allowed


ASCII English EXTLATCH

ASCII - Command | EXTLATCH |
Syntax Transmit | EXTLATCH [Data] |
Syntax Receive | EXTLATCH <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3681 (hex)
DIM | - | PROFIBUS PNU | 1985 (dec) IND = 1 (dec)
Range | 0 .. 2 | DPR | 385 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Selection of the Source of the Latch Inputs

Description

The configuration variable EXTLATCH defines the source for the position information using the Latch functions of the digital inputs (IN1MODE=26 and/or IN2MODE=26). If more than one inputs (1 or 2) are configured as Latch input, EXTLATCH defines the different sources. If only one input is configured as Latch input, both different sources are stored at the same time.

If EXTLATCH=0 the actuall position controller feedback is latched, that is

EXTPOS = 0 the actuall value of the standard feedback (FBTYPE)

EXTPOS > 0 he actuall value of an external feedback.

EXTPOS < 0 the value of the latched data is defined by

EXTLATCH = 0 latch position PFB by both digital inputs 1and 2 (IN1MODE=26 / IN2MODE=26) in the register LATCH1P32 and LATCH2P32

EXTLATCH = 1 latch position PFB0 by digital input 1 in LATCH1P32 and position PFB by digital input 2 in LATCH2P32

EXTLATCH =2 latch position PFB0 by both digital inputs 1and 2 in register LATCH1P32 and LATCH2P32


ASCII English EXTPOS

ASCII - Command | EXTPOS |
Syntax Transmit | EXTPOS [Data] |
Syntax Receive | EXTPOS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3539 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 1 (dec)
Range | -30 ... 30 | DPR | 57 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | Yes
Short Description | Position Value For Position Control

Description

The parameter EXTPOS define the source of feedback used for the position loop. For EXTPOS = 0 the motor feedback, defined by the command FBTYPE, will used for the position loop. For EXTPOS > 0 an external feedback will used for position loop. The gearing factor of the external feedback to bring the external position to 32Bit per revolution will set by the parameter EGEARO as a multiplier and EGEARI as a divisor.

If EXTPOS is set to negative values the feedback is read and the position stored in PFB0. The position loop acts with the commutation feedback (FBTYPE).

example:
EXTPOS = -6 The sinus/cosinus-Feedback(5V) is read. The position can be monitored by ASCII-command PFB0.
The input of the external feedback is withput effect to the position control.

EGEARI and EGEARO can be used to set the ratio:

1. On all analog read position feedbacks EXTPOS=6,7,8,9 the position is calculated by the ENCLINES-setting and converted to the 32Bit/turn -format. The parameter EGEARI/EGEARO are only for the gearing-factor.
On EGEARI-feedback turn the motor makes EGEARO turns.

example:
EGEARI=10,EGEARO=3 -> ratio 10 : 3

2. On all digital read position feedbacks( EXTPOS=1...4 )
the parameter ENCIN defines the feedback pulses / turn.
The parameter EGEARI/EGEARO sets the gearing-faktor.

example:
An external digital Encoder has got 1024 pulses / turn,
on 1 feedback turn the motor runs 3 turns.
The necessary settings are:

EXTPOS 3,
ENCIN 1024,
EGEARI 1,
EGEARO 3
Status | connector | Feedback for position control
EXTPOS = 0 - no external feedback
EXTPOS = 1 | connector X3 | 24 V pulse / direction
EXTPOS = 2 | connector X3 | 24 V digital encoder
EXTPOS = 3 | connector X5 | 5 V digital encoder
EXTPOS = 4 | connector X5 | 5 V pulse / direction
EXTPOS = 5 | connector X5 | SSI encoder
EXTPOS = 6 | connector X1 | 5V SinCos Encoder
EXTPOS = 7 | connector X1 | 12V SinCos Encoder
EXTPOS = 8 | connector X1 | ENDAT
EXTPOS = 9 | connector X1 | HIPERFACE
EXTPOS=10 | connector X1 | 5V ROD encoder for actual position value in positon control mode
EXTPOS = 11 connector X1 5V BiSS-B digital feedback. The primary feedback has to be a resolver (FBTYPE = 0).

Fw >= 2.28
EXTPOS = 12 connector X1 BiSS C
FBTYPE=33

Fw >= 5.18
EXTPOS = 13 connector X1 EnDat 2.2
FBTYPE=32

ab Fw >= 5.18
EXTPOS = 25 connector X1 SSI Encoder
FBTYPE=32

ab Fw >= 5.18
EXTPOS = 30 connector X1 5 V ROD digital Encoder
FBTYPE=32

ab Fw >= 5.18


ASCII English EXTWD

ASCII - Command | EXTWD |
Syntax Transmit | EXTWD [Data] |
Syntax Receive | EXTWD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 353A (hex)
DIM | ms | PROFIBUS PNU | 1658 (dec) IND = 1 (dec)
Range | 1 .. 32000 | DPR | 58 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | External Watch Dog (Fieldbus)

Description

The EXTWD parameter can be used to define the monitoring time (watchdog timer) for the fieldbus/slot communication. The monitoring is only active if the EXTWD parameter has a value greater than zero (EXTWD=0 means monitoring is switched off) and the output stage is enabled. If the preset time runs out, without the timer being retriggered, then the warning n04 (threshold monitoring) is generated and the drive is stopped. The amplifier remains ready for operation, and the output stage is still enabled. This warning must be cancelled (function CLRFAULT or INxMODE=14) before a new motion command (setpoint) can be accepted.
For DeviceNet, set to 1 to enable F04 and 0 to disable. (Watchdog time is set by DeviceNet controller.)


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Test and Diagnosis

Test Feedback/Motor

The feedback/motor test page offers a wiring test for the encoder or motor connection.

When the function is started in the current control mode (OPMODE = 2) with an enabled output, the motor slowly begins to turn. The movement is controlled without using the position encoder (U/F mode). The imported encoder position is observed and noted for evaluation purposes only. Using the position data, the encoder resolution, counting direction and encoder connection can be controlled. If the connection of the analog tracks is faulty, encoders that produce both digital as well as analog information (Endat2.1, Hiperface, BiSS-B) may sometimes lose positioning accuracy only. The drive can still be operated without any problems. Depending on the resolution of the encoder system, it can be difficult to detect such wiring errors.

This test function continually reads both the analog (if available) as well as the digital positional information of the encoder and checks the data for plausibility. If deviations occur, the test function tries to identify the cause of the problem.

The following parameters must be input correctly to ensure that the test can be carried out:

  • Correct feedback type (FBTYPE)
  • Correct parameters for the current control circuit
  • Positive encoder counting direction (DIR=21)
  • Correct number of motor pole pairs MPOLES

Risk of injury in case of vertical or pre-loaded load!
The test works with reduced torque, therefore the testing of hanging load or pre-loaded load is not allowed. If possible, The test should be done without coupled load.

einheiten

Settings

1. Number of revolutions (mechanical)

Specified travel path for the test movement. Since the movement occurs without sensors, it is important that the number of motor pole pairs is set correctly. Depending on the resolution of the encoder, at least one full mechanical rotation should be made.

2. Current as % of nominal motor current

The sensorless operation mode requires a d-directional current (to generate a field). The d-current required for this is provided through this input.

Result

The overall result of the test is displayed on this screen. For the individual tests, a green/red LED shows whether the respective test has been successful (green) or unsuccessful (red).

1. Correct motor phasing – the travel path was successfully covered.
2. Correct feedback – no feedback problem detected
3. Correct rotational direction – the rotational direction of the encoder is positive - the analog and digital counting directions of an analog/digital encoder match.
4. Correct encoder resolution – the detected resolution of the encoder does match the set values..

X1 Connector

This display only applies for encoders with analog and digital position measuring (Endat2.1, Hiperface, BiSS-B). Using the recorded positional information, the correlation between the analog and digital tracks is checked. If there is a discrepancy in the positional information, it may have been caused by interchanged X1 lines (sine/ cosine). The test function tries to detect the potential wiring errors and displays the result using the red or green LED.

Feedback – extended encoder information

This display only applies for encoders with analog and digital position measuring (Endat2.1, Hiperface, BiSS-B).

1. Number of periods – number of sine/cosine periods per encoder rotation
2. Resolution – number of counts (digital position) per sinus period (analog position)
3. Counting direction – positive/negative counting direction
4. Motor phase – a current motor phase is detected at the end of the test function. Should the detected value match the current MPHASE setting, the green LED turns on. If the value deviates by under 5 degrees, the yellow LED turns on, any higher and the red LED turns on.

The result of the feedback/motor test can depend greatly on external influences.

Start the measurement procedure by clicking on the "Start Test/Movement" button.

Click on the “Return to Feedback Page” button to return to the feedback page.

Endat 2.2 Diagnosis

Contains up to 16 ENDAT2.2 encoder diagnose information. Diagnosis data has to be supported by the encoder and by the firmware (5.91 and newer) and configured in the drive (see ASCII command EN22CNFG). The meaning of the transmitted value can be found in the ENDAT encoder documentation delivered by the manufacturer.

Monitoring Information

Contains up to 16 ENDAT2.2 encoder monitoring information. Diagnosis data has to be supported by the encoder and by the firmware and configured in the drive (see ASCII commands EN22CNFG and .EN22DCNT).

Additional Information 1

Contains up to 16 ENDAT2.2 encoder additional information 1 (AI1). Diagnosis data has to be supported by the encoder and by the firmware and configured in the drive (see ASCII commands EN22CNFG and . EN22A1CNT).

Additional Information 2

Contains up to 16 ENDAT2.2 encoder additional information 2 (AI2). Diagnosis data has to be supported by the encoder and by the firmware and configured in the drive (see ASCII commands EN22CNFG and . EN22A2CNT).

HIPERFACE DSL Diagnosis

This page presents status information, which have been transmitted by the DSL Encoder.

Click on the “Return to Feedback Page” button to return to the feedback page.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Wake and Shake - Expert

einheiten

Wake and Shake is used for feedback systems without commutation signals, such as a Hall sensor or a

SinCos encoder. Experts can make settings for the Wake and Shake procedure on this screen.

Settings with significant errors may lead to motor overspeed. Risk of injury. The parameters should only be changed after consulting a service technician.

Screen text | ASCII parameter
WSCNFG0 - Pulse Method
T1 | WSTIME, function execution time
REFIP2 | REFIP2, peak current for commutation location
REFIP | REFIP, peak current
T2 | WSTIME2, pause time between the current vectors
T3 | WSTIME3, time interval between coarse and fine tuning
WSCNFG1 - Control Loop Method
P | MPKP, P component of the position controller
I | MPKI, I component of the position controller
D | MPKD, D component of the position controller
Zeit | MPTIME, alignment time for commutation location
REFIP2 | REFIP2, peak current for commutation location
Hilfe | Opens the KDN page Wake and Shake

Click on the “Help” button to open the KDN page Wake and Shake, which contains detailed information. Click on the “Return to Feedback Page” button to return to the feedback page.


ASCII English FBGEARI

ASCII - Command | FBGEARI |
Syntax Transmit | FBGEARI [Data] |
Syntax Receive | FBGEARI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3893 (hex)
DIM |  | PROFIBUS PNU | 1715 (dec) IND = 33 (dec)
Range | 1...2147483647 | DPR | 915 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | feedback | EEPROM | Yes
Short Description | compensation facor motor/gearing

Description

This function is used to compensate for the possibly existing transmission between the motor and the encoder. It can also be used to manipulate the encoder resolution.

This function is only active when FBGEARI FBGEARO and have different values. The position value at the output of gearing is stored in the macro variable NEWBISS (in the terminal with "M NEWBISS").

NEWBISS = position * FBGEARO / FBGEARI

For the variable NEWBISS is in the lower 32 bits contain the position within one revolution of a 64-bit variable. The upper 32 bits contain the number of full revolutions


ASCII English FBGEARO

ASCII - Command | FBGEARO |
Syntax Transmit | FBGEARO [Data] |
Syntax Receive | FBGEARO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3894 (hex)
DIM |  | PROFIBUS PNU | 1716 (dec) IND = 33 (dec)
Range | 1...2147483647 | DPR | 916 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | feedback | EEPROM | Yes
Short Description | compensation facor motor/gearing

Description

This function is used to compensate for the possibly existing transmission between the motor and the encoder. It can also be used to manipulate the encoder resolution.

This function is only active when FBGEARI FBGEARO and have different values. The position value at the output of gearing is stored in the macro variable NEWBISS (in the terminal with "M NEWBISS").

NEWBISS = position * FBGEARO / FBGEARI

For the variable NEWBISS is in the lower 32 bits contain the position within one revolution of a 64-bit variable. The upper 32 bits contain the number of full revolutions


ASCII English FBTYPE

ASCII - Command | FBTYPE |
Syntax Transmit | FBTYPE [Data] |
Syntax Receive | FBTYPE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 353B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 1 (dec)
Range | 0 ... 36 | DPR | 59 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | Yes
Short Description | Selection of commutation feedback

Description

The FBTYPE command is used to select the type of feedback device that is used for the commutation and velocity controller. It is also ued for the position controller unless EXTPOS = 1.
The type of encoder that is set is only initialized when the amplifier is switched on, which means that the amplifier must be switched off and then on again after every change of this variable.
The encoder parameters can be altered by using the appropriate ASCII command (in brackets) and then saved in the encoder EEPROM, using the HSAVE command. The encoder commands (HISOFFS, HICOFFS, HIFACT1, HSAVE) are only available when communication with the connected encoder has been established.
If communication with the encoder is not possible, then the error message ENCODER FAULT F04 is displayed.
When the data are loaded from the encoder, the setting for the motor number in the encoder is compared with the internal setting (MNUMBER). If the numbers are different, then an attempt is made to load a motor data set from the internal motor database that has the same motor number as that stored in the encoder. At the same time, the warning “NEW MOTOR DATA SET” n12 is displayed.
In order to prevent a warning being generated at the next power-on, the latest MNUMBER setting should be saved in the EEPROM, using the SAVE command. If it was not possible to load a valid motor number from the encoder (for instance, when an encoder is used for the first time), then no motor data will be loaded. However, the n12 warning will still be generated. The HSAVE command can be used to save the preset setting for the motor number (MNUMBER) in the encoder, so that no warning will be produced at the next power-on.
When using an encoder without a parameter channel (FBTYPE=7/16), and thus without the facility for storing parameters, the offset values HISOFFS / HICOFFS / HIFACT1 will be saved in the serial EEPROM of the amplifier. After an alteration, these values can be permanently stored by using the SAVE command.
The absolute position for EnDat, SSI and HIPERFACE certain FBTYPE settings are read only during initialization (while booting the amplifier). To avoid incorrect readings, the position is read up to 5 times. The position is only accepted as valid if the difference between two adjacent readings is less than the value of the in-position window PEINPOS. If too large position error F04 is displayed.

In all sensorless modes (FBTYPE = 10.11), the output frequency is limited to 599 Hz. This yields the following limits of maximum speed (in RPM): MSPEED (max) = 599Hz * 60 / (MPOLES/2) If your application requires a higher output frequency, please contact our support.
Status | Type of Feedback System | Description
FBTYPE = 0 Resolver Data is loaded from the drive EEPROM.

connector X2
FBTYPE = 1 SinCos 5V connector X1

(MPHASE from EEPROM)

A linearmotor with analoge hall feedback can operate without wake & shake if lENCLINES = 1.
FBTYPE = 2 Hiperface (Stegmann) In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Offset compensation Sine (HISOFFS)
Offset compensation Cosine (HICOFFS)
Amplitude scaling (HIFACT1)
Motor number (MNUMBER)
Motorphase (MPHASE)

connector X1
FBTYPE = 3 SinCos 12V connector X1

(MPHASE fromEEPROM)
FBTYPE = 4 EnDAT (Heidenhain) In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Offset compensation Sine (HISOFFS)
Offset compensation Cosine (HICOFFS)
Amplitude scaling (HIFACT1)
Motor number (MNUMBER)
Motorphase (MPHASE)

connector X1
FBTYPE = 5 | SinCos with Hall | connector X1
FBTYPE = 6 | SinCos 12V with Hall | connector X1
FBTYPE = 7 SinCos 5V mit W&S connector X1

FW >= 2.18
A linearmotor with analoge hall feedback can operate without W&S if ENCLIINES = 1 and DRVCNFG Bit 8 = 1 is set. Additional is bit "reference ok" set. (standardfunction Bit 8). If this is not allowed use FBTYPE =1 for this feedback.
FBTYPE = 8 | SinCos 12 V with W & S | connector X1
FBTYPE = 9 | SSI | connector X5
FBTYPE =10 sensorless -
FBTYPE =11 Hall only
5 V 		connector X1
FBTYPE =12 | RS422 feedback device (A quad B) 24V level. | connector X3
FBTYPE = 13 digital encoder 5V connector X5

(MPHASE from EEPROM
FBTYPE = 14 | digital encoder 24V with Hall | connector X1/X3
FBTYPE = 15 digital encoder 5V with Hall connector X1

By use of digital feedback (ROD) at X1 (FBTYPE=15,17) the
external ROD-indexpulse can used for homing (NREF 1,2,7) and for the ROD output.

The parameter REFMODE has to set at 5.
FBTYPE = 16 | digital encoder 24V with W&S | connector X3
FBTYPE = 17 digital encoder
5V - W&S 		connector X1

By use of digital feedback (ROD) at X1 (FBTYPE=15,17) the
external ROD-indexpulse can used for homing (NREF 1,2,7) and for the ROD output.

The parameter REFMODE has to set at 5.
FBTYPE = 18 digital encoder
5V with Hall 		connector X1/X5
FBTYPE = 19 digital encoder
5V - W&S 		connector X5
FBTYPE = 20 BISS - Feedback
5V - digital 		connector X1

After the amplifier is switched on all Encoder-EEPROM data are load in the drive. These are:
motor number MNUMBER,
motor phase MPHASE

only FW > 2.14
FBTYPE = 21 EnDat + W&S connector X1

EnDat with W&S: the absolute position is red by the feedback eeprom through the parameter channeland and MPHASE is calculatet by Wake & Shake.

This kind of FBTYPE is a combination between FBTYPE=4 und FBTYPE=7
FBTYPE = 22 BISS - Feedback
12V - digital 		connector X1

After the amplifier is switched on all Encoder-EEPROM data are load in the drive. These are:
sinus offset adjustment HISOFFS,
offset adjustment cosinus HICOFFS,
amplitude scaling HIFACT1,
motor number MNUMBER,
motor phase MPHASE

only FW > 2.14
FBTYPE = 23 BISS Feedback
5V - analog 		connector X1

After the amplifier is switched on all Encoder-EEPROM data are load in the drive. These are:
sinus offset adjustment HISOFFS,
offset adjustment cosinus HICOFFS,
amplitude scaling HIFACT1,
motor number MNUMBER,
motor phase MPHASE

only FW > 2.14
FBTYPE = 24 BISS Feedback
12V - analog 		connector X1

After the amplifier is switched on all Encoder-EEPROM data are load in the drive. These are:
sinus offset adjustment HISOFFS,
offset adjustment cosinus HICOFFS,
amplitude scaling HIFACT1,
motor number MNUMBER,
motor phase MPHASE

only FW > 2.14
FBTYPE = 25 only S700:
SSI 		Connector X1

FW = 3.06
FBTYPE = 26 only S700:

SSI - linear feedback 		FW > 3.06

For SSIRESOL=0, a rotary encoder is also supported. Therefor the settings of the parameters SSIRXD and SSIREVOL are used.
FBTYPE = 27 | digital encoder 5V (MPHASE from EEPROM | connector X1
FBTYPE = 28 | SSI-Linear | connector X5 (POS-I/O-Optioncard)
FBTYPE = 29 | n.a. | booked
FBTYPE = 30 | ROD with W&S | connector X1
FBTYPE = 31 | ROD | connector X1
FBTYPE = 32 EnDAT 2.2 with 5V connector X1

In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Motor number (MNUMBER)
Motorphase (MPHASE)

connector X1
FBTYPE = 33 BiSS-C
5V - digital 		connector X1

For configuration have a look at (BISSCNFG)

only with Renishaw feedback
FBTYPE = 34 EnDAT 2.2 with 12V connector X1

In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Motor number (MNUMBER)
Motorphase (MPHASE)

connector X1
FBTYPE = 35 Hiperface DSL (HDSL)

S700: hardware-version >= 2.30
S300: hardware-version >= 4.20 		connector X1

from FW Version >= 6.00
FBTYPE = 36 Smart Feedback Device (SFD3)

S700: hardware-version >= 2.30
S300: hardware-version >= 4.20 		connector X1

from FW Version >= 6.00


ASCII English FBTYPEX

ASCII - Command | FBTYPEX |
Syntax Transmit | FBTYPEX [Data] |
Syntax Receive | FBTYPEX <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 369B (hex)
DIM | - | PROFIBUS PNU | 2011 (dec) IND = 1 (dec)
Range | 0 .. 33 | DPR | 411 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Display of the actual feedback

Description

The FBTYPEX command can be used to display the current feedback setting. With the FBTYPE = 3 (automatic feedback detection) setting, this object contains the identifier of the automatically detected feedback unit.

An offset of d100 indicates whether a multiturn encoder has been recognized at FBTYPE = 2, 3 and 4.

e.g: EnDat multiturn was detected. FBTYPEX display d104.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Feedback

Select the feedback unit that is part of your motor.

Different setting options will appear on the page according to what is selected. If Wake and Shake feedback or the sensorless option is selected, additional pages for special settings will appear in the navigation area.

Calculate Offset

The Offset compensates the mechanical error of the feedback unit in the motor. Change these parameters only while the servo amplifier is disabled.

Automatic Start!
An incorrect setting can cause the motor to run away, even with a speed setpoint n=0 ! Risk of injury due to uncontrolled motion of the load. Make sure you set the feedback system installed in your motor. Check the rating plate of the motor and the type code.

Example: Resolver

einheiten

Screen text | ASCII parameter
Feedback Type | FBTYPE
No. of Poles | MRESPOLES
Offset | MPHASE
Time | ZERO
Current | REFIP2
Count direction | DIR
Bandwidth | MRESBW
Observer Feedforward | VLO
Treat single-turn feedback like multi-turn | DRVCNFG
Reference Offset Source Drive/Encoder | DRVCNFG2
Encoder Voltage X1 | ENCVON
Angle of Rotation | PRD
Calculate RK | Calculation of the correction parameter for resolver feedback CALCRK. The motor performs a motion using the set parameters.
Resolver correction parameter | CALCRK

Example: SinCos with Hall

einheiten7

Screen text | ASCII parameter
Feedback Type | FBTYPE
Encoder Lines | ENCLINES
Offset | MPHASE
Time | ZERO
Current | REFIP2
Count direction | DIR
Bandwidth | MRESBW
Observer Feedforward | VLO
Treat single-turn feedback like multi-turn | DRVCNFG
Reference Offset Source Drive/Encoder | DRVCNFG2
Encoder Voltage X1 (deactivated) | ENCVON
Angle of Rotation | PRD
Calculate HP | Calculation of the correction parameter for encoder feedback CALCHP. The motor performs a motion using the set parameters.
SinCos correction parameter | CALCRK
Hall Signal States | The status of the Hall inputs is displayed. You can find detailed information about Hall sensors on the KDN page Hall Sensors.


ASCII English FFTSW

ASCII - Command | FFTSW |
Syntax Transmit | FFTSW [Data] |
Syntax Receive | FFTSW <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3866 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 33 (dec)
Range | 0 .. 255 | DPR | 870 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.51 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | other commands | EEPROM | Yes
Short Description | Current feed forward configuration

Description

FFTSW is a bit-form variable for configuration of the current feed forward functionality.

Bit 1 ( 0x00000001)
=1 current feed forward added after the current set point filter
=0 added before the set point filter

Bit 2 ( 0x00000002)
=1 extended current feed forward functionality (new)
=0 standard current feed forward functionality (old)

Bit 3 ( 0x00000004)
=1 inertia feed forward switched on
=0 inertia feed forward switched off

Bit 4 ( 0x00000008)
=1 current feed forward linear interpolation off
=0 current feed forward linear interpolation on

Bit 5 ( 0x00000010)
=1 velocity linear interpolation off
=0 velocity linear interpolation on


ASCII English FHKP

ASCII - Command | FHKP |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English FHTN

ASCII - Command | FHTN |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English FILTMODE

ASCII - Command | FILTMODE |
Syntax Transmit | FILTMODE [Data] |
Syntax Receive | FILTMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 353C (hex)
DIM | - | PROFIBUS PNU | 1660 (dec) IND = 1 (dec)
Range | 0 ... 2 | DPR | 60 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.21 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | filter | EEPROM | Yes
Short Description | Smith Predictor

Description

The Smith Predictor estimates the current, which will settle in 62,5 ms, to compensate the delay time of the servo drive. (fs = 8 kHz). A new motor model with electrical motor time constant is used. Te = L / R. The algorithm is switched on by FILTMODE 2 . KC sets the predictor activity (KC = 1 >>> 100 %, KC = 0,3 >>> 30 %)

To execute the algorithm the following motor parameter have to be saved in the drive:
MRS Phase-Phase resistor of the winding
ML Phase-Phase inductivity of the winding in mH.

With predictor the current controller bandwith can be set up to 2,5 kHz (fs = 8 kHz). If the predictor is switched on the CTUNE default value is 1,8 kHz. Usual the current controller gain MLGQ can be increased by 50 %.

The smith predictor is switched of with value 0 or 1


ASCII English FLTCNT

ASCII - Command | FLTCNT |
Syntax Transmit | FLTCNT |
Syntax Receive | FLTCNT <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0, 65535 per Fault Message | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Fault Frequency

Description

The FLTCNT command provides a listing of all possible error messages, with the number of occurrences of each type of fault in clear text. The total number of faults (sum of the individual faults) is given out before the fault list.


ASCII English FLTCNT *

ASCII - Command | FLTCNT * |
Syntax Transmit | FLTCNT * |
Syntax Receive | FLTCNT * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | 1 x Integer32 + 32 x Integer16 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Fault Frequency

Description

The command returns a list of 33 numbers:
1st number: total number of faults (Integer32)
2nd number number of occurrences of fault F01
3rd number number of occurrences of fault F02
..........
33rd number number of occurrences of fault F32


ASCII English FLTHIST

ASCII - Command | FLTHIST |
Syntax Transmit | FLTHIST |
Syntax Receive | FLTHIST <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | Number and TRUN | PROFIBUS PNU | -
Range | 10 No. of Last Messages+Times | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Fault History: Display last 10 faults

Description

The FLTHIST command produces a list of the last 10 faults that occurred, together with the corresponding number of operating hours at the time of occurrence, in clear text.


ASCII English FLTHIST *

ASCII - Command | FLTHIST * |
Syntax Transmit | FLTHIST * |
Syntax Receive | FLTHIST * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | 20 x Integer32 | CANBus Object Number | -
DIM | Number and TRUN | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Fault History: Display last 10 faults

Description

The FLTHIST command produces a list of the last 10 faults that occurred, together with the corresponding number of operating hours at the time of occurrence, in clear text.
The output looks like this:
n1 t1 n2 t2 n3 t3 ....n10 t10
n – fault number
t – time of the event (operating hours counter) [in 1024/60000 minutes]


ASCII English FW

ASCII - Command | FW |
Syntax Transmit | FW |
Syntax Receive | FW <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 3657 (hex)
DIM | - | PROFIBUS PNU | 1943 (dec) IND = 1 (dec)
Range | - | DPR | 343 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | No
Short Description | Displays the Version Number of the Firmware

Description

The command FW displays the versionnumber of the firmware. The command is also appears in the DUMP list and is part of the parameter settings of the drive.


ASCII English GEARFILT

ASCII - Command | GEARFILT |
Syntax Transmit | GEARFILT [Data] |
Syntax Receive | GEARFILT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D6 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 17 (dec)
Range | 0 .. 16 | DPR | No
Default | 4 |
Opmode | 4 | Data Type Bus/DPR | Command
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | -
Short Description | second order low pass filter (OPMODE=4)

Description

For the operation of electronic gearing ( OPMODE = 4 ), a second order low pass filter is introduced, to smooth the input position command signal. This command GEARFILT can be used to determine the corresponding frequency of the electronic gearing filter.

GEARFILT f (HZ)

1 318
2 159
3 80
4 40
5 20
6 10
7 5
8 2.5

The filter is only used, if it is necessary, because the filter also introduces a delay to prevent the slave from following the master exactly at time during acceleration and deceleration. Normally, GEARFILT = 4 with 40 Hz cut-frequency is chosen.


ASCII English GEARI

ASCII - Command | GEARI |
Syntax Transmit | GEARI [Data] |
Syntax Receive | GEARI <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 353E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 1 (dec)
Range | -2147483648 ... 2147483647 | DPR | 62 (dec)
Default | 1024 |
Opmode | 4 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Input Factor for Electronic Gearing

Description

In master/slave applications (OPMODE=4) this parameter can be used to set the master/slave translation ratio.

1. In case of analoge input signals (GEARMODE=6...9 ) the position is registered by the ENCLINES setting and
converted in the 32bit/turn format.
The parameter GEARI/GEARO is only for the gearing-ratio.

Example:
GEARI ->> feedback turns
GEARO - >> motor turns.
GEARI=10,GEARO=3 -> ratio 10 : 3

2. In case of SSI-feedback (GEARMODE=5) the position is set and calvulated by SSIRXD and SSIREVOL and converted in the 32bit/turn format.
The parameter GEARI/GEARO is only for the gearing-ratio.

3. In case of all digital position inputs (GEARMODE=1...4) the parameter GEARI defines the feedback pulses within GEARO motor turns.
Example:
An externer ROD-feedbackhas 1024 pulses / turn, by 1 feedback turnn the motor should go 3 turns.
The corresponding setting is:
GEARI = 1024, GEARO 3


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Electronic Gearing

einheiten

If the servo amplifier will follow a setpoint as a slave with a gear ratio, you can select the gearing source here and define the gear ratio.

Screen text | ASCII parameter
Ext. Gearing Source | GEARMODE
Count Direction | DIR
Gear Ratio (nominator) | GEARO
Gear Ratio (denominator) | GEARI
Input Filter | GEARFILT


ASCII English GEARMODE

ASCII - Command | GEARMODE |
Syntax Transmit | GEARMODE [Data] |
Syntax Receive | GEARMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 353F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 1 (dec)
Range | 0 .. 30 | DPR | 63 (dec)
Default | 0 |
Opmode | 4 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | position loop | EEPROM | Yes
Short Description | Position Input Electronic Gearing Mode

Description

The servo amplifier is controlled through different interfaces from various sources. The GEARMODE variable configures the source that provides the master setpoint (position). For the connector pin assignments, see the Installation Manual. All devices resolver, SinCos and incremental signals can be used at the same time. Resolver for commutation and speed control, SinCos for position control and incremental encoder for electronic gearing. Following settings have to be made: EXTPOS=1 .. 3 (External actual position)
Status |  | Description
GEARMODE=0 |  | No Feedback
GEARMODE=1 | X3 (24V Pulse/Direction) | Pulse And Direction Digital I/O 24V (X3) With a stepper motor control (pulse/direction, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored. INPUT1=direction (Low = positive, High = negative) INPUT2=pulse
GEARMODE=2 | X3 (24V ROD) | digital encoder Encoder Follower Digital I/O 24V (X3) With an incremental encoder (track A/B, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored.
GEARMODE=3 | X5 (5V ROD) | digital encoder Encoder Follower Digital I/O 5V X5 With an incremental encoder connected to connector X5 (Drive 400 X4), terminals 4, 5, 6, 7. ENCMODE has to be set to "0".
GEARMODE=4 | X5 (5V pulse and direction) | pulse and direction Digital I/O With a stepper motor control connected to connector X5, terminals 4, 5, 6, 7. INPUT1=direction (Low = positive, High = negative) INPUT2=pulse ENCMODE has to be set to "0"
GEARMODE=5 | X5 (SSI) | SSI at X5
GEARMODE=6 | X1 (5V) | sine encoder Only analog processing.
GEARMODE=7 | X1 (12V) | sine encoder Only analog processing.
GEARMODE=8 | X1 (EnDat) | The difference to GEARMODE=6 is, that the parameter channel of the encoder is read and the absolute position is transfered to the position register. ENCLINES is calculated automatically to thie internal resolution of 20 Bit per rev of the encoder. This setting can be used in position mode under EXTPOS=1. The sine/cosine signals of the encoder are read analog. This increases the resolution significantly.
GEARMODE=9 | X1 (HIPERFACE) | The difference to GEARMODE=6 is, that the parameter channel of the encoder is read and the absolute position is transfered to the position register. ENCLINES is calculated automatically to the internal resolution of 20 Bit per rev of the encoder. This setting can be used in position mode under EXTPOS=1. The sine/cosine signals of the encoder are read analog. This increases the resolution significantly.
GEARMODE=10 | X1 (5V ROD) | ROD-encoder as master - slave input (OPMODE = 4)
GEARMODE=25 | X1 (SSI) | SSI at X1
GEARMODE=27 | X1 (5V) | pulse/direction Only digital processing
GEARMODE=30 | X1 (ROD) | ROD (A Quad B) Only digital processing


ASCII English GEARO

ASCII - Command | GEARO |
Syntax Transmit | GEARO [Data] |
Syntax Receive | GEARO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3540 (hex)
DIM | - | PROFIBUS PNU | 1664 (dec) IND = 1 (dec)
Range | 0 .. 2147483647 | DPR | 64 (dec)
Default | 1 |
Opmode | 4 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Output Factor for Electronic Gearing

Description

In master/slave applications (OPMODE=4) this parameter can be used to set the master/slave translation ratio.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

General

Introduction

This documentation explains the use of the DriveGUI.EXE setup software for setting parameters and configuring servo amplifiers. Detailed descriptions of functions and parameters are located in the Object Reference Guide (part of the software's Online Help system).
The setup software must be installed on a personal computer (PC). The PC is connected to the servo amplifier by a communication cable. The setup software initiates the communication between PC and servo amplifier.
With very little effort you can alter parameters and instantly observe the effect on the drive, since there is a continuous (online) connection to the amplifier. At the same time, important actual values are read out from the amplifier and displayed on the monitor of the PC (oscilloscope functions).
Any interface modules (expansion cards), which may be built into the amplifier, are automatically recognized and the additional parameters required for position control or motion-block definition are made available.

You can save sets of data on data media (archiving), and load them again. You can also print out the data sets.

How to use the Online-Help

The Online-Help can be used like an Internet website with links, navigation frame and back/forward buttons.

helpscreen

Navigation

All frames are visible only, if you started the online help from the menu bar of the setup software. If you use Context Help or function key F1, the fulltext search frame and the text frame are visible only. In this case you can restart the help system by clicking the symbol "Home".

Full text search

The button Show/Hide activates/deactivates the full text search frame. Use asterisk or question mark (? or *) as usual with Windows search.

If, despite the SHOW button being pressed, the window in which you enter a search term does not open the first time the help system is called, the search-window column width is preset to “0” by the operating system. In this case, modify the column width by dragging the gray column separator at the left edge of the window, a process with which you should be familiar from WINDOWS.

Used Symbols

Symbol | Indication
 | Indicates a hazardous situation which, if not avoided, will result in death or serious injury.
 | Indicates a hazardous situation which, if not avoided, could result in death or serious injury.
 | Indicates a hazardous situation which, if not avoided, could result in minor or moderate injury.
 | This is not a safety symbol. This symbol indicates situations which, if not avoided, could result in property damage.
 | This is not a safety symbol. This symbol indicates important notes.
 | Warning of a danger (general). The type of danger is specified by the warning text next to it.
 | Warning of danger from electricity and its effects.
 | Warning of danger from hot surfaces.
 | Warning of danger from suspended loads.
 | Warning of danger from automatic start.

Safety

This section helps you to recognize and avoid dangers to people and objects.

You should pay attention to this

Read the documentation!

Read the available documentation for servo amplifier and servo motor before installation and commissioning. Improper handling of the devices can cause harm to people or damage to property. The operator of systems using the must require that all personnel who work with the drive read and understand the manual before using the devices.

Perform a risk assessment!

The manufacturer of the machine must generate a risk assessment for the machine, and take appropriate measures to ensure that unforeseen movements cannot cause injury or damage to any person or property. Additional requirements on specialist staff may also result from the risk assessment.

Specialist staff required!

Only properly qualified personnel are permitted to perform such tasks as transport, installation and setup. Qualified specialist staff are persons with expertise in transport, installation, assembly, commissioning and operation of electrotechnical equipment.

  • Transport, storage, unpacking: only by personnel with knowledge of handling electrostatically sensitive components.
  • Mechanical installation: only by qualified personnel with mechanical expertise.
  • Electrical installation: only by qualified personnel with electrotechnical expertise.
  • Basic tests / setup: only by qualified personnel with expertise in electrical engineering and drive technology.

The qualified personnel must know and observe ISO 12100 / IEC 60364 / IEC 60664 and national accident prevention regulations.

Check Hardware Revision!

Check the Hardware Revision Number of the product (see product label). This number is the link between your product and the manual, it must match the Hardware Revision Number on the cover page of the manual. Check the European "File Archive" if the numbers doesn't match. The archive contains all manual revisions with reference to the Hardware-Revision Number.

Pay attention to the technical data!

Adhere to the technical data and the specifications on connection conditions (rating plate and documentation). If permissible voltage values or current values are exceeded, the devices can be damaged. Unsuitable motor or wrong wiring will damage the system components. Check the combination of drive and motor.

Observe electrostatically sensitive components!

The servo amplifier contain electrostatically sensitive components which may be damaged by incorrect handling. Electrostatically discharge your body before touching the device. Avoid contact with highly insulating materials (artificial fabrics, plastic film etc.). Place the servo amplifier on a conductive surface.

Automatic restart

The drive might restart automatically after power on, voltage dip or interruption of the supply voltage, depending on the parameter setting. Risk of death or serious injury for humans working in the machine.

If the parameter AENA is set to 1, then place a warning sign to the machine (Warning: Automatic Restart at Power On) and ensure, that power on is not possible, while humans are in a dangerous zone of the machine. In case of using an undervoltage protection device, you must observe EN 60204-1:2006 chapter 7.5.

Hot surface!

The surfaces of the servo amplifiers can be hot in operation. Risk of minor burns!
The surface temperature can exceed 80°C. Measure the temperature, and wait until the motor has cooled down below 40°C before touching it.

Earthing!

It is vital that you ensure that the devices are safely earthed to the PE (protective earth) busbar in the switch cabinet. Without low-resistance earthing no personal protection can be guaranteed and there is a risk of death from electric shock.

Leakage Current!

Since the leakage current to PE is more than 3.5 mA, in compliance with IEC61800-5-1 the PE connection must either be doubled or a connecting cable with a cross-section >10 mm² must be used. Deviating measures according to regional standards might be possible.

High voltages!

Ensure that the switching cabinet remains closed while the devices are in operation.

Do not remove any connectors during operation as this may cause electrical arcing, resulting in personal injury and damage to contacts. DC Bus link connections can carry dangerous voltage levels several minutes fter the line voltage has been switched off (self-discharge time).

Wait at least seven minutes after disconnecting the servo amplifier from the main supply power before touching potentially live sections of the equipment (such as contacts) or removing any connections. Capacitors can have dangerous voltages present up to seven minutes after switching off the supply power. Always measure the voltage in the DC bus link and wait until the voltage is below 50 V before handling components.

Reinforced Insulation!

Thermal sensors, motor holding brakes and feedback systems built into the connected motor must have reinforced insulation (according to IEC61800-5-1) against system components with power voltage, according to the required application test voltage.

Check parameters before enabling the servo amplifier

Date saved on SD cards are not safe against unintended third-party changes. After loading a data set, you must always check the parameters before you enable the servo amplifier.

Never modify the servo amplifiers!

It is permissible to use the setup software to alter the settings of the servo amplifier. Any other alterations will invalidate the warranty. Opening the housing causes loss of warranty and all certificates become unvalid.
Warning signs are added to the device housing. If these signs are damaged, they must be replaced immediately.

Use as directed

Servo amplifiers are safety components that are built into electrical plant or machines, and can only be operated as integral components of such plant or machines.

The manufacturer of the machine must generate a risk assessment for the machine, and take appropriate measures to ensure that unforeseen movements cannot cause injury or damage to any person or property.

If the servo amplifiers are used in residential areas, in business and commercial areas, or in small industrial operations, then additional filter measures must be implemented by the user.

Cabinet and Wiring

The servo amplifiers must only be operated in a closed control cabinet, taking into account the ambient conditions defined in the instructions manual. Ventilation or cooling may be necessary to keep the temperature within the cabinet below 40°C.

Use only copper conductors for wiring. The conductor cross-sections can be derived from the standard IEC 60204 (alternatively for AWG cross-sections: NEC Table 310-16, 60°C or 75°C column).

Power supply

Syxx0 : Servo amplifiers in the S3xx0/S7xx0 series (overvoltage category III acc. to EN 61800-5-1) can be supplied from 1-phase or 3-phase grounded (earthed) industrial supply networks (TN-system, TT-system with grounded neutral point, no more than 42kA symmetrical rated current at 110V-10% to 230V+10%).

Syxx6 : Servo amplifiers in the S3xx6/S7xx6 series (overvoltage category III acc. to EN 61800-5-1) can be supplied from 3-phase grounded (earthed) industrial supply networks (TN-system, TT-system with grounded neutral point, no more than 42kA symmetrical rated current at 208V-10%, 230V, 240V, 400V or 480V+10%).

Periodic overvoltage between phases (L1, L2, L3) and the housing of the servo
amplifier must not exceed 1000V crest. In accordance with IEC 61800, voltage spikes (< 50µs) between phases must not exceed 1000V. Voltage spikes (< 50µs) between a phase and the housing must not exceed 2000V.

Motors

The servo amplifiers are exclusively intended for driving suitable brush less synchronous servomotors, asynchronous motors and DC motors with control of torque, speed and/or position.
The rated voltage of the motors must be at least as high as the DC bus link voltage divided by [image] produced by the servo amplifier (UnMotor³ UDC/ [image]).

Safety

The STO function is exclusively intended to provide functional safety, by preventing the restart of a system. To achieve this functional safety, the wiring of the safety circuits must meet the safety requirements of IEC 60204, ISO 12100, IEC 62061 respectively ISO 13849-1.

In case of single channel control: if STO is automatically activated by a control system, then make sure that the output of the control is monitored for possible malfunction.

To achieve PL e or SIL CL3, the safe switching of the pulse inhibitor must be tested periodically by analyzing the feedback signal from the safety control.

Observe the user documentation for safety cards S1/S2/S1-2/S2-2 when you use a safety expansion card.

Prohibited use

Other use than described in chapter Use as Directed is not intended and can lead to damage of persons, equipment or things.

The use of the servo amplifier in the following environments is prohibited:
- potentially explosive areas
- environments with corrosive and/or electrically conductive acids, alkaline solutions, oils, vapors, dusts
- directly on non-grounded supply networks or on asymmetrically grounded supplies with a voltage higher than 240V.
- on ships or off-shore applications

Commissioning the servo amplifier is prohibited if the machine in which it was installed,
- does not meet the requirements of the EC Machinery Directive
- does not comply with the EMC Directive or with the Low Voltage Directive
- does not comply with any national directives

The control of holding brakes by the servo amplifier alone may not be used in applications, where functional safety is to be ensured with the brake.

The STO function must not be used if the drive is to be made inactive for the following reasons :
1. Cleaning, maintenance and repair operations, long inoperative periods: In such cases, the entire system should be disconnected from the supply by the personnel, and secured (main switch).
2. Emergency-Off situations: the mains contactor must be switched off (by the emergency-Off button).

ASCII Object Reference Guide

Integrated in this Online Help is an Object Reference Guide of the servo amplifier's firmware. All functions and parameters are described there with full details.

The reference starts in a single frame: ASCII Object Reference

Servo System Overview

This topic provides a quick lesson in servo system - an overview of what it is and how it works.

What is a Servo System?
A servo system essentially comprises an intelligent servo drive and a servo motor that operates with a PLC or CNC to perform complex, specialized moves in one or more directions, or axes. These complex and specialized moves, which are needed in the automation of industrial tasks, are collectively known as motion control.

Servo systems are applied in many different field for automation - in the motor industry, the petrol industry, the textile industry, in packaging systems, warehousing systems and so on.

Closed Loop Servo Systems
In a servo system, feedback information - motor position and motor velocity is sent from the feedback unit of the motor back to the servo amplifier. The servo amplifier analyses the feedback, makes adjustments as needed, and generates new currents to bring the motor to the commanded velocity. This cycle constantly repeats itself in a closed loop. A closed loop that controls the position of the shaft or load is called a position loop. A closed loop that keeps the velocity of the motor on the commanded value is called a velocity loop.

Servo System Components
A servo system consists of:

Servo motor

A servo motor moves machinery in a single axis of motion.

Electrical motors are driven by magnetic fields. Motors have a stationary field generated by the magnets of the motor and a rotating or movable field called stator winding or armature. They operate on the principles of synchronous motors. All rotary motors have some type of bearing that supports the rotor at each end.

Every motor has at least two magnetic motor poles, normally four or six. The servo amplifier generates the current in the stator so that a controllable torque is available at the shaft.

The servo motors turn (travel) in two directions - positive and negative. Two forms of angular measurement are commonly used in motion control - degree measurement and radian measurement, where 360 degrees constitute one revolution or 2p radians.

The servo amplifier operates with standard synchronous servo motors as well as with direct drive motors (rotary or linear), induction machines and DC motors. For more information about these motors see the motor manuals.

Motor Stabilizing

Stabilizing (tuning) the motor is a fundamental task in achieving best system performance. To stabilize a motor, you must set up initial values for and adjust several motion parameters using DriveGUI.EXE. These parameter settings compensate for the difference between the actual motion and the commanded motion - getting the actual as close to the commanded as possible, with minimal oscillation and noise. This difference is called following error. Observe the application notes for Setup unknown motors.

Load

The load is the machinery and equipment that each motor drives. It is everything connected to the output shaft of a motor, including the shaft itself. A motor must be appropriately sized to its load to ensure the motor is powerful enough to carry out your automation tasks. A servo system delivers and converts motion to a load via one or more of the following mechanical techniques:

Direct drive
motor connected to a rotating table

Screw drive
motor connected to a lead screw carrying a slide (moving table)

Rack and pinion
motor connected to a cogwheel that moves a rack

Belt and pulleys
motor connected to rollers that move conveyor belts or chains and sprockets

Feedback device

Every closed-loop servo system needs at least one device to return feedback information from each motor (or load) to servo amplifiers . Depending on the feedback device, feedback is transmitted back to the servo drive in the form of digital signals or analog signals. Two types of feedback devices are supported:

Encoder - returns analog or digital signals (optical)

Resolver - returns analog signals (magnetical)

Servo amplifier

The servo amplifiers comprise a three-phase, power supply, and high-performance control unit all housed in a single enclosure. The several control loops are realize totally digital in the micro controller.

Feedback Device

Servo motors are available with these feedback units:

  • RESOLVER
  • Encoder (different types)
  • Incremental encoder with HALL

In a closed-loop feedback system, the innermost loop is the commutation loop, which monitors the motor's rotor and ensures that it keeps spinning. Outer loops are: Position loop, Velocity loop and Current loop
Velocity information and the velocity loop are derived from (are computed based on) position information.
The current loop is also known as a torque loop, since amplitude of the electrical current is directly proportional to torque. Torque is force applied in an axis of rotation. All available feedback systems are listed in the KDN on page Multi-Feedback.

Resolvers
The servo amplifier can use single (two poles) or multi-speed (multiple poles) resolver feedback to calculate primary position, velocity, and commutation information. A resolver can be thought of as a transformer whose output is unique for any given shaft position (an absolute position feedback). The transformer is driven with a sinewave reference signal. Two AC signals are returned from the resolver into the Sine and Cosine inputs. All three of these sinewave signals are low-level and susceptible to noise.

Encoders
Encoders direct pulses of light, from a light source at the motor or load, to photo detectors through an encoded disk. These light pulses are then converted into digital feedback information. There are two general types of encoders - rotary and linear. Rotary (rotating disk) encoders are typically mounted to the motor shaft. Linear encoders are typically mounted to the load.

The Motion Profile

Overview
Motion operations are universally embodied in a graph called the motion profile. Understanding and using motion profiles to define your motion application is an important part of achieving best system performance.

The motion profile plots one or more motion operations and measures it against time.

Commanded motion: the motion that is supposed to happen ideally and precisely, without error, when the motor executes a velocity or position command

Actual motion: the motion that really happens in the motor, when a velocity or position command is executed

Closing the Gap between Setpoint and Actual
Best system performance is achieved when you can stabilize or "dampen" the difference or "close the gap" between the commanded motion and the actual motion. This difference is called following error. Stabilizing the servo system means setting the relevant parameters in the servo amplifier, to get as close to the commanded position as possible.

Basic Motion Profile Characteristics
Commanded and actual motion profile shapes have the following characteristics that are also universal to all motion operations:

Profile Characteristic | Meaning
Moving | Moving refers to the execution of a motion instruction that makes the motor move. A motion profile's moving portion represents most of the profile - the motion itself. The motor is considered moving for as long as the motion controller is commanding new positions. The point at which motion stops is known as the target position.
In Position | When a motion command stops executing, and the motor slows to within a few counts of its target position, the motor is considered to be stopped, or "In Position." A range of positions, typically plotted in a motion profile, represents in position. That is, In Position is signaled when the motor gets close enough to the target position -- within its In-Position range that you have specified, via its parameter. An In-Position signal is often used to make sure the motor stops before the machinery continues its operation.

Limits and Ranges of Operation

Overview
Another important task in achieving best system performance is setting certain motion limits and ranges of operation to protect equipment from damage and to optimize operational efficiency.

Two Types of Settings
There are two types of settings for motion limits and ranges of operation:

Type of Setting | Meaning
Fault limit | Fault limits are settings that signal errors when certain limits on motor movement, such as speed and position, as well as electrical current, are exceeded. Fault limits are designed to protect equipment from damage and can cause the drive and motor to shut down. For example, every motion control system has hardware limit switches, which are used in the position loop to set a limit on how far the actual motor position can deviate from the commanded position before a fault is signaled. You may also program software limits. The difference, or gap, between commanded position and actual position is known as following error. Such a limit protects against motor runaway and stalling.
Tolerance band | Tolerance bands are set and specify the safe, efficient physical ranges for the equipment. Some of these tolerance bands do the following: — In the current loop, set a limit on the amount of electrical current to the drive and motor. This protects the motor from damage that would be caused by excessive current. — In the position loop, place a limit on how far the motor can travel in a positive or negative direction. — Set a range of positions that are considered to be In Position. That is, this range specifies how far the motor can deviate from its commanded position and still be considered in the correct position.

Acceleration and Deceleration

Overview
If the servo amplifier is operated with motion tasks under position control, different acceleration/deceleration profiles can be chosen. It depends on the mechanical structure of the machine and the required dynamical quality, which profile should be chosen. If the machine tends to sway (e.g. robot arm), sine² would be the best choice. Here the torque is altered linear and the velocity characteristic becomes square. This reduces the excitation to sway. Disadvantage of this profile is the double up of the acceleration/deceleration time.
If the machine is mechanically stiff and there are high requirements in dynamics, the linear profile should be chosen. This leads to a torque step at the beginning and the end of each acceleration/deceleration ramp.

Two Types of Acceleration and Deceleration
The following table describes the two fundamental acceleration and deceleration types, linear and square.
A motion profile may accommodate a combination of these two types.

Type | Description
Trapezoidal | Trapezoidal is a rate of acceleration and deceleration that represents a steady speed-up and slow-down.
Sine² | To limit any jolting, the drive is accelerated/decelerated within the acceleration time along an acceleration ramp without any discontinuities. The resulting speed characteristic corresponds to a sine² curve.

Further acceleration curves are stored in profile tables. You can create your own profile tables, information for that can be found in the KDN.


ASCII English GET

ASCII - Command | GET |
Syntax Transmit | GET |
Syntax Receive | GET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 3541 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 1 (dec)
Range | - | DPR | 65 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: output data

Description

The GET command returns a list with all the most recently recorded SCOPE data. The list consists of n+3 lines (n = no. items of data recorded)
Line 1: commentary e.g. “Drive Recording”
Line 2: n, timebase in msec e.g. 10, 0.25 (10 data lines, timebase 250 microseconds)
Line 3: var1, var2, var3 names of the recorded variables, e.g. VCMD, V, ICMD
Line 4: data1, data2, data3 recorded data, e.g. 0, 20.3, -0.5
Line 5: data1, dat2, data3
..
Line 1: data1, data2, data3

see also RECORD, RECTRIG


ASCII English GF

ASCII - Command | GF |
Syntax Transmit | GF [Data] |
Syntax Receive | GF <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 ... 10 | DPR | No
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | proportional gain of the flux controller

Description

GF is a parameter for the base speed range of the induction maschine. The default values for GF respectively for GF 1ms. Normally, they can be left at these values, as the rotor's flow only reacts very slowly.

Please have a look to GFTN


ASCII English GFTN

ASCII - Command | GFTN |
Syntax Transmit | GFTN [Data] |
Syntax Receive | GFTN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 3907 (hex)
DIM | ms | PROFIBUS PNU | 1831 (dec) IND = 33 (dec)
Range | 1 .. 32000 | DPR | No
Default | 150 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 2.11
Function Group | other commands | EEPROM | Yes
Short Description | time constant flow controlinduction maschine)

Description

GFTN is a parameter for the base speed range of the induction maschine. The default values for GF respectively for GFTN 150ms. Normally, they can be left at these values, as the rotor's flow only reacts very slowly.

Please have a look to GF


ASCII English GP

ASCII - Command | GP |
Syntax Transmit | GP [Data] |
Syntax Receive | GP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3542 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1666 (dec) IND = 1 (dec)
Range | 0.1 ... 1000 | DPR | 66 (dec)
Default | 0.1 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | position loop | EEPROM | Yes
Short Description | Position Control Loop: Proportional Gain

Description

This variable is the proportional gain of the position control loop . If GP is set too low, the lag or settling time is too long and the drive is too soft. If GP is set too high, the drive oscillates.

If the parameters (GP=GP2) are eqaul, the interpolation is switched off which is the case by default. As long as they are equal, a change of GP leads to an automatic change of GP2, so that they remain the same. Only when GP2 is set once at a value other than GP, pairing is dissolved and both parameters can be modified separately. By setting GP2 to GP parameter coupling is activated again.

Who does not need the interpolation function and only use GP, the existence of GP2 will not even notice.


ASCII English GP2

ASCII - Command | GP2 |
Syntax Transmit | GP2 [Data] |
Syntax Receive | GP2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C3 (hex)
DIM | VUNIT | PROFIBUS PNU | 1763 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 963 (dec)
Default | 0.1 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.10
Function Group | position loop | EEPROM | Yes
Short Description | proportional gain for the velocity higher than GPS2

Description

GP2 is a paramter of th position loop and is the proportional gain for the velocity higher than GPS2

If the parameters (GP=GP2) are eqaul, the interpolation is switched off which is the case by default. As long as they are equal, a change of GP leads to an automatic change of GP2, so that they remain the same. Only when GP2 is set once at a value other than GP, pairing is dissolved and both parameters can be modified separately. By setting GP2 to GP parameter coupling is activated again.

Who does not need the interpolation function and only use GP, the existence of GP2 will not even notice.


ASCII English GP_X

ASCII - Command | GP_X |
Syntax Transmit | GP_X [Data] |
Syntax Receive | GP_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3761 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1809 (dec) IND = 17 (dec)
Range | 0.1 ... 1000 | DPR | 609 (dec)
Default | 0.1 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | position loop | EEPROM | Yes
Short Description | Position Control Loop: Proportional Gain 2

Description

see PARCNFG


ASCII English GPDELAY

ASCII - Command | GPDELAY |
Syntax Transmit | GPDELAY [Data] |
Syntax Receive | GPDELAY <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38AF (hex)
DIM | ms | PROFIBUS PNU | 1743 (dec) IND = 33 (dec)
Range | 0 .. 16 | DPR | 943 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM |
Short Description | delay for external position set point

Description

GPDELAY = 0: no delay (default)
GPDELAY >0 (in msec): delay for proportional and integral part of the position loop (highest resolution 0.0625 msec).

The external position set point (macro variable NEWPOS) received via fieldbus or macro application is used for microinterpolation and calculation of the internal position set point (macro variable S_SETL). This information is also used for calculation of the velocity feed forward, acceleration feed forward and position error. For GPDELAY>0 the source for the position error calculation is delayed by the configured parameter GPDELAY. This means: the feed forward commands are calculated with the real position profile S_SETL and the proportional and integral parts of the position loop are feed with the delayed profile S_SETT.


ASCII English GPFFT

ASCII - Command | GPFFT |
Syntax Transmit | GPFFT [Data] |
Syntax Receive | GPFFT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3544 (hex)
DIM | - | PROFIBUS PNU | 1668 (dec) IND = 1 (dec)
Range | 0 ... 2147480 | DPR | 68 (dec)
Default | 1 |
Opmode | 4,5,8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.1
Function Group | position loop | EEPROM | Yes
Short Description | Position control loop: feed forward for the current setpoint

Description

Position control loop: feed forward for the current setpoint.
Has to be set, that the following error is minimized.

This parameter has effect for control structure only in the following cases:
1.using table based motion task enabled with bit in O_C. ;
2.using sine squared acceleration and deceleration motion profiles.

If GV is changed after optimizing GPFFT, GPFFT has to be changed also inversely proportional.


ASCII English GPFFT_X

ASCII - Command | GPFFT_X |
Syntax Transmit | GPFFT [Data] |
Syntax Receive | GPFFT_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3762 (hex)
DIM | - | PROFIBUS PNU | 1810 (dec) IND = 17 (dec)
Range | 0 ... 2147480 | DPR | 610 (dec)
Default | 1 |
Opmode | 4,5,8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | Yes
Short Description | Position control loop: feed forward for the current setpoint 2

Description

see PARCNFG


ASCII English GPFFTV

ASCII - Command | GPFFTV |
Syntax Transmit | GPFFTV [Data] |
Syntax Receive | GPFFTV <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 386A (hex)
DIM | - | PROFIBUS PNU | 1674 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 874 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | position loop | EEPROM | Yes
Short Description | Viscous friction compensation

Description

This current feed forward is generated from the internal trajectory speed value and is valid for all all position loop modes (OPMODE=4...8). This setting is valid only for extenden feed forware functionality (FFTSW=2).


ASCII English GPFFV

ASCII - Command | GPFFV |
Syntax Transmit | GPFFV [Data] |
Syntax Receive | GPFFV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3545 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 1 (dec)
Range | 0 ... 1000 | DPR | 69 (dec)
Default | 1 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.4
Function Group | position loop | EEPROM | Yes
Short Description | Position Control Loop: Feed Forward for Velocity

Description

This variable is used in the position control loop. Feed forward is used to ease the position controller task. A better setting for GPFFV means better utilization of the dynamic range of the position controller. The most favorable setting (usually about 1.0), depends on factors external to the drive such as friction, dynamic resistance, and stiffness. If GPFFV is set too low, the drive lags. If GPFFV is set too high, the drive oversteers.


ASCII English GPFFV_X

ASCII - Command | GPFFV_X |
Syntax Transmit | GPFFV [Data] |
Syntax Receive | GPFFV_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3763 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 17 (dec)
Range | 0 ... 1000 | DPR | 611 (dec)
Default | 1 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | position loop | EEPROM | Yes
Short Description | Position Control Loop: Feed Forward for Velocity 2

Description

see PARCNFG


ASCII English GPFFVDELAY

ASCII - Command | GPFFVDELAY |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 38AC (hex)
DIM | - | PROFIBUS PNU | 1740 (dec) IND = 33 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English GPS1

ASCII - Command | GPS1 |
Syntax Transmit | GPS1 [Data] |
Syntax Receive | GPS1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C4 (hex)
DIM | VUNIT | PROFIBUS PNU | 1764 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 964 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | low velocity threshold (position loop)

Description

The parameter GPS1 is the low velocity threshold in the position loop VUNIT.

For velocity values between GPS1 and GPS2 there is a linear interpolation between GP and GP2


ASCII English GPS2

ASCII - Command | GPS2 |
Syntax Transmit | GPS2 [Data] |
Syntax Receive | GPS2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C5 (hex)
DIM | VUNIT | PROFIBUS PNU | 1765 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 965 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | high velocity threshold (position loop)

Description

The parameter GPS2 is the high velocity threshold in the position loop VUNIT

For velocity values between GPS1 and GPS2 there is a linear interpolation between GP and GP2


ASCII English GPTN

ASCII - Command | GPTN |
Syntax Transmit | GPTN [Data] |
Syntax Receive | GPTN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38B1 (hex)
DIM | position loop cycle time | PROFIBUS PNU | 1745 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 945 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | integral gain of the PI position loop

Description

Parameter GPTN defines the integral gain of the PI position loop (unit depends on DPWM in µsec).

GPTN=0 (default): integral part switched off
GPTN>0: integral part switched on

please have a look DPWM


ASCII English GPTN_X

ASCII - Command | GPTN_X |
Syntax Transmit | GPTN_X [Data] |
Syntax Receive | GPTN_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38B2 (hex)
DIM | position loop cycle time | PROFIBUS PNU | 1746 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 946 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | integral gain of the PI position loop

Description

Parameter GPTN defines the integral gain of the PI position loop (unit depends on DPWM in µsec).

GPTN=0 (default): integral part switched off
GPTN>0: integral part switched on

please have a look DPWM

-------------------------------------------------------------------------------------------

Switching over parameter sets is realized with a pointer, which always points to one of the two parameter structures (parameter set 1: default or parameterset 2: shadow parameters). While switching the pointer between these two structures all parameters that are defined in the structures are switched over in parallel. Because the parameters are already converted in the structures, it is avoided that undefined conditions occure.

The parameters of the second parameter set are defined similarly to the major parameter set by ASCII commands. To define the second parameter set, the sequence "_X" must be added to the ASCII command.

Example:
The command "GV" is used to define the gain of the velocity controller. To change this parameter in the second parameter set the command "GV_X" must be used.

To save memory in the amplifier, only those parameters are stored in the second set, which differ from the first parameter set. If no parameter is preset for the second set, thes econd set is initialised automatically identical to the first set. The user must therefore only define the rerquired parameters for the second set, not all parameters.

The automatical initialising of the second parameters set always requires an update of the set, if a parameter of the first set has been changed. This could result in a reset of special second set parameters. To avoid this, the parameterizing of the second set must always been done after initializing the first set.

As soon as PAR_X gets a different value than PAR,this parameter is saved in the serial EEPROM. The value of PAR_X now appears in the DUMP list at the end of the parameter section.

All parameters that can be used for this functionality can be listed combined with their values by the command PARDUMP.


ASCII English GPTNTH1

ASCII - Command | GPTNTH1 |
Syntax Transmit | GPTNTH1 [Data] |
Syntax Receive | GPTNTH1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38A7 (hex)
DIM |  | PROFIBUS PNU | 1735 (dec) IND = 33 (dec)
Range | 0 .. 16000 | DPR | 935 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | integral part threshold for velocity set point

Description

GPTNTH1 (in VUNIT) integral part threshold for velocity set point. The integral part of the position loop is activated when the velocity set point falls below the threshold value.

Have a look to GPTN, GPTNTH2, GPTNTH3


ASCII English GPTNTH2

ASCII - Command | GPTNTH2 |
Syntax Transmit | GPTNTH2 [Data] |
Syntax Receive | GPTNTH2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38A8 (hex)
DIM |  | PROFIBUS PNU | 1736 (dec) IND = 33 (dec)
Range | 0 .. 16000 | DPR | 936 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | integral part threshold for velocity actual value

Description

GPTNTH2 (in VUNIT) integral part threshold for velocity actual value. The integral part of the position loop is activated when the velocity actual value falls below the threshold value.

Have a look to GPTN, GPTNTH1, GPTNTH3


ASCII English GPTNTH3

ASCII - Command | GPTNTH3 |
Syntax Transmit | GPTNTH3 [Data] |
Syntax Receive | GPTNTH3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38A8 (hex)
DIM |  | PROFIBUS PNU | 1652 (dec) IND = 17 (dec)
Range | 0 .. 2147483647 | DPR | 460 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | integral part threshold for following error

Description

GPTNTH3 (in PUNIT) integral part threshold for following error. The integral part of the position loop is activated when the following error falls below the threshold value.

Have a look to GPTN, GPTNTH1, GPTNTH2


ASCII English GU

ASCII - Command | GU |
Syntax Transmit | GU [Data] |
Syntax Receive | GU <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 32000 | DPR | No
Default | 1000 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | proportinal gain for field weakening

Description

GU is a paramter for using a asycron maschine and describes the proportional gain of the voltage controler for the field weakening.


ASCII English GUTN

ASCII - Command | GUTN |
Syntax Transmit | GUTN [Data] |
Syntax Receive | GUTN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 10 | DPR | No
Default | 0.1 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | time constant of field weakening

Description

GUTN is a paramter for using a asycron maschine and describes the time constant (in ms) of the voltage controler for the field weakening.


ASCII English GV

ASCII - Command | GV |
Syntax Transmit | GV [Data] |
Syntax Receive | GV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3548 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 1 (dec)
Range | variable | DPR | 72 (dec)
Default | variable |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity Control Loop: Proportional Gain

Description

GV gives the proportional (ac) gain of the velocity control loop. This also affects GVTN. The dimension is As/rad

GV(default) = DISCALE / 325
GV(max) = (40000 * DISCALE) / 325

DISCALE – depend on the current scaling of the amplifier (type in „M DISCALE“ in the terminal)

example:
S706: max. current = 3*6A = 18 A
GV(default) = 18/325 = 0.055
GV(max) = (40000 * 18)/325 = 2215

If the parameter (GM = GV2) is equal, the interpolation is switched off which is the case by default. As long as they are equal, a change of GM leads to an automatic change of GV2, so that they remain the same. Only when GV2 is set once at a value other than GM, the coupling is resolved and both parameters can be modified separately. By setting GV2 GV parameter coupling is activated again.

Who does not need the interpolation function and just use GV, the existence of GV2 will not even notice.


ASCII English GV2

ASCII - Command | GV2 |
Syntax Transmit | GV2 [Data] |
Syntax Receive | GV2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C6 (hex)
DIM | VUNIT | PROFIBUS PNU | 1766 (dec) IND = 33 (dec)
Range | variable | DPR | 966 (dec)
Default | variable |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | proportional gain for the velocity higher than GVS2

Description

The parameter GV2 is a velocity loop paramter and is the proportional gain for the velocity higher than GVS2

If the parameter (GM = GV2) is equal, the interpolation is switched off which is the case by default. As long as they are equal, a change of GM leads to an automatic change of GV2, so that they remain the same. Only when GV2 is set once at a value other than GM, the coupling is resolved and both parameters can be modified separately. By setting GV2 GV parameter coupling is activated again.

Who does not need the interpolation function and just use GV, the existence of GV2 will not even notice.


ASCII English GV_X

ASCII - Command | GV_X |
Syntax Transmit | GV [Data] |
Syntax Receive | GV_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3760 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 17 (dec)
Range | variable | DPR | 608 (dec)
Default | variable |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity Control Loop: Proportional Gain 2

Description

siehe PARCNFG


ASCII English GVFR

ASCII - Command | GVFR |
Syntax Transmit | GVFR [Data] |
Syntax Receive | GVFR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 354B (hex)
DIM | - | PROFIBUS PNU | 1675 (dec) IND = 1 (dec)
Range | 0.0 .. 1.0 | DPR | 75 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.00 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | PI-PLUS Actual Velocity Feedforward

Description

GVFR is a tuning variable of the velocity control loop which sets the feed-forward to feedback gain ratio for the Pseudo Derivative Feedback with Feed-Forward. (PDFF or PI+) . With GVFR 1 the behavior of the velocity control loop is like a standard PI controller. GVFR 0.65 is a value which suppresses step response overshoot.


ASCII English GVFR_X

ASCII - Command | GVFR_X |
Syntax Transmit | GVFR [Data] |
Syntax Receive | GVFR_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 375E (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 17 (dec)
Range | 0.0 .. 1.0 | DPR | 606 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.00 |
Configuration | No | Last Change of this Object | 1.8
Function Group | velocity loop | EEPROM | Yes
Short Description | PI-PLUS Actual Velocity Feedforward

Description

see PARCNFG


ASCII English GVS1

ASCII - Command | GVS1 |
Syntax Transmit | GVS1 [Data] |
Syntax Receive | GVS1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1767 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 967 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | velocity loop | EEPROM | Yes
Short Description | low velocity threshold (velocity loop)

Description

The parameter GVS1 is the lower velocity threshold in velocity loop and is displayed in VUNIT

For velocity values between GVS1 and GVS2 there is a linear interpolation between GV and GV2.


ASCII English GVS2

ASCII - Command | GVS2 |
Syntax Transmit | GVS2 [Data] |
Syntax Receive | GVS2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38C8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1768 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 968 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | velocity loop | EEPROM | Yes
Short Description | high velocity threshold (velocity loop)

Description

The parameter GVS2 is the high velocity threshold in velocity loop and is displayed in VUNIT

For velocity values between GVS1 and GVS2 there is a linear interpolation between GV and GV2.


ASCII English GVTN

ASCII - Command | GVTN |
Syntax Transmit | GVTN [Data] |
Syntax Receive | GVTN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 354D (hex)
DIM | ms | PROFIBUS PNU | 1677 (dec) IND = 1 (dec)
Range | 0.0 , GV/62.5 .. 1000.0 | DPR | 77 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity Control Loop: I-Integration Time

Description

This variable determines the integral-action time/integral time constant. Smaller motors permit shorter integration times. Larger motors or high moments of inertia in the load usually require integration times of 20ms or more. With GVTN=0ms, the I-component is switched off. If the GVTN value is too low, the drive runs roughly or strongly overshoots with high inertia loads. If the GVTN value is too high, the drive is too soft.


ASCII English GVTN_X

ASCII - Command | GVTN_X |
Syntax Transmit | GVTN [Data] |
Syntax Receive | GVTN_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 375F (hex)
DIM | ms | PROFIBUS PNU | 1807 (dec) IND = 17 (dec)
Range | 0.0 , GV/62.5 .. 1000.0 | DPR | 607 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity Control Loop: I-Integration Time 2

Description

siehe PARCNFG


ASCII English GVTV

ASCII - Command | GVTV |
Syntax Transmit | GVTV [Data] |
Syntax Receive | GVTV <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38FD (hex)
DIM | ms | PROFIBUS PNU | 1821 (dec) IND = 33 (dec)
Range | 0 .. 20000 | DPR | 1021 (dec)
Default | 0 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | preservation time of the volume flow controller

Description

This parameter can be used to configure the preservation time of the flow controller (PID2).


ASCII English HALLDIR

ASCII - Command | HALLDIR |
Syntax Transmit | HALLDIR [Data] |
Syntax Receive | HALLDIR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3550 (hex)
DIM | - | PROFIBUS PNU | 1680 (dec) IND = 1 (dec)
Range | -1 .. 1 | DPR | 80 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.00 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | Yes
Short Description | Hall segment table number

Description

In the S300 firmware there are 2 tables with hall segment numbers.

HALLDIR = 0: order of hall segments 1,5,4,6,2,3
HALLDIR = 1: order of hall segments 1,3,2,6,4,5

The correct table number can be determined by moving the motor in the positive direction (velocity > 0)
And checking the order of the hall segments with the macro command (M SR_HALL).


ASCII English HALLENDIR

ASCII - Command | HALLENDIR |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English HDSLLED

ASCII - Command | HDSLLED |
Syntax Transmit | HDSLLED |
Syntax Receive | HDSLLED <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3919 (hex)
DIM | 0,1 mA | PROFIBUS PNU | 1849 (dec) IND = 33 (dec)
Range | 32 bit | DPR | 1049 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | LED current of the optical unit in Hiperface DSL encoder

Description

With a connected and configured Hiperface DSL encoder (FBTYPE = 35), the LED current of the optical unit in the encoder feedback can be read out for diagnostic purposes. The unit is 0.1 mA.


ASCII English HDSLPOS

ASCII - Command | HDSLPOS |
Syntax Transmit | HDSLPOS |
Syntax Receive | HDSLPOS <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer64 | CANBus Object Number | -
DIM | counts | PROFIBUS PNU | -
Range | 64 bit | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Integer64
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | position read from the Hiperface DSL encoder

Description

For a connected and configured Hiperface DSL feedback (FBTYPE=35), the HDSLPOS command can be used to display the position read from the encoder. This position is displayed in the internal encoder units and should only be used for diagnostic purposes.


ASCII English HDSLRANGE

ASCII - Command | HDSLRANGE |
Syntax Transmit | HDSLRANGE |
Syntax Receive | HDSLRANGE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Hiperface DSL encoder limits

Description

For a connected and configured Hiperface DSL encoder (FBTYPE = 35), the HDSLRANGE command provides minimum and maximum values for specific operating variables. The following values are provided (in the order given):

- Minimum transducer temperature in 0.1 ° C
- Maximum transducer temperature in 0.1 ° C
- Minimum LED current in 0.1 mA
- Maximum LED current in 0.1 mA
- Minimum supply voltage in mV
- Maximum supply voltage in mV
- Maximum speed in UPM
- Maximum acceleration in 1000 rad / sec2


ASCII English HDSLROTAT

ASCII - Command | HDSLROTAT |
Syntax Transmit | HDSLROTAT |
Syntax Receive | HDSLROTAT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 391D (hex)
DIM | rpm | PROFIBUS PNU | 1853 (dec) IND = 33 (dec)
Range | 32 bit | DPR | 1053 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Total number of detected encoder revolutions

Description

For a connected and configured Hiperface DSL encoder (FBTYPE = 35), the HDSLROTAT command supplies the total number of detected revolutions stored in the encoder. This value can be used for diagnostic purposes.


ASCII English HDSLTEMP

ASCII - Command | HDSLTEMP |
Syntax Transmit | HDSLTEMP |
Syntax Receive | HDSLTEMP <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3918 (hex)
DIM | 0,1 °C | PROFIBUS PNU | 1848 (dec) IND = 33 (dec)
Range | 32 bit | DPR | 1048 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | Motor / Encoder temp. from the Hiperface DSL encoder Motor / Encoder temperature from the Hiperface DSL encoder

Description

For a connected and configured Hiperface DSL encoder (FBTYPE = 35) the encoder / motor temperature is transmitted in addition to the position. The unit is 0.1 ° C. This temperature is used to monitor the motor temperature. This value can also be displayed as TEMPM (in °C).


ASCII English HDSLTIME

ASCII - Command | HDSLTIME |
Syntax Transmit | HDSLTIME |
Syntax Receive | HDSLTIME <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 391C (hex)
DIM | Minuten | PROFIBUS PNU | 1852 (dec) IND = 33 (dec)
Range | 32 bit | DPR | 1052 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | counter of operating hours of the Hiperface DSL encoder

Description

The HDSLTIME command provides the operating time of the encoder (in minutes) for a connected and configured Hiperface DSL encoder (FBTYPE = 35). The time is recorded in the encoder and stored in a fixed value memory every 20 minutes. It should only be used for diagnostic purposes.


ASCII English HDSLTYPE

ASCII - Command | HDSLTYPE |
Syntax Transmit | HDSLTYPE |
Syntax Receive | HDSLTYPE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | No
Short Description | Hiperface DSL encoder data (nameplate)

Description

For a connected and configured Hiperface DSL encoder (FBTYPE = 35), the HDSLTYPE command provides resolution, type designation and hardware / software version of the HDSL encoder. The following values are provided (in the order given):

- feedback type
0 = rotatory bipolar
1 = linear bipolar
2 = rotatory unipolar
3 = linear unipolar
- encoder resolution (in counts per revolution)
- Number of detected revolutions (multiturn / singleturn)
- Encoder name as ASCII string
- Serial number
- Hardware and firmware version
- Firmware date
- Size of the internal EEPROM in bytes


ASCII English HDSLVEL

ASCII - Command | HDSLVEL |
Syntax Transmit | HDSLVEL |
Syntax Receive | HDSLVEL <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 391B (hex)
DIM | rpm | PROFIBUS PNU | 1851 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 1051 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | actual velocity of the Hiperface DSL encoder

Description

For a connected and configured Hiperface DSL encoder (FBTYPE = 35), the HDSLVEL command provides the current speed of the encoder. The supplied value is inaccurate and should only be used for diagnostic purposes.


ASCII English HDSLVOLT

ASCII - Command | HDSLVOLT |
Syntax Transmit | HDSLVOLT |
Syntax Receive | HDSLVOLT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 391A (hex)
DIM | 1 mV | PROFIBUS PNU | 1850 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 1050 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | No
Short Description | supply voltage of the Hiperface DSL encoder

Description

At a connected and configured Hiperface DSL encoder (FBTYPE = 35), the value of the supply voltage of the encoder can be read out for diagnostic purposes. The unit is 1 mV.


ASCII English HDUMP

ASCII - Command | HDUMP |
Syntax Transmit | HDUMP |
Syntax Receive | HDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Output all sin/cos (Hiperface) variables

Description

List all sincos feedback variables stored in the encoders memory. (Hyperface or Endat)


ASCII English HELP

ASCII - Command | HELP |
Syntax Transmit | HELP |
Syntax Receive | HELP <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Output Parameter Help Information

Description

Using the parameter HELP <name> produces a display of help information for the ASCII parameter “name”. This help information includes input limits and both the actual and default values for the parameter.
e.g. HELP GV
GV act=6 min=0 max=1000 default=1


ASCII English HICOFFS

ASCII - Command | HICOFFS | For Manufacturer Use only
Syntax Transmit | HICOFFS [Data] |
Syntax Receive | HICOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3552 (hex)
DIM | mV | PROFIBUS PNU | 1682 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 82 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Hiperface: Cosine-Offset (incremental track)

Description

The HICOFFS command sets the offset correction (in mV) for the cosine signal of the incremental track.
The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HICOFFS setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HIFACT1

ASCII - Command | HIFACT1 | For Manufacturer Use only
Syntax Transmit | HIFACT1 [Data] |
Syntax Receive | HIFACT1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3553 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 1 (dec)
Range | 10000 .. 32767 | DPR | 83 (dec)
Default | 16384 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Encoder
Short Description | Hiperface: Sin/Cos Gain Factor (incremental track)

Description

The HIFACT1 command sets the amplitude scaling for the sine signal of the absolute track (SinCoder). The amplitude scaling is for the value 16384 = 1.

The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HIFACT1 setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HISOFFS

ASCII - Command | HISOFFS | For Manufacturer Use only
Syntax Transmit | HISOFFS [Data] |
Syntax Receive | HISOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3554 (hex)
DIM | mV | PROFIBUS PNU | 1684 (dec) IND = 1 (dec)
Range | -10000 .. 10000 | DPR | 84 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Encoder
Short Description | Hiperface: Sin/Cos Offset (incremental track)

Description

The HISOFFS command sets the offset correction (in mV) for the sine signal of the incremental track.
The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HISOFFS setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HLIMIT1

ASCII - Command | HLIMIT1 |
Syntax Transmit | HLIMIT1 [Data] |
Syntax Receive | HLIMIT1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3896 (hex)
DIM |  | PROFIBUS PNU | 1718 (dec) IND = 33 (dec)
Range | 0...2147483647 | DPR | 918 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 3.62 |
Configuration | No | Last Change of this Object | 2.8
Function Group | position loop | EEPROM | Yes
Short Description | Software limit switch 1 for homing move

Description

The parameter HLIMIT1 offers the possibility to limitate the move of the drive during the homing move.
This parameter defines the maximal distance between the start point of the homing move and the position
of the reference switch or hardware limit switch. When the reference switch is not reached within the distance
HLIMIT1, the error F26 (Limit switch) is generated.

HLIMIT2,HLIMIT3,ERRCODE *


ASCII English HLIMIT2

ASCII - Command | HLIMIT2 |
Syntax Transmit | HLIMIT2 [Data] |
Syntax Receive | HLIMIT2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3897 (hex)
DIM |  | PROFIBUS PNU | 1719 (dec) IND = 33 (dec)
Range | 0...2147483647 | DPR | 919 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 3.62 |
Configuration | No | Last Change of this Object | 2.8
Function Group | position loop | EEPROM | Yes
Short Description | Software limit switch 2 for homing move

Description

The parameter HLIMIT2 offers the possibility to limitate the move of the drive during the homing move.
This parameter defines the maximal distance between the start point of the homing move and the position
of the reference switch or hardware limit switch. When the reference switch is not reached within the distance
HLIMIT2, the error F26 (Limit switch) is generated.

HLIMIT1,HLIMIT3,ERRCODE *


ASCII English HLIMIT3

ASCII - Command | HLIMIT3 |
Syntax Transmit | HLIMIT3 [Data] |
Syntax Receive | HLIMIT3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3898 (hex)
DIM |  | PROFIBUS PNU | 1720 (dec) IND = 33 (dec)
Range | 0...2147483647 | DPR | 920 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 3.62 |
Configuration | No | Last Change of this Object | 2.8
Function Group | position loop | EEPROM | Yes
Short Description | Software limit switch 3 for homing move

Description

The parameter HLIMIT3 offers the possibility to limitate the move of the drive during the homing move.
This parameter defines the maximal distance between the hardware limit switch or reference switch and the position of external zero pulse (REFMODE>0). If the drive reaches this limit before the zero pulse was recognized, the error F26 (Limit swich) is generated.

HLIMIT1,HLIMIT2,ERRCODE *,REFMODE


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Homing

einrichten

Homing (reference traverse) is an absolute task that is used to zero the drive for subsequent positioning operations. You can choose between various types of homing.

After homing, the drive reports "InPosition" and then enables the position controller in the servo amplifier.

The limit switch functions: 2, PSTOP and 3, NSTOP must be activated for digital inputs 3 or 4 to achieve full homing functionality.

Be sure that the zero point of the machine (reference point) is in a position that allows the subsequent positioning operations. The software limit-switches that were set as parameters may be ineffective. The axis could move to the hardware limit-switch or even the mechanical stop. There is a risk of damage.

If the reference point (machine zero point) is approached at high inertia with excessive velocity, it can be run over and the axis moves in the worst case up to the hardware limit-switch or the mechanical stop. There is a risk of damage.

Without homing the position controller can not be operated with internal motion tasks. After switching on the 24V auxiliary voltage, homing must be performed.

During homing the start signal must not be taken away. The start signal must remain present until the “InPosition” message appears.

When homing is started, then the SW Enable is set automatically. Homing is started in OPMODE 8 only, but the SW Enable is set in all OPMODES. Therefore the drive accelerates depending on a given analog setpoint, if the START command is executed in OPMODE 1 or OPMODE 3 .

Homing Type (NREF)

You can choose which type of homing should be performed.

No | Function | Reference point is
0 | Set Home Reference immediately | the setpoint position
1 | Home Switch and Zero Pulse | the first feedback zero-mark outside the home switch
2 | Limit Switch and Zero Pulse | the first feedback zero-mark outside the limit switch
3 | Home Switch without Zero Pulse | the edge of the home switch
4 | Limit Switch without Zero Pulse | the edge of the limit switch
5 | within one Revolution and Zero Puls | the next feedback zero-mark
6 | Set Ref.Point immediately on Position Command | the actual position
7 | Move to Mechanical Stop (Ref. Ipeak) and Zero Pulse | the first feedback zero-mark outside the mechanical stop. Peak current is limited to Homing Ipeak during the movement. (see screen page "Current Loop").
8 | Move to an absolute SSI-Position | the read position from the SSI input at the beginning of the homing
9 | Move to Mechanical Stop (Ref. Ipeak) without Zero Pulse | the actual position, when the drive is at the mechanical stop and the following error reachs 50% of the max. allowable following error. Peak current is limited to Homing Ipeak during the movement. (see screen page "Current Loop").

Homing Speed (VREF)
Speed for the homing operation. The sign is automatically fixed by the selected direction of motion.

Acc. Ramp (ACCR)
Acceleration ramp for homing operation. This ramp is also valid for jog mode.

Dec. Ramp (DECR)
Deceleration ramp for the homing operation. This ramp is also valid for jog mode. This deceleration ramp is only used if the operating mode allows it. For homing to a hardware limit-switch, the emergency ramp is used.

Direction of Motion (DREF)
Determines the direction of motion for homing. The setting "distance-dependent" is only relevant for Homing 5 (within one turn). In this case, the direction is chosen to give the shortest distance to the zero-mark. This parameter also defines the direction of motion for a Modulo type of axis.

Offset (ROFFS)
With the reference offset you can assign an absolute position value other than 0 to the reference point. With an offset for the reference position, you are not actually making a physical change, but the offset is used as a reference value within the position control of the servo amplifier. Homing to the reference switch does not finish at zero, but at the preset reference offset value.

The reference offset must be set before homing is started.

Auto-home on Enable (AUTOHOME)

The selected homing is started automatically after the servo amplifier has been enabled.

Zero Pulse Source (REFMODE)

Select the zero pulse source for the homing here.

Automatic sFollowing Motion Task after Homing (NREFMT)

When the homing is done, the selected motion task is started automatically. Setting of "0" disables this function.

Start on the fly (NREFMT)

The motion task starts immediately. The bits “homing active=0“ and ”homing finnished=1“ are set after the motion task is finished.

Homing type 0

Sets the reference point to the setpoint position (the following error is lost). The load does not move.

Homing type 1

Before starting homing, check the safety of the system since the load may move even if the limit-switches are disconnected or defective.

Homing without limit switches, with homing switch, with feedback zero

Negative traverse, positive count direction Negative traverse, negative count direction

Homing with limit switches, with homing switch, with feedback zero
Negative traverse, positive count direction

Positive traverse, positive count direction

Homing type 2

Homing with limit switches, without homing switch, with feedback zero

Negative traverse, positive count direction

Positive traverse, positive count direction

Homing type 3

Before starting homing, check the safety of the system since the load may move even if the limit-switches are disconnected or defective.

Homing with limit switches, with homing switch, without feedback zero

Negative traverse, positive count direction

Positive traverse, positive count direction

Homing type 4

Homing with limit switches, without homing switch, without feedback zero
Negative traverse, positive count direction

Positive traverse, positive count direction

Homing type 5

Behavior for successively repeated starts of Homing 5:
The position controller can only hold the motor in the zero position by passing the zero mark by ± 1 count. On a repeated start of Homing 5, depending on the position (1 count in advance of or 1 count behind the zero-mark) and the count direction, the movement may be a full motor turn!

Homing with limit switches, without homing switch, with feedback zero

Negative traverse, positive count direction | Positive traverse, positive count direction

Homing type 6

Sets the reference point to the actual position (the following error is not lost). The load does not move.

Homing type 7

Using this type of homing can damage the mechanical stop on the machine. The peak current, Ipeak, and the continuous current, Irms, are limited for the duration of the homing run.

A more severe limiting of the current is possible. (see parameter Homing Ipeak on screen page "Current Loop").

Mechanical stop, without limit switches, without homing switch, with feedback zero

Negative traverse, positive count direction | Positive traverse, positive count direction

Homing type 8

Prerequisite: an absolute encoder (SSI) is connected to to the encoder input X1 of the servo amplifier. When the homing starts, the absolute position is read at connector X1. The reference point is set to this position. The load does not move.

Homing type 9

Using this type of homing can damage the mechanical stop on the machine. The peak current, Ipeak, and the continuous current, Irms, are limited for the duration of the homing run.

A more severe limiting of the current is possible. (see parameter Homing Ipeak on screen page "Current Loop").

Mechanical stop, without limit switches, without homing switch, without feedback zero

Negative traverse, positive count direction | Positive traverse, positive count direction

The meanings of the abbreviations in the drawings are:

N | Limit switch NSTOP | P | Limit switch PSTOP | SP | Start position
R | Homing switch | vref | preset velocity | NM | feedback zero mark


ASCII English HSAVE

ASCII - Command | HSAVE | For Manufacturer Use only
Syntax Transmit | HSAVE |
Syntax Receive | HSAVE | Available in |
Type | Command | MMI | No
ASCII Format | Command | CANBus Object Number | 3556 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 1 (dec)
Range | - | DPR | 86 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | drive configuration | EEPROM | No
Short Description | Hiperface: Save Parameters in Encoder

Description

If FBTYPE=2 or =4 is set, the HSAVE command saves the variables for the encoder (HIPERFACE / EnDat) in the serial EEPROM of the encoder. With the setting FBTYPE=7, only the variables for the incremental track, as well as MNUMBER and MPHASE are saved in the serial EEPROM of the amplifier.

This command is only available if the amplifier has detected a sin/cos encoder (FBTYPE =2;4;7).
FBTYPE = 2 HIPERFACE (Sick Stegmann)
FBTYPE = 4 EnDat 2.1 (Heidenhain)
FBTYPE = 7 SINCOS – Encoder ohne eigenem ser. EEPROM
FBTYPE = 20 BiSS-B 5V digital (Hengstler)
FBTYPE = 22 BiSS-B 12V digital (Hengstler)
FBTYPE = 23 BiSS-B 5V analog (Hengstler)
FBTYPE = 24 BiSS-B 12V analog (Hengstler)
FBTYPE = 32 EnDat 2.2 (Heidenhain)
FBTYPE = 34 EnDat 2.2 12V (Heidenhain)

This paramter doesn't work with the following combinations:
FBTYPE = 33 BiSS-C
FBTYPE = 36 SFD3

The HSAVE command saves the following variables.
MNUMBER*
MPHASE*
HICOFFS*
HISOFFS*
HIFACT1*
MBRAKE*
MSERIALNO*
* If FBTYPE = 7, these parameters are saved in the serial EEPROM of the amplifier.

Hiperface encoder, which have contents, can be erased by "HSAVE ERASE".

In order to use an unknown Hiperface encoder, the parameter field of the encoder must be initialized. There is also the command HSAVE OEM "ID" "PPR" "BPR" "R"

The parameters ID, PPR, BPR, R have the following meaning:
ID - hiperface ID. If an unknown hiperface was recognized by the drive, so the ID is in parentheses issued "Unknown (ID)"
PPR - periods per revolution. Number of enclines per revolution
BPR - bits per revolution: Number of bits per encoder revolution
R - revolutions: Number of turns

After the command has been executed, so the next time the amplifier of the transmitter is recognized and accepted the data.

With HSAVE OEM (without parameters) can be checked if the firmware used supports this command.

FW >=2.23
HSAVE BAM
This command is used to set the actual position within one turn to value zero.


ASCII English HVER

ASCII - Command | HVER |
Syntax Transmit | HVER |
Syntax Receive | HVER <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 3557 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 1 (dec)
Range | max 50 ASCII Characters | DPR | 87 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Output the Hardware Version

Description

The HVER command returns the designation for the hardware version, in the following form:
“Drive 3xx Hardware Version (yy) zzzz”
xx - designation of the output stage (current rating)
yy - designation of the hardware version
zzzz - date of the first hardware revision


ASCII English HWCNT

ASCII - Command | HWCNT |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English I

ASCII - Command | I |
Syntax Transmit | I |
Syntax Receive | I <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3558 (hex)
DIM | A | PROFIBUS PNU | 1688 (dec) IND = 1 (dec)
Range | - | DPR | 88 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Current Monitor

Description

This variable returns the actual current value in amperes. This value is always positive.


ASCII English I2TLIM

ASCII - Command | I2TLIM |
Syntax Transmit | I2TLIM [Data] |
Syntax Receive | I2TLIM <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 355A (hex)
DIM | % | PROFIBUS PNU | 1690 (dec) IND = 1 (dec)
Range | 0 .. 100 | DPR | 90 (dec)
Default | 80 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | I2T Warning

Description

This variable defines a threshold for the I2T warning. As soon as the I2T values goes above this threshold, the warning, n01, is generated. This warning is passed on to a control system via a digital output (OxMODE=11). If the I2TLIM value is too low, the message appears too soon and the drive is not fully utilized. If the I2TLIM value is too high, limiting occurs at the same time as the message.


ASCII English ICMD

ASCII - Command | ICMD |
Syntax Transmit | ICMD |
Syntax Receive | ICMD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 355B (hex)
DIM | A | PROFIBUS PNU | 1691 (dec) IND = 1 (dec)
Range | -DIPEAK .. DPEAK | DPR | 91 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | No
Short Description | Current Setpoint

Description

Shows the internal current setpoint.


ASCII English ICMDVLIM

ASCII - Command | ICMDVLIM |
Syntax Transmit | ICMDVLIM [Data] |
Syntax Receive | ICMDVLIM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3685 (hex)
DIM | VUNIT | PROFIBUS PNU | 1989 (dec) IND = 1 (dec)
Range | 0 .. VLIM | DPR | 389 (dec)
Default | 0 |
Opmode | 2,3 | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.00 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | current loop | EEPROM | Yes
Short Description | Velocity Limit in Current Control

Description

The ICMDVLIM parameter defines a digital speed limit (unit: VUNIT) when specifying a current setpoint in OPMODE = 2 and 3

The function is only activated when ICMDVLIM> 0. A change of ICMDVLIM is possible (changing the configuration) only when the amplifier is disabled.

Under certain conditions, this variable is to be seen as a configuration variable. A change of the value from 0 to >0 or from >0 to 0 is interpreted as a change of the configuration and may only take place with disabled power stage. After that, a COLDSTART is mandatory!


ASCII English ID

ASCII - Command | ID |
Syntax Transmit | ID |
Syntax Receive | ID <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 355D (hex)
DIM | A | PROFIBUS PNU | 1693 (dec) IND = 1 (dec)
Range | - | DPR | 93 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | D-component of Current Monitor

Description

The D-axes component of the actual current value.


ASCII English IDDUMP

ASCII - Command | IDDUMP |
Syntax Transmit | IDDUMP [Data] |
Syntax Receive | IDDUMP <Data> | Available in |
Type | Multi-Line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode | All | Data Type Bus/DPR | String
Drive State |  | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | No
Short Description | outputs the list of the object (parameter) numbers

Description

This command IDDUMP displays the list of the object (parameter) numbers in a terminal with the corresponding ASCII names.

please have a look to MAXCMD


ASCII English IEXTT

ASCII - Command | IEXTT |
Syntax Transmit | IEXTT [Data] |
Syntax Receive | IEXTT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3869 (hex)
DIM | A | PROFIBUS PNU | 1673 (dec) IND = 33 (dec)
Range | -DICONT .. +DICONT | DPR | 873 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 3.05 |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Weight compensation

Description

IEXTT describes a weight compensation (constant current feed forwared usefull for vertical load)


ASCII English IEXTTLIM

ASCII - Command | IEXTTLIM |
Syntax Transmit | IEXTTLIM [Data] |
Syntax Receive | IEXTTLIM <Data> | Available in |
Type |  | MMI | No
ASCII Format | Float | CANBus Object Number | 38B6 (hex)
DIM |  | PROFIBUS PNU | 1750 (dec) IND = 33 (dec)
Range |  | DPR | 950 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | current loop | EEPROM |
Short Description | support the vertical axis support the vertical axis

Description

From version 3.76 / 5.06 the support of the vertical axis in the S700 firmware was expanded. In addition to the IEXTT parameter With which the holding torque for the vertical axis can be defined, the parameter IEXTTLIM was implemented.

The current setpoint can be asymmetrically limited using the IEXTTLIM parameter. Analog to IEXTT The input is in amperes. The current limitation is only activated when the holding torque IEXTT <> 0 and IEXTTLIM <> 0 are actived.


ASCII English IN

ASCII - Command | IN |
Syntax Transmit | IN |
Syntax Receive | IN <Data> | Available in |
Type | Multi-line Return Command | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 2.9
Function Group | digital I/O | EEPROM | No
Short Description | List Analog Voltage Values

Description

The IN command returns the input voltages for the 8 A/D channels as counts (-4096 ... +4096).

S700/S300_ARM9
A/D channels:
channel 0 cosine resolver
channel 1 resolver sine
channel 2 sine encoder
channel 3 cosine encoder
channel 4 current IA
channel 5 current IB
channel 6 channel setpoint 1
channel 7 setpoint 2
channel 8 motor temperature
channel 9 heatsink temperature
channel 10 ambient temperature
channel 11 feedback of sense encoder
channel 12 reserve
channel 13 DC link voltage
channel 14 reserve
channel 15 reserve

S300_ARM7
A/D channels:
channel 0 current IA
channel 1 setpoint 1
channel 2 sine resolver
channel 3 sine encoder
channel 4 heatsink temperature
channel 5 ambient temperature
channel 6 feedback of sense encoder
channel 7 reserve
channel 8 current IB
channel 9 Setpoint 2
channel 10 cosine resolver
channel 11 cosine encoder
channel 12 motor temperature
channel 13 DC link voltage
channel 14 reserve
channel 15 reserve


ASCII English IN1

ASCII - Command | IN1 |
Syntax Transmit | IN1 |
Syntax Receive | IN1 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3561 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 1 (dec)
Range | - | DPR | 97 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input 1

Description

The status of the digital input INPUT1.


ASCII English IN1HCMD

ASCII - Command | IN1HCMD |
Syntax Transmit | IN1HCMD [Data] |
Syntax Receive | IN1HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

The command IN1HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 1 that has been configured with the function IN1MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN1HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN1LCMD

ASCII - Command | IN1LCMD |
Syntax Transmit | IN1LCMD [Data] |
Syntax Receive | IN1LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

The command IN1LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 1 that has been configured with the function IN1MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN1LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN1MODE

ASCII - Command | IN1MODE |
Syntax Transmit | IN1MODE [Data] |
Syntax Receive | IN1MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3562 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 1 (dec)
Range | 0 .. 90 | DPR | 98 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 1

Description

The IN1MODE command is used to configure the function of the digital input INPUT1. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN1MODE=0 | no function | The state of the input 1 is read and can be used via fieldbus or Slot card.
IN1MODE=1 | Failure Reset | Software reset of the servo amplifier in the event of a fault. The high input signal is ignored, if the drive has no fault. All the functions and displays are set to the initial status. Parameters that are not stored in the EEPROM are erased, the parameter set that is stored in the EEPROM is loaded. If any of the error messages F01, F02, F03, F05, F08, F13, F16 or F19 ( p.52) are present, then no software-reset will be carried out, just the error message will be deleted. This means that, for example, the encoder output signals are stable and can continue to be evaluated by the controls. When the input is high, while the auxillary 24V supply is switched on, the drive waits, before the input is set to low. This state is symbolised in the display. The first of the three display positions displays a "A".
IN1MODE=2 | no function |
IN1MODE=3 | no function |
IN1MODE=4 | no function |
IN1MODE=5 | no function |
IN1MODE=6 | no function |
IN1MODE=7 | no function |
IN1MODE=8 | Analog In 1/Analog In 2 | Switches over the setpoint inputs Analog In 1/2 at ANCNFG = 0. This function is only effective if the analog set-point function 0,Xcmd=Analog In 1 has been selected. High level at the input : Analog In 2 (terminals X3/6,7) is active Low level at the input : Analog In 1 (terminals X3/4,5) is active
IN1MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (INxMODE =17, Start_MT IO). If you wire up a reference/homing switch (INxMODE =12, Reference) and (also) want to start a following task (INxMODE =15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced.
IN1MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN1MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN1MODE=12 | Reference | home/reference switch located on machine
IN1MODE=13 | digital encoder/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE = 2) High level at the input : ROD-compatible position signals (ENCMODE = 1)
IN1MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN1MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started. (see also O_C tablel 3)
IN1MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN1TRIG. Motion task number “0” (IN1TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task. Only OPMODE 4 or 8
IN1MODE=17 | Start_MT IO | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN1MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN1TRIG. Make the conversion according to the following equation: IN1TRIG given in % of IPEAK
IN1MODE=19 | Off |
IN1MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN1TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=4,5,6,8 has to be selected. The speed is given in units of the position controller given by VUNIT, the sign selects the moving direction.
IN1MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier. High = off Low = on
IN1MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN1MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN1TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN1MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN1TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input1=low OPMODE=4 Input1=high OPMODE=8 IN1MODE=24 (Activate Input) IN1TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN1MODE=25 | Zero_latch | Sets the digital encoder zero pulse offset. The current position, depending on the digital encoder resolution (ENCOUT) that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN1MODE=26 | Position Latch | A edge on this input latches the actual position. The position can then be read by LATCH1P32 (positive edge) or LATCH1N32 (negative edge). The actual 16-Bit position (absolute in one turn) can be read by LATCH1P16 (positive edge) and LATCH1N16 (negative edge). The status of the latching can be read by the equivalent bits of DRVSTAT. The min. cycle time for a low/high to high/low transaction is 500µs. The min. time between two latch pulses is 1 msec. In case IN1TRIG value is <> 0, the motion task with the fiting number is executed.
IN1MODE=27 | Quick Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode. Drive is still enabled!
IN1MODE=28 | Starting Jogmode | OPMODE = 4,5,6,8 Firmware >= 0.73 A rising edge starts a jogmode with speed VJOG. A falling edge stopps the movement.
IN1MODE=29 | Starting motion task / homing | With the rising edge the motion task starts which is coded with digital inputs INxMODE=9. With motion task 0 a homing procedure starts. Warning: a falling edge does not stop motion!
IN1MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INH1CMD, the command buffer for the negative edge is IN1LCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input.
IN1MODE=32 | Brake | Warning ! With suspended loads, this function will lead to slipping of the axes ! A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled.
IN1MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232. This setting can't be used in combination with GUI software.
IN1MODE=36 | Give Offset to Gearing Function | Gearing mode OPMODE =4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN1TRIG. The scaling is in 32Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN1TRIG can be calculated: IN1TRIG = n [rpm]*2^32/(4000*60) example: n = 500 [U/min] INxTRIG = 500 * 2^32 / (4000*60) = 8947848
IN1MODE=37 | change of source for position detection with EXTPOS > 0 | = 0 Position from the external encoder (preselection with EXTPOS). = 1 Position is detected by the first encoder on the motor (FBTYPE).
IN1MODE=38 | Enable signal for following motion task | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN1MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN1TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT), bit 15 is the sign and defines the moving direction and the time by the upper 16 bit (given in msec) of the help variable IN1TRIG. A rising edge at INPUT1 changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN1TRIG. After the defined time or a falling edge at INPUT1 is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN1TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN1TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN1TRIG = 0x000afe0c = 720396
IN1MODE=40 | Additional hardware input | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage.
IN1MODE=41 | Emergency Stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN1MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time.
IN1MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN1MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN1TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position.
IN1MODE=49 | emergency stop (sensorless) | (High active) By a going edge an emergency stop is activated (current controlled without feedback)
IN1MODE=50 | emergency stop (sensorless) | (Low active) By a going edge an emergency stop is activated (current controlled without feedback)
IN1MODE=51 | Master slave synchronisation | to synchronisate by ENGAGE =6 to decouple ENGAGE =12
IN1MODE=53 | Master slave synchronisation | to synchronisate by ENGAGE =7 to decouple ENGAGE =12
IN1MODE=57 | switch to second parameter set | Low: std. Parameter used High: second Parameter group used see also command PARCNFG
IN1MODE=60 | VOSPD-Switch | Switch Overspeed Threshhold (VOSPD) the rising edge switch from overspeed threshhold VOSPD) to INxTRIG. the falling edge actives the initially value
IN1MODE=61 | Pulse Length on IN1 | Measure Pulse Length on IN1 It is activated for the latch function. It measures the time between the rising and falling edge at input IN1. The measured time (in 1 usec increments) is stored in the Latchvariable LATCH1N32. About the status bits in TRJSTAT the state of the time measurement can be read: TRJSTAT = 0x2000000-rising edge recognized, timing continues TRJSTAT = 0x4000000 falling edge recognized , finished timekeeping
IN1MODE=62 | discharge of the dc-bus | When the DC-Bus should be discharge, first switch off the main voltage. Manually, set the digital input to 1, after some seconds, the DC-Link capacitor is discharged and VBUS nearby 0 Set back the digital input to 0 and now the DC-Bus can be charged again and the amplifier can be operated as normal. Danger: In order to prevent this function from being activated when the supply is switched on, the net-BTB signal (power supply on) is internally monitored. If the monitoring of the net BTB is switched off (NONBTB> 0), this function can not be used.


ASCII English IN1TRIG

ASCII - Command | IN1TRIG |
Syntax Transmit | IN1TRIG [Data] |
Syntax Receive | IN1TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3563 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 1 (dec)
Range | -2147483648 .. 2147483647 | DPR | 99 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for IN1MODE

Description

Auxiliary trigger variable for IN1MODE. Certain settings of IN1MODE require you to specify an additional trigger level. See IN1MODE for further details.


ASCII English IN2

ASCII - Command | IN2 |
Syntax Transmit | IN2 |
Syntax Receive | IN2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3564 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 100 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input 2

Description

The status of the digital input INPUT2.


ASCII English IN2HCMD

ASCII - Command | IN2HCMD |
Syntax Transmit | IN2HCMD [Data] |
Syntax Receive | IN2HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

The command IN2HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 2 that has been configured with the function IN2MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN2HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN2LCMD

ASCII - Command | IN2LCMD |
Syntax Transmit | IN2LCMD [Data] |
Syntax Receive | IN2LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

The command IN2LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 2 that has been configured with the function IN2MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN2LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN2MODE

ASCII - Command | IN2MODE |
Syntax Transmit | IN2MODE [Data] |
Syntax Receive | IN2MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3565 (hex)
DIM | - | PROFIBUS PNU | 1701 (dec) IND = 1 (dec)
Range | 0 .. 90 | DPR | 101 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 2

Description

The IN2MODE command is used to configure the function of the digital input INPUT2. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN2MODE=0 | no function | The state of the input 1 is read and can be used via fieldbus or Slot card.
IN2MODE=1 | no function |
IN2MODE=2 | no function |
IN2MODE=3 | no function |
IN2MODE=4 | no function |
IN2MODE=5 | no function |
IN2MODE=6 | no function |
IN2MODE=7 | no function |
IN2MODE=8 | selection Analog In 1 / 2 | Switches over the setpoint inputs Analog In 1/2 at ANCNFG = 0. This function is only effective if the analog set-point function 0, Xcmd = Analog In 1 has been selected. High level at the input : Analog In 2 (terminals X3/6,7) is active Low level at the input : Analog In 1 (terminals X3/4,5) is active
IN2MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (INxMODE =17, Start_MT IO). If you wire up a reference/homing switch (INxMODE =12, Reference) and (also) want to start a following task (INxMODE =15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced.
IN2MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN2MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN2MODE=12 | Reference | home/reference switch located on machine
IN2MODE=13 | digital encoder/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE = 2) High level at the input : ROD-compatible position signals (ENCMODE = 1)
IN2MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN2MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started. (see also O_C tablel 3)
IN2MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN2TRIG. Motion task number “0” (IN2TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task. Only OPMODE 4 or 8
IN2MODE=17 | Start_MT IO | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN2MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN2TRIG. Make the conversion according to the following equation: IN2TRIG given in % of IPEAK
IN2MODE=19 | Off |
IN2MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN2TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=4,5,6,8 has to be selected. The speed is given in units of the position controller given by VUNIT, the sign selects the moving direction.
IN2MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier. High = off Low = on
IN2MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN2MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN2TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN2MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN2TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input1=low OPMODE=4 Input1=high OPMODE=8 IN1MODE=24 (Activate Input) IN2TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN2MODE=25 | Zero_latch | Sets the digital encoder zero pulse offset. The current position, depending on the digital encoderresolution (ENCOUT) that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN2MODE=26 | Position Latch | A edge on this input latches the actual position. The position can then be read by LATCH2P32 (positive edge) or LATCH2N32 (negative edge). The actual 16-Bit position (absolute in one turn) can be read by LATCH2P16 (positive edge) and LATCH2N16 (negative edge). The status of the latching can be read by the equivalent bits of DRVSTAT. The min. cycle time for a low/high to high/low transaction is 500µs. The min. time between two latch pulses is 1 msec. In case IN1TRIG value is <> 0, the motion task with the fiting number is executed.
IN2MODE=27 | Quick Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode. Drive is still enabled!
IN2MODE=28 | Starting Jogmode | OPMODE = 4,5,6,8 Firmware >= 0.73 A rising edge starts a jogmode with speed VJOG. A falling edge stopps the movement.
IN2MODE=29 | Starting motion task / homing | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A falling ege does not stop motion.
IN2MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INH2CMD, the command buffer for the negative edge is IN2LCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input.
IN2MODE=32 | Brake | Warning ! With suspended loads, this function will lead to slipping of the axes ! A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled.
IN2MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232. This setting can't be used in combination with GUI software.
IN2MODE=36 | Give Offset to Gearing Function | Gearing mode OPMODE =4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN2TRIG. The scaling is in 32Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN2TRIG can be calculated: IN2TRIG = n [rpm]*2^32/(4000*60) example: n = 500 [U/min] INxTRIG = 500 * 2^32 / (4000*60) = 8947848
IN1MODE=37 | change of source for position detection with EXTPOS > 0 | = 0 Position from the external encoder (preselection with EXTPOS). = 1 Position is detected by the first encoder on the motor (FBTYPE).
IN2MODE=38 | Enable signal for following motion task | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN2MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN2TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT), bit 15 is the sign and defines the moving direction and the time by the upper 16 bit (given in msec) of the help variable IN2TRIG. A rising edge at INPUT1 changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN2TRIG. After the defined time or a falling edge at INPUT1 is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN2TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN2TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN2TRIG = 0x000afe0c = 720396
IN2MODE=40 | Additional hardware input | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage.
IN2MODE=41 | Emergency Stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN2MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time.
IN2MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN2MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN2TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position.
IN2MODE=49 | emergency stop sensorless (high active) | By a rising edge an emergency stop is activated (current controlled without feedback)
IN2MODE=50 | emergency stop sensorless (low active) | By a falling edge an emergency stop is activated (current controlled without feedback)
IN2MODE=51 | Master/Slave synchronisation |
IN2MODE=53 | Master/Slave synchronisation |
IN2MODE=57 | switch between data set | Low: std. Parameter used High: second Parameter group used see also command PARCNFG
IN2MODE=60 | VOSPD-Switch | Switch Overspeed Threshhold (VOSPD) the rising edge switch from overspeed threshhold VOSPD) to INxTRIG. the falling edge actives the initially value
IN2MODE=61 | Pulse Length on IN2 | Measure Pulse Length on IN2
IN2MODE=62 | discharge of the dc-bus | When the DC-Bus should be discharge, first switch off the main voltage. Manually, set the digital input to 1, after some seconds, the DC-Link capacitor is discharged and VBUS nearby 0 Set back the digital input to 0 and now the DC-Bus can be charged again and the amplifier can be operated as normal. Danger: In order to prevent this function from being activated when the supply is switched on, the net-BTB signal (power supply on) is internally monitored. If the monitoring of the net BTB is switched off (NONBTB> 0), this function can not be used.


ASCII English IN2PM

ASCII - Command | IN2PM |
Syntax Transmit | IN2PM [Data] |
Syntax Receive | IN2PM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362E (hex)
DIM | - | PROFIBUS PNU | 1902 (dec) IND = 1 (dec)
Range | 0,1,2 | DPR | 302 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | digital I/O | EEPROM | Yes
Short Description | state of the digital input

Description

The IN2PM command is used to configure the function of a digital output during a motion task (motion block) sequence.

The function "NextInPos" is available if an I/O expansion card is used (terminal X11B4) or a digital output of the drive is configured with the function OxMODE=16. At the start of the first motion block (motion task), the “NextInPos” output is always set to 0. The response of the output during the execution of the motion block sequence depends on the configuration variable IN2PM.

IN2PM=0 – the output is inverted at the start of the next block.
IN2PM=1– the output is set to 0 at the start of a motion block, and set to HIGH at the end of a motion block.
IN2PM=2 – the output is inverted at the end of a block.
With a sequence of motion blocks where the blocks are started immediately, only the IN2PM=0 or IN2PM=2 settings make sense. If the setting is IN2PM=1, the HIGH state is so short that it may not be registered at all by the external control system.

If a following task is started with the aid of an I/O (INxMODE=15), then the IN2PM=2 or IN2PM=1 setting should be used. With this setting, the end of a motion block is signaled by the HIGH state (IN2PM=1) or the change of state (IN2PM=2) at the “NextInPos” output. The external control system can then initialize the continuation of the motion task sequence via the “Start next task” input.
See also IN1MODE = 15


ASCII English IN2TRIG

ASCII - Command | IN2TRIG |
Syntax Transmit | IN2TRIG [Data] |
Syntax Receive | IN2TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3566 (hex)
DIM | - | PROFIBUS PNU | 1702 (dec) IND = 1 (dec)
Range | -2147483648 .. 2147483647 | DPR | 102 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for IN2MODE

Description

Auxiliary trigger variable for IN2MODE. Certain settings of IN2MODE require you to specify an additional trigger level. See IN2MODE for further details.


ASCII English IN3

ASCII - Command | IN3 |
Syntax Transmit | IN3 [Data] |
Syntax Receive | IN3 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3567 (hex)
DIM | - | PROFIBUS PNU | 1703 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 103 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input 3

Description

The status of the digital input INPUT3.


ASCII English IN3HCMD

ASCII - Command | IN3HCMD |
Syntax Transmit | IN3HCMD [Data] |
Syntax Receive | IN3HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

The command IN3HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 3 that has been configured with the function IN3MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN3HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN3LCMD

ASCII - Command | IN3LCMD |
Syntax Transmit | IN3LCMD [Data] |
Syntax Receive | IN3LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

The command IN3LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 3 that has been configured with the function IN3MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN3LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN3MODE

ASCII - Command | IN3MODE |
Syntax Transmit | IN3MODE [Data] |
Syntax Receive | IN3MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3568 (hex)
DIM | - | PROFIBUS PNU | 1704 (dec) IND = 1 (dec)
Range | 0 .. 90 | DPR | 104 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 3

Description

The IN3MODE command is used to configure the function of the digital input INPUT3. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN3MODE=0 | Off | The state of the input 1 is read and can be used via fieldbus or Slot card.
IN3MODE=1 | Off |
IN3MODE=1 | Reset | Software reset of the servo amplifier in the event of a fault. The high input signal is ignored, if the drive has no fault. All the functions and displays are set to the initial status. Parameters that are not stored in the EEPROM are erased, the parameter set that is stored in the EEPROM is loaded. If any of the error messages F01, F02, F03, F05, F08, F13, F16 or F19 ( p.52) are present, then no software-reset will be carried out, just the error message will be deleted. This means that, for example, the encoder output signals are stable and can continue to be evaluated by the controls. When the input is high, while the auxillary 24V supply is switched on, the drive waits, before the input is set to low. This state is symbolised in the display. The first of the three display positions displays a "A".
IN3MODE=2 | PSTOP | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=3 | NSTOP (4.78) | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=4 | PSTOP+Intg.Off | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN3MODE=5 | NSTOP + Int. off | A low on the input disables the negative direction (counterclockwise if DIR=1, clockwise if DIR=0). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN3MODE=6 | PSTOP+NSTOP | A low on the input disables the positive and the negative direction. At the same time, a warning "n10" and "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=7 | P/Nstop+Intg.Off | A low on the input disables the positive and the negative direction. At the same time, a warning "n10" and "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN3MODE=8 | selection Analog In 1 / 2 | Switches over the setpoint inputs Analog In 1/2 at ANCNFG = 0. This function is only effective if the Analog In function = 0 Xcmd=Analog In 1 has been selected. High level at the input : Analog In 2 (terminals X3/6,7) is active Low level at the input : Analog In 1 (terminals X3/4,5) is active
IN3MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (INxMODE =17, Start_MT IO). If you wire up a reference/homing switch (INxMODE =12, Reference) and (also) want to start a following task (INxMODE =15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced.
IN3MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN3MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN3MODE=12 | Reference | home/reference switch located on machine
IN3MODE=13 | digital encoder/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE = 2) High level at the input : ROD-compatible position signals (ENCMODE = 1)
IN3MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN3MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started. (see also O_C tablel 3)
IN3MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN3TRIG. Motion task number “0” (IN3TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task. Only OPMODE 4 or 8
IN3MODE=17 | Start_MT IO | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN3MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN3TRIG. Make the conversion according to the following equation: IN3TRIG given in % of IPEAK
IN3MODE=19 | Off |
IN3MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN3TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT, the sign selects the moving direction.
IN3MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier. High = off Low = on
IN3MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN3MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN3TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN3MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN3TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input1=low OPMODE=4 Input1=high OPMODE=8 IN1MODE=24 (Activate Input) IN3TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN3MODE=25 | Zero_latch | Sets the digital encoder zero pulse offset. The current position, depending on the digital encoder resolution (ENCOUT) that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN3MODE=27 | Quick Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode. Drive is still enabled!
IN3MODE=28 | Starting Jogmode | ONLY OPMODE = 8 Firmware >= 0.73 A rising edge starts a jogmode with speed VJOG. A falling edge stopps the movement.
IN3MODE=29 | Starting motion task / homing | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A falling ege does not stop motion.
IN3MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INH3CMD, the command buffer for the negative edge is IN3LCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input.
IN3MODE=32 | Brake | Warning ! With suspended loads, this function will lead to slipping of the axes ! A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled.
IN3MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232. This setting can't be used in combination with GUI software.
IN3MODE=36 | Give Offset to Gearing Function | Gearing mode OPMODE =4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN3TRIG. The scaling is in 32Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN3TRIG can be calculated: IN3TRIG = n [rpm]*2^32/(4000*60) example: n = 500 [U/min] INxTRIG = 500 * 2^32 / (4000*60) = 8947848
IN1MODE=37 | change of source for position detection with EXTPOS > 0 | = 0 Position from the external encoder (preselection with EXTPOS). = 1 Position is detected by the first encoder on the motor (FBTYPE).
IN3MODE=38 | Enable signal for following motion task | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN3MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN3TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT), bit 15 is the sign and defines the moving direction and the time by the upper 16 bit (given in msec) of the help variable IN3TRIG. A rising edge at INPUT1 changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN3TRIG. After the defined time or a falling edge at INPUT1 is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN3TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN3TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN3TRIG = 0x000afe0c = 720396
IN3MODE=40 | Additional hardware input | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage.
IN3MODE=41 | Emergency Stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN3MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time.
IN3MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN1MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN3TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position.
IN3MODE=49 | emergency stop (sensorless) | (High active) By a going edge an emergency stop is activated (current controlled without feedback)
IN3MODE=50 |  |
IN3MODE=51 |  |
IN3MODE=53 |  |
IN3MODE=57 | switch to second parameter set | Low: std. Parameter used High: second Parameter group used see also command PARCNFG
IN3MODE=60 | VOSPD-Switch | Switch Overspeed Threshhold (VOSPD)
IN3MODE=62 | discharge of the dc-bus | When the DC-Bus should be discharge, first switch off the main voltage. Manually, set the digital input to 1, after some seconds, the DC-Link capacitor is discharged and VBUS nearby 0 Set back the digital input to 0 and now the DC-Bus can be charged again and the amplifier can be operated as normal. Danger: In order to prevent this function from being activated when the supply is switched on, the net-BTB signal (power supply on) is internally monitored. If the monitoring of the net BTB is switched off (NONBTB> 0), this function can not be used.


ASCII English IN3TRIG

ASCII - Command | IN3TRIG |
Syntax Transmit | IN3TRIG [Data] |
Syntax Receive | IN3TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3569 (hex)
DIM | - | PROFIBUS PNU | 1705 (dec) IND = 1 (dec)
Range | -2147483648 .. 2147483647 | DPR | 105 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for IN3MODE

Description

Auxiliary trigger variable for IN3MODE. Certain settings of IN3MODE require you to specify an additional trigger level. See IN3MODE for further details.


ASCII English IN4

ASCII - Command | IN4 |
Syntax Transmit | IN4 |
Syntax Receive | IN4 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356A (hex)
DIM | - | PROFIBUS PNU | 1706 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 106 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input 4.

Description

The status of the digital input INPUT4.


ASCII English IN4HCMD

ASCII - Command | IN4HCMD |
Syntax Transmit | IN4HCMD [Data] |
Syntax Receive | IN4HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

The command IN4HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 4 that has been configured with the function IN4MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN4HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN4LCMD

ASCII - Command | IN4LCMD |
Syntax Transmit | IN4LCMD [Data] |
Syntax Receive | IN4LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

The command IN4LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 4 that has been configured with the function IN4MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN4LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN4MODE

ASCII - Command | IN4MODE |
Syntax Transmit | IN4MODE [Data] |
Syntax Receive | IN4MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356B (hex)
DIM | - | PROFIBUS PNU | 1707 (dec) IND = 1 (dec)
Range | 0 .. 90 | DPR | 107 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 4

Description

The IN4MODE command is used to configure the function of the digital input INPUT4. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN4MODE=0 | Off | The state of the input 1 is read and can be used via fieldbus or Slot card.
IN4MODE=1 | Off |
IN4MODE=2 | PSTOP (4.78) | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN4MODE=3 | NSTOP | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN4MODE=4 | NSTOP + Int. off | A low on the input disables the negative direction (counterclockwise if DIR=1, clockwise if DIR=0). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN4MODE=5 | NSTOP+Intg.Off | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN4MODE=6 | Off |
IN4MODE=7 | Off |
IN4MODE=8 | selection Analog In 1/ .2 | Switches over the setpoint inputs Analog In 1/2 at ANCNFG = 0. This function is only effective if the analog set-point function 0,Xcmd=Analog In 1 has been selected. High level at the input : Analog In 2 (terminals X3/6,7) is active Low level at the input : Analog In 1 (terminals X3/4,5) is active
IN4MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (INxMODE =17, Start_MT IO). If you wire up a reference/homing switch (INxMODE =12, Reference) and (also) want to start a following task (INxMODE =15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced.
IN4MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN4MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN4MODE=12 | Reference | home/reference switch located on machine
IN4MODE=13 | digital encoder /SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE = 2) High level at the input : ROD-compatible position signals (ENCMODE = 1)
IN4MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN4MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started. (see also O_C tablel 3)
IN4MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN4TRIG. Motion task number “0” (IN4TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task. Only OPMODE 4 or 8
IN4MODE=17 | Start_MT IO | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN4MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN4TRIG. Make the conversion according to the following equation: IN4TRIG given in % of IPEAK
IN4MODE=19 | Off |
IN4MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN4TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT, the sign selects the moving direction.
IN4MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier. High = off Low = on
IN4MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN4MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN4TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN4MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN4TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input1=low OPMODE=4 Input1=high OPMODE=8 IN1MODE=24 (Activate Input) IN4TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN4MODE=25 | Zero_latch | Sets the digital encoder zero pulse offset. The current position, depending on the digital encoder resolution (ENCOUT) that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN4MODE=27 | Quick Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode. Drive is still enabled!
IN4MODE=28 | Starting Jogmode | ONLY OPMODE = 8 Firmware >= 0.73 A rising edge starts a jogmode with speed VJOG. A falling edge stopps the movement.
IN4MODE=29 | Starting motion task / homing | Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A falling ege does not stop motion.
IN4MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INH4CMD, the command buffer for the negative edge is IN4LCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input.
IN4MODE=32 | Brake | Warning ! With suspended loads, this function will lead to slipping of the axes ! A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled.
IN4MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232. This setting can't be used in combination with GUI software.
IN4MODE=36 | Give Offset to Gearing Function | Gearing mode OPMODE =4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN4TRIG. The scaling is in 32Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN4TRIG can be calculated: IN4TRIG = n [rpm]*2^32/(4000*60) example: n = 500 [U/min] INxTRIG = 500 * 2^32 / (4000*60) = 8947848
IN1MODE=37 | change of source for position detection with EXTPOS > 0 | = 0 Position from the external encoder (preselection with EXTPOS). = 1 Position is detected by the first encoder on the motor (FBTYPE).
IN4MODE=38 | Enable signal for following motion task | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN4MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN4TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT), bit 15 is the sign and defines the moving direction and the time by the upper 16 bit (given in msec) of the help variable IN4TRIG. A rising edge at INPUT1 changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN4TRIG. After the defined time or a falling edge at INPUT1 is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN4TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN4TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN4TRIG = 0x000afe0c = 720396
IN4MODE=40 | Additional hardware input | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage.
IN4MODE=41 | Emergency Stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN4MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time.
IN4MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN1MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN4TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position.
IN4MODE=49 | emergency stop (sensorless) | (High active) By a going edge an emergency stop is activated (current controlled without feedback)
IN4MODE=50 |  |
IN4MODE=51 |  |
IN4MODE=53 |  |
IN4MODE=57 | switch to second parameter set | Low: std. Parameter used High: second Parameter group used see also command PARCNFG
IN4MODE=60 | VOSPD-Switch | Switch Overspeed Threshhold (VOSPD)
IN4MODE=62 | discharge of the dc-bus | When the DC-Bus should be discharge, first switch off the main voltage. Manually, set the digital input to 1, after some seconds, the DC-Link capacitor is discharged and VBUS nearby 0 Set back the digital input to 0 and now the DC-Bus can be charged again and the amplifier can be operated as normal. Danger: In order to prevent this function from being activated when the supply is switched on, the net-BTB signal (power supply on) is internally monitored. If the monitoring of the net BTB is switched off (NONBTB> 0), this function can not be used.


ASCII English IN4TRIG

ASCII - Command | IN4TRIG |
Syntax Transmit | IN4TRIG [Data] |
Syntax Receive | IN4TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 356C (hex)
DIM | - | PROFIBUS PNU | 1708 (dec) IND = 1 (dec)
Range | -2147483648 .. 2147483647 | DPR | 108 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for IN4MODE

Description

Auxiliary trigger variable for IN4MODE. Certain settings of IN4MODE require you to specify an additional trigger level. See IN4MODE for further details.


ASCII English IN5

ASCII - Command | IN5 |
Syntax Transmit | IN5MODE [Data] |
Syntax Receive | IN5 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36F5 (hex)
DIM |  | PROFIBUS PNU | 1701 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 501 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN5_22

ASCII - Command | IN5_22 |
Syntax Transmit | IN5 ... IN22 |
Syntax Receive | IN5 ... IN22 | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital inputs 5 ... 22

Description

The status of the digital input INPUTx. X = 5 ... 22


ASCII English IN5_22MODE

ASCII - Command | IN5_22MODE |
Syntax Transmit | INxMODE [Data] |
Syntax Receive | IN5_22MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 90 | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital inputs 5 ...22

Description

The commands IN5MODE ... IN22MODE are used to set the mode of the digital inputs INPUT5 .... INPUT22.

4 digital inputs are given by the standard S300/S700 hardware. 18 additional digital inputs can be controlled by the firmware, so 22 digital inputs are availbale.

The digital I/O’s are the 24V inputs (hardware) and the software I/O’s (controlled by software : Fildbus, RS232, DPR-interface).

The possible combinations are:

without I/O-extensioncard

1. hardware
input basic unit: 4 (IN1 - IN4)

2. software
virtual inputs: 18 (IN5 - IN22)

with I/O-extensioncard

1. hardware
inputs basic unit: 4 (IN1 - IN4)
inputs extension card 14 (IN5 – IN18)

2. software
virtual inputs: 4 (IN19 - IN22)

All digital inputs can be set to several configurations.
The command INxMODE sets the used function. (x is the number of the used input). The auxiliary coefficient is set to the command INxTRIG
(x = 5, 6, ....20)
seeIN5_20TRIG

The input status can be monitored via command INx
(x = 5, 6, ....20)
see IN5...20 .

Following settings are not possible:

INxMODE =

NSTOP/PSTOP-Function (INxMODE=2,3,4,5,6,7) only for x=3,4 .
Latch-Function (INxMODE=26,44,45,46) only for x=1,2
ASCII-Buffer (INxMODE=30,33) only for x=1...6

The PNU numbers are selected like

IN5MODE PNU 1702 (dec) IND 17 (dec)
IN6MODE PNU 1705 (dec) IND 17 (dec)
IN7MODE PNU 1708 (dec) IND 17 (dec)
IN8MODE PNU 1711 (dec) IND 17 (dec)
IN9MODE PNU 1714 (dec) IND 17 (dec)
IN10MODE PNU 1717 (dec) IND 17 (dec)
IN11MODE PNU 1720 (dec) IND 17 (dec)
IN12MODE PNU 1723 (dec) IND 17 (dec)
IN13MODE PNU 1726 (dec) IND 17 (dec)
IN14MODE PNU 1729 (dec) IND 17 (dec)
IN15MODE PNU 1732 (dec) IND 17 (dec)
IN16MODE PNU 1735 (dec) IND 17 (dec)
IN17MODE PNU 1738 (dec) IND 17 (dec)
IN18MODE PNU 1741 (dec) IND 17 (dec)
IN19MODE PNU 1744 (dec) IND 17 (dec)
IN20MODE PNU 1747 (dec) IND 17 (dec)
IN21MODE PNU 1827 (dec) IND 17 (dec)
IN22MODE PNU 1830 (dec) IND 17 (dec)


ASCII English IN5_22TRIG

ASCII - Command | IN5_22TRIG |
Syntax Transmit | INxTRIG [Data] |
Syntax Receive | IN5_22TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | long int | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital inputs 5 ... 22

Description

Auxiliary trigger variable. Certain settings require you to specify an additional trigger level. See IN5_22MODE for further details.


ASCII English IN5MODE

ASCII - Command | IN5MODE |
Syntax Transmit | IN5MODE [Data] |
Syntax Receive | IN5MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36F6 (hex)
DIM |  | PROFIBUS PNU | 1702 (dec) IND = 17 (dec)
Range |  | DPR | 502 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN5TRIG

ASCII - Command | IN5TRIG |
Syntax Transmit | IN5TRIG [Data] |
Syntax Receive | IN5TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36F7 (hex)
DIM |  | PROFIBUS PNU | 1703 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 503 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN6

ASCII - Command | IN6 |
Syntax Transmit | IN6 [Data] |
Syntax Receive | IN6 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36F8 (hex)
DIM |  | PROFIBUS PNU | 1704 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 504 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN6MODE

ASCII - Command | IN6MODE |
Syntax Transmit | IN6MODE [Data] |
Syntax Receive | IN6MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36F9 (hex)
DIM |  | PROFIBUS PNU | 1705 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 505 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN6TRIG

ASCII - Command | IN6TRIG |
Syntax Transmit | IN6TRIG [Data] |
Syntax Receive | IN6TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36FA (hex)
DIM |  | PROFIBUS PNU | 1706 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 506 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN7

ASCII - Command | IN7 |
Syntax Transmit | IN7 [Data] |
Syntax Receive | IN7 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36FB (hex)
DIM |  | PROFIBUS PNU | 1707 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 507 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN7MODE

ASCII - Command | IN7MODE |
Syntax Transmit | IN7MODE [Data] |
Syntax Receive | IN7MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36FC (hex)
DIM |  | PROFIBUS PNU | 1708 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 508 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN7TRIG

ASCII - Command | IN7TRIG |
Syntax Transmit | IN7TRIG [Data] |
Syntax Receive | IN7TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36FD (hex)
DIM |  | PROFIBUS PNU | 1709 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 509 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN8

ASCII - Command | IN8 |
Syntax Transmit | IN8 [Data] |
Syntax Receive | IN8 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36FE (hex)
DIM |  | PROFIBUS PNU | 1710 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 510 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN8MODE

ASCII - Command | IN8MODE |
Syntax Transmit | IN8MODE [Data] |
Syntax Receive | IN8MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36FF (hex)
DIM |  | PROFIBUS PNU | 1711 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 511 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN8TRIG

ASCII - Command | IN8TRIG |
Syntax Transmit | IN8TRIG [Data] |
Syntax Receive | IN8TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3700 (hex)
DIM |  | PROFIBUS PNU | 1712 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 512 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN9

ASCII - Command | IN9 |
Syntax Transmit | IN9 [Data] |
Syntax Receive | IN9 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3701 (hex)
DIM |  | PROFIBUS PNU | 1713 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 513 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN9MODE

ASCII - Command | IN9MODE |
Syntax Transmit | IN9MODE [Data] |
Syntax Receive | IN9MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3702 (hex)
DIM |  | PROFIBUS PNU | 1714 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 514 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN9TRIG

ASCII - Command | IN9TRIG |
Syntax Transmit | IN9TRIG [Data] |
Syntax Receive | IN9TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3703 (hex)
DIM |  | PROFIBUS PNU | 1715 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 515 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN10

ASCII - Command | IN10 |
Syntax Transmit | IN10 |
Syntax Receive | IN10 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3704 (hex)
DIM |  | PROFIBUS PNU | 1716 (dec) IND = 17 (dec)
Range |  | DPR | 516 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN10MODE

ASCII - Command | IN10MODE |
Syntax Transmit | IN10MODE [Data] |
Syntax Receive | IN10MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3705 (hex)
DIM |  | PROFIBUS PNU | 1717 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 517 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN10TRIG

ASCII - Command | IN10TRIG |
Syntax Transmit | IN10TRIG [Data] |
Syntax Receive | IN10TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3706 (hex)
DIM |  | PROFIBUS PNU | 1718 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 518 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN11

ASCII - Command | IN11 |
Syntax Transmit | IN11 |
Syntax Receive | IN11 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3707 (hex)
DIM |  | PROFIBUS PNU | 1719 (dec) IND = 17 (dec)
Range |  | DPR | 519 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN11MODE

ASCII - Command | IN11MODE |
Syntax Transmit | IN11MODE [Data] |
Syntax Receive | IN11MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3708 (hex)
DIM |  | PROFIBUS PNU | 1720 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 520 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN11TRIG

ASCII - Command | IN11TRIG |
Syntax Transmit | IN11TRIG [Data] |
Syntax Receive | IN11TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3709 (hex)
DIM |  | PROFIBUS PNU | 1721 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 521 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN12

ASCII - Command | IN12 |
Syntax Transmit | IN12 |
Syntax Receive | IN12 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 370A (hex)
DIM |  | PROFIBUS PNU | 1722 (dec) IND = 17 (dec)
Range |  | DPR | 522 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN12MODE

ASCII - Command | IN12MODE |
Syntax Transmit | IN12MODE [Data] |
Syntax Receive | IN12MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 370B (hex)
DIM |  | PROFIBUS PNU | 1723 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 523 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN12TRIG

ASCII - Command | IN12TRIG |
Syntax Transmit | IN12TRIG [Data] |
Syntax Receive | IN12TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 370C (hex)
DIM |  | PROFIBUS PNU | 1724 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 524 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN13

ASCII - Command | IN13 |
Syntax Transmit | IN13 |
Syntax Receive | IN13 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 370D (hex)
DIM |  | PROFIBUS PNU | 1725 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 525 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN13MODE

ASCII - Command | IN13MODE |
Syntax Transmit | IN13MODE [Data] |
Syntax Receive | IN13MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 370E (hex)
DIM |  | PROFIBUS PNU | 1726 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 526 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN13TRIG

ASCII - Command | IN13TRIG |
Syntax Transmit | IN13TRIG [Data] |
Syntax Receive | IN13TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 370F (hex)
DIM |  | PROFIBUS PNU | 1727 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 527 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN14

ASCII - Command | IN14 |
Syntax Transmit | IN14 |
Syntax Receive | IN14 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3710 (hex)
DIM |  | PROFIBUS PNU | 1728 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 528 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN14MODE

ASCII - Command | IN14MODE |
Syntax Transmit | IN14MODE [Data] |
Syntax Receive | IN14MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3711 (hex)
DIM |  | PROFIBUS PNU | 1729 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 529 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN14TRIG

ASCII - Command | IN14TRIG |
Syntax Transmit | IN14TRIG [Data] |
Syntax Receive | IN14TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3712 (hex)
DIM |  | PROFIBUS PNU | 1730 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 530 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN15

ASCII - Command | IN15 |
Syntax Transmit | IN15 |
Syntax Receive | IN15 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3713 (hex)
DIM |  | PROFIBUS PNU | 1731 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 531 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN15MODE

ASCII - Command | IN15MODE |
Syntax Transmit | IN15MODE [Data] |
Syntax Receive | IN15MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3714 (hex)
DIM |  | PROFIBUS PNU | 1732 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 532 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN15TRIG

ASCII - Command | IN15TRIG |
Syntax Transmit | IN15TRIG [Data] |
Syntax Receive | IN15TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3715 (hex)
DIM |  | PROFIBUS PNU | 1733 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 533 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN16

ASCII - Command | IN16 |
Syntax Transmit | IN16 |
Syntax Receive | IN16 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3716 (hex)
DIM |  | PROFIBUS PNU | 1734 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 534 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN16MODE

ASCII - Command | IN16MODE |
Syntax Transmit | IN16MODE [Data] |
Syntax Receive | IN16MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3717 (hex)
DIM |  | PROFIBUS PNU | 1735 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 535 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN16TRIG

ASCII - Command | IN16TRIG |
Syntax Transmit | IN16TRIG [Data] |
Syntax Receive | IN16TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3718 (hex)
DIM |  | PROFIBUS PNU | 1736 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 536 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN17

ASCII - Command | IN17 |
Syntax Transmit | IN17 |
Syntax Receive | IN17 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3719 (hex)
DIM |  | PROFIBUS PNU | 1737 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 537 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN17MODE

ASCII - Command | IN17MODE |
Syntax Transmit | IN17MODE [Data] |
Syntax Receive | IN17MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 371A (hex)
DIM |  | PROFIBUS PNU | 1738 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 538 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN17TRIG

ASCII - Command | IN17TRIG |
Syntax Transmit | IN17TRIG [Data] |
Syntax Receive | IN17TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 371B (hex)
DIM |  | PROFIBUS PNU | 1739 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 539 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN18

ASCII - Command | IN18 |
Syntax Transmit | IN18 |
Syntax Receive | IN18 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 371C (hex)
DIM |  | PROFIBUS PNU | 1740 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 540 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN18MODE

ASCII - Command | IN18MODE |
Syntax Transmit | IN18MODE [Data] |
Syntax Receive | IN18MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 371D (hex)
DIM |  | PROFIBUS PNU | 1741 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 541 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN18TRIG

ASCII - Command | IN18TRIG |
Syntax Transmit | IN18TRIG [Data] |
Syntax Receive | IN18TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 371E (hex)
DIM |  | PROFIBUS PNU | 1742 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 542 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN19

ASCII - Command | IN19 |
Syntax Transmit | IN19 |
Syntax Receive | IN19 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 371F (hex)
DIM |  | PROFIBUS PNU | 1743 (dec) IND = 17 (dec)
Range | 0 .. 1 | DPR | 543 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of Digital Input

Description

see IN5_22


ASCII English IN19HCMD

ASCII - Command | IN19HCMD |
Syntax Transmit | IN19HCMD [Data] |
Syntax Receive | IN19HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

see IN2HCMD


ASCII English IN19LCMD

ASCII - Command | IN19LCMD |
Syntax Transmit | IN19LCMD [Data] |
Syntax Receive | IN19LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

see IN2LCMD


ASCII English IN19MODE

ASCII - Command | IN19MODE |
Syntax Transmit | IN19MODE [Data] |
Syntax Receive | IN19MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3720 (hex)
DIM |  | PROFIBUS PNU | 1744 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 544 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN19TRIG

ASCII - Command | IN19TRIG |
Syntax Transmit | IN19TRIG [Data] |
Syntax Receive | IN19TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3721 (hex)
DIM |  | PROFIBUS PNU | 1745 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 545 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN20

ASCII - Command | IN20 |
Syntax Transmit | IN20 |
Syntax Receive | IN20 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3722 (hex)
DIM |  | PROFIBUS PNU | 1746 (dec) IND = 17 (dec)
Range |  | DPR | 546 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | No
Short Description | Status of digital input

Description

see IN5_22


ASCII English IN20HCMD

ASCII - Command | IN20HCMD |
Syntax Transmit | IN20HCMD [Data] |
Syntax Receive | IN20HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for high level

Description

see IN2HCMD


ASCII English IN20LCMD

ASCII - Command | IN20LCMD |
Syntax Transmit | IN20LCMD [Data] |
Syntax Receive | IN20LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | max 64 ASCII Characters | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Command buffer for low level

Description

see IN2LCMD


ASCII English IN20MODE

ASCII - Command | IN20MODE |
Syntax Transmit | IN20MODE [Data] |
Syntax Receive | IN20MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3723 (hex)
DIM |  | PROFIBUS PNU | 1747 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 547 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

see IN5_22MODE


ASCII English IN20TRIG

ASCII - Command | IN20TRIG |
Syntax Transmit | IN20TRIG [Data] |
Syntax Receive | IN20TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3724 (hex)
DIM |  | PROFIBUS PNU | 1748 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 548 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

see IN5_22TRIG


ASCII English IN21MODE

ASCII - Command | IN21MODE |
Syntax Transmit | IN21MODE [Data] |
Syntax Receive | IN21MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3773 (hex)
DIM |  | PROFIBUS PNU | 1827 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 627 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

only S700:
see IN5_22MODE


ASCII English IN21TRIG

ASCII - Command | IN21TRIG |
Syntax Transmit | IN21TRIG [Data] |
Syntax Receive | IN21TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3774 (hex)
DIM |  | PROFIBUS PNU | 1828 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 628 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

only S700:
see IN5_22TRIG


ASCII English IN22MODE

ASCII - Command | IN22MODE |
Syntax Transmit | IN22MODE [Data] |
Syntax Receive | IN22MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3776 (hex)
DIM |  | PROFIBUS PNU | 1830 (dec) IND = 17 (dec)
Range | 0 .. 90 | DPR | 630 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital input

Description

only S700:
see IN5_22MODE


ASCII English IN22TRIG

ASCII - Command | IN22TRIG |
Syntax Transmit | IN22TRIG [Data] |
Syntax Receive | IN22TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3777 (hex)
DIM |  | PROFIBUS PNU | 1831 (dec) IND = 17 (dec)
Range | -2147483648 .. 2147483647 | DPR | 631 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | digital I/O | EEPROM | Yes
Short Description | Variable for digital input

Description

only S700:
see IN5_22TRIG


ASCII English Index

\
ACC
ACC_X
ACCR
ACCUNIT
ACTFAULT
ACTIVE
ACTRS232
ADC0_15
ADDR
AENA
ALIAS
AN11NR
AN11RANGE
AN1TRIG
AN2TRIG
ANCNFG
ANDB
ANHFACT1
ANHFACT2
ANIN1
ANIN2
ANIN3
ANIN4
ANOFF1
ANOFF2
ANOFF3
ANOFF4
ANOUT1
ANOUT2
ANZERO1
ANZERO2
ANZERO3
ANZERO4
ARHPD
ARHPF
ARLP2
ARLPD
ARLPF
ASMWAIT
AUTOHOME
AVZ1
AVZ2
BCC
BCCOT
BISSCNFG
BISSREVOL
BQMODE
BTIME
BUILDRK
BUILDRP
BUSP0
BUSP1
BUSP10
BUSP11
BUSP12
BUSP13
BUSP14
BUSP15
BUSP16
BUSP2
BUSP3
BUSP4
BUSP5
BUSP6
BUSP7
BUSP8
BUSP9
CALCCOG
CALCHP
CALCMP
CALCPOSIO
CALCRK
CALCRP
CANDUMP
CANSDO
CARDDEL
CARDDIR
CARDINFO
CARDSAVE
CARDUPDATE
CBAUD
CCSAVE
CINPOS
CLRFAULT
CLRHR
CLRORDER
CLRWARN
CMDDLY
COGFILT
COGMODE
COGRED
COLDSTART
CONTINUE
CPHASE
CSCNFG
CSENID
CSERR
CSIDMAX
CSIOSTAT
CSSTAT
CTUNE
CUPDATE
DAOFFSET1
DAOFFSET2
DEC
DEC_X
DECDIS
DECR
DECSTOP
DENA
DI2T
DICONT
DIFVAR
DILIM
DIPEAK
DIR
DIRIN
DIROUT
DIS
DISDPR
DNBAUD
DNDUMP
DNMACID
DOVRIDE
DPRILIMIT
DPRSTATE
DPRVAR1_16
DPV17_64
DPWM
DR_TYPE
DREF
DRIVE
DRVCNFG
DRVCNFG2
DRVCNFG3
DRVCNFG4
DRVSTAT
DRVSTAT2
DUMP
DUMPEMAP
DUMPSLNO
ECATCSA
EGEARI
EGEARO
EMRGTO
EN
EN22A1CNT
EN22A2CNT
EN22AI1
EN22AI2
EN22CNFG
EN22DCNT
EN22DIAG
ENCDIV
ENCDIVD
ENCFIX
ENCFIXD
ENCIN
ENCLINES
ENCMODE
ENCOUT
ENCTO
ENCVON
ENCZERO
ENGAGE
ERESMASK
ERND
ERRCNFG
ERRCODE
ERRCODE *
ERRCODE2
ERRMASK
ERRPARAM
ERRTIME
ESPEED
ETHMODE
EWH
EXTBRAKE
EXTLATCH
EXTPOS
EXTWD
FBGEARI
FBGEARO
FBTYPE
FBTYPEX
FFTSW
FHKP
FHTN
FILTMODE
FLTCNT
FLTCNT *
FLTHIST
FLTHIST *
FW
GEARFILT
GEARI
GEARMODE
GEARO
GET
GF
GFTN
GP
GP_X
GP2
GPDELAY
GPFFT
GPFFT_X
GPFFTV
GPFFV
GPFFV_X
GPFFVDELAY
GPS1
GPS2
GPTN
GPTN_X
GPTNTH1
GPTNTH2
GPTNTH3
GU
GUTN
GV
GV_X
GV2
GVFR
GVFR_X
GVS1
GVS2
GVTN
GVTN_X
GVTV
HALLDIR
HALLENDIR
HDSLLED
HDSLPOS
HDSLRANGE
HDSLROTAT
HDSLTEMP
HDSLTIME
HDSLTYPE
HDSLVEL
HDSLVOLT
HDUMP
HELP
HICOFFS
HIFACT1
HISOFFS
HLIMIT1
HLIMIT2
HLIMIT3
HSAVE
HVER
HWCNT
I
I2TLIM
ICMD
ICMDVLIM
ID
IDDUMP
IEXTT
IEXTTLIM
IN
IN1
IN10
IN10MODE
IN10TRIG
IN11
IN11MODE
IN11TRIG
IN12
IN12MODE
IN12TRIG
IN13
IN13MODE
IN13TRIG
IN14
IN14MODE
IN14TRIG
IN15
IN15MODE
IN15TRIG
IN16
IN16MODE
IN16TRIG
IN17
IN17MODE
IN17TRIG
IN18
IN18MODE
IN18TRIG
IN19
IN19HCMD
IN19LCMD
IN19MODE
IN19TRIG
IN1HCMD
IN1LCMD
IN1MODE
IN1TRIG
IN2
IN20
IN20HCMD
IN20LCMD
IN20MODE
IN20TRIG
IN21MODE
IN21TRIG
IN22MODE
IN22TRIG
IN2HCMD
IN2LCMD
IN2MODE
IN2PM
IN2TRIG
IN3
IN3HCMD
IN3LCMD
IN3MODE
IN3TRIG
IN4
IN4HCMD
IN4LCMD
IN4MODE
IN4TRIG
IN5
IN5_22
IN5_22MODE
IN5_22TRIG
IN5MODE
IN5TRIG
IN6
IN6MODE
IN6TRIG
IN7
IN7MODE
IN7TRIG
IN8
IN8MODE
IN8TRIG
IN9
IN9MODE
IN9TRIG
INPOS
INPT0
INPT1
INTERPOL
IOLINK
IPEAK
IPEAKN
IPEAKP
IQ
IQFILTK
IQFILTTAU
ISCALE1
ISCALE2
ISTFR
IVTICK
J
JRATIO
K
KC
KC_X
KEYLOCK
KTN
KTN_X
LASTWMASK
LATCH1N16
LATCH1N32
LATCH1P16
LATCH1P32
LATCH2N16
LATCH2N32
LATCH2P16
LATCH2P32
LDUMP
LED1
LED2
LED3
LEDSTAT
LINRESOL
LIST
LOAD
M
M_RESET
MAXCMD
MAXISETP
MAXSUMME
MAXTEMPE
MAXTEMPH
MAXTEMPM
MAXVSETP
MBPDRVSTAT
MBRAKE
MCFW
MCOSPHI
MCTR
MDBCNT
MDBGET
MDBLIST
MDBSET
MDRV
MFR
MH
MI2T
MICONT
MICONT_X
MIMR
MIMRQ
MINSUMME
MIPEAK
MIPEAK_X
MJ
MJ_X
MJOG
MKT
MKT_X
ML
ML_X
MLGC
MLGC_X
MLGD
MLGD_X
MLGP
MLGP_X
MLGQ
MLGQ_X
MNAME
MNUMBER
MONITOR1
MONITOR2
MOVE
MPHASE
MPHASE2
MPITCH
MPKD
MPKI
MPKP
MPOLES
MPOLES_X
MPR
MPTIME
MRESBW
MRESPOLES
MRS
MRS_X
MSERIALNO
MSG
MSLBRAKE
MSPEED
MTAB
MTANGLP
MTIME
MTIME_X
MTMUX
MTR
MTYPE
MUR
MVANGLB
MVANGLF
MVANGLMODE
MVANGLP
MVER
MVR
NONBTB
NREF
NREFG
NREFMT
O_ACC
O_C
O_DEC
O_FN
O_FT
O_P
O_TAB
O_V
O1
O10
O10MODE
O10TRIG
O11
O11MODE
O11TRIG
O12
O12MODE
O12TRIG
O13
O13MODE
O13TRIG
O14
O14MODE
O14TRIG
O15
O15MODE
O15TRIG
O16
O16MODE
O16TRIG
O17
O17MODE
O17TRIG
O18
O18MODE
O18TRIG
O1MODE
O1TRIG
O2
O2MODE
O2TRIG
O3
O3_18
O3_18MODE
O3_18TRIG
O3MODE
O3TRIG
O4
O4MODE
O4TRIG
O5
O5MODE
O5TRIG
O6
O6MODE
O6TRIG
O7
O7MODE
O7TRIG
O8
O8MODE
O8TRIG
O9
O9MODE
O9TRIG
OCOPY
OLIST
OPMODE
OPTION
OPTION2
ORDER
OTUNE
OVRIDE
P
P1
P1_P16
P10
P11
P12
P13
P14
P15
P16
P2
P3
P4
P5
P6
P7
P8
P9
PARCNFG
PARDUMP
PARRST
PASS
PASSCNFG
PASSPLC
PASSX
PASSXPLC
PBAL
PBALMAX
PBALRES
PBAUD
PE
PEINPOS
PEMAX
PFB
PFB0
PFBHI
PFBLO
PGEARI
PGEARO
PIOBUF
PLLCOFFS
PLLDOFFS
PLLHUB
PLLWOFFS
PMECH
PMODE
PNOID
POSCNFG
POSRSTAT
PPOTYP
PRBASE
PRD
PRIOR1
PRIOR2
PRIOR3
PRIOR4
PRIOR5
PROMPT
PSINUS
PSTATE
PSTEP
PTARGET
PTARGOFFS
PTBASE
PTMIN
PUNIT
PV
PVMAX
PVMAXN
PVMAXP
QCNFG
QENA
QFACT
QFACTCOMP
QFACTFILT
QFACTOR
QFCFACT
QFCMD
QFCMDFILT
QFMAX
QFSET
QKPEFF
QMACT
QMCMD
QMCMDLIM
QMLIMN
QMLIMP
QPE
QPRACT
QPRMAX
QPRSET
QPRSETEFF
QT1
QTAB1KP
QTAB1TN
QTAB1TV
QTAB1V
QTAB2KP
QTAB2TN
QTAB2TV
QTAB2V
QTAB3KP
QTAB3TN
QTAB3TV
QTAB3V
QTAB4KP
QTAB4TN
QTAB4TV
QTAB4V
QTAB5KP
QTAB5TN
QTAB5TV
QTAB5V
QTABID
QTIMEKD
QTNEFF
QTVEFF
QVAL
QVT1
RDP
RDPBIAS
RDPBIAS2
RDPCLAMP
RDPINT
RDPKI
RDPKP
RDPON
READY
RECDONE
RECING
RECOFF
RECORD
RECRDY
RECTRIG
REFIP
REFIP2
REFLS
REFMODE
REFNOFFS
REFNPOS
REFPOS
RELTIME
REMOTE
RESAMPL
RESOLVER
RESPHASE
RK
ROFFS
ROFFSABS
ROFFSSSI
RS232T
RSTVAR
RSVERROFF
RUNIN
S
S1DLY
SAVE
SBAUD
SCAN
SDLY
SERCERR
SERCLIST
SERCOFFS
SERCOS
SERCSET
SERIALNO
SETENCOFFS
SETREF
SKIP1SP
SKIP1W
SKIP2SP
SKIP2W
SLACCMAX
SLEN
SLIDK01
SLIMAX
SLIQK
SLIQK1
SLJSWITCH
SLMODE
SLOTIO
SLTEMPM
SLTSWITCH
SMNUMBER
SOFTIN
SOFTOUT
SPHAS
SRND
SSIGRAY
SSIINV
SSIMASK
SSIRESOL
SSIREVOL
SSIRXD
SSITIME
SSITOUT
SSTAT
STAGECODE
STAT
STATCODE
STATCODE *
STATIO
STATUS
STEP
STOP
STOPMODE
SWCNFG
SWE1
SWE2
SYNCSRC
T
TASK
TBRAKE
TBRAKE0
TEMPE
TEMPH
TEMPM
TEMPMFILT
TEN
TEST1
TESTENC
TRJSTAT
TRUN
TRUNS
TSTEP
UCOMP
UID
UMAX
UPDATE
UVLTMODE
V
VBUS
VBUSBAL
VBUSBOFFS
VBUSCNTMAX
VBUSFACT
VBUSLIM
VBUSMAX
VBUSMIN
VBUSOFFS
VBUSRAMP
VBW
VCMD
VCOMM
VCTIME
VEL0
VER
VINPOS
VJOG
VLIM
VLIMN
VLIMP
VLO
VLO_X
VMIX
VMUL
VOHPD
VOHPF
VOLPD
VOMODE
VOMOPDE
VOSPD
VOSPDREF
VOUTMAX
VREF
VREF0
VSCALE1
VSCALE2
VSTART
VSTFR
VTIMEKD
VTUNE
VUNIT
VWM
WMASK
WPOS
WPOSE
WPOSP
WPOSX
WSAMPL
WSCNFG
WSLOOP
WSRED
WSTIME
WSTIME2
WSTIME3
ZERO
ZEROTIME


ASCII English Index Group

MAXCMD | Sonstige
ANIN3 | analog I/O
VSCALE1 | analog I/O
VSCALE2 | analog I/O
ISCALE2 | analog I/O
AN11NR | analog I/O
AN11RANGE | analog I/O
ANCNFG | analog I/O
ADC0_15 | analog I/O
ANZERO4 | analog I/O
ANZERO3 | analog I/O
ANOFF4 | analog I/O
ANZERO2 | analog I/O
ANIN4 | analog I/O
DAOFFSET2 | analog I/O
MONITOR2 | analog I/O
MONITOR1 | analog I/O
DAOFFSET1 | analog I/O
ANOUT2 | analog I/O
ANOUT1 | analog I/O
AN2TRIG | analog I/O
AN1TRIG | analog I/O
IN | digital I/O
ISCALE1 | analog I/O
ANOFF3 | analog I/O
ANZERO1 | analog I/O
ANOFF2 | analog I/O
ANOFF1 | analog I/O
ANIN1 | analog I/O
ANDB | analog I/O
ANIN2 | analog I/O
LED2 | display
KEYLOCK | display
LED1 | display
LEDSTAT | display
LED3 | display
O6TRIG | digital I/O
EXTLATCH | digital I/O
O9TRIG | digital I/O
O7TRIG | digital I/O
IN17 | digital I/O
IOLINK | digital I/O
O5TRIG | digital I/O
O4TRIG | digital I/O
O3TRIG | digital I/O
IN16 | digital I/O
O3_18MODE | digital I/O
IN20LCMD | digital I/O
IN13 | digital I/O
LATCH2P32 | digital I/O
ACCUNIT | digital I/O
O12TRIG | digital I/O
O11TRIG | digital I/O
IN2PM | digital I/O
IN11MODE | digital I/O
O18TRIG | digital I/O
LATCH1N16 | digital I/O
O8MODE | digital I/O
LATCH2N16 | digital I/O
LATCH2P16 | digital I/O
SOFTOUT | digital I/O
O10TRIG | digital I/O
IN19LCMD | digital I/O
IN11 | digital I/O
O8TRIG | digital I/O
O1 | digital I/O
O9 | digital I/O
BTIME | digital I/O
O9MODE | digital I/O
IN8 | digital I/O
IN10MODE | digital I/O
IN1MODE | digital I/O
O10MODE | digital I/O
IN15 | digital I/O
DIRIN | digital I/O
O13MODE | digital I/O
PUNIT | digital I/O
O1MODE | digital I/O
IN3TRIG | digital I/O
O2TRIG | digital I/O
IN2TRIG | digital I/O
O18 | digital I/O
IN20MODE | digital I/O
O14MODE | digital I/O
IN2 | digital I/O
IN4 | digital I/O
IN3 | digital I/O
IN20TRIG | digital I/O
IN19MODE | digital I/O
IN18TRIG | digital I/O
IN3MODE | digital I/O
O4MODE | digital I/O
IN20 | digital I/O
O16MODE | digital I/O
O15 | digital I/O
DIROUT | digital I/O
O15MODE | digital I/O
O5MODE | digital I/O
SLOTIO | digital I/O
IN14 | digital I/O
IN19 | digital I/O
SOFTIN | digital I/O
O3MODE | digital I/O
IN21MODE | digital I/O
IN21TRIG | digital I/O
O3_18 | digital I/O
IN22MODE | digital I/O
IN22TRIG | digital I/O
O3 | digital I/O
O12MODE | digital I/O
O11MODE | digital I/O
IN15MODE | digital I/O
IN4HCMD | digital I/O
IN4LCMD | digital I/O
IN19TRIG | digital I/O
IN9MODE | digital I/O
O17MODE | digital I/O
O17TRIG | digital I/O
O18MODE | digital I/O
O16 | digital I/O
IN16MODE | digital I/O
LATCH1N32 | digital I/O
O1TRIG | digital I/O
O2 | digital I/O
O2MODE | digital I/O
IN4TRIG | digital I/O
IN5 | digital I/O
IN5_22 | digital I/O
O17 | digital I/O
IN14MODE | digital I/O
IN2LCMD | digital I/O
IN1HCMD | digital I/O
LATCH2N32 | digital I/O
LATCH1P32 | digital I/O
IN7 | digital I/O
IN9TRIG | digital I/O
LATCH1P16 | digital I/O
IN6 | digital I/O
IN5_22TRIG | digital I/O
VUNIT | digital I/O
IN17MODE | digital I/O
O6MODE | digital I/O
IN18 | digital I/O
IN1LCMD | digital I/O
IN2HCMD | digital I/O
IN2MODE | digital I/O
IN3HCMD | digital I/O
IN3LCMD | digital I/O
O7MODE | digital I/O
IN18MODE | digital I/O
IN10 | digital I/O
IN1TRIG | digital I/O
O3_18TRIG | digital I/O
IN13MODE | digital I/O
O13 | digital I/O
IN9 | digital I/O
IN7MODE | digital I/O
IN8MODE | digital I/O
O13TRIG | digital I/O
O14TRIG | digital I/O
O12 | digital I/O
O16TRIG | digital I/O
IN19HCMD | digital I/O
O4 | digital I/O
O5 | digital I/O
O6 | digital I/O
O7 | digital I/O
O8 | digital I/O
IN12MODE | digital I/O
O10 | digital I/O
O11 | digital I/O
O15TRIG | digital I/O
IN12TRIG | digital I/O
IN20HCMD | digital I/O
IN5_22MODE | digital I/O
IN5TRIG | digital I/O
IN6TRIG | digital I/O
IN7TRIG | digital I/O
IN8TRIG | digital I/O
IN1 | digital I/O
IN5MODE | digital I/O
IN11TRIG | digital I/O
IN4MODE | digital I/O
IN13TRIG | digital I/O
IN14TRIG | digital I/O
IN15TRIG | digital I/O
IN12 | digital I/O
IN16TRIG | digital I/O
O14 | digital I/O
IN17TRIG | digital I/O
IN6MODE | digital I/O
IN10TRIG | digital I/O
VTUNE | velocity loop
DEC_X | velocity loop
DECSTOP | velocity loop
VCTIME | velocity loop
ACC | velocity loop
ACC_X | velocity loop
GVS2 | velocity loop
VEL0 | velocity loop
VLIM | velocity loop
VLIMN | velocity loop
SLTSWITCH | velocity loop
DECDIS | velocity loop
GV | velocity loop
GVS1 | velocity loop
GVFR | velocity loop
J | velocity loop
VCMD | velocity loop
DEC | velocity loop
VCOMM | velocity loop
VINPOS | velocity loop
GVTN | velocity loop
GV2 | velocity loop
GV_X | velocity loop
VLIMP | velocity loop
GVTN_X | velocity loop
EMRGTO | velocity loop
GVFR_X | velocity loop
STEP | velocity loop
ENCOUT | encoder emulation
ENCZERO | encoder emulation
ENCMODE | encoder emulation
ROFFSABS | feedback
SSIRXD | feedback
RESPHASE | feedback
EXTPOS | feedback
VWM | feedback
BISSREVOL | feedback
ENCIN | feedback
EGEARO | feedback
TESTENC | feedback
SMNUMBER | feedback
HICOFFS | feedback
VLO | feedback
ROFFSSSI | feedback
CALCHP | feedback
EGEARI | feedback
HALLDIR | feedback
MRESBW | feedback
HIFACT1 | feedback
RK | feedback
ENCFIXD | feedback
ENCFIX | feedback
EN22A1CNT | feedback
LINRESOL | feedback
RESOLVER | feedback
BUILDRK | feedback
RESAMPL | feedback
EN22CNFG | feedback
SSIMASK | feedback
EN22A2CNT | feedback
ENCDIVD | feedback
SSITIME | feedback
FBTYPEX | feedback
ZERO | feedback
FBGEARO | feedback
FBGEARI | feedback
ENCDIV | feedback
ZEROTIME | feedback
HDSLTEMP | feedback
HISOFFS | feedback
FBTYPE | feedback
PSINUS | feedback
VMIX | feedback
HDSLVOLT | feedback
HDSLVEL | feedback
EN22AI1 | feedback
HDSLTIME | feedback
VLO_X | feedback
HDSLROTAT | feedback
HDSLRANGE | feedback
HDSLPOS | feedback
HDSLLED | feedback
EN22DIAG | feedback
EN22DCNT | feedback
EN22AI2 | feedback
HDSLTYPE | feedback
SSIREVOL | feedback
ENCLINES | feedback
SSITOUT | feedback
MPHASE2 | feedback
SSIRESOL | feedback
MRESPOLES | feedback
MPHASE | feedback
BISSCNFG | feedback
SSIGRAY | feedback
SSIINV | feedback
RSVERROFF | feedback
BUSP15 | fieldbus
BUSP14 | fieldbus
BUSP13 | fieldbus
BUSP12 | fieldbus
BUSP11 | fieldbus
BUSP10 | fieldbus
PLLHUB | fieldbus
BUSP9 | fieldbus
BUSP7 | fieldbus
DUMPEMAP | Fieldbus
SBAUD | fieldbus
VMUL | fieldbus
ECATCSA | fieldbus
BUSP16 | fieldbus
SETENCOFFS | Feedback
BUSP8 | fieldbus
ETHMODE | fieldbus
SERCSET | fieldbus
PLLDOFFS | Fieldbus
MBPDRVSTAT | fieldbus
PIOBUF | fieldbus
PLLWOFFS | Fieldbus
SERCLIST | fieldbus
SSTAT | fieldbus
SCAN | fieldbus
SLEN | fieldbus
PLLCOFFS | fieldbus
BUSP0 | fieldbus
PPOTYP | fieldbus
IDDUMP | fieldbus
SPHAS | fieldbus
BUSP3 | fieldbus
SERCERR | fieldbus
SERCOS | fieldbus
BUSP2 | fieldbus
BUSP4 | fieldbus
DNDUMP | fieldbus
PNOID | fieldbus
EXTWD | fieldbus
BUSP1 | fieldbus
CBAUD | fieldbus
BUSP6 | fieldbus
DNBAUD | fieldbus
PBAUD | fieldbus
DNMACID | fieldbus
BUSP5 | fieldbus
CANSDO | fieldbus
PSTATE | fieldbus
SYNCSRC | fieldbus
CANDUMP | fieldbus
ARLPD | filter
ARHPD | filter
ARHPF | filter
FILTMODE | filter
AVZ2 | filter
ARLP2 | filter
VOHPF | filter
VOLPD | filter
VOHPD | filter
BQMODE | filter
ARLPF | filter
AVZ1 | filter
RUNIN | intern
SERCOFFS | intern
WSRED | intern
FHKP | intern
TEN | intern
NREFG | intern
TEST1 | intern
PRIOR2 | intern
PRIOR3 | intern
PRIOR4 | intern
PRIOR5 | intern
SLIMAX | intern
VOMODE | intern
VOMOPDE | intern
QVAL | intern
PRIOR1 | intern
BUILDRP | intern
GPFFVDELAY | intern
MIMRQ | intern
ANHFACT2 | intern
FHTN | intern
HALLENDIR | intern
HWCNT | intern
MCTR | intern
JRATIO | intern
MAXSUMME | intern
MINSUMME | intern
IVTICK | intern
ANHFACT1 | intern
V | actual values
P | actual values
ACTIVE | actual values
DRVSTAT2 | actual values
PFB | actual values
TRJSTAT | actual values
PFBHI | actual values
IQ | actual values
ERRCODE * | actual values
ID | actual values
PRD | actual values
EWH | actual values
ERRCODE | actual values
VBUS | actual values
PFBLO | actual values
READY | actual values
PV | actual values
DRVSTAT | actual values
REMOTE | actual values
I | actual values
PBAL | actual values
STATUS | actual values
STATIO | actual values
STATCODE * | actual values
STATCODE | actual values
STAT | actual values
DI2T | actual values
CLRHR | actual values
DICONT | actual values
PMECH | actual values
DIPEAK | actual values
PFB0 | actual values
DISDPR | control commands
MJOG | control commands
OPMODE | control commands
MH | control commands
DIS | control commands
MOVE | control commands
STOP | control commands
S | control commands
CONTINUE | control commands
EN | control commands
COLDSTART | control commands
CLRFAULT | control commands
K | control commands
ERND | drive configuration
CLRWARN | drive configuration
WMASK | drive configuration
\ | drive configuration
CALCRK | drive configuration
DRVCNFG | drive configuration
LOAD | drive configuration
HELP | drive configuration
LASTWMASK | drive configuration
OPTION | drive configuration
HDUMP | drive configuration
BCC | drive configuration
VER | drive configuration
PASSXPLC | drive configuration
LIST | drive configuration
M | drive configuration
M_RESET | drive configuration
S1DLY | drive configuration
DRVCNFG4 | drive configuration
FLTCNT * | drive configuration
ERRMASK | drive configuration
FLTHIST * | drive configuration
PASSPLC | drive configuration
PBALMAX | drive configuration
RELTIME | drive configuration
ALIAS | drive configuration
DRVCNFG3 | drive configuration
VBUSLIM | drive configuration
PASSCNFG | drive configuration
MPITCH | drive configuration
ENGAGE | drive configuration
MSG | drive configuration
VBUSBAL | drive configuration
PASS | drive configuration
PASSX | drive configuration
CALCPOSIO | drive configuration
VBUSFACT | drive configuration
DIFVAR | drive configuration
DUMP | drive configuration
CTUNE | drive configuration
CUPDATE | drive configuration
HSAVE | drive configuration
HVER | drive configuration
FLTCNT | drive configuration
FLTHIST | drive configuration
VBUSCNTMAX | drive configuration
MDRV | drive configuration
DR_TYPE | drive configuration
CPHASE | drive configuration
VBUSRAMP | drive configuration
LDUMP | drive configuration
VBUSOFFS | drive configuration
VBUSBOFFS | drive configuration
OPTION2 | drive configuration
UID | drive configuration
ACTFAULT | drive configuration
ADDR | drive configuration
AENA | drive configuration
NONBTB | drive configuration
STOPMODE | drive configuration
VBUSMIN | drive configuration
SDLY | drive configuration
STAGECODE | drive configuration
PBALRES | drive configuration
MVER | drive configuration
TASK | drive configuration
TRUN | drive configuration
TRUNS | drive configuration
UPDATE | drive configuration
ERRPARAM | drive configuration
PARCNFG | drive configuration
VBUSMAX | drive configuration
CCSAVE | drive configuration
VBW | drive configuration
OTUNE | drive configuration
RSTVAR | drive configuration
DRVCNFG2 | drive configuration
SRND | drive configuration
SAVE | drive configuration
CALCRP | drive configuration
SERIALNO | drive configuration
DRIVE | drive configuration
UVLTMODE | drive configuration
PARRST | drive configuration
DPWM | drive configuration
POSCNFG | drive configuration
CALCMP | drive configuration
PARDUMP | drive configuration
PMODE | drive configuration
CALCCOG | drive configuration
BCCOT | drive configuration
DIR | drive configuration
NREFMT | position loop
CLRORDER | position loop
O_ACC | position loop
NREF | position loop
VOSPD | position loop
SWE1 | position loop
VJOG | position loop
POSRSTAT | position loop
O_DEC | position loop
O_FN | position loop
P8 | position loop
P9 | position loop
PE | position loop
DREF | position loop
OLIST | position loop
DECR | position loop
GEARI | position loop
MTMUX | position loop
PVMAXN | position loop
PVMAXP | position loop
PTBASE | position loop
REFIP2 | position loop
REFLS | position loop
REFMODE | position loop
ROFFS | position loop
PGEARI | position loop
PTMIN | position loop
PEINPOS | position loop
PTARGOFFS | position loop
ACCR | position loop
GPFFT | position loop
GP | position loop
GEARO | position loop
GEARMODE | position loop
O_P | position loop
SWCNFG | position loop
PVMAX | position loop
P13 | position loop
PEMAX | position loop
P1_P16 | position loop
P1 | position loop
OVRIDE | position loop
P4 | position loop
P2 | position loop
P16 | position loop
P11 | position loop
P14 | position loop
VREF | position loop
P12 | position loop
O_TAB | position loop
WPOSE | position loop
PRBASE | position loop
GPFFV | position loop
OCOPY | position loop
WPOS | position loop
PTARGET | position loop
P15 | position loop
GPS1 | position loop
VOSPDREF | position loop
GPFFTV | position loop
HLIMIT1 | position loop
REFNPOS | position loop
REFNOFFS | position loop
HLIMIT2 | position loop
HLIMIT3 | position loop
P10 | position loop
GPS2 | position loop
P3 | position loop
GP2 | position loop
GPFFV_X | position loop
GPFFT_X | position loop
GP_X | position loop
WPOSX | position loop
UCOMP | position loop
REFPOS | position loop
WPOSP | position loop
INTERPOL | position loop
P7 | position loop
ORDER | position loop
GPTN_X | position loop
SWE2 | position loop
GPTN | position loop
INPT0 | position loop
INPT1 | position loop
AUTOHOME | position loop
GPDELAY | position loop
P6 | position loop
GEARFILT | position loop
GPTNTH2 | position loop
P5 | position loop
GPTNTH3 | position loop
GPTNTH1 | position loop
PGEARO | position loop
VREF0 | position loop
MAXISETP | position loop
O_C | position loop
SETREF | position loop
REFIP | position loop
INPOS | position loop
O_V | position loop
O_FT | position loop
MAXVSETP | position loop
ML | motor
MTYPE | motor
MKT_X | motor
MJ_X | motor
MIPEAK_X | motor
MICONT_X | motor
ML_X | motor
MTAB | motor
MTIME | motor
COGMODE | motor
COGFILT | motor
MPOLES_X | motor
MKT | motor
TBRAKE | motor
MTIME_X | motor
MSPEED | motor
MNAME | motor
COGRED | motor
MDBSET | motor
MNUMBER | motor
MDBGET | motor
MBRAKE | motor
MICONT | motor
MDBLIST | motor
MDBCNT | motor
EXTBRAKE | motor
MI2T | motor
TBRAKE0 | motor
MIPEAK | motor
MPOLES | motor
MJ | motor
RECOFF | oscilloscope
RECRDY | oscilloscope
RECORD | oscilloscope
RECDONE | oscilloscope
RECTRIG | oscilloscope
GET | oscilloscope
RECING | oscilloscope
PROMPT | RS232
RS232T | RS232
ACTRS232 | RS232
CMDDLY | RS232
CSIOSTAT | safety
CSENID | safety
CSCNFG | safety
CSIDMAX | safety
CSSTAT | safety
CSERR | safety
CARDDEL | SD-Card
CARDDIR | SD-Card
CARDSAVE | SD-Card
CARDINFO | SD-Card
CARDUPDATE | SD-Card
SLMODE | sensorless
SLIQK | sensorless
SLIDK01 | sensorless
SLJSWITCH | sensorless
VOUTMAX | sensorless
SLIQK1 | sensorless
SLACCMAX | sensorless
QFACTOR | servo pump
QTIMEKD | servo pump
QTAB2TV | servo pump
QTABID | servo pump
QFCMD | servo pump
QTAB2KP | servo pump
QPRMAX | servo pump
QTAB4KP | servo pump
QTAB5KP | servo pump
QTAB1TN | servo pump
QTAB2TN | servo pump
QTAB3TN | servo pump
QTAB4TN | servo pump
QTVEFF | servo pump
QTAB1TV | servo pump
QTAB1KP | servo pump
QTAB3TV | servo pump
QTAB4TV | servo pump
QTAB5TV | servo pump
QTAB1V | servo pump
QTAB2V | servo pump
QTAB3V | servo pump
QTAB4V | servo pump
QTAB5V | servo pump
GVTV | servo pump
VTIMEKD | servo pump
QTAB5TN | servo pump
QT1 | servo pump
QFACTFILT | servo pump
QFACT | servo pump
QFACTCOMP | servo pump
QPRSET | servo pump
QPRACT | servo pump
QENA | servo pump
QTAB3KP | servo pump
QVT1 | servo pump
QTNEFF | servo pump
QMCMDLIM | servo pump
QMACT | servo pump
QMLIMP | servo pump
QMLIMN | servo pump
QCNFG | servo pump
QFSET | servo pump
QFCFACT | servo pump
QFCMDFILT | servo pump
QFMAX | servo pump
QKPEFF | servo pump
QPE | servo pump
QPRSETEFF | servo pump
QMCMD | servo pump
RDPBIAS2 | other commands
RDPBIAS | other commands
DPV17_64 | other commands
RDPCLAMP | other commands
RDPINT | other commands
RDPKP | other commands
RDPON | other commands
GF | other commands
ISTFR | other commands
RDPKI | other commands
DUMPSLNO | other commands
SKIP1W | other commands
SKIP1SP | other commands
IQFILTTAU | other commands
IQFILTK | other commands
VSTART | other commands
MCOSPHI | other commands
MUR | other commands
MFR | other commands
IEXTT | other commands
RDP | other commands
ERRTIME | other commands
MVANGLB | other commands
PSTEP | other commands
SKIP2SP | other commands
DOVRIDE | other commands
DENA | other commands
DILIM | other commands
VSTFR | other commands
FW | other commands
ESPEED | other commands
ERRCODE2 | other commands
MRS | other commands
MRS_X | other commands
DPRILIMIT | other commands
MVANGLF | other commands
GFTN | other commands
ERRCNFG | other commands
ENCVON | other commands
FFTSW | other commands
MTANGLP | other commands
GU | other commands
MIMR | other commands
ENCTO | other commands
SKIP2W | other commands
UMAX | other commands
MCFW | other commands
GUTN | other commands
DPRSTATE | other commands
MSERIALNO | other commands
ASMWAIT | other commands
MPR | other commands
DPRVAR1_16 | other commands
MVR | other commands
MTR | other commands
MVANGLMODE | other commands
MVANGLP | other commands
ERESMASK | other commands
IEXTTLIM | current loop
MSLBRAKE | current loop
KTN | current loop
IPEAK | current loop
T | current loop
KC_X | current loop
KTN_X | current loop
MLGC_X | current loop
MLGD_X | current loop
CINPOS | current loop
MLGQ_X | current loop
ICMD | current loop
TSTEP | current loop
IPEAKP | current loop
I2TLIM | current loop
KC | current loop
MLGC | current loop
IPEAKN | current loop
MLGD | current loop
MLGP | current loop
MLGP_X | current loop
MLGQ | current loop
ICMDVLIM | current loop
MAXTEMPH | temperatures
MAXTEMPM | temperatures
SLTEMPM | temperatures
TEMPM | temperatures
TEMPH | temperatures
TEMPE | temperatures
MAXTEMPE | temperatures
TEMPMFILT | temperatures
WSTIME3 | wake&shake
MPKP | wake&shake
MPTIME | wake&shake
MPKI | wake&shake
WSTIME | wake&shake
WSCNFG | wake&shake
WSTIME2 | wake&shake
WSAMPL | wake&shake
WSLOOP | wake&shake
MPKD | wake&shake


ASCII English Index Object

OTUNE | Object
SLJSWITCH | Object
SLTSWITCH | Object
BTIME | Object
RESAMPL | Object
LIST | Object
M | Object
P1_P16 | Object
ERRCODE | Object
SERCOFFS | Object
FLTHIST * | Object
ALIAS | Object
DUMPEMAP | Object
SLTEMPM | Object
MDBLIST | Object
ORDER | Object
CANSDO | Object
CCSAVE | Object
CANDUMP | Object
O3_18TRIG | Object
IN19HCMD | Object
FLTCNT * | Object
ANHFACT2 | Object
RDPBIAS2 | Object
NREFG | Object
MIMRQ | Object
MCTR | Object
MINSUMME | Object
MAXSUMME | Object
IVTICK | Object
HWCNT | Object
HALLENDIR | Object
PLLDOFFS | Object
FHKP | Object
MNAME | Object
ANHFACT1 | Object
DPV17_64 | Object
MTAB | Object
CARDUPDATE | Object
CARDSAVE | Object
CARDDEL | Object
CARDDIR | Object
CARDINFO | Object
IN5_22 | Object
FHTN | Object
HELP | Object
IN5_22MODE | Object
STEP | Object
TSTEP | Object
CALCCOG | Object
IN | Object
IN5_22TRIG | Object
IN19LCMD | Object
IN20LCMD | Object
COGRED | Object
GU | Object
O3_18MODE | Object
GUTN | Object
HDUMP | Object
OLIST | Object
VER | Object
DNDUMP | Object
VOHPF | Object
MPR | Object
VOHPD | Object
VOLPD | Object
VOSPDREF | Object
O3_18 | Object
SERCLIST | Object
PLLWOFFS | Object
RECORD | Object
IN2LCMD | Object
IDDUMP | Object
PLLCOFFS | Object
PARDUMP | Object
PARRST | Object
ADC0_15 | Object
DPRVAR1_16 | Object
UMAX | Object
ECATCSA | Object
IN20HCMD | Object
PSTEP | Object
RECTRIG | Object
SERCERR | Object
SERCOS | Object
TRUN | Object
UPDATE | Object
VBW | Object
VTUNE | Object
DPRSTATE | Object
SLMODE | Object
STATCODE * | Object
HDSLTYPE | Object
DIFVAR | Object
DUMP | Object
EN22AI2 | Object
IN3HCMD | Object
IN2HCMD | Object
IN4LCMD | Object
LDUMP | Object
IN1LCMD | Object
SETENCOFFS | Object
SLIMAX | Object
EN22DIAG | Object
STATUS | Object
IN1HCMD | Object
HDSLPOS | Object
HDSLRANGE | Object
J | Object
CTUNE | Object
PSINUS | Object
SLACCMAX | Object
TESTENC | Object
GF | Object
IN4HCMD | Object
SLIQK | Object
SLIDK01 | Object
VOUTMAX | Object
SLIQK1 | Object
EN22AI1 | Object
TEN | Object
TEST1 | Object
VOMODE | Object
VOMOPDE | Object
QVAL | Object
FLTCNT | Object
IN3LCMD | Object
FLTHIST | Object
ACC | Object 1
ACCR | Object 2
ACTFAULT | Object 3
ACTIVE | Object 4
ADDR | Object 5
AENA | Object 6
ANCNFG | Object 7
ANDB | Object 8
ANIN1 | Object 9
ANIN2 | Object 10
ANOFF1 | Object 11
ANOFF2 | Object 12
EGEARI | Object 13
EGEARO | Object 14
ANZERO1 | Object 15
ANZERO2 | Object 16
AVZ1 | Object 17
CALCHP | Object 18
CALCRK | Object 19
CALCRP | Object 20
CBAUD | Object 21
PRIOR3 | Object 22
PRIOR4 | Object 23
CLRFAULT | Object 24
CLRHR | Object 25
CLRORDER | Object 26
CLRWARN | Object 27
PRIOR5 | Object 28
CONTINUE | Object 29
MPITCH | Object 30
CUPDATE | Object 31
RESOLVER | Object 32
INPT1 | Object 33
DEC | Object 34
DECDIS | Object 35
DECR | Object 36
DECSTOP | Object 37
DICONT | Object 39
DIPEAK | Object 41
DIR | Object 42
DIS | Object 43
DREF | Object 44
DRVSTAT | Object 45
DR_TYPE | Object 46
EN | Object 48
JRATIO | Object 49
ENCIN | Object 50
ENCLINES | Object 51
ENCMODE | Object 52
ENCOUT | Object 53
MPHASE2 | Object 54
ENCZERO | Object 55
MAXCMD | Object 56
EXTPOS | Object 57
EXTWD | Object 58
FBTYPE | Object 59
FILTMODE | Object 60
GEARI | Object 62
GEARMODE | Object 63
GEARO | Object 64
GET | Object 65
GP | Object 66
ENCTO | Object 67
GPFFT | Object 68
GPFFV | Object 69
ENCVON | Object 70
GV | Object 72
GVFR | Object 75
GVTN | Object 77
SOFTIN | Object 78
SOFTOUT | Object 79
HALLDIR | Object 80
HICOFFS | Object 82
HIFACT1 | Object 83
HISOFFS | Object 84
HSAVE | Object 86
HVER | Object 87
I | Object 88
DI2T | Object 89
I2TLIM | Object 90
ICMD | Object 91
ID | Object 93
ERRMASK | Object 94
ERRTIME | Object 95
IN1 | Object 97
IN1MODE | Object 98
IN1TRIG | Object 99
IN2 | Object 100
IN2MODE | Object 101
IN2TRIG | Object 102
IN3 | Object 103
IN3MODE | Object 104
IN3TRIG | Object 105
IN4 | Object 106
IN4MODE | Object 107
IN4TRIG | Object 108
INPOS | Object 109
IPEAK | Object 110
IPEAKN | Object 111
IQ | Object 112
ISCALE1 | Object 113
ISCALE2 | Object 114
K | Object 115
KC | Object 116
KEYLOCK | Object 117
ML | Object 119
LATCH2P16 | Object 120
LATCH2N16 | Object 121
LATCH2P32 | Object 122
LATCH2N32 | Object 123
LATCH1P32 | Object 124
LATCH1N32 | Object 125
LED1 | Object 126
LED2 | Object 127
LED3 | Object 128
LEDSTAT | Object 129
LOAD | Object 131
MAXTEMPE | Object 132
MAXTEMPH | Object 133
MAXTEMPM | Object 134
MBRAKE | Object 135
MDBCNT | Object 136
MDBGET | Object 137
MDBSET | Object 138
CPHASE | Object 139
VLIM | Object 140
MH | Object 141
MICONT | Object 142
MIPEAK | Object 143
MJOG | Object 145
MVANGLP | Object 146
MKT | Object 147
IPEAKP | Object 148
MLGC | Object 149
MLGD | Object 150
MLGP | Object 151
MLGQ | Object 152
MNUMBER | Object 153
MONITOR1 | Object 154
MONITOR2 | Object 155
MPHASE | Object 156
MPOLES | Object 157
MRESBW | Object 160
MRESPOLES | Object 161
MSG | Object 162
MSPEED | Object 163
MI2T | Object 164
MTANGLP | Object 165
MTYPE | Object 166
MVANGLB | Object 167
MVANGLF | Object 168
M_RESET | Object 169
NONBTB | Object 170
MJ | Object 171
MTIME | Object 172
NREF | Object 173
O1 | Object 174
O1MODE | Object 175
O1TRIG | Object 176
O2 | Object 177
O2TRIG | Object 179
OPMODE | Object 180
OPTION2 | Object 181
OPTION | Object 181
OVRIDE | Object 182
O_ACC | Object 183
O_TAB | Object 184
O_C | Object 185
O_DEC | Object 186
O_FN | Object 188
O_FT | Object 189
O_P | Object 190
O_V | Object 191
PBAL | Object 192
PBALMAX | Object 193
PBALRES | Object 194
PBAUD | Object 195
PE | Object 197
PEINPOS | Object 198
PEMAX | Object 199
PFB | Object 200
PFB0 | Object 201
PGEARI | Object 202
PGEARO | Object 203
PIOBUF | Object 204
PMODE | Object 205
PNOID | Object 206
POSCNFG | Object 207
PPOTYP | Object 208
PRBASE | Object 209
PRD | Object 210
PROMPT | Object 211
PSTATE | Object 212
PTBASE | Object 213
PTMIN | Object 214
PV | Object 215
PVMAX | Object 216
PVMAXN | Object 217
PVMAXP | Object 219
READY | Object 221
RECDONE | Object 222
RECING | Object 223
RECOFF | Object 224
RECRDY | Object 225
REFIP | Object 226
REFPOS | Object 227
REMOTE | Object 228
RESPHASE | Object 229
RK | Object 230
ROFFS | Object 231
RS232T | Object 232
RSTVAR | Object 233
S | Object 234
SAVE | Object 235
SBAUD | Object 236
SCAN | Object 237
VBUSCNTMAX | Object 238
SERIALNO | Object 239
SETREF | Object 240
SLEN | Object 242
SLOTIO | Object 243
SPHAS | Object 244
VBUSLIM | Object 245
SSIGRAY | Object 246
SSIINV | Object 247
SSTAT | Object 250
DUMPSLNO | Object 250
STAT | Object 251
STATIO | Object 252
STOP | Object 254
STOPMODE | Object 255
SWCNFG | Object 256
SWE1 | Object 260
SWE2 | Object 262
ARHPD | Object 263
ARHPF | Object 264
ARLP2 | Object 265
ARLPD | Object 266
ARLPF | Object 267
PRIOR1 | Object 268
PRIOR2 | Object 269
T | Object 270
TASK | Object 271
TEMPE | Object 272
TEMPH | Object 273
TEMPM | Object 274
TRJSTAT | Object 275
TRUNS | Object 276
UID | Object 278
UVLTMODE | Object 279
V | Object 280
SSIREVOL | Object 281
VBUS | Object 282
VBUSBAL | Object 283
VBUSMAX | Object 284
VBUSMIN | Object 285
VCMD | Object 286
VEL0 | Object 288
VJOG | Object 289
VLIMP | Object 290
VLIMN | Object 291
VMIX | Object 293
VMUL | Object 294
VOSPD | Object 295
VREF | Object 296
VSCALE1 | Object 297
VSCALE2 | Object 298
\ | Object 299
DILIM | Object 300
DENA | Object 301
IN2PM | Object 302
KTN | Object 303
INPT0 | Object 304
UCOMP | Object 305
COLDSTART | Object 306
WPOS | Object 310
SRND | Object 311
ERND | Object 312
MDRV | Object 313
BCC | Object 314
REFMODE | Object 316
VLO | Object 317
WMASK | Object 318
WPOSE | Object 319
WPOSP | Object 320
WPOSX | Object 321
MOVE | Object 322
POSRSTAT | Object 323
P1 | Object 324
P2 | Object 325
P3 | Object 326
P4 | Object 327
P5 | Object 328
P6 | Object 329
P7 | Object 330
P8 | Object 331
P9 | Object 332
P10 | Object 333
P11 | Object 334
P12 | Object 335
P13 | Object 336
P14 | Object 337
P15 | Object 338
P16 | Object 339
PTARGET | Object 340
ACTRS232 | Object 341
ROFFSABS | Object 342
FW | Object 343
DPRILIMIT | Object 344
ACCUNIT | Object 345
VCOMM | Object 346
MTMUX | Object 347
REFLS | Object 349
SSIRXD | Object 350
VUNIT | Object 351
PUNIT | Object 352
SSITOUT | Object 353
BQMODE | Object 358
MIMR | Object 363
MTR | Object 364
MVR | Object 365
TBRAKE | Object 366
TBRAKE0 | Object 367
CMDDLY | Object 368
MSLBRAKE | Object 369
DRVCNFG | Object 370
DISDPR | Object 371
ESPEED | Object 373
DPWM | Object 374
DRIVE | Object 375
LATCH1P16 | Object 383
LATCH1N16 | Object 384
EXTLATCH | Object 385
STAGECODE | Object 386
SYNCSRC | Object 387
INTERPOL | Object 388
ICMDVLIM | Object 389
MRS | Object 390
MBPDRVSTAT | Object 397
SERCSET | Object 401
SMNUMBER | Object 405
VREF0 | Object 408
AN11NR | Object 409
AN11RANGE | Object 410
FBTYPEX | Object 411
DNBAUD | Object 415
DNMACID | Object 416
MSERIALNO | Object 419
ISTFR | Object 420
VSTFR | Object 421
DOVRIDE | Object 438
RDP | Object 439
RDPBIAS | Object 440
RDPCLAMP | Object 441
RDPINT | Object 442
RDPKI | Object 443
RDPKP | Object 444
RDPON | Object 445
GPTNTH3 | Object 460
ENGAGE | Object 461
LASTWMASK | Object 462
COGMODE | Object 463
WSTIME | Object 464
WSAMPL | Object 465
NREFMT | Object 466
COGFILT | Object 467
PASSX | Object 468
PASS | Object 469
GEARFILT | Object 470
AUTOHOME | Object 471
PASSCNFG | Object 472
EMRGTO | Object 476
WSLOOP | Object 482
REFIP2 | Object 483
DRVCNFG2 | Object 484
BUSP1 | Object 485
BUSP2 | Object 486
BUSP3 | Object 487
BUSP4 | Object 488
BUSP5 | Object 489
BUSP6 | Object 490
BUSP7 | Object 491
BUSP8 | Object 492
BUSP9 | Object 493
BUSP10 | Object 494
BUSP11 | Object 495
BUSP12 | Object 496
BUSP13 | Object 497
BUSP14 | Object 498
BUSP15 | Object 499
BUSP16 | Object 500
IN5 | Object 501
IN5MODE | Object 502
IN5TRIG | Object 503
IN6 | Object 504
IN6MODE | Object 505
IN6TRIG | Object 506
IN7 | Object 507
IN7MODE | Object 508
IN7TRIG | Object 509
IN8 | Object 510
IN8MODE | Object 511
IN8TRIG | Object 512
IN9 | Object 513
IN9MODE | Object 514
IN9TRIG | Object 515
IN10 | Object 516
IN10MODE | Object 517
IN10TRIG | Object 518
IN11 | Object 519
IN11MODE | Object 520
IN11TRIG | Object 521
IN12 | Object 522
IN12MODE | Object 523
IN12TRIG | Object 524
IN13 | Object 525
IN13MODE | Object 526
IN13TRIG | Object 527
IN14 | Object 528
IN14MODE | Object 529
IN14TRIG | Object 530
IN15 | Object 531
IN15MODE | Object 532
IN15TRIG | Object 533
IN16 | Object 534
IN16MODE | Object 535
IN16TRIG | Object 536
IN17 | Object 537
IN17MODE | Object 538
IN17TRIG | Object 539
IN18 | Object 540
IN18MODE | Object 541
IN18TRIG | Object 542
IN19 | Object 543
IN19MODE | Object 544
IN19TRIG | Object 545
IN20 | Object 546
IN20MODE | Object 547
IN20TRIG | Object 548
O3 | Object 549
O3MODE | Object 550
O3TRIG | Object 551
O4 | Object 552
O4MODE | Object 553
O4TRIG | Object 554
O5 | Object 555
O5MODE | Object 556
O5TRIG | Object 557
O6 | Object 558
O6MODE | Object 559
O6TRIG | Object 560
O7 | Object 561
O7MODE | Object 562
O7TRIG | Object 563
O8 | Object 564
O8MODE | Object 565
O8TRIG | Object 566
O9 | Object 567
O9MODE | Object 568
O9TRIG | Object 569
OCOPY | Object 570
O10 | Object 570
O10MODE | Object 571
O10TRIG | Object 572
O11 | Object 573
O11MODE | Object 574
O11TRIG | Object 575
O12 | Object 576
O12MODE | Object 577
O12TRIG | Object 578
O13 | Object 579
O13MODE | Object 580
O13TRIG | Object 581
O14 | Object 582
O14MODE | Object 583
O14TRIG | Object 584
O15 | Object 585
O15MODE | Object 586
O15TRIG | Object 587
O16 | Object 588
O16MODE | Object 589
O16TRIG | Object 590
O17 | Object 591
O17MODE | Object 592
O17TRIG | Object 593
O18 | Object 594
O18MODE | Object 595
O18TRIG | Object 596
ERESMASK | Object 597
RUNIN | Object 598
SDLY | Object 599
VWM | Object 601
ERRPARAM | Object 602
DRVSTAT2 | Object 603
WSRED | Object 604
PARCNFG | Object 605
GVFR_X | Object 606
GVTN_X | Object 607
GV_X | Object 608
GP_X | Object 609
GPFFT_X | Object 610
GPFFV_X | Object 611
KC_X | Object 612
KTN_X | Object 613
MPOLES_X | Object 614
MLGC_X | Object 615
MLGD_X | Object 616
MLGP_X | Object 617
MLGQ_X | Object 618
MJ_X | Object 619
MRS_X | Object 620
ML_X | Object 621
MKT_X | Object 622
MTIME_X | Object 623
MICONT_X | Object 624
MIPEAK_X | Object 625
IN21MODE | Object 627
IN21TRIG | Object 628
IN22MODE | Object 630
IN22TRIG | Object 631
ETHMODE | Object 632
BUILDRK | Object 848
BUILDRP | Object 849
VINPOS | Object 854
ZERO | Object 857
BUSP0 | Object 859
EXTBRAKE | Object 860
ERRCODE * | Object 861
STATCODE | Object 862
DIROUT | Object 863
MVER | Object 865
ERRCODE2 | Object 866
WSTIME2 | Object 867
ROFFSSSI | Object 868
WSTIME3 | Object 869
FFTSW | Object 870
VCTIME | Object 871
ASMWAIT | Object 872
IEXTT | Object 873
GPFFTV | Object 874
CINPOS | Object 876
REFNOFFS | Object 877
REFNPOS | Object 878
DRVCNFG3 | Object 879
MPKD | Object 880
MPKI | Object 881
MPKP | Object 882
MPTIME | Object 883
WSCNFG | Object 884
PFBLO | Object 885
PFBHI | Object 886
ACC_X | Object 887
DEC_X | Object 888
O2MODE | Object 889
AVZ2 | Object 890
SSIRESOL | Object 891
DAOFFSET1 | Object 892
DAOFFSET2 | Object 893
ANOUT1 | Object 894
ANOUT2 | Object 895
AN1TRIG | Object 896
AN2TRIG | Object 897
IOLINK | Object 899
ERRCNFG | Object 900
MFR | Object 901
MUR | Object 902
MCOSPHI | Object 903
VSTART | Object 904
IQFILTK | Object 905
IQFILTTAU | Object 906
SKIP1SP | Object 907
SKIP1W | Object 908
SKIP2SP | Object 909
SKIP2W | Object 910
CALCMP | Object 911
CSSTAT | Object 912
CSIOSTAT | Object 913
CSERR | Object 914
FBGEARI | Object 915
FBGEARO | Object 916
BCCOT | Object 917
HLIMIT1 | Object 918
HLIMIT2 | Object 919
HLIMIT3 | Object 920
PASSPLC | Object 921
PASSXPLC | Object 922
PTARGOFFS | Object 923
RSVERROFF | Object 924
DIRIN | Object 925
RELTIME | Object 926
ANIN3 | Object 928
ANIN4 | Object 929
ANOFF3 | Object 930
ANOFF4 | Object 931
ANZERO3 | Object 932
ANZERO4 | Object 933
CALCPOSIO | Object 934
GPTNTH1 | Object 935
GPTNTH2 | Object 936
GPFFVDELAY | Object 940
GPDELAY | Object 943
GPTN | Object 945
GPTN_X | Object 946
MAXISETP | Object 947
MAXVSETP | Object 948
IEXTTLIM | Object 950
BISSCNFG | Object 951
S1DLY | Object 953
TEMPMFILT | Object 955
EWH | Object 958
VBUSBOFFS | Object 959
VLO_X | Object 960
VBUSRAMP | Object 961
VBUSFACT | Object 962
GP2 | Object 963
GPS1 | Object 964
GPS2 | Object 965
GV2 | Object 966
GVS1 | Object 967
GVS2 | Object 968
CSCNFG | Object 970
CSENID | Object 971
CSIDMAX | Object 972
DRVCNFG4 | Object 974
MVANGLMODE | Object 975
VBUSOFFS | Object 976
PMECH | Object 977
P | Object 978
ENCFIX | Object 979
LINRESOL | Object 981
ENCDIV | Object 982
QCNFG | Object 983
QFACTOR | Object 984
QFCFACT | Object 985
QMACT | Object 986
QTVEFF | Object 987
VTIMEKD | Object 988
QFSET | Object 989
QFACT | Object 990
QPRSET | Object 991
QPRACT | Object 992
QMCMD | Object 993
QFACTCOMP | Object 994
QFACTFILT | Object 995
QTIMEKD | Object 996
QVT1 | Object 997
QMCMDLIM | Object 998
QMLIMP | Object 999
QPRSETEFF | Object 1000
QFMAX | Object 1001
QPRMAX | Object 1002
QTAB1KP | Object 1003
QTAB2KP | Object 1004
QTAB3KP | Object 1005
QTAB4KP | Object 1006
QTAB5KP | Object 1007
QTAB1V | Object 1008
QTAB2V | Object 1009
QTAB3V | Object 1010
QTAB4V | Object 1011
QTAB5V | Object 1012
QTAB1TN | Object 1013
QTAB2TN | Object 1014
QTAB3TN | Object 1015
QTAB4TN | Object 1016
QTAB5TN | Object 1017
QPE | Object 1018
QKPEFF | Object 1019
QTNEFF | Object 1020
GVTV | Object 1021
QTABID | Object 1024
QTAB1TV | Object 1025
QTAB2TV | Object 1026
QTAB3TV | Object 1027
QTAB4TV | Object 1028
QTAB5TV | Object 1029
GFTN | Object 1031
MCFW | Object 1032
ENCDIVD | Object 1033
ENCFIXD | Object 1034
SSITIME | Object 1035
SSIMASK | Object 1036
EN22A1CNT | Object 1037
EN22A2CNT | Object 1038
EN22CNFG | Object 1039
EN22DCNT | Object 1040
ZEROTIME | Object 1042
QENA | Object 1043
QFCMD | Object 1044
QFCMDFILT | Object 1045
QT1 | Object 1046
QMLIMN | Object 1047
HDSLTEMP | Object 1048
HDSLLED | Object 1049
HDSLVOLT | Object 1050
HDSLVEL | Object 1051
HDSLTIME | Object 1052
HDSLROTAT | Object 1053
PLLHUB | Object 1057
BISSREVOL | Object 1058


ASCII English INPOS

ASCII - Command | INPOS |
Syntax Transmit | INPOS [Data] |
Syntax Receive | INPOS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356D (hex)
DIM | - | PROFIBUS PNU | 1709 (dec) IND = 1 (dec)
Range | - | DPR | 109 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Status of In-Position Signal

Description

The INPOS command returns the status of the IN-Position bit of the status register (DRVSTAT).
As long as the difference between the last target position (motion task) and the actual position (PFB) is within the width of the preset In-Position window (PEINPOS), a 1 is signalled, otherwise a 0.

see also INPT0


ASCII English INPT0

ASCII - Command | INPT0 |
Syntax Transmit | INPT [Data] |
Syntax Receive | INPT0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3630 (hex)
DIM | ms | PROFIBUS PNU | 1904 (dec) IND = 1 (dec)
Range | 1 .. 32000 | DPR | 304 (dec)
Default | 10 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.3
Function Group | position loop | EEPROM | Yes
Short Description | In-Position Delay

Description

The INPT0 command defines a delay time for the In-Position signal. At the start of a motion block, the In-Position signal is removed, and the monitoring of the In-Position window is only activated again after the end of this preset time. This function is especially important for positioning tasks within the In-Position window. In such a case, it ensures that the In-Position signal is always removed for a definite time.

See also INPOS


ASCII English INPT1

ASCII - Command | INPT1 |
Syntax Transmit | INPT1 [Data] |
Syntax Receive | INPT1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3521 (hex)
DIM | - | PROFIBUS PNU | 1633 (dec) IND = 1 (dec)
Range | 0 ... 32000 | DPR | 33 (dec)
Default | 0 |
Opmode | 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | delay time for the “IN POSITION”

Description

The command INPT1 defines the delay time for the “IN POSITION” and “REFERENCE POINT SET” messages.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Installation

Hardware Installation

1. | Unpack servo amplifier and accessories
2. | Keep the Instructions Manual ready (print if necessary)
3. | Observe safety instructions in the manuals.
4. | Mount the servo amplifier as described in the Instructions Manual
5. | Wire the servo amplifier as described in the Instructions Manual or apply the minimum wiring for drive test (see graphics below).

Minimum Wiring S300

The minimum drive test wiring does not fulfill any requirements to safety or functionality of your application, it just shows the required wiring for drive testing without load.

Minimum Wiring S701-724 (STO dual channel)

The minimum drive test wiring does not fulfill any requirements to safety or functionality of your application, it just shows the required wiring for drive testing without load.

S700system

Minimum Wiring S748/772

The minimum drive test wiring does not fulfill any requirements to safety or functionality of your application, it just shows the required wiring for drive testing without load.

Software Installation

Minimum requirements for the PC

Processor | at least Pentium® II or comparable
Operating system | WINDOWS 2000 / XP
Graphics adapter | Windows compatible, color
Drives | hard disk with at least 10 MB free space, CD-ROM drive
Interface | one free serial interface (COM1 to COM10)

With other operating systems an emergency operation is feasible through an ASCII terminal emulation (without graphical user interface).
Interface settings : 38400 bps, databit 8, no parity, stopbit 1, no flow control.

On the CD-ROM you can find an installation program, which makes it easy to install the setup software on your PC.

Install

Autostart function activated:
Insert the CD-ROM into a free drive. A window with the start screen opens. There you find a link to the setup software DriveGUI.EXE. Click it and follow the instructions.

Autostart function deactivated:
Insert the CD-ROM into a free drive. Click on START (task bar), then on Run. Enter the program call: x:\autorun.exe or x:\index.htm (x = correct CD drive letter).
Click OK and proceed as described above.

Connection to the serial interface of the PC

Connect the interface cable to a serial interface on your PC (COM: to COM10) and to the serial interface of the servo amplifier (see Instructions Manual). USB to serial converter can be used optionally.

Firmware Upgrade

Hints for upgrading the servo amplifier's firmware see chapter "Firmware Upgrade".

Switch-On the Amplifier

1. | Check the wiring of the amplifier
2. | Switch on the 24 V power supply for the servo amplifier.
3. | Wait about 30 seconds, until the front display of the servo amplifier displays the current class (e.g. 03 for 3 amps). If the power supply voltage is switched on, too, a leading P is displayed (e.g. P03 for Power, 3 amps).

If an error code (F_ _) or a warning (n_ _) or a hint (. /_ / E/S/A) appears in the display, you will find the description in the appendix.
If there is fault, fix the problem, see chapter Trouble-Shooting.


ASCII English INTERPOL

ASCII - Command | INTERPOL |
Syntax Transmit | INTERPOL [Data] |
Syntax Receive | INTERPOL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3684 (hex)
DIM | - | PROFIBUS PNU | 1988 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 388 (dec)
Default | 0 |
Opmode | 5,6 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.00 |
Configuration | Yes | Last Change of this Object | 2.1
Function Group | position loop | EEPROM | Yes
Short Description | Type of Interpolation in OPMODE 5 and 6

Description

INTERPOL defines the type of interpolation for external trajectory mode (OPMODE 5 and 6). This functionality can only be used, selecting the synchronization that can be activated by SYNCSRC.

INTERPOL=0: linear interpolation
INTERPOL=1: spline interpolation (only for SERCOS)
INTERPOL=5: cubic interpolation
INTERPOL=6: linear interpolation of acceleration


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

I/O Expansion Card

This screen is avalable only if an I/O expansion card is inserted into the servo amplifier.

ioerweiterung

The status of the 14 additional inputs and 8 outputs is displayed here.

Inputs: Function INxMODE withx={5...18}

Outputs: Function OxMODE with x={3...10}

Clicking the "..." buttons opens a configuration screen for assigning functions to the programmable I/Os.

ioconfig


ASCII English IOLINK

ASCII - Command | IOLINK |
Syntax Transmit | IOLINK [Data] |
Syntax Receive | IOLINK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3883 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 33 (dec)
Range | 32 Bits | DPR | 899 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.18 |
Configuration | No | Last Change of this Object | 2.1
Function Group | digital I/O | EEPROM | Yes
Short Description | connection between a digital out- and input

Description

Creates an internal connection between a digital output and the coresponding digital input.
Every bit of the IOLINK variable coresponds to the pair of digital inputs/outputs.
e.g.
IOLINK 5
Bit0=1 digital input 1 is connected to the digital output 1.
Bit2=1 digital input 3 is connected to the digital output 3.

In combination with INxMODE/OxMODE commands, this function allows realization of small control tasks without participation of external PLC.


ASCII English IPEAK

ASCII - Command | IPEAK |
Syntax Transmit | IPEAK [Data] |
Syntax Receive | IPEAK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 356E (hex)
DIM | A | PROFIBUS PNU | 1710 (dec) IND = 1 (dec)
Range | 0.0 ... DIPEAK | DPR | 110 (dec)
Default | IMAX |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | current loop | EEPROM | Yes
Short Description | Application Peak Current

Description

IPEAK sets the peak rated current IPEAKP and IPEAKN of the application (RMS value). The value to be entered is limited to the lower of the peak rated current of the motor (MIPEAK) or amplifier (DIPEAK). If the IPEAK value is too low, the drive shows following errors and the peak torque is too low. If the IPEAK value is too high, the motor is endangered.


ASCII English IPEAKN

ASCII - Command | IPEAKN |
Syntax Transmit | IPEAKN [Data] |
Syntax Receive | IPEAKN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 356F (hex)
DIM | A rms | PROFIBUS PNU | 1711 (dec) IND = 1 (dec)
Range | 0.0 ... DIPEAK | DPR | 111 (dec)
Default | IMAX |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | negative motor peak rms current

Description

Negative motor peak rms current. Can be reduced to DICONT or MICONT in I2T fallback condition


ASCII English IPEAKP

ASCII - Command | IPEAKP |
Syntax Transmit | IPEAKP [Data] |
Syntax Receive | IPEAKP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3594 (hex)
DIM | A rms | PROFIBUS PNU | 1748 (dec) IND = 1 (dec)
Range | 0 ... DIPEAK | DPR | 148 (dec)
Default | IMAX |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | positive motor peak rms current

Description

Positive motor peak rms current. Can be reduced to DICONT or MICONT in I2T fallback condition


ASCII English IQ

ASCII - Command | IQ |
Syntax Transmit | IQ [Data] |
Syntax Receive | IQ <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3570 (hex)
DIM | A | PROFIBUS PNU | 1712 (dec) IND = 1 (dec)
Range | - | DPR | 112 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Q-Component of Current Monitor

Description

The Q-axes component of the actual current value.


ASCII English IQFILTK

ASCII - Command | IQFILTK |
Syntax Transmit | IQFILTK [Data] |
Syntax Receive | IQFILTK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3889 (hex)
DIM |  | PROFIBUS PNU | 1705 (dec) IND = 33 (dec)
Range | 0 .. 2.5 | DPR | 905 (dec)
Default | 0 |
Opmode | 1,2 | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Gain factor for slip compensation. Used in V/f Control

Description

Gain factor for slip compensation. Used in V/f Control.
100% Slip compensation: IQFILTK = 1

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII English IQFILTTAU

ASCII - Command | IQFILTTAU |
Syntax Transmit | IQFILTTAU [Data] |
Syntax Receive | IQFILTTAU <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 388A (hex)
DIM | ms | PROFIBUS PNU | 1706 (dec) IND = 33 (dec)
Range | 0 .. 2000 | DPR | 906 (dec)
Default | 200 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Low-pass filter time constant for slip compensation

Description

Low-pass filter time constant for slip compensation. Used in V/f Control.
Iq is low-pass filtered (smoothed) before it is used for slip compensation.


ASCII English ISCALE1

ASCII - Command | ISCALE1 |
Syntax Transmit | ISCALE1 [Data] |
Syntax Receive | ISCALE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3571 (hex)
DIM | A/10V | PROFIBUS PNU | 1713 (dec) IND = 1 (dec)
Range | 0 ... DIPEAK | DPR | 113 (dec)
Default | 15 |
Opmode | 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Scaling of Analog Current Setpoint 1

Description

Defines the scaling for the analog setpoint input 1 (if it is a current setpoint in OPMODE = 3). The current value that is set here corresponds to the maximum input voltage (10V).


ASCII English ISCALE2

ASCII - Command | ISCALE2 |
Syntax Transmit | ISCALE2 [Data] |
Syntax Receive | ISCALE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3572 (hex)
DIM | A/10V | PROFIBUS PNU | 1714 (dec) IND = 1 (dec)
Range | 0 ... DIPEAK | DPR | 114 (dec)
Default | 15 |
Opmode | 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | analog I/O | EEPROM | Yes
Short Description | Scaling of Analog Current Setpoint 2

Description

Defines the scaling for the analog setpoint input 2 (if it is a current setpoint in OPMODE = 3). The current value that is set here corresponds to the maximum input voltage (10V).


ASCII English ISTFR

ASCII - Command | ISTFR |
Syntax Transmit | ISTFR [Data] |
Syntax Receive | ISTFR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36A4 (hex)
DIM | A | PROFIBUS PNU | 2020 (dec) IND = 1 (dec)
Range | 0 ... DIPEAK | DPR | No
Default | 0 |
Opmode | 0, 1, 4...8 | Data Type Bus/DPR | Integer32
Drive State | Disable | Weighting | 1000
Start Firmware | 1.30 |
Configuration | No | Last Change of this Object | 1.1
Function Group | other commands | EEPROM | Yes
Short Description | Current Limit for velocity-dependent friction compensation

Description

The two parameters ISTFR and VSTFR define the friction compensation curve. If ISTFR is set to 0 the function is inactive. The friction compensation changes the additional current from -ISTFR to ISTFR if the velocity changes from -VSTFR to VSTFR. The current is added before the velocity filter, so the filter applies also to the friction compensation.

It is a configuration parameter if it is changed from "0" to another value, other changes can be done online.

V=0 -> IFRICT = 0
V= 50% of VSTFR -> IFRICT = 50% of ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% of VSTFR -> IFRICT = -50% of ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII English IVTICK

ASCII - Command | IVTICK |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English J

ASCII - Command | J |
Syntax Transmit | J [Data] |
Syntax Receive | J <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Float | CANBus Object Number | -
DIM | rpm (velocity) / ms (Time) | PROFIBUS PNU | -
Range | -15000.0 .. 15000.0 (=velocity),long int (Time) | DPR | No
Default | - |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | No
Short Description | Service Function: Constant Velocity

Description

The command “J <n> <t>” can be used to define a constant velocity <n> (in rpm) for a defined time <t> (in msec). If the <t> entry is missing, the drive runs continuously.


ASCII English JRATIO

ASCII - Command | JRATIO |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 3531 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English K

ASCII - Command | K |
Syntax Transmit | K |
Syntax Receive | K | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3573 (hex)
DIM | - | PROFIBUS PNU | 1715 (dec) IND = 1 (dec)
Range | - | DPR | 115 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Kill (=Disable)

Description

The K (Kill) command is a short form command of the “DIS” command.


ASCII English KC

ASCII - Command | KC |
Syntax Transmit | KC [Data] |
Syntax Receive | KC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3574 (hex)
DIM | - | PROFIBUS PNU | 1716 (dec) IND = 1 (dec)
Range | 0.0 .. 1.0 | DPR | 116 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.8
Function Group | current loop | EEPROM | Yes
Short Description | I-Controller Prediction Constant

Description

KC is a tuning variable of the current loop. For compensation of time delay a predicted current value can be used in addition to the measured motor current. KC 1 switches the current prediction on, KC 0.5 sets it to 50% and KC 0 switches it off. Disabling the current prediction can cause an unstable current loop.
Depending to function FILTMODE KC selects different algorithms . By setting FILTMODE=1 (Default) the usually prediction is used, with setting FILTMODE =2 the Smith Predictor is switched on. If the Smith Predictors is on the proportional gain of the current controller MLGQ can increase, in case the settings ML and MRS are tuned well .


ASCII English KC_X

ASCII - Command | KC_X |
Syntax Transmit | KC [Data] |
Syntax Receive | KC_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3764 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 17 (dec)
Range | 0.0 .. 1.0 | DPR | 612 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | I-Controller Prediction Constant 2

Description

see PARCNFG


ASCII English KEYLOCK

ASCII - Command | KEYLOCK |
Syntax Transmit | KEYLOCK [Data] |
Syntax Receive | KEYLOCK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3575 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 117 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | display | EEPROM | Yes
Short Description | Locks the push buttons

Description

If KEYLOCK=1, operation of the amplifier from the keys on the front panel is inhibited.
The display functions of the instrument (error messages, warnings) remain active.


ASCII English KTN

ASCII - Command | KTN |
Syntax Transmit | KTN [Data] |
Syntax Receive | KTN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 362F (hex)
DIM | ms | PROFIBUS PNU | 1903 (dec) IND = 1 (dec)
Range | 0.2 ... 2 | DPR | 303 (dec)
Default | 0.6 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | Current Controller Integral-Action Time

Description

The integral-action time (integration time constant) of the current control loop.


ASCII English KTN_X

ASCII - Command | KTN_X |
Syntax Transmit | KTN [Data] |
Syntax Receive | KTN_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3765 (hex)
DIM | ms | PROFIBUS PNU | 1813 (dec) IND = 17 (dec)
Range | 0.2 ... 2 | DPR | 613 (dec)
Default | 0.6 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | Current Controller Integral-Action Time 2

Description

see PARCNFG


ASCII English LASTWMASK

ASCII - Command | LASTWMASK |
Syntax Transmit | LASTWMASK [Data] |
Syntax Receive | LASTWMASK <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36CE (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 17 (dec)
Range | long int | DPR | 462 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Fault history of WMASK

Description

WMASK gives the possibility to create a mask to change warnings to errors. If the F24 occurs, LASTWMASK displays the warnings that caused the error.


ASCII English LATCH1N16

ASCII - Command | LATCH1N16 |
Syntax Transmit | LATCH16N [Data] |
Syntax Receive | LATCH1N16 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3680 (hex)
DIM | - | PROFIBUS PNU | 1984 (dec) IND = 1 (dec)
Range | - | DPR | 384 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.03 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 16-bit Position (negative edge)

Description

The LATCH1N16 command returns the position where latching was performed by the last negative (falling) edge on digital input 1 (IN1MODE=26). The position value is absolute within one turn, and is given out in the internal units (counts 0 ... 65535). In order to get the absolute 32-bit position in SI units (taking account of the position control loop resolution PGEARI/PGEARO), the command LATCH1N32 should be used.
The commands LATCH1N16 and LATCH1N32 have the effect of erasing the status bit 23 “negative latch made” in the status register TRJSTAT.


ASCII English LATCH1N32

ASCII - Command | LATCH1N32 |
Syntax Transmit | LATCH1N32 [Data] |
Syntax Receive | LATCH1N32 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 357D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 1 (dec)
Range | - | DPR | 125 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 32-bit Position (negative edge)

Description

The LATCH1N32 command returns the position where latching was performed by the last negative (falling) edge on digital input 1 (IN1MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH1N16 command should be used.
The commands LATCH1N16 and LATCH1N32 have the effect of erasing the status bit 23 “negative latch made” in the status register TRJSTAT.


ASCII English LATCH1P16

ASCII - Command | LATCH1P16 |
Syntax Transmit | LATCH1P16 [Data] |
Syntax Receive | LATCH1P16 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 367F (hex)
DIM | - | PROFIBUS PNU | 1983 (dec) IND = 1 (dec)
Range | - | DPR | 383 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 16-bit Position (positive edge)

Description

The LATCH1P16 command returns the position where latching was performed by the last positive (rising) edge on digital input 1 (IN1MODE=26). The position value is absolute within one turn, and is given out in the internal units (counts 0 ... 65535). In order to get the absolute 32-bit position in SI units (taking account of the position control loop resolution PGEARI/PGEARO), the command LATCH1P32 should be used.
The commands LATCH1P16 and LATCH1P32 have the effect of erasing the status bit 20 “positive latch made” in the status register DRVSTAT.


ASCII English LATCH1P32

ASCII - Command | LATCH1P32 |
Syntax Transmit | LATCH1P32 [Data] |
Syntax Receive | LATCH1P32 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 357C (hex)
DIM | - | PROFIBUS PNU | 1724 (dec) IND = 1 (dec)
Range | - | DPR | 124 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 32-bit Position (positive edge)

Description

The LATCH1P32 command returns the position where latching was performed by the last positive (rising) edge on digital input 1 (IN1MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH1P16 command should be used.
The commands LATCH1P16 and LATCH1P32 have the effect of erasing the status bit 20 “positive latch made” in the status register DRVSTAT.


ASCII English LATCH2N16

ASCII - Command | LATCH2N16 |
Syntax Transmit | LATCH2N16 [Data] |
Syntax Receive | LATCH2N16 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3579 (hex)
DIM | - | PROFIBUS PNU | 1721 (dec) IND = 1 (dec)
Range | - | DPR | 121 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 16-bit Position (negative edge)

Description

The LATCH2N16 command returns the position where latching was performed by the last negative (falling) edge on digital input 2 (IN2MODE=26). The position value is absolute within one turn, and is given out in the internal units (counts 0 ... 65535). In order to get the absolute 32-bit position in SI units (taking account of the position control loop resolution PGEARI/PGEARO), the command LATCH2N32 should be used.
The commands LATCH2N16 and LATCH2N32 have the effect of erasing the status bit 23 “negative latch made” in the status register TRJSTAT.


ASCII English LATCH2N32

ASCII - Command | LATCH2N32 |
Syntax Transmit | LATCH2N32 [Data] |
Syntax Receive | LATCH2N32 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 357B (hex)
DIM | - | PROFIBUS PNU | 1723 (dec) IND = 1 (dec)
Range | - | DPR | 123 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 32-bit Position (negative edge)

Description

The LATCH2N32 command returns the position where latching was performed by the last negative (falling) edge on digital input 2 (IN2MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH2N16 command should be used.
The commands LATCH2N16 and LATCH2N32 have the effect of erasing the status bit 23 “negative latch made” in the status register TRJSTAT.


ASCII English LATCH2P16

ASCII - Command | LATCH2P16 |
Syntax Transmit | LATCH2P16 [Data] |
Syntax Receive | LATCH2P16 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3578 (hex)
DIM | - | PROFIBUS PNU | 1720 (dec) IND = 1 (dec)
Range | - | DPR | 120 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 16-bit Position (positive edge)

Description

The LATCH2P16 command returns the position where latching was performed by the last positive (rising) edge on digital input 2 (IN2MODE=26). The position value is absolute within one turn, and is given out in the internal units (counts 0 ... 65535). In order to get the absolute 32-bit position in SI units (taking account of the position control loop resolution PGEARI/PGEARO), the command LATCH2P32 should be used.
The commands LATCH2P16 and LATCH2P32 have the effect of erasing the status bit 20 “positive latch made” in the status register DRVSTAT.


ASCII English LATCH2P32

ASCII - Command | LATCH2P32 |
Syntax Transmit | LATCH2P32 [Data] |
Syntax Receive | LATCH2P32 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 357A (hex)
DIM | - | PROFIBUS PNU | 1722 (dec) IND = 1 (dec)
Range | - | DPR | 122 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | Latched 32-bit Position (positive edge)

Description

The LATCH2P32 command returns the position where latching was performed by the last positive (rising) edge on digital input 2 (IN2MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH2P16 command should be used.
The commands LATCH2P16 and LATCH2P32 have the effect of erasing the status bit 20 “positive latch made” in the status register DRVSTAT.


ASCII English LDUMP

ASCII - Command | LDUMP |
Syntax Transmit | LDUMP [data] |
Syntax Receive | LDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Parameter Output of Motor Data

Description

The command LDUMP <name> can be used to output the parameters for the motor data set <name> from the internal database. The <name> that is entered must be a valid motor designation from the motor database (see MDBLIST). If the <name> parameter is not entered, the motor parameters that are loaded at present will be displayed.


ASCII English LED1

ASCII - Command | LED1 |
Syntax Transmit | LED1 [Data] |
Syntax Receive | LED1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 357E (hex)
DIM | - | PROFIBUS PNU | 1726 (dec) IND = 1 (dec)
Range | 0 ... 127 | DPR | 126 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | display | EEPROM | -
Short Description | State of Display 1 Segment

Description

The command LED1 returns the present status (7-segment code) of the segment in LED1 (left).

Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED1 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LED2

ASCII - Command | LED2 |
Syntax Transmit | LED2 [Data] |
Syntax Receive | LED2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 357F (hex)
DIM | - | PROFIBUS PNU | 1727 (dec) IND = 1 (dec)
Range | 0 ... 127 | DPR | 127 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | display | EEPROM | -
Short Description | State of Display 2 Segment

Description

The command LED2 returns the present status (7-segment code) of the segment in LED2 (center).
Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED2 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LED3

ASCII - Command | LED3 |
Syntax Transmit | LED3 [Data] |
Syntax Receive | LED3 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3580 (hex)
DIM | - | PROFIBUS PNU | 1728 (dec) IND = 1 (dec)
Range | 0 ...127 | DPR | 128 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | display | EEPROM | -
Short Description | State of Display 3 Segment

Description

The command LED3 returns the present status (7-segment code) of the segment in LED2 (right).
Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED3 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LEDSTAT

ASCII - Command | LEDSTAT |
Syntax Transmit | LEDSTAT [Data] |
Syntax Receive | LEDSTAT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3581 (hex)
DIM | - | PROFIBUS PNU | 1729 (dec) IND = 1 (dec)
Range | 0 ... 17 | DPR | 129 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | display | EEPROM | -
Short Description | Display page

Description

The variable LEDSTAT shows the number of the present “display page”.
Altering the LEDSTAT variable makes it possible the change the display via the serial interface.
The assignments are as follows:
LEDSTAT=0 Display is switched off
LEDSTAT=1 Status display
LEDSTAT=2 Fieldbus address
LEDSTAT=3 CAN Baud rate
LEDSTAT=4 Parameter S01 (Kp velocity control loop)
LEDSTAT=5 Parameter S02 (Tn velocity control loop)
LEDSTAT=6 Parameter S03 (setpoint offset)
LEDSTAT=7 Parameter S04 (motor number)
LEDSTAT=8 Parameter S05 (encoder selection)
LEDSTAT=9 Parameter S06 (brake selection)
LEDSTAT=10 Parameter S07 (Multidrive selection, from software 3.00)
LEDSTAT=11 Load data from the EEPROM
LEDSTAT=12 Save data in the EEPROM
LEDSTAT=13 Set default values (from software 3.00)
LEDSTAT=14 New configuration of the amplifier (M_RESET, from software 3.00)
LEDSTAT=15 Error messages
LEDSTAT=16 Serial number


ASCII English LINRESOL

ASCII - Command | LINRESOL |
Syntax Transmit | LINRESOL [Data] |
Syntax Receive | LINRESOL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38D5 (hex)
DIM | nm / Count | PROFIBUS PNU | 1781 (dec) IND = 33 (dec)
Range | 0 … 2^31 | DPR | 981 (dec)
Default | 0 |
Opmode | all | Data Type Bus/DPR | Interger32
Drive State | - | Weighting |
Start Firmware | 5.87 |
Configuration | No | Last Change of this Object | 2.11
Function Group | feedback | EEPROM | Yes
Short Description | Conversion factor for linear measurement systems

Description

With linear measuring systems that can not be automatically recognized as such (SSI, BISS), the position calculation can only be done correctly if the conversion factor for the linear units LINRESOL previously defined correctly. This parameter describes the size of a position counts in nm. Using this information and the size of the polpitches MPITCH, the position can be calculated within a Polpitches.
LINRESOL = 0: no linear units defined, it is a rotary encoder
LINRESOL > 0: conversion of linear units is enabled.

from FW 5.90:
SSI encoder:
There is a phenomenon that occurs with SSI encoders which provide a non-binary resolution. The parameter LINRESOL can be used in two ways:

MTYPE = 2 linear motor: LINRESOL describes the size of an SSI Counts

MTYPE = 1 rotary motor with binary SSI resolution
LINRESOL = 0, the position is calculated from the information SSIRXD and SSIREVOL

MTYPE = 1 rotary motor with a non-binary resolution (e.g. 1000 counts / rev)
LINRESOL = 1000 Describes the number of SSI counts per motor revolution


ASCII English LIST

ASCII - Command | LIST |
Syntax Transmit | LIST |
Syntax Receive | LIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | List All ASCII Commands

Description

All those commands are listed which can be used for to the present motor/amplifier configuration. ASCII commands that require specific hardware (e.g. Hiperface/Endat, Profibus,Sercos) will only be displayed if the corresponding hardware has been recognized correctly.


ASCII English LOAD

ASCII - Command | LOAD |
Syntax Transmit | LOAD |
Syntax Receive | LOAD | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3583 (hex)
DIM | - | PROFIBUS PNU | 1731 (dec) IND = 1 (dec)
Range | - | DPR | 131 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Load parameters from serial EEPROM

Description

The LOAD command loads the parameters from the serial EEPROM. All parameter changes that have been made since the last SAVE command (save in the serial EEPROM) will be lost.


LOGO

ASCII Object Reference

sorted by


ASCII English M

ASCII - Command | M |
Syntax Transmit | M [Data] |
Syntax Receive | M <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | -
Short Description | Read/write Macro Variable

Description

The M command can be used to access any internal macro variable.
Macro variables are variables which can be used by the macro routines. They are called by name within a macro routine. The complete variable information (name, address) is managed in the form of a table. There are two types of macro variable.
1. System variables – these variables are determined by the firmware, and are fixed. Both the names and the addresses for such variables are constant within a given firmware version. The table with the data for the variables is within the programming area, so that the system variables can be accessed at any time.
2. User variables – these variables are set up in the macro routines during the initialization phase of the amplifier. The availability of a specific variable, or its physical address, depends on the amplifier configuration. The table with the information for the variables is set up in the RAM, and is normally only required during the compilation of the macro programs (initialization phase). After the initialization has been concluded, the table is removed from the memory. In this case, it is not possible to access the user variables through the M command.
If the parameter setting MSG=2 is found when the amplifier is switched on, then the table for the user variables is kept in the memory. In this case, it will also be possible to access the user variables through the M command.
The M command can be used in one of three forms:
1. “M” – a list of all the system and user variables is generated

2. “M name” – an information line is generated for the variable <name>, in the following form:
“name [TYPE] address FORMAT=value”
The individual elements are interpreted as follows:
name = name of the macro variable
TYPE = variable type (SYSTEM or USER)
address = physical address of the variable (hexadecimal format)
FORMAT = variable type (BYTE,WORD,LONG,STRING), the suffix FAST means that the variable is stored in the internal (fast) RAM
Value = variable contents (in hexadecimal format, or as ASCII string, depending on FORMAT)

3. “M name value” – the number “value” is entered in the variable “name”
The entry for “value” must be made as a decimal number. If the character sequence “0x” is added as a prefix, the number can be entered in hexadecimal format.


ASCII English M_RESET

ASCII - Command | M_RESET | For Manufacturer Use only
Syntax Transmit | M_RESET |
Syntax Receive | M_RESET | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 35A9 (hex)
DIM | - | PROFIBUS PNU | 1769 (dec) IND = 1 (dec)
Range | - | DPR | 169 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disable | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Recompile Macro Programs

Description

All macro programs are compiled and started when the amplifier is switched on. The compilation of the macro programs is managed by configuration variables. The values for these configuration variables must be fixed before the compilation procedure is started. If the value of a configuration variable is altered at a later time, this change will only take effect with the next compilation of the macro programs. This means, that after changing a configuration variable, this change should first be stored in the EEPROM (see SAVE command) and the amplifier should then be switched off and on again.
The M_RESET command offers an alternative. This command is used to force a new compilation of the macro programs, without having to switch the amplifier off and on again. Since this function, unlike that performed during the initialization phase, is carried out while the interrupts are enabled, it takes longer to complete (about 5 min).


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Macro Programming

We offer specific macro programs for specific applications. Ask our Customer Support for further information. Detailled information can be found in the KDN on page "Macro Programming" with a link to a Macro-Language overview.

The editor MacroStar with compiler functionality is on the product CDrom or you can download the tool from our File Selector.

Preprogrammed macros for the funcionalities listed below can be order (must be paid):

P/I-Control

For simple path controls with a dancer or pressing with a dynamometer.

Flying Saw

For basic functions of a flying saw with flexible cutting distance.

Torque Coupling via field bus

Simple master Slave torque coupling with integrated Enable function.

Position Coupling via field bus

Simple master Slave position coupling with integrated Enable function.

and more

....


ASCII English MAXCMD

ASCII - Command | MAXCMD |
Syntax Transmit | MAXCMD |
Syntax Receive | MAXCMD <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3538 (hex)
DIM |  | PROFIBUS PNU | 1656 (dec) IND = 1 (dec)
Range | - | DPR | 56 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | Sonstige | EEPROM | No
Short Description | max. number of DPR variables

Description

This parameter displays the max. number of DPR objects. Many of them are not documented because they are debug objects or are used in customer-specific firmvware versions.

please have a look IDDUMP


ASCII English MAXISETP

ASCII - Command | MAXISETP |
Syntax Transmit | MAXISETP [Data] |
Syntax Receive | MAXISETP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38B3 (hex)
DIM |  | PROFIBUS PNU | 1747 (dec) IND = 33 (dec)
Range | 0 .. 16000 | DPR | 947 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM | Yes
Short Description | limitation of the integral part of the position loop

Description

The proportional and integral part of the position loop can be saturated with the parameters MAXVSETP and MAXISETP:

MAXISETP: limit for the integral part of the position loop (in RPM)

The value of 0 (default) means - no limitation


ASCII English MAXSUMME

ASCII - Command | MAXSUMME |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English MAXTEMPE

ASCII - Command | MAXTEMPE |
Syntax Transmit | MAXTEMPE [Data] |
Syntax Receive | MAXTEMPE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3584 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1732 (dec) IND = 1 (dec)
Range | 10 .. 80 | DPR | 132 (dec)
Default | 75 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.8
Function Group | temperatures | EEPROM | Yes
Short Description | Ambient Temperature Switch off Threshold

Description

The ambient temperature value for switching off the power stage and opening the BTB / RTO contact. If the drive temperature (as given by TEMPE) exceeds this value, the drive faults (F13).


ASCII English MAXTEMPH

ASCII - Command | MAXTEMPH |
Syntax Transmit | MAXTEMPH [Data] |
Syntax Receive | MAXTEMPH <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3585 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1733 (dec) IND = 1 (dec)
Range | 20 ... 85 | DPR | 133 (dec)
Default | 80 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | temperatures | EEPROM | Yes
Short Description | Heat Sink Temperature Switch off Threshold

Description

The heat sink temperature for switching off. If the heat sink temperature (as given by TEMPH) exceeds this value, the drive faults.

The following max. limits are:
S300: 85 degree
S700: 90 degree
S748/S772 : 105 degree


ASCII English MAXTEMPM

ASCII - Command | MAXTEMPM |
Syntax Transmit | MAXTEMPM [Data] |
Syntax Receive | MAXTEMPM <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3586 (hex)
DIM | Ohms or [MTAB units] | PROFIBUS PNU | 1734 (dec) IND = 1 (dec)
Range | -6000.0 .. 6000.0 | DPR | 134 (dec)
Default | 300 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | temperatures | EEPROM | Yes
Short Description | Motor Temperature Switch off Threshold

Description

The motor temperature for switching off (defined by the resistance in ohms).

MAXTEMPM = 0 switches off the monitoring of the motor temperature (F06)

In existing temperature characteristic (see MTAB) the units change for the parameter MAXTEMPM and TEMPM of Ohm to the unit that was used in the characteristic definition.

see also SLTEMPM, TEMPM, MTAB


ASCII English MAXVSETP

ASCII - Command | MAXVSETP |
Syntax Transmit | MAXVSETP [Data] |
Syntax Receive | MAXVSETP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38B4 (hex)
DIM |  | PROFIBUS PNU | 1748 (dec) IND = 33 (dec)
Range | 0 .. 16000 | DPR | 948 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | position loop | EEPROM |
Short Description | Limitation of the proportional part of the position loop

Description

The proportional and integral part of the position loop can be saturated with the parameters MAXVSETP and MAXISETP.

MAXVSETP: limit for the proportional part of the position loop (in RPM)

The value of 0 (default) means - no limitation


ASCII English MBPDRVSTAT

ASCII - Command | MBPDRVSTAT |
Syntax Transmit | MBPDRVSTAT [Data] |
Syntax Receive | MBPDRVSTAT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 368D (hex)
DIM | - | PROFIBUS PNU | 1997 (dec) IND = 1 (dec)
Range | 0 .. 31 | DPR | 397 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | Yes
Short Description | State of the Modbus+ Network

Description

MBPDRVSTAT gives the state of the Modbus+ network of the drive. The bit 3 can be written by the drive and can be saved. If the bit is set, Modbus+ network errors are indicated at the drive.


ASCII English MBRAKE

ASCII - Command | MBRAKE |
Syntax Transmit | MBRAKE [Data] |
Syntax Receive | MBRAKE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3587 (hex)
DIM | - | PROFIBUS PNU | 1735 (dec) IND = 1 (dec)
Range | 0..4 | DPR | 135 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.4
Function Group | motor | EEPROM | Yes
Short Description | Select Motor Holding Brake

Description

MBRAKE enables the brake function for a 24V holding brake in the motor directly from the servo amplifier.

MBRAKE = 0 Brake function is disabled
MBRAKE = 1 Brake function is enabled. The output at the BRAKE terminal is 24V if the ENABLE signal is present (brake off) and 0V if the ENABLE signal is missing (brake activated).
MBRAKE = 2 If the wake&shake mode is activated (FBTYPE = 7 or 8) the holding brake is deactivated after the wake&shake mode.
MBRAKE = 3 reserved

since FW >= 5.19
MBRAKE = 4 Breake function is enabled but the monitoring of brake fault is disabled.


ASCII English MCFW

ASCII - Command | MCFW |
Syntax Transmit | MCFW [Data] |
Syntax Receive | MCFW <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3908 (hex)
DIM | - | PROFIBUS PNU | 1832 (dec) IND = 33 (dec)
Range | 1 .. 2 | DPR | 1032 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.00 |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | The Correction Factor of the Field Weakening

Description

This command is only for the induction motor mode (MTYPE = 3).
The correction factor of the field weakening.
This correction factor is introduced to compensate the nonlinearity of the magnetizing inductance since the magnetizing current is decreased according to the rotor mechanical velocity during the field weakening.


ASCII English MCOSPHI

ASCII - Command | MCOSPHI |
Syntax Transmit | MCOSPHI [Data] |
Syntax Receive | MCOSPHI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3887 (hex)
DIM |  | PROFIBUS PNU | 1703 (dec) IND = 33 (dec)
Range | 0.5 .. 1 | DPR | 903 (dec)
Default | 0.8 |
Opmode | 1,2 | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Power Factor (cos phi) of the induction motor

Description

Power Factor (cos phi) of the induction motor.
Used in V/f Control scheme to calculate the rated slip s_R for slip compensation.

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII English MCTR

ASCII - Command | MCTR |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English MDBCNT

ASCII - Command | MDBCNT |
Syntax Transmit | MDBCNT |
Syntax Receive | MDBCNT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3588 (hex)
DIM | - | PROFIBUS PNU | 1736 (dec) IND = 1 (dec)
Range | 1 .. 127 | DPR | 136 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | No
Short Description | Number of Motor Data Sets

Description

MDBCNT returns the number of motor data sets that can be loaded for the present combination of output stage + feedback. A change of the feedback setting FBTYPE is used, for instance, to ensure that only the data sets for resolver motors or EnDat motors are used.


ASCII English MDBGET

ASCII - Command | MDBGET |
Syntax Transmit | MDBGET [Data] |
Syntax Receive | MDBGET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 3589 (hex)
DIM | - | PROFIBUS PNU | 1737 (dec) IND = 1 (dec)
Range | 1 .. MDBCNT | DPR | 137 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | No
Short Description | Get Actual Motor Data Set

Description

The MDBGET command generates an information line (directory entry) for the latest motor data set that was selected with the MDBSET command. The information line consists of the following elements:
data set number, motor name, motor number, motor family
The individual elements are interpreted as follows:
Data set number: the number for the data set within the motor database. This number can be used to address a motor data set with the MDBSET command. This number is increased automatically at every MDBGET call.
Motor name: a symbolic motor designation (max. length 12 characters).
Motor number: a number that can be used to uniquely identify a particular motor. This number is used to load a data set from the motor database with the MNUMBER command.
Motor family: an additional designation (for internal use only).

The group of commands MDBCNT,MDBSET,MDBGET can be used by an external control system, to read out the contents of the motor database. The procedure is as follows:
1. Read out the number of available data sets, using the MDBCNT command.
2. Set the data set pointer to the first data set, using the MDBSET 1 command.
3. Read out the first directory entry, using the MDBGET command.
4. Repeat step 3 until the number of available data sets (MDBCNT) has been read.

The MDBLIST command offers an alternative. This command can be used to display the complete list.


ASCII English MDBLIST

ASCII - Command | MDBLIST |
Syntax Transmit | MDBLIST [*] |
Syntax Receive | MDBLIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | No
Short Description | List of Motor Data Sets

Description

The MDBLIST command returns the list of contents for the motor database (for the present combination of output stage + feedback). One motor database entry is displayed per line on the screen, in the following format:
motor name, motor number, motor family, amplifier designation

The individual elements are interpreted as follows:
Motor name: a symbolic motor designation (max. length 12 characters).
Motor number: a number that can be used to uniquely identify a particular motor. This number is used to load a data set from the motor database with the MNUMBER command.
Motor family: an additional designation (for internal use only).

If PROMPT 2 is set, a formatted output appears, which is especially suitable for terminal display.

The MDBLIST * command can be used to display the complete list of contents for the motor database. The difference to the output generated by MDBLIST is that the contents also include motor data sets that are not suitable for the present combination of output stage and feedback. These data sets will be displayed, but they cannot be loaded.
Compared with the MDBLIST output, the MDBLIST * output has been enlarged by the columns “Amplifier designation” and “Feedback”. These designations can be used to find out for which output stage or FBTYPE setting this data set was created.
Amplifier designation 6xx, where xx = current rating
Feedback: 0=Resolver, 2=Hiperface, 4=Endat


ASCII English MDBSET

ASCII - Command | MDBSET |
Syntax Transmit | MDBSET [Data] |
Syntax Receive | MDBSET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 358A (hex)
DIM | - | PROFIBUS PNU | 1738 (dec) IND = 1 (dec)
Range | 1 .. MDBCNT | DPR | 138 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | No
Short Description | Set Actual Motor Data Set

Description

The MDBSET command can be used to address a specific data set from the motor database. The subsequent MDBGET command provides the directory entry for the selected motor data set (see MDBGET description).


ASCII English MDRV

ASCII - Command | MDRV |
Syntax Transmit | MDRV [Data] |
Syntax Receive | MDRV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | - | CANBus Object Number | 3639 (hex)
DIM |  | PROFIBUS PNU | 1913 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 313 (dec)
Default | 0 |
Opmode | all | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.4
Function Group | drive configuration | EEPROM | Yes
Short Description | selection of multidrive functionality

Description

The command MDRV enables the multi drive functionality.

MDRV=0 Multi drive functionality (address range ADDR 0...127)
The SCAN command gives every time a "0" (no external drives recognised)

MDRV=1 Multi drive active (address range ADDR 0...63)
The SCAN command checks the CAN-bus if there are more drives.


ASCII English MFR

ASCII - Command | MFR |
Syntax Transmit | MFR [Data] |
Syntax Receive | MFR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3885 (hex)
DIM | Hz | PROFIBUS PNU | 1701 (dec) IND = 33 (dec)
Range | 10 .. 500 | DPR | 901 (dec)
Default | 50 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Rated frequency of the induction motor

Description

Rated frequency of the induction motor.
Used in V/f Control scheme to calculate the rated slip s_R for slip compensation.

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII English MH

ASCII - Command | MH |
Syntax Transmit | MH |
Syntax Receive | MH | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 358D (hex)
DIM | - | PROFIBUS PNU | 1741 (dec) IND = 1 (dec)
Range | - | DPR | 141 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Start Homing

Description

The MH (move home) command is used to start a homing movement (reference traverse) via the serial interface. Homing type, direction and speed are taken from the NREF, DREF and VREF parameters.
See also SETREF especially for OPMODE 1...6.


ASCII English MI2T

ASCII - Command | MI2T |
Syntax Transmit | MI2T |
Syntax Receive | MI2T <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35A4 (hex)
DIM | % | PROFIBUS PNU | 1764 (dec) IND = 1 (dec)
Range | 0 ... 100 | DPR | 164 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | No
Short Description | Motor I2T load

Description

This variable returns the average current as a percentage of the continuous current (see MICONT). The average current is filtered with the time constant MTIME.


ASCII English MICONT

ASCII - Command | MICONT |
Syntax Transmit | MICONT [Data] |
Syntax Receive | MICONT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 358E (hex)
DIM | A | PROFIBUS PNU | 1742 (dec) IND = 1 (dec)
Range | 10% of DICONT, .. 2* DICONT | DPR | 142 (dec)
Default | DICONT |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor Continuous Current Rating

Description

This parameter limits the continues current of the amplifier, depending on the maximum continuous current rating of the motor.


ASCII English MICONT_X

ASCII - Command | MICONT_X |
Syntax Transmit | MICONT [Data] |
Syntax Receive | MICONT_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3770 (hex)
DIM | A | PROFIBUS PNU | 1824 (dec) IND = 17 (dec)
Range | 10% of DICONT, .. 2* DICONT | DPR | 624 (dec)
Default | DICONT |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Motor Continuous Current Rating

Description

see PARCNFG


ASCII English MIMR

ASCII - Command | MIMR |
Syntax Transmit | MIMR [Data] |
Syntax Receive | MIMR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 366B (hex)
DIM | A | PROFIBUS PNU | 1963 (dec) IND = 1 (dec)
Range | variable | DPR | 363 (dec)
Default | variable |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 2.13
Function Group | other commands | EEPROM | Yes
Short Description | current command D-part

Description

If a asynchron motor is used MTYPE = 3 a D-part for the current is sticked in.


ASCII English MIMRQ

ASCII - Command | MIMRQ |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English MINSUMME

ASCII - Command | MINSUMME |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English MIPEAK

ASCII - Command | MIPEAK |
Syntax Transmit | MIPEAK [Data] |
Syntax Receive | MIPEAK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 358F (hex)
DIM | A | PROFIBUS PNU | 1743 (dec) IND = 1 (dec)
Range | 10% of DIPEAK, .. 2*DIPEAK | DPR | 143 (dec)
Default | DIPEAK |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor Peak Current Rating

Description

MIPEAK limits the IPEAK setting of the amplifier, depending on the maximum peak current rating of the motor. The peak current should not exceed 4 times the rated current (MICONT) of the motor. The actual value is also determined by the peak current (DIPEAK) of the servo amplifier used (defines the maximum value for the entry of IPEAK in the current controller).


ASCII English MIPEAK_X

ASCII - Command | MIPEAK_X |
Syntax Transmit | MIPEAK [Data] |
Syntax Receive | MIPEAK_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3771 (hex)
DIM | A | PROFIBUS PNU | 1825 (dec) IND = 17 (dec)
Range | 10% of DIPEAK, .. 2*DIPEAK | DPR | 625 (dec)
Default | DIPEAK |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Motor Peak Current Rating

Description

see PARCNFG


ASCII English MJ

ASCII - Command | MJ |
Syntax Transmit | MJ [Data] |
Syntax Receive | MJ <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 35AB (hex)
DIM | kgcm^2 | PROFIBUS PNU | 1771 (dec) IND = 1 (dec)
Range | 0.01 ... 1000 | DPR | 171 (dec)
Default | 3 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor inertia

Description

Motor inertia

MJ is in kg in case of a linear motor.


ASCII English MJ_X

ASCII - Command | MJ_X |
Syntax Transmit | MJ [Data] |
Syntax Receive | MJ_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 376B (hex)
DIM | kgcm^2 | PROFIBUS PNU | 1819 (dec) IND = 17 (dec)
Range | 0.01 ... 1000 | DPR | 619 (dec)
Default | 3 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Motor inertia 2

Description

see PARCNFG


ASCII English MJOG

ASCII - Command | MJOG |
Syntax Transmit | MJOG |
Syntax Receive | MJOG | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3591 (hex)
DIM | - | PROFIBUS PNU | 1745 (dec) IND = 1 (dec)
Range | - | DPR | 145 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Start Jog Mode

Description

MJOG starts the jog mode via the serial interface (OPMODE 8 only ). The velocity in the jog mode is taken from VJOG (with ± sign). Jog mode is defined as a continuous motion at a constant velocity. This type of operation is started without a reference point being set (without homing). The hardware limit switches are monitored. Software limit switches are only monitored if a reference point is set (the drive has been homed). Acceleration and deceleration ramps are taken from the settings for homing (see ACCR, DECR, and VJOG).


ASCII English MKT

ASCII - Command | MKT | For Manufacturer Use only
Syntax Transmit | MKT [Data] |
Syntax Receive | MKT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3593 (hex)
DIM | - | PROFIBUS PNU | 1747 (dec) IND = 1 (dec)
Range | 0.0 .. 10.0 | DPR | 147 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor KT

Description

The torque constant of the motor in Nm/A.

This parameter is used for sensorless control. The value can be online checked according to the following equation:

Kt = 60 * SQRT (3) * Ui / ( 2 * PI * n)

Ui induced voltage of the motor
n actual rotor velocity


ASCII English MKT_X

ASCII - Command | MKT_X | For Manufacturer Use only
Syntax Transmit | MKT [Data] |
Syntax Receive | MKT_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 376E (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 17 (dec)
Range | 0.0 .. 10.0 | DPR | 622 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Motor KT

Description

see PARCNFG


ASCII English ML

ASCII - Command | ML |
Syntax Transmit | L [Data] |
Syntax Receive | ML <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3577 (hex)
DIM | mH | PROFIBUS PNU | 1719 (dec) IND = 1 (dec)
Range | 0 .. 200 | DPR | 119 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.9
Function Group | motor | EEPROM | Yes
Short Description | Stator Inductance of the Motor

Description

The parameter describes the stator inductance between phase and phase in mH.


ASCII English ML_X

ASCII - Command | ML_X |
Syntax Transmit | L [Data] |
Syntax Receive | ML_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 376D (hex)
DIM | mH | PROFIBUS PNU | 1821 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 621 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Stator Inductance of the Motor

Description

see PARCNFG


ASCII English MLGC

ASCII - Command | MLGC |
Syntax Transmit | MLGC [Data] |
Syntax Receive | MLGC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3595 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1749 (dec) IND = 1 (dec)
Range | 0.2 .. 1.0 | DPR | 149 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at rated current)

Description

The current control loop includes an adaptive alteration of the gain that depends on the current. The MLGC parameter defines the relative gain referred to MLGQ for continuous current.

MLGC = 0.8 means that the gain of the current control loop for continuous current is 80% of MLGQ. A linear interpolation is made for the gain from current = 0 up to current = MICONT.


ASCII English MLGC_X

ASCII - Command | MLGC_X |
Syntax Transmit | MLGC [Data] |
Syntax Receive | MLGC_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3767 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1815 (dec) IND = 17 (dec)
Range | 0.2 .. 1.0 | DPR | 615 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at rated current)

Description

see PARCNFG


ASCII English MLGD

ASCII - Command | MLGD |
Syntax Transmit | MLGD [Data] |
Syntax Receive | MLGD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3596 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1750 (dec) IND = 1 (dec)
Range | 0.4 .. 1.0 | DPR | 150 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | Adaptive Gain for Current Control loop, D-component

Description

The D-component of the current control loop (field component). The MLGD parameter defines the relative gain referred to MLGQ.

MLGC = 0.6 means that the gain of the current control loop D-component is 60% of MLGQ.


ASCII English MLGD_X

ASCII - Command | MLGD_X |
Syntax Transmit | MLGD [Data] |
Syntax Receive | MLGD_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3768 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1816 (dec) IND = 17 (dec)
Range | 0.4 .. 1.0 | DPR | 616 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | Adaptive Gain for Current Control loop, D-component

Description

see PARCNFG


ASCII English MLGP

ASCII - Command | MLGP |
Syntax Transmit | MLGP [Data] |
Syntax Receive | MLGP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3597 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1751 (dec) IND = 1 (dec)
Range | 0.1 .. 1.0 | DPR | 151 (dec)
Default | 0.4 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at peak current)

Description

The current control loop includes an adaptive alteration of the gain that depends on the current. The MLGP parameter defines the relative gain referred to MLGQ for peak current.

MLGP = 0.6 means that the gain of the current control loop for peak current is 60% of MLGQ. A linear interpolation is made for the gain from current = MICONT up to current = MIPEAK.


ASCII English MLGP_X

ASCII - Command | MLGP_X |
Syntax Transmit | MLGP [Data] |
Syntax Receive | MLGP_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3769 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1817 (dec) IND = 17 (dec)
Range | 0.1 .. 1.0 | DPR | 617 (dec)
Default | 0.4 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at peak current)

Description

see PARCNFG


ASCII English MLGQ

ASCII - Command | MLGQ |
Syntax Transmit | MLGQ [Data] |
Syntax Receive | MLGQ <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3598 (hex)
DIM | - | PROFIBUS PNU | 1752 (dec) IND = 1 (dec)
Range | variable | DPR | 152 (dec)
Default | variable |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | Absolute Gain of Current Control loop

Description

MLGQ gives the proportional (ac) gain of the current control loop. This also affects MLGC, MLGP and MLGD KTN. The dimension is V/A.

MLGQ(min) = 540 / DISCALE
MLGG(Default) = 540*1000 / DISCALE
MLGQ(max) = 540*30000 / DISCALE

DISCALE – depend on the current scaling of the amplifier („M DISCALE“ in the terminal)

example:
S706: max. peak current = 3* 6A = 18A = 18000 mA

MLGQ(min) = 540 / 18000 = 0,3
MLGG(Default) = 540*1000 / 18000 = 30
MLGQ(max) = 540*30000 / 18000 = 900


ASCII English MLGQ_X

ASCII - Command | MLGQ_X |
Syntax Transmit | MLGQ [Data] |
Syntax Receive | MLGQ_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 376A (hex)
DIM | - | PROFIBUS PNU | 1818 (dec) IND = 17 (dec)
Range | 3 .. 1800 | DPR | 618 (dec)
Default | 60 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | current loop | EEPROM | Yes
Short Description | Absolute Gain of Current Control loop

Description

see PARCNFG


ASCII English MNAME

ASCII - Command | MNAME |
Syntax Transmit | MNAME [Data] |
Syntax Receive | MNAME <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 12 ASCII Characters | DPR | No
Default | Blanks |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor Name

Description

The MNAME parameter is directly related to the motor number MNUMBER.
When a motor data set is loaded from the motor database (MNUMBER command), the motor designation MNAME is also transferred. If a customer-specific motor designation is to be defined, then this can be done with the MNAME command.
When the motor name is altered, the motor number (MNUMBER) is set to 0, to indicate a customer-specific motor data set.


ASCII English MNUMBER

ASCII - Command | MNUMBER |
Syntax Transmit | MNUMBER [Data] |
Syntax Receive | MNUMBER <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3599 (hex)
DIM | - | PROFIBUS PNU | 1753 (dec) IND = 1 (dec)
Range | -2 .. 32767 | DPR | 153 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | motor | EEPROM | Yes
Short Description | Motor Number

Description

The command “MNUMBER nr” is used to load a motor data set with the number “nr” from the motor database. If MNUMBER 0 is entered, then no data set will be loaded, but the variable MNUMBER will simply be set to 0. This setting indicates a customer-specific motor data set.

Since FW > = 5.77:
MNUMBER = -1 -> While booting, only the offset values are loaded from the feedback. The settings for MNUMBER and MPHASE are ignored.

MNUMBER = -2 ->While booting, the offset values ??and MPHASE are loaded from the feedback. The setting for MNUMBER is ignored.

Comment:
MNUMBER = 0 .... 32767 -> While booting the value of MNUMBER + MPHASE + offset values are read from the encoder. If the motor number (SMNUMBER) deviates from the motor number set in the drive (MNUMBER), the motor data set SMNUMBER is loaded from the internal motor database and a warning n12 (new motor data) is displayed. If the motor number in the encoder (SMNUMBER) is set to 0, MNUMBER is also set to 0 and no motor data set is loaded. This setting is reserved for a custom motor data set.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Monitor

monitor

All important parameters are displayed.

Additionally, you can see the value of 3 parameters. Fill in the ASCII names of the parameters of macro variables (with leading M) you want to see.

Drive-I²t-Load

The actual effective load is shown as % of the preset amplifier's effective current Irms.

Motor-I²t-Load

The actual effective load is shown as % of the preset motor's standstill current Io.

Effective Current

This shows the value (in A) of the actual current indication (r.m.s. value, always positive).

D Component

Shows the value (in A) of the current D-component (Id, reactive current) of the current indication.

Q Component

Shows the value (in A) of the current Q-component (Iq, active current) of the current indication. The sign that is displayed is negative in regenerative operation (motor under braking).

Bus Voltage

The DC-link (DC-bus) voltage produced by the amplifier is shown in V.

Regen Power

The mean value (calculated during 30s) of the regenerative power is shown in W.

Heat Sink Temperature

The temperature of the heat sink in the servo amplifier is shown in °C.

Internal Temperature

The temperature inside the servo amplifier is shown in °C.

Motor Thermistor Resistance

The actual resistance in ohms is shown, if a PTC resistor is used in the motor winding. The value can be used to calculate the actual motor winding temperature. If a thermo switch is used, absolute temperature cannot be evaluated.

Angle of Rotation

Displays the actual angle of rotation of the rotor in "°mech" or in "counts" referred to the mechanical zero point of the measuring system.

Indicated is the absolute position within one turn of the motor axis.

The dimension "counts" is a hexadecimal number with 20 bits accuracy (that means 1 turn ~ 220-1 counts).

Actual Velocity

Displays the actual rotational speed of the motor in rpm.

Velocity Command

Displays the currently set speed in rpm.

Position

Shows the momentary position in user units.

Following Error

Shows the momentary following error in user units.

Electrical Power

Current electrical power at the motor terminals P

Mechanical Power

Current mechanical power et the motor shaft PMECH

User-defined Variables to monitor

You can see the value of 3 parameters. Fill in the ASCII names of the parameters you want to see.

Analog Inputs

Displays the actual voltages (in mV) at the setpoint inputs.

Digital Inputs/Outputs

Displays the current status of the digital inputs and outputs.

Usable Macro Variables (selection, insert with leading M to the input field):

Macro Variable (selection) | Short Description
ERRCODE | Error state variable (see ERRCODE)
STATCODE | Drive state variable (see STATCODE)
TRJSTAT | Trajectory state variable (see TRJSTAT)
ADVAL0…15 | Analog input values
ADVAL0 | Cosine resolver
ADVAL1 | Sine resolver
tADVAL2 | Motor current Ia
ADVAL3 | Motor current Ib
ADVAL4 | Sine encoder
ADVAL5 | Cosine encoder
ADVAL6 | Analog setpoint 1
ADVAL7 | Analog setpoint 2
ADVAL8 | Motor temperature
ADVAL9 | Heatsink temperature
ADVAL10 | Environments temperature
ADVAL11 | Sense voltage encoder
ADVAL12 | n.c.
ADVAL13 | DC bus link voltage
ADVAL14 | n.c.
ADVAL15 | n.c.
SIENC | Normalised sine encoder +/- 1350 <> 1Vss
COENC | Normalised cosine encoder +/- 1350 <> 1Vss
SR_RXDE | Zero pulse port for NREF = 5
SR_HALL | Hall segments port
PFBL | Position Feedback 64 Bit size. The lower 32 bits includes the position within a revolution, the upper 32 bits counts the number of revolutions.
S_SETL | Position setpoint 64 Bit size. The lower 32 bits includes the position within a revolution, the upper 32 bits counts the number of revolutions.
PFB | Position Feedback (PRBASE size)
S_SET | Position setpoint (PRBASE size)
S_SETH | Sercos position setpoint (1 Revolution = 2^20)
PTARGET | Target position for the last/current motion task (PRBASE size)
PSPEED | Actual velocity setpoint in counts/250µsec
PSPEEDMS | Actual velocity setpoint in counts/250µsec for master/slave trajectory
PSPEED3 | Actual velocity setpoint for internal motion task trajectory
PENDSPEED | End velocity setpoint for the actual motion task
MOVEP_NR | Number of the last/actual motion task
NIZFLAG | State of the external zero pulse
PSTOP | State of the PSTOP limit switch
NSTOP | State of the NSTOP limit switch
INPUT1…20 | State of the hardware/software input 1…20
OUTPUT1...18 | State of the hardware/software output 1..18
HARDENA | State of the hardware enable
EN_P_I | State of the power stage (1=enabled, 0=disabled)
NET_BTBI | State of the net BTB
ENABLE_I | State of the internal enable signal
SOFTENABLE | State of the software enable
EN_BRAKE_I | Brake state (1=open, 0=closed)
PRD | Feedback position inside one revolution
IVORCMD | Current feed forward (3280 = DIPEAK)
PBAL | Regenerative power actual value
SR5VINCR | Pulse counter for X5 Master / Slave (5V)
SR24VINCR | Pulse counter for X3 Master / Slave (24V)


ASCII English MONITOR1

ASCII - Command | MONITOR1 |
Syntax Transmit | MONITOR1 [Data] |
Syntax Receive | MONITOR1 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 359A (hex)
DIM | mV | PROFIBUS PNU | 1754 (dec) IND = 1 (dec)
Range | -10000 ..10000 | DPR | 154 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 3.75 |
Configuration | No | Last Change of this Object | 2.13
Function Group | analog I/O | EEPROM | No
Short Description | Monitor 1 Output voltage

Description

Real/set value for the analog output 1 of the POSIO card.
s. ANOUT1

FW 3.75/5.02


ASCII English MONITOR2

ASCII - Command | MONITOR2 |
Syntax Transmit | MONITOR2 [Data] |
Syntax Receive | MONITOR2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 359B (hex)
DIM | mV | PROFIBUS PNU | 1755 (dec) IND = 1 (dec)
Range | -10000 ..10000 | DPR | 155 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.75 |
Configuration | No | Last Change of this Object | 2.13
Function Group | analog I/O | EEPROM | No
Short Description | Monitor 2 Output voltage

Description

Real/set value for the analog output 2 of the POSIO card.
s. ANOUT2

FW 3.75/5.02


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Motor / Feedback

Available with "Quick Motor/Drive Setup" only. Simplified setting of the motor related parameters. The quick setup of the parameters makes the tuning of the motor/amplifier combination in the application much easier. Special motors must be defined with the during the "Complete Setup" with Custom Motor Parameters on the screen "Motor".
Depending on the selection of rotary or linear motor the screen looks different.

Rotatory Motors

einheiten

Resolver is fixed to 2 pole in the Quick Motor/Drive Setup.

Change "pole n°" on feedback screen in Complete Setup later, if required.

Example EnDat Feedback: kamera .

Screen text | ASCII parameter
Feedback Type | FBTYPE
Encoder Lines | ENCLINES (with encoder feedback only)
Motor: Select from Database... | Click the button "Select from Database...". Open the database file (mdb_ _ _.csv) and select the used motor out of the list.
Brake | MBRAKE
Calculated Quick Tuning | If you know the Load-to-motor inertia ratio, enter the number and select the desired servo performance. If you don't know the inertia ratio, select "Do not tune".
Load-to-Motor Inertia Ratio | This value is the basis for calculating the velocity loop gain parameter.
Desired Servo Performance | This category is used for calculating some parameters of the current loop.

Linear Motors

einheiten6

If you select a linear motor, the screen changes.

Screen text | ASCII parameter
Feedback Type | FBTYPE
Encoder Lines | ENCLINES (with encoder feedback only). Click Calculate for calculating the encoder lines.
Motor: Select from Database... | Click the button "Select from Database...". Open the database file (mdb_ _ _.csv) and select the used motor out of the list.
Brake | MBRAKE
Calculated Quick Tuning | If you know the Load-to-motor inertia ratio, enter the number and select the desired servo performance. If you don't know the inertia ratio, select "Do not tune".
Load-to-Motor Inertia Ratio | This value is the basis for calculating the velocity loop gain parameter.
Desired Servo Performance | This category is used for calculating some parameters of the current loop.

enclines

Fill in the Encoder signal period and click "Calculate ENCLINES....". The calculated value is used for ASCII parameter ENCLINES.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Field Weakening

einheiten

Parameter settings for a speed-dependent phase lead (field weakening for permanent magnet servomotors). Please also refer to the KDN page Phase Lead for more information.

Screen text | ASCII parameter
upper diagram for AKM, VLM, Cartridge motors
Degree: | MVANGLF
lower diagram for all Goldline motors
Degree: | MVANGLP
speed threshold | MVANGLB
V_max | VLIM
Activate SR600 compatibility mode | MVANGLMODE

For motors made by other manufacturers, please request this information from the manufacturer concerned.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Motor

einheiten

Setting the motor-related parameters .
Motor data saved in the servo amplifier:
Select the motor type being used from the Motor Family selection list. In doing this, you also limit the individual motors displayed to those of a single motor family. Now select your motor in the Number-Name field.

Motor data saved in an external file:
Select a motor from an external database file (“Select Motor from Database” button). If your motor is not included in the database, enter the parameters for a user-defined motor yourself.

The displayed parameters cannot be edited. If you want to change individual data, do so via the “Custom Motor Parameters” button.

Screen text | ASCII parameter
Motor Type | MTYPE
Io | MICONT
Io max | MIPEAK
El. Thermal Time Constant | motor-dependant constante
Max. Speed | MSPEED
Motor-Family | selection of a motor family stored in the servo amplifier
Number - Name | MDBLIST
No. of Poles | MPOLES
L | ML
Stator Winding Resistance | MRS
Brake | MBRAKE
Pole-Pair Pitch | MPITCH (with PM Linear Motor only)

Select Motor from Database

einheiten5

Open the database (usually with CSV format).

einheiten51

All available records are listed. You can select two filter criteria for reducing the number of listed records. Select the requested record. You can view the record parameters and check them.

If everything is ok, click "Select and Return". The record data are transmitted to the corresponding parameters in the setup software.

Custom Motor Parameters

einheiten4

Setting parameters for a customer-specific motor.

Screen text | ASCII parameter
Motor Type | MTYPE
Linear Motor Type | (with PM Linear Motor only)
Motor Name | MNAME
Cont. current | MICONT
Peak current | MIPEAK
Maximum Speed | MSPEED
Motor Poles | MPOLES
Pole-Pair Pitch | MPITCH (with PM Linear Motor only)
Motor torque constant (Force conctant with linear motors) | MKT
L, line-to-line | ML
Stator Winding Resistance | MRS
Motor inertia | MJ
Brake | MBRAKE
Disable delay (brake) | TBRAKE
Enable delay (brake) | TBRAKE0
Thermistor Switch-off Treshold | MAXTEMPM
Feedback Type | FBTYPE
Max. allowed line voltage | VBUSBAL

Hints for evaluating motor parameters: see application note Tuning of an unknown motor.
Hints for sensorless operation of asynchron motors: see application note Asynchron machine - V/f Control.

Hints for the use of DC motors see application note DC Motor setup.

KTY Support

If a KTY temperature sensor is installed in the motor being used, click on the “Activate KTY Support” button. The servo amplifier can detect the absolute temperature at the measuring point if it knows the characteristic of the sensor. Each sensor characteristic can be reproduced with sufficient accuracy using 10 points. The typical KTY types are already included in the selection list. Select the KTY type and click on “Load Selection”. The values saved will be transferred to the characteristic table.

If the KTY type for your motor is not included in the list, you can enter 10 points for its characteristic in the table and save the settings using the “Save Settings As...” button.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Cogging torque compensation

einheiten

This function generates a table with current feed-forward values for cogging (torque) compensation, and activates this compensation. A distinction is made between linear and rotary motors in the case of this setting.

Prerequisite:

A reference point must be set (Homing). To ensure correct operation, you must check that the reference point is always at the same position it was in while the current feed-forward table was being created.

First select the cogging mode (drive type) and then enter the values for the measurement run.

The load will move during the measurement run. Ensure that the travel path is unobstructed and secured.

The axis will remain enabled after the measurement run.

Click on the “Start Measurement Run” button to start the measurement run.
You can find detailed information about the process on the KDN page Cogging Suppression.

Screen Text | ASCII parameter
Deactivated | COGMODE
Linear Motor | COGMODE (256 points)
Rotatory Motor | COGMODE (256 points)
High resolution table | COGMODE (4096 points)
Velocity | CALCCOG
Filter | COGFILT
Start position | CALCCOG
Distance | CALCCOG
Help | Starts KDN page Cogging Suppression


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Setup of an unknown motor

Even without known motor and feedback data the drive can be configured. Set the parameters and functions in the terminal screen (commands are presented in italic font).

Steps 1...8: Without load (Motor shaft must be accessible)

Step | Analyse / Set | Description
1 | Brake / no brake | Is it possible to turn the motor shaft manually (without gearbox or load)? => No: check if brake cable is connected to the servo amplifier MBRAKE 1 => Yes: MBRAKE 0
2 | Direction of Feedback | Open the Feedback Screen Turn the motor shaft clockwise with hand. (look to the front of the axis) Pointer rotate clockwise => OK Pointer rotate unclockwise => Change two signal wires of the feedback (SIN+ and SIN-).
3 | Resolver pole pairs / Encoder Enclines | Open the Feedback Screen Turn the motor clockwise with hand. (look to the front of the axis) Check: One rotation of the motor shaft = one rotation of the pointer Yes => OK No => change MRESPOLES for Resolver / ENCLINES for Encoder and check again
4 | Motor pole pairs | OPMODE 2 MPOLES 0 Switch on main power, set AS-Enable, set HW-Enable EN T 0.3 The motor shaft takes a preferential position. Turn the motor shaft manually. Count the steps (x=steps/turn) within one turn, every step is one pole pair. MPOLES x
5 | Commutation angle | Danger! Don't touch the motor shaft! With the Zero command the offset angle is measured. OPMODE 2 EN ZERO ZERO ZERO SAVE HSAVE ( for ENDAT and HIPERFACE feedbacks only)
6 | Direction of commutation | OPMODE 2 EN T 0.1 T 0.2 T 0.3 ... T 0.n ... until motor shaft rotates slowly Clockwise => OK Counterclockwise => change two motor wires (U2<->V2).
7 | Smith Predictor | Measure the phase-to-phase resistor (x in Ohm) and inductance (y in mH) values for the motor or take the values from the motor label. MRS x ML y K FILTMODE 2 SAVE COLDSTART
8 | Proportional Gain Current loop | OPMODE 2 EN CTUNE

Steps 9...14: With load

The motor shaft will rotate, the load will be moved! Risk of injury. Remove everything from the motion traverse. Don't touch the load when you proceed.

Step | Analyse / Set | Description
9 | Feedback Fine Tuning (Only for high precision systems) | OPMODE 0 EN CALCRK CALCHP
10 | Observer tuning | OPMODE 0 EN OTUNE
11 | Proportional gain Velocity loop | OPMODE 0 GVTN 0 EN STEP 500 50 500 –50 Open the oszilloscope screen and optimize the response of the actual speed to the setpoint change. Change GV in 20% steps until the response is best: GV 1 GV 1.2 GV 1.4 ...
12 | Integral gain Velocity loop | OPMODE 0 GVTN 30 EN STEP 500 50 500 –50 Open the oszilloscope screen and optimize the response of the actual speed to the setpoint change by changing GVTN in 20% steps GVTN 30 GVTN 25 GVTN 20 ...
13 | Bode Plot | Check the application for resonance (see screen page Bode Plot).
14 | Proportional gain Position loop | Define two motion task in position loop with identical distance but contrary direction. (one task starts the other) OPMODE 8 EN MOVE X Open the oszilloscope screen and minimize the following error by changing GP in 20% steps GP 0.1 GP 0.15 GP 0.2 … SAVE

Asynchron machine - V/f Control

Simple Sensorless Control for Induction Machines (Constant V/f Feed Forward Control). Hints for setup can be found in the KDN.

DC Motor Setup

Direct current drives need special adjustments and connections for the operation at the servoamplifier, due to their constructive differences. The servoamplifiers require special adjustments and wiring to run a DC motor (with brushes) due to construction differences of a DC motor. Hints for setup can be found in the KDN.


ASCII English MOVE

ASCII - Command | MOVE |
Syntax Transmit | MOVE [Data] |
Syntax Receive | MOVE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3642 (hex)
DIM | - | PROFIBUS PNU | 1922 (dec) IND = 1 (dec)
Range | 0 ... 300 | DPR | 322 (dec)
Default | 0 |
Opmode | 4, 8 | Data Type Bus/DPR | Integer16
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | control commands | EEPROM | No
Short Description | Start Motion Task

Description

The command “MOVE nr” starts the motion task “nr” from the motion task memory.
If the command is used without a parameter, then the number of the most recently started task will be displayed.


ASCII English MPHASE

ASCII - Command | MPHASE |
Syntax Transmit | MPHASE [Data] |
Syntax Receive | MPHASE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 359C (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1756 (dec) IND = 1 (dec)
Range | 0 .. 360 | DPR | 156 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Motor Phase, Feedback Offset

Description

The MOTOR PHASE parameter is handled in different ways, depending on the type of feedback (FBTYPE) that is used.
FBTYPE=0 resolver
MPHASE is saved in the serial EEPROM of the amplifier (SAVE command) and is transferred after every power-on of the amplifier.

FBTYPE=2, 4 Hiperface/Endat
MPHASE is saved in the serial EEPROM of the encoder (HSAVE command) and is read out from the encoder after every power-on of the amplifier. So if an encoder is exchanged, the MPHASE setting goes with the encoder. When a new encoder is fitted, the MPHASE value must be re-established and stored in the encoder (HSAVE command).

FBTYPE=7 sin/cos encoder without an internal EEPROM
MPHASE will be determined automatically at the first enable of the output stage (Wake & Shake)
It is not necessary to make a separate determination of the MPHASE value, or to save it.


ASCII English MPHASE2

ASCII - Command | MPHASE2 |
Syntax Transmit | MPHASE2 [Data] |
Syntax Receive | MPHASE2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3536 (hex)
DIM | - | PROFIBUS PNU | 1654 (dec) IND = 1 (dec)
Range | 0 ... 359, 1000 | DPR | 54 (dec)
Default | 1000 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 6.35 |
Configuration | Yes | Last Change of this Object |
Function Group | feedback | EEPROM | Yes
Short Description | Commutationfineadjustment

Description

Defines the MPHASE setting after the homing move. A value between 0 and 359 activates the function for setting the MPHASE value after the homing move is done The value MPHASE2 is written to the MPHASE parameter because the MPHASE parameter, which is calculated during W&S, can be imprecise.

The setting MPHASE2 1000 switches this function off.


ASCII English MPITCH

ASCII - Command | MPITCH |
Syntax Transmit | MPITCH [Data] |
Syntax Receive | MPITCH <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 351E (hex)
DIM | um | PROFIBUS PNU | 1630 (dec) IND = 1 (dec)
Range |  | DPR | 30 (dec)
Default | 32000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 0.67 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | pole pair pitch for linear motor

Description

The command MPITCH defines the pole - pair pitch for a linear motor.


ASCII English MPKD

ASCII - Command | MPKD |
Syntax Transmit | MPKD [Data] |
Syntax Receive | MPKD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3870 (hex)
DIM | - | PROFIBUS PNU | 1680 (dec) IND = 33 (dec)
Range | - | DPR | 880 (dec)
Default | 10000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.53 |
Configuration | No | Last Change of this Object | 2.0
Function Group | wake&shake | EEPROM | Yes
Short Description | D-Term for the commutation alignment PID position loop

Description

D-Term for the commutation alignment PID position loop (CALCMP)


ASCII English MPKI

ASCII - Command | MPKI |
Syntax Transmit | MPKI [Data] |
Syntax Receive | MPKI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3871 (hex)
DIM | - | PROFIBUS PNU | 1681 (dec) IND = 33 (dec)
Range | - | DPR | 881 (dec)
Default | 1000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.53 |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | wake&shake | EEPROM | Yes
Short Description | I-Integration Time for the commutation alignment PID position loop (CALCMP)

Description

I-Integration Time for the commutation alignment PID position loop (CALCMP)


ASCII English MPKP

ASCII - Command | MPKP |
Syntax Transmit | MPKP [Data] |
Syntax Receive | MPKP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3872 (hex)
DIM | - | PROFIBUS PNU | 1682 (dec) IND = 33 (dec)
Range | - | DPR | 882 (dec)
Default | 600 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.53 |
Configuration | No | Last Change of this Object | 2.7
Function Group | wake&shake | EEPROM | Yes
Short Description | Proportional gain for the commutation alignment PID position loop (CALCMP)

Description

Proportional gain for the commutation alignment PID position loop (CALCMP)


ASCII English MPOLES

ASCII - Command | MPOLES |
Syntax Transmit | MPOLES [Data] |
Syntax Receive | MPOLES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 359D (hex)
DIM | Poles | PROFIBUS PNU | 1757 (dec) IND = 1 (dec)
Range | 0, 2, 4, 6, .. , 256 | DPR | 157 (dec)
Default | 6 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | motor | EEPROM | Yes
Short Description | Number of Motor Poles

Description

The number of motor poles per turn of the motor.
MPOLES = 0 is not saved into the drive. The setting MPOLES =0 is also not monitored in the MMI.

Linear Motors:
The standard setting for linear motors is MPOLES = 2.
An exception is if enclines is not an integer value for the pole pitch distance (MPITCH). In this case a differnt value for enclines and MPOLES is required. Contact our technical support.

In all sensorless modes (FBTYPE = 10.11), the output frequency is limited to 599 Hz. This yields the following limits of maximum speed (in RPM): MSPEED (max) = 599Hz * 60 / (MPOLES/2) If your application requires a higher output frequency, please contact our support.

Under certain conditions, this variable is to be seen as a configuration variable. Only the setting of the value to 0 can be done with enabled power stage. All other changes may only be made if the power stage is disabled.

With these parameters, the amplifier decides whether a COLDSTART is necessary. The MPOLES change from the last value after the COLDSTART to 0 or back to 0 does not require a COLDSTART, otherwise a COLDSTART is required (e. g. from 6 to 8).


ASCII English MPOLES_X

ASCII - Command | MPOLES_X |
Syntax Transmit | MPOLES [Data] |
Syntax Receive | MPOLES_X <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3766 (hex)
DIM | Poles | PROFIBUS PNU | 1814 (dec) IND = 17 (dec)
Range | 0, 2, 4, 6, .. , 256 | DPR | 614 (dec)
Default | 6 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | motor | EEPROM | Yes
Short Description | Number of Motor Poles

Description

see PARCNFG, MPOLES

Under certain conditions, this variable is to be seen as a configuration variable. Only the setting of the value to 0 can be done with enabled power stage. All other changes may only be made if the power stage is disabled.

With these parameters, the amplifier decides whether a COLDSTART is necessary. The MPOLES_X change from the last value after the COLDSTART to 0 or back to 0 does not require a COLDSTART, otherwise a COLDSTART is required (e. g. from 6 to 8).


ASCII English MPR

ASCII - Command | MPR |
Syntax Transmit | MPR [Data] |
Syntax Receive | MPR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | -
DIM | W | PROFIBUS PNU | -
Range | 100 .. 10000 | DPR | No
Default | 500 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Rated output power of the motor

Description

Rated output power of the motor

Used for calculation of MTR


ASCII English MPTIME

ASCII - Command | MPTIME |
Syntax Transmit | MPTIME [Data] |
Syntax Receive | MPTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3873 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 33 (dec)
Range | - | DPR | 883 (dec)
Default | 500 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.53 |
Configuration | No | Last Change of this Object | 2.0
Function Group | wake&shake | EEPROM | Yes
Short Description | Alignment time for the commutation alignment PID position loop (CALCMP)

Description

Alignment time for the commutation alignment PID position loop (CALCMP)


ASCII English MRESBW

ASCII - Command | MRESBW |
Syntax Transmit | MRESBW [Data] |
Syntax Receive | MRESBW <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A0 (hex)
DIM | Hz | PROFIBUS PNU | 1760 (dec) IND = 1 (dec)
Range | 50 .. 2000 | DPR | 160 (dec)
Default | 300 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Resolver Bandwidth

Description

MRESBW is a tuning parameter that sets the bandwidth (in Hz) of the inner control loop. A high value (>800 Hz) results in a fast (low phase lag) and noisy velocity signal. A low value (<400 Hz) results in a slow (higher phase lag) and smooth velocity signal. The default value of 600 Hz is a compromise between phase lag and noise. The phase lag can be reduced by providing the acceleration feed forward signal (VLO = 1 ).

With a wide bandwidth, the drive responds more rapidly to control loop deviations and there is a smaller following error (reduced lag). A very wide bandwidth only makes sense with low moments of inertia, low KP, and very high acceleration values. A narrower bandwidth produces a filter effect. The rotational velocity and positional control are smoother (encoder equivalent output is quieter as well).
For the sensorless drive, the Luenberger Observer is used as the adaptive controller. Therefore, the parameter MRESBW corresponds to the bandwidth of the adaptive controller. It is normally set between 25 and 100 Hz.


ASCII English MRESPOLES

ASCII - Command | MRESPOLES |
Syntax Transmit | MRESPOLES [Data] |
Syntax Receive | MRESPOLES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35A1 (hex)
DIM | - | PROFIBUS PNU | 1761 (dec) IND = 1 (dec)
Range | 2, 4, .. 32 | DPR | 161 (dec)
Default | 2 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Number of Resolver Poles (Multispeed)

Description

The number of resolver poles (multispeed resolver) per turn.


ASCII English MRS

ASCII - Command | MRS |
Syntax Transmit | MRS [Data] |
Syntax Receive | MRS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3686 (hex)
DIM | Ohms | PROFIBUS PNU | 1990 (dec) IND = 1 (dec)
Range | 0 .. 200 | DPR | 390 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | other commands | EEPROM | Yes
Short Description | Winding Resistance of the Stator Phase-Phase

Description

The parameter describes the stator winding resistance phase-phase in Ohm


ASCII English MRS_X

ASCII - Command | MRS_X |
Syntax Transmit | MRS [Data] |
Syntax Receive | MRS_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 376C (hex)
DIM | Ohms | PROFIBUS PNU | 1820 (dec) IND = 17 (dec)
Range | 0 .. 200 | DPR | 620 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | other commands | EEPROM | Yes
Short Description | Winding Resistance of the Stator Phase-Phase

Description

see PARCNFG


ASCII English MSERIALNO

ASCII - Command | MSERIALNO |
Syntax Transmit | MSERIALNO [Data] |
Syntax Receive | MSERIALNO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36A3 (hex)
DIM | - | PROFIBUS PNU | 2019 (dec) IND = 1 (dec)
Range | Long Int | DPR | 419 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | No
Short Description | Serial no of the motor for encoder feedback

Description

MSERIALNO give the possibility to add a serial number of the motor. It is stored in the encoder with parameter channel (EnDAT or Hiperface) of the motor by typing in HSAVE.
MSERIALNO gives the serial number of the connected motor with encoder feedback.
This command can only be used, if a motor with encoder is connected.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Motion Service

Be aware that the actual position of the load permits the subsequent positioning operations. The software limit-switches that were set as parameters are inactive, depending on the operation mode. The axis could move to the hardware limit-switch or the mechanical stop. There is a risk of damage.

Observe the "safe reduced speed" requirements for your application!

einheiten

You can move the drive with constant speed (jog mode). The drive moves with the preset speed when the + or – button is pressed. It stops when the button is released.

Jog (digital velocity mode checks parameters in velocity controller)

Jog mode in OPMODE 0.

plus positive speed

minus negative speed

Fill in the speed (dimension: speed in velocity loop)

Jog (position motion tasks mode checks parameters in position controller)

Jog mode in OPMODE 8.

positive speed

negative speed

Fill in the speed (dimension: speed in position loop)


ASCII English MSG

ASCII - Command | MSG |
Syntax Transmit | MSG [Data] |
Syntax Receive | MSG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35A2 (hex)
DIM | - | PROFIBUS PNU | 1762 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 162 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Enable / Disable All Messages via RS232

Description

If “MSG 2” is set, then the execution of the individual initialization steps will be signaled through the serial interface when the amplifier is switched on (initialization phase). This setting should only be used for test purposes (e.g. during commissioning).
Since the drive setup software Drive.exe only works with the setting “MSG 1”, the “MSG 2” setting can only be implemented with the help of a terminal program (not in the terminal window of the operating program).


ASCII English MSLBRAKE

ASCII - Command | MSLBRAKE |
Syntax Transmit | MSLBRAKE [Data] |
Syntax Receive | MSLBRAKE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3671 (hex)
DIM | - | PROFIBUS PNU | 1969 (dec) IND = 1 (dec)
Range | 1 .. 32 | DPR | 369 (dec)
Default | 8 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | Yes
Short Description | DEC ramp at sensorless emergency stop

Description

If the feedback unit trips (Fault F04, F08 or F25), it is impossible to stop the motor with the standard commutation. Therefore a sensorless stop is implemented. It is not possible to define a ramp, because it depends on the friction and inertia of the system. MSLBRAKE offers the possibility to change the emergency ramp in this case. The lower MSLBRAKE is, the lower is the deceleration of the motor.


ASCII English MSPEED

ASCII - Command | MSPEED |
Syntax Transmit | MSPEED [Data] |
Syntax Receive | MSPEED <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35A3 (hex)
DIM | rpm | PROFIBUS PNU | 1763 (dec) IND = 1 (dec)
Range | 0.0 .. 12000.0 | DPR | 163 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | motor | EEPROM | Yes
Short Description | Maximum Rated Motor Velocity

Description

The MSPEED sets the upper limit for the following amplifier parameters: VLIM, VLIMN,
5/6 * VOSPD.

In all sensorless modes (FBTYPE = 10.11), the output frequency is limited to 599 Hz. This yields the following limits of maximum speed (in RPM): MSPEED (max) = 599Hz * 60 / (MPOLES/2) If your application requires a higher output frequency, please contact our support.

Details are shown at parameter VUNIT .


ASCII English MTAB

ASCII - Command | MTAB |
Syntax Transmit | MTAB [Data] |
Syntax Receive | MTAB <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | Ohm | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.45 |
Configuration | No | Last Change of this Object | 2.8
Function Group | motor | EEPROM | Yes
Short Description | Enter the KTY characteristics

Description

With the syntax: MTAB Temp1 R1 Temp2 R2…Temp10 R10 defines the required characteristic curve

Temp1..10 : temperature in arbitrary value X
R1...R10: Resistor in Ohm

The number of points for the temperature characteristics must be 2 to 10. Internally, there will be a linear interpolation between the points. To delete the curve, type in MTAB 0 0

In a non-existent characteristic MTAB the command returns no values??. If the characteristic is not defined, then the temperature display TEMPM and the temperature error threshold MAXTEMPM appears as a resistance in ohms.

For existing characteristic MTAB the units change for the parameters MAXTEMPM and TEMPM from ohms to unit X

Please have a look to: TEMPM und MAXTEMPM


ASCII English MTANGLP

ASCII - Command | MTANGLP |
Syntax Transmit | MTANGLP [Data] |
Syntax Receive | MTANGLP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A5 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1765 (dec) IND = 1 (dec)
Range | 0 .. 45 | DPR | 165 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Current Lead

Description

The current-dependent phase lead that is applied to make use of the reluctance torque at motor peak current (MIPEAK.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Motion Task

Overview

fahrsatz1

For each positioning task, you must define motion tasks. These motion tasks are selected by a motion task number and stored in the servo amplifier.

Motion task No. | Memory | Preassumption | Note
1...200 | EEPROM | Output stage disabled | permanently stored
201...300 | RAM | none | volatile storage

When the servo amplifier is switched on, the RAM motion blocks 201...300 are automatically pre-loaded with the parameters of the EEPROM motion blocks 1...100.

All motion tasks are represented in tabular form. All motion task parameters can be entered in the table directly. The standard Windows operations are available (Cut, Copy, Paste, Delete).

The clipboard operations cut, copy and paste are only possible for complete rows so, for these operations, the appropriate row must be selected. Deletion is possible both, row- and cellwise. A line can be selected either by clicking on the row number, or through the keyboard shortcuts <Shitft>+<Space> (similar to Microsoft Excel).

Double-clicking a line number in the table opens the screen page for the associated motion task.

The SW-enable is automatically set when the motion task starts. The motion task is only started in OPMODE 8. However, the SW-enable is set in all OPMODES. The drive can be accelerated by an analog setpoint that is applied, if the START command is executed in OPMODE 1 or 3.
The motion task is not started if the target position is beyond the defined SW-limit switches (warning messages n06/n07 and n08)

Edit

einheiten2

Number
Displays the active motion task number.

Trajectory/Profile (O_C)

Determines which type of acceleration/braking ramp is used to carry out a motion task. Depending on the used profile a higher peak power of the amplifier is required (see KDN page Acceleration Profile Tables). The shown profile changes according to the selected table.

trapezoidal | The drive is given a constant linear acceleration/deceleration to the target speed.
table | The acceleration/braking ramps can be adjusted with a customer profile stored previously in the servo amplifier.
acc. (sine²) | To limit any jolting, the drive is accelerated/decelerated within the acceleration time along an acceleration ramp without any disruptions. The resulting speed characteristic corresponds to a sine² curve. The profile is stored in a table in the servo amplifier.

Table / Acc. No. (O_TAB)
Selection of a velocity profile from the table selected by trajectory. You can get more information on this topic in KDN page Acceleration Profile Tables.

Integrated profile tables:

IPx= Ipeak factor x: profile requires x% more peak current of the servo amplifier
I2tx= I2t factor y: profile requires y% more peak charge of the servo amplifier

red: P_cmd (position set point)
green: v_cmd (velocity set point)
blue: I_cmd (torque set point)

0 | IPx 157% I2tx 123% | profil0
1 | IPx 200% I2tx 150% | profil1
2 | IPx 132% I2tx 115% | profil2
3 | IPx 113% I2tx 106% | profil3
4...15 | unused | Customer specific tables with totally 4000 points possible (see KDN page Setup of Acceleration Profile Tables).

v_cmd (O_V)
This parameter determines the velocity of movement for digital setpoint provision. If v_max is set to a value less than v_cmd at a later time, the position controller uses the smaller value.

Analog In 1
Analog setpoint provision at input An In 1 (terminals X3/4-5, is used. The value is read at the start of the motion task.

Acceleration (O_ACC)
This parameter determines the acceleration ramp steepness, depending on the selected units.

Decelaration (O_DEC)
This parameter determines the deceleration ramp steepness, depending on the selected units

Motion Type (O_C)
This selection determines whether the motion task is interpreted as a relative or an absolute task.

ABS | movement to an absolute target position, relative to the reference point.
REL cmd | relative to last target (setpoint) position (in connection with motion block changeover: e.g., summing operation)
REL act | relative to actual position at start (in connection with motion block changeover: e.g., register control)
REL InPos | when the load is in the InPosition window: relative to last target position when the load is not in the InPosition window: relative to actual position at start
REL Latch pos. | contact our applications department.
REL Latch neg. | contact our applications department.

Target position / Distance (O_P)
This parameter defines the distance or the target position, depending on the motion type.

Units
Unit for path and speed entries. See screen page "Units/Mechanical"

Next Motion Task

Select whether a new motion task should be started automatically, after the present task is complete. The InPosition signal is only enabled when the last motion task (no further task) is processed.
You can use the output function "16, Next-InPos" to generate a signal at a digital output when each target position within a sequence of motion tasks has been reached.

Next Number
The number of the next task, which starts automatically after the current task is complete.

Start Condition (O_C)

immediately

The next task is started as soon as the target position is reached.

I/O

The next task is started by a signal at a digital input. This is only meaningful with "Motion blending type a".

Condition: the digital input must have the function "15, Start next Motion Task" assigned, and the target position must have been reached.

You can preselect the logic using the "Start with" parameter.

Time

The next task is started with a defined delay after the target position has been reached. You can enter the delay time using the "Delay time" parameter. This is only meaningful with "Motion blending type a".

I/O or Time

The next task is started by a signal at a digital input or after a defined delay. This is only meaningful with "Motion blending type a".
The trigger is the event that occurs first (the start signal or the end of the delay time) Condition: the digital input must have the function "15, Start next Motion Task" assigned, and the target position must have been reached. You can preselect the logic using the "Start with" parameter, and enter the delay time using the "Delay time" parameter.

Start by I/O edge (O_C)
The logic for the digital input that has the function "15, Start next Motion Task" assigned to it.
LOW-level: 0 ... 7 V

HIGH-level: 12 ...3 0 V / 7 mA

Delay Time (O_FT)
The entry (in ms) for the delay time between reaching the target position and starting the next task.

Motion blending
Select the action to be taken when the target position for the present motion task is reached.

a | The drive brakes to a stop in the target position. The next motion task is started.
b | The drive moves at v_cmd of the present motion task to the target position, and accelerates through to v_cmd of the next task.
c | The changeover to the next task is brought so far forward that the v_cmd of the next task is already reached by the time the target of the present motion task is reached.

Clear Motion Task
Deletes the motion task from the table.


ASCII English MTIME

ASCII - Command | MTIME |
Syntax Transmit | MTIME [Data] |
Syntax Receive | MTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 35AC (hex)
DIM | s | PROFIBUS PNU | 1772 (dec) IND = 1 (dec)
Range | 1 ... 600 | DPR | 172 (dec)
Default | 16 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Motor thermal time constant

Description

Motor thermal time constant to calculate MI2T with MICONT


ASCII English MTIME_X

ASCII - Command | MTIME_X |
Syntax Transmit | MTIME [Data] |
Syntax Receive | MTIME_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 376F (hex)
DIM | s | PROFIBUS PNU | 1823 (dec) IND = 17 (dec)
Range | 1 ... 600 | DPR | 623 (dec)
Default | 16 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | motor | EEPROM | Yes
Short Description | Motor thermal time constant

Description

see PARCNFG


ASCII English MTMUX

ASCII - Command | MTMUX |
Syntax Transmit | MTMUX [Data] |
Syntax Receive | MTMUX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 365B (hex)
DIM | - | PROFIBUS PNU | 1947 (dec) IND = 1 (dec)
Range | 0 ... 300 | DPR | 347 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.6
Function Group | position loop | EEPROM | No
Short Description | Presetting for motion task that is processed later

Description

The command MTMUX presets the number of a motion task that is then prepared to work with commands O_P,O_V,O_C,O_ACC,O_DEC,O_FT,O_FN.
All this commands then have access to the selected motion task.

MTMUX work only with motion tasks no. 0, 201 ... 300.

MTMUX is not stored in EEPROM. While start-up of the drive, MTMUX is automatically set to "0".


ASCII English MTR

ASCII - Command | MTR |
Syntax Transmit | MTR [Data] |
Syntax Receive | MTR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 366C (hex)
DIM | ms | PROFIBUS PNU | 1964 (dec) IND = 1 (dec)
Range | 20 ... 1000 | DPR | 364 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.37 |
Configuration | No | Last Change of this Object | 1.37
Function Group | other commands | EEPROM | Yes
Short Description | Rotor time constant

Description

Rotor time constant for calculation of the magnetic rotor flux and the gap


ASCII English MTYPE

ASCII - Command | MTYPE |
Syntax Transmit | MTYPE [Data] |
Syntax Receive | MTYPE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35A6 (hex)
DIM | - | PROFIBUS PNU | 1766 (dec) IND = 1 (dec)
Range | 1 ... 4 | DPR | 166 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | motor | EEPROM | Yes
Short Description | Motor Type

Description

MTYPE sets the drive control algorithms to different motor types as follows:
MTYPE = 1: permanent magnet motor
MTYPE = 2: permanent magnet motor with Id current control
The one case is for the linear permanent magnet motor, the other case is for the sensorless drive of permanent magnet motor.
MTYPE = 3: asynchronous motor (Induction motor)
MTYPE = 4: reserved for voice coil motor


ASCII English MUR

ASCII - Command | MUR |
Syntax Transmit | MUR [Data] |
Syntax Receive | MUR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3886 (hex)
DIM | V | PROFIBUS PNU | 1702 (dec) IND = 33 (dec)
Range | 100 .. 500 | DPR | 902 (dec)
Default | 230 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | rated voltage of the induction machin

Description

MUR is a paramtere for using a induction maschine and describes the rated voltage of the induction motor (in Volt)


ASCII English MVANGLB

ASCII - Command | MVANGLB |
Syntax Transmit | MVANGLB [Data] |
Syntax Receive | MVANGLB <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35A7 (hex)
DIM | rpm | PROFIBUS PNU | 1767 (dec) IND = 1 (dec)
Range | 0 .. 15000 | DPR | 167 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Float
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Velocity-dependent Lead (Start Phi)

Description

This is a compensation for the inductive phase shift between the motor voltage and the motor current at high velocitys. With defined voltage relationships, it permits a higher torque at the final limit velocity. Alternatively, the achievable final limit velocity can be increased by up to 30%. Depending on the motor velocity, the phase shift (commutation angle) is increased linearly from the Start Phi point up to the Limit Phi value (MVANGLF) at the final limit velocity. The most favorable setting depends on the type of motor and the final limit velocity.
See also MVANGLF.


ASCII English MVANGLF

ASCII - Command | MVANGLF |
Syntax Transmit | MVANGLF [Data] |
Syntax Receive | MVANGLF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A8 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1768 (dec) IND = 1 (dec)
Range | 0 .. 45 | DPR | 168 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Velocity-dependent Lead (Limit Phi)

Description

This is a compensation for the inductive phase shift between the motor voltage and the motor current at high velocitys. With defined voltage relationships, this permits a higher torque at the final limit velocity. Alternatively, the achievable final limit velocity can be increased by up to 30%. Depending on the motor velocity, the phase shift is increased linearly from the Start Phi point (MVANGLB) up to the End Phi value at the final limit velocity. The most favorable setting depends on the type of motor and the final limit velocity.
See also MVANGLB.


ASCII English MVANGLMODE

ASCII - Command | MVANGLMODE |
Syntax Transmit | MVANGLMODE [Data] |
Syntax Receive | MVANGLMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 38CF (hex)
DIM |  | PROFIBUS PNU | 1775 (dec) IND = 33 (dec)
Range | 0 .. 1 | DPR | 975 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State |  | Weighting |
Start Firmware | 5.50 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM |
Short Description | SR600 kompat. mode for speed dependend phase lead

Description

The phase lead with S300/S700 based on the method of the SR600. In the actual implementing some changes have been made which lead to the following improvements:

1. better operational dynamics in the field weakening
2. dynamic current limit (resulting in a slower rise of I2t)
3. active phase lead, with acceleration and(!) deceleration

In situations where a desired behavior is similar to the SR600 (e.g. using parameters obtained with a SR600), this can be enabled by setting MVANGLMODE = 1


ASCII English MVANGLP

ASCII - Command | MVANGLP |
Syntax Transmit | MVANGLP [Data] |
Syntax Receive | MVANGLP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3592 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1746 (dec) IND = 1 (dec)
Range | 0 .. 60 | DPR | 146 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | other commands | EEPROM | Yes
Short Description | Velocity-dependent Lead (Commutation Angle)

Description

The inductive phase shift between the motor current and the motor voltage is compensated at high velocities. With the given voltage conditions, a higher torque is achieved at the velocity limit.
Alternatively, the achievable velocity limit is increased by 30%. The phase shift is increased linearly from a value of 0 degrees at MVANGLB up to a final value of MVANGLF degrees at VLIM. The optimum setting depends on the type of motor and velocity limit.


ASCII English MVER

ASCII - Command | MVER |
Syntax Transmit | MVER |
Syntax Receive | MVER <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 3861 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 33 (dec)
Range |  | DPR | 865 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Float32
Drive State | - | Weighting |
Start Firmware | 2.14 |
Configuration | No | Last Change of this Object | 1.5
Function Group | drive configuration | EEPROM | No
Short Description | Version of the motor data base

Description

This variable includes the version of the motor data base.


ASCII English MVR

ASCII - Command | MVR |
Syntax Transmit | MVR [Data] |
Syntax Receive | MVR <Data> | Available in |
Type |  | MMI | No
ASCII Format | - | CANBus Object Number | 366D (hex)
DIM |  | PROFIBUS PNU | 1965 (dec) IND = 1 (dec)
Range | 0 .. MSPEED | DPR | 365 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.13
Function Group | other commands | EEPROM |
Short Description | Nominal speed of asynchron motor

Description

Rated speed of the induction motor.

Significance depends on mode of operation:

1. Normal operation of the induction machine (with sensor): (DRVCNFG2 Bit 0x8000000=1)
MVR defines the beginning of field for the induction machine. Above this speed, the nominalD-current (MIMR) is lowered. MVR = 0 disables field weakening

2. V/f control (no sensor): (DRVCNFG2 Bit 0x8000000=0)
Used to calculate V/f trajectory.


ASCII English NONBTB

ASCII - Command | NONBTB |
Syntax Transmit | NONBTB [Data] |
Syntax Receive | NONBTB <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AA (hex)
DIM | - | PROFIBUS PNU | 1770 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 170 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Mains-BTB Check On/Off

Description

If the AC main power is missing, then the output stage will produce a fault message F16 (Mains-RTO) if the drive is enabled. To disable this response set NONBTB = 1. In the case the drive is powered direct by DC power this setting is requiered.

The influence of the NONBTB setting is as follows:

NONBTB=0: Prechargelevel=350V , VBUS-ripple 1.5V/1msek, monitoring Net-BTB activ for 400/480V-line entry
NONBTB=1: Prechargelevel=350V, VBUS-ripple 1.5V/1msek, monitoring Net-BTB not activ for 400/480V-line entry
NONBTB=2: reserved
NONBTB=3: Prechargelevel=100V, VBUS-ripple 1.5V/1msek, monitoring Net-BTB not activ for 230V-line entry
NONBTB=4: Prechargelevel=10V, VBUS-ripple 1.5V/1msek, monitoring Net-BTB not activ for 48V-line entry

An adittional parameter RELTIME can be used to deactivate the monitoring of the VBUS ripple.
See also UVLTMODE.


ASCII English NREF

ASCII - Command | NREF |
Syntax Transmit | NREF [Data] |
Syntax Receive | NREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AD (hex)
DIM | - | PROFIBUS PNU | 1773 (dec) IND = 1 (dec)
Range | -2 .. 20 | DPR | 173 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | Yes
Short Description | Homing Mode

Description

For linear movements, before a positioning movement can be started, a homing operation must be carried out. The reference point set in this operation is valid until the next hardware reset of the amplifier. An attempt to start positioning without a reference point being set causes a warning (LCD display n09). Any previously-set reference point is cancelled before the homing operation begins.
A preset zero-point offset is taken into account for the position output and display. Exception: Homing=5. In this case, the true current position is displayed. You can shift the zero-crossing point of the motor shaft within one turn by using ENCZERO.
Zero-point recognition: The reference point is set to the first zero-crossing point of the feedback unit (zero mark) after recognition of the reference switch transition. Two-pole resolvers and all encoders have just one zero-crossing per turn, so the positioning at the zero mark is unambiguous within a motor turn. For four-pole resolvers, there are two zero-crossings per turn. For six-pole resolvers, there are three zero-crossings per turn. If the transition of the reference switch lies very close to the zero-crossing point of the feedback unit, the positioning to the zero mark can vary by one motor turn. The repetition accuracy of homing operations made without zero-point recognition depends on the traversing velocity and the mechanical design of the reference or limit switch.
For homing modes 1 and 3, a digital input must be configured as a zero-mark input (home position) (INxMODE=12 or I/O expansion card).
For homing modes 2 and 4, a digital input must be configured as a hardware limit switch ( see also IN3MODE or IN4MODE).
For homing modes 1, 2, 3, 4, 5, and 7, the setting of the zero-pulse offset for the Encoder Equivalent Output (EEO) output is taken into account (the zero point is set so both the output of the zero pulse and the display of the zero position appear at zero-pulse offset).
The setting of the reference offset (ROFFS) is taken into account for all homing modes. The zero point is assigned to a freely chosen absolute position value.

If a multiturn encoder is used, every homing move can be started. If the homing move is ready, RSOFFS is calculated automatically and a SAVE command is executed.
Wenn the drive is switched off and on, the drive has the same position.

See also REFMODE, VREF
Status | Short Description | Additional Description
NREF=0 Set Reference at actual position The actual position becomes the refernce point ( the target and the actual position are set to ROFFS).
The distance between the actual and the target position is lost.
NREF=1 Traverse to the reference switch with zero-mark recognition. The drive starts a move using DREF, until a positive edge at the reference switch is detected. Then the distance to the next zero point of the resolver is calculated and a move to this position is started.
If the reference switch is present (input signal = high), a move in the opposite direction of DREF is startet until a negative edge is detected. Then the homing move is started.
If a hardware limit switch is detected (start of the homing move behind the reference switch), the direction is changed and a move is started, until a positive and a negative level edge is detected at the reference switch. Then the homing move is started. At the end of the homing move, the target and the actual position are set to ROFFS.
NREF=2 Move to hardware limit-switch, with zero-mark recognition. The drive starts a move using DREF until the hardware limit switch is reached. Then the direction is changed and the drive moves to the next zero point of the resolver.
At the end of the homing move, the target and the actual position are set to ROFFS.
NREF=3 Move to reference switch, without zero-mark recognition. The drive starts a move using DREF, until a positive edge at the reference switch is detected. The position at the edge of the reference move is eqivalent to ROFFS. Then the drive stops.
If the reference switch is present (input signal = high), a move in the opposite direction of DREF is startet until a negative edge is detected. Then the homing move is started.
If a hardware limit switch is detected (start of the homing move behind the reference switch), the direction is changed and a move is started, until a positive and a negative level edge is detected at the reference switch. Then the homing move is started. The real stop position is not the edge of the reference switch and depends on the selected speed and the deceleration ramp.
NREF=4 Move to hardware limit-switch, without zero-mark recognition. The drive starts a move using DREF, until the hardware limit switch is detected. Then the direction is changed and a move is started until the hardware limit switch is high again. The position at the edge of the hardware limit switch is eqivalent to ROFFS. Then the drive stops.
The real stop position is not the edge of the hardware limit switch and depends on the selected speed and the deceleration ramp.
NREF=5 Move to the next zero-mark of the feedback unit. Homing to the next zero point of the resolver. The moving direction is given by variable DREF.
DREF=0 negative
DREF=1 positive
DREF=2 the direction is given by the shortest distance.
NREF=6 Set Reference at actual position, without loosing target position The actual position becomes the reference point ( the position setpoint and the actual position are set to ROFFS).
The difference to NREF=0 is, that the distance between target and actual position is not lost (position error).
NREF=7 Move to mechanical stop with zero-mark recognition When the homing mode 7 is started, the peak current limit threshold IPEAK is set to REFIP (peak current for the homing mode in A) in the drirection given by DREF (DREF=0 negative, DREF=1 positive).
When the drive moves the motor, the contouring error is monitored and if the error becomes higher than PEMAX / 2 (half of the contouring error window), the direction is changed and a move to the next zero point of the resolver is startet. The motor stops in that position and sets the actual and the target position to ROFFS. The peak current of the drive is set back to the original value of IPEAK.
NREF=8 | Move to absolute SSI-position | When a homing mode 8 is started, the actual position of an external Multiturn SSI encoder (selected by GEARMODE) is read, calculated with GEARI and GEARO to internal counts and an offset value ROFFSSSI is added. The result is a target position for a motion task that is started. When the target position is reached, the IN-POSITION bit is set. This function is done for a gantry application with multiturn encoder feedback and coupling of the two drive using SSI multiturn,
NREF=9 Move to mechanical stop without zero-mark recognition When the homing mode 9 is started, the peak current limit threshold IPEAK is set to REFIP (peak current for the homing mode in A) in the drirection given by DREF (DREF=0 positive, DREF=1 negative).
When the drive moves the motor, the contouring error is monitored and if the error becomes higher than PEMAX / 2 (half of the contouring error window), this position is used to set the actual and the target position to ROFFS. The peak current of the drive is set back to the original value of IPEAK.


ASCII English NREFG

ASCII - Command | NREFG |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English NREFMT

ASCII - Command | NREFMT |
Syntax Transmit | NREFMT [Data] |
Syntax Receive | NREFMT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36D2 (hex)
DIM |  | PROFIBUS PNU | 1666 (dec) IND = 17 (dec)
Range | 0 ... 511 | DPR | 466 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Homing wih following motion task

Description

The command NREFMT will automatically start a motion task at the end of homing.

The parameter NREFMT is a bit-variable (16 bit)

FEDCBA9876543210
xxxxxxxcnnnnnnnn

Bits 0..7 (nnnnnnnn) number of the automatic started motion task
number = 0 no motion task will be started.

Bit 8 =0 motion task nn will be startet after the motor stopped. The bits "homing active=0“ and "homing finnished=1“ are set before motion task nn is started.

=1 motion task nn starts immediately. The bits "homing active=0“ and "homing finnished=1“ are set after motion task nn is finnished.


ASCII English O1

ASCII - Command | O1 |
Syntax Transmit | O1 [Data] |
Syntax Receive | O1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AE (hex)
DIM | - | PROFIBUS PNU | 1774 (dec) IND = 1 (dec)
Range |  | DPR | 174 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | State of Digital Output 1

Description

S300:
The O1 command returns the state of the digital output 1 (0 = Low,1 = High).
If no function (O1MODE=0) is assigned to digital output 1 , then the High/Low state can be given out at output 1 by using the command “O1 1” or “O1 0”.

S700:
The O1 command returns the state of the digital output 1 (0 = Low,1 = High).
If the function (O1MODE=23) is assigned to digital output 1 , then the High/Low state can be given out at output 1 by using the command “O1 1” or “O1 0”.


ASCII English O1MODE

ASCII - Command | O1MODE |
Syntax Transmit | O1MODE [Data] |
Syntax Receive | O1MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AF (hex)
DIM | - | PROFIBUS PNU | 1775 (dec) IND = 1 (dec)
Range | 0 .. 100 | DPR | 175 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Output 1

Description

The O1 command returns the state of the digital output 1 (0 = Low,1 = High). If no function is assigned to digital output 1 (O1MODE=0), then the High/Low state can be given out at output 1 by using the command “O1 1” or “O1 0”.
Status | Function | Description
O1MODE=0 | Off (S700: signal X3-6 is configured as default to input) | S300: The state of the digital output 1 can be set/cleared by RS232/Fieldbus or Slot board with O1 S700: The Pin X3-6 could configure both to input or output. The default is input for this signal. By using a digital output e.g. for a macro program, the function OxMODE=23 "DPR output" must configurate
O1MODE=1 | v_act<O1TRIG | As long as the absolute value for the motor velocity is lower than a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O1TRIG. The ouput is high, if V < O1TRIG and becomes low, if V > O1TRIG + 0.01 * MSPEED.
O1MODE=2 | v_act>O1TRIG | As long as the absolute value for the motor velocity is higher than a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O1TRIG. The ouput is high, if V > O1TRIG and becomes low, if V < O1TRIG + 0.01 * MSPEED.
O1MODE=3 | Mains-RTO | This signals the operational readiness of the drive power output stage. After switching on the mains supply, a HIGH-signal is output until the DC-link circuit is fully charged up. A LOW-signal is output when the charging of the DC-link circuit is finished. If the DC-link voltage falls below VBUSMIN value, then a HIGH-signal will be output. The “Undervoltage” monitoring is inactive.
O1MODE=4 | Regen off | Signals if the preset regen power (screen page “Basic Setup”) is exceeded.
O1MODE=5 | Sw_limit | This produces a HIGH-signal if a software limit-switch is reached (a preset function of the corresponding position register, set to “SW limit-switch 1” or “SW limit-switch 2” – the function is defined in the screen page “Position”). A motion task in the opposite direction resets the output.
O1MODE=6 | Pos.>x | If the position (angular position of the motor shaft) exceeds a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected, you can enter the signaling posi-tion in increment (a number or fraction of motor turns N) as O1TRIG. Make the calculation according to the following equation: x = 1048576 *N *Inkr. Maximum possible entry value:x =2 31 = 2147483648, this corresponds to N = 2048
O1MODE=7 | InPos | When the target position for a motion task has been reached (the InPosition window PEINPOS), this is signaled by the output of a HIGH-signal. A cable break will not be detected. The width of the InPosition window for all the valid motion tasks is entered in the “Position data” screen page. If a sequence of motion tasks is performed one after another, then the signal for reaching the final position of the motion-task sequence will be output (target position of the last motion task). Signaling that the target position of each motion task has been reached, in a sequence of motion tasks, can be achieved with the function “16, Next_InPos”.
O1MODE=8 | I_act<O1TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is lower than a defined value in mA (O1TRIG). After the function has been selected, you can enter the current value as O1TRIG in mA.
O1MODE=9 | I_act>O1TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is higher than a defined value in mA (O1TRIG). After the function has been selected, you can enter the current value as O1TRIG in mA.
O1MODE=10 | Ferror | If the position goes outside the preset contouring-error window, this is indicated by a LOW-signal. The width of the contouring-error window (PEMAX) is entered in the screen page “Position” for all the valid motion tasks.
O1MODE=11 | I2T | The reaching of the set I2t signaling threshold (I2TLIM, warning n01) or the failure of a mains phase (warning n05) is signaled with a high signal.
O1MODE=12 .. 15 | reserved | -
O1MODE=16 | Next-InPos | The start of each motion task in an automatically executed sequence of motion tasks is signalled by an inversion of the output signal. The output produces a Low signal at the start of the first motion task of the motion task sequence. The type of message can be set by IN2PM
O1MODE=17 | Error/Warn | The output produces a HIGH-signal if an error or a warning message is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE. n32 has no effect to the output.
O1MODE=18 | Error | The output produces a HIGH-signal if an error is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE
O1MODE=19 | DC_Link>O1TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is higher than a defined value in volts (O1TRIG). After the function has been selected, you can enter the voltage value as O1TRIG in Volt..
O1MODE=20 | DC_Link < O1TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is lower than a defined value in volts (O1TRIG). After the function has been selected, you can enter the voltage value in O1TRIG in Volt.
O1MODE=21 | ENABLE | A HIGH-signal is output if the servo amplifier is enabled. To obtain the enable, the external Hardware Enable signal must be present, the Enable status must be set in the setup software (or via the fieldbus interface) and no errors must be present that would cause an automatic internal disabling of the servo amplifier. If function OxMODE = is selected, the enable signal is high, if the line voltage is applied and the charging of the link capacitors is finished. The drive is disabled, if the DC-link voltage wents under the threshold VBUSMIN.
O1MODE=22 | Zero_pulse | The zero mark/pulse (HIGH-signal) is indicated by the encoder-emulation. This function is only use-ful at very low velocities. Vmax = 15000 / ENCOUT e.g. ENCOUT=256 Pulses/Rev Vmax = 58 rpm O1TRIG can be used to stretch the zero pulse length in positive direction. Important: The used LSB have to be set to 1, allowed O1TRIG values are only 2^n-1 (n=1....32) example O1TRIG=1,3,7,15,31...). The calculation is done by formula O1TRIG / 2^32 * 360°. Example 1: O1TRIG=1073741823 = 0x3FFFFFFF. 1073741823 * 360°/ 2^32 = 90° -> A HIGH signal is monitored on 0 - 90° Example 2: O1TRIG = 134217727 = 0x7FFFFFF 134217727 * 360° / 2^32 = 11,25° -> A HIGH signal is monitored on 0 - 11,25°
O1MODE=23 | Slot-DPR (S700: signal X3-6 to output) | S300: This configuration enables the possibility to output a state from the Slot board (mem DPR Slot Board Offset 0x3E4). If no Slot board is available, this configuration is equal to OxMODE=0. S700: The Pin X3-6 could configure both to input or output. The default is input for this signal. By using a digital output e.g. for a macro program, the function OxMODE=23 "DPR output" must configurate
O1MODE=24 | Ref_OK | The output signals High, if a reference point is available. Reference traverse (homing) has been carried out, or a reference point has been set. (see NREF)
O1MODE=25 .. 29 | - | reserved
O1MODE=30 | Postion register(s) state | For OxMODE = 30 the output OUTPUTx is set to 1 if a cam is "active". The output is set to 0 if no cam is signaled. To use this function, a cam (or several) must be defined first. This is done using the position registers P1..P16. The position registers should Can be used in pairs. Cam 1: P1 and P2 Cam 2: P5 and P6 Cam 3: P11 and P12 With the help of the OxTRIG variable, the cams to be monitored are defined. The mask for the above example would look like this: OxTRIG = 3123 (hex representation 0x0C33, the associated bit is set for each position register) As soon as one of the three cams is exceeded, the output OUTPUTx is set to 1. Example 2: O1MODE = 30 O1TRIG = 3 (Hex 0x0003) O2MODE = 30 O2TRIG = 3120 (Hex 0x0C30) Output 1 is set when cam 1 is active (P1 and P2). Output 2 is set when cam 2 (P5, P6) or cam 3 (P11, P12) is active.
O1MODE=31 | Analog In 1< O1TRIG | The output is high, if the Analog In voltage at Analog In 1 is lower than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=32 | Analog In 1> O1TRIG | The output is high, if the Analog In voltage at Analog In 1 is higher than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=33 | Analog In 2 < O1TRIG | The output is high, if the Analog In voltage at Analog In 2 is lower than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=34 | Analog In 2 > O1TRIG | The output is high, if the Analog In voltage at Analog In 2 is higher than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=35 | Internal Enable | The state of the internal ENABLE signal is mirrored on the digital output. If the setiings are: MBRAKE=0, STOPMODE=0 and ACTFAULT=0, the function is similar to O1MODE=21. If one of the three variables is "1", the output changes to low, when the drives starts to dec to "0". If O1MODE=21, the output is low, if the drive has stopped and has disabled the output stage.
O1MODE=36 | Logical OR: DRVSTAT - O1TRIG | This function makes a OR operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=37 | Logical AND: DRVSTAT -O1TRIG | This function makes a AND operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=38 | Logical OR: TRJSTAT - O1TRIG | This function makes a OR operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=39 | Logical AND: TRJSTAT - O1TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=40 | Logical OR: POSRSTAT - O1TRIG | This function makes a OR operation between the Bit-variable POSRSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=41 | Logical AND: POSRSTAT - O1TRIG | This function makes a AND operation between the Bit-variable POSRSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=42 | Internal temperature warning | This function enables a temperature warning. If one of the three internal measured temperatures reaches the trip level, the digital output ist set to high. After the selected delay time given in O1TRIG the drive generates a error message and disables the output stage. The delay time has the range 0...30000 msec and effects following temperatures: Motor temperature TEMPM, threshold MAXTEMPM Heatsink temperature TEMPH, Threshold MAXTEMPH Ambient temperature TEMPE, threshold MAXTEMPE
O1MODE=43 | The sign of the actual velocity | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0
O1MODE=44 | Target Speed deviation: abs(Target Speed - Actual Speed) < x | The OUTPUT1 is set, if the absolute of the difference between the internal velocity command (bevore the rampgenerator) and the actual velocity is smaller than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT).
O1MODE=45 | Target Speed deviation: abs(Target Speed - Actual Speed) > x | The output 1 is set, if the absolute of the difference between the internal velocity command bevore the rampgenerator) and the actual velocity is bigger than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT).
O1MODE=46 | Current in Window (low active) | The digital output 1 is set, if the absolute of the difference between current command and actual value is smaller than the window, defined by O1TRIG. The window is given in mA.
O1MODE=47 | Current not in Window (low active) | The digital output 1 is set, if the absolute of the difference between current command and actual value is greater than the window, defined by O1TRIG. The window is given in mA.
O1MODE=48 | Logical NOR: DRVSTAT - O1TRIG | This function makes a inverted OR operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=49 | Logical NAND: DRVSTAT -O1TRIG | This function makes a inverted AND operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=50 | Logical NOR: TRJSTAT - O1TRIG | This function makes a inverted OR operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=51 | Logical NAND: TRJSTAT - O1TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=52 | Logical AND: POSRSTAT - O1TRIG | same as O1MODE = 41 but the output is for PTBASE * 250 us on high level
O1MODE=53 | Master/Slave synchron | Master/Slave synchron
O1MODE=54 | prepared for moving | version > =1.21 The output is high if all following conditions are true software-enable set no error DC link loaded (VBUS > VBUSMIN) no contouring error (Warnung n03)
O1MODE=55 | Actual master-slave status | Version >=2.13 Output=1 The slave is in master/slave modus. This can be: 1. synchroize up to the master speed 2. following the master-position 3. Declutch the master slave mode Ausgang=0 - None of the master slave modes is active. The master pulses are ignored.1 see also function INxMODE=42,43
O1MODE=56 | Actual master-slave status | Output 1 will be set, if the following conditions are complied with: OPMODE=4 AND within 16 ms no new master command value AND the absolute value of the following error PE smaller than value PEINPOS
O1MODE=57 | - | reserved
O1MODE=58 | activation of the extern brake | output O1 = 1 – breake open output O1 = 0 – breake closed The output O1 signals the state of the internal brake control again and can be used as a status output or for the activation of a second brake. This function is only available if a brake (MBRAKE > 0) has been configured.
O1MODE=59 | activation of the extern brake (inverted) | output O1 = 1 – breake closed output O1 = 0 – breake open The output O1 signals the state of the internal brake control again and can be used as a status output or for the activation of a second brake. This function is only available if a brake (MBRAKE > 0) has been configured.
O1MODE=60 | Error present (Low-active) | Error present (Low-active)
O1MODE=61 | MT Target Velocity reached (High-active) | MT Target Velocity reached (High-active)
O1MODE=62 | MT Target Velocity reached (Low-active) | MT Target Velocity reached (Low-active)
O1MODE=69 | Master/ Slave synchronous; Slave Speed > 0 | Master/ Slave synchronous; Slave Speed > 0
O1MODE=70 | STO-Status | STO-Status
O1MODE=71 | Actual Speed within Window | The output 1 is set, if the absolute of the difference between the internal velocity command (after the rampgenerator) and the actual velocity is smaller than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT).
O1MODE=72 | Actual Spped not within Window | The output 1 is set, if the absolute of the difference between the internal velocity command (after the rampgenerator) and the actual velocity is bigger than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT).
O1MODE=73 | logical OR between ERRCODE an O1TRIG | Using these functions, the result of an OR link between the bit variable ERRCODE and a bit mask of the auxiliary variable O1TRIG to the digital output 1 can be issued.
O1MODE=74 | logical NOR between ERRCODE an O1TRIG | Using these functions, the result of an inverted OR operation between the Bit-variable ERRCODE and a bit mask of the auxiliary variable O1TRIG can be issued to the digital output 1.


ASCII English O1TRIG

ASCII - Command | O1TRIG |
Syntax Transmit | O1TRIG [Data] |
Syntax Receive | O1TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B0 (hex)
DIM | - | PROFIBUS PNU | 1776 (dec) IND = 1 (dec)
Range | long int | DPR | 176 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for O1MODE

Description

The function of the auxiliary variable O1TRIG depends on the configuration of O1MODE.
see O1MODE


ASCII English O2

ASCII - Command | O2 |
Syntax Transmit | O2 [Data] |
Syntax Receive | O2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B1 (hex)
DIM | - | PROFIBUS PNU | 1777 (dec) IND = 1 (dec)
Range | - | DPR | 177 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | State of Digital Output 2

Description

see O1


ASCII English O2MODE

ASCII - Command | O2MODE |
Syntax Transmit | O2MODE [Data] |
Syntax Receive | O2MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B2 (hex)
DIM | - | PROFIBUS PNU | 1689 (dec) IND = 33 (dec)
Range | 0 .. 100 | DPR | 889 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Output 2

Description

The O2MODE command can be used to configure the function of the digital output O2. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
O2MODE=0 | Off (S700: signal X3-7 is configured as default to input) | S300: The state of the digital output 1 can be set/cleared by RS232/Fieldbus or Slot board with O2 S700: The Pin X3-7 could configure both to input or output. The default is input for this signal. By using a digital output e.g. for a macro program, the function OxMODE=23 "DPR output" must configurate
O2MODE=1 | v_act<O2TRIG | As long as the absolute value for the motor velocity is lower than a preset value (O2TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O2TRIG. The ouput is high, if V < O2TRIG and becomes low, if V > O2TRIG + 0.01 * MSPEED.
O2MODE=2 | v_act > O2TRIG | As long as the absolute value for the motor velocity is higher than a preset value (O2TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O2TRIG. The ouput is high, if V > O2TRIG and becomes low, if V < O2TRIG - 0.01 * MSPEED.
O2MODE=3 | Mains-RTO | This signals the operational readiness of the drive power output stage. After switching on the mains supply, a HIGH-signal is output until the DC-link circuit is fully charged up. A LOW-signal is output when the charging of the DC-link circuit is finished. If the DC-link voltage falls below VBUSMIN value, then a HIGH-signal will be output. The “Undervoltage” monitoring is inactive.
O2MODE=4 | Regen off | Signals if the preset regen power (screen page “Basic Setup”) is exceeded.
O2MODE=5 | Sw_limit | This produces a HIGH-signal if a software limit-switch is reached (a preset function of the corresponding position register, set to “SW limit-switch 1” or “SW limit-switch 2” – the function is defined in the screen page “Position”). A motion task in the opposite direction resets the output.
O2MODE=6 | Pos.>x | If the position (angular position of the motor shaft) exceeds a preset value (O2TRIG), a HIGH-signal will be output. After the function has been selected, you can enter the signaling posi-tion in increment (a number or fraction of motor turns N) as O2TRIG. Make the calculation according to the following equation: x = 1048576 *N *Inkr. Maximum possible entry value:x =2 31 = 2147483648, this corresponds to N = 2048
O2MODE=7 | InPos | When the target position for a motion task has been reached (the InPosition window PEINPOS), this is signaled by the output of a HIGH-signal. A cable break will not be detected. The width of the InPosition window for all the valid motion tasks is entered in the “Position data” screen page. If a sequence of motion tasks is performed one after another, then the signal for reaching the final position of the motion-task sequence will be output (target position of the last motion task). Signaling that the target position of each motion task has been reached, in a sequence of motion tasks, can be achieved with the function “16, Next_InPos”.
O2MODE=8 | I_act<O2TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is lower than a defined value in mA (O2TRIG). After the function has been selected, you can enter the current value as O2TRIG in mA.
O2MODE=9 | I_act>O2TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is higher than a defined value in mA (O2TRIG). After the function has been selected, you can enter the current value as O2TRIG in mA.
O2MODE=10 | Ferror | If the position goes outside the preset contouring-error window, this is indicated by a LOW-signal. The width of the contouring-error window (PEMAX) is entered in the screen page “Position” for all the valid motion tasks.
O2MODE=11 | I2T | The reaching of the set I2t signaling threshold (I2TLIM, warning n01) or the failure of a mains phase (warning n05) is signaled with a high signal.
O2MODE=12 .. 15 | - | reserved
O2MODE=16 | Next-InPos | The start of each motion task in an automatically executed sequence of motion tasks is signalled by an inversion of the output signal. The output produces a Low signal at the start of the first motion task of the motion task sequence. The type of message can be set by IN2PM
O2MODE=17 | Error/Warn | The output produces a HIGH-signal if an error or a warning message is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE. n32 has no effect to the output.
O2MODE=18 | Error | The output produces a HIGH-signal if an error is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE
O2MODE=19 | DC_Link>O2TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is higher than a defined value in volts (O2TRIG). After the function has been selected, you can enter the voltage value as O2TRIG in Volt..
O2MODE=20 | DC_Link < O2TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is lower than a defined value in volts (O2TRIG). After the function has been selected, you can enter the voltage value in O2TRIG in Volt.
O2MODE=21 | ENABLE | A HIGH-signal is output if the servo amplifier is enabled. To obtain the enable, the external Hardware Enable signal must be present, the Enable status must be set in the setup software (or via the fieldbus interface) and no errors must be present that would cause an automatic internal disabling of the servo amplifier. If function OxMODE = is selected, the enable signal is high, if the line voltage is applied and the charging of the link capacitors is finished. The drive is disabled, if the DC-link voltage wents under the threshold VBUSMIN.
O2MODE=22 | Zero_pulse | The zero mark/pulse (HIGH-signal) is indicated by the encoder-emulation. This function is only use-ful at very low velocities. Vmax = 15000 / ENCOUT e.g. ENCOUT=256 Pulses/Rev Vmax = 58 rpm O2TRIG can be used to stretch the zero pulse length in positive direction. Important: The used LSB have to be set to 1, allowed O2TRIG values are only 2^n-1 (n=1....32) example O2TRIG=1,3,7,15,31...). The calculation is done by formula O2TRIG / 2^32 * 360°. Example 1: O2TRIG=1073741823 = 0x3FFFFFFF. 1073741823 * 360°/ 2^32 = 90° -> A HIGH signal is monitored on 0 - 90° Example 2: O2TRIG = 134217727 = 0x7FFFFFF 134217727 * 360° / 2^32 = 11,25° -> A HIGH signal is monitored on 0 - 11,25°
O2MODE=23 | Slot-DPR | This configuration enables the possibility to output a state from the Slot board (mem DPR Slot Board Offset 0x3E4). If no Slot board is available, this configuration is equal to OxMODE=0. If a Device-Net option board is plugged in the drive, this setting enables access of Device-Net to digital output 1 By using a digital output with a macro program, the function OxMODE=23 "DPR output" must configurate
O2MODE=24 | Ref_OK | The output signals High, if a reference point is available. Reference traverse (homing) has been carried out, or a reference point has been set. (see NREF)
O2MODE=25 .. 29 | - | reserved
O2MODE=30 |  |
O2MODE=31 | Analog In 1< O2TRIG | The output is high, if the Analog In voltage at Analog In 1 is lower than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=32 | Analog In 1> O2TRIG | The output is high, if the Analog In voltage at Analog In 1 is higher than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=33 | Analog In 2 < O2TRIG | The output is high, if the Analog In voltage at Analog In 2 is lower than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=34 | Analog In 2 > O2TRIG | The output is high, if the Analog In voltage at Analog In 2 is higher than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=35 | Internal Enable | The state of the internal ENABLE signal is mirrored on the digital output. If the setiings are: MBRAKE=0, STOPMODE=0 and ACTFAULT=0, the function is similar to O1MODE=21. If one of the three variables is "1", the output changes to low, when the drives starts to dec to "0". If O1MODE=21, the output is low, if the drive has stopped and has disabled the output stage.
O2MODE=36 | Logical OR: DRVSTAT - O2TRIG | This function makes a OR operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=37 | Logical AND: DRVSTAT -O2TRIG | This function makes a AND operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=38 | Logical OR: TRJSTAT - O2TRIG | This function makes a OR operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=39 | Logical AND: TRJSTAT - O2TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=40 | Logical OR: POSRSTAT - O2TRIG | This function makes a OR operation between the Bit-variable POSRSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=41 | Logical AND: POSRSTAT - O2TRIG | This function makes a AND operation between the Bit-variable POSRSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=42 | Internal temperature warning | This function enables a temperature warning. If one of the three internal measured temperatures reaches the trip level, the digital output ist set to high. After the selected delay time given in O2TRIG the drive generates a error message and disables the output stage. The delay time has the range 0...30000 msec and effects following temperatures: Motor temperature TEMPM, threshold MAXTEMPM Heatsink temperature TEMPH, Threshold MAXTEMPH Ambient temperature TEMPE, threshold MAXTEMPE
O2MODE=43 | The sign of the actual velocity | OUTPUT2 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0
O2MODE=44 | Velocity In-Position (active high) | The output 2 is set, if the absolute of the difference between the internal velocity command and the actual velocity is smaller than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT).
O2MODE=45 | Velocity In-Position (aktive low) | The output 2 is set, if the absolute of the difference between the internal velocity command and the actual velocity is bigger than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT).
O2MODE=46 | Current in Window (low active) | The digital output 2 is set, if the absolute of the difference between current command and actual value is smaller than the window, defined by O2TRIG. The window is given in mA.
O2MODE=47 | Current not in Window (low active) | The digital output 2 is set, if the absolute of the difference between current command and actual value is greater than the window, defined by O2TRIG. The window is given in mA.
O2MODE=48 | Logical NOR: DRVSTAT - O2TRIG | This function makes a inverted OR operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=49 | Logical NAND: DRVSTAT -O2TRIG | This function makes a inverted AND operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=50 | Logical NOR: TRJSTAT - O2TRIG | This function makes a inverted OR operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=51 | Logical NAND: TRJSTAT - O2TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 1.
O2MODE=52 | Logical AND: POSRSTAT - O2TRIG | same as O2MODE = 41 but the output is for PTBASE * 250 us on high level
O2MODE=53 | Master/Slave synchron | Master/Slave synchron
O2MODE=54 | prepared for moving | version > =1.21 The output is high if all following conditions are true software-enable set no error DC link loaded (VBUS > VBUSMIN) no contouring error (Warnung n03)
O2MODE=55 | master slave status | Version >=2.13: The function OxMODE=55 monitors the actual master slave status at the slave axis. Output=1 The slave is in master/slave modus. This can be: 1. synchroize up to the master speed 2. following the master-position 3. Declutch the master slave mode Ausgang=0 - None of the master slave modes is active. The master pulses are ignored.1 see also function INxMODE=42,43
O2MODE=56 | Actual master-slave status | Output 2 will be set, if the following conditions are complied with: OPMODE=4 AND within 16 ms no new master command value AND the absolute value of the following error PE smaller than value PEINPOS
O2MODE=57 | - | reserved
O2MODE=58 | control an external brake | output O2 = 1 – breake open output O2 = 0 – breake closed The output O2 signals the state of the internal brake control again and can be used as a status output or for the activation of a second brake. This function is only available if a brake (MBRAKE > 0) has been configured.
O2MODE=59 | control an external brake (inverted) | output O2 = 1 – breake closed output O2 = 0 – breake open The output O2 signals the state of the internal brake control again and can be used as a status output or for the activation of a second brake. This function is only available if a brake (MBRAKE > 0) has been configured.
O2MODE=60 | Error present (Low-active) | Error present (Low-active)
O2MODE=61 | MT Target Velocity reached (High-active) | MT Target Velocity reached (High-active)
O2MODE=62 | MT Target Velocity reached (Low-active) | MT Target Velocity reached (Low-active)
O2MODE=69 | Master/ Slave synchronous; Slave Speed > 0 | Master/ Slave synchronous; Slave Speed > 0
O2MODE=70 | STO-Status | STO-Status
O2MODE=71 | Actual Speed within Window | The Output 2 is set, if the absolute of the difference between the internal velocity command (after the rampgenerator) and the actual velocity is smaller than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT).
O2MODE=72 | Actual Spped not within Window | The Output 2 is set, if the absolute of the difference between the internal velocity command (after the rampgenerator) and the actual velocity is bigger than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT).
O2MODE=73 | logical OR between ERRCODE an O2TRIG | Using these functions, the result of an OR link between the bit variable ERRCODE and a bit mask of the auxiliary variable O2TRIG to the digital output 2 can be issued.
O2MODE=74 | logical NOR between ERRCODE an O2TRIG | Using these functions, the result of an inverted OR operation between the Bit-variable ERRCODE and a bit mask of the auxiliary variable O2TRIG can be issued to the digital output 2.


ASCII English O2TRIG

ASCII - Command | O2TRIG |
Syntax Transmit | O2TRIG [Data] |
Syntax Receive | O2TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 1 (dec)
Range | long int | DPR | 179 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for O2MODE

Description

The function of the auxiliary variable O2TRIG depends on the configuration of O2MODE.
see O2MODE


ASCII English O3

ASCII - Command | O3 |
Syntax Transmit | O3 [Data] |
Syntax Receive | O3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3725 (hex)
DIM |  | PROFIBUS PNU | 1749 (dec) IND = 17 (dec)
Range |  | DPR | 549 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 3

Description

see O3_18


ASCII English O3_18

ASCII - Command | O3_18 |
Syntax Transmit | O3_18 [data] |
Syntax Receive | O3_18 | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | digital I/O | EEPROM | No
Short Description | State of Digital Output 3 to 18

Description

This is a group description of output 3 to 18:

example: The O3 command returns the state of the digital output 3 (0 = Low,1 = High).
If no function is assigned to digital output 3 (O3MODE=0), then the High/Low state can be given out at output 3 by using the command “O3 1” or “O3 0”.


ASCII English O3_18MODE

ASCII - Command | O3_18MODE |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 100 | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.1
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of Digital Outputs 3 to 18

Description

This is a group description of the function of digital output 3 to 18

example: The O3 command returns the state of the digital output O3 (0 = Low,1 = High).
If no function is assigned to digital output 3 (O3MODE=0), then the High/Low state can be given out at output 3 by using the command “O3 1” or “O3 0”.


ASCII English O3_18TRIG

ASCII - Command | O3_18TRIG |
Syntax Transmit | O3_18TRIG [Data] |
Syntax Receive | O3_18TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | long int | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for OxMODE

Description

This is a group description of the auxiliary variables OxTRIG with x=3 .. 18

example: The function of the auxiliary variable O3TRIG depends on the configuration of O3MODE.


ASCII English O3MODE

ASCII - Command | O3MODE |
Syntax Transmit | O3MODE [Data] |
Syntax Receive | O3MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3726 (hex)
DIM |  | PROFIBUS PNU | 1750 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 550 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 3

Description

see O3_18MODE


ASCII English O3TRIG

ASCII - Command | O3TRIG |
Syntax Transmit | O3TRIG [Data] |
Syntax Receive | O3TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3727 (hex)
DIM |  | PROFIBUS PNU | 1751 (dec) IND = 17 (dec)
Range |  | DPR | 551 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 3

Description

see O3_18TRIG


ASCII English O4

ASCII - Command | O4 |
Syntax Transmit | O4 [Data] |
Syntax Receive | O4 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3728 (hex)
DIM |  | PROFIBUS PNU | 1752 (dec) IND = 17 (dec)
Range |  | DPR | 552 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 4

Description

see O3_18


ASCII English O4MODE

ASCII - Command | O4MODE |
Syntax Transmit | O4MODE [Data] |
Syntax Receive | O4MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3729 (hex)
DIM |  | PROFIBUS PNU | 1753 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 553 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 4

Description

see O3_18MODE


ASCII English O4TRIG

ASCII - Command | O4TRIG |
Syntax Transmit | O4TRIG [Data] |
Syntax Receive | O4TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 372A (hex)
DIM |  | PROFIBUS PNU | 1754 (dec) IND = 17 (dec)
Range |  | DPR | 554 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 4

Description

see O3_18TRIG


ASCII English O5

ASCII - Command | O5 |
Syntax Transmit | O5 [Data] |
Syntax Receive | O5 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 372B (hex)
DIM |  | PROFIBUS PNU | 1755 (dec) IND = 17 (dec)
Range |  | DPR | 555 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 5

Description

see O3_18


ASCII English O5MODE

ASCII - Command | O5MODE |
Syntax Transmit | O5MODE [Data] |
Syntax Receive | O5MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 372C (hex)
DIM |  | PROFIBUS PNU | 1756 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 556 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 5

Description

see O3_18MODE


ASCII English O5TRIG

ASCII - Command | O5TRIG |
Syntax Transmit | O5TRIG [Data] |
Syntax Receive | O5TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 372D (hex)
DIM |  | PROFIBUS PNU | 1757 (dec) IND = 17 (dec)
Range |  | DPR | 557 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 5

Description

see O3_18TRIG


ASCII English O6

ASCII - Command | O6 |
Syntax Transmit | O6 [Data] |
Syntax Receive | O6 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 372E (hex)
DIM |  | PROFIBUS PNU | 1758 (dec) IND = 17 (dec)
Range |  | DPR | 558 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 6

Description

see O3_18


ASCII English O6MODE

ASCII - Command | O6MODE |
Syntax Transmit | O6MODE [Data] |
Syntax Receive | O6MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 372F (hex)
DIM |  | PROFIBUS PNU | 1759 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 559 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 6

Description

see O3_18MODE


ASCII English O6TRIG

ASCII - Command | O6TRIG |
Syntax Transmit | O6TRIG [Data] |
Syntax Receive | O6TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3730 (hex)
DIM |  | PROFIBUS PNU | 1760 (dec) IND = 17 (dec)
Range |  | DPR | 560 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 6

Description

see O3_18TRIG


ASCII English O7

ASCII - Command | O7 |
Syntax Transmit | O7 [Data] |
Syntax Receive | O7 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3731 (hex)
DIM |  | PROFIBUS PNU | 1761 (dec) IND = 17 (dec)
Range |  | DPR | 561 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 7

Description

see O3_18


ASCII English O7MODE

ASCII - Command | O7MODE |
Syntax Transmit | O7MODE [Data] |
Syntax Receive | O7MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3732 (hex)
DIM |  | PROFIBUS PNU | 1762 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 562 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 7

Description

see O3_18MODE


ASCII English O7TRIG

ASCII - Command | O7TRIG |
Syntax Transmit | O7TRIG [Data] |
Syntax Receive | O7TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3733 (hex)
DIM |  | PROFIBUS PNU | 1763 (dec) IND = 17 (dec)
Range |  | DPR | 563 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 7

Description

see O3_18TRIG


ASCII English O8

ASCII - Command | O8 |
Syntax Transmit | O8 [Data] |
Syntax Receive | O8 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3734 (hex)
DIM |  | PROFIBUS PNU | 1764 (dec) IND = 17 (dec)
Range |  | DPR | 564 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 8

Description

see O3_18


ASCII English O8MODE

ASCII - Command | O8MODE |
Syntax Transmit | O8MODE [Data] |
Syntax Receive | O8MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3735 (hex)
DIM |  | PROFIBUS PNU | 1765 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 565 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 8

Description

see O3_18MODE


ASCII English O8TRIG

ASCII - Command | O8TRIG |
Syntax Transmit | O8TRIG [Data] |
Syntax Receive | O8TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3736 (hex)
DIM |  | PROFIBUS PNU | 1766 (dec) IND = 17 (dec)
Range |  | DPR | 566 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 8

Description

see O3_18TRIG


ASCII English O9

ASCII - Command | O9 |
Syntax Transmit | O9 [Data] |
Syntax Receive | O9 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3737 (hex)
DIM |  | PROFIBUS PNU | 1767 (dec) IND = 17 (dec)
Range |  | DPR | 567 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 9

Description

see O3_18


ASCII English O9MODE

ASCII - Command | O9MODE |
Syntax Transmit | O9MODE [Data] |
Syntax Receive | O9MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3738 (hex)
DIM |  | PROFIBUS PNU | 1768 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 568 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 9

Description

see O3_18MODE


ASCII English O9TRIG

ASCII - Command | O9TRIG |
Syntax Transmit | O9TRIG [Data] |
Syntax Receive | O9TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3739 (hex)
DIM |  | PROFIBUS PNU | 1769 (dec) IND = 17 (dec)
Range |  | DPR | 569 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 9

Description

see O3_18TRIG


ASCII English O10

ASCII - Command | O10 |
Syntax Transmit | O10 [Data] |
Syntax Receive | O10 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 373A (hex)
DIM |  | PROFIBUS PNU | 1770 (dec) IND = 17 (dec)
Range |  | DPR | 570 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 10

Description

see O3_18


ASCII English O10MODE

ASCII - Command | O10MODE |
Syntax Transmit | O10MODE [Data] |
Syntax Receive | O10MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 373B (hex)
DIM |  | PROFIBUS PNU | 1771 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 571 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 10

Description

see O3_18MODE


ASCII English O10TRIG

ASCII - Command | O10TRIG |
Syntax Transmit | O10TRIG [Data] |
Syntax Receive | O10TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 373C (hex)
DIM |  | PROFIBUS PNU | 1772 (dec) IND = 17 (dec)
Range |  | DPR | 572 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 10

Description

see O3_18TRIG


ASCII English O11

ASCII - Command | O11 |
Syntax Transmit | O11 [Data] |
Syntax Receive | O11 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 373D (hex)
DIM |  | PROFIBUS PNU | 1773 (dec) IND = 17 (dec)
Range |  | DPR | 573 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 11

Description

see O3_18


ASCII English O11MODE

ASCII - Command | O11MODE |
Syntax Transmit | O11MODE [Data] |
Syntax Receive | O11MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 373E (hex)
DIM |  | PROFIBUS PNU | 1774 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 574 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 11

Description

see O3_18MODE


ASCII English O11TRIG

ASCII - Command | O11TRIG |
Syntax Transmit | O11TRIG [Data] |
Syntax Receive | O11TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 373F (hex)
DIM |  | PROFIBUS PNU | 1775 (dec) IND = 17 (dec)
Range |  | DPR | 575 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 11

Description

see O3_18TRIG


ASCII English O12

ASCII - Command | O12 |
Syntax Transmit | O12 [Data] |
Syntax Receive | O12 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3740 (hex)
DIM |  | PROFIBUS PNU | 1776 (dec) IND = 17 (dec)
Range |  | DPR | 576 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 12

Description

see O3_18


ASCII English O12MODE

ASCII - Command | O12MODE |
Syntax Transmit | O12MODE [Data] |
Syntax Receive | O12MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3741 (hex)
DIM |  | PROFIBUS PNU | 1777 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 577 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 12

Description

see O3_18MODE


ASCII English O12TRIG

ASCII - Command | O12TRIG |
Syntax Transmit | O12TRIG [Data] |
Syntax Receive | O12TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3742 (hex)
DIM |  | PROFIBUS PNU | 1778 (dec) IND = 17 (dec)
Range |  | DPR | 578 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 12

Description

see O3_18TRIG


ASCII English O13

ASCII - Command | O13 |
Syntax Transmit | O13 [Data] |
Syntax Receive | O13 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3743 (hex)
DIM |  | PROFIBUS PNU | 1779 (dec) IND = 17 (dec)
Range |  | DPR | 579 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 13

Description

see O3_18


ASCII English O13MODE

ASCII - Command | O13MODE |
Syntax Transmit | O13MODE [Data] |
Syntax Receive | O13MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3744 (hex)
DIM |  | PROFIBUS PNU | 1780 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 580 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 13

Description

see O3_18MODE


ASCII English O13TRIG

ASCII - Command | O13TRIG |
Syntax Transmit | O13TRIG [Data] |
Syntax Receive | O13TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3745 (hex)
DIM |  | PROFIBUS PNU | 1781 (dec) IND = 17 (dec)
Range |  | DPR | 581 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 13

Description

see O3_18TRIG


ASCII English O14

ASCII - Command | O14 |
Syntax Transmit | O14 [Data] |
Syntax Receive | O14 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3746 (hex)
DIM |  | PROFIBUS PNU | 1782 (dec) IND = 17 (dec)
Range |  | DPR | 582 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 14

Description

see O3_18


ASCII English O14MODE

ASCII - Command | O14MODE |
Syntax Transmit | O14MODE [Data] |
Syntax Receive | O14MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3747 (hex)
DIM |  | PROFIBUS PNU | 1783 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 583 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 14

Description

see O3_18MODE


ASCII English O14TRIG

ASCII - Command | O14TRIG |
Syntax Transmit | O14TRIG [Data] |
Syntax Receive | O14TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3748 (hex)
DIM |  | PROFIBUS PNU | 1784 (dec) IND = 17 (dec)
Range |  | DPR | 584 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 14

Description

see O3_18TRIG


ASCII English O15

ASCII - Command | O15 |
Syntax Transmit | O15 [Data] |
Syntax Receive | O15 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3749 (hex)
DIM |  | PROFIBUS PNU | 1785 (dec) IND = 17 (dec)
Range |  | DPR | 585 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 15

Description

see O3_18


ASCII English O15MODE

ASCII - Command | O15MODE |
Syntax Transmit | O15MODE [Data] |
Syntax Receive | O15MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 374A (hex)
DIM |  | PROFIBUS PNU | 1786 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 586 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 15

Description

see O3_18MODE


ASCII English O15TRIG

ASCII - Command | O15TRIG |
Syntax Transmit | O15TRIG [Data] |
Syntax Receive | O15TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 374B (hex)
DIM |  | PROFIBUS PNU | 1787 (dec) IND = 17 (dec)
Range |  | DPR | 587 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 15

Description

see O3_18TRIG


ASCII English O16

ASCII - Command | O16 |
Syntax Transmit | O16 [Data] |
Syntax Receive | O16 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 374C (hex)
DIM |  | PROFIBUS PNU | 1788 (dec) IND = 17 (dec)
Range |  | DPR | 588 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 16

Description

see O3_18


ASCII English O16MODE

ASCII - Command | O16MODE |
Syntax Transmit | O16MODE [Data] |
Syntax Receive | O16MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 374D (hex)
DIM |  | PROFIBUS PNU | 1789 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 589 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 16

Description

see O3_18MODE


ASCII English O16TRIG

ASCII - Command | O16TRIG |
Syntax Transmit | O16TRIG [Data] |
Syntax Receive | O16TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 374E (hex)
DIM |  | PROFIBUS PNU | 1790 (dec) IND = 17 (dec)
Range |  | DPR | 590 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 16

Description

see O3_18TRIG


ASCII English O17

ASCII - Command | O17 |
Syntax Transmit | O17 [Data] |
Syntax Receive | O17 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 374F (hex)
DIM |  | PROFIBUS PNU | 1791 (dec) IND = 17 (dec)
Range |  | DPR | 591 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 17

Description

see O3_18


ASCII English O17MODE

ASCII - Command | O17MODE |
Syntax Transmit | O17MODE [Data] |
Syntax Receive | O17MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3750 (hex)
DIM |  | PROFIBUS PNU | 1792 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 592 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 17

Description

see O3_18MODE


ASCII English O17TRIG

ASCII - Command | O17TRIG |
Syntax Transmit | O17TRIG [Data] |
Syntax Receive | O17TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3751 (hex)
DIM |  | PROFIBUS PNU | 1793 (dec) IND = 17 (dec)
Range |  | DPR | 593 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 17

Description

see O3_18TRIG


ASCII English O18

ASCII - Command | O18 |
Syntax Transmit | O18 [Data] |
Syntax Receive | O18 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3752 (hex)
DIM |  | PROFIBUS PNU | 1794 (dec) IND = 17 (dec)
Range |  | DPR | 594 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | No
Short Description | State of digital output 18

Description

see O3_18


ASCII English O18MODE

ASCII - Command | O18MODE |
Syntax Transmit | O18MODE [Data] |
Syntax Receive | O18MODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3753 (hex)
DIM |  | PROFIBUS PNU | 1795 (dec) IND = 17 (dec)
Range | 0 .. 100 | DPR | 595 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Function of digital output 18

Description

see O3_18MODE


ASCII English O18TRIG

ASCII - Command | O18TRIG |
Syntax Transmit | O18TRIG [Data] |
Syntax Receive | O18TRIG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3754 (hex)
DIM |  | PROFIBUS PNU | 1796 (dec) IND = 17 (dec)
Range |  | DPR | 596 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.2
Function Group | digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for digital output 18

Description

see O3_18TRIG


ASCII English O_ACC

ASCII - Command | O_ACC |
Syntax Transmit | O_ACC [Data] |
Syntax Receive | O_ACC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B7 (hex)
DIM | ms, mm/sec ^2 | PROFIBUS PNU | 1783 (dec) IND = 1 (dec)
Range | 0 ... 2147483647 | DPR | 183 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.6
Function Group | position loop | EEPROM | Yes
Short Description | Acceleration Time 1 for Motion Task 0

Description

The command O_ACC can be used to define the acceleration ramp for motion task 0 (direct motion block). The scaling of the acceleration time depends on the PGEARI, PGEARO and O_C parameters.

1. Bit 12 of the motion task control variable O_C is = 0.
The acceleration time is given in milliseconds for acceleration from 0 to the target speed O_V.
2. Bit 12 of the motion task control variable O_C is = 1.
The acceleration is given in mm/sec². The resulting run-up time is calculated at the start of the motion task.

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed, position and acceleration. In this case, O_ACC is interpreted as a run-up time in msec.


ASCII English O_C

ASCII - Command | O_C |
Syntax Transmit | O_C [Data] |
Syntax Receive | O_C <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B9 (hex)
DIM | - | PROFIBUS PNU | 1785 (dec) IND = 1 (dec)
Range | int | DPR | 185 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Control Variable for Motion Task 0

Description

The O_C command defines the type of motion task for the local motion task 0 (direct motion task). A bit-variable (32 bits) is transferred as the parameter. The individual bits of this variable are interpreted as follows: see also o_c_3
Bit | Significance | Meaning
0 | 0x0001 | Bit for the type of motion task (relative or absolute) (see table 2)
1 | 0x0002 | Bit for the type of the relative motion task (see table 2)
2 | 0x0004 | Bit for the type of the relative motion task (see table 2)
3 | 0x0008 | =0 no next motion task, at the end of the motion task, the drive stops. =1 Next motion task selected, at the end of the motion task, automatically the next motion task is started. The number of the next motion task is given by O_FN This function is only available with linear acceleration.
4 | 0x0010 | Bit for the type of next motion task (see table 3)
5 | 0x0020 | Bit for the type of next motion task (see table 3)
6 | 0x0040 | Bit for the type of next motion task (see table 3)
7 | 0x0080 | Bit for the type of next motion task (see table 3)
8 | 0x0100 | Bit for the type of next motion task (see table 3)
9 | 0x0200 | =0 The motion task is executed via the internal trajectory generator. =1 A stored lookup table profile is started. The table has to be stored in the flash of the drive. O_TAB gives the number of the selected table. The sum of O_ACC and O_DEC gives the moving time of the profile in ms, independent of ACCUNIT.
10 | 0x0400 | =0 The profile is executed in the given direction. =1 The profile is executed in the inverse direction.
11 | 0x0800 | reserved
12 | 0x1000 | reserved
13 | 0x2000 | =0 The target postition and target speed of the motion task are in [IncrementsPRBASE]and [InkrementePRBASE / 250us]. They are nopt internal calculated in other units. The unit IncrementsPRBASE means one turn is erqual 2^PRBASE increments. =1 The target position and target speed is given in SI units. There must be a calulation with PGEARI and PGEARO to get the internal counts (see also O_S, O_V, PGEARI, PGEARO). If VUNIT <> 0 the speed is given in VUNIT
14 | 0x4000 | =0 The speed that is given in the motion task is the target speed. =1 The target speed is given by the analog setpoint 1. When a motion task is started, the anlog input is read and becomes the target speed of the motion task (Scaling: 10V=VSCALE1). The absolute of Analog In 1 is used.
15 | 0x8000 | Bit 3 of the type of the relative motion task (see separate table)
16 | 0x10000 | If bit 16 is set a table motion task is started. Bit 9 has to be set to 0.
17 | 0x20000 | =1 Position setpoint in internal increments and in 32 bit format.one turn is equal 2^32 increments. The speed is monitored in increments 32/250µs.
 | Table 2 | Type of relative/absolute Motion Task
Bit 15/2/1/0 | Meaning |
xxx0 | Absolute Motion Task, the position value in the motion task is the new target position |
x001 | Relative Motion Task, the position value in the motion task is added to the old target position. The target position depends on the IN-POSITION message: IN-POSITION=1 target position = last target position + relative position of the motion task IN-POSITION = 0 target position = actual position + relative position of the motion task |
x011 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = last target position + relative position of the motion task |
x101 | Relative Motion Task, the position value in the motion task is added to the actual position. target position = actual position + relative position of the motion task |
0111 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = last latched position at the positive edge of the input + relative position of the motion task (see object LATCH1P32, LATCH1N32, LATCH1P16, LATCH1N16, LATCH2P32, ...) |
1111 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = latched position at the negative edge of the input + relative move of the motion task (see object LATCH32N |
 | Table 3 | Type of Next motion task
Bit 8/7/6/5/4 | Meaning |
00000 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. Then it starts the next motion task in the sequence. |
00001 | Switch over to next motion task without stop. The drive moves to the target position with target speed of the actual motion task. Then it starts the next motion task in the sequence. |
10001 | Switch over to next motion task without stop. The drive calculates the brake point, that the speed of the motor at target position becomes the speedof the next motion task in the sequence. |
00010 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started, if the digital input selected by INxMODE=15 is switched to low. |
00110 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started, if the digital input selected by INxMODE=15 is switched to high. |
01000 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT). |
01010 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT) or if the digital input selected by INxMODE=15 is set to low. |
01110 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT) or if the digital input selected by INxMODE=15 is set to high. |


ASCII English O_DEC

ASCII - Command | O_DEC |
Syntax Transmit | O_DEC [Data] |
Syntax Receive | O_DEC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35BA (hex)
DIM | ms, mm/sec ^2 | PROFIBUS PNU | 1786 (dec) IND = 1 (dec)
Range | 0 ... 2147483647 | DPR | 186 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.6
Function Group | position loop | EEPROM | Yes
Short Description | Braking Time 1 for Motion Task 0

Description

The command O_DEC can be used to define the deceleration (braking) ramp for motion task 0 (direct motion task). The scaling of the deceleration/braking time depends on the PGEARI, PGEARO and O_C parameters.

1. Bit 12 of the motion task control variable O_C is = 0.
The braking time is given in milliseconds for deceleration from target speed O_V down to 0.
2. Bit 12 of the motion task control variable O_C is = 1.
The deceleration is given in mm/sec². The resulting run-down time is calculated at the start of the motion task.

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed, position and acceleration. In this case, O_DEC is interpreted as a run-down time in msec.


ASCII English O_FN

ASCII - Command | O_FN |
Syntax Transmit | O_FN [Data] |
Syntax Receive | O_FN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35BC (hex)
DIM | - | PROFIBUS PNU | 1788 (dec) IND = 1 (dec)
Range | 0, 1, .. ,180,192 .. 255 | DPR | 188 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Next Task Number for Motion Task 0

Description

The command O_FN can be used to define the number of the following motion block. This number is only used if bit 3 (next block activated) of the motion block control word is set to 1.
The motion block number can have the following values:
0 - direct motion block
1 ... 180 motion block from the Flash EEPROM
192 ... 255 motion block from the RAM


ASCII English O_FT

ASCII - Command | O_FT |
Syntax Transmit | O_FT [Data] |
Syntax Receive | O_FT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35BD (hex)
DIM | ms | PROFIBUS PNU | 1789 (dec) IND = 1 (dec)
Range | 0 .. 32767 | DPR | 189 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | No
Short Description | Delay before Next Motion Task

Description

This parameter can be used to delay the start of the next motion task (if one is defined). This parameter is only evaluated if bit 3 (next task activated) and bit 7 (delay time activated) of the motion task control word are set.


ASCII English O_P

ASCII - Command | O_P |
Syntax Transmit | O_P [Data] |
Syntax Receive | O_P <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35BE (hex)
DIM | - | PROFIBUS PNU | 1790 (dec) IND = 1 (dec)
Range | long int | DPR | 190 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer64
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Target Position/Path for Motion Task 0

Description

The command O_P can be used to define the target position for motion block 0 (direct motion block). Depending on the type of motion task (absolute or relative) this parameter will be interpreted as an absolute target position or a relative path movement. The scaling of the position depends on the PGEARI, PGEARO, PRBASE and O_C parameters.

1. Bit 13 of the motion block control word = 0 (given in internal units)
The position /path is given in counts.
Scaling: PRBASE=20 -> 1048576 increments per turn
PRBASE=16 -> 65536 increments per turn

2. Bit 13 of the motion block control variable is = 1 (taking the resolution into account)
The position is converted according to the following formula:
Position [increments] = O_P * PGEARO / PGEARI

Note: If the resolution is set to 1 (PGEARI=PGEARO*2^PRBASE) then internal units (counts) will be used for the speed, position and acceleration.


ASCII English O_TAB

ASCII - Command | O_TAB |
Syntax Transmit | O_TAB [Data] |
Syntax Receive | O_TAB <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 35B8 (hex)
DIM |  | PROFIBUS PNU | 1784 (dec) IND = 1 (dec)
Range |  | DPR | 184 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM |
Short Description | select acceleration profile table

Description

see also >> GUI Onlinehelp >> Acceleration Profile Tables


ASCII English O_V

ASCII - Command | O_V |
Syntax Transmit | O_V [Data] |
Syntax Receive | O_V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35BF (hex)
DIM | - | PROFIBUS PNU | 1791 (dec) IND = 1 (dec)
Range | 0 ... 2147483647 | DPR | 191 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | No
Short Description | Target Speed for Motion Task 0

Description

The command O_V can be used to define the target speed for motion block 0 (direct motion block). The scaling of the speed depends on the PGEARI, PGEARO, PRBASE and O_C parameters.

1. Bit 13 of the motion block control word = 0 (given in internal units)
The speed is given in counts.
Scaling: PRBASE=20 -> 140/32 increments per rpm
PRBASE=16 -> 140/512 increments per rpm

2. Bit 13 of the motion block control variable is = 1 (taking the resolution into account)
The speed is given in the actual VUNIT - units.
On VUNIT =0 or 5 the speed is converted according to the following formula:
Speed [increments] = O_P * PGEARO / PGEARI / 4000

Note: If PGEARI = PGEARO * 2^PRBASE, then there will be no conversion from user-defined units into increments. In this case, the position and velocity must be given in increments.


ASCII English OCOPY

ASCII - Command | OCOPY |
Syntax Transmit | OCOPY [ - Data] |
Syntax Receive | OCOPY <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer8 Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0,1,..,180,192..255 | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled (only RAM) / Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Save/copy Motion Tasks

Description

The OCOPY command can be used to copy motion tasks from one storage location to another. The motion block number can have the following values:
0 - direct/local motion block
1 ... 200 motion blocks from the ROM. The ROM motion blocks are stored in a segment of the internal Flash EEPROM. They remain in the amplifier memory even after the 24V supply has been switched off. Write access to these motion blocks is only permitted if the output stage has been disabled.
201 ... 300 motion blocks from the RAM. The RAM motion blocks can also be written while the output stage is enabled. But the contents of these motion blocks will be lost if the 24V supply is switched off. When the controller is switched on, the RAM motion blocks will be initialized with the contents of ROM motion blocks 1 ... 64.

e.g.
OCOPY 0 1 save the local motion block (direct motion block /RAM) as ROM motion task 1
(The output stage must be inhibited while this command is carried out)
OCOPY 1 201 copy the first ROM motion block to the RAM (number 201)
OCOPY 1 - 16 201 copy ROM motion blocks 1 ... 16 to the RAM (201 ... 216)


ASCII English OLIST

ASCII - Command | OLIST |
Syntax Transmit | OLIST [Data] [Data] |
Syntax Receive | OLIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | List of Motion Task Data

Description

The command “OLIST x number” is used to output the contents of “number” motion blocks (= motion orders) one after another, starting with block “x”. The interpretation and sequence of the parameters that are shown corresponds to the parameters of the ORDER command.
If the “number” parameter is missing, then just the contents of motion block “x” will be shown.
If both the “x” and the “number” parameter are missing, then the contents of all the valid motion blocks will be shown (i.e. motion blocks with valid data and correct checksums).


ASCII English OPMODE

ASCII - Command | OPMODE |
Syntax Transmit | OPMODE [Data] |
Syntax Receive | OPMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B4 (hex)
DIM | - | PROFIBUS PNU | 1780 (dec) IND = 1 (dec)
Range | 0, 1, .. , 8 | DPR | 180 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | control commands | EEPROM | Yes
Short Description | Operating Mode

Description

The OPMODE command is used to set the operating mode (basic function) for the amplifier. This operating mode can be changed over at any time, through the fieldbus interface or the digital I/O (INxMODE=24). The following settings are possible:
Status | Short Description | Description
OPMODE=0 | Velocity control -digital command | Digital (rotational) velocity There are different possibilities to generate a velocity command: - RS232 Interface ("J" command) - Fieldbus Interface (PROFIBUS, CANopen, SERCOS, DPR Slot boards)
OPMODE=1 | Velocity control -analog command | Analog (rotational) velocity The velocity setpoint is generated by the Analog In s 1/2. The configuration is done with ANCNFG and INxMODE=8.
OPMODE=2 | Current control -digital command | Digital torque The current setpoint can be generated by: - RS232 Interface ("T" command) - Fieldbus Interface (PROFIBUS, CANopen, SERCOS, DPR Slot boards)
OPMODE=3 | Current control -analog command | Analog torque The current command is generated by the Analog In s 1/2. The configuration is done with ANCNFG and INxMODE=8.
OPMODE=4 | Electronic Gearing (Master/Slave) | Position: electr. gearing The target position is generated by an extrenal encoder. The type of the activated interface is selected by GEARMODE.
OPMODE=5 | External Trajectory | Position: ext. position nodes The target position is generated by fieldbus (PROFIBUS, CANopen or DRP Slot board). The cycle time for writing the new position can be selected with the command PTBASE in 250µs steps. The position controller brings the actual position to the new target postion in the selected time. When using ANCNFG=8, the target position is given by the Analog In 1. The analog voltage is read every 250µs and is used as target position for the position controller. The scaling of the anlog input voltage is done with SRND and ERND. Before this function is active, a homing move has to completed.
OPMODE=6 | SERCOS control | SERCOS control
OPMODE=7 | Reserved |
OPMODE=8 | Motion Tasks | Position: motion blocks This setting allows the starting of motion tasks and also the homing moves.


ASCII English OPTION

ASCII - Command | OPTION |
Syntax Transmit | OPTION |
Syntax Receive | OPTION <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 1 (dec)
Range | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.3
Function Group | drive configuration | EEPROM | No
Short Description | Option Slot ID

Description

The OPTION command returns the identification for the slot card that has been detected. The following IDs are possible at present:
H0000 no slot card detected
H01xx I/O-expansion card
H20xx RODSSI (only S700)
H21xx SAFETY (only S700)
H0Cxx PROFIBUS
H03xx SERCOS
H06xx client-specific
H8xxx client-specific
H88xx EtherCat

The least significant 8 bits (xx) indicate the hardware revision of the corresponding card.


ASCII English OPTION2

ASCII - Command | OPTION2 |
Syntax Transmit | OPTION2 |
Syntax Receive | OPTION2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 1 (dec)
Range | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | drive configuration | EEPROM | No
Short Description | Option Slot ID

Description

The OPTION2 command returns the identification for the slot card that has been detected. The following IDs are possible at present:
H0000 no slot card detected
H20xx RODSSI (only S700)
H21xx SAFETY (only S700)

The least significant 8 bits (xx) indicate the hardware revision of the corresponding card.


ASCII English ORDER

ASCII - Command | ORDER |
Syntax Transmit | ORDER [Data1...Data10] |
Syntax Receive | ORDER | Available in |
Type | Command | MMI | No
ASCII Format | Integer32 ... Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 200, 201 .. 300 | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled (only RAM) / Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | position loop | EEPROM | Yes
Short Description | Set Motion Task Parameters

Description

The ORDER command can be used to define any RAM/EEprom motion task (= order). The ORDER command can be used in one of three forms:

ORDER the contents of the direct motion task (nr = 0) are shown
ORDER nr the contents of motion task number “nr” are shown
ORDER nr o_p o_v o_c o_acc o_dec o_tab reserved o_fn o_ft = definition of motion task “nr”

The “nr” parameter specifies the number of the motion task that is to be defined. The motion task number can have the following values:

0 - direct/local motion task

1 ... 200 motion tasks from the EEprom.
The EEprom motion tasks are stored in a segment of the internal flash memory. They remain in the amplifier memory even after the 24V supply has been switched off. Write access to these motion tasks is only permitted if the output stage has been disabled.

201 ... 300 motion tasks from the RAM.
The RAM motion tasks can also be written while the output stage is enabled. But the contents of these motion tasks will be lost if the 24V supply is switched off. When the controller is switched on, the RAM motion tasks will be initialized with the contents of EEprom motion tasks 1 ... 100.

The individual elements o_p ... o_ft have the same interpretation as the corresponding ASCII commands.

O_P target position/path for the motion task
O_V target speed/velocity
O_C type of motion task (control word)
O_ACC acceleration ramp /starting acceleration
O_DEC braking ramp / deceleration
O_TAB number of the lookup table

O_FN number of following motion tasks
O_FT delay before starting next motion task


ASCII English OTUNE

ASCII - Command | OTUNE |
Syntax Transmit | OTUNE [Data] |
Syntax Receive | OTUNE <Data> | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 100 ... 800 Hz | DPR | No
Default | 250 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | optimizing function VLO parameter

Description

The command “OTUNE [data]” starts an optimizing function for the VLO (parameter for the Luenberger Velocity Observer) at the frequency “data” Hz.


ASCII English OVRIDE

ASCII - Command | OVRIDE |
Syntax Transmit | OVRIDE [Data] |
Syntax Receive | OVRIDE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35B6 (hex)
DIM | - | PROFIBUS PNU | 1782 (dec) IND = 1 (dec)
Range | 0 .. 7 | DPR | 182 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.9
Function Group | position loop | EEPROM | Yes
Short Description | Override Function for Motion Tasks

Description

The override function can be used to influence the speed/velocity for a motion block, reference movements and jog mode through the analog/digital interface. When this function is activated, the analog command is read every millisecond and used for scaling the velocity for the motion block.
Analog input=10V motion block velocity = the target velocity that is programmed in the motion block
Analog input=5V motion block velocity = 50% of the programmed target velocity

The override function does not work with sin^2 curves.

The following settings are possible:
OVRIDE=0 override function is switched off

OVRIDE=1 analog input 1 input is activated for the override function

OVRIDE=2 analog input 2 input is activated for the override function

OVRIDE=3 Digital interface is activated for the override function. The digital Interface can be: Sercos, CAN, PROFIBUS, DPR , RS 232 and all other field busses.
see DOVRIDE.

S300/S700: Expansion of function of OVRIDE from the Firmware 1.37

OVRIDE=4 Limiting of the motion task speed by the master speed

In case motion tasks are used in electronic gearing the motion task speed is limited in a way, so that the sign of the slave speed (master + motion task) is not inverted.

Example 1: Master-Speed (PSPEED1) = +1000
The motion task speed (PSPEED3) is limited to (-1000...PVMAX)

Example 2: Master-Speed (PSPEED1) = -2000
The motion task speed (PSPEED3) ) is limited to (-PVMAX...+2000).

OVRIDE=5 Limiting of the motion task speed by the positive master speed

In case of negative master speed command the motion task speed is set to 0 .

Example 1: Master-Speed (PSPEED1) = +1000
The motion task speed (PSPEED3) is limited to (-1000...PVMAX)

Example 2: Master-Speed (PSPEED1) = -2000
The motion task speed (PSPEED3) ) is limited to 0.

OVRIDE=6 Limiting of the motion task speed by the negative master speed

In case of positive master speed command the motion task speed is set to 0 .

Example 1: Master-Speed (PSPEED1) = +1000
The motion task speed (PSPEED3) ) is limited to 0.

Example 2: Master-Speed (PSPEED1) = -2000
The motion task speed (PSPEED3) is limited to (-PVMAX ... +2000).

Bei positiver Master-Geschwindigkeit wird die Fahrsatz-Geschwindigkeit auf 0 begrenzt.

Beispiel 1: Master-Geschwindigkeit (PSPEED1) = +1000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf 0 begrenzt.

Beispiel 2: Master-Geschwindigkeit (PSPEED1) = -2000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf den Bereich (-PVMAX...+2000) begrenzt.


ASCII English P

ASCII - Command | P |
Syntax Transmit | P [Data] |
Syntax Receive | P <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38D2 (hex)
DIM | Watt [W] | PROFIBUS PNU | 1778 (dec) IND = 33 (dec)
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | actual values | EEPROM | No
Short Description | calculated active power (electrical)

Description

Actual current and voltage command are used to calculate the actual active power that the motor supplied with


ASCII English P1

ASCII - Command | P1 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type |  | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3644 (hex)
DIM |  | PROFIBUS PNU | 1924 (dec) IND = 1 (dec)
Range |  | DPR | 324 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P1_P16

ASCII - Command | P1_P16 |
Syntax Transmit | P1 [Data] |
Syntax Receive | P1_P16 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | long int | DPR | (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register 1 ... 16

Description

The variables P1 ... P16 contain the position values for the position thresholds 1 ... 16.
The scaling of the position depends on the PGEARI, PGEARO, PRBASE parameters, and is calculated according to the following formula:

P[increments] = P[entered] * PGEARO / PGEARI

1048576 increments/turn at PRBASE=20
65536 increments/turn at PRBASE=16

see also description of WPOS, WPOSE, WPOSP, WPOSX, POSRSTAT

The object number is given for P1. The other object numbers up to P16 are the next ones.


ASCII English P2

ASCII - Command | P2 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3645 (hex)
DIM |  | PROFIBUS PNU | 1925 (dec) IND = 1 (dec)
Range |  | DPR | 325 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P3

ASCII - Command | P3 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3646 (hex)
DIM |  | PROFIBUS PNU | 1926 (dec) IND = 1 (dec)
Range |  | DPR | 326 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P4

ASCII - Command | P4 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3647 (hex)
DIM |  | PROFIBUS PNU | 1927 (dec) IND = 1 (dec)
Range |  | DPR | 327 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P5

ASCII - Command | P5 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3648 (hex)
DIM |  | PROFIBUS PNU | 1928 (dec) IND = 1 (dec)
Range |  | DPR | 328 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P6

ASCII - Command | P6 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3649 (hex)
DIM |  | PROFIBUS PNU | 1929 (dec) IND = 1 (dec)
Range |  | DPR | 329 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P7

ASCII - Command | P7 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364A (hex)
DIM |  | PROFIBUS PNU | 1930 (dec) IND = 1 (dec)
Range |  | DPR | 330 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P8

ASCII - Command | P8 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364B (hex)
DIM |  | PROFIBUS PNU | 1931 (dec) IND = 1 (dec)
Range |  | DPR | 331 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P9

ASCII - Command | P9 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364C (hex)
DIM |  | PROFIBUS PNU | 1932 (dec) IND = 1 (dec)
Range |  | DPR | 332 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P10

ASCII - Command | P10 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364D (hex)
DIM |  | PROFIBUS PNU | 1933 (dec) IND = 1 (dec)
Range |  | DPR | 333 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P11

ASCII - Command | P11 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364E (hex)
DIM |  | PROFIBUS PNU | 1934 (dec) IND = 1 (dec)
Range |  | DPR | 334 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P12

ASCII - Command | P12 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 364F (hex)
DIM |  | PROFIBUS PNU | 1935 (dec) IND = 1 (dec)
Range |  | DPR | 335 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P13

ASCII - Command | P13 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3650 (hex)
DIM |  | PROFIBUS PNU | 1936 (dec) IND = 1 (dec)
Range |  | DPR | 336 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P14

ASCII - Command | P14 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3651 (hex)
DIM |  | PROFIBUS PNU | 1937 (dec) IND = 1 (dec)
Range |  | DPR | 337 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P15

ASCII - Command | P15 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3652 (hex)
DIM |  | PROFIBUS PNU | 1938 (dec) IND = 1 (dec)
Range |  | DPR | 338 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


ASCII English P16

ASCII - Command | P16 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3653 (hex)
DIM |  | PROFIBUS PNU | 1939 (dec) IND = 1 (dec)
Range |  | DPR | 339 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Fast Position Register

Description

see P1_P16


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Switch Parameter Configuration

basis

With essential control parameters, you can switch quickly between two values; for example, if there are two significantly different loads on the same drive.

All switchable parameters are displayed on this screen. Double-clicking on a parameter value in the table opens a small editing window which allows the value to be changed. Complete the entry by pressing the Return key. You can also exit the input boxes by pressing the ESC key.

You can switch between the two parameter sets either using a digital input (function 57, example for digital input 1: IN1MODE) or automatically using an internal function.

Using the ASCII parameter PARCNFG, you can define the internal function during whose execution the second (alternative) parameter set is active. In this case you can select Wake and Shake, a motion task or an operating mode.

Button | ASCII parameter
"Reset Second Parameter Set" | Resets the values in the alternative parameter set to the default values.
"Reset User Inputs" | Resets all inputs in both parameter sets to their original values.
"Save All Parameters In Drive" | Transfers all parameter values on display and both parameter sets to the servo amplifier.


ASCII English PARCNFG

ASCII - Command | PARCNFG |
Syntax Transmit | PARCNFG [Data] |
Syntax Receive | PARCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 375D (hex)
DIM |  | PROFIBUS PNU | 1805 (dec) IND = 17 (dec)
Range |  | DPR | 605 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.11 |
Configuration | Yes | Last Change of this Object | 1.8
Function Group | drive configuration | EEPROM | Yes
Short Description | Configuration of parameter sets switching functions

Description

The command PARCNFG is used to select the function for the second parameter group. This group contains the parameters GP,GPFFT,GPFFV,GV,GVFR,GVTN,KC,KTN,MICONT,MIPEAK,MJ,MKT,ML
MLGC,MLGD,MLGP,MLGQ,MPOLES,MRS,MTIME with the ending _X.

Selection of the active parameters
The selection can be activated by a digital input or via an internal function.

By dig. Input
The function INxMODE=57 is used for this process. Only one digital input setting 57 is allowed otherwise a warning n24 – parameter error is monitored.
Also the command PARCNFG has to be 0 or warning n24 is activated . The digital input level selects the parameter group
- Low: main parameter group
- High: second parameter group

Automatic mode

PARCNFG = 0x0000 always standard parameters
PARCNFG = 0x0001 second parameter group for the Wake&Shake-process.
PARCNFG = 0x0002 second parameter group active during motion tasks, homing or jog mode.
PARCNFG = 0x0004 second parameter group is used for OPMODE =4..8. OPMODE 0...3 are using parameter group 1.

Siehe auch PARDUMP, PARRST


ASCII English PARDUMP

ASCII - Command | PARDUMP |
Syntax Transmit | PARDUMP |
Syntax Receive | PARDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | String
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 1.8
Function Group | drive configuration | EEPROM | No
Short Description | List of switchable parameter sets

Description

The ASCII parameter PARDUMP lists all drive parameters that are included in the switchable parameter set.

ACC,DEC,GP,GPFFT,GPFFV,GV,GVFR,GVTN,KC,KTN,MICONT,MIPEAK,MJ,MKT,ML
MLGC,MLGD,MLGP,MLGQ,MPOLES,MRS,MTIME,VLO

The output looks like this:

GP 0.1 (GP_X 0.2)
GV 1.5 (GV_X 3)
Data Set 1 activ

The first parameter in every line ist the ascii parameter from the main parameter set.
The parameter in brackets is the ascii parameter from the second (shadow) parameter set.
The last line indicates the currently active parameter set.


ASCII English PARRST

ASCII - Command | PARRST |
Syntax Transmit | PARRST [Data] |
Syntax Receive | PARRST <Data> | Available in |
Type |  | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 1.8
Function Group | drive configuration | EEPROM |
Short Description | second parameter set = main parameter set

Description

The ASCII parameter PARRST resets all parameters of the second (shadow) parameter set to the values of the main parameter set.

See also PARCNFG, PARDUMP


ASCII English PASS

ASCII - Command | PASS |
Syntax Transmit | PASS [Data] |
Syntax Receive | PASS <Data> | Available in |
Type | Variable w | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 36D5 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 17 (dec)
Range | -2147483647...2147483648 | DPR | No
Default | 0 |
Opmode |  | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM |
Short Description | Password Input

Description

This variable defines the value of the password. When the password function is activ (PASSX = y)
the change of parameter is only possible after the setting of a valid password value “PASS y”


ASCII English PASSCNFG

ASCII - Command | PASSCNFG |
Syntax Transmit | PASSCNFG [Data] |
Syntax Receive | PASSCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D8 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 17 (dec)
Range | 0 .. 2 | DPR | 472 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | Integer8
Drive State |  | Weighting |
Start Firmware | 3.00 |
Configuration | No | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM |
Short Description | Password Function

Description

The command PASSCNFG sets the passwort-function.

PASSCNFG = 0 all parameter writing procedures are locked

PASSCNFG = 1 only parameter SAVE is locked

PASSCNFG = 2 parameter access isn't possible (no reading and no writing). Only the command PASS is permitted

PASSCNFG = 3 commands RSTVAR and SAVE are not allowed and only after entering a password (PASS/PASSX) are executed.

Please have a look to: PASS, PASSX


ASCII English PASSPLC

ASCII - Command | PASSPLC |
Syntax Transmit | PASSPLC [Data] |
Syntax Receive | PASSPLC <Data> | Available in |
Type | Variable w | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3899 (hex)
DIM |  | PROFIBUS PNU | 1721 (dec) IND = 33 (dec)
Range | -2147483647...2147483647 | DPR | 921 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.63 |
Configuration | No | Last Change of this Object | 2.3
Function Group | drive configuration | EEPROM | No
Short Description | Password value for PLC commands

Description

This variable defines the value of the password. When the password function is activ (PASSXPLC = y)
the call of PLC commands is only possible after the setting of a valid password value “PASSPLC y”


ASCII English PASSX

ASCII - Command | PASSX |
Syntax Transmit | PASSX [Data] |
Syntax Receive | PASSX <Data> | Available in |
Type | Variable w | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36D4 (hex)
DIM |  | PROFIBUS PNU | 1668 (dec) IND = 17 (dec)
Range | -2147483647...2147483648 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | activate password function

Description

PASSX activates the password function
PASSX=0 password function switched off
PASSX=y password function switched on.
The change of all parametera is only possible after the setting of a valid password “PASS y”.


ASCII English PASSXPLC

ASCII - Command | PASSXPLC |
Syntax Transmit | PASSXPLC |
Syntax Receive | PASSXPLC 0 | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 389A (hex)
DIM |  | PROFIBUS PNU | 1722 (dec) IND = 33 (dec)
Range | -2147483647...2147483647 | DPR | 922 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 3.63 |
Configuration | No | Last Change of this Object | 2.4
Function Group | drive configuration | EEPROM | Yes
Short Description | Password configuration for PLC commands

Description

PASSXPLC activates the password function

PASSXPLC=0 password function switched off
PASSXPLC=y password function switched on.

The PLC commands are only possible after the setting of a valid password “PASSPLC y”.


ASCII English PBAL

ASCII - Command | PBAL |
Syntax Transmit | PBAL |
Syntax Receive | PBAL <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C0 (hex)
DIM | W | PROFIBUS PNU | 1792 (dec) IND = 1 (dec)
Range | 0 .. 1500 | DPR | 192 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Actual Regen Power

Description

The actual value of average regen power.


ASCII English PBALMAX

ASCII - Command | PBALMAX |
Syntax Transmit | PBALMAX [Data] |
Syntax Receive | PBALMAX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C1 (hex)
DIM | W | PROFIBUS PNU | 1793 (dec) IND = 1 (dec)
Range | see Manual | DPR | 193 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | Yes
Short Description | Maximum Regen Power

Description

This parameter can be used to limit the continuous power dissipated in the regen resistor.
If the actual value of the power in the regen resistor exceeds the preset maximum value, then the regen resistor is switched off. This may trigger the fault message “Overvoltage” as a result. If the maximum value is too high, the regen resistor may be overloaded.

Defaultwerte:

with PBALRES = 0
SR 303, SR 341 20 W
SR 306, SR 310, SR 343, SR 346 50 W

with PBALRES >= 1
SR 303, SR 341 300W
SR 306, SR 310, SR 343, SR 346 1000 W

Note: From the perspective of the drive is PBALMAX the maximum power that is released permanently to the regen resistor. From the viewpoint of the regen resistance is this the rated power.


ASCII English PBALRES

ASCII - Command | PBALRES |
Syntax Transmit | PBALRES [Data] |
Syntax Receive | PBALRES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35C2 (hex)
DIM | - | PROFIBUS PNU | 1794 (dec) IND = 1 (dec)
Range | 0 ... 200 | DPR | 194 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Select Regen Resistor

Description

This parameter can be used to select whether the internal (0) or an external (> 0) regen resistor should be used.The value > 0 sets the regen resistor in ohm.

Note: The allowed resistor value depends to the used drive type. Look into the installation manuel for the data, please.

It affects the PBALMAX parameter.


ASCII English PBAUD

ASCII - Command | PBAUD |
Syntax Transmit | PBAUD |
Syntax Receive | PBAUD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35C3 (hex)
DIM | kBaud | PROFIBUS PNU | 1795 (dec) IND = 1 (dec)
Range | 1.0 .. 12000.0 | DPR | 195 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Profibus Baud Rate

Description

The PBAUD command reads out the present PROFIBUS baud rate. The baud rate is provided by the master (control system). The Drive detects the baud rate automatically.
The following settings are possible (in kbaud/kbps):
12000
6000
3000
1500
500
187.5
93.75
45.45
19.2
9.6


ASCII English PE

ASCII - Command | PE |
Syntax Transmit | PE |
Syntax Receive | PE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C5 (hex)
DIM | µm | PROFIBUS PNU | 1797 (dec) IND = 1 (dec)
Range | long int | DPR | 197 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Actual Following Error

Description

The following error OPMODE = 8 or contouring error OPMODE = 5 or 6 is the momentary difference between the position command and the actual position and is displayed in the same units as the position control loop (PGEARI / PGEARO).

See description of PFB , PEMAX, PUNITS


ASCII English PEINPOS

ASCII - Command | PEINPOS |
Syntax Transmit | PEINPOS [Data] |
Syntax Receive | PEINPOS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C6 (hex)
DIM | PUNIT | PROFIBUS PNU | 1798 (dec) IND = 1 (dec)
Range | long int | DPR | 198 (dec)
Default | 4000 |
Opmode | >=4 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.8
Function Group | position loop | EEPROM | Yes
Short Description | In-Position Window

Description

If the distance between the actual position and the target position during the execution of an internal motion block is less than the window width that has been set, then the In-Position signal is generated (status message, digital output).
The In-Position window is entered in the same units as the position control loop (PGEARI / PGEARO).
See description of PFB
The absolute position for EnDat, SSI and HIPERFACE certain FBTYPE settings are read only during initialization (while booting the amplifier). To avoid incorrect readings, the position is read up to 5 times. The position is only accepted as valid if the difference between two adjacent readings is less than the value of the in-position window PEINPOS. If too large position error F04 is displayed.


ASCII English PEMAX

ASCII - Command | PEMAX |
Syntax Transmit | PEMAX [Data] |
Syntax Receive | PEMAX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C7 (hex)
DIM | µm | PROFIBUS PNU | 1799 (dec) IND = 1 (dec)
Range | long int | DPR | 199 (dec)
Default | 262144 |
Opmode | >=4 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Max. Following Error

Description

If the momentary following or contouring error (PE) goes beyond the maximum value set, the motion is stopped and the following error warning (n03) or contouring error fault (F03) is generated. The motion block can only be continued (CONTINUE) or restarted after the warning has been acknowledged (CLRFAULT, digital input INxMODE=14). PEMAX=0 switches off the following error monitoring.
If a following error occurs, negative values do not result in a stop of the axis. The status bit and warning are still there. Starting a motion task or a following error reset is quitting the following error bit.


ASCII English PFB

ASCII - Command | PFB |
Syntax Transmit | PFB |
Syntax Receive | PFB <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C8 (hex)
DIM | µm | PROFIBUS PNU | 1800 (dec) IND = 1 (dec)
Range | long int | DPR | 200 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Actual Position from Feedback Device

Description

The PFB command returns the actual value of the position (from the position control loop feedback). The unit for the position value depends on the PGEARI, PGEARO and PRBASE settings.

PFB = Position * PGEARI / PGEARO
whereby:
Position = position value in increments, 1048576/turn for PRBASE=20, 65536/turn for PRBASE=16
PGEARI, PGEARO - resolution of position control loop

Note: If the resolution is set to 1 (PGEARI=PGEARO) then the PFB command provides internal units (counts).

If the position information of an external encoder is evaluated (EXTPOS=1,2,3), then this information can be displayed by using the PFB0 command.


ASCII English PFB0

ASCII - Command | PFB0 |
Syntax Transmit | PFB0 [Data] |
Syntax Receive | PFB0 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C9 (hex)
DIM | Counts | PROFIBUS PNU | 1801 (dec) IND = 1 (dec)
Range | - | DPR | 201 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Position from External Encoder

Description

The PFB0 command returns the actual position, calculated from the position information provided by an external encoder. The position is only derived from an external encoder if the configuration variable EXTPOS is set to 1,2,3. The unit for the position value depends on the PGEARI, PGEARO and ENCIN settings.

PFB0 = Position * PGEARI / PGEARO
whereby:
Position = position value in increments
PGEARI, PGEARO - resolution of position control loop

Note: If the resolution is set to 1 (PGEARI=PGEARO) then the PFB0 command provides internal units (counts).


ASCII English PFBHI

ASCII - Command | PFBHI |
Syntax Transmit | PHBHI [Data] |
Syntax Receive | PFBHI <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3876 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 886 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.05 |
Configuration | No | Last Change of this Object | 2.12
Function Group | actual values | EEPROM | No
Short Description | returns the lower 32 bit of the 64 bit position

Description

The parameter PFBHI latches the actual 64 Bit-position (PFB) and returns the upper 32 bit. With the command PFBLO, the lower half (lower 32 bits) is read the 64 bit position.


ASCII English PFBLO

ASCII - Command | PFBLO |
Syntax Transmit | PFBLO [Data] |
Syntax Receive | PFBLO <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3875 (hex)
DIM | - | PROFIBUS PNU | 1685 (dec) IND = 33 (dec)
Range | 32 Bit | DPR | 885 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.05 |
Configuration | No | Last Change of this Object | 2.12
Function Group | actual values | EEPROM | No
Short Description | returns the lower 32 bit of the 64 bit position

Description

The parameter PFBLO latches the actual 64 Bit-position (PFB) and returns the lower 32 bit. With the command PFBHI, the upper half (upper 32 bits) is read the 64 bit position.


ASCII English PGEARI

ASCII - Command | PGEARI |
Syntax Transmit | PGEARI [Data] |
Syntax Receive | PGEARI <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CA (hex)
DIM | µm | PROFIBUS PNU | 1802 (dec) IND = 1 (dec)
Range | 1 ... 2147483647 | DPR | 202 (dec)
Default | 10000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | Yes
Short Description | Position Resolution (Numerator)

Description

Description:

The pararameter PGEARI is used in conjunction with the PGEARO parameter to convert the internal position and speed from increments into user-defined units. The PGEARI parameter contains the number of user-defined units that are counted at PGEARO turns. The user decides which unit is used by the formula PGEARI/PGEARO.

Note: If PGEARI = PGEARO * 2^PRBASE, then there will be no conversion from user-defined units into increments. In this case, the position and velocity must be given in increments.

1. Example:

If a band-conveyer moves 3cm by one turn of the rotor shaft and the operator wants to use the unit mm, the value of PGEARI/PGEARO must be 30000. It is advisable to set PGEARI=30000 and PGEARO=1. The position can now be adjusted in mm.

If a gearing is connected previous to the band-conveyer with a ratio of 3:1, the user just needs to set PGEARO=3. Also odd-numbered values of the ratio are possible (e.g. 2.5:1). For that purpose PGEARI must be multiplicated with 2 and PGEARO with 5.

2. Example

A motion task should be driven by a certain speed. Therefore Bit 13 of the motion task controllword o_c has to be set on 1. For that purpose the parameter o_v describes the target speed in the user-defined unit/sec. To get the target speed in SI-units use the following formula:

o_v=10000; PGEARI=1000, PGEARO=1

n [rev*sec^-1] = o_v / ( PGEARI / PGEARO )

Examples to explain the

Resolution = PGEARI / PGEARO :

Linearmotor >>> 1

Turntable >>> 2

Turntable extern driven >>> 3

Spindel >>> 4

Beltdrive >>> 5


ASCII English PGEARO

ASCII - Command | PGEARO |
Syntax Transmit | PGEARO [Data] |
Syntax Receive | PGEARO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CB (hex)
DIM | µm | PROFIBUS PNU | 1803 (dec) IND = 1 (dec)
Range | 1 .. 2048 | DPR | 203 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | Yes
Short Description | Position Resolution (Denominator)

Description

Description:

The parameter PGEARO is used in conjunction with the PGEARI parameter to convert the control loop position and speed from user-defined units into internal increments.
The PGEARO parameter contains in combination with PRBASE the number of increments that are moved if the path to be moved has a length of PGEARI.
The conversion is made according to the following formula:

Position[increments] = Position[user-defined unit] * PGEARO *2^PRBASE / PGEARI
Velocity[increments/250us] = Velocity[user-defined unit] * PGEARO *2^PRBASE / (PGEARI * 4000)

Note: If PGEARI = PGEARO * 2^PRBASE, then there will be no conversion from user-defined units into increments. In this case, the position and velocity must be given in increments.

The maximum of PGEARO pepends on PRBASE and is calculated by 2^(31-PRBASE)

Position: 1 turn = 2^PRBASE increments

Velocity: speed [rpm] * 2^PRBASE / (4000 *60)

For an example: see PGEARI and PRBASE


ASCII English PIOBUF

ASCII - Command | PIOBUF |
Syntax Transmit | PIOBUF [Data] |
Syntax Receive | PIOBUF <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 35CC (hex)
DIM | - | PROFIBUS PNU | 1804 (dec) IND = 1 (dec)
Range | - | DPR | 204 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Profibus data

Description

This command reads out the present PROFIBUS input and output buffers. The output buffer handles the data flow from the control system to the Drive, and the input buffer handles the data flow from the Drive to the control system. Each buffer is 20 bytes long (telegram length) and is put together from the PKW section (8 bytes. i.e. 4 words) and the PZD section (12 bytes, 6 words). The individual bytes are in hexadecimal format.
PIOBUF provides 20 bytes of output buffer in the first line, and 20 bytes of input buffer in the second line.

If the communication over the PROFIBUS is interrupted or faulty, then a fault message “ERR [PIOBUF] NO DATA EXCHANGE SPC3 - INTERRUPT” is generated.


ASCII English PLLCOFFS

ASCII - Command | PLLCOFFS |
Syntax Transmit | PLLCOFFS [Data] |
Syntax Receive | PLLCOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 20 | DPR | No
Default | 0 |
Opmode | all | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 5.45 |
Configuration | No | Last Change of this Object | 2.11
Function Group | fieldbus | EEPROM | Yes
Short Description | PLL counter outside of the synchronization window

Description

This variable specifies how often the fieldbus PLL routine may be out of synchronization window in a row before a synchronization error is generated. This number_OutOfSync = 1 + PLLCOFFS applies.

example: PLLCCOFFS =4: for five times the PLL is allowed to lie outside of the synchronization window before an error (F28,F29) is generated.

Have a look to ERRCODE *, PLLDOFFS, PLLWOFFS


ASCII English PLLDOFFS

ASCII - Command | PLLDOFFS |
Syntax Transmit | PLLDOFFS [Data] |
Syntax Receive | PLLDOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM | µs | PROFIBUS PNU | -
Range | 0 .. 1000 | DPR | No
Default | 0 |
Opmode | 5 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 5.45 |
Configuration | No | Last Change of this Object | 2.11
Function Group | Fieldbus | EEPROM | Yes
Short Description | move of synchronization routine

Description

With the PLLDOFFS command you move the time of synchronization routine in time by x [microseconds] further away from the sync event (for EtherCAT these are the cyclical setpoints). The time unit of this command is [microseconds]. This value is added to an already hard-coded in the software time interval, which assumes different values ??for different fieldbuses or for different cycle times.

have a look to: ERRCODE *, PLLCOFFS, PLLWOFFS


ASCII English PLLHUB

ASCII - Command | PLLHUB |
Syntax Transmit | PLLHUB [Data] |
Syntax Receive | PLLHUB <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3921 (hex)
DIM | - | PROFIBUS PNU | 1857 (dec) IND = 33 (dec)
Range | 0 ... 6 | DPR | 1057 (dec)
Default | 1 |
Opmode |  | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | Yes
Short Description | fieldbus synchronization ratio

Description

This parameter defines how fast the drive is synchronized to the fieldbus communication.
PLLHUB=1 slow and smooth synchronization
PLLHUB=6 fast but rude synchronization.

Applications should work with small values when possible (< 3). Higher values can cause poor drive performance and problems with fieldbus synchronisation.

From FW >= 6.02 the DPR for fieldbus access is available.

please have a look to ERRCODE * = F28/F29


ASCII English PLLWOFFS

ASCII - Command | PLLWOFFS |
Syntax Transmit | PLLWOFFS [Data] |
Syntax Receive | PLLWOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM | µs | PROFIBUS PNU | -
Range | 0 .. 150 | DPR | No
Default | 0 |
Opmode | 5 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 5.45 |
Configuration | No | Last Change of this Object | 2.11
Function Group | Fieldbus | EEPROM | Yes
Short Description | increase of the window for synchronization

Description

With the command PLLWOFFS you increase the window in which the PLL is considered routine synchronized. The time unit of this command is [microseconds]. This value is added to an in software has already been coded window size, which takes different values ??for different fieldbuses or for different cycle times.

have a look to: ERRCODE *, PLLCOFFS, PLLDOFFS


ASCII English PMECH

ASCII - Command | PMECH |
Syntax Transmit | P [Data] |
Syntax Receive | PMECH <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38D1 (hex)
DIM | Watt [W] | PROFIBUS PNU | 1777 (dec) IND = 33 (dec)
Range | - | DPR | 977 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.9
Function Group | actual values | EEPROM | No
Short Description | estimated mechanical power deliverd by the motor

Description

Actual velocity and actual current together with the torque constant MKT are used to estimate the actual mechanical power that the motor delivers.

Since FW 5.68 with DPR-Objekt-No 977


ASCII English PMODE

ASCII - Command | PMODE |
Syntax Transmit | PMODE [Data] |
Syntax Receive | PMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35CD (hex)
DIM | - | PROFIBUS PNU | 1805 (dec) IND = 1 (dec)
Range | 0 .. 8 | DPR | 205 (dec)
Default | (0) 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | drive configuration | EEPROM | Yes
Short Description | Line Phase Mode

Description

Theis parameter configurate the line phase mode

only for the S30x - not available on S34x!
PMODE=0 single phase operation (current limit)

for S300/S700
PMODE=1 three phase operation, current limited and warning n05 in case of network phase missing
PMODE=2 three phase operation, error message F19 in case of DC bus break down
PMODE=3 three phase operation, current limited and warning n05 in case of network phase missing
PMODE=4 direct DC feed
PMODE=5 such als PMODE=1, the warning or fault is generated by enabled drive
PMODE=6 such als PMODE=2, the warning or fault is generated by enabled drive
PMODE=7 such als PMODE=3, the warning or fault is generated by enabled drive
PMODE=8 reserved

If the current limiting is activated, it only applies to periods of acceleration. A braking operation can still be carried out at full current.


ASCII English PNOID

ASCII - Command | PNOID |
Syntax Transmit | PNOID [Data] |
Syntax Receive | PNOID <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CE (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 1 (dec)
Range | - | DPR | 206 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | PROFIBUS ID

Description

The PNOID command reads out the identification number of the Drive. This number is used for the unique identification of the Drive as a participant in the PROFIBUS network. The ID is allocated and managed by the PROFIBUS User Organization.
This instrument ID is also part of the GSD (base data for the instrument).

PNOID returns the identification number 045D (hexadecimal).


ASCII English POSCNFG

ASCII - Command | POSCNFG |
Syntax Transmit | POSCNFG [Data] |
Syntax Receive | POSCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35CF (hex)
DIM | - | PROFIBUS PNU | 1807 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 207 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | Yes
Short Description | Axes Type

Description

Use the axis type to select whether the axis is treated as a linear or rotary axis. This variable does not imply that the motor is a linear or rotary motor, but instead, affects the way the software limit switches are used by the Firmware. The software limit switches are treated in different ways, depending on the selection. The possible settings are:
POSCNFG=0 | Linear Axes | Axes with a limited range of movement. The zero position for position tracking is fixed by a homing operation. With this setting, a set reference point is a precondition to be able to implement motion blocks. After the homing movement (setting the reference point) has been completed, the position is continuously tracked for the control loop, and remains valid until the amplifier is switched off. In case a multiturn absolute feedback is used a reference move after drive switch on is not necessary. see also ROFFS
POSCNFG=1 | Modulo Axis | Axes with a limited range of movement. The minimum position is SRND and the maximum position is ERND-1. If the maimum position ERND-1 is reached, it automatically switches over to SRND. The absolute target positions have to be in the defined range. If a motion task is startet, which has a absolute position outside the range, a warning "n08" is displayed (wrong motion task). Relative moves are calculated in a way, that the target position always is in the defined range. A positioning in a axes like this, gives two possibilities of direction to the target position. DREF gives the possibility to restrict the direction if an absolute motion task type is selected. This axes type also needs a homing move. In case a multiturn absolute feedback is used a reference move after drive switch on is not necessary. see also ROFFS
POSCNFG=2 | Modulo axis with cyclic storing of the 64bit position | equal to POSCNFG=1 with activated storing of the 64 bit position (have a look to DRVCNFG2 Bit 22)


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Position Data

einheiten

Adjust the position control for the requirements of your application.

Screen text | ASCII parameter
Axis Type | POSCNFG
Modulo Direction of Motion | DREF
max. Following Error | PEMAX
In Position Window | PEINPOS
Modulo Start Pos. | SRND
t acc/dec min | PTMIN
v max (pos.) | PVMAXP
v max (neg.) | PVMAXN
Modulo End Pos. | ERND
Software Limit Switch No.1 (neg.) | SWCNFG
at Position No.1 | SWE1
Software Limit Switch No.2 (pos.) | SWCNFG
at Position No.2 | SWE2

The method of positioning the software limit-switch can be seen in the diagram below:

Legend

MA1 : Machine stop, left
HE1 : Hardware limit-switch, left
NI : Zero pulse initiator (reference)
SE1 : Software limit-switch 1
SE2 : Software limit-switch 2
HE2 : Hardware limit-switch right
MA2 : Machine stop right
+ : Positive count direction
- : Negative count direction


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Position Loop

einheiten

Position loop setting. You can select for example, whether the position control works with an external feedback system or with the motor-feedback system. The example above shows the screen for a selected secondary position feedback.

Screen text | ASCII parameter
FF Factor v | GPFFV
Proportional Gain (Kp_p) | GP
Integral Time (Tn_p) | GPTN
Secondary Position Feedback | EXTPOS
Count Direction | DIR
Lines per Rev. (only with sec. position feedback >0) | ENCLINES
Gear Ratio (nominator) (only with sec. position feedback >0) | EGEARO
Gear Ratio (denominator) (only with sec. position feedback >0) | EGEARI


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Position Loop Extension

einheiten

Set speed-dependent position control in the upper diagram. The amplification factor changes according to the speed.

The lower diagram allows you to connect an integral component for position control, dependent upon tracking errors and speed.

Screen text | ASCII parameter
GP2 | GP2, proportional gain 2, position loop
GP | GP, proportional gain, position loop
GPS1 | GPS1, lower velocity limit
GPS2 | GPS2, upper velocity limit
GPeff | rms value of proportional gain GP
GPTN | GPTN, integral gain, position loop
MAXISETP | MAXISETP, maximum current value
PE | PE, following error
V_CMD | V_CMD, with OPMODEs 0, 1, 4, 5, 6, 7, 8 = Velocity set point, with OPMODEs 2, 3 = Actual Velocity
V_ACT | V_ACT, Actual Velocity


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Position Registers

einheiten

Exceeding or falling of up to 16 position values in the motion way can be monitored. The actual position is visible as well. You can report the status of the position registers with a digital output (see screen page Digital I/O)

Hints for setting up cams see KDN page Camming.

Screen text | ASCII parameter
Positions Registers | WPOS
Check | WPOSX
Enable | WPOSE
Signal, if | WPOSP
Pos. | P1...P16


ASCII English POSRSTAT

ASCII - Command | POSRSTAT |
Syntax Transmit | POSRSTAT [Data] |
Syntax Receive | POSRSTAT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3643 (hex)
DIM | - | PROFIBUS PNU | 1923 (dec) IND = 1 (dec)
Range | - | DPR | 323 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Status of Fast Position Registers 1 ... 16

Description

The variable POSRSTAT returns the present status of the fast position registers.
This variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the status information of position registers P1 ... P16.
Bit=0 position signaling inactive
Bit=1 position signaling active (position overrun for WPOSP=0 or underrun for WPOSP=1).

See also WPOS


ASCII English PPOTYP

ASCII - Command | PPOTYP |
Syntax Transmit | PPOTYP [Data] |
Syntax Receive | PPOTYP <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35D0 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 1 (dec)
Range | 2 | DPR | 208 (dec)
Default | 2 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | Profibus PPO Type

Description

PPOTYP reads the PROFIBUS DP telegram type. The amplifier supports telegram type 2 (telegram consists of 10 words (20 bytes) and is divided into a PKW section (4 words) and a PZD section (6 words)). PPOTYP returns the value, 2.


ASCII English PRBASE

ASCII - Command | PRBASE |
Syntax Transmit | PRBASE [Data] |
Syntax Receive | PRBASE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35D1 (hex)
DIM | - | PROFIBUS PNU | 1809 (dec) IND = 1 (dec)
Range | 1 ... 28 | DPR | 209 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | position loop | EEPROM | Yes
Short Description | Position Resolution

Description

Description:

The drive works with an internal 64Bit variable for counting the number of turns of the rotor shaft and for the internal position resolution. The upper 32Bit are disposed for counting the number of turns, the lower 32 Bit are acting for the internal position resolution. External controller are working mostly with 32Bit variables. Therefore 32Bit of the 64Bit variable must be copied in an internal 32Bit variable.

PRBASE defines, how many Bits of this 32 Bit variable are acting for the position resolution. The remaining Bits are used for counting the number of turns. The resolution is only activated when the amplifier is switched off and then on again.

Note: If PGEARI = PGEARO * 2^PRBASE, then there will be no conversion from user-defined units into increments. In this case, the position and velocity must be given in increments.

PRBASE=20:
20Bits are available for the internal position resolution. With the remaining 12 Bits, the drive can count 2^12=4096 =+/-2047 turns.

PRBASE=16:
16Bits are available for the internal position resolution. With the remaining 16 Bits, the drive can count 2^12=65536=+/-32767 turns.

Example:

Internal 64Bit variable: : 0x00000012 15E3A455
Number of turns Position

Internal 32Bit variable at PRBASE=20 : 0x01215E3A

Internal 32Bit variable at PRBASE=16 : 0x001215E3


ASCII English PRD

ASCII - Command | PRD |
Syntax Transmit | PRD [Data] |
Syntax Receive | PRD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D2 (hex)
DIM | Counts | PROFIBUS PNU | 1810 (dec) IND = 1 (dec)
Range | 0 .. 1048575 | DPR | 210 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | 20-bit Position Feedback

Description

The PRD command returns a 20-bit position (absolute within one turn) that is derived from the signals of the feedback device (FBTYPE). Unlike the position from the position control loop, PFB, this position cannot be altered.
PRD is not related to PRBASE


ASCII English PRIOR1

ASCII - Command | PRIOR1 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 360C (hex)
DIM | - | PROFIBUS PNU | 1868 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English PRIOR2

ASCII - Command | PRIOR2 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 360D (hex)
DIM | - | PROFIBUS PNU | 1869 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English PRIOR3

ASCII - Command | PRIOR3 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 3516 (hex)
DIM | - | PROFIBUS PNU | 1622 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English PRIOR4

ASCII - Command | PRIOR4 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 3517 (hex)
DIM | - | PROFIBUS PNU | 1623 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English PRIOR5

ASCII - Command | PRIOR5 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 351C (hex)
DIM | - | PROFIBUS PNU | 1628 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

PROFIBUS Expansion Card

This screen is avalable only if a PROFIBUS expansion card is inserted into the servo amplifier.

Profibus1

The PROFIBUS-specific parameters, the bus status, and the data words in the transmit and receive directions (as seen by the bus-master) are displayed on this screen page. This page is helpful when searching for errors and commissioning the bus communication.

Baudrate | The baud rate that is given by the PROFIBUS master is shown here
PNO Identnr. | The PNO identification is the number for the amplifier in the list of ID-numbers of the PROFIBUS user organization.
Address | Station address of the amplifier (Setup see CAN/Fieldbus).
PPO type | The amplifier only supports PPO-type 2 of the PROFIDRIVE profile.
Interface states | Shows the present status of the bus communication. Data can only be transferred across the PROFIBUS when the “Communication OK” message appears.
Input | The last bus object that was received by the master.
Output | The last bus object that was sent by the master.

The data for input/output are only transferred, if the threshold monitoring for the servo amplifier has been activated in the master’s hardware configuration.

Important amplifier configuration parameters

The following parameters configure the amplifier for the Profibus interface.

EXTWD (PNU 1658)
With this parameter, the observation time (watch dog) for the fieldbus-slot communication can be set (setup see CAN/Fieldbus). The observation is only active, if a value higher than 0 is assigned to EXTWD (EXTWD=0, observation switched off) and the output stage is enabled. If the set time runs out, without the watchdog-timer being newly triggered by the arrival of a telegram, then the warning n04 (response monitoring) is generated and the drive is stopped. The amplifier remains ready for operation and the output stage enabled. Before a new driving command (setpoint) is accepted, this warning must be deleted (function CLRFAULT or INxMODE=14).

ADDR (PNU 918)
With this command, the node address of the amplifier is set (setup see CAN/Fieldbus). When the address has been changed, all parameters should be saved to the EEPROM and the amplifier switched off and on again.

AENA (PNU 1606)
With this parameter, the state of the software-enable after switch-on can be defined (setup see BASIC SETUP). The software-enable allows an external control to enable/disable the output stage. For amplifiers with analog setpoints (OPMODE=1,3) the software-enable is set automatically after switch-on and the devices are ready for operation immediately (if hardware-enable is present). For all others, software-enable will be set to the value of AENA. The variable AENA also has functionality when resetting the amplifier after an error (by digital input 1 or the CLRFAULT command). If an error can be reset by the software, the software-enable is set to the value of AENA after the error is cleared. In this way the behavior of the amplifier after a software-reset is similar to after the drive is switched on.

INPT0 (PNU 1904)
With INPT0 a delay for the in-position message can be set (setup see TERMINAL). With the start of a motion task the in-position message is deleted and the monitoring of the position is activated after expiration of the adjusted time. This function is particularly important for positioning procedures within the in-position window. In this case the in-position message is delayed for a defined time.

Instrument Control

On this screen page the individual bits of the control word (STW) and the status word (ZSW) are shown. The device status resulting from the status word is visualized in the status machine. The current status is shown as black, all others are grey. Additionally the previous status is shown by emphasizing the number of the appropriate arrow.


ASCII English PROMPT

ASCII - Command | PROMPT |
Syntax Transmit | PROMPT [Data] |
Syntax Receive | PROMPT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35D3 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 1 (dec)
Range | 0 .. 3 | DPR | 211 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | RS232 | EEPROM | No
Short Description | Select RS232 Protocol

Description

The PROMPT parameter can be used to set the protocol for the RS232 transmission. The following settings are possible:
PROMPT=0 | No Echo | The data that is received through the RS232 interface is not automatically echoed (transmitted). There is no output of the prompt (-->) symbol.
PROMPT=1 | "-->" plus Echo | The data that is received through the RS232 interface is automatically echoed (transmitted). The prompt (-->) symbol is given for inputting data.
PROMPT=2 | Terminal Mode | This setting is the same as PROMPT=1 except: 1. If a CR(Enter) command is typed in at the beginning of the line, the last command is repeated. 2. Some commands (like DUMP) output more than one line of information. In this cases, the output is automatically stopped after one page.
PROMPT=3 | "-->" plus Echo plus Checksum | This setting is the same as PROMPT=1 except an additional checksum is transmitted and checked in both directions to prevent wrong data. All character of a command are summed (Modulo 256 without CR). example: Command string : "ADDR 1<CR>" generate Checksum: "A" = 0x41 "D" = 0x44 "D" = 0x44 "R" = 0x52 " " = 0x20 "1" = 0x31 The sum is: 0x16C Modulo 256: 0x6C = 108 (Dec) First Character: 108/16 + 0x30 =0x36 = "6" Sec. Character: 108%16 + 0x30 = 0x3C = "<" The command string is: "ADDR 16<" <CR> When the command string is received, the same calculation is done and the last two characters in front of the <CR> are compared with the received data. If the checksum is ok, the ACK (0x06) is send, if no NACK (0x15) is send.


ASCII English PSINUS

ASCII - Command | PSINUS |
Syntax Transmit | PSINUS [Frequenz] [Amplitude] |
Syntax Receive |  | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | Frequency: 1 .. 100; Amplitude: | DPR | No
Default | Frequency: 5Hz; Amplitude: 2048 counts |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enable | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | feedback | EEPROM | Nein
Short Description | sinus service-function

Description

The PSINUS command is used as a service function.

At startup, two parameters can be specified:

PSINUS [Frequency] [Amplitude]

Frequency - Sine frequency in Hz (range 1 to 100) (Default = 5 Hz)
Amplitude - Sinusoidal deflection in counts (2048 = +/- 2.8 degrees mechanical, max. 8192) (default 2048)

If PSINUS is called without parameters, the default values are valid.


ASCII English PSTATE

ASCII - Command | PSTATE |
Syntax Transmit | PSTATE [Data] |
Syntax Receive | PSTATE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 35D4 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 1 (dec)
Range | - | DPR | 212 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Profibus Status

Description

The command PSTATE reads out the present status of the PROFIBUS communication. The first value that is shown provides the SPC3 WATCHDOG status, the second value provides the PROFIBUS DP-status.
SPC3 WATCHDOG status
0 = baud rate search
1 = check baud rate
2 = DP mode, i.e. the bus watchdog is active

PROFIBUS-DP status
0 = wait for parameterization, performed by the master
1 = wait for configuration, performed by the master
2 = data exchange
3 = fault – the cause could, for instance, have been a faulty parameterization telegram in the data transfer phase.

Productive data can only be received, i.e. data exchanged for the PKW and PZD sections of the Drive, when the SPC3 WATCHDOG status has the value 2, and the PROFIBUS-DP status has the value 2.


ASCII English PSTEP

ASCII - Command | PSTEP |
Syntax Transmit | PSTEP [Data] |
Syntax Receive | PSTEP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 Integer32 Integer16 Integer32 | CANBus Object Number | -
DIM | ms (DurationN) / Velocity Units (velocityN) | PROFIBUS PNU | -
Range | Duration:0 to 32767; Velocity:-PVMAX to +PVMAX | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | Integer16 Integer32 Integer16 Integer32
Drive State | Enabled | Weighting |
Start Firmware | 2.32 |
Configuration | No | Last Change of this Object | 1.9
Function Group | other commands | EEPROM | -
Short Description | Service Operation (PSTEP Command)

Description

S700 and S300 FW > 2.32:

The PSTEP command is used to implement a service function through the operating mode "motion tasks" (OPMODE=8). The command can be used in the following forms.
1. PSTEP
The command provides the present settings for the service function.
2. PSTEP T1 V1
A digital setpoint V1 (VUNITs) is provided for time T1 (in msec). After T1 has elapsed, the digital setpoint is set to 0.
3. PSTEP T1 V1 T2 V2
A digital setpoint V1 (VUNITs) is provided for time T1 (in msec). After T1 has elapsed, a digital setpoint V2 (VUNITs) is provided for time T2 (in msec). After T2 has elapsed, the T1/V1 cycle starts again. This command can be used to create an endless reversing operation.
e.g. PSTEP 1000 10000 1000 -10000

The service operation can always be cancelled by using the STOP command.
For this service operation, the acceleration / deceleration ramps ACCR and DECR are active.
The "motion tasks" operating mode is a precondition for executing the PSTEP command.


ASCII English PTARGET

ASCII - Command | PTARGET |
Syntax Transmit | PTARGET [Data] |
Syntax Receive | PTARGET <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3654 (hex)
DIM | - | PROFIBUS PNU | 1940 (dec) IND = 1 (dec)
Range | long int | DPR | 340 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Last Target Position

Description

The command PTARGET can be used to request the target position for the last motion task that was started (and possibly already interrupted). This position is accepted as a new target position, as soon as the CONTINUE command is executed (to continue the last motion task).


ASCII English PTARGOFFS

ASCII - Command | PTARGOFFS |
Syntax Transmit | PTARGOFFS [Data] |
Syntax Receive | PTARGOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 389B (hex)
DIM |  | PROFIBUS PNU | 1723 (dec) IND = 33 (dec)
Range | -2147483647...2147483647 | DPR | 923 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 3.66 |
Configuration | No | Last Change of this Object | 2.4
Function Group | position loop | EEPROM | Yes
Short Description | Motion tasks position target shift

Description

The parameter PTARGOFFS offers the possibility to shift the target position of the absolute motion tasks.
The PTARGOFFS value is added to the motion task target position at the start of the motion task. The relative motion tasks are not affected by this value.


ASCII English PTBASE

ASCII - Command | PTBASE |
Syntax Transmit | PTBASE [Data] |
Syntax Receive | PTBASE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35D5 (hex)
DIM | 1/4 ms | PROFIBUS PNU | 1813 (dec) IND = 1 (dec)
Range | 1 ... 127 | DPR | 213 (dec)
Default | 4 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | position loop | EEPROM | Yes
Short Description | Time base for the external trajectory

Description

The PTBASE parameter is used to define the interpolation time for the external trajectory (OPMODE=5). The time is set in 250 microsecond steps, and defined the time period in which the drive should reach the next position command. Since the internal position control loop works in 250 microsecond steps, an interpolation of the given position command (external trajectory) is also given in 250 microsecond steps.

For SERCOS the scalling is PTBASE 2=500us, PTBASE 4 = 1000us…


ASCII English PTMIN

ASCII - Command | PTMIN |
Syntax Transmit | PTMIN [Data] |
Syntax Receive | PTMIN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D6 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1814 (dec) IND = 1 (dec)
Range | 3 .. 126000 | DPR | 214 (dec)
Default | 3150 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | position loop | EEPROM | Yes
Short Description | Min. Acceleration Ramp for Motion Tasks

Description

The minimum acceleration ramp PTMIN defines the minimum time that is permitted for a velocity change from 0 to PVMAX. Regardless of how the acceleration value is entered (milliseconds, SI units), the acceleration that is used is limited to PVMAX / PTMIN at the start of a motion task.
With the help of the PVMAX and PTMIN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.


ASCII English PUNIT

ASCII - Command | PUNIT |
Syntax Transmit | PUNIT [Data] |
Syntax Receive | PUNIT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3660 (hex)
DIM | - | PROFIBUS PNU | 1952 (dec) IND = 1 (dec)
Range | 0 ... 15 | DPR | 352 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Set Resolution of the Position

Description

PUNIT enables a systemwide setting for the unit of position for the position controller. The following settings are possible:

PUNIT=0 internal Unit (user specific)
PUNIT=1 1 dm (0.1 m)
PUNIT=2 1 cm (0.01 m)
PUNIT=3 1 mm
PUNIT=4 0.1 mm
PUNIT=5 0.01 mm
PUNIT=6 1 µm
PUNIT=7 0.1 µm
PUNIT=8 0.01 µm
PUNIT=9 1 nm
PUNIT=10 0.1 nm
PUNIT=11 inch.
PUNIT=12 °

The parameter PUNIT is only used for the MMI. It calculates different units for the MMI. All internal calculations (position controller resolution PGEARI and motion tasks are not effected.

IF PUNIT=0 there is no difference to older firmware versions. The unit is defined only by PGEARI.

e.g: PGEARI=360 (Unit = Degree)
PGEARI=3600 (Unit= 0.1 Degree)


ASCII English PV

ASCII - Command | PV |
Syntax Transmit | PV [Data] |
Syntax Receive | PV <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 35D7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1815 (dec) IND = 1 (dec)
Range | long int | DPR | 215 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Actual Velocity (Position Control Loop)

Description

The actual velocity (position control loop) can be requested by using the PV command.
The scaling of the velocity depends on the PGEARI, and PGEARO parameters.


ASCII English PVMAX

ASCII - Command | PVMAX |
Syntax Transmit | PVMAX [Data] |
Syntax Receive | PVMAX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1816 (dec) IND = 1 (dec)
Range | 0 .. VLIM | DPR | 216 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | position loop | EEPROM | Yes
Short Description | Max. Velocity for Position Control

Description

The parameter PVMAX defines the maximum velocity that is permitted for a motion task. When a motion task is started, the target velocity for the motion task is limited to the value of PVMAX.
With the help of the PVMAX and PTMIN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.

When used together with the PVMAXN parameter, it is possible to implement a directionally-dependent velocity limit. The PVMAX determines the maximum velocity for positive and negative directions together. By making a subsequent entry for PVMAXN, the limit for the negative direction can be set separately.

Further, the parameter PVMAX dependens on the settings of the parameter VUNIT.

See VLIM , PVMAXP, PVMAXN, VUNIT, PGEARI, PGEARO


ASCII English PVMAXN

ASCII - Command | PVMAXN |
Syntax Transmit | PVMAXN [Data] |
Syntax Receive | PVMAXN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D9 (hex)
DIM | VUNIT | PROFIBUS PNU | 1817 (dec) IND = 1 (dec)
Range | 0 .. VLIM | DPR | 217 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Max. (Negative) Velocity for Position Control

Description

The parameter PVMAXN defines the maximum velocity (in the negative direction) that is permitted for a motion task. When a motion task is started, the target velocity for the motion task is limited to the value of PVMAXN.
When the maximum velocity for the positive direction (PVMAX) is defined, the PVMAXN parameter is set to the PVMAX value at the same time. So, if a separate setting is required for the negative direction of movement, the value for PVMAXN must be entered separately, afterwards.
With the help of the PVMAX, PTMIN and PVMAXN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.


ASCII English PVMAXP

ASCII - Command | PVMAXP |
Syntax Transmit | PVMAX [Data] |
Syntax Receive | PVMAXP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35DB (hex)
DIM | VUNIT | PROFIBUS PNU | 1819 (dec) IND = 1 (dec)
Range | 0 .. VLIM | DPR | 219 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Max. (positive) Velocity for Position Control

Description

The parameter PVMAXN defines the maximum velocity (in the negative direction) that is permitted for a motion task. When a motion task is started, the target velocity for the motion task is limited to the value of PVMAXN.
When the maximum velocity for the positive direction (PVMAX) is defined, the PVMAXN parameter is set to the PVMAX value at the same time. So, if a separate setting is required for the negative direction of movement, the value for PVMAXN must be entered separately, afterwards.
With the help of the PVMAX, PTMIN and PVMAXN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.


ASCII English QCNFG

ASCII - Command | QCNFG |
Syntax Transmit | QCNFG [Data] |
Syntax Receive | QCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38D7 (hex)
DIM |  | PROFIBUS PNU | 1783 (dec) IND = 33 (dec)
Range | -2147483647...2147483647 | DPR | 983 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | Configuration variable of the servo punp

Description

The parameter QCNFG is a bit variable. With this parameter you can configure the servo pump function

Bit 0 – pump direction 0=right, 1=left
Bit 1 – adaption active
Bit 2 – efficiency compensation active
Bit 3 – reserved
Bit 4 - configuration of SW2
Bit 5 - configuration of SW2
Bit 6 - configuration of SW2
Bit 7 - configuration of SW2

SW2 configuration bits
Bit 4,5,6,7 = 0 SW2 deactivated
Bit 4,5,6,7 = 1 SW2 switchable via input 1
Bit 4,5,6,7 = 2 SW2 switchable via input 2
Bit 4,5,6,7 = 3 SW2 switchable via input 3
Bit 4,5,6,7 = 4 SW2 switchable via input 4
Bit 4,5,6,7 = 5 SW2 switchable via input 5
Bit 4,5,6,7 = 6 SW2 switchable via input 6
Bit 4,5,6,7 = 7 SW2 volume setpoint 10V = QFMAX
Bit 4,5,6,7 = 8 SW2 pressure setpoint 10V = QPRMAX


ASCII English QENA

ASCII - Command | QENA |
Syntax Transmit | QFACTOR [Data] |
Syntax Receive | QENA <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3913 (hex)
DIM |  | PROFIBUS PNU | 1843 (dec) IND = 33 (dec)
Range | 0/1 | DPR | 1043 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer8
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | enable of servo pump function

Description

With QENA=1 the servo pump funcktion is enabled


ASCII English QFACT

ASCII - Command | QFACT |
Syntax Transmit | QFACT |
Syntax Receive | QFACT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38DE (hex)
DIM | l/min | PROFIBUS PNU | 1790 (dec) IND = 33 (dec)
Range | - | DPR | 990 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | volume-flow actual value (without filter)

Description

This paramtere QFACT displays the volume-flow actual value in l/min without a filter.


ASCII English QFACTCOMP

ASCII - Command | QFACTCOMP |
Syntax Transmit | QFACTCOMP |
Syntax Receive | QFACTCOMP <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38E2 (hex)
DIM | l/min | PROFIBUS PNU | 1794 (dec) IND = 33 (dec)
Range | - | DPR | 994 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | volume-flow actual value (after compensation)

Description

This paramtere QFACTCOMP displays the volume-flow actual value in l/min after efficiency compensation


ASCII English QFACTFILT

ASCII - Command | QFACTFILT |
Syntax Transmit | QFACTFILT [Data] |
Syntax Receive | QFACTFILT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38E3 (hex)
DIM | 1/min | PROFIBUS PNU | 1795 (dec) IND = 33 (dec)
Range | - | DPR | 995 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | Filtered setpoint for the volume flow

Description

The parameter FCMDFILT gives the current volume-flow setpoint behind a first-order low-pass filter.

The filter time constant can be defined via parameter QT1.


ASCII English QFACTOR

ASCII - Command | QFACTOR |
Syntax Transmit | QFACTOR [Data] |
Syntax Receive | QFACTOR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38D8 (hex)
DIM | cm3 | PROFIBUS PNU | 1784 (dec) IND = 33 (dec)
Range | 0 .. 2147480 | DPR | 984 (dec)
Default | 100 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 6.00 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | swallowing volume

Description

Definition of the swallowing volume in cm3 per revolution


ASCII English QFCFACT

ASCII - Command | QFCFACT |
Syntax Transmit | QFCFACT |
Syntax Receive | QFCFACT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38D9 (hex)
DIM |  | PROFIBUS PNU | 1785 (dec) IND = 33 (dec)
Range | - | DPR | 985 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | current efficiency factor (volume)

Description

The factor can be found in the efficiency table, and changes depending on the current actual pressure/speed: 1000 = 1.000


ASCII English QFCMD

ASCII - Command | QFCMD |
Syntax Transmit | QFACTOR [Data] |
Syntax Receive | QFCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3914 (hex)
DIM |  | PROFIBUS PNU | 1844 (dec) IND = 33 (dec)
Range | -214780 .. 2147480 | DPR | 1044 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | volume-flow setpoint

Description

This parameter QFCMD configures the volume-flow setpoint


ASCII English QFCMDFILT

ASCII - Command | QFCMDFILT |
Syntax Transmit | QFACTOR [Data] |
Syntax Receive | QFCMDFILT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3915 (hex)
DIM |  | PROFIBUS PNU | 1845 (dec) IND = 33 (dec)
Range | - | DPR | 1045 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | filtered setpoint for the volume flow

Description

This parameter QFSET gives the current volume-flow setpoint behind a first-order low-pass filter. The filter time constant can be defined via parameter QT1.


ASCII English QFMAX

ASCII - Command | QFMAX |
Syntax Transmit | QFMAX [Data] |
Syntax Receive | QFMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38E9 (hex)
DIM | 1/min | PROFIBUS PNU | 1801 (dec) IND = 33 (dec)
Range | 0 .. 2147480 | DPR | 1001 (dec)
Default | 10 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | max setpoint for the volume flow

Description

This parameter QFMAX defines the maximum value for the volume-flow setpoint. This value corresponds to a specification of 10V at analog input SW2.


ASCII English QFSET

ASCII - Command | QFSET |
Syntax Transmit | QFSET |
Syntax Receive | QFSET <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38DD (hex)
DIM | l/min | PROFIBUS PNU | 1789 (dec) IND = 33 (dec)
Range | - | DPR | 989 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Filtered setpoint for the volume flow

Description

This parameter QFSET gives the current volume-flow setpoint behind a first-order low-pass filter.
The filter time constant can be defined via parameter QT1.


ASCII English QKPEFF

ASCII - Command | QKPEFF |
Syntax Transmit | QKPEFF |
Syntax Receive | QKPEFF <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38FB (hex)
DIM |  | PROFIBUS PNU | 1819 (dec) IND = 33 (dec)
Range | - | DPR | 1019 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | Regulator parameter adaption: active KP value

Description

This parameter QKPEFF displays the active KP value of the regulator parameter adaption


ASCII English QMACT

ASCII - Command | QMACT |
Syntax Transmit | QMACT |
Syntax Receive | QMACT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38DA (hex)
DIM |  | PROFIBUS PNU | 1786 (dec) IND = 33 (dec)
Range | - | DPR | 986 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Current actual torque

Description

This parameter QMACT displays the current actual torque.


ASCII English QMCMD

ASCII - Command | QMCMD |
Syntax Transmit | QMCMD |
Syntax Receive | QMCMD <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38E1 (hex)
DIM |  | PROFIBUS PNU | 1793 (dec) IND = 33 (dec)
Range | - | DPR | 993 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | current torque setpoint

Description

This parameter QMCMD defines the current before torque limitation.


ASCII English QMCMDLIM

ASCII - Command | QMCMDLIM |
Syntax Transmit | QMCMDLIM |
Syntax Receive | QMCMDLIM <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38E6 (hex)
DIM | Nm | PROFIBUS PNU | 1798 (dec) IND = 33 (dec)
Range | - | DPR | 998 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | Current torque setpoint hind the limitation

Description

This parameter QMCMDLIM defines the current torque setpoint behind the limitation.


ASCII English QMLIMN

ASCII - Command | QMLIMN |
Syntax Transmit | QMLIMN [Data] |
Syntax Receive | QMLIMN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3917 (hex)
DIM | Nm | PROFIBUS PNU | 1847 (dec) IND = 33 (dec)
Range | variable | DPR | 1047 (dec)
Default | variable |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | Torque limitation for pressure release

Description

This parameter QMLIMN defines the torque limitation for pressure release of servo pump..


ASCII English QMLIMP

ASCII - Command | QMLIMP |
Syntax Transmit | QMLIMP [Data] |
Syntax Receive | QMLIMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38E7 (hex)
DIM | Nm | PROFIBUS PNU | 1799 (dec) IND = 33 (dec)
Range | variable | DPR | 999 (dec)
Default | variable |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | Torque limitation for pressure build-up

Description

This parameter QMLIMP defines the torque limitation for pressure build-up of servo pump..


ASCII English QPE

ASCII - Command | QPE |
Syntax Transmit | QPE |
Syntax Receive | QPE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38FA (hex)
DIM | bar | PROFIBUS PNU | 1818 (dec) IND = 33 (dec)
Range | -int32 ... +int32 | DPR | 1018 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | current pressure-regulator deviation

Description

This parameter QPE displays the current pressure-regulator deviation.


ASCII English QPRACT

ASCII - Command | QPRACT |
Syntax Transmit | QPRACT |
Syntax Receive | QPRACT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38E0 (hex)
DIM |  | PROFIBUS PNU | 1792 (dec) IND = 33 (dec)
Range | - | DPR | 992 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | actual pressure value

Description

QPRACT gives the current actual pressure value in bar. The actual pressure value is calculated based on the
analog voltage at input SW1 and the pressure sensor calibration table.


ASCII English QPRMAX

ASCII - Command | QPRMAX |
Syntax Transmit | QPRMAX [Data] |
Syntax Receive | QPRMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38EA (hex)
DIM | bar | PROFIBUS PNU | 1802 (dec) IND = 33 (dec)
Range | 0 .. 2147480 | DPR | 1002 (dec)
Default | 200 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | max pressure setpoint

Description

QPRMAX defines the maximum value for the pressure setpoint. This value corresponds to a specification of 10V at analog input SW2.


ASCII English QPRSET

ASCII - Command | QPRSET |
Syntax Transmit | QPRSET [Data] |
Syntax Receive | QPRSET <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38DF (hex)
DIM |  | PROFIBUS PNU | 1791 (dec) IND = 33 (dec)
Range | -2147480 .. 2147480 | DPR | 991 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | actual pressure setpoint

Description

This parameter QPRSET displays the actual pressure setpoint.


ASCII English QPRSETEFF

ASCII - Command | QPRSETEFF |
Syntax Transmit | QPRSETEFF] |
Syntax Receive | QPRSETEFF <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38E8 (hex)
DIM | bar | PROFIBUS PNU | 1800 (dec) IND = 33 (dec)
Range | - | DPR | 1000 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | No
Short Description | actual pressure setpoint (effective)

Description

please have a look to QPRSET


ASCII English QT1

ASCII - Command | QT1 |
Syntax Transmit | QT1 [Data] |
Syntax Receive | QT1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3916 (hex)
DIM | msec | PROFIBUS PNU | 1846 (dec) IND = 33 (dec)
Range | - | DPR | 1046 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | Yes | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | constant for the volume-flow setpoint filter

Description

This parameter QT1 describes the filter time constant for the volume-flow setpoint filter (first-order low-pass filter).


ASCII English QTAB1KP

ASCII - Command | QTAB1KP |
Syntax Transmit | QTAB1KP [Data] |
Syntax Receive | QTAB1KP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38EB (hex)
DIM |  | PROFIBUS PNU | 1803 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1003 (dec)
Default | 0.1 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: KP – amplification for QTAB1V

Description

The intersections QTAB1KP ... QTAB5KP are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB1TN

ASCII - Command | QTAB1TN |
Syntax Transmit | QTAB1TN [Data] |
Syntax Receive | QTAB1TN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F5 (hex)
DIM | ms | PROFIBUS PNU | 1813 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 1013 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TN – reset time for QTAB1V

Description

The intersections QTAB1TN ... QTAB5TN are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB1TV

ASCII - Command | QTAB1TV |
Syntax Transmit | QTAB1TV [Data] |
Syntax Receive | QTAB1TV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3901 (hex)
DIM |  | PROFIBUS PNU | 1825 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1025 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TV – hold-back time for QTAB1V

Description

The intersections QTAB1TV ... QTAB5TV are used in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB1V

ASCII - Command | QTAB1V |
Syntax Transmit | QTAB1V [Data] |
Syntax Receive | QTAB1V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F0 (hex)
DIM | Bar | PROFIBUS PNU | 1808 (dec) IND = 33 (dec)
Range | 0 .. int32 | DPR | 1008 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: Speed 1

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB2KP

ASCII - Command | QTAB2KP |
Syntax Transmit | QTAB2KP [Data] |
Syntax Receive | QTAB2KP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38EC (hex)
DIM |  | PROFIBUS PNU | 1804 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1004 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: KP – amplification for QTAB2V

Description

The intersections QTAB1KP ... QTAB5KP are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB2TN

ASCII - Command | QTAB2TN |
Syntax Transmit | QTAB2TN [Data] |
Syntax Receive | QTAB2TN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F6 (hex)
DIM | ms | PROFIBUS PNU | 1814 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 1014 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TN – reset time for QTAB2V

Description

The intersections QTAB1TN ... QTAB5TN are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB2TV

ASCII - Command | QTAB2TV |
Syntax Transmit | QTAB2TV [Data] |
Syntax Receive | QTAB2TV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3902 (hex)
DIM |  | PROFIBUS PNU | 1826 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1026 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TV – hold-back time for QTAB2V

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB2V

ASCII - Command | QTAB2V |
Syntax Transmit | QTAB2V [Data] |
Syntax Receive | QTAB2V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F1 (hex)
DIM | Bar | PROFIBUS PNU | 1809 (dec) IND = 33 (dec)
Range | 0 .. int32 | DPR | 1009 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: Speed 2

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB3KP

ASCII - Command | QTAB3KP |
Syntax Transmit | QTAB3KP [Data] |
Syntax Receive | QTAB3KP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38ED (hex)
DIM |  | PROFIBUS PNU | 1805 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1005 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: KP – amplification for QTAB3V

Description

The intersections QTAB1KP ... QTAB5KP are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB3TN

ASCII - Command | QTAB3TN |
Syntax Transmit | QTAB3TN [Data] |
Syntax Receive | QTAB3TN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F7 (hex)
DIM | ms | PROFIBUS PNU | 1815 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 1015 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TN – reset time for QTAB3V

Description

The intersections QTAB1TN ... QTAB5TN are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB3TV

ASCII - Command | QTAB3TV |
Syntax Transmit | QTAB3TV [Data] |
Syntax Receive | QTAB3TV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3903 (hex)
DIM |  | PROFIBUS PNU | 1827 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1027 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TV – hold-back time for QTAB3V

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB3V

ASCII - Command | QTAB3V |
Syntax Transmit | QTAB3V [Data] |
Syntax Receive | QTAB3V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F2 (hex)
DIM | Bar | PROFIBUS PNU | 1810 (dec) IND = 33 (dec)
Range | 0 .. int32 | DPR | 1010 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: Speed 3

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB4KP

ASCII - Command | QTAB4KP |
Syntax Transmit | QTAB4KP [Data] |
Syntax Receive | QTAB4KP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38EE (hex)
DIM |  | PROFIBUS PNU | 1806 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1006 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: KP – amplification for QTAB4V

Description

The intersections QTAB1KP ... QTAB5KP are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB4TN

ASCII - Command | QTAB4TN |
Syntax Transmit | QTAB4TN [Data] |
Syntax Receive | QTAB4TN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F8 (hex)
DIM | ms | PROFIBUS PNU | 1816 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 1016 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TN – reset time for QTAB4V

Description

The intersections QTAB1TN ... QTAB5TN are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB4TV

ASCII - Command | QTAB4TV |
Syntax Transmit | QTAB4TV [Data] |
Syntax Receive | QTAB4TV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3904 (hex)
DIM |  | PROFIBUS PNU | 1828 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1028 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TV – hold-back time for QTAB4V

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB4V

ASCII - Command | QTAB4V |
Syntax Transmit | QTAB4V [Data] |
Syntax Receive | QTAB4V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F3 (hex)
DIM | Bar | PROFIBUS PNU | 1811 (dec) IND = 33 (dec)
Range | 0 .. int32 | DPR | 1011 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: Speed 4

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB5KP

ASCII - Command | QTAB5KP |
Syntax Transmit | QTAB5KP [Data] |
Syntax Receive | QTAB5KP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38EF (hex)
DIM |  | PROFIBUS PNU | 1807 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1007 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: KP – amplification for QTAB5V

Description

The intersections QTAB1KP ... QTAB5KP are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB5TN

ASCII - Command | QTAB5TN |
Syntax Transmit | QTAB5TN [Data] |
Syntax Receive | QTAB5TN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F9 (hex)
DIM | ms | PROFIBUS PNU | 1817 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 1017 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TN – reset time for QTAB5V

Description

The intersections QTAB1TN ... QTAB5TN are in connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB5TV

ASCII - Command | QTAB5TV |
Syntax Transmit | QTAB5TV [Data] |
Syntax Receive | QTAB5TV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3905 (hex)
DIM |  | PROFIBUS PNU | 1829 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 1029 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: TV – hold-back time for QTAB5V

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTAB5V

ASCII - Command | QTAB5V |
Syntax Transmit | QTAB5V [Data] |
Syntax Receive | QTAB5V <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38F4 (hex)
DIM | Bar | PROFIBUS PNU | 1812 (dec) IND = 33 (dec)
Range | 0 .. int32 | DPR | 1012 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: Speed 5

Description

The intersections QTAB1TN ... QTAB5TN, QTAB1TV ... QTAB5TV and QTAB1KP ... QTAB5KP are in
connection with the values QTAB1V ... QTAB5V for calculating a parameter switching table.

Depending on the current motor speed, the corresponding controller parameters are activated.


ASCII English QTABID

ASCII - Command | QTABID |
Syntax Transmit | QTABID |
Syntax Receive | QTABID <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3900 (hex)
DIM |  | PROFIBUS PNU | 1824 (dec) IND = 33 (dec)
Range | 0 .. 5 | DPR | 1024 (dec)
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | Regulator parameter adaption: Current parameter index

Description

The QTABID shows the current index in the regulator parameter table.
QTABID=0 no parameter adaption, QKP,QTV and QTN active
QTABID=1 speed 1. QTAB1KP,QTAB1TV and QTAB1TN are active.
QTABID=2 speed 2. QTAB2KP,QTAB2TV and QTAB2TN are active.
QTABID=3 speed 3. QTAB3KP,QTAB3TV and QTAB3TN are active.
QTABID=4 speed 4. QTAB4KP,QTAB4TV and QTAB4TN are active.
QTABID=5 speed 5. QTAB5KP,QTAB5TV and QTAB5TN are active.


ASCII English QTIMEKD

ASCII - Command | QTIMEKD |
Syntax Transmit | QTIMEKD [Data] |
Syntax Receive | QTIMEKD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 38E4 (hex)
DIM | ms | PROFIBUS PNU | 1796 (dec) IND = 33 (dec)
Range | 0 .. 2147480 | DPR | 996 (dec)
Default | 1 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | time constant of the D-section of the pressure flow regulator

Description

This parameter QMTIMEKD configures the time constant of the D- section or the pressure flow regulator (PID).


ASCII English QTNEFF

ASCII - Command | QTNEFF |
Syntax Transmit | QTNEFF |
Syntax Receive | QTNEFF <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38FC (hex)
DIM |  | PROFIBUS PNU | 1820 (dec) IND = 33 (dec)
Range | - | DPR | 1020 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | No
Short Description | Regulator parameter adaption: active TN value

Description

This parameter QTNEFF displays the active TN value of the regulator parameter adaption.


ASCII English QTVEFF

ASCII - Command | QTVEFF |
Syntax Transmit | QTVEFF |
Syntax Receive | QTVEFF <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 38DB (hex)
DIM |  | PROFIBUS PNU | 1787 (dec) IND = 33 (dec)
Range | - | DPR | 987 (dec)
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.13
Function Group | servo pump | EEPROM | Yes
Short Description | Regulator parameter adaption: active TV value

Description

This parameter QTNEFF displays the active TV value of the regulator parameter adaption.


ASCII English QVAL

ASCII - Command | QVAL |
Syntax Transmit | QVAL |
Syntax Receive | QVAL <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format |  | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode | all | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | intern | EEPROM | No
Short Description | internal Parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English QVT1

ASCII - Command | QVT1 |
Syntax Transmit | QVT1 [Data] |
Syntax Receive | QVT1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38E5 (hex)
DIM |  | PROFIBUS PNU | 1797 (dec) IND = 33 (dec)
Range | 0 .. 1000 | DPR | 997 (dec)
Default | 1 |
Opmode | 0 | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | smoothing time actual value

Description

This parameter QVT1 configures the filter time constant for the volume-flow actual value filter (first-order low-pass filter).


ASCII English RDP

ASCII - Command | RDP |
Syntax Transmit | RDP |
Syntax Receive | RDP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36B7 (hex)
DIM | - | PROFIBUS PNU | 2039 (dec) IND = 1 (dec)
Range | 0 .. 2 | DPR | 439 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.19 |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | RDP operation modes

Description

the following RDP modes are possible:

0: RDP disabled; normal S700 operation.
1: RDP mode enabled; Enable mode = “Fault Disables Other Drive.”
2: RDP mode enabled; Enable mode = “Fault Forces Other Drive From RDP.”


ASCII English RDPBIAS

ASCII - Command | RDPBIAS |
Syntax Transmit | RDPBIAS [Data] |
Syntax Receive | RDPBIAS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36B8 (hex)
DIM | Ampere | PROFIBUS PNU | 2040 (dec) IND = 1 (dec)
Range |  | DPR | 440 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.13
Function Group | other commands | EEPROM | Yes
Short Description | RDP bias current

Description

With the parameter RDPBIAS the RDP bias current is set: normally value at 10%-25% of continuous current DICONT .


ASCII English RDPBIAS2

ASCII - Command | RDPBIAS2 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | other commands | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English RDPCLAMP

ASCII - Command | RDPCLAMP |
Syntax Transmit | RDPCLAMP [Data] |
Syntax Receive | RDPCLAMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36B9 (hex)
DIM |  | PROFIBUS PNU | 2041 (dec) IND = 1 (dec)
Range |  | DPR | 441 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | maximum output of equalization circuit

Description

With the parameter RDPCLAMB the RDP maximum output of equalization circuit is set: normally value is 50 (in RPMs).


ASCII English RDPINT

ASCII - Command | RDPINT |
Syntax Transmit | RDPINT [Data] |
Syntax Receive | RDPINT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36BA (hex)
DIM |  | PROFIBUS PNU | 2042 (dec) IND = 1 (dec)
Range |  | DPR | 442 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | integral value of the RDP equalization circuit

Description

RDPINT equals the integral value of the RDP equalization circuit.

Scaled for 9000000 = 1RPM (this is 9 million = 1RPM) and is limited by RDPCLAMP.


ASCII English RDPKI

ASCII - Command | RDPKI |
Syntax Transmit | RDPKI [Data] |
Syntax Receive | RDPKI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36BB (hex)
DIM |  | PROFIBUS PNU | 2043 (dec) IND = 1 (dec)
Range |  | DPR | 443 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | integral gain of equalization circuit

Description

RDPINT equals the integral gain of equalization circuit: typical value is 13


ASCII English RDPKP

ASCII - Command | RDPKP |
Syntax Transmit | RDPKP [Data] |
Syntax Receive | RDPKP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36BC (hex)
DIM |  | PROFIBUS PNU | 2044 (dec) IND = 1 (dec)
Range |  | DPR | 444 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | Yes
Short Description | proportional gain of equalization circuit

Description

RDPKP equals the proportional gain of equalization circuit: typical value is 300


ASCII English RDPON

ASCII - Command | RDPON |
Syntax Transmit | RDPON [Data] |
Syntax Receive | RDPON <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36BD (hex)
DIM |  | PROFIBUS PNU | 2045 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 445 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM | No
Short Description | RDP state

Description

With the parameter RDPON the actual RDP state is displayed:

0: no RDP function active (default)
1: RDP active


ASCII English READY

ASCII - Command | READY |
Syntax Transmit | READY |
Syntax Receive | READY <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DD (hex)
DIM | - | PROFIBUS PNU | 1821 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 221 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Status of the Software Enable

Description

Requests the status of the internal software enable.
READY = 0 Disabled
READY = 1 Enabled


ASCII English RECDONE

ASCII - Command | RECDONE |
Syntax Transmit | RECDONE |
Syntax Receive | RECDONE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DE (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 222 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Recording Done

Description

The RECDONE command can be used to request the status of the SCOPE recording. The command returns a 1 if the recording is finished and the data can now be requested with the GET command.


ASCII English RECING

ASCII - Command | RECING |
Syntax Transmit | RECING |
Syntax Receive | RECING <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DF (hex)
DIM | - | PROFIBUS PNU | 1823 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 223 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Recording in Progress

Description

Returns a 1 if the recording is active. At the end of a recording, or if the recording has not started, a 0 is returned.


ASCII English RECOFF

ASCII - Command | RECOFF |
Syntax Transmit | RECOFF [Data] |
Syntax Receive | RECOFF | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35E0 (hex)
DIM | - | PROFIBUS PNU | 1824 (dec) IND = 1 (dec)
Range | - | DPR | 224 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Cancel Scope Recording

Description

RECOFF stops the SCOPE recording (if started). State after RECOFF: RECRDY=1, RECING=0, RECDONE=0.


ASCII English RECORD

ASCII - Command | RECORD |
Syntax Transmit | RECORD [Data] |
Syntax Receive | RECORD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 1 .. 10000 (=Time);1 .. 1024(=Points); ASCII String (=Var) | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Capture Data for Recording

Description

The RECORD command can be used to define the data for the next SCOPE recording. The command is used in the following form.

RECORD time number var1 [var2] [var3] [var4]

time: the sampling interval in 250 µs- steps
number: the number of sample points to be recorded.
The maximum possible number depends on the number and size of the variables to be recorded.
If the number entered is too large, it will automatically be limited (when recording Long/Float variables, a maximum of 512 sample points can be recorded).
var1,var2,var3 - names of the variables to be recorded. Apart from the names for macro variables, the following names can be used.
I - actual value of current
ICMDVAL - setpoint for current
PE - following error
V - actual value of velocity
VCMD - setpoint for velocity
VBUS - DC-bus (DC-link) voltage
PFB - actual position


ASCII English RECRDY

ASCII - Command | RECRDY |
Syntax Transmit | RECRDY [Data] |
Syntax Receive | RECRDY <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35E1 (hex)
DIM | - | PROFIBUS PNU | 1825 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 225 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Status of RECORD Function

Description

After the recording has been made trigger-ready by RECORD / RECTRIG, the RECRDY command generates a 0. As soon as the trigger condition defined by RECRDY is fulfilled, and the recording starts, RECRDY generates a 1. When the drive is started, RECRDY is set to 1.

(RECRDY=0 means “waiting for trigger event”)


ASCII English RECTRIG

ASCII - Command | RECTRIG |
Syntax Transmit | RECTRIG [Data] |
Syntax Receive | RECTRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | ASCII String (=Mode);Depends upon Mode (=Level);0 .. 1023 (=Loc.); 0, 1 (=Dir.) | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | oscilloscope | EEPROM | No
Short Description | Scope: Activate Recording Function

Description

The RECTRIG command prepares the SCOPE function for a data recording.
The command is used in the following form.

RECTRIG mode level location direction

mode: designates the name of a variable that is to be used to trigger the recording. If the designation IMM is used, the recording starts immediately. In this case, the parameters “level”, “location” and “direction” do not have to be specified.

level: specifies the value of the variable that has to be reached to trigger the recording.

location: give the number of points that are to be recorded previous to the moment of the trigger event.

direction: specifies in which direction the value must pass the threshold “level” of the “mode” variable in order to trigger the recording.
direction=0 falling (variable value falls below threshold level)
direction=1 rising (variable value goes above threshold level)


ASCII English REFIP

ASCII - Command | REFIP |
Syntax Transmit | REFIP [Data] |
Syntax Receive | REFIP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35E2 (hex)
DIM | A | PROFIBUS PNU | 1826 (dec) IND = 1 (dec)
Range | 0.0 .. min(IPEAK,IPEAKN) | DPR | 226 (dec)
Default | min(IPEAK,IPEAKN,DICONT/2) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Peak Rated Current for Homing 7

Description

The REFIP parameter can be used to set the peak current for homing to a stop. When Homing mode 7 is started (homing to a stop and searching for a zero mark), IPEAK, the normal value for peak current, is set to the value REFIP. When the homing movement is finished, the IPEAK parameter is reset to the previous (normal) value.

- - - - - - - - - - - - -

REFIP is also used for the wake & shake procedure (FBTYPE=7,8). It sets the current limit for the first phase (rough angle adjustment). The second wake & shake phase is done by the IPEAK setting.


ASCII English REFIP2

ASCII - Command | REFIP2 |
Syntax Transmit |  |
Syntax Receive |  | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36E3 (hex)
DIM |  | PROFIBUS PNU | 1683 (dec) IND = 17 (dec)
Range | 0 ...IPEAK | DPR | 483 (dec)
Default | IPEAK |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Peak Rated Current for Commutation process

Description

REFIP2 limits the peak current during the wake & shake procedure.
After wake & shake is finished the current is reset to the IPEAK value.

>>> see also REFIP


ASCII English REFLS

ASCII - Command | REFLS |
Syntax Transmit | REFLS [Data] |
Syntax Receive | REFLS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 365D (hex)
DIM | - | PROFIBUS PNU | 1949 (dec) IND = 1 (dec)
Range | 0, 1, 2, 3 | DPR | 349 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Effect HW-limitswitches by homing

Description

REFLS defines the drive behavior when activating a hardware limit during a homing move.

REFLS=0 Change direction at NSTOP and PSTOP
REFLS=1 Change direction at PSTOP, create error message F26 (limit switch) at NSTOP
REFLS=2 Change direction at NSTOP, create error message F26 (limit switch) at PSTOP
REFLS=3 Create error message F26 (limit switch) at NSTOP and PSTOP

REFLS used when /NREF/ ( homing mode) = 1 or 3


ASCII English REFMODE

ASCII - Command | REFMODE |
Syntax Transmit | REFMODE [Data] |
Syntax Receive | REFMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 363C (hex)
DIM | - | PROFIBUS PNU | 1916 (dec) IND = 1 (dec)
Range | 0 .. 8 | DPR | 316 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.2
Function Group | position loop | EEPROM | Yes
Short Description | Source of the Zero Pulse in Homing Mode

Description

The command REFMODE selects the source of the zero pulse in homing mode.

REFMODE=0 Resolver- or singleturn encoder-zero, Zero crossing per rev of a multiturn encoder / at EXTPOS=1 Data-Pin connector X1

REFMODE=1 digital INPUT1
REFMODE=2 digital INPUT2
REFMODE=3 digital INPUT3
REFMODE=4 digital INPUT4
REFMODE=5 Data-Pin of connector X1
REFMODE=6 Zero pulse of the connector X5
REFMODE=7 Zero crossing of the absolute multiturn encoder (per rev)


ASCII English REFNOFFS

ASCII - Command | REFNOFFS |
Syntax Transmit | REFNOFFS [Data] |
Syntax Receive | REFNOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 386D (hex)
DIM | - | PROFIBUS PNU | 1677 (dec) IND = 33 (dec)
Range | -360 ... 360 | DPR | 877 (dec)
Default | 90 |
Opmode | - | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.51 |
Configuration | No | Last Change of this Object | 1.9
Function Group | position loop | EEPROM | Yes
Short Description | position of analog zero puls

Description

To get a better reference position accuracy the external zero pulse can be used additional. The input is selecte by REFMODE.
The S300/S700 has two different methods to use an external zero pulse:

1. Edge detection of the zero pulse REFNOFFS=0
If the edge is detected the position is reset (ROFFS), the motor slows down and returns to the position of the edge detection position.
If the reference motion is to fast the accuracy of this method isn't good.

2. Edge detection of the zero pulse with additional analoge positioning REFNOFFS=1...360
The accuracy of this methode is not influenced by the reference speed, but it can only be used with feedbacks that includes sine cosine signals. The zero pulse is only to detect the sine cosine cycle.


ASCII English REFNPOS

ASCII - Command | REFNPOS |
Syntax Transmit | REFNPOS [Data] |
Syntax Receive | REFNPOS <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 386E (hex)
DIM |  | PROFIBUS PNU | 1678 (dec) IND = 33 (dec)
Range | 0 ... 359 | DPR | 878 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.51 |
Configuration | No | Last Change of this Object | 1.9
Function Group | position loop | EEPROM | No
Short Description | external zero pulse offset inside sine/c0sine cycle

Description

Only S700

Position of the external zeropuls (REFMODE, REFNOFFS) within an encoder periode.
See also (REFNOFFS)


ASCII English REFPOS

ASCII - Command | REFPOS |
Syntax Transmit | REFPOS [Data] |
Syntax Receive | REFPOS <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 35E3 (hex)
DIM | Counts | PROFIBUS PNU | 1827 (dec) IND = 1 (dec)
Range | 0 ... 1048576 | DPR | 227 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.14 |
Configuration | No | Last Change of this Object | 1.3
Function Group | position loop | EEPROM | No
Short Description | Reference Switch Position

Description

The REFPOS command returns the position (20-bit, within one turn) to be used for detecting the “Reference criterion” during the homing movement. The “Reference criterion” depends on NREF, the type of homing movement.

NREF=0,5,6 REFPOS = position for starting the homing movement
NREF=1,3 REFPOS = position for detecting the rising edge of the reference switch
NREF=2,4 REFPOS = position for detecting the falling edge of the reference switch
NREF=7 REFPOS = position for detecting a stop (PE>PEMAX / 2)
NREF=8 REFPOS is not altered


ASCII English RELTIME

ASCII - Command | RELTIME |
Syntax Transmit | RELTIME [Data] |
Syntax Receive | RELTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 389E (hex)
DIM |  | PROFIBUS PNU | 1726 (dec) IND = 33 (dec)
Range | 0, 10000....100000 | DPR | 926 (dec)
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.3
Function Group | drive configuration | EEPROM |
Short Description | switching on of the thyristor voltage control

Description

Defines the max time for switching on of the thyristor voltage control (S748 / S772 only)
After the switching on of mains, the thyristor control is switched on after the bus voltage VBUS becomes constant.
In case of poor mains quality this phase can lasts a long time. The parameter RELTIME limitates this time to the configured number of msec. The thyristor controls is switched on when VBUS>350V and the RELTIME expired.

RELTIME=0 switches the time limitation off.


ASCII English REMOTE

ASCII - Command | REMOTE |
Syntax Transmit | REMOTE |
Syntax Receive | REMOTE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35E4 (hex)
DIM | - | PROFIBUS PNU | 1828 (dec) IND = 1 (dec)
Range | 0 .. 1 | DPR | 228 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Status of the Hardware Enable

Description

The REMOTE command indicates the state of the hardware enable input .
1 indicates a High state of the inputs (hardware enable is set), a 0 indicates a Low state.


ASCII English RESAMPL

ASCII - Command | RESAMPL |
Syntax Transmit | RESAMPL [Data] |
Syntax Receive | RESAMPL <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 8191 | DPR | No
Default | 1000 |
Opmode | all | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | feedback | EEPROM | Yes
Short Description | Resolver cable break supervision

Description

The parameter RESAMPL describes the minimum resolver amplitude. Not only the amplitude but also sine/cosine phase is monitored. This functionality can activeted with set bits 4 and 5 in the parameter CPHASE.


ASCII English RESOLVER

ASCII - Command | RESOLVER |
Syntax Transmit | RESOLVER [Data] |
Syntax Receive | RESOLVER <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3520 (hex)
DIM |  | PROFIBUS PNU | 1632 (dec) IND = 1 (dec)
Range | 0 ... 2 | DPR | 32 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Resolver excitation gain adjust +/- 20%

Description

RESOLVER 0 will reduce the excitation by 20%.
RESOLVER 2 will increase the excitation by 20%.


ASCII English RESPHASE

ASCII - Command | RESPHASE |
Syntax Transmit | RESPHASE [Data] |
Syntax Receive | RESPHASE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E5 (hex)
DIM | - | PROFIBUS PNU | 1829 (dec) IND = 1 (dec)
Range | +/-90 bei S300 (+/-511 bei S700) | DPR | 229 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Resolver Phase

Description

Please refer to the ASCII command CALCRP.


ASCII English RK

ASCII - Command | RK |
Syntax Transmit | RK [Data] |
Syntax Receive | RK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E6 (hex)
DIM | Counts | PROFIBUS PNU | 1830 (dec) IND = 1 (dec)
Range | 12000 ..19000 | DPR | 230 (dec)
Default | 16384 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Gain Adjust for Resolver Sine Signal

Description

The RK parameter can be used to correct any amplitude difference that may exist between the sine and cosine signals from the resolver. The relationships are as follows:
RK = 16384 no alteration of the amplitude of the sine signal
RK < 16384 sine signal amplitude is reduced
RK > 16384 sine signal amplitude is increased

An incorrect setting of this correction factor will result in velocity/velocity variations (ripple) which are strongly dependent on the position.
The CALCRK command enables an automatic determination of the correction factor RK.

This value will not be changed by a parameter download, since it only depends on the equipment.


ASCII English ROFFS

ASCII - Command | ROFFS |
Syntax Transmit | ROFFS [Data] |
Syntax Receive | ROFFS | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35E7 (hex)
DIM | µm | PROFIBUS PNU | 1831 (dec) IND = 1 (dec)
Range | long int | DPR | 231 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | position loop | EEPROM | Yes
Short Description | Reference Offset

Description

The ROFFS parameter is used for Resolver or single-turn encoder (homing to reference point is possible)

The ROFFS parameter can be used to assign a freely chosen absolute position as the reference position (zero position) that will be reached at the end of a homing movement.
The scaling of the position depends on the settings for PGEARI, PGEARO, PRBASE.
If the resolution is set to 1 (PGEARI=PGEARO), then internal units (counts) will be used.

If a homing is executed and the feedback is an absolute encoder, then the drive calculates after completion of homing a reference offset and stores it automatically in the serial EEPROM.


ASCII English ROFFSABS

ASCII - Command | ROFFSABS |
Syntax Transmit | ROFFSABS [Data] |
Syntax Receive | ROFFSABS | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3656 (hex)
DIM | µm | PROFIBUS PNU | 1942 (dec) IND = 1 (dec)
Range | long int | DPR | 342 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 0.39 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Reference Offset

Description

The ROFFSABS parameter is used with an absolute encoder (multi-turn, homing to reference point is also possible)
The ROFFSABS sets an offset to the absolute encoder position. This procedure is executed by drive power on. The parameter must be saved in the EEPROM (using the SAVE command) after every alteration of the ROFFSABS variable, and the amplifier must then be switched off and on again (COLDSTART command).

Example:
If a position 10000 (PFB) is shown when the amplifier is switched on with ROFFSABS = 0, ROFFSABS = –10000 will shift the position to the value 0.


ASCII English ROFFSSSI

ASCII - Command | ROFFSSSI |
Syntax Transmit | ROFFSSSI [Data] |
Syntax Receive | ROFFSSSI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3864 (hex)
DIM | - | PROFIBUS PNU | 1668 (dec) IND = 33 (dec)
Range | INT32 | DPR | 868 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.28 |
Configuration | No | Last Change of this Object | 2.1
Function Group | feedback | EEPROM | Yes
Short Description | SSI absolute position offset

Description

This parameter defines the SSI position offset for the NREF=8 homing move.


ASCII English RS232T

ASCII - Command | RS232T |
Syntax Transmit | RS232T [Data] |
Syntax Receive | RS232T <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E8 (hex)
DIM | ms | PROFIBUS PNU | 1832 (dec) IND = 1 (dec)
Range | 0 .. 10000 | DPR | 232 (dec)
Default | 2500 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.12
Function Group | RS232 | EEPROM | Yes
Short Description | RS232 Watch Dog

Description

If the monitoring of the serial interface is activated (RS232 watchdog), then the RS232T command can be used to set the time for the watchdog timer.

please have a look ACTRS232


ASCII English RSTVAR

ASCII - Command | RSTVAR |
Syntax Transmit | RSTVAR |
Syntax Receive | RSTVAR | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35E9 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 1 (dec)
Range | - | DPR | 233 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Restore Variables (Default Values)

Description

The RSTVAR command resets all parameters / variables to the default settings. The parameters which are stored in the EEPROM are not immediately affected by this. The default settings only become permanent when the SAVE command is used (save parameters in the EEPORM).

In case configuration settings had been changed SAVE and COLDSTART is required.


ASCII English RSVERROFF

ASCII - Command | RSVERROFF |
Syntax Transmit | RSVERROFF [Data] |
Syntax Receive | RSVERROFF <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 389C (hex)
DIM |  | PROFIBUS PNU | 1724 (dec) IND = 33 (dec)
Range | 0 .. 1 | DPR | 924 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 3.66 |
Configuration | No | Last Change of this Object | 2.3
Function Group | feedback | EEPROM | No
Short Description | Resolver error supervision off

Description

RSVERROFF=1 switches off the supervision of the following error messages in the case that the power stage is disabled:

1.F04 Resolver error
2.F06 motor temperature
3.F08 Overspeed

This function allows to disconnect the resolver motor from the drive without generating an error message. For safety reasons this setting cannot be stored permanently in the drive.


ASCII English RUNIN

ASCII - Command | RUNIN |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 3756 (hex)
DIM | - | PROFIBUS PNU | 1798 (dec) IND = 17 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English S

ASCII - Command | S |
Syntax Transmit | S |
Syntax Receive | S | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35EA (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 1 (dec)
Range | - | DPR | 234 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | Stop Motor and Disable Drive

Description

The S command stops the drive (using the braking ramp DECSTOP). As soon as the velocity/velocity falls below the standstill threshold (VEL0) the output stage is disabled.
The S command corresponds to the command K (or DIS) if the STOPMODE option is set to 1.


ASCII English S1DLY

ASCII - Command | S1DLY |
Syntax Transmit | S1DLY [Data] |
Syntax Receive | S1DLY <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 38B9 (hex)
DIM | msec | PROFIBUS PNU | 1753 (dec) IND = 33 (dec)
Range | 0 .. 100000 | DPR | 953 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.17 |
Configuration | No | Last Change of this Object | 2.7
Function Group | drive configuration | EEPROM | Yes
Short Description | switch-on delay

Description

The parameter S1DLY the initialization of the (only!) S700 may be delayed. A delay can be useful in conjunction with option cards that have a very long initialization phase.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Safety Card

This screen shows the status of the built-in safety card.

Profibus1

The upper area shows data of the built-in card and the current I/O state. The error stack shows a history of safety errors related to the operation time counter of the servo amplifier.

Time | Operational time counter
No. | Safety Fault code (oXX see file S700 Safety Cards Error Codes on download page File Selector (document type: Safety Manual)
Index | Safety Fault Subindex (iYY see file S700 Safety Cards Error Codes on download page File Selector (document type: Safety Manual)
Fault | Fault description
CPU, Par1, Par2, Par3 | internal parameters


ASCII English SAVE

ASCII - Command | SAVE |
Syntax Transmit | SAVE |
Syntax Receive | SAVE | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35EB (hex)
DIM | - | PROFIBUS PNU | 1835 (dec) IND = 1 (dec)
Range | - | DPR | 235 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Save Data in EEPROM

Description

The SAVE command stores the present settings of the amplifier parameters in the serial EEPROM. At the same time, the checksum for the parameter field is updated and also saved in the serial EEPROM. The save process takes about 2 seconds. During this time, the 24V supply for the amplifier must not be switched off. If this supply voltage is switched off during the save process, this may result in invalid data (or none) being saved in the serial EEPROM. A checksum error will be detected at the next power-on of the equipment, and the fault message F09 will be generated.
Furthermore, all the amplifier parameters will be reset to the default values. In order to reset the F09 fault, the SAVE command must be used once more, and the amplifier must be switched off and on again.

A SAVE command is set, if an absolute feedback is used and a homing is executed.The reference offset is calculated and the command SAVE is set.


ASCII English SBAUD

ASCII - Command | SBAUD |
Syntax Transmit | SBAUD [Data] |
Syntax Receive | SBAUD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35EC (hex)
DIM | MBaud | PROFIBUS PNU | 1836 (dec) IND = 1 (dec)
Range | 2, 4, 8, 16 | DPR | 236 (dec)
Default | 4 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.00 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | Sercos: Baud Rate

Description

This parameter sets the transmission rate for SERCOS in MBAUD.


ASCII English SCAN

ASCII - Command | SCAN |
Syntax Transmit | SCAN |
Syntax Receive | SCAN <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35ED (hex)
DIM | - | PROFIBUS PNU | 1837 (dec) IND = 1 (dec)
Range | - | DPR | 237 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.00 |
Configuration | No | Last Change of this Object | 2.6
Function Group | fieldbus | EEPROM | No
Short Description | Detect CAN Stations

Description

For a CAN network with several drives connected, there is an option for using a serial connection to one of the devices (master) to communicate with all the other amplifiers. To do this, the SCAN command is initiated on the master device, which performs an automatic detection of all the drivess that are connected. The response to the SCAN command contains the total number and a list of the addresses of all the drive devices that have been detected.

The time taken to carry out this command is strongly dependent on the baud rate (CBAUD) that is has been set for CAN, and is in the range from 1 second (at 1 Mbaud/1 Mbps) to 37 seconds (at 10Kbaud/10 kbps).


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Oscilloscope

oszilloskop

Handling notes

Zoom

This function is independent from the used firmware version. It can be used in offline or online mode.

Click and hold the left mouse button in the curve area. Drag the mouse to create a zoom rectangle.

When the mouse button is released, the selected rectangle is enlarged to the entire display area. A short click of the right mouse button deactivates the zoom function and displays the entire curve. If the data cursor is placed in the zoomed area when the zoom is active, then the left / right arrow keys can be used to move the zoom area within the entire curve. Use the arrow down / up or the mouse wheel to stretch or compress the range of the time axis around the data cursor.

Hide/Unhide Channels

Click the left mouse button on the channel text (for example, channel 2) to hide the associated curve. The channel text “Channel 2" is replaced by ”—-". Clicking the left mouse button again unhide the curve of the corresponding channel.

By clicking the right mouse button on the channel text, all channels except the selected channel are hided (solo display). Clicking the right mouse button again on the solo channel will unhide all curves.

Channels

Only first 4 channels are visible on the scope page, but up to 10 channels can be recorded (see tab Extended Channels) and can be stored in the Scope-Excel-File.

Cycle time for the measurement acquisition ³ 250 µs.

Resolution
The number of measured points per time unit (storage depth). Setting: fine, normal, coarse

Time/Div
Scaling of the time axis. Select the time/division. Setting: 1 ... 5000 ms/div
Total length of the time axis: 8 * x ms/Div

Channel 1 to 4
Assignment of the displayed variables to the channels.

I_act | Actual torque (current)
I_cmd | Torque setpoint
v_act | Actual velocity
v_cmd | Velocity setpoint
P_act | Actual position
P_cmd | Position setpoint
PERROR | Position error
VBUS | DC-link (bus) voltage
Off | Channel is not used
user-defined | Macro Variable

If you select "user-defined" you can display the value of a MACRO parameter. For channel 4 for example this screen appears:

makro

Fill in the macro variable name (see selection of macro variables below).

Macro Variable (selection) | Short Description
ERRCODE | Error state variable (see ERRCODE)
STATCODE | Drive state variable (see STATCODE)
TRJSTAT | Trajectory state variable (see TRJSTAT)
ADVAL0…15 | Analog input values
ADVAL0 | Cosine resolver
ADVAL1 | Sine resolver
tADVAL2 | Motor current Ia
ADVAL3 | Motor current Ib
ADVAL4 | Sine encoder
ADVAL5 | Cosine encoder
ADVAL6 | Analog setpoint 1
ADVAL7 | Analog setpoint 2
ADVAL8 | Motor temperature
ADVAL9 | Heatsink temperature
ADVAL10 | Environments temperature
ADVAL11 | Sense voltage encoder
ADVAL12 | n.c.
ADVAL13 | DC bus link voltage
ADVAL14 | n.c.
ADVAL15 | n.c.
SIENC | Normalised sine encoder +/- 1350 <> 1Vss
COENC | Normalised cosine encoder +/- 1350 <> 1Vss
SR_RXDE | Zero pulse port for NREF = 5
SR_HALL | Hall segments port
PFBL | Position Feedback 64 Bit size. The lower 32 bits includes the position within a revolution, the upper 32 bits counts the number of revolutions.
S_SETL | Position setpoint 64 Bit size. The lower 32 bits includes the position within a revolution, the upper 32 bits counts the number of revolutions.
PFB | Position Feedback (PRBASE size)
S_SET | Position setpoint (PRBASE size)
S_SETH | Sercos position setpoint (1 Revolution = 2^20)
PTARGET | Target position for the last/current motion task (PRBASE size)
PSPEED | Actual velocity setpoint in counts/250µsec
PSPEEDMS | Actual velocity setpoint in counts/250µsec for master/slave trajectory
PSPEED3 | Actual velocity setpoint for internal motion task trajectory
PENDSPEED | End velocity setpoint for the actual motion task
MOVEP_NR | Number of the last/actual motion task
NIZFLAG | State of the external zero pulse
PSTOP | State of the PSTOP limit switch
NSTOP | State of the NSTOP limit switch
INPUT1…20 | State of the hardware/software input 1…20
OUTPUT1...18 | State of the hardware/software output 1..18
HARDENA | State of the hardware enable
EN_P_I | State of the power stage (1=enabled, 0=disabled)
NET_BTBI | State of the net BTB
ENABLE_I | State of the internal enable signal
SOFTENABLE | State of the software enable
EN_BRAKE_I | Brake state (1=open, 0=closed)
PRD | Feedback position inside one revolution
IVORCMD | Current feed forward (3280 = DIPEAK)
PBAL | Regenerative power actual value
SR5VINCR | Pulse counter for X5 Master / Slave (5V)
SR24VINCR | Pulse counter for X3 Master / Slave (24V)

Auto-scale
For each channel the range of measurement can be selected: automatically (Auto checkbox is active) or manually (Auto checkbox is inactive, and min./max. values have been entered).

Auto-Scaling Mode
You can select standard or min/max scaling.

Trigger

einheiten3

Trigger-Mode
Measurement is triggered once if Single-Shot is set. Cyclical triggering is done with the Auto setting.

Trigger signal

The current and speed variables can be used as trigger signals. In addition, "Direct" can be used for immediate (independent) triggering. The setting "user-defined" enables manual entry of an ASCII variable.

Trigger position

X-value for triggering (time axis)

Trigger level

Y-value for triggering

Trigger edge

Triggering on the rising or falling edge

Recording / Scope File

einheiten31

Save
Saves the recorded measurements to a data medium in CSV format (to be evaluated with MS-Excel).

Load
Loads a CSV data file and displays the curves on the oscilloscope diagram.

Mem
If this is active when a new curve is recorded, the previous measurement is saved so a comparison can be made between the two measurements. The previous measurement curve is displayed in a darker color than the latest curve. The measurement range settings must be identical for both measurements. If not, the "Mem" checkbox is de-activated and locked.

Show interpolated values
If the chackbox is activated, intermediate values between the mearured values are interpolated.

Current plot file
Displays the filename and location of a loaded CSV file.

Motion Service

Be sure that the actual position of the load permits the subsequent positioning operations. The software limit-switches that were set as parameters are inactive, depending on the operation mode. The axis could move to the hardware limit-switch or even the mechanical stop. There is a risk of damage.

einheiten32

Function

Select one of the service functions described below. Click on the "Parameter" button and set the corresponding parameter. Start the function using the START button. The function continues until you click the STOP button or until you hit function key F11.

Direct current | Apply a direct current to the motor with adjustable size and electrical field-vector angle. The changeover from speed control to current control is made automatically. Commutation is made independently of the feedback (resolver or similar). The motor locks into a preferred position.
Speed | Operates the drive at constant speed. An internal digital setpoint is provided (speed is adjustable).
Torque | Operates the drive with constant current (constant acceleration). An internal digital setpoint is provided (current is adjustable). The changeover from speed control to current control is made automatically. Commutation is made independently of the feedback (resolver or similar).
Reversing | Operates the drive in reversing mode, with separate adjustable speed and reversing time for each direction of rotation.
Motion Task | Starts the motion task, which is selected on the screen page "Service Parameters"
Zero | Function for the automatic setting of the feedback unit phase, according to the phase position of the motor. Operation mode switches to OPMODE2 .
 | With service functions "Direct Current" and “Zero,” the motor shaft moves into preferential position. It can move rapidly to get arrive there.
Start / Stop | Start / Stop the selected service function. Stop can be done with F11 as well.

Parameters

service2

Adjust the service function parameters.

Tuning

einheiten33

Some variables important for the control behavior are combined here. You can tune the servo amplifier without closing the oscilloscope screen page.

Kp_v | GV
Tn_v | GVTN
LP Freq. | ARLPF
2nd LP Freq. | ARLP2
HP Freq. | ARHPF
Kp_p | GP
Velocity FF | GPFFV
Current FF | GPFFT
Resolver BW | MRESBW
Observer FF | VLO

Settings

Basic setup for the scope can be done here.

einheiten331

Buttons "Mem. Channel x Color..." define the colors of the previous measurement curve. Click to "Restore Defaults" sets the colors back to manufacturer defaults.

Screen text | ASCII parameter
Oscilloscope Sample Rate 4kHz/16kHz | DRVCNFG2

Extended Channels

Number of scope channels extended to 10. Only first 4 channels are visible on the scope page, but all channels are stored in the Scope-Excel-File. Select checkbox "Extended Channels" and map channels 5 to 10 as described for channels 1 to 4 (see Channels)

einheiten3312

WS Tuning

This tab only appears when the Wake and Shake control loop method is selected (see also the chapter Wake and Shake).

einheiten3311

The “Start CALCMP” button initiates the Wake and Shake function.

Recording

Cursor functionality

When a data set is displayed (from a file, or by starting a recording), the measured values for the signals are displayed in the co-ordinate system for the selected time period by a mouse click. A click outside the coordinate system, or a click while pressing the shift-key, resets the values in the display to zero.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

SD Card

On this screen, you can configure, save, and load files on the memory card.

Profibus1

During the loading/saving processes, the servo amplifier is disabled and then re-enabled. Depending on the function, the device may be reset and rebooted.

Ensure that coupled loads are secured, particularly if they are suspended loads.

In the upper area of the screen, you can configure the data to be transferred. It makes sense to use the predefined configuration settings for the tasks performed most frequently:

  • complete Drive Backup: Complete data set including tuning and motion task data; e.g., for an identical replacement device at the same location.
  • Transferable Backup: Data set without tuning or motion task data; this can be transferred to an amplifier with a different rated current, for example.

You can also decide for yourself which data you would like to save or load. To do this, make your selection from the components that are available. There are various preset enforced connections available for these components; these help you avoid undesirable incompatibilities.

Firmware | Servo amplifier operating system, see also download page File Selector (document type: Firmware)
PLC | Macro Programm, see also the KDN page Macro Programming
MDB | Motor database, see File Selector (document type: Motor Database)
Profil Tables | Customer-specific Profile Tables, see the KDN page Acceleration Profile Tables
Parameter | Parameter set for the control loops and motor/feedback settings.
Motion Tasks | Definition of the Motion Tasks
Cogging Table | Data for Cogging Compensation of the connected motor. This data is only valid for the servo amplifier/motor combination for which it was produced.
Offset Values | Offset data. This data is only valid for the servo amplifier/motor combination for which it was produced.
Safety Card Setting | Safety-related parameters of the Safety Card. This data is linked to the serial number of the installed safety card and cannot be used with other cards.

File extensions:

Backup Type | Extension
Firmware (FW), motor database (MDB), profile tables (PT) | *.FMP
Parameters and motion tasks | *.PAR
Motion tasks | *.MTS
Motor database | *.MDB
Macros (PLC) | *.PLC
Cogging table | *.COG
Transferable Backup (FW, PLC, MDB, PT) | *.TBK
Complete drive backup | *.DBK

Delete File

The window in the bottom area displays the files available on the memory card. You can delete files. To do this, select a file in the window and click on the “Delete” button.

Load

The “Load From SD Card” button is not enabled until at least one component has been selected. Click on the button to open a file selection window:

In this example, the MDB (motor database) component has been selected; however, the memory card does not contain any files with the extension “.MDB”.

In cases like this, open the selection list for the file type and select “*.all”. All available files on the card will now be displayed.

Select the required file and click OK.

The data is now loaded to the servo amplifier. If no data is displayed, make sure the card has been formatted with a FAT32 file type.

Save

The “Save To SD Card” button is not enabled until at least one component has been selected. Click on the button to open a Save As window:

In this example, the MDB (motor database) component has
been selected.

Enter a file name and click OK. The data is now saved to the memory card.

Used ASCII parameters

CARDINFO | CARDINFO, displays the rating plate of the memory card (FAT32)
CARDDIR | CARDDIR, displays the root directory of the memory card
CARDDEL | CARDDEL, deletes a file from the root directory of the memory card
CARDSAVE | CARDSAVE, displays the root directory of the memory card
CARDUPDATE | CARDUPDATE, loads a firmware/data component from the card to the flash memory of the amplifier.


ASCII English SDLY

ASCII - Command | SDLY |
Syntax Transmit | SDLY [Data] |
Syntax Receive | SDLY <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3757 (hex)
DIM | - | PROFIBUS PNU | 1799 (dec) IND = 17 (dec)
Range | 0 ... 100 000 | DPR | 599 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.31 |
Configuration | No | Last Change of this Object | 2.8
Function Group | drive configuration | EEPROM | Yes
Short Description | Start delay

Description

SDLY sets the start delay for the program execution.
After the boot up the RTO function and the supervisor program execution will be delayed for SDLY msec.

See also ERRCODE * F10


ASCII English SERCERR

ASCII - Command | SERCERR |
Syntax Transmit | SERCERR |
Syntax Receive | SERCERR <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 ... 8 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Wrong access to SERCOS command

Description

The command SERERR displays an error generated by an wrong access with the command SERCOS to an IDN.

See also object SERCOS.


ASCII English SERCLIST

ASCII - Command | SERCLIST |
Syntax Transmit | SERCLIST [Data] |
Syntax Receive | SERCLIST <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 ... 8 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Acess to IDN list Access to IDN List

Description

The command SERCLIST enables the access to an element of the IDN list. After that, the IDN can be read by command SERCOS. See also object SERCOS.


ASCII English SERCOFFS

ASCII - Command | SERCOFFS |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

SERCOS Expansion Card

This screen is avalable only if a SERCOS expansion card is inserted into the servo amplifier.

Sercos

Configuration of the SERCOS interface for proper communication with the master.

Set the cable length (max. 45m, important for optical power) and the baud rate (see installation manual of the servo amplifier).

If the optical power is not adjusted properly, there will be errors in the telegram transmission, and the red error LED on the drive lights. In normal communication, the green transmit and receive LEDs flash very fast, the LEDs seem constantly lit.

For further information for installing a SERCOS system, see the SERCOS documentation and our application notes available on our website.

Fiber Optic Cable Length
If the optical power is not adjusted properly, there will be errors in the telegram transmission. You can define the cable length (in meter) for a standard 1 mm² fiber optic cable.

0 m | Very short connection
1 m…< 15 m | Length of the connection with a 1 mm² plastic cable
15 m…<30 m | Length of the connection with a 1 mm² plastic cable
³ 30 m | Length of the connection with a 1 mm² plastic cable

Baud Rate
If the baud rate is not adjusted correctly, communication will not work. Adjust the baud rate in MBaude here.

Address
The actual amplifier address is indicated (Setup see CAN/Fieldbus).

Phase
The actual phase of the SERCOS transmission is indicated.

Cycle time
Actual cycle time is indicated.

Monitor IDN

No.
Enter an IDN here, which is then cyclically updated (example: to watch IDNP 3036 the number has to be 3036!). This is used as the internal “service channel”.

Value
The value of the monitored IDN. For IDNs that contain lists, only the list length is displayed.

Product SERCOS settings

Error if HW Limit Switch is signaled (IDNP 3015)
This function is used to set the behavior on reaching the hardware limit switch.

Faults which require a Coldstart will not clear (IDNP 3016)
This function can be used to prevent faults from being cleared when a reset command is given. This applies to faults that normally require a coldstart to clear.

Allow SW Enable before HW Enable (IDNP 3028)
Allows enable via SERCOS to be set before the hardware enable. Otherwise error F29 is generated.

Enable Acceleration Feedforward (IDNP 3052)
The feed forward gain calculated by the amplifier can be modified via the ASCII parameter GPFFT or IDN 348.

Standard SERCOS settings

Invert Position Command Value (IDN 55)
The position polarity parameter is used to switch the polarities of position data. The motor shaft turns clockwise when there is a positive position setpoint difference and no inversion.

Invert Position Feedback Value 1 (IDN 51)
This function can be used to invert the polarity of the internal actual-position value.

Invert Position Feedback Value 2 (IDN 53)
This function can be used to invert the polarity of the external actual-position value.

Enable Position Limit Values (IDN 55)
Activates the software limit switches. Always active for linear position scaling.

Invert Velocity Command Value (IDN 44)
This function can be used to invert the polarity of the speed setpoint. The motor axis turns clockwise if a positive speed setpoint is present without invert enabled.

Invert Velocity Feedback Value (IDN 43)
This function can be used to invert the polarity of the actual-speed value.

Enable Spline Interpolation (IDNP 3040)
Only when a cycle time of 500 µs is selected can spline interpolation be selected instead of linear interpolation. Modulo must not be active.

Scaling Method
Rotary or linear.

Standard Scaling Type
Default or parameter scaling.

Scaling Units
Units for selected scaling.

Data Reference
The data reference can be to the motor shaft (internal feedback) or to the load (external feedback).

Processing Format
Modulo format

Bus Parameters

Telegram Type Parameter
Selected telegram type

Primary Operation Mode
Position, speed or current control

Position Control Parameters

Motor Feedback
Feedback to be used

External Feedback
Feedback to be used

Following Error Monitoring
Select operational mode with (default) or no internal velocity feed forward

Input revolutions of load gear
Gear ratio IDN 121.

Output revolutions of load gear
Gear ratio IDN 122.

Feed constant
Feed with linear scaling

Rotational Position Resolution
Increments per revolution.

Resolution of Rotational Feedback 1
Resolution of external feedback.


ASCII English SERCOS

ASCII - Command | SERCOS |
Syntax Transmit | SERCOS [Data] |
Syntax Receive | SERCOS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 8 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Read the Data of an Sercos IDN

Description

Gives the contents of an Sercos IDN. Write access changes the selected number of the IDN, read access gives the contents of the selected IDN. If the selected IDN is a list, only the list value where SERCLIST points to is displayed. If SERCOS generates an error (e.g. wrong IDN number), SERCERR is set to "1" and a value of "0" is displayed.


ASCII English SERCSET

ASCII - Command | SERCSET |
Syntax Transmit | SERCSET [Data] |
Syntax Receive | SERCSET <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3691 (hex)
DIM | - | PROFIBUS PNU | 2001 (dec) IND = 1 (dec)
Range | Long Int | DPR | 401 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | No
Short Description | Set Sercos / EtherCAT Settings

Description

The object SERCSET gives the possiblity to change some of the Sercos or EtherCAT settings. Changes have to be saved in the EEPROM and effect at the next start-up of the drive. The not described bits effect other Sercos settings. In so far, this command should only be used in combination with the MMI. See also Sercos IDN Manual.

Attention: If the fieldbus is switched, the unuesed bits have to be erased!

By using EtherCAT fieldbus, the meaning of the bits is as follows:
Bit 0-15: reserve
Bit 16 (0x0001 0000) = 1: Bootstrap over master activate a coldstart of the amplifier
Bit 17 (0x0002 0000) = 1: no monitoring of warning n17

Bit 18 (0x0004 0000) = 0: If bit 17 is set, 10 telegrams must neglect before synchronization is lost. This monitoring is only active in the status "operational".
Bit 18 (0x0004 0000) = 1: no EtherCAT interrupts are monitored

Bit 19 (0x0008 0000) = 1: in fault state - during reset a coldstart is executet - F29 will be set
Bit 20 (0x0010 0000) = 1: actual values will be written in 250 ms instead of interrupt (faster)
Bit 21 (0x0020 0000) = 1: Bit 5 in statusword will be updatet at source of the quickstop as well (so hardware- and software limit switch)
Bit 22-31: reserve

By using SERCOS fieldbus, the meaning of the bits is as follows:
Bit | Significane | Meaning
0 | 0x0000 0001 | = 1: IDN 3015 Hardware Limit Switch Effect
1 | 0x0000 0002 | = 1: IDN 3016 CLRFAULT Command Effect
2 | 0x0000 0004 | = 1: IDN 3028 switch on procedure HW & SW - Enable
3 | 0x0000 0008 | = 1: IDN 3052 acceleration feed forward
4-11 | 0x0000 0FF0 | = 1: IDN 55 polarity Target Position, Bit 8 Hardware Limit Switch
12-15 | 0x0000 F000 | =1: IDN 43 polarity Target Speed
16 | 0x0001 0000 | = 1: SLEN binary
17 | 0x0002 0000 | = 1: MST Check für DMS
18 | 0x0004 0000 | = 1: IDN 3059 external feed forward only current
19 | 0x0008 0000 | = 1: IDN 3059 external feed forward speed and current
20 | 0x0010 0000 | = 1: IDN 3040 quadrature interpolation
21 | 0x0020 0000 | = 1: Control of OPMODE switched off (FW 3.55)
22 | 0x0040 0000 | reserve
23 | 0x0080 0000 | = 1: Switches Bit 3 in the AT-Status off
24-31 | 0xFF00 0000 | = 1: IDN 76


ASCII English SERIALNO

ASCII - Command | SERIALNO |
Syntax Transmit | SERIALNO |
Syntax Receive | SERIALNO <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35EF (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 1 (dec)
Range | 10 ASCII characters | DPR | 239 (dec)
Default | Factory default |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Drive Serial Number

Description

Serial number of drive amplifier.


ASCII English SETENCOFFS

ASCII - Command | SETENCOFFS |
Syntax Transmit | SETENCOFFS [param1] [param2] [param3] |
Syntax Receive | - | Available in |
Type | Command | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | -2147483648 .. 2147483647 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Interger32
Drive State | - | Weighting |
Start Firmware | 5.86 |
Configuration | No | Last Change of this Object | 2.12
Function Group | Feedback | EEPROM | No
Short Description | function for zero offset

Description

The function SETENCOFFS supports the zero offset for the encoder systems HIPERFACE (Sick Stegmann) and ENDAT 2.1 & 2.2 (Heidenhain).

HIPERFACE:
There are two parameters when required. The position value and the hardware password. It runs the "Set position" HIPERFACE own command (0x43). For details, see the manufacturer-specific documentation.

EnDAT:
It will require up to three parameters when calling. The number of parameters depends on the type of function execution. The following function calls are supported:

1. mode of zero offset
0 - back to the delivery status
1 - electronic zeroing
2 - to a certain position
3 - to a certain value

2. type of zero offset (required only type 2 & 3)

3. HW password: For details, see the manufacturer-specific documentation (D722024-03-A-01 / Pkt.10 EnDAT zero offset).


ASCII English SETREF

ASCII - Command | SETREF |
Syntax Transmit | SETREF |
Syntax Receive | SETREF | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 35F0 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 1 (dec)
Range | - | DPR | 240 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Set Reference Point

Description

The SETREF command is used to declare the present position as the reference point (i.e. the actual position is set to the value of ROFFS) and to set the bit that permits the execution of motion blocks.
The SETREF command corresponds to the execution of a homing to a reference with NREF=0.


ASCII English Shortform

\ | Selection of remote address
ACC | Acceleration ramp
ACC_X | acceleration ramp velocity controller 2. Set
ACCR | Acceleration ramp for homing/jog modes
ACCUNIT | Type of acceleration setpoint for the system
ACTFAULT | Active fault mode
ACTIVE | Output stage active/inhibited
ACTRS232 | Activate RS232 watchdog
ADC0_15 | internal offset values
ADDR | Multidrop address
AENA | Software auto-enable
ALIAS | Drive name
AN11NR | No. of INxTRIG variable, that is changed analog
AN11RANGE | Range of the analog change of INxTRIG
AN1TRIG | Scaling of the analog output 1
AN2TRIG | Scaling of the analog output 2
ANCNFG | Configuration of analog input
ANDB | Dead band of the analog velocity input signal
ANHFACT1 | internal parameter
ANHFACT2 | internal parameter
ANIN1 | Voltage at analog input 1
ANIN2 | Voltage at analog input 2
ANIN3 | Voltage at analog input 3 (POS I/O)
ANIN4 | Voltage at analog input 4
ANOFF1 | Analog offset for analog input 1
ANOFF2 | Analog offset for analog input 2
ANOFF3 | Analog offset for analog input 3 (POS I/O)
ANOFF4 | Analog offset for analog input 4 (POS I/O)
ANOUT1 | Configuration of the Analog Output 1
ANOUT2 | Configuration of the Analog Output 2
ANZERO1 | Zero analog input 1
ANZERO2 | Zero analog input 2
ANZERO3 | Zero analog input 3 (POS I/O)
ANZERO4 | Zero analog input 4 (POS I/O)
ARHPD | Damping high pass filter
ARHPF | Frequency limit high pass filter
ARLP2 | Low pass filter
ARLPD | Damping low pass filter
ARLPF | Frequency limit low pass filter
ASMWAIT | Forced delay of the velocity command value for induction machines
AUTOHOME | Automatic homing
AVZ1 | Filter time constant for analog input 1
AVZ2 | Filter time constant for analog input 2
BCC | EEPROM check sum
BCCOT | EEPROM check sum without life time counter
BISSCNFG | configuration parameter for BiSS-C
BISSREVOL | Number of multiturn bits for a BISS-C encoder
BQMODE | Filter selection
BTIME | Discharge time of the DC link at INxMODE 62
BUILDRK | calculation of RK
BUILDRP | internal parameter
BUSP0 | fieldbus configurationsvariable
BUSP1 | fieldbus configurationsvariable (CAN or Sercos)
BUSP10 | debug fieldbus variable for EtherCAT
BUSP11 | debug fieldbus variable for EtherCAT
BUSP12 | fieldbus configurationsvariable
BUSP13 | fieldbus configurationsvariable
BUSP14 | fieldbus configurationsvariable
BUSP15 | fieldbus configurationsvariable
BUSP16 | fieldbus configurationsvariable
BUSP2 | fieldbus configurationsvariable
BUSP3 | fieldbus configurationsvariable
BUSP4 | fieldbus configurationsvariable
BUSP5 | fieldbus configurationsvariable
BUSP6 | fieldbus configurationsvariable
BUSP7 | fieldbus configurationsvariable
BUSP8 | fieldbus configurationsvariable
BUSP9 | debug fieldbus variable for EtherCAT
CALCCOG | Generate lookup table for cogging compensation
CALCHP | Determining the Hiperface/ENDAT parameters
CALCMP | Cycles for commutation alignment by PID control loop
CALCPOSIO | Initialisation of the POS I/O card
CALCRK | Calculate resolver parameters
CALCRP | Calculate resolver phase
CANDUMP | List with CANopen communication parameter
CANSDO | Access to a CAN Service Data Object
CARDDEL | deletes a file from the root diretory
CARDDIR | display of the root directory
CARDINFO | information about the SD card
CARDSAVE | save data from the drive to the SD memory card
CARDUPDATE | load data from the SD memory card to the drive
CBAUD | Baud Rate CAN Bus
CCSAVE | Save / reset CANopen communication parameter
CINPOS | Current “In Position” or “Target reached” message
CLRFAULT | Clear drive fault
CLRHR | Bit 5 of status register STAT is cleared
CLRORDER | Deleting a Motion Task
CLRWARN | Warning mode
CMDDLY | Command delay time for RS232
COGFILT | Bandwidth factor for cogging-compensation filter
COGMODE | Cogging-compensation mode
COGRED | Factor for GV reduction during cogging measurement
COLDSTART | Drive reset
CONTINUE | Continue last position order
CPHASE | configuration of fault monitoring
CSCNFG | Configuration Variable for safety card
CSENID | reactive current impression
CSERR | Actual error values of the safety card
CSIDMAX | Maximum value for reactive current command
CSIOSTAT | Input and output states of the safety card
CSSTAT | Status information of safety card
CTUNE | Calculate current parameters
CUPDATE | Program update (CAN bus)
DAOFFSET1 | Analog Offset Output 1
DAOFFSET2 | Analog Offset Output 2
DEC | Deceleration rate
DEC_X | Deceleration ramp velocity controller 2. Set
DECDIS | Deceleration used on disable output stage
DECR | Deceleration ramp for homing/jog modes
DECSTOP | Quick stop – braking ramp for emergency situations
DENA | DPR software disable reset mode
DI2T | Drive I2T load
DICONT | Drive continuous current
DIFVAR | List variables with values
DILIM | DPR current limit
DIPEAK | Drive peak rated current
DIR | Direction of different actuall values
DIRIN | polarity of the digital inputs
DIROUT | polarity of the digital outputs
DIS | Software-Disable
DISDPR | Disable DPR access
DNBAUD | DeviceNet baud rate
DNDUMP | Debugging information DeviceNet
DNMACID | MACID (Adress) for DeviceNet card
DOVRIDE | Digital override factor
DPRILIMIT | Digital Limiting of the peak Current via DPR
DPRSTATE | DPR state
DPRVAR1_16 | macro temp variable
DPV17_64 | variable for macro or PLC program
DPWM | PWM/current loop/position loop configuration
DR_TYPE | Gives the Output Stage Indentification
DREF | Direction for Homing
DRIVE | type of the servo drive (drive family
DRVCNFG | Configuration parameter for additional drive functionality
DRVCNFG2 | Configuration parameter for additional drive functionality
DRVCNFG3 | Configuration parameter for additional drive functionality
DRVCNFG4 | Configuration parameter for additional drive functionality
DRVSTAT | internal Status information
DRVSTAT2 | internal status information
DUMP | List All EEPROM Variables with Values
DUMPEMAP | Control of the free mapping of EtherCat
DUMPSLNO | Listing of the numerical EEProm-parameters
ECATCSA | holds the Configured Station Alias address
EGEARI | Ratio external feedback
EGEARO | Ratio external feedback
EMRGTO | defines the emergency time out
EN | Software-Enable
EN22A1CNT | Endat 2.2 status of additional information 1
EN22A2CNT | Endat 2.2 Status of additional information 2
EN22AI1 | Endat 2.2 act. values of additional information 1
EN22AI2 | Endat 2.2 act. values of additional information 2
EN22CNFG | Config.parameter for ENDAT 2.2 additional information
EN22DCNT | Endat 2.2 status of the diagnostic information
EN22DIAG | Endat 2.2 actual values of the diagnostic information
ENCDIV | Divisor for the decimal places of ENCLINES
ENCDIVD | Divisor for the decimal places of ENCIN
ENCFIX | Decimal places for the ENCLINES parameter
ENCFIXD | Decimal places for the ENCIN parameter
ENCIN | digital feedback resolution
ENCLINES | SinCos Encoder Resolution
ENCMODE | Selection of Encoder Emulation
ENCOUT | Resolution Encoder Emulation (ROD)
ENCTO | Encoder supply delay
ENCVON | power supply for the external encoder (connector X1
ENCZERO | Zero Pulse Offset EEO (ROD)
ENGAGE | Master -slave switch on / off
ERESMASK | Failure reset setting
ERND | End position of modulo axes
ERRCNFG | behavior of the drive in the case of error
ERRCODE | Activated Fault Messages
ERRCODE * | Output Error Register
ERRCODE2 | Additional error code info
ERRMASK | mask for activate the error timer
ERRPARAM | Objectnumber of the incorrect parameter (warning n24)
ERRTIME | Error handling delay time
ESPEED | Maximum velocity corresponding to the Feedback Type
ETHMODE | Select on-board field bus interface
EWH | consumed electric energy in watt-hours
EXTBRAKE | software brake on/off software configuration
EXTLATCH | Selection of the Source of the Latch Inputs
EXTPOS | Position Value For Position Control
EXTWD | External Watch Dog (Fieldbus)
FBGEARI | compensation facor motor/gearing
FBGEARO | compensation facor motor/gearing
FBTYPE | Selection of commutation feedback
FBTYPEX | Display of the actual feedback
FFTSW | Current feed forward configuration
FHKP | internal parameter
FHTN | internal parameter
FILTMODE | Smith Predictor
FLTCNT | Fault Frequency
FLTCNT * | Fault Frequency
FLTHIST | Fault History: Display last 10 faults
FLTHIST * | Fault History: Display last 10 faults
FW | Displays the Version Number of the Firmware
GEARFILT | second order low pass filter (OPMODE=4)
GEARI | Input Factor for Electronic Gearing
GEARMODE | Position Input Electronic Gearing Mode
GEARO | Output Factor for Electronic Gearing
GET | Scope: output data
GF | proportional gain of the flux controller
GFTN | time constant flow controlinduction maschine)
GP | Position Control Loop: Proportional Gain
GP_X | Position Control Loop: Proportional Gain 2
GP2 | proportional gain for the velocity higher than GPS2
GPDELAY | delay for external position set point
GPFFT | Position control loop: feed forward for the current setpoint
GPFFT_X | Position control loop: feed forward for the current setpoint 2
GPFFTV | Viscous friction compensation
GPFFV | Position Control Loop: Feed Forward for Velocity
GPFFV_X | Position Control Loop: Feed Forward for Velocity 2
GPFFVDELAY | internal parameter
GPS1 | low velocity threshold (position loop)
GPS2 | high velocity threshold (position loop)
GPTN | integral gain of the PI position loop
GPTN_X | integral gain of the PI position loop
GPTNTH1 | integral part threshold for velocity set point
GPTNTH2 | integral part threshold for velocity actual value
GPTNTH3 | integral part threshold for following error
GU | proportinal gain for field weakening
GUTN | time constant of field weakening
GV | Velocity Control Loop: Proportional Gain
GV_X | Velocity Control Loop: Proportional Gain 2
GV2 | proportional gain for the velocity higher than GVS2
GVFR | PI-PLUS Actual Velocity Feedforward
GVFR_X | PI-PLUS Actual Velocity Feedforward
GVS1 | low velocity threshold (velocity loop)
GVS2 | high velocity threshold (velocity loop)
GVTN | Velocity Control Loop: I-Integration Time
GVTN_X | Velocity Control Loop: I-Integration Time 2
GVTV | preservation time of the volume flow controller
HALLDIR | Hall segment table number
HALLENDIR | internal parameter
HDSLLED | LED current of the optical unit in Hiperface DSL encoder
HDSLPOS | position read from the Hiperface DSL encoder
HDSLRANGE | Hiperface DSL encoder limits
HDSLROTAT | Total number of detected encoder revolutions
HDSLTEMP | Motor / Encoder temp. from the Hiperface DSL encoder Motor / Encoder temperature from the Hiperface DSL encoder
HDSLTIME | counter of operating hours of the Hiperface DSL encoder
HDSLTYPE | Hiperface DSL encoder data (nameplate)
HDSLVEL | actual velocity of the Hiperface DSL encoder
HDSLVOLT | supply voltage of the Hiperface DSL encoder
HDUMP | Output all sin/cos (Hiperface) variables
HELP | Output Parameter Help Information
HICOFFS | Hiperface: Cosine-Offset (incremental track)
HIFACT1 | Hiperface: Sin/Cos Gain Factor (incremental track)
HISOFFS | Hiperface: Sin/Cos Offset (incremental track)
HLIMIT1 | Software limit switch 1 for homing move
HLIMIT2 | Software limit switch 2 for homing move
HLIMIT3 | Software limit switch 3 for homing move
HSAVE | Hiperface: Save Parameters in Encoder
HVER | Output the Hardware Version
HWCNT | internal parameter
I | Current Monitor
I2TLIM | I2T Warning
ICMD | Current Setpoint
ICMDVLIM | Velocity Limit in Current Control
ID | D-component of Current Monitor
IDDUMP | outputs the list of the object (parameter) numbers
IEXTT | Weight compensation
IEXTTLIM | support the vertical axis support the vertical axis
IN | List Analog Voltage Values
IN1 | Status of Digital Input 1
IN10 | Status of Digital Input
IN10MODE | Function of digital input
IN10TRIG | Variable for digital input
IN11 | Status of Digital Input
IN11MODE | Function of digital input
IN11TRIG | Variable for digital input
IN12 | Status of Digital Input
IN12MODE | Function of digital input
IN12TRIG | Variable for digital input
IN13 | Status of Digital Input
IN13MODE | Function of digital input
IN13TRIG | Variable for digital input
IN14 | Status of Digital Input
IN14MODE | Function of digital input
IN14TRIG | Variable for digital input
IN15 | Status of Digital Input
IN15MODE | Function of digital input
IN15TRIG | Variable for digital input
IN16 | Status of Digital Input
IN16MODE | Function of digital input
IN16TRIG | Variable for digital input
IN17 | Status of Digital Input
IN17MODE | Function of digital input
IN17TRIG | Variable for digital input
IN18 | Status of Digital Input
IN18MODE | Function of digital input
IN18TRIG | Variable for digital input
IN19 | Status of Digital Input
IN19HCMD | Command buffer for high level
IN19LCMD | Command buffer for low level
IN19MODE | Function of digital input
IN19TRIG | Variable for digital input
IN1HCMD | Command buffer for high level
IN1LCMD | Command buffer for low level
IN1MODE | Function of Digital Input 1
IN1TRIG | Variable for IN1MODE
IN2 | Status of Digital Input 2
IN20 | Status of digital input
IN20HCMD | Command buffer for high level
IN20LCMD | Command buffer for low level
IN20MODE | Function of digital input
IN20TRIG | Variable for digital input
IN21MODE | Function of digital input
IN21TRIG | Variable for digital input
IN22MODE | Function of digital input
IN22TRIG | Variable for digital input
IN2HCMD | Command buffer for high level
IN2LCMD | Command buffer for low level
IN2MODE | Function of Digital Input 2
IN2PM | state of the digital input
IN2TRIG | Variable for IN2MODE
IN3 | Status of Digital Input 3
IN3HCMD | Command buffer for high level
IN3LCMD | Command buffer for low level
IN3MODE | Function of Digital Input 3
IN3TRIG | Variable for IN3MODE
IN4 | Status of Digital Input 4.
IN4HCMD | Command buffer for high level
IN4LCMD | Command buffer for low level
IN4MODE | Function of Digital Input 4
IN4TRIG | Variable for IN4MODE
IN5 | Status of digital input
IN5_22 | Status of digital inputs 5 ... 22
IN5_22MODE | Function of digital inputs 5 ...22
IN5_22TRIG | Variable for digital inputs 5 ... 22
IN5MODE | Function of digital input
IN5TRIG | Variable for digital input
IN6 | Status of digital input
IN6MODE | Function of digital input
IN6TRIG | Variable for digital input
IN7 | Status of digital input
IN7MODE | Function of digital input
IN7TRIG | Variable for digital input
IN8 | Status of digital input
IN8MODE | Function of digital input
IN8TRIG | Variable for digital input
IN9 | Status of digital input
IN9MODE | Function of digital input
IN9TRIG | Variable for digital input
INPOS | Status of In-Position Signal
INPT0 | In-Position Delay
INPT1 | delay time for the “IN POSITION”
INTERPOL | Type of Interpolation in OPMODE 5 and 6
IOLINK | connection between a digital out- and input
IPEAK | Application Peak Current
IPEAKN | negative motor peak rms current
IPEAKP | positive motor peak rms current
IQ | Q-Component of Current Monitor
IQFILTK | Gain factor for slip compensation. Used in V/f Control
IQFILTTAU | Low-pass filter time constant for slip compensation
ISCALE1 | Scaling of Analog Current Setpoint 1
ISCALE2 | Scaling of Analog Current Setpoint 2
ISTFR | Current Limit for velocity-dependent friction compensation
IVTICK | internal parameter
J | Service Function: Constant Velocity
JRATIO | internal parameter
K | Kill (=Disable)
KC | I-Controller Prediction Constant
KC_X | I-Controller Prediction Constant 2
KEYLOCK | Locks the push buttons
KTN | Current Controller Integral-Action Time
KTN_X | Current Controller Integral-Action Time 2
LASTWMASK | Fault history of WMASK
LATCH1N16 | Latched 16-bit Position (negative edge)
LATCH1N32 | Latched 32-bit Position (negative edge)
LATCH1P16 | Latched 16-bit Position (positive edge)
LATCH1P32 | Latched 32-bit Position (positive edge)
LATCH2N16 | Latched 16-bit Position (negative edge)
LATCH2N32 | Latched 32-bit Position (negative edge)
LATCH2P16 | Latched 16-bit Position (positive edge)
LATCH2P32 | Latched 32-bit Position (positive edge)
LDUMP | Parameter Output of Motor Data
LED1 | State of Display 1 Segment
LED2 | State of Display 2 Segment
LED3 | State of Display 3 Segment
LEDSTAT | Display page
LINRESOL | Conversion factor for linear measurement systems
LIST | List All ASCII Commands
LOAD | Load parameters from serial EEPROM
M | Read/write Macro Variable
M_RESET | Recompile Macro Programs
MAXCMD | max. number of DPR variables
MAXISETP | limitation of the integral part of the position loop
MAXSUMME | internal parameter
MAXTEMPE | Ambient Temperature Switch off Threshold
MAXTEMPH | Heat Sink Temperature Switch off Threshold
MAXTEMPM | Motor Temperature Switch off Threshold
MAXVSETP | Limitation of the proportional part of the position loop
MBPDRVSTAT | State of the Modbus+ Network
MBRAKE | Select Motor Holding Brake
MCFW | The Correction Factor of the Field Weakening
MCOSPHI | Power Factor (cos phi) of the induction motor
MCTR | internal parameter
MDBCNT | Number of Motor Data Sets
MDBGET | Get Actual Motor Data Set
MDBLIST | List of Motor Data Sets
MDBSET | Set Actual Motor Data Set
MDRV | selection of multidrive functionality
MFR | Rated frequency of the induction motor
MH | Start Homing
MI2T | Motor I2T load
MICONT | Motor Continuous Current Rating
MICONT_X | Motor Continuous Current Rating
MIMR | current command D-part
MIMRQ | internal parameter
MINSUMME | internal parameter
MIPEAK | Motor Peak Current Rating
MIPEAK_X | Motor Peak Current Rating
MJ | Motor inertia
MJ_X | Motor inertia 2
MJOG | Start Jog Mode
MKT | Motor KT
MKT_X | Motor KT
ML | Stator Inductance of the Motor
ML_X | Stator Inductance of the Motor
MLGC | Current Control loop Adaptive Gain (Q-component at rated current)
MLGC_X | Current Control loop Adaptive Gain (Q-component at rated current)
MLGD | Adaptive Gain for Current Control loop, D-component
MLGD_X | Adaptive Gain for Current Control loop, D-component
MLGP | Current Control loop Adaptive Gain (Q-component at peak current)
MLGP_X | Current Control loop Adaptive Gain (Q-component at peak current)
MLGQ | Absolute Gain of Current Control loop
MLGQ_X | Absolute Gain of Current Control loop
MNAME | Motor Name
MNUMBER | Motor Number
MONITOR1 | Monitor 1 Output voltage
MONITOR2 | Monitor 2 Output voltage
MOVE | Start Motion Task
MPHASE | Motor Phase, Feedback Offset
MPHASE2 | Commutationfineadjustment
MPITCH | pole pair pitch for linear motor
MPKD | D-Term for the commutation alignment PID position loop
MPKI | I-Integration Time for the commutation alignment PID position loop (CALCMP)
MPKP | Proportional gain for the commutation alignment PID position loop (CALCMP)
MPOLES | Number of Motor Poles
MPOLES_X | Number of Motor Poles
MPR | Rated output power of the motor
MPTIME | Alignment time for the commutation alignment PID position loop (CALCMP)
MRESBW | Resolver Bandwidth
MRESPOLES | Number of Resolver Poles (Multispeed)
MRS | Winding Resistance of the Stator Phase-Phase
MRS_X | Winding Resistance of the Stator Phase-Phase
MSERIALNO | Serial no of the motor for encoder feedback
MSG | Enable / Disable All Messages via RS232
MSLBRAKE | DEC ramp at sensorless emergency stop
MSPEED | Maximum Rated Motor Velocity
MTAB | Enter the KTY characteristics
MTANGLP | Current Lead
MTIME | Motor thermal time constant
MTIME_X | Motor thermal time constant
MTMUX | Presetting for motion task that is processed later
MTR | Rotor time constant
MTYPE | Motor Type
MUR | rated voltage of the induction machin
MVANGLB | Velocity-dependent Lead (Start Phi)
MVANGLF | Velocity-dependent Lead (Limit Phi)
MVANGLMODE | SR600 kompat. mode for speed dependend phase lead
MVANGLP | Velocity-dependent Lead (Commutation Angle)
MVER | Version of the motor data base
MVR | Nominal speed of asynchron motor
NONBTB | Mains-BTB Check On/Off
NREF | Homing Mode
NREFG | internal parameter
NREFMT | Homing wih following motion task
O_ACC | Acceleration Time 1 for Motion Task 0
O_C | Control Variable for Motion Task 0
O_DEC | Braking Time 1 for Motion Task 0
O_FN | Next Task Number for Motion Task 0
O_FT | Delay before Next Motion Task
O_P | Target Position/Path for Motion Task 0
O_TAB | select acceleration profile table
O_V | Target Speed for Motion Task 0
O1 | State of Digital Output 1
O10 | State of digital output 10
O10MODE | Function of digital output 10
O10TRIG | Auxiliary Variable for digital output 10
O11 | State of digital output 11
O11MODE | Function of digital output 11
O11TRIG | Auxiliary Variable for digital output 11
O12 | State of digital output 12
O12MODE | Function of digital output 12
O12TRIG | Auxiliary Variable for digital output 12
O13 | State of digital output 13
O13MODE | Function of digital output 13
O13TRIG | Auxiliary Variable for digital output 13
O14 | State of digital output 14
O14MODE | Function of digital output 14
O14TRIG | Auxiliary Variable for digital output 14
O15 | State of digital output 15
O15MODE | Function of digital output 15
O15TRIG | Auxiliary Variable for digital output 15
O16 | State of digital output 16
O16MODE | Function of digital output 16
O16TRIG | Auxiliary Variable for digital output 16
O17 | State of digital output 17
O17MODE | Function of digital output 17
O17TRIG | Auxiliary Variable for digital output 17
O18 | State of digital output 18
O18MODE | Function of digital output 18
O18TRIG | Auxiliary Variable for digital output 18
O1MODE | Function of Digital Output 1
O1TRIG | Auxiliary Variable for O1MODE
O2 | State of Digital Output 2
O2MODE | Function of Digital Output 2
O2TRIG | Auxiliary Variable for O2MODE
O3 | State of digital output 3
O3_18 | State of Digital Output 3 to 18
O3_18MODE | Function of Digital Outputs 3 to 18
O3_18TRIG | Auxiliary Variable for OxMODE
O3MODE | Function of digital output 3
O3TRIG | Auxiliary Variable for digital output 3
O4 | State of digital output 4
O4MODE | Function of digital output 4
O4TRIG | Auxiliary Variable for digital output 4
O5 | State of digital output 5
O5MODE | Function of digital output 5
O5TRIG | Auxiliary Variable for digital output 5
O6 | State of digital output 6
O6MODE | Function of digital output 6
O6TRIG | Auxiliary Variable for digital output 6
O7 | State of digital output 7
O7MODE | Function of digital output 7
O7TRIG | Auxiliary Variable for digital output 7
O8 | State of digital output 8
O8MODE | Function of digital output 8
O8TRIG | Auxiliary Variable for digital output 8
O9 | State of digital output 9
O9MODE | Function of digital output 9
O9TRIG | Auxiliary Variable for digital output 9
OCOPY | Save/copy Motion Tasks
OLIST | List of Motion Task Data
OPMODE | Operating Mode
OPTION | Option Slot ID
OPTION2 | Option Slot ID
ORDER | Set Motion Task Parameters
OTUNE | optimizing function VLO parameter
OVRIDE | Override Function for Motion Tasks
P | calculated active power (electrical)
P1 | Fast Position Register
P1_P16 | Fast Position Register 1 ... 16
P10 | Fast Position Register
P11 | Fast Position Register
P12 | Fast Position Register
P13 | Fast Position Register
P14 | Fast Position Register
P15 | Fast Position Register
P16 | Fast Position Register
P2 | Fast Position Register
P3 | Fast Position Register
P4 | Fast Position Register
P5 | Fast Position Register
P6 | Fast Position Register
P7 | Fast Position Register
P8 | Fast Position Register
P9 | Fast Position Register
PARCNFG | Configuration of parameter sets switching functions
PARDUMP | List of switchable parameter sets
PARRST | second parameter set = main parameter set
PASS | Password Input
PASSCNFG | Password Function
PASSPLC | Password value for PLC commands
PASSX | activate password function
PASSXPLC | Password configuration for PLC commands
PBAL | Actual Regen Power
PBALMAX | Maximum Regen Power
PBALRES | Select Regen Resistor
PBAUD | Profibus Baud Rate
PE | Actual Following Error
PEINPOS | In-Position Window
PEMAX | Max. Following Error
PFB | Actual Position from Feedback Device
PFB0 | Position from External Encoder
PFBHI | returns the lower 32 bit of the 64 bit position
PFBLO | returns the lower 32 bit of the 64 bit position
PGEARI | Position Resolution (Numerator)
PGEARO | Position Resolution (Denominator)
PIOBUF | Profibus data
PLLCOFFS | PLL counter outside of the synchronization window
PLLDOFFS | move of synchronization routine
PLLHUB | fieldbus synchronization ratio
PLLWOFFS | increase of the window for synchronization
PMECH | estimated mechanical power deliverd by the motor
PMODE | Line Phase Mode
PNOID | PROFIBUS ID
POSCNFG | Axes Type
POSRSTAT | Status of Fast Position Registers 1 ... 16
PPOTYP | Profibus PPO Type
PRBASE | Position Resolution
PRD | 20-bit Position Feedback
PRIOR1 | internal parameter
PRIOR2 | internal parameter
PRIOR3 | internal parameter
PRIOR4 | internal parameter
PRIOR5 | internal parameter
PROMPT | Select RS232 Protocol
PSINUS | sinus service-function
PSTATE | Profibus Status
PSTEP | Service Operation (PSTEP Command)
PTARGET | Last Target Position
PTARGOFFS | Motion tasks position target shift
PTBASE | Time base for the external trajectory
PTMIN | Min. Acceleration Ramp for Motion Tasks
PUNIT | Set Resolution of the Position
PV | Actual Velocity (Position Control Loop)
PVMAX | Max. Velocity for Position Control
PVMAXN | Max. (Negative) Velocity for Position Control
PVMAXP | Max. (positive) Velocity for Position Control
QCNFG | Configuration variable of the servo punp
QENA | enable of servo pump function
QFACT | volume-flow actual value (without filter)
QFACTCOMP | volume-flow actual value (after compensation)
QFACTFILT | Filtered setpoint for the volume flow
QFACTOR | swallowing volume
QFCFACT | current efficiency factor (volume)
QFCMD | volume-flow setpoint
QFCMDFILT | filtered setpoint for the volume flow
QFMAX | max setpoint for the volume flow
QFSET | Filtered setpoint for the volume flow
QKPEFF | Regulator parameter adaption: active KP value
QMACT | Current actual torque
QMCMD | current torque setpoint
QMCMDLIM | Current torque setpoint hind the limitation
QMLIMN | Torque limitation for pressure release
QMLIMP | Torque limitation for pressure build-up
QPE | current pressure-regulator deviation
QPRACT | actual pressure value
QPRMAX | max pressure setpoint
QPRSET | actual pressure setpoint
QPRSETEFF | actual pressure setpoint (effective)
QT1 | constant for the volume-flow setpoint filter
QTAB1KP | Regulator parameter adaption: KP – amplification for QTAB1V
QTAB1TN | Regulator parameter adaption: TN – reset time for QTAB1V
QTAB1TV | Regulator parameter adaption: TV – hold-back time for QTAB1V
QTAB1V | Regulator parameter adaption: Speed 1
QTAB2KP | Regulator parameter adaption: KP – amplification for QTAB2V
QTAB2TN | Regulator parameter adaption: TN – reset time for QTAB2V
QTAB2TV | Regulator parameter adaption: TV – hold-back time for QTAB2V
QTAB2V | Regulator parameter adaption: Speed 2
QTAB3KP | Regulator parameter adaption: KP – amplification for QTAB3V
QTAB3TN | Regulator parameter adaption: TN – reset time for QTAB3V
QTAB3TV | Regulator parameter adaption: TV – hold-back time for QTAB3V
QTAB3V | Regulator parameter adaption: Speed 3
QTAB4KP | Regulator parameter adaption: KP – amplification for QTAB4V
QTAB4TN | Regulator parameter adaption: TN – reset time for QTAB4V
QTAB4TV | Regulator parameter adaption: TV – hold-back time for QTAB4V
QTAB4V | Regulator parameter adaption: Speed 4
QTAB5KP | Regulator parameter adaption: KP – amplification for QTAB5V
QTAB5TN | Regulator parameter adaption: TN – reset time for QTAB5V
QTAB5TV | Regulator parameter adaption: TV – hold-back time for QTAB5V
QTAB5V | Regulator parameter adaption: Speed 5
QTABID | Regulator parameter adaption: Current parameter index
QTIMEKD | time constant of the D-section of the pressure flow regulator
QTNEFF | Regulator parameter adaption: active TN value
QTVEFF | Regulator parameter adaption: active TV value
QVAL | internal Parameter
QVT1 | smoothing time actual value
RDP | RDP operation modes
RDPBIAS | RDP bias current
RDPBIAS2 | internal parameter
RDPCLAMP | maximum output of equalization circuit
RDPINT | integral value of the RDP equalization circuit
RDPKI | integral gain of equalization circuit
RDPKP | proportional gain of equalization circuit
RDPON | RDP state
READY | Status of the Software Enable
RECDONE | Scope: Recording Done
RECING | Scope: Recording in Progress
RECOFF | Scope: Cancel Scope Recording
RECORD | Scope: Capture Data for Recording
RECRDY | Scope: Status of RECORD Function
RECTRIG | Scope: Activate Recording Function
REFIP | Peak Rated Current for Homing 7
REFIP2 | Peak Rated Current for Commutation process
REFLS | Effect HW-limitswitches by homing
REFMODE | Source of the Zero Pulse in Homing Mode
REFNOFFS | position of analog zero puls
REFNPOS | external zero pulse offset inside sine/c0sine cycle
REFPOS | Reference Switch Position
RELTIME | switching on of the thyristor voltage control
REMOTE | Status of the Hardware Enable
RESAMPL | Resolver cable break supervision
RESOLVER | Resolver excitation gain adjust +/- 20%
RESPHASE | Resolver Phase
RK | Gain Adjust for Resolver Sine Signal
ROFFS | Reference Offset
ROFFSABS | Reference Offset
ROFFSSSI | SSI absolute position offset
RS232T | RS232 Watch Dog
RSTVAR | Restore Variables (Default Values)
RSVERROFF | Resolver error supervision off
RUNIN | internal parameter
S | Stop Motor and Disable Drive
S1DLY | switch-on delay
SAVE | Save Data in EEPROM
SBAUD | Sercos: Baud Rate
SCAN | Detect CAN Stations
SDLY | Start delay
SERCERR | Wrong access to SERCOS command
SERCLIST | Acess to IDN list Access to IDN List
SERCOFFS | internal parameter
SERCOS | Read the Data of an Sercos IDN
SERCSET | Set Sercos / EtherCAT Settings
SERIALNO | Drive Serial Number
SETENCOFFS | function for zero offset
SETREF | Set Reference Point
SKIP1SP | Skip Speed 1
SKIP1W | Skip Width 1
SKIP2SP | Skip Speed 2
SKIP2W | Skip Width 2
SLACCMAX | slopes in sensorless mode
SLEN | Sercos Optical Range
SLIDK01 | factor (weight) for Ud
SLIMAX | internal parameter
SLIQK | factor (weight) for load-current iq
SLIQK1 | second factor (weight) for “load-current"
SLJSWITCH | threshold from stepper to sensorless mode
SLMODE | stepper mode for sensorless
SLOTIO | I/O-Expansion Card: I/O States
SLTEMPM | monitoring of the motor temperature
SLTSWITCH | transition time to nominal speed
SMNUMBER | Stored Motor Number in the feedback Device
SOFTIN | Input variable for digital software inputs INPUT5…INPUT20
SOFTOUT | State variable for the virtual digital Outputs
SPHAS | Sercos Phase
SRND | Start Position of Modulo Axes
SSIGRAY | SSI format selection
SSIINV | polarity of SSI Clock
SSIMASK | filter mask for received SSI data Filter mask for received SSI data
SSIRESOL | resolution of the SSI Linear encoder
SSIREVOL | Number of multiturn bits (SSI)
SSIRXD | Sets the number of received SSI-bits
SSITIME | SSI setting time
SSITOUT | Transmit setting time SSI
SSTAT | status of the Sercos interface as text string
STAGECODE | Power Stage Identification
STAT | Drive Status Word
STATCODE | Plain Text Warnings
STATCODE * | Status Variable “Warnings”
STATIO | I/O Status
STATUS | Detailed amplifier status
STEP | Step Service Operation
STOP | adjust setpoint to 0
STOPMODE | Brake Response for Disable
SWCNFG | Configuration of software limit switches
SWE1 | SW limit switch (smallest position)
SWE2 | SW limit switch (biggest position)
SYNCSRC | source for the synchronization
T | Digital current setpoint
TASK | Task workload
TBRAKE | Disable Delaytime with Holding Brake
TBRAKE0 | Enable Delaytime with Holding Brake
TEMPE | Ambient Temperature
TEMPH | Heat Sink Temperature
TEMPM | Motor Temperature
TEMPMFILT | time constant for the filter of motor temperature sensors
TEN | internal parameter
TEST1 | internal parameter
TESTENC | test of feedback and motor
TRJSTAT | Status2 Information
TRUN | Run-time counter in min
TRUNS | Run-time counter in s
TSTEP | Service operation torque steps
UCOMP | Backlash Compensation
UID | User-ID
UMAX | maximal output voltage at field weakening
UPDATE | Program Update via RS232
UVLTMODE | Undervoltage Mode
V | Actual Velocity
VBUS | DC-bus voltage
VBUSBAL | Maximum Line Voltage
VBUSBOFFS | abatement of the Regen switch on threshold
VBUSCNTMAX | internal parameter
VBUSFACT | gain factor for the deceleration ramp control
VBUSLIM | threshold of the phase failure monitoring
VBUSMAX | Maximum DC-bus Voltage
VBUSMIN | Minimum DC-bus Voltage
VBUSOFFS | correction value for the regen threshold S748/S772
VBUSRAMP | switching on threshold for the braking ramp control
VBW | Generate Bode Diagram
VCMD | Internal Velocity Setpoint in RPM
VCOMM | Velocity Threshold for Commutation error
VCTIME | Commutation error time
VEL0 | Standstill Threshold
VER | Firmware Version
VINPOS | Velocity within InPosition window
VJOG | Speed for Jog Mode
VLIM | Max. velocity
VLIMN | Max. negative velocity
VLIMP | Max. velocity
VLO | Software resolver/digital converter feedforward
VLO_X | Software resolver/digital converter feedforward
VMIX | Velocity Mix: Feedback / external Encoder
VMUL | Velocity scale factor
VOHPD | Higher order velocity-observer high-pass damping
VOHPF | Higher order velocity-observer high-pass frequency
VOLPD | Higher order velocity-observer low-pass damping
VOMODE | internal parameter
VOMOPDE | internal parameter
VOSPD | Overspeed
VOSPDREF | Overspeed limit for homing phase
VOUTMAX | sensorless mode: maximum output voltage
VREF | Speed for homing
VREF0 | Homing mode reduction factor
VSCALE1 | SW1 velocity scaling factor
VSCALE2 | SW2 velocity scaling factor
VSTART | Starting Voltage for V/f Control
VSTFR | Velocity for max. friction compensation
VTIMEKD | time const. of d component for the volume flow controller
VTUNE | Autotuning Velocity Loop
VUNIT | Systemwide Definition of Velocity / Speed
VWM | limit value for SinCos voltage
WMASK | Warning as fault mask
WPOS | Enable position registers
WPOSE | Enable fast position registers 1 ... 16
WPOSP | Polarity of fast position registers 1 ... 16
WPOSX | Mode of fast position registers 1 ... 16
WSAMPL | Minimum move of W&S mode
WSCNFG | Type of commutation alignment
WSLOOP | W&S Loops
WSRED | internal parameter
WSTIME | Operation time of the W&S - function
WSTIME2 | W&S delay time
WSTIME3 | W&S delay time
ZERO | automatic calculation of commutation angle
ZEROTIME | Default value for the ZERO function


ASCII English SKIP1SP

ASCII - Command | SKIP1SP |
Syntax Transmit | SKIP1SP [Data] |
Syntax Receive | SKIP1SP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 388B (hex)
DIM | rpm | PROFIBUS PNU | 1707 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 907 (dec)
Default | 0 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Skip Speed 1

Description

Skip Speed 1.
Used in V/f Control scheme to avoid operation in a speed range (defined by SKIP1W) around this speed.
This way resonances can be masked out.
See: SKIP1W, SKIP2SP, SKIP2W.


ASCII English SKIP1W

ASCII - Command | SKIP1W |
Syntax Transmit | SKIP1SP [Data] |
Syntax Receive | SKIP1W <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 388C (hex)
DIM | rpm | PROFIBUS PNU | 1708 (dec) IND = 33 (dec)
Range | 0 .. 500 | DPR | 908 (dec)
Default | 0 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Skip Width 1

Description

Skip Width 1.
Used in V/f Control scheme to avoid operation in the speed range (+/- 0.5 * SKIP1W) around SKIP1SP.
This way resonances can be masked out.
See: SKIP1SP, SKIP2SP, SKIP2W.


ASCII English SKIP2SP

ASCII - Command | SKIP2SP |
Syntax Transmit | SKIP1SP [Data] |
Syntax Receive | SKIP2SP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 388D (hex)
DIM | rpm | PROFIBUS PNU | 1709 (dec) IND = 33 (dec)
Range | 0 .. 3000 | DPR | 909 (dec)
Default | 0 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Skip Speed 2

Description

Skip Speed 2.
Used in V/f Control scheme to avoid operation in a speed range (defined by SKIP2W) around this speed.
This way resonances can be masked out.
See: SKIP2W, SKIP1SP, SKIP1W.


ASCII English SKIP2W

ASCII - Command | SKIP2W |
Syntax Transmit | SKIP1SP [Data] |
Syntax Receive | SKIP2W <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 388E (hex)
DIM | rpm | PROFIBUS PNU | 1710 (dec) IND = 33 (dec)
Range | 0 .. 500 | DPR | 910 (dec)
Default | 0 |
Opmode | 1,2 | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Skip Width 2

Description

Skip Width 2.
Used in V/f Control scheme to avoid operation in the speed range (+/- 0.5 * SKIP2W) around SKIP2SP.
This way resonances can be masked out.
See: SKIP2SP, SKIP1SP, SKIP1W.


ASCII English SLACCMAX

ASCII - Command | SLACCMAX |
Syntax Transmit | SLACCMAX [Data] |
Syntax Receive | SLACCMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 1 .. 268435455 | DPR | No
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | - |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | slopes in sensorless mode

Description

The parameter SLACCMAX desribe the ramp in sensorless mode. At the beginning, try at most SLACCMAX = ACC = DEC. If this value shows troubles at transition point, make the slopes slower, specially the value for SLACCMAX


ASCII English SLEN

ASCII - Command | SLEN |
Syntax Transmit | SLEN [Data] |
Syntax Receive | SLEN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35F2 (hex)
DIM | m | PROFIBUS PNU | 1842 (dec) IND = 1 (dec)
Range | 0 .. 45 | DPR | 242 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | fieldbus | EEPROM | Yes
Short Description | Sercos Optical Range

Description

This parameter can be used to set the optical range (in meters) for a standardized 1mm² plastic optical fiber cable.

minimum output at 0
maximum output at 45


ASCII English SLIDK01

ASCII - Command | SLIDK01 |
Syntax Transmit | SLIDK01 [Data] |
Syntax Receive | SLIDK01 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | -5000 .. 5000 | DPR | No
Default | 1 |
Opmode | all | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | factor (weight) for Ud

Description

SLIDK01 sets a weight for “voltage in D”. It affects directly and aggressively the performance of sensorless. A value of 0.23 is recommended. But if you are losing orientation, the valued can be reduced to 0.20. An even smaller value can show some troubles in performance.


ASCII English SLIMAX

ASCII - Command | SLIMAX |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English SLIQK

ASCII - Command | SLIQK |
Syntax Transmit | SLIQK [Data] |
Syntax Receive | SLIQK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | -5000 .. 5000 | DPR | No
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | factor (weight) for load-current iq

Description

SLIQK sets a factor (weight) for “load-current iq” in position calculation under Sensorless. Its value depends on DIPEAK and therefore, its value should be selected from following table:

S701; SLIQK = 1
S706: SLIQK = 4
S712: SLIQK = 8
S724: SLIQK = 10
S748: SLIQK = 20
S772: SLIQK = 30


ASCII English SLIQK1

ASCII - Command | SLIQK1 |
Syntax Transmit | SLIQK1 [Data] |
Syntax Receive | SLIQK1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | -2 .. 2 | DPR | No
Default | 0 |
Opmode | all | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | - |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | second factor (weight) for “load-current"

Description

The parameter SLIQK1 sets a second weight for “load-current Iq” in sensorless mode. Its value should be set to one


ASCII English SLJSWITCH

ASCII - Command | SLJSWITCH |
Syntax Transmit | SLJSWITCH [Data] |
Syntax Receive | SLJSWITCH <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM | rpm | PROFIBUS PNU | -
Range | 0 .. 599 (dual use: 72000) | DPR | No
Default | 500 |
Opmode | all | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | threshold from stepper to sensorless mode

Description

SLJSWITCH sets a threshold (in rpm) to commute from stepper mode into sensorless mode. This value should be at least 15% of motor nominal speed.


ASCII English SLMODE

ASCII - Command | SLMODE |
Syntax Transmit | SLMODE [Data] |
Syntax Receive | SLMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 5 | DPR | No
Default | 1 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware |  |
Configuration | Yes | Last Change of this Object | 2.7
Function Group | sensorless | EEPROM | Yes
Short Description | stepper mode for sensorless

Description

Withe the parameter SLMODE the stepper mode will be choosen

Vorraussetzung FBTYPE=10 und MTYPE= 1


ASCII English SLOTIO

ASCII - Command | SLOTIO |
Syntax Transmit | SLOTIO |
Syntax Receive | SLOTIO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35F3 (hex)
DIM | - | PROFIBUS PNU | 1843 (dec) IND = 1 (dec)
Range | - | DPR | 243 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | No
Short Description | I/O-Expansion Card: I/O States

Description

The SLOTIO command returns the states of the inputs and outputs on the I/O-expansion card (slot card) in the format Hxxxxxxxx
Bit number Bit combination Input/Output Description
0 0x00000001 Input Bit 0 Motion block number (A0)
1 0x00000002 Input Bit 1 Motion block number (A1)
2 0x00000004 Input Bit 2 Motion block number (A2)
3 0x00000008 Input Bit 3 Motion block number (A3)
4 0x00000010 Input Bit 4 Motion block number (A4)
5 0x00000020 Input Bit 5 Motion block number (A5)
6 0x00000040 Input Bit 6 Motion block number (A6)
7 0x00000080 Input Bit 7 Motion block number (A7)
8 0x00000100 Input Reference switch
9 0x00000200 Input Acknowledge Contouring error
10 0x00000400 Input Start next motion block
11 0x00000400 Input Start jog mode
12 0x00001000 Input Continue a motion block
13 0x00002000 Input Start motion block no. A0 ... A7
14 0x00004000 Output “In-Position” signal
15 0x00008000 Output “In-Position2” signal (next)
16 0x00010000 Output Contouring error
17 0x00020000 Output “Position register 1” signal
18 0x00040000 Output “Position register 2” signal
19 0x00080000 Output “Position register 3” signal
20 0x00100000 Output “Position register 4” signal
21 0x00200000 Output “Position register 5” signal
22 0x00400000 Status 24Volt - On
23 0x00800000 Status Slot fault
24...31 Reserve


ASCII English SLTEMPM

ASCII - Command | SLTEMPM |
Syntax Transmit | SLTEMPM [Data] |
Syntax Receive | SLTEMPM <Data> | Available in |
Type |  | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.3
Function Group | temperatures | EEPROM |
Short Description | monitoring of the motor temperature

Description

SLTEMPM=0 – no monitoring of the motor temperature in sensless mode (FBTYPE=10 und 11)
SLTEMPM=1 – monitoring of the motor temperature in sensless mode (FBTYPE=10 und 11)


ASCII English SLTSWITCH

ASCII - Command | SLTSWITCH |
Syntax Transmit | SLTSWITCH [Data] |
Syntax Receive | SLTSWITCH <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | -
DIM | ms | PROFIBUS PNU | -
Range | 0 .. 10000 | DPR | No
Default | 200 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.12
Function Group | velocity loop | EEPROM | Yes
Short Description | transition time to nominal speed

Description

SLTSWITCH defines a time (in ms) to remain at velocity threshold (SLJSWITCH). This means, if SLTSWITCH is 100ms, the motor stops the acceleration and rotates for 100ms at SLJSWITCH. After those 100ms, the commutation into Sensorless takes place and motor accelerates further. A value of zero means an instantaneous commutation.


ASCII English SMNUMBER

ASCII - Command | SMNUMBER |
Syntax Transmit | SMNUMBER |
Syntax Receive | SMNUMBER <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3695 (hex)
DIM | - | PROFIBUS PNU | 2005 (dec) IND = 1 (dec)
Range | 0 .. 32767 | DPR | 405 (dec)
Default | 0 |
Opmode | - | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | No
Short Description | Stored Motor Number in the feedback Device

Description

SMNUMBER gives the motor number, that is stored in the feedback device (EnDAT or HIPERFACE).

This Object makes sense with FBTYPE = 2 or 4, otherwise "0" is returned.


ASCII English SOFTIN

ASCII - Command | SOFTIN |
Syntax Transmit | SOFTIN [Data] |
Syntax Receive | SOFTIN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 354E (hex)
DIM | - | PROFIBUS PNU | 1678 (dec) IND = 1 (dec)
Range | Integer32 | DPR | 78 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.00 |
Configuration | No | Last Change of this Object | 2.14
Function Group | digital I/O | EEPROM | No
Short Description | Input variable for digital software inputs INPUT5…INPUT20

Description

The bit variable SOFTIN describes the actual state of the virtual digital inputs INPUT5 … INPUT20
The relation between the Bit number and the digital input is as follows:

Bit0 INPUT5
Bit1 INPUT6
….
Bit15 INPUT20

The write access to the parameter SOFTIN affects directly the state of the corresponding digital input
For example:

SOFTIN 5 : the digital inputs INPUT5 and INPUT7 becomes the state high

The function of the virtual digital inputs can be configured by the commands IN5MODE…IN20MODE

In case that an external I/O slot card is used, only a reduced number of virtual inputs is available (INPUT19…INPUT20)


ASCII English SOFTOUT

ASCII - Command | SOFTOUT |
Syntax Transmit | SOFTOUT [Data] |
Syntax Receive | SOFTOUT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 354F (hex)
DIM | - | PROFIBUS PNU | 1679 (dec) IND = 1 (dec)
Range | Integer32 | DPR | 79 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.00 |
Configuration | No | Last Change of this Object | 1.3
Function Group | digital I/O | EEPROM | No
Short Description | State variable for the virtual digital Outputs

Description

The bit variable SOFTOUT describes the actual state of the virtual digital outputs OUTPUT3 … OUTPUT18

The relation between the Bit number and the digital output is as follows:

Bit0 OUTPUT3
Bit1 OUTPUT4
….
BIT15 OUTPUT18

The function of the virtual digital outputs can be configured by the commands O3MODE…O18MODE

In case that an external I/O slot card is used, only a reduced number of virtual outputs is available OUTPUT11…OUTPUT18)


ASCII English SPHAS

ASCII - Command | SPHAS |
Syntax Transmit | SPHAS |
Syntax Receive | SPHAS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35F4 (hex)
DIM | - | PROFIBUS PNU | 1844 (dec) IND = 1 (dec)
Range | - | DPR | 244 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.67 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | Sercos Phase

Description

Shows the present Sercos phase.

Phase 0 Close ring and reset
Phase 1 Drive identification
Phase 2 Communication initialization
Phase 3 Parameter initialization
Phase 4 Ready for operation


ASCII English SRND

ASCII - Command | SRND |
Syntax Transmit | SRND [Data] |
Syntax Receive | SRND <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3637 (hex)
DIM | - | PROFIBUS PNU | 1911 (dec) IND = 1 (dec)
Range |  | DPR | 311 (dec)
Default | -PGEARI/2 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Start Position of Modulo Axes

Description

The SRND parameter is used to define the start of the range of movement for a modulo axes (POSCNFG=2). The end of the range can be set by the ERND command. All positioning operations are made in the positioning range <SRND...ERND-1>.
The entry for SRND is made in SI units (taking account of PGEARI, PGEARO).


ASCII English SSIGRAY

ASCII - Command | SSIGRAY |
Syntax Transmit | SSIGRAY [Data] |
Syntax Receive | SSIGRAY <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35F6 (hex)
DIM | - | PROFIBUS PNU | 1846 (dec) IND = 1 (dec)
Range | 0,1 | DPR | 246 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | SSI format selection

Description

The command is used to select the SSI format

SSIGRAY 0 = Binär
SSIGRAY 1 = Gray


ASCII English SSIINV

ASCII - Command | SSIINV |
Syntax Transmit | SSIINV [Data] |
Syntax Receive | SSIINV <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35F7 (hex)
DIM | - | PROFIBUS PNU | 1847 (dec) IND = 1 (dec)
Range | 0 .. 3 | DPR | 247 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable | Weighting |
Start Firmware | 3.55 |
Configuration | No | Last Change of this Object | 2.1
Function Group | feedback | EEPROM | Yes
Short Description | polarity of SSI Clock

Description

nur S300:

The behavior of the SSI interface at X5.
The SSIINV command has different interpretations, depending on whether the SSI is configured as an output or an input.

1. SSI output
SSIINV = 0: normal clock level
SSIINV = 1: inverted clock level
SSIINV = 2: normal clock level, only 12 Bit resolution
SSIINV = 3: inverted clock level, only 12 Bit resulotion


ASCII English SSIMASK

ASCII - Command | SSIMASK |
Syntax Transmit | SSIMASK [Data] |
Syntax Receive | SSIMASK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 390C (hex)
DIM | - | PROFIBUS PNU | 1836 (dec) IND = 33 (dec)
Range | 0…0xFFFFFFFF (dec: -2147483648 .. 2147483647) | DPR | 1036 (dec)
Default | 0XFFFFFFFF (dec: -1) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.87 |
Configuration | No | Last Change of this Object | 2.11
Function Group | feedback | EEPROM | Yes
Short Description | filter mask for received SSI data Filter mask for received SSI data

Description

By using the variable SSIMASK the warning- / error bits can be filtered in the incoming SSI data. In the SSI date only the position information is expected, the existing state information must be hidden by deleting the bits in SSIMASK.

The received SSI-date with the SSIMASK value is calculated with an AND operation. The result is further processed as position information.


ASCII English SSIRESOL

ASCII - Command | SSIRESOL |
Syntax Transmit | SSIRESOL [Data] |
Syntax Receive | SSIRESOL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 387B (hex)
DIM | - | PROFIBUS PNU | 1691 (dec) IND = 33 (dec)
Range | 0 .. 32 Bits | DPR | 891 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 3.07 |
Configuration | Yes | Last Change of this Object | 2.14
Function Group | feedback | EEPROM | Yes
Short Description | resolution of the SSI Linear encoder

Description

Defines the resolution of the SSI Linear encoder (FBTYPE=26/28).
This parameter includes the number of counts delivered by the SSI encoder pro motor polpitch.
e.g.
SSI-Resolution 1µm
Polpitch 28 mm = 28000 µm
ENCLINES=1000
SSIRESOL=28


ASCII English SSIREVOL

ASCII - Command | SSIREVOL |
Syntax Transmit | SSIREVOL [Data] |
Syntax Receive | SSIREVOL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3619 (hex)
DIM | - | PROFIBUS PNU | 1881 (dec) IND = 1 (dec)
Range | 0 .. 16 | DPR | 281 (dec)
Default | 4 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.2
Function Group | feedback | EEPROM | Yes
Short Description | Number of multiturn bits (SSI)

Description

The command SSIREVOL defines the number of multiturn-bits by the SSI – transmission (receive)
In combination with command SSIRXD all bits in the SSI-telegramm are defined.

SSIRXD – all SSI-bits
SSIREVOL – bits for multiturn-information

Bits per feedback turn = SSIRXD - SSIREVOL

Default value S700: 12


ASCII English SSIRXD

ASCII - Command | SSIRXD |
Syntax Transmit | SSIRXD [Data] |
Syntax Receive | SSIRXD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 365E (hex)
DIM | - | PROFIBUS PNU | 1950 (dec) IND = 1 (dec)
Range | 1 ... 33 | DPR | No
Default | 24 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Sets the number of received SSI-bits

Description

The command ‘SSIRXD’ sets the number of received SSI-bits .

REGISTER max. 32 bit

number of bits:

1 => SSIRXD 1

2 => SSIRXD 2

…

32 => SSIRXD 32

33 => SSIRXD 33


ASCII English SSITIME

ASCII - Command | SSITIME |
Syntax Transmit | SSITIME [Data] |
Syntax Receive | SSITIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 390B (hex)
DIM | µsec | PROFIBUS PNU | 1835 (dec) IND = 33 (dec)
Range | 1 ... 15 | DPR | 1035 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 5.87 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | Yes
Short Description | SSI setting time

Description

This parameter set the SSI settling time at SSITOUT = 3


ASCII English SSITOUT

ASCII - Command | SSITOUT |
Syntax Transmit | SSITOUT [Data] |
Syntax Receive | SSITOUT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3661 (hex)
DIM | - | PROFIBUS PNU | 1953 (dec) IND = 1 (dec)
Range | 0 .. 3 | DPR | 353 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | Yes
Short Description | Transmit setting time SSI

Description

The command SSIOUT sets the monoflop - setting time of the SSI - transmittion.

SSI - OUTPUT:
SSITOUT = 0 <= setting time 13 µsec
SSITOUT = 1 <= setting time 3 µsec

since FW 5.87:
SSITOUT = 2 <= setting time 8 µsec
SSITOUT = 3 <= free programmable settling time (input via the parameter SSITIME)

SSI - INPUT:
This parameter defines the clock-frequency, which is used for the read of the SSI-data word.

SSITOUT 0: 1MHz only for 1. & 2. feedback (FBTYPE, EXTPOS)
SSITOUT 1: 500 kHz only for 1. & 2. feedback (FBTYPE, EXTPOS)
SSITOUT 2: 250 kHz only for second feedback (EXTPOS)
SSITOUT 3: 125 kHz only for second feedback (EXTPOS)


ASCII English SSTAT

ASCII - Command | SSTAT |
Syntax Transmit | SSTAT [Data] |
Syntax Receive | SSTAT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | String | CANBus Object Number | 35FA (hex)
DIM | - | PROFIBUS PNU | 1850 (dec) IND = 1 (dec)
Range | - | DPR | 250 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | String
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | No
Short Description | status of the Sercos interface as text string

Description

Presents the actual status of the Sercos interface, as a text string.


ASCII English STAGECODE

ASCII - Command | STAGECODE |
Syntax Transmit | - |
Syntax Receive | STAGECODE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3682 (hex)
DIM | - | PROFIBUS PNU | 1986 (dec) IND = 1 (dec)
Range | 1, 2, .., 19 | DPR | 386 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Power Stage Identification

Description

Give the identification of the power stage-

STAGECODE=0 not allowed (Hardware error)
STAGECODE=1 S 303
STAGECODE=2 S 306
STAGECODE=3 S 310
STAGECODE=4 S 341
STAGECODE=5 S 343
STAGECODE=6 S 346
STAGECODE=7..9 earmarked
STAGECODE=10 S 701
STAGECODE=11 S 703
STAGECODE=12 S 706
STAGECODE=13 S 712
STAGECODE=14 S 724
STAGECODE=15 S 712P (30A/400V)
STAGECODE=16 S 724P (72A/400V)
STAGECODE=17 S 748
STAGECODE=18 S 772
STAGECODE=19..41 earmarked
STAGECODE=42 S 701
STAGECODE=43 S 703
STAGECODE=44 S 706
STAGECODE=45 S 712
STAGECODE=46 S 724
STAGECODE=47 S 721P (30A/230V)
STAGECODE=48 S 724P (72A/230V)


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Use

Start the Software

Click the icon on your Windows desktop to start the software.

Online/Offline

You can work offline or online with DriveGUI.EXE.

online: connected to a working servo amplifier (24 V auxiliary voltage)
offline: without connecting to a working servo amplifier

Online

The machine manufacturer must perform a risk assessment for the machine and must ensure that unforeseen movement of the machine is never a hazard to personnel or devices. Only if these measures are taken can the customization of online parameters by qualified staff be permitted.

The software checks the existing interfaces. If it detects a connected servo amplifier, the software starts with the start screen. If Multilink function is switched on (MDRV=1), then a list of scanned servo amplifiers in the system is shown, where you can select the required one. More information to Multilink can be found in the KDN on page Multilink with Setup Software.

comnet

If you have never started a communication before, you have to configure the communication parameters first.

Choose the communication system and the interface (COM1 ... COM10), where the servo amplifier is connected to. Set the baudrate and speed and click OK.

The software tries to communicate with these parameters. If it's successful, you see the start screen. If not, you receive this error message:

Frequent causes:
- wrong interface chosen
- wrong connector chosen at the servo amplifier
- interface is used by another software
- 24 V auxiliary voltage for the servo amplifier not working
- interface cable broken or wrong wiring

Quit the error message. The software starts in the offline mode now, that requires the manual selection of the amplifier's type. Quit this selection by closing the window.
Fix the communication problem. Restart the software in Online mode.

Offline

If you work offline, all functions that need a communication line between the servo amplifier and PC, are not active.

The software can't detect a servo amplifier type in the offline mode. You need to select an amplifier type first.

Select the data line from the displayed list that corresponds to your device and the mains specification.

All valid combinations (continuous current and mains voltage) are given. Click OK. A default data set is loaded now.

These data can be changed and stored to an external file.

Screen layout

Title bar

The program name and the name of the currently valid data set (amplifier) are displayed in the title bar.

Menu bar

File | New | A new data set is created for editing. The current data set will be closed and not saved.
 | Open | A data set is read from the data medium (hard disk, diskette) and becomes the currently valid set. The servo amplifier must first be disabled.
 | Save | Saves the current data set in a file on your PC
 | Print | Prints the current data set to you Windows standard printer.
 | all other functions | Standard Windows
Edit | all functions | Standard Windows
Communication | Connect | Connect to servo amplifier
 | Disconnect | Disconnect servo amplifier, software switches to offline mode
 | Reload | Reloads all parameters and motion tasks data
 | Refresh page settings | Refreshs the old, unchanged data of the actual sreen page.
 | Apply page settings | Saves the parameters of the actual page to the RAM of the servo amplifier.
 | Select device | Select the communication network
 | Device parameters | Adjust the communication parameters
Drive | Stop | Stop movement in OPMODE 0, 2, 8
 | Enable | Software Enable for power output stage
 | Disable | Software Disable for power output stage
 | Save to EEPROM | The actual parameter set is permanently saved to the EEPROM of the servo amplifier.
 | Clear EEPROM | The manufacturer default parameter set will be saved to the EEPROM of the servo amplifier.
 | RESET | Hardware reset (cold start)
 | Clear errors | Actual error messages are quit. The reaction depends on the actual error: immediately ready to operate or reboot.
 | Select OPMODE | Select the operation mode of the servo amplifier OPMODE
Tools | Upgrade Tool | Start of the Upgrade Tool, see Software Upgrade
 | CalcLK | Start of the Converter Tool for profile table data
 | SafetyGUI | Start of the Setup Software SafetyGUI for built-in Safety Cards
 | MacroStar | Start of the Makro Editor MacroStar, see Macro Programming
 | Select language | select the language version of the software
View | Tool bar | Visability of the tool bar
 | Status bar | Visability of the status bar
Help | Contents | Online help start page for the setup software
 | Help F1 | Help page for the active screen
 | Support | Contact information for questions
 | About DriveGUI | Version of the setup software

Tool bar

Standard Windows

Connect | Enable (Shift+F12)
Disconnect | Disable (F12)
Reload | Save to EEPROM
Refresh page settings | Clear EEPROM
Apply page settings | Clear errors
Stop movement (F11) | Reset
Context help | Software version
Help for the current screen |

opmode

Operation mode of the servo amplifier OPMODE

Status bar

The communication status between servo amplifier and setup software is indicated on the left side of this bar.
On the right side of the status bar, the operation status (online/offline) and several other staus messages are monitored.

Navigation frame

navigation

In a structure similar to Windows Eplorer, links to all screen pages are listed that you need for setup, optimizing and monitoring of the servo amplifier. The selected screen is shown in the main frame.

The top level of the tree shows the name of the connected servo amplifier (DRIVE0 in the example).

Main frame

main

The main frame (basic setup as an example) allows changing parameters, monitoring actual values of the servo amplifier and selecting functions.

Help functions

Key F1 | Starts Online Help for the actual screen page.
help | Button in the tool bar. Starts Online Help for the actual screen page.
Menu bar Help | Starts Online Help with it's first page.
hilfeicon1 | Context Help. Click the help symbol first. Then click the function for which you need help.

The Online Help delivers detailed information to all the parameters (ASCII object reference) that can be used by the servo amplifier.

Help for all situations can be found also in the KDN.


ASCII English Revision

ASCII Object Description
Edition REV 2.14
Edition | Description | Created
REV 1.0 beta | Beta Basic Edition | 11.05.04
REV 1.0 | Basic Edition | 03.05.05
REV 1.1 | New Commands and amendments | 11.10.05
REV 1.2 | New Commands and amendments | 02.02.06
REV 1.3 | New Commands and amendments | 11.09.06
REV 1.4 | New Commands and amendments | 23.10.06
REV 1.5 | New Commands and amendments | 30.10.06
REV 1.6 | New Commands and amendments | 03.11.06
REV 1.7 | New Commands and amendments | 23.11.06
REV 1.8 | New Commands and amendments | 15.03.07
REV 1.9 | New Commands and amendments | 21.12.07
REV 2.0 | New Commands and amendments | 30.01.08
REV 2.1 | New Commands and amendments | 05.12.08
REV 2.2 | New Commands and amendments | 18.06.09
REV 2.3 | New Commands and amendments | 25.02.11
REV 2.4 | New Commands and amendments | 21.02.11
REV 2.5 | New Commands and amendments | 13.11.12
REV 2.6 | New Commands and amendments | 13.06.13
REV 2.7 | New Commands and amendments | 29.07.13
REV 2.8 | New Commands and amendments | 08.11.13
REV 2.9 | New Commands and amendments | 08.05.14
REV 2.10 | New Commands and amendments | 28.10.15
REV 2.11 | New Commands and amendments | 24.03.16
REV 2.12 | New Commands and amendments | 05.12.16
REV 2.13 | New Commands and amendments | 17.11.17
REV 2.14 | New Commands and amendments | 15.05.18


ASCII English STAT

ASCII - Command | STAT |
Syntax Transmit | STAT |
Syntax Receive | STAT | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35FB (hex)
DIM | - | PROFIBUS PNU | 1851 (dec) IND = 1 (dec)
Range | int (=Word) | DPR | 251 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | actual values | EEPROM | No
Short Description | Drive Status Word

Description

The STAT command provides a 16-bit status word in hexadecimal format (Hxxxx).

Bit Value Interpretation
0 0x0001 =0 if output stage is enabled
=1 output stage disabled
1 0x0002 =0 if controller is ready for operation (BTB)
=1 fault present
2 0x0004 =0 no password active
=1 password active (PASSX>0)
3 0x0008 =0 no service function active
=1 if service function is active
4 0x0010 =0 no PLC-password active (PASSXPLC=0)
=1 PLC-password active (PASSXPLC>0)
5 0x0020 =1 after a hardware reset, is cancelled by CLRHR
6 0x0040 =1 configuration variable was altered (SAVE and COLDSTART)
=0 no configuration variable altered
7 0x0080 =1 safety relay is active (AS-Option)
=0 safety relay is not active
8 0x0100 =1 discrepancy between RAM and EEPROM parameters (cancelled by SAVE command).
=0 RAM and EEPROM parameters are the same
9 0x0200 =1 slot-expansion card is available
=0 slot-expansion card is not available
10 0x0400 =1 RAM parameter modified (cancelled by DUMP command)
=0 no change in RAM parameters since the last DUMP.
11...15 Reserve

Bits 5, 6, 8 and 10 are used for an external signal that internal parameters have been changed

Bit 5 hardware reset
Bit 5 is set if the parameters are copied from the serial EEPROM to the RAM (this happens after a hardware reset of a LOAD command). If this bit is set, all the parameters should be requested by the parameterization software (DUMP command) and bit 5 should be cancelled by the CLRHR command.

Bit 6 configuration variable was altered
Any alteration of a configuration variable (a variable that makes it necessary to recompile the macro, i.e. to reset the amplifier) means that this bit will be set to 1. If this bit is set, the parameterization software should generate a SAVE / COLDSTART command (controller reset) at a suitable moment. Bit 6 is only cancelled by a hardware reset (COLDSTART).

Bit 8 discrepancy between EEPROM and RAM parameters
Any alteration of a RAM parameter means that this bit is set to 1. If this bit is set, the parameterization software should generate a SAVE command (save the data in the EEPROM) at a suitable moment (e.g. on exiting the program). This bit is cancelled by a SAVE command.

Bit 10 RAM parameters modified
Any alteration of a RAM parameter through a parameterization channel other than the RS232 means that this bit is set to 1. If this bit is set, the parameterization software should generate a DUMP command (read all data) at a suitable moment. This bit is cancelled by a DUMP command.


ASCII English STATCODE

ASCII - Command | STATCODE |
Syntax Transmit | STATCODE |
Syntax Receive | STATCODE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 385E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 33 (dec)
Range | - | DPR | 862 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Plain Text Warnings

Description

The warnings are displayed as plain text.

See also STATCODE *


ASCII English STATCODE *

ASCII - Command | STATCODE * |
Syntax Transmit | STATCODE * |
Syntax Receive | STATCODE * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 .. 0xFFFFFFFF | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | actual values | EEPROM | No
Short Description | Status Variable “Warnings”

Description

The STATCODE * command returns the internal warnings in the form of a bit-variable. The assignments for the individual bits can be seen in the following table.
Bit | Display | Meaning
0 / 0x00000001 | n01 | =1 I2T Threshold override
1 / 0x00000002 | n02 | =1 Regen message
2 / 0x00000004 | n03 | =1 Contouring error
3 / 0x00000008 | n04 | =1 watchdog limit reached
4 / 0x00000010 | n05 | =1 Line phase missing
5 / 0x00000020 | n06 | =1 Software limit switch 1 active
6 / 0x00000040 | n07 | =1 Software limit switch 2 active
7 / 0x00000080 | n08 | =1 Wrong motion task started Bit is set if a not defined motion task was sellected, the target position is out of range (software limit switches) or wrong (out of range) settings for ACCR, DECR are used . If a FW >=2.31 is used the checksum of the table motion task is active, this means the conversion tool 4.0 is necessary. In case a table motion task is created by an older conversion version it will effect a n08 warning. The warning gets also active, if AUTOHOME is used or a digital input is selected as reference input ( for example IN1MODE 16 ) and OPMODE <> 4 or 8. Starting a not existing table motion task can also be the reason (FW > 2.14)
8 / 0x00000100 | n09 | =1 Reference point not set
9 / 0x00000200 | n10 | =1 PSTOP active is set as long as the hardware limit switch PSTOP active is cleared when the hardware limit switch PSTOP is inactive.
10 / 0x00000400 | n11 | =1 NSTOP active is set as long as the hardware NSTOP active is deleted as soon as the hardware NSTOP is inactive.
11 / 0x00000800 | n12 | =1 Default motor settings loaded is set at start-up phase when the engine number from the serial EEPROM and the engine number from the EnDAT or Hiperface encoder are different. If you enter a valid motor number and storing the data in the encoder HSAVE and in the internal EEPROM SAVE is no longer issued this warning the next time the timer.
12 / 0x00001000 | n13 | =1 Slot warning (I/O extension board) If no 24V supply voltage for the I/O card, the warning n13 generated and executed once an emergency stop. Subsequently, however, the drive can be moved without 24V I/O supply. If the application requires it, the user can by setting the bits generate an additional error F24 and thereby prevent any motor movement WMASK. The monitoring of the 24V power supply can by configure CPHASE.
13 / 0x00002000 | n14 | = 1 This warning is issued in the following situations: 1. Wake & Shake active (e.g., FBTYPE = 7,8 ...) As soon as the output stage has been enabled and the determination of the motor phase has been terminated, the warning is cleared. 2. Safe brake test (SBT) active This function can only be activated if a safety card (S700) is used. As long as the warning n14 is active, the external setpoints (for example, from the fieldbus interface) are ignored.
14 / 0x00004000 | n15 | reserved
15 / 0x00008000 | n16 | Is active, if one or more of the warnings n17...n31 are active.
16 / 0x00010000 | n17 | Fieldbus-Sync is not locked
17 / 0x00020000 | n18 | Using Multiturn encoder feedback, a overrun over the maximum number of resolutions (+/-2048) was detected
18 / 0x00040000 | n19 | The motion task ramps are limited (range overflow on motion task data)
19 / 0x00080000 | n20 | Invalid motion task
20 / 0x00100000 | n21 | PLC program error (for details see plc code)
21 / 0x00200000 | n22 | max. motortemperatur reached (the user can shut down the process before the temperature eror will interrupt the process immediately)
22 / 0x00400000 | n23 | Sin Cos Feedback warning level reached see also VWM
23 / 0x00800000 | n24 | Bit is set to 1, if during boot up process the plausibility check is negative see also ERRPARAM
24...30 | n25 .. n31 | reserved
31 / 0x80000000 | n32 | =1 Beta version of the firmware


ASCII English STATIO

ASCII - Command | STATIO |
Syntax Transmit | STATIO |
Syntax Receive | STATIO <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | 7 x Integer8 | CANBus Object Number | 35FC (hex)
DIM | - | PROFIBUS PNU | 1852 (dec) IND = 1 (dec)
Range | 0,1 (=State) | DPR | 252 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | I/O Status

Description

The STATIO command returns the actual state of the digital inputs and outputs of the servo amplifier, in the following sequence.
IN1 IN2 IN3 IN4 ENABLE OUT1 OUT2

A 0 at the appropriate position means that the corresponding input/output is in the Low state, a 1 signifies the High state.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Status (Faults/Warnings)

status

The actual fault status and the run time monitor of the servo amplifier are displayed here. Compare to the runtime status you can simply calculate when an fault occurrs.

Top left is the fault history with the time (run time) when the fault occured.

Top right is information about the frequency for every fault.

The center area, the actual fault and warnings are listed.

Bottom list: With special errors extended error information is shown here (see ERRCODE2).
The button "Troubleshooting" starts the help page "Troubleshooting"
You can find a list of all warnings and fault messages.

Mapping of Warnings to Fault F24...

Click Button "Mapping of Warnings to Fault F24... " to define the fault message F24 (bit variable WMASK, see chapter Warnings and Faults ).

basis-fehler-f24

Immediate Power Stage Disable on faults Fxx...

Click Button "Immediate Power Stage Disable on faults Fxx... " to define, which faults must immediately disable the power stage (bit variable ERRCNFG, see chapter Faults ).

basis-fehler-f241


ASCII English STATUS

ASCII - Command | STATUS |
Syntax Transmit | STATUS |
Syntax Receive | STATUS <Data> | Available in |
Type | Multi-line Return Command | MMI | Yes
ASCII Format | Integer16 Integer32 Integer16 Integer16 Integer16 | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | int (=Word); long int (=DoubleWord) | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.13 |
Configuration | No | Last Change of this Object | 2.13
Function Group | actual values | EEPROM | No
Short Description | Detailed amplifier status

Description

The STATUS command returns the detailed status information in the form of a 5 status variables in hexadecimal format.

Word no. 1 Format Hxxxx
Bit 0 =0 if hardware enable is set (ENABLE input = 24V)
Bit 1 =0 if software enable is set
Bit 2 reserve
Bit 3 =0 if amplifier is ready for operation (BTB / no fault)

Word no. 2 Format Hxxxx
Bits 0 ... 31 fault variable (see ERRCODE)

Word no. 3 Format Hxxxx
Word no. 4 Format Hxxxx
=0 no service function active
=1 service function “constant current/velocity” is active
=2 jog mode MJOX is active

Word no. 5 Format Hxxxx

Bit Value Interpretation
0 0x0001 =1 motion block / homing movement / jog mode is active
1 0x0002 =1 reference point set
2 0x0004 =1 reference switch occupied (home position)
3 0x0008 =1 IN-POSITION signal
4 0x0010 =1 position has been latched (positive edge)
5 0x0020 =1 homing in progress
6 0x0040 =1 jog mode is running
7 0x0080 =1 position has been latched (negative edge)
8 ... 15 reserve


ASCII English STEP

ASCII - Command | STEP |
Syntax Transmit | STEP [Data] |
Syntax Receive | STEP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 Float Integer16 Float | CANBus Object Number | -
DIM | ms (DurationN) / rpm (velocityN) | PROFIBUS PNU | -
Range | Duration:0 to 32767; velocity:-VLIM to +VLIM | DPR | No
Default | Duration:1000; velocity1/2: 100/-100 |
Opmode | 0 | Data Type Bus/DPR | Integer16 Float Integer16 Float
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.9
Function Group | velocity loop | EEPROM | -
Short Description | Step Service Operation

Description

Only S700:

The STEP command is used to implement a service function through the operating mode “digital velocity control” (OPMODE=0). The command can be used in the following forms.
1. STEP
The command provides the present settings for the service function.
2. STEP T1 V1
A digital setpoint V1 (RPM) is provided for time T1 (in msec). After T1 has elapsed, the digital setpoint is set to 0.
3. STEP T1 V1 T2 V2
A digital setpoint V1 (RPM) is provided for time T1 (in msec). After T1 has elapsed, a digital setpoint V2 (RPM) is provided for time T2 (in msec). After T2 has elapsed, the T1/V1 cycle starts again. This command can be used to create an endless reversing operation.
e.g. STEP 1000 500 1000 -500

The service operation can always be cancelled by using the STOP command.
The “digital velocity control” operating mode is a precondition for implementing the STEP command.


ASCII English STOP

ASCII - Command | STOP |
Syntax Transmit | STOP |
Syntax Receive | STOP | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | 35FE (hex)
DIM | - | PROFIBUS PNU | 1854 (dec) IND = 1 (dec)
Range | - | DPR | 254 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | control commands | EEPROM | No
Short Description | adjust setpoint to 0

Description

The STOP command breaks off the drive movement. The response of the drive varies according to the operating mode that is valid at the moment.

1. OPMODE=0 (digital velocity control)
The STOP command has the effect of setting the velocity setpoint to 0.
The drive brakes along the preset braking ramp for the velocity control loop (DEC).

2. OPMODE=2 (digital current control)
The STOP command has the effect of setting the current setpoint to 0.
The drive coasts down.

3. OPMODE=8 (internal motion tasks)
The STOP command has the effect of breaking off the present motion task (jog mode / homing movement).
The drive brakes along the decel ramp that is defined in the motion task. The motion task can be restarted by CONTINUE or digital input defined with INxMODE=22.

The STOP command has no function in the OPMODE=1,3,4,5,6,7 operating modes.


ASCII English STOPMODE

ASCII - Command | STOPMODE |
Syntax Transmit | STOPMODE [Data] |
Syntax Receive | STOPMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35FF (hex)
DIM | - | PROFIBUS PNU | 1855 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 255 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | Yes
Short Description | Brake Response for Disable

Description

STOPMODE defines the response of the drive to a disabling of the output stage.
The following settings are possible:
STOPMODE=0 the output stage is immediately disabled, and the drive coasts down.

STOPMODE=1 the drive is run down under velocity control to velocity 0 (DECDIS ramp). When the velocity falls below the standstill threshold VEL0, the output stage is disabled. The output stage will also be disabled if the VEL0 velocity is not reached within 5 seconds (a 5-second time-out).

Note: In Sensorless mode (FBTYPE=10) is the speed estimation not possible at low speeds, the actual value is not used but the command value of the setpoint speed. To be sure that the drive speed is at zero, after the speed setpoint had the threshold below VEL0, started a time. When this time has elapsed, it is assumed that the drive speed is zero and the output stage can be disabled. The delay time is derived from the EMRGTO value.


kms

Customer Support

We are committed to quality customer service. In order to serve in the most effective way,
please contact your local sales representative for assistance.
If you are unaware of your local sales representative, please contact the European or North American customer support.

Help for all situations can also be found in the Kollmorgen Developers Network (KDN): https://kdn.kollmorgen.com/

Current and historical documents can be downloaded from our File Archive: http://www.wiki-kollmorgen.eu/wiki/tiki-index.php.

KOLLMORGEN Customer Support - Europe

Internet | www.kollmorgen.com
E-Mail | technik@kollmorgen.com
Phone | +49(0)2102 - 9394 - 0
Fax: | +49(0)2102 - 9394 - 3155

KOLLMORGEN Customer Support North America

Internet | www.kollmorgen.com
E-Mail | support@kollmorgen.com
Phone: | +1 - 540 - 633 - 3545
Fax: | +1 - 540 - 639 - 4162


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Firmware Upgrade

The field upgrade of the servo amplifiers requires the application program "DriveUpgrade Tool_....exe". While installing the setup software this tool usually is installed (see Windows start-menu). Source files for upgrading Firmware are accessible from our CDROM and the Website, former firmware version can be found in the European File Selector.

You can use the download utility to upgrade the firmware, the motor database, the profile tables and the PLC program. Possible interfaces are serial PC interfaces (COM1...10) with standard serial (nullmodem) cable or with USB-Serial converter.

Requirement: Microsoft DotNet version 3.5 or later must be installed!

Preparation for serial transmission

  • mains power must be switched off
  • DC link voltage must be <100V
  • 24 VDC power supply must be on to the servo amplifier
  • an RS-232 serial port connection (null modem) between the computer and the servo amplifier (connector X6) must exist
  • The selected RS-232 serial port must not be used by another software
  • DriveUpgrade Tool_....exe, along with the source file for the upgrade, must be accessible by your computer
  • Parameters and motion tasks must be saved in the EEPROM or in external files, Flash Eprom will be cleared. If you are not sure about the parameters, start the amplifier's setup software and save parameters/motion tasks to EEPROM. Close the setup software.

Upgrade

Run the Drive Upgrade Tool.

screen300

1. Select the servo amplifier's type (Drive Type).

2. Select the data type which shall be loaded to the servo amplifier (Type of file to download).

3. Select the interface where the servo amplifier is connected to

4. Click the Browse+Download button to select the file

Attention! Take care that you use the correct file.
Example:
Don't use a motor database file for a firmware upgrade.

5. The process is started now. You can see hints in the process window.

The software initiates communication and set-up for the amplifier. The amplifier displays ‘-‘ in the left most character or "del" on the 3 digit display while it is setting up. When set-up is complete, the ‘-‘ moves to the center character or "Prg" appears on the 3 digit display and the data transfer begins. The upgrade utility monitors the progress with a status bar.

When the process is complete, the tool shows that in the process window:

upgrade2

Cycle the 24 VDC supply to the servo amplifier (turn off then back on) and the firmware download is complete. Close the upgrade tool and your servo amplifier is ready to set-up for your application.


ASCII English SWCNFG

ASCII - Command | SWCNFG |
Syntax Transmit | SWCNFG [Data] |
Syntax Receive | SWCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Unsigned16 | CANBus Object Number | 3600 (hex)
DIM | - | PROFIBUS PNU | 1856 (dec) IND = 1 (dec)
Range | 0 .. 65535 | DPR | 256 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Unsigned16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Configuration of software limit switches

Description

Configuration of software limit switches

The SWCNFG variable can be considered as a bit-variable. The individual bits are interpreted as follows:

Bit 0 =1 Software limit switch 1 active
Bit 1 =1 Software limit switch 2 active

The software limit sitches are acting only after a homing is done.

see also SWE1, SWE2


ASCII English SWE1

ASCII - Command | SWE1 |
Syntax Transmit | SWE1 [Data] |
Syntax Receive | SWE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3604 (hex)
DIM | - | PROFIBUS PNU | 1860 (dec) IND = 1 (dec)
Range | long int | DPR | 260 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | SW limit switch (smallest position)

Description

The variable SWE1 contains the position value for the limit switch..
The scaling of the position depends on the PGEARI / PGEARO / PRBASE parameters, and is calculated according to the following formula:

SWE1[increments] = SWE1[input] * PGEARO / PGEARI

1048576 increments/turn for PRBASE=20
65536 increments/turn for PRBASE=16

SWE1 < SWE2

see also description of SWCNFG


ASCII English SWE2

ASCII - Command | SWE2 |
Syntax Transmit | SWE2 [Data] |
Syntax Receive | SWE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3606 (hex)
DIM | - | PROFIBUS PNU | 1862 (dec) IND = 1 (dec)
Range | long int | DPR | 262 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | SW limit switch (biggest position)

Description

The variable SWE2 contains the position value for the limit switch.
The scaling of the position depends on the PGEARI / PGEARO / PRBASE parameters, and is calculated according to the following formula:

SWE2[increments] = SWE2[input] * PGEARO / PGEARI

1048576 increments/turn for PRBASE=20
65536 increments/turn for PRBASE=16

SWE1 < SWE2

see also description of SWCNFG


ASCII English SYNCSRC

ASCII - Command | SYNCSRC |
Syntax Transmit | SYNCSRC [Data] |
Syntax Receive | SYNCSRC <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3683 (hex)
DIM | - | PROFIBUS PNU | 1987 (dec) IND = 1 (dec)
Range | 0 .. 10 | DPR | 387 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | fieldbus | EEPROM | Yes
Short Description | source for the synchronization

Description

This parameter defines the source for the synchronization of the control loops to the external fieldbus.

0: No synchronization
1: (reserved) synchronization via Sercos
2: Synchronization via KS3000 Fire-Wire option board
3: Synchronization via CANopen
4: old DPR card
5: new DPR card (e.g. EtherCAT wire card)
6: new DPR card with Aquarius Protokoll (EtherCat)


ASCII English T

ASCII - Command | T |
Syntax Transmit | T [Data] |
Syntax Receive | T <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Float | CANBus Object Number | 360E (hex)
DIM | A | PROFIBUS PNU | 1870 (dec) IND = 1 (dec)
Range | -DIPEAK .. DIPEAK | DPR | 270 (dec)
Default | - |
Opmode | 2 | Data Type Bus/DPR | Integer32
Drive State | Enabled | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | current loop | EEPROM | No
Short Description | Digital current setpoint

Description

The “T” command can be used to define a constant current setpoint <i> (in A).
This current setpoint remains effective until a new T / STOP / OPMODE command is executed.


ASCII English TASK

ASCII - Command | TASK |
Syntax Transmit | TASK |
Syntax Receive | TASK <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | String | CANBus Object Number | 360F (hex)
DIM | - | PROFIBUS PNU | 1871 (dec) IND = 1 (dec)
Range | max 80 ASCII Characters | DPR | 271 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Task workload

Description

The TASK command shows the loading for the individual firmware tasks.
The figures signify the number of functions performed per second.


ASCII English TBRAKE

ASCII - Command | TBRAKE |
Syntax Transmit | TBRAKE [Data] |
Syntax Receive | TBRAKE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 366E (hex)
DIM | ms | PROFIBUS PNU | 1966 (dec) IND = 1 (dec)
Range | 10 .. 10000 | DPR | 366 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Disable Delaytime with Holding Brake

Description

TBRAKE defines a disable delay time with holding brake.
If the drive is disabled, it controls the holding brake if selected. After the motor is stopped, the holding brake is switched off and a delay timer (value is TBRAKE) is started. When the time is gone, the drive is disabled.


ASCII English TBRAKE0

ASCII - Command | TBRAKE0 |
Syntax Transmit | TBRAKE0 [Data] |
Syntax Receive | TBRAKE0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 366F (hex)
DIM | ms | PROFIBUS PNU | 1967 (dec) IND = 1 (dec)
Range | -10 .. 10000 | DPR | 367 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | motor | EEPROM | Yes
Short Description | Enable Delaytime with Holding Brake

Description

The parameter TBRAKE0 defines a reaction time of the holding brake when the drive is enabled.
If the drive is enabled (hardware/software enable) the drive controls the holding brake. During the selected time TBRAKE0, the internal velocity setpoint is set to 0. After the time when the brake is open, the setpoint is accepted internally and the motor can run.

Important !
If the value TBRAKE0 is to big, this can cause on a vertical axis a fall down.

If the TRBAKE0 is set to values <0, the internal setpoint is activated before the holding brake is open.


ASCII English TEMPE

ASCII - Command | TEMPE |
Syntax Transmit | TEMPE |
Syntax Receive | TEMPE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3610 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1872 (dec) IND = 1 (dec)
Range | -20 .. 90 | DPR | 272 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | temperatures | EEPROM | No
Short Description | Ambient Temperature

Description

Displays the present internal temperature in °C.


ASCII English TEMPH

ASCII - Command | TEMPH |
Syntax Transmit | TEMPH |
Syntax Receive | TEMPH <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3611 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1873 (dec) IND = 1 (dec)
Range | -20 .. 90 | DPR | 273 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | temperatures | EEPROM | No
Short Description | Heat Sink Temperature

Description

Displays the present heat sink temperature in °C.


ASCII English TEMPM

ASCII - Command | TEMPM |
Syntax Transmit | TEMPM |
Syntax Receive | TEMPM <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3612 (hex)
DIM | Ohms or [MTAB units] | PROFIBUS PNU | 1874 (dec) IND = 1 (dec)
Range | 0 .. 10000 | DPR | 274 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | temperatures | EEPROM | No
Short Description | Motor Temperature

Description

Indicates the motor temperature, in the form of the resistance of the temperature sensor (in ohms). In existing temperature characteristic MTAB the units change for the parameter MAXTEMPM and TEMPM of Ohm to the unit that was used in the characteristic definition.

see also MAXTEMPM, MTAB


ASCII English TEMPMFILT

ASCII - Command | TEMPMFILT |
Syntax Transmit | TEMPMFILT [Data] |
Syntax Receive | TEMPMFILT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38BB (hex)
DIM | ms | PROFIBUS PNU | 1755 (dec) IND = 33 (dec)
Range | 0 .. 50000 | DPR | 955 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.18 |
Configuration | No | Last Change of this Object | 2.7
Function Group | temperatures | EEPROM | Yes
Short Description | time constant for the filter of motor temperature sensors

Description

The parameter TEMPMFILT describes the time constant for filtering of temperature value with motor temperature sensors. Interferences of the signal can be eliminated with this function. The measured and filtered temperature value is used for supervising and for monitoring the motor temperature. The time constant of the filter can be set with TEMPMFILT .


ASCII English TEN

ASCII - Command | TEN |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | - |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Terminal

terminal

Communication with the servo amplifier is made through ASCII commands. A complete object reference is part of the online help or can be downloaded from our website.

Commands sent to the servo amplifier are marked by "-->". The answers from the servo amplifier appear without any preceding characters.

The last 500 lines are displayed.

Command
Enter the ASCII command here, with the parameters. End the entry with RETURN or use the APPLY button to start the transmission.

The terminal software should be used only by experts. In many instances, there will be no confirmation query.

Pressing the F3 function key recalls the last commands (max last 100 commands).


ASCII English TEST1

ASCII - Command | TEST1 |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English TESTENC

ASCII - Command | TESTENC |
Syntax Transmit | TESTENC |
Syntax Receive | TESTENC | Available in |
Type | Command | MMI | Yes
ASCII Format | Command | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | - | DPR | No
Default | - |
Opmode | 2 | Data Type Bus/DPR | Command
Drive State | Enable | Weighting |
Start Firmware | 5.90 |
Configuration | No | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | No
Short Description | test of feedback and motor

Description

Feedback-/motor test offers the possibility of a wiring test for the encoder or motor connection. When the function is started, a slow movement of the motor is initiated in the current control mode (OPMODE = 2) when the output stage is enabled. The movement is purely controlled without the involvement of the position encoder (U/ F mode). The encoder position read is only observed and recorded for the evaluation purposes. The encoder resolution, counting direction as well as the feedback connection can be checked using the position data. For encoders that provide both digital and analogue information (Endat2.1, Hiperface, BiSS-B), it may happen that only the positioning accuracy is lost if the analogue tracks are connected incorrectly. The drive can nevertheless be operated without any problems. Depending on the resolution of the encoder system, such wiring errors can be difficult to find. The present test function continuously reads both the analog (if present) and the digital position information of the encoder and checks them for their plausibility. In case of deviations, it tries to determine the cause of the problem.

The following parameterizations are necessary for the test to be carried out:
- Correct feedback type (FBTYPE)
- Correct parameter setting of the current controller
- Positive encoder counting direction (DIR = 21)
- Correct motor pole number (MPOLES)


ASCII English BQMODE

BQMODE=2

The transfer function is

           s
       ---------- + 1
       2*pi*ARHPF
G(s) = --------------
           s
       ---------- + 1

2*pi*ARLPF

T

BQMODE=3

The transfer function is

             s       2                   s
       ( ---------- )  + 2 * ARHPD * ---------- + 1
         2*pi*ARHPF                  2*pi*ARHPF
G(s) = --------------------------------------------
             s       2                   s
       ( ---------- )  + 2 * ARLPD * ---------- + 1

2*pi*ARLPF 2*pi*ARLPF

BQMODE=4

The transfer function is

                           1
G(s) = --------------------------------------------
             s       2                   s
       ( ---------- )  + 2 * ARLPD * ---------- + 1

2*pi*ARLPF 2*pi*ARLPF


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Online Help for Setup Software DriveGUI.exe

valid for DriveGUI.EXE Version 3.3.2, Edition Mai 2018

This document is a translated version of the original German version.

Contents

General | Screen pages
Introduction | Setup Wizard
How to use the Online-Help | — Basic Setup, Parameter Switching
Safety instructions | — Units / Mechanical
ASCII Object Reference | — CAN- / Fieldbus Settings
Overview Servo Systems | — U/F Control
 | — Motor / Feedback
Installation | — Feedback, Wake&Shake, Test&Diagnosis
Hardware Installation | — Motor, Field Weakening, Cogging
Software Installation | — Current Loop
Switch-On the Amplifier | — Velocity Loop
 | — Position Loop, Extension
Use | — Position Data
Start | — Position Registers
Online/Offline | — Electronic Gearing
Screen layout | — Encoder Emulation
Help functions | — Analog I/O
 | — Digital I/O
Application Notes | Motion Service
Drive calculation | Status (Errors/Warnings)
Servo Pump | Monitor
Macro Programming | Homing
Setup of an unknown motor | Motion Tasks
Software Upgrade | Oscilloscope
Appendix | Bode Plot
Glossary | Terminal
Related documents | I/O Expansion card
Errors | SERCOS
Warnings | PROFIBUS
Trouble Shooting | EtherCAT
 | Autotuning
 | Safety Card
 | SD Card


ASCII English TRJSTAT

ASCII - Command | TRJSTAT |
Syntax Transmit | TRJSTAT |
Syntax Receive | TRJSTAT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3613 (hex)
DIM | - | PROFIBUS PNU | 1875 (dec) IND = 1 (dec)
Range | 0 .. 0xFFFFFFFF | DPR | 275 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.3
Function Group | actual values | EEPROM | No
Short Description | Status2 Information

Description

The TRJSTAT command returns the internal status information in the form of a bit-variable. The status information is primarily used for internal functions. Only the bits that are marked by an “*” can be used for external functions (control system). Bits 16 ... 20 are also mirrored in the DRVSTAT status variable.
Bit | Significance | Meaning
0 | 0x00000001 | =1 the output INPOS2 is updated every msec
1 | 0x00000002 | =1 At the end of the actual motion task, the drive outputs no IN-POSITION signal (a motion task sequence was activated.
2* | 0x00000004 | =1 Toggle Bit "Motion task finished". Is toggled at the end of a motion task. The toggling of the Bit is done, if the target position is reached and the profile generator is switched off. This is different to the functionality of the IN-POSITION Bit. When the drive is switched on, this Bit is set to low.
3...15 |  | reserved
16* | 0x00010000 | =1 Motion task active (position control) Is set, if a motion task is started( motion task, Jog, Homing). Is cleared, if a motion task has finished or is stopped (STOP).
17* | 0x00020000 | =1 Reference point set Is set, if the homing move has successfully finished or if the feedback device is a multiturn encoder. Is cleared, when a homing move is started. see also bit no. 21
18* | 0x00040000 | =1 Home position Is high, if the homing switch is active, otherwise low.
19* | 0x00080000 | =1 In-Position Is set, if the difference between the actual position and the target position is smaller than PEINPOS. Is cleared, if the distance is greater.
20* | 0x00100000 | =1 Position latch activated (positive latch) Is set, if a positive edge at Latch input 2 (configured by IN2MODE=26) was detected. Is cleared, if the position is read by LATCH2P16 / LATCH2P32.
21* | 0x00200000 | =1 Homing move is active Is set, if a Homing move was started. Is cleared, if the homing move is successful or stopped (STOP).
22* | 0x00400000 | =1 Jog move active Is set, if a Jog move is started. Is cleared, if the Jog move is stopped.
23 | 0x00800000 | =1 Position latch activated (negative latch) Is set, if a negative edge at Latch input 2 (configured by IN2MODE=26) was detected. Is cleared, if the position is read by LATCH2N16 / LATCH2N32.
24 | 0x01000000 | =1 Emergency stop active Is set, if an emergency stop has occurred (DEC-phase after an error, active hardware limit switches, Input configured as Emergency stop with level low.
25 | 0x02000000 | =1 position latch at input1 (positive transition), if a rising edge at input 1 is detected, when input1 is defined as latch input (IN1MODE=26). Is reset, if the latched position is read by LATCH1P16 or LATCH1P32.
26 | 0x04000000 | =1 position latch at input1 (negative transition), if a falling edge at input 1 is detected, when input1 is defined as latch input (IN1MODE=26). Is reset, if the latched position is read by LATCH1N16 or LATCH1N32.
27 | 0x08000000 | reserved
28 | 0x10000000 | = 1 (REFDONE) This bit will be set at the end of the homing and the motor is on halt. = 0 This bit will be erased at the start at a motion task or homing.
29 | 0x20000000 | =1 Amplifier is in acceleration stage of a motion task
30 | 0x40000000 | =1 Amplifier is in deceleration stage of a motion task


ASCII English TRUN

ASCII - Command | TRUN |
Syntax Transmit | TRUN |
Syntax Receive | TRUN <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | hhhhh:mm | PROFIBUS PNU | -
Range | 00000:00 to 99999:45 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Run-time counter in min

Description

The run-time counter shows the operating life of the amplifier (if the 24V is applied) in minutes.
The internal resolution of the run-time counter is 1 second.
Since the run-time counter value is included in the serial EEPROM of the amplifier, it is only updated in the EEPROM every 8 minutes So switching off the 24V supply can cause a loss in the record of up to 8 minutes.


ASCII English TRUNS

ASCII - Command | TRUNS |
Syntax Transmit | TRUN |
Syntax Receive | TRUNS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 3614 (hex)
DIM | hhhhh:mm | PROFIBUS PNU | 1876 (dec) IND = 1 (dec)
Range | 00000:00 to 99999:45 | DPR | 276 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Run-time counter in s

Description

FW >=1.61
The run-time counter shows the operating life of the amplifier (if the 24V is applied) in seconds.
The internal resolution of the run-time counter is 1 second.
Since the run-time counter value is included in the serial EEPROM of the amplifier, it is only updated in the EEPROM every 8 minutes So switching off the 24V supply can cause a loss in the record of up to 8 minutes.


ASCII English TSTEP

ASCII - Command | TSTEP |
Syntax Transmit | TSTEP [Data] |
Syntax Receive | TSTEP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 Float Integer16 Float | CANBus Object Number | -
DIM | ms (DurationN) / As (CurrentN) | PROFIBUS PNU | -
Range | Duration:0 to 32767; Current:IPEAKN to IPEAKP | DPR | No
Default | - |
Opmode | 2 | Data Type Bus/DPR | Integer16 Float Integer16 Float
Drive State | Enabled | Weighting |
Start Firmware | 2.32 |
Configuration | No | Last Change of this Object | 1.9
Function Group | current loop | EEPROM | No
Short Description | Service operation torque steps

Description

S700 and S300 FW > 2.32:

The TSTEP command is used to implement a service function through the operating mode "digital torque control" (OPMODE=2). The command can be used in the following forms.
1. TSTEP
The command provides the present settings for the service function.
2. TSTEP T1 C1
A digital setpoint C1 (Amperes) is provided for time T1 (in msec). After T1 has elapsed, the digital setpoint is set to 0.
3. TSTEP T1 C1 T2 C2
A digital setpoint C1 (Amperes) is provided for time T1 (in msec). After T1 has elapsed, a digital setpoint C2 (Amperes) is provided for time T2 (in msec). After T2 has elapsed, the T1/C1 cycle starts again. This command can be used to create an endless reversing operation (rectangular torque progression and triangular velocity progression; T1 and T2 have to be selected as short as the motor cannot be accelerated beyond +/-VOSPD, otherwise the error F08 is generated).
e.g. TSTEP 100 0.5 100 -0.5

The service operation can always be cancelled by using the STOP command.
The "digital torque control" operating mode is a precondition for executing the TSTEP command.


ASCII English UCOMP

ASCII - Command | UCOMP |
Syntax Transmit | UCOMP [Data] |
Syntax Receive | UCOMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3631 (hex)
DIM | PUNIT | PROFIBUS PNU | 1905 (dec) IND = 1 (dec)
Range |  | DPR | 305 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.14 |
Configuration | No | Last Change of this Object | 1.3
Function Group | position loop | EEPROM | Ja
Short Description | Backlash Compensation

Description

For many applications it is necessary to approach motion block positions from one direction only (to avoid backlash errors arising from the interplay of the rack and pinion). To do this, at the start of a motion block the target position for the motion block is shifted by a correction value, and the motion block is only started for the real target value when this corrected position has been reached. The behavior of this function is controlled by the UCOMP parameter. The value of this parameter is the size of the correction, the sign shows the direction in which the correction is to be made. If the sign is positive, the correction is only made for positive velocities (i.e. the target position is always approached from the right), if it is negative, the correction is only made for negative velocities. This function is switched off if UCOMP is set to 0 (default setting).
e.g.
1. Actual position = 0, target position = 1000, UCOMP = 100 -> the drive moves to position 1100, reverses, and stops at position 1000.
2. Actual position = 1000, target position = 0, UCOMP = 100 -> the drive moves directly to position 0
3. Actual position = 1000, target position = 0, UCOMP =-100 -> the drive moves to position -100, reverses, and stops at position


ASCII English UID

ASCII - Command | UID |
Syntax Transmit | UID [Data] |
Syntax Receive | UID <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3616 (hex)
DIM | All | PROFIBUS PNU | 1878 (dec) IND = 1 (dec)
Range | -32768 .. 32767 | DPR | 278 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.7
Function Group | drive configuration | EEPROM | Yes
Short Description | User-ID

Description

The UID variable is used to distinguish customers. Many customers already have numbers assigned.


ASCII English UMAX

ASCII - Command | UMAX |
Syntax Transmit | UMAX [Data] |
Syntax Receive | UMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 2000 | DPR | No
Default | 1900 |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | other commands | EEPROM |
Short Description | maximal output voltage at field weakening

Description

UMAX is a parameter for using a induction maschine and describes the maximal output voltage at field weakening.


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Units / Mechanical

einheiten

The user units for all input fields in the setup software can be preselected here.

Screen text | ASCII parameter
Position | PUNIT
Velocity | VUNIT
Acceleration | ACCUNIT
Position Loop Resolution (nominator) | PGEARI
Position Loop Resolution (denominator) | PGEARO

The adjustment of resolution depends on the application.

Calculation of resolution

Click on the big button which shows the application graphics.

If your application does not correspond to any of the listed examples, enter the required parameters directly in the fields on the “Units” screen.

First, select the application that corresponds to your own. Next, set the position unit. Select the position unit that provides you with the required accuracy for your application.

Example |
max. accuracy | 50nm
Position unit | 10nm

If you change the application type, the selected position unit may become impermissible. In such cases, the position-unit input window remains empty and you have to select a new unit.

Leadscrew

The load is driven via a lead screw. Enter the screw lead.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Conveyor

Enter the driven shaft diameter.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Belt

Enter the driven- and output-shaft diameters.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Gear Belt

Enter the number of teeth per revolution of the driven gear wheel and the number of teeth per unit of length.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Gear Belt 2

Enter the number of teeth on the driven and output gear wheels.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Nip Rolls

Enter the driven shaft diameter.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Direct Drive Rotary

On selecting a length position unit, enter the appropriate radius for the route to be traversed. If the position unit is ° (degrees), you do not have to enter anything else.

Then click the “Calculate conversion factors and return” button.

Direct Drive Linear

The pole-pair width and encoder signal period depend on the device and are set on the Motor or Feedback screens.

Then click the “Calculate conversion factors and return” button.

Rack and Pinion

Enter the number of teeth per revolution of the driven gear wheel and the number of teeth per unit of length.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.

Disk

Enter the radius of the mounted disk.

If a gearhead is flange-mounted on the motor, you must also enter the gearhead data (either the number of teeth or the ratio of the revolutions).

Then click the “Calculate conversion factors and return” button.


ASCII English UPDATE

ASCII - Command | UPDATE |
Syntax Transmit | UPDATE [Data] |
Syntax Receive | UPDATE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | Name | PROFIBUS PNU | -
Range | ALL,USER,TABLE,PROG,PORDER,MBASE,Lookup | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Program Update via RS232

Description

The UPDATE command makes it possible to program the internal Flash EEPROM via the serial interface.

Procedure for a software update:

1. Connect the amplifier to the serial interface of a PC.
2. Start the terminal program HINT2.EXE COM2: 38400 (the computer should be booted in DOS mode).
This establishes the connection between the PPC and the command interpreter of the Drive. To check the connection, enter the LIST command. The response should be a list of all the available commands, shown on the screen.
3. Enter the command UPDATE ALL xxxx in the command line.
xxxx - Name of the firmware file that is to be programmed. Take care that the file xxx for programming is in the active directory. If no file name is entered, then the name ALL is used as a default.

Attention !!! When the drive is programmed with ALL, the loaded motion tasks are deleted. Save motion tasks before programming the firmware.

The programming takes about 40 minutes.

The addresses that are programmed are displayed during the programming procedure. If the display remains static, but the download has not been completed (this problem has been observed on several PCs), then operate the ENTER key. The programming will then carry on.
If the programming procedure is interrupted, then the amplifier will report this in the monitor program at the next power-on (a “-” sign in the first position of the display).
In this case, the download can be restarted by the following command sequence:
X: xxxx
xxxx - Name of the firmware file to be programmed.
Procedure for loading a motor database:

A standard motor database is included as a subset of the firmware. If a customer-specific motor database is required, then it can be loaded after the firmware has been programmed.
This requires the following command:

UPDATE MBASE xxxx

xxxx - Name of the motor database file that is to be programmed. Take care that the file xxx for programming is in the active directory. If no file name is entered, then the name MBASE is used as a default.


ASCII English UVLTMODE

ASCII - Command | UVLTMODE |
Syntax Transmit | UVLTMODE [Data] |
Syntax Receive | UVLTMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3617 (hex)
DIM | - | PROFIBUS PNU | 1879 (dec) IND = 1 (dec)
Range | 0, 1 | DPR | 279 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Undervoltage Mode

Description

The configuration variable UVLTMODE activates or inhibits the undervoltage monitoring of the amplifier.
If the monitoring is activated (UVLTMODE=1), then the fault message F05 (undervoltage) is generated as soon a s the DC-bus voltage falls below the undervoltage threshold VBUSMIN and the output stage is activated .


ASCII English V

ASCII - Command | V |
Syntax Transmit | V |
Syntax Receive | V <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3618 (hex)
DIM | MSPEED | PROFIBUS PNU | 1880 (dec) IND = 1 (dec)
Range | -15000 .. 15000 | DPR | 280 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | Actual Velocity

Description

The present velocity of the motor.


ASCII English VBUS

ASCII - Command | VBUS |
Syntax Transmit | VBUS |
Syntax Receive | VBUS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 361A (hex)
DIM | V | PROFIBUS PNU | 1882 (dec) IND = 1 (dec)
Range | 0 .. 900 | DPR | 282 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | actual values | EEPROM | No
Short Description | DC-bus voltage

Description

The present voltage of the DC-bus.


ASCII English VBUSBAL

ASCII - Command | VBUSBAL |
Syntax Transmit | VBUSBAL [Data] |
Syntax Receive | VBUSBAL <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 361B (hex)
DIM | - / V | PROFIBUS PNU | 1883 (dec) IND = 1 (dec)
Range | 0, 1, 2, 3, 4, 40..750 | DPR | 283 (dec)
Default | depends on type of drive |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 2.8
Function Group | drive configuration | EEPROM | Yes
Short Description | Maximum Line Voltage

Description

This setting is for the maximum permissible voltage for the motor. For instance, if a motor that is rated for a 400V supply is connected to the amplifier, then the setting must be VBUSBAL = 2 (400V). This sets regen and overvoltage thresholds in the amplifier to acceptable values for the motor. This ensures that the motor windings are not damaged.

VBUSBAL - Setting in the range of 40 to 750 are used to choose the maximum network voltage.
In this case ist VBUSMAX = 1,2 x VBUSBAL

only for S300:
VBUSBAL=0 (115 V) VBUSMAX = 235V, regen threshold = 200V

only for S300/S700:
VBUSBAL=1 (230 V) VBUSMAX = 455V, regen threshold = 400V
VBUSBAL=2 (400 V) VBUSMAX = 800V, regen threshold = 720V
VBUSBAL=3 (480 V) VBUSMAX = 900V, regen threshold = 840V

additional for S748/S772 since FW-version 5.67
VBUSBAL=4 (480V) VBUSMAX = 900V, regen threshold = 790V

The default value of VBUSBAL depends on the type of the drive:
S303,S306,S310 : VBUSBAL=2
S341,S343,S346 : VBUSBAL=3
S700: 230V version VBUSBAL=1
S700: 400V version VBUSBAL=3
S748/S772: since FW 5.67 VBUSBAL=4


ASCII English VBUSBOFFS

ASCII - Command | VBUSBOFFS |
Syntax Transmit | VBUSBOFFS [Data] |
Syntax Receive | VBUSBOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 38BF (hex)
DIM | Volt | PROFIBUS PNU | 1759 (dec) IND = 33 (dec)
Range | 0 .. 83 | DPR | 959 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware | 5.19 |
Configuration | No | Last Change of this Object | 2.7
Function Group | drive configuration | EEPROM | Yes
Short Description | abatement of the Regen switch on threshold

Description

This parameter abatements the regen switch on threshold by VBUSBOFFS in volt. By increasing this value the regen resistor is switched on earlier.


ASCII English VBUSCNTMAX

ASCII - Command | VBUSCNTMAX |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 35EE (hex)
DIM | - | PROFIBUS PNU | 1838 (dec) IND = 1 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | drive configuration | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English VBUSFACT

ASCII - Command | VBUSFACT |
Syntax Transmit | VBUSFACT [Data] |
Syntax Receive | VBUSFACT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38C2 (hex)
DIM |  | PROFIBUS PNU | 1762 (dec) IND = 33 (dec)
Range | 0.1 .. 10 | DPR | 962 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.53 |
Configuration | No | Last Change of this Object | 2.7
Function Group | drive configuration | EEPROM | Yes
Short Description | gain factor for the deceleration ramp control

Description

In order to limit the DC link voltage rise that occurs during braking, the slope of the deceleration ramp is controlled depending on the intermediate circuit voltage.

When decelerating the motor, due to the regenerative operation, the DC link voltage increases. If the intermediate circuit voltage exceeds the regen threshold, the control of the ballast resistor is activated. With further increase in the DC link voltage, when the overvoltage threshold is exceeded, the error F02 "DC-link overvoltage" is generated. To avoid this error, the rise in the DC link voltage must be limited. This can be achieved by the braking ramp slope is regulated depending on the intermediate circuit voltage.

VBUSFACT: Gain factor for the deceleration ramp control

Determines the degree of influence of the braking ramp by the increase in the DC link voltage. If the value is higher, the braking curve is flatter.

Please have a look to VBUSRAMP


ASCII English VBUSLIM

ASCII - Command | VBUSLIM |
Syntax Transmit | VBUSLIM [Data] |
Syntax Receive | VBUSLIM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | - | CANBus Object Number | 35F5 (hex)
DIM | % | PROFIBUS PNU | 1845 (dec) IND = 1 (dec)
Range | 70...95 | DPR | 245 (dec)
Default | 90 |
Opmode | All | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.6
Function Group | drive configuration | EEPROM | Yes
Short Description | threshold of the phase failure monitoring

Description

This parameter describes th threshold of the phase failure monitoring function.

The dimension of this bar is % of the avarage DC bus. If the bar of the DC bus for min. 25msec fall below, there will be generatet a warning (n05) or a fault (F19) depending on the settings of PMODE.


ASCII English VBUSMAX

ASCII - Command | VBUSMAX |
Syntax Transmit | VBUSMAX |
Syntax Receive | VBUSMAX <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 361C (hex)
DIM | V | PROFIBUS PNU | 1884 (dec) IND = 1 (dec)
Range | 235, 455, 800, 900 | DPR | 284 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | drive configuration | EEPROM | No
Short Description | Maximum DC-bus Voltage

Description

The VBUSMAX parameter shows the value for the monitoring threshold for the fault message F02 (overvoltage).
This fault message is generated as soon as the DC-bus voltage goes above the value of VBUSMAX. The VBUSMAX threshold depends on the setting for VBUSBAL.

VBUSBAL=0 (115 V) VBUSMAX=235V
VBUSBAL=1 (230 V) VBUSMAX=455V
VBUSBAL=2 (400 V) VBUSMAX=800V
VBUSBAL=3 (480 V) VBUSMAX=900V
VBUSBAL=4 (480 V) VBUSMAX=900V (only for S748/S772 from FW 5.67)


ASCII English VBUSMIN

ASCII - Command | VBUSMIN |
Syntax Transmit | VBUSMIN [Data] |
Syntax Receive | VBUSMIN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 361D (hex)
DIM | V | PROFIBUS PNU | 1885 (dec) IND = 1 (dec)
Range | 30 .. 800 | DPR | 285 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | Yes
Short Description | Minimum DC-bus Voltage

Description

VBUSMIN defines the lower threshold for monitoring the DC-bus voltage. The fault message F05 (undervoltage) is generated as soon as the DC-bus voltage goes below this threshold. Undervoltage monitoring is only active under the following conditions.
1. Output stage is enabled
2. Monitoring is activated UVLTMODE=1
3. MAINSBTB function is not active (OxMODE<>3)
4. The switch-off of the monitoring function by a digital input (INxMODE=21) is not active.


ASCII English VBUSOFFS

ASCII - Command | VBUSOFFS |
Syntax Transmit | VBUSOFFS [Data] |
Syntax Receive | VBUSOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38D0 (hex)
DIM | V | PROFIBUS PNU | 1776 (dec) IND = 33 (dec)
Range | -10 ... 10 | DPR | 976 (dec)
Default | 0 |
Opmode | all | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 5.65 |
Configuration | No | Last Change of this Object | 2.11
Function Group | drive configuration | EEPROM | Yes
Short Description | correction value for the regen threshold S748/S772

Description

This parameter corrected voltage offset between working in DC composite amplifiers. If the ballast benefits are not shared equally among the coupled amplifiers, this can be caused by offsets in the voltage measurement. Increasing this value reduces the ballast power at the associated amplifier.


ASCII English VBUSRAMP

ASCII - Command | VBUSRAMP |
Syntax Transmit | VBUSRAMP |
Syntax Receive | VBUSRAMP | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 38C1 (hex)
DIM | % | PROFIBUS PNU | 1761 (dec) IND = 33 (dec)
Range | -100 .. 100 | DPR | 961 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 5.33 |
Configuration | No | Last Change of this Object | 2.7
Function Group | drive configuration | EEPROM | Yes
Short Description | switching on threshold for the braking ramp control

Description

In order to limit the DC link voltage rise that occurs during braking, the slope of the deceleration ramp is controlled depending on the intermediate circuit voltage.

When decelerating the motor, due to the regenerative operation, the DC link voltage increases. If the intermediate circuit voltage exceeds the regen threshold, the control of the ballast resistor is activated. With further increase in the DC link voltage, when the overvoltage threshold is exceeded, the error F02 "DC-link overvoltage" is generated. To avoid this error, the rise in the DC link voltage must be limited. This can be achieved by the braking ramp slope is regulated depending on the intermediate circuit voltage.

VBUSRAMP: switching on threshold for the braking ramp control

This parameter describes the voltage threshold at which uses the ramp control.The value refers to the difference between the Balla stone threshold and the overvoltage threshold.
VBUSRAMP = 100%, the regulation sets a threshold for the ballast (100% below the overvoltage threshold)
VBUSRAMP = 20% of the control action starts at a voltage that is 20% below the overvoltage threshold
VBUSRAMP = 0 (default) control turned off

The deceleration ramp is scaled linearly between the "switch-on" and "Overvoltage Threshold".

DC link voltage <switch-on -> no ramp limitation

When specifying a negative value VBUSRAMP can be activated instead of a linear scale, a square scaling.

e.g. VBUSRAMP = -100%

please have alook to VBUSFACT


ASCII English VBW

ASCII - Command | VBW |
Syntax Transmit | VBW |
Syntax Receive | VBW | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | 0 | DPR | No
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Generate Bode Diagram

Description

VBW [fmin] [fmax] [sample] [switch]

Velocity BandWidth

Using the function VBW the Drive calculates a velocity loop Bode plot. Default are 30 samples (sample) between 20 Hz (fmin) and 800 Hz (fmax). Output are the gain in db and the phase shift in degree of the open loop and the closed loop of the velocity controller. Using MSG 2 the results are immediately shown. Standard is to query the data with the GET command. To use the function VBW the drive should be in OPMODE 0 and enabled. The shaft will move only a few degree. In case of resonance load velocity overshoot can cause a Fault which can result in an uncontrolled coasting of the motor.

[switch] = 1: Filter switched off
GV reduced to 20%
GVTN reduced to 50 ms


ASCII English VCMD

ASCII - Command | VCMD |
Syntax Transmit | VCMD |
Syntax Receive | VCMD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 361E (hex)
DIM | MSPEED | PROFIBUS PNU | 1886 (dec) IND = 1 (dec)
Range | -VMAX .. VMAX | DPR | 286 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | No
Short Description | Internal Velocity Setpoint in RPM

Description

The VCMD variable contains the internal velocity setpoint (after the ramp generator) in RPM.
Depending on the operating mode that is set (OPMODE=0), this value is either provided directly and digitally (fieldbus, slot card) or derived from the analog velocity setpoint (OPMODE=1).
For operating modes that do not use a velocity control loop (OPMODE=2,3) the VCMD variable has the value V of the actual velocity.


ASCII English VCOMM

ASCII - Command | VCOMM |
Syntax Transmit | VCOMM [Data] |
Syntax Receive | VCOMM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 365A (hex)
DIM | [VUNIT] | PROFIBUS PNU | 1946 (dec) IND = 1 (dec)
Range | 0 .. 1.2 * MSPEED | DPR | 346 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity Threshold for Commutation error

Description

The command VCOMM defines the threshold for the commutation error function.
The definition of an commutation error is that the sign of the actual current has the right relationship to the sign of the change of the velocity of the motor. This indicates a run-away of the motor and causes a disable of the output stage.

This commutation error is supervised, if the actual velocity is above the VCOMM threshold. To disable the function, VCOMM has to be set to VLIM.


ASCII English VCTIME

ASCII - Command | VCTIME |
Syntax Transmit | VCTIME [Data] |
Syntax Receive | VCTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3867 (hex)
DIM | ms | PROFIBUS PNU | 1671 (dec) IND = 33 (dec)
Range | 0 ... 100 | DPR | 871 (dec)
Default | 24 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 2.31 |
Configuration | No | Last Change of this Object | 1.9
Function Group | velocity loop | EEPROM | No
Short Description | Commutation error time

Description

VCTIME defines a commutation error surveillance time
Conditions for a commutation error have to be fullfilled for VCTIME msec before an error F25 is generated.


ASCII English VEL0

ASCII - Command | VEL0 |
Syntax Transmit | VEL0 [Data] |
Syntax Receive | VEL0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3620 (hex)
DIM | - | PROFIBUS PNU | 1888 (dec) IND = 1 (dec)
Range |  | DPR | 288 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | velocity loop | EEPROM | Yes
Short Description | Standstill Threshold

Description

The VEL0 (Velocity "0") parameter defines the velocity threshold (in RPM) for the standstill signal.
The standstill signal is required for the following functions:
1. Standstill signal in the status register DRVSTAT.
2. If the brake is configured (MBRAKE=1), then, if the output stage is disabled, first of all the velocity is reduced to 0, and the brake is only applied after the velocity has fallen below the standstill threshold.
3. If the ACTFAULT option is activated (active braking in the event of a fault), or the STOPMODE option (active braking if the output stage is disabled), then the standstill threshold defines the velocity below which the output stage will actually be disabled.

The minimum VEL0 value is changed from 0 rpm to 1 rpm in FW >= 2.14


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Velocity Loop

einheiten

Parameters for tuning the velocity loop. Usually changes are not necessary, if the motor dataset is correct.

Screen text | ASCII parameter
Speed Limit (pos.) | VLIMP
Speed Limit (neg.) | VLIMN
Speed treshold | VEL0
Overspeed | VOSPD
Acc. Ramp | ACC
Dec. Ramp | DEC
PI-Plus | GVFR
Gain (Kp_v) | GV
Integral Time (Tn_v) | GVTN
LP-Freq. | ARLPF
2nd LP-Freq. | ARLP2
HP-Freq. | ARHPF

Deceleration/Disable Behavior

Screen text | ASCII parameter
Deceleration/Disable Behavior (Error) - more information to the errors see parameter ERRCODES | ACTFAULT
Dec. Ramp | DECSTOP
Deceleration/Disable Behavior (Disable Command) | STOPMODE
Dec. Ramp | DECDIS


ASCII English VER

ASCII - Command | VER |
Syntax Transmit | VER [*] |
Syntax Receive | VER <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range | max 50 ASCII Characters | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Firmware Version

Description

The command VER returns the version designation and the date of creation for the firmware.
The expanded form of the command (VER *) returns a version list for the various firmware and hardware components.
- Version of the basic firmware
- Hardware revision
- CPLD version
- CAN: firmware version
- Version of the motor database (MDB)
- Profibus/Sercos firmware version


ASCII English VINPOS

ASCII - Command | VINPOS |
Syntax Transmit | VINPOS [Data] |
Syntax Receive | VINPOS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3856 (hex)
DIM |  | PROFIBUS PNU | 1654 (dec) IND = 33 (dec)
Range | 0 .. 120% of MSPEED | DPR | 854 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting | 1000
Start Firmware | 1.37 |
Configuration | Yes | Last Change of this Object | 2.13
Function Group | velocity loop | EEPROM | Yes
Short Description | Velocity within InPosition window

Description

VINPOS command defines the size of the velocity InPosition windows for the VINPOS state message (Bit 1 in DRVSTAT2).
As long as the difference between the last target velocity (VCMD) and the actual velocity (V) is within the width of the velocity In-Position window (VINPOS), a 1 is signalled, otherwise a 0
The signal change is not signaled before the new state was valid at least INPT0 msec.


ASCII English VJOG

ASCII - Command | VJOG |
Syntax Transmit | VJOG [Data] |
Syntax Receive | VJOG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3621 (hex)
DIM | see VUNIT | PROFIBUS PNU | 1889 (dec) IND = 1 (dec)
Range | -500008 ... 500008 | DPR | 289 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Speed for Jog Mode

Description

Jog mode is effectively an endless motion task, and is implemented by the internal position control loop.
The sign for the speed indicates the direction for jog operation. The scaling of the velocity is given in position control loop units, and depends on the PGEARI and PGEARO parameters.


ASCII English VLIM

ASCII - Command | VLIM |
Syntax Transmit | VLIM [Data] |
Syntax Receive | VLIM <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 358C (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1740 (dec) IND = 1 (dec)
Range | 0.0 .. MSPEED | DPR | 140 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Max. velocity

Description

The VLIM parameter defines the maximum velocity (velocity control loop) in units defined by VUNIT.
VLIM is also used for limiting the following parameters:
1. MVANGLB <= 0.9*VLIM
2. MSPEED >= VLIM
3. PVMAX <= (VLIM * PGEARI * 2^PRBASE) / (60 * PGEARO)

When used together with the VLIMN and/or VLIMP parameters, it is possible to implement a directionally-dependent rotational velocity limit. The VLIM command determines the maximum velocity for both positive and negative directions.


ASCII English VLIMN

ASCII - Command | VLIMN |
Syntax Transmit | VLIMN [Data] |
Syntax Receive | VLIMN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3623 (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1891 (dec) IND = 1 (dec)
Range | 0.0 .. MSPEED | DPR | 291 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Max. negative velocity

Description

The VLIMN parameter defines the maximum velocity for the negative direction (velocity control loop) in units defined by VUNIT.VLIMN is also used for limiting PVMAXN:
PVMAXN <= (VLIMN * PGEARI * 2^PRBASE) / (60 * PGEARO)

When used together with the VLIMP parameter, it is possible to implement a directionally-dependent rotational velocity limit. The VLIMP command determines the maximum velocity for the positive direction.


ASCII English VLIMP

ASCII - Command | VLIMP |
Syntax Transmit | VLIM [Data] |
Syntax Receive | VLIMP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3622 (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1890 (dec) IND = 1 (dec)
Range | 0.0 .. MSPEED | DPR | 290 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.14
Function Group | velocity loop | EEPROM | Yes
Short Description | Max. velocity

Description

The VLIMN parameter defines the maximum velocity for the positiv direction (velocity control loop) in units defined by VUNIT.
VLIMPis also used for limiting PVMAXN:
PVMAXP <= (VLIMP * PGEARI * 2^PRBASE) / (60 * PGEARO)

When used together with the VLIMN parameter, it is possible to implement a directionally-dependent rotational velocity limit. The VLIMN command determines the maximum velocity for the negative direction.


ASCII English VLO

ASCII - Command | VLO |
Syntax Transmit | VLO [Data] |
Syntax Receive | VLO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 363D (hex)
DIM | - | PROFIBUS PNU | 1917 (dec) IND = 1 (dec)
Range | 0 ... 30 | DPR | 317 (dec)
Default | 0.5 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | feedback | EEPROM | Yes
Short Description | Software resolver/digital converter feedforward

Description

VLO is a parameter of the Luenberger Velocity Observer. To reduce the delay of the derivation the observer can be served with the torque component of the current. The effective inertia is estimated by the gain of the velocity loop (GV). Setting VLO to zero the acceleration will not influence the observer. With a value of 1 the acceleration is full enabled. With VLO 0.5 the Observer will use 50% of the acceleration torque. Reducing VLO can result in an instable velocity loop.


ASCII English VLO_X

ASCII - Command | VLO_X |
Syntax Transmit | VLO_X [Data] |
Syntax Receive | VLO_X <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38C0 (hex)
DIM | - | PROFIBUS PNU | 1760 (dec) IND = 33 (dec)
Range | 0 ... 30 | DPR | 960 (dec)
Default | 0.5 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.7
Function Group | feedback | EEPROM | Yes
Short Description | Software resolver/digital converter feedforward

Description

VLO_X is a parameter of the Luenberger Velocity Observer. To reduce the delay of the derivation the observer can be served with the torque component of the current. The effective inertia is estimated by the gain of the velocity loop (GV). Setting VLO_X to zero the acceleration will not influence the observer. With a value of 1 the acceleration is full enabled. With VLO_X 0.5 the Observer will use 50% of the acceleration torque. Reducing VLO_X can result in an instable velocity loop.

Switching over parameter sets is realized with a pointer, which always points to one of the two parameter structures (parameter set 1: default or parameterset 2: shadow parameters). While switching the pointer between these two structures all parameters that are defined in the structures are switched over in parallel. Because the parameters are already converted in the structures, it is avoided that undefined conditions occure.

The parameters of the second parameter set are defined similarly to the major parameter set by ASCII commands. To define the second parameter set, the sequence "_X" must be added to the ASCII command.

Example:
The command "GV" is used to define the gain of the velocity controller. To change this parameter in the second parameter set the command "GV_X" must be used.

To save memory in the amplifier, only those parameters are stored in the second set, which differ from the first parameter set. If no parameter is preset for the second set, thes econd set is initialised automatically identical to the first set. The user must therefore only define the rerquired parameters for the second set, not all parameters.

The automatical initialising of the second parameters set always requires an update of the set, if a parameter of the first set has been changed. This could result in a reset of special second set parameters. To avoid this, the parameterizing of the second set must always been done after initializing the first set.

As soon as PAR_X gets a different value than PAR,this parameter is saved in the serial EEPROM. The value of PAR_X now appears in the DUMP list at the end of the parameter section.

All parameters that can be used for this functionality can be listed combined with their values by the command PARDUMP.


ASCII English VMIX

ASCII - Command | VMIX |
Syntax Transmit | VMIX [Data] |
Syntax Receive | VMIX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3625 (hex)
DIM |  | PROFIBUS PNU | 1893 (dec) IND = 1 (dec)
Range | 0.0 .. 1.0 | DPR | No
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 5.92 |
Configuration | No | Last Change of this Object | 2.13
Function Group | feedback | EEPROM | Yes
Short Description | Velocity Mix: Feedback / external Encoder

Description

If an external encoder is used for position control EXTPOS=1 the commutation and speed control uses the feedback device of the motor (feedback device selected by FBTYPE).

VMIX sets the ratio of the motor feedback and external device used by the speed controler.

e.g.
VMIX=1.0 Velocity exclusively from the feedback device selected by FBTYPE (100 %)
VMIX=0.5 50 % feedback device selected by FBTYPE / 50 % external encoder

VMIX is available if FILTMODE = 0 or 1.
VMIX is available only in position mode OPMODE = 8


ASCII English VMUL

ASCII - Command | VMUL |
Syntax Transmit | VMUL [Data] |
Syntax Receive | VMUL <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3626 (hex)
DIM | - | PROFIBUS PNU | 1894 (dec) IND = 1 (dec)
Range | 1 .. 65535 | DPR | 294 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.13
Function Group | fieldbus | EEPROM | Yes
Short Description | Velocity scale factor

Description

VMUL is required by many fieldbus systems (PROFIBUS,CANBUS), since some fieldbus protocols only permit speed values in 16-bit format.The VMUL parameter is used to scale the speed (position control loop) for jog mode and motion tasks. This scaling factor can then be used to expand the 16-bit speed value from the fieldbus to give the internal 32-bit value.

See also: manual for PROFIBUS, CANBUS


ASCII English VOHPD

ASCII - Command | VOHPD |
Syntax Transmit | VOLPD [Data] |
Syntax Receive | VOHPD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 10 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | filter | EEPROM | Yes
Short Description | Higher order velocity-observer high-pass damping

Description

Higher order velocity-observer high-pass damping

See also MRESBW, VOLPD, VOHPD


ASCII English VOHPF

ASCII - Command | VOHPF |
Syntax Transmit | VOHPF [Data] |
Syntax Receive | VOHPF <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | Hz | PROFIBUS PNU | -
Range | 0 .. 10000 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | filter | EEPROM | Yes
Short Description | Higher order velocity-observer high-pass frequency

Description

Higher order velocity- observer high-pass frequency

See also MRESBW, VOLPD, VOHPD


ASCII English VOLPD

ASCII - Command | VOLPD |
Syntax Transmit | VOLPD [Data] |
Syntax Receive | VOLPD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | -
DIM |  | PROFIBUS PNU | -
Range | 0 .. 10 | DPR | No
Default | 0.5 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.13
Function Group | filter | EEPROM | Yes
Short Description | Higher order velocity-observer low-pass damping

Description

Higher order velocity-observer low-pass damping

If VOLPD is set to a nonzero value, the higher order velocity observer is activated and used instead of the regular observer.
MRESBW then defines the low-pass-filter frequency and VOLPD its damping.

See also MRESBW, VOHPF, VOHPD.


ASCII English VOMODE

ASCII - Command | VOMODE |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default | 4 |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware | 2.20 |
Configuration | No | Last Change of this Object | 2.12
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English VOMOPDE

ASCII - Command | VOMOPDE |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | -
DIM | - | PROFIBUS PNU | -
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State | - | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English VOSPD

ASCII - Command | VOSPD |
Syntax Transmit | VOSPD [Data] |
Syntax Receive | VOSPD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3627 (hex)
DIM | rpm | PROFIBUS PNU | 1895 (dec) IND = 1 (dec)
Range | 0.0 .. 1.2*MSPEED | DPR | 295 (dec)
Default | 3600 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Overspeed

Description

The VOSPD parameter sets the overspeed threshold. As soon as the actual velocity exceeds this limit, the fault message F08 (overspeed) is generated and the output stage is disabled.


ASCII English VOSPDREF

ASCII - Command | VOSPDREF |
Syntax Transmit | VOSPDREF [Data] |
Syntax Receive | VOSPDREF <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | -
DIM | rpm | PROFIBUS PNU | -
Range | 0.0 .. 1.2 * MSPEED | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting | 1000
Start Firmware | 3.15 |
Configuration | Yes | Last Change of this Object | 2.1
Function Group | position loop | EEPROM | Yes
Short Description | Overspeed limit for homing phase

Description

This parameter defines the overspeed limit value during the homing phase.
In the case of VOSPDREF=0 the main overspeed limit VOSPD is activ.
After the homing move is done , the VOSPDREF becomes inactiv.
In the case that no homing move is required the VOSPDREF can be deactivated by writing the 0 value.


ASCII English VOUTMAX

ASCII - Command | VOUTMAX |
Syntax Transmit | VOUTMAX [Data] |
Syntax Receive | VOUTMAX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | -
DIM | % | PROFIBUS PNU | -
Range | 0 .. 1 | DPR | No
Default | 0.95 |
Opmode | all | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | - |
Configuration | No | Last Change of this Object | 2.11
Function Group | sensorless | EEPROM | Yes
Short Description | sensorless mode: maximum output voltage

Description

The parameter VOUTMAX specifies the maximum output voltage in sensorless mode: 1 = 100%


ASCII English VREF

ASCII - Command | VREF |
Syntax Transmit | VREF [Data] |
Syntax Receive | VREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3628 (hex)
DIM | ( >VUNIT) | PROFIBUS PNU | 1896 (dec) IND = 1 (dec)
Range | 0 ... VLIM/VLIMN | DPR | 296 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Speed for homing

Description

The VREF is used to define the velocity value (VREF>0) for homing to a reference. The direction of the reference is taken from the DREF variable.
The scaling of the velocity is given in position control loop units, and depends on the PGEARI and PGEARO parameters.


ASCII English VREF0

ASCII - Command | VREF0 |
Syntax Transmit | VREF0 [Data] |
Syntax Receive | VREF0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3698 (hex)
DIM | - | PROFIBUS PNU | 2008 (dec) IND = 1 (dec)
Range | 0.01 .. 2.0 | DPR | 408 (dec)
Default | 0.125 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | Yes
Short Description | Homing mode reduction factor

Description

The parameter VREF0 reduces the homing speed, after the load reaches e.g. the reference switch, while searching for a zero pulse of an external encoder.
The selection of the source of the zero pulse can be selected by REFMODE.
The second homing speed can be reduced by VREF0 in % of VREF.

Example 1:

REFMODE=1 Zeropulse via digital input 1
NREF=1 Homing move with reference switch with zero pulse
VREF=10000 Homing speed 10000 µm/sec
VREF0=0.2 Reduction of the speed to 2000 µm/sec

Starting a homing move, the drive starts to find the reference switch with the speed of 10000 µm/sec. If the reference switch was found, the speed is reduced to 2000 µm/sec and then the search for the zero pulse is started. If the zero pulse was recognised at digital input 1(high level), the homing move is stopped.

Example 2:

REFMODE=2 Zero pulse via digiatl input 2
NREF=5 Zero pulse in one turn of the motor
VREF=10000
VREF0=0.2

The criteria for the search of the zero pulse is fulfilled, so the reference move is directly started with 2000 µm/sec.


ASCII English VSCALE1

ASCII - Command | VSCALE1 |
Syntax Transmit | VSCALE1 [Data] |
Syntax Receive | VSCALE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3629 (hex)
DIM | VUNIT / 10 V | PROFIBUS PNU | 1897 (dec) IND = 1 (dec)
Range | -16000 .. 16000 (for VUNIT=0) | DPR | 297 (dec)
Default | 3000 (for VUNIT=0) |
Opmode | 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | analog I/O | EEPROM | Yes
Short Description | SW1 velocity scaling factor

Description

If the analog input 1 is used as the setpoint input for velocity control, then the VSCALE1 parameter can be used to set the scaling of the input voltage.
A 10V velocity setpoint input at input 1 produces a velocity of VSCALE1.

Attention: VSCALE1/VSCALE2 may not be smaller than 2UPM!


ASCII English VSCALE2

ASCII - Command | VSCALE2 |
Syntax Transmit | VSCALE2 [Data] |
Syntax Receive | VSCALE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 362A (hex)
DIM | rpm / 10 V | PROFIBUS PNU | 1898 (dec) IND = 1 (dec)
Range | -16000 .. 16000 (for VUNIT=0) | DPR | 298 (dec)
Default | 3000 (for VUNIT=0) |
Opmode | 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 2.10
Function Group | analog I/O | EEPROM | Yes
Short Description | SW2 velocity scaling factor

Description

If the analog input 2 is used as the setpoint input for velocity control, then the VSCALE2 parameter can be used to set the scaling of the input voltage.
A 10V velocity setpoint input at input 2 produces a velocity of VSCALE2.

Attention: VSCALE1/VSCALE2 may not be smaller than 2UPM!


ASCII English VSTART

ASCII - Command | VSTART |
Syntax Transmit | VSTART [Data] |
Syntax Receive | VSTART <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3888 (hex)
DIM |  | PROFIBUS PNU | 1704 (dec) IND = 33 (dec)
Range | 0 .. 1 | DPR | 904 (dec)
Default | 0.05 |
Opmode | 1,2 | Data Type Bus/DPR | Integer32
Drive State |  | Weighting | 1000
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.1
Function Group | other commands | EEPROM | Yes
Short Description | Starting Voltage for V/f Control

Description

Starting Voltage for V/f Control (induction motor).
Given as a fraction of the nominal voltage.
Used to calculate V/f trajectory at lower speeds.
Voltage when velocity command is 0 (J = 0).


ASCII English VSTFR

ASCII - Command | VSTFR |
Syntax Transmit | VSTFR [Data] |
Syntax Receive | VSTFR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36A5 (hex)
DIM | VUNIT | PROFIBUS PNU | 2021 (dec) IND = 1 (dec)
Range | 0 ... 230 UPM | DPR | 421 (dec)
Default | 0 |
Opmode | 0, 1, 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 1.30 |
Configuration | No | Last Change of this Object | 1.1
Function Group | other commands | EEPROM | Yes
Short Description | Velocity for max. friction compensation

Description

see ISTFR


ASCII English VTIMEKD

ASCII - Command | VTIMEKD |
Syntax Transmit | VTIMEKD [Data] |
Syntax Receive | VTIMEKD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 38DC (hex)
DIM | ms | PROFIBUS PNU | 1788 (dec) IND = 33 (dec)
Range | -- | DPR | 988 (dec)
Default | 1 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weighting | 1000
Start Firmware | 6.00 |
Configuration | No | Last Change of this Object | 2.12
Function Group | servo pump | EEPROM | Yes
Short Description | time const. of d component for the volume flow controller

Description

This parameter can be used to configure the time constant (in ms) of the D component for the volume flow controller.


ASCII English VTUNE

ASCII - Command | VTUNE |
Syntax Transmit | VTUNE [Data] |
Syntax Receive | VTUNE <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer16 Float | CANBus Object Number | -
DIM | Ms (DurationN) / rpm (velocityN) | PROFIBUS PNU | -
Range | 0..32767 | DPR | No
Default |  |
Opmode | 0 | Data Type Bus/DPR | Integer16 Float
Drive State | Enable | Weighting |
Start Firmware | 3.65 |
Configuration | No | Last Change of this Object | 2.2
Function Group | velocity loop | EEPROM | No
Short Description | Autotuning Velocity Loop

Description

The step height and –duration can be set according to the machine:

1. VTUNE
Without parameters, the velocity set point varies between +100rpm and -100 for the duration of 400ms.

2. VTUNE T1 V1
The velocity set point varies between +V1 and –V1 (rpm) for the duration T1 (ms)

The slope of the steps is defined by ACC and DEC.
For best results the slope should be set as steep as possible (Observe machine constraints !).

The process can be stopped ant any time using the STOP command.


ASCII English VUNIT

ASCII - Command | VUNIT |
Syntax Transmit | VUNIT [Data] |
Syntax Receive | VUNIT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 365F (hex)
DIM | - | PROFIBUS PNU | 1951 (dec) IND = 1 (dec)
Range | 0 .. 8 | DPR | 351 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | digital I/O | EEPROM | Yes
Short Description | Systemwide Definition of Velocity / Speed

Description

VUNIT gives the systemwide definition of velocity / speed resolution. This parameter effects all parameters that are related to velocity of the velocity controller and speed of the position controller.

VUNIT = 0 gives velocity in RPM (example OPMODE = 0)
gives speed in µm/sec (example OPMODE = 8).
VUNIT = 1 Unit = RPM
VUNIT = 2 Unit = Rad/Sec
VUNIT = 3 Unit = Degree/Sec
VUNIT = 4 Unit = increments in PRBASE-format / 250µs

example: PRBASE = 24
1500U/min = 25U/s = 25*2^24/4000 IncrPRBASE / 250µs = 104857 IncrPRBASE / 250µs

VUNIT = 5 Unit = PUNIT / Sec
VUNIT = 6 Unit = PUNIT / Min
VUNIT = 7 Unit = 1000 * PUNIT / Sec
VUNIT = 8 Unit = 1000 * PUNIT / Min

Remark:
1. All parameters that are related to velovity have a fixed format of 32 Bit with 3 fractional digits. This causes a problem with some of the VUNIT settings (especially VUNIT=6), related to the resolution of the position controller (PGEARI), that not the full range of speed can be used. Under this condition, a different setting of VUNIT is necessary.

2. All parameters that are related to speed have a fixed format of 32 Bit with no fractional digits. This causes a problem with some of the VUNIT settings (especially VUNIT=3) to give fractional digits. Under this condition, a different setting of VUNIT is necessary.

Definition of the Calculation factors

VUNIT=1 1 UPM = 1048576*32/(4000*60) =~ 139.8 Counts
VUNIT=2 1 Rad/sec = 1048576*32/(4000*2*PI) =~ 1335 Counts
VUNIT=3 1 Grad/sec = 1048576*32/(4000*360) =~ 23.3 Counts
VUNIT=4 1 Counts/250µs = 32 Counts
VUNIT=5 1 PUNIT / sec = PGEARO / (125 * PGEARI)
VUNIT=6 1 PUNIT / min = (PGEARO * 60) / (125 * PGEARI)
VUNIT=7 1000 PUNIT / sec = PGEARO / (125 * PGEARI * 1000)
VUNIT=8 1000 PUNIT / min = (PGEARO * 60) / (125 * PGEARI * 1000)


ASCII English VWM

ASCII - Command | VWM |
Syntax Transmit | VWM [Data] |
Syntax Receive | VWM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3759 (hex)
DIM | - | PROFIBUS PNU | 1801 (dec) IND = 17 (dec)
Range | 0 ... 1500 | DPR | 601 (dec)
Default | 400 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.35 |
Configuration | No | Last Change of this Object | 1.2
Function Group | feedback | EEPROM | No
Short Description | limit value for SinCos voltage

Description

VWM defines the limit value for n23 warning (SinCos voltage too low). This warning can be used to get a message when a SinCos encoder (linear unit) becomes dirty


DriveGUI Online Hilfe

ASCII Object Reference

Help Start page

Send us Feedback

Screen pages

Setup Wizard

setupwizard

The Setup Wizard leads you through the necessary steps for configuring your servo amplifier. Depending on the selected application, only the active screen pages are necessary.

Select the setup type for your application:

— Quick Motor/Drive Setup
— Analog Application Setup
— Gearing Application Setup
— Motion Task Application Setup
— Complete Setup
— Induction Motor Setup V/f Control)

Enter the wizard. The first relevant screen page for your application pops up. Click "Next" and "Previous" to move between screens, or move directly to any screen by clicking in the navigation tree on the left.

Click the "Refresh" toolbar button to bring back the original data for the current screen.

If you need more or all setup pages, change the Setup Wizard setting. The last setting is saved when you exit the software and will be reloaded at restart.


ASCII English WMASK

ASCII - Command | WMASK |
Syntax Transmit | WMASK [Data] |
Syntax Receive | WMASK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 363E (hex)
DIM | - | PROFIBUS PNU | 1918 (dec) IND = 1 (dec)
Range | -21474836470 ... 21474836470 | DPR | 318 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | drive configuration | EEPROM | No
Short Description | Warning as fault mask

Description

The WMASK parameter can be used to reconfigure a warning as the fault message F24.
The WMASK parameter is a bit-variable, with bit assignments that correspond to the STATCODE * status variable. The bit that is set within the WMAKS variable means that the corresponding warning bit in the STATCODE * variable should generate an F24 fault message, as well as a warning. Unlike warnings, a fault message results in the disabling of the output stage, and the opening of the BTB contact. A reconfiguration of a warning to a fault message can be especially relevant for the following warnings: contouring/following error, threshold detection, hardware limit switch. The value has to be entered in decimal.

See also LASTWMASK


ASCII English WPOS

ASCII - Command | WPOS |
Syntax Transmit | WPOS |
Syntax Receive | WPOS <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3636 (hex)
DIM | - | PROFIBUS PNU | 1910 (dec) IND = 1 (dec)
Range | 0, 1, 2 | DPR | 310 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Enable position registers

Description

Going above/below a position is detected and signaled by the position register within 1 millisecond. The functional range can be set to continually or once.
The fast position registers are enabled through the WPOS configuration variable.
WPOS=0 Position register disabled
WPOS=1 Position register enabled, no spontaneous CAN message on change of status.
WPOS=2 Position register enabled, spontaneous CAN message on change of status (this setting is only via CAN-Bus possible).

Changes of the WPOS variable between 0 and >0 can only be made offline (SAVE and COLDSTART), a change between 1 and 2 can also be made online.

There is a total of 16 position registers P1 ... P16, that can be configured with the help of 3 control variables. The position signals are indicated through a status variable. All control/status variables can be considered as 32-bit variables, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.

Control variables:
WPOSE Enable/disable a position register
Bit=0 the corresponding position register is not monitored
Bit=1 the position register is monitored

WPOSP Polarity for the position signaling
Bit=0 Position signal is generated on going above/beyond (overrun) the position
Bit=1 Position signal is generated on going below/behind (underrun) the position

WPOSX – Type of position monitoring
Bit=0 position is monitored continuously
Bit=1 position is monitored once. When the position signal is generated, the corresponding enable bit (WPOSE) is set to 0, so that the monitoring is disabled for this position register,

Status variable:
POSRSTAT (z_data.Posrstat) – Position signaling
Bit=0 position signaling inactive
Bit=1 position signaling active (position overrun for WPOSP=0 or underrun for WPOSP=1).

Position register:
The position registers 1 to 16 can be accessed by the ASCII command P1 ... P16. Position values are displayed in the same units as the position control loop (PGEARI / PGEARO conversion).
The variables that are required for the fast position registers (WPOSE, WPOSP, WPOSX, P1 ... P16) can be saved in the serial EEPROM by using the SAVE command. Those position registers P1 ... P16 which are not used should be set to 0 (since the default value for a position register is 0, no space will be occupied in the serial EEPROM).
The individual position signals from the status register POSRSTAT can be output from the digital outputs of the motherboard.

OxMODE=40
This function is used to produce the result of a logical OR operation (on the bit-variable POSRSTAT and a bit-mask from the auxiliary variable OxTRIG) at the digital output x.

OxMODE=41
This function is used to produce the result of a logical AND operation (on the bit-variable POSRSTAT and a bit-mask from the auxiliary variable OxTRIG) at the digital output x.


ASCII English WPOSE

ASCII - Command | WPOSE |
Syntax Transmit | WPOSE |
Syntax Receive | WPOSE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 363F (hex)
DIM | - | PROFIBUS PNU | 1919 (dec) IND = 1 (dec)
Range | 0 ..65535 | DPR | 319 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Enable fast position registers 1 ... 16

Description

The bit-variable WPOSE is used to configure the fast position registers P1 ... P16 individually. The WPOSE variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.

Bit=0 the corresponding position register is not monitored
Bit=1 the position register is monitored
See also WPOS


ASCII English WPOSP

ASCII - Command | WPOSP |
Syntax Transmit | WPOSP [Data] |
Syntax Receive | WPOSP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3640 (hex)
DIM | - | PROFIBUS PNU | 1920 (dec) IND = 1 (dec)
Range | 0 .. 65535 | DPR | 320 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Polarity of fast position registers 1 ... 16

Description

The bit-variable WPOSP is used to configure the fast position registers P1 ... P16 individually. The WPOSP variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.
Bit=0 Position signal is generated on going above/beyond (overrun) the position
Bit=1 Position signal is generated on going below/behind (underrun) the position

See also WPOS


ASCII English WPOSX

ASCII - Command | WPOSX |
Syntax Transmit | WPOSX [Data] |
Syntax Receive | WPOSX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3641 (hex)
DIM | - | PROFIBUS PNU | 1921 (dec) IND = 1 (dec)
Range | 0 ... 65535 | DPR | 321 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | position loop | EEPROM | No
Short Description | Mode of fast position registers 1 ... 16

Description

The bit-variable WPOSX can be used to configure the fast position registers P1 ... P16 individually. The WPOSX variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.
Bit=0 Position is monitored permanently
Bit=1 Position is monitored once. If a 1 is set the Enable-Bit WPOSE is set to 0, so the monitor function is diabled .

See also WPOS


ASCII English WSAMPL

ASCII - Command | WSAMPL |
Syntax Transmit | WSAMPL [Data] |
Syntax Receive | WSAMPL <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36D1 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 17 (dec)
Range | 0 ... 2^31-1 | DPR | 465 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | wake&shake | EEPROM | Yes
Short Description | Minimum move of W&S mode

Description

WSAMPL sets the minimum movement for W&S - function in FBTYPE = 7 and 8. The units are internal counts.
If WSAMPL = 0, the calculation is automatically done with ENCLINES.

see also WSLOOP


ASCII English WSCNFG

ASCII - Command | WSCNFG |
Syntax Transmit | WSCNFG [Data] |
Syntax Receive | WSCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3874 (hex)
DIM | - | PROFIBUS PNU | 1684 (dec) IND = 33 (dec)
Range | - | DPR | 884 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weighting |
Start Firmware | 2.53 |
Configuration | Yes | Last Change of this Object | 2.0
Function Group | wake&shake | EEPROM | Yes
Short Description | Type of commutation alignment

Description

The configuration parameter WSCNFG defines the type of the commutation alignment used for FBTYPE=7,8,16,17,19,21

WSCNFG=0 Method 1: Standard Wake & Shake
WSCNFG=1 Method 2: commutation alignment by PID position control loop (CALCMP)
WSCNFG=2 Method 3: commutation alignment by fixed commutation vector (ZERO)


ASCII English WSLOOP

ASCII - Command | WSLOOP |
Syntax Transmit | WSLOOP [Data] |
Syntax Receive | WSLOOP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36E2 (hex)
DIM | - | PROFIBUS PNU | 1682 (dec) IND = 17 (dec)
Range | 1 ... 50 | DPR | 482 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | wake&shake | EEPROM | Yes
Short Description | W&S Loops

Description

Max. number of Wake&Shake repeats MPHASE is calculated as mean value of all W&S repeats

see also WSAMPL


ASCII English WSRED

ASCII - Command | WSRED |
Syntax Transmit | - |
Syntax Receive | - | Available in |
Type | - | MMI | No
ASCII Format | - | CANBus Object Number | 375C (hex)
DIM | - | PROFIBUS PNU | 1804 (dec) IND = 17 (dec)
Range |  | DPR | No
Default |  |
Opmode |  | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.11
Function Group | intern | EEPROM | Yes
Short Description | internal parameter

Description

This parameter is internal and is not documented. It could be a customized or test/service parameter.

It is not allowed to change this parameter!


ASCII English WSTIME

ASCII - Command | WSTIME |
Syntax Transmit | WSTIME [Data] |
Syntax Receive | WSTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36D0 (hex)
DIM | ms | PROFIBUS PNU | 1664 (dec) IND = 17 (dec)
Range | 0 ... 100 | DPR | 464 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.8
Function Group | wake&shake | EEPROM | Yes
Short Description | Operation time of the W&S - function

Description

WSTIME defines the operation time of the W&S - function in FBTYPE = 7 and 8. The different current vectors are switched on for this time and the move distance is proportional to the WSTIME value. See also WSAMPL.
If WSTIME is set to "0", the calculation depends on the value of GV and is done automatically.


ASCII English WSTIME2

ASCII - Command | WSTIME2 |
Syntax Transmit | WSTIME2 [Data] |
Syntax Receive | WSTIME2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3863 (hex)
DIM | ms | PROFIBUS PNU | 1667 (dec) IND = 33 (dec)
Range | 0 .. 500 | DPR | 867 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.26 |
Configuration | No | Last Change of this Object | 2.1
Function Group | wake&shake | EEPROM | Yes
Short Description | W&S delay time

Description

WSTIME2 defines the delay time of the W&S - function for FBTYPE = 7 and 8. This time is a delay time between the switching of different current vectors during the wake & shake procedure.The default value for this delay is 1 msec (WSTIME2=0). This time should be increased in the case of movement interferences between single current vectors.


ASCII English WSTIME3

ASCII - Command | WSTIME3 |
Syntax Transmit | WSTIME3 [Data] |
Syntax Receive | WSTIME3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3865 (hex)
DIM | ms | PROFIBUS PNU | 1669 (dec) IND = 33 (dec)
Range | 0 .. 500 | DPR | 869 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weighting |
Start Firmware | 2.31 |
Configuration | No | Last Change of this Object | 2.3
Function Group | wake&shake | EEPROM | Yes
Short Description | W&S delay time

Description

This time is a delay time between the switching of the coarse calculation done in current mode and the fine calculation of the commutation angle done in velocity mode during the wake & shake procedure. The default value for this delay is 0 msec (WSTIME3=0). This time should be increased in the case of interferences while switching from the coarse to the fine calculation. Choosing too big values just enlarges the wake and shake procedure duration.


ASCII English ZERO

ASCII - Command | ZERO |
Syntax Transmit | ZERO |
Syntax Receive | ZERO | Available in |
Type | Variable w | MMI | Yes
ASCII Format | Command | CANBus Object Number | 3857 (hex)
DIM |  | PROFIBUS PNU | 1657 (dec) IND = 33 (dec)
Range |  | DPR | 857 (dec)
Default | - |
Opmode | 2 | Data Type Bus/DPR | -
Drive State |  | Weighting |
Start Firmware |  |
Configuration | No | Last Change of this Object | 2.10
Function Group | feedback | EEPROM | No
Short Description | automatic calculation of commutation angle

Description

With this parameter ZERO the automatic calculation of commutation angle will be started.

Optionally, the execution time can be specified (in ms). Untimed 1000 ms is used. Meaningful number range from 1000 to 20000 ms. The motor shaft should rotate while load-free. The parameter REFIP2 peak rated current for commutation limits the peak current during the wake & shake procedure.


ASCII English ZEROTIME

ASCII - Command | ZEROTIME |
Syntax Transmit | ZEROTIME [Data] |
Syntax Receive | ZEROTIME <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3912 (hex)
DIM | ms | PROFIBUS PNU | 1842 (dec) IND = 33 (dec)
Range | 100 .. 60000 | DPR | 1042 (dec)
Default | 10000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weighting |
Start Firmware | 5.90 |
Configuration | No | Last Change of this Object | 2.11
Function Group | feedback | EEPROM | Yes
Short Description | Default value for the ZERO function

Description

The command ZEROTIME defines the current application for commutation (s. command ZERO). If the command ZERO is called with no parameters, the current application is taken from the parameter ZEROTIME. This is especially useful when the ZERO function through the fieldbus starts.