DriveGui Online Help

Inhaltsverzeichnis

Figures

title

general

installation

start

wizard

basic

parameter

units

can

asynchron

mot_fdbk

feedback

fb_ws

fb_test

motor

mot_feld

motor_cog

current

velocity

position

position_erw

posdata

posreg

gearing

encoder

ana_io

digi_io

mservice

status

monitor

homing

mtasktab

scope

bode

terminal

io_opt

sercos

profi

ethercat

Autotuning

safetycard

sd_card

Antriebsberechnung

Makroprogrammierung

Motorsetup

SW-Upgrade

appendix


ASCII Deutsch ACC

ASCII - Kommando | ACC |
Syntax Senden | ACC [Data] |
Syntax Empfangen | ACC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3501 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1601 (dec) IND = 1 (dec)
Bereich | 3 ..126000 | DPR | 1 (dec)
Default | 31400 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Drehzahlregelung

Beschreibung

Das Kommando ACC definiert die Beschleunigungsrampe des Drehzahlreglers. Die Beschleunigungsrampe ACC wird nur bei Sollwertsprüngen benutzt, die eine Erhöhung der Drehzahl nach sich ziehen (Beschleunigungsvorgang). Für den Bremsvorgang gilt der Parameter DEC.

Siehe auch ACCUNIT


ASCII Deutsch ACC_X

ASCII - Kommando | ACC_X |
Syntax Senden | ACC_X [Data] |
Syntax Empfangen | ACC_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3877 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1687 (dec) IND = 33 (dec)
Bereich | 3 ... 126000 | DPR | 887 (dec)
Default | 3150 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 3.07 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Drehzahlr. 2. Parametersatz

Beschreibung

siehe PARCNFG


ASCII Deutsch ACCR

ASCII - Kommando | ACCR |
Syntax Senden | ACCR [Data] |
Syntax Empfangen | ACCR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3502 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1602 (dec) IND = 1 (dec)
Bereich | 3 ..126000 | DPR | 2 (dec)
Default | 3150 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando ACCR definiert die Beschleunigungsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. . Die Vorgabe erfolgt in ACCUNIT. Bei ACCUNIT =0 (Beschleunigung in ms) bezieht sich der Wert von ACCR auf PVMAX.
Die Beschleunigungsrampe ACCR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).


ASCII Deutsch ACCUNIT

ASCII - Kommando | ACCUNIT |
Syntax Senden | ACCUNIT [Data] |
Syntax Empfangen | ACCUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3659 (hex)
DIM | - | PROFIBUS PNU | 1945 (dec) IND = 1 (dec)
Bereich | 0,1, ... , 30 | DPR | 345 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Art der Beschleunigungsvorgabe im System

Beschreibung

Mit dem Kommando ACCUNIT kann die systemweite Beschleunigungseinheit
definiert werden. Diese Einheit gilt sowohl für die Rampen des Trajektoriengenerators (interne Fahrsätze, OPMODE 8) als auch für die Brems-/Beschleunigungsrampen des Drehzahlreglers.

ACCUNIT = 0 in ms bis zu VLIM bzw. PVMAX
ACCUNIT = 1 Beschleunigung wird in rad/sek² vorgegeben
ACCUNIT = 2 Beschleunigung wird in UPM/sek vorgegeben
ACCUNIT = 3 Beschleunigung wird in PUNIT/sek²
ACCUNIT = 4 Beschleunigung wird in 1000*PUNIT/sek²
ACCUNIT = 5 Beschleunigung wird in 1000000*PUNIT/sek²

Bei der Einstellung ACCUNIT=1 wird dieses Bit ignoriert, d.h. die Rampen werden
ausschließlich in rad/sek² erwartet.

Bei der Änderung der Variable ACCUNIT werden alle Beschleunigungs-/Brems-Parameter die davon betroffen sind, intern auf die jeweils gültige Einheit umgerechnet. Dazu gehören folgende Parameter:
ACC,ACCR,DEC,DECR,DECSTOP,DECDIS

Die automatische Parameteranpassung gilt nicht für die internen Fahrsätze. Aus diesem Grund sollte die Festlegung der gültigen Beschleunigungseinheit vor der Erstellung des ersten Fahrsatzes erfolgen.
Bei einer Änderung von ACCUNIT zu einem späteren Zeitpunkt, müssen die Anfahr-/Bremsbeschleunigungswerte aller Fahrsätze überprüft und ggf. korrigiert werden.

Die Anfahr-/Bremsrampen der Fahrsätze werden grundsätzlich durch die Einstellung PTMIN begrenzt. Diese Einstellung erfolgt in den ACCUNIT-Einheiten oder in msek

Achtung !!
Bei ACCUNIT=0 wird die maximale Beschleunigung durch kleine PTMIN-Werte eingestellt, bei ACCUNIT>0 durch große Werte


ASCII Deutsch ACTFAULT

ASCII - Kommando | ACTFAULT |
Syntax Senden | ACTFAULT [Data] |
Syntax Empfangen | ACTFAULT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3503 (hex)
DIM | - | PROFIBUS PNU | 1603 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 3 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Fehler Stopp Modus

Beschreibung

Mit Hilfe des Kommandos ACTFAULT kann das Verhalten des Antriebes beim Auftreten eines Fehlers bestimmt werden.
ACTFAULT=0: Beim Auftreten eines Fehlers wird die Endstufe sofort gesperrt, der Antrieb trudelt aus.
ACTFAULT=1: Beim Auftreten eines Fehlers wird eine Nothalt-Prozedur eingeleitet, die aus folgenden Schritten besteht:
1. Umschalten des Reglermodes auf die Drehzahlregelung (OPMODE=0)
2. Umschalten der Bremsrampe des Drehzahlreglers (DEC) auf die Nothaltrampe (DECSTOP)
3. Setzen des internen Drehzahlsollwertes auf 0 (vor dem Rampengenerator).
4. Starten eines Timers (Time-Out-Zeit = 5 sek)

Sobald der interne Drehzahlsollwert (hinter dem Rampengenerator) den Wert 0 erreicht hatte, wird die Endstufe gesperrt und der ursprüngliche Reglermode eingestellt. Dies geschieht auch, wenn der Time-Out abgelaufen ist bevor der Drehzahlsollwert den Wert 0 erreicht hatte.

Anmerkung:
Bei manchen kritischen Fehlern wird die Endstufe sofort gesperrt. Die Einstellung ACTFAULT=1 hat dann keine Funktion (s. Beschreibung ERRCODE *).

Mit dem Paramet ERRCNFG kann für einzelne Fehler das sofortige Sperren der Endstufe erzwungen werden. Die Einstellung ACTFAULT=1 hat dann keine Funktion.


ASCII Deutsch ACTIVE

ASCII - Kommando | ACTIVE |
Syntax Senden | ACTIVE |
Syntax Empfangen | ACTIVE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3504 (hex)
DIM | - | PROFIBUS PNU | 1604 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 4 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Endstufe freigegeben/gesperrt

Beschreibung

Das Kommando ACTIVE liefert den aktuellen Zustand der Endstufe.
ACTIVE=1 Endstufe ist freigegeben
ACTIVE=0 Endstufe ist gesperrt

Für die Freigabe der Endstufe müssen, abhängig von der Reglerkonfiguration,
folgende Bedingungen erfüllt sein:

1. Standardkonfiguration (keine Netzbtb-Funktion aktiv)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden

2. Netzbtb-Funktion aktiv (O1MODE oder O2MODE=3)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden
- Netz-BTB vorhanden
- Zwischenkreisspannung > Unterspannung-Meldeschwelle


ASCII Deutsch ACTRS232

ASCII - Kommando | ACTRS232 |
Syntax Senden | ACTRS232 [Data] |
Syntax Empfangen | ACTRS232 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3655 (hex)
DIM | - | PROFIBUS PNU | 1941 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 341 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | RS232 | EEPROM | Nein
Kurzbeschreibung | Freigabe des RS232-Watchdogs

Beschreibung

Das Kommando ACTRS232 aktiviert bzw. deaktiviert die Überwachung der seriellen Schnittstelle (RS232-Watchdog).

ACTRS232=0 keine Überwachung der seriellen Kommunikation
ACTRS232=1 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird jede Bewegung angehalten und die Warnung n04 angezeigt. Die Warnung muß über die Funktion "Fehler quittieren" gelöscht werden.
ACTRS232=2 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird die aktuelle Bewegung angehalten und ACTRS232 auf 0 gesetzt. Es wird keine Warnung ausgegeben.

Nach dem Einschalten des Verstärkers ist der RS232-Watchdog immer deaktiviert (ACTRS232=0). Beim Starten einer Service-Funktion über die serielle Schnittstelle, sollte das PC-Programm (bzw. eine externe Steuerung) dafür sorgen, daß die Überwachung der Schnittstelle eingeschaltet wird. Dadurch wird sichergestellt, daß beim Abbruch der Kommunikation bzw. bei einem PC-Absturz die Service-Funktion automatisch abgebrochen wird.


ASCII Deutsch ADC0_15

ASCII - Kommando | ADC0_15 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | analog I/O | EEPROM |
Kurzbeschreibung | interne Offsetwerte

Beschreibung

interne Offsetwerte, die nicht(!) vom Benutzer verändert werden dürfen


ASCII Deutsch ADDR

ASCII - Kommando | ADDR |
Syntax Senden | ADDR [Data] |
Syntax Empfangen | ADDR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 3505 (hex)
DIM | - | PROFIBUS PNU | 1605 (dec) IND = 1 (dec)
Bereich | 0 .. 127 | DPR | 5 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Stationsadresse

Beschreibung

Mit dem Kommando ADDR wird die Feldbus-Adresse des Verstärkers definiert (CANBUS/PROFIBUS/SERCOS). Nach der Änderung der Adresse sollten alle Parameter im EEPROM abgespeichert werden (s. SAVE-Kommando) und der Verstärker aus- und eingeschaltet werden.


ASCII Deutsch AENA

ASCII - Kommando | AENA |
Syntax Senden | AENA [Data] |
Syntax Empfangen | AENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3506 (hex)
DIM | - | PROFIBUS PNU | 1606 (dec) IND = 1 (dec)
Bereich | 0 ,1 | DPR | 6 (dec)
Default | 0 |
Opmode | 0, 2, 4, 5, 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Initialisierungszustand der Software-Freigabe

Beschreibung

Mit dem Kommando AENA (Auto Enable) kann der Zustand des Software-Enable beim Einschalten des Verstärkers definiert werden.

Damit die Endstufe freigegeben wird, muß sowohl das Hardware-Enable als auch das Software-Enable gesetzt werden (Reihenschaltung).
Mit dem Software-Enable wird einer externen Steuerung die Möglichkeit gegeben, über eine Bus-Anschaltung (CANBUS/PROFIBUS/SERCOS/RS232) bzw. über eine Slot-Erweiterungskarte, die Endstufe softwaremässig zu sperren bzw. freizugeben.
Bei Geräten, die mit einem analogen Sollwert arbeiten (OPMODE=1,3) wird beim Einschalten des Verstärkers das Software-Enable automatisch gesetzt, so daß diese Geräte sofort betriebsbereit sind (Hardware-Enable vorausgesetzt).
Bei allen anderen Geräten, die mit einem digitalen Sollwert arbeiten (OPMODE=0,2,4..8), wird beim Einschalten das Software-Enable auf den Wert von AENA gesetzt.

Die Variable AENA hat auch eine Funktion beim Resettieren des Verstärkers nach einem Fehler (über digitalen Eingang 1 bzw. mit dem ASCII-Kommando CLRFAULT).
Bei Fehlern, die softwaremässig resettiert werden können, wird, nachdem der Fehler gelöscht wurde, das Software-Enable auf den Zustand von AENA gesetzt.
Auf diese Weise ist das Verhalten des Verstärkers beim Software-Reset analog zu dem Einschaltverhalten.


ASCII Deutsch ALIAS

ASCII - Kommando | ALIAS |
Syntax Senden | ALIAS [Data] |
Syntax Empfangen | ALIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 8 ASCII Characters | DPR | Nein
Default | DRIVE0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Symbolischer Verstärker-Name

Beschreibung

Mit dem Kommando ALIAS kann einem Verstärker ein symbolischer Name zugewiesen werden. Bei Verwendung des PC-Bedienprogrammes erscheint dieser Name in der Titelzeile aller geöffneten Parameter-Fenster.
Im Multi-Drive-Mode (Parametrieren von mehreren über den CAN-BUS verbundenen Verstärkern) kann anhand des ALIAS-Namen das Parameter-Fenster dem zugehörigen Verstärker eindeutig zugeordnet werden.


ASCII Deutsch AN1TRIG

ASCII - Kommando | AN1TRIG |
Syntax Senden | AN1TRIG [Data] |
Syntax Empfangen | AN1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3880 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 33 (dec)
Bereich | Long Int | DPR | 896 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierung des Analogausgangs 1

Beschreibung

Mit dem Parameter AN1TRIG kann die Ausgangsspannung des Monitorausgangs 1 prozentual skaliert werden. Unabhängig von der Funktion, die mit ANOUT1 für den Ausgang 1 konfiguriert wurde, wird die Ausgangsspannung mit dem Faktor AN1TRIG multipliziert. Dies entspricht folgender Formel:

analoge Ausgangspannung = Ausgang der Funktion ANOUT1 * (AN1TRIG/100%)

Beispiel:
ANOUT1 = 1 Ausgabe der Istdrehzahl. Normierung: 10V bei Istdrehzahl=VLIM

AN1TRIG = 100 % - 10V am Ausgang bei Drehzahl=VLIM
AN1TRIG = 50 % - 5V am Ausgang bei Drehzahl=VLIM, dies entspricht einer Spannung von 10V bei 2*VLIM
AN1TRIG = 200 % - 20V am Ausgang bei Drehzahl=VLIM, dies entspricht einer Spannung von 10V bei VLIM/2

siehe auch ANOUT1, VLIM


ASCII Deutsch AN2TRIG

ASCII - Kommando | AN2TRIG |
Syntax Senden | AN1TRIG [Data] |
Syntax Empfangen | AN2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3881 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 33 (dec)
Bereich | Long Int | DPR | 897 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierung des Analogausgangs 2

Beschreibung

Mit dem Parameter AN2TRIG kann die Ausgangsspannung des Monitorausgangs 2 prozentual skaliert werden. Unabhängig von der Funktion, die mit ANOUT2 für den Ausgang 2 konfiguriert wurde, wird die Ausgangsspannung mit dem Faktor AN2TRIG multipliziert. Dies entspricht folgender Formel:

analoge Ausgangspannung = Ausgang der Funktion ANOUT2 * (AN2TRIG/100%)

Beispiel:
ANOUT2 = 1 Ausgabe der Istdrehzahl. Normierung: 10V bei Istdrehzahl=VLIM

AN2TRIG = 100 % - 10V am Ausgang bei Drehzahl=VLIM
AN2TRIG = 50 % - 5V am Ausgang bei Drehzahl=VLIM, dies entspricht einer Spannung von 10V bei 2*VLIM
AN2TRIG = 200 % - 20V am Ausgang bei Drehzahl=VLIM, dies entspricht einer Spannung von 10V bei VLIM/2

sie auch ANOUT2, VLIM


ASCII Deutsch AN11NR

ASCII - Kommando | AN11NR |
Syntax Senden | AN11NR [Data] |
Syntax Empfangen | AN11NR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3699 (hex)
DIM | - | PROFIBUS PNU | 2009 (dec) IND = 1 (dec)
Bereich | 0, 1, 2, 3, 4 | DPR | 409 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.01
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Nr. der INxTRIG Variable, bei analoger Vorgabe

Beschreibung

Mit dem Parameter AN11NR kann die Nummer (x) des digitalen Eingangs festgelegt werden, dessen Hilfsvariable (IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG) über den analogen Eingang SW2 beeinflußt werden soll. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.


ASCII Deutsch AN11RANGE

ASCII - Kommando | AN11RANGE |
Syntax Senden | AN11RANGE [Data] |
Syntax Empfangen | AN11RANGE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 369A (hex)
DIM | - | PROFIBUS PNU | 2010 (dec) IND = 1 (dec)
Bereich | -262144 .. 262143 | DPR | 410 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Bereich für die analoge Änderung von INxTRIG

Beschreibung

Der Parameter AN11RANGE beschreibt die Wert-Änderung der Variable IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG, wenn die Spannung am analogen Eingang 2 (SW2) von 0 auf 10V geändert wird. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.

Beispiel:

ANCNFG=11
AN11NR=1
IN1TRIG=1000
AN11RANGE=500

bei SW2=0V IN1TRIG = 1000
bei SW2=10V IN1TRIG = 1500
bei SW2=-10V IN1TRIG = 500


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

I/O analog

einheiten

Weisen Sie den analogen Ein-/Ausgängen des Servoverstärkers vordefinierte Funktionen zu. Analoge Ausgänge stehen nur bei S700 mit installierten Erweiterungskarte PosI/O-Monitor zur Verfügung.

Bildschirmtext | ASCII-Parameter
Analog-Eingänge | ANCNFG
Offset Eingang 1 | ANOFF1
Stromskalierung Eingang 1 | ISCALE1
Drehzahl-Skalierung Eingang 1 | VSCALE1
Offset Eingang 2 | ANOFF2
Stromskalierung Eingang 2 | ISCALE2
Drehzahl-Skalierung Eingang 2 | VSCALE2
Filter Eingang 1 | AVZ1
Drehzahl-Sollwert-Totband | ANDB
Analog-Ausgang 1 | ANOUT1
Skalierung Ausgang 1 | abhängig von der gewählten Funktion ANOUT1
D/A Offset Ausgang 1 | DAOFFSET1
Analog-Ausgang 2 | ANOUT2
Skalierung Ausgang 2 | abhängig von der gewählten Funktion ANOUT2
D/A Offset Ausgang 2 | DAOFFSET2


ASCII Deutsch ANCNFG

ASCII - Kommando | ANCNFG |
Syntax Senden | ANCNFG [Data] |
Syntax Empfangen | ANCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3507 (hex)
DIM | - | PROFIBUS PNU | 1607 (dec) IND = 1 (dec)
Bereich | -1 .. 14 | DPR | 7 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Konfiguration der analogen Eingänge

Beschreibung

Mit dem Kommando ANCNFG kann die Funktion der analogen Eingänge konfiguriert werden. ANCNFG = -1: Einlesen der analogen Eingänge wird abgeschaltet Da die Variable ANCNFG für die Konfiguration des Gerätes benutzt wird, muß nach einer Änderung der Variable der Regler aus- und eingeschaltet werden (vorher SAVE aufrufen).
Zustand |  | Beschreibung
ANCNFG=0 | (Xcmd=Setp.1) | Analog IN1 wird je nach OPMODE als Drehzahl- (OPMODE=1) bzw. Stromsollwert (OPMODE=3) benutzt. Falls einer der digitalen Eingänge für Sollwert-Umschaltung konfiguriert wurde (IN1MODE, IN2MODE, IN3MODE oder IN4MODE=8), wird je nach Zustand dieses Eingangs, Analog In 1 (Eingang=Low) oder Analog In 2 (Eingang=High) als Drehzahl- bzw. Stromsollwert benutzt. Skalierung: Analog In 1=10V Drehzahlsollwert=VSCALE1 (OPMODE=1) Analog In 1=10V Stromsollwert=ISCALE1 (OPMODE =3) Analog In 2=10V Drehzahlsollwert=VSCALE2 (OPMODE=1) Analog In 2=10V Stromsollwert=ISCALE2 (OPMODE=3)
ANCNFG=1 | v_cmd=Setp.1, Icmd=Setp.2 | Analog In 2 wird als Stromsollwert benutzt (bei OPMODE = 3), Analog In 1 dient als Drehzahlsollwert (bei OPMODE = 1) Skalierung: Analog In 1 = 10V Drehzahlsollwert = VSCALE1 Analog In 2 = 10V Stromsollwert = ISCALE2
ANCNFG=2 | Setp.1 = nsoll, Setp.2 = Isoll | Analog In 1 wird als Drehzahlsollwert benutzt. Analog In 2 wird als Stromvorsteuerung benutzt Skalierung: Analog In 2=10V Stromvorsteuerung=ISCALE2
ANCNFG=3 | Xcmd=Setp.1, Ipeak1=Setp.2 | Analog In 1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus Analog In 2 wird für die Strombegrenzung benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Diese Strombegrenzung wirkt in allen OPMODE
ANCNFG=4 | Xcmd=Setp.1+Setp.2 | Analog In 1 und Analog In 2 werden summiert und je nach OPMODE als Sollwert benutzt. Für die Skalierung werden die Kommandos ISCALE1,ISCALE2 (OPMODE 3) oder VSCALE1,VSCALE2 (OPMODE 1) benutzt.
ANCNFG=5 | Xcmd=Setp.1*Setp.2 | Analog In 1 und Analog In 2 werden multipliziert. Das Produkt wird je nach OPMODE als Strom- bzw. Drehzahlsollwert benutzt. Analog In 1 = Sollwert (ISCALE1/VSCALE1) Analog In 2 = Skalierungsfaktor 10V = 100% / -10V = -100%
ANCNFG=6 | Electronic Gearing | Analog In 1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Analog In 2 wird zur Korrektur von GEARO (elektrisches Getriebe) benutzt. MitVSCALE2 kann der Korrekturfaktor (in %) vorgegeben werden. Z.B. VSCALE2=20 Analog In 2= +10V GEAROeff = GEARO*1.2 Analog In 2= -10V GEAROeff = GEARO*0.8 Analog In 2= 0V GEAROeff = GEARO
ANCNFG=7 | Setp.1 = Isoll, Setp.2 = Nmax | Analog In 1 wird als Stromsollwert benutzt (OPMODE muss auf 3 stehen), Analog In 2 bestimmt die erreichbare Drehzahl Skalierung: Analog In 1=10V Stromsollwert=ISCALE1 Analog In 2=10V Drehzahlgrenze Nmax=VSCALE2 Die Drehzahl des Motors wird bei Erreichen von Nmax begrenzt
ANCNFG=8 | Setp.1 = Psoll | Analog In 1 wird als Positionssollwert benutzt (nur bei OPMODE=5 aktiv). Der Verfahrbereich für die "analoge Positionierung" wird durch die Parameter SRND und ERND bestimmt. Skalierung: Analog In 1 = 0V Position = SRND Analog In 1 = +/- 10V Position = ERND Wenn der Verstärker eingeschaltet wird, so ist zunächst der Referenzpunkt nicht gesetzt und es erfolgt keine Bewegung, auch wenn der OPMODE bereits auf 5 gesetzt ist. Nun muss zunächst eine Referenzfahrt über einen digitalen Eingang gestartet werden. Die Umschaltung auf OPMODE=8 wird automatisch vorgenommen. Wenn die Referenzfahrt beendet ist, kann der digitale Eingang wieder auf low geschaltet werden und dann wird automatisch die über den Eingang 1 vorgegebene Position angefahren. POSCNFG muss auf "0" eingestellt sein.
ANCNFG=10 | Reserviert |
ANCNFG=11 |  | Interne Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (Analog In 2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes Analog In 2 wirkt sich unmittelbar aus (Reaktionszeit ca 1..10 msek, s. auch Beschreibung der Parameter AN11NR und AN11RANGE
ANCNFG=12 |  | Interne Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (Analog In 2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes Analog In 2 wirkt sich erst bei der nächsten steigenden Flanke aus. s. auch Beschreibung der Parameter AN11NR und AN11RANGE.
ANCNFG=13 | Xcmd=Setp.1, Ipeak1=Setp.2 | Analog In 1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus Analog In 2 wird für die Strombegrenzung des positiven Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der negative Strom wird nicht beeinflusst. Das heißt, das in der positiven Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird. Diese Strombegrenzung wirkt in allen OPMODE
ANCNFG=14 | Xcmd=Setp.1, Ipeak1=Setp.2 | Analog In 1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus Analog In 2 wird für die Strombegrenzung des negativen Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der positive Strom wird nicht beeinflusst. Das heißt, das in der negativen Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird. Diese Strombegrenzung wirkt in allen OPMODE


ASCII Deutsch ANDB

ASCII - Kommando | ANDB |
Syntax Senden | ANDB [Data] |
Syntax Empfangen | ANDB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3508 (hex)
DIM | mV | PROFIBUS PNU | 1608 (dec) IND = 1 (dec)
Bereich | 0.0 .. 10000.0 | DPR | 8 (dec)
Default | 0 |
Opmode | 1, 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Totband für den analogen Drehzahlsollwert

Beschreibung

Die Spannung, die unter dem vorgegebenem Grenzwert liegt, wird als "Rauschen" betrachtet und intern auf 0 gesetzt. Damit kann bei Sollwert 0 ein Stillstand des Antriebes erreicht werden.
Je nach Betriebsart wirkt sich dieser Parameter auf SW1 oder SW2 (abhängig davon welcher Sollwerteingang als Drehzahlquelle benutzt wird).
S. auch Kommando ANCNFG.


ASCII Deutsch ANHFACT1

ASCII - Kommando | ANHFACT1 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch ANHFACT2

ASCII - Kommando | ANHFACT2 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch ANIN1

ASCII - Kommando | ANIN1 |
Syntax Senden | ANIN1 [Data] |
Syntax Empfangen | ANIN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3509 (hex)
DIM | mV | PROFIBUS PNU | 1609 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 9 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW1

Beschreibung

Das Kommando ANIN1 liefert den aktuellen Spannungswert am Analog-Eingang SW1.


ASCII Deutsch ANIN2

ASCII - Kommando | ANIN2 |
Syntax Senden | ANIN2 |
Syntax Empfangen | ANIN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 350A (hex)
DIM | mV | PROFIBUS PNU | 1610 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 10 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW2

Beschreibung

Das Kommando ANIN2 liefert den aktuellen Spannungswert am Analog-Eingang SW2.


ASCII Deutsch ANIN3

ASCII - Kommando | ANIN3 |
Syntax Senden | ANIN3 [Data] |
Syntax Empfangen | ANIN3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38A0 (hex)
DIM | mV | PROFIBUS PNU | 1728 (dec) IND = 33 (dec)
Bereich | -10000 .. 10000 | DPR | 928 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW3 (POS I/O)

Beschreibung

Nur S700

Das Kommando ANIN3 liefert den aktuellen Spannungswert am Analog-Eingang SW3.


ASCII Deutsch ANIN4

ASCII - Kommando | ANIN4 |
Syntax Senden | ANIN4 [Data] |
Syntax Empfangen | ANIN4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38A1 (hex)
DIM | mV | PROFIBUS PNU | 1729 (dec) IND = 33 (dec)
Bereich | -10000 .. 10000 | DPR | 929 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW4

Beschreibung

Das Kommando ANIN4 liefert den aktuellen Spannungswert am Analog-Eingang SW4.


ASCII Deutsch ANOFF1

ASCII - Kommando | ANOFF1 |
Syntax Senden | ANOFF1 [Data] |
Syntax Empfangen | ANOFF1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350B (hex)
DIM | mV | PROFIBUS PNU | 1611 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 11 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang analog input 1

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang 1 ANIN1 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOFF2

ASCII - Kommando | ANOFF2 |
Syntax Senden | ANOFF2 [Data] |
Syntax Empfangen | ANOFF2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350C (hex)
DIM | mV | PROFIBUS PNU | 1612 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 12 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW2

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang 2 ANIN2 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOFF3

ASCII - Kommando | ANOFF3 |
Syntax Senden | ANOFF3 [Data] |
Syntax Empfangen | ANOFF3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38A2 (hex)
DIM | mV | PROFIBUS PNU | 1730 (dec) IND = 33 (dec)
Bereich | -10000..10000 | DPR | 930 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW3 (POS I/O)

Beschreibung

Nur S700

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang 3 ANIN3 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOFF4

ASCII - Kommando | ANOFF4 |
Syntax Senden | ANOFF4 [Data] |
Syntax Empfangen | ANOFF4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38A3 (hex)
DIM | mV | PROFIBUS PNU | 1731 (dec) IND = 33 (dec)
Bereich | -10000..10000 | DPR | 931 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW4 (POS I/O)

Beschreibung

Nur S700

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang 4 ANIN4 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOUT1

ASCII - Kommando | ANOUT1 |
Syntax Senden | ANOUT1 [Data] |
Syntax Empfangen | ANOUT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 387E (hex)
DIM |  | PROFIBUS PNU | 1694 (dec) IND = 33 (dec)
Bereich | 0 .. 9 | DPR | 894 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Vorwahl für den Analogausgang 1

Beschreibung

nur S700 Konfiguration des Analogausganges 1. Der aktuall ausgegebene Wert kann mit MONITOR1 eingelesen werden. Der Ausgangswiderstand beträgt 2,2 kOhm.
Zustand | Funktion | Beschreibung
0 | aus | keine Spannungsausgabe am Monitorausgang 1
1 | n_ist | Ausgabe des Drehzahlistwertes (10 V = VLIM)
2 | I_ist | Ausgabe des Stromistwertes (10V = IPEAK)
3 | n_soll | Ausgabe des Drehzahlsollwertes (10V = VLIM)
4 | I_soll | Ausgabe des Stromsollwertes (10V = IPEAK)
5 | PE | Ausgabe des Schleppfehlers (10V = PEMAX)
6 | Slot | Ausgabe eines DPR-Wertes über den Monitorausgang 1 (bei vorhandener DPR-Slotkarte). ab FW >= 5.38
7 | PFB | Am analogen Ausgang wird die aktuelle Position ausgegeben. Die Normierung bezieht sich auf die Größe des Modulo-Bereiches ERND-SRND. die Ausgangsspannung wird nach folgender Formel berechnet: ANOUTx = 10V * (PFB-SRND)/(ERND-SRND) Wenn SRND bei 0 liegt, so kriegt man eine Spannung +/- 10V für +/- ERND Falls SRND ungleich 0 ist, so ist die Ausgabe unsymmetrisch. Was auf jeden Fall gilt: bei PFB=SRND ist die Spannung=0 und bei PFB=ERND ist die Spannung = 10V.
8 | U_const=x | Am analogen Ausgang wird eine konstante Spannung ausgegeben. Die auszugebende Spannung muß in der Hilfsvariable AN1TRIG in mV vorgegeben werden.
9 | I2T | Ausgabe von I2T (10V = 100%)


ASCII Deutsch ANOUT2

ASCII - Kommando | ANOUT2 |
Syntax Senden | ANOUT2 [Data] |
Syntax Empfangen | ANOUT2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 387F (hex)
DIM |  | PROFIBUS PNU | 1695 (dec) IND = 33 (dec)
Bereich | 0 .. 9 | DPR | 895 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Vorwahl für den Analogausgang 2

Beschreibung

nur S700 Konfiguration des Analogausganges 2. Der aktuall ausgegebene Wert kann mit MONITOR2 eingelesen werden. Der Ausgangswiderstand beträgt 2,2 kOhm.
Zustand | Funktion | Beschreibung
0 | aus | keine Spannungsausgabe am Monitorausgang 2
1 | n_ist | Ausgabe des Drehzahlistwertes (10 V = VLIM)
2 | I_ist | Ausgabe des Stromistwertes (10V = IPEAK)
3 | n_soll | Ausgabe des Drehzahlsollwertes (10V = VLIM)
4 | I_soll | Ausgabe des Stromsollwertes (10V = IPEAK)
5 | PE | Ausgabe des Schleppfehlers (10V = PEMAX)
6 | Slot | Ausgabe eines DPR-Wertes über den Monitorausgang 2 (bei vorhandener DPR-Slotkarte). ab FW >= 5.38
7 | PFB | Am analogen Ausgang wird die aktuelle Position ausgegeben. Die Normierung bezieht sich auf die Größe des Modulo-Bereiches ERND-SRND. die Ausgangsspannung wird nach folgender Formel berechnet: ANOUTx = 10V * (PFB-SRND)/(ERND-SRND) Wenn SRND bei 0 liegt, so kriegt man eine Spannung +/- 10V für +/- ERND Falls SRND ungleich 0 ist, so ist die Ausgabe unsymmetrisch. Was auf jeden Fall gilt: bei PFB=SRND ist die Spannung=0 und bei PFB=ERND ist die Spannung = 10V.
8 | U_const=x | Am analogen Ausgang wird eine konstante Spannung ausgegeben. Die auszugebende Spannung muß in der Hilfsvariable AN2TRIG in mV vorgegeben werden.
9 | I2T | Ausgabe von I2T (10V = 100%)


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Applikationshinweise

Weitere Applikationshinweise finden Sie im KDN.

Antriebsberechnung

Das Antriebsberechnungs-Tool AnyDim finden Sie auf der Produkt-CDROM und auf KDN Seite Tools).

Für die volle Funktionalität öffnen Sie das Programm direkt mit Excel (nicht im Internet Browser). In der Tabelle finden Sie als Zellen-Kommentar zu jedem wichtigen Eingabefeld (auf rote Markierung klicken) weitere Informationen.

Servo Pumpe

In der Firmware-Version 5.82 wurde die Funktionalität des S700 um das Modul „Servopumpe“ erweitert. In Verbindung mit der Servopumpen Funktionalität, kann ein S700 Servoverstärker genutzt werden, um einen Hydraulikzylinder anzutreiben. Das Gesamtsystem besteht in der Regel aus einem Servoverstärker, einem Motor mit Positions-Rückführeinheit sowie einem Hydraulikzylinder mit Druck-Rückführeinheit. Die kaskadierte Druck-/Volumenstromregelung im S700 sorgt für die Einhaltung eines vorgegebenen Zylinderdruck- bzw. Durchfluss-Profils.

Weitere Informationen und alle Parameter finden Sie in der Applikationsschrift Servo Pumpe.


ASCII Deutsch ANZERO1

ASCII - Kommando | ANZERO1 |
Syntax Senden | ANZERO1 |
Syntax Empfangen | ANZERO1 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 350F (hex)
DIM | - | PROFIBUS PNU | 1615 (dec) IND = 1 (dec)
Bereich | - | DPR | 15 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Offsetabgleich für den Analogeingang 1

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 1 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 1 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF1. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.

Mit dieser Funktion kann ein max. Offset von 75 mV abgeglichen werden.


ASCII Deutsch ANZERO2

ASCII - Kommando | ANZERO2 |
Syntax Senden | ANZERO2 |
Syntax Empfangen | ANZERO2 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3510 (hex)
DIM | - | PROFIBUS PNU | 1616 (dec) IND = 1 (dec)
Bereich | - | DPR | 16 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW2

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 2 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 2 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF2. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.

Mit dieser Funktion kann ein max. Offset von 75 mV abgeglichen werden.


ASCII Deutsch ANZERO3

ASCII - Kommando | ANZERO3 |
Syntax Senden | ANZERO3 |
Syntax Empfangen | ANZERO3 | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 38A4 (hex)
DIM |  | PROFIBUS PNU | 1732 (dec) IND = 33 (dec)
Bereich | - | DPR | 932 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW3 (POS I/O)

Beschreibung

Nur S700

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 3 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 3 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF3. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.

Mit dieser Funktion kann ein max. Offset von 75 mV abgeglichen werden.


ASCII Deutsch ANZERO4

ASCII - Kommando | ANZERO4 |
Syntax Senden | ANZERO4 |
Syntax Empfangen | ANZERO4 | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 38A5 (hex)
DIM |  | PROFIBUS PNU | 1733 (dec) IND = 33 (dec)
Bereich | - | DPR | 933 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 / 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW4 (POS I/O)

Beschreibung

Nur S700

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 4 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 4 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF4. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.

Mit dieser Funktion kann ein max. Offset von 75 mV abgeglichen werden.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Anhang

Glossar

B | Bremsschaltung | Wandelt vom Motor beim Bremsen rückgespeiste Energie über den Bremswiderstand in Wärme um.
 | Bode Plot | Resonanz-Analysefunktion
C | Clock | Taktsignal
 | Counts | Inkremente, interne Zählimpulse, 1 Impuls=1/220 Umdr-1
D | Disable | Wegnahme des ENABLE-Signals (siehe auch Enable)
 | Drehzahlregler | Regelt die Differenz zwischen Drehzahlsollwert SW und Drehzahlistwert zu 0 aus. Ausgang : Stromsollwert
E | EEPROM | Elektrisch löschbarer Speicher im Servoverstärker. Im EEPROM gespeicherte Daten gehen nicht verloren, wenn die Hilfsspannung abgeschaltet wird.
 | Enable | Freigabesignal für den Servoverstärker, Hardware-Enable über 24V Signal an X3, Software-Enable Kommando über die Inbetriebnahme-Software, Feldbus oder permanent gesetzt. Beide sind erforderlich zur Freigabe.
 | Enddrehzahl | Maximalwert für die Drehzahlnormierung bei ±10V
 | Endschalter | Begrenzungsschalter im Verfahrweg der Maschine; Ausführung als Öffner
F | Fahrsatz | Datenpaket mit allen Lageregelungsparametern, die für einen Fahrauftrag erforderlich sind
G | GRAY-Format | Spezielle Form der binären Zahlendarstellung
H | Haltebremse | Bremse im Motor, die nur bei Motorstillstand eingesetzt werden darf
I | I²t-Schwelle | Überwachung des tatsächlich abgeforderten Effektivstroms
 | Ipeak, Spitzenstrom | Effektivwert des Impulsstroms
 | Irms, Effektivstrom | Effektivwert des Dauerstroms
K | KP, P-Verstärkung | Proportionale Verstärkung eines Regelkreises
L | Lageregler | Regelt die Differenz zwischen Lagesollwert und Lageistwert zu 0 aus. Ausgang: Drehzahlsollwert
M | Maschine | Gesamtheit miteinander verbundener Teile oder Vorrichtungen, von denen mindestens eine beweglich ist
 | Monitorausgang | Ausgabe eines analogen Messwertes
N | Nullimpuls | Wird von Inkrementalgebern einmal pro Umdrehung ausgegeben, dient der Nullung der Maschine
P | P-Regler | Regelkreis, der rein proportional arbeitet
 | Phasenverschiebung | Kompensation der Nacheilung zwischen elektromagnetischem und magnetischem Feld im Motor
 | PID-Regler | Regelkreis mit proportionalem, integralen und differentiellen Verhalten
R | RAM | Flüchtiger Speicher im Servoverstärker. Im RAM gespeicherte Daten gehen verloren, wenn die Hilfsspannung fehlt
 | Reset | Neustart des Mikroprozessors
 | Reversierbetrieb | Betrieb mit periodischem Drehrichtungswechsel
 | ROD interface | Inkrementelle Positionsausgabe
S | SSI interface | Zyklisch absolute, serielle Positionsausgabe
 | Stromregler | Regelt die Differenz zwischen Stromsollwert und Stromistwert zu 0 aus. Ausgang : Leistungsausgangs-Spannung
 | SW-Rampen | Begrenzung der Änderungsgeschwindigkeit des Drehzahlsollwertes
T | Tn, I-Nachstellzeit | Integral-Anteil des Regelkreises
Z | Zwischenkreis | Gleichgerichtete und geglättete Leistungsspannung

Weiterführende Dokumentation

Die unten aufgelisteten Dokumente befinden sich auf der Produkt-CDROM und können von unserem Dateiarchiv herunter geladen werden.

Handbücher

  • Betriebsanleitung des Servoverstärkers (Montage, Installation, Inbetriebnahme)
  • CANopen Handbuch
  • PROFIBUS Handbuch
  • SERCOS Handbuch
  • DeviceNet Handbuch
  • EtherCAT Handbuch
  • Handbücher für verschiedene Motorreihen
  • Zubehör Handbuch

Fehlermeldungen

Auftretende Fehler werden im LED-Display an der Frontplatte über eine Fehlernummer kodiert (siehe ERRCODE) angezeigt. Bei Fehlern, die in der Tabelle unten mit "*" markiert sind, werden zusätzliche Informationen mit der Kennung "ixx" angezeigt (ERRCODE2).

Die Reaktion des Servoverstärkers hängt vom Fehler und von der Einstellung des Parameters ACTFAULT ab. Fehler können über Hardware Reset des Servoverstärkers oder je nach Fehler (siehe ERRCODE) auch über CLRFAULT zurückgesetzt werden.

Hinweise zu möglichen Ursachen und zur Beseitigung des Fehlers finden Sie im Abschnitt Trouble Shooting.

Kode | Bezeichnung | Erklärung
E | Statusmeldung, kein Fehler | Zwischenkreisspannung ist vorhanden. Verstärker ist freigegeben (Enable)
P | Statusmeldung, kein Fehler | Zwischenkreisspannung ist vorhanden. Verstärker ist gesperrt (Disable)
. . . | Statusmeldung, kein Fehler | Verstärker aktualisiert die Startkonfiguration
- | Statusmeldung, kein Fehler | Programmiermodus z.B. beim Firmware-Update
- S - | Statusmeldung, kein Fehler | STO-Enable-Eingang ist nicht beschaltet, Endstufe gesperrt
888 | Statusmeldung, kein Fehler | FPGA Programm nicht geladen
nd0 | Statusmeldung, kein Fehler | Non Dual Use Firmware (gekennzeichnet mit “_ND0") wird benutzt.
nd1 | Statusmeldung, kein Fehler | Eine AL-3A225 Export klassifizierte Dual Use Firmware (gekennzeichnet mit “_ND1") wird benutzt.
CCC | Speicherkarte | Zugriffs-Problem auf die Speicherkarte
dUF | Dual Use Firmware | Es wurde versucht, eine AL-3A225 Export klassifizierte Firmware in einen “nicht Dual-Use” Verstärker zu laden. Benutzen Sie ein mit “_ND0" gekennzeichnete Firmware.
F01 | Kühlkörpertemperatur | Kühlkörpertemperatur zu hoch (default: 80°C)
F02 | Überspannung | Überspannung im Zwischenkreis. Grenzwert abhängig von der Netzspannung
F03 | Schleppfehler | Meldung des Lagereglers
F04* | Rückführung | Kabelbruch, Kurzschluss, Erdschluss
F05 | Unterspannung | Unterspannung im Zwischenkreis (default: 100V)
F06 | Motortemperatur | Temperaturfühler defekt oder Motortemperatur zu hoch.
F07* | Spannung intern | Internen Versorgungsspannungen fehlerhaft
F08 | Überdrehzahl | Motor geht durch, Drehzahl unzulässig hoch
F09 | EEPROM | Checksummenfehler
F10 | Reserve | Reserve
F11 | Motorbremse | Kabelbruch, Kurzschluss, Erdschluss
F12 | Motorphase | Motorphase fehlt (Leitungsbruch o.ä.), in Vorbereitung
F13 | Umgebungstemp. | Umgebungstemperatur zu hoch
F14* | Endstufe | Fehler in der Leistungsendstufe, auch bei falscher Motorleitung oder nicht aufgelegtem Schirm.
F15 | I²t max. | I²t-Maximalwert überschritten
F16 | Netz-BTB | Fehlen von 2 oder 3 Phasen der Einspeisung
F17 | A/D-Konverter | Fehler in der analog-digital-Wandlung, oft hervorgerufen durch sehr starke elektromagnetische Störungen
F18* | Bremsschaltung | Bremsschaltung defekt oder Einstellung fehlerhaft
F19 | Zwischenkreis | Spannungseinbruch im Zwischenkreis
F20* | Slotfehler | Slot-Fehler, hängt von verwendeter Erweiterungskarte ab, siehe ASCII Befehlsreferenz ERRCODE
F21 | Handlingfehler | Handling-Fehler auf der Erweiterungskarte
F22 | reserviert | reserviert
F23 | CAN Bus aus | Schwerwiegender CAN Bus Kommunikationsfehler
F24 | Warnung | Warnungsanzeige wird als Fehler gewertet
F25* | Kommutierungsfehler | Kommutierungsfehler
F26 | Endschalter | Referenzfahrt-Fehler (Hardware-Endschalter erreicht)
F27 | STO | Fehler bei der Bedienung STO , Eingänge STO-ENABLE und ENABLE wurden gleichzeitig gesetzt
F28 | Feldbus Fehler | Synchronisationsfehler, siehe ASCII Befehlsreferenz ERRCODE
F29* | Feldbus Fehler | Kommunikation Erweiterungskarte/Feldbus gestört, siehe ASCII Befehlsreferenz ERRCODE
F30 | Emergency Timeout | Timeout Not-Stop
F31 | Safety Karte Fehler | Safety Fehlercode (siehe Datei Safety Card Error Codes auf der Download Seite Dateiarchiv): oXX : Safety Fehlernummer iYY : Safety Fehlersubindex
F32* | Systemfehler | Systemsoftware reagiert nicht korrekt

Warnungen

Auftretende Störungen, die nicht zum Abschalten der Verstärker-Endstufe führen (BTB-Kontakt bleibt geschlossen), werden im LED-Display an der Frontplatte über eine Warnungsnummer kodiert angezeigt.

Einige Warnmeldungen führen zu einem geführten Stillsetzen des Antriebs (Bremsung mit Notrampe).
Die Reaktion des Servoverstärkers hängt von der Warnung ab (siehe STATCODE).

Hinweise zu möglichen Ursachen finden Sie im Abschnitt Trouble Shooting

Nummer | Bezeichnung | Erklärung
E | Statusmeldung | Zwischenkreisspannung ist vorhanden. Verstärker ist freigegeben (Enable)
P | Statusmeldung | Zwischenkreisspannung ist vorhanden. Verstärker ist gesperrt (Disable)
. . . | Statusmeldung | Verstärker aktualisiert die Startkonfiguration
- | Statusmeldung | Programmiermodus z.B. beim Firmware-Update
- S - | Statusmeldung | STO-Enable-Eingang ist nicht beschaltet, Endstufe gesperrt
888 | Statusmeldung | FPGA Programm nicht geladen
nd0 | Statusmeldung | Non Dual Use Firmware (gekennzeichnet mit “_ND0") wird benutzt.
nd1 | Statusmeldung | Eine AL-3A225 Export klassifizierte Dual Use Firmware (gekennzeichnet mit “_ND1") wird benutzt.
n01 | I²t | I²t-Meldeschwelle überschritten
n02 | Bremsleistung | eingestellte Bremsleistung erreicht
n03 | S_fehl | eingestelltes Schleppfehler-Fenster überschritten
n04 | Ansprechüberwachung | Ansprechüberwachung (Feldbus) aktiv
n05 | Netzphase | Netzphase fehlt
n06 | Sw-Endschalter 1 | Software-Endschalter 1 überschritten
n07 | Sw-Endschalter 2 | Software-Endschalter 2 überschritten
n08 | Fahrauftrag_Fehler | Ein fehlerhafter Fahrauftrag wurde gestartet
n09 | Kein Referenzpunkt | Beim Fahrauftrag-Start war kein Referenzpunkt gesetzt
n10 | PSTOP | Endschalter PSTOP betätigt
n11 | NSTOP | Endschalter NSTOP betätigt
n12 | Motordefaultwerte geladen | nur ENDAT oder HIPERFACE® : Unterschiedliche Motornummern in Encoder und Verstärker gespeichert, Motordefaultwerte wurden geladen
n13 | Erweiterungskarte | 24V Versorgung für I/O-Erweiterungskarte nicht in Ordnung
n14 | SinCos-Feedback | SinCos Kommutierung (wake & shake) nicht vollzogen, wird bei freigegebenem Verstärker und ausgeführtem wake & shake gelöscht
n15 | Reserve | Reserve
n16 | Summenwarnung | Summenwarnung für n17 bis n31
n17 | Feldbus Sync | CAN Sync ist nicht eingeloggt
n18 | Multiturn Überlauf | Maximale Anzahl von Umdrehungen überschritten
n19 | Rampe beim Fahrsatz wurde begrenzt | Wertebereichüberschreitung bei Fahrsatzdaten
n20 | Ungültiger Fahrsatz | Ungültiger Fahrsatz
n21 | Warnung durch SPS Programm | Bedeutung geht aus Programm hervor
n22 | Motortemperatur überschritten | Die Warnung gibt dem Anwender Reaktionsmöglichkeiten, bevor der Fehler "Motorübertemperatur" zur Reglerabschaltung führt.
n23 | Sinus Kosinus Geber | Warnschwelle erreicht
n24 | Digital-Eingänge | Unlogische Konfiguration
n25-n31 | Reserve | Reserve
n32 | Firmware Betaversion | Firmwareversion ist nicht freigegeben

Trouble Shooting

Abhängig von den Bedingungen in Ihrer Anlage können vielfältige Ursachen für die auftretende Störung verantwortlich sein. Bei Mehrachssystemen können weitere versteckte Fehlerursachen vorliegen.

Beseitigen Sie auftretende Fehler und Störungen unter Beachtung der Arbeitssicherheit. Fehlerbeseitigung nur durch qualifiziertes und eingewiesenes Fachpersonal.

Unsere Applikationsabteilung hilft Ihnen bei Problemen weiter.

Hilfe bei Fehlern

Display | Bedeutung | Ursache | Behebung / Erklärung
Fehlermeldung Kommunikationsstörung (Inbetriebnahme-Software) |  | falsche Leitung verwendet | Nullmodem-Leitung verwenden
 |  | Leitung auf falschen Steckplatz am Servoverstärker oder PC gesteckt | Leitung auf richtige Steckplätze am Servoverstärker und PC stecken
 |  | falsche PC-Schnittstelle gewählt | Schnittstelle korrekt anwählen
F01 | Kühlkörpertemperatur | Umgebungstemperatur zu hoch | Grenzwert vom Hersteller auf 80°C eingestellt. Umgebungstemperatur senken.
 |  | Verstärker verschmutzt | Lüftungsschlitze kontrollieren / ausblasen. Luftfilter verwenden.
 |  | Lüfter defekt / nicht kontaktiert | Luftstrom / Lüftergeräusch kontrollieren, falls defekt, Verstärker an Hersteller zur Reparatur senden.
 |  | Zu kleiner Wert MAXTEMPH | Bereich 20 .. 85°C, default 80°C
 |  | Kein Luftstrom durch beengten Einbau | Umbau des Schaltschranks. Klimagerät einbauen.
 |  | Hardware defekt | Verstärker an Hersteller zur Reparatur senden
F02 | Überspannung im Zwischenkreis. Grenzwert abhängig von der eingestellten Netzspannung | Bremsenergie zu hoch | Vorher Anzeige von „n02“. Evtl. externen Bremswiderstand verwenden oder bei mehreren Verstärkern Zwischenkreise verbinden.
 |  | Netzspannung zu niedrig eingestellt | Auf Bildschirmseite Basiseinstellungen die Netzspannung korrekt einstellen
 |  | Bremswiderstand falsch konfiguriert | Auf Bildschirmseite Basiseinstellungen die Angaben für den internen bzw. externen Bremswiderstand korrekt einstellen
 |  | Bremswiderstand nicht korrekt angeschlossen | Verdrahtung prüfen (siehe Betriebsanleitung). Interner Bremswiderstand: Brücke am Stecker muss vorhanden sein! Externer Bremswiderstand: Brücke am Stecker muss entfernt sein!
 |  | Sicherung im Bremswiderstand hat ausgelöst | Sicherung ersetzen
 |  | Bremsrampen zu steil | Auf Bildschirmseite Drehzahlregler die Bremsrampen verlängern
 |  | Zwischenkreise nicht verbunden | Bei mehreren Verstärkern gleicher Familie die DC-Zwischenkreise verbinden (siehe Betriebsanleitung)
F03 | Schleppfehler Meldung des Lagereglers (nur in OPMODE 5 oder 6) | Achse ist mechanisch schwergängig oder blockiert | Mechanik prüfen
 |  | Drehmoment reicht nicht für die eingestellten Rampen | Flachere Rampen fahren(ACC, DEC)
 |  | Rampen im Drehzahlregler sind länger als die Rampen im Positionsregler | Beschleunigungsrampe (ACC) und Bremsrampe (DEC) im Drehzahlregler senken
 |  | Verstärkungen zu klein eingestellt. Achse zu undynamisch | Verstärkung anpassen, Bildschirmseiten Drehzahlregler und evtl. Lageregler
 |  | Verstärkungen zu groß eingestellt. Achse schwingt | Verstärkung anpassen, Bildschirmseiten Drehzahlregler und evtl. Lageregler , Filter einsetzen
 |  | IPEAK (Maximaler Strom) zu niedrig | Schleppfehlerfenster vergrößern (Bildschirmseiten Positionierdaten) oder größeren Verstärker / Motor einsetzten, IPEAK erhöhen.
F04 | Rückführung Kabelbruch | Kurzschluss, Erdschluss | Kontrolle der Feedbackleitung
 |  | Geber defekt | Geber / Motor tauschen
 |  | Kontakte im Stecker nicht in Ordnung | Durchmessen der Kontakte
 |  | Falsches Feedback eingestellt | Siehe FBTYPE
 |  | Falsche / defekte Feedbackleitung | Leitung kontrollieren (Besonders kritisch im Kabelschlepp)
 |  | Nicht kompatibles Feedback | Siehe FBTYPE
 |  | Schlecht geschirmte Leitungen | Einsatz von geeigneten Leitungen (siehe Betriebsanleitung)
 |  | Zu lange Feedbackleitung | Max. zulässige Leitungslänge einhalten (siehe Betriebsanleitung)
 |  | Einkopplung von Störsignalen | Abschirmung prüfen, Mindestabstand zwischen Leistungskabeln und Signalverbindungen einhalten (siehe Betriebsanleitung)
F05 | Unterspannung | Netzschütz nicht geschlossen | Verdrahtung / Not-Aus / Steuerlogik / ...
 |  | Einschaltreihenfolge nicht beachtet | Zuerst das über den BTB Kontakt geschaltete Leistungsschütz einschalten und ca. 0,5s später das Enable-Signal zuschalten
 |  | Not-Aus hat die Netzspannung abgeschaltet | Information an Bediener
 |  | Parameter VBUSMIN zu klein eingestellt | Anpassung des Parameters, z.B.: bei 48VDC Anwendungen.
 |  | Bei einigen Applikationen muss mit UVLTMODE 0 die Überwachung abgeschaltet werden | Beispiel: Positionieren der Achse bei Netzausfall.
F06 | Motortemperatur | Motortemperatur zu hoch | Falsche Motorparameter / Schlechte Kühlung
 |  | Temperaturfühler defekt | Widerstand des Fühlers messen. Schalter: niedrige Temperatur: Schalter geschlossen / hohe Temperatur: Schalter offen. Kaltleiter (PTC): niedrige Temperatur: kleiner Widerstand / hohe Temperatur: hoher Widerstand
 |  | Stecker der Rückführeinheit lose oder Rückführleitung unterbrochen | Stecker-/Leitungskontrolle
 |  | Motor ohne Temperaturfühler | Einbau einer Brücke im Stecker
 |  | Abschaltschwelle für Temperaturfühler zu niedrig eingestellt | Parameter MAXTEMPM einstellen (auf Abschaltschwelle, siehe Parameterbeschreibung)
 |  | Verstärker defekt | Temperaturkontakt zur Überprüfung an der Resolver- oder SinCos-Schnittstelle überbrücken
 |  | Nicht unterstützter Thermoschalter / Element | Applikationsabteilung kontaktieren
F07 | Interne Versorgungsspannungen fehlerhaft | Externer Kurzschluss oder Überlast einer Versorgungsspannung | Alle Stecker außer 24V abziehen und prüfen, ob der Fehler beim Einschalten wieder auftritt
 |  | 24V für Verstärkerlogik unterschritten | Toleranzvorgaben der 24V-Spannungsversorgung einhalten (siehe Betriebsanleitung)
 |  | Motorbremse mit zu hoher Stromaufnahme. | Max. Motorbremsstrom einhalten (siehe Betriebsanleitung), Bremse mit externer Spannung versorgen.
 |  | Hardware defekt | Verstärker an Hersteller zur Reparatur senden
 |  | Feedback System mit zu hoher Stromaufnahme | Applikationsabteilung kontaktieren
F08 | Überdrehzahl - Motor geht durch | Drehzahl unzulässig hoch | VOSPD (Grenzdrehzahl) überprüfen und gegebenenfalls. erhöhen.
 |  | Drehzahl unzulässig hoch | Überschwingen durch Parametrierung der Verstärkungen vermindern
 |  | Feedbackleitung defekt | (evtl. durch Wackeln an der Leitung überprüfen) Leitung austauschen
 |  | VLIM zu niedrig | Beim neuen Einladen eines Motors werden auch schneller drehende Motoren mit nur maximal 3.000 U/min eingetragen. Für höhere Drehzahlen muss die Enddrehzahl und die Überdrehzahl angepasst werden.
 |  | Motor schwingt. | Parameter Anpassung
 |  | Tabellen Fahrauftrag mit zu kleiner Zeitvorgabe. | Sollzeiten vergrößern oder Motor mit höherer Nenndrehzahl verwenden
 |  | Feedback des falschen Motors eingesteckt. | Zuordnung prüfen und korrigieren
 |  | Motorphasen vertauscht | Belegung prüfen
 |  | Feedback falsch eingestellt | Winkeloffset korrekt einstellen (MPHASE)
F09 | EEPROM Checksummenfehler | Verstärker während des Speichervorgangs ausgeschaltet | Parameter erneut einspielen und speichern
 |  | Von Hand geänderter Parametersatz mit Kleinbuchstaben eingeladen. | Kleinbuchstaben in Großbuchstaben abändern
 |  | Hardware defekt | Verstärker an Hersteller zur Reparatur senden
F10 | Kabelbruch an X5 | Stecker- / Leitungsproblem | Stecker / Leitungen überprüfen.
 |  | Überwachung im Slave spricht zu früh an nach einem Neustart | Den Parameter SDLY auf 8.000 setzten. (ab FW 1.3.1)
 |  | Keine Differenzspannungs- signale verwendet | Signalquellen müssen zwischen –5V und 5 V umschalten. Nicht zwischen 0V und 5V.
F11 | Motorbremse Kabelbruch | Kurzschluss, Erdschluss | Kabel ersetzen
 |  | Motorleitung ohne Bremsadern | Passende Motorleitung anschließen
 |  | Motor ohne Bremse | MBRAKE auf 0 setzten
 |  | Zu kleine Stromaufnahme der Motorbremse. | Stromaufnahme auf min. 150mA erhöhen (z.B. durch Parallelwiderstände).
 |  | Hardware defekt | Verstärker an Hersteller zur Reparatur senden
F12 | Motorphase | Schlecht oder nicht aufgelegter Schirm der Motorleitung | Schirmanbindungen kontrollieren
 |  | Starke äußere EMV Störungen | Zusätzliches Auslegen der Motorschirme auf der Montageplatte des Schaltschrankes.
 |  | Zu hohe Kapazität der Motorleitung | Verwendung einer Motordrossel / Leitungslänger verkürzen / Kollmorgen Europe GmbH Leitungen verwenden
 |  | Eingebautes Motorschütz schaltet nicht rechtzeitig. | Schütz überprüfen
 |  | Eingebautes Motorschütz hat verbrannte Kontakte. | Schütz überprüfen
 |  | Verstärker defekt | Verstärker an Hersteller zur Reparatur senden
 |  | Motorstecker nicht eingesteckt am Verstärker. | Stecker prüfen
 |  | Motorstecker nicht eingesteckt am Motor. | Stecker prüfen
F13 | Umgebungstemperatur zu hoch | Umgebungstemperatur zu hoch | Kühlgerät einsetzen
 |  | Erfassung defekt (oft gleichzeitig mit F17) | Verstärker an Hersteller zur Reparatur senden
 |  | Abschaltschwelle zu klein | TEMPE erhöhen
 |  | Schaltschrank zu warm. | Kühlgerät einsetzen
F14 | Endstufe | Kurzschluss in der Motorleitung | Motorleitung ersetzen
 |  | Endstufe defekt | Verstärker an Hersteller zur Reparatur senden
 |  | Isolationsfehler im Motor | Mit Ohmmeter zwischen den Motorphasen messen: müssen symmetrisch sein. Motorphasen gegen PE messen, muss unendlich sein. Falls vorhanden mit Hochspannungstester Motorphasen gegen PE messen.
 |  | Motorschütz schaltet nicht rechtzeitig. | Schaltreihenfolge prüfen
 |  | Motorschütz hat verbrannte Kontakte. | Motorschütz ersetzen.
F15 | I²t-Maximalwert überschritten | Antrieb ist mechanisch schwergängig | Mechanik prüfen, größeren Verstärker/Motor einsetzen
 |  | Sinus² Rampen | Beschleunigungs-/Bremsrampen verlängern (ACC, DEC)
 |  | Falsche Auslegung | Applikationsabteilung kontaktieren
 |  | Phasenwinkel zwischen Feedback und Magnetelementen im Motor nicht korrekt. | MPHASE korrigieren, evtl. mit ZERO neu einstellen.
 |  | Zu steile Rampen | Beschleunigungs-/Bremsrampen verlängern (ACC, DEC)
 |  | Zu kleine Pausenzeiten | Erholungspausen zwischen Fahraufträgen verlängern (Bildschirmseite Fahraufträge)
 |  | Schwingen im Stromregler | Verstärkung MLGQ und Nachstellzeit KTN anpassen
 |  | Motor hat Windungsschluss (nur bei Teilschluss) | Motor ersetzen
F16 | Netz-BTB, Fehlen von 1, 2 oder 3 Phasen der Einspeisung | Bei einphasiger Einspeisung ist dreiphasiger Betrieb eingestellt. | Auf Bildschirmseite Basiseinstellungen korrigieren
 |  | Fehlende Phasen bei der Einspeisung. | Verdrahtung/Sicherungen/Hauptschütz prüfen
 |  | Für eine DC Einspeisung werden besondere Einstellungen benötigt. | Applikationsabteilung kontaktieren
 |  | Verstärkerfreigabe (Enable) lag an, obwohl keine Netzspannung vorhanden war | Verstärker erst freigeben, wenn die Netzspannung eingeschaltet ist (Einschaltreihenfolge bachten)
F17 | A/D-Konverter Fehler | Starke elektromagnetische Störungen | EMV-Störungen reduzieren, Abschirmung und Erdung überprüfen. Geräte, die Magnetfelder erzeugen, mit größerem Abstand zum Verstärker montieren.
 |  | Verstärker defekt | Verstärker an Hersteller zur Reparatur senden
F18 | Bremsschaltung | Externer Bremswiderstand gewählt, aber nicht angeschlossen | Auf Bildschirmseite Basiseinstellungen korrigieren
 |  | Schalttransistor defekt | Verstärker an Hersteller zur Reparatur senden
F19 | Zwischenkreis (Abschaltbar für den Betrieb an zwei Phasen) | Es liegt keine Spannung an den Leistungsanschlüssen an. | Leistungsversorgung einschalten
 |  | Spannungsklasse ist falsch parametriert. | VBUSMIN anpassen
 |  | Zu starke Belastung des Zwischenkreises beim Beschleunigen in Kombination mit einer weichen Spannungsquelle (Trenntrafo) | Parameter oder Hardware anpassen
F20 | Slotfehler | Hardwarefehler der Erweiterungskarte | Bei Erweiterungskarte I/O-14/08 die externe Spannungsversorgung der Karte überprüfen
 |  | Falsche PROFIBUS Karte | Applikationsabteilung kontaktieren
 |  | Firmware unterstützt die eingesteckte Karte nicht. | Applikationsabteilung kontaktieren
 |  | Karte steckt nicht korrekt | Karte herausziehen und gemäß Beschreibung in der Betriebsanleitung neu einstecken und festschrauben.
 |  | Stromaufnahme der Einsteckkarte zu hoch. | Applikationsabteilung kontaktieren
 |  | POS I/O Karte nach dem Einbau nicht initialisiert. | Eingabe CALCPOSIO ins Terminal
F21 | Handlingfehler | Softwarefehler der Erweiterungskarte | Applikationsabteilung kontaktieren
 |  | Nicht zulässige Einsteckkarte | Applikationsabteilung kontaktieren
F22 | Reserviert | Reserviert |
F23 | CAN Bus | Schwerwiegender CAN Bus Kommunikationsfehler | CAN Leitung / Steuerung überprüfen
F24 | Warnung | Warnmeldung wird als Fehler ausgegeben | Mit dem Parameter WMASK kann ausgelesen werden welche Warnung(en) als Fehler gewertet werden. Anhand dieser Information muss in der Liste mit Warnmeldungen nachgeschlagen werden. Parameter LASTWMASK gibt an, welche Warnung zuletzt zu F24 geführt hat.
F25 | Kommutierungsfehler (Mögliches Durchgehen des Motor) Kraftvektor und Bewegung sind entgegengesetzt. | Verdrahtungsfehler Motorphasen | Motorleitung durchtesten – DIR anpassen
 |  | Verdrahtungsfehler Feedbackleitung | Drehrichtung im Monitorfenster kontrollieren, Feedbackleitung durchtesten – DIR anpassen
 |  | Spiel / Schwingen der Mechanik | Mechanik untersuchen und gegebenenfalls richten
 |  | Überwachung zu empfindlich | VCOMM erhöhen (VCOMM = MSPEED bedeutet minimale Empfindlichkeit)
 |  | Motorleitung / Feedbackleitung von einem anderem Motor aufgesteckt. | Zuordnung Verstärker-Motor prüfen und korrigieren.
 |  | Offset zu hoch | Resolverpolzahl (MRESPOLES), Motorpolzahl (MPOLES) und Offset (MPHASE) überprüfen
 |  | Wake&Shake fehlgeschlagen | Wake&Shake durchführen
F26 | Endschalter Referenzfahrt-Fehler Hardware - Endschalter erreicht (definiert durch REFLS) | Kabelbruch der Endschalterleitungen | Leitung durchmessen
 |  | Nicht zur Achse gehörende Endschalter angeschlossen. | Zuordnung Endschalter-Achse prüfen und korrigieren.
 |  | Keine Endschalter angeschlossen. | Eingangsfunktionen deaktivieren (Bildschirmseite I/O digital
 |  | Endschalter vertauscht. | PSTOP und NSTOP den Eingänge korrekt zuordnen (Bildschirmseite I/O digital
F27 | STO Fehler | Die STO Freigabe wurde gleichzeitig oder später als die Verstärkerfreigabe Enable geschaltet. | Einschaltreihenfolge einhalten (siehe Betriebsanleitung)
 |  | Kabelfehler in der Ansteuerung. | Leitungen durchmessen, Verdrahtung prüfen.
F28 | Feldbus, ext.Trajektorie | Fehler „externe Trajektorie“ wird generiert, wenn der Sollwertsprung bei der Vorgabe der externen Positions-Trajektorie den maximal zulässigen Wert überschreitet. | Anpassung der vorgegebenen Werte (VLIM / PVMAX)
 |  | EtherCAT: Der Fehler “Synchronisation” wird generiert wenn der Antrieb im Phasenhochlauf nicht synchronisieren lässt bzw. wenn der Antrieb im EtherCAT Zustand „Operational“ seine Synchronisation verliert. | EtherCAT System prüfen.
F29 | Erweiterungskarte allgemein | Software Enable wird gesetzt bei nicht gesetztem Hardware Enable | Hardware Enable zuerst setzen
 |  | Software Enable wird gesetzt bei abgeschalteter Netzspannung | Zuerst Netzspannung einschalten
 |  | Erweiterungskarte wird von der Firmware nicht unterstützt (z.B: bei kundenspezifischer Firmware). | Firmware aktualisieren
 |  | Feldbus Synchronisation über die Erweiterungskarte konnte nicht erreicht werden | Performance des Feldbus Masters überprüfen. Baudrate verkleinern
 | EtherCAT | “Fehler Löschen” (CLRFAULT) wenn der anstehende Fehler einen COLDSTART erfordert. Dies wird nur dann als Fehler gewertet, wenn das Bit 0x00080000 im Parameter SERCSET auf 1 steht. | COLDSTART im Terminalfenster eingeben.
 |  | Anwahl einer ungültigen Mapping Nummer | Korrekte Nummer anwählen
 |  | Mapping Länge fehlerhaft | Länge prüfen
 | SYNQNET | Aufschalten der Sollwerte bei anstehendem n14 - Wake&Shake | Sollwerte erst nach Ende der W&S Prozedur aufschalten
 |  | Phasenhochlauf Time Out (zwischen Phase3 und 4) | Netzwerkstruktur prüfen
 |  | „Upcount Lifetime counter“ abgelaufen |
 |  | Peercop Timeout abgelaufen |
 | SERCOS | Lichtwellenleiter gebrochen | Glasfaserleitung erneuern
 |  | MST Fehler | SERCOS Master überprüfen
 |  | nicht erlaubter Interrupt | Programmierung überprüfen
 |  | interner SERCOS Fehler (unbekannte ASIC Version) | Hardware prüfen
 |  | ungültiger SERCOS Mode |
F30 | Emergency Timeout Timeout Not-Stopp Default 5.000ms Motor kommt in der eingestellten Zeit nicht zum Stillstand | Rampe zu groß | DECSTOP verkürzen
 |  | Spitzenstrom zu niedrig eingestellt | IPEAK vergrößern
 |  | Zeit zu kurz eingestellt | EMRGTO vergrößern
 |  | Verstärker zu klein | Größeren Verstärker wählen
F31 | Safety-Karte Fehler | Ansprechüberwachung der Safetykarte meldet Fehlercode (siehe Datei Safety Card Error Codes auf der Download Seite Dateiarchiv): oXX : Safety Fehlernummer iYY : Safety Fehlersubindex | Fehlermeldung der Safetykarte überprüfen (siehe Datei Safety Card Error Codes auf der Download Seite Dateiarchiv)
F32 | Systemfehler Systemsoftware reagiert nicht korrekt | Prozessor überlastet | Zu viele Teilnehmer im Netzwerk/zu schnelle Baudrate/zu komplexe Funktionen (PLC)
 |  | Hardware defekt | Verstärker an Hersteller zur Reparatur senden

Hilfe bei Warnungen

Display | Bedeutung | Ursache | Behebung / Erklärung
n01 | I²t: Strombelastung überschreitet die eingestellte Meldeschwelle I2TLIM. | Mechanik schwergängig | Mechanik prüfen
 |  | Verstärker unterdimensioniert | Verstärker mit höherem Strom einsetzen
 |  | Motor unterdimensioniert | Motor mit höherem Strom einsetzen
 |  | Fahrprofil zu aggressiv | Erholungszeiten definieren
n02 | Die Bremsleistung überschreitet den eingestellten Grenzwert PBALMAX. | falsche Bremsleistung eingestellt | Einstellung prüfen
 |  | Leistung des internen Bremswiderstandes zu gering | externen Bremswiderstand verwenden, Bremsrampen verlängern (DEC / DECSTOP )
n03 | Schleppfehler überschreitet den Grenzwert PEMAX. | Mechanik schwergängig | Mechanik prüfen
 |  | Verstärker unterdimensioniert | Verstärker mit höherem Strom einsetzen
 |  | Fahrprofil zu aggressiv | Erholungszeiten definieren, Rampen verlängern
 |  | Schleppfehler zu klein eingestellt | Einstellung überprüfen
n04 | Überwachung der Feldbuskommunikation hat angesprochen (EXTWD). | Bei Inbetriebnahme: kein Feldbus angeschlossen | vorübergehend Watchdog deaktivieren (EXTWD = 0)
 |  | Im Betrieb: Kommunikationsproblem | Bus-Installation prüfen
n05 | Eine der drei Netzphasen fehlt |  | Netzanschluss, Sicherungen und Netzschütz prüfen
n06 | Eingestellte Position des Software- Endschalter 1 SWE1 ist unterschritten | Achse wurde über die als Endposition konfigurierte Position hinaus bewegt | Position der Achse und Einstellung des Software-Endschalters überprüfen
n07 | Eingestellte Position des Software- Endschalter 2 SWE2 ist überschritten | Achse wurde über die als Endposition konfigurierte Position hinaus bewegt | Position der Achse und Einstellung des Software-Endschalters überprüfen
n08 | Fahrauftrag fehlerhaft | Gestarteter Fahrauftrag existiert nicht (Checksumme fehlerhaft) | Fahrauftrag neu anlegen
 |  | Zielposition liegt außerhalb des zulässigen Bereiches | Software-Endschalter und Zielpositionen prüfen
 |  | Beschleunigungswerte fehlerhaft | Einheiten und Zahlenwerte prüfen
 |  | OPMODE lässt Funktion nicht zu | Korrekten OPMODE einstellen
n09 | Kein Referenzpunkt | Bei Start eines Fahrauftrages war noch kein Referenzpunkt gesetzt. | Referenzfahrt ausführen oder Referenzpunkt setzen
n10 | Hardware- Endschalter PSTOP | Positiver Endschalter hat angesprochen | Achse in negative Richtung vom Endschalter fahren
 |  | Endschalter nicht angeschlossen | Parametrierung der digitalen I/Os ändern oder Endschalter anschließen
 |  | Endschaltersensor hat falsche Logik. | Öffner als Endschalter einsetzen (statt Schließer).
n11 | Hardware- Endschalter NSTOP | Negativer Endschalter hat angesprochen | Achse in positive Richtung vom Endschalter fahren
 |  | Endschalter nicht angeschlossen | Parametrierung der dig. I/Os ändern oder Endschalter anschließen
 |  | Endschaltersensor hat falsche Logik. | Öffner als Endschalter einsetzen (statt Schließer).
n12 | Motordefaultwerte geladen | Motornummern in Encoder und Verstärker weichen voneinander ab | Motornummer mit SAVE im EEPROM speichern und über HSAVE im Encoder.
n13 | Erweiterungskarte | 24V-Versorgung für die I/O-Erweiterungskarte fehlt | Verdrahtung und 24V-Netzteil prüfen
n14 | SinCos-Feedback | SinCos-Kommutierung (wake&shake) nicht vollzogen | Verstärker freigeben
n16 | Summenwarnung | Summenmeldung für die Warnungen n17...n31 | Siehe gemeldete Warnung
n17 | Feldbus Sync | CAN Sync ist aktiviert, wird aber nicht oder nicht synchron von der Steuerung gesendet. | Feldbus Einstellungen prüfen
n18 | Multiturn Überlauf | mehr als +/-2048 Umdrehungen bei angeschlossenem Multiturn-Geber gezählt | Ignorieren bzw. Überwachung mit DRVCNFG Bit7=1 deaktivieren
 |  |  | Motor vor Montage auf Geberposition 0 fahren
n19 | Rampe beim Fahrsatz wurde begrenzt | zulässiger Wertebereich durch die Fahrsatzdaten überschritten | Fahrsatzdaten überprüfen
n20 | Ungültiger Fahrsatz |  | Daten des zuletzt gestarteten Fahrsatzes überprüfen. Die Fahrsatznummer gegebenenfalls mit MOVE ermitteln.
n21 | Warnung durch SPS Programm | Nur bei Makroprogramm im Servoverstärker | Anwendungsspezifisch
n22 | Motortemperatur überschritten | Eingestellte Warnschwelle überschritten, Motor überlastet | Motortemperatur prüfen.
 |  | Mechanik schwergängig/blockiert | Mechanik prüfen
n23 | Sinus Kosinus Geber | Signalamplitude zu gering | Signalamplitude prüfen, eventuell mit Oszilloskop nachmessen
n24 | Digital-Eingänge | Konfiguration unlogisch | Die letzte Konfigurationsänderung rückgängig machen
n32 | Firmware Betaversion | Nur zu Testzwecken | Verwendung der Firmware auf eigene Gefahr

Tipps bei sonstigen Problemen

Die unten beschriebenen Situationen werden nicht unbedingt durch einen Fehler oder eine Warnung gemeldet.

Problem | mögliche Fehlerursachen | Maßnahmen zur Beseitigung der Fehlerursachen
Motor dreht nicht | Servoverstärker nicht freigegeben | Hardware ENABLE Signal anlegen
 | Software nicht freigegeben | Software Enable aktivieren
 | Sollwertleitung unterbrochen | Sollwertleitung prüfen
 | Motorphasen vertauscht | Motorphasen korrekt auflegen
 | Bremse ist nicht gelöst | Bremsenansteuerung prüfen
 | Antrieb ist mechanisch blockiert | Mechanik prüfen
 | Motorpolzahl nicht korrekt eingestellt | Parameter Motorpolzahl einstellen
 | Rückführung falsch eingestellt | Rückführung korrekt einstellen
Motor schwingt | Verstärkung zu hoch (Drehzahlregler) | Kp~GV (Drehzahlregler) verkleinern
 | Abschirmung Rückführleitung unterbrochen | Rückführleitung erneuern
 | AGND nicht verdrahtet | AGND mit CNC-GND verbinden
Antrieb zu weich | Verstärkung Kp~GV (Drehzahlregler) zu klein | Kp~GV (Drehzahlregler) vergrößern
 | Nachstellzeit Tn~GVTN (Drehzahlregler) zu groß | Tn~GVTN (Drehzahlregler), Motordefaultwert
 | ARLPF / ARHPF zu groß | ARLPF / ARHPF verkleinern
 | ARLP2 zu groß | ARLP2 verkleinern
Antrieb läuft rauh | Verstärkung Kp~GV (Drehzahlregler) zu groß | Kp~GV (Drehzahlregler) verkleinern
 | Nachstellzeit Tn~GVTN (Drehzahlregler) zu klein | Tn~GVTN (Drehzahlregler), Motordefaultwert
 | ARLPF / ARHPF zu klein | ARLPF / ARHPF vergrößern
 | ARLP2 zu klein | ARLP2 vergrößern
Achse driftet bei Sollwert=0V | Offset bei analoger Sollwertvorgabe nicht korrekt abgeglichen | Offset (Analog I/O) abgleichen
 | AGND nicht mit CNC-GND der Steuerung verbunden | AGND und CNC-GND verbinden


ASCII Deutsch ARHPD

ASCII - Kommando | ARHPD |
Syntax Senden | ARHPD [Data] |
Syntax Empfangen | ARHPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3607 (hex)
DIM |  | PROFIBUS PNU | 1863 (dec) IND = 1 (dec)
Bereich | 0 ... 10 | DPR | 263 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Float 32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Dämpfung Hochpass

Beschreibung

ARHPD ist die Hochpaßdämpfung des Drehzahlfilters.

Eine detailliertere Beschreibung zur Einstellung des/der Drehzahlreglerfilter/s findet sich unter BQMODE.


ASCII Deutsch ARHPF

ASCII - Kommando | ARHPF |
Syntax Senden | ARHPF [Data] |
Syntax Empfangen | ARHPF [Data] | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3608 (hex)
DIM |  | PROFIBUS PNU | 1864 (dec) IND = 1 (dec)
Bereich | 0 ... 4000 | DPR | 264 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Grenzfrequenz Hochpass

Beschreibung

ARHPF ist die Hochpaß-Frequenz des Drehzahlfilters.

Eine detailliertere Beschreibung zur Einstellung des/der Drehzahlreglerfilter/s findet sich unter BQMODE.


ASCII Deutsch ARLP2

ASCII - Kommando | ARLP2 |
Syntax Senden | ARLP2 [Data] |
Syntax Empfangen | ARLP2 [Data] | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3609 (hex)
DIM | Hz | PROFIBUS PNU | 1865 (dec) IND = 1 (dec)
Bereich | 0 ... 1500 | DPR | 265 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Tiefpass in Hz

Beschreibung

ARLP2 ist die Einsatzfrequenz eines zusätzlichge Tief-Pass-Filters 1.Ordnung für den Drehzahlregler. Nur wenn ARLP2 ist auf einen Wert > 0 eingestellt ist, so ist der Filter activ.

Tief-Pass-Filter werden genutzt, um hochfrequente Störsignale zu unterdrücken (z.B. Resonanzen und Rauschen).

Eine detailliertere Beschreibung zur Einstellung des/der Drehzahlreglerfilter/s findet sich unter BQMODE.


ASCII Deutsch ARLPD

ASCII - Kommando | ARLPD |
Syntax Senden | ARLPD [Data] |
Syntax Empfangen | ARLPD [Data] | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 360A (hex)
DIM |  | PROFIBUS PNU | 1866 (dec) IND = 1 (dec)
Bereich | 0 ... 10 | DPR | 266 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Dämpfung Tiefpass

Beschreibung

ARLPD ist die Tiefpaßdämpfung des Drehzahlfilters.

Eine detailliertere Beschreibung zur Einstellung des/der Drehzahlreglerfilter/s findet sich unter BQMODE.


ASCII Deutsch ARLPF

ASCII - Kommando | ARLPF |
Syntax Senden | ARLPF [Data] |
Syntax Empfangen | ARLPF [Data] | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 360B (hex)
DIM |  | PROFIBUS PNU | 1867 (dec) IND = 1 (dec)
Bereich | 0 ... 4000 | DPR | 267 (dec)
Default | 160 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Grenzfrequenz Tiefpass

Beschreibung

ARLPF ist die Tiefpaß-Frequenz des Drehzahlfilters.

Eine detailliertere Beschreibung zur Einstellung des/der Drehzahlreglerfilter/s findet sich unter BQMODE.


ASCII Objektreferenz

Ihr Internet Browser ist nicht geeignet. Verwenden Sie einen Browser, der Frames darstellen kann.


ASCII Deutsch ASMWAIT

ASCII - Kommando | ASMWAIT |
Syntax Senden | ASMWAIT [Data] |
Syntax Empfangen | ASMWAIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3868 (hex)
DIM | ms | PROFIBUS PNU | 1672 (dec) IND = 33 (dec)
Bereich | 0 .. 2000 | DPR | 872 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | erzw. Verzögerung des Drehzahlsollwerts (Asynchr.)

Beschreibung

Erzwungene Verzögerung des Drehzahlsollwerts bei Betrieb einer Asynchronmaschine.
Die Asynchronmaschine muss zuerst magnetisiert werden, bevor sie das volle Drehmoment erzeugen kann.
Mit ASMWAIT lässt sich die erzwungene Wartezeit einstellen, während der der Drehzahlsollwert nach dem Freigabe der Endstufe (Hardware/Software-Enable) noch auf dem Wert 0 gehalten wird. Wenn die Maschine vollständig magnetisiert ist, kann sie mit dem vollen Drehmoment starten.

Betrieb ohne Bremse (MBRAKE = 0):
Q-Strom wird sofort nach der Freigabe der Endstufe zugelassen, damit sich die Welle nicht zu stark bewegt.

Betrieb mit Bremse (MBRAKE = 1):
TBRAKE0 verhindert, dass Q-Strom zugelassen wird, da die Maschine sonst gegen die Bremse arbeiten würde, wenn diese noch nicht vollständig geöffnet ist.
ASMWAIT < TBRAKE0: Nach der Freigabe der Endstufe werden Drehzahlsollwert und Q-Strom bis zum Ablauf von TBRAKE0 auf dem Wert 0 gehalten. Die Bremse wird sofort gelüftet. Die Magnetisierung der Asynchronmaschine beginnt vor Ablauf von TBRAKE0 (festgelegt durch ASMWAIT).
ASMWAIT > TBRAKE0: Nach der Freigabe der Endstufe werden Drehzahlsollwert und Q-Strom bis zum Ablauf von ASMWAIT auf dem Wert 0 gehalten. Die Magnetisierung der Asynchronmaschine beginnt sofort nach der Freigabe. Die Bremse wird vor Ablauf von ASMWAIT gelüftet (TBRAKE0).


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

U/f Steuerung

uf

Diese Bildschirmseite erscheint nur bei angewähltem Setup Wizard "Asynchron-Motor (U/f-Steuerung). Hier können Sie alle erforderlichen Parameter zum Betrieb eines Induktionsmotors (Asynchronmotors) einstellen.

Bildschirmtext | ASCII-Parameter
Drehzahl 1 | SKIP1SP
Breite 1 | SKIP1W
Drehzahl 2 | SKIP2SP
Breite 2 | SKIP2W
Io | MICONT
Iomax | MIPEAK
Beschl. Rampe | ACC
Bremsrampe | DEC
Polzahl | MPOLES
Nennspannung | MUR
Minimal-Spannung | VSTART
Nenndrehzahl | MVR
Verstärkung | IQFILTK
Leistungsfaktor | MCOSPHI
TP-Zeitkonstante | IQFILTTAU
Nennfrequenz | MFR
Brems-/Disable-Verhalten (Fehler) | ACTFAULT
Bremsrampe (Fehler) | DECSTOP
Brems-/Disable-Verhalten (Disable-Befehl) | STOPMODE
Bremsrampe (Disable) | DECDIS

Hinweise für den sensorlosen Betrieb von Asynchronmotoren siehe Applikationshinweis Asynchronmaschine - U/f Steuerung.


ASCII Deutsch AUTOHOME

ASCII - Kommando | AUTOHOME |
Syntax Senden | AUTOHOME [Data] |
Syntax Empfangen | AUTOHOME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D7 (hex)
DIM |  | PROFIBUS PNU | 1671 (dec) IND = 17 (dec)
Bereich | 0,1 | DPR | 471 (dec)
Default | 0 |
Opmode | 8, 4 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Automatische Referenzfahrt

Beschreibung

Mit dem Kommando AUTOHOME kann das automatische Starten einer Referenzfahrt beim Freigeben der Endstufe aktiviert werden.

AUTOHOME=0 Keine automatische Referenzfahrt bei der Endstufenfreigabe

AUTOHOME=1 Beim Freigeben der Endstufe wird automatisch eine Referenzfahrt gestartet (s. Kommando MH)

Ab FW 1.31:
AUTOHOME=2 Beim Freigeben der Endstufe wird automatisch eine Referenzfahrt gestartet, falls noch kein Referenzpunkt gesetzt war.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Autotuning

Die Tuning Funktionen passen die Defaultwerte des Herstellers an die Lastverhältnisse an, um Schleppfehler zu minimieren. Eine Optimierung der Regelkreise für hochdynamische oder hochpräzise Anwendungen muss manuell durchgeführt werden.

Das Autotuning kann mehrfach gestartet werden, da die Ergebnisse aufeinander aufbauen (Start Qualität).

0danger - color
Während der Tuning Funktionen wird der Servoverstärker freigegeben und die Last kann sich bewegen. Verletzungsgefahr! Um gefährliche Situationen zu vermeiden, beachten Sie folgende Hinweise:

  • Bei vertikalen Achsen: bewegen Sie die Last manuell in den unteren Totpunkt und stellen Sie die Bewegungsrichtung auf "nur negativ" oder "nur positiv" abhängig von der Anwendung, bevor Sie Test oder Tuning Funktionen starten.
  • Bei Feedbacks ohne Kommutierung: Führen Sie zunächst ein Wake&Shake durch.
  • Lösen Sie Feststellbremsen.
  • Führen Sie das Autotuning in 4 Schritten durch (siehe Screenshot). Alle Funktionen geben die Endstufe frei und führen zu Bewegungen der Motorachse:
    1- Strom Tuning
    2 - Beobachter Tuning
    3 - Einstellungen für Auto Tuning testen
    4 - Auto Tuning

Die Inbetriebnahme-Software prüft automatisch, ob das Autotuning in der Firmware implementiert ist und aktiviert die Funktionalitäten. Sollte ihre Firmware das Autotuning nicht unterstützen, so wird die Seite zwar angezeigt, jedoch sind die Bedienelemente deaktiviert.

Profibus1

Voraussetzung:

  • Motor und Feedback müssen korrekt eingestellt sein. Bei Feedbacksystemen ohne Kommutierung muss Wake&Shake durchgeführt worden sein.
  • Die Last muss angekoppelt sein.
  • Der Antrieb darf nicht festgebremst sein.

Strom und Beobachter Tuner

Starte Strom Tuner | Diese Schaltfläche startet die Tuningfunktion für den Stromregler. Hierzu muss OPMODE auf 2 gesetzt sein.
Starte Beobachter Tuner | Diese Schaltfläche startet eine Optimierungsfunktion für den VLO-Parameter. VLO ist ein Parameter des Luenberger Drehzahl Beobachters. Eine zu starke Verkleinerung von VLO kann die Stabilität des Drehzahlregelkreises gefährden.

Testbetrieb

Die Achse ist nun soweit voreingestellt, dass ein erster Bewegungstest erfolgen kann. Wechseln Sie dazu auf die Seite „Oszilloskop“.

Unter dem Punkt „Service-Funktionen“ kann die Betriebsfunktion gewählt werden und die Bewegungsparameter eingegeben werden.

Horizontale/Rotatorische Achsen: | Bewegen Sie die Achse in Mittelstellung. Verwenden Sie für einen ersten Testlauf die Funktion Reversierbetrieb. Stellen Sie die Parameter auf ungefährliche Werte ein. ACHTUNG: Stoppen Sie die Bewegung manuell (Stop Schaltfläche oder F11)
Vertikalen Achsen: | Bewegen Sie die Achse zum unteren Totpunkt. Verwenden Sie für einen ersten Testlauf die Funktion Drehzahl (Geschwindigkeit) wählen. Stellen Sie die Parameter auf ungefährliche Werte ein. ACHTUNG: Stoppen Sie die Bewegung manuell (Stop Schaltfläche oder F11)

Sollte ihre Achse mit den standard Drehzahlreglerparametern sich nicht bewegen, können Sie die Proportionalverstärkung „GV“ erhöhen, bis eine Bewegung gesehen wird. Die Änderung der Parameter kann auf der Oszilloskopseite unter „Regler Einstellungen“ während des Servicebetriebs vorgenommen werden.

Starten Sie während des Testbetriebs eine Oszilloskopaufnahme und speichern Sie das Bild als Referenzaufnahme, um nach dem Autotuning das Ergebnis zu vergleichen und zu bewerten. Zu diesem Zweck speichern Sie die Aufzeichnungen in einer Datei.

Nun können Sie mit dem Autotuning fortfahren. Wechseln Sie wieder zur Seite Auto-Tuning.

Drehzahl-Tuner

TIPP: Die Flankensteilheit der Sprünge wird definiert durch ACC und DEC. Für gute Ergebnisse sollte eine möglichst große Flankensteilheit gewählt werden (Maschinenbeschränkung beachten!).

ASCII-Parameter | Beschreibung
GV | Proportionalverstärkungsfaktor
MRESBW | Bandbreite des Feedbacks
VLO | Beobachtervorsteuerung
GVTN | Integralanteil
ARLPF | Filter Tiefpassfrequenz
ARHPF | Filter Hochpassfrequenz
ARLPD | Filter Tiefpassdämpfung
ARHPD | Filter Hochpassdämpfung
Start Auto-Tuning | Klicken des Buttons startet die Autotuning Routine. Während des Tunings wird der Mauszeiger als „busy“ angezeigt und ein Fortschrittsbalken zeigt den Stand des Tunings an. Es ist möglich, während des Tunings beispielsweise die I²T Auslastung des Servoverstärkers auf der Monitor-Seite zu beobachten. Das Tuning ist abgeschlossen, wenn der Statusbalken 100% anzeigt und der Button Start Auto-Tuning wieder aktiviert ist. Sie können nun das Tuning mit anderen Parametern und Einstellungen erneut starten oder das Ergebnis mit Referenzmessungen vergleichen, indem Sie eine neue Oszilloskopaufnahme mit den gleichen Bewegungsparametern durchführen.
Stop + Disable | Klicken des Buttons stoppt die Autotuning Routine. Der Servoverstärker wird gesperrt und die aktuellen Werte befinden sich im flüchtigen Speicher. Ein Verlassen des Fensters führt ebenfalls zum Stop des Autotunings.
Start Qualität | Zustand zu Beginn der Autotuning Funktion
Aktuelle Qualität | Momentan erreichtes Ergebnis
Beste Qualität | Bestes bisher erreichtes Ergebnis

Auto-Tuning senkt GV um 20% unter den ermittelten Maximalwert, um eine robuste Einstellungen zu liefern. Wenn es sich um hochdynamische Anwendungen handelt, können Sie GV wieder um 20% erhöhen.

Speichern Sie die ermittelten Werte im EEPROM.


ASCII Deutsch AVZ1

ASCII - Kommando | AVZ1 |
Syntax Senden | AVZ1 [Data] |
Syntax Empfangen | AVZ1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3511 (hex)
DIM | ms | PROFIBUS PNU | 1617 (dec) IND = 1 (dec)
Bereich | 0.2 .. 100.0 | DPR | 17 (dec)
Default | 1 |
Opmode | 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Filter-Zeitkonstante für den Analogeingang 1

Beschreibung

Filter-Zeitkonstante für den Analogeingang SW1 (62,5µs Zykluszeit)


ASCII Deutsch AVZ2

ASCII - Kommando | AVZ2 |
Syntax Senden | AVZ2 [Data] |
Syntax Empfangen | AVZ2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 387A (hex)
DIM | ms | PROFIBUS PNU | 1690 (dec) IND = 33 (dec)
Bereich | 0.2 .. 100.0 | DPR | 890 (dec)
Default | 1 |
Opmode | 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Filter-Zeitkonstante für den Analogeingang 2

Beschreibung

Nur S700

Filter-Zeitkonstante für den Analogeingang SW2 (62,5µs Zykluszeit)


ASCII Deutsch \

ASCII - Kommando | \ |
Syntax Senden | \ [Data] |
Syntax Empfangen | \ <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 362B (hex)
DIM | - | PROFIBUS PNU | 1899 (dec) IND = 1 (dec)
Bereich | 0(=Master) .. 63 | DPR | 299 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Anwahl der Remote Adresse

Beschreibung

Bei einem CAN-Netzwerk an dem mehrere Verstärker angeschlossen sind, gibt es die Möglichkeit über eine serielle Verbindung zu einem der Geräte (Master), eine Kommunikation zu allen anderen Verstärkern herzustellen. Dazu wird mit dem Kommando SCAN am Master-Gerät eine automatische Erkennung aller angeschlossenen Verstärkers eingeleitet. Die Antwort auf das SCAN-Kommando enthält eine Adressenaufstellung aller erkannten Verstärker.
Mit dem Kommando "\ Addr" kann das Gerät mit der Adresse "Addr" aktiviert werden. Jedes weitere Kommando das über die serielle Schnittstelle übertragen wird, wird von der Master-Station ignoriert und über CAN-Bus an die aktivierte Verstärker-Station weitergeleitet. Die Antworten, die diese Station über CAN-Bus liefert, werden auf die serielle Schnittstelle umgeleitet. Mit dem Kommando "\ 0" kann die Slave-Station abgewählt und die Master-Station wieder aktiviert werden.

Wenn MDRV = 0 gesetzt wird, so wird die Multi-Link Funktionalität abgeschaltet.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Basiseinstellungen

basis

Bremswiderstand*, Netzspannung und das Verhalten bei Netzausfall wird hier eingestellt.

Angezeigt werden die Stammdaten des Servoverstärkers wie Seriennummer und Betriebsstunden. Sie können dem Servoverstärker einen Namen (max. 8 Zeichen) zuweisen.

Bildschirmtext | ASCII-Parameter
Bremswiderstand intern/extern* | PBALRES
Bremswiderstand Wert* | PBALRES
max. Bremsleistung* | PBALMAX
Netzspannung | VBUSBAL
Aktion bei Verlust einer Netzphase | PMODE
Name | ALIAS
Command Delay | CMDDLY
Beim Booten Software-Enable setzen | AENA
Reglereinstellungen | Verschiedene Frequenzeinstellungen für die PWM, Stromregler und Positionsregler sind wählbar.
Gerätekonfiguration für Experten | DRVCNFG, DRVCNFG2, DRVCNFG3, DRVCNFG4 Diese Einstellungen sollten nur von Experten geändert werden. Wenn Sie auf die jeweilige Schaltfläche "Einstellen" klicken, öffnen sich umfangreiche Listen mit Funktionen des Servoverstärkers, die ein- oder ausgeschaltet werden können.

* = erscheinen nicht, wenn "Schnelleinstellung (Motor-/Verstärker-Kombination)" im Setup Wizard ausgewählt wurde.


ASCII Deutsch BCC

ASCII - Kommando | BCC |
Syntax Senden | BCC |
Syntax Empfangen | BCC <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 363A (hex)
DIM | - | PROFIBUS PNU | 1914 (dec) IND = 1 (dec)
Bereich | - | DPR | 314 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | EEPROM-Checksumme

Beschreibung

Die Variable BCC liefert eine Checksumme für den Parameterbereich des seriellen EEPROM's.
In diesem Bereich werden bei einem SAVE-Kommando alle internen Parameter des Verstärkers in ASCII-Form abgelegt. Die Checksumme entsteht durch Aufsummieren aller gespeicherten Bytes und wird mit jedem LOAD bzw. SAVE-Kommando neu berechnet. Sie dient lediglich der Erkennung von EEPROM-Fehlern.
Sie kann auch benutzt werden, um zu erkennen, ob der in der Steuerung vorhandene Datensatz mit dem im Servo hinterlegten übereinstimmt.


ASCII Deutsch BCCOT

ASCII - Kommando | BCCOT |
Syntax Senden | BCCOT [Data] |
Syntax Empfangen | BCCOT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3895 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 33 (dec)
Bereich | - | DPR | 917 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.2
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | EEPROM-Checksumme ohne Betriebsstundenzähler

Beschreibung

Die Variable BCCOT liefert eine Checksumme für den Parameterbereich des seriellen EEPROM's ohne Betriebsstundenzähler.
In diesem Bereich werden bei einem SAVE-Kommando alle internen Parameter des Verstärkers in ASCII-Form abgelegt. Diese Checksumme entsteht durch Aufsummieren der gespeicherten Bytes und wird mit jedem LOAD bzw. SAVE-Kommando neu berechnet. Sie ist geeignet, um Parameteränderungen festzustellen.


ASCII Deutsch BISSCNFG

ASCII - Kommando | BISSCNFG |
Syntax Senden | BISSCNFG [Data] |
Syntax Empfangen | BISSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38B7 (hex)
DIM | - | PROFIBUS PNU | 1751 (dec) IND = 33 (dec)
Bereich | -32768 .. 32767 | DPR | 951 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.06 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Konfigurationsparameter für BiSS-C

Beschreibung

Dieser Parameter wird in Verbindung mit dem FBTYPE = 33 genutzt. Er setzt zum einen fest, wie viele Bits für die Position eines BiSS C-Mode unidirektional Gebers abgeholt werden müssen, also die Auflösung und zum anderen welchen Aktiv – Pegel das Error- und Warn – Bit im Frame haben.

Nach BiSS Spezifikation sind das Error und das Warn Bit aktiv ‚0’. Sollte eine Invertierung erforderlich sein, ist dies durch folgende Addition möglich.

Error – Bit
0x40 (64) aktiv ‚1’

Warn – Bit
0x80 (128) aktiv ‚1’


ASCII Deutsch BISSREVOL

ASCII - Kommando | BISSREVOL |
Syntax Senden | BISSREVOL [Data] |
Syntax Empfangen | BISSREVOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3922 (hex)
DIM | - | PROFIBUS PNU | 1858 (dec) IND = 33 (dec)
Bereich | 0 ... 32 | DPR | 1058 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 6.02 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl der Multiturn-Bits bei einem BISS-C-Geber

Beschreibung

Dieser Parameter gibt die Anzahl der Multiturn-Bits bei einem BISS-C-Geber an

BISSREVOL=0 Singleturn


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Bode-Plot

Diese Funktion darf nur von erfahrenen Regelungstechnikern gestartet werden. Nach Quittieren der Sicherheitsabfrage wird die Bewegung der Achse mit interner Sollwertvorgabe sofort automatisch gestartet !
Auf Anfrage bieten wir Ihnen eine entsprechende Schulung an.

bode1

Mit Hilfe des Bode Plots können Sie den Drehzahlregelkreis unter Berücksichtigung der mechanischen Eigenheiten der Maschine analysieren und optimieren.

Der Bode Plot zeichnet den Frequenzgang des Drehzahlregelkreises auf. Das System wird durch eine sinusförmige Eingangsgröße erregt. Die Ausgangsgröße hat dieselbe Frequenz, jedoch eine andere Amplitude und eine gewisse Phasenverschiebung.

Durch die Verhältnisse der Frequenzabhängigkeit der Amplitude (Amplitudengang: das frequenzabhängige Amplitudenverhältnis in logarithmischer Darstellung) sowie der Phasenverschiebung (Phasengang: die frequenzabhängige Phasenverschiebung) wird die komplette dynamische Eigenschaft des Regelkreises beschrieben.

Amplitudengang
Der Amplitudengang bezeichnet das frequenzabhängige Amplitudenverhältnis in logarithmischer Darstellung

Phasengang
Der Phasengang beschreibt die frequenzabhängige Phasenverschiebung.

Zur qualitativen Beschreibung dieses Frequenzgangs des offenen Regelkreises werden folgende Kenndaten verwendet:

Phasenreserve (open loop)
Abstand der Phasenkennlinie von der -180°-Geraden bei der Durchtrittsfrequenz, d.h. beim Durchgang der Amplitudenkennlinie durch die 0-dB-Kennlinie.

Amplitudenreserve (open loop)
Abstand der Amplitudenkennlinie von der 0-dB-Linie beim Phasenwinkel -180°

Die Eigenschaften des geschlossenen Regelkreis werden mit Hilfe des Bode-Plots über die Begriffe "Bandbreite" und "Peaking" bewertet:

Bandbreite (closed loop)
Als Bandbreite bezeichnet man die Frequenz, bei welcher das logarithmische Amplitudenverhältnis auf -3dB abgefallen ist.

Peaking (closed loop)
Der Begriff Peaking beschreibt das Überschwingen des geschlossenen Regelkreises, welches dem Maximum im Amplitudengang entspricht.

Bode Plot
Start der Datenerfassung.

Parameter…
Aufruf der Bildschirmseite "Bode Plot Parameter". Über diese Seite werden Frequenzbereich sowie Anzahl der Schritte vorgegeben.

bodeparameter

Schalter Offener Kreis / Geschlossener Kreis bzw Filter-Funktion
“Offener Kreis / Geschl. Kreis”
Es werden Amplituden- und Phasengang des offenen und geschlossenen Regelkreises angezeigt.

“Offener Kreis / Filter-Funktion”
Angezeigt werden Amplituden- und Phasengang
- des offenen Regelkreises
- eines nachgeschalteten Filters
- des offenen Regelkreises einschließlich des Filters angezeigt (resultierender Verlauf).

Diese Funktion dient also der “Simulation” eines Filters.

Einstellungen (nur bei Filter-Funktion)
Wählen Sie die die gewünschte Filterfunktion im Auswahlfenster. Die Filterparameter müssen über das Terminalfenster eingestellt werden.

PID-T2-Filter
Der PID-T2 Filters kann benutzt werden, um effektiv Drehmomentschwankungen und Resonanzen bei Motor, Getriebe und angekoppelter Last zu reduzieren.
ASCII-Parameter für diesen Filter:
BQMODE = 2
ARLPF - TP-Frequenz
ARHPF - HP-Frequenz

Tiefpass 1. Ordnung
Tief-Pass-Filter werden genutzt, um hochfrequente Störsignale (z.B. Resonanzen und Rauschen) zu unterdrücken.
ASCII-Parameter für diesen Filter:
ARLP2

Tiefpass 2. Ordnung
Tief-Pass-Filter werden genutzt, um hochfrequente Störsignale (z.B. Resonanzen und Rauschen) zu unterdrücken.
ASCII-Parameter für diesen Filter:
ARLPF - TP-Frequenz
ARLPD - TP-Dämpfung

Bi-Quad
Der Bi-Quad Filters kann benutzt werden, um effektiv Resonanzen im 2 Massen Schwinger System zu reduzieren.
ASCII-Parameter für diesen Filter:
BQMODE = 3
ARLPF - TP-Frequenz
ARLPD - TP-Dämpfung
ARHPF - HP-Frequenz
ARHPD - HP-Dämpfung

bodefilter

Speichern
Speichern der erfassten Messwerte auf Datenträger in CSV Format (kann mit MS-Excel ausgewertet werden).

Laden
Laden einer CSV-Datei und Darstellung der Kurven im Diagramm.

Aktualisieren
Laden und Anzeigen des zuletzt aufgezeichneten Datensatzes.

Cursor-Funktion
Bei der Anzeige eines Datensatzes (aus einer Datei oder durch Starten einer Aufzeichnung) werden durch einen Mausklick in das Koordinatensystem die Werte der gemessene Signale für den gewählten Zeitpunkt angezeigt. Ein Klick außerhalb des Koordinatensystems setzt die Anzeige der Werte auf 0 zurück.

Beispiel
bode


ASCII Deutsch BQMODE

ASCII - Kommando | BQMODE |
Syntax Senden | BQMODE [Data] |
Syntax Empfangen | BQMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3666 (hex)
DIM | - | PROFIBUS PNU | 1958 (dec) IND = 1 (dec)
Bereich | 0...4 | DPR | 358 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Filterwahl

Beschreibung

Zustand | Kurzbeschreibung | Beschreibung
BQMODE=0 | Filter ausgeschaltet |
BQMODE=1 | Kompatibilitätsmodus | ARHPF, ARLPD und ARHPD. Nachfolgender Filter ist eingestellt: ARLPF > 0,ARHPF > 0,ARLPD = ARHPD = 0 : PID-T2 Filter ARLPF > 0, ARHPF > 0, ARLPD > 0, ARHPD = 0 : Notch /Bi-Quad ARLPF > 0, ARLPD > 0, ARHPD = ARHPD = 0 : 2.Ordnung Tief Pass Filter ARLPF = ARHPF = ARLPD = ARHPD = 0 : Filter ausgeschaltet
BQMODE=2 | PID-T2 Filter | Der PID-T2 Filter ist nur mit folgenden Einstellungen eingeschaltet: ARLPF > 0, ARHPF > 0. Der PID-T2 Filters kann benutzt werden, um effektiv Drehmoment Schwankungen und Resopnanzen bei Motor Getriebe und angekoppelter Last zu reduzieren. Die Übertragungsfunktion ist TF
BQMODE=3 | Notch - /Bi-Quad Filter | Der Notch / Bi-Quad Filter ist nur aktiv wenn folgende Bedingungen erfüllt sind: ARLPF > 0, ARHPF > 0, ARLPD > 0, ARHPD = 0. Der Notch Filter kann genutzt werden, um Einzelresonanzen zu unterdrücken. Kleine Abweichungen zwischen Filter Frequenz und Resonanz Frequenz beeinflußt die Filterwirkung erheblich. Diese hohe Parameter Sensibilität macht den Einsatz dieses Filters schwierig. Der Bi-Quad Filters kann benutzt werden, um effektiv resonanzenim 2 Massen Schwinger System zu rduzieren Die Übertragungsfunktion ist TF Anmerkung: Wenn ARLPF = ARHPF, ARLPD > 0 und ARHPD = 0, ist wirkt der Filter wie ein Notch Filter, sonst hanelt es sich um einen Be-Quad Filter.
BQMODE=4 | Tiefpass Filter 2.Ordnung | Dieser Filter ist nur bei folgenden Bedingungen aktiv ARLPF > 0, ARLPD > 0. Die Übertragungsfunktion ist TF


ASCII Deutsch BTIME

ASCII - Kommando | BTIME |
Syntax Senden | BTIME [Data] |
Syntax Empfangen | BTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | ms | PROFIBUS PNU | -
Bereich | 63 .. 2046 | DPR | Nein
Default | 512 |
Opmode | all | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Entladezeit des Zwischenkreises bei INxMODE 62

Beschreibung

Entladezeit des Zwischenkreises bei INxMODE 62


ASCII Deutsch BUILDRK

ASCII - Kommando | BUILDRK |
Syntax Senden | BUILDRK [Data] |
Syntax Empfangen | BUILDRK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3850 (hex)
DIM |  | PROFIBUS PNU | 1648 (dec) IND = 33 (dec)
Bereich | 0, 1 | DPR | 848 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | -
Kurzbeschreibung | automatische Ermittlung von RK

Beschreibung

SO = Speicherort
S = Speicher (wo die Standard Reglerparameter abgespeichert werden)
SF = System Flash
OG = Obere Grenze von RK (16384 + 500 = 16884)
UG = Untere Grenze von RK (16384 - 500 = 15884)

BUILDRK = 0
- automatische Ermittlung von RK ist deaktiviert
- es wird der RK-Wert aus S verwende

BUILDRK = 1
- automatische Ermittlung von RK ist aktiviert
- es wird der RK-Wert im SF verwendet (falls gültig)
- wenn RK-Wert im SF nicht gültig, dann wird RK aus S als Startwert verwendet und optimiert
- alle 60 Minuten wird ermittelter RK-Wert im SF gespeichert.
- RK-Wert wird immer nur in kleinen Schritten verändert und dem Optimum angenähert.
- eine automatische Ermittlung von RK wird nur bei Drehhlen 1000 U/min ausgeführt, d.h. ch die Beschleunigungs- und Abbremsphase wird zur Optimierung genutzt.
- Automatische Ermittlung von RK wird gestartet, sobald sich der Motor mindestens 360° gedreht hat.

Wichtig:
Damit eine RK-Ermittlung durchgeführt werden kann, muss sich der Motor mindestens eine Umdrehung drehen können.

Bemerkung:
RK-Wert im SF überschreibt nicht den RK-Wert im S


ASCII Deutsch BUILDRP

ASCII - Kommando | BUILDRP |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3851 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 33 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch BUSP0

ASCII - Kommando | BUSP0 |
Syntax Senden | BUSP0 [Data] |
Syntax Empfangen | BUSP0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 385B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 33 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 859 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

SERCOS:
IDN 97 Maske Zustandsklasse 2 unteren 16 BIT
IDN 98 Maske Zustandsklasse 3 obere 16 BIT

CAN: (ab Firmware 2.51)
Die Bits 0 ..7 dienen dazu bestimmten Warnungen freizuschalten. Defaultzustand ist, dass bei den entsprechenden Warnungen keine Emergency - Message auf dem Bus ausgelöst werden. Bei gesetzter 1 für dieses Bit werden die Emergencys freigeschaltet.

Bedeutung der gesetzten Bits:
Bit 0: Emergency bei Wegschalten des Hardware-Enable im CANopen - Zustand OPERATION ENABLE, Error Code 0x7181
Bit 1: Emergency bei Warnung n06 (Unterschreiten des Software-Endschalters 1), Error Code 0x8683
Bit 2: Emergency bei Warnung n07 (Überschreiten des Software-Endschalters 2), Error Code 0x8684
Bit 3: Emergency bei Warnung n08 (Fehlerhafter Fahrauftrag gestartet), Error Code 0x8681
Bit 4: Emergency bei Warnung n09 (kein Referenzpunkt gesetzt), Error Code 0x8685
Bit 5: Emergency bei Warnung n10 (PSTOP erreicht), Error Code 0x8686
Bit 6: Emergency bei Warnung n11 (NSTOP erreicht), Error Code 0x8687


ASCII Deutsch BUSP1

ASCII - Kommando | BUSP1 |
Syntax Senden | BUSP1 [Data] |
Syntax Empfangen | BUSP1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E5 (hex)
DIM | - | PROFIBUS PNU | 1685 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 485 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfig.variable für Feldbusse (CAN oder Sercos)

Beschreibung

Konfiguration für CANopen/EtherCAT:

Bit 0: Ab der Firmware 2.51 wird das Bit 30 der Einstellung der COB-IDs für die Tx-PDOs kontrolliert. Der Antrieb setzt dieses Bit und erwartet auch, dass der COB - Identifier mit gesetztem Bit 30 geschrieben wird (Bedeutung: keine RTR-Abfrage der Tx-PDOs möglich). Wird Bit 0 auf 1 gesetzt wird das Bit 30 nicht kontrolliert.

Falls ein Antrieb (mit FW < 2.51) ersetzt wurde, wird nach dem Tausch die Warnung n17 (siehe STATCODE *) ausgegeben. Nach Abspeichern des Parameters BUSP1 =1 ist ein synchronisierter Feldbusbetrieb wieder gewährleistet.

Konfiguration für Sercos:

BUSP1 gibt den Zustand des Antriebs an. Das Bit 3 kann vom Antrieb beschrieben und abgespeichert werden. Damit wird gekennzeichnet, ob Modbus+ - Netzwerkfehler zum Antrieb gemeldet werden sollen oder nicht.

default: T3 = 450µs bei 500µs Zykluszeit (s.u.)

T3 = T2 + 50 us fest bei 250us Zykluszeit!
Priorität für T3 bei 500 us:
1. BUSP1 Bits 16 - 27
2. BUSP1 Bits 8 - 12
3. T3 von der Steuerung

Bit HEX Wertigkeit Bedeutung
0 0x00000001 1 Strom-Vorsteuerung 1 Takt länger
1 0x00000002 2 Strom-Vorsteuerung 1 Takt kürzer
2 0x00000004 4 Geschwindigkeits-Vorsteuerung 1 Takt länger
3 0x00000008 8 Geschwindigkeits-Vorsteuerung 1 Takt kürzer
4 0x00000010 16 1 weiterer Takt Verzögerung, wenn nicht quadratisch interpoliert wird
5 0x00000020 32 Lage-Sollwert +Vorsteuerungen 4 Takte Verzögerung
6 0x00000040 64 Lage-Sollwert +Vorsteuerungen 5 Takte Verzögerung
7 0x00000080 128 Lage-Sollwert +Vorsteuerungen 6 Takte Verzögerung
8 0x00000100 256 T3 = T2 (Zeitpunkt MDT) + 50µs nur bei 500µs Zykluszeit
9 0x00000200 512 T3 = 100µs nur bei 500µs Zykluszeit
10 0x00000400 1024 T3 = 200µs nur bei 500µs Zykluszeit
11 0x00000800 2048 T3 = 300µs nur bei 500µs Zykluszeit
12 0x00001000 4096 T3 = 510µs nur bei 500µs Zykluszeit
13 0x00002000 8192 Verzögerung Lage-Istwert um 1 Sercos Takt
14 0x00004000 16384 Verzögerung Lage-Istwert um 2 Sercos Takte
15 0x00008000 32768 Verzögerung Lage-Istwert um 250µs; nur bei 500µs Zykluszeit
16–27 0x0FFF0000 Zeitpunkt T3 aus und nach IDN 3062
28-31 0xF0000000 reserviert


ASCII Deutsch BUSP2

ASCII - Kommando | BUSP2 |
Syntax Senden | BUSP2 [Data] |
Syntax Empfangen | BUSP2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E6 (hex)
DIM | 10 ms | PROFIBUS PNU | 1686 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 486 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter gibt die Time-out Zeit der Modbus Kommunikation in 10ms an. Wenn der Verstärker in dieser Zeit keinen neuen Interrupt von der Karte bekommt, wird der Antrieb disabled und die Kommunikation im Parameter BUSP1 als fehlerhaft angezeigt.

SERCOS:
IDN 15 Telegrammart in Byte 0
IDN 32 Hauptbetriebsart in Byte 2


ASCII Deutsch BUSP3

ASCII - Kommando | BUSP3 |
Syntax Senden | BUSP3 [Data] |
Syntax Empfangen | BUSP3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E7 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 487 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter definiert die Vorgaberichtung bei der Initialisierung für die Modbus Adresse.
BUSP3 = 0 Die Adresse wird von der Modbus-Karte geschrieben.
BUSP3 = 1 Die Adresse des Verstärkers ADDR wird in die Modbus-Karte geschrieben.

SERCOS:
IDN 121 Lastgetriebe Eingangsumdrehung
mit Datenbezug am Motor


ASCII Deutsch BUSP4

ASCII - Kommando | BUSP4 |
Syntax Senden | BUSP4 [Data] |
Syntax Empfangen | BUSP4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E8 (hex)
DIM | - | PROFIBUS PNU | 1688 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 488 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter definiert die Anzahl der Datenworte (Sollwerte), die zyklisch übertragen werden. Daten, die durch diesen Parameter als Prozessdaten freigegegen sind, können nicht über den SDO Parameterkanal (Messaging) beschrieben werden.

SERCOS:
IDN 122 Lastgetriebe Ausgangsumdrehung mit Datenbezug am Motor


ASCII Deutsch BUSP5

ASCII - Kommando | BUSP5 |
Syntax Senden | BUSP5 [Data] |
Syntax Empfangen | BUSP5 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E9 (hex)
DIM | - | PROFIBUS PNU | 1689 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 489 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter gibt die Adresse des Modbus-Masters für diesen Verstärker an. Während der Initialisierung wird dieser Parameter vom Verstärker zur Modbuskarte geschrieben. Auf der Karte werden dann nur Modbusdaten an den verstärker weitergeleitet, die von diesem Master gesendet wurden.

SERCOS:
IDN 123 - Vorschubkonstante


ASCII Deutsch BUSP6

ASCII - Kommando | BUSP6 |
Syntax Senden | BUSP6 [Data] |
Syntax Empfangen | BUSP6 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36EA (hex)
DIM | - | PROFIBUS PNU | 1690 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 490 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Mit diesem Parameter wird die Länge der zyklischen Istwerte in 16Bit Datenworten festgelegt, die in jedem Zyklus vom Verstärker zur Modbuskarte geschrieben werden.
SERCOS:
IDN 79 - Lageauflösung

CAN:
Testparameter zur individuellen Bustiming - Einstellung. Falls ungleich 0, ist die Einstellung für CBAUD ungültig
Wertebereich: -2^31 .. 2^31 - 1


ASCII Deutsch BUSP7

ASCII - Kommando | BUSP7 |
Syntax Senden | BUSP7 [Data] |
Syntax Empfangen | BUSP7 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36EB (hex)
DIM | - | PROFIBUS PNU | 1691 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 491 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

SERCOS:
IDN 117 – Auflösung externer Geber

Bei gesteckten Optionskarten SERCOS,AQUARIUS,MODBUS,FIPIO,FIREWIRE
Default-Wert = 1, sonst Default-Wert=0


ASCII Deutsch BUSP8

ASCII - Kommando | BUSP8 |
Syntax Senden | BUSP8 [Data] |
Syntax Empfangen | BUSP8 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36EC (hex)
DIM | - | PROFIBUS PNU | 1692 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 492 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

BUSP8 = IDN 138


ASCII Deutsch BUSP9

ASCII - Kommando | BUSP9 |
Syntax Senden | BUSP9 [Data] |
Syntax Empfangen | BUSP9 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36ED (hex)
DIM | - | PROFIBUS PNU | 1693 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 493 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Hilfsvariable für EtherCAT Feldbus

Beschreibung

Der Parameter BUSP9 zeigt unter EtherCAT die aktuellen Werte für das Kontrollwort (Bits 0...7) und Statuswort (Bits 8...16) an.

siehe auch BUSP11


ASCII Deutsch BUSP10

ASCII - Kommando | BUSP10 |
Syntax Senden | BUSP10 [Data] |
Syntax Empfangen | BUSP10 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36EE (hex)
DIM | - | PROFIBUS PNU | 1694 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 494 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Hilfsvariable für EtherCAT Feldbus

Beschreibung

Der Parameter BUSP10 zeigt die aktuell gültigen Mapping-Nummern an (Bits 0...7 Sollwert, Bits 8..16 Istwerte).


ASCII Deutsch BUSP11

ASCII - Kommando | BUSP11 |
Syntax Senden | BUSP11 [Data] |
Syntax Empfangen | BUSP11 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36EF (hex)
DIM | - | PROFIBUS PNU | 1695 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 495 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Hilfsvariable für EtherCAT Feldbus

Beschreibung

Der Parameter BUSP11 zeigt die aktuellen Werte für CoE Kontrollwort (Bits 0...7) und Statuswort (Bits 8...16) an.

siehe auch BUSP9


ASCII Deutsch BUSP12

ASCII - Kommando | BUSP12 |
Syntax Senden | BUSP12 [Data] |
Syntax Empfangen | BUSP12 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F0 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 496 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch BUSP13

ASCII - Kommando | BUSP13 |
Syntax Senden | BUSP13 [Data] |
Syntax Empfangen | BUSP13 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F1 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 497 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch BUSP14

ASCII - Kommando | BUSP14 |
Syntax Senden | BUSP14 [Data] |
Syntax Empfangen | BUSP14 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F2 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 498 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch BUSP15

ASCII - Kommando | BUSP15 |
Syntax Senden | BUSP15 [Data] |
Syntax Empfangen | BUSP15 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F3 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 499 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch BUSP16

ASCII - Kommando | BUSP16 |
Syntax Senden | BUSP16 [Data] |
Syntax Empfangen | BUSP16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F4 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 17 (dec)
Bereich | 0 .. 15 | DPR | 500 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Konfigurationsvariable für Feldbusse

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch CALCCOG

ASCII - Kommando | CALCCOG |
Syntax Senden | CALCCOG [Data] |
Syntax Empfangen | CALCCOG <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enable | Wichtung |
ab Firmware | 2.21 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Erzeugung einer Tabelle zur Coggingkompenation

Beschreibung

Syntax:
CALCCOG [Geschwindigkeit] (rotativer Antrieb)
CALCCOG [Geschwindigkeit] [Distanz] [Start Position] (Linearmotors)

Das CALCCOG Kommando generiert eine Tabelle mit Stromvorsteuerwerten zur Kogging Kompensation.
Die Voraussetzungen für diese Funktion sind:
Für die Bewegung muss der Regler in OPMODE = 8 sein.
Der Referenzpunkt ist gesetzt .
Die Endstufe ist aktiv..
Weder Referenzfahrt, Tippbetrieb noch Fahrauftrag ist aktiviert.

Für rotative Antriebe (MTYPE ? 2), wird nur ein optionaler Parameter zugelassen. Er setzt die Motorgeschwindigkeit (nur positive Werte) für die Messwerterfassung fest.Die Grundeinstellung ist 5/min. Die Messung startet an der aktuellen Position and endet nach einer Umdrehung.
Bei Linearmotoren (MTYPE = 2), können drei optionale Parameter gesetzt werden. Der Erste setzt die Geschwindigkeit (nur positive Werte) für die Messwerterfassung fest. Die Grundeinstellung ist 5 Polpaare/min. Der zweite Wert setzt die Messstrecke fest, bei der die Werte erfasst werden. Dieser Bereich wird bei aktiver Coggingkompensation verbessert.

Die Distanz muss im Bereich 1/4, 1/2, 1, 2, 4, .., 2^m Polpaar pitches liegen, mit m als positive Integer-Zahl. Der Ausgangswert ist ein Polpaar.
Der optionale Parameter "Start Position" legt den Anfang für die Messstrecke fest. Wenn dieser Parameter gesetzt ist und von der aktuellen Position abweicht wird ein Fahrauftrag generiert um zur erforderlichen Startposition zu fahren mit Geschwindigkeit VEF.

Note: Parameters can only be omitted in right-to-left order, i.e. valid command lines are:
CALCCOG [Geschwindigkeit] [Distanz] [Start Position]
CALCCOG [Geschwindigkeit] [Distanz]
CALCCOG [Geschwindigkeit]
CALCCOG


ASCII Deutsch CALCHP

ASCII - Kommando | CALCHP |
Syntax Senden | CALCHP [Data] , [Data] |
Syntax Empfangen | CALCHP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 3512 (hex)
DIM | rpm | PROFIBUS PNU | 1618 (dec) IND = 1 (dec)
Bereich | 0 .. 200 | DPR | 18 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Ermittlung der Sinus/Cosinus-Parameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung der Sinus/Cosinus-T-Parameter gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor eine volle Umdrehung mit der vorgegebener Drehzahl. Während dieser Phase werden die Offset-Parameter (HISOFFS/HICOFFS) sowie sinus/cosinus-Verstärkungsfaktor (HIFACT1) berechnet. Nachdem die Funktion ausgeführt wurde, können die neu ermittelten Parameter mit dem Kommandos HSAVE bei EnDAT-, Hiperface oder BiSS-Gebern sowie bei Sin/Cos Gebern im EEPROM mit dem Kommando SAVE abgespeichert werden.

Die Funktion CALCHP ist nur dann verfügbar, wenn als Feedback-Device ein Hiperface- (FBTYPE=2), ein EnDAT- (FBTYPE=4), ein BiSS- (FBTYPE=23, 24) oder ein Sinus/Cosinus-Geber (FBTYPE=1, 3, 5, 6, 7, 8, 26) vorgewählt wurde.

Nach dem Kommando kann die Drehzahl und der Winkel, die bei der Ausführung des Kommandos verwendet werden sollen, angeben werden.

Z.B. CALCHP 5 10, Führe CALCHP mit 5 Upm und einem Bewegungswinkel von 10° aus.


ASCII Deutsch CALCMP

ASCII - Kommando | CALCMP |
Syntax Senden | CALCMP |
Syntax Empfangen | CALCMP <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 388F (hex)
DIM | - | PROFIBUS PNU | 1711 (dec) IND = 33 (dec)
Bereich | 0 .. 10000000 | DPR | 911 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Meßzyklen für Kommutierungsfindung mit PID Regler

Beschreibung

CALCMP definiert die Zyxklenanzahl der Durchläufe bei der Kommutierungserfassung mit PID Positionsregelung.


ASCII Deutsch CALCPOSIO

ASCII - Kommando | CALCPOSIO |
Syntax Senden | CALCPOSIO |
Syntax Empfangen | CALCPOSIO <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 38A6 (hex)
DIM |  | PROFIBUS PNU | 1734 (dec) IND = 33 (dec)
Bereich |  | DPR | 934 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.75 - 5.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Kalibrierung der POS I/O Karte

Beschreibung

Mit diesem Kommando kann die POS I/O-Karte kalibriert werden. Dieses Kommando sollte einmalig ausgeführt werden bei nicht gestecktem X3c-Stecker im Falle des Datenverlustes der POSIO-Karte (Fehler F20 “POSIO data bcc error”).

Nur für S700: ab FW 3.75/5.02


ASCII Deutsch CALCRK

ASCII - Kommando | CALCRK |
Syntax Senden | CALCRK [Data] |
Syntax Empfangen | CALCRK | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 3513 (hex)
DIM | rpm | PROFIBUS PNU | 1619 (dec) IND = 1 (dec)
Bereich | 0 .. 200 | DPR | 19 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ermittlung der Resolverparameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung des Resolver-Parameters RK (sinus/cosinus-Verstärkungsfaktor) gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor ca.2,5 Umdrehung mit der vorgegebenen Drehzahl. Falls CALCRK ohne Parameter gestartet wird, so wird die Defaulteinstallung benutzt. Nachdem die Funktion ausgeführt wurde, kann der neu ermittelte Parameter RK mit dem Kommando SAVE im EEPROM abgespeichert werden. Mit diesem Kommando kann die Stromwelligkeit des Motors bei hohen Drehzahlen reduziert werden. Kann nur bei Resolverrückführung benutzt werden.

Demnach kann RK in folgendem Bereich liegen: 12.000 = RK = 19.000

Ein Wert von 16384 entspricht einer Verstärkung von 1.0

Beispiel:
RK=18000 -> Verstärkung von 1.098
RK=16000 -> Verstärkung von 0.976


ASCII Deutsch CALCRP

ASCII - Kommando | CALCRP |
Syntax Senden | CALCRP |
Syntax Empfangen | CALCRP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 3514 (hex)
DIM | - | PROFIBUS PNU | 1620 (dec) IND = 1 (dec)
Bereich | - | DPR | 20 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ermittlung der Resolverphase

Beschreibung

Dieser Befehl wird benutzt um die Berechnung des Resolver-Parameter RESPHASE (Resolver Phasenverschiebung) zu starten.

Bevor diese Berechnung über das Terminal gestartet wird, muss der Antrieb disabled sowie die Zwischenkreisspannung ausgeschaltet werden. Weiterghin soll MSG = 2 eingestellt werden. Nach dem Start wird der Wert von RESPHASE berechnet. Nach Abschluß wird der ermittelte Wert im Terminal angezeigtsowie die Informationen "ERR 4 Feedback!". Das ist normal und man kann es ignorieren. Um RESPHASE dauerhaft abzuspeicher muss noch SAVE eingegeben und abschließend mit COLDSTART der Antrieb neu gestartet werden.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

CAN- / Feldbus

einheiten

Stationsadresse und Übertragungs-Rate im Feldbus-Netzwerk wird hier eingestellt.

Bildschirmtext | ASCII-Parameter
Adresse | ADDR
Externer Watchdog (Feldbus) | EXTWD
CAN-Bus-Einstellungen |
Baudrate | CBAUD
Heartbeat Guard: Consumer CANopen Objekt 1016h sub1 | CANSDO
Heartbeat Guard: Producer CANopen Objekt 1017h sub0 | CANSDO
Node Guarding: Lifetime factor CANopen Objekt 100Dh sub0 | CANSDO
Node Guarding: Guard Time CANopen Objekt 100Ch sub0 | CANSDO
Feldbus-Mapping-Daten im EEPROM speichern | DRVCNFG

Aktuelles Guarding/Mapping im Regler speichern (CCSAVE)

Die eingestellten Kommunikationsparameter werden im Servoverstärker gespeichert.

Guarding-/Mapping-Defaults zum Regler schreiben (CCSAVE)

Die CANopen Kommunikationsparameter werden auf Defaultwerte zurückgesetzt. Die neuen Werte werden erst beim Neustart (COLDSTART) des Servoverstärkers aktiv.

Heartbeat

Das Heartbeat Protokoll definiert einen Fehlerüberwachungsdienst ohne Remote Frame. Ein Heartbeat Producer überträgt zyklisch eine Heartbeat Nachricht. Einer oder mehrere Heartbeat Consumer empfangen die Meldung. Der Heartbeat Consumer überwacht den Empfang des Heartbeat während der Heartbeat Consumer Time. Wenn der Heartbeat während dieser Zeit nicht empfangen wird, wird ein Heartbeat Event erzeugt. Die Consumer Heartbeat Time definiert die erwartete Heartbeat-Zykluszeit und muss größer sein als die zugehörige "Producer Heartbeat Time", die auf dem Gerät konfiguriert wurde, die sie erzeugt. Ist die Consumer Heartbeat Time gleich 0, wird der Eintrag nicht benutzt.

Nodeguard

Das Node Guarding Protokoll dient der Funktionsüberwachung des Antriebs. Dazu wird der Antrieb in äquidistanten Zeitabständen vom CANopen - Master angesprochen.
Das Produkt der "Guard Time" und "Life Time Factor" ergibt die Ansprechüberwachungszeit. Ist einer dieser beiden Werte 0, ist die Ansprechüberwachung deaktiviert. Das Wird der Antrieb innerhalb der Ansprechüberwachungszeit, nicht angesprochen, tritt die Warnung n04 am Antrieb auf

Gemappte PDOs...

Klicken Sie auf die Schaltfläche "Gemappte PDOs..."

Es gibt zwei unterschiedliche Typen von konfigurierbaren PDOs: Empfangs PDOs (RxPDOs) und Sende PDOs (TxPDOs). Der Inhalt der PDOs ist vordefiniert. Wenn der Dateninhalt für eine spezielle Anwendung nicht brauchbar ist, können die Datenobjekte in den PDOs frei geändert (remapped) werden. Wählen Sie über die Register das gewünschte PDO an.
Weitere Informationen zum PDO Mapping finden Sie im CANopen Handbuch.

Hinzufügen oder Ändern eines Mappings öffnet eine Eingabemaske:

Eine Liste aller verfügbaren Mapping Parameter finden Sie im CANopen Handbuch.

Zusätzlich können Sie wichtige Kommunikationsparameter für den Datenaustausch einstellen:

Bildschirmtext | ASCII-Parameter
COB-ID | CANSDO
Transmission Type | CANSDO
Inhibit Time (nur bei TxPDOs) | CANSDO
Event Timer (nur bei TxPDOs) | CANSDO

Änderungen übernehmen
Die geänderten Mappings werden in den Servoantrieb übertragen. Erst jetzt werden die Einträge überprüft.

Einstellungen neu laden
Die Kommunikationsparameter werden frisch vom Servoverstärker gelesen.


ASCII Deutsch CANDUMP

ASCII - Kommando | CANDUMP |
Syntax Senden | CANDUMP |
Syntax Empfangen | CANDUMP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.15 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Liste der CANopen-Kommunikationsparameter

Beschreibung

Beschreibung

Über das Kommando CANDUMP wird die Liste der CANopen-Kommunikationsparameter angefordert.
Die Liste besteht aus einer Reihe von CANSDO-Kommandos, die zum Parametrieren eines Antriebs verwendet werden kann.


ASCII Deutsch CANSDO

ASCII - Kommando | CANSDO |
Syntax Senden | CANSDO [Data] |
Syntax Empfangen | CANSDO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode |  | Datentyp Bus/DPR | INT32
Verstärker Status |  | Wichtung |
ab Firmware | 2.15 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Zugriff auf ein CAN Service Data Object

Beschreibung

Das ASCII-Kommando CANSDO <Objekt> <Wert> gibt einen Lese- und Schreibzugriff auf CAN-SDOs, wobei Objekt Index, Subindex und Länge des Objektverzeichniseintrags angibt.

Beispiel:

Schreibzugriff:
CANSDO 0x2F001802 1 bedeutet, dass das Objekt 1800 sub 2 mit einem Wert von 1 beschrieben werden soll und eine Länge von 1 Byte=8 Bit hat. Die Länge muß zum Typ des Objektverzeichniseintrags passen (2F = 1 byte, 2B = 2 bytes, 27 = 3 bytes, 23 = 4 bytes).

Leszugriff:
CANSDO 0x40416000 liest das Objekt 6041 subindex 0.

Für weitere Informationen schauen Sie bitte in das CAN-Handbuch


ASCII Deutsch CARDDEL

ASCII - Kommando | CARDDEL |
Syntax Senden | CARDDEL |
Syntax Empfangen | CARDDEL | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 3.60 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | SD-Card | EEPROM | Nein
Kurzbeschreibung | löscht eine Datei aus dem Root Verzeichnis

Beschreibung

CARDDEL „Name“

löscht die Datei „Name“ aus dem Root Verzeichnis der Karte.


ASCII Deutsch CARDDIR

ASCII - Kommando | CARDDIR |
Syntax Senden | CARDDIR |
Syntax Empfangen | CARDDIR | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 3.60 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | SD-Card | EEPROM | Nein
Kurzbeschreibung | gibt das Inhaltsverzeichnis der Root aus

Beschreibung

CARDDIR

Es wird das Root Inhaltsverzeichnis der Karte angezeigt. In eckigen Klammern erscheint jeweils die Anzeige der Dateigröße. Die Unterverzeichnisse werden mit <DIR> gekennzeichnet.


ASCII Deutsch CARDINFO

ASCII - Kommando | CARDINFO |
Syntax Senden | CARDINFO |
Syntax Empfangen | CARDINFO | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 3.60 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | SD-Card | EEPROM | Nein
Kurzbeschreibung | Information über die SD-Speicherkarte

Beschreibung

CARDINFO

Es wird das Typenschild der Speicherkarte angezeigt. Zu den angezeigten Informationen gehört unter anderem der Kartentyp (MMC/SD) und die Speichergröße.


ASCII Deutsch CARDSAVE

ASCII - Kommando | CARDSAVE |
Syntax Senden | CARDSAVE |
Syntax Empfangen | CARDSAVE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 3.60 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | SD-Card | EEPROM | Nein
Kurzbeschreibung | Speichert Daten vom Drive auf der SD Speicherarte

Beschreibung

CARDSAVE <Option> “name"

Speichert eine Firmware/Daten- Komponente des S700 unter dem Namen „name“ auf die Speicherkarte. Da CARDSAVE die Firmware des Verstärkers betrifft, darf das Kommando nur bei gesperrter Endstufe ausgeführt werden. Nach der Ausführung des Kommandos erfolgt ein automatischer Reset des Verstärkers. Das Abspeichern/Laden der Verstärkerparameter (Option PARAM) oder Safety Parameter (Option SAFETY) kann allerdings auch bei freigegebener Endstufe ausgeführt werden. Nahezu alle Dateien die mit dem Kommando CARDSAVE abgespeichert wurden, liegen im Binärformat vor. Die Ausnahme bildet die Parameter Datei, (Kommando CARDSAVE PARAM), die als ASCII Datei abgespeichert wird und direkt von der Inbetriebnahme Software (DRIVEGUI) eingelesen werden kann. Diese Datei kann auch mit einem Editor Programm angesehen und editiert werden.


ASCII Deutsch CARDUPDATE

ASCII - Kommando | CARDUPDATE |
Syntax Senden | CARDUPDATE |
Syntax Empfangen | CARDUPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 3.60 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | SD-Card | EEPROM | Nein
Kurzbeschreibung | lädt daten von der SD Speicherkarte ins Drive

Beschreibung

CARDUPDATE <Option> “name"

Lädt eine Firmware/Daten- Komponente des S700 von der Karte in den Flash Speicher des Verstärkers. Da CARDUPDATE die Firmware des Verstärkers betrifft, darf das Kommando nur bei gesperrter Endstufe ausgeführt werden. Nach der Ausführung des Kommandos erfolgt ein automatischer Reset des Verstärkers. Das Abspeichern/Laden der Verstärkerparameter (Option PARAM) kann allerdings auch bei freigegebener Endstufe ausgeführt werden. Das Kommando „CARDUPDATE <option> <name>“ erwartet unter dem „Namen“ eine Datei die entweder im Binär- oder im S - Record Format vorliegt. Die Binären Dateien sind in der Regel Dateien die zuvor mit dem CARDSAVE Kommando abgespeichert wurden. Die S- Record Dateien sind Dateien die vor allem auf dem elektronischen Wege verbreitet werden. Dazu gehören z.B. Firmware Versionen, die von der Website heruntergeladen wurden.


ASCII Deutsch CBAUD

ASCII - Kommando | CBAUD |
Syntax Senden | CBAUD [Data] |
Syntax Empfangen | CBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3515 (hex)
DIM | kBaud | PROFIBUS PNU | 1621 (dec) IND = 1 (dec)
Bereich | 10,20,50,100,125,250,333,500,666,800,1000 | DPR | 21 (dec)
Default | 500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Übertragungsrate CAN-Bus

Beschreibung

Übertragungsrate CAN-Bus


ASCII Deutsch CCSAVE

ASCII - Kommando | CCSAVE |
Syntax Senden | CCSAVE [Data] |
Syntax Empfangen | CCSAVE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 , 1 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.15 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | CANopen Kommunikationsparameter speichern/reseten

Beschreibung

Beschreibung

CCSAVE dient dazu die CANopen spezifischen Kommuniaktionsparameter im Objektbereich 1000h – 1FFFh abzuspeichern oder zurück auf Defaultwerte zu setzen.

Es sind zwei Werte zulässig:

0 – Die CANopen-Kommunikationsparameter werden auf Defaultwerte zurückgesetzt. Die CAN COB-ID's werden für die eingestellete Adresse ADDR neu berechnet. Die neuen Werte werden erst beim Neustart des Servoantriebs aktiv.
1 – Die aktuell eingestellten CANopen-Kommunikationsparameter im Servoantrieb werden intern gespeichert. Sie werden dann so beim Einschalten wieder aktiv.


ASCII Deutsch CINPOS

ASCII - Kommando | CINPOS |
Syntax Senden | CINPOS [Data] |
Syntax Empfangen | CINPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 386C (hex)
DIM | - | PROFIBUS PNU | 1676 (dec) IND = 33 (dec)
Bereich | 0 .. 3280 | DPR | 876 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.51 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Meldeschwelle vom Strom “In Pos” Fenster

Beschreibung

Mit dem Befehl CINPOS gibt man eine Meldeschwelle des Betrages vom Strom im "In Position" Fenster vor. Abhängig von dieser Schwelle wird das Bit 2 von DRVSTAT gesetzt oder gelöscht.

DRVSTAT=0x100: ICMD - I < CINPOS
DRVSTAT=0x000: ICMD - I > CINPOS

Der Status wird erst geändert wenn die Totzeit INPT0 (in ms) überschritten wurde.


ASCII Deutsch CLRFAULT

ASCII - Kommando | CLRFAULT |
Syntax Senden | CLRFAULT |
Syntax Empfangen | CLRFAULT | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3518 (hex)
DIM | - | PROFIBUS PNU | 1624 (dec) IND = 1 (dec)
Bereich | - | DPR | 24 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Löschen des Verstärker-Fehlers

Beschreibung

Das CLRFAULT Kommando löscht den Fehlerzustand eines Verstärkers. Abhängig von der Art des anstehenden Fehlers wird ein Software- bzw. Hardware-Reset des Verstärkers ausgeführt.
Bei einem Software-Reset ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die vollständige Initialisierungsphase durchlaufen (wie bei Power-On).
Außer den Verstärker-Fehlern (Display-Anzeige Fxx) werden auch folgende Warnungen gelöscht:
- Schleppfehler
- Ansprechüberwachung

Bei der Vorwahl CLRWARN=1 (separates Löschen von Warnungen) bewirkt dieses Kommando das Löschen aller anstehenden Warnungen.
Die Aufstellung aller möglichen Fehlermeldungen mit der Information über erforderlichen Hardware/Software-Reset kann der Beschreibung des Kommandos ERRCODE entnommen werden.

Das Kommando CLRFAULT kann entweder über den ASCII-Kanal (Befehl CLRFAULT) oder über den CAN / PROFIBUS (Bit „Fehler löschen“ im Steuerword) oder aber über einen digitalen Eingang (Funktion „Regler RESET“) ausgeführt werden.

Achtung: Bei den Fehlern F04/F08/F25 geht u.U. die Positionsinformation verloren. Das bedeutet auch, dass der Referenzpunkt gelöscht wird. Das Löschen des Referenzpunktes wird nicht sofort, sondern erst zum Zeitpunkt des „Fehlerresets“ vorgenommen. Das hat den Vorteil, dass bei Multiturn-Gebern das Bit gelöscht und sofort wieder gesetzt werden kann. Bei Singleturn-Gebern bleibt das Bit gelöscht.


ASCII Deutsch CLRHR

ASCII - Kommando | CLRHR |
Syntax Senden | CLRHR |
Syntax Empfangen | CLRHR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3519 (hex)
DIM | - | PROFIBUS PNU | 1625 (dec) IND = 1 (dec)
Bereich | - | DPR | 25 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Löschen des Bit 5 im Statutsregister STAT

Beschreibung

Nach jedem Einschalten bzw. Hardware-Reset des Verstärkers wird das Bit 5 (0x20)
im STAT-Kommando auf 1 gesetzt. Mit dem Kommando CLRHR kann dieses Bit auf 0
gesetzt werden.

Mögliche Anwendung:
Die Parametriersoftware fordert alle Verstärkerparameter an, sobald ein Hardware-Reset (Bit 5 im STAT-Kommando) erkannt wurde. Nachdem alle Parameter eingelesen wurden, wird mit dem CLRHR-Kommando das Hardare-Reset-Bit auf 0 gesetzt. Das Status-Register STAT wird zyklisch abgefragt. Sobald das Hardware-Reset-Bit auf 1 steht, bedeutet es, daß der Verstärker aus- und eingeschaltet wurde und daß alle Parameter neu eingelesen werden müssen.


ASCII Deutsch CLRORDER

ASCII - Kommando | CLRORDER |
Syntax Senden | CLRORDER |
Syntax Empfangen | CLRORDER | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 351A (hex)
DIM | - | PROFIBUS PNU | 1626 (dec) IND = 1 (dec)
Bereich | 0;1 ..180; 192 .. 255 | DPR | 26 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Löschen eines Fahrsatzes

Beschreibung

Mit dem Kommando „CLRORDER xx“ wird der Fahrsatz xx gelöscht.


ASCII Deutsch CLRWARN

ASCII - Kommando | CLRWARN |
Syntax Senden | CLRWARN [Data] |
Syntax Empfangen | CLRWARN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 351B (hex)
DIM | - | PROFIBUS PNU | 1627 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 27 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.18 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Behandlung der Verstärker-Warnungen

Beschreibung

Mit der Konfigurationsvariable CLRWARN kann das Verhalten des Verstärkers beim Auftreten einer Warnung gesteuert werden.

CLRWARN=0 Warnungen werden solange angezeigt, bis die Ursache der Warnung beseitigt wird.
Warnungen können nicht quittiert werden (Ausnahmen: Schleppfehler, Ansprechüberwachung).
CLRWARN=1 Eine Warnung wird nur im Moment des Auftretens angezeigt (Flanke).
Alle Warnungen können mit dem Kommando CLRFAULT bzw. mit dem digitalen Eingang (Funktion „Regler Reset“) gelöscht werden.

Die Aufstellung der möglichen Warnungen kann der Beschreibung des Kommandos STATCODE * entnommen werden.


ASCII Deutsch CMDDLY

ASCII - Kommando | CMDDLY |
Syntax Senden | CMDDLY [Data] |
Syntax Empfangen | CMDDLY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3670 (hex)
DIM | ms | PROFIBUS PNU | 1968 (dec) IND = 1 (dec)
Bereich | 0 ... 160 | DPR | 368 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.1
Funktionsgruppe | RS232 | EEPROM | Ja
Kurzbeschreibung | Kommandoverzögerungszeit der RS232

Beschreibung

Der Parameter CMDDLY definiert eine Verzögerungszeit für die Antworten des Servoverstärkers auf ASCII-Kommandos (RS232-Schnittstelle). Damit wird gewährleistet, daß auch langsamere Steuerungen, den Verstärker über die serielle Schnittstelle bedienen können.
Die Verzögerungszeit CMDDLY definiert die Zeit zwischen dem Empfang des letzten Zeichens eines ASCII-Befehls und dem ersten Zeichen eines Antwort-Strings.
Die Pausen zwischen den einzelnen Zeichen können nicht verändert werden. Sie sind durch die Baud-Rate bzw. durch die internen Verarbeitungszeiten im Verstärker vorgegeben.

Die Verzögerungszeit CMDDLY definiert nur die minimale Pause zwischen dem ASCII-Befehl und der zugehörigen Antwort. Bei Befehlen, die längere Verarbeitungszeit haben, ist diese Pause länger als der eingestellte Wert CMDDLY.


ASCII Deutsch COGFILT

ASCII - Kommando | COGFILT |
Syntax Senden | COGFILT [Data] |
Syntax Empfangen | COGFILT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36D3 (hex)
DIM | - | PROFIBUS PNU | 1667 (dec) IND = 17 (dec)
Bereich | 0...1 | DPR | 467 (dec)
Default | 0.1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 2.21 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Bandbreitenfaktor des Cogginkkompensationsfilters

Beschreibung

Der Parameter COGFILT stellt die Bandbreite eines Filters ein, der im Zusammenhang mit der Cogging-Kompensation auf die drehmomentbildende Komponente des Stromsollwertes angewendet wird. Der Filter wird auf die Feedforward-Werte angewendet, die mit der Funktion CALCCOG ermittelt und in einer Tabelle abgelegt worden sind. COGFILT kann Werte zwischen 0 und 1 annehmen. Der Wert 0 bedeutet, daß alle Frequenzkomponenten herausgefiltert werden; der Wert 1 bedeutet, daß der Filter deaktiviert ist.


ASCII Deutsch COGMODE

ASCII - Kommando | COGMODE |
Syntax Senden | COGMODE [Data] |
Syntax Empfangen | COGMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CF (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 17 (dec)
Bereich | 0 .. 3 | DPR | 463 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.21 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Coggingkompensation de-/aktiv

Beschreibung

Der Parameter COGMODE aktiviert (Wert=1) oder deaktiviert (Wert=0) die Cogging Kompensation, die dazu dient, den durch das Cogging verursachten Drehmoment Rippel auszugleichen.

ab FW 5.38
COGMODE=2 Cogging-Fahrt wird im Drehzahl-Mode ausgeführt
COGMODE=3 Cogging-Fahrt wird im Drehzahl-Mode ausgeführt, es wird eine hochauflösende Coggingtabelle erstellt (höheren Genauigkeit).

Die Kompensation wird durch einen positionsabhängigen Strom-Feedforward erreicht, dessen Wert aus einer Tabelle gelesen und zur drehmomentbildenden Komponente des Stroms addiert wird.
Bevor die Cogging Kompensation gebraucht werden kann, muss die Tabelle der Stromvorsteuerung durch die Funktion CALCCOG erstellt werden.

Da die Werte für die Stromvorsteuerung von der Position PFB abhängig sind, kann die Funktion nur genutzt werden, nachdem ein Referenzpunkt gesetzt worden ist. Damit die Cogging-Kompensation korrekt funktioniert, muß sichergestellt sein, daß der Referenzpunkt immer an derselben Position gesetzt wird oder daß nach jedem neuen Referenzieren die Funktion CALCCOG erneut ausgeführt wird.

Da im Stromreglermodus alle Feedforward-Signale deaktiviert sind, ist die Cogging-Kompensation im OPMODE 2 und 3 nicht verfügbar.

siehe auch:
DRVCNFG3 = 0x80 (Bit 7) Für die Berechnung der Coggingtabelle wird die PRD-Position (Kommutierung) benutzt und nicht PFB (Lageregelung) Diese Einstellung ist sinnvoll für alle Rundachsen.


ASCII Deutsch COGRED

ASCII - Kommando | COGRED |
Syntax Senden | COGRED [Data] |
Syntax Empfangen | COGRED <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0.01 ... 1 | DPR | Nein
Default | 0.1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 2.51 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Faktor der GV Senkung während der Coggingmessung

Beschreibung

Während der Berechnung der Coggingkompensation über CALCCOG wird GV reduziert, um zu verhindern, dass der Strom schwankt. Standardmäßig wird während der Cogging Messung GV auf 10% seines regulären Wertes reduziert. Für kleine GV-Werte kann dies möglicherweise nicht ausreichen, um ddas Cogging korrekt zu messen. Daher kann mit dem Parameter COGRED GV im Bereich von 0,01 bis 1 während der Cogging-Messung eingestellt werden. Wenn der reduzierte GV Wert unter 0,05 liegt, ist er intern auf 0,05 begrenzt.


ASCII Deutsch COLDSTART

ASCII - Kommando | COLDSTART |
Syntax Senden | COLDSTART |
Syntax Empfangen | COLDSTART | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3632 (hex)
DIM | - | PROFIBUS PNU | 1906 (dec) IND = 1 (dec)
Bereich | - | DPR | 306 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Hardware-Reset des Verstärkers

Beschreibung

Hardware-Reset des Verstärkers. Hierzu muss der Verstärker disabled sein. Alle Fehler werden zurückgesetzt. Wenn Konfigurationsparameter geändert wurden, kann der Verstärker nach dem COLDSTART wieder freigegeben werden.


ASCII Deutsch CONTINUE

ASCII - Kommando | CONTINUE |
Syntax Senden | CONTINUE |
Syntax Empfangen | CONTINUE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 351D (hex)
DIM | - | PROFIBUS PNU | 1629 (dec) IND = 1 (dec)
Bereich | - | DPR | 29 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Fortsetzen des letzten Fahrauftrages

Beschreibung

Mit dem Kommando CONTINUE kann ein zuvor mit dem Kommando STOP abgebrochener Fahrsatz fortgesetzt werden (zu Ende gefahren werden). Dies ist besonders wichtig bei einem Fahrsatz mit relativer Verfahrstrecke.


ASCII Deutsch CPHASE

ASCII - Kommando | CPHASE |
Syntax Senden | CPHASE [Data] |
Syntax Empfangen | CPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 358B (hex)
DIM |  | PROFIBUS PNU | 1739 (dec) IND = 1 (dec)
Bereich | 0 .. 0x7FFF | DPR | 139 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.3 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Einstellung der Fehlerüberwachung

Beschreibung

Mit dem Parameter CPHASE kann die Fehlerüberwachung der Motorphase, I/O Optionskarte, Feedback (SinCos & Resolver) sowie vom Ballastfehler eingestellt werden. Siehe auch STATCODE *
Bit | Wertigkeit | Beschreibung
0 | 0x0001 | =0 Kablebrucherkennung für Motorkabel ist aktiv =1 keine Kablebrucherkennung für Motorkabel
1 | 0x0002 | =0 Amplitudenüberwachung des Feedbacks ist aktiv =1 keine Amplitudenüberwachung für Feedback
2 | 0x0004 | =0 I/O Fehler/Warnungen werden ausgegeben =1 keine I/O Fehler/Warnungen werden ausgegeben (ab FW 5.45)
3 | 0x0008 | =0 Ballast-Überwachung ist aktiv =1 keine Ballast-Überwachung (ab FW 5.67)
4 | 0x0010 | =0 alte Resolverüberwachung =1 erweiterte Resolverüberwachung (ab FW 5.78)
5 | 0x0020 | =0 keine Überwachung vom Resolvergradient =1 Überwachung vom Resolvergradient ist aktiv (nur aktiv bei gesetztem Bit der erweiterte Resolverüberwachung) (ab FW 5.78)
6 | 0x0040 | reserviert
7 | 0x0080 | =1 keine Überwachnung des Bus-Off Fehlers (F23) (ab FW 5.78)


ASCII Deutsch CSCNFG

ASCII - Kommando | CSCNFG |
Syntax Senden | CSCNFG [Data] |
Syntax Empfangen | CSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38CA (hex)
DIM |  | PROFIBUS PNU | 1770 (dec) IND = 33 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 970 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | safety | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für die Sicherheitskarte

Beschreibung

Das Kommando CSCNFG liefert die Konfigurationsmöglichkeiten der Sicherheitskarte in Form einer Bit-Variable.

Bit Beschreibung
0 =1 Deaktiviert die Sollwertüberwachung im OPMODE 2+3 (andernfalls ist OPMODE 2+3 mit Sicherheitskarte nicht möglich!)
1 =1 Deaktiviert die Sollwertüberwachung in allen OPMODE
2 reserve
3 reserve
4 =1 Bremsenstatus wird zur Sicherheitskarte geschrieben
5 =1 Bremsenstatus wird zur Sicherheitskarte geschrieben und die Ansteuerung des Servoverstärkers abgeschaltet
6..30 reserve
31 =1 CLRFAULT löst kein Rücksetzen der Sicherheitskarte aus, wenn auf dieser kein Fehler ansteht


ASCII Deutsch CSENID

ASCII - Kommando | CSENID |
Syntax Senden | CSENID [Data] |
Syntax Empfangen | CSENID <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 38CB (hex)
DIM |  | PROFIBUS PNU | 1771 (dec) IND = 33 (dec)
Bereich | 0 / 1 | DPR | 971 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | safety | EEPROM | Ja
Kurzbeschreibung | Blindstromeinprägung

Beschreibung

CSENID ermöglicht die Einprägung eines Blindstromanteils (Id) falls der Wirkstromanteil (Iq) für die Plausibilisierung der Sicherheitskarte nicht ausreicht. Für den zuverlässigen Betrieb der Sicherheitskarte werden Minimalströme vorausgesetzt. Können diese durch Iq nicht erreicht werden muss ein Id eingeprägt werden um dies zu erreichen.

Die maximale Höhe des Blindstromanteils kann per CSIDMAX eingestellt werden. Der Id Anteil wird automatisch verringert wenn Iq ansteigt und ist sobald CSIDMAX überschritten wird Null.

CSENID =1 aktiviert die Blindstromeinprägung (nur wenn eine Sicherheitskarte vorhanden ist).

Achtung: Falls die Safetykarte entfernt wird muss der Wert für CSENID wieder auf 0 gesetzt werden, ansonsten wird ein Slotfehler (F20) generiert.

Bei gesteckter SAFETY-Karte ist der Default-Wert=1, ansonsten =0


ASCII Deutsch CSERR

ASCII - Kommando | CSERR |
Syntax Senden | CSERR [Data] |
Syntax Empfangen | CSERR <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3892 (hex)
DIM |  | PROFIBUS PNU | 1714 (dec) IND = 33 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 914 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | safety | EEPROM | Nein
Kurzbeschreibung | Fehlernummern der Safety Optionskarte

Beschreibung

Der Befehl CSERR gibt als Bit-Variable den Fehler der Safety-Optionskarte zurück.
Bit | Anzeige | Beschreibung
0 | o01 | SS1, Fehler in der Safety Function 'Safe Stop 1'
1 | o02 | SS2, Fehler in der Safety Function 'Safe Stop 2'
2 | o03 | SOS, Fehler in der Safety Function 'Safe Operating Stop'
3 | o04 | SLS, Fehler in der Safety Function 'Safely Limited Speed'
4 | o05 | SSR, Fehler in der Safety Function 'Safe Speed Range'
5 | o06 | SDI, Fehler in der Safety Function 'Safe Direction'
6 | o07 | SBT, Fehler in der Safety Function 'Safe Brake Test'
7 | o08 | reserviert
8 | o09 | reserviert
9 | o10 | reserviert
10 | o11 | reserviert
11 | o12 | Fehler Eingangsbeschaltung digitale Eingänge
12 | o13 | Fehler Beschaltung/Verdrahtung/Rücklesen digitale Ausgänge
13 | o14 | Fehler Test Spannungsüberwachung
14 | o15 | Fehler beim Watchdog-Test (Auslösen, Entladen)
15 | o16 | Fehler beim Speichertest (Flash/RAM)
16 | o17 | Timing Fehler (Überwachung Interrupt)
17 | o18 | Überwachung Position durch Stromsignal
18 | o19 | Überwachung Position durch Gebersignal(intern, extern, Sollwert)
19 | o20 | Fehlerhafter Parameter (Protego)
20 | o21 | Eingangszustände/Konfigurationsdaten passen nicht zueinander
21 | o22 | Fehler Datenabgleich Kanal A-B
22 | o23 | reserviert
23 | o24 | reserviert
24 | o25 | Fehler beim Schreiben/Löschen im Flash-Speicher
25 | o26 | Zeitliche Synchronisation zwischen Kanal A und B
26 | o27 | Watchdog hat ausgelöst
27 | o28 | Überprüfung Daten/Parameter (Datenübertragung, Konfiguration)
28 | o29 | Timeout beim Übertragen von Daten/Parameter
29 | o30 | Fehler CRC-Berechnung
30 | o31 | Fehler Überprüfung Gerätedaten (Seriennummer, Version)
31 | o32 | Fehler System-Software (fatal)


ASCII Deutsch CSIDMAX

ASCII - Kommando | CSIDMAX |
Syntax Senden | CSIDMAX [Data] |
Syntax Empfangen | CSIDMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38CC (hex)
DIM |  | PROFIBUS PNU | 1772 (dec) IND = 33 (dec)
Bereich |  | DPR | 972 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | safety | EEPROM | Ja
Kurzbeschreibung | Maximaler Wert für Blindstromeinprägung

Beschreibung

Ein Wert von 328 entspricht 10% DIPEAK.

Siehe auch CSENID


ASCII Deutsch CSIOSTAT

ASCII - Kommando | CSIOSTAT |
Syntax Senden | CSIOSTAT [Data] |
Syntax Empfangen | CSIOSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3894 (hex)
DIM |  | PROFIBUS PNU | 1713 (dec) IND = 33 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 913 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | safety | EEPROM | Nein
Kurzbeschreibung | Ein- und Ausgangsstatus der Sicherheitskarte

Beschreibung

Das Kommando CSIOSTAT liefert die Ein- und Ausgangszustände der Sicherheitskarte in Form einer Bit-Variable.

Bit Beschreibung
0 Zustand Eingang 'SS1 Activate'
1 Zustand Eingang 'SS2 Activate'
2 Zustand Eingang 'SOS Activate'
3 Zustand Eingang 'SLS Activate'
4 Zustand Eingang 'SSR Activate'
5 Zustand Eingang 'SDI Left Activate'
6 Zustand Eingang 'SDI Right Activate'
7 Zustand Eingang 'SBT Activate'
8 Zustand Ausgang 'Ready'
9 Zustand Ausgang 'STO Acknowledge'
10 Zustand Ausgang 'SOS Acknowledge'
11 Zustand Ausgang 'SDI Acknowledge'
12 Zustand Ausgang 'Safe Range Acknowledge'
13 Zustand Ausgang 'SBT Acknowledge'
14 Zustand zweipoliger Ausgang 'Safe Brake Control' (externe Bremse)
15 Zustand Ausgang 'STO SIL3' (zweiter Abschaltpfad)
16 Zustand Eingang 'SS1 SIL3/Reset'
29 Bremsrampensteuerung SS2 (0=antriebsgeführt, 1=steuerungsgeführt)
30 Bremsrampensteuerung SS1 (0=antriebsgeführt, 1=steuerungsgeführt)
31 NOTSTOP-Bremsrampe bei SS1 (0=nicht aktiviert, 1=aktiviert)


ASCII Deutsch CSSTAT

ASCII - Kommando | CSSTAT |
Syntax Senden | CSSTAT [Data] |
Syntax Empfangen | CSSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3890 (hex)
DIM |  | PROFIBUS PNU | 1712 (dec) IND = 33 (dec)
Bereich | 0 .. 2147483647 | DPR | 912 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | safety | EEPROM | Nein
Kurzbeschreibung | Status der Sicherheitskarte

Beschreibung

Das Kommando CSSTAT liefert die internen Status-Informationen der Sicherheitskarte in Form einer Bit-Variable.

Bit Beschreibung
0 LED POWER, Status LED 'POWER' auf Frontblende der Sicherheitskarte
1 LED RUN, Status LED 'RUN' auf Frontblende der Sicherheitskarte
2 LED CONFIG, Status LED 'CONFIG' auf Frontblende der Sicherheitskarte
3 LED FAULT, Status LED 'FAULT' auf Frontblende der Sicherheitskarte
4 STO, Zustand interner 'STO' (0 = STO inaktiv, 1 = STO aktiv)
5 Download OK, OK-Meldung nach erfolgreichem Download der Konfiguration
8 STARTUP, Bit gesetzt, wenn Sicherheitskarte im Zustand 'STARTUP'
9 RUN, Bit gesetzt, wenn Sicherheitskarte im Zustand 'RUN'
10 STOP, Bit gesetzt, wenn Sicherheitskarte im Zustand 'STOP'
11 CONFIG, Bit gesetzt, wenn Sicherheitskarte im Zustand 'CONFIG'


ASCII Deutsch CTUNE

ASCII - Kommando | CTUNE |
Syntax Senden | CTUNE |
Syntax Empfangen | CTUNE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | Hz | PROFIBUS PNU | -
Bereich | 500 ... 2500 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Optimierung der Stromreglerparameter

Beschreibung

Autotune-Funktion für den Stromregler. Hierzu muss der OPMODE = 2 gesetzt sein.

Als zusätzlichen Parameter kann die Bandbreite angegeben werden, bei der die Optimierung durchgeführt wird.
Die Defaultwerte sind:
- bei FILTMODE = 2 1800 Hz ansonsten 1200 Hz


ASCII Deutsch CUPDATE

ASCII - Kommando | CUPDATE |
Syntax Senden | CUPDATE |
Syntax Empfangen | CUPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 351F (hex)
DIM | - | PROFIBUS PNU | 1631 (dec) IND = 1 (dec)
Bereich | - | DPR | 31 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Programm-Update über CAN-Bus

Beschreibung

Das CUPDATE-Kommando aktiviert eine Funktion, die über CAN-Bus-Schnittstelle Daten empfangen und in den Programmspeicher des Verstärkers eintragen kann. Nachdem diese Funktion aktiviert wurde,werden keine Kommandos mehr über die serielle Schnittstelle angenommen.
Für den Download der Daten auf der PC-Seite sollte das Programm PRGDOWN.EXE eingesetzt werden. Dieses Programm arbeitet im Handshake-Verfahren mit der Firmware zusammen und bereitet die Daten für die CAN-Übertragung vor.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Stromregler

einheiten

Parameter für die Optimierung des Stromreglers. Änderungen meist nicht erforderlich, wenn die korrekten motorbezogenen Daten aus der Datenbank geladen wurden.

Bildschirmtext | ASCII-Parameter
Ipeak (pos.) | IPEAKP
Ipeak (neg.) | IPEAKN
Ref.-Ipeak | REFIP
I²t-Warnung | I2TLIM
Verstärkung (Kp_i) | MLGQ
Nachstellzeit (Tn_i) | KTN


ASCII Deutsch DAOFFSET1

ASCII - Kommando | DAOFFSET1 |
Syntax Senden | DAOFFSET1 [Data] |
Syntax Empfangen | DAOFFSET1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 387C (hex)
DIM | mV | PROFIBUS PNU | 1692 (dec) IND = 33 (dec)
Bereich | -500 .. 500 | DPR | 892 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Offsetwert für den Analogausgang 1

Beschreibung

Mit dem Parameter DAOFFSET1 wird der Offset für den D/A-Ausgang 1 auf der POSIO-Karte definiert.
Dieser Parameter wird bei der Eingabe im EEPROM der POSIO-Karte gespeichert.

DAOFFSET2 = 2058 -10V
DAOFFSET2 = 1250 0V
DAOFFSET2 = 442 10V

FW > 5.00


ASCII Deutsch DAOFFSET2

ASCII - Kommando | DAOFFSET2 |
Syntax Senden | DAOFFSET2 [Data] |
Syntax Empfangen | DAOFFSET2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 387D (hex)
DIM | mV | PROFIBUS PNU | 1693 (dec) IND = 33 (dec)
Bereich | -500 .. 500 | DPR | 893 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Offsetwert für den Analogausgang 2

Beschreibung

Mit dem Parameter DAOFFSET2 wird der Offset für den D/A-Ausgang 2 auf der POSIO-Karte definiert.
Dieser Parameter wird bei der Eingabe im EEPROM der POSIO-Karte gespeichert.

DAOFFSET2 = 2058 -10V
DAOFFSET2 = 1250 0V
DAOFFSET2 = 442 10V

FW > 5.00


ASCII Deutsch DEC

ASCII - Kommando | DEC |
Syntax Senden | DEC [Data] |
Syntax Empfangen | DEC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3522 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1634 (dec) IND = 1 (dec)
Bereich | depending on ACCUNIT | DPR | 34 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für den Drehzahlsollwert

Beschreibung

Das Kommando DEC definiert die Bremsrampe des Drehzahlreglers. Die Bremsrampe DEC wird nur bei Sollwertsprüngen benutzt, die eine Verringerung der Drehzahl nach sich ziehen (Bremsvorgang). Für den Beschleunigungsvorgang gilt der Parameter ACC.
Die Bremsrampe DEC gilt für jede Sollwertänderung, die digital oder analog vorgegeben wird. Für die Sollwertänderungen, die intern aufgrund von Nothaltsituationen generiert werden (z.B Verstärkerfehler bzw. Wegnahme der Endstufenfreigabe), gelten separate Bremsrampen (DECSTOP/DECDIS).

Die Rampe kann mit verschiedenen Einheiten belegt werden. Details hierzu sind beim Parameter ACCUNIT aufgeführt.

Siehe auch ACCUNIT


ASCII Deutsch DEC_X

ASCII - Kommando | DEC_X |
Syntax Senden | DEC_X [Data] |
Syntax Empfangen | DEC_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3878 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1688 (dec) IND = 33 (dec)
Bereich | depending on ACCUNIT | DPR | 888 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 3.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Bremsrampe Drehzahlr. 2. Parametersatz

Beschreibung

siehe PARCNFG


ASCII Deutsch DECDIS

ASCII - Kommando | DECDIS |
Syntax Senden | DECDIS [Data] |
Syntax Empfangen | DECDIS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3523 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1635 (dec) IND = 1 (dec)
Bereich | depending on ACCUNIT | DPR | 35 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahl-Bremsrampe beim Sperren der Endstufe

Beschreibung

Beim Sperren der Endstufe (Wegnahme des Hardware- oder Software-Enable) wird der interne Drehzahlsollwert mit der eingestellten DECDIS-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Die Rampe DECDIS wirkt sich nur bei Motoren mit konfigurierter Bremse (MBRAKE=1) bzw. bei der Vorwahl STOPMODE=1 aus.
Bei STOPMODE=0 wird die Endstufe sofort gesperrt und der Antieb trudelt aus.

Siehe auch ACCUNIT


ASCII Deutsch DECR

ASCII - Kommando | DECR |
Syntax Senden | DECR [Data] |
Syntax Empfangen | DECR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3524 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1636 (dec) IND = 1 (dec)
Bereich | depending on ACCUNIT | DPR | 36 (dec)
Default |  |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando DECR definiert die Bremsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. Die Vorgabe erfolgt in ACCUNIT. Bei ACCUNIT=0 (Beschleunigung in ms) bezieht sich der Wert von DECR auf PVMAX.
Die Bremsramperampe DECR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).
Die Rampe kann mit verschiedenen Einheiten belegt werden. Details hierzu sind beim Parameter ACCUNIT aufgeführt.


ASCII Deutsch DECSTOP

ASCII - Kommando | DECSTOP |
Syntax Senden | DECSTOP [Data] |
Syntax Empfangen | DECSTOP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3525 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1637 (dec) IND = 1 (dec)
Bereich | depending on ACCUNIT | DPR | 37 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Bremsrampe in Nothaltsituation

Beschreibung

Bei Nothaltsituationen wird der interne Drehzahlsollwert mit der eingestellten DECSTOP-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Eine Nothaltsituation liegt in folgenden Fällen vor:
- Verstärkerfehler (bei ACTFAULT=1)
- Schleppfehler
- Ansprechüberwachung (Feldbusgeräte)
- Hardware/Software-Endschalter
- Schnell Halt-Funktion über digitalen Eingang (INxMODE=27)
- Schnell Halt-Funktion über Feldbus (Steuerwort)

Siehe auch ACCUNIT


DriveGui Online Help

general

0gefahr

helpscreen

Frame 6573 (8)

Frame 6574 (5)

warning_r_electricity

Frame73 (9)

warning_r_hot

Frame73 (11)

warning_r_autostart

0danger - color

0warnung

installation

warning_r_general

qssystem

warning_r_general1

s700system

warning_r_general2

S748system

Frame 6574 (9)

start

icon_drivegui

screen001

SI029f

comnet

screen0051

screen003

screen004

screen006

winmenu

Frame11

Frame17

Frame12

Frame18

Frame13

Frame19

Frame14

Frame20

Frame15

Frame21

Frame16

Frame22

hilfeicon

Frame23

help

opmode

navigation

main

help (2)

hilfeicon1

wizard

setupwizard

basic

basis

parameter

basis

units

einheiten

Frame61 (2)

calc_leadscrew1

calc_leadscrew2

calc_leadscrew

calc_leadscrew4

calc_leadscrew5

calc_leadscrew3

calc_leadscrew7

calc_leadscrew8

calc_leadscrew6

calc_leadscrew9

can

einheiten

can_pdo

can_param

asynchron

uf

mot_fdbk

einheiten

Frame61 (3)

kamera

einheiten6

enclines

feedback

warning_r_general

einheiten

0warnung

einheiten7

fb_ws

einheiten

warning_r_general

0danger - color

fb_test

warning_r_general

0gefahr

einheiten

endat22_d

HDSL_d

motor

einheiten

einheiten5

einheiten51

einheiten4

mot_feld

einheiten

motor_cog

einheiten

Frame61 (2)

current

einheiten

velocity

einheiten

position

einheiten

position_erw

einheiten

posdata

einheiten

A0243-26

posreg

einheiten

gearing

einheiten

encoder

einheiten

einheiten1

ana_io

einheiten

digi_io

einheiten

incmd21

incmd2

incmd

incmd1

incmd11

incmd111

mservice

Frame 6573 (8)

einheiten

plus

minus

Frame1 (4)

Frame1 (5)

status

status

basis-fehler-f242

basis-fehler-f241

monitor

monitor

homing

einrichten

Frame 6574 (2)

Frame 6574 (3)

Frame 6574 (4)

Frame 6574 (6)

Frame2

Frame33 (2)

A0243-28

Frame33 (3)

A0243-281

Frame33 (6)

Frame2 (2)

A0243-2811

A0243-28111

Frame33 (10)

Frame 6574 (7)

Frame33 (8)

Frame33 (12)

Frame2 (3)

A0243-2811111

Frame33 (14)

Frame2 (4)

A0243-281111

Frame33 (16)

A0243-28111111

mtasktab

fahrsatz1

Frame 6574 (4)

einheiten2

profil0

profil1

profil2

profil3

scope

oszilloskop

oszilloskop_kanal

makro1

einheiten3

einheiten31

Frame 6573 (8)

einheiten32

Frame 6573 (9)

service2

einheiten33

einheiten331

einheiten3312

einheiten3311

farben

oszilloskop_record

bode

Frame2 (5)

bode1

bodeparameter

bodefilter

bode

terminal

terminal

io_opt

ioerweiterung

ioconfig

sercos

Sercos

profi

Profibus1

Frame3

Frame2

ethercat

Profibus1

Autotuning

Frame2 (5)

0danger - color

Profibus1

safetycard

Profibus1

sd_card

Profibus1

Frame2 (5)

sd-card_load

sd-card_load1

Antriebsberechnung

anydim

ServoPumpe_d

Motorsetup

Frame2 (5)

0danger - color

SW-Upgrade

screen300

upgrade2

appendix

Frame86 (5)


DriveGui Online Help

Inhaltsverzeichnis

  • Onlinehilfe zur Inbetriebnahme-Software DriveGUI.exe
  • Inhalt
  • Allgemeines
    • Einführung
    • Bedienung der Online-Hilfe
      • Navigation
      • Volltextsuche
    • Verwendete Symbole
    • Zu Ihrer Sicherheit
      • Das sollten Sie beachten
      • Bestimmungsgemäße Verwendung
      • Nicht bestimmungsgemäße Verwendung
    • ASCII Objekt-Referenz
    • Übersicht Servoantriebe
      • Rückführeinheiten
      • Das Bewegungsprofil
      • Arbeitsbereiche und -begrenzungen
      • Beschleunigen und Bremsen
  • Installation
    • Hardware-Installation
      • Minimalverdrahtung S300
      • Minimalverdrahtung S701-724 (STO zweikanalig)
      • Minimalverdrahtung S748/772
    • Setup Software - Installation
    • Firmware Upgrade
    • Verstärker einschalten
  • Bedienung
    • Start der Software
    • Online/Offline arbeiten
      • Online arbeiten
      • Offline arbeiten
    • Bildschirmaufbau
      • Titelleiste
      • Menüleiste
      • Symbolleiste
      • Statusleiste
      • Navigationsfenster
      • Hauptfenster
    • Hilfe Funktionen
  • Bildschirmseiten
    • Setup Wizard
    • Basiseinstellungen
    • Parameterumschaltung
    • Einheiten
      • Berechnung der Auflösung
    • CAN- / Feldbus
      • Gemappte PDOs...
    • U/f Steuerung
    • Motor / Feedback
      • Rotatorische Motoren
      • Linearmotoren
    • Feedback
      • Offset Berechnen
      • Beispiel Resolver
      • Beispiel SinCos mit Hall
    • Wake & Shake
    • Feedback Test und Diagnose
      • Test Feedback/Motor
      • Endat 2.2 Diagnose
      • HIPERFACE DSL Diagnose
    • Motor
      • Motor aus Datenbank auswählen
      • Parameter für benutzerdef. Motor
      • KTY Support
    • Feldschwächung
    • Cogging / Rastmoment Kompensation
    • Stromregler
    • Drehzahlregler
    • Lageregler
    • Lageregler Erweiterung
    • Positionierdaten
    • Positionsregister
    • Elektronisches Getriebe
    • Encoder-Emulation
      • Inkrementralgeber
      • Absolutwertgeber
    • I/O analog
    • I/O digital
      • OPMODE Einstellungen (INxMODE 24)
      • Geschwindigkeit-Zeit Einstellungen (INxMODE 39)
      • Kommando-Buffer Einstellungen (INxMODE 30)
      • TRJSTAT Maskeneinstellungen (OxMODE 38/39/50/51)
      • DRVSTAT Maskeneinstellungen (OxMODE 36/37/48/49)
      • POSRSTAT Maskeneinstellungen (OxMODE 40/41)
    • Service-Funktionen
    • Status (Fehler/Warnungen)
    • Monitor
    • Einrichtbetrieb
      • Referenzfahrt 0
      • Referenzfahrt 1
      • Referenzfahrt 2
      • Referenzfahrt 3
      • Referenzfahrt 4
      • Referenzfahrt 5
      • Referenzfahrt 6
      • Referenzfahrt 7
      • Referenzfahrt 8
      • Referenzfahrt 9
    • Fahraufträge
      • Übersicht
      • Bearbeiten
      • Folgefahrauftrag
    • Oszilloskop
      • Hinweise zur Bedienung
      • Kanäle
      • Trigger
      • Aufzeichnung / Oszillogramme
      • Service-Funktionen
      • Regler-Einstellung
      • Oszilloskop-Einstellung
      • Extended Channels
      • WS Tuning
      • Aufzeichnung
    • Bode-Plot
    • Terminal
    • I/O-Erweiterungskarte
    • SERCOS Erweiterungskarte
    • PROFIBUS Erweiterungskarte
      • Wichtige Konfigurationsparameter
      • Zustandsmaschine
    • EtherCAT Erweiterungskarte
    • Autotuning
      • Strom und Beobachter Tuner
      • Testbetrieb
      • Drehzahl-Tuner
    • Safetykarte
    • SD Karte
      • Datei Löschen
      • Laden
      • Speichern
      • Verwendete ASCII Befehle
  • Applikationshinweise
    • Antriebsberechnung
    • Servo Pumpe
    • Makroprogrammierung
    • Inbetriebnahme unbekannter Motoren
    • Asynchronmaschine - U/f Steuerung
    • Gleichstrommotor
    • Firmware Upgrade
  • Anhang
    • Glossar
    • Weiterführende Dokumentation
    • Fehlermeldungen
    • Warnungen
    • Trouble Shooting
      • Hilfe bei Fehlern
      • Hilfe bei Warnungen
      • Tipps bei sonstigen Problemen


ASCII Deutsch DENA

ASCII - Kommando | DENA |
Syntax Senden | DENA [Data] |
Syntax Empfangen | DENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362D (hex)
DIM | - | PROFIBUS PNU | 1901 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 301 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | DPR Software Disable Reset Modus

Beschreibung

Bei externen DPR-SLOT-Karten gibt es die Möglichkeit durch Wegnahme des DPR-Software-Enable ggf. anstehende Geräte-Fehler zu löschen. Diese Funktion kann mit Hilfe der Variable DENA aktiviert oder gesperrt werden.

DENA=0 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen (kundenspezifisches Protokoll: Beckhoff).

DENA=1 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen.

DENA=2 Kein Reset bei Wegnahme von Software-Enable.


ASCII Deutsch DI2T

ASCII - Kommando | DI2T |
Syntax Senden | DI2T [Data] |
Syntax Empfangen | DI2T <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer 8 | CANBus Objektnummer | 3559 (hex)
DIM | % | PROFIBUS PNU | 1689 (dec) IND = 1 (dec)
Bereich | 0 ... 100 | DPR | 89 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer 8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Regler I2T Auslastung

Beschreibung

Gibt die durchschnittliche I2T Belastung des Reglers in % von DICONT wieder. Dieser Durchschnittswert ist gefiltert mit einer Zeitkonstanten von 16 Sekunden.


ASCII Deutsch DICONT

ASCII - Kommando | DICONT |
Syntax Senden | DICONT |
Syntax Empfangen | DICONT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3527 (hex)
DIM | A | PROFIBUS PNU | 1639 (dec) IND = 1 (dec)
Bereich | 1.5 .. 20.0 | DPR | 39 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Geräte-Nennstrom

Beschreibung

DICONT gibt den Geräte-Nennstrom zurück.


ASCII Deutsch DIFVAR

ASCII - Kommando | DIFVAR |
Syntax Senden | DIFVAR |
Syntax Empfangen | DIFVAR <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Parameterunterschiede zu den Default-Einstellungen

Beschreibung

Das Kommando liefert eine Liste mit Parametern, deren Einstellungen nicht den Defaultwerten entsprechen. Die Liste enthält Einträge in folgender Form:

PARAMETER Wert (Default) PARAMETER = Parametername
Wert = aktuelle Parametereinstellung
Default = Defaultwert des Parameters


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

I/O digital

einheiten

Weisen Sie den digitalen Eingängen und Ausgängen des Servoverstärkers vordefinierte Funktionen zu.
Je nach Funktion können Sie einen Wert eingeben oder gelangen über die zugehörige Schaltfläche in ein erweitertes Eingabefenster.
Die Eingänge 21/22 sind nur bei S700 verfügbar. Bei diesem Servoverstärker sind zwei bidirektionale Schnittstellen vorhanden, die je nach Funktionswahl als Ein- oder Ausgang verwendet werden. Die Einstellung Eingang 21 ist automatisch gegen Ausgang 1 verriegelt, Eingang 22 gegen Ausgang 2.

Bildschirmtext | ASCII-Parameter
Eingang | IN1MODE (Beispiel für Eingang 1)
Wert | IN1TRIG (Beispiel für Eingang 1)
Ausgang | O1MODE (Beispiel für Ausgang 1)
Wert | O1TRIG (Beispiel für Ausgang 1)
Invert | DIRIN Invertiert die gewählte Funktion DIROUT Invertiert die gewählte Funktion

OPMODE Einstellungen (INxMODE 24)

incmd21

Der Operationsmodus des Servoverstärkers wird über einen digitalen Eingang umgeschaltet. Es wird der Zustand des Signals (high oder low) ausgewertet. Wählen Sie die gewünschten OPMODE Einstellungen.

Geschwindigkeit-Zeit Einstellungen (INxMODE 39)

incmd2

Bildschirmtext | ASCII-Parameter
Konstante Drehzahl | IN1TRIG (Beispiel für Eingang 1), Bit 0...15
Dauer | IN1TRIG (Beispiel für Eingang 1), Bit 16...31

Kommando-Buffer Einstellungen (INxMODE 30)

incmd

Eingabe der ASCII Kommandos, die ausgeführt werden sollen. Abhängig von der Flanke des Eingangssignals können Sie unterschiedliche Kommandofolgen definieren.
Beispiele für den Gebrauch von INxMODE30 finden Sie im KDN.

Bildschirmtext | ASCII-Parameter
Kommandofolge, positive Flanke | IN1HCMD (Beispiel für Eingang 1)
Kommandofolge, negative Flanke | IN1LCMD (Beispiel für Eingang 1)

TRJSTAT Maskeneinstellungen (OxMODE 38/39/50/51)

incmd1

Die Variable TRJSTAT liefert die internen Status-Informationen in Form einer Bit-Variable. Die Statusinformationen 3...15 und 27...31 werden für interne Funktionen benutzt. Die Bits 0...2 und 16...26 können für externe Funktionen (Steuerung) benutzt werden. Wählen Sie in der Bitmaske die Informationen an, die überwacht werden sollen. Die Bitmaske wird mit dem Variableninhalt entsprechend Ihrer Logikvorwahl (AND, OR, NAND, NOR) verglichen. Der digitale Ausgang wird gesetzt, wenn das Ergebnis logisch 1 ist.

DRVSTAT Maskeneinstellungen (OxMODE 36/37/48/49)

incmd11

Die Variable DRVSTAT liefert die internen Status-Informationen in Form einer Bit-Variable. Wählen Sie in der Bitmaske die Informationen an, die überwacht werden sollen. Die Bitmaske wird mit dem Variableninhalt entsprechend Ihrer Logikvorwahl (AND, OR, NAND, NOR) verglichen. Der digitale Ausgang wird gesetzt, wenn das Ergebnis logisch 1 ist.

POSRSTAT Maskeneinstellungen (OxMODE 40/41)

incmd111

Die Variable POSRSTAT liefert den aktuellen Status der schnellen Positionsregister. Wählen Sie in der Bitmaske die Register an, die überwacht werden sollen. Die Bitmaske wird mit dem Variableninhalt entsprechend Ihrer Logikvorwahl (AND, OR) verglichen. Der digitale Ausgang wird gesetzt, wenn das Ergebnis logisch 1 ist.
Ein Beispiel für den Gebrauch der Positionsregister finden Sie im KDN (Nockenfunktion).
Die Funktion der Positionsregister wird auf der Bildschirmseite POSITIONSREGISTER eingestellt.


ASCII Deutsch DILIM

ASCII - Kommando | DILIM |
Syntax Senden | DILIM [Data] |
Syntax Empfangen | DILIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362C (hex)
DIM | - | PROFIBUS PNU | 1900 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 300 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | DPR Strombegrenzung aktivieren

Beschreibung

Bei externen DPR-SLOT-Karten gibt es eine Möglichkeit den Gerätestrom über das DPR (RAM-Schnittstelle zu der SLOT-Karte) zu begrenzen. Diese Funktionalität muß mit der Konfigurationsvariable DILIM freigegeben werden.


ASCII Deutsch DIPEAK

ASCII - Kommando | DIPEAK |
Syntax Senden | DIPEAK |
Syntax Empfangen | DIPEAK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3529 (hex)
DIM | A | PROFIBUS PNU | 1641 (dec) IND = 1 (dec)
Bereich | 3.0 .. 70.0 | DPR | 41 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Geräte-Spitzenstrom

Beschreibung

DIPEAK gibt den Geräte-Siptzenstrom zurück.


ASCII Deutsch DIR

ASCII - Kommando | DIR |
Syntax Senden | DIR [Data] |
Syntax Empfangen | DIR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 352A (hex)
DIM | - | PROFIBUS PNU | 1642 (dec) IND = 1 (dec)
Bereich | 0 ... 2047 | DPR | 42 (dec)
Default | 21 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 0.87 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Zählrichtungen verschiedener Istwerte

Beschreibung

DIR ist eine 16-Bit Variable, bei der die einzelnen Bits die Zählrichtung unterschiedlicher Rückführeinheiten festlegen.
Bit=1 positive Richtung, Bit=0 negative Richtung

Bit 0 (0x01) Zählrichtung für FBTYPE (=1 positiv)
Bit 1 (0x02)
Bit 2 (0x04) Zählrichtung für EXTPOS (=1 positiv)
Bit 3 (0x08)
Bit 4 (0x10) Zählrichtung für GEARMODE (=1 positiv)
Bit 5 (0x20)
Bit 6 (0x40) =1 invertierte Kommutierung
Bit 7 (0x80) =1 Inverse Enkoder Absolutposition (ENDAT,HYPERFACE, BISS)
Bit 8 (0x100) =1 inverse Zählrichtung für analoges Hall über ANIN1/ANIN2
Bit 9 (0x200) =1 inverse Zählrichtung für analoges Hall über X1 (sinus+/sinus-)


ASCII Deutsch DIRIN

ASCII - Kommando | DIRIN |
Syntax Senden | DIRIN [Data] |
Syntax Empfangen | DIRIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 389D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 33 (dec)
Bereich | 0...2147483647 | DPR | 925 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.66 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Polarität für digitale Eingänge

Beschreibung

Mit dem Parameter DIRIN kann die Polarität der digitalen Eingänge definiert werden.
DIRIN ist eine Bitvariable wo jedem digitalen Eingang x (INPUTx) das Bit Nr x zugeordnet ist.
Das Setzen eines Bits zu 1 invertiert den entsprechenden digitalen Eingang.

Diese Funktion kann nur in Verbindung mit den Eingängen IN1,IN2,IN3,IN4 (IN21,IN22 für S700) genutzt werden.


ASCII Deutsch DIROUT

ASCII - Kommando | DIROUT |
Syntax Senden | DIROUT [Data] |
Syntax Empfangen | DIROUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 385F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 33 (dec)
Bereich |  | DPR | 863 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.05 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Polarität für digitale Ausgänge

Beschreibung

DIROUT ist eine Bitvariable. Je ein einzelnes Bit bezieht sich auf einen digitalen Ausgang. Eine 1 invertiert die Polarität am Ausgang.

Ausgänge Basisplatine: 2 (O1 - O2)
Ausgänge Erweiterungskarte 8 (O3 – O10)
virtuelle Ausgänge: 8 (O11 - O18)


ASCII Deutsch DIS

ASCII - Kommando | DIS |
Syntax Senden | DIS |
Syntax Empfangen | DIS | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 352B (hex)
DIM | - | PROFIBUS PNU | 1643 (dec) IND = 1 (dec)
Bereich | - | DPR | 43 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Software Disable der Endstufe

Beschreibung

Mit dem Kommando DIS wird die Software-Freigabe für die Endstufe auf 0 gesetzt. Je nach Konfiguration (s. MBRAKE,STOPMODE) trudelt der Antrieb aus bzw. wird kontrolliert heruntergefahren.


ASCII Deutsch DISDPR

ASCII - Kommando | DISDPR |
Syntax Senden | DISDPR [Data] |
Syntax Empfangen | DISDPR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3673 (hex)
DIM | - | PROFIBUS PNU | 1971 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 371 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | -
Kurzbeschreibung | Disablen des DPR-Zugriffs für Schreibbefehle

Beschreibung

Mit dem Parameter DISDPR=1 kann die Übernahme der Sollwerte von einer externen Slot-DPR-Karte (z.B. Lightbus) gesperrt werden. In diesem Fall werden nur noch Lesezugriffe (Auslesen der Istwerte) akzeptiert. Die Schreibzugriffe wie z.B. Übergabe der Sollwerte, Freigeben/Sperren der Endstufe, Umschalten der Betriebsart usw. werden vollständig ignoriert. Bei dieser Einstellung ist es möglich bei laufender externer Kommunikation die internen Service-Funktionen des Verstärkers (konstante Drehzahl, konstanter Strom ...) zu nutzen.

DISDPR=0 Übernahme der Sollwerte freigeschaltet
DISDPR=1 keine Übernahme der Sollwerte von der externen Slot-Karte

Die Einstellung für DISDPR wird nicht im EEPROM abgespeichert und gilt nur bis zum nächsten Ausschalten des Verstärkers.


ASCII Deutsch DNBAUD

ASCII - Kommando | DNBAUD |
Syntax Senden | DNBAUD [Data] |
Syntax Empfangen | DNBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 369F (hex)
DIM | kBaud | PROFIBUS PNU | 2015 (dec) IND = 1 (dec)
Bereich | 125,250,500 | DPR | Nein
Default | 125 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | DeviceNet Baudrate

Beschreibung

Der Baudraten Schalter auf der DeviceNet-Optionskarte kann auf 0 (125 KBaud), 1 (250 kBaud) oder
2 (500 kBaud) eingestellt werden. Wenn der Schalter auf einen Wert größer als 2 gesetzt ist, ist die Baudrate konfigurierbar durch den Parameter DNBAUD und über DeviceNet. Im Bereich von 0 bis 2 kann nicht mit dem Parameter DNBAUD oder DeviceNet die Baudrate gesteuert werden.


ASCII Deutsch DNDUMP

ASCII - Kommando | DNDUMP |
Syntax Senden | DNDUMP [Data] |
Syntax Empfangen | DNDUMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | fieldbus | EEPROM | -
Kurzbeschreibung | Debugging Information DeviceNet

Beschreibung

Der Parameter DNDUMP gibt Debuginformationen vom Status des DeviceNet-Anschlusses aus.


ASCII Deutsch DNMACID

ASCII - Kommando | DNMACID |
Syntax Senden | DNMACID [Data] |
Syntax Empfangen | DNMACID <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36A0 (hex)
DIM | - | PROFIBUS PNU | 2016 (dec) IND = 1 (dec)
Bereich | 0...63 | DPR | Nein
Default | 63 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | MACID (Addresse) für DeviceNet Karte

Beschreibung

Die MACID (Address-) Schalter auf der DeviceNet Optionskarte können für Adressen zwischen 0 und 63 eingestellt werden.Falls Werte größer als 63 eingestellt wurden, können MACID mit dem Terminal Parameter DNMACID und durch das DEVICE-Netz eingestellt werden.


ASCII Deutsch DOVRIDE

ASCII - Kommando | DOVRIDE |
Syntax Senden | DOVRIDE [Data] |
Syntax Empfangen | DOVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36B6 (hex)
DIM | - | PROFIBUS PNU | 2038 (dec) IND = 1 (dec)
Bereich | 0 .. 8192 | DPR | 438 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Vorgabe eines digitalen Override-Faktors

Beschreibung

Beim Aktivieren einer digitalen OVERRIDE-Funktion (s. Kommando OVRIDE=3)
Wird mit Hilfe dieses Parameters der digitale Override-Faktor vorgegeben.
Dabei gilt folgende Normierung:

DOVRIDE=0 Fahrsatzgeschwindigkeit = 0
DOVRIDE=8192 Fahrsatzgeschwindigkeit = 100 %


ASCII Deutsch DPRILIMIT

ASCII - Kommando | DPRILIMIT |
Syntax Senden | DPRILIMIT [Data] |
Syntax Empfangen | DPRILIMIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3658 (hex)
DIM | - | PROFIBUS PNU | 1944 (dec) IND = 1 (dec)
Bereich | 0 .. 3280 | DPR | 344 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Digitale Begrenzung des Spitzenstroms über DPR

Beschreibung

Mit dem Kommando DPRILIMIT kann der Spitzenstrom digital begrenzt werden.
Dabei gilt folgende Normierung:

DPRILIMIT=3280 Strombegrenzung=DIPEAK
DPRILIMIT=0 Strombegrenzung = 0

Beim Einschalten des Verstärkers wird die Variable DPRILIMIT auf 3280 (keine Strombegrenzung)gesetzt. Sie wird nicht im EEPROM abgespeichert, d.h. um die Begrenzung zu aktivieren muß die Variable über Feldbus/Slot-Karte/RS232/IO-Kommandosequenz beschrieben werden.

Die digitale Strombegrenzung muß mit der Konfigurationsvariable DILIM=1 freigeschaltet werden.

Achtung. für EtherCAT SDO Kommunikation bitte das Objekt 0x2061 SubIndex 0 benutzen


ASCII Deutsch DPRSTATE

ASCII - Kommando | DPRSTATE |
Syntax Senden | DPRSTATE [Data] |
Syntax Empfangen | DPRSTATE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | DPR Status

Beschreibung

DPRSTATE ist eine reine Debug Information für DPR basierte Interfaces. DPRSTATE wrid u.a. zum Phasenhochlauf und zur SDO Kommunikation benutzt.


ASCII Deutsch DPRVAR1_16

ASCII - Kommando | DPRVAR1_16 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | -2147483648 .. 2147483647 | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Macro Hilfsvariablen

Beschreibung

Hilfsvariablen für Macro- und PLC-Prgrammen:

DPRVAR1 Objekt Nr = 422 CAN-Objekt 0x36A6 (hex) PROF-PNU 2022 (dec) IND = 1 (dec)
DPRVAR2 Objekt Nr = 423 CAN-Objekt 0x36A7 (hex) PROF-PNU 2023 (dec) IND = 1 (dec)
DPRVAR3 Objekt Nr = 424 CAN-Objekt 0x36A8 (hex) PROF-PNU 2024 (dec) IND = 1 (dec)
DPRVAR4 Objekt Nr = 425 CAN-Objekt 0x36A9 (hex) PROF-PNU 2025 (dec) IND = 1 (dec)
DPRVAR5 Objekt Nr = 426 CAN-Objekt 0x36AA (hex) PROF-PNU 2026 (dec) IND = 1 (dec)
DPRVAR6 Objekt Nr = 427 CAN-Objekt 0x36AB (hex) PROF-PNU 2027 (dec) IND = 1 (dec)
DPRVAR7 Objekt Nr = 428 CAN-Objekt 0x36AC (hex) PROF-PNU 2028 (dec) IND = 1 (dec)
DPRVAR8 Objekt Nr = 429 CAN-Objekt 0x36AD (hex) PROF-PNU 2029 (dec) IND = 1 (dec)
DPRVAR9 Objekt Nr = 430 CAN-Objekt 0x36AE (hex) PROF-PNU 2030 (dec) IND = 1 (dec)
DPRVAR10 Objekt Nr = 431 CAN-Objekt 0x36AF (hex) PROF-PNU 2031 (dec) IND = 1 (dec)
DPRVAR11 Objekt Nr = 432 CAN-Objekt 0x36B0 (hex) PROF-PNU 2032 (dec) IND = 1 (dec)
DPRVAR12 Objekt Nr = 433 CAN-Objekt 0x36B1 (hex) PROF-PNU 2033 (dec) IND = 1 (dec)
DPRVAR13 Objekt Nr = 434 CAN-Objekt 0x36B2 (hex) PROF-PNU 2034 (dec) IND = 1 (dec)
DPRVAR14 Objekt Nr = 435 CAN-Objekt 0x36B3 (hex) PROF-PNU 2035 (dec) IND = 1 (dec)
DPRVAR15 Objekt Nr = 436 CAN-Objekt 0x36B4 (hex) PROF-PNU 2036 (dec) IND = 1 (dec)
DPRVAR16 Objekt Nr = 437 CAN-Objekt 0x36B5 (hex) PROF-PNU 2037 (dec) IND = 1 (dec)


ASCII Deutsch DPV17_64

ASCII - Kommando | DPV17_64 |
Syntax Senden | DPV17_64 [Data] |
Syntax Empfangen | DPV17_64 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | -2147483648 .. 2147483647 | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Macro Hilfsvariablen

Beschreibung

Hilfsvariablen für Macro- und PLC-Prgrammen:

DPV17 Objekt Nr = 700 CAN-Objekt 0x37BC (hex) PROF-PNU 1900 (dec) IND = 17
DPV18 Objekt Nr = 701 CAN-Objekt 0x37BD (hex) PROF-PNU 1901 (dec) IND = 17
DPV19 Objekt Nr = 702 CAN-Objekt 0x37BE (hex) PROF-PNU 1902 (dec) IND = 17
DPV20 Objekt Nr = 703 CAN-Objekt 0x37BF (hex) PROF-PNU 1903 (dec) IND = 17
DPV21 Objekt Nr = 704 CAN-Objekt 0x37C0 (hex) PROF-PNU 1904 (dec) IND = 17
DPV22 Objekt Nr = 705 CAN-Objekt 0x37C1 (hex) PROF-PNU 1905 (dec) IND = 17
DPV23 Objekt Nr = 706 CAN-Objekt 0x37C2 (hex) PROF-PNU 1906 (dec) IND = 17
DPV24 Objekt Nr = 707 CAN-Objekt 0x37C3 (hex) PROF-PNU 1907 (dec) IND = 17
DPV25 Objekt Nr = 708 CAN-Objekt 0x37C4 (hex) PROF-PNU 1908 (dec) IND = 17
DPV26 Objekt Nr = 709 CAN-Objekt 0x37C5 (hex) PROF-PNU 1909 (dec) IND = 17
DPV27 Objekt Nr = 710 CAN-Objekt 0x37C6 (hex) PROF-PNU 1910 (dec) IND = 17
DPV28 Objekt Nr = 711 CAN-Objekt 0x37C7 (hex) PROF-PNU 1911 (dec) IND = 17
DPV29 Objekt Nr = 712 CAN-Objekt 0x37C8 (hex) PROF-PNU 1912 (dec) IND = 17
DPV30 Objekt Nr = 713 CAN-Objekt 0x37C9 (hex) PROF-PNU 1913 (dec) IND = 17
DPV31 Objekt Nr = 714 CAN-Objekt 0x37CA (hex) PROF-PNU 1914 (dec) IND = 17
DPV32 Objekt Nr = 715 CAN-Objekt 0x37CB (hex) PROF-PNU 1915 (dec) IND = 17
DPV33 Objekt Nr = 716 CAN-Objekt 0x37CC (hex) PROF-PNU 1916 (dec) IND = 17
DPV34 Objekt Nr = 717 CAN-Objekt 0x37CD (hex) PROF-PNU 1917 (dec) IND = 17
DPV35 Objekt Nr = 718 CAN-Objekt 0x37CE (hex) PROF-PNU 1918 (dec) IND = 17
DPV36 Objekt Nr = 719 CAN-Objekt 0x37CF (hex) PROF-PNU 1919 (dec) IND = 17
DPV37 Objekt Nr = 720 CAN-Objekt 0x37D0 (hex) PROF-PNU 1920 (dec) IND = 17
DPV38 Objekt Nr = 721 CAN-Objekt 0x37D1 (hex) PROF-PNU 1921 (dec) IND = 17
DPV39 Objekt Nr = 722 CAN-Objekt 0x37D2 (hex) PROF-PNU 1922 (dec) IND = 17
DPV40 Objekt Nr = 723 CAN-Objekt 0x37D3 (hex) PROF-PNU 1923 (dec) IND = 17
DPV41 Objekt Nr = 724 CAN-Objekt 0x37D4 (hex) PROF-PNU 1924 (dec) IND = 17
DPV42 Objekt Nr = 725 CAN-Objekt 0x37D5 (hex) PROF-PNU 1925 (dec) IND = 17
DPV43 Objekt Nr = 726 CAN-Objekt 0x37D6 (hex) PROF-PNU 1926 (dec) IND = 17
DPV44 Objekt Nr = 727 CAN-Objekt 0x37D7 (hex) PROF-PNU 1927 (dec) IND = 17
DPV45 Objekt Nr = 728 CAN-Objekt 0x37D8 (hex) PROF-PNU 1928 (dec) IND = 17
DPV46 Objekt Nr = 729 CAN-Objekt 0x37D9 (hex) PROF-PNU 1929 (dec) IND = 17
DPV47 Objekt Nr = 730 CAN-Objekt 0x37DA (hex) PROF-PNU 1930 (dec) IND = 17
DPV48 Objekt Nr = 731 CAN-Objekt 0x37DB (hex) PROF-PNU 1931 (dec) IND = 17
DPV49 Objekt Nr = 732 CAN-Objekt 0x37DC (hex) PROF-PNU 1932 (dec) IND = 17
DPV50 Objekt Nr = 733 CAN-Objekt 0x37DD (hex) PROF-PNU 1933 (dec) IND = 17
DPV51 Objekt Nr = 734 CAN-Objekt 0x37DE (hex) PROF-PNU 1934 (dec) IND = 17
DPV52 Objekt Nr = 735 CAN-Objekt 0x37DF (hex) PROF-PNU 1935 (dec) IND = 17
DPV53 Objekt Nr = 736 CAN-Objekt 0x37E0 (hex) PROF-PNU 1936 (dec) IND = 17
DPV54 Objekt Nr = 737 CAN-Objekt 0x37E1 (hex) PROF-PNU 1937 (dec) IND = 17
DPV55 Objekt Nr = 738 CAN-Objekt 0x37E2 (hex) PROF-PNU 1938 (dec) IND = 17
DPV56 Objekt Nr = 739 CAN-Objekt 0x37E3 (hex) PROF-PNU 1939 (dec) IND = 17
DPV57 Objekt Nr = 740 CAN-Objekt 0x37E4 (hex) PROF-PNU 1940 (dec) IND = 17
DPV58 Objekt Nr = 741 CAN-Objekt 0x37E5 (hex) PROF-PNU 1941 (dec) IND = 17
DPV59 Objekt Nr = 742 CAN-Objekt 0x37E6 (hex) PROF-PNU 1942 (dec) IND = 17
DPV60 Objekt Nr = 743 CAN-Objekt 0x37E7 (hex) PROF-PNU 1943 (dec) IND = 17
DPV61 Objekt Nr = 744 CAN-Objekt 0x37E8 (hex) PROF-PNU 1944 (dec) IND = 17
DPV62 Objekt Nr = 745 CAN-Objekt 0x37E9 (hex) PROF-PNU 1945 (dec) IND = 17
DPV63 Objekt Nr = 746 CAN-Objekt 0x37EA (hex) PROF-PNU 1946 (dec) IND = 17
DPV64 Objekt Nr = 747 CAN-Objekt 0x37EB (hex) PROF-PNU 1947 (dec) IND = 17


ASCII Deutsch DPWM

ASCII - Kommando | DPWM |
Syntax Senden | DPWM [Data] |
Syntax Empfangen | DPWM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3676 (hex)
DIM | - | PROFIBUS PNU | 1974 (dec) IND = 1 (dec)
Bereich | 0 .. 4 | DPR | 374 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | PWM für Stromregler- und Positionsreglekreis

Beschreibung

DPWM definiert die PWM-, die Stromregler- und Positionsreglerfrequenz.
Folgende Einstellungen sind möglich

DPWM=0 PWM Frequenz 8 KHz, Stromregler 16 KHz, Positionsregler 4 KHz
DPWM=1 PWM Frequenz 16 KHz, Stromregler 32 KHz, Positionsregler 4 KHz (nur ARM7, FW 3.xx)
DPWM=2 PWM Frequenz 16 KHz, Stromregler 16 KHz, Positionsregler 4 KHz
DPWM=3 PWM Frequenz 8 KHz, Stromregler 16 KHz, Positionsregler 8 KHz
DPWM=4 PWM Frequenz 4 KHz, Stromregler 16 KHz, Positionsregler 4 KHz (seit FW >= 5.39)

Achtung:
bei DPWM = 1 oder 2 (16kHz) wird der Strom wie folgt begerenzt:
IPEAK wird auf 60% von DIPEAK begrenzt
Nennstrom wird bei 230V Ausführung auf auf 80% von DICONT begrenzt.
Nennstrom wird bei 400V Ausführung auf auf 60% von DICONT begrenzt.


ASCII Deutsch DR_TYPE

ASCII - Kommando | DR_TYPE |
Syntax Senden | DR_TYPE |
Syntax Empfangen | DR_TYPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 352E (hex)
DIM | - | PROFIBUS PNU | 1646 (dec) IND = 1 (dec)
Bereich | 1 .. 8 | DPR | 46 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Liefert die Endstufenkennung

Beschreibung

Mit dem Kommando DR_TYPE kann die Endstufenkennung ausgelesen werden.


ASCII Deutsch DREF

ASCII - Kommando | DREF |
Syntax Senden | DREF [Data] |
Syntax Empfangen | DREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 352C (hex)
DIM | - | PROFIBUS PNU | 1644 (dec) IND = 1 (dec)
Bereich | 0...34 | DPR | 44 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Fahrtrichtung für die Referenzfahrt

Beschreibung

Mit dem Parameter DREF kann die Vorzugsrichtung bei einer Referenzfahrt und beim Positionieren mit einer Modulo-Achse definiert werden. Bits 0..3 gelten dabei für die Referenzfahrt, Bits 4..7 für die Modulo-Achse (POSCNFG=1). Die möglichen Kombinationen sind in der Tabelle aufgelistet. Bei einer Referentfahrt mit Nullpunktsuche ist DREF auf 2,18 oder 34 einzustellen. Siehe auch POSCNFG
 | Referenzfahrt-Richtung | Modulo-Richtung
DREF = 0 | negativ | negativ
DREF = 1 | positiv | negativ
DREF = 2 | entfernungsabhängig | negativ
DREF =4 | Negative Referenzfahrt-Richtung ohne Umkehr der Fahrtrichtung | ab der Version 1.30 DREF =4 Referenzfahrt-Richtung negativ (wie DREF=0), nur negative Fahrt zugelassen, keine Umkehr der Fahrtrichtung bei aktivem Referenz-/Endschalter Ein bei Referenzfahrtstart belegter Endschalter NSTOP wird nicht freigefahren, sondern der Nullpunkt ebenfalls direkt gesetzt.. Die Genauigkeit wird geringer, da nicht auf die Flanke des Endschalters bzw. den nächsten Nullpunkt referenziert wird. Diese Einstellungen haben nur dann Sinn, wenn eine Referenzfahrt auf einen Referenzschalter vorgewählt ist (NREF=1,3).
DREF = 5 | Positive Referenzfahrt-Richtung ohne Umkehr der Fahrtrichtung | >= Version 1.30 DREF =5 Referenzfahrt-Richtung positiv (wie DREF=1), nur positive Fahrt zugelassen, keine Umkehr der Fahrtrichtung bei aktivem Referenz-/Endschalter Ein bei Referenzfahrtstart belegter Endschalter PSTOP wird nicht freigefahren, sondern der Nullpunkt ebenfalls direkt gesetzt.. Die Genauigkeit wird geringer, da nicht auf die Flanke des Endschalters bzw. den nächsten Nullpunkt referenziert wird. Diese Einstellungen haben nur dann Sinn, wenn eine Referenzfahrt auf einen Referenzschalter vorgewählt ist (NREF=1,3).
DREF = 16 | negativ | positiv
DREF = 17 | positiv | positiv
DREF = 18 | entfernungsabhängig | positiv
DREF = 32 | negativ | entfernungsabhängig
DREF = 33 | positiv | entfernungsabhängig
DREF = 34 | entfernungsabhängig | entfernungsabhängig


ASCII Deutsch DRIVE

ASCII - Kommando | DRIVE |
Syntax Senden | DRIVE |
Syntax Empfangen | DRIVE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3677 (hex)
DIM | - | PROFIBUS PNU | 1975 (dec) IND = 1 (dec)
Bereich | 32Bit | DPR | 375 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 0.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Hardware-Kennung des Servoverstärkers

Beschreibung

Die Variable DRIVE liefert die Hardware-Kennung des Servo-Verstärkers. Anhand dieser Kennung kann die Verstärker-Familie erkannt werden.

gilt nur für den Antrieb mit ARM9:
Bit 0…7 reserviert
Bit 8 = 1 230V-Variante
= 0 400V-Variante
Bit 9 = 1 P-Variante (12A/24A)
Bit 10 = 1 ARM9 (S300)
Bit 11 = 1 Unterstützung der ServoPumpen-Funktionalität durch die Firmware
Bit 16…31 Verstärker-Bezeichnung z.B. 712

Zusätzlich kann mir VER * oder SDO-Objekt 0x1009 (für CAN oder EtherCAT) die Layout-Version im Format Jahr/Kalenderwoche abgefragt werden.

Layout-Version älter als 1007 gehört zum S700/HW2.0/FW 3.xx.
Layout-Version höher/gleich 1007 gehört zum S700/HW2.1/FW 5.xx.


ASCII Deutsch DRVCNFG

ASCII - Kommando | DRVCNFG |
Syntax Senden | DRVCNFG [Data] |
Syntax Empfangen | DRVCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3672 (hex)
DIM | - | PROFIBUS PNU | 1970 (dec) IND = 1 (dec)
Bereich | long int | DPR | 370 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Konfiguartions Parameter für Zusatzfunktionen

Beschreibung

Die Konfigurationsvariable stellt sicher, dass bei neuen oder erweiterten CAN-Bus Funktionen, keine Inkompatibilitäten zu früheren Versionen entsteht. Falls bei neueren Versionen einen Inkompatibilität festgestellt wird, so kann diese Funktion wieder deaktiviert werden, in dem das entsprechende Bit zurückgesetzt wird. Die gewählte Bitkombination muss dezimal eingegeben werden. Beispiel: Bit 2 und 5 gewählt ergibt 2^2+2^5 = 4 + 32 = 36
Bit | Wertigkeit | Beschreibung
0 | 0x1 | reserviert
1 | 0x2 | reserviert
2 | 0x4 | reserviert
3 | 0x8 | reserviert
4 | 0x10 | reserviert
5 | 0x20 | reserviert
6 | 0x40 | reserviert
7 | 0x80 | reserviert
8 | 0x100 | = 1 Ein Single-Turn Geber wie ein Multi-Turn behandelt. Beim Einschalten wird die absolute Position innerhalb einer Umdrehung übernommen PFB . Es ist keine Referenzfahrt erforderlich. Diese Einstellung wird auch für analoge Hallgeber mit ENCLINES =1 benötigt.
9 | 0x200 | reserviert
10 | 0x400 | reserviert
11 | 0x800 | reserviert
12 | 0x1000 | reserviert
13 | 0x2000 | = 1 Konfiguration für fliegendes Umschalten von Fahraufträgen: Beim Start des neuen Fahrsatzes wird überprüft, ob die Verfahrstrecke kleiner als die Bremsstrecke ist. Dann wird der Bremsvorgang mit der Rampe des laufenden Fahrsatzes eingeleitet. = 0 Der Folgefahrsatz wird immer gestartet. Es kann zu einem sehr schnellen Stop kommen.
14 | 0x4000 | reserviert
15 | 0x8000 | = 1 nur einfaches Einlesen der absoluten ENDAT-Position = 0 ENDAT wird mehrfach (bis zu 5 mal) eingelesen. Die absolute Position wird nur dann übernommen wenn min. 2x, max. 5x die gleiche Position ausgelesen wird. siehe auch FBTYPE=4
16 | 0x1 0000 | = 1 Bei Folgefahrsätzen wird immer auf die Beschleunigungsrampe des Folgefahrsatzes umgeschaltet = 0 Es werden folgende Rampen verwendet: -Ist die Geschwindigkeit des Folgefahrsatzes größer und gleichgerichtet, wird die Beschleunigungsrampe des Folgefahrsatzes verwendet - Ist die Geschwindigkeit des Folgefahrsatzes kleiner und gleichgerichtet, wird die Bremsrampe des ersten Fahrsatzes verwendet - Ist der Folgefahrsatz entgegen gerichtet, wird mit der Bremsrampe des ersten gebremst und mit der Beschleunigungsrampe des zweiten Fahrsatzes beschleunigt
17 | 0x2 0000 | reserviert
18 | 0x4 0000 | reserviert
19 | 0x8 0000 | = 1 Position des externen Gebers, PFB0 wird am Ende der Referenzfahrt nicht zurückgesetzt = 0 Position PFB0 wird am Ende der Referenzfahrt auf ROFFS gesetzt
20 | 0x10 0000 | reserviert
21 | 0x20 0000 | = 1 keine Checksummenüberwachung bei EQI Feedback = 0 Checksummenüberwachung bei EQI Feedback aktiviert siehe auch FBTYPE = 4
22 | 0x40 0000 | = 1 Bei gesperrter Endstufe werden keine Encoder - Impulse mehr ausgegeben = 0 Ständige Encoder - Ausgabe
23 | 0x80 0000 | reserviert
24 | 0x100 0000 | =1 Bei Bit 13 = 1 wird nach Bremsung, bei der die letzte Zielposition überfahren wurde, auf Zielposition zurückgefahren = 0 keine Rückfahrt
25 | 0x200 0000 | reserviert
26 | 0x400 0000 | reserviert
27 | 0x800 0000 | reserviert
28 | 0x1000 0000 | reserviert
29 | 0x2000 0000 | reserviert
30 | 0x4000 0000 | = 1 verschärfte Überwachung der SinCos-Amplitude. Es wird nicht nur die Summe der Quadrate überwacht sondern auch die Summe der einfachen Signale. Bei jeder Verletzung wird die Variable MAXDIFFI inkrementiert. Sobald MAXDIFFI den Wert MAXDIFF überschreitet, wird eine Warnung n23 generiert. Die Variable MAXDIFFI wird alle 8 Minuten zu 0 gesetzt. Bei aktivierter Funktion gibt der Wert MAXDIFFI eine Aussage über die Qualität der SinCos-Signale.
31 | 0x8000 0000 | reserviert


ASCII Deutsch DRVCNFG2

ASCII - Kommando | DRVCNFG2 |
Syntax Senden | DRVCNFG2 [Data] |
Syntax Empfangen | DRVCNFG2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36E4 (hex)
DIM |  | PROFIBUS PNU | 1684 (dec) IND = 17 (dec)
Bereich | 32 Bit | DPR | 484 (dec)
Default | 268435456 (0x1000 0000) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Konfiguartions Parameter für Zusatzfunktionen

Beschreibung

Mit der Konfigurationsvariablen DRVCNFG2 können unterschiedliche Zusatzfunktionen des Verstärkers aktiviert werden.
Bit | Wertigkeit | Beschreibung
0 | 0x1 | reserviert
1 | 0x2 | = 0 Die Latchfunktionalität für den ersten digitalen Eingang ist immer aktiv = 1 Die Latchfunktionalität für den ersten digitalen Eingang muss von der Steuerung oder vom MacroPrgramm über die Variable ENA1P/ENA1N aktiviert werden siehe auch: IN1MODE=26
2 | 0x4 | = 0 Die Latchfunktionalität für den zweiten digitalen Eingang ist immer aktiv = 1 Die Latchfunktionalität für den zweiten digitalen Eingang muss von der Steuerung oder vom MacroPrgramm über die Variable ENA2P/ENA2N aktiviert werden siehe auch: IN2MODE=26
3 | 0x8 | 1 = Die Übernahme der Stromvorsteuerung von der externen Slot-Karte (DPR) wird aktiviert. 0 = Keine Übernahme der Stromvorsteuerung von der externen Karte
4..7 | - | reserviert
8 | 0x100 | = 0 ROFFSABS – Wert vom ser. EEProm wird übernommen = 1 ROFFSABS wird im Geber gespeichert und beim Einschalten wieder gelesen.
9..13 | - | reserviert
14 | 0x4000 | = 0 alle Warnungen außer n32 und n14 werden mit CLRFAULT zurückgesetzt = 1 alle Warnungen außer n14 und n23 und n32 werden mit CLRFAULT zurückgesetzt
15 | 0x8000 | Driftstop am Endschalter, nur gültig in OPMODE = 4 = 0 Driftstop bei Master -Slave -Anwendung inaktiv = 1 Driftstop aktiv Vorsicht: Falls die Nothalt-Situation (Hardware-Endschalter, Software-Endschalter, INxMODE=27 etc.) bei freigegebenem Drive vom Benutzer manuell aufgehoben wird, kann der Antrieb von selbst mit maximaler Geschwindigkeit losfahren.
16 | 0x10000 | = 0 Am Ende einer Referenzfahrt (mit Multiturn-Geber) wird ROFFSABS neu berechnet und im EEPROM abgespeichert. = 1 Keine Berechnung und kein Abspeichern vom Refferenzoffset ROFFSABS nach einer Referenzfahrt bei Multiturn-Gebern.
17 | 0x20000 | = 0 Fligender Wechsel des Sinus Profiles wird sofort übernommen = 1 Bei fliegendem Umschalten von sinus Fahraufträgen Abbremsen auf 0 erzwingen bevor Folgefahrauftrag staren kann
18 | 0x40000 | ab FW >= 2.14 = 0 Scope-Abtastrate mit 250 µs (4 kHz) Der Drehzahlistwert des Drehzahlbeobachters wird beim Aufzeichnen eines Bode Plots genutzt. = 1 Scope-Abtastrate von 62.5 µs (16 kHz) aktiviert. Bei Encodern mit Sinus/ Cosinus Spur als Motorgeber, wird das direkt differenzierte Encodersignal für die Aufzeichnung eines Bode Plots genutzt.
19 | 0x80000 | ab FW >= 3.07 = 0 die Funktion ANCNFG=8 benutzt den Absolutwert der SW1-Spannung. Die Spannung -/+ 10V wird auf den Bereich SRND...ERND abgebildet. = 1 die Funktion ANCNFG=8 benutzt den vorzeichenbehafteten Wert der SW1-Spannung. Die Spannung -/+ 10V wird auf den Bereich SRND - (ERND-SRND)...ERND abgebildet.
20 | 0x100000 | ab FW >= 3.07 = 0 Überwachung der SENSE-Spannung aktiv (bei Versorgung eines externen Gebers über X1) = 1 Überwachung der SENSE-Spannung abgeschaltet Das Abschalten der Überwachung kann sinnvoll sein, wenn ein Geber extern versorgt wird und die interne Spannungsversorgung nicht benötigt wird. siehe auch: FBTYPE
21 | 0x200000 | ab FW >= 3.08 = 0 Falls bei "STO disable" das Software-Enable gesetzt war, so wird beim Setzen von "AS-Option enable" das Software-Enable automatisch gesetzt. = 1 Beim Setzen von "STO enable" bleibt das Software-Enable auf 0 unabhängig davon wie der Zustand beim Setzen von "AS-Option disable" war.
22 | 0x400000 | S300/S700: Diese Funktion darf erst ab der FW >= 3.70/5.00 benutzt werden. = 0 kein zyklisches Speichern der oberen 32 Bit der 64 Bit-Position im Eeprom. = 1 Abspeichern der oberen 32 Bit der 64 Bit-Position im Eeprom. Diese Funktion entspricht der Funktion POSCNFG == 2, kann aber auch ohne aktivierte Modulo-Funktionalität benutzt werden. Achtung: Durch das zyklische Abspeichern der Positionswerte im Flash/EEPROM, kann die Lebensdauer des Speichers verkürzt werden. Da das Abspeichern der 64Bit-Position alle 1024 Umdrehungen erfolgt, entspricht das bei einem mit 3000 UPM drehenden Antrieb, einer Zykluszeit von 20 Sekunden. Die max. Anzahl der Schreibzyklen beträgt im Dauerbetrieb mit 3000 RPM: S300 mit FW 3.xx: ca. 240 Tage S300/S700 mit FW 5.xx: ca. 8800 Tage Aktivierung dieser Funktion bei einer älteren Firmware kann zur Beschädigung des internen Flash-Speichers führen.
23 | 0x800000 | reserviert
24 | 0x1000000 | ab FW >= 3.06 = 0 bei FBTYPE=23,24 wird beim Einschalten die absolute BISS-Position im Sensor-Mode eingelesen = 1 bei FBTYPE=23,24 wird beim Einschalten die absolute BISS-Position im Register-Mode eingelesen Diese Einstellung kann benutzt werden, falls es Probleme beim Einlesen des BISS-Gebers geben sollte. (Leitung stark bedämpft).
25 | 0x2000000 | = 0 bei den Funktionen INxMODE=43…46 wird in INxTRIG der Wert der Ausgleichstrecke erwartet = 1 bei den Funktionen INxMODE=43…46 wird in INxTRIG die Nummer des Ausgleich-Fahrsatzes erwartet.
26 | 0x4000000 | = 0 die SinCos-Positionserfassung benutzt die digitale Information des Hardware-Zählers sowie die „analoge“-Information aus dem FPGA-Erfassungsmodul. = 1 die SinCos-Positionserfassung benutzt nur die Information aus dem FPGA-Erfassungsmodul (Debug-Zwecke).
27 | 0x8000000 | = 0 Asynchronmotor - Feldschwächung gesteuert = 1 Asynchronmotor - Feldschwächung mit Spannungsregler
28 | 0x10000000 | = 0 Sercos-Istwerte werden mit dem nächsten Sercos-Tick übernommen. = 1 Sercos-Istwerte werden sofort übernommen. Damit kann das Problem mit der Dateninkonsistenz gelöst werden.
29 | - | reserviert
30 | 0x40000000 | = 0 Beim Resettieren der Fehler F04 oder F25 wird immer ein Hardware-Reset ausgeführt. = 1 Beim gesetzten Bit 30 bewirken alle "Fehler-Reset"-Kommandos einen softwaremaessigen Reset der-Fehler F04 (Resolver) oder F25 (Kommutierung). Beim Resolver Fehler wirkt sich dieses Bit nur bei der Einstellung FBTYPE = 0 aus.
31 | 0x80000000 | = 0 Funktionen im Objektkanal werden durch Lesen ausgelöst = 1 Funktionen im Objektkanal werden durch Schreiben ausgelöst


ASCII Deutsch DRVCNFG3

ASCII - Kommando | DRVCNFG3 |
Syntax Senden | DRVCNFG3 [Data] |
Syntax Empfangen | DRVCNFG3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 386F (hex)
DIM |  | PROFIBUS PNU | 1679 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 879 (dec)
Default | 24 (0x18) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.57 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Konfiguartions Parameter für Zusatzfunktionen

Beschreibung

Mit der Konfigurationsvariablen DRVCNFG3 können unterschiedliche Zusatzfunktionen des Verstärkers aktiviert werden.
Bit | Wertigkeit | Beschreibung
0 | 0x1 | =1 altes BISS-Format wird aktiviert (mit 24 Bit/Umdrehung). Diese Einstellung sollte bei BISS-Gebern benutzt werden, die vor dem 05.05.2006 hergestellt wurden. =0 das Positionsformat wird aus dem Geber eingelesen
1 | 0x2 | reserviert
2 | 0x4 | 0 = Abtastrate der digitalen Eingänge mit 4 KHz aktivieren 1 = Abtastrate der digitalen Eingänge mit 16 KHz aktivieren
3 | 0x8 | 0 = Strom-Offsetmessung findet nach(!) dem Einschalten der Zwischenkreisspannung statt 1 = Strom-Offsetmessung beim(!) Einschalten des Drives ab FW 5.40
4 | 0x10 | 1 = Reset von harten Fehlern möglichst ohne COLDSTART durchführen
5 | 0x20 | reserviert
6 | 0x40 | 1 = Übertragung des gelatchten Distributed Clocks (sonst Position) über EtherCat aktivieren
7 | 0x80 | 1 = Verwendung von PRD (sonst PFB) bei COGMODE 1 und 2 aktivieren (nur rotatorische Motoren)
8 | 0x100 | 1 = Startverzögerung eines Fahrauftrages (bis die Bremse gelüftet ist) deaktivieren
9 | 0x200 | reserviert
10 | 0x400 | reserviert
11 | 0x800 | reserviert
12 | 0x1000 | reserviert
13 | 0x2000 | reserviert
14 | 0x4000 | 1 = Start vom Fahrauftrag in 4 KHz Routine
15 | 0x8000 | reserviert
16 | 0x10000 | 1 = Erweiterte EtherCAT XML Version (Fahrauftrag, Flexibles Mapping) aktivieren (ab FW >= 5.18)
17 | 0x20000 | 1 = Sercos: command break acknowledged by STAT=1
18 | 0x40000 | 1 = Beeinflussung der Drehzahlreglerrampen durch CAN-Objekte 6083/6084 deaktivieren
19 | 0x80000 | 1 = Temperaturabhängige Erhöhung des Nennstroms (um 10%) aktivieren
20 | 0x100000 | 1 = Positionssollwert wird über ROD ausgegeben
21 | 0x200000 | 1 = S300 keine ROD-Überwachung
22 | 0x400000 | 0 = keine Berücksichtigung des INPOS-Fensters beim Umschalten des OPMODE‘s 1 = Auswertung des INPOS-Fensters beim Umschalten auf OPMODE=4 aktivieren (Positionssprung möglich)
23 | 0x800000 | 1 = torque setpoint via object 6071 is taken directly, not in 1 ms task
24 | 0x1000000 | 1 = Abschalten des Feldschwächbetriebes (gilt ab FW 5.17 und 3.80)
25 | 0x2000000 | 1 = Beim Umschalten des OPMODE auf 4 (Master/Slave) wird der interne Drehzahlsollwert VCMD nicht zu 0 gesetzt. Dies kann benutzt werden um eine fliegende Umschaltung zwischen den OPMODE (ohne Zwischenstopp) zu realisieren. (gilt ab FW 5.17 und 3.80)
26 | 0x40000000 | 1 = Rampenkorrektur beim Abbruch eines Fahrsatzes. Falls ein Fahrsatz kurz vor dem Erreichen der Zielposition abgebrochen wird, so kann es passieren, dass der Antrieb kurz hinter der Zielposition zum Stehen kommt. Bei gesetztem Bit wird die Bremsrampe so angepasst, dass der Zielpunkt auf keinen Fall überfahren wird.
27 | 0x80000000 | 1 = kein automatisches Zurücksetzen der Encoder-Warnungen
28 | 0x100000000 | 1 = Ausgabe der externen Geberposition (PFB0) über ROD aktivieren
29 | 0x200000000 | reserviert
30 | 0x400000000 | 1 = Zyklische EtherCAT Sollwerte bei gesperrter Endstufe aktivieren
31 | 0x800000000 | 1 = Erweiterung des Phasenwinkels auf 90° (sonst 45°) im Felschwächbetrieb aktivieren


ASCII Deutsch DRVCNFG4

ASCII - Kommando | DRVCNFG4 |
Syntax Senden | DRVCNFG4 [Data] |
Syntax Empfangen | DRVCNFG4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38CE (hex)
DIM |  | PROFIBUS PNU | 1774 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 974 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.40 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Konfiguartions Parameter für Zusatzfunktionen

Beschreibung

Mit der Konfigurationsvariablen DRVCNFG4 können unterschiedliche Zusatzfunktionen des Verstärkers aktiviert werden.
Bit | Wert | Beschreibung
0 | 0x1 | 1 = Kein Zurückfahren zu der Ausgangsposition nach dem Wake&Shake
1 | 0x2 | 1 = Abschalten der korrigierten Berechnung von PVMAX für SERCOS Die „alte“ Berechnung funktioniert nur wenn PGEARI=2^PRBASE, die neue Berechnung behebt dieses Problem. Bei Kompatibilitätsproblemen kann dies durchs Setzen des Bits rückgängig gemacht werden.
2 | 0x4 | 1 = Aktivieren der Reset-Automatik für das SinCos-Modul im FPGA. Bei sehr gestörten SinCos-Signalen kann es zu Problemen bei der Positionserfassung kommen. Bei gesetztem Bit wird die FPGA-Position mit Hilfe des Hardware-Zählers überwacht. Bei Bedarf wird das FPGA-Modul zurückgesetzt.
3 | 0x8 | 1 = Softwaremäßige Überwachung des Endstufenfehlers F14. Falls diese Überwachung aktiv ist, wird F14 gemeldet bevor die Hardware-Erkennung angesprochen hatte. Dies dient dem Schutz der Endstufe bei völlig falsch eingestelltem Stromregler. Siehe auch ERRCODE *
4 | 0x10 | reserviert
5 | 0x20 | 1 = kein Überwachung des Feedbackfehlers F04 beim Einsatz eines digitalen Encoders (ENDAT2.2 oder BISS-C) als zweiten Geber.
6 | 0x40 | 1 = keine Anhebung der Ballastschwelle bei hoher Ballastleistung. Um die Ballastverteilung im Zwischenkreisverbund gleichmäßig zu halten, wird die Einschaltschwelle mit steigender Leistung angehoben. Dies führt zum verzögerten Einschalten des Ballastwiderstandes. Bei Verstärkern, die nicht im Zwischenkreisverbund arbeiten, kann dieser Effekt unerwünscht sein.
7 | 0x80 | 1 = CAN/EtherCat: die Endstufe wird nicht freigegeben in dem DS402-Status "Switched On".
8 | 0x100 | 1 = EtherCAT-Status „Operation Enable“ wird gemeldet erst wenn die Sollwerte akzeptiert werden und nicht wenn die Endstufe freigegen wird (Meldung erst nachdem die Beruhigungszeit für die Endstufe abgelaufen ist).
9 | 0x200 | 1 = bei Benutzung eines externen Gebers wird die Referenzfahrt (bei entsprechendem NREF) nicht auf den Nulldurchgang dieses Gebers sondern auf den Nulldurchgang des primären Gebers (Resolver) durchgeführt.
10 | 0x400 | 1 = kein Zurücksetzen des Drehzahlregler-Integralanteils bei gesperrter Endstufe. Diese Einstellung kann Sinnvoll sein, um das Abrutschen von hängenden Lasten bei Bremsenansteuerung zu minimieren.
11 | 0x800 | 1 = verbesserte Berechnung der aktuellen Geschwindigkeit in "Hall-Only-Modus". Diese Funktion ist zurzeit defaultmässig nicht aktiv (aus Kompatibilitätsgründen) sollte aber bei neuen „Hall-Only“-Applikationen benutzt werden.
12 | 0x1000 | 1 = fliegende Synchronisation mit einem drehendem Motor. Beim Einschalten des Verstärkers/Freigeben der Endstufe wird der Drehzahlregler auf die aktuelle Drehzahl des Motors aufsynchronisiert. Dies bedeutet, dass beim Freigeben der Endstufe einmalig der digitale Drehzahlsollwert auf den aktuellen Drehzahlistwert gesetzt wird. Solange kein neuer Sollwert empfangen wurde (Feldbus,analog,RS232) wird diese Drehzahl gehalten. Vorsicht: Wenn die Funktion aktiv ist, kann das zum Driften des Motors im „Stillstand“ führen.
13 | 0x2000 | 1 = X1-Initialisierung zum SSI-Einlesen. Diese Funktion ist nur in Verbindung mit einem Makro-Programme sinnvoll, wenn die SSI-Schnittstelle in dem Makro-Programm eingelesen werden soll ohne geeignete FBTYPE/GEARMODE/EXTPOS-Einstellungen.
14 | 0x4000 | 1 = X5-Initialisierung zum SSI-Einlesen. Diese Funktion ist nur in Verbindung mit einem Makro-Programme sinnvoll, wenn die SSI-Schnittstelle in dem Makro-Programm eingelesen werden soll ohne geeignete FBTYPE/GEARMODE/EXTPOS-Einstellungen.
15....31 | - | reserviert


ASCII Deutsch DRVSTAT

ASCII - Kommando | DRVSTAT |
Syntax Senden | DRVSTAT |
Syntax Empfangen | DRVSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 352D (hex)
DIM | - | PROFIBUS PNU | 1645 (dec) IND = 1 (dec)
Bereich | 0 .. 0xFFFFFFFF | DPR | 45 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Geräte-Statusinformation

Beschreibung

Das Kommando DRVSTAT liefert die internen Status-Informationen in Form einer Bit-Variable.

Unter Level werden die verschiedenen Reaktionen vom Verstärker auf die Warnung angegeben:

Level = 0 Eine Störung wird als Warnung Nr. xx im Display angezeigt (Anzeige nxx).
Darüber hinaus wird im Statusregister ein Warnungsbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann. Die Endstufe bleibt enabled, der Verstärker ist weiterhin betriebsbereit (BTB), der Betrieb kann u.U. eingeschränkt sein (Strombegrenzung). Mit dem Verschwinden der Störungsursache ist sofort ein uneingeschränkter Betrieb möglich.

Level 1: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt drehzahlgeregelt mit der Nothalt-Rampe (DECSTOP). Die Endstufe bleibt enabled, der Verstärker ist weiterhin betriebsbereit (BTB). Weiterer Betrieb ist erst nach Quittieren bzw. Verschwinden der Fehlerursache möglich. Die Störung wird als Warnung Nr. xx im Display angezeigt (Anzeige nxx). Darüber hinaus wird im Statusregister ein Warnungsbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.
Bit/Display/Level | Bitkombination | Beschreibung
1 / n02 / 0 0x00000002 =1 Ballast-Meldung
wird gesetzt, wenn die aktuelle Ballastleistung die Schwelle PBALMAX überschreitet.
Wird gelöscht, sobald die PBALMAX unterschritten wird.
2 / n03 / 1 0x00000004 =1 Schleppfehler
wird gesetzt sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet.
Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“ über INxMODE=14
3 / n04 / 1 0x00000008 =1 Ansprechüberwachung aktiv
wird gesetzt, wenn die BUS/SLOT-Ansprechüberwachungszeit EXTWD überschritten wurde.
Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“ über INxMODE=14.
4 / n05 / 0 0x00000010 =1 Netzphase fehlt
wird gesetzt sobald das Fehlen einer der 3 Netzphasen festgestellt wird.
Wird gelöscht wenn alle 3 Netzphasen vorhanden.
5 / n06 / 1 0x00000020 =1 Software-Endschalter 1 unterschritten
- wird gesetzt sobald die eingestellte Position des Software-Endschalters 1 SWE1 unterschritten wird.
- Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition unterhalb von SWE1 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt).
Wird gelöscht wenn die Position SWE1 überschritten wird und ein positiver Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
6 / n07 / 1 0x00000040 =1 Software-Endschalter 2 überschritten
- wird gesetzt sobald die eingestellte Position des Software-Endschalters 2 SWE2 überschritten wird.
- Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition oberhalb von SWE2 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt).
Wird gelöscht wenn die Position SWE2 unterschritten wird und ein negativer Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
7 / n08 / 0 0x00000080 =1 Fehlerhafter Fahrauftrag gestartet
wird gesetzt wenn versucht wird einen nichtvorhandenen (fehlerhafte Checksumme) Fahrauftrag zu starten.
Wird gelöscht wenn ein gültiger Fahrsatz gestartet wird.
8 / n09 / 0 0x00000100 = 1 Referenzpunkt nicht gesetzt
wird gesetzt, wenn ein Fahrsatz gestartet wird, ohne dass zuvor eine Referenzfahrt durchgeführt wurde.
Wird gelöscht nach einer abgeschlossenen Referenzfahrt.
9 / n10 / 1 0x00000200 = 1 PSTOP aktiv
ist gesetzt solange der Hardware-Endschalter PSTOP aktiv
wird gelöscht sobald der Hardware-Endschalter PSTOP inaktiv wird.
10 / n11 / 1 0x00000400 =1 NSTOP aktiv
ist gesetzt solange der Hardware-Endschalter NSTOP aktiv
wird gelöscht sobald der Hardware-Endschalter NSTOP inaktiv wird.
11 / n12 / 0 0x00000800 =1 Default-Motordaten geladen
wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem SINCOS-Geber unterschiedlich sind.
Wenn danach die Daten im EEPROM gespeichert werden (SAVE), wird die Warnung nach dem nächsten Einschalten nicht mehr angezeigt.
12 / n13 / 1 0x00001000 =1 Slot-Warnung (I/O-Karte)
wird gesetzt, wenn die 24 V Versorgungsspannung für die I/O-Erweiterungskarte fehlen.
Wird gelöscht, wenn die 24V-Versorgung der I/O-Erweiterungskarte vorhanden.
13 / n14 / 0 0x00002000 =1 Ermittlung von MPHASE (FBTYPE=7)
wird gesetzt beim Einschalten des Verstärkers.
Wird gelöscht wenn die Endstufe freigegeben wurde und der Wert für MPHASE mit W&S ermittelt werden konnte.
(Wake & Shake - Prozedur )
14 / n15 / 0 | 0x00004000 | reserviert
15 / n16 / 0 | 0x00008000 | Summenwarnung der Warnungen n17...n31
16 0x00010000 =1 Auftrag aktiv (Lageregelung)
wird gesetzt sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt).
Wird gelöscht wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
17 0x00020000 =1 Referenzpunkt gesetzt
gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn).
Wird gelöscht beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt.

Dieses Bit bedeutet NICHT: Referenzfahrt abgeschlossen.
18 0x00040000 =1 Home-Position
ist gesetzt solange der Referenzschalter belegt ist.
Wird gelöscht sobald der Referenzschalter nicht belegt
19 0x00080000 =1 In-Position
wird gesetzt sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS ist.
Wird gelöscht sobald der Abstand größer als PEINPOS.
Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
20 0x00100000 =1 Positionslatch erfolgte (positive Flanke)
wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird.
Wird gelöscht wenn die gelatchte Position ausgelesen wird (z.B.: LATCH1N16/LATCH1N32)
21 | 0x00200000 | reserviert
22 | 0x00400000 | reserviert
23 | 0x00800000 | reserviert
24 | 0x01000000 | reserviert
25 | 0x02000000 | reserviert
26 0x04000000 =1 Initialisierung beendet
wird gesetzt nachdem die interne Initialisierung des Verstärkers abgeschlossen ist.
27 | 0x08000000 | reserviert
28 0x10000000 =1 Motorstillstandsmeldung
Das Bit ist gesetzt, wenn die aktuelle Motordrehzahl kleiner als die Schwelle VEL0 ist
29 0x20000000 =1 Sicherheitsrelais
wird gesetzt wenn das Sicherheitsrelais offen (AS-Option)
wird gelöscht wenn das Sicherheitsrelais geschlossen.
30 0x40000000 =1 Endstufe freigegeben
wird gesetzt wenn Software- und Hardwareenable gesetzt sind.
31 0x80000000 =1 Fehler steht an
wird gesetzt wenn der Verstärker gestört (Endstufe gesperrt, Fehlernummer Fxx wird auf dem Display angezeigt).
Mit dem Kommando ERRCODE kann der Fehler im Klartext ausgegeben werden.
Das Bit wird gelöscht beim Einschalten des Verstärkers bzw. beim Kommando CLRFAULT oder beim Aufruf der Funktion „Fehler löschen“.


ASCII Deutsch DRVSTAT2

ASCII - Kommando | DRVSTAT2 |
Syntax Senden | DRVSTAT2 [Data] |
Syntax Empfangen | DRVSTAT2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 375B (hex)
DIM | - | PROFIBUS PNU | 1803 (dec) IND = 17 (dec)
Bereich | - | DPR | 603 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | interne Status Information

Beschreibung

Das ASCII Kommando DRVSTAT2 ergänzt das Kommando DRVSTAT und gibt intere Status Information in Form einer Bit-Variablen wieder
Bit | Wertigkeit | Beschreibung
0 | 0x00000001 | Ergebnis der VINPOS Funktion Solange eine Differenz zwischen der letzten Zielgeschwindigkeit VCMD und der aktuellen Gerschwindigkeit V innerhalb der Breite des VINPOS -Fensters ist, wird eine 1 ausgegeben, sonst eine 0. Das Signal wechselt nicht, bevor der neue Zustand für eine Zeit INPT0 msec anstand.
1 | 0x00000002 | =1 Slave ist mit dem Master synchronisiert Slave und Master synchronisiert Diese Funktion ist nur bei folgenden Einstellungen möglich: INxMODE=42,43,51,53 or ENGAGE>0


ASCII Deutsch DUMP

ASCII - Kommando | DUMP |
Syntax Senden | DUMP |
Syntax Empfangen | DUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Auflistung aller EEPROM-Variablen

Beschreibung

Das Kommando liefert eine Liste aller im seriellen EEPROM abspeicherbaren Parameter mit den aktuellen Werten. Alle Parameter, die verstärkerspezifisch sind (z.B. A/D-Offsetwerte) fangen mit einem ";" (Semikolon) an.


ASCII Deutsch DUMPEMAP

ASCII - Kommando | DUMPEMAP |
Syntax Senden | DUMPEMAP [Data] |
Syntax Empfangen | DUMPEMAP <Data> | Vorhanden in |
Type | -- | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 5.17 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | Fieldbus | EEPROM | Nein
Kurzbeschreibung | Kontrolle des freien Mappings unter EtherCat

Beschreibung

Mit diesem Kommando kann das eingestellte freie Mapping kontrolliert werden.kann.

DUMPEMAP liefert die eingestellten Mappings
DUMPEMAP * liefert eine Liste der mappbaren Objekten

Für das freie Mapping stehen insgesamt 64 Bytes zur Verfügung. Die max. Anzahl der mappbaren Objekte ist: 16 schnelle (250 µsec) + 16 langsame (1 msec) pro Übertragungsrichtung.

Die schnellen zyklischen Werte (Receive) werden nur im CAN-Zustand „Operation enable“ Verarbeitet (Kontrollwort 0xf).

S700: ab FW 5.17


ASCII Deutsch DUMPSLNO

ASCII - Kommando | DUMPSLNO |
Syntax Senden | DUMPSLNO [Data] |
Syntax Empfangen | DUMPSLNO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 35FA (hex)
DIM |  | PROFIBUS PNU | 1850 (dec) IND = 1 (dec)
Bereich | write 0 read 0 ... Integer16 | DPR | 250 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Auflistung der numerischen EEProm-Variablen

Beschreibung

Mit dem Kommando DUMPSLNO kann sequentiell eine Liste der Objektnummern der im EEProm gespeicherten numerischen Parameter angefordert werden. Die Parameter sind dabei so angeordnet, wie sie auch im Parameterfile des GUIs angeordnet sind, die Prioritäten der Parameter werden also berücksichtigt.

Mit „DUMPSLNO 0“ wird die Liste wieder zurückgesetzt.

Das Kommando kann verwendet werden um alle relevanten Parameter zum Speichern und Laden einer Parameterliste zu erhalten.

Beispiel:

-->DUMPSLNO

343 ; FW command

-->DUMPSLNO

194 ; PBALRES command

-->DUMPSLNO

209 ; PRBASE command

Am Ende der Liste erscheint eine 0.


ASCII Deutsch ECATCSA

ASCII - Kommando | ECATCSA |
Syntax Senden | ECATCSA [Data] |
Syntax Empfangen | ECATCSA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 65535 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.65 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | speichert die "Configured Station Alias" Addresse

Beschreibung

Mit dem Parameter ECATCSA wird die "Configured Station Alias" Addresse für den EtherCAT Feldbus gespeichert.


ASCII Deutsch EGEARI

ASCII - Kommando | EGEARI |
Syntax Senden | EGEARI [Data] |
Syntax Empfangen | EGEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 350D (hex)
DIM | - | PROFIBUS PNU | 1613 (dec) IND = 1 (dec)
Bereich | 1 ... long Integer | DPR | 13 (dec)
Default | 1 |
Opmode | 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Getriebefaktor externen Lagegeber

Beschreibung

Bei Positionierung auf einen externen Lagegeber kann mit den Parametern EGEARI und EGEARO das Übersetzungsverhältnis
eingestellt werden. Bei EGEARI-Umdrehungen des Gebers macht der Motor EGEARO Umdrehungen.

Diese Einstellung wirkt sich ausschließlich auf die Generierung des Drehzahl-Sollwertes aus.
Sie hat keinen Einfluß auf die erfasste bzw. emulierte Position (ROD/SSI).


ASCII Deutsch EGEARO

ASCII - Kommando | EGEARO |
Syntax Senden | EGEARO [Data] |
Syntax Empfangen | EGEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 350E (hex)
DIM | - | PROFIBUS PNU | 1614 (dec) IND = 1 (dec)
Bereich | 0 ... Long Integer | DPR | 14 (dec)
Default | 1 |
Opmode | 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Getriebefaktor externen Lagegeber

Beschreibung

Bei Positionierung auf einen externen Lagegeber kann mit den Parametern EGEARI und EGEARO das Übersetzungsverhältnis eingestellt werden. Bei EGEARI-Umdrehungen des Gebers macht der Motor EGEARO Umdrehungen.

Diese Einstellung wirkt sich ausschließlich auf die Generierung des Drehzahl-Sollwertes aus.
Sie hat keinen Einfluß auf die erfasste bzw. emulierte Position (ROD/SSI).


ASCII Deutsch EMRGTO

ASCII - Kommando | EMRGTO |
Syntax Senden | EMRGTO [Data] |
Syntax Empfangen | EMRGTO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36DC (hex)
DIM | - | PROFIBUS PNU | 1676 (dec) IND = 17 (dec)
Bereich | 0 ... 2147483647 | DPR | 476 (dec)
Default | 5000 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | definiert die Abschaltzeit im Fehlerfall

Beschreibung

EMRGTO definiert die Fehlerfall Zeit bei der einstellung ACTFAULT=1 and STOPMODE=1.

Nachdem die ACTFAULT (Regler Fehler) oder STOPMODE (Enstufen) Bedingungen erfüllt sind, versucht der Regler die Achse auf Geschwindiglkeit 0 abzubremsen. Ist dies nicht möglich, so wird die Endstufe spätestens nach der mit EMRGTO eingestellten Zeit gesperrt. Der Fehler F30 wird angezeigt.

EMRGTO = 0 F30 Fehlerüberwachung ist ausgeschaltet.

ab FW 0.80

Falls innerhalb von 25 % der EMRGTO Zeit die Geschwindigkeit nicht um 1 / 8 reduziert werden konnte, wird der Fehler F30 generiert.
This is because the default of 5 seconds could be very long if for what ever reason no speed deceleration is done.

EMRGTO kann nur auf Werte = 0 oder >= 10 eingestellt werden.


ASCII Deutsch EN

ASCII - Kommando | EN |
Syntax Senden | EN |
Syntax Empfangen | EN | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3530 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 1 (dec)
Bereich | - | DPR | 48 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Setzen des Software-Enable

Beschreibung

Mit dem Kommando EN wird die Software-Freigabe für die Endstufe gesetzt.
Wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen), so ist die Endstufe freigegeben.
Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die Leistungsspannung eingeschaltet wurde und die Ladeschaltung den Zwischenkreis aufgeladen hat. Wenn die Leistungsspannung bei enabletem Gerät weggeschaltet wird, so bleibt das Gerät enabled, bis die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet.


ASCII Deutsch EN22A1CNT

ASCII - Kommando | EN22A1CNT |
Syntax Senden | EN22A1CNT |
Syntax Empfangen | EN22A1CNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 390D (hex)
DIM | - | PROFIBUS PNU | 1837 (dec) IND = 33 (dec)
Bereich | 0 .. 65535 | DPR | 1037 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat2.2 Status der Zusatzinformationen 1

Beschreibung

Bei diesem Parameter handelt es sich um eine Bit-Variable. Bei gesetztem Bit ist die zugehörige Zusatzinformation 1 verfügbar. Falls das Bit gelöscht ist, so wird die zugehörige Information von dem ENDAT2.2-Geber nicht unterstützt.

Die einzelnen Bits sind folgenden Informationen zugeordnet:

Bit 0 – Positionswert 2
Bit 1 – Testwert
Bit 2 – Temperaturfühler 1 (extern)
Bit 3 – Temperaturfühler 2 (on board)
Bit 4 – weitere Sensoren
Bit 5…15 frei


ASCII Deutsch EN22A2CNT

ASCII - Kommando | EN22A2CNT |
Syntax Senden | EN22A2CNT |
Syntax Empfangen | EN22A2CNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 390E (hex)
DIM | - | PROFIBUS PNU | 1838 (dec) IND = 33 (dec)
Bereich | 0 .. 65535 | DPR | 1038 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat2.2 Status der Zusatzinformationen 2

Beschreibung

Bei diesem Parameter handelt es sich um eine Bit-Variable. Bei gesetztem Bit ist die zugehörige Zusatzinformation 2 verfügbar. Falls das Bit gelöscht ist, so wird die zugehörige Information von dem ENDAT2.2-Geber nicht unterstützt.

Die einzelnen Bits sind folgenden Informationen zugeordnet:

Bit 0 – Kommutierung
Bit 1 – Beschleunigung
Bit 2 – Grenzlagensignal
Bit 3 – asynchroner Positionswert
Bit 4 – Betriebszustandfehlerquellen
Bit 5 – reserviert
Bit 6 – Positionswert 2
Bit 7 – Zeitstempel
Bit 8…15 frei


ASCII Deutsch EN22AI1

ASCII - Kommando | EN22AI1 |
Syntax Senden | EN22AI1 |
Syntax Empfangen | EN22AI1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | 16 x Integer16 | CANBus Objektnummer | 2055 (hex)
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 65535 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | 16 x Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat2.2 akt. Werte der Zusatzinformationen 1

Beschreibung

Das Kommando EN22AI1 liefert 16 Zahlen (getrennt durch <Leerzeichen>), die den 16 Zusatzinformationen 1 zugeordnet sind. Für die Zusatzinformationen, die von dem Geber nicht unterstützt werden, wird der Wert 0 übertragen. Mit Hilfe des Parameters EN22A1CNT, können die gültigen Zusatzinformationen extrahiert werden.

ab FW>=6.05 kann dieser Parameter über eine SDO-Objektnr. via CAN/EtherCAT abgefragt werden.


ASCII Deutsch EN22AI2

ASCII - Kommando | EN22AI2 |
Syntax Senden | EN22AI2 |
Syntax Empfangen | EN22AI2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | 16 x Integer16 | CANBus Objektnummer | 2056 (hex)
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 65535 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | 16 x Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat 2.2 akt. Werte der Zusatzinformationen 2

Beschreibung

Das Kommando EN22AI2 liefert 16 Zahlen (getrennt durch <Leerzeichen>), die den 16 Zusatzinformationen 2 zugeordnet sind. Für die Zusatzinformationen, die von dem Geber nicht unterstützt werden, wird der Wert 0 übertragen. Mit Hilfe des Parameters EN22A2CNT, können die gültigen Zusatzinformationen extrahiert werden.

ab FW>=6.05 kann dieser Parameter über eine SDO-Objektnr. via CAN/EtherCAT abgefragt werden.


ASCII Deutsch EN22CNFG

ASCII - Kommando | EN22CNFG |
Syntax Senden | EN22CNFG [Data] |
Syntax Empfangen | EN22CNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 390F (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 33 (dec)
Bereich | 0 .. 3 | DPR | 1039 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Konfig.parameter für ENDAT2.2-Zusatzinformationen

Beschreibung

Bei diesem Parameter handelt es sich um eine Bit-Variable. Das Setzen eines Bits aktiviert das Einlesen der zugehörigen ENDAT2.2-Zusatzinformationen.

Bit 0 = 1 Einlesen der Diagnoseinformationen (Bewertungszahlen)
Bit 1 = 1 Einlesen der Zusatzinformationen 1
Bit 2 = 1 Einlesen der Zusatzinformationen 2

Das Setzen eines Bits auf 0 sperrt das Einlesen der zugehörigen Zusatzinformationen


ASCII Deutsch EN22DCNT

ASCII - Kommando | EN22DCNT |
Syntax Senden | EN22DCNT |
Syntax Empfangen | EN22DCNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3910 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 33 (dec)
Bereich | 0 .. 65535 | DPR | 1040 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat2.2 Status der Diagnoseinformationen

Beschreibung

Bei diesem Parameter handelt es sich um eine Bit-Variable. Bei gesetztem Bit ist die zugehörige Diagnoseinformation verfügbar. Falls das Bit gelöscht ist, so wird die zugehörige Information von dem ENDAT2.2-Geber nicht unterstützt.

Die einzelnen Bits sind folgenden Informationen zugeordnet:

Bit 0 – Bewertungszahl 1
Bit 1 – Bewertungszahl 2
Bit 2 – Bewertungszahl 3
Bit 3 – Bewertungszahl 4
Bit 4 – Bewertungszahl 5
Bit 5 – Bewertungszahl 6
Bit 6…14 frei
Bit 15 – systemspezifische Daten


ASCII Deutsch EN22DIAG

ASCII - Kommando | EN22DIAG |
Syntax Senden | EN22DIAG |
Syntax Empfangen | EN22DIAG <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | 16 x Integer16 | CANBus Objektnummer | 2054 (hex)
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 65535 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | 16 x Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Endat2.2 aktuellen Werte der Diagnoseinformationen

Beschreibung

Das Kommando EN22DIAG liefert 16 Zahlen (getrennt durch <Leerzeichen>), die den 16 Diagnoseinformationen zugeordnet sind. Für die Diagnoseinformationen, die von dem Geber nicht unterstützt werden, wird der Wert 0 übertragen. Mit Hilfe des Parameters EN22DCNT, können die gültigen Diagnosewerte extrahiert werden.

ab FW>=6.05 kann dieser Parameter über eine SDO-Objektnr. via CAN/EtherCAT abgefragt werden.


ASCII Deutsch ENCDIV

ASCII - Kommando | ENCDIV |
Syntax Senden | ENCDIV [Data] |
Syntax Empfangen | ENCDIV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 38D6 (hex)
DIM |  | PROFIBUS PNU | 1782 (dec) IND = 33 (dec)
Bereich |  | DPR | 982 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.87 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Divisor für die Nachkommastellen von ENCLINES

Beschreibung

Die Parameter ENCFIX/ENCDIV definieren die Nachkommastellen für den Parameter ENCLINES.
Damit werden auch Linearmotoren unterstützt, die keine ganzzahlige Anzahl von Sinus-Perioden pro Polpitch aufweisen. Die Nachkommastellen werden als Divisor/Dividend vorgegeben.

Beispiel 1: Bei 2048.45 Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCLINES 2048
ENCFIX 45
ENCDIV 100

Beispiel 2: Bei 1000.33333(3) Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCLINES 1000
ENCFIX 1
ENCDIV 3


ASCII Deutsch ENCDIVD

ASCII - Kommando | ENCDIVD |
Syntax Senden | ENCDIVD [Data] |
Syntax Empfangen | ENCDIVD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3909 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 33 (dec)
Bereich | 1 ... 2147483647 | DPR | 1033 (dec)
Default | 100000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.87 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Divisor für die Nachkommastellen von ENCIN

Beschreibung

Die Parameter ENCFIXD/ENCDIVD definieren die Nachkommastellen für den Parameter ENCIN. Damit werden auch Linearmotoren unterstützt, die keine ganzzahlige Anzahl von Sinus-Perioden pro Polpitch aufweisen.

Die Nachkommastellen werden als Divisor/Dividend vorgegeben.

Beispiel 1: Bei 2048.45 Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCIN 2048
ENCFIXD 45
ENCDIVD 100

Beispiel 2: Bei 1000.33333(3) Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCIN 1000
ENCFIXD 1
ENCDIVD 3


ASCII Deutsch ENCFIX

ASCII - Kommando | ENCFIX |
Syntax Senden | ENCFIX [Data] |
Syntax Empfangen | ENCFIX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 38D3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 33 (dec)
Bereich | 0 .. 2147483647 | DPR | 979 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.86 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Nachkommastellen für den ENCLINES-Parameters

Beschreibung

Die Parameter ENCFIX/ENCDIV definieren die Nachkommastellen für den Parameter ENCLINES. Damit werden auch Linearmotoren unterstützt, die keine ganzzahlige Anzahl von Sinus-Perioden pro Polpitch aufweisen.

Die Nachkommastellen werden als Divisor/Dividend vorgegeben.

Beispiel 1: Bei 2048.45 Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCLINES 2048
ENCFIX 45
ENCDIV 100

Beispiel 2: Bei 1000.33333(3) Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCLINES 1000
ENCFIX 1
ENCDIV 3


ASCII Deutsch ENCFIXD

ASCII - Kommando | ENCFIXD |
Syntax Senden | ENCFIX [Data] |
Syntax Empfangen | ENCFIXD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 390A (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 33 (dec)
Bereich | 0 .. 2147483647 | DPR | 1034 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.86 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Nachkommastellen für den ENCIN-Parameters

Beschreibung

Die Parameter ENCFIXD/ENCDIVD definieren die Nachkommastellen für den Parameter ENCIN. Damit werden auch Linearmotoren unterstützt, die keine ganzzahlige Anzahl von Sinus-Perioden pro Polpitch aufweisen.

Die Nachkommastellen werden als Divisor/Dividend vorgegeben.

Beispiel 1: Bei 2048.45 Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCIN 2048
ENCFIXD 45
ENCDIVD 100

Beispiel 2: Bei 1000.33333(3) Perioden pro Polpitch werden folgende Einstellungen notwendig:
ENCIN 1000
ENCFIXD 1
ENCDIVD 3


ASCII Deutsch ENCIN

ASCII - Kommando | ENCIN |
Syntax Senden | ENCIN [Data] |
Syntax Empfangen | ENCIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3532 (hex)
DIM | - | PROFIBUS PNU | 1650 (dec) IND = 1 (dec)
Bereich | 16 ... 8388608 | DPR | 50 (dec)
Default | 1024 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 0.87 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Auflösung digitales Messsystem

Beschreibung

Die Auflösung (Anzahl der Rechteck Pulse) eines Impulsgeber wird mit der Variablen ENCIN eingestellt.
Beim rotatorischen Motor ist das die Impulsanzahl pro Motorumdrehung, beim Linearmotor die Impulsanzahl pro Motorpolpaarbreite.

Dieser Parameter wird in Kombination mit EXTPOS = 1 ... 4 oder FBTYPE=12…19 genutzt.

FW >= 2.17
Max.Wert für ENCIN = 8 388 608


ASCII Deutsch ENCLINES

ASCII - Kommando | ENCLINES |
Syntax Senden | ENCLINES [Data] |
Syntax Empfangen | ENCLINES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer24 | CANBus Objektnummer | 3533 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 1 (dec)
Bereich | 65535 | DPR | 51 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | Integer24
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Auflösung eines SinCos-Gebers

Beschreibung

ENCLINES beschreibt die Auflösung (ohne Vierfachauswertung) des Sinus-Cosinus-Encoders, wenn dieser als Standardrückführung verwendet wird. Bei rotierenden Motoren ist die Strichzahl pro Umdrehung anzugeben, bei Linearmotoren wird die Anzahl der Striche pro Polteilung angegeben. Wird ein ENDAT oder Hiperface Geber benutzt, so wird die Strichzahl automatisch beim Initialisieren gesetzt.

Beispiel zur Einstellung von ENCLINES beim Linearmotor >>>> 1

Falls ein externer Geber zur Lageerfassung genutzt wird, beziehen sich die ENCLINES auf dieses Meßsystem.

Bei EnDat-Lineargeber werden ENCLINES nicht im Geber abgespeichert und dadurch automaisch gesetzt.


ASCII Deutsch ENCMODE

ASCII - Kommando | ENCMODE |
Syntax Senden | ENCMODE [Data] |
Syntax Empfangen | ENCMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3534 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 1 (dec)
Bereich | 0..13 | DPR | 52 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | encoder emulation | EEPROM | Ja
Kurzbeschreibung | Auswahl der Encoder-Emulation

Beschreibung

Zustand | Schnittstelle | Beschreibung
ENCMODE=0 | X5 - (Eingang) | Encoder-Emulation abgeschaltet - X5 wirkt als Eingang
ENCMODE=1 | X5 - ROD (Ausgang) | ROD-Ausgabe (RS 422) Auflösung = ENCOUT pro Motorumdrehung (rotativer Motor). Auflösung = ENCOUT pro Motor Polpaarbreite (Linear Motor). Besonderheit: Die ROD-Emulation bezieht sich auf je ein Polpaar des Resolvers, d.h. bei einem 6-poligen Resolver werden 3x ENCOUT pro Geberumdrehung ausgegeben.
ENCMODE=2 | X5 - SSI (Ausgang) | SSI-Ausgabe kann auch als SSI-Eingang benutzt werden siehe auch GEARMODE=7 SSIREVOL
ENCMODE=3 | X5 - ROD (Ausgang) | ROD-Interpolation Ausgabe Diese Einstellung ist nur bei einem SINCOS-Motor möglich (FBTYPE>0). Bei der ROD-Interpolation werden pro Motorumdrehung ENCOUT*ENCLINES Impulse ausgegeben. Bei ENCMODE=3 sind folgende ENCOUT-Einstellungen möglich: 4,8,16,32,64,128
ENCMODE=4 | X5 - SSI (Ausgang) | Ausgabe der Lageregler-Sollposition über der SSI-Schnittstelle. Die Position wird im Format 16/16 ausgegeben (16 Bit/Umdrehung + 16 Bit für die Anzahl der Umdrehungen). siehe auch SSIREVOL
ENCMODE=5 | X5 - SSI (Ausgang) | Ausgabe der Lageregler-Istposition über der SSI-Schnittstelle. Die Position wird im Format 16/16 ausgegeben (16 Bit/Umdrehung + 16 Bit für die Anzahl der Umdrehungen).
ENCMODE=6 | - | reserviert
ENCMODE=7 | - | reserviert
ENCMODE=8 | - | reserviert
ENCMODE=9 | X1 - ROD (Ausgang) | ROD-Ausgabe über X1 (Emulation) ähnlich wie ENCMODE=1
ENCMODE=10 | X1 - SSI (Ausgang) | SSI-Ausgabe über X1 (Emulation) ähnlich wie ENCMODE=2 siehe auch SSIREVOL
ENCMODE=11 | - | reserviert
ENCMODE=12 | X1 - SSI (Ausgang) | SSI-Ausgabe einer 32Bit-Soll-Position ähnlich wie ENCMODE=4 siehe auch SSIREVOL
ENCMODE=13 | X1 - SSI (Ausgang) | SSI-Ausgabe einer 32Bit-Ist-Position ähnlich wie ENCMODE=5 siehe auch SSIREVOL


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Encoder-Emulation

Diese Funktion ist bei S700 nur mit installierter Erweiterungskarte "PosI/O" oder "PosI/O-Monitor" verfügbar.

Inkrementralgeber

einheiten

Wählen Sie die gewünschte Encoder-Emulation (hier: ROD=Inkrementalgeber).

Bildschirmtext | ASCII-Parameter
Encoder-Emulation | ENCMODE
Auflösung | ENCOUT
Nullimpuls-Offset | ENCZERO

Absolutwertgeber

einheiten1

Wählen Sie die gewünschte Encoder-Emulation (hier SSI).

Bildschirmtext | ASCII-Parameter
Encoder-Emulation | ENCMODE
Übertragungs-Timeout SSI | SSITOUT
Bit-Anzahl (Multi-/Single-Turn) | SSIREVOL
SSI-Codierung | SSIGRAY


ASCII Deutsch ENCOUT

ASCII - Kommando | ENCOUT |
Syntax Senden | ENCOUT [Data] |
Syntax Empfangen | ENCOUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3535 (hex)
DIM | CPR | PROFIBUS PNU | 1653 (dec) IND = 1 (dec)
Bereich | -524288 ... +524288 | DPR | 53 (dec)
Default | 1024 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | encoder emulation | EEPROM | Ja
Kurzbeschreibung | Auflösung für die Encoder-Emulation (ROD)

Beschreibung

Auflösung für der digitalen Encoder-Emulation (ROD)

ENCOUT definiert die Anzahl der Impulse, die bei einer Motorumdrehung oder einem Pole pitch (beim Linearmotor) über die ROD-Schnittstelle ausgegeben werden. Die Ausgabe folgender ENCMODE-Werte erfolgt aus dem FPGA: 32, 64, 128, 256, 512, 1024, 2048, 4096 - alle anderen Werte werden von der Firmware generiert. Ab Firmware 4.94 sind alle Werte zwischen 256 bis 4096 einstellbar (256,257 ....... 4095,4096).

Achtung: Da die Ausgabe per FPGA genauer als die Ausgabe aus der Firmware ist, sollte die oben genannten Werte gegenüber denen aus dem zulässigen Wertebereich vorgezogen werden!

Ab der Version 0.87 ist auch eine negative Eingabe möglich. Die negative Vorgabe bedeutet eine Drehung der Zählrichtung. Bei einer Drehung des Gebers/Resolvers um eine Umdrehung nach rechts, werden ENCOUT Impulse in entgegengesetzte Richtung (also nach links) ausgegeben.

Bei Resolvern mit mehr als 2 Polen gibt es pro Polpaar einen Nullimpuls, z.B. 6 poliger Resolver >> 3 Nullimpulse pro 360° mechanisch.

Der Nullimpuls wird nur bis Auflösungen von max. 4096 counts ausgegeben.

Weiterführende Informationen siehe REFMODE,ENCMODE


ASCII Deutsch ENCTO

ASCII - Kommando | ENCTO |
Syntax Senden | ENCTO [Data] |
Syntax Empfangen | ENCTO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3543 (hex)
DIM | ms | PROFIBUS PNU | 1667 (dec) IND = 1 (dec)
Bereich | 100 .. 12000 | DPR | 67 (dec)
Default | 2000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 0.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Einschaltverzögerung des Encoders

Beschreibung

Parameter ENCTO definiert eine Verzögerungszeit zwischen dem Einschalten der Encoder-Versorgungsspannung und dem Zeitpunkt wann der Encoder-Typenschild ausgelesen wird.


ASCII Deutsch ENCVON

ASCII - Kommando | ENCVON |
Syntax Senden | ENCVON [Data] |
Syntax Empfangen | ENCVON <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3546 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 1 (dec)
Bereich | 0 ... 2 | DPR | 70 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 0.73 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | -
Kurzbeschreibung | Geber-Versorgungsspannung über den Stecker X1

Beschreibung

Mit dem Kommando ENCVON kann die Ausgabe der Geber-Versorgungsspannung über den Stecker X1 aktiviert werden. ENCVON=1 bewirkt die Ausgabe einer 5V-Versorgungsspannug, bei ENCVON=2 werden 12Vausgegeben. Die Ausgabe der externen Versorgungsspannung wird nur dann aktiviert, wenn keine Versorgungsspannung für einen vorgewählten Geber (ENDAT,HIPERFACE über FBTYPE, GEARMODE oder EXTPOS) benötigt wird. Bei Vorwahl eines Gebers hat die, für diesen Geber benötigte Spannung einen Vorrang vor der ENCVON-Einstellung. Eine Ausgabe von 12V (ENCVON=2) ist nur dann möglich, wenn die SENSE-Leitung nicht verdrahtet ist.


ASCII Deutsch ENCZERO

ASCII - Kommando | ENCZERO |
Syntax Senden | ENCZERO [Data] |
Syntax Empfangen | ENCZERO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3537 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 1 (dec)
Bereich | 0 .. ENCOUT-1 | DPR | 55 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | encoder emulation | EEPROM | Ja
Kurzbeschreibung | Nullimpulsoffset (ROD-Ausgabe)

Beschreibung

Mit Hilfe des Kommandos ENCZERO kann die Ausgabe des ROD-Nullimpulses innerhalb einer Umdrehung verschoben werden. Die Verschiebung erfolgt im Uhrzeigersinn z.B.
ENCOUT 1024
ENCZERO 256 Der Nullimpuls wird bei 90 Grad ausgegeben.

Wirkt auch bei SSI - Ausgabe.


ASCII Deutsch ENGAGE

ASCII - Kommando | ENGAGE |
Syntax Senden | ENGAGE [Data] |
Syntax Empfangen | ENGAGE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CD (hex)
DIM |  | PROFIBUS PNU | 1653 (dec) IND = 17 (dec)
Bereich | 0...8 | DPR | 461 (dec)
Default | 0 |
Opmode | 4 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.38 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Ein-/Ausschalten des Master/Slave-Betriebes

Beschreibung

Mit dem Kommando ENGAGE kann die Funktionalität für das Ein-/Ausschalten des Master/Slave-Betriebes (Aufsynchronisieren) aktiviert werden.

ENGAGE=0 Master/Slave-Betrieb aktiv sobald OPMODE=4

ENGAGE=1 Master/Slave-Betrieb aktiv wenn OPMODE=4 und Synchronisationskommando ENGEDGE vorgegeben wurde.

Bei ENGAGE=1 ist nach dem Einschalten des Verstärkers der Master/Slave-Betrieb
Zunächst inaktiv (ENGEDGE=0).
Um den Master/Slave-Betrieb zu aktivieren muß über die interne Variable ENGEDGE
Ein Aufsynchronisierkommando vorgegeben werden. Dies geschieht üblicherweise über ein Feldbus-Interface, das interne PLC-Programm bzw. mit dem Kommando M ENGEDGE.

Die Synchronisationsvariable ENGEDGE kann folgende Werte enthalten:

ENGEDGE=0 keine Synchronisation,
Master/Slave nicht aktiv, Slave hält die aktuelle Position

ENGEDGE=1 Aufsynchronisieren über die Geschwindigkeit.
Der Slave beschleunigt auf die Geschwindigkeit des Masters mit der Rampe ACCR. Nachdem die Geschwindigkeit des Masters erreicht wurde, wird ENGEDGE automatisch auf 5 gesetzt (Fahren synchron zum Master). Diese Funktion wird auch dann aktiviert wenn eine steigende Flanke an einem mit z.B.IN3MODE=42 konfigurierten Eingang erkannt wurde.

ENGEDGE=2 Auskoppeln,
der Slave leitet die Bremsphase ein mit einer konstanten Bremsrampe DECR. Nachdem der Stillstand erreicht wurde, wird ENGEDGE automatisch auf 0 gesetzt (Slave im Stillstand). Diese Funktion wird auch dann aktiviert, wenn eine fallende Flanke an einem mit z.B. INxMODE=42,43,51 konfigurierten Eingang erkannt wurde.

ENGEDGE=3 Aufsynchronisieren über die Geschwindigkeit mit Wegdifferenzausgleich.

Beim Setzen dieses Wertes wird die Position des Masters intern gelatcht. Anschliessend beschleunigt der Slave auf die Geschwindigkeit des Masters mit der Rampe ACCR. Nachdem die Geschwindigkeit des Masters erreicht wurde, wird ENGEDGE automatisch auf 4 gesetzt (Wegausgleich) und über die Erhöhung der Geschwindigkeit die Wegdifferenz zwischen der aktuellen und der gelatchten Masterposition ausgeglichen. Nachdem Der Wegausgleich abgeschlossen wurde, wird die Variable ENGEDGE automatisch auf 5 gesetzt (Fahren synchron zum Master). Diese Funktion wird auch dann aktiviert wenn eine steigende Flanke an einem mit z.B. IN3MODE=43 konfigurierten Eingang erkannt wurde.

ENGEDGE=4 interne Verwendung

ENGEDGE=5 Slave läuft synchron zum Master.
Dieser Wert spiegelt nur den internen Zustand der Master/Slave-Statusmaschine wieder und nicht den tatsächlichen Zustand der Synchronität (Schleppfehler).

ENGEDGE=6 Aufsynchronisieren über Position mit konstanter Beschleunigung (linear).
Der Slave beschleunigt auf Die Geschwindigkeit des Masters innerhalb einer bestimmten Strecke. In der Variable M IN51MERK wird die Verfahrstrecke eingetragen innerhalb welcher die Geschwindigkeit des Masters erreicht werden soll. Die Strecke bezieht sich auf den Slave und wird in Counts (20 Bit/Umdrehung => 2^20) eingegeben. Nachdem die Position und Geschwindigkeit des Masters erreicht wurden, wird ENGEDGE automatisch auf 5 gesetzt (Fahren synchron zum Master). Diese Funktion wird auch dann aktiviert, wenn eine steigende Flanke an einem mit z.B. IN3MODE=51 konfigurierten Eingang erkannt wurde.

ENGEDGE=7 Aufsynchronisieren über Position mit kundenspezifischen Profil.

Der Slave beschleunigt auf Die Geschwindigkeit des Masters innerhalb einer bestimmten Strecke. In der Variable M IN51MERK wird die Verfahrstrecke eingetragen innerhalb welcher die Geschwindigkeit des Masters erreicht werden soll. Die Strecke bezieht sich auf den Slave und wird in Counts (20 Bit/Umdrehung => 2^20) eingegeben. Das Profil mit dem das Aufsynchronisieren erfolgt, wird der ersten Lookup-Tabelle entnommen (sinus2 im Falle der Standard-Tabelle).
Nachdem die Position und Geschwindigkeit des Masters erreicht wurden, wird ENGEDGE automatisch auf 5 gesetzt (Fahren synchron zum Master). Diese Funktion wird auch dann aktiviert, wenn eine steigende Flanke an einem mit z.B. IN3MODE=53 konfigurierten Eingang erkannt wurde.

ENGEDGE=8..11 reserviert

ENGEDGE=12 Auskoppeln, Bremsphase über kundenspezifisches Profil.
Das Profil mit dem das Auskoppeln erfolgt, wird der ersten Lookup-Tabelle entnommen (sinus2 im Falle der Standard-Tabelle).
Nachdem der Stillstand erreicht wurde, wird ENGEDGE automatisch auf 0 gesetzt (Slave im Stillstand).
Diese Funktion wird auch dann aktiviert, wenn eine fallende Flanke an einem mit INxMODE=53 konfigurierten Eingang erkannt wurde


ASCII Deutsch ERESMASK

ASCII - Kommando | ERESMASK |
Syntax Senden | ERESMASK [Data] |
Syntax Empfangen | ERESMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3755 (hex)
DIM | - | PROFIBUS PNU | 1797 (dec) IND = 17 (dec)
Bereich |  | DPR | 597 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 0.86 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Fehlerrücksetzverhalten

Beschreibung

Das Kommando ERESMASK beschreibt das Verhalten des Verstärkers beim Quittieren eines anstehenden Verstärkerfehlers. Bei gesetztem Bit xx, wird beim Quittieren des Fehlers Fxx+1 der Verstärker hardwaremäßig resettiert. Wenn das Bit nicht gesetzt ist, so wird der Fehler softwaremäßig gelöscht (kein Hardware-Reset nötig).
s. auch Beschreibung von ERRCODE


ASCII Deutsch ERND

ASCII - Kommando | ERND |
Syntax Senden | ERND [Data] |
Syntax Empfangen | ERND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3638 (hex)
DIM | - | PROFIBUS PNU | 1912 (dec) IND = 1 (dec)
Bereich | - | DPR | 312 (dec)
Default | 2^31-1 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Endposition Modulo-Achse

Beschreibung

Mit dem Parameter ERND wird das Ende des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Der Anfang des Bereiches kann mit dem Kommando SRND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für ERND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI,PGEARO).


ASCII Deutsch ERRCNFG

ASCII - Kommando | ERRCNFG |
Syntax Senden | ERRCNFG [Data] |
Syntax Empfangen | ERRCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3884 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 33 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 900 (dec)
Default | 83894274 (0x50002002) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Verhalten des Verstärkers im Fehlerfall

Beschreibung

Das Kommando ERRCNFG definiert das Verhalten des Verstärkers im Falle eines Fehlers Fxx.
Bei gesetztem Bit xx, wird im Falle des Fehlers Fxx+1 die Endstufe sofort gesperrt. Dies funktioniert unabhängig von der Einstellung des Parameters ACTFAULT.

Beispiel:

Der Default-Wert 83894274 (-> 0x0500 2002) sorgt für sofortiges Sperren der Endstufe beim Auftreten von einem oder mehreren der folgenden Fehler:
F02 Fehler Überspannung
F14 Fehler Endstufe
F25 Kommutierungsfehler (Durchgehen des Motors)
F27 Fehler „-AS-Option“

Bei manchen kritischen Fehlern wird die Endstufe sofort gesperrt. Dieses Verhalten kann durch das Setzen des ERRCNFG-Bits auf 0 nicht verändert werden.

siehe auch Beschreibung ERRCODE, ERRCODE *


ASCII Deutsch ERRCODE

ASCII - Kommando | ERRCODE |
Syntax Senden | ERRCODE |
Syntax Empfangen | ERRCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Ausgabe der aktiven Fehlermeldungen

Beschreibung

Das Kommando ERRCODE liefert die Information über aktuell anstehende Fehler im Klartext.

Siehe auch ERRCODE *


ASCII Deutsch ERRCODE2

ASCII - Kommando | ERRCODE2 |
Syntax Senden | ERRCODE2 |
Syntax Empfangen | ERRCODE2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3862 (hex)
DIM | - | PROFIBUS PNU | 1666 (dec) IND = 33 (dec)
Bereich | 0..55 | DPR | 866 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Fehlercode Zusatzinformation

Beschreibung

Falls ERRCODE !=0 ist gibt das ASCII Kommando ERRCODE2 ggf. zusätzliche Informaionen. Im Display wird ein i mit der Nnummer von ERRCODE2 ausgegeben.
Zustand | Fehler | Beschreibung
ERRCODE2 = 0 | - | keine zusätzliche Information
ERRCODE2 = 1 | F32 | System-Fehler Software-WatchDog
ERRCODE2 = 2 | F32 | System-Fehler falsche Reihenfolge in der Kommandotabelle
ERRCODE2 = 3 | F32 | System-Fehler Makro-Uebersetzungsfehler
ERRCODE2 = 4 | - | reserviert
ERRCODE2 = 5 | F25 | Kommutierungsfehler Geschwindigkeitsüberwachung
ERRCODE2 = 6 | F25 | Kommutierungsfehler: Stromüberwachung
ERRCODE2 = 7 | F25 | Kommutierungsfehler: fehlerhaftes Hall-Segment
ERRCODE2 = 8 | F25 | Kommutierungsfehler: W&S Schleppfehler
ERRCODE2 = 9 | F25 | Kommutierungsfehler: W&S zu grosse Auslenkung
ERRCODE2 = 10 | F25 | Kommutierungsfehler: W&S zu wenig Auslenkung
ERRCODE2 = 11 | F25 | Kommutierungsfehler: W&S IQ zu gross
ERRCODE2 = 12 | F25 | Kommutierungsfehler: W&S falscher Mittelwert
ERRCODE2 = 13 | F07 | Gate-Spannung fehlt (interner Hardware-Fehler)
ERRCODE2 = 14 | F07 | 15V-Versorgungsspannung fehlt (interner Hardware Fehler)
ERRCODE2 = 15 | F32 | diese Firmware ist nicht geeignet für die eingesetzte Slot-Karte
ERRCODE2 = 16 | F04 | Fehler beim Lesen der BISS-Position im Registermode
ERRCODE2 = 17 | - | reserviert
ERRCODE2 = 18 | F04 | BISS-Kommunicationsfehler
ERRCODE2 = 19 | - | reserviert
ERRCODE2 = 20 | F25 | Sinus/Cosinus-Amplitude zu gross
ERRCODE2 = 21 | F07 | 15V Versorgungsspannung fehlt (748/772)
ERRCODE2 = 22 | F04 | Das Einlesen der Encoder-Daten (lansamer Zugriff) war nicht möglich (Kommunikationsproblem zum Encoder)
ERRCODE2 = 23 | F04 | Das Einlesen der Encoder-Daten (schneller Zugriff) war nicht möglich (Kommunikationsproblem zum Encoder)
ERRCODE2 = 24 | - | reserviert
ERRCODE2 = 25 | F20 | Einlesen der Daten von der POSIO-Karte war nicht möglich siehe CALCPOSIO
ERRCODE2 = 26 | - | reserviert
ERRCODE2 = 27 | F32 | fehlerhafte Flash-Daten (Endstufenkennung)
ERRCODE2 = 28 | F04 | Ermittlung der FRAME-Laenge bei Biss_C fehlgeschlagen
ERRCODE2 = 29 | F29 | Die eingesteckte Optionskarte passt nicht mit der Software des Antriebs zusammen.
ERRCODE2 = 30 | F29 | Die eingesteckte Optionskarte versucht den Antrieb zu enablen obwohl das Hardware enable Signal fehlt oder die Busspanung zu niedrig ist.
ERRCODE2 = 31 | F29 | Das Hardware enable Signal wurde zurück genommen während die Optionskarte sich im Betrieb befindet und den Antrieb enabled hat. Hardware enable Signal fehlt oder die Busspanung zu niedrig ist.
ERRCODE2 = 32 | F29 | Der Antrieb war nicht in der Lage sich während des Phasenhochlaufs mit der Optionskarte zu synchronisieren bzw. die Synchronisation ging im laufenden Betrieb verloren.
ERRCODE2 = 33 | F29 | Die Optionskarte forder per Kontrollwort ein CLRFAULT Kommando an während ein Fehler anliegt, welcher einen Software Reset nach sich zieht. Dieser Fehler wird nur bei bestimmten DPR-Karten generiert und erfordert eine Freischaltung via dem Kommando SERCSET.
ERRCODE2 = 34 | F29 | Der EtherCAT master fordert einen Statuswechsel von Operational in einen anderen Zustand an, obwohl sich der Servoverstärker in einem eingeschalteten Zustand (Software enable = true) befindet. Falls die beiden Fehler F28/F29 anstehen wurde unter EtherCAT die Synchronisation verloren.
ERRCODE2 = 35 | F29 | Die vom EtherCAT Master per SDO übertragene Sollwert-Mapping Nummer ist dem Antrieb nicht bekannt.
ERRCODE2 = 36 | F29 | Die vom EtherCAT Master per SDO übertragene Istwert-Mapping Nummer ist dem Antrieb nicht bekannt.
ERRCODE2 = 37 | F29 | Die vom EtherCAT Master angenommene Länge des Sollwert-Mappings stimmt nicht mit der angenommenen Länge des Antriebs überein.
ERRCODE2 = 38 | F29 | Die vom EtherCAT Master angenommene Länge des Istwert-Mappings stimmt nicht mit der angenommenen Länge des Antriebs überein.
ERRCODE2 = 39 | F29 | Die eingesteckte Optionskarte zeigt einen Kartenfehler oder Netzwerkfehler an. Diese Statusmeldung wird nur von bestimmten Optionskarten generiert.
ERRCODE2 = 40 | F29 | Der SynqNet Master hat eine ungueltige Einstellung für die Auflösung der Geschwindigkeiten gewählt.
ERRCODE2 = 41 | F29 | Die vom Sercos Master eingestellte Betriebsart stimmt nicht mit dem im Antrieb eingestellten überein (OPMODE).
ERRCODE2 = 42 | F29 | Die Sercos Interrupt Funktion hat einen Kabelbruch erkannt.
ERRCODE2 = 43 | F29 | Der Servoverstärker hat den Ausfall von Sercos MSTs (Master Synchronization Telegram) erkannt.
ERRCODE2 = 44 | F29 | Der Servoverstärker hat einen unbekannten/ungültigen Sercos Interrupt Typen erkannt.
ERRCODE2 = 45 | F29 | Der Servoverstärker hat einen Sercos ASIC mit unbekannter/ungültiger Versionsnummer erkannt.
ERRCODE2 = 46 | F29 | Der Servoverstärker hat im Objekt IDN14 einen Fehlerzustand erkannt.
ERRCODE2 = 47 | F29 | Die FireWire Optionskarte hat den Watchdog Counter im DPR nicht aktualisiert.
ERRCODE2 = 48 | F29 | Die Modbus+ Optionskarte hat aufgehört Interrupt-Signale zu generieren.
ERRCODE2 = 49 | F29 | EtherNet hat den SDO Transfer gestoppt.
ERRCODE2 = 50 | F14 | Überlauf bei der Strommessung
ERRCODE2 = 51 | F18 | Ballastfehler (Hardware)
ERRCODE2 = 52 | F18 | Max. Ballastleistung erreicht
ERRCODE2 = 53 | F04 | Min. Resolveramplitude unterschritten
ERRCODE2 = 54 | F04 | Max. Amplitudensprung bei den Resolversignalen
ERRCODE2 = 55 | F04 | Phasenabweichung zwischen Sinus/Cosinus des Resolvers


ASCII Deutsch ERRCODE *

ASCII - Kommando | ERRCODE * |
Syntax Senden | ERRCODE * |
Syntax Empfangen | ERRCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 385D (hex)
DIM | - | PROFIBUS PNU | 1661 (dec) IND = 33 (dec)
Bereich | 0 .. 0xFFFFFFFF | DPR | 861 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Ausgabe des Fehlerregisters

Beschreibung

Das Kommando ERRCODE * liefert die Information über aktuell anstehende Fehler in Form einer Bit-Variable. Ein Bit wird gesetzt sobald der zugehörige Fehler erkannt worden ist. Das Löschen der Fehlerbits erfolgt beim Hardware-Reset des Verstärkers.
Fehler, die mit dem Kürzel SW gekennzeichnet sind, können auch per Software-Reset (Funktion „Fehler löschen“, CLRFAULT) gelöscht werden.

Unter Level werden die verschiedenen Fehlerbehandlungen angegeben.

Level 2: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt drehzahlgeregelt mit der Nothalt-Rampe (DECSTOP). Nach dem Erreichen der Stillstandsschwelle VEL0 (spätestens nach 5 Sekunden) wird die Endstufe gesperrt. Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 3: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt ohne Positionsinformation der Rückführeinheit. Nach dem Erreichen des Stillstands wird die Endstufe gesperrt.Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 4: Eine Störung führt zum sofortigen Sperren der Endstufe. Der Antrieb trudelt unkontrolliert aus, der Verstärker ist nicht mehr betriebsbereit (kein BTB). Der weitere Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx).
Das Fehlerbit, das im Statusregister gesetzt wird, kann über einen digitalen Ausgang nach außen gemeldet werden.

Bei den Fehlern, die gleichzeitig den Ebenen 2/3 und 4 zugeordnet sind, entscheidet über die Ebenen-Zugehörigkeit der Zustand der Parameter ACTFAULT und MBRAKE.

ACTFAULT=1 oder MBRAKE=1 LEVEL 2 bzw. 3 (Default-Einstellung)
ACTFAULT=0 und MBRAKE=0 LEVEL 4

Wichtig, bitte beachten Sie auch ERRCNFG:
Das Kommando ERRCNFG definiert das Verhalten des Verstärkers im Falle eines Fehlers Fxx. Bei gesetztem Bit xx, wird im Falle des Fehlers Fxx+1 die Endstufe sofort gesperrt. Dies funktioniert unabhängig von der Einstellung des Parameters ACTFAULT. Bei manchen kritischen Fehlern wird die Endstufe sofort gesperrt. Dies geschieht unabhängig von den Einstellungen ACTFAULT und ERRCNFG. Die entsprechenden Fehlermeldungen sind in der folgenden Tabelle gesondert gekennzeichnet.

Für detailierte Fehlerbeschreibungen siehe ERRCODE2
Bit/Displ./Reset/Level | Bitkombination | Beschreibung
00/F01/SW/2,4 0x00000001 =1 Fehler Kühlkörpertemperatur
wird gesetzt sobald die aktuelle Kühlkörpertemperatur (TEMPH) den maximal zulässigen Wert (MAXTEMPH) überschreitet.
01/F02/SW/2,4 0x00000002 =1 Fehler Überspannung
wird gesetzt sobald die Zwischenkreisspannung den max. zulässigen Wert (gegeben über VBUSBAL) überschreitet.

Dieser Fehler führt zum sofortigen Sperren der Endstufe.
02/F03/SW/2 0x00000004 =1 Schleppfehler bei Ausführung der externen Trajektorie (OPMODE=6/SERCOS)
wird gesetzt sobald die Geschwindigkeit, die über die externe Trajektorie vorgegeben wird, die max. Drehzahl VLIM/VLIMN überschreitet.

Bei Vorgabe einer externen Trajektorie (OPMODE=5), wird beim Überschreiten des Schleppfehlerfensters anstelle einer Warnung der Fehler F03 generiert. Dies führt zum Sperren der Endstufe.
03/F04/HW/3,4 0x00000008 =1 Feedback-Fehler
wird gesetzt wenn die Amplitude der Resolver/Encoder-Signale den minimalen Grenzwert unterschreitet

Der Antrieb wird stromgeregelt abgebremst.

Achtung: Bei den Fehlern F04/F08/F25 geht u.U. die Positionsinformation verloren. Das bedeutet auch, dass der Referenzpunkt gelöscht wird. Das Löschen des Referenzpunktes wird nicht sofort, sondern erst zum Zeitpunkt des „Fehlerresets“ vorgenommen. Das hat den Vorteil, dass bei Multiturn-Gebern das Bit gelöscht und sofort wieder gesetzt werden kann. Bei Singleturn-Gebern bleibt das Bit gelöscht.
04/F05/SW/2,4 0x00000010 =1 Fehler Unterspannung
wird gesetzt sobald die Zwischenkreisspannung den min. zulässigen Wert (VBUSMIN) unterschreitet.
05/F06/HW/2,4 0x00000020 =1 Fehler Motortemperatur
wird gesetzt sobald der Widerstand des Motortemperaturfühlers (TEMPM) den maximal zulässigen Wert (MAXTEMPM) überschreitet.

Ab FW >= 2.27 wird der Fehler softwaremäßig zurückgesetzt.
06/F07/HW/2,4 0x00000040 =1 wird gemeldet wenn die internen Versorgungsspannungen fehlerhaft sind.

Dieser Fehler führt zum sofortigen Sperren der Endstufe.
07/F08/SW/3,4 0x00000080 =1 Fehler Überdrehzahl
wird gesetzt wenn die aktuelle Motordrehzahl (V) den max. zulässigen Wert (VOSPD) überschreitet.

Der Antrieb wird stromgeregelt abgebremst.

Achtung: Bei den Fehlern F04/F08/F25 geht u.U. die Positionsinformation verloren. Das bedeutet auch, dass der Referenzpunkt gelöscht wird. Das Löschen des Referenzpunktes wird nicht sofort, sondern erst zum Zeitpunkt des „Fehlerresets“ vorgenommen. Das hat den Vorteil, dass bei Multiturn-Gebern das Bit gelöscht und sofort wieder gesetzt werden kann. Bei Singleturn-Gebern bleibt das Bit gelöscht.
08/F09/HW/4 0x00000100 =1 Fehler EEPROM
wird gesetzt, wenn beim Lesen/Schreiben des seriellen EEPROM´s ein Fehler aufgetreten ist. Dieser Fehler kann wird verursacht entweder durch ein fehlerhaftes EEPROM oder durch eine fehlerhafte Daten-Checksumme. In dem zweiten Fall kann der Fehler durch erneutes Abspeichern der Daten (SAVE) beseitigt werden.
09/F10/HW 0x00000200 Kabelbruch ROD Schnittstelle oder Zeitproblem beim Reglerbooten zwischen Master und Slave

siehe auch SDLY
10/F11/HW/2,4 0x00000400 =1 Fehler Bremse
wird gesetzt, wenn der Bremsenschalter einen Fehler meldet (z.B. Bremse nicht angeschlossen).
11/F12/HW | 0x00000800 | Motorphase fehlt (z.B. Leitungsbruch)
12/F13/SW/2,4 0x00001000 =1 Fehler Umgebungstemperatur
wird gesetzt sobald die aktuelle Umgebungstemperatur (TEMPE) den maximal zulässigen Wert (MAXTEMPE) überschreitet.
13/F14/HW/2,4 0x00002000 =1 Fehler Endstufe
Es sind folgende Ursachen möglich: Erdschluß, Motorkurzschluß oder Ballastkurzschluß.

Dieser Fehler führt zum sofortigen Sperren der Endstufe.
14/F15/SW/2,4 | 0x00004000 | =1 I2tmax überschritten.
15/F16/SW/2,4 | 0x00008000 | =1 Netz-BTB
16/F17/HW/2,4 0x00010000 =1 Fehler A/D-Wandler
wird gesetzt wenn beim Einschalten des Verstärkers zu große Stromoffsetwerte gemessen werden.
17/F18/HW/2,4 | 0x00020000 | =1 Ballast-Fehler (defekter Ballasttransistor, Vorwahl „Ballastwiderstand extern“ bei Anschluss des internen Ballastwiderstandes).
18/F19/SW/2,4 0x00040000 =1 Einbruch der Zwischenkreisspannung (fehlende Netzphase ?)
(siehe auch VBUSLIM, PMODE und VBUSMAX
19/F20/HW/2,4 0x00080000 =1 Slot-Error
Diese Fehlermeldung wird generiert, wenn bei vorhandener Slot-Erweiterungskarte ein Fehler erkannt wurde. Die mögliche Fehlerursache hängt von der Art der Slot-Erweiterungskarte ab.

1. I/O-Erweiterungskarte – Der Fehler wird generiert, wenn ein Kurzschlusses am Ausgang der I/O-Karte anliegt.

2. DPR-Erweiterungskarten (Beckhoff,L&B,Sigmatek)
Die Fehlermeldung erscheint, wenn der DPR-Innterrupt von der Erweiterungskarte ausbleibt (die Überwachungszeit kann mit dem Parameter EXTWD in msek eingestellt werden).

3. PROFIBUS: Initialisierungsfehler nach dem Einschalten

4. S700/Safety: F20 wird generiert, wenn der Parameter CSENID auf 1 steht und keine Safety-Karte von der Firmware erkannt wurde. Es kann folgende zwei Fälle geben:
1. Der Verstärker verfügt über eine Safety-Karte. In diesem Fall sollte überprüft werden, ob die Karte korrekt eingesetzt ist.
2. Der Verstärker hat gar keine Safety-Karte. In diesem Fall sollte der Parameter CSENID auf 0 gesetzt werden und die Änderung abgespeichert werden.
Beim nächsten Einschalten des Verstärkers sollte die Fehlermeldung F20 verschwinden.

Achtung: Durch das Setzen von CSENID, aber ohne eingesteckte Safety-Karte, kann es zur unnötigen Erwärmung des Motors führen!
20/F21/HW/2,4 0x00100000 =1 Handling Error
PROFIBUS:
Wird der Operationsmode (OPMODE) bei betriebsbereitem PROFIBUS über einen anderen Kommunikationskanal geändert, wird diese Fehlermeldung generiert und der Antrieb, falls erforderlich, notgebremst.
Ausnahme: Betriebsart –126 (nur Profibus). Gesicherte Betriebsart nach dem Einschalten.
21/F22/HW/2,4 | 0x00200000 | reserviert
22/F23/HW/2,4 0x00400000 =1 CANBUS Bus-Off
Fehler in der CAN – Kommunikation
Die Kommunikationsstörung BUSOFF wird direkt von der Schicht 2 (CAN Controller) überwacht und gemeldet. Diese Meldung kann unterschiedliche Ursachen haben. Hier einige Beispiele: Telegramm wird gesendet, obwohl kein weiterer CAN – Knoten angeschlossen ist, CAN Knoten weisen unterschiedliche Baudraten auf, Busleitung defekt, Reflexionen auf den Leitungen aufgrund fehlerhafter Leitungsabschlüsse,......

Ein BUSOFF wird vom Antrieb nur gemeldet, wenn ein weiterer CAN Knoten angeschlossen ist und mindesten ein Objekt zu Beginn erfolgreich abgesetzt werden konnte. Der Zustand BUSOFF wird mit der Fehlermeldung F23 signalisiert. Sollte beim Auftreten dieses Fehlers die Endstufe freigegeben (enable) sein und eine Fahrfunktion ausgeführt werden, wird der Antrieb mit der Notbremsrampe angehalten und die Endstufe gesperrt (disable).
23/F24/SW/2,4 | 0x00800000 | Warnung in Fehler gewandelt (definiert durch WMASK)
24/F25/HW/3,4 0x01000000 Kommutierungsfehler (Durchgehen des Motors)

Der Antrieb wird sofort disabled.

Siehe auch VCOMM

Achtung: Bei den Fehlern F04/F08/F25 geht u.U. die Positionsinformation verloren. Das bedeutet auch, dass der Referenzpunkt gelöscht wird. Das Löschen des Referenzpunktes wird nicht sofort, sondern erst zum Zeitpunkt des „Fehlerresets“ vorgenommen. Das hat den Vorteil, dass bei Multiturn-Gebern das Bit gelöscht und sofort wieder gesetzt werden kann. Bei Singleturn-Gebern bleibt das Bit gelöscht.
25/F26/SW/2,4 | 0x02000000 | Hardware-Endschalter - Fehler bei Referenzfahrt
26/F27/HW/4 0x04000000 =1 Fehler „-AS-Option“
Diese Fehlermeldung wird generiert, wenn beim Aktivwerden der AS-Option die Endstufe freigegeben war.

Dieser Fehler führt zum sofortigen Sperren der Endstufe.
27/F28/SW/2 0x08000000 =1
EtherCAT
Fehler Synchronisation
wird generiert wenn der Antrieb im Phasenhochlauf nicht synchronisieren lässt bzw. wenn der Antrieb im EtherCAT Zustand „Operational“ seine Synchronisation verliert.
28/F29/SW/2 0x10000000 =1
Slotkartenfehler

EtherCat + DPR-Karten
1.Software-Enable wird gesetzt bei nicht gesetztem Hardware-Enable
2.Software-Enable wird gesetzt bei abgeschalteter Netzspannung
3.Fehler-Löschen (CLRFAULT) wenn der anstehende Fehler einen COLDSTART erfordert. Dies wird nur dann als Fehler gewertet, wenn das Bit 0x00080000 im Parameter SERCSET auf 1 steht.
4.Anwahl einer ungültigen Mapping-Nummer
5.Mapping-Länge fehlerhaft (EtherCat)
6.Slot-Karte wird von der Firmware nicht unterstützt (z.B: bei kundenspezifischer Firmware).
7.Feldbus-Synchronisation konnte nicht erreicht werden: (DPR cards)
8.Aufschalten der Sollwerte bei anstehendem n14 - Wake&Shake (Synqnet)
9.Phasenhochlauf-Time-Out abgelaufen (zwischen Phase3 und 4) (Synqnet)
10.„Upcount Lifetime counter“ abgelaufen
11.Peercop Timeout abgelaufen (Synqnet)

SERCOS-Fehler

12.Fiber break (Sercos)
13.MST failure (Sercos)
14.nicht erlaubter Interrupt (Sercos)
15.interner Sercos-Fehler (unbekannte ASIC-Version)
16.ungültiger SERCOS-Mode
29/F30/SW 0x20000000 Notstop Time-out

Notstop Time-out: Siehe auch EMRGTO
30/F31/SW | 0x40000000 | Reserve
31/F32/HW/4 0x80000000 =1 Systemfehler
zeigt einen internen Fehler an. Dieser Fehler wird beim Einschalten des Verstärkers generiert, wenn die Systemüberprüfung während der Initialisierungsphase nicht erfolgreich abgeschlossen werden konnte.
Es sind folgende Ursachen möglich:
1. Fehlerhafte Datentabelle im Flash (mögliche Ursache: abgebrochener Firmware-Update).
2. Macro-Fehler (fehlerhaftes Macro-Programm)
3. Software-Watch-Dog (Fehler bei der Programmausführung)
4. Serielles EEPROM (Fehler beim Lesen/Schreiben des seriellen EEPROM´s)
5. Makro-RAM - zu wenig RAM für die Makro-Programme
Beim Einschalten des Verstärkers, wird im Falle eines Systemfehlers, die genaue Fehlerursache über die serielle Schnittstelle (RS232) ausgegeben.

Der Fehler F32 kann ggf. durch folgenden Vorgang beseitigt werden: ASCII - Befehl SAVE ausführen lassen. Wenn dieser Speichervorgang abgeschlossen ist den Regler resetten.


ASCII Deutsch ERRMASK

ASCII - Kommando | ERRMASK |
Syntax Senden | ERRMASK [Data] |
Syntax Empfangen | ERRMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 355E (hex)
DIM | - | PROFIBUS PNU | 1694 (dec) IND = 1 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 94 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | - |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Fehlerauswahlmaske um Verzögerungszeit zu aktiv.

Beschreibung

Der Parameter ERRMASK bestimmt die Fehler, die nach der Fehlerverzögerungszeit (ERRTIME) aktiviert werden.

Siehe auch ERRCODE * und ERRTIME


ASCII Deutsch ERRPARAM

ASCII - Kommando | ERRPARAM |
Syntax Senden | ERRPARAM |
Syntax Empfangen | ERRPARAM <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 375A (hex)
DIM |  | PROFIBUS PNU | 1802 (dec) IND = 17 (dec)
Bereich |  | DPR | 602 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Objektnummer falscher Parameter (Warnung n24)

Beschreibung

Das Kommando liefert die Objektnummer des fehlerhaften Parameters, der zur Warnung n24 führt.
Während der Initialisierungsphase überprüft der Antrieb die Plausibilität der Konfigurations Parameter. Im Falle von Falscheingaben (z.B. Referenzeingang für 2 dig. Eingänge konfiguriert) erfolgt die Warnung n24.b (s. STATCODE ) . Der ASCII Name des fehlerhaften Parameters kann mit IDDUMP angezeigt werden.

Folgende Plausibilität wird überprüft:

Funktion INxMODE=2,3,4,5 nur für x=3 oder 4
Funktion INxMODE=6,7 nur für x=3
Funktion INxMODE=19 nur für x=2
Funktion INxMODE=26 nur für x=1 and 2
Funktion INxMODE=30,33 nur für x=1..4,19,20
Funktions INxMODE=2,3,4,5,6,7,8,10,11,12,13,14,15,19,21,22,25,29,32,38,42 sind für alle digitalen Eingänge möglich, aber jede Funktion kann nur einmal angewählt werden.


ASCII Deutsch ERRTIME

ASCII - Kommando | ERRTIME |
Syntax Senden | ERRTIME [Data] |
Syntax Empfangen | ERRTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 355F (hex)
DIM | ms | PROFIBUS PNU | 1695 (dec) IND = 1 (dec)
Bereich | 0 .. 20000 | DPR | 95 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 2.11 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Fehler Verzögerungszeit

Beschreibung

Der Parameter ERRTIME bestimmt die Verzögerungszeit bevor die Funktion ERRMASK oder ERRCODE ausgeführt wird.

Siehe auch ERRCODE und ERRMASK


ASCII Deutsch ESPEED

ASCII - Kommando | ESPEED |
Syntax Senden | - |
Syntax Empfangen | ESPEED <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3675 (hex)
DIM | rpm | PROFIBUS PNU | 1973 (dec) IND = 1 (dec)
Bereich | 0 .. 16000 | DPR | 373 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Maximale Drehzahl in Abhängigkeit vom Gebertyp

Beschreibung

Das Kommando ESPEED liefert die maximale Drehzahl, die bei der vorhandenen
Rückführeinheit (FBTYPE), vom Antrieb gefahren werden kann.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

EtherCAT Erweiterungskarte

Diese Bildschirmseite erscheint nur, wenn eine EtherCAT Erweiterungskarte in den Servoverstärker eingebaut ist.

Profibus1

Diese Bildschirmseite gibt Informationen über:
- die aktuelle Kommunikationsphase im Kommunikations-Status
- das ausgewählte zyklische Ist- und Sollwert Mapping
- den Zustand der CAN-over-EherCAT Zustandsmaschine

Sie können verschiedene spezielle EtherCAT Einstellungen vornehmen (siehe auch SERCSET). Die aktuelle Kommunikationszykluszeit kann in 250µs Schritten eingestellt bzw. abgelesen werden. Diese Zykluszeit wird meistens von der EtherCAT Steuerung im Phasenhochlauf beschrieben (siehe auch PTBASE).


ASCII Deutsch ETHMODE

ASCII - Kommando | ETHMODE |
Syntax Senden | ETHMODE [Data] |
Syntax Empfangen | ETHMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3778 (hex)
DIM | - | PROFIBUS PNU | 1832 (dec) IND = 17 (dec)
Bereich | 0..2 | DPR | 632 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.07 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Wählt das On-Board-Feldbus-Interface aus

Beschreibung

nur S700: nur S300 FW >= 5.00 Wählt das On-Board-Feldbus-Interface aus, welches beim Booten aktiviert wird. Mit Multidrive MDRV muss ETHMODE auf 2 stehen.
0 | CAN | On-Board-CAN ist permanent aktiviert
1 | auto-detect | Wenn beim Booten eine EtherCAT-Verbindung erkannt wird, wird das On-Board-EtherCAT aktiviert, andernfalls wird CAN aktiviert.
2 | EtherCAT | On-Board-EtherCAT ist permanent aktiviert Multidrive MDRV mit EtherCAT: ETHMODE muss auf 2 stehen. Achtung: Bei dieser Einstellung wird die EtherCAT-Status-Maschine sofort aktiv. Solange sie sich in dem Init-State befindet und keine Kommunikation stattfindet, sind nur digitale Sollwert-Vorgaben möglich. Sobald OPMODE auf 1 oder 3 geschaltet wird, wird die Endstufe gesperrt. Der Hintergrund ist: Solange die Steuerung nicht hochgefahren wurde und keine Kommunikation zum Drive aufgebaut wurde, darf keine Motor-Bewegung stattfinden. Es soll verhindert werden, dass eine analoge Betriebsart im Eeprom gespeichert wurde und beim Einschalten sich die Achse bewegt.


ASCII Deutsch EWH

ASCII - Kommando | EWH |
Syntax Senden | EWH [Data] |
Syntax Empfangen | EWH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38BE (hex)
DIM | Wattstunde | PROFIBUS PNU | 1758 (dec) IND = 33 (dec)
Bereich | 0 .. 2147483647 | DPR | 958 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | actual values | EEPROM | Ja
Kurzbeschreibung | Energieaufnahme in WattStunden

Beschreibung

Die Variable EWH liefert die aufgenommene elektrische Energie in WattStunden. Sie entspricht dem aufintegrierten Wert von Ud*Id + Uq*Iq.
Der Wert wird alle 8 Minuten im Flash abgespeichert, so dass bei häufigem Aus-/Einschalten des Verstärkers größere Messfehler entstehen können.

Durch einen Schreibzugriff kann diese Variable auf beliebige Start-Werte gesetzt werden.

Die Anzeige erfolgt zwar in Wattstunden, das Datum wird aber intern in Wattsekunden abgespeichert. Der genaue Wert kann über die Makro-Variable EWS („M EWS“) abgefragt werden.


ASCII Deutsch EXTBRAKE

ASCII - Kommando | EXTBRAKE |
Syntax Senden | EXTBRAKE [Data] |
Syntax Empfangen | EXTBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 385C (hex)
DIM |  | PROFIBUS PNU | 1660 (dec) IND = 33 (dec)
Bereich | 0..3 | DPR | 860 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Software Bremsensteuerung an / aus

Beschreibung

Der Parameter ist verknüpft mit der Macrocvariable EXTBRAKEC, die mit einem PLC oder Marco Programm benutzt werden kann. Folgende Einstellungen sind möglich:

EXTBRAKE=0 keine externe Bremsensteuerung, Bremsenansteuerung obliegt dem Drive (default)
EXTBRAKE=1 externe Bremsensteuerung ist nur erlaubt, wenn keine Zwischenkreisspannung eingeschaltet ist (Standardprocedur für externe Bremsensteuerung beim S300/S700).

erweitert ab Firmware 5.53/3.89
EXTBRAKE=2 externe Bremsensteuerung ist nur erlaubt, wenn Antrieb enabled ist
EXTBRAKE=3 externe Bremsensteuerung ist nur erlaubt, wenn Antrieb enabled und keine Nothalt-Rampe aktiv ist.

erweitert ab Firmware 5.77
EXTBRAKE=4 externe Bremsensteuerung ist immer erlaubt


ASCII Deutsch EXTLATCH

ASCII - Kommando | EXTLATCH |
Syntax Senden | EXTLATCH [Data] |
Syntax Empfangen | EXTLATCH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3681 (hex)
DIM | - | PROFIBUS PNU | 1985 (dec) IND = 1 (dec)
Bereich | 0 .. 2 | DPR | 385 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Einstellung der Quellen für die Latch-Eingänge

Beschreibung

Die Konfigurationsvariable EXTLATCH definiert die Quelle der Positionsinformation bei Verwendung der Latch-Funktionen.
Bei EXTLATCH=0 wird immer die aktuelle Lagereglerposition gelatcht d.h. bei

EXTPOS = 0 ist das die Position des Hauptgebers (FBTYPE) und bei

EXTPOS > 0 die Position des externen Gebers. Bei

EXTPOS < 0 wird die Quelle für den Positionslatch wie folgt definiert:

EXTLATCH = 0 latchen der Position PFB mit beiden digitalen Eingängen 1und 2 (IN1MODE=26 / IN2MODE=26) in das Register LATCH1P32 und LATCH2P32

EXTLATCH = 1 latchen der Position PFB0 mit digital Eingang 1 in LATCH1P32 und Position PFB mit digital Eingang 2 in LATCH2P32

EXTLATCH =2 latchen der Position PFB0 mit beiden digitalen Eingängen 1und 2 in das Register LATCH1P32 und LATCH2P32


ASCII Deutsch EXTPOS

ASCII - Kommando | EXTPOS |
Syntax Senden | EXTPOS [Data] |
Syntax Empfangen | EXTPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3539 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 1 (dec)
Bereich | -30 ... 30 | DPR | 57 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Positionsquelle der Lageregelung

Beschreibung

Dieser Parameter EXTPOS definiert die Quelle des Lagegebers, welcher zur Lageregelung verwendet werden soll- Bei der Einstellung EXTPOS = 0 wird der Motor Geber, definiert mit dem Kommando FBTYPE, zur Lageregelung verwendet. Für Einstellungen EXTPOS > 0 wird ein externer Geber zur Lageregelung verwendet. Das Übersetzungsverhältnis des externen Gebers um die Auflösung der externen Position auf 32 Bit pro Umdrehung zu bringen, wird durch die Parameter EGEARO als Multiplikator und EGEARI als Divisor eingestellt.

Beim Setzen von EXTPOS auf negative Werte, wird der entsprechende Geber eingelesen und die Position in PFB0 abgelegt. Die Lageregelung findet aber mit Hilfe der Kommutierungseinheit (FBTYPE) statt (wie bei EXTPOS=0).

z.B: EXTPOS = -6 Der Sinus/Cosinus-Geber (5V) wird eingelesen. Die eingelesene Position kann mit dem ASCII-Kommando PFB0 angezeigt werden. Das Einlesen des externen Gebers hat in diesem Fall keinen Einfluß auf die Lageregelung.

Beim Einlesen des externen Gebers kann mit den Parametern EGEARI und EGEARO das Übersetzungsverhältnis eingestellt werden. Dabei gilt folgendes:

1. Bei allen Positionsquellen, die analog erfasst werden d.h. EXTPOS=6,7,8,9 wird die Position anhand der ENCLINES-Einstellung erfasst und in das 32Bit/Umdrehung-Format konvertiert. Die Parameter EGEARI/EGEARO beschreiben das reine Gearing-Faktor. Bei EGEARI-Umdrehungen des Gebers macht der Motor EGEARO Umdrehungen.

z.B: EGEARI=10,EGEARO=3 -> Übersetungsverhältnis 10 zu 3

2. Bei allen Positionsquellen, die digital erfasst werden d.h EXTPOS=1...4, beschreibt der Parameter ENCIN die Anzahl der Geberimpulse pro Umdrehung. Die Parameter EGEARI/EGEARO beschreiben das reine Gearing-Faktor.

z.B: ein externer ROD-Geber liefert 1024 Impulse pro Umdrehung, bei 1 Geber-Umdrehung soll der Motor 3 Umdrehungen machen. Es sind folgende Einstellungen notwendig:

EXTPOS 3,
ENCIN 1024,
EGEARI 1,
EGEARO 3
Zustand | Stecker | Lagegeber für Lageregelung
EXTPOS = 0 - kein externes Feedback
EXTPOS = 1 | Stecker X3 | 24 V Puls / Richtung
EXTPOS = 2 | Stecker X3 | 24V ROD Encoder
EXTPOS = 3 | Stecker X5 | 5 V ROD Encoder
EXTPOS = 4 | Stecker X5 | 5 V Puls / Richtung
EXTPOS = 5 | Stecker X5 | SSI Encoder
EXTPOS = 6 | Stecker X1 | 5V SinCos Encoder
EXTPOS = 7 | Stecker X1 | 12V SinCos Encoder
EXTPOS = 8 | Stecker X1 | ENDAT
EXTPOS = 9 | Stecker X1 | HIPERFACE
EXTPOS=10 | Stecker X1 | 5V ROD-Geber als Quelle für den Lageregler-Positionsistwert
EXTPOS = 11 Stecker X1 5V BiSS-B Digital Geber. Als primärer Geber muss ein Resolver eingestellt werden (FBTYPE = 0).

ab Fw >= 2.28
EXTPOS = 12 Stecker X1 BiSS C
FBTYPE=33

ab Fw >= 5.18
EXTPOS = 13 Stecker X1 EnDat 2.2
FBTYPE=32

ab Fw >= 5.18
EXTPOS = 25 Stecker X1 SSI Encoder
FBTYPE=32

ab Fw >= 5.18
EXTPOS = 30 Stecker X1 5 V ROD digital Encoder
FBTYPE=32

ab Fw >= 5.18


ASCII Deutsch EXTWD

ASCII - Kommando | EXTWD |
Syntax Senden | EXTWD [Data] |
Syntax Empfangen | EXTWD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 353A (hex)
DIM | ms | PROFIBUS PNU | 1658 (dec) IND = 1 (dec)
Bereich | 1 .. 32000 | DPR | 58 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Überwachungszeit für Feldbus-Befehle

Beschreibung

Mit dem Parameter EXTWD kann die Überwachungszeit (Watch-Dog) für die Feldbus/Slot-Kommunikation definiert werden. Die Überwachung ist nur dann aktiv, wenn der Parameter EXTWD einen Wert größer 0 enthält (EXTWD=0, Überwachung abgeschaltet) und die Endstufe freigegeben ist. Falls die eingestellte Zeit abgelaufen ist, ohne daß der Timer neu getriggert wurde,so wird die Warnung n04 (Ansprechüberwachung) generiert und der Antrieb angehalten. Der Verstärker bleibt weiterhin betriebsbereit und die Endstufe freigegeben. Bevor ein neues Fahrkommando (Sollwert) akzeptiert wird, muß diese Warnung gelöscht werden (Funktion CLRFAULT oder INxMODE=14).
Beim DeviceNet wird die Überwachung mit dem Wert 1/0 ein-/ausgeschaltet. (Die Watchdog Zeit wird über den DeviceNet Controller gesetzt.)


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Feedback Test und Diagnose

Test Feedback/Motor

Die Feedback-/Motortest-Seite ermöglicht einen Verdrahtungstests für den Geber- bzw. Motoranschluss.

Beim Starten der Funktion wird im Stromreglermode (OPMODE = 2) bei freigegebener Endstufe eine langsame Bewegung des Motors gestartet. Die Bewegung erfolgt gesteuert ohne Beteiligung des Positionsgebers (U/F-Mode). Die eingelesene Geberposition wird nur für Auswertungszwecke beobachtet und aufgezeichnet. Anhand der Positionsdaten kann die Geberauflösung, Zählrichtung sowie der Geberanschluss kontrolliert werden. Bei Gebern, die sowohl digitale als auch analoge Informationen liefern (Endat2.1, Hiperface, BiSS-B) kann es vorkommen, dass bei fehlerhaftem Anschluss der analogen Spuren nur die Positioniergenauigkeit verloren geht. Der Antrieb kann trotzdem problemlos betrieben werden. Je nach Auflösung des Gebersystems lassen sich solche Verdrahtungsfehler schwer finden.

Die vorliegende Testfunktion liest kontinuierlich sowohl die analogen (falls vorhanden) als auch die digitalen Positionsinformationen des Gebers und kontrolliert sie auf ihre Plausibilität. Bei Abweichungen versucht sie die Ursache des Problems zu ermitteln.

Folgende Parameter müssen korrekt eingestellt sein, damit der Test durchgeführt werden kann:

  • Korrekter Feedbacktyp (FBTYPE)
  • Korrekte Parametrierung des Stromreglers
  • Positive Geber-Zählrichtung (DIR=21)
  • Korrekte Motorpolpaarzahl MPOLES

0gefahr
Verletzungsgefahr bei vertikalen oder vorgespannten Lasten!
Die Messung wird mit vermindertem Drehmoment durchgeführt, daher ist eine Prüfung von Achsen mit hängender oder mit Federkraft vorgespannter Last nicht erlaubt. Falls möglich sollte der Test ohne Motor-Last erfolgen.

einheiten

Einstellungen

1. Anzahl der Umdrehungen (mechanisch)
Vorgabe der Verfahrstrecke für die Test-Bewegung. Da die Bewegung sensorlos erfolgt, ist es wichtig, dass die Motorpolzahl korrekt eingestellt wurde. Je nach Auflösung des Gebers sollte wenigstens eine volle mechanische Umdrehung zurückgelegt werden.
2. Strom in % von Motornennstrom
Die sensorlose Betriebsart erfordert eine Bestromung in D-Richtung (feldbildend). Der dafür benötigte D-Strom wird durch diese Eingabe vorgegeben.

Ergebnis

Diese Anzeige stellt das Gesamtergebnis des Tests dar. Eine grüne/rote „LED“ bei den einzelnen Tests zeigt, ob der zugehörige Test erfolgreich (grün) oder nicht erfolgreich (rot) absolviert wurde.
1. Motorphasen korrekt – die Verfahrstrecke konnte zurückgelegt werden
2. Feedback korrekt – es wurde kein Feedback-Problem entdeckt
3. Drehrichtungen korrekt – Die Drehrichtung des Gebers ist positiv, bei einem analog/digital-Geber passen die analoge und digitale Zählrichtungen zueinander.
4. Geberauflösung korrekt – die ermittelte Auflösung des Gebers stimmt mit den eingestellten Werten überein.

X1 Stecker

Diese Anzeige gilt nur für Geber mit analoger und digitaler Positionserfassung (Endat2.1, Hiperface, BISS-B). Anhand der erfassten Positionsinformationen wird die Zuordnung der analogen und digitalen „Spuren“ zueinander überprüft. Eine Diskrepanz bei den Positionsinformationen kann durch vertauschte Anschlüsse am Stecker X1 (+/- bzw. Sinus/Cosinus) verursacht sein. Die Testfunktion versucht den möglichen Verdrahtungsfehler zu finden und zeigt das Ergebnis mit einer roten/grünen LED an.

Feedback – erweiterte Geberinformation

Diese Anzeige gilt nur für Geber mit analoger und digitaler Positionserfassung (Endat2.1, Hiperface, BISS-B).
1. Anzahl Perioden – Anzahl der Sinus-Perioden pro Geberumdrehung
2. Auflösung – Anzahl der Counts (digitale Position) pro eine Sinus-Periode (analoge Position)
3. Zählrichtung – positive/negative Zählrichtung
4. Motorphase – Am Ende der Testfunktion wird eine aktuelle Motorphase ermittelt. Falls der ermittelte Wert mit der aktuellen Einstellung MPHASE übereinstimmt, so wird eine grüne LED angezeigt. Bei einer Abweichung von weniger als 5 Grad erscheint eine gelbe ansonsten eine rote LED.

Das Ergebnis des Feedback-/Motortests kann stark von den äußeren Einflüssen abhängen.

Klicken auf die Schaltfläche "Test/Bewegung Starten" startet die Messung.
Klicken auf die Schaltfläche "Zurück zur Feedback-Seite" bringt Sie zurück zur Feedback Seite.

Endat 2.2 Diagnose

Enthält ENDAT2.2 Encoder Diagnose Informationen. Die Daten müssen sowohl vom Encoder als auch von der Firmware (5.91 oder neuer) unterstützt werden und im Servoverstärker konfiguriert sein (siehe ASCII Befehle EN22CNFG). Die Bedeutung der übertragenen Daten finden Sie in der ENDAT Dokumentation des Geberherstellers.

Diagnose

Enthält bis zu 16 ENDAT2.2 Encoder Diagnose Informationen. Diagnosedaten müssen sowohl vom Encoder als auch von der Firmware unterstützt werden und im Servoverstärker konfiguriert sein (siehe ASCII Befehle EN22CNFG und EN22DCNT).

Zusätzliche Information 1

Enthält bis zu 16 ENDAT2.2 Encoder zusätzliche Informationen 1 (AI1). Diagnosedaten müssen sowohl vom Encoder als auch von der Firmware unterstützt werden und im Servoverstärker konfiguriert sein (siehe ASCII Befehle EN22CNFG und EN22A1CNT).

Zusätzliche Information 2

Enthält bis zu 16 ENDAT2.2 Encoder zusätzliche Informationen 2 (AI2). Diagnosedaten müssen sowohl vom Encoder als auch von der Firmware unterstützt werden und im Servoverstärker konfiguriert sein (siehe ASCII Befehle EN22CNFG und EN22A2CNT).

HIPERFACE DSL Diagnose

Auf dieser Seite werden DSL Encoder Statusinformationen angezeigt, die vom Encoder übermittelt wurden.

Klicken auf die Schaltfläche "Zurück zur Feedback-Seite" bringt Sie zurück zur Feedback Seite.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Wake & Shake

einheiten

Wake and Shake wird benutzt für Feedbacksysteme ohne Kommutierungssignale, z.B. HALL oder eine Sinus/Cosinus Geber. Auf dieser Bildschirmseite können Experten den Wake and Shake Ablauf einstellen.

0danger - color
Bei grob fehlerhaften Einstellungen kann der Motor durchgehen! Verletzungsgefahr. Diese Parameter sollten nur nach Rücksprache mit einem Servicetechniker verändert werden.

Bildschirmtext | ASCII-Parameter
WSCNFG0 - Pulse Methode
T1 | WSTIME, Ausführungszeit der Funktion
REFIP2 | REFIP2, Spitzenstrom für die Kommutierungsfindung
REFIP | REFIP, Spitzenstrom
T2 | WSTIME2, Pausenzeit zwischen den Stromvektoren
T3 | WSTIME3, Zeitabstand zwischen Grob- und Feinabstimmung
WSCNFG1 - Regelkreis Methode
P | MPKP, P-Anteil des Lagereglers
I | MPKI, I-Anteil des Lagereglers
D | MPKD, D-Anteil des Lagereglers
Zeit | MPTIME, Ausrichtzeit für die Kommutierungsfindung
REFIP2 | REFIP2, Spitzenstrom für die Kommutierungsfindung
Hilfe | Öffnet die KDN Seite Wake und Shake.

Klicken auf die Schaltfläche "Hilfe" öffnet die KDN Seite Wake und Shake mit detaillierten Informationen. Klicken auf die Schaltfläche "Return to Feedback Page" bringt Sie zurück zur Feedback Seite.


ASCII Deutsch FBGEARI

ASCII - Kommando | FBGEARI |
Syntax Senden | FBGEARI [Data] |
Syntax Empfangen | FBGEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3893 (hex)
DIM |  | PROFIBUS PNU | 1715 (dec) IND = 33 (dec)
Bereich | 1...2147483647 | DPR | 915 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Kompensationsfaktor Motor/Getriebe

Beschreibung

Diese Funktion dient dazu, das ggf. vorhandene Getriebe zwischen dem Motor und dem Geber zu kompensieren. Sie kann auch dazu benutzt werden um die Geberauflösung zu manipulieren (z.B. um die Auflösung eines sehr langen Linearmasstabs zu reduzieren).

Diese Funktion ist nur aktiv, wenn FBGEARI und FBGEARO unterschiedliche Werte haben. Der Positionswert am Ausgang des Gearings wird in der Macrovariable NEWBISS abgelegt (im Terminal mit "M NEWBISS").

NEWBISS = Position * FBGEARO / FBGEARI

Bei der Variable NEWBISS handelt es sich um eine 64-Bit-Variable bei der die unteren 32 Bits die Position innerhalb einer Umdrehung enthalten. Die oberen 32 Bits enthalten die Anzahl der vollen Umdrehungen


ASCII Deutsch FBGEARO

ASCII - Kommando | FBGEARO |
Syntax Senden | FBGEARO [Data] |
Syntax Empfangen | FBGEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3894 (hex)
DIM |  | PROFIBUS PNU | 1716 (dec) IND = 33 (dec)
Bereich | 1...2147483647 | DPR | 916 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Kompensationsfaktor Motor/Getriebe

Beschreibung

Diese Funktion dient dazu, das ggf. vorhandene Getriebe zwischen dem Motor und dem Geber zu kompensieren. Sie kann auch dazu benutzt werden um die Geberauflösung zu manipulieren (z.B. um die Auflösung eines sehr langen Linearmasstabs zu reduzieren).

Diese Funktion ist nur aktiv, wenn FBGEARI und FBGEARO unterschiedliche Werte haben. Der Positionswert am Ausgang des Gearings wird in der Macrovariable NEWBISS abgelegt (im Terminal mit "M NEWBISS").

NEWBISS = Position * FBGEARO / FBGEARI

Bei der Variable NEWBISS handelt es sich um eine 64-Bit-Variable bei der die unteren 32 Bits die Position innerhalb einer Umdrehung enthalten. Die oberen 32 Bits enthalten die Anzahl der vollen Umdrehungen


ASCII Deutsch FBTYPE

ASCII - Kommando | FBTYPE |
Syntax Senden | FBTYPE [Data] |
Syntax Empfangen | FBTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 1 (dec)
Bereich | 0 ... 36 | DPR | 59 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Vorwahl der Kommutierungs - Rückführeinheit

Beschreibung

Mit dem Kommando FBTYPE kann die Art des Feedback-Devices vorgewählt werden.
Die eingestellte Geberart wird nur beim Einschalten des Verstärkers initialisiert d.h. nach jeder Änderung dieser Variable, muß der Verstärker aus- und eingeschaltet werden.
Die Encoder-Parameter können mit dem entsprechenden ASCII-Kommando (in Klammern) verändert und mit dem Kommando HSAVE im Encoder-Eeprom abgespeichert werden. Die Encoder-Kommandos (HISOFFS, HICOFFS, HIFACT1, HSAVE) sind nur dann verfügbar, wenn eine Kommunikation zum angeschlossenen Encoder aufgebaut werden konnte.
Falls der Encoder nicht angesprochen werden konnte, so wird die Fehlermeldung ENCODER-FEHLER F04 angezeigt.
Beim Laden der Daten aus dem Encoder wird die Einstellung der Motornummer im Encoder mit der internen Einstellung (MNUMBER) verglichen. Falls die Nummern unterschiedlich sind, so wird versucht aus der internen Motordatenbank einen Motordatensatz mit der im Encoder abgelegten Motornummer zu laden. Gleichzeitig wird die Warnung „NEUER MOTORDATENSATZ“ n12 angezeigt.
Damit beim nächsten Einschalten keine Warnung ausgegeben wird, sollte die aktuelle MNUMBER-Einstellung mit dem Kommando SAVE im EEPROM abgespeichert werden. Falls keine gültige Motordatensatznummer aus dem Encoder geladen werden konnte (z.B. bei einem zum ersten Mal benutzten Encoder), so werden keine Motor-Daten geladen. Die Warnung n12 wird aber weiterhin ausgegeben. Mit dem HSAVE-Kommando kann die aktuelle Einstellung der Motornummer (MNUMBER) im Encoder abgespeichert werden, so daß beim nächsten Einschalten keine Warnung mehr generiert wird.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7/16) und damit ohne Fähigkeit Parameter abzuspeichern, werden die Offsetwerte HISOFFS / HICOFFS / HIFACT1 im seriellen EEPROM des Verstärkers abgespeichert. Nach einer Änderung können diese Werte mit dem SAVE-Kommando dauerhaft gespeichert werden.
Die absolute Position für ENDAT,HIPERFACE und SSI wird bei bestimmten FBTYPE-Einstellungen nur während der Initialisierung eingelesen (beim Einschalten des Verstärkers). Um Fehllesungen auszuschliessen wird die Position bis zu 5 Mal gelesen. Die Position wird nur dann als gültig übernommen, wenn die Differenz zwischen zwei benachbarten Lesungen kleiner ist als der Wert des In-Position-Fensters PEINPOS. Bei zu großen Positionsabweichungen wird F04 ausgegeben.

Bei allen geberlosen Betriebsarten (FBTYPE=10,11) wird die Ausgangsfrequenz auf 599 Hz begrenzt. Daraus ergibt sich folgende Limitierung der maximalen Drehzahl (in UPM): MSPEED(max) = 599Hz*60 /( MPOLES/2) Falls Ihre Applikation eine höhere Ausgangsfrequenz benötigt, kontaktieren Sie bitte unser Support.
Zustand | Art des Gebers | Beschreibung
FBTYPE = 0 Resolver Daten werden aus dem EEPROM des Verstärkers geladen.

Stecker X2
FBTYPE = 1 SinCos 5V Stecker X1

(MPHASE aus dem EEPROM)

Mit ENCLINES = 1 kann ein Linearmotor mit analogem Hallsignal ohne Wake & Shake betrieben werden.
FBTYPE = 2 Hiperface (Stegmann) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)

Stecker X1
FBTYPE = 3 SinCos 12V Stecker X1

(MPHASE aus dem EEPROM)
FBTYPE = 4 EnDAT (Heidenhain) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)

Stecker X1
FBTYPE = 5 | SinCos 5V mit Hall | Stecker X1
FBTYPE = 6 | SinCos 12V mit Hall | Stecker X1
FBTYPE = 7 SinCos 5V mit W&S Stecker X1

FW >= 2.18
Ein Linearmotor mit analogem Hallsignal kann ohne W&S genutzt werden, wenn ENCLIINES = 1 und DRVCNFG Bit 8 = 1 eingestellt wird. Außerdem wird auch das Bit "Referenz ok" direkt gesetzt (Standardfunktion des Bit 8). Falls dies nicht gewünscht ist kann FBTYPE =1 genutzt werden.
FBTYPE = 8 | SinCos 12 V mit W & S | Stecker X1
FBTYPE = 9 | SSI | Stecker X5
FBTYPE =10 Sensorlos -
FBTYPE =11 nur Hall
5 V 		Stecker X1
FBTYPE =12 | RS 422 mit 24V Pegel | Stecker X3
FBTYPE = 13 ROD 5V Stecker X5

(MPHASE aus dem EEPROM)
FBTYPE = 14 | ROD 24V mit Hall | Stecker X1/X3
FBTYPE = 15 ROD 5V mit Hall Stecker X1

Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden.

Dafür muß der Parameter REFMODE auf 5 gesetzt werden.
FBTYPE = 16 | ROD 24 V mit W&S | Stecker X3
FBTYPE = 17 ROD
5V mit W&S 		Stecker X1

Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden. Dafür muß der Parameter REFMODE auf 5 gesetzt werden.
FBTYPE = 18 ROD
5V mit Hall 		Stecker X1/X5
FBTYPE = 19 ROD
5V - W&S 		Stecker X5
FBTYPE = 20 BiSS Geber
5V - digital 		Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Motornummer MNUMBER
Motorphase MPHASE

ab FW > 2.14
FBTYPE = 21 EnDat mit W&S Anschluss X1

EnDat mit W&S: es wird der Parameterkanal eingelesen (absolute Position) und MPHASE über Wake & Shake ermittelt.
Diese Einstellung ist eine Mischung zwischen FBTYPE=4 und FBTYPE=7
FBTYPE = 22 BiSS Geber
12V - digital 		Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus HISOFFS
Offsetkorrektur Cosinus HICOFFS
Amplitudennormierung HIFACT1
Motornummer MNUMBER
Motorphase MPHASE

ab FW > 2.14
FBTYPE = 23 BiSS Geber
5V - analog 		Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus HISOFFS
Offsetkorrektur Cosinus HICOFFS
Amplitudennormierung HIFACT1
Motornummer MNUMBER
Motorphase MPHASE

ab FW > 2.14
FBTYPE = 24 BiSS Geber
12V - analog 		Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus HISOFFS
Offsetkorrektur Cosinus HICOFFS
Amplitudennormierung HIFACT1
Motornummer MNUMBER
Motorphase MPHASE

ab FW > 2.14
FBTYPE = 25 nur S700:
SSI 		Stecker X1

ab FW = 3.06
FBTYPE = 26 nur S700:

SSI - Lineargeber 		ab FW > 3.06

Bei SSIRESOL=0 wird auch ein rotatorischer Geber unterstützt. Es gelten dann die Einstellungen für SSIRXD und SSIREVOL.
FBTYPE = 27 | ROD 5V (MPHASE aus dem EEPROM) | Stecker X1
FBTYPE = 28 | SSI-Linear | Stecker X5 (POS I/O-Optionskarte)
FBTYPE = 29 | n.a. | reserviert
FBTYPE = 30 | ROD mit W&S | Stecker X1
FBTYPE = 31 | ROD | Stecker X1
FBTYPE = 32 EnDAT 2.2 mit 5V Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Motornummer (MNUMBER)
Motorphase (MPHASE)

Stecker X1
FBTYPE = 33 BiSS-C
5V - digital 		Stecker X1

Zur Konfiguration siehe auch (BISSCNFG)

nur mit Renishaw-Geber
FBTYPE = 34 EnDAT 2.2 mit 12V Anschluss X1

Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Motornummer (MNUMBER)
Motorphase (MPHASE)

Stecker X1
FBTYPE = 35 Hiperface DSL (HDSL)

S700: Hardware-Version >= 2.30
S300: Hardware-Version >= 4.20 		Anschluss X1

ab FW Version >= 6.00
FBTYPE = 36 Smart Feedback Device (SFD3)

S700: Hardware-Version >= 2.30
S300: Hardware-Version >= 4.20 		Anschluss X1

ab FW Version >= 6.00


ASCII Deutsch FBTYPEX

ASCII - Kommando | FBTYPEX |
Syntax Senden | FBTYPEX [Data] |
Syntax Empfangen | FBTYPEX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 369B (hex)
DIM | - | PROFIBUS PNU | 2011 (dec) IND = 1 (dec)
Bereich | 0 .. 33 | DPR | 411 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Anzeige der erkannten Rückführungsart

Beschreibung

Mit dem Kommando FBTYPEX kann die aktuelle Feedback-Einstellung angezeigt werden. Bei der Einstellung FBTYPE=3 (automatische Feedback-Erkennung), enthält dieses Objekt die Kennung der automatisch erkannten Rückführeinheit.

Durch einen Offset von d100 wird gekennzeichnet, ob ein Multiturngeber bei FBTYPE=2, 3 und 4 erkannt wurde.

z.B.: Endat Multiturngeber wurde erkannt. Dann liefert FBTYPEX d104.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Feedback

Wählen Sie die Rückführeinheit, die an Ihren Motor angeschlossen ist.

Je nach Auswahl erscheinen unterschiedliche Einstellmöglichkeiten auf der Seite. Wenn Wake&Shake Feedbacks oder Sensorless angewählt wird, werden für Spezialeinstellungen zusätzliche Seiten in der Navigation eingeblendet.

Offset Berechnen

Der Offset kompensiert mechanische Fehlstellung des Resolvers/Encoders im Motor. Änderung nur möglich bei gesperrtem (Disable) Verstärker.

0warnung
Automatischer Anlauf!
Bei falscher Einstellung kann der Motor auch bei Drehzahl-Sollwert n=0 durchgehen Verletzungsgefahr durch unkontrollierte Bewegung der Last. Stellen Sie sicher, dass Sie genau das Feedbacksystem auswählen, das in Ihrem Motor eingebaut ist. Prüfen Sie Typenschild des Motors und Typenschlüssel.

Beispiel Resolver

einheiten

Bildschirmtext | ASCII-Parameter
Feedback-Typ | FBTYPE
Polzahl | MRESPOLES
Offset | MPHASE
Zeit | ZERO
Strom | REFIP2
Zählrichtung | DIR
Bandbreite | MRESBW
Beobachter-Vorsteuerung | VLO
Single-Turn-Geber wie Multi-Turn-Geber behandeln | DRVCNFG
Referenzoffset-Quelle Verstärker/Encoder | DRVCNFG2
Encoder Spannung X1 | ENCVON
Drehwinkel | PRD
Berechne RK | Berechnung des Korrekturparameters für Resolver Feedback CALCRK. Der Motor führt eine Bewegung mit den eingestellten Parametern aus
Resolver Korrekturparameter | CALCRK

Beispiel SinCos mit Hall

einheiten7

Bildschirmtext | ASCII-Parameter
Feedback-Typ | FBTYPE
Encoder-Striche | ENCLINES
Offset | MPHASE
Zeit | ZERO
Strom | REFIP2
Zählrichtung | DIR
Bandbreite | MRESBW
Beobachter-Vorsteuerung | VLO
Single-Turn-Geber wie Multi-Turn-Geber behandeln | DRVCNFG
Referenzoffset-Quelle Verstärker/Encoder | DRVCNFG2
Encoder Spannung X1 (deaktiviert) | ENCVON
Drehwinkel | PRD
Berechne HP | Berechnung des Korrekturparameters für Encoder Feedback CALCHP. Der Motor führt eine Bewegung mit den eingestellten Parametern aus
SinCos Korrekturparameter | CALCRK
Hall Signalzustände | Der Status der Hall Eingänge wird angezeigt. Detaillierte Informationen zu Hall Gebern finden Sie auf KDN Seite Hall Geber.


ASCII Deutsch FFTSW

ASCII - Kommando | FFTSW |
Syntax Senden | FFTSW [Data] |
Syntax Empfangen | FFTSW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3866 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 33 (dec)
Bereich | 0 .. 255 | DPR | 870 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.51 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Konfiguration der Stromvorsteuerung

Beschreibung

FFTSW ist eine Bit-Variable um die Stromvorsteuerung zu konfigurieren.

Bit 1 ( 0x00000001)
=1 Stromvorsteuerung wird hinter dem Sollwertfilter addiert
=0 Stromvorsteuerung wird vor dem Sollwertfilter addiert

Bit 2 ( 0x00000002)
=1 erweiterte Stromvorsteuerungsfunktionalität (neu)
=0 standard Stromvorsteuerungsfunktionalität (alt)

Bit 3 ( 0x00000004)
=1 Massenträgheitsvorsteuerung ein
=0 Massenträgheitsvorsteuerung aus

Bit 4 ( 0x00000008)
=1 lineare Interpolation für die Stromvorsteuerung aus
=0 lineare Interpolation für die Stromvorsteuerung ein

Bit 5 ( 0x00000010)
=1 lineare Geschwindigkeitsinterpolation aus
=0 lineare Geschwindigkeitsinterpolation ein


ASCII Deutsch FHKP

ASCII - Kommando | FHKP |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch FHTN

ASCII - Kommando | FHTN |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch FILTMODE

ASCII - Kommando | FILTMODE |
Syntax Senden | FILTMODE [Data] |
Syntax Empfangen | FILTMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 353C (hex)
DIM | - | PROFIBUS PNU | 1660 (dec) IND = 1 (dec)
Bereich | 0 ... 2 | DPR | 60 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.21 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Smith Predictor

Beschreibung

Der Smith Predictor schätzt den Strom, der sich in 62,5 ms einstellt, um die Totzeit des Servoumrichters zu kompensieren (fs = 8 kHz). Statt dem bisher verwendeten Model einer reinen Induktivität wird ein Motormodel mit der elektrischen Zeitkonstante des Motors te = L / R verwendet. Eingeschaltet wird der Algorithmus mit FILTMODE 2 (2 = EIN; alles andere bedeutet AUS) und KC 1 (1,0 = 100% ? die Prediction wird zu 100 % verwendet; 0,5 -> 50 % ...)

Für den Algorithmus müssen die Parameter des Motors im Antrieb gespeichert werden:
MRS Phase-Phase Widerstand der Wicklung
ML Phase-Phase Induktivität der Wicklung in mH.

Mit dem Predictor kann die Bandbreite des Stromregelkreises auf über 2,5 kHz eingestellt werden (fs = 8 kHz). Wenn der Predictor eingeschaltet ist, beträgt der Defaultwert für CTUNE 1,8 kHz. Üblicherweise kann der Proportional-Anteil des Stromreglers MLGQ um mehr als 50 % vergrößert werden.

Mit 0 oder 1 ist der Smith Predictor ausgeschaltet.


ASCII Deutsch FLTCNT

ASCII - Kommando | FLTCNT |
Syntax Senden | FLTCNT |
Syntax Empfangen | FLTCNT <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0, 65535 per Fault Message | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando FLTCNT gibt eine Aufstellung aller möglichen Fehlermeldungen mit der zugehörigen Anzahl der bisher aufgetretenen Fehler im Klartext aus. Vor der eigentlichen Fehlerliste wird die Gesamtzahl der Fehler (Summe der Einzelfehler) ausgegeben.


ASCII Deutsch FLTCNT *

ASCII - Kommando | FLTCNT * |
Syntax Senden | FLTCNT * |
Syntax Empfangen | FLTCNT * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 1 x Integer32 + 32 x Integer16 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando liefert eine Liste von 33 Zahlen:
Zahl 1. Gesamtzahl der Fehler (Integer32)
Zahl 2. Anzahl des Auftretens für den Fehler F01
Zahl 3. Anzahl des Auftretens für den Fehler F02
..........
Zahl 33. Anzahl des Auftretens für den Fehler F32


ASCII Deutsch FLTHIST

ASCII - Kommando | FLTHIST |
Syntax Senden | FLTHIST |
Syntax Empfangen | FLTHIST <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | Number and TRUN | PROFIBUS PNU | -
Bereich | 10 No. of Last Messages+Times | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie den zugehörigen Betriebsstundenstand beim Auftreten des Fehlers im Klartext aus.


ASCII Deutsch FLTHIST *

ASCII - Kommando | FLTHIST * |
Syntax Senden | FLTHIST * |
Syntax Empfangen | FLTHIST * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 20 x Integer32 | CANBus Objektnummer | -
DIM | Number and TRUN | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST * gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie dem zugehörigen Betriebsstundenstand beim Auftreten des Fehlers als Zahlen aus.
Die Ausgabe sieht wie folgt aus:
n1 t1 n2 t2 n3 t3 ....n10 t10
n - Fehlernummer
t - Zeitpunkt des Auftretens (Betriebsstundenzähler) [in 1024/60000 Minuten]


ASCII Deutsch FW

ASCII - Kommando | FW |
Syntax Senden | FW |
Syntax Empfangen | FW <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3657 (hex)
DIM | - | PROFIBUS PNU | 1943 (dec) IND = 1 (dec)
Bereich | - | DPR | 343 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Liefert die Versionsnummer der Firmware

Beschreibung

Das Kommando FW liefert die Versionsnummer der aktuellen Firmware. Das Kommando erscheint in der Ausgabe des DUMP-Kommandos und damit gehört es zum Parametersatz des Verstärkers.


ASCII Deutsch GEARFILT

ASCII - Kommando | GEARFILT |
Syntax Senden | GEARFILT [Data] |
Syntax Empfangen | GEARFILT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D6 (hex)
DIM | - | PROFIBUS PNU | 1670 (dec) IND = 17 (dec)
Bereich | 0 .. 16 | DPR | Nein
Default | 4 |
Opmode | 4 | Datentyp Bus/DPR | Command
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | -
Kurzbeschreibung | Tiefpaßfilter zweiter Ordnung (OPMODE=4)

Beschreibung

Beim elektronischen Getriebe ( OPMODE = 4 ), kann ein Tiefpaßfilter zweiter Ordnung aktiviert werden, um den Sollwert zu glätten. Der Befehl GEARFILT setzt hierbei die Frequenz fest.

GEARFILT f (HZ)
1 318
2 159
3 80
4 40
5 20
6 10
7 5
8 2.5

Der Filter sollte nur benutzt werden wenn es bei der Anwendung notwendig ist, da er eine dynamische Verzögerung zwischen Master und Slave hervorruft. Standardmäßig kann GEARFILT = 4 mit 40 Hz Einsatzfrequenz gewählt werden.

GEARFILT=0 : Filter abgeschaltet


ASCII Deutsch GEARI

ASCII - Kommando | GEARI |
Syntax Senden | GEARI [Data] |
Syntax Empfangen | GEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 353E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 1 (dec)
Bereich | -2147483648 ... 2147483647 | DPR | 62 (dec)
Default | 1024 |
Opmode | 4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Eingangsfaktor "elektronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.

Bei Master/Slave-Betrieb kann mit den Parametern GEARI und GEARO das Master/Slave-
Übersetzungsverhältnis eingestellt werden. Dabei gilt folgendes:

1. Bei allen Positionsquellen, die analog erfasst werden d.h. GEARMODE=6...9
wird die Position anhand der ENCLINES-Einstellung erfasst und in
das 32Bit/Umdrehung-Format konvertiert.
Die Parameter GEARI/GEARO beschreiben das reine Gearing-Verhältnis. Bei GEARI-Umdrehungen des Gebers macht der Motor GEARO Umdrehungen.
z.B: GEARI=10,GEARO=3 -> Übersetungsverhältnis 10 zu 3

2. Bei einem SSI-Geber (GEARMODE=5) wird die Position anhand der Einstellungen SSIRXD und SSIREVOL
berechnet und in das 32Bit/Umdrehung-Format konvertiert. Die Parameter GEARI/GEARO beschreiben
das reine Gearing-Verhältnis. Bei GEARI-Umdrehungen des Gebers macht der Motor GEARO Umdrehungen.

3. Bei allen Positionsquellen, die digital erfasst werden d.h GEARMODE=1...4, beschreibt der Parameter GEARI die Anzahl der Geberimpulse die eine Drehung des Motors um GEARO Umdrehungen bewirken.

z.B:
ein externer ROD-Geber liefert 1024 Impulse pro Umdrehung, bei 1 Geber-Umdrehung
soll der Motor 3 Umdrehungen machen. Es sind folgende Einstellungen notwendig:
GEARI = 1024, GEARO= 3


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Elektronisches Getriebe

einheiten

Wenn der Servoverstärker als Slave einer Sollwertvorgabe folgen soll, können Sie hier die Sollwertquelle wählen und eine Übersetzung einstellen.

Bildschirmtext | ASCII-Parameter
Quelle für Master-Sollwertvorgabe | GEARMODE
Zählrichtung | DIR
Übersetzungsverhältnis (Zähler) | GEARO
Übersetzungsverhältnis (Nenner) | GEARI
Eingangs-Filter | GEARFILT


ASCII Deutsch GEARMODE

ASCII - Kommando | GEARMODE |
Syntax Senden | GEARMODE [Data] |
Syntax Empfangen | GEARMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 1 (dec)
Bereich | 0 .. 30 | DPR | 63 (dec)
Default | 0 |
Opmode | 4 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Masterschnittstelle für "elektronisches Getriebe"

Beschreibung

Mit dem Parameter GEARMODE kann die Quelle für die Master-Sollwertvorgabe (Position) konfiguriert werden. Es ist möglich gleichzeitig Resolver, Sincos und ROD-Signale auszuwerten. Damit kann der Resolver für die Kommutierung, Sincos für die externe Lageregelung und ROD für Master/Slave-Funktion eingesetzt werden. Um diese Funktion zu nutzen müssen folgende Einstellungen gemacht werden: EXTPOS= 1...3 (Einlesen der Position für externe Lageregelung)
Zustand | Schnittstelle | Beschreibung
GEARMODE=0 | - | Kein Geber
GEARMODE=1 | X3 (24V Puls/Richtung) | Puls/Richtungseingang an X3, 24V INPUT1=Richtung (Low=positiv, High=negativ) INPUT2=Pulse Es müssen keine weiteren Eingangsfunktionen angewählt werden. Falls welche ausgewählt wurden, so werden diese ignoriert.
GEARMODE=2 | X3 (24V ROD) | Digital Encoder
GEARMODE=3 | X5 (5V ROD) | Digital Encoder Encoder Folger an X5. An X5 kann ein Inkrementalgeber mit 5V - A/B-Signalen angeschlossen werden. ENCMODE muss auf "0" gesetzt werden.
GEARMODE=4 | X5 (5V Puls/Richtung) | Puls/Richtung an ENCMODE muss auf "0" gesetzt werden.
GEARMODE=5 | X5 (SSI) | SSI an X5
GEARMODE=6 | X1 (5V) | Sinus Encoder Nur analoge Auswertung.
GEARMODE=7 | X1 (12V) | Sinus Encoder Nur analoge Auswertung.
GEARMODE=8 | X1 (EnDat) | Der Unterschied zu GEARMODE=6 ist, dass auch der Parameterkanal gelesen wird und damit die absolute Position zur Verfügung steht. ENCLINES wird automatisch auf si eingestellt, dass die interne Scalierung auf 20Bit pro Umdrehung des Gebers eingestellt ist. Der Positionswert kann nur zur Positionierung bei EXTPOS=1 verwendet werden. Ein weiterer Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog eingelesen werden.
GEARMODE=9 | X1 (HIPERFACE) | Der Unterschied zu GEARMODE=6 ist, dass auch der Parameterkanal gelesen wird und damit die absolute Position zur Verfügung steht. ENCLINES wird automatisch auf si eingestellt, dass die interne Scalierung auf 20Bit pro Umdrehung des Gebers eingestellt ist. Der Positionswert kann nur zur Positionierung bei EXTPOS=1 verwendet werden. Ein weiterer Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog eingelesen werden.
GEARMODE=10 | X1 (5V ROD) | ROD-Geber als Quelle für die Master/Slave-Sollwertvorgabe (OPMODE=4)
GEARMODE=25 | X1 (SSI) | SSI an X1
GEARMODE=27 | X1 (5V) | Plus/Richtung Nur digitale Auswertung
GEARMODE=30 | X1 (ROD) | ROD (A QUAD B) Nur digitale Auswertung.


ASCII Deutsch GEARO

ASCII - Kommando | GEARO |
Syntax Senden | GEARO [Data] |
Syntax Empfangen | GEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3540 (hex)
DIM | - | PROFIBUS PNU | 1664 (dec) IND = 1 (dec)
Bereich | 0 .. 2147483647 | DPR | 64 (dec)
Default | 1 |
Opmode | 4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Ausgangsfaktor "elektronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.

Bei Master/Slave-Betrieb kann mit den Parametern GEARI und GEARO das Master/Slave-
Übersetzungsverhältnis eingestellt werden. Dabei gilt folgendes:

1. Bei allen Positionsquellen, die analog erfasst werden d.h. GEARMODE=6...9
wird die Position anhand der ENCLINES-Einstellung erfasst und in
das 32Bit/Umdrehung-Format konvertiert. Die Parameter GEARI/GEARO beschreiben
das reine Gearing-Faktor. Bei GEARI-Umdrehungen des Gebers macht der Motor
GEARO Umdrehungen.
z.B: GEARI=10,GEARO=3 -> Übersetungsverhältnis 10 zu 3

2. Bei allen Positionsquellen, die digital erfasst werden d.h GEARMODE=1...5,
beschreibt der Parameter GEARI die Anzahl der Geberimpulse die eine Drehung
des Motors um GEARO Umdrehungen bewirken.
z.B:
ein externer ROD-Geber liefert 1024 Impulse pro Umdrehung, bei 1 Geber-Umdrehung
soll der Motor 3 Umdrehungen machen. Es sind folgende Einstellungen notwendig:
GEARI = 1024, GEARO 3


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Allgemeines

Einführung

Diese Dokumentation beschreibt die Inbetriebnahmesoftware DRIVEGUI.EXE für die Parametrierung und Inbetriebnahme der Servoverstärker. Eine detaillierte Beschreibung der einzelnen Funktionen und Parameter finden Sie in der ASCII-Befehlsreferenz (Teil der Online-Hilfe der Software)
Die Inbetriebnahmesoftware muss auf einem Personal-Computer (PC) installiert werden. Der PC ist mit einer Übertragungsleitung mit dem Servoverstärker verbunden. Die Inbetriebnahmesoftware stellt die Kommunikation zwischen PC und Servoverstärker her.
ie können mit wenig Aufwand Parameter ändern und die Wirkung sofort am Antrieb erkennen, da eine ständige Verbindung (online Verbindung) zum Verstärker besteht. Gleichzeitig werden wichtige Istwerte aus dem Verstärker eingelesen und am PC-Monitor angezeigt (Oszilloskop-Funktionen).
Eventuell im Verstärker eingebaute Interface-Module (Erweiterungskarten) werden automatisch erkannt und die erforderlichen zusätzlichen Parameter zur Lageregelung oder Fahrsatzdefinition zur Verfügung gestellt.
Sie können Datensätze auf einem Datenträger speichern (archivieren) und wieder laden. Die Datensätze können Sie ausdrucken.

Bedienung der Online-Hilfe

Die Online-Hilfe ist wie eine Internetseite aufgebaut und zu bedienen.

helpscreen

Navigation

Das Navigationsfenster mit Inhaltsverzeichnis ist nur sichtbar, wenn Sie die Online-Hilfe über die Menüleiste des Inbetriebnahme-Programms aufgerufen haben. Wenn Sie die Kontexthilfe verwenden oder F1, wird nur das Informationsfenster und das Suchfenster eingeblendet. In jedem Fall können Sie über das Symbol "Startseite" die Onlinehilfe in Volldarstellung neu öffnen.

Volltextsuche

Die Schaltfläche "Ein-/Ausblenden" aktiviert/deaktiviert die Volltextsuche. Benutzen Sie Platzhalter (? bzw. *) wie unter Windows üblich.
Wenn beim ersten Aufruf des Hilfesystems das Fenster zur Eingabe des Suchbegriffs trotz Betätigen der Schaltfläche EINBLENDEN nicht erscheint, ist die Spaltenbreite des Suchfensters durch das Betriebssystem mit "0" vordefiniert. Verändern Sie in diesem Fall die Spaltenbreite durch Ziehen der grauen Spaltentrennlinie am linken Fensterrand wie unter WINDOWS üblich.

Verwendete Symbole

Symbol / Warnwort | Bedeutung
0gefahr | Weist auf eine gefährliche Situation hin, die, wenn sie nicht vermieden wird, zum Tode oder zu schweren, irreversiblen Verletzungen führen wird.
0warnung | Weist auf eine gefährliche Situation hin, die, wenn sie nicht vermieden wird, zum Tode oder zu schweren, irreversiblen Verletzungen führen kann.
0danger - color | Weist auf eine gefährliche Situation hin, die, wenn sie nicht vermieden wird, zu leichten Verletzungen führen kann.
 | Dies ist kein Sicherheits-Symbol. Dieses Symbol weist auf eine Situation hin, die, wenn sie nicht vermieden wird, zu Beschädigung von Sachen führen kann.
 | Dies ist kein Sicherheits-Symbol. Dieses Symbol weist auf wichtige Informationen hin.
 | Warnung vor einer Gefahr (allgemein). Die Art der Gefahr wird durch den nebenstehenden Warntext spezifiziert.
 | Warnung vor gefährlicher elektrischer Spannung und deren Wirkung.
 | Warnung vor Gefahren durch heiße Oberfläche.
 | Warnung vor Gefahren durch hängende Last.
 | Warnung vor Gefahren durch automatischen Anlauf.

Zu Ihrer Sicherheit

Dieses Kapitel hilft Ihnen, Gefährdungen für Personen und Sachen zu erkennen und zu vermeiden.

Das sollten Sie beachten

Dokumentation lesen

Lesen Sie vor der Montage und Inbetriebnahme die Betriebsanleitungen des Servoverstärkers und des verwendeten Motors. Falsches Handhaben des Servoverstärkers kann zu Personen- oder Sachschäden führen. Der Betreiber muss daher sicherstellen, dass alle mit Arbeiten am Servoverstärker betrauten Personen die Betriebsanleitung des Servoverstärkers gelesen und verstanden haben und dass die Sicherheitshinweise in diesem Handbuch beachtet werden.

Risikobeurteilung erstellen

Der Maschinenhersteller muss eine Risikobeurteilung für die Maschine erstellen und geeignete Maßnahmen treffen, dass unvorhergesehene Bewegungen nicht zu Schäden an Personen oder Sachen führen können. Aus der Risikobeurteilung leiten sich eventuell auch zusätzliche Anforderungen an das Fachpersonal ab.

Fachpersonal erforderlich

Für Arbeiten wie Transport, Installation, Inbetriebnahme und Instandhaltung darf nur qualifiziertes Personal eingesetzt werden. Qualifiziertes Personal sind Personen, die mit Transport, Installation, Inbetriebnahme von elektrischen Antrieben vertraut sind.

  • Transport, Lagerung, Auspacken: nur durch Personal mit Kenntnissen in der
    Behandlung elektrostatisch gefährdeter Bauelemente.
  • Mechanische Installation: nur durch Personal mit Kenntnissen in mechanischen Arbeiten.
  • Elektrische Installation: nur durch Personal mit Kenntnissen in elektrotechnischen Arbeiten.
  • Inbetriebnahme: nur durch Fachleute mit weitreichenden Kenntnissen in den Bereichen Elektrotechnik und Antriebstechnik.

Das Fachpersonal muss ebenfalls IEC 60364 / IEC 60664 und nationale Unfallverhütungsvorschriften kennen und beachten.

Hardware Revision prüfen

Prüfen Sie die Hardware Revisionsnummer (siehe Typenschild). Diese Nummer muss mit den Angaben auf der Titelseite der Betriebsanleitung übereinstimmen. Wenn die Nummern nicht übereinstimmen, besuchen Sie das Europäische Dateiarchiv. Dort finden Sie alle Handbuchversionen mit Bezug zur Hardware Revisionsnummer.

Technische Daten beachten

Halten Sie die technischen Daten und die Angaben zu den Anschlussbedingungen (Typenschild und Dokumentation) ein. Wenn zulässige Spannungswerte oder Stromwerte überschritten werden, können die Geräte geschädigt oder zerstört werden. Ein ungeeigneter Motor oder fehlerhafte Verdrahtung beschädigen die Systemkomponenten. Prüfen Sie die Kombination aus Verstärker und Motor. Gleichen Sie die Nennspannung und den Nennstrom der Komponenten ab.

Elektrostatische Aufladung beachten

Die Servoverstärker enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können. Entladen Sie Ihren Körper, bevor Sie den Servoverstärker berühren. Vermeiden Sie den Kontakt mit hochisolierenden Stoffen (Kunstfaser, Kunststofffolien etc.). Legen Sie den Servoverstärker auf eine leitfähige Unterlage.

Automatischer Wiederanlauf

Der Antrieb kann abhängig von der Parametereinstellung nach dem Einschalten der Netzspannung, bei Spannungseinbrüchen oder Unterbrechungen automatisch anlaufen. Es besteht die Gefahr von tödlichen oder schweren Verletzungen für Personen, die in der Maschine arbeiten.
Wenn der Parameter AENA auf 1 gesetzt ist, warnen Sie an der Maschine mit einem Warnschild (Warnung: Automatischer Wiederanlauf nach Einschalten!) und stellen Sie sicher, dass ein Einschalten der Netzspannung nicht möglich ist, während sich Personen im gefährdeten Bereich der Maschine aufhalten. Wenn Sie einen Unterspannungsschutz benutzen, beachten Sie Kapitel 7.5 der EN60204-1:2006.

Heiße Oberflächen

Während des Betriebes können Servoverstärker heiße Oberflächen besitzen. Die Oberflächentemperatur kann 80°C überschreiten. Gefahr leichter Verbrennungen! Messen Sie die Temperatur und warten Sie, bis der Servoverstärker auf 40°C abgekühlt ist, bevor Sie ihn berühren.

Erdung

Stellen Sie die ordnungsgemäße Erdung des Gerätes mit der PE-Schiene im Schaltschrank als Bezugspotential sicher. Ohne niederohmige Erdung ist keine personelle Sicherheit gewährleistet und es besteht Lebensgefahr durch elektrischen Schlag.

Ableitstrom

Da der Ableitstrom zu PE mehr als 3,5 mA beträgt, muss in Übereinstimmung mit der Norm EN61800-5-1 der PE-Anschluss entweder doppelt ausgeführt oder ein Anschlusskabel mit einem Querschnitt von >10 mm² verwendet werden. Abweichende Maßnahmen sind in Übereinstimmung mit regionalen Vorschriften möglich.

Hohe Spannungen

Halten Sie während des Betriebs der Geräte den Schaltschrank geschlossen. Das Fehlen von optische Anzeigen gewährleisten nicht die Spannungsfreiheit. Leistungsanschlüsse können Spannung führen, auch wenn sich der Motor nicht dreht.

Ziehen Sie keine Stecker während des Betriebs. Es besteht die Gefahr von Tod oder schweren gesundheitlichen Schäden beim Berühren freiliegender Kontakte. In ungünstigen Fällen können Lichtbögen entstehen und Personen und Kontakte schädigen.

Warten Sie nach dem Trennen der Servoverstärker von den Versorgungsspannungen mehrere Minuten, bevor Sie spannungsführende Teile (z.B. Kontakte, Gewindebolzen) berühren oder Anschlüsse lösen. Kondensatoren im Servoverstärker führen mehrere Minuten nach Abschalten der Versorgungsspannungen gefährliche Spannungen. Messen Sie zur Sicherheit die Spannung im Zwischenkreis und warten Sie, bis die Spannung unter 50V abgesunken ist.

Verstärkte Isolierung

Im Motor eingebaute Temperaturfühler, Motorhaltebremsen und Rückführsysteme müssen mit einer verstärkten Isolierung (gem. EN 61800-5-1) gegenüber Systemkomponenten mit Leistungsspannung versehen sein, entsprechend der geforderten Prüfspannung der Applikation.

Parameter vor dem Einschalten prüfen

Auf Datenträger gespeicherte Datensätze sind nicht gesichert gegen ungewollte Veränderung durch Dritte. Nach Laden eines Datensatzes müssen Sie daher grundsätzlich alle Parameter prüfen, bevor Sie den Servoverstärker freigeben.

Geräte nicht verändern

Die Setup-Software kann verwendet werden, um die Einstellungen des Verstärkers zu ändern. Jede weitere Veränderung führt zum Erlöschen der Gewährleistung. Öffnen der Geräte bedeutet Verlust der Gewährleistung und alle Zertifikate der Geräte verlieren ihre Gültigkeit.
Am Gehäuse sind Warnsymbole angebracht. Beschädigte Warnsymbole müssen sofort ersetzt werden.

Bestimmungsgemäße Verwendung

Die Servoverstärker werden als Sicherheitsbauteile in elektrische Anlagen oder Maschinen eingebaut und dürfen nur als integrierte Komponenten der Anlage in Betrieb genommen werden.

Der Maschinenhersteller muss eine Risikobeurteilung für die Maschine erstellen und geeignete Maßnahmen treffen, dass unvorhergesehene Bewegungen nicht zu Schäden an Personen oder Sachen führen können.

Bei Einsatz der Servoverstärker im Wohnbereich, in Geschäfts- und Gewerbebereichen sowie Kleinbetrieben müssen Sie zusätzliche Filtermaßnahmen treffen.

Einbau und Verdrahtung

Sie dürfen die Servoverstärker nur im geschlossenen Schaltschrank unter Berücksichtigung der auf Seite definierten Umgebungsbedingungen betreiben. Um die Schaltschranktemperatur unter 40°C zu halten, kann Belüftung oder Kühlung erforderlich sein.

Verwenden Sie nur Kupferleitungen zur Verdrahtung. Die Leiterquerschnitte ergeben sich aus der Norm EN 60204 (bzw. Tabelle 310-16 der NEC 60°C oder 75°C Spalte für AWG Querschnitte).

Spannungsversorgung

Syxx0 : Die Servoverstärker der Serie S3xx0/S7xx0 (Überspannungskategorie III gem. EN 61800-5-1) können direkt an dreiphasigen, geerdeten Industrienetzen (TN-Netz, TT-Netz mit geerdetem Sternpunkt, max. 42kA symmetrischer Nennstrom) bei 208V-10%, 230V, 240V, 400V oder 480V+10% angeschlossen werden.

Syxx6 : Die Servoverstärker der Serie S3xx6/S7xx6 (Überspannungskategorie III gem. EN 61800-5-1) können direkt an einphasigen oder dreiphasigen, geerdeten Industrienetzen (TN-Netz, TT-Netz mit geerdetem Sternpunkt, max. 42kA symmetrischer Nennstrom) bei 110V-10% bis 230V+10% angeschlossen werden.

Periodische Überspannungen zwischen Außenleitern (L1, L2, L3) und Gehäuse des Servoverstärkers dürfen 1000V (Amplitude) nicht überschreiten.
Gemäß EN 61800 dürfen Spannungsspitzen (< 50µs) zwischen den Außenleitern 1000V nicht überschreiten. Spannungsspitzen (< 50µs) zwischen Außenleitern und Gehäuse dürfen 2000V nicht überschreiten.

Motoren

Die Servoverstärker sind ausschließlich dazu bestimmt, geeignete bürstenlose Synchron-Servomotoren, Asynchronmotoren oder Gleichstrom-/VoiceCoil-Motoren drehmoment-, drehzahl- und/oder lagegeregelt anzutreiben.

Die Nennspannung der Motoren muss höher oder mindestens gleich der vom Servoverstärker gelieferten Zwischenkreisspannung dividiert durch [image] sein (UnMotor ³ UDC/ [image]).

Sicherheit

Die Sicherheitsfunktion STO ist ausschließlich dazu bestimmt, einen Antrieb funktional sicher gegen Wiederanlauf zu sichern. Um die funktionale Sicherheit zu erreichen, muss die Schaltung des Sicherheitskreises die Sicherheitsanforderungen der EN 60204, EN 12100, EN 62061 bzw. EN 13849-1 erfüllen.

Wenn STO von einer Steuerung automatisch angesteuert wird, muss sichergestellt sein, dass der Ausgang der Steuerung gegen Fehlfunktion überwacht wird.

SIL3/PLe wird bei zweikanaligem Ansteuern der Eingänge STO1-ENABLE und STO2-ENABLE nur erreicht, wenn das sichere Schalten der Impulssperre periodisch getestet wird.

Bei Verwendung der Safety Karte S3 bzw. S4 beachten Sie die Bedienungsanleitungen der Sicherheitskarten.

Nicht bestimmungsgemäße Verwendung

Eine andere Verwendung als in der bestimmungsgemäßen Verwendung beschrieben ist nicht bestimmungsgemäß und kann zu Schäden bei Personen, Gerät oder Sachen führen.

Der Betrieb des Servoverstärkers in folgenden Umgebungen ist verboten:
- explosionsgefährdete Bereiche und Umgebungen mit ätzenden und/oder
elektrisch leitenden Säuren, Laugen, Ölen, Dämpfen, Stäuben
- direkt an ungeerdeten oder unsymmetrisch geerdeten Netzen mit UN >240V
- auf Schiffen oder in Off-Shore Anlagen

Der bestimmungsgemäße Betrieb des Servoverstärkers ist untersagt, wenn die Maschine, in die er eingebaut wurde,
- nicht den Bestimmungen der EG Maschinenrichtlinie entspricht
- nicht die Bestimmung der EMV-Richtlinie erfüllt
- nicht die Bestimmung der Niederspannungs-Richtlinie erfüllt

Die Ansteuerung von Haltebremsen durch den Servoverstärker alleine darf nicht in Anwendungen verwendet werden, wo mit der Bremse die funktionale Sicherheit gewährleistet werden soll.

Die Sicherheitsfunktion STO darf nicht verwendet werden, wenn der Antrieb aus folgenden Gründen stillgesetzt werden soll :
- Reinigungs-, Wartungs- und Instandsetzungsarbeiten, lange Betriebsunterbrechungen.
In diesen Fällen muss die gesamte Anlage vom Personal spannungsfrei geschaltet und gesichert
werden (Hauptschalter).
- Not-Aus Situationen. Im Not-Aus Fall wird das Netzschütz abgeschaltet (Not-Aus Taster).

ASCII Objekt-Referenz

Integriert in diese Online-Hilfe ist eine Objekt-Referenz der Firmware des Servoverstärkers. Alle Funktionen und Parameter werden mit allen Features beschrieben.

Die Referenz öffnet sich in einem eigenen Bildschirmfenster: ASCII Objekt-Referenz

Übersicht Servoantriebe

Dieser Abschnitt ist eine kurze Einführung in die Technik der Servoantriebe.

Was ist ein Servoantrieb?
Ein Servoantrieb umfasst grundsätzlich einen intelligenten Servoverstärker und einen Servomotor, der in Verbindung mit einer SPS oder CNC für komplexe, spezialisierte Bewegungen in eine oder mehrere Richtungen sorgt. Diese komplexen und spezialisierten Bewegungen, die für die Automation industrieller Aufgaben notwendig sind, werden als Motion Control bezeichnet.

Servoantriebe werden in vielfältigen Bereichen zur Automation eingesetzt - im Automobilbau, bei der Rohölveredelung, in der Textilindustrie, bei Verpackungssystemen, in der Lagerhaltung und vieles mehr.

Servoantriebe mit geschlossenem Regelkreis
In einem Servoantrieb werden Rotorlage und Drehzahl vom Rückführsystem im Motor zurück zum Servoverstärker gemeldet. Der Servoverstärker wertet die Rückmeldung aus, vergleicht die Werte mit den Vorgaben und erzeugt dann entsprechende Ströme, um den Motor auf die vorgegebene Drehzahl zu regeln. Dieser Ablauf wird in einem geschlossenen Regelkreis ständig wiederholt. Ein Regelkreis, der die Position der Welle oder Last regelt, wird Lageregelkreis genannt, ein Regelkreis, der die Drehzahl des Motors auf dem vorgegebenen Wert hält, ist ein Drehzahlregelkreis.

Bestandteile eines Servoantriebs
Ein Servoantrieb besteht aus:

Servomotor

Ein Servomotor treibt eine Achse einer Maschine an.

Servomotoren werden durch Magnetfelder angetrieben. Sie haben ein von den Permanentmagneten erzeugtes stationäres Magnetfeld und ein von der Statorwicklung erzeugtes Drehfeld. Sie arbeiten nach dem Prinzip des Synchronmotors. Der Rotor eines drehenden Motors ist an beiden Enden gelagert.

Jeder Motor hat mindestens zwei magnetische Pole, zumeist aber vier oder sechs. Durch den Servoverstärker wird der Statorstrom im Motor so erzeugt, dass ein steuerbares Drehmoment an der Motorwelle zur Verfügung steht.

Servomotoren drehen (fahren) in zwei Richtungen – positiv und negativ. Zwei Arten der Drehwinkelmessung sind in der Antriebstechnik gebräuchlich – in Grad und in RAD, wobei eine Umdrehung 360° oder 2p RAD entspricht.

Der Servoverstärker arbeitet mit Servo-Synchronmotoren und mit Direktantrieben (rotatorisch oder linear). Außerdem können Asynchronmotoren und Gleichstrommotoren betrieben werden. Weitere Informationen finden Sie in den Motorhandbüchern.

Motor Optimierung

Die besten Laufeigenschaften eines Servomotors können nur durch die richtige Optimierung des Servoverstärkers erreicht werden. Angefangen bei voreingestellten Parametern (Stromregler wird automatisch durch Wahl des verwendeten Motors optimiert) muss der Drehzahlregler so eingestellt werden, dass sich bei einer Sprungantwort ein möglichst schnelles Einschwingen des Drehzahlistwertes auf den Sollwert ergibt. Hierbei ist darauf zu achten, dass dieses Einschwingen mit nur einem Überschwinger erreicht wird. Wenn der Positionsregler eingesetzt wird, so muss dieser anschließend so eingestellt werden, dass sich ein möglichst kleiner Schleppfehler (Abweichung zwischen Positionssoll- und istwert) ergibt. Bitte beachten Sie auch die Hinweise zum Setup unbekannter Motoren.

Last

Die Last sind Teile einer Maschine, die von einem Motor angetrieben werden. Der Motor muss so ausgelegt sein, dass die Anforderungen an die Dynamik und Laufruhe der Maschine erfüllt werden. Ein Servosystem liefert Antriebsenergie an die Last z.B. über folgende mechanische Anbindungen:

Direktantrieb
Der Motor ist direkt mit z.B. einem Rundtisch verbunden.

Spindelantrieb
Der Motor bewegt die Last über eine Spindel.

Zahnstange und Ritzel
Der Motor bewegt über ein Zahnrad eine Last, die mit einer Zahnstange verbunden ist.

Riemenantrieb
Der Motor bewegt die Last über einen Zahnriemen.

Rückführeinheit

Jeder Servoverstärker benötigt eine Rückführeinheit, die die aktuelle Position und Drehzahl des Motors zur Verfügung stellt. Abhängig von der Rückführeinheit werden die Informationen als digitale oder analoge Signale übermittelt. Zwei Arten von Rückführeinheiten werden unterstützt:

Encoder – Übermittelt analoge oder digitale Signale (optisch)

Resolver – Übermittelt analoge Signale (magnetisch)

Servoverstärker

Der Servoverstärker besteht aus einer dreiphasigen Leistungsendstufe, der Spannungsversorgung und einem Microcontrollersystem. Die verschiedenen Regelkreise sind vollständig digital im Microcontrollersystem realisiert.

Rückführeinheiten

Die Servomotoren sind mit verschiedenen Rückführeinheiten (auch Feedback genannt) erhältlich, u.a. mit:

  • Resolver
  • Encoder
  • Inkrementalgeber mit HALL

In einem System, welches mit geschlossenen Regelkreisen arbeitet, wird die von der Rückführeinheit erfasste Position zur Kommutierung des Motors benutzt.
Außerdem ist noch eine Kaskadenregelung für Strom-, Drehzahl- und Positionsregelung integriert.
Die Drehzahlinformation wird durch die Ableitung der Position berechnet.
Der Stromregler wird auch als Drehmomentregler bezeichnet, da das Drehmoment direkt proportional zum Strom ist. Eine Übersicht über die verfügbaren Feedbacksysteme finden Sie im KDN auf Seite Multi-Feedback.

Resolver
Den Resolver kann man sich als Transformator vorstellen, dessen Kopplungen der Sekundärwicklungen (Sinus und Cosinus) sich mit der Position der Antriebswelle ändern. Damit kann eine absolute Position innerhalb einer Umdrehung bestimmt werden. Der Resolver wird mit einer sinusförmigen Spannung erregt. Die Erregerspannung und die beiden Ausgangsspannungen haben eine kleine Amplitude und sind empfindlich gegen Störungen. Der Servoverstärker kann zwei- und mehrpolige Resolver unterstützen, um die aktuelle Position und Drehzahl der Motorwelle zu berechnen.

Encoder
Encoder sind optische oder induktive Messsysteme, die am Ausgang Signale zur aktuellen Position des Motors zur Verfügung stellen. Es werden zwei Arten von Encodern unterschieden: rotatorische und lineare Encoder. Rotatorische Geber werden bei Standardmotoren auf der Motorwelle montiert. Lineare Encoder werden typischerweise an der Last direkt montiert.

Das Bewegungsprofil

Übersicht
Bewegungsabläufe werden einheitlich in einem Diagramm, genannt Bewegungsprofil, dargestellt. Das Verstehen und Umsetzen von Bewegungsprofilen in der Anwendung ist ein wichtiger Schritt, um die bestmögliche Systemleistung zu erreichen.

Das Bewegungsprofil ist die Darstellung einer oder mehrerer Bewegungsabläufe über der Zeitachse.

Vorgegebene Bewegung: die Bewegung, die der Motor idealerweise fehlerfrei ausführen sollte, wenn er eine Drehzahl- oder Lagevorgabe erhält.

Tatsächliche Bewegung: die Bewegung, die tatsächlich vom Motor ausgeführt wird, wenn er eine Drehzahl- oder Lagevorgabe erhält.

Die Lücke zwischen Sollwert und Istwert schließen
Die beste Systemleistung wird erreicht, wenn die Abweichung zwischen vorgegebener und tatsächlicher Bewegung möglichst gut ausgeregelt werden kann. Die Abweichung wird Schleppfehler genannt. Den Servoantrieb zu optimieren bedeutet, die relevanten Parameter im Verstärker so einzustellen, dass die Abweichung statisch und dynamisch möglichst optimal ausgeregelt werden kann.

Merkmale von Bewegungsprofilen
Die Profile haben folgende Merkmale, die allen Bewegungsabläufen gemein sind:
Es werden Sollposition, maximale Geschwindigkeit und Beschleunigungs-/Bremsrampen definiert.

Merkmal | Bedeutung
Bewegung | Bewegung wird durch den Befehl, eine Zielposition anzufahren, gestartet. Durch das Bewegungsprofil mit Rampen und maximaler Geschwindigkeit werden immer wieder neue Positionssollwerte vorgegeben. Die Position, an der die Bewegung gestoppt wird, wird als Zielposition bezeichnet.
In Position | Wenn die tatsächliche Position des Antriebs in den Bereich der Zielposition kommt, wird die Differenz mit dem In-Positionsfenster verglichen. Ist die Differenz kleiner als das In-Positionsfenster, so wird eine In-Positionsmeldung ausgegeben.

Arbeitsbereiche und -begrenzungen

Übersicht
Ein wichtiger Schritt zur Erhöhung der Maschinensicherheit ist das Festlegen sicherer Arbeitsbereiche und -begrenzungen.

Zwei Arten der Einstellung
Es gibt zwei Arten, Betriebsbereiche und -begrenzungen festzulegen:

Einstellungsart | Bedeutung
Abschaltung bei Überschreitung der Arbeitsbereiche | Im Servoverstärker sind verschiedene Überwachungsmöglichkeiten eingebaut, die bewirken, dass Strom, Drehzahl oder Position so begrenzt werden, dass gefährliche Zustände zum Abschalten des Verstärkers führen um Maschinenschaden zu vermeiden. Zum Beispiel muss jede Positionierachse die in Positionsregelung arbeitet, mit Hardware-Endschaltern ausgerüstet sein. Diese sollen ein Verfahren der Achse in die mechanischen Endanschläge verhindern. Zusätzlich können noch Software-Endschalter definiert werden. Die Differenz zwischen Soll- und Istposition wird Schleppfehler genannt. Eine Überwachung des Schleppfehlers über ein Schleppfehlerfenster verhindert ein Durchgehen des Motors.
Begrenzung der Arbeitsbereiche | Die Arbeitsbereiche definieren die Bedingungen, unter denen der Servoverstärker sicher arbeitet. Einige von diesen Arbeitsbereichen sind: — Der Stromregler besitzt eine Spitzen- und Dauerstrombegrenzung, um den Motor vor Überlastung zu schützen. — Im Positionsregler wird die Verfahrstrecke definiert, die festlegt, welche Strecke in positiver und negativer Richtung verfahren werden kann. — Das In-Positionfenster legt fest, ab welcher Entfernung von der Sollposition die Meldung "InPosition" ausgegeben werden soll

Beschleunigen und Bremsen

Übersicht
Wenn der Servoverstärker in Positionsregelung mit Fahrsätzen betrieben wird, können verschiedene Beschleunigungs/Bremsprofile ausgewählt werden. Welche Art bei einer Maschine eingesetzt werden soll, hängt davon ab, wie die Mechanik aufgebaut ist und welche Dynamik gefordert ist. Wenn es sich bei der Maschine um eine schwingfähige Mechanik handelt (Beispiel Roboterarm), so ist es ratsam die Sinus²-Rampe zu verwenden. Bei dieser Rampenart wird das Drehmoment linear verändert, so dass sich für den Drehzahlverlauf ein quadratischer Verlauf ergibt. Damit wird eine Schwingungsanregung der Mechanik verringert. Nachteil dieser Rampenart ist, dass sich die Beschleunigungs/Bremszeit bei gegebenem Drehmoment des Motors im Vergleich zu Trapezform verdoppelt.
Wenn es sich bei der Anwendung um eine mechanisch schwingungsarme Maschine handelt, die hochdynamisch beschleunigt/abgebremst werden soll, so empfiehlt sich der Einsatz der Trapez-Rampe. Hierbei kommt es zu einem Drehmomentsprung am Anfang und am Ende einer Beschleunigungs/Bremsrampe (zeitoptimal).

Zwei Arten des Beschleunigens/Bremsens
Die folgende Tabelle beschreibt die zwei grundsätzlichen Arten des Beschleunigens/Bremsens - linear und quadratisch. Ein Bewegungsprofil kann eine Kombination beider Arten umfassen.

Methode | Beschreibung
Trapez | Brems-/Beschleunigungsrate mit konstanter Geschwindigkeitszu-/abnahme.
Sinus² | Um einen Ruck zu vermeiden, wird der Antrieb innerhalb der Beschleunigungs-/Bremsrampe kontinuierlich beschleunigt/gebremst. Das Drehzahldiagramm gleicht einer Sinus²-Kurve.

Weitere Kurvenformen sind als Tabellen hinterlegt. Es ist möglich, eigene Profiltabellen zu erstellen. Informartionen hierzu finden Sie im KDN.


ASCII Deutsch GET

ASCII - Kommando | GET |
Syntax Senden | GET |
Syntax Empfangen | GET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3541 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 1 (dec)
Bereich | - | DPR | 65 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Ausgabe der aufgezeichneten SCOPE-Daten

Beschreibung

Das GET-Kommando liefert eine Liste mit den zuletzt aufgezeichneten SCOPE-Daten. Die Liste besteht aus n+3 Zeilen (n=Anzahl der aufgenommenen Daten)
Zeile 1: Kommentarzeile z.B. "Drive Recording"
Zeile 2: n,Zeitbasis in msek z.B. 10,0.25 (10 Datenzeilen, Zeitbasis 250 usek)
Zeile 3: var1,var2,var3 Namen der aufgezeichneten Variablen z.B. VCMD, V, ICMD
Zeile 4: data1,data2,data3 aufgezeichnete Daten z.B. 0,20.3, -0.5
Zeile 5: data1,dat2,data3
..
Zeile n+3: data1,data2,data3

s.auch RECORD, RECTRIG


ASCII Deutsch GF

ASCII - Kommando | GF |
Syntax Senden | GF [Data] |
Syntax Empfangen | GF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 ... 10 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Flussreglers.

Beschreibung

Bei GF handelt es sich um einen Parameter um den Grunddrehzahlbereich der Asynchronmaschine zu beeinflussen. Der Defaultwert für GF beträgt 1ms. Normalerweise kann sie auf diesem Wert belassen werden, da der Rotorfluss nur sehr langsam reagiert.

siehe auch GFTN


ASCII Deutsch GFTN

ASCII - Kommando | GFTN |
Syntax Senden | GFTN [Data] |
Syntax Empfangen | GFTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3907 (hex)
DIM | ms | PROFIBUS PNU | 1831 (dec) IND = 33 (dec)
Bereich | 1 .. 32000 | DPR | Nein
Default | 150 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Zeitkonstante vom Flussregler (Asynchronmaschine)

Beschreibung

Bei GFTN handelt es sich um einen Parameter um den Grunddrehzahlbereich der Asynchronmaschine zu beeinflussen. Der Defaultwert für GFTN beträgt 100ms. Normalerweise kann sie auf diesem Wert belassen werden, da der Rotorfluss nur sehr langsam reagiert.

siehe auch GF


ASCII Deutsch GP

ASCII - Kommando | GP |
Syntax Senden | GP [Data] |
Syntax Empfangen | GP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3542 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1666 (dec) IND = 1 (dec)
Bereich | 0.1 ... 1000 | DPR | 66 (dec)
Default | 0.1 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler: Proportionalverstärkung

Beschreibung

Mit dieser Variable wird die Proportionalverstärkung des Positionsregelkreises eingestellt. Wenn GP zu niedrig eingestellt ist, ist die Reaktionszeit zu lang und der Antrieb ist zu weich weich eingestellt. Wenn GP zu hoch eingestellt ist, schwingt der Antrieb.

Wenn die Parameter (GP=GP2) gleich sind, ist die Interpolation abgeschaltet was per default der Fall ist. Solange beide Parameter gleich sind, führt eine Änderung von GP zu automatischer Änderung von GP2, so dass sie weiterhin gleich bleiben. Erst wenn GP2 einmalig auf einen anderen Wert gesetzt wird als GP, ist die Kopplung aufgelöst und beide Parameter können separat modifiziert werden. Durch Setzen von GP2 auf GP wird Parameterkopplung wieder aktiviert.

Wer die die Interpolationsfunktion nicht braucht und nur GP benutzen, wird die Existenz von GP2 gar nicht merken.


ASCII Deutsch GP2

ASCII - Kommando | GP2 |
Syntax Senden | GP2 [Data] |
Syntax Empfangen | GP2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C3 (hex)
DIM | VUNIT | PROFIBUS PNU | 1763 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 963 (dec)
Default | 0.1 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Proport. bei Geschwindigkeiten höher als GPS2

Beschreibung

GP2 ist ein Parameter des Lageregelkreises und gibt den Proportionalanteil an falls die Geschwindigkeiten höher als GPS2 liegt.

Wenn die Parameter (GP=GP2) gleich sind, ist die Interpolation abgeschaltet was per default der Fall ist. Solange sie gleich sind, führt eine Änderung von GP zu automatischer Änderung von GP2, so dass sie weiterhin gleich bleiben. Erst wenn GP2 einmalig auf einen anderen Wert gesetzt wird als GP, ist die Kopplung aufgelöst und beide Parameter können separat modifiziert werden. Durch Setzen von GP2 auf GP wird Parameterkopplung wieder aktiviert.

Wer die die Interpolationsfunktion nicht braucht und nur GP benutzen, wird die Existenz von GP2 gar nicht merken.


ASCII Deutsch GP_X

ASCII - Kommando | GP_X |
Syntax Senden | GP_X [Data] |
Syntax Empfangen | GP_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3761 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1809 (dec) IND = 17 (dec)
Bereich | 0.1 ... 1000 | DPR | 609 (dec)
Default | 0.1 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler: Proportionalverstärkung 2

Beschreibung

siehe PARCNFG


ASCII Deutsch GPDELAY

ASCII - Kommando | GPDELAY |
Syntax Senden | GPDELAY [Data] |
Syntax Empfangen | GPDELAY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38AF (hex)
DIM | ms | PROFIBUS PNU | 1743 (dec) IND = 33 (dec)
Bereich | 0 .. 16 | DPR | 943 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM |
Kurzbeschreibung | Verzögerung des externen Lagereglers

Beschreibung

GPDELAY = 0: keine Verzögerung (default)
GPDELAY >0 (in msek): Verzögerungszeit des proportional- und Integraltanteils des Lagereglers (hohe Auflösung 0.0625 msek).

Der externe Position Sollwert (Markovariable NEWPOS) kann über Feldbus oder eine Makro-Anwendung ausgelesen werden und für die Berechnung des internen Positionssollwert (Makrovariable S_SETL) verwendet werden. Die Markovariable S_SETL wird auch für die Berechnung der Geschwindigkeits- und Beschleunigungsvorsteuerung sowie dem Positionsfehler verwendet.

Für GPDELAY> 0 die Berechnung des Positionsfehlers wird durch den Parameter GPDELAY verzögert. Das heißt: Für die Vorsteuerung wird mit der nicht verzögerte Position S_SETL und die proportional- und integral Bestandteile des Lagereglers wird die (mit GPDELAY) verzögerten Postion S_SETT berechnet.


ASCII Deutsch GPFFT

ASCII - Kommando | GPFFT |
Syntax Senden | GPFFT [Data] |
Syntax Empfangen | GPFFT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3544 (hex)
DIM | - | PROFIBUS PNU | 1668 (dec) IND = 1 (dec)
Bereich | 0 ... 2147480 | DPR | 68 (dec)
Default | 1 |
Opmode | 4,5,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Stromvorsteuerung - Positionsregelkreis

Beschreibung

Mit der Stromvortsteuerung kann der Schleppfehler minimiert werden.

Dieser Parameter hat für den Positionsregler in folgenden Fällen Einfluß:
1.Es werden Tabbellenfahrsätze genutzt und das zugehörige Bit von O_C ist aktiv. ;
2.Sinusförmige Fahrprofile werden benutzt ;

Falls GV geändert wird, nachdem GPFFT eingestellt wurde, wird GPFFT umgekehrt proportional angepaßt.


ASCII Deutsch GPFFT_X

ASCII - Kommando | GPFFT_X |
Syntax Senden | GPFFT [Data] |
Syntax Empfangen | GPFFT_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3762 (hex)
DIM | - | PROFIBUS PNU | 1810 (dec) IND = 17 (dec)
Bereich | 0 ... 2147480 | DPR | 610 (dec)
Default | 1 |
Opmode | 4,5,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Stromvorsteuerung - Positionsregelkreis 2

Beschreibung

siehe PARCNFG


ASCII Deutsch GPFFTV

ASCII - Kommando | GPFFTV |
Syntax Senden | GPFFTV [Data] |
Syntax Empfangen | GPFFTV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 386A (hex)
DIM | - | PROFIBUS PNU | 1674 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 874 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Proportionalverst. für Geschwindigkeitsstromvorst.

Beschreibung

GPFFTV beschreibt eine Proportionalverstärkung für die Geschwindigkeitsstromvorsteuerung.
Die Geschwindigkeitsvorsteuerung gilt für alle Lageregler-Betriebsarten (OPMODE=4...8) und wird aus dem internen Geschwindigkeitsollwert generiert. Diese Einstellung wirkt sich nur bei erweiterten Stromvorsteuerung-Funktionalität (FFTSW=2).


ASCII Deutsch GPFFV

ASCII - Kommando | GPFFV |
Syntax Senden | GPFFV [Data] |
Syntax Empfangen | GPFFV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3545 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 1 (dec)
Bereich | 0 ... 1000 | DPR | 69 (dec)
Default | 1 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Drehzahl

Beschreibung

Diese Variable ist Bestandteil des Lagereglers. Feedforward wird genutzt, um den Lageregler zu entlasten. Je besser GPFFV angepasst ist, desto besser werden die dynamischen Möglichkeiten des Lagereglers ausgenutzt. Die optimale Einstellung hängt von verschieden Parametern ab, die nicht im Regler sind, z.B. Reibung, dynamischer Widerstand und Steifheit der Mechanik. Wenn GPFFV zu niedrig ist, wird der Schleppfehler groß; wenn GPFFV zu groß ist, schwingt die Achse über.


ASCII Deutsch GPFFV_X

ASCII - Kommando | GPFFV_X |
Syntax Senden | GPFFV [Data] |
Syntax Empfangen | GPFFV_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3763 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 17 (dec)
Bereich | 0 ... 1000 | DPR | 611 (dec)
Default | 1 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Drehzahl 2

Beschreibung

siehe PARCNFG


ASCII Deutsch GPFFVDELAY

ASCII - Kommando | GPFFVDELAY |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38AC (hex)
DIM | - | PROFIBUS PNU | 1740 (dec) IND = 33 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch GPS1

ASCII - Kommando | GPS1 |
Syntax Senden | GPS1 [Data] |
Syntax Empfangen | GPS1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C4 (hex)
DIM | VUNIT | PROFIBUS PNU | 1764 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 964 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | untere Drezhzahlschwelle (Lageregler)

Beschreibung

Der Parameter GPS1 gibt die untere Drehzahlschwelle im Lageregler in VUNIT an.


ASCII Deutsch GPS2

ASCII - Kommando | GPS2 |
Syntax Senden | GPS2 [Data] |
Syntax Empfangen | GPS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C5 (hex)
DIM | VUNIT | PROFIBUS PNU | 1765 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 965 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | obere Drezhzahlschwelle (Lageregler)

Beschreibung

Der Parameter GPS2 gibt die oberer Drehzahlschwelle im Lageregler in VUNIT an.


ASCII Deutsch GPTN

ASCII - Kommando | GPTN |
Syntax Senden | GPTN [Data] |
Syntax Empfangen | GPTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38B1 (hex)
DIM | position loop cycle time | PROFIBUS PNU | 1745 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 945 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Integralanteil des PI Lagereglers

Beschreibung

Der Parameter GPTN bestimmt den Inegralanteil des PI Lagereglers (in µsec abhängig von DPWM).

GPTN=0 (default): Integralanteil ausgeschaltet
GPTN>0: Integralanteil fliesst in die Berechnung des Lagereglers mit ein

siehe auch DPWM


ASCII Deutsch GPTN_X

ASCII - Kommando | GPTN_X |
Syntax Senden | GPTN_X [Data] |
Syntax Empfangen | GPTN_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38B2 (hex)
DIM | position loop cycle time | PROFIBUS PNU | 1746 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 946 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Integralanteil des PI Lagereglers

Beschreibung

Der Parameter GPTN bestimmt den Inegralanteil des PI Lagereglers (in µsec abhängig von DPWM).

GPTN=0 (default): Integralanteil ausgeschaltet
GPTN>0: Integralanteil fliesst in die Berechnung des Lagereglers mit ein

siehe auch DPWM

-------------------------------------------------------------------------------------------

Das Umschalten von Parametersätzen wird mit Hilfe eines Zeigers realisiert, der immer auf eine der beiden Parameterstrukturen (Parametersatz 1: Default) oder (Parametersatz 2: Schattenparameter) zeigt. Durch das Umschalten des Zeigers zwischen den beiden Strukturen werden auch die innerhalb der Strukturen definierten Parameter schlagartig umgeschaltet. Dadurch, dass die Parameter innerhalb der Strukturen bereits umgerechnet sind, wird vermieden, dass undefinierte Zustände entstehen, wo Parameter nur teilweise mit den neuen und teilweise mit den alten Werten umgerechnet sind.

Die Parameter des zweiten Parametersatzes werden ähnlich wie beim Hauptparametersatz mit Hilfe von ASCII-Kommandos definiert. Um den zweiten Parametersatz zu beschreiben, muss dem ASCII-Kommando die Buchstabenfolge „_X“ hinzugefügt werden.

Beispiel:
Um die Verstärkung des Drehzahlreglers zu verändern, wird das Kommando „GV“ benutzt. Damit dieser Parameter im zweiten Parametersatz verändert werden kann, muss das Kommando GV_X benutzt werden.

Um den Parameterspeicher des Verstärkers zu schonen, werden nur die Parameter des zweiten Parametersatzes abgespeichert, die sich von dem Hauptparametersatz unterscheiden.Falls keine Parameter des zweiten Parametersatzes (PAR_X) vorgegeben werden, wird die zweite Parameterstruktur automatisch mit den gleichen Werten wie der Hauptparametersatz initialisiert. Der Anwender braucht also nicht alle Parameter des zweiten Parametersatzes zu initialisieren. Er muss lediglich die von ihm benötigten Parameter verändern.

Die automatische Initialisierung des Schattenparameters erfordert , dass bei jeder Änderung eines Hauptparameters auch der zugehörige Schattenparameter automatisch auf den gleichen Wert gesetzt wird. Damit der zuvor eingegebene Schattenparameter durch den Hauptparameter nicht überschrieben wird, muss die Parametrierung des zweiten Parametersatzes immer nach der Initialisierung des Hauptparametersatzes erfolgen.

Sobald der Parameter PAR_X einen anderen Wert als PAR bekommt, wird dieser Parameter im seriellen EEPROM abgespeichert. Der PAR_X-Wert erscheint dann auch in der DUMP-Ausgabe und zwar am Ende der Parameterliste.

Mit dem Kommando PARDUMP können alle umschaltbaren Parameter mit den aktuellen Einstellungen ausgegeben werden.


ASCII Deutsch GPTNTH1

ASCII - Kommando | GPTNTH1 |
Syntax Senden | GPTNTH1 [Data] |
Syntax Empfangen | GPTNTH1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38A7 (hex)
DIM |  | PROFIBUS PNU | 1735 (dec) IND = 33 (dec)
Bereich | 0 .. 16000 | DPR | 935 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Grenze des Integralanteil für den Drehzahlsollwert

Beschreibung

Der Parameter GPTNTH1 (in VUNIT) ist eine Integralanteilgrenze für den Drehzahlsollwert. Der Integralanteil im Lagregler ist aktiv, sobald der Drehzahlsollwert unter den Grenzwert GPTNH1 fällt.

siehe auch GPTN, GPTNTH2, GPTNTH3


ASCII Deutsch GPTNTH2

ASCII - Kommando | GPTNTH2 |
Syntax Senden | GPTNTH2 [Data] |
Syntax Empfangen | GPTNTH2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38A8 (hex)
DIM |  | PROFIBUS PNU | 1736 (dec) IND = 33 (dec)
Bereich | 0 .. 16000 | DPR | 936 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Grenze des Integralanteils für den Drehzahlistwert

Beschreibung

Der Parameter GPTNTH2 (in VUNIT) ist eine Integralanteilgrenze für den Drehzahlistwert. Der Integralanteil im Lagregler ist aktiv, sobald der Drehzahlistwert unter den Grenzwert GPTNH2 fällt.

siehe auch GPTN, GPTNTH1, GPTNTH3


ASCII Deutsch GPTNTH3

ASCII - Kommando | GPTNTH3 |
Syntax Senden | GPTNTH3 [Data] |
Syntax Empfangen | GPTNTH3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38A8 (hex)
DIM |  | PROFIBUS PNU | 1652 (dec) IND = 17 (dec)
Bereich | 0 .. 2147483647 | DPR | 460 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Grenze des Integralanteils für den Schleppfehler

Beschreibung

Der Parameter GPTNTH3 (in PUNIT) ist eine Integralanteilgrenze für den Schleppfehler. Der Integralanteil im Lagregler ist aktiv, sobald der Drehzahlistwert unter den Grenzwert GPTNH2 fällt.

siehe auch GPTN, GPTNTH1, GPTNTH2


ASCII Deutsch GU

ASCII - Kommando | GU |
Syntax Senden | GU [Data] |
Syntax Empfangen | GU <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 32000 | DPR | Nein
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung für Feldschwächung

Beschreibung

GU ist ein Parameter zum Betrieb von Asynchronmaschinen und beschreibt die Proportionalverstärkung des Spannungsregler zur Feldschwächung


ASCII Deutsch GUTN

ASCII - Kommando | GUTN |
Syntax Senden | GUTN [Data] |
Syntax Empfangen | GUTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 10 | DPR | Nein
Default | 0.1 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Zeitkonstante für Feldschwächung

Beschreibung

GUTN ist ein Parameter zum Betrieb von Asynchronmaschinen und beschreibt die Zeitkonstante des Spannungsregler (in ms) zur Feldschwächung


ASCII Deutsch GV

ASCII - Kommando | GV |
Syntax Senden | GV [Data] |
Syntax Empfangen | GV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3548 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 1 (dec)
Bereich | variable | DPR | 72 (dec)
Default | variable |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Proportionalverstärkung

Beschreibung

GV gibt die proportionale Verstärkung des Drehzahlreglers an und beeinflusst auch GVTN. Die Einheit ist As/rad
DISCALE – Verstärkerabhängige Stromskalierung (kann über „M DISCALE“ abgefragt werden)

Maximalwert und Defaultwert hängen von der Endstufe ab und werden nach folgender Formel berechnet:
GV(default) = DISCALE / 325
GV(max) = (40000 * DISCALE) / 325

Beispiel:
S706: max. Spitzenstrom = 3*6A = 18 A
GV(default) = 18/325 = 0.055
GV(max) = (40000 * 18)/325 = 221

Wenn die Parameter (GV=GV2) gleich sind, ist die Interpolation abgeschaltet was per default der Fall ist. Solange sie gleich sind, führt eine Änderung von GV zu automatischer Änderung von GV2, so dass sie weiterhin gleich bleiben. Erst wenn GV2 einmalig auf einen anderen Wert gesetzt wird als GV, ist die Kopplung aufgelöst und beide Parameter können separat modifiziert werden. Durch Setzen von GV2 auf GV wird Parameterkopplung wieder aktiviert.

Wer die die Interpolationsfunktion nicht braucht und nur GV benutzen, wird die Existenz von GV2 gar nicht merken.


ASCII Deutsch GV2

ASCII - Kommando | GV2 |
Syntax Senden | GV2 [Data] |
Syntax Empfangen | GV2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C6 (hex)
DIM | VUNIT | PROFIBUS PNU | 1766 (dec) IND = 33 (dec)
Bereich | variable | DPR | 966 (dec)
Default | variable |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Proportinalanteil bei höherer Geschwind. als GVS2

Beschreibung

GV2 ist ein Parameter des Drehzahlregelkreises und gibt den Proportinalanteil an falls die Geschwindigkeit höher als GVS2 ist

Wenn die Parameter (GV=GV2) gleich sind, ist die Interpolation abgeschaltet was per default der Fall ist. Solange sie gleich sind, führt eine Änderung von GV zu automatischer Änderung von GV2, so dass sie weiterhin gleich bleiben. Erst wenn GV2 einmalig auf einen anderen Wert gesetzt wird als GV, ist die Kopplung aufgelöst und beide Parameter können separat modifiziert werden. Durch Setzen von GV2 auf GV wird Parameterkopplung wieder aktiviert.

Wer die die Interpolationsfunktion nicht braucht und nur GV benutzen, wird die Existenz von GV2 gar nicht merken.

GV2(default) = DISCALE / 325
GV2(max) = (40000 * DISCALE) / 325


ASCII Deutsch GV_X

ASCII - Kommando | GV_X |
Syntax Senden | GV [Data] |
Syntax Empfangen | GV_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3760 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 17 (dec)
Bereich | variable | DPR | 608 (dec)
Default | variable |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Proportionalverstärkung 2

Beschreibung

siehe PARCNFG


ASCII Deutsch GVFR

ASCII - Kommando | GVFR |
Syntax Senden | GVFR [Data] |
Syntax Empfangen | GVFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354B (hex)
DIM | - | PROFIBUS PNU | 1675 (dec) IND = 1 (dec)
Bereich | 0.0 .. 1.0 | DPR | 75 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | PI-PLUS Drehzahlistwertvorsteuerung

Beschreibung

GVFR ist ein Parameter des Drehzahlregelkreises, der die Vorsteuerung des Sollwertes beschreibt.
Mit GVFR 1 verhält sich der Drehzahlregler wie ein Standard PI-Regler. Bei GVFR 0 verhählt sich der Drehzahlregler wie ein PDF-Regler (Pseudo Derivative Feedback). Bei GVFR 0.65 verhält sich der Regler wie ein PDFF Regler mit 65% Vorsteuerung (ohne Überschwingen / Pseudo Derivative Feedback with Feed-Forward. / PDFF or PI+)


ASCII Deutsch GVFR_X

ASCII - Kommando | GVFR_X |
Syntax Senden | GVFR [Data] |
Syntax Empfangen | GVFR_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 375E (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 17 (dec)
Bereich | 0.0 .. 1.0 | DPR | 606 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | PI-PLUS Drehzahlistwertvorsteuerung

Beschreibung

siehe PARCNFG


ASCII Deutsch GVS1

ASCII - Kommando | GVS1 |
Syntax Senden | GVS1 [Data] |
Syntax Empfangen | GVS1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1767 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 967 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | untere Drhzahlschwelle (Drehzahlregler)

Beschreibung

Der Parameter GVS1 gibt die untere Drehzahlschwelle im Drehzahlregelkreises in VUNIT an.


ASCII Deutsch GVS2

ASCII - Kommando | GVS2 |
Syntax Senden | GVS2 [Data] |
Syntax Empfangen | GVS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38C8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1768 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 968 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | obere Drhzahlschwelle (Drehzahlregler)

Beschreibung

Der Parameter GVS2 gibt die obere Drehzahlschwelle im Drehzahlregelkreises in VUNIT an.


ASCII Deutsch GVTN

ASCII - Kommando | GVTN |
Syntax Senden | GVTN [Data] |
Syntax Empfangen | GVTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354D (hex)
DIM | ms | PROFIBUS PNU | 1677 (dec) IND = 1 (dec)
Bereich | 0.0 , GV/62.5 .. 1000.0 | DPR | 77 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Nachstellzeit

Beschreibung

Die Drehzahlregler-Nachstellzeit ist die Zeitkonstante des Integralanteils im Drehzahlregler. Wenn GVTN = 0 gesetzt wird, so ist der Integralanteil abgeschaltet.


ASCII Deutsch GVTN_X

ASCII - Kommando | GVTN_X |
Syntax Senden | GVTN [Data] |
Syntax Empfangen | GVTN_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 375F (hex)
DIM | ms | PROFIBUS PNU | 1807 (dec) IND = 17 (dec)
Bereich | 0.0 , GV/62.5 .. 1000.0 | DPR | 607 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Nachstellzeit 2

Beschreibung

siehe PARCNFG


ASCII Deutsch GVTV

ASCII - Kommando | GVTV |
Syntax Senden | GVTV [Data] |
Syntax Empfangen | GVTV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38FD (hex)
DIM | ms | PROFIBUS PNU | 1821 (dec) IND = 33 (dec)
Bereich | 0 .. 20000 | DPR | 1021 (dec)
Default | 0 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Vorhaltzeit des Volumenstromreglers

Beschreibung

Mit diesem Parameter kann man die Vorhaltzeit des Volumenstromreglers (PID2) konfigurieren.


ASCII Deutsch HALLDIR

ASCII - Kommando | HALLDIR |
Syntax Senden | HALLDIR [Data] |
Syntax Empfangen | HALLDIR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3550 (hex)
DIM | - | PROFIBUS PNU | 1680 (dec) IND = 1 (dec)
Bereich | -1 .. 1 | DPR | 80 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Nummer für Hallelement - Tabelle

Beschreibung

In der S300 firmware sind 2 Tabellen mit Hall Segment Nummern hinterlegt.

HALLDIR = 0: Reihenfolge der Hall Segmente 1,5,4,6,2,3
HALLDIR = 1: Reihenfolge der Hall Segmente 1,3,2,6,4,5

Die passende Trabelle kann ermittelt werden, wenn der Motor in die positive Richtung bewegt wird (Geschwindigkeit > 0) und die Hall-Reihenfolge mit der Macro - Variablen M SR_HALL ermittelt wird.


ASCII Deutsch HALLENDIR

ASCII - Kommando | HALLENDIR |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch HDSLLED

ASCII - Kommando | HDSLLED |
Syntax Senden | HDSLLED |
Syntax Empfangen | HDSLLED <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3919 (hex)
DIM | 0,1 mA | PROFIBUS PNU | 1849 (dec) IND = 33 (dec)
Bereich | 32 bit | DPR | 1049 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | LED-Strom der opt Einheit im Hiperface DSL Encoder

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) kann für Diagnose-Zwecke der LED-Strom der optischen Einheit im Geber ausgelesen werden. Die Einheit beträgt 0.1 mA.


ASCII Deutsch HDSLPOS

ASCII - Kommando | HDSLPOS |
Syntax Senden | HDSLPOS |
Syntax Empfangen | HDSLPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer64 | CANBus Objektnummer | -
DIM | counts | PROFIBUS PNU | -
Bereich | 64 bit | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer64
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Position gelesen aus dem Hiperace DSL-Encoder

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) kann mit dem Kommando HDSLPOS die aus dem Geber ausgelesene Position angezeigt werden. Diese Position wird in den internen Geber Einheiten dargestellt und sollte nur zu Diagnosezwecken verwendet werden.


ASCII Deutsch HDSLRANGE

ASCII - Kommando | HDSLRANGE |
Syntax Senden | HDSLRANGE |
Syntax Empfangen | HDSLRANGE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Hiperface DSL Geber-Grenzwerte

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE =35 ) liefert das Kommando HDSLRANGE minimale und maximale Werte für bestimmte Betriebsgrößen. Es werden folgende Werte geliefert (in der angegebenen Reihenfolge):

- Minimale Gebertemperatur in 0.1 °C
- Maximale Gebertemperatur in 0.1 °C
- Minimaler LED-Strom in 0.1 mA
- Maximaler LED-Strom in 0.1 mA
- Minimale Versorgungsspannung in mV
- Maximale Versorgungsspannung in mV
- Maximale Drehzahl in UPM
- Maximale Beschleunigung in 1000 rad/sec2


ASCII Deutsch HDSLROTAT

ASCII - Kommando | HDSLROTAT |
Syntax Senden | HDSLROTAT |
Syntax Empfangen | HDSLROTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 391D (hex)
DIM | rpm | PROFIBUS PNU | 1853 (dec) IND = 33 (dec)
Bereich | 32 bit | DPR | 1053 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Gesamtzahl der erfassten Geber-Umdrehungen

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) liefert das HDSLROTAT-Kommando die im Geber abgespeicherte Gesamzahl der erfassten Umdrehungen. Dieser Wert kann zu Diagnosezwecken verwendet werden.


ASCII Deutsch HDSLTEMP

ASCII - Kommando | HDSLTEMP |
Syntax Senden | HDSLTEMP |
Syntax Empfangen | HDSLTEMP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3918 (hex)
DIM | 0,1 °C | PROFIBUS PNU | 1848 (dec) IND = 33 (dec)
Bereich | 32 bit | DPR | 1048 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Motor/Encoder-Temperatur vom Hiperface DSL-Encoder

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) wird zusätzlich zu der Position die Geber/Motor-Temperatur übertragen. Die Einheit beträgt 0.1 °C. Diese Temperatur wird für die Überwachung der Motortemperatur verwendet. Dieser Wert kann auch als TEMPM (in °C) angezeigt werden.


ASCII Deutsch HDSLTIME

ASCII - Kommando | HDSLTIME |
Syntax Senden | HDSLTIME |
Syntax Empfangen | HDSLTIME <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 391C (hex)
DIM | Minuten | PROFIBUS PNU | 1852 (dec) IND = 33 (dec)
Bereich | 32 bit | DPR | 1052 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Betriebsstunden des Hiperface DSL-Gebers

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) liefert das HDSLTIME-Kommando die Betriebszeit des Gebers (in Minuten).Die Zeit wird im Geber erfasst und alle 20 Minuten in einem Festwertspeicher abgelegt. Sie sollte nur zu Diagnosezwecken benutzt werden.


ASCII Deutsch HDSLTYPE

ASCII - Kommando | HDSLTYPE |
Syntax Senden | HDSLTYPE |
Syntax Empfangen | HDSLTYPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Hiperface DSL Geberdaten (Typenschild)

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) liefert das Kommando HDSLTYPE Auflösung,Typenbezeichnung sowie Hardware/Software-Version des HDSL-Gebers. Es werden folgende Werte geliefert (in der angegebenen Reihenfolge):

- Gebertyp
0 = rotatorisch bipolar
1 = linear bipolar
2 = rotatorisch unipolar
3 = linear unipolar
- Geberauflösung (in Counts pro Umdrehung)
- Anzahl der erfassten Umdrehungen (multiturn/singleturn)
- Gebername als ASCII-String
- Seriennummer
- Hardware- und Firmware-Version
- Firmware-Datum
- Größe des internen EEPROMs in Bytes


ASCII Deutsch HDSLVEL

ASCII - Kommando | HDSLVEL |
Syntax Senden | HDSLVEL |
Syntax Empfangen | HDSLVEL <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 391B (hex)
DIM | rpm | PROFIBUS PNU | 1851 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 1051 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Akt. Drehgeschwindigkeit des Hiperface DSL-Gebers

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) liefert das HDSLVEL-Kommando die aktuelle Drehgeschwindigkeit des Gebers. Der gelieferte Wert ist recht ungenau und sollte nur zu Diagnosezwecken benutzt werden.


ASCII Deutsch HDSLVOLT

ASCII - Kommando | HDSLVOLT |
Syntax Senden | HDSLVOLT |
Syntax Empfangen | HDSLVOLT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 391A (hex)
DIM | 1 mV | PROFIBUS PNU | 1850 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 1050 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Versorgungsspannung des Hiperface DSL-Gebers

Beschreibung

Bei einem angeschlossenen und konfigurierten Hiperface DSL-Geber (FBTYPE=35) kann für Diagnose-Zwecke der Wert der Versorgungsspannung des Gebers ausgelesen werden. Die Einheit beträgt 1 mV.


ASCII Deutsch HDUMP

ASCII - Kommando | HDUMP |
Syntax Senden | HDUMP |
Syntax Empfangen | HDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ausgabe aller SinCos Variablen

Beschreibung

Ausgabe aller SinCos Feedback Variablen


ASCII Deutsch HELP

ASCII - Kommando | HELP |
Syntax Senden | HELP |
Syntax Empfangen | HELP <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Parameter-Hilfe-Information

Beschreibung

Mit dem Parameter HELP <name> kann eine Hilfe-Information für den ASCII Parameter "name" angezeigt werden. Zu der Hilfe-Information gehören Eingabe-Grenzwerte sowie der aktuelle und der Default-Wert des Parameters.
Z.B: HELP GV
GV act=6 min=0 max=1000 default=1


ASCII Deutsch HICOFFS

ASCII - Kommando | HICOFFS |
Syntax Senden | HICOFFS [Data] |
Syntax Empfangen | HICOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3552 (hex)
DIM | mV | PROFIBUS PNU | 1682 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 82 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Hiperface: Cosinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HICOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HICOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HIFACT1

ASCII - Kommando | HIFACT1 |
Syntax Senden | HIFACT1 [Data] |
Syntax Empfangen | HIFACT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3553 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 1 (dec)
Bereich | 10000 .. 32767 | DPR | 83 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)

Beschreibung

Das Kommando HIFACT1 setzt die Amplitudennormierung des Sinus-Signal der Absolutspur (SinCoder). Die Amplitudennormierung ist bei dem Wert 16384 = 1.

Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HIFACT1-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HISOFFS

ASCII - Kommando | HISOFFS |
Syntax Senden | HISOFFS [Data] |
Syntax Empfangen | HISOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3554 (hex)
DIM | mV | PROFIBUS PNU | 1684 (dec) IND = 1 (dec)
Bereich | -10000 .. 10000 | DPR | 84 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HISOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HISOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HLIMIT1

ASCII - Kommando | HLIMIT1 |
Syntax Senden | HLIMIT1 [Data] |
Syntax Empfangen | HLIMIT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3896 (hex)
DIM |  | PROFIBUS PNU | 1718 (dec) IND = 33 (dec)
Bereich | 0...2147483647 | DPR | 918 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.62 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Software limit switch 1 bei der Referenzfahrt

Beschreibung

Der Parameter HLIMIT1 begrenzt die Bewegung beim Homing. Dieser Befehle begrenzt die maximale Strecke vom Start der Referenzfahrt bis zum Hardware Endschalter oder Referenzschalter. Kann der Referenzpunkt bis HLIMIT1 nicht angefahren werden, wird F26 (Hardware-Endschalter - Fehler bei Referenzfahrt) ausgegeben.

Siehe auch
HLIMIT2,HLIMIT3,ERRCODE *


ASCII Deutsch HLIMIT2

ASCII - Kommando | HLIMIT2 |
Syntax Senden | HLIMIT2 [Data] |
Syntax Empfangen | HLIMIT2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3897 (hex)
DIM |  | PROFIBUS PNU | 1719 (dec) IND = 33 (dec)
Bereich | 0...2147483647 | DPR | 919 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.62 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Software limit switch 2 bei der Referenzfahrt

Beschreibung

Der Parameter HLIMIT2 begrent die Bewegung beim Homing. Dieser Befehle begrent die maximale Strecke vom Start der Referenzfahrt bis zum Hardware Endschalter. Kann der Referenzpunkt bis HLIMIT2 nicht angefahren werden, wird F26 (Hardware-Endschalter - Fehler bei Referenzfahrt) ausgegeben.

Siehe auch
HLIMIT1,HLIMIT3,ERRCODE *


ASCII Deutsch HLIMIT3

ASCII - Kommando | HLIMIT3 |
Syntax Senden | HLIMIT3 [Data] |
Syntax Empfangen | HLIMIT3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3898 (hex)
DIM |  | PROFIBUS PNU | 1720 (dec) IND = 33 (dec)
Bereich | 0...2147483647 | DPR | 920 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.62 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Software limit switch 3 bei der Referenzfahrt

Beschreibung

Der Parameter HLIMIT3 begrent die Bewegung beim Homing. Dieser Befehle begrent die maximale Strecke vom Harwareendschalter oder vom Referenzpunkt bis zum externen Nullpunkt (REFMODE<0). Wenn die Position vom HLIMIT3 vor dem externen Nullpunkt erreicht wird, wird F26 (Hardware-Endschalter - Fehler bei Referenzfahrt) ausgegeben.

Siehe auch
HLIMIT1,HLIMIT2,ERRCODE *,REFMODE


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Einrichtbetrieb

einrichten

Die Referenzfahrt ist ein Absolutauftrag, der der Nullung des Antriebs für nachfolgende Positionieraufgaben dient. Sie können verschiedene Arten von Referenzfahrten auswählen. Nach der Referenzfahrt meldet der Antrieb "InPosition" und gibt damit den Lageregler im Servoverstärker frei.

Für vollständige Referenzfahrt-Funktionalität müssen die Endschalterfunktionen: 2, PSTOP und 3, NSTOP für die digitalen Eingänge 3 und 4 aktiviert sein.

Sorgen Sie dafür, dass die Lage des Maschinennullpunktes (Referenzpunkt) die nachfolgenden Positioniervorgänge zulässt. Die parametrierten Software-Endschalter sind eventuell unwirksam. Die Achse fährt eventuell auf den Hardware-Endschalter bzw. auf den mechanischen Anschlag. Es besteht die Gefahr von Beschädigungen.

Wird der Referenzpunkt (Maschinennullpunkt) z.B. bei hohen Massenträgkeitsmomenten mit zu hoher Geschwindigkeit angefahren, kann er überfahren werden und die Achse fährt in ungünstigen Fällen auf den Hardware-Endschalter bzw. auf den mechanischen Anschlag. Es besteht die Gefahr von Beschädigungen.

Ohne vorherige Referenzfahrt kann der Lageregler nicht mit internen Fahraufträgen betrieben werden. Nach Zuschalten der 24V-Hilfsspannung muss zunächst eine Referenzfahrt durchgeführt werden.
Während der Referenzfahrt darf das Start-Signal nicht weggenommen werden.
Das Start-Signal muss solange anstehen, bis die "InPosition"-Meldung erscheint.

Beim Starten der Referenzfahrt wird der SW-Enable automatisch gesetzt. Referenzfahrten werden nur in OPMODE 8 gestartet. Der SW-Enable wird jedoch in allen OPMODES gesetzt. Deshalb kann der Antrieb durch einen anliegenden analogen Sollwert beschleunigen, wenn das START-Kommando in OPMODE 1 oder OPMODE 3 ausgeführt wird.

Referenzfahrt (NREF)

Sie können wählen, welche Art der Referenzfahrt ausgeführt werden soll.

Nr | Funktion | Referenzpunkt wird gesetzt auf
0 | Referenzpunkt setzen | die aktuelle SOLL-Position
1 | auf Referenzschalter mit Nullpunkt | den ersten Nulldurchgang der Rückführeinheit außerhalb des Referenzschalters
2 | auf Endschalter mit Nullpunkt | den ersten Nulldurchgang der Rückführeinheit außerhalb des Endschalters
3 | auf Referenzschalter ohne Nullpunkt | die Flanke des Referenzschalters
4 | auf Endschalter ohne Nullpunkt | die Flanke des Hardwareendschalters
5 | innerhalb einer Umdrehung mit Nullpunkt | den nächsten Nullpunkt der Rückführeinheit
6 | Referenzpunkt 2 setzen | die aktuelle Ist-Position
7 | auf Anschlag mit Nullpunktsuche | den ersten Nulldurchgang der Rückführeinheit außerhalb des Anschlags. Der Impulsstrom wird mit REF-IPEAK auf der Bildschirmseite "Stromregler" eingestellt.
8 | auf absolute SSI-Position | die (bei Beginn der Referenzfahrt) am SSI-Eingang eingelesene Position
9 | auf Anschlag ohne Nullpunktsuche | die Istposition, wenn der Antrieb auf Anschlag steht und der Schleppfehler 50% des max. zul. Schleppfehlers erreicht. Der Impulsstrom wird während des Verfahrens auf REF-IPEAK begrenzt (Bildschirmseite "Stromregler").

Referenzfahrt-Geschwindigkeit (VREF)

Legt die Geschwindigkeit für die Referenzfahrt fest. Das Vorzeichen wird automatisch durch die gewählte Fahrtrichtung bestimmt.

Beschl. Rampe (ACCR)

Beschleunigungszeit für die Referenzfahrt. Die Rampe gilt auch für den Modus Konstante Geschwindigkeit (Tippbetrieb).

Bremsrampe (DECR)

Bremsrampe für die Referenzfahrt. Die Rampe gilt auch für den Modus Konstante Geschwindigkeit (Tippbetrieb). Diese Bremsrampe wird nur dann benutzt, wenn die Betriebsart es zulässt. Bei Referenzfahrten auf einen Hardware-Endschalter wird die Not-Rampe benutzt.

Fahrtrichtung (DREF)

Legt die Fahrtrichtung der Referenzfahrt fest. Die Einstellung "entfernungsabhängig" ist nur relevant für die Referenzfahrt 5 (innerhalb einer Umdrehung). Hier wird die Richtung entsprechend der kürzesten Entfernung zum Nullpunkt gewählt. Dieser Parameter gibt auch die Verfahrrichtung bei Achsentyp Modulo vor.

Offset (ROFFS)

Mit dem Referenz-Offset können Sie dem Referenzpunkt einen von 0 abweichenden absoluten Positionswert zuordnen. Physikalisch ändern Sie mit einem Offset an der Referenzposition nichts, nur innerhalb der Lageregelung des Servoverstärkers wird mit dem Offset als Bezugswert gerechnet. Eine Referenzfahrt zum Referenzschalter endet dann nicht mehr bei Null, sondern bei dem eingestellten Referenz-Offset-Wert.

Der Referenz-Offset muss vor Start der Referenzfahrt gesetzt werden!

Automatische Referenzfahrt bei Enable (AUTOHOME)

Nach Enablen des Servoverstärkers wird automatisch die vorgewählte Referenzfahrt gestartet.

Nullimpuls-Quelle (REFMODE)

Wählen Sie hier die Quelle des Nullimpulses für die Referenzfahrt.

Automatischer Folgefahrauftrag nach Referenzfahrt (NREFMT)

Nach Abschluss der Referenzfahrt wird automatisch der eingestellte Fahrsatz gestartet. Bei Eingabe von "0" wird kein Fahrsatz gestartet.

Fliegender Start (NREFMT)

Fliegender Start des Fahrsatzes. Die Bits „Referenzfahrt läuft=0“ und Referenzfahrt beendet=1“ werden erst nach dem Ende des Fahrsatzes gesetzt.

Referenzfahrt 0

Der Referenzpunkt wird auf die aktuelle Soll-Position gesetzt. Dadurch geht der Schleppfehler (Differenz zwischen Soll- und Istposition) verloren. Der Antrieb macht keine Bewegung.

Referenzfahrt 1

Überprüfen Sie vor dem Start der Referenzfahrt die Sicherheit der Anlage, da ein Verfahren der Last auch bei nicht angeschlossenen oder defekten Endschaltern möglich ist.

Referenzfahrt ohne Endschalter, mit Referenzschalter, mit Nullpunkt:

Fahrtrichtung negativ, Zählrichtung positiv Fahrtrichtung negativ, Zählrichtung negativ

Referenzfahrt mit Endschalter und Referenzschalter, mit Nullpunkt
Fahrtrichtung negativ, Zählrichtung positiv

Fahrtrichtung positiv, Zählrichtung positiv

Referenzfahrt 2

Referenzfahrt 3

Überprüfen Sie vor dem Start der Referenzfahrt die Sicherheit der Anlage, da ein Verfahren der Last auch bei nicht angeschlossenen oder defekten Endschaltern möglich ist.

Referenzfahrt mit Endschalter, mit Referenzschalter, ohne Nullpunkt

Fahrtrichtung negativ, Zählrichtung positiv

Fahrtrichtung positiv, Zählrichtung positiv

Referenzfahrt 4

Referenzfahrt mit Endschalter, ohne Referenzschalter, ohne Nullpunkt
Fahrtrichtung negativ, Zählrichtung positiv

Fahrtrichtung positiv, Zählrichtung positiv

Referenzfahrt 5

Verhalten bei mehrmaligem Start der Referenzfahrt 5 hintereinander:
Der Lageregler kann den Motor nur in der Nullposition halten, indem er die Nullpunkt um ± 1 count überfährt. Bei erneutem Start der Referenzfahrt 5 wird je nach Position (1 count vor oder 1 count hinter der Nullpunkt) und Zählrichtung eventuell eine volle Motorumdrehung gefahren!

Referenzfahrt mit Endschalter, ohne Referenzschalter, mit Nullpunkt

Fahrtrichtung negativ, Zählrichtung positiv | Fahrtrichtung positiv, Zählrichtung positiv

Referenzfahrt 6

Der Referenzpunkt wird auf die aktuelle Ist-Position gesetzt. Der Antrieb macht keine Bewegung.

Referenzfahrt 7

Bei dieser Referenzfahrt kann der Hardwareanschlag der Maschine mechanisch beschädigt werden. Der Spitzenstrom Ipeak und der Effektivstrom Irms werden für die Dauer der Referenzfahrt begrenzt.

Änderung der Strombegrenzung: siehe Bildschirmseite Stromregler, Parameter Ref.-Ipeak.

Referenzfahrt auf Anschlag, ohne Endschalter, ohne Referenzschalter, mit Nullpunkt

Fahrtrichtung negativ, Zählrichtung positiv | Fahrtrichtung positiv, Zählrichtung positiv

Referenzfahrt 8

Voraussetzung: am Encoder-Eingang ist ein Absolutwertgeber (SSI) angeschlossen. Beim Start der Referenzfahrt wird die absolute Position an X1 eingelesen. Der Referenzpunkt wird auf diese Position gesetzt. Der Antrieb macht keine Bewegung.

Referenzfahrt 9

Bei dieser Referenzfahrt kann der Hardwareanschlag der Maschine mechanisch beschädigt werden. Der Spitzenstrom Ipeak und der Effektivstrom Irms werden für die Dauer der Referenzfahrt begrenzt.

Änderung der Strombegrenzung: siehe Bildschirmseite Stromregler, Parameter Ref.-Ipeak.

Referenzfahrt auf Anschlag, ohne Endschalter, ohne Referenzschalter, ohne Nullpunkt

Fahrtrichtung negativ, Zählrichtung positiv | Fahrtrichtung positiv, Zählrichtung positiv

Legende

N | Endschalter NSTOP | P | Endschalter PSTOP | SP | Startposition
R | Referenzschalter | vref | Sollgeschwindigkeit | NM | Nullpunkt der Rückführung


ASCII Deutsch HSAVE

ASCII - Kommando | HSAVE |
Syntax Senden | HSAVE |
Syntax Empfangen | HSAVE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | 3556 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 1 (dec)
Bereich | - | DPR | 86 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Hiperface: Speichern der Parameter im Geber

Beschreibung

Das Kommando HSAVE speichert die Variablen für den Encoder ( HIPERFACE / EnDat ) bei der Einstellung FBTYPE=2 oder =4 im seriellen EEPROM des Encoders. Durch die Einstellung FBTYPE=7 werden nur die Variablen für die Inkrementalspur sowie MNUMBER und MPHASE im internen seriellen EEPROM des Verstärkers gespeichert.

Das Kommando ist nur dann verfügbar, wenn vom Verstärker ein sinus/cosinus Geber erkannt wurde
FBTYPE = 2 HIPERFACE (Sick Stegmann)
FBTYPE = 4 EnDat 2.1 (Heidenhain)
FBTYPE = 7 SINCOS – Encoder ohne eigenem ser. EEPROM
FBTYPE = 20 BiSS-B 5V digital (Hengstler)
FBTYPE = 22 BiSS-B 12V digital (Hengstler)
FBTYPE = 23 BiSS-B 5V analog (Hengstler)
FBTYPE = 24 BiSS-B 12V analog (Hengstler)
FBTYPE = 32 EnDat 2.2 5V (Heidenhain)
FBTYPE = 34 EnDat 2.2 12V (Heidenhain)

Der Befehl HSAVE funktioniert nicht(!) bei folgenden Kombinationen:
FBTYPE = 33 BiSS-C
FBTYPE = 36 SFD3

Das Kommando HSAVE speichert folgende Variablen.
MNUMBER*
MPHASE*
HICOFFS*
HISOFFS*
HIFACT1*
MBRAKE*
MSERIALNO*
* Bei FBTYPE = 7 werden diese Parameter im seriellen EEPROM des Verstärkers abgespeichert.

Hiperface-Geber, welche bereits einen Dateninhalt haben, können gelöscht werden. Hierzu muss HSAVE mit dem Schalter "ERASE" gesendet werden (HSAVE ERASE).

Um einen unbekannten Hiperface-Geber benutzen zu können, muss das Parameter-Feld des Gebers initialisiert werden. Dazu gibt es das Kommando HSAVE OEM „ID“ „PPR“ „BPR“ „R“

Die Parameter ID,PPR,BPR,R haben folgende Bedeutung:
ID – Hiperface-ID. Falls ein unbekannter Hiperface vom Antrieb erkannt wurde, so wird das ID in Klammern ausgegeben „Unknown (ID)“
PPR – periods pro Revolution. Anzahl der Enclines pro Umdrehung
BPR – Bits pro Revolution: Anzahl der Bits pro Geberumdrehung
R – Revolutions: Anzahl der Umdrehungen

Nachdem das Kommando ausgeführt wurde, so wird beim nächsten Einschalten des Verstärkers der Geber erkannt und die Daten übernommen.

Mit HSAVE OEM (ohne Parameter) kann überprüft werden, ob die eingesetzte Firmware dieses Kommando unterstützt.

FW >=2.23
HSAVE BAM
Dieser Befehl kann genutzt werden und muss an geeigneter Stelle im Produktionsablauf eingefügt werden.
Mit diesem Kommando wird nur die aktuelle Position innerhalb einer Umdrehung auf Null gesetzt.


ASCII Deutsch HVER

ASCII - Kommando | HVER |
Syntax Senden | HVER |
Syntax Empfangen | HVER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3557 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 1 (dec)
Bereich | max 50 ASCII Characters | DPR | 87 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Hardware-Version

Beschreibung

Das Kommando HVER liefert eine Hardwareversion-Bezeichnung in folgender Form:
"Drive 3xx Hardware Version (yy) zzzz"
xx - Endstufenbezeichnung (Stromstärke)
yy - Bezeichnung der Hardware-Version
zzzz - Datum der ersten Hardware-Revision


ASCII Deutsch HWCNT

ASCII - Kommando | HWCNT |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch I

ASCII - Kommando | I |
Syntax Senden | I |
Syntax Empfangen | I <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3558 (hex)
DIM | A | PROFIBUS PNU | 1688 (dec) IND = 1 (dec)
Bereich | - | DPR | 88 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Stromistwert

Beschreibung

Der aktuelle Betrag des Stromistwertes in [A]


ASCII Deutsch I2TLIM

ASCII - Kommando | I2TLIM |
Syntax Senden | I2TLIM [Data] |
Syntax Empfangen | I2TLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 355A (hex)
DIM | % | PROFIBUS PNU | 1690 (dec) IND = 1 (dec)
Bereich | 0 .. 100 | DPR | 90 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | I2t-Meldeschwelle

Beschreibung

I2TLIM definiert eine I2T-Meldeschwelle. Sobald der I2T-Wert die eingestellet Schwelle überschreitet, so wird die Warnung "n01" generiert. Diese Meldung kann über einen digitalen Ausgang (Funktion OxMODE=11) an eine Steuerung weitergeleitet werden.


ASCII Deutsch ICMD

ASCII - Kommando | ICMD |
Syntax Senden | ICMD |
Syntax Empfangen | ICMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355B (hex)
DIM | A | PROFIBUS PNU | 1691 (dec) IND = 1 (dec)
Bereich | -DIPEAK .. DPEAK | DPR | 91 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Nein
Kurzbeschreibung | Stromsollwert

Beschreibung

Interner Stromsollwert


ASCII Deutsch ICMDVLIM

ASCII - Kommando | ICMDVLIM |
Syntax Senden | ICMDVLIM [Data] |
Syntax Empfangen | ICMDVLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3685 (hex)
DIM | VUNIT | PROFIBUS PNU | 1989 (dec) IND = 1 (dec)
Bereich | 0 .. VLIM | DPR | 389 (dec)
Default | 0 |
Opmode | 2,3 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlbegrenzung im Stromreglermode

Beschreibung

Der Parameter ICMDVLIM definiert eine digitale Drehzahlbegrenzung (Einheit: VUNIT) bei Vorgabe eines Stromsollwertes bei OPMODE = 2 und 3.

Die Funktion wird nur aktiviert bei ICMDVLIM>0. Eine Änderung von ICMDVLIM ist nur bei gesperrter Endstufe möglich (Änderung der Konfiguration).

Diese Variable ist unter bestimmten Voraussetzungen als eine Konfigurationsvariable zu sehen. Eine Änderung des Wertes von 0 auf >0 oder von >0 auf 0 wird als Änderung der Konfiguration interpretiert und darf nur bei gesperrter Endstufe erfolgen. Danach ist ein COLDSTART zwingend notwendig!


ASCII Deutsch ID

ASCII - Kommando | ID |
Syntax Senden | ID |
Syntax Empfangen | ID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355D (hex)
DIM | A | PROFIBUS PNU | 1693 (dec) IND = 1 (dec)
Bereich | - | DPR | 93 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | D-Anteil vom Strom-Istwert

Beschreibung

Feldbildender Stromistwert (D-Richtung)


ASCII Deutsch IDDUMP

ASCII - Kommando | IDDUMP |
Syntax Senden | IDDUMP [Data] |
Syntax Empfangen | IDDUMP <Data> | Vorhanden in |
Type | Multi-Line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode | All | Datentyp Bus/DPR | String
Verstärker Status |  | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Objektnummern

Beschreibung

Der Befehl IDDUMP gibt eine Liste aller Objektummern im Terminal aus - ggf. mit dem zugeordneten ASCII Befehl.

siehe auch MAXCMD


ASCII Deutsch IEXTT

ASCII - Kommando | IEXTT |
Syntax Senden | IEXTT [Data] |
Syntax Empfangen | IEXTT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3869 (hex)
DIM | A | PROFIBUS PNU | 1673 (dec) IND = 33 (dec)
Bereich | -DICONT .. +DICONT | DPR | 873 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.05 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Haltemoment bei hängenden Achsen

Beschreibung

Mit dem Parameter IEXTT kann das Haltemoment bei hängenden Achsen definiert werden.
Dieser Parameter bewirkt eine konstante Stromvorsteuerung.


ASCII Deutsch IEXTTLIM

ASCII - Kommando | IEXTTLIM |
Syntax Senden | IEXTTLIM [Data] |
Syntax Empfangen | IEXTTLIM <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38B6 (hex)
DIM |  | PROFIBUS PNU | 1750 (dec) IND = 33 (dec)
Bereich |  | DPR | 950 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | current loop | EEPROM |
Kurzbeschreibung | Unterstützung der vertikalen Achse

Beschreibung

Ab Version 3.76/5.06 wurde die Unterstützung der vertikalen Achse in der S700-Firmware erweitert.
Zusätzlich zu dem Parameter IEXTT mit dem das Haltemoment für die vertikale Achse definiert werden kann, wurde der Parameter IEXTTLIM implementiert.

Mit Hilfe des Parameters IEXTTLIM kann der Strom-Sollwert asymmetrisch begrenzt werden. Analog zu IEXTT erfolgt die Eingabe in Ampere. Die Strombegrenzung ist nur bei aktivem Haltemoment IEXTT<>0 und bei IEXTTLIM<>0 aktiviert.


ASCII Deutsch IN

ASCII - Kommando | IN |
Syntax Senden | IN |
Syntax Empfangen | IN <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Anzeige der A/D-Spannungen

Beschreibung

Das Kommando IN gibt die Eingangsspannungen der 8 A/D-Kanäle in counts (-4096...4096) aus.

S700/S300_ARM9
A/D-Kanäle:
Kanal 0 Cosinus Resolver
Kanal 1 Sinus Resolver
Kanal 2 Sinus Encoder
Kanal 3 Cosinus Encoder
Kanal 4 Strom IA
Kanal 5 Strom IB
Kanal 6 Sollwert 1
Kanal 7 Sollwert 2
Kanal 8 Motor-Temperatur
Kanal 9 Kuehlkoerper-Temperatur
Kanal 10 Umgebungstemperatur
Kanal 11 Rueckmeldung Sense Encoder
Kanal 12 Reserve
Kanal 13 Zwischenkreisspannung
Kanal 14 Reserve
Kanal 15 Reserve

S300_ARM7
A/D-Kanäle:
Kanal 0 Strom IA
Kanal 1 Sollwert 1
Kanal 2 Sinus Resolver
Kanal 3 Sinus Encoder
Kanal 4 Kuehlkoerper-Temperatur
Kanal 5 Umgebungstemperatur
Kanal 6 Rueckmeldung Sense Encoder
Kanal 7 Reserve
Kanal 8 Strom IB
Kanal 9 Sollwert 2
Kanal 10 Cosinus Resolver
Kanal 11 Cosinus Encoder
Kanal 12 Motor-Temperatur
Kanal 13 Zwischenkreisspannung
Kanal 14 Reserve
Kanal 15 Reserve


ASCII Deutsch IN1

ASCII - Kommando | IN1 |
Syntax Senden | IN1 |
Syntax Empfangen | IN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3561 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 1 (dec)
Bereich | - | DPR | 97 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT1

Beschreibung

Zustand des digitalen Eingangs INPUT1


ASCII Deutsch IN1HCMD

ASCII - Kommando | IN1HCMD |
Syntax Senden | IN1HCMD [Data] |
Syntax Empfangen | IN1HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN1HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN1MODE=30,33 konfigurierten Eingang 1, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INHCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN1LCMD

ASCII - Kommando | IN1LCMD |
Syntax Senden | IN1LCMD [Data] |
Syntax Empfangen | IN1LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN1LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN1MODE=30,33 konfigurierten Eingang1, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN1LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN1MODE

ASCII - Kommando | IN1MODE |
Syntax Senden | IN1MODE [Data] |
Syntax Empfangen | IN1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3562 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 1 (dec)
Bereich | 0 .. 90 | DPR | 98 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT1

Beschreibung

Mit dem Kommando IN1MODE kann die Funktion des digitalen Eingangs INPUT1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN1MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN1MODE=1 Verstärker Fehler Reset Beim Auftreten eines Verstärker-Fehlers (BTB=0, Display-Anzeige Fxx) führt eine steigende Flanke auf diesem Eingang zum Resettieren des Fehlers, wenn ein Fehler ansteht. Wenn kein Fehler ansteht, so wird der Eingang ignoriert. Je nach Art des Fehlers, erfolgt ein Hardware- bzw. Software-Reset des Verstärkers. Bei einem Software-Reset, ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die gesamte Initialisierungsphase durchlaufen (Power on), so dass die Parameter aus dem EEPROM geladen werden.
Falls beim Einschalten des Verstärkers ein High-Zustand (24V) am INPUT1 erkannt wird, so wird die Initialisierungsphase unterbrochen bis der Eingang den Zustand Low (0V) aufweist. Dieser "Wartezustand" des Verstärkers kann am Display ("A"-Zeichen im ersten Segment) erkannt werden.
IN1MODE=2 | Keine Funktion
IN1MODE=3 | Keine Funktion
IN1MODE=4 | Keine Funktion
IN1MODE=5 | Keine Funktion
IN1MODE=6 | Keine Funktion
IN1MODE=7 | Keine Funktion
IN1MODE=8 | Sollwertumschaltung analog Eingang 1/ analog Eingang | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle Analog In 1/Analog In 2 umgeschaltet werden (Low = Analog In 1, High=Analog In 2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN1MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
IN1MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN1MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN1MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN1MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN1MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN1MODE=15 Folgefahrauftrag Starten Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
(siehe auch O_C Tabelle 3)
IN1MODE=16 Fahrauftrag/Referenzfahrt IN1TRIG starten Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).

Nur in OPMODE 4 und 8 verfügbar
IN1MODE=17 | Fahrauftrag/Referenzfahrt starten <> stoppen | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN1MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN1TRIG in % von IPEAK vorgegeben.
IN1MODE=19 | keine Funktion
IN1MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN1TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=4,5,6,8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM, das Vorzeichen definiert die Drehrichtung
IN1MODE=21 Unterspannung ein/aus Der digitale Eingang schaltet die Überwachung der Unterspannung.
High = aus
Low = ein
IN1MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN1MODE=23 | Fahrauftrag/Referenzfahrt IN1TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN1MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN1TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muss folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN1TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN1MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung (ENCOUT) umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, dass der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN1MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variablen LATCH1P32 (positive Flanke) oder LATCH1N32 (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCH1P16 (positive Flanke) oder LATCH1N16 (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 1 msek.

Hat IN1TRIG einen Wert ungleich 0, so wird der Fahrauftrag mit der jeweiligen Nummer, welcher in IN1TRIG eingetragen ist, direkt gestartet.
IN1MODE=27 schneller Halt Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.

Antrieb bleibt enabled!
IN1MODE=28 Starten eines Tippbetriebes. OPMODE= 4,5,6,8
Ab Firmware 0.73

Eine steigende Flanke startet einen Tippbetrieb mit der Geschwindigkeit VJOG.
Eine fallende Flanke stoppt die Bewegung.
IN1MODE=29 Fahrauftrag/ Referenzfahrt starten Eine steigende Flanke an diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Bei der Nummer 0 wird eine Referenzfahrt gestartet.

Warnung: eine fallende Flanke an diesem Eingang löst kein STOP-Kommando aus.
IN1MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando IN1HCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando IN1LCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer IN1HCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer IN1LCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).
IN1MODE=32 Bremse ein/aus ACHTUNG!
Durch Lösen der Bremse bei gesperrter Endstufe
können abhängig von der Maschinenmechanik gefährliche Zustände entstehen !

Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrter Endstufe möglich.
IN1MODE=33 wie 30 Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.

Diese Funktion ist nicht mit der GUI Bediensoftware benutzbar.
IN1MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN1TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (32 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN1TRIG berechnet werden:

IN1TRIG = n [U/min]*2^32/(4000*60)
Beispiel: n = 500 [U/min]
INxTRIG = 500 * 2^32 / (4000*60) = 8947848

IN1TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS > 0 = 0 Position vom externen Geber (Vorwahl mit EXTPOS).
= 1 Position wird vom ersten Geber am Motor (FBTYPE) erfasst.
IN1MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN1MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN1TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Bit 15 fungiert als Vorzeichenbit und legt damit die Drehrichtung fest. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN1TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN1TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN1TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN1TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN1TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN1TRIG = 0x000afe0c = 720396
IN1MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.
IN1MODE=41 Nothalt Bewirkt das Auslösen eines Schnell Haltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Schnell Halt-Phase abgeschlossen.
Während der Schnell Halt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Schnell Halt wird in der 250µs-Task ausgewertet.
IN1MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
IN1MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN1MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN1TRIG in PGEARI - Einheiten vorgegeben werden
IN1MODE=49 Nothalt sensorless (High aktiv)
Bei einer steigenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN1MODE=50 Nothalt sensorless (Low aktiv)
Bei einer fallenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN1MODE=51 | Master/Slave- Aufsynchronisieren | aufsynchronisierenmit ENGAGE=6 auskoppeln mit ENGAGE = 12
IN1MODE=53 | Master/Slave- Aufsynchronisieren | aufsynchronisierenmit ENGAGE=7 auskoppeln mit ENGAGE = 12
IN1MODE=57 Umschalten zwischen den Parametersätzen Low: std. Parameter werden benutzt
High: zweiter Parametersatz wird benutzt

(s. Kommando PARCNFG)
IN1MODE=60 VOSPD-Switch Umschalten der Überdrehzahl-Schwelle (VOSPD)

steigende Flanke schaltet die Überdrehzahl-Schwelle (VOSPD) auf INxTRIG um, fallende Flanke aktiviert die ursprüngliche VOSPD-Einstellung
IN1MODE=61 Impulslänge IN1 Messung der Impulslänge auf IN1

Es wird dafür die Latch-Funktion aktiviert. Sie misst die Zeit zwischen steigender und fallender Flanke am Eingang IN1.
Die gemessene Zeit (in 1 µsec-Schritten) wird in der Latchvariable LATCH1N32 abgespeichert. Über die Statusbits in TRJSTAT kann der Zustand der Zeitmessung abgelesen werden:
TRJSTAT= 0X2000000– steigende Flanke erkannt, Zeitmessung läuft
TRJSTAT= 0X4000000– fallende Flanke erkannt, Zeitmessung beendet
IN1MODE=62 Entladen des Zwischenkreises Wenn der Zwischenkreis entladen werden soll, muss zuerst die Einspeisung abgeschaltet werden. Nach Aktivieren des Eingangs wird in wenigen Sekunden der Zwischenkreis über den internen Ballastwiderstand entladen bis VBUS ungefähr 0 ist. Der Eingang muss zuerst wieder auf 0 gesetzt werden bevor der Antrieb wieder normal genutzt werden kann.

Achtung:
Damit diese Funktion bei eingeschalteter Einspeisung nicht aktiviert werden kann, wird intern das NETZ-BTB- Signal (Einspeisung ein) überwacht.
Falls die Überwachung des Netz-BTBs abgeschaltet ist (NONBTB>0), kann diese Funktion nicht genutzt werden.


ASCII Deutsch IN1TRIG

ASCII - Kommando | IN1TRIG |
Syntax Senden | IN1TRIG [Data] |
Syntax Empfangen | IN1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3563 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 1 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 99 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN1MODE

Beschreibung

Die Funktion der Hilfsvariable IN1TRIG hängt von der Konfiguration IN1MODE ab.


ASCII Deutsch IN2

ASCII - Kommando | IN2 |
Syntax Senden | IN2 |
Syntax Empfangen | IN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3564 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 100 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT2

Beschreibung

Zustand des digitalen Eingangs INPUT2


ASCII Deutsch IN2HCMD

ASCII - Kommando | IN2HCMD |
Syntax Senden | IN2HCMD [Data] |
Syntax Empfangen | IN2HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN2HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN2MODE=30,33 konfigurierten Eingang 2, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN2HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN2LCMD

ASCII - Kommando | IN2LCMD |
Syntax Senden | IN2LCMD [Data] |
Syntax Empfangen | IN2LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN2LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN2MODE=30,33 konfigurierten Eingang 2, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN2LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN2MODE

ASCII - Kommando | IN2MODE |
Syntax Senden | IN2MODE [Data] |
Syntax Empfangen | IN2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3565 (hex)
DIM | - | PROFIBUS PNU | 1701 (dec) IND = 1 (dec)
Bereich | 0 .. 90 | DPR | 101 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT2

Beschreibung

Mit dem Kommando IN2MODE kann die Funktion des digitalen Eingangs INPUT2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN2MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN2MODE=1 | Keine Funktion
IN2MODE=2 | Keine Funktion
IN2MODE=3 | Keine Funktion
IN2MODE=4 | Keine Funktion
IN2MODE=5 | Keine Funktion
IN2MODE=6 | Keine Funktion
IN2MODE=7 | Keine Funktion
IN2MODE=8 | Sollwertumschaltunganalog Eingang 1 / 2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle Analog In 1/Analog In 2 umgeschaltet werden (Low = Analog In 1, High=Analog In 2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN2MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
IN2MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN2MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN2MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN2MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN2MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN2MODE=15 Folgefahrauftrag Starten Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
(siehe auch O_C Tabelle 3)
IN2MODE=16 Fahrauftrag/Referenzfahrt IN2TRIG starten Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).

Nur in OPMODE 4 und 8 verfügbar
IN2MODE=17 | Fahrauftrag/Referenzfahrt starten <> stoppen | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN2MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN2TRIG in % von IPEAK vorgegeben.
IN2MODE=19 | keine Funktion
IN2MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN2TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=4,5,6,8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM, das Vorzeichen definiert die Drehrichtung
IN2MODE=21 Unterspannung ein/aus Der digitale Eingang schaltet die Überwachung der Unterspannung.
High = aus
Low = ein
IN2MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN2MODE=23 | Fahrauftrag/Referenzfahrt IN2TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN2MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN2TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muss folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN2TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN2MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung (ENCOUT) umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, dass der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN2MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variable LATCH2P32 (positive Flanke) oder LATCH2N32 (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCH2P16 (positive Flanke) oder LATCH2N16N (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 1 msek.

Hat IN1TRIG einen Wert ungleich 0, so wird der Fahrauftrag mit der jeweiligen Nummer, welcher in IN1TRIG eingetragen ist, direkt gestartet.
IN2MODE=27 schneller Halt Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.

Antrieb bleibt enabled!
IN2MODE=28 Starten eines Tippbetriebes. OPMODE=4,5,6,8
Ab Firmware 0.73

Eine steigende Flanke startet einen Tippbetrieb mit der Geschwindigkeit VJOG.
Eine fallende Flanke stoppt die Bewegung.
IN2MODE=29 | Fahrauftrag/ Referenzfahrt starten | Eine steigende Flanke an diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Bei der Nummer 0 wird eine Referenzfahrt gestartet. Eine fallende Flanke an diesem Eingang löst kein STOP-Kommando aus.
IN2MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando IN2HCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando IN2LCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer IN2HCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer IN1LCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).
IN2MODE=32 Bremse ein/aus ACHTUNG!
Durch Lösen der Bremse bei gesperrter Endstufe
können abhängig von der Maschinenmechanik gefährliche Zustände entstehen !

Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrter Endstufe möglich.
IN2MODE=33 wie 30 Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.

Diese Funktion ist nicht mit der GUI Bediensoftware benutzbar.
IN2MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN2TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (32 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN2TRIG berechnet werden:

IN2TRIG = n [U/min]*2^32/(4000*60)
Beispiel: n = 500 [U/min]
INxTRIG = 500 * 2^32 / (4000*60) = 8947848

IN2TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS > 0 = 0 Position vom externen Geber (Vorwahl mit EXTPOS).
= 1 Position wird vom ersten Geber am Motor (FBTYPE) erfasst.
IN2MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN2MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN2TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Bit 15 fungiert als Vorzeichenbit und legt damit die Drehrichtung fest. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN2TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN2TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN2TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN2TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN2TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN2TRIG = 0x000afe0c = 720396
IN2MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.
IN2MODE=41 Nothalt Bewirkt das Auslösen eines Schnell Haltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Schnell Halt-Phase abgeschlossen.
Während der Schnell Halt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Schnell Halt wird in der 250µs-Task ausgewertet.
IN2MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
IN2MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN2MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN2TRIG in PGEARI - Einheiten vorgegeben werden
IN2MODE=49 | Nothalt sensorless (high aktiv) | Bei einer steigenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN2MODE=50 | Nothalt sensorless (low aktiv) | Bei einer fallenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN2MODE=51 | Master/Slave Aufsynchronisation
IN2MODE=53 | Master/Slave Aufsynchronisation
IN2MODE=57 Umschalten zw. Parametersätzen Low: std. Parameter werden benutzt
High: zweiter Parametersatz wird benutzt

(s. Kommando PARCNFG)
IN2MODE=60 VOSPD-Switch Umschalten der Überdrehzahl-Schwelle (VOSPD)

steigende Flanke schaltet die Überdrehzahl-Schwelle (VOSPD) auf INxTRIG um, fallende Flanke aktiviert die ursprüngliche VOSPD-Einstellung
IN2MODE=61 Impulslänge IN2 Messung der Impulslänge auf IN2

Es wird dafür die Latch-Funktion aktiviert. Sie misst die Zeit zwischen steigender und fallender Flanke am Eingang IN2.
Die gemessene Zeit (in 1 µsec-Schritten) wird in der Latchvariable LATCH2N32 abgespeichert. Über die Statusbits in TRJSTAT kann der Zustand der Zeitmessung abgelesen werden:
TRJSTAT= 0X2000000– steigende Flanke erkannt, Zeitmessung läuft
TRJSTAT= 0X4000000– fallende Flanke erkannt, Zeitmessung beendet
IN2MODE=62 Entladen des Zwischenkreises Wenn der Zwischenkreis entladen werden soll, muss zuerst die Einspeisung abgeschaltet werden. Nach Aktivieren des Eingangs wird in wenigen Sekunden der Zwischenkreis über den internen Ballastwiderstand entladen bis VBUS ungefähr 0 ist. Der Eingang muss zuerst wieder auf 0 gesetzt werden bevor der Antrieb wieder normal genutzt werden kann.

Achtung:
Damit diese Funktion bei eingeschalteter Einspeisung nicht aktiviert werden kann, wird intern das NETZ-BTB- Signal (Einspeisung ein) überwacht.
Falls die Überwachung des Netz-BTBs abgeschaltet ist (NONBTB>0), kann diese Funktion nicht genutzt werden.


ASCII Deutsch IN2PM

ASCII - Kommando | IN2PM |
Syntax Senden | IN2PM [Data] |
Syntax Empfangen | IN2PM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362E (hex)
DIM | - | PROFIBUS PNU | 1902 (dec) IND = 1 (dec)
Bereich | 0,1,2 | DPR | 302 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

Mit dem Kommando IN2PM kann die Funktion der Zwischenmeldung bei einer Fahrauftragsfolge konfiguriert werden.

Die Funktion „Zwischenmeldung bei einer Fahrauftragsfolge“ (Folge InPos) ist verfügbar, wenn eine I/O-Erweiterungskarte eingesetzt wird (Klemme X11B4) oder wenn ein digitaler Ausgang des Grundgerätes mit der Funktion OxMODE=16 konfiguriert wurde. Beim Start des ersten Fahrsatzes einer Fahrsatzfolge wird der Ausgang „Folge InPos“ immer auf 0 gesetzt. Das Verhalten des Ausgangs beim Ausführen der Fahrsatzfolge hängt von der Konfigurationsvariable IN2PM ab.

IN2PM=0 – Der Ausgang wird invertiert beim Starten eines Folgefahrsatzes.
IN2PM=2 – Der Ausgang wird invertiert am Ende eines Fahrsatzes.
IN2PM=1 – Beim Start eines Fahrsatzes wird der Ausgang auf 0 gesetzt, am Ende eines Fahrsatzes wird der Ausgang High.

Bei einer Fahrsatzfolge in der die Fahrsätze sofort gestartet werden, sind nur die Einstellungen IN2PM=0 oder IN2PM=2 sinnvoll. Bei der Einstellung IN2PM=1 ist der High-Zustand so kurz, daß er u.U. gar nicht von der externen Steuerung registriert werden kann.

Wenn ein Folgefahrsatz mit Hilfe eines I/O gestartet werden soll (INxMODE=15), so sollte die Einstellung IN2PM=2 bzw. IN2PM=1 benutzt werden. Bei dieser Einstellung wird das Ende eines Fahrsatzes durch den High-Zustand (IN2PM=1) bzw. durch den Zustandwechsel (IN2PM=2) am „Folge-InPos“-Ausgang gemeldet. Daraufhin kann die externe Steuerung über den Eingang „Folgefahrauftrag starten“ das Fortsetzen der Fahrauftragsfolge veranlassen.

Siehe auch IN1MODE = 15


ASCII Deutsch IN2TRIG

ASCII - Kommando | IN2TRIG |
Syntax Senden | IN2TRIG [Data] |
Syntax Empfangen | IN2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3566 (hex)
DIM | - | PROFIBUS PNU | 1702 (dec) IND = 1 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 102 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN2MODE

Beschreibung

Die Funktion der Hilfsvariable IN2TRIG hängt von der Konfiguration IN2MODE ab.
s. IN2MODE


ASCII Deutsch IN3

ASCII - Kommando | IN3 |
Syntax Senden | IN3 [Data] |
Syntax Empfangen | IN3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3567 (hex)
DIM | - | PROFIBUS PNU | 1703 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 103 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT3

Beschreibung

Zustand des digitalen Eingangs INPUT3


ASCII Deutsch IN3HCMD

ASCII - Kommando | IN3HCMD |
Syntax Senden | IN3HCMD [Data] |
Syntax Empfangen | IN3HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando INH3CMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN3MODE=30,33 konfigurierten Eingang 3, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN3HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN3LCMD

ASCII - Kommando | IN3LCMD |
Syntax Senden | IN3LCMD [Data] |
Syntax Empfangen | IN3LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN3LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN3MODE=30,33 konfigurierten Eingang 3, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN3LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN3MODE

ASCII - Kommando | IN3MODE |
Syntax Senden | IN3MODE [Data] |
Syntax Empfangen | IN3MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3568 (hex)
DIM | - | PROFIBUS PNU | 1704 (dec) IND = 1 (dec)
Bereich | 0 .. 90 | DPR | 104 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT3

Beschreibung

Mit dem Kommando IN3MODE kann die Funktion des digitalen Eingangs INPUT3 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN3MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN3MODE=1 | keine Funktion
IN3MODE=1 Verstärker Reset Beim Auftreten eines Verstärker-Fehlers (BTB=0, Display-Anzeige Fxx) führt eine steigende Flanke auf diesem Eingang zum Resettieren des Fehlers, wenn ein Fehler ansteht. Wenn kein Fehler ansteht, so wird der Eingang ignoriert. Je nach Art des Fehlers, erfolgt ein Hardware- bzw. Software-Reset des Verstärkers. Bei einem Software-Reset, ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die gesamte Initialisierungsphase durchlaufen (Power on), so dass die Parameter aus dem EEPROM geladen werden.
Falls beim Einschalten des Verstärkers ein High-Zustand (24V) am INPUT1 erkannt wird, so wird die Initialisierungsphase unterbrochen bis der Eingang den Zustand Low (0V) aufweist. Dieser "Wartezustand" des Verstärkers kann am Display ("A"-Zeichen im ersten Segment) erkannt werden.
IN3MODE=2 | PSTOP | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=3 | NSTOP (4.78) | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=4 | PSTOP mit Integral off | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=5 | NSTOP mit Integral off | Der Low-Pegel sperrt die negative Drehrichtung (gegen Uhrzeigersinn bei DIR=1, Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=6 | PSTOP+NSTOP | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=7 | PSTOP+NSTOP mit Integral off | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=8 | Sollwertumschaltunganalog Eingang 1 / 2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle Analog In 1/Analog In 2 umgeschaltet werden (Low = Analog In 1, High=Analog In 2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN3MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
IN3MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN3MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN3MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN3MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN3MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN3MODE=15 Folgefahrauftrag Starten Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
(siehe auch O_C Tabelle 3)
IN3MODE=16 Fahrauftrag/Referenzfahrt IN2TRIG starten Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).

Nur in OPMODE 4 und 8 verfügbar
IN3MODE=17 | Fahrauftrag/Referenzfahrt starten <> stoppen | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN3MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN3TRIG in % von IPEAK vorgegeben.
IN3MODE=19 | keine Funktion
IN3MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN3TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM, das Vorzeichen definiert die Drehrichtung
IN3MODE=21 Unterspannung ein/aus Der digitale Eingang schaltet die Überwachung der Unterspannung.
High = aus
Low = ein
IN3MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN3MODE=23 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN3MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN3TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muss folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN3TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN3MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung (ENCOUT) umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, dass der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN3MODE=27 schneller Halt Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.

Antrieb bleibt enablet!
IN3MODE=28 Starten eines Tippbetriebes. NUR OPMODE=8 !
Ab Firmware 0.73

Eine steigende Flanke startet einen Tippbetrieb mit der Geschwindigkeit VJOG.
Eine fallende Flanke stoppt die Bewegung.
IN3MODE=29 | Fahrauftrag/ Referenzfahrt starten | Eine steigende Flanke an diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Bei der Nummer 0 wird eine Referenzfahrt gestartet. Eine fallende Flanke an diesem Eingang löst kein STOP-Kommando aus.
IN3MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando IN3HCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando IN3LCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer IN1HCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer IN1LCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).
IN3MODE=32 Bremse ein/aus ACHTUNG!
Durch Lösen der Bremse bei gesperrter Endstufe
können abhängig von der Maschinenmechanik gefährliche Zustände entstehen !

Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrter Endstufe möglich.
IN3MODE=33 wie 30 Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.

Diese Funktion ist nicht mit der GUI Bediensoftware benutzbar.
IN3MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN3TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (32 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN3TRIG berechnet werden:

IN3TRIG = n [U/min]*2^32/(4000*60)
Beispiel: n = 500 [U/min]
INxTRIG = 500 * 2^32 / (4000*60) = 8947848

IN3TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS > 0 = 0 Position vom externen Geber (Vorwahl mit EXTPOS).
= 1 Position wird vom ersten Geber am Motor (FBTYPE) erfasst.
IN3MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN3MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN3TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Bit 15 fungiert als Vorzeichenbit und legt damit die Drehrichtung fest. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN3TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN3TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN3TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN3TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN3TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN3TRIG = 0x000afe0c = 720396
IN3MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.
IN3MODE=41 Nothalt Bewirkt das Auslösen eines Schnell Haltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Schnell Halt-Phase abgeschlossen.
Während der Schnell Halt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Schnell Halt wird in der 250µs-Task ausgewertet.
IN3MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
IN3MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN1MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN3TRIG in PGEARI - Einheiten vorgegeben werden
IN3MODE=49 Nothalt sensorless (High-aktiv) (High aktiv)
Bei einer steigenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN3MODE=50 | Nothalt sensorless (Low-aktiv)
IN3MODE=51 | Master/Slave Aufsynchonisation
IN3MODE=53 | Master/Slave Aufsynchonisation
IN3MODE=57 Umschalten zw. Parametersätzen Low: std. Parameter werden benutzt
High: zweiter Parametersatz wird benutzt

(s. Kommando PARCNFG)
IN3MODE=60 VOSPD-Switch Umschalten der Überdrehzahl-Schwelle (VOSPD)

steigende Flanke schaltet die Überdrehzahl-Schwelle (VOSPD) auf INxTRIG um, fallende Flanke aktiviert die ursprüngliche VOSPD-Einstellung
IN3MODE=62 Entladen des Zwischenkreises Wenn der Zwischenkreis entladen werden soll, muss zuerst die Einspeisung abgeschaltet werden. Nach Aktivieren des Eingangs wird in wenigen Sekunden der Zwischenkreis über den internen Ballastwiderstand entladen bis VBUS ungefähr 0 ist. Der Eingang muss zuerst wieder auf 0 gesetzt werden bevor der Antrieb wieder normal genutzt werden kann.

Achtung:
Damit diese Funktion bei eingeschalteter Einspeisung nicht aktiviert werden kann, wird intern das NETZ-BTB- Signal (Einspeisung ein) überwacht.
Falls die Überwachung des Netz-BTBs abgeschaltet ist (NONBTB>0), kann diese Funktion nicht genutzt werden.


ASCII Deutsch IN3TRIG

ASCII - Kommando | IN3TRIG |
Syntax Senden | IN3TRIG [Data] |
Syntax Empfangen | IN3TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3569 (hex)
DIM | - | PROFIBUS PNU | 1705 (dec) IND = 1 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 105 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN3MODE

Beschreibung

Die Funktion der Hilfsvariable IN3TRIG hängt von der Konfiguration IN3MODE ab.
s. IN3MODE


ASCII Deutsch IN4

ASCII - Kommando | IN4 |
Syntax Senden | IN4 |
Syntax Empfangen | IN4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356A (hex)
DIM | - | PROFIBUS PNU | 1706 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 106 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT4

Beschreibung

Zustand des digitalen Eingangs INPUT4


ASCII Deutsch IN4HCMD

ASCII - Kommando | IN4HCMD |
Syntax Senden | IN4HCMD [Data] |
Syntax Empfangen | IN4HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN4HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN4MODE=30,33 konfigurierten Eingang 4, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN4HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN4LCMD

ASCII - Kommando | IN4LCMD |
Syntax Senden | IN4LCMD [Data] |
Syntax Empfangen | IN4LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN4LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN4MODE=30,33 konfigurierten Eingang 4, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN4LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN4MODE

ASCII - Kommando | IN4MODE |
Syntax Senden | IN4MODE [Data] |
Syntax Empfangen | IN4MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356B (hex)
DIM | - | PROFIBUS PNU | 1707 (dec) IND = 1 (dec)
Bereich | 0 .. 90 | DPR | 107 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT4

Beschreibung

Mit dem Kommando IN4MODE kann die Funktion des digitalen Eingangs INPUT4 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand / State | Funktion | Beschreibung
IN4MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN4MODE=1 | keine Funktion
IN4MODE=2 | PSTOP (4.78) | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=3 | NSTOP | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=4 | NSTOP mit Integral off | Der Low-Pegel sperrt die negative Drehrichtung (gegen Uhrzeigersinn bei DIR=1, Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=5 | NSTOP mit Integral off | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=6 | keine Funktion
IN4MODE=7 | keine Funktion
IN4MODE=8 | Sollwertumschaltung Analog In 1/Analog In 2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle Analog In 1/Analog In 2 umgeschaltet werden (Low = Analog In 1, High=Analog In 2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN4MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
IN4MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN4MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN4MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN4MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN4MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN4MODE=15 Folgefahrauftrag Starten Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
(siehe auch O_C Tabelle 3)
IN4MODE=16 Fahrauftrag/Referenzfahrt IN4TRIG starten Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).

Nur in OPMODE 4 und 8 verfügbar
IN4MODE=17 | Fahrauftrag/Referenzfahrt starten <> stoppen | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN4MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN4TRIG in % von IPEAK vorgegeben.
IN4MODE=19 | keine Funktion
IN4MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN4TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM, das Vorzeichen definiert die Drehrichtung
IN4MODE=21 Unterspannung ein/aus Der digitale Eingang schaltet die Überwachung der Unterspannung.
High = aus
Low = ein
IN4MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN4MODE=23 | Fahrauftrag/Referenzfahrt IN4TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN4MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN4TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muss folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN4TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN4MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung (ENCOUT) umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, dass der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN4MODE=27 schneller Halt Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.

Antrieb bleibt enabled!
IN4MODE=28 Starten eines Tippbetriebes. NUR OPMODE=8 !
Ab Firmware 0.73

Eine steigende Flanke startet einen Tippbetrieb mit der Geschwindigkeit VJOG.
Eine fallende Flanke stoppt die Bewegung.
IN4MODE=29 | Fahrauftrag/ Referenzfahrt starten | Eine steigende Flanke an diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Bei der Nummer 0 wird eine Referenzfahrt gestartet. Eine fallende Flanke an diesem Eingang löst kein STOP-Kommando aus.
IN4MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando IN4HCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando IN4LCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer IN1HCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer IN1LCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).
IN4MODE=32 Bremse ein/aus ACHTUNG!
Durch Lösen der Bremse bei gesperrter Endstufe
können abhängig von der Maschinenmechanik gefährliche Zustände entstehen !

Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrter Endstufe möglich.
IN4MODE=33 wie 30 Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.

Diese Funktion ist nicht mit der GUI Bediensoftware benutzbar.
IN4MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN4TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (32 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN4TRIG berechnet werden:

IN4TRIG = n [U/min]*2^32/(4000*60)
Beispiel: n = 500 [U/min]
INxTRIG = 500 * 2^32 / (4000*60) = 8947848

IN4TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS > 0 = 0 Position vom externen Geber (Vorwahl mit EXTPOS).
= 1 Position wird vom ersten Geber am Motor (FBTYPE) erfasst.
IN4MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN4MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN4TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Bit 15 fungiert als Vorzeichenbit und legt damit die Drehrichtung fest. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN4TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN4TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN4TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN4TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN4TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN4TRIG = 0x000afe0c = 720396
IN4MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.
IN4MODE=41 Nothalt Bewirkt das Auslösen eines Schnell Haltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Schnell Halt-Phase abgeschlossen.
Während der Schnell Halt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Schnell Halt wird in der 250µs-Task ausgewertet.
IN4MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
IN4MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN1MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN4TRIG in PGEARI - Einheiten vorgegeben werden
IN4MODE=49 Nothalt sensorless (High-aktiv) (High aktiv)
Bei einer steigenden Flanke erfolgt ein Nothalt des Antriebes (stromgeregelt ohne Auswertung der Positionsinformation).
IN4MODE=50 | Nothalt sensorless (Low-aktiv)
IN4MODE=51 | Master/Slave Aufsynchonisation
IN4MODE=53 | Master/Slave Aufsynchonisation
IN4MODE=57 Umschalten zw. Parametersätzen Low: std. Parameter werden benutzt
High: zweiter Parametersatz wird benutzt

(s. Kommando PARCNFG)
IN4MODE=60 VOSPD-Switch Umschalten der Überdrehzahl-Schwelle (VOSPD)

steigende Flanke schaltet die Überdrehzahl-Schwelle (VOSPD) auf INxTRIG um, fallende Flanke aktiviert die ursprüngliche VOSPD-Einstellung
IN4MODE=62 Entladen des Zwischenkreises Wenn der Zwischenkreis entladen werden soll, muss zuerst die Einspeisung abgeschaltet werden. Nach Aktivieren des Eingangs wird in wenigen Sekunden der Zwischenkreis über den internen Ballastwiderstand entladen bis VBUS ungefähr 0 ist. Der Eingang muss zuerst wieder auf 0 gesetzt werden bevor der Antrieb wieder normal genutzt werden kann.

Achtung:
Damit diese Funktion bei eingeschalteter Einspeisung nicht aktiviert werden kann, wird intern das NETZ-BTB- Signal (Einspeisung ein) überwacht.
Falls die Überwachung des Netz-BTBs abgeschaltet ist (NONBTB>0), kann diese Funktion nicht genutzt werden


ASCII Deutsch IN4TRIG

ASCII - Kommando | IN4TRIG |
Syntax Senden | IN4TRIG [Data] |
Syntax Empfangen | IN4TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 356C (hex)
DIM | - | PROFIBUS PNU | 1708 (dec) IND = 1 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 108 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN4MODE

Beschreibung

Die Funktion der Hilfsvariable IN4TRIG hängt von der Konfiguration IN4MODE ab.
s. IN4MODE


ASCII Deutsch IN5

ASCII - Kommando | IN5 |
Syntax Senden | IN5MODE [Data] |
Syntax Empfangen | IN5 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36F5 (hex)
DIM |  | PROFIBUS PNU | 1701 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 501 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN5_22

ASCII - Kommando | IN5_22 |
Syntax Senden | IN5 ... IN22 |
Syntax Empfangen | IN5 ... IN22 | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand der digitalen Eingänge 5 ... 22

Beschreibung

Zustand des digitalen Eingangs INPUTx x= 5 ... 22


ASCII Deutsch IN5_22MODE

ASCII - Kommando | IN5_22MODE |
Syntax Senden | INxMODE [Data] |
Syntax Empfangen | IN5_22MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 90 | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion der digitalen Eingänge 5...22

Beschreibung

Mit dem Kommando IN5...22MODE kann die Funktion des digitalen Eingangs INPUT5 .... 22 konfiguriert werden.

Die Hardware des S300/S700 stellt 4 digitale Eingänge zur Verfügung. Die Firmware unterstützt zusätzlich 18 weitere digitale Eingänge. Somit stehen insgesamt 22 digitale Eingänge zur Verfügung.

Zu den digitalen I/O’s gehören sowohl die 24V Eingänge, die über eine Hardware-Schnittstelle von einer Steuerung benutzt werden können, als auch die Software I/O’s, die nur über eine Software-Schnittstelle (Feldbus, RS232, DPR-Schnittstelle) angesprochen werden können.

Die Aufteilung der I/O’s (Hardware/Software) hängt von der vorhandenen Hardware-Konfiguration ab und sieht wie folgt aus:

ohne I/O-Erweiterungskarte

1. Hardware
Eingänge Basisplatine: 4 (IN1 - IN4)

2. Software
virtuelle Eingänge: 18 (IN5 - IN22)

mit I/O-Erweiterungskarte

1. Hardware
Eingänge Basisplatine: 4 (IN1 - IN4)
Eingänge Erweiterungskarte 14 (IN5 – IN18)

2. Software
virtuelle Eingänge: 4 (IN19 - IN22)

Alle digitalen Eingänge sind frei konfigurierbar.
Die Konfiguration erfolgt mit dem Kommando INxMODE, (x bezeichnet die Nummer des zu konfigurierenden Eingangs). Die Hilfswerte, die für manche Funktionen benötigt sind, werden in den Parametern IN5...19TRIG abgelegt. Der Zustand eines Einganges kann mit dem Kommando IN5...20 abgefragt werden. Er kann nur den Wert 0 (Eingang inaktiv) bzw. 1 (Eingang aktiv) annehmen.

Die nachfolgend aufgeführten Funktionen sind NICHT für die Eingänge 5 ... 20 verfügbar:

INxMODE =

NSTOP/PSTOP-Funktionalität (INxMODE=2,3,4,5,6,7) nur für x=3,4 möglich.
Latch-Funktionalität (INxMODE=26,44,45,46) nur bei x=1,2 möglich
ASCII-Buffers (INxMODE=30,33) nur bei x=1...6 möglich

Alle anderen Funktionen können mit jedem beliebigen Eingang verknüpft werden.
Dies gilt auch für alle Ausgangsfunktionen.

Mit jedem digitalen Ein-/Ausgang ist eine Macro-Variable verknüpft, die mit der Scope-Funktion aufgezeichnet, bzw. mit dem M-Kommando angesprochen werden kann.
Die Namen dieser Variablen lauten INPUTx für die digitalen Eingänge (x=1...20)
bzw. OUTPUTx für die digitalen Ausgänge (x=1..18).

Darüber hinaus kann der Zustand der Software-Eingänge mit der Bit-Variable SOFTIN abgefragt bzw. gesetzt werden (Bit0 = INPUT5,Bit15 = INPUT20).
Der Zustand der Software-Ausgänge ist in der Bit-Variable SOFTOUT zusammengefasst (Bit0 = OUTPUT3, BIT15 = OUTPUT18).

Die PNU Nummern sind wie folgt vergeben:

IN5MODE PNU 1702 (dec) IND 17 (dec)
IN6MODE PNU 1705 (dec) IND 17 (dec)
IN7MODE PNU 1708 (dec) IND 17 (dec)
IN8MODE PNU 1711 (dec) IND 17 (dec)
IN9MODE PNU 1714 (dec) IND 17 (dec)
IN10MODE PNU 1717 (dec) IND 17 (dec)
IN11MODE PNU 1720 (dec) IND 17 (dec)
IN12MODE PNU 1723 (dec) IND 17 (dec)
IN13MODE PNU 1726 (dec) IND 17 (dec)
IN14MODE PNU 1729 (dec) IND 17 (dec)
IN15MODE PNU 1732 (dec) IND 17 (dec)
IN16MODE PNU 1735 (dec) IND 17 (dec)
IN17MODE PNU 1738 (dec) IND 17 (dec)
IN18MODE PNU 1741 (dec) IND 17 (dec)
IN19MODE PNU 1744 (dec) IND 17 (dec)
IN20MODE PNU 1747 (dec) IND 17 (dec)
IN21MODE PNU 1827 (dec) IND 17 (dec)
IN22MODE PNU 1830 (dec) IND 17 (dec)


ASCII Deutsch IN5_22TRIG

ASCII - Kommando | IN5_22TRIG |
Syntax Senden | INxTRIG [Data] |
Syntax Empfangen | IN5_22TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | long int | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable der digitalen Eingänge 5 ... 22

Beschreibung

Die Funktion der Hilfsvariablen hängt von der Konfiguration IN5_22MODE ab.


ASCII Deutsch IN5MODE

ASCII - Kommando | IN5MODE |
Syntax Senden | IN5MODE [Data] |
Syntax Empfangen | IN5MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36F6 (hex)
DIM |  | PROFIBUS PNU | 1702 (dec) IND = 17 (dec)
Bereich |  | DPR | 502 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN5TRIG

ASCII - Kommando | IN5TRIG |
Syntax Senden | IN5TRIG [Data] |
Syntax Empfangen | IN5TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36F7 (hex)
DIM |  | PROFIBUS PNU | 1703 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 503 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN6

ASCII - Kommando | IN6 |
Syntax Senden | IN6 [Data] |
Syntax Empfangen | IN6 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36F8 (hex)
DIM |  | PROFIBUS PNU | 1704 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 504 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN6MODE

ASCII - Kommando | IN6MODE |
Syntax Senden | IN6MODE [Data] |
Syntax Empfangen | IN6MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36F9 (hex)
DIM |  | PROFIBUS PNU | 1705 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 505 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN6TRIG

ASCII - Kommando | IN6TRIG |
Syntax Senden | IN6TRIG [Data] |
Syntax Empfangen | IN6TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36FA (hex)
DIM |  | PROFIBUS PNU | 1706 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 506 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN7

ASCII - Kommando | IN7 |
Syntax Senden | IN7 [Data] |
Syntax Empfangen | IN7 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36FB (hex)
DIM |  | PROFIBUS PNU | 1707 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 507 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN7MODE

ASCII - Kommando | IN7MODE |
Syntax Senden | IN7MODE [Data] |
Syntax Empfangen | IN7MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36FC (hex)
DIM |  | PROFIBUS PNU | 1708 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 508 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN7TRIG

ASCII - Kommando | IN7TRIG |
Syntax Senden | IN7TRIG [Data] |
Syntax Empfangen | IN7TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36FD (hex)
DIM |  | PROFIBUS PNU | 1709 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 509 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN8

ASCII - Kommando | IN8 |
Syntax Senden | IN8 [Data] |
Syntax Empfangen | IN8 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36FE (hex)
DIM |  | PROFIBUS PNU | 1710 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 510 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN8MODE

ASCII - Kommando | IN8MODE |
Syntax Senden | IN8MODE [Data] |
Syntax Empfangen | IN8MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36FF (hex)
DIM |  | PROFIBUS PNU | 1711 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 511 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN8TRIG

ASCII - Kommando | IN8TRIG |
Syntax Senden | IN8TRIG [Data] |
Syntax Empfangen | IN8TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3700 (hex)
DIM |  | PROFIBUS PNU | 1712 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 512 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN9

ASCII - Kommando | IN9 |
Syntax Senden | IN9 [Data] |
Syntax Empfangen | IN9 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3701 (hex)
DIM |  | PROFIBUS PNU | 1713 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 513 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN9MODE

ASCII - Kommando | IN9MODE |
Syntax Senden | IN9MODE [Data] |
Syntax Empfangen | IN9MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3702 (hex)
DIM |  | PROFIBUS PNU | 1714 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 514 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN9TRIG

ASCII - Kommando | IN9TRIG |
Syntax Senden | IN9TRIG [Data] |
Syntax Empfangen | IN9TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3703 (hex)
DIM |  | PROFIBUS PNU | 1715 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 515 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN10

ASCII - Kommando | IN10 |
Syntax Senden | IN10 |
Syntax Empfangen | IN10 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3704 (hex)
DIM |  | PROFIBUS PNU | 1716 (dec) IND = 17 (dec)
Bereich |  | DPR | 516 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN10MODE

ASCII - Kommando | IN10MODE |
Syntax Senden | IN10MODE [Data] |
Syntax Empfangen | IN10MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3705 (hex)
DIM |  | PROFIBUS PNU | 1717 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 517 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN10TRIG

ASCII - Kommando | IN10TRIG |
Syntax Senden | IN10TRIG [Data] |
Syntax Empfangen | IN10TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3706 (hex)
DIM |  | PROFIBUS PNU | 1718 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 518 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN11

ASCII - Kommando | IN11 |
Syntax Senden | IN11 |
Syntax Empfangen | IN11 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3707 (hex)
DIM |  | PROFIBUS PNU | 1719 (dec) IND = 17 (dec)
Bereich |  | DPR | 519 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN11MODE

ASCII - Kommando | IN11MODE |
Syntax Senden | IN11MODE [Data] |
Syntax Empfangen | IN11MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3708 (hex)
DIM |  | PROFIBUS PNU | 1720 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 520 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN11TRIG

ASCII - Kommando | IN11TRIG |
Syntax Senden | IN11TRIG [Data] |
Syntax Empfangen | IN11TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3709 (hex)
DIM |  | PROFIBUS PNU | 1721 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 521 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN12

ASCII - Kommando | IN12 |
Syntax Senden | IN12 |
Syntax Empfangen | IN12 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 370A (hex)
DIM |  | PROFIBUS PNU | 1722 (dec) IND = 17 (dec)
Bereich |  | DPR | 522 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN12MODE

ASCII - Kommando | IN12MODE |
Syntax Senden | IN12MODE [Data] |
Syntax Empfangen | IN12MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 370B (hex)
DIM |  | PROFIBUS PNU | 1723 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 523 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN12TRIG

ASCII - Kommando | IN12TRIG |
Syntax Senden | IN12TRIG [Data] |
Syntax Empfangen | IN12TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 370C (hex)
DIM |  | PROFIBUS PNU | 1724 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 524 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN13

ASCII - Kommando | IN13 |
Syntax Senden | IN13 |
Syntax Empfangen | IN13 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 370D (hex)
DIM |  | PROFIBUS PNU | 1725 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 525 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN13MODE

ASCII - Kommando | IN13MODE |
Syntax Senden | IN13MODE [Data] |
Syntax Empfangen | IN13MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 370E (hex)
DIM |  | PROFIBUS PNU | 1726 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 526 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN13TRIG

ASCII - Kommando | IN13TRIG |
Syntax Senden | IN13TRIG [Data] |
Syntax Empfangen | IN13TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 370F (hex)
DIM |  | PROFIBUS PNU | 1727 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 527 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang1

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN14

ASCII - Kommando | IN14 |
Syntax Senden | IN14 |
Syntax Empfangen | IN14 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3710 (hex)
DIM |  | PROFIBUS PNU | 1728 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 528 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN14MODE

ASCII - Kommando | IN14MODE |
Syntax Senden | IN14MODE [Data] |
Syntax Empfangen | IN14MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3711 (hex)
DIM |  | PROFIBUS PNU | 1729 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 529 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN14TRIG

ASCII - Kommando | IN14TRIG |
Syntax Senden | IN14TRIG [Data] |
Syntax Empfangen | IN14TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3712 (hex)
DIM |  | PROFIBUS PNU | 1730 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 530 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN15

ASCII - Kommando | IN15 |
Syntax Senden | IN15 |
Syntax Empfangen | IN15 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3713 (hex)
DIM |  | PROFIBUS PNU | 1731 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 531 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN15MODE

ASCII - Kommando | IN15MODE |
Syntax Senden | IN15MODE [Data] |
Syntax Empfangen | IN15MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3714 (hex)
DIM |  | PROFIBUS PNU | 1732 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 532 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN15TRIG

ASCII - Kommando | IN15TRIG |
Syntax Senden | IN15TRIG [Data] |
Syntax Empfangen | IN15TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3715 (hex)
DIM |  | PROFIBUS PNU | 1733 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 533 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN16

ASCII - Kommando | IN16 |
Syntax Senden | IN16 |
Syntax Empfangen | IN16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3716 (hex)
DIM |  | PROFIBUS PNU | 1734 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 534 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN16MODE

ASCII - Kommando | IN16MODE |
Syntax Senden | IN16MODE [Data] |
Syntax Empfangen | IN16MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3717 (hex)
DIM |  | PROFIBUS PNU | 1735 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 535 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN16TRIG

ASCII - Kommando | IN16TRIG |
Syntax Senden | IN16TRIG [Data] |
Syntax Empfangen | IN16TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3718 (hex)
DIM |  | PROFIBUS PNU | 1736 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 536 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN17

ASCII - Kommando | IN17 |
Syntax Senden | IN17 |
Syntax Empfangen | IN17 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3719 (hex)
DIM |  | PROFIBUS PNU | 1737 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 537 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN17MODE

ASCII - Kommando | IN17MODE |
Syntax Senden | IN17MODE [Data] |
Syntax Empfangen | IN17MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 371A (hex)
DIM |  | PROFIBUS PNU | 1738 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 538 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN17TRIG

ASCII - Kommando | IN17TRIG |
Syntax Senden | IN17TRIG [Data] |
Syntax Empfangen | IN17TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 371B (hex)
DIM |  | PROFIBUS PNU | 1739 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 539 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN18

ASCII - Kommando | IN18 |
Syntax Senden | IN18 |
Syntax Empfangen | IN18 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 371C (hex)
DIM |  | PROFIBUS PNU | 1740 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 540 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN18MODE

ASCII - Kommando | IN18MODE |
Syntax Senden | IN18MODE [Data] |
Syntax Empfangen | IN18MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 371D (hex)
DIM |  | PROFIBUS PNU | 1741 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 541 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN18TRIG

ASCII - Kommando | IN18TRIG |
Syntax Senden | IN18TRIG [Data] |
Syntax Empfangen | IN18TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 371E (hex)
DIM |  | PROFIBUS PNU | 1742 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 542 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN19

ASCII - Kommando | IN19 |
Syntax Senden | IN19 |
Syntax Empfangen | IN19 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 371F (hex)
DIM |  | PROFIBUS PNU | 1743 (dec) IND = 17 (dec)
Bereich | 0 .. 1 | DPR | 543 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN19HCMD

ASCII - Kommando | IN19HCMD |
Syntax Senden | IN19HCMD [Data] |
Syntax Empfangen | IN19HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

siehe IN2HCMD


ASCII Deutsch IN19LCMD

ASCII - Kommando | IN19LCMD |
Syntax Senden | IN19LCMD [Data] |
Syntax Empfangen | IN19LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

siehe IN2LCMD


ASCII Deutsch IN19MODE

ASCII - Kommando | IN19MODE |
Syntax Senden | IN19MODE [Data] |
Syntax Empfangen | IN19MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3720 (hex)
DIM |  | PROFIBUS PNU | 1744 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 544 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN19TRIG

ASCII - Kommando | IN19TRIG |
Syntax Senden | IN19TRIG [Data] |
Syntax Empfangen | IN19TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3721 (hex)
DIM |  | PROFIBUS PNU | 1745 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 545 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Eingang

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN20

ASCII - Kommando | IN20 |
Syntax Senden | IN20 |
Syntax Empfangen | IN20 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3722 (hex)
DIM |  | PROFIBUS PNU | 1746 (dec) IND = 17 (dec)
Bereich |  | DPR | 546 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22


ASCII Deutsch IN20HCMD

ASCII - Kommando | IN20HCMD |
Syntax Senden | IN20HCMD [Data] |
Syntax Empfangen | IN20HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

siehe IN2HCMD


ASCII Deutsch IN20LCMD

ASCII - Kommando | IN20LCMD |
Syntax Senden | IN20LCMD [Data] |
Syntax Empfangen | IN20LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | max 64 ASCII Characters | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

siehe IN2LCMD


ASCII Deutsch IN20MODE

ASCII - Kommando | IN20MODE |
Syntax Senden | IN20MODE [Data] |
Syntax Empfangen | IN20MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3723 (hex)
DIM |  | PROFIBUS PNU | 1747 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 547 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

siehe IN5_22MODE


ASCII Deutsch IN20TRIG

ASCII - Kommando | IN20TRIG |
Syntax Senden | IN20TRIG [Data] |
Syntax Empfangen | IN20TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3724 (hex)
DIM |  | PROFIBUS PNU | 1748 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 548 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

siehe IN5_22TRIG


ASCII Deutsch IN21MODE

ASCII - Kommando | IN21MODE |
Syntax Senden | IN21MODE [Data] |
Syntax Empfangen | IN21MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3773 (hex)
DIM |  | PROFIBUS PNU | 1827 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 627 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

nur S700:
siehe IN5_22MODE


ASCII Deutsch IN21TRIG

ASCII - Kommando | IN21TRIG |
Syntax Senden | IN21TRIG [Data] |
Syntax Empfangen | IN21TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3774 (hex)
DIM |  | PROFIBUS PNU | 1828 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 628 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

nur S700:
siehe IN5_22TRIG


ASCII Deutsch IN22MODE

ASCII - Kommando | IN22MODE |
Syntax Senden | IN22MODE [Data] |
Syntax Empfangen | IN22MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3776 (hex)
DIM |  | PROFIBUS PNU | 1830 (dec) IND = 17 (dec)
Bereich | 0 .. 90 | DPR | 630 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs

Beschreibung

nur S700:
siehe IN5_22MODE


ASCII Deutsch IN22TRIG

ASCII - Kommando | IN22TRIG |
Syntax Senden | IN22TRIG [Data] |
Syntax Empfangen | IN22TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3777 (hex)
DIM |  | PROFIBUS PNU | 1831 (dec) IND = 17 (dec)
Bereich | -2147483648 .. 2147483647 | DPR | 631 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Zustand des digitalen Eingangs

Beschreibung

nur S700:
siehe IN5_22TRIG


ASCII Deutsch Index

\
ACC
ACC_X
ACCR
ACCUNIT
ACTFAULT
ACTIVE
ACTRS232
ADC0_15
ADDR
AENA
ALIAS
AN11NR
AN11RANGE
AN1TRIG
AN2TRIG
ANCNFG
ANDB
ANHFACT1
ANHFACT2
ANIN1
ANIN2
ANIN3
ANIN4
ANOFF1
ANOFF2
ANOFF3
ANOFF4
ANOUT1
ANOUT2
ANZERO1
ANZERO2
ANZERO3
ANZERO4
ARHPD
ARHPF
ARLP2
ARLPD
ARLPF
ASMWAIT
AUTOHOME
AVZ1
AVZ2
BCC
BCCOT
BISSCNFG
BISSREVOL
BQMODE
BTIME
BUILDRK
BUILDRP
BUSP0
BUSP1
BUSP10
BUSP11
BUSP12
BUSP13
BUSP14
BUSP15
BUSP16
BUSP2
BUSP3
BUSP4
BUSP5
BUSP6
BUSP7
BUSP8
BUSP9
CALCCOG
CALCHP
CALCMP
CALCPOSIO
CALCRK
CALCRP
CANDUMP
CANSDO
CARDDEL
CARDDIR
CARDINFO
CARDSAVE
CARDUPDATE
CBAUD
CCSAVE
CINPOS
CLRFAULT
CLRHR
CLRORDER
CLRWARN
CMDDLY
COGFILT
COGMODE
COGRED
COLDSTART
CONTINUE
CPHASE
CSCNFG
CSENID
CSERR
CSIDMAX
CSIOSTAT
CSSTAT
CTUNE
CUPDATE
DAOFFSET1
DAOFFSET2
DEC
DEC_X
DECDIS
DECR
DECSTOP
DENA
DI2T
DICONT
DIFVAR
DILIM
DIPEAK
DIR
DIRIN
DIROUT
DIS
DISDPR
DNBAUD
DNDUMP
DNMACID
DOVRIDE
DPRILIMIT
DPRSTATE
DPRVAR1_16
DPV17_64
DPWM
DR_TYPE
DREF
DRIVE
DRVCNFG
DRVCNFG2
DRVCNFG3
DRVCNFG4
DRVSTAT
DRVSTAT2
DUMP
DUMPEMAP
DUMPSLNO
ECATCSA
EGEARI
EGEARO
EMRGTO
EN
EN22A1CNT
EN22A2CNT
EN22AI1
EN22AI2
EN22CNFG
EN22DCNT
EN22DIAG
ENCDIV
ENCDIVD
ENCFIX
ENCFIXD
ENCIN
ENCLINES
ENCMODE
ENCOUT
ENCTO
ENCVON
ENCZERO
ENGAGE
ERESMASK
ERND
ERRCNFG
ERRCODE
ERRCODE *
ERRCODE2
ERRMASK
ERRPARAM
ERRTIME
ESPEED
ETHMODE
EWH
EXTBRAKE
EXTLATCH
EXTPOS
EXTWD
FBGEARI
FBGEARO
FBTYPE
FBTYPEX
FFTSW
FHKP
FHTN
FILTMODE
FLTCNT
FLTCNT *
FLTHIST
FLTHIST *
FW
GEARFILT
GEARI
GEARMODE
GEARO
GET
GF
GFTN
GP
GP_X
GP2
GPDELAY
GPFFT
GPFFT_X
GPFFTV
GPFFV
GPFFV_X
GPFFVDELAY
GPS1
GPS2
GPTN
GPTN_X
GPTNTH1
GPTNTH2
GPTNTH3
GU
GUTN
GV
GV_X
GV2
GVFR
GVFR_X
GVS1
GVS2
GVTN
GVTN_X
GVTV
HALLDIR
HALLENDIR
HDSLLED
HDSLPOS
HDSLRANGE
HDSLROTAT
HDSLTEMP
HDSLTIME
HDSLTYPE
HDSLVEL
HDSLVOLT
HDUMP
HELP
HICOFFS
HIFACT1
HISOFFS
HLIMIT1
HLIMIT2
HLIMIT3
HSAVE
HVER
HWCNT
I
I2TLIM
ICMD
ICMDVLIM
ID
IDDUMP
IEXTT
IEXTTLIM
IN
IN1
IN10
IN10MODE
IN10TRIG
IN11
IN11MODE
IN11TRIG
IN12
IN12MODE
IN12TRIG
IN13
IN13MODE
IN13TRIG
IN14
IN14MODE
IN14TRIG
IN15
IN15MODE
IN15TRIG
IN16
IN16MODE
IN16TRIG
IN17
IN17MODE
IN17TRIG
IN18
IN18MODE
IN18TRIG
IN19
IN19HCMD
IN19LCMD
IN19MODE
IN19TRIG
IN1HCMD
IN1LCMD
IN1MODE
IN1TRIG
IN2
IN20
IN20HCMD
IN20LCMD
IN20MODE
IN20TRIG
IN21MODE
IN21TRIG
IN22MODE
IN22TRIG
IN2HCMD
IN2LCMD
IN2MODE
IN2PM
IN2TRIG
IN3
IN3HCMD
IN3LCMD
IN3MODE
IN3TRIG
IN4
IN4HCMD
IN4LCMD
IN4MODE
IN4TRIG
IN5
IN5_22
IN5_22MODE
IN5_22TRIG
IN5MODE
IN5TRIG
IN6
IN6MODE
IN6TRIG
IN7
IN7MODE
IN7TRIG
IN8
IN8MODE
IN8TRIG
IN9
IN9MODE
IN9TRIG
INPOS
INPT0
INPT1
INTERPOL
IOLINK
IPEAK
IPEAKN
IPEAKP
IQ
IQFILTK
IQFILTTAU
ISCALE1
ISCALE2
ISTFR
IVTICK
J
JRATIO
K
KC
KC_X
KEYLOCK
KTN
KTN_X
LASTWMASK
LATCH1N16
LATCH1N32
LATCH1P16
LATCH1P32
LATCH2N16
LATCH2N32
LATCH2P16
LATCH2P32
LDUMP
LED1
LED2
LED3
LEDSTAT
LINRESOL
LIST
LOAD
M
M_RESET
MAXCMD
MAXISETP
MAXSUMME
MAXTEMPE
MAXTEMPH
MAXTEMPM
MAXVSETP
MBPDRVSTAT
MBRAKE
MCFW
MCOSPHI
MCTR
MDBCNT
MDBGET
MDBLIST
MDBSET
MDRV
MFR
MH
MI2T
MICONT
MICONT_X
MIMR
MIMRQ
MINSUMME
MIPEAK
MIPEAK_X
MJ
MJ_X
MJOG
MKT
MKT_X
ML
ML_X
MLGC
MLGC_X
MLGD
MLGD_X
MLGP
MLGP_X
MLGQ
MLGQ_X
MNAME
MNUMBER
MONITOR1
MONITOR2
MOVE
MPHASE
MPHASE2
MPITCH
MPKD
MPKI
MPKP
MPOLES
MPOLES_X
MPR
MPTIME
MRESBW
MRESPOLES
MRS
MRS_X
MSERIALNO
MSG
MSLBRAKE
MSPEED
MTAB
MTANGLP
MTIME
MTIME_X
MTMUX
MTR
MTYPE
MUR
MVANGLB
MVANGLF
MVANGLMODE
MVANGLP
MVER
MVR
NONBTB
NREF
NREFG
NREFMT
O_ACC
O_C
O_DEC
O_FN
O_FT
O_P
O_TAB
O_V
O1
O10
O10MODE
O10TRIG
O11
O11MODE
O11TRIG
O12
O12MODE
O12TRIG
O13
O13MODE
O13TRIG
O14
O14MODE
O14TRIG
O15
O15MODE
O15TRIG
O16
O16MODE
O16TRIG
O17
O17MODE
O17TRIG
O18
O18MODE
O18TRIG
O1MODE
O1TRIG
O2
O2MODE
O2TRIG
O3
O3_18
O3_18MODE
O3_18TRIG
O3MODE
O3TRIG
O4
O4MODE
O4TRIG
O5
O5MODE
O5TRIG
O6
O6MODE
O6TRIG
O7
O7MODE
O7TRIG
O8
O8MODE
O8TRIG
O9
O9MODE
O9TRIG
OCOPY
OLIST
OPMODE
OPTION
OPTION2
ORDER
OTUNE
OVRIDE
P
P1
P1_P16
P10
P11
P12
P13
P14
P15
P16
P2
P3
P4
P5
P6
P7
P8
P9
PARCNFG
PARDUMP
PARRST
PASS
PASSCNFG
PASSPLC
PASSX
PASSXPLC
PBAL
PBALMAX
PBALRES
PBAUD
PE
PEINPOS
PEMAX
PFB
PFB0
PFBHI
PFBLO
PGEARI
PGEARO
PIOBUF
PLLCOFFS
PLLDOFFS
PLLHUB
PLLWOFFS
PMECH
PMODE
PNOID
POSCNFG
POSRSTAT
PPOTYP
PRBASE
PRD
PRIOR1
PRIOR2
PRIOR3
PRIOR4
PRIOR5
PROMPT
PSINUS
PSTATE
PSTEP
PTARGET
PTARGOFFS
PTBASE
PTMIN
PUNIT
PV
PVMAX
PVMAXN
PVMAXP
QCNFG
QENA
QFACT
QFACTCOMP
QFACTFILT
QFACTOR
QFCFACT
QFCMD
QFCMDFILT
QFMAX
QFSET
QKPEFF
QMACT
QMCMD
QMCMDLIM
QMLIMN
QMLIMP
QPE
QPRACT
QPRMAX
QPRSET
QPRSETEFF
QT1
QTAB1KP
QTAB1TN
QTAB1TV
QTAB1V
QTAB2KP
QTAB2TN
QTAB2TV
QTAB2V
QTAB3KP
QTAB3TN
QTAB3TV
QTAB3V
QTAB4KP
QTAB4TN
QTAB4TV
QTAB4V
QTAB5KP
QTAB5TN
QTAB5TV
QTAB5V
QTABID
QTIMEKD
QTNEFF
QTVEFF
QVAL
QVT1
RDP
RDPBIAS
RDPBIAS2
RDPCLAMP
RDPINT
RDPKI
RDPKP
RDPON
READY
RECDONE
RECING
RECOFF
RECORD
RECRDY
RECTRIG
REFIP
REFIP2
REFLS
REFMODE
REFNOFFS
REFNPOS
REFPOS
RELTIME
REMOTE
RESAMPL
RESOLVER
RESPHASE
RK
ROFFS
ROFFSABS
ROFFSSSI
RS232T
RSTVAR
RSVERROFF
RUNIN
S
S1DLY
SAVE
SBAUD
SCAN
SDLY
SERCERR
SERCLIST
SERCOFFS
SERCOS
SERCSET
SERIALNO
SETENCOFFS
SETREF
SKIP1SP
SKIP1W
SKIP2SP
SKIP2W
SLACCMAX
SLEN
SLIDK01
SLIMAX
SLIQK
SLIQK1
SLJSWITCH
SLMODE
SLOTIO
SLTEMPM
SLTSWITCH
SMNUMBER
SOFTIN
SOFTOUT
SPHAS
SRND
SSIGRAY
SSIINV
SSIMASK
SSIRESOL
SSIREVOL
SSIRXD
SSITIME
SSITOUT
SSTAT
STAGECODE
STAT
STATCODE
STATCODE *
STATIO
STATUS
STEP
STOP
STOPMODE
SWCNFG
SWE1
SWE2
SYNCSRC
T
TASK
TBRAKE
TBRAKE0
TEMPE
TEMPH
TEMPM
TEMPMFILT
TEN
TEST1
TESTENC
TRJSTAT
TRUN
TRUNS
TSTEP
UCOMP
UID
UMAX
UPDATE
UVLTMODE
V
VBUS
VBUSBAL
VBUSBOFFS
VBUSCNTMAX
VBUSFACT
VBUSLIM
VBUSMAX
VBUSMIN
VBUSOFFS
VBUSRAMP
VBW
VCMD
VCOMM
VCTIME
VEL0
VER
VINPOS
VJOG
VLIM
VLIMN
VLIMP
VLO
VLO_X
VMIX
VMUL
VOHPD
VOHPF
VOLPD
VOMODE
VOMOPDE
VOSPD
VOSPDREF
VOUTMAX
VREF
VREF0
VSCALE1
VSCALE2
VSTART
VSTFR
VTIMEKD
VTUNE
VUNIT
VWM
WMASK
WPOS
WPOSE
WPOSP
WPOSX
WSAMPL
WSCNFG
WSLOOP
WSRED
WSTIME
WSTIME2
WSTIME3
ZERO
ZEROTIME


ASCII Deutsch Index Gruppe

MAXCMD |
ANIN3 | Analoge I/O
VSCALE1 | Analoge I/O
VSCALE2 | Analoge I/O
ISCALE2 | Analoge I/O
AN11NR | Analoge I/O
AN11RANGE | Analoge I/O
ANCNFG | Analoge I/O
ADC0_15 | Analoge I/O
ANZERO4 | Analoge I/O
ANZERO3 | Analoge I/O
ANOFF4 | Analoge I/O
ANZERO2 | Analoge I/O
ANIN4 | Analoge I/O
DAOFFSET2 | Analoge I/O
MONITOR2 | Analoge I/O
MONITOR1 | Analoge I/O
DAOFFSET1 | Analoge I/O
ANOUT2 | Analoge I/O
ANOUT1 | Analoge I/O
AN2TRIG | Analoge I/O
AN1TRIG | Analoge I/O
IN | Analoge I/O
ISCALE1 | Analoge I/O
ANOFF3 | Analoge I/O
ANZERO1 | Analoge I/O
ANOFF2 | Analoge I/O
ANOFF1 | Analoge I/O
ANIN1 | Analoge I/O
ANDB | Analoge I/O
ANIN2 | Analoge I/O
LED2 | Anzeige
KEYLOCK | Anzeige
LED1 | Anzeige
LEDSTAT | Anzeige
LED3 | Anzeige
O6TRIG | Digitale I/O
EXTLATCH | Digitale I/O
O9TRIG | Digitale I/O
O7TRIG | Digitale I/O
IN17 | Digitale I/O
IOLINK | Digitale I/O
O5TRIG | Digitale I/O
O4TRIG | Digitale I/O
O3TRIG | Digitale I/O
IN16 | Digitale I/O
O3_18MODE | Digitale I/O
IN20LCMD | Digitale I/O
IN13 | Digitale I/O
LATCH2P32 | Digitale I/O
ACCUNIT | Digitale I/O
O12TRIG | Digitale I/O
O11TRIG | Digitale I/O
IN2PM | Digitale I/O
IN11MODE | Digitale I/O
O18TRIG | Digitale I/O
LATCH1N16 | Digitale I/O
O8MODE | Digitale I/O
LATCH2N16 | Digitale I/O
LATCH2P16 | Digitale I/O
SOFTOUT | Digitale I/O
O10TRIG | Digitale I/O
IN19LCMD | Digitale I/O
IN11 | Digitale I/O
O8TRIG | Digitale I/O
O1 | Digitale I/O
O9 | Digitale I/O
BTIME | Digitale I/O
O9MODE | Digitale I/O
IN8 | Digitale I/O
IN10MODE | Digitale I/O
IN1MODE | Digitale I/O
O10MODE | Digitale I/O
IN15 | Digitale I/O
DIRIN | Digitale I/O
O13MODE | Digitale I/O
PUNIT | Digitale I/O
O1MODE | Digitale I/O
IN3TRIG | Digitale I/O
O2TRIG | Digitale I/O
IN2TRIG | Digitale I/O
O18 | Digitale I/O
IN20MODE | Digitale I/O
O14MODE | Digitale I/O
IN2 | Digitale I/O
IN4 | Digitale I/O
IN3 | Digitale I/O
IN20TRIG | Digitale I/O
IN19MODE | Digitale I/O
IN18TRIG | Digitale I/O
IN3MODE | Digitale I/O
O4MODE | Digitale I/O
IN20 | Digitale I/O
O16MODE | Digitale I/O
O15 | Digitale I/O
DIROUT | Digitale I/O
O15MODE | Digitale I/O
O5MODE | Digitale I/O
SLOTIO | Digitale I/O
IN14 | Digitale I/O
IN19 | Digitale I/O
SOFTIN | Digitale I/O
O3MODE | Digitale I/O
IN21MODE | Digitale I/O
IN21TRIG | Digitale I/O
O3_18 | Digitale I/O
IN22MODE | Digitale I/O
IN22TRIG | Digitale I/O
O3 | Digitale I/O
O12MODE | Digitale I/O
O11MODE | Digitale I/O
IN15MODE | Digitale I/O
IN4HCMD | Digitale I/O
IN4LCMD | Digitale I/O
IN19TRIG | Digitale I/O
IN9MODE | Digitale I/O
O17MODE | Digitale I/O
O17TRIG | Digitale I/O
O18MODE | Digitale I/O
O16 | Digitale I/O
IN16MODE | Digitale I/O
LATCH1N32 | Digitale I/O
O1TRIG | Digitale I/O
O2 | Digitale I/O
O2MODE | Digitale I/O
IN4TRIG | Digitale I/O
IN5 | Digitale I/O
IN5_22 | Digitale I/O
O17 | Digitale I/O
IN14MODE | Digitale I/O
IN2LCMD | Digitale I/O
IN1HCMD | Digitale I/O
LATCH2N32 | Digitale I/O
LATCH1P32 | Digitale I/O
IN7 | Digitale I/O
IN9TRIG | Digitale I/O
LATCH1P16 | Digitale I/O
IN6 | Digitale I/O
IN5_22TRIG | Digitale I/O
VUNIT | Digitale I/O
IN17MODE | Digitale I/O
O6MODE | Digitale I/O
IN18 | Digitale I/O
IN1LCMD | Digitale I/O
IN2HCMD | Digitale I/O
IN2MODE | Digitale I/O
IN3HCMD | Digitale I/O
IN3LCMD | Digitale I/O
O7MODE | Digitale I/O
IN18MODE | Digitale I/O
IN10 | Digitale I/O
IN1TRIG | Digitale I/O
O3_18TRIG | Digitale I/O
IN13MODE | Digitale I/O
O13 | Digitale I/O
IN9 | Digitale I/O
IN7MODE | Digitale I/O
IN8MODE | Digitale I/O
O13TRIG | Digitale I/O
O14TRIG | Digitale I/O
O12 | Digitale I/O
O16TRIG | Digitale I/O
IN19HCMD | Digitale I/O
O4 | Digitale I/O
O5 | Digitale I/O
O6 | Digitale I/O
O7 | Digitale I/O
O8 | Digitale I/O
IN12MODE | Digitale I/O
O10 | Digitale I/O
O11 | Digitale I/O
O15TRIG | Digitale I/O
IN12TRIG | Digitale I/O
IN20HCMD | Digitale I/O
IN5_22MODE | Digitale I/O
IN5TRIG | Digitale I/O
IN6TRIG | Digitale I/O
IN7TRIG | Digitale I/O
IN8TRIG | Digitale I/O
IN1 | Digitale I/O
IN5MODE | Digitale I/O
IN11TRIG | Digitale I/O
IN4MODE | Digitale I/O
IN13TRIG | Digitale I/O
IN14TRIG | Digitale I/O
IN15TRIG | Digitale I/O
IN12 | Digitale I/O
IN16TRIG | Digitale I/O
O14 | Digitale I/O
IN17TRIG | Digitale I/O
IN6MODE | Digitale I/O
IN10TRIG | Digitale I/O
VTUNE | Drehzahlregler
DEC_X | Drehzahlregler
DECSTOP | Drehzahlregler
VCTIME | Drehzahlregler
ACC | Drehzahlregler
ACC_X | Drehzahlregler
GVS2 | Drehzahlregler
VEL0 | Drehzahlregler
VLIM | Drehzahlregler
VLIMN | Drehzahlregler
SLTSWITCH | Drehzahlregler
DECDIS | Drehzahlregler
GV | Drehzahlregler
GVS1 | Drehzahlregler
GVFR | Drehzahlregler
J | Drehzahlregler
VCMD | Drehzahlregler
DEC | Drehzahlregler
VCOMM | Drehzahlregler
VINPOS | Drehzahlregler
GVTN | Drehzahlregler
GV2 | Drehzahlregler
GV_X | Drehzahlregler
VLIMP | Drehzahlregler
GVTN_X | Drehzahlregler
EMRGTO | Drehzahlregler
GVFR_X | Drehzahlregler
STEP | Drehzahlregler
ENCOUT | Encoder Emulation
ENCZERO | Encoder Emulation
ENCMODE | Encoder Emulation
ROFFSABS | Feedback
SSIRXD | Feedback
RESPHASE | Feedback
EXTPOS | Feedback
VWM | Feedback
BISSREVOL | Feedback
ENCIN | Feedback
EGEARO | Feedback
TESTENC | Feedback
SMNUMBER | Feedback
HICOFFS | Feedback
VLO | Feedback
ROFFSSSI | Feedback
CALCHP | Feedback
EGEARI | Feedback
HALLDIR | Feedback
MRESBW | Feedback
HIFACT1 | Feedback
RK | Feedback
ENCFIXD | Feedback
ENCFIX | Feedback
EN22A1CNT | Feedback
LINRESOL | Feedback
RESOLVER | Feedback
BUILDRK | Feedback
RESAMPL | Feedback
EN22CNFG | Feedback
SSIMASK | Feedback
EN22A2CNT | Feedback
ENCDIVD | Feedback
SSITIME | Feedback
FBTYPEX | Feedback
ZERO | Feedback
FBGEARO | Feedback
FBGEARI | Feedback
ENCDIV | Feedback
ZEROTIME | Feedback
HDSLTEMP | Feedback
HISOFFS | Feedback
FBTYPE | Feedback
PSINUS | Feedback
VMIX | Feedback
HDSLVOLT | Feedback
HDSLVEL | Feedback
EN22AI1 | Feedback
HDSLTIME | Feedback
VLO_X | Feedback
HDSLROTAT | Feedback
HDSLRANGE | Feedback
HDSLPOS | Feedback
HDSLLED | Feedback
EN22DIAG | Feedback
EN22DCNT | Feedback
EN22AI2 | Feedback
HDSLTYPE | Feedback
SSIREVOL | Feedback
ENCLINES | Feedback
SSITOUT | Feedback
MPHASE2 | Feedback
SSIRESOL | Feedback
MRESPOLES | Feedback
MPHASE | Feedback
BISSCNFG | Feedback
SSIGRAY | Feedback
SSIINV | Feedback
RSVERROFF | Feedback
BUSP15 | Feldbus
BUSP14 | Feldbus
BUSP13 | Feldbus
BUSP12 | Feldbus
BUSP11 | Feldbus
BUSP10 | Feldbus
PLLHUB | Feldbus
BUSP9 | Feldbus
BUSP7 | Feldbus
DUMPEMAP | Feldbus
SBAUD | Feldbus
VMUL | Feldbus
ECATCSA | Feldbus
BUSP16 | Feldbus
SETENCOFFS | Feldbus
BUSP8 | Feldbus
ETHMODE | Feldbus
SERCSET | Feldbus
PLLDOFFS | Feldbus
MBPDRVSTAT | Feldbus
PIOBUF | Feldbus
PLLWOFFS | Feldbus
SERCLIST | Feldbus
SSTAT | Feldbus
SCAN | Feldbus
SLEN | Feldbus
PLLCOFFS | Feldbus
BUSP0 | Feldbus
PPOTYP | Feldbus
IDDUMP | Feldbus
SPHAS | Feldbus
BUSP3 | Feldbus
SERCERR | Feldbus
SERCOS | Feldbus
BUSP2 | Feldbus
BUSP4 | Feldbus
DNDUMP | Feldbus
PNOID | Feldbus
EXTWD | Feldbus
BUSP1 | Feldbus
CBAUD | Feldbus
BUSP6 | Feldbus
DNBAUD | Feldbus
PBAUD | Feldbus
DNMACID | Feldbus
BUSP5 | Feldbus
CANSDO | Feldbus
PSTATE | Feldbus
SYNCSRC | Feldbus
CANDUMP | Feldbus
ARLPD | Filter
ARHPD | Filter
ARHPF | Filter
FILTMODE | Filter
AVZ2 | Filter
ARLP2 | Filter
VOHPF | Filter
VOLPD | Filter
VOHPD | Filter
BQMODE | Filter
ARLPF | Filter
AVZ1 | Filter
RUNIN | intern
SERCOFFS | intern
WSRED | intern
FHKP | intern
TEN | intern
NREFG | intern
TEST1 | intern
PRIOR2 | intern
PRIOR3 | intern
PRIOR4 | intern
PRIOR5 | intern
SLIMAX | intern
VOMODE | intern
VOMOPDE | intern
QVAL | intern
PRIOR1 | intern
BUILDRP | intern
GPFFVDELAY | intern
MIMRQ | intern
ANHFACT2 | intern
FHTN | intern
HALLENDIR | intern
HWCNT | intern
MCTR | intern
JRATIO | intern
MAXSUMME | intern
MINSUMME | intern
IVTICK | intern
ANHFACT1 | intern
V | Istwerte
P | Istwerte
ACTIVE | Istwerte
DRVSTAT2 | Istwerte
PFB | Istwerte
TRJSTAT | Istwerte
PFBHI | Istwerte
IQ | Istwerte
ERRCODE * | Istwerte
ID | Istwerte
PRD | Istwerte
EWH | Istwerte
ERRCODE | Istwerte
VBUS | Istwerte
PFBLO | Istwerte
READY | Istwerte
PV | Istwerte
DRVSTAT | Istwerte
REMOTE | Istwerte
I | Istwerte
PBAL | Istwerte
STATUS | Istwerte
STATIO | Istwerte
STATCODE * | Istwerte
STATCODE | Istwerte
STAT | Istwerte
DI2T | Istwerte
CLRHR | Istwerte
DICONT | Istwerte
PMECH | Istwerte
DIPEAK | Istwerte
PFB0 | Istwerte
DISDPR | Kommandos
MJOG | Kommandos
OPMODE | Kommandos
MH | Kommandos
DIS | Kommandos
MOVE | Kommandos
STOP | Kommandos
S | Kommandos
CONTINUE | Kommandos
EN | Kommandos
COLDSTART | Kommandos
CLRFAULT | Kommandos
K | Kommandos
ERND | Konfiguration
CLRWARN | Konfiguration
WMASK | Konfiguration
\ | Konfiguration
CALCRK | Konfiguration
DRVCNFG | Konfiguration
LOAD | Konfiguration
HELP | Konfiguration
LASTWMASK | Konfiguration
OPTION | Konfiguration
HDUMP | Konfiguration
BCC | Konfiguration
VER | Konfiguration
PASSXPLC | Konfiguration
LIST | Konfiguration
M | Konfiguration
M_RESET | Konfiguration
S1DLY | Konfiguration
DRVCNFG4 | Konfiguration
FLTCNT * | Konfiguration
ERRMASK | Konfiguration
FLTHIST * | Konfiguration
PASSPLC | Konfiguration
PBALMAX | Konfiguration
RELTIME | Konfiguration
ALIAS | Konfiguration
DRVCNFG3 | Konfiguration
VBUSLIM | Konfiguration
PASSCNFG | Konfiguration
MPITCH | Konfiguration
ENGAGE | Konfiguration
MSG | Konfiguration
VBUSBAL | Konfiguration
PASS | Konfiguration
PASSX | Konfiguration
CALCPOSIO | Konfiguration
VBUSFACT | Konfiguration
DIFVAR | Konfiguration
DUMP | Konfiguration
CTUNE | Konfiguration
CUPDATE | Konfiguration
HSAVE | Konfiguration
HVER | Konfiguration
FLTCNT | Konfiguration
FLTHIST | Konfiguration
VBUSCNTMAX | Konfiguration
MDRV | Konfiguration
DR_TYPE | Konfiguration
CPHASE | Konfiguration
VBUSRAMP | Konfiguration
LDUMP | Konfiguration
VBUSOFFS | Konfiguration
VBUSBOFFS | Konfiguration
OPTION2 | Konfiguration
UID | Konfiguration
ACTFAULT | Konfiguration
ADDR | Konfiguration
AENA | Konfiguration
NONBTB | Konfiguration
STOPMODE | Konfiguration
VBUSMIN | Konfiguration
SDLY | Konfiguration
STAGECODE | Konfiguration
PBALRES | Konfiguration
MVER | Konfiguration
TASK | Konfiguration
TRUN | Konfiguration
TRUNS | Konfiguration
UPDATE | Konfiguration
ERRPARAM | Konfiguration
PARCNFG | Konfiguration
VBUSMAX | Konfiguration
CCSAVE | Konfiguration
VBW | Konfiguration
OTUNE | Konfiguration
RSTVAR | Konfiguration
DRVCNFG2 | Konfiguration
SRND | Konfiguration
SAVE | Konfiguration
CALCRP | Konfiguration
SERIALNO | Konfiguration
DRIVE | Konfiguration
UVLTMODE | Konfiguration
PARRST | Konfiguration
DPWM | Konfiguration
POSCNFG | Konfiguration
CALCMP | Konfiguration
PARDUMP | Konfiguration
PMODE | Konfiguration
CALCCOG | Konfiguration
BCCOT | Konfiguration
DIR | Konfiguration
NREFMT | Lageregler
CLRORDER | Lageregler
O_ACC | Lageregler
NREF | Lageregler
VOSPD | Lageregler
SWE1 | Lageregler
VJOG | Lageregler
POSRSTAT | Lageregler
O_DEC | Lageregler
O_FN | Lageregler
P8 | Lageregler
P9 | Lageregler
PE | Lageregler
DREF | Lageregler
OLIST | Lageregler
DECR | Lageregler
GEARI | Lageregler
MTMUX | Lageregler
PVMAXN | Lageregler
PVMAXP | Lageregler
PTBASE | Lageregler
REFIP2 | Lageregler
REFLS | Lageregler
REFMODE | Lageregler
ROFFS | Lageregler
PGEARI | Lageregler
PTMIN | Lageregler
PEINPOS | Lageregler
PTARGOFFS | Lageregler
ACCR | Lageregler
GPFFT | Lageregler
GP | Lageregler
GEARO | Lageregler
GEARMODE | Lageregler
O_P | Lageregler
SWCNFG | Lageregler
PVMAX | Lageregler
P13 | Lageregler
PEMAX | Lageregler
P1_P16 | Lageregler
P1 | Lageregler
OVRIDE | Lageregler
P4 | Lageregler
P2 | Lageregler
P16 | Lageregler
P11 | Lageregler
P14 | Lageregler
VREF | Lageregler
P12 | Lageregler
O_TAB | Lageregler
WPOSE | Lageregler
PRBASE | Lageregler
GPFFV | Lageregler
OCOPY | Lageregler
WPOS | Lageregler
PTARGET | Lageregler
P15 | Lageregler
GPS1 | Lageregler
VOSPDREF | Lageregler
GPFFTV | Lageregler
HLIMIT1 | Lageregler
REFNPOS | Lageregler
REFNOFFS | Lageregler
HLIMIT2 | Lageregler
HLIMIT3 | Lageregler
P10 | Lageregler
GPS2 | Lageregler
P3 | Lageregler
GP2 | Lageregler
GPFFV_X | Lageregler
GPFFT_X | Lageregler
GP_X | Lageregler
WPOSX | Lageregler
UCOMP | Lageregler
REFPOS | Lageregler
WPOSP | Lageregler
INTERPOL | Lageregler
P7 | Lageregler
ORDER | Lageregler
GPTN_X | Lageregler
SWE2 | Lageregler
GPTN | Lageregler
INPT0 | Lageregler
INPT1 | Lageregler
AUTOHOME | Lageregler
GPDELAY | Lageregler
P6 | Lageregler
GEARFILT | Lageregler
GPTNTH2 | Lageregler
P5 | Lageregler
GPTNTH3 | Lageregler
GPTNTH1 | Lageregler
PGEARO | Lageregler
VREF0 | Lageregler
MAXISETP | Lageregler
O_C | Lageregler
SETREF | Lageregler
REFIP | Lageregler
INPOS | Lageregler
O_V | Lageregler
O_FT | Lageregler
MAXVSETP | Lageregler
ML | Motor
MTYPE | Motor
MKT_X | Motor
MJ_X | Motor
MIPEAK_X | Motor
MICONT_X | Motor
ML_X | Motor
MTAB | Motor
MTIME | Motor
COGMODE | Motor
COGFILT | Motor
MPOLES_X | Motor
MKT | Motor
TBRAKE | Motor
MTIME_X | Motor
MSPEED | Motor
MNAME | Motor
COGRED | Motor
MDBSET | Motor
MNUMBER | Motor
MDBGET | Motor
MBRAKE | Motor
MICONT | Motor
MDBLIST | Motor
MDBCNT | Motor
EXTBRAKE | Motor
MI2T | Motor
TBRAKE0 | Motor
MIPEAK | Motor
MPOLES | Motor
MJ | Motor
RECOFF | Oszilloskop
RECRDY | Oszilloskop
RECORD | Oszilloskop
RECDONE | Oszilloskop
RECTRIG | Oszilloskop
GET | Oszilloskop
RECING | Oszilloskop
PROMPT | RS232
RS232T | RS232
ACTRS232 | RS232
CMDDLY | RS232
CSIOSTAT | Safety
CSENID | Safety
CSCNFG | Safety
CSIDMAX | Safety
CSSTAT | Safety
CSERR | Safety
CARDDEL | SD-Card
CARDDIR | SD-Card
CARDSAVE | SD-Card
CARDINFO | SD-Card
CARDUPDATE | SD-Card
SLMODE | Sensorless
SLIQK | Sensorless
SLIDK01 | Sensorless
SLJSWITCH | Sensorless
VOUTMAX | Sensorless
SLIQK1 | Sensorless
SLACCMAX | Sensorless
QFACTOR | Servopumpe
QTIMEKD | Servopumpe
QTAB2TV | Servopumpe
QTABID | Servopumpe
QFCMD | Servopumpe
QTAB2KP | Servopumpe
QPRMAX | Servopumpe
QTAB4KP | Servopumpe
QTAB5KP | Servopumpe
QTAB1TN | Servopumpe
QTAB2TN | Servopumpe
QTAB3TN | Servopumpe
QTAB4TN | Servopumpe
QTVEFF | Servopumpe
QTAB1TV | Servopumpe
QTAB1KP | Servopumpe
QTAB3TV | Servopumpe
QTAB4TV | Servopumpe
QTAB5TV | Servopumpe
QTAB1V | Servopumpe
QTAB2V | Servopumpe
QTAB3V | Servopumpe
QTAB4V | Servopumpe
QTAB5V | Servopumpe
GVTV | Servopumpe
VTIMEKD | Servopumpe
QTAB5TN | Servopumpe
QT1 | Servopumpe
QFACTFILT | Servopumpe
QFACT | Servopumpe
QFACTCOMP | Servopumpe
QPRSET | Servopumpe
QPRACT | Servopumpe
QENA | Servopumpe
QTAB3KP | Servopumpe
QVT1 | Servopumpe
QTNEFF | Servopumpe
QMCMDLIM | Servopumpe
QMACT | Servopumpe
QMLIMP | Servopumpe
QMLIMN | Servopumpe
QCNFG | Servopumpe
QFSET | Servopumpe
QFCFACT | Servopumpe
QFCMDFILT | Servopumpe
QFMAX | Servopumpe
QKPEFF | Servopumpe
QPE | Servopumpe
QPRSETEFF | Servopumpe
QMCMD | Servopumpe
RDPBIAS2 | Sonstige
RDPBIAS | Sonstige
DPV17_64 | Sonstige
RDPCLAMP | Sonstige
RDPINT | Sonstige
RDPKP | Sonstige
RDPON | Sonstige
GF | Sonstige
ISTFR | Sonstige
RDPKI | Sonstige
DUMPSLNO | Sonstige
SKIP1W | Sonstige
SKIP1SP | Sonstige
IQFILTTAU | Sonstige
IQFILTK | Sonstige
VSTART | Sonstige
MCOSPHI | Sonstige
MUR | Sonstige
MFR | Sonstige
IEXTT | Sonstige
RDP | Sonstige
ERRTIME | Sonstige
MVANGLB | Sonstige
PSTEP | Sonstige
SKIP2SP | Sonstige
DOVRIDE | Sonstige
DENA | Sonstige
DILIM | Sonstige
VSTFR | Sonstige
FW | Sonstige
ESPEED | Sonstige
ERRCODE2 | Sonstige
MRS | Sonstige
MRS_X | Sonstige
DPRILIMIT | Sonstige
MVANGLF | Sonstige
GFTN | Sonstige
ERRCNFG | Sonstige
ENCVON | Sonstige
FFTSW | Sonstige
MTANGLP | Sonstige
GU | Sonstige
MIMR | Sonstige
ENCTO | Sonstige
SKIP2W | Sonstige
UMAX | Sonstige
MCFW | Sonstige
GUTN | Sonstige
DPRSTATE | Sonstige
MSERIALNO | Sonstige
ASMWAIT | Sonstige
MPR | Sonstige
DPRVAR1_16 | Sonstige
MVR | Sonstige
MTR | Sonstige
MVANGLMODE | Sonstige
MVANGLP | Sonstige
ERESMASK | Sonstige
IEXTTLIM | Stromregler
MSLBRAKE | Stromregler
KTN | Stromregler
IPEAK | Stromregler
T | Stromregler
KC_X | Stromregler
KTN_X | Stromregler
MLGC_X | Stromregler
MLGD_X | Stromregler
CINPOS | Stromregler
MLGQ_X | Stromregler
ICMD | Stromregler
TSTEP | Stromregler
IPEAKP | Stromregler
I2TLIM | Stromregler
KC | Stromregler
MLGC | Stromregler
IPEAKN | Stromregler
MLGD | Stromregler
MLGP | Stromregler
MLGP_X | Stromregler
MLGQ | Stromregler
ICMDVLIM | Stromregler
MAXTEMPH | Temperaturen
MAXTEMPM | Temperaturen
SLTEMPM | Temperaturen
TEMPM | Temperaturen
TEMPH | Temperaturen
TEMPE | Temperaturen
MAXTEMPE | Temperaturen
TEMPMFILT | Temperaturen
WSTIME3 | Wake&Shake
MPKP | Wake&Shake
MPTIME | Wake&Shake
MPKI | Wake&Shake
WSTIME | Wake&Shake
WSCNFG | Wake&Shake
WSTIME2 | Wake&Shake
WSAMPL | Wake&Shake
WSLOOP | Wake&Shake
MPKD | Wake&Shake


ASCII Deutsch Index Objekt

OTUNE | Object
SLJSWITCH | Object
SLTSWITCH | Object
BTIME | Object
RESAMPL | Object
LIST | Object
M | Object
P1_P16 | Object
ERRCODE | Object
SERCOFFS | Object
FLTHIST * | Object
ALIAS | Object
DUMPEMAP | Object
SLTEMPM | Object
MDBLIST | Object
ORDER | Object
CANSDO | Object
CCSAVE | Object
CANDUMP | Object
O3_18TRIG | Object
IN19HCMD | Object
FLTCNT * | Object
ANHFACT2 | Object
RDPBIAS2 | Object
NREFG | Object
MIMRQ | Object
MCTR | Object
MINSUMME | Object
MAXSUMME | Object
IVTICK | Object
HWCNT | Object
HALLENDIR | Object
PLLDOFFS | Object
FHKP | Object
MNAME | Object
ANHFACT1 | Object
DPV17_64 | Object
MTAB | Object
CARDUPDATE | Object
CARDSAVE | Object
CARDDEL | Object
CARDDIR | Object
CARDINFO | Object
IN5_22 | Object
FHTN | Object
HELP | Object
IN5_22MODE | Object
STEP | Object
TSTEP | Object
CALCCOG | Object
IN | Object
IN5_22TRIG | Object
IN19LCMD | Object
IN20LCMD | Object
COGRED | Object
GU | Object
O3_18MODE | Object
GUTN | Object
HDUMP | Object
OLIST | Object
VER | Object
DNDUMP | Object
VOHPF | Object
MPR | Object
VOHPD | Object
VOLPD | Object
VOSPDREF | Object
O3_18 | Object
SERCLIST | Object
PLLWOFFS | Object
RECORD | Object
IN2LCMD | Object
IDDUMP | Object
PLLCOFFS | Object
PARDUMP | Object
PARRST | Object
ADC0_15 | Object
DPRVAR1_16 | Object
UMAX | Object
ECATCSA | Object
IN20HCMD | Object
PSTEP | Object
RECTRIG | Object
SERCERR | Object
SERCOS | Object
TRUN | Object
UPDATE | Object
VBW | Object
VTUNE | Object
DPRSTATE | Object
SLMODE | Object
STATCODE * | Object
HDSLTYPE | Object
DIFVAR | Object
DUMP | Object
EN22AI2 | Object
IN3HCMD | Object
IN2HCMD | Object
IN4LCMD | Object
LDUMP | Object
IN1LCMD | Object
SETENCOFFS | Object
SLIMAX | Object
EN22DIAG | Object
STATUS | Object
IN1HCMD | Object
HDSLPOS | Object
HDSLRANGE | Object
J | Object
CTUNE | Object
PSINUS | Object
SLACCMAX | Object
TESTENC | Object
GF | Object
IN4HCMD | Object
SLIQK | Object
SLIDK01 | Object
VOUTMAX | Object
SLIQK1 | Object
EN22AI1 | Object
TEN | Object
TEST1 | Object
VOMODE | Object
VOMOPDE | Object
QVAL | Object
FLTCNT | Object
IN3LCMD | Object
FLTHIST | Object
ACC | Object 1
ACCR | Object 2
ACTFAULT | Object 3
ACTIVE | Object 4
ADDR | Object 5
AENA | Object 6
ANCNFG | Object 7
ANDB | Object 8
ANIN1 | Object 9
ANIN2 | Object 10
ANOFF1 | Object 11
ANOFF2 | Object 12
EGEARI | Object 13
EGEARO | Object 14
ANZERO1 | Object 15
ANZERO2 | Object 16
AVZ1 | Object 17
CALCHP | Object 18
CALCRK | Object 19
CALCRP | Object 20
CBAUD | Object 21
PRIOR3 | Object 22
PRIOR4 | Object 23
CLRFAULT | Object 24
CLRHR | Object 25
CLRORDER | Object 26
CLRWARN | Object 27
PRIOR5 | Object 28
CONTINUE | Object 29
MPITCH | Object 30
CUPDATE | Object 31
RESOLVER | Object 32
INPT1 | Object 33
DEC | Object 34
DECDIS | Object 35
DECR | Object 36
DECSTOP | Object 37
DICONT | Object 39
DIPEAK | Object 41
DIR | Object 42
DIS | Object 43
DREF | Object 44
DRVSTAT | Object 45
DR_TYPE | Object 46
EN | Object 48
JRATIO | Object 49
ENCIN | Object 50
ENCLINES | Object 51
ENCMODE | Object 52
ENCOUT | Object 53
MPHASE2 | Object 54
ENCZERO | Object 55
MAXCMD | Object 56
EXTPOS | Object 57
EXTWD | Object 58
FBTYPE | Object 59
FILTMODE | Object 60
GEARI | Object 62
GEARMODE | Object 63
GEARO | Object 64
GET | Object 65
GP | Object 66
ENCTO | Object 67
GPFFT | Object 68
GPFFV | Object 69
ENCVON | Object 70
GV | Object 72
GVFR | Object 75
GVTN | Object 77
SOFTIN | Object 78
SOFTOUT | Object 79
HALLDIR | Object 80
HICOFFS | Object 82
HIFACT1 | Object 83
HISOFFS | Object 84
HSAVE | Object 86
HVER | Object 87
I | Object 88
DI2T | Object 89
I2TLIM | Object 90
ICMD | Object 91
ID | Object 93
ERRMASK | Object 94
ERRTIME | Object 95
IN1 | Object 97
IN1MODE | Object 98
IN1TRIG | Object 99
IN2 | Object 100
IN2MODE | Object 101
IN2TRIG | Object 102
IN3 | Object 103
IN3MODE | Object 104
IN3TRIG | Object 105
IN4 | Object 106
IN4MODE | Object 107
IN4TRIG | Object 108
INPOS | Object 109
IPEAK | Object 110
IPEAKN | Object 111
IQ | Object 112
ISCALE1 | Object 113
ISCALE2 | Object 114
K | Object 115
KC | Object 116
KEYLOCK | Object 117
ML | Object 119
LATCH2P16 | Object 120
LATCH2N16 | Object 121
LATCH2P32 | Object 122
LATCH2N32 | Object 123
LATCH1P32 | Object 124
LATCH1N32 | Object 125
LED1 | Object 126
LED2 | Object 127
LED3 | Object 128
LEDSTAT | Object 129
LOAD | Object 131
MAXTEMPE | Object 132
MAXTEMPH | Object 133
MAXTEMPM | Object 134
MBRAKE | Object 135
MDBCNT | Object 136
MDBGET | Object 137
MDBSET | Object 138
CPHASE | Object 139
VLIM | Object 140
MH | Object 141
MICONT | Object 142
MIPEAK | Object 143
MJOG | Object 145
MVANGLP | Object 146
MKT | Object 147
IPEAKP | Object 148
MLGC | Object 149
MLGD | Object 150
MLGP | Object 151
MLGQ | Object 152
MNUMBER | Object 153
MONITOR1 | Object 154
MONITOR2 | Object 155
MPHASE | Object 156
MPOLES | Object 157
MRESBW | Object 160
MRESPOLES | Object 161
MSG | Object 162
MSPEED | Object 163
MI2T | Object 164
MTANGLP | Object 165
MTYPE | Object 166
MVANGLB | Object 167
MVANGLF | Object 168
M_RESET | Object 169
NONBTB | Object 170
MJ | Object 171
MTIME | Object 172
NREF | Object 173
O1 | Object 174
O1MODE | Object 175
O1TRIG | Object 176
O2 | Object 177
O2TRIG | Object 179
OPMODE | Object 180
OPTION2 | Object 181
OPTION | Object 181
OVRIDE | Object 182
O_ACC | Object 183
O_TAB | Object 184
O_C | Object 185
O_DEC | Object 186
O_FN | Object 188
O_FT | Object 189
O_P | Object 190
O_V | Object 191
PBAL | Object 192
PBALMAX | Object 193
PBALRES | Object 194
PBAUD | Object 195
PE | Object 197
PEINPOS | Object 198
PEMAX | Object 199
PFB | Object 200
PFB0 | Object 201
PGEARI | Object 202
PGEARO | Object 203
PIOBUF | Object 204
PMODE | Object 205
PNOID | Object 206
POSCNFG | Object 207
PPOTYP | Object 208
PRBASE | Object 209
PRD | Object 210
PROMPT | Object 211
PSTATE | Object 212
PTBASE | Object 213
PTMIN | Object 214
PV | Object 215
PVMAX | Object 216
PVMAXN | Object 217
PVMAXP | Object 219
READY | Object 221
RECDONE | Object 222
RECING | Object 223
RECOFF | Object 224
RECRDY | Object 225
REFIP | Object 226
REFPOS | Object 227
REMOTE | Object 228
RESPHASE | Object 229
RK | Object 230
ROFFS | Object 231
RS232T | Object 232
RSTVAR | Object 233
S | Object 234
SAVE | Object 235
SBAUD | Object 236
SCAN | Object 237
VBUSCNTMAX | Object 238
SERIALNO | Object 239
SETREF | Object 240
SLEN | Object 242
SLOTIO | Object 243
SPHAS | Object 244
VBUSLIM | Object 245
SSIGRAY | Object 246
SSIINV | Object 247
SSTAT | Object 250
DUMPSLNO | Object 250
STAT | Object 251
STATIO | Object 252
STOP | Object 254
STOPMODE | Object 255
SWCNFG | Object 256
SWE1 | Object 260
SWE2 | Object 262
ARHPD | Object 263
ARHPF | Object 264
ARLP2 | Object 265
ARLPD | Object 266
ARLPF | Object 267
PRIOR1 | Object 268
PRIOR2 | Object 269
T | Object 270
TASK | Object 271
TEMPE | Object 272
TEMPH | Object 273
TEMPM | Object 274
TRJSTAT | Object 275
TRUNS | Object 276
UID | Object 278
UVLTMODE | Object 279
V | Object 280
SSIREVOL | Object 281
VBUS | Object 282
VBUSBAL | Object 283
VBUSMAX | Object 284
VBUSMIN | Object 285
VCMD | Object 286
VEL0 | Object 288
VJOG | Object 289
VLIMP | Object 290
VLIMN | Object 291
VMIX | Object 293
VMUL | Object 294
VOSPD | Object 295
VREF | Object 296
VSCALE1 | Object 297
VSCALE2 | Object 298
\ | Object 299
DILIM | Object 300
DENA | Object 301
IN2PM | Object 302
KTN | Object 303
INPT0 | Object 304
UCOMP | Object 305
COLDSTART | Object 306
WPOS | Object 310
SRND | Object 311
ERND | Object 312
MDRV | Object 313
BCC | Object 314
REFMODE | Object 316
VLO | Object 317
WMASK | Object 318
WPOSE | Object 319
WPOSP | Object 320
WPOSX | Object 321
MOVE | Object 322
POSRSTAT | Object 323
P1 | Object 324
P2 | Object 325
P3 | Object 326
P4 | Object 327
P5 | Object 328
P6 | Object 329
P7 | Object 330
P8 | Object 331
P9 | Object 332
P10 | Object 333
P11 | Object 334
P12 | Object 335
P13 | Object 336
P14 | Object 337
P15 | Object 338
P16 | Object 339
PTARGET | Object 340
ACTRS232 | Object 341
ROFFSABS | Object 342
FW | Object 343
DPRILIMIT | Object 344
ACCUNIT | Object 345
VCOMM | Object 346
MTMUX | Object 347
REFLS | Object 349
SSIRXD | Object 350
VUNIT | Object 351
PUNIT | Object 352
SSITOUT | Object 353
BQMODE | Object 358
MIMR | Object 363
MTR | Object 364
MVR | Object 365
TBRAKE | Object 366
TBRAKE0 | Object 367
CMDDLY | Object 368
MSLBRAKE | Object 369
DRVCNFG | Object 370
DISDPR | Object 371
ESPEED | Object 373
DPWM | Object 374
DRIVE | Object 375
LATCH1P16 | Object 383
LATCH1N16 | Object 384
EXTLATCH | Object 385
STAGECODE | Object 386
SYNCSRC | Object 387
INTERPOL | Object 388
ICMDVLIM | Object 389
MRS | Object 390
MBPDRVSTAT | Object 397
SERCSET | Object 401
SMNUMBER | Object 405
VREF0 | Object 408
AN11NR | Object 409
AN11RANGE | Object 410
FBTYPEX | Object 411
DNBAUD | Object 415
DNMACID | Object 416
MSERIALNO | Object 419
ISTFR | Object 420
VSTFR | Object 421
DOVRIDE | Object 438
RDP | Object 439
RDPBIAS | Object 440
RDPCLAMP | Object 441
RDPINT | Object 442
RDPKI | Object 443
RDPKP | Object 444
RDPON | Object 445
GPTNTH3 | Object 460
ENGAGE | Object 461
LASTWMASK | Object 462
COGMODE | Object 463
WSTIME | Object 464
WSAMPL | Object 465
NREFMT | Object 466
COGFILT | Object 467
PASSX | Object 468
PASS | Object 469
GEARFILT | Object 470
AUTOHOME | Object 471
PASSCNFG | Object 472
EMRGTO | Object 476
WSLOOP | Object 482
REFIP2 | Object 483
DRVCNFG2 | Object 484
BUSP1 | Object 485
BUSP2 | Object 486
BUSP3 | Object 487
BUSP4 | Object 488
BUSP5 | Object 489
BUSP6 | Object 490
BUSP7 | Object 491
BUSP8 | Object 492
BUSP9 | Object 493
BUSP10 | Object 494
BUSP11 | Object 495
BUSP12 | Object 496
BUSP13 | Object 497
BUSP14 | Object 498
BUSP15 | Object 499
BUSP16 | Object 500
IN5 | Object 501
IN5MODE | Object 502
IN5TRIG | Object 503
IN6 | Object 504
IN6MODE | Object 505
IN6TRIG | Object 506
IN7 | Object 507
IN7MODE | Object 508
IN7TRIG | Object 509
IN8 | Object 510
IN8MODE | Object 511
IN8TRIG | Object 512
IN9 | Object 513
IN9MODE | Object 514
IN9TRIG | Object 515
IN10 | Object 516
IN10MODE | Object 517
IN10TRIG | Object 518
IN11 | Object 519
IN11MODE | Object 520
IN11TRIG | Object 521
IN12 | Object 522
IN12MODE | Object 523
IN12TRIG | Object 524
IN13 | Object 525
IN13MODE | Object 526
IN13TRIG | Object 527
IN14 | Object 528
IN14MODE | Object 529
IN14TRIG | Object 530
IN15 | Object 531
IN15MODE | Object 532
IN15TRIG | Object 533
IN16 | Object 534
IN16MODE | Object 535
IN16TRIG | Object 536
IN17 | Object 537
IN17MODE | Object 538
IN17TRIG | Object 539
IN18 | Object 540
IN18MODE | Object 541
IN18TRIG | Object 542
IN19 | Object 543
IN19MODE | Object 544
IN19TRIG | Object 545
IN20 | Object 546
IN20MODE | Object 547
IN20TRIG | Object 548
O3 | Object 549
O3MODE | Object 550
O3TRIG | Object 551
O4 | Object 552
O4MODE | Object 553
O4TRIG | Object 554
O5 | Object 555
O5MODE | Object 556
O5TRIG | Object 557
O6 | Object 558
O6MODE | Object 559
O6TRIG | Object 560
O7 | Object 561
O7MODE | Object 562
O7TRIG | Object 563
O8 | Object 564
O8MODE | Object 565
O8TRIG | Object 566
O9 | Object 567
O9MODE | Object 568
O9TRIG | Object 569
OCOPY | Object 570
O10 | Object 570
O10MODE | Object 571
O10TRIG | Object 572
O11 | Object 573
O11MODE | Object 574
O11TRIG | Object 575
O12 | Object 576
O12MODE | Object 577
O12TRIG | Object 578
O13 | Object 579
O13MODE | Object 580
O13TRIG | Object 581
O14 | Object 582
O14MODE | Object 583
O14TRIG | Object 584
O15 | Object 585
O15MODE | Object 586
O15TRIG | Object 587
O16 | Object 588
O16MODE | Object 589
O16TRIG | Object 590
O17 | Object 591
O17MODE | Object 592
O17TRIG | Object 593
O18 | Object 594
O18MODE | Object 595
O18TRIG | Object 596
ERESMASK | Object 597
RUNIN | Object 598
SDLY | Object 599
VWM | Object 601
ERRPARAM | Object 602
DRVSTAT2 | Object 603
WSRED | Object 604
PARCNFG | Object 605
GVFR_X | Object 606
GVTN_X | Object 607
GV_X | Object 608
GP_X | Object 609
GPFFT_X | Object 610
GPFFV_X | Object 611
KC_X | Object 612
KTN_X | Object 613
MPOLES_X | Object 614
MLGC_X | Object 615
MLGD_X | Object 616
MLGP_X | Object 617
MLGQ_X | Object 618
MJ_X | Object 619
MRS_X | Object 620
ML_X | Object 621
MKT_X | Object 622
MTIME_X | Object 623
MICONT_X | Object 624
MIPEAK_X | Object 625
IN21MODE | Object 627
IN21TRIG | Object 628
IN22MODE | Object 630
IN22TRIG | Object 631
ETHMODE | Object 632
BUILDRK | Object 848
BUILDRP | Object 849
VINPOS | Object 854
ZERO | Object 857
BUSP0 | Object 859
EXTBRAKE | Object 860
ERRCODE * | Object 861
STATCODE | Object 862
DIROUT | Object 863
MVER | Object 865
ERRCODE2 | Object 866
WSTIME2 | Object 867
ROFFSSSI | Object 868
WSTIME3 | Object 869
FFTSW | Object 870
VCTIME | Object 871
ASMWAIT | Object 872
IEXTT | Object 873
GPFFTV | Object 874
CINPOS | Object 876
REFNOFFS | Object 877
REFNPOS | Object 878
DRVCNFG3 | Object 879
MPKD | Object 880
MPKI | Object 881
MPKP | Object 882
MPTIME | Object 883
WSCNFG | Object 884
PFBLO | Object 885
PFBHI | Object 886
ACC_X | Object 887
DEC_X | Object 888
O2MODE | Object 889
AVZ2 | Object 890
SSIRESOL | Object 891
DAOFFSET1 | Object 892
DAOFFSET2 | Object 893
ANOUT1 | Object 894
ANOUT2 | Object 895
AN1TRIG | Object 896
AN2TRIG | Object 897
IOLINK | Object 899
ERRCNFG | Object 900
MFR | Object 901
MUR | Object 902
MCOSPHI | Object 903
VSTART | Object 904
IQFILTK | Object 905
IQFILTTAU | Object 906
SKIP1SP | Object 907
SKIP1W | Object 908
SKIP2SP | Object 909
SKIP2W | Object 910
CALCMP | Object 911
CSSTAT | Object 912
CSIOSTAT | Object 913
CSERR | Object 914
FBGEARI | Object 915
FBGEARO | Object 916
BCCOT | Object 917
HLIMIT1 | Object 918
HLIMIT2 | Object 919
HLIMIT3 | Object 920
PASSPLC | Object 921
PASSXPLC | Object 922
PTARGOFFS | Object 923
RSVERROFF | Object 924
DIRIN | Object 925
RELTIME | Object 926
ANIN3 | Object 928
ANIN4 | Object 929
ANOFF3 | Object 930
ANOFF4 | Object 931
ANZERO3 | Object 932
ANZERO4 | Object 933
CALCPOSIO | Object 934
GPTNTH1 | Object 935
GPTNTH2 | Object 936
GPFFVDELAY | Object 940
GPDELAY | Object 943
GPTN | Object 945
GPTN_X | Object 946
MAXISETP | Object 947
MAXVSETP | Object 948
IEXTTLIM | Object 950
BISSCNFG | Object 951
S1DLY | Object 953
TEMPMFILT | Object 955
EWH | Object 958
VBUSBOFFS | Object 959
VLO_X | Object 960
VBUSRAMP | Object 961
VBUSFACT | Object 962
GP2 | Object 963
GPS1 | Object 964
GPS2 | Object 965
GV2 | Object 966
GVS1 | Object 967
GVS2 | Object 968
CSCNFG | Object 970
CSENID | Object 971
CSIDMAX | Object 972
DRVCNFG4 | Object 974
MVANGLMODE | Object 975
VBUSOFFS | Object 976
PMECH | Object 977
P | Object 978
ENCFIX | Object 979
LINRESOL | Object 981
ENCDIV | Object 982
QCNFG | Object 983
QFACTOR | Object 984
QFCFACT | Object 985
QMACT | Object 986
QTVEFF | Object 987
VTIMEKD | Object 988
QFSET | Object 989
QFACT | Object 990
QPRSET | Object 991
QPRACT | Object 992
QMCMD | Object 993
QFACTCOMP | Object 994
QFACTFILT | Object 995
QTIMEKD | Object 996
QVT1 | Object 997
QMCMDLIM | Object 998
QMLIMP | Object 999
QPRSETEFF | Object 1000
QFMAX | Object 1001
QPRMAX | Object 1002
QTAB1KP | Object 1003
QTAB2KP | Object 1004
QTAB3KP | Object 1005
QTAB4KP | Object 1006
QTAB5KP | Object 1007
QTAB1V | Object 1008
QTAB2V | Object 1009
QTAB3V | Object 1010
QTAB4V | Object 1011
QTAB5V | Object 1012
QTAB1TN | Object 1013
QTAB2TN | Object 1014
QTAB3TN | Object 1015
QTAB4TN | Object 1016
QTAB5TN | Object 1017
QPE | Object 1018
QKPEFF | Object 1019
QTNEFF | Object 1020
GVTV | Object 1021
QTABID | Object 1024
QTAB1TV | Object 1025
QTAB2TV | Object 1026
QTAB3TV | Object 1027
QTAB4TV | Object 1028
QTAB5TV | Object 1029
GFTN | Object 1031
MCFW | Object 1032
ENCDIVD | Object 1033
ENCFIXD | Object 1034
SSITIME | Object 1035
SSIMASK | Object 1036
EN22A1CNT | Object 1037
EN22A2CNT | Object 1038
EN22CNFG | Object 1039
EN22DCNT | Object 1040
ZEROTIME | Object 1042
QENA | Object 1043
QFCMD | Object 1044
QFCMDFILT | Object 1045
QT1 | Object 1046
QMLIMN | Object 1047
HDSLTEMP | Object 1048
HDSLLED | Object 1049
HDSLVOLT | Object 1050
HDSLVEL | Object 1051
HDSLTIME | Object 1052
HDSLROTAT | Object 1053
PLLHUB | Object 1057
BISSREVOL | Object 1058


ASCII Deutsch INPOS

ASCII - Kommando | INPOS |
Syntax Senden | INPOS [Data] |
Syntax Empfangen | INPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356D (hex)
DIM | - | PROFIBUS PNU | 1709 (dec) IND = 1 (dec)
Bereich | - | DPR | 109 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | In-Position-Meldung

Beschreibung

Das Kommando INPOS liefert den Zustand des IN-Position-Bits des Statusregisters (DRVSTAT).
Solange die Differenz zwischen der letzten Zielposition (Fahrauftrag) und der Istposition (PFB) kleiner ist als das eingestellte IN-Position-Fenster (PEINPOS), so wird eine 1 gemeldet, ansonsten eine 0.

Siehe auch INPT0


ASCII Deutsch INPT0

ASCII - Kommando | INPT0 |
Syntax Senden | INPT [Data] |
Syntax Empfangen | INPT0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3630 (hex)
DIM | ms | PROFIBUS PNU | 1904 (dec) IND = 1 (dec)
Bereich | 1 .. 32000 | DPR | 304 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | In-Position-Verzögerung

Beschreibung

Das Kommando INPT0 definiert eine Verzögerungszeit für die In-Position-Meldung. Beim Start eines Fahrsatzes wird die In-Position-Meldung zurückgenommen und erst nach Ablauf der eingestellten Zeit die Überwachung des In-Position-Fensters aktiviert. Diese Funktion ist besonders wichtig bei Positioniervorgängen innerhalb des In-Position-Fensters. In diesem Fall wird auf jeden Fall sichergestellt, daß die In-Position-Meldung für eine definierte Zeit zurückgenommen wird.

Siehe auch INPOS


ASCII Deutsch INPT1

ASCII - Kommando | INPT1 |
Syntax Senden | INPT1 [Data] |
Syntax Empfangen | INPT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3521 (hex)
DIM | - | PROFIBUS PNU | 1633 (dec) IND = 1 (dec)
Bereich | 0 ... 32000 | DPR | 33 (dec)
Default | 0 |
Opmode | 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Verzögerungszeit für die "In Position" Meldung

Beschreibung

Das Kommando INPT1 definiert eine Verzögerungszeit für die IN-POSITION-Meldung.Die IN-POSITION-Meldung wird erst dann ausgegeben, nachdem sich der Antrieb INPT1 msec lang innerhalb des IN-POSITION-Fensters aufgehalten hatte.Dieser Parameter definiert gleichzeitig die Verzögerungszeit für die Ausgabe der Meldung „Referenzpunkt gesetzt“.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Installation

Hardware-Installation

1. | Servoverstärker und Zubehör aus der Verpackung nehmen.
2. | Betriebsanleitung bereitlegen (bei Bedarf ausdrucken).
3. | Warnhinweise in den Handbüchern beachten.
4. | Servoverstärker wie in der Betriebsanleitung beschrieben montieren.
5. | Servoverstärker wie in der Betriebsanleitung beschrieben verdrahten oder verwenden Sie für den Schnelltest die u.a. Minimalverdrahtung:

Minimalverdrahtung S300

Diese Verdrahtung erfüllt keinerlei Anforderungen an die Sicherheit oder Funktionstüchtigkeit Ihrer Anwendung. Sie zeigt lediglich die für den Schnelltest ohne Last erforderliche Mindestverdrahtung.

Minimalverdrahtung S701-724 (STO zweikanalig)

Diese Verdrahtung erfüllt keinerlei Anforderungen an die Sicherheit oder Funktionstüchtigkeit Ihrer Anwendung. Sie zeigt lediglich die für den Schnelltest ohne Last erforderliche Mindestverdrahtung.

Minimalverdrahtung S748/772

Diese Verdrahtung erfüllt keinerlei Anforderungen an die Sicherheit oder Funktionstüchtigkeit Ihrer Anwendung. Sie zeigt lediglich die für den Schnelltest ohne Last erforderliche Mindestverdrahtung.

Setup Software - Installation

Minimale Anforderungen an den PC:

Prozessor | mindestens Pentium® II oder vergleichbar
Betriebssystem | WINDOWS 2000 / XP / VISTA / 7
Grafikkarte | Windows kompatibel, color
Laufwerke | Festplatte (mindestens 20 MB frei) CDROM Laufwerk
Schnittstelle | eine freie serielle Schnittstelle (COM1 bis COM10)

Bei allen anderen Betriebssystemen ist eine Notbedienung mit einer ASCII-Terminal-Emulation (ohne graphische Oberfläche) möglich.
Interface-Einstellung : 38400 Baud, Databit 8, kein Parity, Stopbit 1, kein Flow control.

Auf der CD-ROM befindet sich ein Installationsprogramm, das Ihnen die Installation der Inbetriebnahmesoftware auf Ihrem PC erleichtert.

Installieren

Autostart-Funktion aktiviert:
Legen sie die CD-ROM in ein freies Laufwerk ein. Es öffnet sich ein Fenster mit dem Startbildschirm der CD. Dort finden Sie eine Verknüpfung zur Inbetriebnahmesoftware DRIVEGUI.EXE. Klicken Sie darauf und folgen sie den Anweisungen.

Autostart-Funktion deaktiviert:
Legen sie die CD-ROM in ein freies Laufwerk ein. Kllicken Sie auf START (Task-Leiste), dann auf Ausführen. Geben Sie im Eingabefenster den Programmaufruf : x:\autorun.exe oder x:\index.htm (x= korrekter CD-Laufwerksbuchstabe) ein.
Klicken Sie OK und gehen dann wie oben beschrieben vor.

Verbindung Servoverstärker und PC

Schließen Sie die Übertragungsleitung an eine serielle Schnittstelle Ihres PC (COM1 bis COM10) und an die serielle Schnittstelle des Servoverstärkers an (siehe Betriebsanleitung des Servoverstärkers). USB-Seriell Wandler können optional verwendet werden.

Firmware Upgrade

Hinweise zur Aktualisierung der Servoverstärker-Firmware finden Sie im Kapitel "Firmware Upgrade".

Verstärker einschalten

1. | Verdrahtung des Servoverstärkers überprüfen
2. | 24V Hilfsspannungsversorgung für den Servoverstärkers einschalten.
3. | Warten Sie etwa 30s, bis die Anzeige in der Frontplatte des Servoverstärker die Stromtype (z.B. 03 für 3 A) anzeig. Ist die Leistungsversorgung ebenfalls zu geschaltet, wird ein führendes P (z.B. P03 für Power, 3 A) angezeigt.

Wird ein Fehlercode (F_ _) oder eine Warnung (n_ _) oder ein Hinweis
(./_ / E/S/A) angezeigt, finden Sie die entsprechende Beschreibung im Anhang.
Anzeige eines Fehlercodes: beseitigen Sie die Ursache, Hinweise siehe Trouble-Shooting.


ASCII Deutsch INTERPOL

ASCII - Kommando | INTERPOL |
Syntax Senden | INTERPOL [Data] |
Syntax Empfangen | INTERPOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3684 (hex)
DIM | - | PROFIBUS PNU | 1988 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 388 (dec)
Default | 0 |
Opmode | 5,6 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Interpolationsmethode bei OPMODE 5 und 6

Beschreibung

Die Einstellung der Interpolationsart erfolgt mit dem Parameter INTERPOL.

Dieser Parameter erlaubt die Auswahl der Interpolatinsmethode im Betrieb mit der Vorgabe einer Positionstrajektorie (OPMODE 5 oder 6). Der Interpolator arbeitet mit einer Abtastzeit von 250 µsec. Die Bus-Positionssollwerte werden mit einer Zykluszeit von PTBASE durch die Steuerung vorgegeben. Der Interpolator sorgt dafür, dass die durch die Steuerung vorgegebenen Positionssollwerte auf die interne Zykluszeit von 250 µsec umgerechnet werden. Bei PTBASE=1 (Buszykluszeit von 250 µsec)
findet keine Interpolation statt.

Es gibt folgende Interpolationsarten:

INTERPOL=0: lineare Interpolation
INTERPOL=1: spline Interpolation (nur im SERCOS-Betrieb)
INTERPOL=5: kubische Interpolation
INTERPOL=6: lineare Interpolation der Beschleuinigung

Dieser Parameter kann nur bei einem synchronen Betrieb des Servoverstäkers genutzt werden, siehe auch ASCII Parameter SYNCSRC.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

I/O-Erweiterungskarte

Diese Bildschirmseite erscheint nur, wenn eine I/O-Erweiterungskarte in den Servoverstärker eingebaut ist.

ioerweiterung

Der Zustand der 14 zusätzlichen Eingänge und 8 Ausgänge der I/O Erweiterungskarte wird angezeigt.

Eingänge: Funktion INxMODE mit x={5...18}
Ausgänge: Funktion OxMODE mit x={3...10}

Alle Ein-/Ausgänge können über die jeweilige Schaltfläche “...” konfiguriert werden; bei Betätigung der Schaltfläche wird ein entsprechendes Dialogfenster geöffnet.

ioconfig


ASCII Deutsch IOLINK

ASCII - Kommando | IOLINK |
Syntax Senden | IOLINK [Data] |
Syntax Empfangen | IOLINK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3883 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 33 (dec)
Bereich | 32 Bits | DPR | 899 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Verbindung zwischen dig. Aus- sowie Eingang

Beschreibung

Der Parameter IOLINK stellt eine interne Verbindung zwischen einem digitalen Ausgang und dem entsprechenden digitalen Eingang her. Jedes einzelne Bit der Variable IOLINK entspricht einem Ausgang/Eingang-Paar.
z.B.
IOLINK 5
Bit0=1 digitaler Ausgang 1 ist verbunden mit dem digitalen Eingang 1.
Bit2=1 digitaler Ausgang 3 ist verbunden mit dem digitalen Eingang 3.

In Verbindung mit den Kommandos INxMODE/OxMODE, ermöglicht diese Funktion Realisierung von einfachen
Steuerungsfunktionen ohne Beteiligung einer externen Steuerung.


ASCII Deutsch IPEAK

ASCII - Kommando | IPEAK |
Syntax Senden | IPEAK [Data] |
Syntax Empfangen | IPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 356E (hex)
DIM | A | PROFIBUS PNU | 1710 (dec) IND = 1 (dec)
Bereich | 0.0 ... DIPEAK | DPR | 110 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom

Beschreibung

Mit IPEAK wird der Spitzennennstrom IPEAKP und IPEAKN der Anwendung (Effektivwert als RMS-Wert) eingestellt. Dieser Wert ist auf den unteren Nennstrom des Motors (MIPEAK) oder Verstärkers (DIPEAK) begrenzt. Wenn der IPEAK-Wert zu niedrig gewählt wurde, ist auch das Drehmoment zu niedrig und im Antrieb wird ein Scheppfehler angezeigt. Wenn der IPEAK-Wert zu hoch ist, könnten die Motorwicklung beschädigt werden.


ASCII Deutsch IPEAKN

ASCII - Kommando | IPEAKN |
Syntax Senden | IPEAKN [Data] |
Syntax Empfangen | IPEAKN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 356F (hex)
DIM | A rms | PROFIBUS PNU | 1711 (dec) IND = 1 (dec)
Bereich | 0.0 ... DIPEAK | DPR | 111 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Max.negativer Impulsstrom des Motors in A rms

Beschreibung

Max. negativer Impulsstrom des Motors in A rms. Kann bei I2T Begrenzung auf DICONT oder MICONT zurückfallen.


ASCII Deutsch IPEAKP

ASCII - Kommando | IPEAKP |
Syntax Senden | IPEAKP [Data] |
Syntax Empfangen | IPEAKP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3594 (hex)
DIM | A rms | PROFIBUS PNU | 1748 (dec) IND = 1 (dec)
Bereich | 0 ... DIPEAK | DPR | 148 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Max.positiver Impulsstrom des Motors in A rms

Beschreibung

Max. positiver Impulsstrom des Motors in A rms. Kann bei I2T Begrenzung auf DICONT oder MICONT zurückfallen.


ASCII Deutsch IQ

ASCII - Kommando | IQ |
Syntax Senden | IQ [Data] |
Syntax Empfangen | IQ <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3570 (hex)
DIM | A | PROFIBUS PNU | 1712 (dec) IND = 1 (dec)
Bereich | - | DPR | 112 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Q-Anteil des Stromistwertes

Beschreibung

Drehmomentbildender Stromistwert (Q-Richtung)


ASCII Deutsch IQFILTK

ASCII - Kommando | IQFILTK |
Syntax Senden | IQFILTK [Data] |
Syntax Empfangen | IQFILTK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3889 (hex)
DIM |  | PROFIBUS PNU | 1705 (dec) IND = 33 (dec)
Bereich | 0 .. 2.5 | DPR | 905 (dec)
Default | 0 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Verstärkungsfaktor für die Schlupfkompensation

Beschreibung

Verstärkungsfaktor für die Schlupfkompensation. (U/f Steuerung)
100% Schlupfkompensation: IQFILTK = 1

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII Deutsch IQFILTTAU

ASCII - Kommando | IQFILTTAU |
Syntax Senden | IQFILTTAU [Data] |
Syntax Empfangen | IQFILTTAU <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 388A (hex)
DIM | ms | PROFIBUS PNU | 1706 (dec) IND = 33 (dec)
Bereich | 0 .. 2000 | DPR | 906 (dec)
Default | 200 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Zeitkonstante zur Schlupfkompensation (Tiefpass)

Beschreibung

Zeitkonstante des Tiefpassfilters für die Schlupfkompensation. (U/f Steuerung)
Iq wird vor der Verwendung für die Schlupfkompensation mit einem Tiefpassfilter geglättet.


ASCII Deutsch ISCALE1

ASCII - Kommando | ISCALE1 |
Syntax Senden | ISCALE1 [Data] |
Syntax Empfangen | ISCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3571 (hex)
DIM | A/10V | PROFIBUS PNU | 1713 (dec) IND = 1 (dec)
Bereich | 0 ... DIPEAK | DPR | 113 (dec)
Default | 15 |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 1

Beschreibung

Definiert die Normierung des analogen Eingangs 1 (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISCALE2

ASCII - Kommando | ISCALE2 |
Syntax Senden | ISCALE2 [Data] |
Syntax Empfangen | ISCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3572 (hex)
DIM | A/10V | PROFIBUS PNU | 1714 (dec) IND = 1 (dec)
Bereich | 0 ... DIPEAK | DPR | 114 (dec)
Default | 15 |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 2

Beschreibung

Definiert die Normierung des analogen Eingangs 2 (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISTFR

ASCII - Kommando | ISTFR |
Syntax Senden | ISTFR [Data] |
Syntax Empfangen | ISTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A4 (hex)
DIM | A | PROFIBUS PNU | 2020 (dec) IND = 1 (dec)
Bereich | 0 ... DIPEAK | DPR | Nein
Default | 0 |
Opmode | 0, 1, 4...8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disable | Wichtung | 1000
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Stromgrenze f. drehzahlabhängige. Reibungskomp.

Beschreibung

Die beiden Kommandos ISTFR und VSTFR definieren die Eckwerte für die Reibungs-Kompensation. Mit ISTFR wird diese Kompensation aktiviert und bewirkt die Aufschaltung einer drehzahlabhängigen Stromvorsteuerung. Die Aufschaltung erfolgt vor dem Drehzahlregler-Filter, so dass dieser auch auf die Reibungs-Kompensation wirkt.

Wenn IFSTFR von 0 auf einen anderen Wert geändert wird, so muss der Parameter zunächst gespeichert werden und ein Reset muss erfolgen. Dann kann der Parameter online geändert werden.

V=0 -> IFRICT = 0
V= 50% von VSTFR -> IFRICT = 50% von ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% von VSTFR -> IFRICT = -50% von ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII Deutsch IVTICK

ASCII - Kommando | IVTICK |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch J

ASCII - Kommando | J |
Syntax Senden | J [Data] |
Syntax Empfangen | J <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | -
DIM | rpm (velocity) / ms (Time) | PROFIBUS PNU | -
Bereich | -15000.0 .. 15000.0 (=velocity),long int (Time) | DPR | Nein
Default | - |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Nein
Kurzbeschreibung | Service-Funktion "konstante Drehzahl"

Beschreibung

Mit dem Kommando "J <n> <t>" kann eine konstante Drehzahl <n> (in UPM) für eine bestimmte Zeit <t> (in msek) vorgegeben werden. Fehlt die Eingabe der Zeit <t>, so läuft der Antrieb im Endlosbetrieb.


ASCII Deutsch JRATIO

ASCII - Kommando | JRATIO |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3531 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch K

ASCII - Kommando | K |
Syntax Senden | K |
Syntax Empfangen | K | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3573 (hex)
DIM | - | PROFIBUS PNU | 1715 (dec) IND = 1 (dec)
Bereich | - | DPR | 115 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Software-Sperre der Endstufe

Beschreibung

Das K-Kommando stellt eine verkürzte (Kommandolänge) Form des Kommandos "DIS" dar.


ASCII Deutsch KC

ASCII - Kommando | KC |
Syntax Senden | KC [Data] |
Syntax Empfangen | KC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3574 (hex)
DIM | - | PROFIBUS PNU | 1716 (dec) IND = 1 (dec)
Bereich | 0.0 .. 1.0 | DPR | 116 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Stromistwert-Vorsteuerung Stromregler

Beschreibung

KC ist ein Parameter des Stromregelkreises. Zur Kompensation von Verzugszeiten kann dem gemessenen Motorstrom eine vorhersehbare Stromänderung hinzugefügt werden (Strom Prädiktion). KC 1 schaltet diese ein, KC 0.5 setzt sie auf 50 % und KC 0 schaltet sie aus. Das Ausschalten der Stromprädiktion kann die Stabilität des Stromregelkreises beeinträchtigen.
Abhängig von der Funktion FILTMODE schaltet KC unterschiediche Algorithmen ein bzw. aus. Bei der Einstellung FILTMODE=1 (Default) wird die herkömmliche Prädiktion verwendet, bei der Einstellung FILTMODE=2 wird ein Smith Predictor verwendet. Bei Verwendung des Smith Predictors kann die Proportionalverstärkung des Stromregelkreises MLGQ deutlich angehoben werden (höhere Dynamik), wenn die Motorparameter ML und MRS korrekt eingestellt sind.


ASCII Deutsch KC_X

ASCII - Kommando | KC_X |
Syntax Senden | KC [Data] |
Syntax Empfangen | KC_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3764 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 17 (dec)
Bereich | 0.0 .. 1.0 | DPR | 612 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Stromistwert-Vorsteuerung Stromregler 2

Beschreibung

siehe PARCNFG


ASCII Deutsch KEYLOCK

ASCII - Kommando | KEYLOCK |
Syntax Senden | KEYLOCK [Data] |
Syntax Empfangen | KEYLOCK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3575 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 117 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | display | EEPROM | Ja
Kurzbeschreibung | Sperre für die Tastenbedienung

Beschreibung

Bei KEYLOCK=1 ist die Bedienung des Verstärkers über die Tasten auf der Frontplatte gesperrt. Die Anzeige-Funktionen des Gerätes (Fehlermeldungen, Warnungen) sind weiterhin aktiv.


ASCII Deutsch KTN

ASCII - Kommando | KTN |
Syntax Senden | KTN [Data] |
Syntax Empfangen | KTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 362F (hex)
DIM | ms | PROFIBUS PNU | 1903 (dec) IND = 1 (dec)
Bereich | 0.2 ... 2 | DPR | 303 (dec)
Default | 0.6 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Stromreglers

Beschreibung

Integralanteil des Stromreglers


ASCII Deutsch KTN_X

ASCII - Kommando | KTN_X |
Syntax Senden | KTN [Data] |
Syntax Empfangen | KTN_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3765 (hex)
DIM | ms | PROFIBUS PNU | 1813 (dec) IND = 17 (dec)
Bereich | 0.2 ... 2 | DPR | 613 (dec)
Default | 0.6 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Stromreglers 2

Beschreibung

siehe PARCNFG


ASCII Deutsch LASTWMASK

ASCII - Kommando | LASTWMASK |
Syntax Senden | LASTWMASK [Data] |
Syntax Empfangen | LASTWMASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36CE (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 17 (dec)
Bereich | long int | DPR | 462 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Fehlerspeicher von WMASK

Beschreibung

Über WMASK kann eine Maske erstellt werden, welche Warnungen in Fehler umgewandelt werden sollen. Falls der Fehler F24 auftritt, kann dann über LASTWMASK ausgelesen werden, welche Warnungen zu diesem Fehler geführt haben.


ASCII Deutsch LATCH1N16

ASCII - Kommando | LATCH1N16 |
Syntax Senden | LATCH16N [Data] |
Syntax Empfangen | LATCH1N16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3680 (hex)
DIM | - | PROFIBUS PNU | 1984 (dec) IND = 1 (dec)
Bereich | - | DPR | 384 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.03 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 16 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH16N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH1N32 benutzt werden.
Die Kommandos LATCH1N16 und LATCH1N32 bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCH1N32

ASCII - Kommando | LATCH1N32 |
Syntax Senden | LATCH1N32 [Data] |
Syntax Empfangen | LATCH1N32 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 357D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 1 (dec)
Bereich | - | DPR | 125 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH1N32 gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH1N16 benutzt werden.
Die Kommandos LATCH1N16 und LATCH32N bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCH1P16

ASCII - Kommando | LATCH1P16 |
Syntax Senden | LATCH1P16 [Data] |
Syntax Empfangen | LATCH1P16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 367F (hex)
DIM | - | PROFIBUS PNU | 1983 (dec) IND = 1 (dec)
Bereich | - | DPR | 383 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 16 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH1P16 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH1P32 benutzt werden.
Die Kommandos LATCH1P16 und LATCH1P32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT


ASCII Deutsch LATCH1P32

ASCII - Kommando | LATCH1P32 |
Syntax Senden | LATCH1P32 [Data] |
Syntax Empfangen | LATCH1P32 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357C (hex)
DIM | - | PROFIBUS PNU | 1724 (dec) IND = 1 (dec)
Bereich | - | DPR | 124 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH1P32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH1P16 benutzt werden.
Die Kommandos LATCH1P16 und LATCH1P32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT.


ASCII Deutsch LATCH2N16

ASCII - Kommando | LATCH2N16 |
Syntax Senden | LATCH2N16 [Data] |
Syntax Empfangen | LATCH2N16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3579 (hex)
DIM | - | PROFIBUS PNU | 1721 (dec) IND = 1 (dec)
Bereich | - | DPR | 121 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 16 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH2N16 gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH2N32 benutzt werden.
Die Kommandos LATCH2N16 und LATCH2N32 bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCH2N32

ASCII - Kommando | LATCH2N32 |
Syntax Senden | LATCH2N32 [Data] |
Syntax Empfangen | LATCH2N32 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 357B (hex)
DIM | - | PROFIBUS PNU | 1723 (dec) IND = 1 (dec)
Bereich | - | DPR | 123 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH2N32 gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH2N16 benutzt werden.
Die Kommandos LATCH2N16 und LATCH2N32 bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCH2P16

ASCII - Kommando | LATCH2P16 |
Syntax Senden | LATCH2P16 [Data] |
Syntax Empfangen | LATCH2P16 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3578 (hex)
DIM | - | PROFIBUS PNU | 1720 (dec) IND = 1 (dec)
Bereich | - | DPR | 120 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 16 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH2P16 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH2P32 benutzt werden.
Die Kommandos LATCH2P16 und LATCH2P32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT


ASCII Deutsch LATCH2P32

ASCII - Kommando | LATCH2P32 |
Syntax Senden | LATCH2P32 [Data] |
Syntax Empfangen | LATCH2P32 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357A (hex)
DIM | - | PROFIBUS PNU | 1722 (dec) IND = 1 (dec)
Bereich | - | DPR | 122 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH2P32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH2P16 benutzt werden.
Die Kommandos LATCH2P16 und LATCH2P32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT.


ASCII Deutsch LDUMP

ASCII - Kommando | LDUMP |
Syntax Senden | LDUMP [data] |
Syntax Empfangen | LDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Parameterausgabe eines Motordatensatzes

Beschreibung

Mit dem Kommando LDUMP <name> können die Parameter des Motordatensatzes <name> aus der internen Motordatenbank ausgegeben werden. Als <name> muß eine gültige Motorbezeichnungen aus der Motordatenbank angegeben werden (s. MDBLIST). Falls der Parameter <name> nicht angegeben wird, so werden die aktuell geladenen Motor-Parameter angezeigt.


ASCII Deutsch LED1

ASCII - Kommando | LED1 |
Syntax Senden | LED1 [Data] |
Syntax Empfangen | LED1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357E (hex)
DIM | - | PROFIBUS PNU | 1726 (dec) IND = 1 (dec)
Bereich | 0 ... 127 | DPR | 126 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | display | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED1-Segmentes

Beschreibung

Das Kommando LED1 liefert den aktuellen Zustand (7-Segment-Code) des LED1-Segmentes (links).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED1 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED2

ASCII - Kommando | LED2 |
Syntax Senden | LED2 [Data] |
Syntax Empfangen | LED2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357F (hex)
DIM | - | PROFIBUS PNU | 1727 (dec) IND = 1 (dec)
Bereich | 0 ... 127 | DPR | 127 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | display | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED2-Segmentes

Beschreibung

Das Kommando LED2 liefert den aktuellen Zustand (7-Segment-Code) des LED2-Segmentes (mitte).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED2 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED3

ASCII - Kommando | LED3 |
Syntax Senden | LED3 [Data] |
Syntax Empfangen | LED3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3580 (hex)
DIM | - | PROFIBUS PNU | 1728 (dec) IND = 1 (dec)
Bereich | 0 ...127 | DPR | 128 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | display | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED3-Segmentes

Beschreibung

Das Kommando LED3 liefert den aktuellen Zustand (7-Segment-Code) des LED3-Segmentes (rechts).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED3 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LEDSTAT

ASCII - Kommando | LEDSTAT |
Syntax Senden | LEDSTAT [Data] |
Syntax Empfangen | LEDSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3581 (hex)
DIM | - | PROFIBUS PNU | 1729 (dec) IND = 1 (dec)
Bereich | 0 ... 17 | DPR | 129 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | display | EEPROM | -
Kurzbeschreibung | Seitennummer für das LED-Display

Beschreibung

Die Variable LEDSTAT zeigt die Nummer der aktuellen "Display-Seite". Durch die Änderung der Variable LEDSTAT, kann über die serielle Schnittstelle die Anzeige umgeschaltet werden.
Es gilt folgende Zuordnung:
LEDSTAT=0 Ansteuerung der Anzeige abgeschaltet
LEDSTAT=1 Status-Anzeige
LEDSTAT=2 Feldbusadresse
LEDSTAT=3 CAN-Baudrate
LEDSTAT=4 Parameter S01 (Kp Drehzahlregler)
LEDSTAT=5 Parameter S02 (Tn Drehzahlregler)
LEDSTAT=6 Parameter S03 (Sollwert-Offset)
LEDSTAT=7 Parameter S04 (Motornummer)
LEDSTAT=8 Parameter S05 (Encoder-Vorwahl)
LEDSTAT=9 Parameter S06 (Bremsenvorwahl)
LEDSTAT=10 Parameter S07 (Multidrive-Vorwahl, ab Software 3.00)
LEDSTAT=11 Laden der Daten aus dem EEPROM
LEDSTAT=12 Speichern der Daten im EEPROM
LEDSTAT=13 Default-Werte setzen (ab Software 3.00)
LEDSTAT=14 Neukonfiguration des Verstärkers (M_RESET, ab Software 3.00)
LEDSTAT=15 Fehlermeldungen
LEDSTAT=16 Seriennummer


ASCII Deutsch LINRESOL

ASCII - Kommando | LINRESOL |
Syntax Senden | LINRESOL [Data] |
Syntax Empfangen | LINRESOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38D5 (hex)
DIM | nm / Count | PROFIBUS PNU | 1781 (dec) IND = 33 (dec)
Bereich | 0 … 2^31 | DPR | 981 (dec)
Default | 0 |
Opmode | all | Datentyp Bus/DPR | Interger32
Verstärker Status | - | Wichtung |
ab Firmware | 5.87 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Umrechnungsfaktor bei linearen Messsystemen

Beschreibung

Bei Linearen Messsystemen, die nicht automatisch als solche erkannt werden können (SSI,BISS), kann die Positionsberechnung nur dann korrekt erfolgen, wenn der Umrechnungsfaktor für die Linearen Einheiten LINRESOL vorher korrekt definiert wurde. Dieser Parameter beschreibt die Größe eines Position-Counts in nm. Mit Hilfe dieser Angabe und der Größe des Polpitches MPITCH, kann die Position innerhalb eines Polpitches berechnet werden.
LINRESOL = 0: keine Lineareinheiten definiert, es handelt sich um einen rotatorischen Geber
LINRESOL > 0: Umrechnung der Lineareinheiten ist aktiviert.

ab FW 5.90:
SSI-Geber:
Es gibt eine Besonderheit bei SSI-Gebern, die eine nicht binäre Auflösung liefern. Dort kann der Parameter LINRESOL auf zweifache Weise benutzt werden

MTYPE = 2 Linearmotor: LINRESOL beschreibt die Größe eines SSI-Counts

MTYPE = 1 rotatorischer Motor mit binärer SSI-Auflösung
LINRESOL = 0 die Position wird berechnet aus den Angaben SSIRXD und SSIREVOL

MTYPE = 1 rotatorischer Motor mit einer nicht-binären Auflösung (z.B 1000 Counts/Umdrehung)
LINRESOL = 1000 Beschreibt die Anzahl der SSI-Counts pro Motorumdrehung


ASCII Deutsch LIST

ASCII - Kommando | LIST |
Syntax Senden | LIST |
Syntax Empfangen | LIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Auflistung aller ASCII-Kommandos

Beschreibung

Es werden alle Kommandos aufgelistet, die für die vorhandene Verstärker/Motor-Konfiguration möglich sind. ASCII-Befehle, die bestimmte Hardware voraussetzen (z.B. Hiperface/Endat, Profibus,Sercos) werden nur dann angezeigt, wenn die entsprechende Hardware korrekt erkannt wurde.


ASCII Deutsch LOAD

ASCII - Kommando | LOAD |
Syntax Senden | LOAD |
Syntax Empfangen | LOAD | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3583 (hex)
DIM | - | PROFIBUS PNU | 1731 (dec) IND = 1 (dec)
Bereich | - | DPR | 131 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Laden der Parameter aus dem seriellen EEPROM

Beschreibung

Das Kommando LOAD bewirkt das Laden der Parameter aus dem seriellen EEPROM. Alle Parameteränderungen, die seit dem letzten SAVE-Kommando (Abspeichern im seriellen EEPROM) durchgeführt wurden, gehen verloren.


LOGO

ASCII Objektreferenz

sortiert nach:


ASCII Deutsch M

ASCII - Kommando | M |
Syntax Senden | M [Data] |
Syntax Empfangen | M <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | -
Kurzbeschreibung | Lesen/Schreiben einer Macro-Variable

Beschreibung

Mit dem Kommando "M" kann jede interne Macro-Variable angesprochen werden.
Macro-Variablen sind Variablen, die von den Macro-Routinen benutzt werden. Sie werden innerhalb einer Macro-Routine mit ihren Namen angesprochen. Die vollständige Variablen-Information (Name, Adresse) wird in Form einer Tabelle verwaltet. Es gibt zwei Arten von Macro-Variablen:
1. System-Variablen - diese Variablen werden fest von der Firmware vorgegeben. Sowohl die Namen als auch die Adressen von diesen Variablen sind innerhalb einer bestimmten Firmware-Version konstant. Die Tabelle mit den Variablen-Daten liegt im Programmbereich, so daß der Zugriff auf System-Variablen jederzeit möglich ist.
2. User-Variablen - diese Variablen werden während der Initialisierungsphase des Verstärkers in den Macro-Routinen angelegt. Das Vorhandensein einer bestimmten Variable bzw. deren physikalische Adresse hängt von der Konfiguration des Verstärkers ab. Die Tabelle mit Variablen-Informationen wird im RAM angelegt und normalerweise nur während der Übersetzung der Macro-Programme (Initialisierungsphase) benötigt. Nachdem die Initialisierung abgeschlossen ist, wird die Tabelle aus dem Speicher entfernt. Der Zugriff auf die User-Variablen mit dem M-Kommando ist in diesem Fall nicht möglich.
Falls beim Einschalten des Verstärkers die Parametereinstellung MSG=2 gefunden wird, so wird die Variablen-Tabelle für die User-Variablen im Speicher gelassen. Auf diese Weise kann auch eine User-Variable mit dem M-Kommando angesprochen werden.
Das Kommando M kann in einer der drei Formen benutzt werden:
1. "M" es wird eine Liste aller System- und User-Variablen ausgegeben.

2. "M name" es wird eine Informationszeile zu der Variable <name> in folgender Form ausgegeben:
"Name [TYPE] Adresse FORMAT=Wert"
Die einzelnen Komponenten haben folgende Bedeutung:
name = Name der Macro-Variable
TYPE = Variablentype (SYSTEM oder USER)
adresse = physikalische Adresse der Variable (Hexadezimale Darstellung)
FORMAT = Variablenart (BYTE,WORD,LONG,STRING), der Zusatz FAST bedeutet, daß die Variable im internen (schnellen) RAM abgelegt ist.
Wert= Variableninhalt (Hexadezimale Darstellung bzw. ASCII-String je nach FORMAT)

3. "M Name Wert" die Zahl "Wert" wird in der Variable "Name" eingetragen.
Die Angabe "Wert" wird in dezimaler Darstellung erwartet. Bei Voreinstellung der Zeichenfolge "0x" kann die Zahl auch in hexadezimaler Darstellung angegeben werden.


ASCII Deutsch M_RESET

ASCII - Kommando | M_RESET |
Syntax Senden | M_RESET |
Syntax Empfangen | M_RESET | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35A9 (hex)
DIM | - | PROFIBUS PNU | 1769 (dec) IND = 1 (dec)
Bereich | - | DPR | 169 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Neuübersetzung der Macro-Programme

Beschreibung

Alle Macro-Programme werden beim Einschalten des Verstärkers übersetzt (compiliert) und gestartet. Die Übersetzung der Macro-Programme wird durch s.g. Konfigurationsvariablen gesteuert. Die Werte dieser Konfigurationsvariablen müssen bereits vor dem Start des Übersetzungsvorganges feststehen. Falls der Wert einer Konfigurationsvariable zu einem späteren Zeitpunkt verändert wird, so wirkt sich diese Änderung erst bei der nächsten Überstzung der Macro-Programme aus. Das bedeutet, daß nach einer Änderung einer Konfigurationsvariable, diese Änderung zunächst im EEPROM abgespeichert (SAVE Kommando) und der Verstärker aus- und eingeschaltet werden muß.
Eine Alternative bietet das Kommando M_RESET. Mit diesem Kommando wird eine Neu-Übersetzung der Makro-Programme erzwungen, ohne daß der Verstärker aus- und eingeschaltet werden muß. Da diese Funktion, im Gegensatz zu der Initialisierungsphase, bei freigeschalteten Interrupts ausgeführt wird, beträgt ihre Ausführungszeit entsprechend länger (ca. 5 Minuten).


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Makroprogrammierung

Für typische Anwendungen bieten wir Ihnen spezifische Makro-Programme an. Bei Interesse an diesen Funktionen setzen Sie sich mit unserer Applikationsabteilung in Verbindung. Umfangreiche Beschreibungen finden Sie auch im KDN unter "Makro Programmierung", unter anderem ist dort eine Übersicht über die Makrosprache zu finden.

Den Editor mit Compiler Funktionalität MacroStar finden Sie auf der Produkt-CDROM oder Sie können das Tool von unserem Datei Archiv herunter laden.

Vorbereitete Makros für die u.a. Funktionen können angefordert werden (kostenpflichtig):

P/I-Regler

Für einfache Bahnsteuerungen mit einem Tänzer oder Pressungen mit einer Kraftmessdose.

Fliegende Säge

Für Grundfunktionen einer fliegenden Säge mit flexibler Schnittlänge.

Drehmoment-Kopplung über Feldbus

Einfache Master-Slave Drehmoment-Kopplung mit integrierter Freigabe Funktion.

Positions-Kopplung über Feldbus

Einfache Master-Slave Positionskopplung mit integrierter Freigabe Funktion.

und weitere

...


ASCII Deutsch MAXCMD

ASCII - Kommando | MAXCMD |
Syntax Senden | MAXCMD |
Syntax Empfangen | MAXCMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3538 (hex)
DIM |  | PROFIBUS PNU | 1656 (dec) IND = 1 (dec)
Bereich | - | DPR | 56 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | Sonstige | EEPROM | Nein
Kurzbeschreibung | max. Anzahl der DPR-Objekte

Beschreibung

Mit diesem Parameter kann man die max. Anzahl der DPR Objekte ausgeben lassen. Davon sind viele nicht dokumentiert, da sie Debugobjekte sind oder in kundenspezifischen Firmware Versionen zum Einsatz kommen.

siehe auch IDDUMP


ASCII Deutsch MAXISETP

ASCII - Kommando | MAXISETP |
Syntax Senden | MAXISETP [Data] |
Syntax Empfangen | MAXISETP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38B3 (hex)
DIM |  | PROFIBUS PNU | 1747 (dec) IND = 33 (dec)
Bereich | 0 .. 16000 | DPR | 947 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Begrenzung des Integralanteils des Lagereglers

Beschreibung

MAXISETP ist ein Parameter des Lageregelkreises und begrenzt den Integralanteil (in RPM).

Für MAXISETP = 0 (default) ist keine Begrenzung aktiv.


ASCII Deutsch MAXSUMME

ASCII - Kommando | MAXSUMME |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch MAXTEMPE

ASCII - Kommando | MAXTEMPE |
Syntax Senden | MAXTEMPE [Data] |
Syntax Empfangen | MAXTEMPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3584 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1732 (dec) IND = 1 (dec)
Bereich | 10 .. 80 | DPR | 132 (dec)
Default | 75 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | temperatures | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Umgebungstemperatur

Beschreibung

Abschaltwert der Umgebungstemperatur. Wenn TEMPE den Schwellwert erreicht, wird ein Fehler ausgelöst (F13).


ASCII Deutsch MAXTEMPH

ASCII - Kommando | MAXTEMPH |
Syntax Senden | MAXTEMPH [Data] |
Syntax Empfangen | MAXTEMPH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3585 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1733 (dec) IND = 1 (dec)
Bereich | 20 ... 85 | DPR | 133 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | temperatures | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Kühlkörpertemperatur

Beschreibung

Abschaltwert der Kühlkörpertemperatur. Wenn die Kühlkörpertemperatur (TEMPH) diesen Wert überschreitet, so wird im Verstärker ein Fehler ausgelöst.

dabei gelten folgende max. Grenzwerte:
S300: 85 Grad
S700: 90 Grad
S748/S772 : 105 Grad


ASCII Deutsch MAXTEMPM

ASCII - Kommando | MAXTEMPM |
Syntax Senden | MAXTEMPM [Data] |
Syntax Empfangen | MAXTEMPM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3586 (hex)
DIM | Ohms or [MTAB units] | PROFIBUS PNU | 1734 (dec) IND = 1 (dec)
Bereich | -6000.0 .. 6000.0 | DPR | 134 (dec)
Default | 300 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | temperatures | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Motortemperatur (Widerstand)

Beschreibung

Abschaltwert der Motortemperatur (Widerstand in Ohm)

Mit MAXTEMPM = 0 wird die Temperaturüberwachung vom Motor abgeschaltet. (F06)

Bei vorhandener Temperaturkennlinie (siehe MTAB) ändern sich die Einheiten für die Parameter MAXTEMPM und TEMPM von Ohm auf die Einheit, die bei der Kennliniendefinition verwendet wurde.

siehe auch SLTEMPM, TEMPM, MTAB


ASCII Deutsch MAXVSETP

ASCII - Kommando | MAXVSETP |
Syntax Senden | MAXVSETP [Data] |
Syntax Empfangen | MAXVSETP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38B4 (hex)
DIM |  | PROFIBUS PNU | 1748 (dec) IND = 33 (dec)
Bereich | 0 .. 16000 | DPR | 948 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | position loop | EEPROM |
Kurzbeschreibung | begrenzt den Proportinalanteil im Lageregler

Beschreibung

MAXVSETP ist ein Parameter des Lageregelkreises und begrenzt den Proportionalanteil (in RPM).

Für MAXVSETP = 0 (default) ist keine Begrenzung aktiv.


ASCII Deutsch MBPDRVSTAT

ASCII - Kommando | MBPDRVSTAT |
Syntax Senden | MBPDRVSTAT [Data] |
Syntax Empfangen | MBPDRVSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 368D (hex)
DIM | - | PROFIBUS PNU | 1997 (dec) IND = 1 (dec)
Bereich | 0 .. 31 | DPR | 397 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Zustand des Modbus+ Netzwerks

Beschreibung

MBPDRVSTAT gibt den Zustand des Antriebs im Modbus+ Netzwerk an. Das Bit 3 kann vom Antrieb beschrieben und abgespeichert werden. Damit wird gekennzeichnet, ob Modbus+ - Netzwerkfehler zum Antrieb gemeldet werden sollen oder nicht.


ASCII Deutsch MBRAKE

ASCII - Kommando | MBRAKE |
Syntax Senden | MBRAKE [Data] |
Syntax Empfangen | MBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3587 (hex)
DIM | - | PROFIBUS PNU | 1735 (dec) IND = 1 (dec)
Bereich | 0..4 | DPR | 135 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Vorwahl für Motorbremse

Beschreibung

Vorwahl für Motorbremse
Wenn die Motorbremse angewählt wurde, ändert sich das Disable-Verhalten des Gerätes.

MBRAKE = 0 Haltebremsenfunktion ist abgeschaltet
MBRAKE = 1 Haltebremsenfunktion ist aktiviert. Beim Enablen des Verstärkers wird die Bremse gelüftet. Beim Disablen des Verstärkers fällt die Bremse nach dem Stoppen der Achse wieder ein.
MBRAKE = 2 Beim Wake&Shake - Modus (FBTYPE = 7 oder 8) wird die Bremse nicht gelüftet, bis der Wake&shake-Modus abgeschlossen ist.
MBRAKE = 3 reserviert

ab FW >= 5.19:
MBRAKE = 4 Die Bremsenfunktion ist aktiviert aber es findet keine Überwachung des Bremsenfehlers statt.

Die Möglichen Anwendungsfälle für MBRAKE=4:
1. Der Verstärker kann mit einer Bremse betrieben werden, die sehr wenig Strom entnimmt.
2. Falls keine Bremse angeschlossen wird, so kann die Bremsenverzögerungszeit TBRAKE weiterhin genutzt werden. Über diese Zeit lässt sich das Sperren der Endstufe nach dem Stillstand verzögern. Dies wird bei den Applikationen mit nachschwingenden Lasten gebraucht.


ASCII Deutsch MCFW

ASCII - Kommando | MCFW |
Syntax Senden | MCFW [Data] |
Syntax Empfangen | MCFW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3908 (hex)
DIM | - | PROFIBUS PNU | 1832 (dec) IND = 33 (dec)
Bereich | 1 .. 2 | DPR | 1032 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Korrekturfaktor für die Feldschwächung

Beschreibung

Dieses Objekt wird nur bei MTYPE=3 (Asynchronmotor) benutzt.
Korrekturfaktor für die Feldschwächung.
Der Korrekturfaktor wurde eingeführt, um Nichtlinearitäten der magnetisierenden Induktivität durch den kleiner werdenden Magnetisierungsstrom bei steigender Drehzahl während der Feldschwächung zu kompensieren.


ASCII Deutsch MCOSPHI

ASCII - Kommando | MCOSPHI |
Syntax Senden | MCOSPHI [Data] |
Syntax Empfangen | MCOSPHI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3887 (hex)
DIM |  | PROFIBUS PNU | 1703 (dec) IND = 33 (dec)
Bereich | 0.5 .. 1 | DPR | 903 (dec)
Default | 0.8 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Leistungsfaktor (cos phi) der Asynchronmaschine

Beschreibung

Leistungsfaktor (cos phi) der Asynchronmaschine (U/f Steuerung).
Wird zur Berechnung der Nennschlupfs für die Schlupfkompensation benötigt.

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII Deutsch MCTR

ASCII - Kommando | MCTR |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch MDBCNT

ASCII - Kommando | MDBCNT |
Syntax Senden | MDBCNT |
Syntax Empfangen | MDBCNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3588 (hex)
DIM | - | PROFIBUS PNU | 1736 (dec) IND = 1 (dec)
Bereich | 1 .. 127 | DPR | 136 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Nein
Kurzbeschreibung | Anzahl der Motorsätze

Beschreibung

Das Kommando MDBCNT liefert die Anzahl der Motordatensätze die für die vorhandene Endstufe/Feedback-Kombination geladen werden können. Durch Änderung der Feedback-Einstellung FBTYPE kann erreicht werden, daß z.B. nur die Datensätze für Resolver-, bzw. Endat-Motoren berücksichtigt werden.


ASCII Deutsch MDBGET

ASCII - Kommando | MDBGET |
Syntax Senden | MDBGET [Data] |
Syntax Empfangen | MDBGET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3589 (hex)
DIM | - | PROFIBUS PNU | 1737 (dec) IND = 1 (dec)
Bereich | 1 .. MDBCNT | DPR | 137 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Nein
Kurzbeschreibung | Info-Zeile für einen Motordatensatz

Beschreibung

Das Kommando MDBGET liefert eine Informationszeile (Directory-Eintrag) für den zuletzt mit dem MDBSET-Kommando angewählten Motordatensatz. Die Informationszeile besteht aus folgenden Komponenten:
Datensatznummer, Motorname, Motornummer, Motorfamilie
Die einzelnen Komponenten haben folgende Bedeutung:
Datensatznummer: Nummer des Motordatensatzes innerhalb der Motordatenbank. Über diese Nummer kann ein Motordatensatz mit dem Kommando MDBSET adressiert werden. Mit jedem MDBGET-Aufruf wird diese Nummer automatisch erhöht.
Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)
Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER-Kommando aus der Motordatenbank zu laden.
Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)

Die Kommando-Gruppe MDBCNT,MDBSET,MDBGET kann von einer externen Steuerung benutzt werden, um das Inhaltsverzeichnis der Motordatenbank einzulesen. Die Vorgehensweise sit wie folgt:
1. Mit dem "MDBCNT"-Kommando die Anzahl der verfügbaren Datensätze einlesen.
2. Mit dem "MDBSET 1"-Kommando den Datensatzzeiger auf den ersten Datensatz setzen.
3. Mit dem "MDBGET"-Kommando den ersten Direcory-Eintrag einlesen.
4. Schritt 3 wiederholen bis die Anzahl der verfügbaren Datensätze (MDBCNT) eingelesen wurde.

Eine Alternative bietet das Kommando MDBLIST. Mit diesem Kommando kann das gesamte Inhaltsverzeichnis angezeigt werden.


ASCII Deutsch MDBLIST

ASCII - Kommando | MDBLIST |
Syntax Senden | MDBLIST [*] |
Syntax Empfangen | MDBLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Nein
Kurzbeschreibung | Inhaltsverzeichnis der Motordatenbank

Beschreibung

Mit dem Kommando MDBLIST kann das Inhaltsverzeichnis der Motordatenbank für die vorhandene Endstufen-Kombination) ausgegeben werden. Gültige Datensätze für eine Endstufe müssen im Bereich DICONT = (0.25 .. 4) * MICONT liegen.Pro Bildschirmzeile wird ein Motordatenbank-Eintrag im folgenden Format angezeigt:Motorname, Motornummer, Motorfamilie, VerstärkerbezeichnungDie einzelnen Komponenten haben folgende Bedeutung:Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER -Kommando aus der Motordatenbank zu laden.Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)Bei Einstellung " PROMPT 2" erfolgt eine formatierte Ausgabe, die besonders für die Terminaldarstellung geeignet ist.Mit dem Kommando "MDBLIST *" kann das gesamte Inhaltsverzeichnis der Motordatenbank ausgegeben werden. Im Gegensatz zu der MDBLIST-Ausgabe erscheinen in dem Inhaltsverzeichnis auch Motordatensätze die für die aktuelle Endstufe/Feedback-Kombination nicht geeignet sind.


ASCII Deutsch MDBSET

ASCII - Kommando | MDBSET |
Syntax Senden | MDBSET [Data] |
Syntax Empfangen | MDBSET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 358A (hex)
DIM | - | PROFIBUS PNU | 1738 (dec) IND = 1 (dec)
Bereich | 1 .. MDBCNT | DPR | 138 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Nein
Kurzbeschreibung | Vorwahl eines Motordatensatzes

Beschreibung

Mit dem MDBSET-Kommando kann ein bestimmter Datensatz aus der Motordatenbank adressiert werden. Das anschliessende MDBGET-Kommando liefert den Directory-Eintrag für den angewählten Motordatensatz. S. Beschreibung MDBGET.


ASCII Deutsch MDRV

ASCII - Kommando | MDRV |
Syntax Senden | MDRV [Data] |
Syntax Empfangen | MDRV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3639 (hex)
DIM |  | PROFIBUS PNU | 1913 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 313 (dec)
Default | 0 |
Opmode | all | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Anwahl der Multidrive Funktionalität

Beschreibung

Das Kommando MDRV gibt die Multidrive-Funktionalität des Verstärkers frei.

MDRV=0 Multidrive-Funktionalität (Adressbereich von ADDR 0...127)
Das SCAN-Kommando liefert immer 0 als Anzahl der angeschlossenen Stationen.

MDRV=1 Multidrive aktiv (Adressbereich von ADDR 0...63)
Das SCAN-Kommando überprüft den gültigen Adressbereich nach angeschlossenen Stationen.


ASCII Deutsch MFR

ASCII - Kommando | MFR |
Syntax Senden | MFR [Data] |
Syntax Empfangen | MFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3885 (hex)
DIM | Hz | PROFIBUS PNU | 1701 (dec) IND = 33 (dec)
Bereich | 10 .. 500 | DPR | 901 (dec)
Default | 50 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Nennfrequenz der Asynchronmaschine

Beschreibung

Nennfrequenz der Asynchronmaschine (U/f Steuerung).
Wird zur Berechnung der Nennschlupfs für die Schlupfkompensation benötigt.

s(iq) = iq * IQFILTK * s_R / (MICONT * MCOSPHI)
s_R = MFR – (MVR * MPOLES) / (60 * 2)


ASCII Deutsch MH

ASCII - Kommando | MH |
Syntax Senden | MH |
Syntax Empfangen | MH | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 358D (hex)
DIM | - | PROFIBUS PNU | 1741 (dec) IND = 1 (dec)
Bereich | - | DPR | 141 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Start der Referenzfahrt

Beschreibung

Mit dem MH-Kommando (move home) kann über die serielle Schnittstelle eine Referenzfahrt gestartet werden. Die Referenzfahrt-Art, Richtung und Geschwindigkeit werden den Parametern NREF,DREF und VREF entnommen.
Siehe auch SETREF besonders für OPMODE 1...6.


ASCII Deutsch MI2T

ASCII - Kommando | MI2T |
Syntax Senden | MI2T |
Syntax Empfangen | MI2T <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35A4 (hex)
DIM | % | PROFIBUS PNU | 1764 (dec) IND = 1 (dec)
Bereich | 0 ... 100 | DPR | 164 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Nein
Kurzbeschreibung | Motor I2T Auslastung

Beschreibung

Gibt die durchschnittliche I2T Belastung des Motors in % von MICONT wieder. Dieser Durchschnittswert ist gefiltert mit der Zeitkonstanten MTIME.


ASCII Deutsch MICONT

ASCII - Kommando | MICONT |
Syntax Senden | MICONT [Data] |
Syntax Empfangen | MICONT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358E (hex)
DIM | A | PROFIBUS PNU | 1742 (dec) IND = 1 (dec)
Bereich | 10% of DICONT, .. 2* DICONT | DPR | 142 (dec)
Default | DICONT |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor Nennstrom

Beschreibung

Dieser Parameter begrenzt den Nennstrom des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MICONT_X

ASCII - Kommando | MICONT_X |
Syntax Senden | MICONT [Data] |
Syntax Empfangen | MICONT_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3770 (hex)
DIM | A | PROFIBUS PNU | 1824 (dec) IND = 17 (dec)
Bereich | 10% of DICONT, .. 2* DICONT | DPR | 624 (dec)
Default | DICONT |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor Nennstrom

Beschreibung

siehe PARCNFG


ASCII Deutsch MIMR

ASCII - Kommando | MIMR |
Syntax Senden | MIMR [Data] |
Syntax Empfangen | MIMR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366B (hex)
DIM | A | PROFIBUS PNU | 1963 (dec) IND = 1 (dec)
Bereich | variable | DPR | 363 (dec)
Default | variable |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Sollstrom in D-Richtung

Beschreibung

Bei Benutzung einer Asynchronmaschine MTYPE = 3 wird dauerhaft ein von 0 verschiedener Strom in D-Richtung eingeprägt. MIMR legt dessen Höhe fest. Als Richtwert gilt 0,5*Nennstrom.

Minimalwert = 10% von MICONT
Maximalwert = 200% von MICONT im Sensorless-Betrieb (FBTYPE=10) ansonsten 100% von MICONT
Defaultwert = 48% von MICONT bei Asynchronmotor (MTYPE=3) ansonsten 25% von MICONT


ASCII Deutsch MIMRQ

ASCII - Kommando | MIMRQ |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch MINSUMME

ASCII - Kommando | MINSUMME |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch MIPEAK

ASCII - Kommando | MIPEAK |
Syntax Senden | MIPEAK [Data] |
Syntax Empfangen | MIPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358F (hex)
DIM | A | PROFIBUS PNU | 1743 (dec) IND = 1 (dec)
Bereich | 10% of DIPEAK, .. 2*DIPEAK | DPR | 143 (dec)
Default | DIPEAK |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor Spitzenstrom

Beschreibung

Dieser Parameter begrenzt die IPEAK-Einstellung des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MIPEAK_X

ASCII - Kommando | MIPEAK_X |
Syntax Senden | MIPEAK [Data] |
Syntax Empfangen | MIPEAK_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3771 (hex)
DIM | A | PROFIBUS PNU | 1825 (dec) IND = 17 (dec)
Bereich | 10% of DIPEAK, .. 2*DIPEAK | DPR | 625 (dec)
Default | DIPEAK |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor Spitzenstrom

Beschreibung

siehe PARCNFG


ASCII Deutsch MJ

ASCII - Kommando | MJ |
Syntax Senden | MJ [Data] |
Syntax Empfangen | MJ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 35AB (hex)
DIM | kgcm^2 | PROFIBUS PNU | 1771 (dec) IND = 1 (dec)
Bereich | 0.01 ... 1000 | DPR | 171 (dec)
Default | 3 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Massenträgheitsmoment des Motors

Beschreibung

Massenträgheitsmoment des Motors

Bei einem Linearmotor wird MJ in Kg eingegeben.


ASCII Deutsch MJ_X

ASCII - Kommando | MJ_X |
Syntax Senden | MJ [Data] |
Syntax Empfangen | MJ_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 376B (hex)
DIM | kgcm^2 | PROFIBUS PNU | 1819 (dec) IND = 17 (dec)
Bereich | 0.01 ... 1000 | DPR | 619 (dec)
Default | 3 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Massenträgheitsmoment des Motors 2

Beschreibung

siehe PARCNFG


ASCII Deutsch MJOG

ASCII - Kommando | MJOG |
Syntax Senden | MJOG |
Syntax Empfangen | MJOG | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3591 (hex)
DIM | - | PROFIBUS PNU | 1745 (dec) IND = 1 (dec)
Bereich | - | DPR | 145 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Start des Tippbetriebes

Beschreibung

Mit dem MJOG-Kommando kann über die serielle Schnittstelle der Tippbetrieb gestartet werden. Die Tippbetrieb-Geschwindigkeit wird dem Parameter VJOG entnommen (vorzeichenbehaftet).
Der Tippbetrieb kann gefahren werden, ohne vorher eine Referenzfahrt duchführen zu müssen. Die Hardware-Endschalter werden ausgewertet. Die Software-Endschalter werden ausgewertet, wenn der Referenzpunkt gesetzt ist, sonst nicht. Als Rampen werden ebenfalls die Rampen der Referenzfahrt benutzt (ACCR, DECR, VJOG).


ASCII Deutsch MKT

ASCII - Kommando | MKT |
Syntax Senden | MKT [Data] |
Syntax Empfangen | MKT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3593 (hex)
DIM | - | PROFIBUS PNU | 1747 (dec) IND = 1 (dec)
Bereich | 0.0 .. 10.0 | DPR | 147 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor KT

Beschreibung

Die Drehmomentkonstante des Motors in Nm/A.

Dieser Parameter wird bei sensorlosen Antrieben benutzt. Diese Variabele kann online kontrolliert werden über die Gleichung:

Kt = 60 * SQRT(3) * Ui / ( 2 * PI * n)

Ui Induzierte Spannung des Motors
n Aktuelle Drehzahl des Motors


ASCII Deutsch MKT_X

ASCII - Kommando | MKT_X |
Syntax Senden | MKT [Data] |
Syntax Empfangen | MKT_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 376E (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 17 (dec)
Bereich | 0.0 .. 10.0 | DPR | 622 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor KT

Beschreibung

siehe PARCNFG


ASCII Deutsch ML

ASCII - Kommando | ML |
Syntax Senden | L [Data] |
Syntax Empfangen | ML <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3577 (hex)
DIM | mH | PROFIBUS PNU | 1719 (dec) IND = 1 (dec)
Bereich | 0 .. 200 | DPR | 119 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Statorinduktivität des Motors

Beschreibung

Statorinduktivität Phase-Phase in mH.


ASCII Deutsch ML_X

ASCII - Kommando | ML_X |
Syntax Senden | L [Data] |
Syntax Empfangen | ML_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 376D (hex)
DIM | mH | PROFIBUS PNU | 1821 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 621 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Statorinduktivität des Motors

Beschreibung

siehe PARCNFG


ASCII Deutsch MLGC

ASCII - Kommando | MLGC |
Syntax Senden | MLGC [Data] |
Syntax Empfangen | MLGC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3595 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1749 (dec) IND = 1 (dec)
Bereich | 0.2 .. 1.0 | DPR | 149 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Dauerstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGC gibt die relative Verstärkung bezogen auf MLGQ bei Dauerstrom an.

MLGC = 0.8 bedeutet, dass die Verstärkung des Stromreglers bei Dauerstrom 80% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = 0 auf Strom = MICONT.


ASCII Deutsch MLGC_X

ASCII - Kommando | MLGC_X |
Syntax Senden | MLGC [Data] |
Syntax Empfangen | MLGC_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3767 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1815 (dec) IND = 17 (dec)
Bereich | 0.2 .. 1.0 | DPR | 615 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Dauerstrom

Beschreibung

siehe PARCNFG


ASCII Deutsch MLGD

ASCII - Kommando | MLGD |
Syntax Senden | MLGD [Data] |
Syntax Empfangen | MLGD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3596 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1750 (dec) IND = 1 (dec)
Bereich | 0.4 .. 1.0 | DPR | 150 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung des D-Stromreglers

Beschreibung

Der D-Anteil des Stromregler (feldbildende Komponente). Der Parameter MLGD gibt die relative Verstärkung bezogen auf MLGQ an.

MLGD = 0.6 bedeutet, dass die Verstärkung des D-Stromreglers 60% von MLGQ beträgt.


ASCII Deutsch MLGD_X

ASCII - Kommando | MLGD_X |
Syntax Senden | MLGD [Data] |
Syntax Empfangen | MLGD_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3768 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1816 (dec) IND = 17 (dec)
Bereich | 0.4 .. 1.0 | DPR | 616 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung des D-Stromreglers

Beschreibung

siehe PARCNFG


ASCII Deutsch MLGP

ASCII - Kommando | MLGP |
Syntax Senden | MLGP [Data] |
Syntax Empfangen | MLGP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3597 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1751 (dec) IND = 1 (dec)
Bereich | 0.1 .. 1.0 | DPR | 151 (dec)
Default | 0.4 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Spitzenstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGP gibt die relative Verstärkung bezogen auf MLGQ bei Spitzenstrom an.

MLGP = 0.6 bedeutet, dass die Verstärkung des Stromreglers bei Spitzenstrom 60% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = MICONT auf Strom = MIPEAK.


ASCII Deutsch MLGP_X

ASCII - Kommando | MLGP_X |
Syntax Senden | MLGP [Data] |
Syntax Empfangen | MLGP_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3769 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1817 (dec) IND = 17 (dec)
Bereich | 0.1 .. 1.0 | DPR | 617 (dec)
Default | 0.4 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Spitzenstrom

Beschreibung

siehe PARCNFG


ASCII Deutsch MLGQ

ASCII - Kommando | MLGQ |
Syntax Senden | MLGQ [Data] |
Syntax Empfangen | MLGQ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3598 (hex)
DIM | - | PROFIBUS PNU | 1752 (dec) IND = 1 (dec)
Bereich | variable | DPR | 152 (dec)
Default | variable |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Absolute Verstärkung des Stromreglers

Beschreibung

MLGQ gibt die proportionale Verstärkung des Stromreglers an. Beeinflusst auch MLGC, MLGP und MLGD KTN. Die Einheit lautet V/A

MLGQ(min) = 540 / DISCALE
MLGG(Default) = 540*1000 / DISCALE
MLGQ(max) = 540*30000 / DISCALE

DISCALE – Verstärkerabhängige Stromskalierung (kann über „M DISCALE“ abgefragt werden)

Beispiel:
SR706: max. Spitzenstrom = 18 A = 18000 mA

MLGQ(min) = 540 / 18000 = 0,3
MLGG(Default) = 540*1000 / 18000 = 30
MLGQ(max) = 540*30000 / 18000 = 900


ASCII Deutsch MLGQ_X

ASCII - Kommando | MLGQ_X |
Syntax Senden | MLGQ [Data] |
Syntax Empfangen | MLGQ_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 376A (hex)
DIM | - | PROFIBUS PNU | 1818 (dec) IND = 17 (dec)
Bereich | 3 .. 1800 | DPR | 618 (dec)
Default | 60 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Absolute Verstärkung des Stromreglers

Beschreibung

siehe PARCNFG


ASCII Deutsch MNAME

ASCII - Kommando | MNAME |
Syntax Senden | MNAME [Data] |
Syntax Empfangen | MNAME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 12 ASCII Characters | DPR | Nein
Default | Blanks |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor-Name

Beschreibung

Der Parameter MNAME steht im direkten Zusammenhang mit der Motornummer MNUMBER.
Beim Ladden eines Motordatensatzes aus der Motordatenbank (Kommando MNUMBER), wird
auch die Motorbezeichnung MNAME übernommen. Falls eine kundenspezifische Motorbezeichnung vergeben werden soll, so kann dies mit dem Kommando MNAME geschehen.
Bei Änderung des Motornamens wird die Motornummer (MNUMBER) auf 0 gesetzt (als Kennzeichen für den kundenspezifischen Motordatensatz).


ASCII Deutsch MNUMBER

ASCII - Kommando | MNUMBER |
Syntax Senden | MNUMBER [Data] |
Syntax Empfangen | MNUMBER <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3599 (hex)
DIM | - | PROFIBUS PNU | 1753 (dec) IND = 1 (dec)
Bereich | -2 .. 32767 | DPR | 153 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Laden eines Motor-Datensatzes

Beschreibung

Mit dem Kommando "MNUMBER nr" wird ein Motordatensatz (mit der Motornummer nr) aus der Motordatenbank geladen. Bei Vorgabe von "MNUMBER 0" wird kein Datensatz geladen sondern lediglich die Variable MNUMBER auf 0 gesetzt. Diese Einstellung bedeutet einen kundenspezifischen Motor-Datensatz.

Ab FW >= 5.77:
MNUMBER= -1 -> Beim Einschalten des Verstärkers werden nur die Offsetwerte aus dem Geber geladen. Die Einstellungen für MNUMBER und MPHASE werden nicht übernommen.

MNUMBER= -2 -> Beim Einschalten des Verstärkers werden die Offsetwerte sowie MPHASE aus dem Geber geladen. Die Einstellung für MNUMBER wird ignoriert.

Bemerkung:
MNUMBER=0….32767 -> Beim Einschalten des Verstärkers werden MNUMBER + MPHASE + Offsetwerte aus dem Encoder gelesen. Falls die dort abgespeicherte Motornummer (SMNUMBER) von der im Drive eingestellten Motornummer (MNUMBER) abweicht, so wird der Motordatensatz SMNUMBER aus der internen Motordatenbank geladen und eine Warnung n12 (neue Motordaten) ausgegeben. Falls die Motornummer im Geber (SMNUMBER) auf 0 gesetzt ist, so wird beim Einschalten MNUMBER ebenfalls auf 0 gesetzt und kein Motordatensatz geladen. Diese Einstellung ist für einen kundenspezifischen Motordatensatz im Verstärker reserviert.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Monitor

monitor

Alle wichtigen Betriebsparameter werden angezeigt.

Zusätzlich können Sie sich die Werte von 3 ASCII-Parametern oder Makro-Variablen (mit führendem M eingeben) Ihrer Wahl anzeigen lassen.

Regler-I²t-Auslastung | Die aktuelle, effektive Belastung wird in % vom eingestellten Verstärker Effektivstrom Irms angezeigt.
Motor-I²t-Auslastung | Die aktuelle, effektive Belastung wird in % vom eingestellten Motor Stillstandsstrom Io angezeigt.
Strom (Effektivwert) | Angezeigt wird der Betrag des aktuellen Stromzeigers in Ampere (immer positiv).
Strom D-Anteil | Angezeigt wird der Wert der Stromkomponente D (Id, Blindanteil) des Stromzeigers in Ampere.
Strom Q-Anteil | Angezeigt wird der Wert der Stromkomponente Q (Iq, Wirkanteil) des Stromzeigers in A. Das angezeigte Vorzeichen ist negativ bei generatorischem Betrieb (Motor wird gebremst).
Zwischenkreisspannung | Die vom Verstärker erzeugte DC-Zwischenkreisspannung wird in V angezeigt.
Bremsleistung | Die aktuelle Bremsleistung (gemittelt über 30 sek.) wird in W angezeigt.
Kühlkörper-Temperatur | Die Temperatur des Kühlkörpers im Servoverstärker wird in °C angezeigt.
Innentemperatur | Die Innentemperatur im Servoverstärker wird in °C angezeigt.
Widerstand des Motor-Temperaturfühlers | Bei Verwendung eines PTC Temperaturfühlers in der Motorwicklung wird der aktuelle Widerstandswert in Ohm angezeigt und damit eine Beurteilung der aktuellen Wicklungstemperatur möglich. Wird ein Thermoschalter verwendet, sind absolute Temperaturbeurteilungen nicht möglich.
Drehwinkel | Angezeigt wird der aktuelle Drehwinkel des Rotors °mech und counts bezogen auf den mechanischen Nullpunkt des Messsystems. Angezeigt wird die absolute Position innerhalb einer Umdrehung. Die Angabe in counts erfolgt hexadezimal mit 20 Bit Genauigkeit (dies bedeutet: 1 Umdrehung entspricht 220-1 counts)
Drehzahl-Istwert | Angezeigt wird die aktuelle Drehzahl des Motors in min-1
Drehzahl-Sollwert | Angezeigt wird der aktuelle Drehzahlsollwert in min-1
Position | Angezeigt wird die aktuelle Ist-Position in der eingestellten Positionseinheit
Schleppfehler | Angezeigt wird der aktuelle Ist-Schleppfehler in der eingestellten Positionseinheit
Elektrische Leistung | Aktuelle elektrische Leistung an der Motorklemme P
Mechanische Leistung | Aktuelle mechanische Leistung an der Motorwelle PMECH
Zu überwachende benutzerdefinierte Variablen | Sie können 3 Parameter Ihrer Wahl überwachen. Geben Sie dazu in die Felder ASCII-Komm. die ASCII Namen der Parameter ein.
Analog-Eingänge | Angezeigt werden die aktuellen Spannungen an den Analogeingängen in mV.
Analog-Ausgänge | Angezeigt werden die aktuellen Spannungen an den Analogausgängen in mV. Nur sichtbar mit installierter Erweiterungskarte PosI/O-Monitor.
Digitale Ein-/Ausgänge | Angezeigt werden die Zustände der digitalen Ein-/Ausgänge.

Liste der verfügbaren Makrovariablen (Auszug, mit führendem M ins Eingabefeld eingeben):

Makro Variablen (Auswahl) | Kurzbeschreibung
ERRCODE | Fehlerstatus (siehe ERRCODE)
STATCODE | Verstärkerstatus (siehe STATCODE)
TRJSTAT | Status Trajektorie (siehe TRJSTAT)
ADVAL0…15 | Analoge Eingangswerte
ADVAL0 | Cosinus Resolver
ADVAL1 | Sinus Resolver
ADVAL2 | Motorstrom Ia
ADVAL3 | Motorstrom Ib
ADVAL4 | Sinus Encoder
ADVAL5 | Cosinus Encoder
ADVAL6 | Analog Sollwert 1
ADVAL7 | Analog Sollwert 2
ADVAL8 | Motortemperatur
ADVAL9 | Kühlkörpertemperatur
ADVAL10 | Umgebungstemperatur
ADVAL11 | Sense Spannung Encoder
ADVAL12 | n.c.
ADVAL13 | Zwischenkreisspannung
ADVAL14 | n.c.
ADVAL15 | n.c.
SIENC | Sinus Encoder normalisiert +/- 1350 <> 1Vss
COENC | Cosinus Encoder normalisiert +/- 1350 <> 1Vss
SR_RXDE | Nullimpulseingang bei NREF = 5
SR_HALL | Hall Segment Eingang
PFBL | Positionsrückführung 64 Bit. Die unteren 32 Bit beinhalten die Position innerhalb einer Umdrehung, die oberen 32 Bit die Anzahl der Umdrehungen.
S_SETL | Positionssollwert 64 Bit. Die unteren 32 Bit beinhalten die Position innerhalb einer Umdrehung, die oberen 32 Bit die Anzahl der Umdrehungen.
PFB | Positionsrückführung (PRBASE definiert Format)
S_SET | Positionssollwert (PRBASE definiert Format)
S_SETH | SERCOS Positionssollwert (1 Umdrehung = 2^20)
PTARGET | Zielposition für den letzten/aktuellen Fahrauftrag (PRBASE definiert Format)
PSPEED | Aktueller Drehzahlsollwert in counts/250µsec
PSPEEDMS | Aktueller Drehzahlsollwert in counts/250µsec für Master/Slave Trajektorie
PSPEED3 | Aktueller Drehzahlsollwert für interne Fahrsatz Trajektorie
PENDSPEED | Zielgeschwindigkeitssollwert des aktuellen Fahrauftrage
MOVEP_NR | Nummer des letzten/aktuellen Fahrauftrages
NIZFLAG | Status des externen Nullimpulses
PSTOP | Status des PSTOP Endschalters
NSTOP | Status des NSTOP Endschalters
INPUT1…20 | Status der Eingänge Input 1…20
OUTPUT1...18 | Status des Ausgänge Output 1..18
HARDENA | Status des Hardware Enable
EN_P_I | Status der Endstufe (1=enabled, 0=disabled)
NET_BTBI | Status des Netz-BTB
ENABLE_I | Status des internen Enable Signals
SOFTENABLE | Status des Software Enable
EN_BRAKE_I | Status der Haltebremse (1=open, 0=closed)
PRD | Position Rückführung innerhalb einer Umdrehung
IVORCMD | Stromvorsteuerung (3280 = DIPEAK)
PBAL | Aktueller Wert Bremsleistung
SR5VINCR | Impulszähler für X5 Master / Slave (5V)
SR24VINCR | Impulszähler für X3 Master / Slave (24V)


ASCII Deutsch MONITOR1

ASCII - Kommando | MONITOR1 |
Syntax Senden | MONITOR1 [Data] |
Syntax Empfangen | MONITOR1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 359A (hex)
DIM | mV | PROFIBUS PNU | 1754 (dec) IND = 1 (dec)
Bereich | -10000 ..10000 | DPR | 154 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.75 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Monitor1-Ausgangsspannung

Beschreibung

Dieser Parameter zeigt den aktuellen Wert der Spannung am analogen Ausgang 1 der POSIO-Karte.
Bei ANOUT1=6 kann mit diesem Parameter der Ausgabe-Wert in mV vorgegeben werden.

Ab FW 3.75/5.02


ASCII Deutsch MONITOR2

ASCII - Kommando | MONITOR2 |
Syntax Senden | MONITOR2 [Data] |
Syntax Empfangen | MONITOR2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 359B (hex)
DIM | mV | PROFIBUS PNU | 1755 (dec) IND = 1 (dec)
Bereich | -10000 ..10000 | DPR | 155 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.75 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | analog I/O | EEPROM | Nein
Kurzbeschreibung | Monitor2-Ausgangsspannung

Beschreibung

Dieser Parameter zeigt den aktuellen Wert der Spannung am analogen Ausgang 2 der POSIO-Karte.
Bei ANOUT2=6 kann mit diesem Parameter der Ausgabe-Wert in mV vorgegeben werden.

Ab FW 3.75/5.02


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Motor / Feedback

Nur im Setupmodus "Schnelleinstellung" verfügbar. Vereinfachte Einstellung der motorbezogen Parameter. Die Schnelleinstellung der Regel-Parameter vereinfacht die Anpassung der Servoverstärker/Motor-Kombination an die Maschine erheblich. Spezialmotoren müssen während des "Vollständigen Setups" mit "Parameter für benutzerdefinierte Motoren" auf der Bildschirmseite "Motor" definiert werden.
Abhängig vom gewählten Motortyp (rotatorisch oder linear) differiert der Bildschirm.

Rotatorische Motoren

einheiten

Resolverpolzahl ist im Setupmodus "Schnelleinstellung" auf 2 festgelegt.

Falls erforderlich, ändern Sie die Polzahl im Setupmodus "Komplettes Setup" auf der Bildschirmseite "Feedback"

Beispiel EnDat-Rückführung: kamera .

Bildschirmtext | ASCII-Parameter
Feedback-Typ | FBTYPE
Encoder-Striche | ENCLINES (nur bei Encoder Feedback)
Motor: Aus Datenbank auswählen... | Klicken Sie auf den Button "Aus Datenbank auswählen...". Öffnen Sie die gespeicherte Datenbankdatei (mdb_ _ _.csv) und wählen Sie den verwendeten Motortyp aus der Liste.
Bremse | MBRAKE
Schnell-Einstellung der Regeleparameter | Wenn Sie das Massenverhältnis Last:Motor kennen, geben Sie die Zahl ein und wählen Sie die gewünschte Steifigkeit der Regelung. Wenn das Massenverhältnis nicht bekannt ist, wählen Sie "Einst. nicht ändern".
Massenverhältnis Last/Motor | Dieser Wert dient als Grundlage zur Ermittlung der Verstärkung im Drehzahlregler
Gewünschte Steifigkeit der Regelung | Die Kategorie der Regelqualität wird zur Ermittlung diverser Parameter im Stromregler verwendet.

Linearmotoren

einheiten6

Wenn ein Linearmotor gewählt wird, werden obige Felder angezeigt.

Bildschirmtext | ASCII-Parameter
Feedback-Typ | FBTYPE
Encoder-Striche | ENCLINES (nur bei Encoder Feedback). Klicken Sie auf "Berechnen..." um die Encoder-Striche zu berechnen
Motor: Aus Datenbank auswählen... | Klicken Sie auf den Button "Aus Datenbank auswählen...". Öffnen Sie die gespeicherte Datenbankdatei (mdb_ _ _.csv) und wählen Sie den verwendeten Motortyp aus der Liste.
Bremse | MBRAKE
Schnell-Einstellung der Regeleparameter | Wenn Sie das Massenverhältnis Last:Motor kennen, geben Sie die Zahl ein und wählen Sie die gewünschte Steifigkeit der Regelung. Wenn das Massenverhältnis nicht bekannt ist, wählen Sie "Einst. nicht ändern".
Massenverhältnis Last/Motor | Dieser Wert dient als Grundlage zur Ermittlung der Verstärkung im Drehzahlregler
Gewünschte Steifigkeit der Regelung | Die Kategorie der Regelqualität wird zur Ermittlung diverser Parameter im Stromregler verwendet.

enclines

Tragen Sie die Encoder-Signalperiode ein und klicken Sie auf "ENCLINES berechnen und schließen". Der berechnete Wert wird für den ASCII Parameter ENCLINES verwendet.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Feldschwächung

einheiten

Einstellung der Parameter für eine drehzahlabhängige Phasenvoreilung (Feldschwächung für Permanentmagnet Servomotoren). Lesen Sie hierzu auch die KDN Seite Phasenvoreilung.

Bildschirmtext | ASCII-Parameter
oberes Diagramm für AKM, VLM, Cartridge Motoren
Grad: | MVANGLF
unteres Diagramm für alle Goldline Motoren
Grad: | MVANGLP
Geschwindigkeitsschwelle | MVANGLB
V_max | VLIM
Aktiviere SR600 Kompatibilitätsmodus | MVANGLMODE

Bei Motoren anderer Hersteller erfragen Sie diese Information beim Hersteller.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Motor

einheiten

Einstellung der motorbezogen Parameter.
Im Servoverstärker gespeicherte Motordaten:
Wählen Sie in der Auswahlliste Motor-Familie den verwendeten Motortyp und beschränken Sie damit die Anzeige der Einzelmotoren auf eine Motorfamilie. Wählen Sie nun Ihren Motor im Feld Nummer-Name.

Extern in einer Datei gespeicherte Motordaten:
Wählen Sie einen Motor aus einer externen Datenbankdatei (Schaltfläche "Motor aus Datenbank auswählen"). Sollte Ihr Motor nicht in der Datenbank enthalten sein, geben Sie die Parameter für einen benutzerdefinierten Motor selbst ein.

Die angezeigten Parameter sind nicht editierbar. Wenn Sie einzelne Daten ändern wollen, verwenden Sie die Schaltfläche "Parameter für benutzerdefinierte Motoren".

Bildschirmtext | ASCII-Parameter
Motor-Typ | MTYPE
Io | MICONT
Iomax | MIPEAK
El. therm. Zeitkonstante | Feste, motorabhängige Konstante
Grenzdrehzahl | MSPEED
Motorfamilie | Auswahl einer im Verstärker gespeicherten Motorfamilie
Nummer - Name | MDBLIST
Polzahl | MPOLES,
L | ML
Stator-Wicklungswiderstand | MRS
Bremse | MBRAKE
Polpaarbreite | MPITCH (nur bei Motortyp Linear-Synchronmotor)

Motor aus Datenbank auswählen

einheiten5

Öffnen Sie die angezeigt Motordatenbank (meist im CSV Format).

einheiten51

Sie erhalten nun alle vorhandenen Motordatensätze in der Motordatenbank angezeigt. Über die beiden Auswahlfelder oben können Sie Filter setzen, um die Zahl der angezeigten Motortypen zu reduzieren. Wählen Sie den für Sie zutreffenden Datensatz an. Sie können sich die Daten anzeigen lassen und sie prüfen. Betätigen der Schaltfläche "Auswählen und schließen" übernimmt die Parameter in den aktuellen Datensatz der Inbetriebnahmesoftware.

Parameter für benutzerdef. Motor

Bildschirmtext | ASCII-Parameter
Motor-Typ | MTYPE
Linearmotor-Bauart | (nur bei Motortyp Linear-Synchronmotor)
Motor-Name | MNAME
Dauerstrom | MICONT
Spitzenstrom | MIPEAK
Grenzdrehzahl | MSPEED
Motor-Polzahl | MPOLES
Polpaarbreite | MPITCH (nur bei Motortyp Linear-Synchronmotor)
Motor-Drehmomentkonstante (Kraftkonstante bei Linearmotoren) | MKT
L, Leiter-Leiter | ML
Stator-Wicklungswiderstand | MRS
Motor-Trägheitsmoment (Masse bei Linearmotoren) | MJ
Bremse | MBRAKE
Disable-Verzögerung (Bremse) | TBRAKE
Enable-Verzögerung (Bremse) | TBRAKE0
Thermistor Switch-off Treshold | MAXTEMPM
Feedback-Typ | FBTYPE
Max. allowed line voltage | VBUSBAL

Hinweise für die Parameterermittlung eines unbekannten Motors siehe Applikationshinweis Tuning eines unbekannten Motors.
Hinweise für den sensorlosen Betrieb von Asynchronmotoren siehe Applikationshinweis Asynchronmaschine - U/f Steuerung.
Hinweise für den Betrieb von Gleichstrommotoren siehe Applikationshinweis Inbetriebnahme DC Motoren.

KTY Support

Wenn im verwendeten Motor ein KTY Temperatursensor eingebaut ist, klicken Sie auf die Schaltfläche "KTY-Support aktivieren". Der Servoverstärker kann die absolute Temperatur an der Messstelle erkennen, wenn er die Kennlinie des Sensors kennt. Mit 10 Punkten kann jede Sensorkennlinie ausreichend genau nachgebildet werden. In der Auswahlliste sind die typischen Kollmorgen KTY Typen bereits eingetragen. Wählen Sie den KTY Typ und Klicken Sie auf "Ausw. Laden". Die gespeicherten Werte werden in die Kennlinientabelle übertragen.

Wenn der KTY Typ Ihres Motors nicht in der Liste enthalten ist, können Sie 10 Punkte seiner Kennlinie in die Tabelle eintragen und die Einstellungen mit der Schaltfläche "Einst. speichern unter..." abspeichern.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Cogging / Rastmoment Kompensation

einheiten

Die Funktion generiert eine Tabelle mit Stromvorsteuerwerten zur Cogging (Rastmoment) Kompensation und aktiviert die Kompensation. Dabei wird für die Einstellung zwischen linearen und rotatorischen Motoren unterschieden.

Voraussetzung:
Ein Referenzpunkt muss eingestellt sein (Einrichtbetrieb). Für den korrekten Betrieb muss sichergestellt werden, dass sich der Referenzpunkt immer an derselben Position befindet wie während der Erstellung der Stromvorsteuertabelle.

Wählen Sie zunächst den Cogging Modus (Antriebstyp) und geben Sie dann die Werte für die Messfahrt ein.

Während der Messfahrt bewegt sich die Last. Stellen Sie sicher, dass der Verfahrweg frei und gesichert ist.

Nach Ende der Messfahrt bleibt die Achse Enabled.

Klicken auf die Schaltfläche "Starte Messfahrt" startet die Messfahrt.
Detaillierte Informationen zum angewendeten Verfahren finden Sie auf der KDN Seite Rastmoment Unterdrückung.

Bildschirmtext | ASCII-Parameter
Deaktiviert | COGMODE
Linear Motor | COGMODE (256 Messpunkte)
Rotatorischer Motor | COGMODE (256 Messpunkte)
Hochauflösende Tabellen | COGMODE (4096 Messpunkte)
Geschwindigkeit | CALCCOG
Filter | COGFILT
Startposition | CALCCOG
Distanz | CALCCOG
Hilfe | Öffnet die KDN Seite Rastmoment Unterdrückung.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Inbetriebnahme unbekannter Motoren

Auch ohne bekannte Motor-/Feedbackdaten können Sie den Antrieb parametrieren. Die Beschreibung geht davon aus, dass Sie alle Parameter im Terminalfenster einstellen (Befehle sind kursiv dargestellt).

Schritte 1...8: Ohne angekoppelte Last (Motorwelle muss zugänglich sein)

Schritt | Analysieren/Einstellen | Beschreibung
1 | mit / ohne Haltebremse | Kann die Motorwelle von Hand gedreht werden (ohne Getriebe und Last)? => Nein: prüfen, ob Bremsadern am Verstärker angeschlossen sind, MBRAKE 1 => Ja: MBRAKE 0
2 | Richtung der Rückführeinheit | Bildschirmseite Feedback öffnen (vollständiges Setup) Die Motorwelle im Uhrzeigersinn (Blick auf die Welle) mit der Hand drehen Symbol rotiert im Uhrzeigersinn => OK Symbol rotiert gegen den Uhrzeigersinn => zwei Signalleitungen der Rückführeinheit vertauschen, z.B. SIN+ and SIN-.
3 | Resolver Polpaarzahl/ Encoder Enclines | Bildschirmseite Feedback öffnen (vollständiges Setup) Die Motorwelle im Uhrzeigersinn (Blick auf die Welle) mit der Hand drehen Prüfen: Eine Umdrehung der Motorwelle = eine Umdrehung des Symbols J => OK Nein => Resolver: MRESPOLES ändern / Encoder: ENCLINES ändern und erneut prüfen
4 | Motor-Polpaarzahl | OPMODE 2 MPOLES 0 Leistungsspannung einschalten, AS-Enable anlegen, HW-Enable anlegen EN T 0.3 Die Motorwelle nimmt eine Vorzugsstellung ein. Die Motorwelle mit der Hand drehen. Zählen Sie die Rastmomente in einer Umdrehung (x=Schritte/Umdr.), jedes Rasten entspricht einem Polpaar. MPOLES x
5 | Kommutierungswinkel | Gefahr! Die Motorwelle nicht mehr berühren! Mit dem Kommando Zero wird der Winkel-Offset ermittelt. OPMODE 2 EN ZERO ZERO ZERO SAVE HSAVE ( Nur bei ENDAT- und HIPERFACE-Encodern)
6 | Kommutierungsrichtung | OPMODE 2 EN T 0.1 T 0.2 T 0.3 ... T 0.n ... bis die Motorwelle langsam rotiert im Uhrzeigersinn => OK gegen den Uhrzeigersinn => zwei Motorleitungen tauschen, z.B. U2<->V2.
7 | Smith Predictor | Messen Sie die Phase-Phase Werte von Wicklungswiderstand (x in Ohm) und Wicklungsinduktivität (y in mH) des Motors oder nehmen Sie die auf dem Typenschild genannten Werte. MRS x ML y K FILTMODE 2 SAVE COLDSTART
8 | Proportionale Verstärkung im Stromregler | OPMODE 2 EN CTUNE

Schritte 9...14: Mit angekoppelter Last

0danger - color
Die Motorwelle wird sich drehen, die angekoppelte Last wird bewegt. Verletzungsgefahr.
Bevor Sie fortfahren: Gegenstände aus dem Verfahrweg entfernen! Dann nicht mehr in den Verfahrweg hineingreifen!

Schritt | Analysieren/Einstellen | Beschreibung
9 | Feineinstellung der Rückführeinheit (nur in hochpräzisen Systemen erforderlich) | OPMODE 0 EN CALCRK CALCHP
10 | Observer tuning | OPMODE 0 EN OTUNE
11 | Proportionale Verstärkung im Drehzahlregler | OPMODE 0 GVTN 0 EN STEP 500 50 500 –50 Bildschirmseite Oszilloskop öffnen. Verhalten des Geschwindigkeits- Istwertes bei Sollwertsprung optimieren. Ändern Sie dazu GV in 20% Schritten bis der Istwert optimal dem Sollwert folgt: GV 1 GV 1.2 GV 1.4 ...
12 | Integrale Verstärkung im Drehzahlregler | OPMODE 0 GVTN 30 EN STEP 500 50 500 –50 Bildschirmseite Oszilloskop öffnen. Verhalten des Geschwindigkeits- Istwertes bei Sollwertsprung optimieren. Ändern Sie dazu GVTN in 20% Schritten bis der Istwert optimal dem Sollwert folgt: GVTN 30 GVTN 25 GVTN 20 ...
13 | Bode Plot | Prüfen der Applikation auf Resonanzschwingungen (siehe Bildschirmseite Bode Plot).
14 | Proportionale Verstärkung im Lageregler | Definieren Sie zwei Fahrsätze mit entgegengesetzter Richtung und gleicher Fahrstrecke (ein Auftrag startet den anderen) OPMODE 8 EN MOVE X Bildschirmseite Oszilloskop öffnen. Minimieren Sie den Schleppfehler durch Ändern von GP in 20% Schritten GP 0.1 GP 0.15 GP 0.2 … SAVE

Asynchronmaschine - U/f Steuerung

Einfacher sensorloser Betrieb von Asynchronmotoren (U/f Steuerung). Hinweise zum Setup finden Sie im KDN.

Gleichstrommotor

Standard Gleichstrommotoren (mit Bürsten) können auch mit dem Servoverstärker betrieben werden. Dazu muss der Motortyp entsprechend eingestellt und die richtigen Anschlussklemmen verwendet werden. Hinweise zum Setup finden Sie im KDN.


ASCII Deutsch MOVE

ASCII - Kommando | MOVE |
Syntax Senden | MOVE [Data] |
Syntax Empfangen | MOVE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3642 (hex)
DIM | - | PROFIBUS PNU | 1922 (dec) IND = 1 (dec)
Bereich | 0 ... 300 | DPR | 322 (dec)
Default | 0 |
Opmode | 4, 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Starten eines Fahrsatzes

Beschreibung

Das Kommando "MOVE nr" startet den Fahrsatz "nr" aus dem Fahrsatzspeicher.
Falls das Kommando ohne Parameter benutzt wird, so wird die zuletzt gestartete Fahrsatznummer angezeigt.


ASCII Deutsch MPHASE

ASCII - Kommando | MPHASE |
Syntax Senden | MPHASE [Data] |
Syntax Empfangen | MPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 359C (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1756 (dec) IND = 1 (dec)
Bereich | 0 .. 360 | DPR | 156 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Phasenoffset zwischen Feedback und Motorwicklung

Beschreibung

Der Parameter Motorphase wird je nach eingesetzter Rückführeinheit (FBTYPE) unterschiedlich gehandhabt.
FBTYPE=0 Resolver
MPHASE wird im seriellen EEPROM des Verstärkers gespeichert (Kommando SAVE) und nach jedem Einschalten des Verstärkers übernommen.

FBTYPE=2,4 Hiperface/Endat
MPHASE wird im EEPROM des Gebers abgelegt (Kommando HSAVE) und nach jedem Einschalten des Verstärkers aus dem Geber eingelesen. Beim Tausch eines Gebers wandert die MPHASE-Einstellung mit dem Geber mit. Beim Einsatz eines neuen Gebers muß der MPHASE-Wert neu ermittelt und in dem Geber abgespeichert werden (HSAVE Kommando).

FBTYPE=7 sinus/cosinus-Geber ohne internes EEPROM

MPHASE wird beim ersten Freigeben der Endstufe automatisch ermittelt (Wake & Shake)
Es gibt keine Notwendigkeit den MPHASE-Wert zu ermitteln bzw. abzuspeichern.


ASCII Deutsch MPHASE2

ASCII - Kommando | MPHASE2 |
Syntax Senden | MPHASE2 [Data] |
Syntax Empfangen | MPHASE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3536 (hex)
DIM | - | PROFIBUS PNU | 1654 (dec) IND = 1 (dec)
Bereich | 0 ... 359, 1000 | DPR | 54 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 6.35 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV |
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Kommutierungsfeinabstimmung

Beschreibung

Mit dem Parameter MPASE2 <= 359 wird eine Funktion aktiviert, bei der am Ende einer Referenzfahrt die MPHASE-Einstellung durch MPHASE2 überschrieben wird. Diese Funktion kann benutzt werden um eine grobe MPHASE-Einstellung, die durch die Wake&Shake-Funktion gefunden wurde, durch eine genauere zu ersetzen.

Mit dem WERT MPHASE2 1000 wird diese Funktion abgeschaltet.


ASCII Deutsch MPITCH

ASCII - Kommando | MPITCH |
Syntax Senden | MPITCH [Data] |
Syntax Empfangen | MPITCH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 351E (hex)
DIM | um | PROFIBUS PNU | 1630 (dec) IND = 1 (dec)
Bereich |  | DPR | 30 (dec)
Default | 32000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 0.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Linearmotor - Polpaarbreite

Beschreibung

Das Kommando MPITCH definiert die Polpaarbreite bei einem Linearmotor.


ASCII Deutsch MPKD

ASCII - Kommando | MPKD |
Syntax Senden | MPKD [Data] |
Syntax Empfangen | MPKD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3870 (hex)
DIM | - | PROFIBUS PNU | 1680 (dec) IND = 33 (dec)
Bereich | - | DPR | 880 (dec)
Default | 10000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | D-Anteil für die Kommutierungsermittlung

Beschreibung

D-Anteil für die Kommutierungsermittlung mit PID Positionsregler (CALCMP)


ASCII Deutsch MPKI

ASCII - Kommando | MPKI |
Syntax Senden | MPKI [Data] |
Syntax Empfangen | MPKI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3871 (hex)
DIM | - | PROFIBUS PNU | 1681 (dec) IND = 33 (dec)
Bereich | - | DPR | 881 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | PID - Positionsregelung zur Kommutierungsfindung

Beschreibung

I- Anteil der PID - Positionsregelung zur Kommutierungsfindung CALCMP


ASCII Deutsch MPKP

ASCII - Kommando | MPKP |
Syntax Senden | MPKP [Data] |
Syntax Empfangen | MPKP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3872 (hex)
DIM | - | PROFIBUS PNU | 1682 (dec) IND = 33 (dec)
Bereich | - | DPR | 882 (dec)
Default | 600 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | PID - Positionsregelung zur Kommutierungsfindung

Beschreibung

P- Anteil der PID - Positionsregelung zur Kommutierungsfindung CALCMP


ASCII Deutsch MPOLES

ASCII - Kommando | MPOLES |
Syntax Senden | MPOLES [Data] |
Syntax Empfangen | MPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 359D (hex)
DIM | Poles | PROFIBUS PNU | 1757 (dec) IND = 1 (dec)
Bereich | 0, 2, 4, 6, .. , 256 | DPR | 157 (dec)
Default | 6 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Anzahl der Motorpole

Beschreibung

Anzahl der Motorpole pro Umdrehung des Motors. MPOLES = 0 wird nicht mehr im Regler gespeichert und auch nicht bei der MMI angezeigt.

Linear Motor:
Die Standardeinstellung für Linear Motore ist MPOLES = 2.

Bei allen geberlosen Betriebsarten (FBTYPE=10,11) wird die Ausgangsfrequenz auf 599 Hz begrenzt. Daraus ergibt sich folgende Limitierung der maximalen Drehzahl (in UPM): MSPEED(max) = 599Hz*60 / (MPOLES/2)
Falls Ihre Applikation eine höhere Ausgangsfrequenz benötigt, kontaktieren Sie bitte unseren Support.

Diese Variable ist unter bestimmten Voraussetzungen als eine Konfigurationsvariable zu sehen. Nur das Setzen des Wertes auf 0 kann bei freigegebener Endstufe erfolgen. Alle anderen Änderungen dürfen nur bei gesperrter Endstufe durchgeführt werden.

Bei diesen Parametern entscheidet der Verstärker, ob ein COLDSTART notwendig ist. Die MPOLES-Änderung von dem letzten Wert nach dem COLDSTART auf 0 bzw. zurück erfordert keinen COLDSTART, sonst ist ein COLDSTART erforderlich (z.B. von 6 auf 8).


ASCII Deutsch MPOLES_X

ASCII - Kommando | MPOLES_X |
Syntax Senden | MPOLES [Data] |
Syntax Empfangen | MPOLES_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3766 (hex)
DIM | Poles | PROFIBUS PNU | 1814 (dec) IND = 17 (dec)
Bereich | 0, 2, 4, 6, .. , 256 | DPR | 614 (dec)
Default | 6 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Anzahl der Motorpole

Beschreibung

siehe PARCNFG, MPOLES

Diese Variable ist unter bestimmten Voraussetzungen als eine Konfigurationsvariable zu sehen. Nur das Setzen des Wertes auf 0 kann bei freigegebener Endstufe erfolgen. Alle anderen Änderungen dürfen nur bei gesperrter Endstufe durchgeführt werden.

Bei diesen Parametern entscheidet der Verstärker, ob ein COLDSTART notwendig ist. Die MPOLES_X Änderung von dem letzten Wert nach dem COLDSTART auf 0 bzw. zurück erfordert keinen COLDSTART, sonst ist ein COLDSTART erforderlich (z.B. von 6 auf 8).


ASCII Deutsch MPR

ASCII - Kommando | MPR |
Syntax Senden | MPR [Data] |
Syntax Empfangen | MPR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | W | PROFIBUS PNU | -
Bereich | 100 .. 10000 | DPR | Nein
Default | 500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Nennausgangsleistung des Motors

Beschreibung

Nennausgangsleistung des Motors

Wird zur Berechnung von MTR verwendet


ASCII Deutsch MPTIME

ASCII - Kommando | MPTIME |
Syntax Senden | MPTIME [Data] |
Syntax Empfangen | MPTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3873 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 33 (dec)
Bereich | - | DPR | 883 (dec)
Default | 500 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | Ausrichtzeit für die Kommutierungsfindung

Beschreibung

Ausrichtzeit für die Kommutierungsfindung beim PID Positionsregelkreis (CALCMP)


ASCII Deutsch MRESBW

ASCII - Kommando | MRESBW |
Syntax Senden | MRESBW [Data] |
Syntax Empfangen | MRESBW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A0 (hex)
DIM | Hz | PROFIBUS PNU | 1760 (dec) IND = 1 (dec)
Bereich | 50 .. 2000 | DPR | 160 (dec)
Default | 300 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Resolver-Bandbreite

Beschreibung

MRESBW ist ein Parameter des Luenberger Beobachters und bestimmt die Bandbreite in Hz (Resolver Digital Konverter). Ein hoher Wert (>800 Hz) ergibt ein schnelles (geringe Phasenverschiebung) durch Rauschen gestörtes Signal. Ein niedriger Wert (< 400 Hz) resultiert in einem langsameren (höhere Phasenverschiebung) aber weniger gestörtem Signal. Der Standardwert von 600 Hz ist ein Kompromiß zwischen Störungen und Phasenverschiebung.
Für sensorlose Antriebe wird der Luenberger Beobachter als adaptiver Controller benutzt. MRESBW ist dann die Bandbreite des adaptiven Controllers. Werte sollten dann zwischen 25 und 100 Hz liegen.


ASCII Deutsch MRESPOLES

ASCII - Kommando | MRESPOLES |
Syntax Senden | MRESPOLES [Data] |
Syntax Empfangen | MRESPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A1 (hex)
DIM | - | PROFIBUS PNU | 1761 (dec) IND = 1 (dec)
Bereich | 2, 4, .. 32 | DPR | 161 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl der Resolverpole

Beschreibung

Anzahl der Resolverpole (Multispeed-Resolver) pro Umdrehung.


ASCII Deutsch MRS

ASCII - Kommando | MRS |
Syntax Senden | MRS [Data] |
Syntax Empfangen | MRS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3686 (hex)
DIM | Ohms | PROFIBUS PNU | 1990 (dec) IND = 1 (dec)
Bereich | 0 .. 200 | DPR | 390 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Wicklungswiderstand des Stators Phase-Phase

Beschreibung

Wicklungswiderstand des Stators Phase-Phase in Ohm.


ASCII Deutsch MRS_X

ASCII - Kommando | MRS_X |
Syntax Senden | MRS [Data] |
Syntax Empfangen | MRS_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 376C (hex)
DIM | Ohms | PROFIBUS PNU | 1820 (dec) IND = 17 (dec)
Bereich | 0 .. 200 | DPR | 620 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Wicklungswiderstand des Stators Phase-Phase

Beschreibung

siehe PARCNFG


ASCII Deutsch MSERIALNO

ASCII - Kommando | MSERIALNO |
Syntax Senden | MSERIALNO [Data] |
Syntax Empfangen | MSERIALNO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36A3 (hex)
DIM | - | PROFIBUS PNU | 2019 (dec) IND = 1 (dec)
Bereich | Long Int | DPR | 419 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | Motorseriennummer bei Encoder mit Parameterkanal

Beschreibung

Mit dem Kommando MSERIALNO kann die Motor-Seriennummer eingegeben werden.
Wird anschließend das Kommando HSAVE eingegeben, so wird diese Nummer in dem seriellen EEPROM des SinCos-Gebers abgespeichert.
Über MSERIALNO kann auch die Seriennummer eines angeschlossenen Motors ausgelesen werden.
Das Kommando MSERIALNO kann nur bei angeschlossenem SinCos-Geber mit Parameterkanal (EnDat oder Hiperface) benutzt werden.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Service-Funktionen

Sorgen Sie dafür, dass die aktuelle Position der Last die nachfolgenden Positioniervorgänge zulässt. Die parametrierten Software-Endschalter sind je nach Betriebsmodusunwirksam. Die Achse fährt eventuell auf den Hardware-Endschalter bzw. auf den mechanischen Anschlag. Es besteht die Gefahr von Beschädigungen.

Beachten Sie die Anforderungen an "sichere reduzierte Geschwindigkeit" für Ihre Anwendung!

einheiten

Sie können hier den Antrieb mit konstanter Geschwindigkeit verfahren (Tippbetrieb). Bei gedrückter Schaltfläche (+ oder –) fährt der Antrieb mit der eingestellten Geschwindigkeit, er stoppt beim Loslassen der Schaltfläche.

Drehzahl digital (Test der Parameter im Drehzahlregler)

Tippbetrieb im drehzahlgeregelten Modus (OPMODE 0).

plus positive Drehzahl

minus negative Drehzahl

Geben Sie die gewünschte Drehzahl ein (Maßeinheit: Drehzahl im Drehzahlregler)

Position Fahrsätze Test der Parameter im Lageregler

Tippbetrieb im lagegeregelten Modus (OPMODE 8)

positive Verfahrgeschwindigkeit

negative Verfahrgeschwindigkeit

Geben Sie die gewünschte Geschwindigkeit ein (Maßeinheit: Geschwindigkeit im Lageregler)


ASCII Deutsch MSG

ASCII - Kommando | MSG |
Syntax Senden | MSG [Data] |
Syntax Empfangen | MSG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A2 (hex)
DIM | - | PROFIBUS PNU | 1762 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 162 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | RS232-Ausgabe der Warnungen/Fehlermeldungen

Beschreibung

Bei der Einstellung "MSG 2" wird beim Einschalten des Verstärkers (Initialisierungsphase) die Ausführung der einzelnen Initialisierungsschritte über die serielle Schnittstelle gemeldet. Diese Einstellung sollte nur zu Testzwecken (Inbetriebnahmephase) vorgenommen werden. Da das PC-Bedienprogramm grundsätzlich mit der Einstellung "MSG 1" arbeitet, kann die Einstellung "MSG 2"
nur mit Hilfe eines Terminalprogrammes vorgenommen werden (nicht im Terminalfenster des Bedienprogrammes).


ASCII Deutsch MSLBRAKE

ASCII - Kommando | MSLBRAKE |
Syntax Senden | MSLBRAKE [Data] |
Syntax Empfangen | MSLBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3671 (hex)
DIM | - | PROFIBUS PNU | 1969 (dec) IND = 1 (dec)
Bereich | 1 .. 32 | DPR | 369 (dec)
Default | 8 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Ja
Kurzbeschreibung | Bremsrampe bei sensorlosem Nothalt

Beschreibung

Bei Ausfall einer Feedback-Einheit (Fehler F04, F08, F25) ist es nicht mehr möglich den Antrieb über die Drehzahlregelung anzuhalten (mit einer definierten Rampe).
In diesem Fall wird versucht über die Stromregelung den Antrieb zum Stillstand zu bringen. Die Drehzahlrampe die sich bei dieser Nothalt-Situation ergibt, hängt von mechanischen Gegebenheiten (Last, Reibung) ab.
Mit dem Kommando MSLBRAKE (Motor sensorles brake) kann die Steigung dieser Rampe
in bestimmten Grenzen beeinflußt werden (je kleiner der Faktor um so länger die Bremsphase).


ASCII Deutsch MSPEED

ASCII - Kommando | MSPEED |
Syntax Senden | MSPEED [Data] |
Syntax Empfangen | MSPEED <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35A3 (hex)
DIM | rpm | PROFIBUS PNU | 1763 (dec) IND = 1 (dec)
Bereich | 0.0 .. 12000.0 | DPR | 163 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Motor Maximaldrehzahl

Beschreibung

Die Einstellung MSPEED stellt die obere Grenze für folgende Verstärkerparameter: VLIM, VLIMN,
5/6 * VOSPD.

Bei allen geberlosen Betriebsarten (FBTYPE=10,11) wird die Ausgangsfrequenz auf 599 Hz begrenzt. Daraus ergibt sich folgende Limitierung der maximalen Drehzahl (in UPM): MSPEED(max) = 599Hz*60 /(MPOLES/2)
Falls Ihre Applikation eine höhere Ausgangsfrequenz benötigt, kontaktieren Sie bitte unseren Support.

Einzelheiten sind beim Parameter VUNIT erklärt.


ASCII Deutsch MTAB

ASCII - Kommando | MTAB |
Syntax Senden | MTAB [Data] |
Syntax Empfangen | MTAB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | Ohm | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Eingabe der KTY-Kennlinie

Beschreibung

Mit der Syntax: MTAB Temp1 R1 Temp2 R2…Temp10 R10 wird die KTY-Kennlinie definiert

Temp1..10 : Temperatur in beliebigen Einheiten X
R1...R10: Widerstand in Ohm

Die Anzahl der Stützpunkte für die Temperaturkennlinie muss zwischen 2 und 10 liegen. Intern findet eine lineare Interpolation zwischen den Stützpunkten statt. Um die Kennlinie zu löschen, sollte die Form MTAB 0 0 benutzt werden.

Bei einer nichtvorhandenen Kennlinie liefert das Kommando MTAB keine Werte. Falls die Kennlinie nicht definiert ist, so wird die Temperaturanzeige TEMPM und die Temperaturfehlerschwelle MAXTEMPM als Widerstand in Ohm angezeigt.

Bei vorhandener Kennlinie MTAB ändern sich die Einheiten für die Parameter MAXTEMPM und TEMPM von Ohm auf Einheit X

siehe auch: TEMPM und MAXTEMPM


ASCII Deutsch MTANGLP

ASCII - Kommando | MTANGLP |
Syntax Senden | MTANGLP [Data] |
Syntax Empfangen | MTANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A5 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1765 (dec) IND = 1 (dec)
Bereich | 0 .. 45 | DPR | 165 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Stromvoreilung

Beschreibung

Stromabhängige Phasenvoreilung zur Ausnutzung des Reluktanz-Drehmomentes.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Fahraufträge

Übersicht

fahrsatz1

Für die einzelnen Positionieraufgaben müssen Sie Fahraufträge definieren. Diese Fahraufträge sind über eine Fahrauftragsnummer anwählbar und im Verstärker gespeichert.

Fahrauftrag Nr. | Speicherort | Voraussetzung | Bemerkung
1...200 | EEPROM | Endstufe disabled | permanent gespeichert
201...300 | RAM | keine | flüchtig

Beim Einschalten des Servoverstärkers werden die RAM-Fahrsätze 201...300 mit den Parametern der EEPROM-Fahrsätze 1...100 automatisch vorbelegt.

Alle Fahraufträge werden in Tabellenform dargestellt. Alle Fahrauftragsparameter lassen sich über die Tabelle direkt eingeben. Für die Bearbeitung stehen die üblichen Windows Funktionen (Ausschneiden, Kopieren, Einfügen, Löschen) zur Verfügung.

Die Zwischenablage-Operationen Ausschneiden, Kopieren und Einfügen sind nur zeilenweise möglich. Das Löschen ist sowohl zeilen- als auch zellenweise möglich. Eine Zeile kann entweder durch einen Mausklick auf die Zeilennummer markiert werden, oder aber durch die Tastenkombination <Shitft>+<Space> (analog zu Microsoft Excel).

Ein Doppelklick auf eine Zeilennummer in der Tabelle oder Anklicken der Schaltfläche "Bearbeiten" öffnet die Bildschirmseite für den zugehörigen Fahrauftrag.

Beim Start des Fahrsatzes wird der SW-Enable automatisch gesetzt. Der Fahrsatz wird nur gestartet bei OPMODE 8 und gesetztem Referenzpunkt (Einrichtbetrieb). Der SW-Enable wird jedoch bei allen OPMODES gesetzt. Daher kann der Antrieb mit einem anliegenden analogen Sollwert beschleunigen, wenn der START Befehl bei OPMODE 1 oder 3 ausgeführt wird.
Der Fahrsatz wird nicht gestartet, wenn die Zielposition außerhalb der definierten SW-Endschalter liegt (Warnmeldungen n06/n07 und n08)

Bearbeiten

einheiten2

Nummer

Anzeige des aktuellen Fahrauftrags zur Bearbeitung.

Trajektorie / Profil (O_C)

Legt fest, welche Art der Beschleunigungs- bzw. Bremsrampe bei Ausführung eines Fahrauftrages benutzt werden soll. Je nach verwendeter Kurvenform ist eine höhere Spitzenbelastbarkeit des Servoverstärkers erforderlich (siehe KDN Seite Fahrprofiltabellen). Das dargestellte Profil ändert sich entsprechend der Auswahl.

Trapez | Der Antrieb wird linear mit einer konstanten Beschleunigung auf die Zielgeschwindigkeit beschleunigt bzw. abgebremst.
Tabelle | Die Beschleunigungs- und Bremsrampe können über ein vorher im Servoverstärker hinterlegtes Kundenprofil eingestellt werden.
Beschl.(Sinus²) | Der Antrieb wird zur Begrenzung des Rucks mit einer stetigen Beschleunigungsrampe innerhalb der Beschleunigungszeit auf die Zielgeschwindigkeit beschleunigt bzw. wieder abgebremst. Der sich daraus ergebende Geschwindigkeitsverlauf entspricht einer sinus²-Kurve. Das Profil dieses Verlaufs ist im Servoverstärker als Tabelle hinterlegt.

Tabellen- / Beschl.- Nr. (O_TAB)
Auswahl eines Geschwindigkeitsprofils aus der mit Trajektorie angewählten Tabelle. Nähere Informationen zu diesem Themenbereich finden Sie auf KDN Seite Fahrprofiltabellen.

Integrierte Tabellen:

IPx= Ipeak Faktor x: Kurvenform erfordert x% höheren Spitzenstrom des Servoverstärkers
I2tx= I2t Faktor y: Kurvenform erfordert y% höheren Nennleistung des Servoverstärkers/Motors

rot: P_cmd (Lage-Sollwert)
grün: v_cmd (Geschwindigkeits-Sollwert)
blau: I_cmd (Drehmoment-Sollwert)

0 | IPx 157% I2tx 123% | profil0
1 | IPx 200% I2tx 150% | profil1
2 | IPx 132% I2tx 115% | profil2
3 | IPx 113% I2tx 106% | profil3
4...15 | nicht belegt | Kundenspezifische Tabellen mit insgesamt 4000 Stützpunkten möglich (siehe KDN Seite Erstellen von Fahrprofiltabellen).

v_soll (O_V)
Dieser Parameter bestimmt die Verfahrgeschwindigkeit bei digitaler Sollwertvorgabe. Wird v_max zu einem späteren Zeitpunkt auf einen Wert kleiner als v_soll reduziert, verwendet der Lageregler den kleineren Wert.

Analog-In 1
Analoge Sollwertvorgabe am Eingang ANALOG IN1 (Skalierung wird gem. der Einstellung auf der Seite "I/O-analog" benutzt). Der Wert wird beim Start des Fahrauftrages übernommen

Beschl.-Rampe (O_ACC)
Dieser Parameter bestimmt die Rampensteilheit der Beschleunigung abhängig von der gewählten Einheit.

Brems-Rampe (O_DEC)
Dieser Parameter bestimmt die Rampensteilheit der Abbremsung abhängig von der gewählten Einheit.

Art (O_C)

Mit dieser Auswahl wird festgelegt, ob der Fahrauftrag als Relativ- oder Absolutauftrag zu interpretieren ist.

ABS | eine Fahrt zu einem absoluten Zielpunkt bezogen auf den Referenzpunkt.
REL soll | relativ zur letzten Ziel(-Soll-)position (in Verbindung mit Fahrsatzumschaltung: z.B. Summierbetrieb)
REL ist | relativ zur Ist-Position beim Start (in Verbindung mit Fahrsatzumschaltung: z.B. Druckmarkensteuerung)
REL In-Pos | wenn die Last im InPositions-Fenster steht: - relativ zur letzten Zielposition wenn die Last nicht im InPositions-Fenster steht: - relativ zur Istposition beim Start
REL Latch pos. | Sprechen Sie mit unserer Applikationsabteilung
REL Latch neg. | Sprechen Sie mit unserer Applikationsabteilung

Zielposition/Verfahrstrecke (O_P)
Dieser Parameter bestimmt die zu verfahrende Strecke bzw. die Zielposition je nach Auftragsart.

Einheiten
Einheit für Weg- und Geschwindigkeitseingaben. Siehe Bildschirmseite "Einheiten".

Folgefahrauftrag

Anwahl, ob nach Abschluss des aktuellen Fahrauftrages automatisch ein neuer Fahrauftrag gestartet werden soll. Das Signal InPosition wird erst freigeschaltet, wenn der letzte Fahrauftrag (kein weiterer Folgeauftrag) abgearbeitet ist.

Das Erreichen jeder Zielposition einer Fahrauftragsfolge können Sie mit der Funktion "16, Folge-InPos" an einem der digitalen Ausgänge ausgeben.

Folge-Nr.

Nummer des Folgeauftrages, der automatisch nach Abschluss des aktuellen Auftrages gestartet werden soll.

Starten über (O_C)

sofort | Der Folgeauftrag wird bei Erreichen der Zielposition sofort gestartet.
I/O | Der Folgeauftrag wird über ein Signal an einem digitalen Eingang gestartet. Dies ist nur sinnvoll mit "Beschl./Bremsen Typ a". Voraussetzung: dem digitalen Eingang muss die Funktion "15,FStart_Folge" zugewiesen sein und die Zielposition muss erreicht sein. Mit dem Parameter "Starten mit" können Sie die Logik vorwählen
Zeit | Der Folgeauftrag nach Erreichen der Zielposition mit einer definierten Verzögerungszeit gestartet. Die Verzögerungszeit geben Sie mit dem Parameter "Verzögerungszeit" vor. Dies ist nur sinnvoll mit "Beschl./Bremsen Typ a".
I/O oder Zeit | Der Folgeauftrag wird über ein Signal an einem digitalen Eingang oder einer definierten Verzögerungszeit gestartet. Dies ist nur sinnvoll mit "Beschl./Bremsen Typ a". Wirksam ist das zuerst eintretende Ereignis (Startsignal oder Zeit abgelaufen) Voraussetzung: dem digitalen Eingang muss die Funktion "15, FStart_Folge" zugewiesen sein und die Zielposition muss erreicht sein. Mit dem Parameter "Starten mit" können Sie die Logik vorwählen und die Verzögerungszeit geben Sie mit dem Parameter "Verzögerungszeit" vor.

Starten mit (O_C)

Logik für den digitalen Eingang, dem die Funktion "15, FStart_Folge" zugewiesen wurde.
Low-Pegel: 0...7V High-Pegel: 12...30V / 7mA

Verzögerungszeit (O_FT)

Eingabe der Verzögerungszeit zwischen Erreichen der Zielposition und Start des Folgeauftrages in ms.

Beschl./Bremsen

Anwahl des Verhaltens beim Erreichen der Zielposition des aktuellen Fahrauftrages

a | Der Antrieb bremst in die Zielposition ab. Anschließend wird der Folgeauftrag gestartet.
b | Der Antrieb fährt mit v_soll des aktuellen Fahrauftrages zur Zielposition und beschleunigt dann fliegend auf v_soll des Folgeauftrages.
c | Die Umschaltung auf den Folgeauftrag wird soweit vorverlegt, dass im Zielpunkt des aktuellen Fahrauftrages v_soll des Folgeauftrages bereits erreicht ist.

Fahrauftrag löschen

Der Fahrauftrag wird aus der Tabelle gelöscht.


ASCII Deutsch MTIME

ASCII - Kommando | MTIME |
Syntax Senden | MTIME [Data] |
Syntax Empfangen | MTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 35AC (hex)
DIM | s | PROFIBUS PNU | 1772 (dec) IND = 1 (dec)
Bereich | 1 ... 600 | DPR | 172 (dec)
Default | 16 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Thermische Zeitkonstante des Motors

Beschreibung

Thermische Zeitkonstante des Motors zu Berechnung von MI2T mit MICONT


ASCII Deutsch MTIME_X

ASCII - Kommando | MTIME_X |
Syntax Senden | MTIME [Data] |
Syntax Empfangen | MTIME_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 376F (hex)
DIM | s | PROFIBUS PNU | 1823 (dec) IND = 17 (dec)
Bereich | 1 ... 600 | DPR | 623 (dec)
Default | 16 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Thermische Zeitkonstante des Motors

Beschreibung

siehe PARCNFG


ASCII Deutsch MTMUX

ASCII - Kommando | MTMUX |
Syntax Senden | MTMUX [Data] |
Syntax Empfangen | MTMUX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 365B (hex)
DIM | - | PROFIBUS PNU | 1947 (dec) IND = 1 (dec)
Bereich | 0 ... 300 | DPR | 347 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.6
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Voreinstellung für zu bearbeitenden Fahrsatz

Beschreibung

Mit dem Kommando MTMUX kann die Nummer eines Fahrsatzes für die Kommandos O_P,O_V,O_C,O_ACC,O_DEC,O_FT,O_FN vorgegeben werden.
Jedes von diesen Kommandos greift dann direkt auf den eingestellten Fahrsatz zu.

Der Parameter MTMUX darf nur mit der Nummer eines RAM-Fahrsatzes beschrieben werden.

Die Einstellung für MTMUX wird nicht im EEPROM abgespeichert. Beim Einschalten des Verstärkers wird dieser Parameter automatisch auf 0 gesetzt.


ASCII Deutsch MTR

ASCII - Kommando | MTR |
Syntax Senden | MTR [Data] |
Syntax Empfangen | MTR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 366C (hex)
DIM | ms | PROFIBUS PNU | 1964 (dec) IND = 1 (dec)
Bereich | 20 ... 1000 | DPR | 364 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.37
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Rotorzeitkonstante

Beschreibung

Rotorzeitkonstante zur Berechnung des Rotorflusses und des Schlupfs.


ASCII Deutsch MTYPE

ASCII - Kommando | MTYPE |
Syntax Senden | MTYPE [Data] |
Syntax Empfangen | MTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35A6 (hex)
DIM | - | PROFIBUS PNU | 1766 (dec) IND = 1 (dec)
Bereich | 1 ... 4 | DPR | 166 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Art des Motors

Beschreibung

Über MTYPE wird der Verstärker auf den Motortyp eingestellt. Folgende Motortypen sind definiert:

MTYPE = 1: Synchron Servomotor
MTYPE = 2: Synchronmotor mit ID Stromregelung (für Linearmotore und sensorloses Betreiben der Synchronmotore)
MTYPE = 3: Asynchronmotor
MTYPE = 4: reserviert für voice coil motor


ASCII Deutsch MUR

ASCII - Kommando | MUR |
Syntax Senden | MUR [Data] |
Syntax Empfangen | MUR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3886 (hex)
DIM | V | PROFIBUS PNU | 1702 (dec) IND = 33 (dec)
Bereich | 100 .. 500 | DPR | 902 (dec)
Default | 230 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Nennspannung des Asynchronmotors

Beschreibung

MUR ist ein Parameter zum Betrieb von Asynchronmaschinen und beschreibt die Nennspannung des Asynchronmotors (in Volt)


ASCII Deutsch MVANGLB

ASCII - Kommando | MVANGLB |
Syntax Senden | MVANGLB [Data] |
Syntax Empfangen | MVANGLB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35A7 (hex)
DIM | rpm | PROFIBUS PNU | 1767 (dec) IND = 1 (dec)
Bereich | 0 .. 15000 | DPR | 167 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Float
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Einsatz Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi (MVANGLF) gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLF.


ASCII Deutsch MVANGLF

ASCII - Kommando | MVANGLF |
Syntax Senden | MVANGLF [Data] |
Syntax Empfangen | MVANGLF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A8 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1768 (dec) IND = 1 (dec)
Bereich | 0 .. 45 | DPR | 168 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Endwert Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi (MVANGLB) und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLB.


ASCII Deutsch MVANGLMODE

ASCII - Kommando | MVANGLMODE |
Syntax Senden | MVANGLMODE [Data] |
Syntax Empfangen | MVANGLMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 38CF (hex)
DIM |  | PROFIBUS PNU | 1775 (dec) IND = 33 (dec)
Bereich | 0 .. 1 | DPR | 975 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 5.50 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM |
Kurzbeschreibung | SR600 Kompat.mode für drehzahlabh. Phasenvoreilung

Beschreibung

Die Phasenvoreilung im S300/S700 basiert auf einem Verfahren, das Bereits im SR600 implementiert war.
In der aktuellen Implementierung wurden allerdings einige Änderungen vorgenommen, die zu folgenden Verbesserungen führen:

1. bessere Dynamik im Feldschwächbetrieb
2. dynamische Strombegrenzung (dies führt zu einem langsameren Anstievon I2t)
3. Phasenvoreilung aktiv sowohl beim Beschleunigen als auch beim Abbresen.

In den Situationen, wo ein Verhalten vergleichbar zu dem Sr600 gewünscht ist (z.B. Verwendung von Parametern die mit einem SR600 ermittelt wurden), kann dieses durch das Setzen von MVANGLMODE=1 aktiviert werden.


ASCII Deutsch MVANGLP

ASCII - Kommando | MVANGLP |
Syntax Senden | MVANGLP [Data] |
Syntax Empfangen | MVANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3592 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1746 (dec) IND = 1 (dec)
Bereich | 0 .. 60 | DPR | 146 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und induzierter Motorspannung wird bei hohen Drehzahlen kompensiert.
Diese kann entweder dazu benutzt werden, um bei gleicher Drehzahl ein größeres Drehmoment zu bekommen oder die Enddrehzahl des Motors um bis zu 30% zu erhöhen.
Die Phasenverschiebung wird linear von "0" bei der Drehzahl MVANGLB bis zu dem in MVANGLF vorgegebenen Winkel bei VLIM verändert.


ASCII Deutsch MVER

ASCII - Kommando | MVER |
Syntax Senden | MVER |
Syntax Empfangen | MVER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3861 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 33 (dec)
Bereich |  | DPR | 865 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Float32
Verstärker Status | - | Wichtung |
ab Firmware | 2.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Version der Motordatenbank

Beschreibung

Dieser Parameter informiert über dieVersion der Motordatenbank


ASCII Deutsch MVR

ASCII - Kommando | MVR |
Syntax Senden | MVR [Data] |
Syntax Empfangen | MVR <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 366D (hex)
DIM |  | PROFIBUS PNU | 1965 (dec) IND = 1 (dec)
Bereich | 0 .. MSPEED | DPR | 365 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM |
Kurzbeschreibung | Nenndrehzahl der Asynchronmaschine

Beschreibung

Nenndrehzahl der Asynchronmaschine.

Bedeutung abhängig von der Betriebsart:

1. Normaler Betrieb der Asynchronmaschine (mit Sensor): (DRVCNFG2 Bit 0x8000000=1)
Der Parameter für Nenndrehzahl legt das Einsetzen der Feldschwächung fest. Oberhalb dieser Drehzahl wird der eingestellte Nenn-D-Strom (MIMR) abgesenkt. MVR = 0 schaltet die Feldschwächung ab (Default).

2. U/f Steuerung (ohne Sensor): (DRVCNFG2 Bit 0x8000000=0)
Wird zur Berechnung des U/f Verlaufs benötigt.


ASCII Deutsch NONBTB

ASCII - Kommando | NONBTB |
Syntax Senden | NONBTB [Data] |
Syntax Empfangen | NONBTB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AA (hex)
DIM | - | PROFIBUS PNU | 1770 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 170 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Netz-BTB-Überprüfung ein/aus

Beschreibung

Das Fehlen der Leistungseinspeisung führt beim Freigeben der Endstufe zu der Fehlermeldung F16 (Netz-BTB). Falls dieses Verhalten unerwünscht ist, so kann die Überwachung des Netz-BTB-Signals ausgeschaltet werden (NONBTB 1). Diese Funktion kann für eine DC-Einspeisung verwendet werden.

NONBTB=0: Vorladeschwelle=350V, VBUS-Welligkeit 1.5V/1msek, Überwachung des Netz-BTB aktiv für 400/480V-Einspeisung
NONBTB=1: Vorladeschwelle=350V, VBUS-Welligkeit 1.5V/1msek, Überwachung des Netz-BTB nicht aktiv für 400/480V-Einspeisung
NONBTB=2: reserviert
NONBTB=3: Vorladeschwelle=100V, VBUS-Welligkeit 1.5V/1msek, Überwachung des Netz-BTB nicht aktiv für 230V-Einspeisung
NONBTB=4: Vorladeschwelle=10V, VBUS-Welligkeit 1.5V/1msek, Überwachung des Netz-BTB nicht aktiv für 48-Einspeisung

Mit dem zusätzlichen Parameter RELTIME kann die Überprüfung der Welligkeit abgeschaltet werden.
Siehe auch UVLTMODE.


ASCII Deutsch NREF

ASCII - Kommando | NREF |
Syntax Senden | NREF [Data] |
Syntax Empfangen | NREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AD (hex)
DIM | - | PROFIBUS PNU | 1773 (dec) IND = 1 (dec)
Bereich | -2 .. 20 | DPR | 173 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Referenzfahrtart

Beschreibung

Bevor eine Positionierfahrt gestartet werden kann (gilt nur für Linearachse), muß eine Referenzfahrt durchgeführt werden. Der dabei gesetzte Referenzpunkt gilt bis zum nächsten Hardware-Reset des Verstärkers. Der Versuch eine Positionierung zu starten ohne daß ein Referenzpunkt gesetzt wurde, wird mit einer Warnung beantwortet (LED-Anzeige n09).
Vor dem Start einer Referenzfahrt wird der ggf. bereits gesetzte Referenzpunkt gelöscht.

Die möglichen Referenzfahrtarten können der nachfolgenden Tabelle entnommen werden.

Für die Referenzfahrten 1 und 3 muß ein digitaler Eingang als Nullposition-Eingang (Home-Position) konfiguriert werden (INxMODE=12 bzw. I/O-Erweiterungskarte).
Für die Referenzfahrten 2 und 4 muß ein digitaler Eingang als Hardware-Endschalter konfiguriert werden (siehe IN3MODE oder IN4MODE).

Bei den Referenzfahrten 1..5,7 wird die Einstellung des Nullimpulsoffsets für die ROD-Ausgabe berücksichtigt (ENCZERO) d.h. der Nullpunkt wird so gelegt, daß sowohl die Ausgabe des Nullimpulses als auch die Anzeige der 0-Position bei „Nullimpulsoffset“ erfolgen.

Bei allen Referenzfahrten wird die Einstellung des Referenzoffsets (ROFFS) berücksichtigt. Damit kann dem Nullpunkt ein beliebiger absoluter Positionswert zugeordnet werden.

Wenn ein Multiturngeber als Rückführung eingesetzt wird, so kann auch eine beliebige Referenzfahrt gestartet werden. Nach Beendigung der Referenzfahrt, wird RSOFFS übernommen und die ermittelten Parameter automatisch im EEPROM gespeichert. Damit steht die gefundene Position auch noch nach dem Aus-/Einschalten der 24V - Versorgung zur Verfügung.

Siehe auch REFMODE und VREF
Zustand | Kurzbeschreibung | Erweiterte Beschreibung
NREF=0 Setzen des Referenzpunktes Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Der Abstand zwischen der Ist- und Soll-Position (Schleppfehler) geht dabei verloren.
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Ab dieser Position wird die Entfernung zum nächsten Nulldurchgang des Resolvers ermittelt und eine Fahrt zu der Nullposition gestartet.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.

Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden. Dafür muß der Parameter REFMODE auf 5 gesetzt werden.
NREF=2 Referenzfahrt auf Endschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht bis der Hardware-Endschalter verlassen wurde. Dann wird eine Fahrt zum nächsten Nulldurchgang des Resolvers gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.

Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden. Dafür muß der Parameter REFMODE auf 5 gesetzt werden.
NREF=3 Referenzfahrt auf Referenzschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Dieser Position wird die Position ROFFS zugeordnet und der Antrieb wird angehalten.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zu dem gesetzten Nullpunkt (Referenzschalter) hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=4 Referenzfahrt auf Endschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht und eine Fahrt gestartet, bis der Hardware-Endschalter verlassen wird.
Die Position die der Flanke des Endschalters entspricht wird auf ROFFS gesetzt und der Antrieb wird angehalten.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zum Endschalter hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=5 Referenzfahrt innerhalb einer Umdrehung Der Antrieb fährt bis zum nächsten Nullpunkt des Resolvers. Die Fahrtrichtung wird durch die Variable DREF vorgegeben
DREF=0 negativ
DREF=1 positiv
DREF=2 die Richtung wird je nach Entfernung zum Nullpunkt gewählt (kleinste Entfernung).
NREF=6 Setzen des Referenzpunktes 2 Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Im Gegensatz zu NREF=0 geht der Abstand zwischen der Ist- und Ziel-Position (Schleppfehler) nicht verloren.
NREF=7 Auf Anschlag mit Nullpunktsuche Beim Start der Referenzfahrtart 7 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 7 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 negativ, DREF=1 positiv) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird die Drehrichtung gewechselt und eine Fahrt zum nächsten Nullpunkt des Resolvers gestartet. Der Antrieb bleibt im Nullpunkt stehen.Die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.

Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden. Dafür muß der Parameter REFMODE auf 5 gesetzt werden.
NREF=8 | Fahren auf die absolute SSI-Position | Beim Start der Referenzfahrt 8 wird eine 32-Bit SSI-Position über den SSI-Eingang (einstellbar mit GEARMODE) eingelesen, mit den Skalierungsfaktoren GEARI und GEARO und dem Offsetwert ROFFSSSI verrechnet, und als Zielposition für einen Fahrsatz benutzt. Der Fahrsatz wird gestartet und nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben.
NREF=9 Fahren auf Anschlag ohne Nullimpulssuche Beim Start der Referenzfahrtart 9 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 9 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 positiv, DREF=1 negativ) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird an dieser Stelle die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.


ASCII Deutsch NREFG

ASCII - Kommando | NREFG |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch NREFMT

ASCII - Kommando | NREFMT |
Syntax Senden | NREFMT [Data] |
Syntax Empfangen | NREFMT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36D2 (hex)
DIM |  | PROFIBUS PNU | 1666 (dec) IND = 17 (dec)
Bereich | 0 ... 511 | DPR | 466 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Referenzfahrt mit automatischem Folgefahrauftrag

Beschreibung

Mit dem Kommando NREFMT kann das automatische Starten eines Fahrsatzes am Ende einer Referenzfahrt aktiviert werden. Der Parameter NREFMT kann als eine Bit-Variable (16 Bit) interpretiert werden:

FEDCBA9876543210
xxxxxxxcnnnnnnnn

Bits 0..7 (nnnnnnnn) beschreiben die Nummer des zu startenden Fahrsatzes
Bei Nummer=0 wird kein Fahrsatz gestartet.

Bit 8 (c) =0 Fahrsatz nn wird gestartet erst nachdem der Stillstand erreicht wurde. In diesem Fall werden die Bits „Referenzfahrt läuft=0“ und „Referenzfahrt beendet=1“ vor dem Start des Fahrsatzes nn gesetzt.

=1 fliegender Start des Fahrsatzes nn. Die Bits „Referenzfahrt läuft=0“ und Referenzfahrt beendet=1“ werden erst nach dem Ende des Fahrsatzes nn gesetzt.


ASCII Deutsch O1

ASCII - Kommando | O1 |
Syntax Senden | O1 [Data] |
Syntax Empfangen | O1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AE (hex)
DIM | - | PROFIBUS PNU | 1774 (dec) IND = 1 (dec)
Bereich |  | DPR | 174 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 1

Beschreibung

S300:
Das Kommando O1 liefert den Zustand des digitalen Ausgangs 1 (0=Low,1=High).
Falls der digitale Ausgang 1 keiner Funktion (O1MODE=0)zugeordnet ist , so kann mit dem Kommando "O1 1" oder "O1 0" der High/Low-Zustand am Ausgang 1 ausgegeben werden.

S700:
Das Kommando O1 liefert den Zustand des digitalen Ausgangs 1 (0=Low,1=High).
Falls der digitale Ausgang 1 der Funktion (O1MODE=23)zugeordnet ist , so kann mit dem Kommando "O1 1" oder "O1 0" der High/Low-Zustand am Ausgang 1 ausgegeben werden.


ASCII Deutsch O1MODE

ASCII - Kommando | O1MODE |
Syntax Senden | O1MODE [Data] |
Syntax Empfangen | O1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AF (hex)
DIM | - | PROFIBUS PNU | 1775 (dec) IND = 1 (dec)
Bereich | 0 .. 100 | DPR | 175 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 1

Beschreibung

Mit dem Kommando O1MODE kann die Funktion des digitalen Ausgangs O1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O1MODE=0 | keine Funktion (S700: Signal X3-6 default als Eingang konfiguriert) | S300: Der Zustand des digitalen Ausgangs O1 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt oder abgefragt werden. S700: Der Pin X3-6 kann sowohl als Ein- als auch Ausgang konfiguriert werden. Per default ist dieses Signal als Eingang konfiguriert. Wenn dieses Signal als Ausgang benutzt werden soll (z.B. für ein Makroprogramm), muß OxMODE=23, "DPR-Ausgabe" zugewiesen werden.
O1MODE=1 | V < O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG unterschritten wird und Low wenn O1TRIG + 0.01 * MSPEED überschritten wird.
O1MODE=2 | V > O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG überschritten wird und Low wenn O1TRIG - 0.01 * MSPEED unterschritten wird.
O1MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf low gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises).
O1MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde.
O1MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG). Ein Fahrbefehl in die entgegengesetzte Richtung setzt den Ausgang zurück.
O1MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O1TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O1MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O1MODE=8 | I<O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=9 | I>O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O1MODE=11 | I2T | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM, Warnung n01) oder der Ausfall einer Netzphase (Warnung n05) wird mit einem High-Signal gemeldet.
O1MODE=12 .. 15 | - | reserviert
O1MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O1MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird (siehe ERRCODE). n32 wirkt nicht auf den Ausgang
O1MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O1MODE=19 | Zwischenkreisspannung > O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=20 | Zwischenkreisspannung < O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der Zwischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O1MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Encoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM Mit O1TRIG kann die Ausgabe des Nullimpuls in positiver Drehrichtung verlängert werden. Wichtig ist, dass die unteren Bits lückenlos mit Einsen aufgefüllt sind, O1TRIG also nur Werte 2^n-1 (n=1....32) annimmt (z.B. O1TRIG=1,3,7,15,31...). Umrechnung in Grad nach folgender Formel: O1TRIG / 2^32 * 360°. Beispiel 1: O1TRIG=1073741823 = 0x3FFFFFFF. 1073741823 * 360°/ 2^32 = 90° -> Ein HIGH Signal wird von 0 - 90° ausgegeben Beispiel 2: O1TRIG = 134217727 = 0x7FFFFFF 134217727 * 360° / 2^32 = 11,25° -> Ein HIGH Signal wird von 0 - 11,25° ausgegeben
O1MODE=23 | DPR-Ausgabe (S700: Signal X3-6 als Ausgang) | S300: Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O1MODE=0. S700: Der Pin X3-6 kann sowohl als Ein- als auch Ausgang konfiguriert werden. Per default ist dieses Signal als Eingang konfiguriert. Wenn dieses Signal als Ausgang benutzt werden soll (z.B. für ein Makroprogramm), muß OxMODE=23, "DPR-Ausgabe" zugewiesen werden.
O1MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O1MODE=25 .. 29 | - | reserviert
O1MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Bei OxMODE=30 wird der Ausgang OUTPUTx auf 1 gesetzt wenn eine Nocke "aktiv" ist. Der Ausgang wird auf 0 gesetzt wenn keine Nocke gemeldet wird. Um diese Funktion nutzen zu können, muss zunächst eine Nocke (oder mehrere) definiert werden. Dies geschieht mit Hilfe der Positionsregister P1..P16. Die Positionsregister sollten paarweise benutzt werden z.B. Nocke 1: P1 und P2 Nocke 2: P5 und P6 Nocke 3: P11 und P12 Mit Hilfe der OxTRIG-Variable werden die zu überwachenden Nocken definiert. Die Maske für das obere Beispiel würde wie folgt aussehen: OxTRIG = 3123 (Hex-Darstellung 0x0C33, für jedes Positionsregister wird das zugehörige Bit gesetzt) Sobald eine der drei Nocken überfahren wird, so wird der Ausgang OUTPUTx auf 1 gesetzt. Beispiel 2: O1MODE=30 O1TRIG=3 (Hex 0x0003) O2MODE=30 O2TRIG=3120 (Hex 0x0C30) Der Ausgang 1 wird gesetzt, wenn die Nocke 1 aktiv ist (P1 und P2). Der Ausgang 2 wird gesetzt, wenn die Nocke 2 (P5,P6) oder die Nocke 3 (P11,P12) aktiv ist.
O1MODE=31 | Analog In 1< O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 1 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=32 | Analog In 1 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 1 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=33 | Analog In 2 < O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 2 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=34 | Analog In 2 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 2 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O1MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O1MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O1MODE=36 | logisches ODER zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=37 | logisches UND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=38 | logisches ODER zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=39 | logisches UND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=40 | logisches ODER zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=41 | logisches UND zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=42 | Ausgabe einer Innentemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O1TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE)
O1MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0
O1MODE=44 | Zielgeschwindigkeitsabweichung Zielgeschwindigkeit - Istgeschwindigkeit< | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert (vor dem Rampengenerator) und dem Drehzahl-Istwert kleiner ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=45 | Zielgeschwindigkeitsabweichung Zielgeschwindigkeit - Istgeschwindigkeit> | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=48 | logisches NOR zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=49 | logisches NAND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=50 | logisches NOR zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=51 | logisches NAND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=52 | logisches UND zwischen POSRSTAT und O1TRIG mit Zeitverzögerung | wie O1MODE = 41, jedoch bleibt der Ausgang um die Zeit PTBASE * 250 us auf High Level
O1MODE=53 | Master/Slave synchron | Master/Slave synchron
O1MODE=54 | Antrieb verfahrbereit | ab Version 1.21: Der Ausgang wird auf High gesetzt wenn alle nachfolgenden Bedingungen erfüllt sind: Software-Enable gesetzt kein Fehler steht an Zwischenkreis aufgeladen (VBUS größer als VBUSMIN) kein Schleppfehler steht an (Warnung n03) Anmerkung: Software- oder Hardwareendschaleter können die Bewegungsrichtung sperren.
O1MODE=55 | Aktivität im Master/Slave-Verbund | Version >=2.13 Ausgang=1 - der Slave befindet sich in dem Master/Slave-Verbund. Dazu gehören folgende Master/Slave-Betriebsphasen: 1. Aufsynchronisieren auf die Master-Geschwindigkeit 2. Folgen der Master-Position 3. Auskoppeln aus dem Master/Slave-Verbund Ausgang=0 - keine der oben genannten Phasen ist aktiv (die Master-Impulse werden ignoriert). s. auch Funktion INxMODE=42,43
O1MODE=56 | Aktivität im Master/Slave-Verbund | Der Ausgang 1 wird gesetzt, wenn folgende Bedingungen erfüllt sind: OPMODE=4 UND 16 ms kein neuer Sollwert vom Master UND der Absolutwert des Schleppfehlers PE kleiner als der Wert von PEINPOS
O1MODE=57 | - | reserviert
O1MODE=58 | Ansteuerung einer externen Bremse | Ausgang O1 = 1 – Bremse lüften Ausgang O1 = 0 – Bremse schliessen Der Ausgang O1 spiegelt den Zustand der internen Bremsenansteuerung wieder und kann benutzt werden als Status-Ausgang oder für die Ansteuerung einer zweiten Bremse. Diese Funktion ist nur verfügbar, wenn eine Bremse (MBRAKE > 0) konfiguriert wurde.
O1MODE=59 | Ansteuerung einer externen Bremse (invertiert) | Ausgang O1 = 1 – Bremse schliessen Ausgang O1 = 0 – Bremse lüften Der Ausgang O1 spiegelt den Zustand der internen Bremsenansteuerung wieder und kann benutzt werden als Status-Ausgang oder für die Ansteuerung einer zweiten Bremse. Diese Funktion ist nur verfügbar, wenn eine Bremse (MBRAKE>0) konfiguriert wurde.
O1MODE=60 | Fehler steht an (Low-aktiv) | Fehler steht an (Low-aktiv)
O1MODE=61 | Fahrsatz-Zielgeschwindigkeit erreicht (High-aktiv) | Fahrsatz-Zielgeschwindigkeit erreicht (High-aktiv)
O1MODE=62 | Fahrsatz-Zielgeschwindigkeit erreicht (Low-aktiv) | Fahrsatz-Zielgeschwindigkeit erreicht (Low-aktiv)
O1MODE=69 | Master/Slave synchron; Slavegeschwindigkei> 0 | Master/Slave synchron; Slavegeschwindigkei> 0
O1MODE=70 | STO-Status | STO-Status
O1MODE=71 | Ist-Geschwindigkeit innerhalb des Vorgabefensters | Der Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert (hinter dem Rampengenerator) und dem Drehzahl-Istwert kleiner ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=72 | Ist-Geschwindigkeit ausserhalb des Vorgabefensters | Der Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert (hinter dem Rampengenerator) und dem Drehzahl-Istwert größer ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=73 | logisches OR zwischen ERRCODE und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer OR Verknüpfung zwischen der Bit-Variable ERRCODE und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=74 | logisches NOR zwischen ERRCODE und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable ERRCODE und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.


ASCII Deutsch O1TRIG

ASCII - Kommando | O1TRIG |
Syntax Senden | O1TRIG [Data] |
Syntax Empfangen | O1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B0 (hex)
DIM | - | PROFIBUS PNU | 1776 (dec) IND = 1 (dec)
Bereich | long int | DPR | 176 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O1MODE

Beschreibung

Die Funktion der Hilfsvariable O1TRIG hängt von der Konfiguration O1MODE ab.
s. O1MODE


ASCII Deutsch O2

ASCII - Kommando | O2 |
Syntax Senden | O2 [Data] |
Syntax Empfangen | O2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B1 (hex)
DIM | - | PROFIBUS PNU | 1777 (dec) IND = 1 (dec)
Bereich | - | DPR | 177 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 2

Beschreibung

siehe O1


ASCII Deutsch O2MODE

ASCII - Kommando | O2MODE |
Syntax Senden | O2MODE [Data] |
Syntax Empfangen | O2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B2 (hex)
DIM | - | PROFIBUS PNU | 1689 (dec) IND = 33 (dec)
Bereich | 0 .. 100 | DPR | 889 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 2

Beschreibung

Mit dem Kommando O2MODE kann die Funktion des digitalen Ausgangs O2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O2MODE=0 | keine Funktion (S700: Signal X3-7 default als Eingang konfiguriert) | S300: Der Zustand des digitalen Ausgangs O2 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt oder abgefragt werden. S700: Der Pin X3-7 kann sowohl als Ein- als auch Ausgang konfiguriert werden. Per default ist dieses Signal als Eingang konfiguriert. Wenn dieses Signal als Ausgang benutzt werden soll (z.B. für ein Makroprogramm), muß OxMODE=23, "DPR-Ausgabe" zugewiesen werden.
O2MODE=1 | V < O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG unterschritten wird und Low wenn O2TRIG + 0.01 * MSPEED überschritten wird.
O2MODE=2 | V > O2TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG überschritten wird und Low wenn O2TRIG - 0.01 * MSPEED unterschritten wird.
O2MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf low gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises).
O2MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde.
O2MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG). Ein Fahrbefehl in die entgegengesetzte Richtung setzt den Ausgang zurück.
O2MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O2TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O2MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O2MODE=8 | I<O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=9 | I>O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O2MODE=11 | I2T | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM, Warnung n01) oder der Ausfall einer Netzphase (Warnung n05) wird mit einem High-Signal gemeldet.
O2MODE=12 .. 15 | - | reserviert
O2MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O2MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird (siehe ERRCODE). n32 wirkt nicht auf den Ausgang
O2MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O2MODE=19 | Zwischenkreisspannung > O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=20 | Zwischenkreisspannung < O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der wischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O2MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Encoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM Mit O2TRIG kann die Ausgabe des Nullimpuls in positiver Drehrichtung verlängert werden. Wichtig ist, dass die unteren Bits lückenlos mit Einsen aufgefüllt sind, O2TRIG also nur Werte 2^n-1 (n=1....32) annimmt (z.B. O2TRIG=1,3,7,15,31...). Umrechnung in Grad nach folgender Formel: O2TRIG / 2^32 * 360°. Beispiel 1: O2TRIG=1073741823 = 0x3FFFFFFF. 1073741823 * 360°/ 2^32 = 90° -> Ein HIGH Signal wird von 0 - 90° ausgegeben Beispiel 2: O2TRIG = 134217727 = 0x7FFFFFF 134217727 * 360° / 2^32 = 11,25° -> Ein HIGH Signal wird von 0 - 11,25° ausgegeben
O2MODE=23 | DPR-Ausgabe | Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O1MODE=0. Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Digital-Ausgang 1 über Device-Net. Wenn ein digitaler Ausgang im Makroprogramm verwendet werden soll, muß ihm die die Funktion 23, "DPR-Ausgabe" zugewiesen werden.
O2MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O2MODE=25 .. 29 | - | reserviert
O2MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Bei OxMODE=30 wird der Ausgang OUTPUTx auf 1 gesetzt wenn eine Nocke "aktiv" ist. Der Ausgang wird auf 0 gesetzt wenn keine Nocke gemeldet wird. Um diese Funktion nutzen zu können, muss zunächst eine Nocke (oder mehrere) definiert werden. Dies geschieht mit Hilfe der Positionsregister P1..P16. Die Positionsregister sollten paarweise benutzt werden z.B. Nocke 1: P1 und P2 Nocke 2: P5 und P6 Nocke 3: P11 und P12 Mit Hilfe der OxTRIG-Variable werden die zu überwachenden Nocken definiert. Die Maske für das obere Beispiel würde wie folgt aussehen: OxTRIG = 3123 (Hex-Darstellung 0x0C33, für jedes Positionsregister wird das zugehörige Bit gesetzt) Sobald eine der drei Nocken überfahren wird, so wird der Ausgang OUTPUTx auf 1 gesetzt. Beispiel 2: O1MODE=30 O2TRIG=3 (Hex 0x0003) O2MODE=30 O2TRIG=3120 (Hex 0x0C30) Der Ausgang 1 wird gesetzt, wenn die Nocke 1 aktiv ist (P1 und P2). Der Ausgang 2 wird gesetzt, wenn die Nocke 2 (P5,P6) oder die Nocke 3 (P11,P12) aktiv ist.
O2MODE=31 | Analog In 1< O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 1 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=32 | Analog In 1 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 1 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=33 | Analog In 2 < O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 2 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=34 | Analog In 2 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung Analog In 2 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O1MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O1MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O2MODE=36 | logisches ODER zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=37 | logisches UND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=38 | logisches ODER zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=39 | logisches UND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=40 | logisches ODER zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=41 | logisches UND zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=42 | Ausgabe einer Innentemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O2TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE)
O2MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0
O2MODE=44 | Drehzahl In-Position (High aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert kleiner ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O2MODE=45 | Drehzahl In-Position (low aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O2MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O2TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O2TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=48 | logisches NOR zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=49 | logisches NAND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=50 | logisches NOR zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=51 | logisches NAND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O2MODE=52 | logisches UND zwischen POSRSTAT und O2TRIG mit Zeitverzögerung | wie O2MODE = 41, jedoch bleibt der Ausgang um die Zeit PTBASE * 250 us auf High Level
O2MODE=53 | Master/Slave synchron | Master/Slave synchron
O2MODE=54 | Antrieb verfahrbereit | ab Version 1.21: Der Ausgang wird auf High gesetzt wenn alle nachfolgenden Bedingungen erfüllt sind: Software-Enable gesetzt kein Fehler steht an Zwischenkreis aufgeladen (VBUS größer als VBUSMIN) kein Schleppfehler steht an (Warnung n03) Anmerkung: Software- oder Hardwareendschaleter können die Bewegungsrichtung sperren.
O2MODE=55 | Aktivität im Master/Slave-Verbund | ab der Version 2.13: Mit der Funktion OxMODE=55 kann bei einem Slave-Antrieb die Aktivität im Master/Slave-Verbund über einen digitalen Ausgang ausgegeben werden. Ausgang=1 - der Slave befindet sich in dem Master/Slave-Verbund. Dazu gehören folgende Master/Slave-Betriebsphasen: 1. Aufsynchronisieren auf die Master-Geschwindigkeit 2. Folgen der Master-Position 3. Auskoppeln aus dem Master/Slave-Verbund Ausgang=0 - keine der oben genannten Phasen ist aktiv (die Master-Impulse werden ignoriert). s. auch Funktion INxMODE=42,43
O2MODE=56 | Aktivität im Master/Slave-Verbund | Der Ausgang 2 wird gesetzt, wenn folgende Bedingungen erfüllt sind: OPMODE=4 UND 16 ms kein neuer Sollwert vom Master UND der Absolutwert des Schleppfehlers PE kleiner als der Wert von PEINPOS
O2MODE=57 | - | reserviert
O2MODE=58 | externe Bremse | Ausgang O2 = 1 – Bremse lüften Ausgang O2 = 0 – Bremse schliessen Der Ausgang O2 spiegelt den Zustand der internen Bremsenansteuerung wieder und kann benutzt werden als Status-Ausgang oder für die Ansteuerung einer zweiten Bremse. Diese Funktion ist nur verfügbar, wenn eine Bremse (MBRAKE > 0) konfiguriert wurde.
O2MODE=59 | externe Bremse (invertiert) | Ausgang O2 = 1 – Bremse schliessen Ausgang O2 = 0 – Bremse lüften Der Ausgang O2 spiegelt den Zustand der internen Bremsenansteuerung wieder und kann benutzt werden als Status-Ausgang oder für die Ansteuerung einer zweiten Bremse. Diese Funktion ist nur verfügbar, wenn eine Bremse (MBRAKE>0) konfiguriert wurde.
O2MODE=60 | Fehler steht an | Fehler steht an (Low-aktiv)
O2MODE=61 | Fahrsatz-Zielgeschwindigkeit erreicht (High-aktiv) | Fahrsatz-Zielgeschwindigkeit erreicht (High-aktiv)
O2MODE=62 | Fahrsatz-Zielgeschwindigkeit erreicht (Low-aktiv) | Fahrsatz-Zielgeschwindigkeit erreicht (Low-aktiv)
O2MODE=69 | Master/Slave synchron; Slavegeschwindigkei> 0 | Master/Slave synchron; Slavegeschwindigkei> 0
O2MODE=70 | STO-Status | STO-Status
O2MODE=71 | Ist-Geschwindigkeit innerhalb des Vorgabefensters | Der Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert (hinter dem Rampengenerator) und dem Drehzahl-Istwert kleiner ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O2MODE=72 | Ist-Geschwindigkeit ausserhalb des Vorgabefensters | Der Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert (hinter dem Rampengenerator) und dem Drehzahl-Istwert größer ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O2MODE=73 | logisches OR zwischen ERRCODE und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer OR Verknüpfung zwischen der Bit-Variable ERRCODE und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=74 | logisches NOR zwischen ERRCODE und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable ERRCODE und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.


ASCII Deutsch O2TRIG

ASCII - Kommando | O2TRIG |
Syntax Senden | O2TRIG [Data] |
Syntax Empfangen | O2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 1 (dec)
Bereich | long int | DPR | 179 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O2MODE

Beschreibung

Die Funktion der Hilfsvariable O2TRIG hängt von der Konfiguration O2MODE ab.
s. O2MODE


ASCII Deutsch O3

ASCII - Kommando | O3 |
Syntax Senden | O3 [Data] |
Syntax Empfangen | O3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3725 (hex)
DIM |  | PROFIBUS PNU | 1749 (dec) IND = 17 (dec)
Bereich |  | DPR | 549 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 3

Beschreibung

siehe O3_18


ASCII Deutsch O3_18

ASCII - Kommando | O3_18 |
Syntax Senden | O3_18 [data] |
Syntax Empfangen | O3_18 | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 3 bis 18

Beschreibung

Dies ist eine Gruppenbeschreibung der Ausgänge 3 bis 18:

Beispiel: Das Kommando O3 liefert den Zustand des digitalen Ausgangs 3 (0=Low,1=High).
Falls der digitale Ausgang 3 keiner Funktion zugeordnet ist (O3MODE=0), so kann mit dem Kommando "O3 1" oder "O3 0" der High/Low-Zustand am Ausgang 3 ausgegeben werden.


ASCII Deutsch O3_18MODE

ASCII - Kommando | O3_18MODE |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 100 | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion der digitalen Ausgänge 3 bis 18

Beschreibung

Dies ist eine Gruppenbeschreibung der Funktionen der digitalen Ausgänge 3 bis 18:

Beispiel: Mit dem Kommando O3MODE kann die Funktion des digitalen Ausgangs O3 konfiguriert werden. Wenn keine Funktion ausgewählt wurde (z.B. O3MODE=0), kann der Ausgang 1 mit "O3 1" oder "O3 0" gesetzt werden.

Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.


ASCII Deutsch O3_18TRIG

ASCII - Kommando | O3_18TRIG |
Syntax Senden | O3_18TRIG [Data] |
Syntax Empfangen | O3_18TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | long int | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für OxMODE

Beschreibung

Dies ist eine Gruppenbeschreibung der Hilfsvariable OxTRIG mit x =3 .. 18

Beispiel: Die Funktion der Hilfsvariable O3TRIG hängt von der Konfiguration O1MODE ab.


ASCII Deutsch O3MODE

ASCII - Kommando | O3MODE |
Syntax Senden | O3MODE [Data] |
Syntax Empfangen | O3MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3726 (hex)
DIM |  | PROFIBUS PNU | 1750 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 550 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs3

Beschreibung

siehe O3_18MODE


ASCII Deutsch O3TRIG

ASCII - Kommando | O3TRIG |
Syntax Senden | O3TRIG [Data] |
Syntax Empfangen | O3TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3727 (hex)
DIM |  | PROFIBUS PNU | 1751 (dec) IND = 17 (dec)
Bereich |  | DPR | 551 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 3

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O4

ASCII - Kommando | O4 |
Syntax Senden | O4 [Data] |
Syntax Empfangen | O4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3728 (hex)
DIM |  | PROFIBUS PNU | 1752 (dec) IND = 17 (dec)
Bereich |  | DPR | 552 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 4

Beschreibung

siehe O3_18


ASCII Deutsch O4MODE

ASCII - Kommando | O4MODE |
Syntax Senden | O4MODE [Data] |
Syntax Empfangen | O4MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3729 (hex)
DIM |  | PROFIBUS PNU | 1753 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 553 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 4

Beschreibung

siehe O3_18MODE


ASCII Deutsch O4TRIG

ASCII - Kommando | O4TRIG |
Syntax Senden | O4TRIG [Data] |
Syntax Empfangen | O4TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 372A (hex)
DIM |  | PROFIBUS PNU | 1754 (dec) IND = 17 (dec)
Bereich |  | DPR | 554 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 4

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O5

ASCII - Kommando | O5 |
Syntax Senden | O5 [Data] |
Syntax Empfangen | O5 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 372B (hex)
DIM |  | PROFIBUS PNU | 1755 (dec) IND = 17 (dec)
Bereich |  | DPR | 555 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 5

Beschreibung

siehe O3_18


ASCII Deutsch O5MODE

ASCII - Kommando | O5MODE |
Syntax Senden | O5MODE [Data] |
Syntax Empfangen | O5MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 372C (hex)
DIM |  | PROFIBUS PNU | 1756 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 556 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 5

Beschreibung

siehe O3_18MODE


ASCII Deutsch O5TRIG

ASCII - Kommando | O5TRIG |
Syntax Senden | O5TRIG [Data] |
Syntax Empfangen | O5TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 372D (hex)
DIM |  | PROFIBUS PNU | 1757 (dec) IND = 17 (dec)
Bereich |  | DPR | 557 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 5

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O6

ASCII - Kommando | O6 |
Syntax Senden | O6 [Data] |
Syntax Empfangen | O6 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 372E (hex)
DIM |  | PROFIBUS PNU | 1758 (dec) IND = 17 (dec)
Bereich |  | DPR | 558 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 6

Beschreibung

siehe O3_18


ASCII Deutsch O6MODE

ASCII - Kommando | O6MODE |
Syntax Senden | O6MODE [Data] |
Syntax Empfangen | O6MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 372F (hex)
DIM |  | PROFIBUS PNU | 1759 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 559 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 6

Beschreibung

siehe O3_18MODE


ASCII Deutsch O6TRIG

ASCII - Kommando | O6TRIG |
Syntax Senden | O6TRIG [Data] |
Syntax Empfangen | O6TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3730 (hex)
DIM |  | PROFIBUS PNU | 1760 (dec) IND = 17 (dec)
Bereich |  | DPR | 560 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 6

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O7

ASCII - Kommando | O7 |
Syntax Senden | O7 [Data] |
Syntax Empfangen | O7 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3731 (hex)
DIM |  | PROFIBUS PNU | 1761 (dec) IND = 17 (dec)
Bereich |  | DPR | 561 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 7

Beschreibung

siehe O3_18


ASCII Deutsch O7MODE

ASCII - Kommando | O7MODE |
Syntax Senden | O7MODE [Data] |
Syntax Empfangen | O7MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3732 (hex)
DIM |  | PROFIBUS PNU | 1762 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 562 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 7

Beschreibung

siehe O3_18MODE


ASCII Deutsch O7TRIG

ASCII - Kommando | O7TRIG |
Syntax Senden | O7TRIG [Data] |
Syntax Empfangen | O7TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3733 (hex)
DIM |  | PROFIBUS PNU | 1763 (dec) IND = 17 (dec)
Bereich |  | DPR | 563 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 7

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O8

ASCII - Kommando | O8 |
Syntax Senden | O8 [Data] |
Syntax Empfangen | O8 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3734 (hex)
DIM |  | PROFIBUS PNU | 1764 (dec) IND = 17 (dec)
Bereich |  | DPR | 564 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 8

Beschreibung

siehe O3_18


ASCII Deutsch O8MODE

ASCII - Kommando | O8MODE |
Syntax Senden | O8MODE [Data] |
Syntax Empfangen | O8MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3735 (hex)
DIM |  | PROFIBUS PNU | 1765 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 565 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 8

Beschreibung

siehe O3_18MODE


ASCII Deutsch O8TRIG

ASCII - Kommando | O8TRIG |
Syntax Senden | O8TRIG [Data] |
Syntax Empfangen | O8TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3736 (hex)
DIM |  | PROFIBUS PNU | 1766 (dec) IND = 17 (dec)
Bereich |  | DPR | 566 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 8

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O9

ASCII - Kommando | O9 |
Syntax Senden | O9 [Data] |
Syntax Empfangen | O9 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3737 (hex)
DIM |  | PROFIBUS PNU | 1767 (dec) IND = 17 (dec)
Bereich |  | DPR | 567 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 9

Beschreibung

siehe O3_18


ASCII Deutsch O9MODE

ASCII - Kommando | O9MODE |
Syntax Senden | O9MODE [Data] |
Syntax Empfangen | O9MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3738 (hex)
DIM |  | PROFIBUS PNU | 1768 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 568 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 9

Beschreibung

siehe O3_18MODE


ASCII Deutsch O9TRIG

ASCII - Kommando | O9TRIG |
Syntax Senden | O9TRIG [Data] |
Syntax Empfangen | O9TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3739 (hex)
DIM |  | PROFIBUS PNU | 1769 (dec) IND = 17 (dec)
Bereich |  | DPR | 569 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 9

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O10

ASCII - Kommando | O10 |
Syntax Senden | O10 [Data] |
Syntax Empfangen | O10 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 373A (hex)
DIM |  | PROFIBUS PNU | 1770 (dec) IND = 17 (dec)
Bereich |  | DPR | 570 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 10

Beschreibung

siehe O3_18


ASCII Deutsch O10MODE

ASCII - Kommando | O10MODE |
Syntax Senden | O10MODE [Data] |
Syntax Empfangen | O10MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 373B (hex)
DIM |  | PROFIBUS PNU | 1771 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 571 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 10

Beschreibung

siehe O3_18MODE


ASCII Deutsch O10TRIG

ASCII - Kommando | O10TRIG |
Syntax Senden | O10TRIG [Data] |
Syntax Empfangen | O10TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 373C (hex)
DIM |  | PROFIBUS PNU | 1772 (dec) IND = 17 (dec)
Bereich |  | DPR | 572 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 10

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O11

ASCII - Kommando | O11 |
Syntax Senden | O11 [Data] |
Syntax Empfangen | O11 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 373D (hex)
DIM |  | PROFIBUS PNU | 1773 (dec) IND = 17 (dec)
Bereich |  | DPR | 573 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 11

Beschreibung

siehe O3_18


ASCII Deutsch O11MODE

ASCII - Kommando | O11MODE |
Syntax Senden | O11MODE [Data] |
Syntax Empfangen | O11MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 373E (hex)
DIM |  | PROFIBUS PNU | 1774 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 574 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 11

Beschreibung

siehe O3_18MODE


ASCII Deutsch O11TRIG

ASCII - Kommando | O11TRIG |
Syntax Senden | O11TRIG [Data] |
Syntax Empfangen | O11TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 373F (hex)
DIM |  | PROFIBUS PNU | 1775 (dec) IND = 17 (dec)
Bereich |  | DPR | 575 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 11

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O12

ASCII - Kommando | O12 |
Syntax Senden | O12 [Data] |
Syntax Empfangen | O12 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3740 (hex)
DIM |  | PROFIBUS PNU | 1776 (dec) IND = 17 (dec)
Bereich |  | DPR | 576 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 12

Beschreibung

siehe O3_18


ASCII Deutsch O12MODE

ASCII - Kommando | O12MODE |
Syntax Senden | O12MODE [Data] |
Syntax Empfangen | O12MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3741 (hex)
DIM |  | PROFIBUS PNU | 1777 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 577 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 12

Beschreibung

siehe O3_18MODE


ASCII Deutsch O12TRIG

ASCII - Kommando | O12TRIG |
Syntax Senden | O12TRIG [Data] |
Syntax Empfangen | O12TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3742 (hex)
DIM |  | PROFIBUS PNU | 1778 (dec) IND = 17 (dec)
Bereich |  | DPR | 578 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 12

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O13

ASCII - Kommando | O13 |
Syntax Senden | O13 [Data] |
Syntax Empfangen | O13 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3743 (hex)
DIM |  | PROFIBUS PNU | 1779 (dec) IND = 17 (dec)
Bereich |  | DPR | 579 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 13

Beschreibung

siehe O3_18


ASCII Deutsch O13MODE

ASCII - Kommando | O13MODE |
Syntax Senden | O13MODE [Data] |
Syntax Empfangen | O13MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3744 (hex)
DIM |  | PROFIBUS PNU | 1780 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 580 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 13

Beschreibung

siehe O3_18MODE


ASCII Deutsch O13TRIG

ASCII - Kommando | O13TRIG |
Syntax Senden | O13TRIG [Data] |
Syntax Empfangen | O13TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3745 (hex)
DIM |  | PROFIBUS PNU | 1781 (dec) IND = 17 (dec)
Bereich |  | DPR | 581 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 13

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O14

ASCII - Kommando | O14 |
Syntax Senden | O14 [Data] |
Syntax Empfangen | O14 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3746 (hex)
DIM |  | PROFIBUS PNU | 1782 (dec) IND = 17 (dec)
Bereich |  | DPR | 582 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 14

Beschreibung

siehe O3_18


ASCII Deutsch O14MODE

ASCII - Kommando | O14MODE |
Syntax Senden | O14MODE [Data] |
Syntax Empfangen | O14MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3747 (hex)
DIM |  | PROFIBUS PNU | 1783 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 583 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 14

Beschreibung

siehe O3_18MODE


ASCII Deutsch O14TRIG

ASCII - Kommando | O14TRIG |
Syntax Senden | O14TRIG [Data] |
Syntax Empfangen | O14TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3748 (hex)
DIM |  | PROFIBUS PNU | 1784 (dec) IND = 17 (dec)
Bereich |  | DPR | 584 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 14

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O15

ASCII - Kommando | O15 |
Syntax Senden | O15 [Data] |
Syntax Empfangen | O15 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3749 (hex)
DIM |  | PROFIBUS PNU | 1785 (dec) IND = 17 (dec)
Bereich |  | DPR | 585 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 15

Beschreibung

siehe O3_18


ASCII Deutsch O15MODE

ASCII - Kommando | O15MODE |
Syntax Senden | O15MODE [Data] |
Syntax Empfangen | O15MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 374A (hex)
DIM |  | PROFIBUS PNU | 1786 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 586 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 15

Beschreibung

siehe O3_18MODE


ASCII Deutsch O15TRIG

ASCII - Kommando | O15TRIG |
Syntax Senden | O15TRIG [Data] |
Syntax Empfangen | O15TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 374B (hex)
DIM |  | PROFIBUS PNU | 1787 (dec) IND = 17 (dec)
Bereich |  | DPR | 587 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 15

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O16

ASCII - Kommando | O16 |
Syntax Senden | O16 [Data] |
Syntax Empfangen | O16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 374C (hex)
DIM |  | PROFIBUS PNU | 1788 (dec) IND = 17 (dec)
Bereich |  | DPR | 588 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 16

Beschreibung

siehe O3_18


ASCII Deutsch O16MODE

ASCII - Kommando | O16MODE |
Syntax Senden | O16MODE [Data] |
Syntax Empfangen | O16MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 374D (hex)
DIM |  | PROFIBUS PNU | 1789 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 589 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 16

Beschreibung

siehe O3_18MODE


ASCII Deutsch O16TRIG

ASCII - Kommando | O16TRIG |
Syntax Senden | O16TRIG [Data] |
Syntax Empfangen | O16TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 374E (hex)
DIM |  | PROFIBUS PNU | 1790 (dec) IND = 17 (dec)
Bereich |  | DPR | 590 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 16

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O17

ASCII - Kommando | O17 |
Syntax Senden | O17 [Data] |
Syntax Empfangen | O17 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 374F (hex)
DIM |  | PROFIBUS PNU | 1791 (dec) IND = 17 (dec)
Bereich |  | DPR | 591 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 17

Beschreibung

siehe O3_18


ASCII Deutsch O17MODE

ASCII - Kommando | O17MODE |
Syntax Senden | O17MODE [Data] |
Syntax Empfangen | O17MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3750 (hex)
DIM |  | PROFIBUS PNU | 1792 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 592 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 17

Beschreibung

siehe O3_18MODE


ASCII Deutsch O17TRIG

ASCII - Kommando | O17TRIG |
Syntax Senden | O17TRIG [Data] |
Syntax Empfangen | O17TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3751 (hex)
DIM |  | PROFIBUS PNU | 1793 (dec) IND = 17 (dec)
Bereich |  | DPR | 593 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 17

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O18

ASCII - Kommando | O18 |
Syntax Senden | O18 [Data] |
Syntax Empfangen | O18 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3752 (hex)
DIM |  | PROFIBUS PNU | 1794 (dec) IND = 17 (dec)
Bereich |  | DPR | 594 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 18

Beschreibung

siehe O3_18


ASCII Deutsch O18MODE

ASCII - Kommando | O18MODE |
Syntax Senden | O18MODE [Data] |
Syntax Empfangen | O18MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3753 (hex)
DIM |  | PROFIBUS PNU | 1795 (dec) IND = 17 (dec)
Bereich | 0 .. 100 | DPR | 595 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 18

Beschreibung

siehe O3_18MODE


ASCII Deutsch O18TRIG

ASCII - Kommando | O18TRIG |
Syntax Senden | O18TRIG [Data] |
Syntax Empfangen | O18TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3754 (hex)
DIM |  | PROFIBUS PNU | 1796 (dec) IND = 17 (dec)
Bereich |  | DPR | 596 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für digitalen Ausgang 18

Beschreibung

siehe O3_18TRIG


ASCII Deutsch O_ACC

ASCII - Kommando | O_ACC |
Syntax Senden | O_ACC [Data] |
Syntax Empfangen | O_ACC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B7 (hex)
DIM | ms, mm/sec ^2 | PROFIBUS PNU | 1783 (dec) IND = 1 (dec)
Bereich | 0 ... 2147483647 | DPR | 183 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.6
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Beschleunigungszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_ACC kann die Beschleunigungsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Beschleunigungszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Beschleunigungszeit wird in msek von 0 auf die Zielgeschwindigkeit O_V vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =_C gleich 1.
Die Beschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Anfahrzeit wird
bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_ACC als Anfahrzeit in msek gewertet.


ASCII Deutsch O_C

ASCII - Kommando | O_C |
Syntax Senden | O_C [Data] |
Syntax Empfangen | O_C <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B9 (hex)
DIM | - | PROFIBUS PNU | 1785 (dec) IND = 1 (dec)
Bereich | int | DPR | 185 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Steuervariable für den Fahrsatz 0

Beschreibung

Das Kommando O_C definiert die Fahrauftragsart für den lokalen Fahrsatz Nr. 0 (Direktfahrsatz). Als Parameter wird eine Bit-Variable übergeben (32 Bits).
Bit | Wertigkeit | Bedeutung
0 | 0x0001 | Bit für die Art des relativen/absoluten Fahrsatzes (s. Tabelle 2)
1 | 0x0002 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
2 | 0x0004 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
3 | 0x0008 | =0 kein Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition bleibt der Antrieb stehen =1 Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition wird automatisch der Folgefahrsatz gestartet. Die Nummer des Folgefahrsatze wird mit dem Kommando O_FN vorgegeben. Diese Funktion ist nur bei linearer Beschleunigung möglich.
4 | 0x0010 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
5 | 0x0020 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
6 | 0x0040 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
7 | 0x0080 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
8 | 0x0100 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
9 | 0x0200 | =0 Der Fahrsatz wird über den internen Trajektoriengenerator gesteuert =1 Es wird der Tabellenfahrsatz gestartet. Hierzu muss die Tabelle über LOOKUP in den Verstärker eingespielt werden. O_TAB gibt die Tabellennummer, die gefahren werden soll, an. Die Summe von O_ACC und O_DEC gibt die Verfahrzeit des Profils in ms an, unabhängig von der Einstellung ACCUNIT.
10 | 0x0400 | Bit 10 (Richtung des Geschwindigkeitsprofils): Ist dieses Bit gesetzt, so wird bei einem absoluten Fahrauftrag eine Zielposition zwischen SRND und ERND in Abhängigkeit vom Analogeingang 1 angefahren. Dies passiert auch wenn POSCNFG auf 0 steht. Die Berechnung lautet: Zielpos = SRND + (ERND-SRND)*ANIN1 / 10V Beispiele: SRND=30000 ; ERND=50000 ; ANIN1 = 5V Zielpos = 30000 + (50000-30000)*5V/10V = 40000 SRND=30000 ; ERND = 50000 ; ANIN1 = -10V Zielpos = 30000 + (50000-30000)*(-10V)/10V = 10000 Auch relative Fahraufträge sind möglich. Der Verfahrweg errechnet sich nach gleicher Formel: Verfahrweg = SRND + (ERND-SRND)*ANIN1/10V
11 | 0x0800 | reserviert
12 | 0x1000 | reserviert
13 | 0x2000 | =0 die Zielposition und die Zielgeschwindigkeit des Fahrsatzes werden als [InkrementePRBASE] bzw. [InkrementePRBASE / 250us] interpretiert. Es findet keine Umrechnung statt. Die Einheit InkrementePRBASE bedeutet, dass eine Umdrehung 2^PRBASE Inkrementen entspricht. =1 die Zielposition und die Zielgeschwindigkeit werden vor dem Start des Fahrsatzes in Inkremente umgerechnet. Für die Umrechnung werden die Parameter PGEARI und PGEARO benutzt. Wenn VUNIT <> 0 wird die Geschwindigkeit in VUNIT angegeben (s. auch Kommandos O_S, O_V, PGEARI, PGEARO)
14 | 0x4000 | =0 die Geschwindigkeit des Fahrsatzes wird beim Fahrsatzstart als die Zielgeschwindigkeit übernommen. =1 die Zielgeschwindigkeit wird beim Fahrsatzstart analog vorgegeben (Analog In 1). Beim Start des Fahrsatzes wird der analoge Analog In 1-Wert eingelesen und als die Zielgeschwindigkeit übernommen (Skalierung: 10V=VSCALE1). Das Vorzeichen der Analog In 1-Spannung wird ignoriert.
15 | 0x8000 | Bit 3 für die Art des relativen Fahrsatzes (s. separate Tabelle)
16 | 0x10000 | Ist das Bit 16 von o_c gesetzt, so wird ein Tabellenfahrsatz (Sinus2-Fahrt) gestartet. Bit 9 muss auf 0 gesetzt werden.
17 | 0x20000 | Ist das Bit 17 gesetzt, so erfolgt die Positionsvorgabe in internen Inkrementen und im 32Bit-Format (Inkr32) . Eine Umdrehung bedeutet also 2^32 Inkremente. Wenn dieses Bit gesetzt ist, so erfolgt die Geschwindigkeitsangabe o_v in Inkr32/250µs. Wichtig ist, dass das Bit 13 von O_C (Umrechnung von benutzerdefinierten Einheiten in Inkremente) auf 0 gesetzt wird.
 | Tabelle 2 | Art des relativen/absoluten Fahrsatzes
Bit 15/2/1/0 | Bedeutung |
xxx0 | Absoluter Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als die Zielposition gewertet. |
x001 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. Die Zielposition wird abhängig vom Zustand der IN-POSITION-Meldung berechnet: IN-POSITION=1: neue Zielposition=letzte Zielposition+Verfahrstrecke IN-POSITION=0: neue Zielposition=aktuelle Position+Verfahrstrecke |
x011 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=letzte Zielposition+Verfahrstrecke |
x101 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=aktuelle Position+Verfahrstrecke |
0111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=letzte positive Latchposition+Verfahrstrecke (s. auch Kommando LATCH1P32, LATCH1N32, LATCH1P16, LATCH1N16, LATCH2P32, ...) |
1111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=negativeLatchposition+Verfahrstrecke (s. auch Kommando LATCH32N) |
 | Tabelle 3 | Art des Folgefahrsatzes
Bit 8/7/6/5/4 | Bedeutung |
00000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes. Anschließend wird der Folgefahrsatz gestartet. |
00001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Antrieb fährt mit der Zielgeschwindigkeit bis in die Zielposition des ersten Fahrsatzes. Anschließend wird bei voller Geschwindigkeit auf den Folgefahrsatz umgeschaltet. |
10001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Umschaltpunkt auf den Folgefahrauftrag wird so vorverlegt, dass in der Zielposition des ersten Fahrsatzes die Zielgeschwindigkeit des Folgefahrsatzes bereits erreicht wird. |
00010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte. |
00110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte. |
01000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |


ASCII Deutsch O_DEC

ASCII - Kommando | O_DEC |
Syntax Senden | O_DEC [Data] |
Syntax Empfangen | O_DEC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BA (hex)
DIM | ms, mm/sec ^2 | PROFIBUS PNU | 1786 (dec) IND = 1 (dec)
Bereich | 0 ... 2147483647 | DPR | 186 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.6
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Bremszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_DEC kann die Bremsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Bremsszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Bremszeit wird in msek von der Zielgeschwindigkeit O_V auf 0 vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =O_C gleich 1.
Die Bremsbeschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Bremszeit
wird bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_DEC als Bremszeit in msek gewertet.


ASCII Deutsch O_FN

ASCII - Kommando | O_FN |
Syntax Senden | O_FN [Data] |
Syntax Empfangen | O_FN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BC (hex)
DIM | - | PROFIBUS PNU | 1788 (dec) IND = 1 (dec)
Bereich | 0, 1, .. ,180,192 .. 255 | DPR | 188 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Folgefahrsatz-Nummer für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_FN kann die Nummer des Folgefahrsatzes definiert werden. Diese Nummer wird nur dann verwendet, wenn das Bit3 (Folgefahrsatz aktiv) des Fahrsatz-Steuerwortes auf 1 steht.
Die Fahrsatz-Nummer kann folgende Werte annehmen:
0 - Direktfahrsatz
1...180 Fahrsatz aus dem Flash-EEPROM
192...255 Fahrsatz aus dem RAM


ASCII Deutsch O_FT

ASCII - Kommando | O_FT |
Syntax Senden | O_FT [Data] |
Syntax Empfangen | O_FT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BD (hex)
DIM | ms | PROFIBUS PNU | 1789 (dec) IND = 1 (dec)
Bereich | 0 .. 32767 | DPR | 189 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Verzögerungszeit für den Folge-Fahrsatz

Beschreibung

Mit Hilfe dieses Parameters kann der Start des Folge-Fahrsatzes (falls definiert) verzögert werden. Dieser Parameter wird nur dann ausgewertet, wenn das Bit3 (Folgefahrsatz aktiv) und das Bit7 (Verzögerungszeit aktiv) des Fahrsatz-Steuerwortes gesetzt sind.


ASCII Deutsch O_P

ASCII - Kommando | O_P |
Syntax Senden | O_P [Data] |
Syntax Empfangen | O_P <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BE (hex)
DIM | - | PROFIBUS PNU | 1790 (dec) IND = 1 (dec)
Bereich | long int | DPR | 190 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer64
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Zielposition/Verfahrstrecke für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_P kann die Zielposition für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Abhängig von der Fahrauftragsart (absolut oder relativ) wird dieser Parameter als absolute Zielposition oder als relative Verfahrstrecke interpretiert. Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Position/Verfahrstrecke wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 1048576 Inkremente pro Umdrehung
PRBASE=16 -> 65536 Inkremente pro Umdrehung

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Position wird nach folgender Formel umgerechnet:
Position [Inkremente] = O_P * PGEARO / PGEARI

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO*2^PRBASE) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet.


ASCII Deutsch O_TAB

ASCII - Kommando | O_TAB |
Syntax Senden | O_TAB [Data] |
Syntax Empfangen | O_TAB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 35B8 (hex)
DIM |  | PROFIBUS PNU | 1784 (dec) IND = 1 (dec)
Bereich |  | DPR | 184 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM |
Kurzbeschreibung | Fahrprofiltabellen

Beschreibung

siehe >> GUI Onlinehilfe >> Fahrprofiltabellen


ASCII Deutsch O_V

ASCII - Kommando | O_V |
Syntax Senden | O_V [Data] |
Syntax Empfangen | O_V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BF (hex)
DIM | - | PROFIBUS PNU | 1791 (dec) IND = 1 (dec)
Bereich | 0 ... 2147483647 | DPR | 191 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Zielgeschwindigkeit für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_V kann die Zielgeschwindigkeit für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Die Normierung der Geschwindigkeit hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Geschwindigkeit wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 140/32 Inkremente pro UPM
PRBASE=16 -> 140/512 Inkremente pro UPM

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Fahrsatzgeschwindigkeit wird in den aktuellen VUNIT-Einheiten erwartet
Bei VUNIT=0 oder 5 wird die Geschwindigkeit nach folgender Formel umgerechnet:
Geschwindigkeit [Inkremente] = O_V * PGEARO / PGEARI / 4000

Achtung: Aus Kompatibilitätsgründen findet bei der Einstellung PGEARI=PGEARO*(2^PRBASE) keine Umrechnung der SI-Einheiten statt. In diesem Fall muss die Position/Geschwindigkeit in Inkrementen vorgegeben werden!


ASCII Deutsch OCOPY

ASCII - Kommando | OCOPY |
Syntax Senden | OCOPY [ - Data] |
Syntax Empfangen | OCOPY <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0,1,..,180,192..255 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Speichern der Fahrsätze

Beschreibung

Mit dem Kommando OCOPY können Fahraufträge zwischen verschiedenen Speicherplätzen kopiert werden. Die Fahrsatznummer kann folgende Werte annehmen:
0 - lokaler Fahrsatz/ Direktfahrsatz
1...200 ROM-Fahrsätze, Die ROM -Fahrsätze werden in einem Segment des internen Flash-Eproms abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.
201...300 RAM-Fahrsätze, Die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der ROM-Fahrsätze 1...64 vorinitialisiert.

z.B:
OCOPY 0 1 Abspeichern des lokalen Fahrsatzes (Direktfahrsatz/RAM) als ROM-Fahrauftrag 1
(bei diesem Kommando muß die Endstufe gesperrt sein)
OCOPY 1 201 Kopieren des ersten ROM-Fahrsatzes ins RAM (Nummer 201)
OCOPY 1 - 16 201 Kopieren der ROM-Fahrsätze 1...16 ins RAM (201...216)


ASCII Deutsch OLIST

ASCII - Kommando | OLIST |
Syntax Senden | OLIST [Data] [Data] |
Syntax Empfangen | OLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Fahrsatzdaten

Beschreibung

Mit dem Kommando "OLIST x anzahl" werden ausgehend von dem Fahrauftrag x die Inhalte von "anzahl" aufeinanderfolgenden Fahraufträgen ausgegeben. Die Bedeutung und die Reihenfolge der angezeigten Parameter entsprechen dabei den Parametern des ORDER-Kommandos.
Falls der Parameter "anzahl" fehlt, so wird nur der Inhalt des Fahrsatzes "x" angezeigt.
Falls beide Parameter "x" und "anzahl" fehlen, so werden die Inhalte aller gültigen Fahrsätze angezeigt (d.h. Fahrsätze mit gültigen Daten und korrekter Checksumme).


ASCII Deutsch OPMODE

ASCII - Kommando | OPMODE |
Syntax Senden | OPMODE [Data] |
Syntax Empfangen | OPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B4 (hex)
DIM | - | PROFIBUS PNU | 1780 (dec) IND = 1 (dec)
Bereich | 0, 1, .. , 8 | DPR | 180 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | control commands | EEPROM | Ja
Kurzbeschreibung | Betriebsart des Verstärkers

Beschreibung

Mit dem Kommando OPMODE kann die Betriebsart (Grundfunktion) des Verstärkers eingestellt werden. Diese Betriebsart kann zu jedem Zeitpunkt über Feldbus-Schnittstelle bzw. digitales I/O (INxMODE=24) umgeschaltet werden Es sind folgende Einstellungen möglich:
Zustand | Kurzbeschreibung | Beschreibung
OPMODE=0 | Drehzahl digital | Der Drehzahlsollwert kann entweder über die RS232-Schnittstelle (Kommando "J") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden.
OPMODE=1 | Drehzahl analog | Der Drehzahlsollwert wird von der Analogschnittstelle 1/2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=2 | Drehmoment digital | Der Stromsollwert kann entweder über die RS232-Schnittstelle (Kommando "T") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden.
OPMODE=3 | Drehmoment analog | Der Stromsollwert wird von der Analogschnittstelle Analog In 1/Analog In 2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=4 | Position elektrisches Getriebe (Master/Slave) | Elektronisches Getriebe Der Lageregler-Positionssollwert wird über die Master (Encoder) Schnittstelle vorgegeben. Die Art der zu verwendeten Schnittstelle kann mit dem Parameter GEARMODE vorgewählt werden.
OPMODE=5 | Position externe Trajektorie | Der Lageregler-Positionssollwert wird über die Feldbus-Schnittstelle (PROFIBUS,CANBUS,DPR-Slot-Karte) vorgegeben. Die Zykluszeit für die Vorgabe des Sollwertes kann mit dem Parameter PTBASE in 250µs-Schritten eingestellt werden. Der Lageregler sorgt dafür, dass die vorgegebene Sollposition innerhalb der eingestellten Zeit erreicht wird. Bei Einstellung ANCNFG=8 kann die externe Trajektorie über den Analogeingang Analog In 1 vorgegeben werden. Die analoge Spannung wird alle 250µs eingelesen und als Positionssollwert für die Lageregelung benutzt. Die Skalierung wird mit Hilfe der Parameter SRND (Position bei 0V) und ERND (Position bei +/- 10V) festgelegt. Bevor diese Funktion aktiv wird, muss zunächst eine Referenz fahrt gestartet werden.
OPMODE=6 | SERCOS | Der Sollwert wird über die SERCOS-Schnittstelle vorgegeben.
OPMODE=7 | Reserve |
OPMODE=8 | Position Fahrsätze | Bei dieser Einstellung können die internen Fahrsätze ausgeführt werden. Der interne Trajektoriengenerator, der bei dieser Einstellung aktiviert wird, sorgt dafür, dass die vorgegebene Fahrsatzposition mit den eingestellten Fahrsatz-Rampen und Fahrsatz-Geschwindigkeit angefahren wird.


ASCII Deutsch OPTION

ASCII - Kommando | OPTION |
Syntax Senden | OPTION |
Syntax Empfangen | OPTION <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 1 (dec)
Bereich | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Slotkarten-Kennung

Beschreibung

Das Kommando OPTION liefert die Kennung der erkannten Slot-Karte. Es sind zurzeit folgende Kennungen möglich:
H0000 keine Slot-Karte erkannt
H01xx I/O-Erweiterungskarte
H20xx RODSSI (nur S700)
H21xx SAFETY (nur S700)
H0Cxx PROFIBUS
H03xx SERCOS
H06xx kundenspezifisch
H8xxx kundenspezifisch
H88xx EtherCat

Die unteren 8 Bits (xx) zeigen die Hardware-Revision der entsprechenden Karte.


ASCII Deutsch OPTION2

ASCII - Kommando | OPTION2 |
Syntax Senden | OPTION2 |
Syntax Empfangen | OPTION2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 1 (dec)
Bereich | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Slotkarten-Kennung

Beschreibung

Das Kommando OPTION2 liefert die Kennung der erkannten Slot-Karte. Es sind zurzeit folgende Kennungen möglich:
H0000 keine Slot-Karte erkannt
H20xx RODSSI (nur S700)
H21xx SAFETY (nur S700)

Die unteren 8 Bits (xx) zeigen die Hardware-Revision der entsprechenden Karte.


ASCII Deutsch ORDER

ASCII - Kommando | ORDER |
Syntax Senden | ORDER [Data1...Data10] |
Syntax Empfangen | ORDER | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer32 ... Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 200, 201 .. 300 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Definition eines Fahrsatzes

Beschreibung

Mit dem ORDER-Kommando kann ein beliebiger RAM/EEprom-Fahrsatz vollständig definiert werden. Das Kommando ORDER kann in 3 verschiedenen Formen benutzt werden:

ORDER Es wird der Inhalt des Direkt-Fahrsatzes (nr=0) angezeigt
ORDER nr Es wird der Inhalt des Fahrsatzes Nummer "nr" angezeigt
ORDER nr o_p o_v o_c o_acc o_dec o_tab reserviert o_fn o_ft = Definition des Fahrsatzes "nr"

Der Parameter "nr" gibt die Nummer des zu definierenden Fahrsatzes an. Die Fahrsatznummer kann folgende Werte annehmen:

0 - lokaler Fahrsatz/ Direktfahrsatz

1...200 EEprom-Fahrsätze,
die EEprom -Fahrsätze werden in einem Segment des internen Flash-Speichers abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.

201..300 RAM-Fahrsätze,
die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der EEprom-Fahrsätze 1...100 vorinitialisiert.

Die einzelnen Komponenten o_p ... o_ft haben die gleiche Bedeutung wie die entsprechende ASCII-Kommandos.

O_P Zielposition/Verfahrstrecke des Fahrsatzes
O_V Zielgeschwindigkeit
O_C Fahrsatzart (Kontrollwort)
O_ACC Anfahrrampe/Anfahrbeschleunigung
O_DEC Bremsrampe/Bremsbeschleunigung
O_TAB Nr der Lookup - Tabelle

O_FN Nummer des Folgefahrsatzes
O_FT Verzögerungszeit vor dem Start des Folgefahrsatzes


ASCII Deutsch OTUNE

ASCII - Kommando | OTUNE |
Syntax Senden | OTUNE [Data] |
Syntax Empfangen | OTUNE <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 100 ... 800 Hz | DPR | Nein
Default | 250 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Optimierungsfunktion VLO-Parameter

Beschreibung

Das Kommando „OTUNE [data]“ startet eine Optimierungsfunktion für den VLO-Parameter. Die Optimierung erfolgt bei der Frequenz „data“.


ASCII Deutsch OVRIDE

ASCII - Kommando | OVRIDE |
Syntax Senden | OVRIDE [Data] |
Syntax Empfangen | OVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35B6 (hex)
DIM | - | PROFIBUS PNU | 1782 (dec) IND = 1 (dec)
Bereich | 0 .. 7 | DPR | 182 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Override-Funktion

Beschreibung

Mit Override-Funktion kann die Geschwindigkeit eines Fahrsatzes, der Referenzfahrt und des Tippbetriebes über die analoge/digitale Schnittstelle beeinflußt werden. Wenn diese Funktion aktiviert ist, so wird jede msek der analoge Sollwert eingelesen und für die Skalierung der Fahrsatzgeschwindigkeit benutzt.
SW=10V Fahrsatzgeschwindigkeit = Zielgeschwindigkeit, die im Fahrsatz programmiert ist
SW=5V Fahrsatzgeschwindigkeit = 50% der programmierten Zielgeschwindigkeit

Die OVERRIDE – Funktion ist nicht bei sin^2 – Rampen möglich !

Es sind folgende Einstellungen möglich:
OVRIDE=0 Override-Funktion abgeschaltet
OVRIDE=1 SW1-Eingang für die Override-Funktion aktiviert
OVRIDE=2 SW2-Eingang für die Override-Funktion aktiviert
OVRIDE=3 DigitaleSchnittstelle für die Override-Funktion aktiviert. Die dig. Schnittstellen können sein: Sercos, PROFIBUS, CAN, DPR und alle weiteren Feldbusse.

S300/S700: Erweiterung der Funktion von OVRIDE ab der Firmware 1.37

OVRIDE=4 Begrenzung der Fahrsatz-Geschwindigkeit durch die Master-Geschwindigkeit

Bei Verwendung von Fahrsätzen im Master/Slave-Betrieb (Überlagerung) wird die Fahrsatz-Geschwindigkeit so begrenzt, daß kein Vorzeichenwechsel bei der Slave-Geschwindigkeit (Master + Fahrsatz) erfolgt.

Beispiel 1: Master-Geschwindigkeit (PSPEED1) = +1000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf den Bereich (-1000...PVMAX) begrenzt.

Beispiel 2: Master-Geschwindigkeit (PSPEED1) = -2000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf den Bereich (-PVMAX...+2000) begrenzt.

OVRIDE=5 Begrenzung der Fahrsatz-Geschwindigkeit durch die positive Master-Geschwindigkeit

Bei negativer Master-Geschwindigkeit wird die Fahrsatz-Geschwindigkeit auf 0 begrenzt.

Beispiel 1: Master-Geschwindigkeit (PSPEED1) = +1000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf den Bereich (-1000...PVMAX) begrenzt.

Beispiel 2: Master-Geschwindigkeit (PSPEED1) = -2000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf 0 begrenzt.

OVRIDE=6 Begrenzung der Fahrsatz-Geschwindigkeit durch die negative Master-Geschwindigkeit

Bei positiver Master-Geschwindigkeit wird die Fahrsatz-Geschwindigkeit auf 0 begrenzt.

Beispiel 1: Master-Geschwindigkeit (PSPEED1) = +1000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf 0 begrenzt.

Beispiel 2: Master-Geschwindigkeit (PSPEED1) = -2000
die Fahrsatz-Geschwindigkeit (PSPEED3) wird auf den Bereich (-PVMAX...+2000) begrenzt.


ASCII Deutsch P

ASCII - Kommando | P |
Syntax Senden | P [Data] |
Syntax Empfangen | P <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38D2 (hex)
DIM | Watt [W] | PROFIBUS PNU | 1778 (dec) IND = 33 (dec)
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | aktuelle Wirkleistung (elektrisch)

Beschreibung

Aus Ist-Strom und Spannungssollwerten errechnete momentane elektrische Wirkleistung, die an den Motor weitergegeben wird.


ASCII Deutsch P1

ASCII - Kommando | P1 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3644 (hex)
DIM |  | PROFIBUS PNU | 1924 (dec) IND = 1 (dec)
Bereich |  | DPR | 324 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P1_P16

ASCII - Kommando | P1_P16 |
Syntax Senden | P1 [Data] |
Syntax Empfangen | P1_P16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | long int | DPR | (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle 1...16

Beschreibung

Die Variablen P1...P16 enthalten die Positionswerte für die Positionsschwellen 1...16.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

P[Inkremente] = P[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von WPOS, WPOSE, WPOSP, WPOSX, POSRSTAT

Die angegebene Objektnummer gilt für P1. Die Objektnummer bis P16 sind aufsteigend.


ASCII Deutsch P2

ASCII - Kommando | P2 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3645 (hex)
DIM |  | PROFIBUS PNU | 1925 (dec) IND = 1 (dec)
Bereich |  | DPR | 325 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P3

ASCII - Kommando | P3 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3646 (hex)
DIM |  | PROFIBUS PNU | 1926 (dec) IND = 1 (dec)
Bereich |  | DPR | 326 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P4

ASCII - Kommando | P4 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3647 (hex)
DIM |  | PROFIBUS PNU | 1927 (dec) IND = 1 (dec)
Bereich |  | DPR | 327 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P5

ASCII - Kommando | P5 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3648 (hex)
DIM |  | PROFIBUS PNU | 1928 (dec) IND = 1 (dec)
Bereich |  | DPR | 328 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P6

ASCII - Kommando | P6 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3649 (hex)
DIM |  | PROFIBUS PNU | 1929 (dec) IND = 1 (dec)
Bereich |  | DPR | 329 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P7

ASCII - Kommando | P7 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364A (hex)
DIM |  | PROFIBUS PNU | 1930 (dec) IND = 1 (dec)
Bereich |  | DPR | 330 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P8

ASCII - Kommando | P8 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364B (hex)
DIM |  | PROFIBUS PNU | 1931 (dec) IND = 1 (dec)
Bereich |  | DPR | 331 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P9

ASCII - Kommando | P9 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364C (hex)
DIM |  | PROFIBUS PNU | 1932 (dec) IND = 1 (dec)
Bereich |  | DPR | 332 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P10

ASCII - Kommando | P10 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364D (hex)
DIM |  | PROFIBUS PNU | 1933 (dec) IND = 1 (dec)
Bereich |  | DPR | 333 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P11

ASCII - Kommando | P11 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364E (hex)
DIM |  | PROFIBUS PNU | 1934 (dec) IND = 1 (dec)
Bereich |  | DPR | 334 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P12

ASCII - Kommando | P12 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 364F (hex)
DIM |  | PROFIBUS PNU | 1935 (dec) IND = 1 (dec)
Bereich |  | DPR | 335 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P13

ASCII - Kommando | P13 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3650 (hex)
DIM |  | PROFIBUS PNU | 1936 (dec) IND = 1 (dec)
Bereich |  | DPR | 336 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P14

ASCII - Kommando | P14 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3651 (hex)
DIM |  | PROFIBUS PNU | 1937 (dec) IND = 1 (dec)
Bereich |  | DPR | 337 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P15

ASCII - Kommando | P15 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3652 (hex)
DIM |  | PROFIBUS PNU | 1938 (dec) IND = 1 (dec)
Bereich |  | DPR | 338 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


ASCII Deutsch P16

ASCII - Kommando | P16 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3653 (hex)
DIM |  | PROFIBUS PNU | 1939 (dec) IND = 1 (dec)
Bereich |  | DPR | 339 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle

Beschreibung

sieheP1_P16


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Parameterumschaltung

basis

Wesentliche Regelungsparameter können zwischen zwei Werten schnell umgeschaltet werden, zum Beispiel für zwei stark unterschiedliche Lasten am selben Antrieb.

Auf dieser Bildschirmseite sind alle umschaltbaren Parameter dargestellt. Doppelklicken auf einen Parameterwert in der Tabelle öffnet ein kleines Bearbeitungsfenster zum Ändern des Wertes. Schließen Sie die Eingabe mit Return ab. Verlassen der Eingabefelder ist auch mit der ESC Taste möglich.

Die Umschaltung zwischen den beiden Parametersätzen kann entweder über einen digitalen Eingang (Funktion 57, Beispiel für Digitaleingang 1: IN1MODE) oder aber automatisch durch eine interne Funktion erfolgen.

Über den ASCII Parameter PARCNFG können Sie die interne Funktion definieren, während deren Ausführung der zweite (alternative) Parametersatz aktiviert ist. Hier können Sie entweder Wake&Shake, Fahrsatz oder Betriebsart anwählen.

Schaltfläche | ASCII-Parameter
"Zurücksetzen des zweiten Parametersatzes" | Setzt die Werte im alternativen Parametersatz auf die Standardwerte zurück.
"Benutzereingaben zurücksetzen" | Setzt alle Eingaben in beiden Parametersätzen auf den Ursprungswert zurück.
"Speichern aller Parameter im Drive" | Überträgt alle angezeigten Parameterwerte und beide Parametersätze in den Servoverstärker.


ASCII Deutsch PARCNFG

ASCII - Kommando | PARCNFG |
Syntax Senden | PARCNFG [Data] |
Syntax Empfangen | PARCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 375D (hex)
DIM |  | PROFIBUS PNU | 1805 (dec) IND = 17 (dec)
Bereich |  | DPR | 605 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.11 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Parameter Umschaltbedingung

Beschreibung

Mit dem Kommando PARCNFG können alle umschaltbaren Reglerparameter, dies sind die Parameter GP,GPFFT,GPFFV,GV,GVFR,GVTN,KC,KTN,MICONT,MIPEAK,MJ,MKT,ML
MLGC,MLGD,MLGP,MLGQ,MPOLES,MRS,MTIME mit der Endung _X beeinflußt werden.

Umschaltung der aktiven Parameter
Die Umschaltung zwischen den beiden Parametersätzen kann entweder über einen digitalen Eingang oder aber durch eine interne Funktion erfolgen.

Umschaltung über dig. Eingang:
Eine Umschaltung des Parametersatzes über einen digitalen Eingang ist mit der Funktion INxMODE=57 möglich. Es darf nur ein einziger digitaler Eingang mit dieser Funktion belegt sein (ansonsten Warnung n24 – Parameterfehler). Falls ein digitaler Eingang mit der Funktion 57 konfiguriert wurde, ist keine Funktionsumschaltung der Parametersätze möglich d.h. PARCNFG muß auf 0 stehen (sonst Warnung n24 – Parameterfehler). Der Pegel des digitalen Eingangs bestimmt welcher Parametersatz aktiv ist:
- Low : Hauptparametersatz
- High : zweiter Parametersatz

Automatisches Umschalten
abhängig von dem Zustand des Verstärkers. Mit Hilfe der Bit-Variable PARCNFG können interne Funktionen definiert werden, bei denen der zweite Parametersatz automatisch aktiviert wird.

PARCNFG = 0x0000 keine automatische Parameterumschaltung
PARCNFG = 0x0001 der zweite Parametersatz wird für die Dauer des Wake&Shake-Betriebes aktiviert.
PARCNFG = 0x0002 der zweite Parametersatz wird für die Dauer eines Fahrsatzes (Referenzfahrt/Tippbetrieb) aktiviert.
PARCNFG = 0x0004 der zweite Parametersatz wird für die OPMODE =4..8 aktiviert. Für OPMODE 0...3 gilt der Parametersatz 1.
Mit Hilfe der Parameter ACC_X und DEC_X ist es möglich unterschiedliche Drehzahlreglerrampen ACC und DEC für OPMODE 0..3 und 4...8 zu konfigurieren.

Siehe auch PARDUMP, PARRST


ASCII Deutsch PARDUMP

ASCII - Kommando | PARDUMP |
Syntax Senden | PARDUMP |
Syntax Empfangen | PARDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | String
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Auflistung der umschaltbaren Parameter

Beschreibung

Das Kommando PARDUMP listet alle umschaltbaren Parameter ACC,DEC,GP,GPFFT,GPFFV,GV,GVFR,GVTN,KC,KTN,MICONT,MIPEAK,MJ,MKT,ML
MLGC,MLGD,MLGP,MLGQ,MPOLES,MRS,MTIME,VLO

Beispiel:

GP 0.1 (GP_X 0.2)
GV 1.5 (GV_X 3)
Data Set 1 activ


ASCII Deutsch PARRST

ASCII - Kommando | PARRST |
Syntax Senden | PARRST [Data] |
Syntax Empfangen | PARRST <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | drive configuration | EEPROM |
Kurzbeschreibung | Basis parametersatz in 2. Parametersatz laden

Beschreibung

Das Kommando PARRST setzt alle Parameters des 2. Parametersatzes auf die Werte des Hauptparametersatzes.

siehe auch PARCNFG, PARDUMP


ASCII Deutsch PASS

ASCII - Kommando | PASS |
Syntax Senden | PASS [Data] |
Syntax Empfangen | PASS <Data> | Vorhanden in |
Type | Variable w | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 36D5 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 17 (dec)
Bereich | -2147483647...2147483648 | DPR | Nein
Default | 0 |
Opmode |  | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM |
Kurzbeschreibung | Password Eingabe

Beschreibung

Bei aktiviertem Password-Schutz (PASSX = y) ist eine Änderung von Verstärker-Parametern nur nach
der Eingabe eines gültigen Passwort-Wertes möglich (“PASS y”).


ASCII Deutsch PASSCNFG

ASCII - Kommando | PASSCNFG |
Syntax Senden | PASSCNFG [Data] |
Syntax Empfangen | PASSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D8 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 17 (dec)
Bereich | 0 .. 2 | DPR | 472 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 3.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM |
Kurzbeschreibung | Passwort Funktion

Beschreibung

Mit dem Kommando PASSCNFG kann die Art der Passwort-Funktion konfiguriert werden.

PASSCNFG = 0 bei aktiviertem Passwortschutz sind alle Parameter-Schreibzugriffe gesperrt.

PASSCNFG = 1 bei aktiviertem Passwortschutz ist nur das Kommando SAVE gesperrt.

PASSCNFG = 2 bei aktiviertem Passwortschutz ist kein Parameter-Zugriff möglich (kein Lesen und kein Schreiben). Lediglich das Kommando PASS ist erlaubt

PASSCNFG = 3 die Kommandos RSTVAR und SAVE sind nicht erlaubt und können nur nach Eingabe eines Passwortes (PASS/PASSX) ausgeführt werden.

siehe auch PASS,PASSX


ASCII Deutsch PASSPLC

ASCII - Kommando | PASSPLC |
Syntax Senden | PASSPLC [Data] |
Syntax Empfangen | PASSPLC <Data> | Vorhanden in |
Type | Variable w | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3899 (hex)
DIM |  | PROFIBUS PNU | 1721 (dec) IND = 33 (dec)
Bereich | -2147483647...2147483647 | DPR | 921 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.63 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Passwort für PLC Programm

Beschreibung

Bei aktiviertem Password-Schutz (PASSXPLC = y) ist die Benutzung der PLC-Kommandos erst nach
der Eingabe eines gültigen Passwort-Wertes möglich (“PASSPLC y”).


ASCII Deutsch PASSX

ASCII - Kommando | PASSX |
Syntax Senden | PASSX [Data] |
Syntax Empfangen | PASSX <Data> | Vorhanden in |
Type | Variable w | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36D4 (hex)
DIM |  | PROFIBUS PNU | 1668 (dec) IND = 17 (dec)
Bereich | -2147483647...2147483648 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Passwort-Schutz aktivieren

Beschreibung

Mit dem Parameter PASSX kann der Passwort-Schutz für die Parameter-Eingaben aktiviert werden.
PASSX=0 kein Passwortschutz
PASSX =y Die Parametereingaben sind erst nach der Eingabe des Passwortes “PASS y” möglich.


ASCII Deutsch PASSXPLC

ASCII - Kommando | PASSXPLC |
Syntax Senden | PASSXPLC |
Syntax Empfangen | PASSXPLC 0 | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 389A (hex)
DIM |  | PROFIBUS PNU | 1722 (dec) IND = 33 (dec)
Bereich | -2147483647...2147483647 | DPR | 922 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.63 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Einstellung für Passwortschutz für PLC-Proframme

Beschreibung

Mit dem Parameter PASSXPLC kann der Passwort-Schutz für das PLC-Programm aktiviert werden.

PASSXPLC=0 Passwortschutz ausgeschaltet
PASSXPLC=y Passwortschutz eingeschaltet

Die PLC-Kommandos sind erst nach der Eingabe des Passwortes “PASSPLC y” möglich.


ASCII Deutsch PBAL

ASCII - Kommando | PBAL |
Syntax Senden | PBAL |
Syntax Empfangen | PBAL <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C0 (hex)
DIM | W | PROFIBUS PNU | 1792 (dec) IND = 1 (dec)
Bereich | 0 .. 1500 | DPR | 192 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Istwert der Ballastleistung

Beschreibung

Istwert der mittleren Ballastleistung


ASCII Deutsch PBALMAX

ASCII - Kommando | PBALMAX |
Syntax Senden | PBALMAX [Data] |
Syntax Empfangen | PBALMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C1 (hex)
DIM | W | PROFIBUS PNU | 1793 (dec) IND = 1 (dec)
Bereich | see Manual | DPR | 193 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Maximale Ballastleistung

Beschreibung

Mit diesem Parameter kann die Dauerleistung des Ballastwiderstandes begrenzt werden.
Falls der Istwert der Ballastleistung den eingestellten Maximalwert überschreitet, so wird der Ballastwiderstand abgeschaltet. Als Folge kann die Fehlermeldung "Überspannung" ausgelöst werden. Bei einem zu hohen Maximalwert kann der Ballastwiderstand überlastet werden.

Defaultwerte:

bei PBALRES = 0
SR 303, SR 341 20 W
SR 306, SR 310, SR 343, SR 346 50 W

bei PBALRES >= 1
SR 303, SR 341 300W
SR 306, SR 310, SR 343, SR 346 1000 W

Anmerkung: Aus der Sicht des Verstärkers handelt es sich bei PBALMAX um die max. Leistung, die dauerhaft an den Ballastwiderstand abgegeben wird. Aus der Sicht des Widerstandes ist das die Nennleistung.


ASCII Deutsch PBALRES

ASCII - Kommando | PBALRES |
Syntax Senden | PBALRES [Data] |
Syntax Empfangen | PBALRES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35C2 (hex)
DIM | - | PROFIBUS PNU | 1794 (dec) IND = 1 (dec)
Bereich | 0 ... 200 | DPR | 194 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Vorwahl des Ballastwiderstandes

Beschreibung

Über diesen Paramerter kann vorgerwählt werden, ob der interne (0) oder ein externer (> 0) Ballastwiderstand verwendet werden soll. Der Wert > 0 gibt den Ballastwiderstand in Ohm an.

Abhängig vom Reglertyp sind nur bestimmte Widerstandswerte zulässig. Maßgebend sind die Angaben im Installationshandbuch. (Rev.1.1)

Beeinflusst den Parameter PBALMAX.


ASCII Deutsch PBAUD

ASCII - Kommando | PBAUD |
Syntax Senden | PBAUD |
Syntax Empfangen | PBAUD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35C3 (hex)
DIM | kBaud | PROFIBUS PNU | 1795 (dec) IND = 1 (dec)
Bereich | 1.0 .. 12000.0 | DPR | 195 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Profibus-Baudrate

Beschreibung

Das Kommando PBAUD liest die aktuelle PROFIBUS - Baudrate aus. Die Baudrate wird vom Master (Steuerung) vorgegeben. Der Verstärker erkennt dies Baudrate automatisch.
Es sind folgende Baudraten möglich [in kBaud]:
12000
6000
3000
1500
500
187.5
93.75
45.45
19.2
9.6


ASCII Deutsch PE

ASCII - Kommando | PE |
Syntax Senden | PE |
Syntax Empfangen | PE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C5 (hex)
DIM | µm | PROFIBUS PNU | 1797 (dec) IND = 1 (dec)
Bereich | long int | DPR | 197 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Istwert des Schleppfehlers

Beschreibung

Der Schleppfehler stellt die aktuelle Differenz zwischen dem Lagesoll- und dem Lageistwert dar
und wird in den Einheiten des Lagereglers angezeigt (PGEARI / PGEARO).
s. Beschreibung von PFB


ASCII Deutsch PEINPOS

ASCII - Kommando | PEINPOS |
Syntax Senden | PEINPOS [Data] |
Syntax Empfangen | PEINPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C6 (hex)
DIM | PUNIT | PROFIBUS PNU | 1798 (dec) IND = 1 (dec)
Bereich | long int | DPR | 198 (dec)
Default | 4000 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | In-Position-Fenster

Beschreibung

Falls bei Ausführung eines internen Fahrsatzes die Entfernung zwischen der aktuellen Position und der Zielposition die eingestellte Fenstergröße unterschreitet, so wird die Meldung In-Position generiert (Statusmeldung, Digitaler Ausgang).
Das In-Position-Fenster wird in den Einheiten des Lagereglers eingegeben (PGEARI / PGEARO).
s. Beschreibung von PFB

Im Master/Slave-Betrieb (OPMODE=4) definiert dieser Parameter die Fenster-Größe für die Erfassung der Master-Vorgaben bei gesperrter Slave-Endstufe. Bei PEINPOS=0 und gesperrter Endstufe werden alle Master-Positionsveränderungen von dem Slave ignoriert.

Bei PEINPOS>0 werden die Positionsveränderungen des Masters bis zu der Fenstergröße (bezogen auf den Slave) mitberücksichtigt, d.h der Schleppfehler des Slaves wird innerhalb dieses Fensters nicht zu 0 gesetzt und es kann maximal die Größe des Fensters erreichen.

Vorsicht: beim Freigeben der Endstufe wird dieser Schleppfehler schlagartig abgebaut. Dies kann zu einem plötzlichen Ruck des Slaves führen.

Die absolute Position für ENDAT,HIPERFACE und SSI wird bei bestimmten FBTYPE-Einstellungen nur während der Initialisierung eingelesen (beim Einschalten des Verstärkers). Um Fehllesungen auszuschliessen wird die Position bis zu 5 Mal gelesen. Die Position wird nur dann als gültig übernommen, wenn die Differenz zwischen zwei benachbarten Lesungen kleiner ist als der Wert des In-Position-Fensters PEINPOS. Bei zu großen Positionsabweichungen wird F04 ausgegeben.


ASCII Deutsch PEMAX

ASCII - Kommando | PEMAX |
Syntax Senden | PEMAX [Data] |
Syntax Empfangen | PEMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C7 (hex)
DIM | µm | PROFIBUS PNU | 1799 (dec) IND = 1 (dec)
Bereich | long int | DPR | 199 (dec)
Default | 262144 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Max. Schleppfehler

Beschreibung

Falls der aktuelle Schleppfehler (PE) den eingestellten Maximalwert überschreitet, so wird der Fahrsatz abgebrochen und die Warnung "Schleppfehler" generiert. Erst nachdem diese Warnung quittiert wird (Kommando CLRFAULT, digitaler Eingang INxMODE=14), kann der Fahrsatz Fortgesetzt (CONTINUE) oder neu gestartet werden.

Die Einstellung PEMAX=0 schaltet die Schleppfehlerüberwachung ab.

Negative Werte in PEMAX führen nicht zu einem Stillsetzen der Achse bei Schleppfehler. Das Statusbit und die Warnung werden allerdings gesetzt. Bas Bit bleibt solane gesetzt, bis der Schleppfehler quittiert wird bzw. ein neuer Fahrsatz gestartet wird


ASCII Deutsch PFB

ASCII - Kommando | PFB |
Syntax Senden | PFB |
Syntax Empfangen | PFB <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C8 (hex)
DIM | µm | PROFIBUS PNU | 1800 (dec) IND = 1 (dec)
Bereich | long int | DPR | 200 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | aktuelle Lagereglerposition

Beschreibung

Das Kommando PFB liefert den Istwert der Lageregler-Position. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO und PRBASE.

PFB = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen, 1048576/Umdrehung bei PRBASE=20, 65536/Umdrehung bei PRBASE=16
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB-Kommando die internen Einheiten(Counts).

Wenn die Positionsinformation eines externen Gebers erfasst wird (EXTPOS=1,2,3), so kann diese Information mit Hilfe des PFB0 - Kommandos angezeigt werden.


ASCII Deutsch PFB0

ASCII - Kommando | PFB0 |
Syntax Senden | PFB0 [Data] |
Syntax Empfangen | PFB0 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C9 (hex)
DIM | Counts | PROFIBUS PNU | 1801 (dec) IND = 1 (dec)
Bereich | - | DPR | 201 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Lagereglerposition über den externen Encoder

Beschreibung

Das Kommando PFB0 liefert den Positions-Istwert, der anhand der Positionsinformation eines externen Gebers berechnet wird. Die Position über einen externen Geber wird nur dann erfasst, wenn die Konfigurationsvariable EXTPOS auf 1,2,3 steht. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO und ENCIN ab.

PFB0 = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB0-Kommando die internen Einheiten(Counts).


ASCII Deutsch PFBHI

ASCII - Kommando | PFBHI |
Syntax Senden | PHBHI [Data] |
Syntax Empfangen | PFBHI <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3876 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 886 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.05 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | gibt die unteren 32 Bits der akt 64 Bit Position

Beschreibung

Das Kommando PFBHI latcht (speichert) die aktuelle 64 Bit-Position (PFB) und liefert die oberen 32 Bit. Mit dem Kommando PFBLO kann die untere Hälfte (unteren 32 Bits) der 64 Bit-Position ausgelesen werden.


ASCII Deutsch PFBLO

ASCII - Kommando | PFBLO |
Syntax Senden | PFBLO [Data] |
Syntax Empfangen | PFBLO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3875 (hex)
DIM | - | PROFIBUS PNU | 1685 (dec) IND = 33 (dec)
Bereich | 32 Bit | DPR | 885 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.05 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | gibt die unteren 32 Bits der akt 64 Bit Position

Beschreibung

Das Kommando PFBLO latcht (speichert) die aktuelle 64 Bit-Position (PFB) und liefert die unteren 32 Bit. Mt dem Kommando PFBHI kann die obere Hälfte (oberen 32 Bits) der 64 Bit-Position ausgelesen werden.


ASCII Deutsch PGEARI

ASCII - Kommando | PGEARI |
Syntax Senden | PGEARI [Data] |
Syntax Empfangen | PGEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CA (hex)
DIM | µm | PROFIBUS PNU | 1802 (dec) IND = 1 (dec)
Bereich | 1 ... 2147483647 | DPR | 202 (dec)
Default | 10000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Zähler)

Beschreibung

Beschreibung:

Der Parameter PGEARI wird in Verbindung mit dem Parameter PGEARO benutzt, um die Lageregler-Position und Geschwindigkeit von benutzerdefinierten Einheiten auf Inkremente umzurechnen.

PGEARI stellt dabei die Anzahl der benutzerdefinierten Einheiten pro PGEARO Umdrehungen dar. Um welche Einheit es sich dabei handelt, bestimmt der Anwender mit der Einstellung PGEARI/PGEARO.

Achtung: Aus Kompatibilitätsgründen findet bei der Einstellung PGEARI=PGEARO*(2^PRBASE) keine Umrechnung der SI-Einheiten statt. In diesem Fall muss die Position/Geschwindigkeit in Inkrementen vorgegeben werden!

Beispiel 1:

Bewegt sich ein Fließband bei einer Motorumdrehung um 3 cm und soll die Auflösung der benutzerdefinierten Einheiten mm betragen, so muss der Wert PGEARI/PGEARO=30000 betragen. Als zweckmäßig erweist sich die Einstellung PGEARI=30000 und PGEARO=1. Der Anwender ist nun in der Lage, die Positionsvorgabe in mm vorzunehmen.

Wird dem Fließband anschließend ein Getriebe, z.B. mit einer Übersetzung von 3:1, vorgeschaltet, so braucht der Parameter PGEARO nur auf den Wert 3 gesetzt zu werden. Auch ungerade Werte eines Getriebes (z.B. 2.5:1) sind möglich. Dazu wird PGEARI mit dem Faktor 2 und PGEARO mit dem Faktor 5 multipliziert.

Beispiel 2:

Ein Fahrauftrag soll mit einer bestimmten Geschwindigkeit abgefahren werden. Dazu muss im Kontrollwort des Fahrauftrags o_c das Bit 13 gesetzt sein. Die Geschwindigkeit o_v des Fahrauftrags wird in diesem Fall in benutzerdefinierte Einheiten pro Sekunde angegeben. Diese Geschwindigkeit muss durch PGEARI/PGEARO geteilt werden und man erhält die Motordrehzahl in der Einheit U*sek^-1.

o_v = 10000; PGEARI = 1000; PGEARO = 1

n [U*sek^-1] = o_v / ( PGEARI / PGEARO )

Einige Beispiele zur Einstellung der Auflösung :

Resolution = PGEARI / PGEARO

Linearmotor >>> 1

Drehtisch >>> 2

Drehtisch am Umfang angetrieben >>> 3

Spindel >>> 4

Riemenantrieb >>> 5


ASCII Deutsch PGEARO

ASCII - Kommando | PGEARO |
Syntax Senden | PGEARO [Data] |
Syntax Empfangen | PGEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CB (hex)
DIM | µm | PROFIBUS PNU | 1803 (dec) IND = 1 (dec)
Bereich | 1 .. 2048 | DPR | 203 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Nenner)

Beschreibung

Beschreibung:

Der Parameter PGEARO wird in Verbindung mit dem Parameter PGEARI benutzt, um die Lageregler-Position und Geschwindigkeit von benutzerdefinierten Einheiten auf interne Inkremente umzurechnen. PGEARO bestimmt zusammen mit PRBASE die Anzahl der Inkremente die gefahren werden, wenn die zu fahrende Strecke PGEARI beträgt.
Die Umrechnung erfolgt nach folgender Formel:

Position[Inkremente] = Position[benutzerdef. Einheiten] * PGEARO * 2^PRBASE / PGEARI
Geschwindigkeit [Inkremente/250us] = Geschwindigkeit[benutzerdef. Einheiten] * PGEARO * 2^PRBASE / (PGEARI * 4000)

Position: 1 Umdrehung = 2^PRBASE Inkremente
Geschwindigkeit: Drehzahl [UPM] * 2^PRBASE / (4000 *60)

Der Maximalwert für PGEARO ist abhhängib von PRBASE und errechnet sich aus 2^(31-PRBASE)

Achtung: Aus Kompatibilitätsgründen findet bei der Einstellung PGEARI=PGEARO*(2^PRBASE) keine Umrechnung der SI-Einheiten statt. In diesem Fall muss die Position/Geschwindigkeit in Inkrementen vorgegeben werden!

Beispiele siehe PGEARI und PRBASE


ASCII Deutsch PIOBUF

ASCII - Kommando | PIOBUF |
Syntax Senden | PIOBUF [Data] |
Syntax Empfangen | PIOBUF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35CC (hex)
DIM | - | PROFIBUS PNU | 1804 (dec) IND = 1 (dec)
Bereich | - | DPR | 204 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Profibus-Daten

Beschreibung

Dieses Kommando liest die PROFIBUS Eingangs- und Ausgangsbuffer aus. Der Ausgangsbuffer beschreibt die Datenrichtung von der Steuerung zum Verstärker - der Eingangsbuffer beschreibt die Datenrichtung vom Verstärker zur Steuerung. Jeder Buffer besteht aus 20 Byte (Telegrammlänge) und setzt sich aus PKW – Teil (8 Byte bzw. 4 Worte)und PZD – Teil (12 Byte bzw. 6 Worte) zusammen. Die Darstellungsform der einzelnen Bytes ist hexadezimal.
PIOBUF liefert in der ersten Zeile 20 Byte Ausgangsbuffer und in der zweiten Zeile 20 Byte Eingangsbuffer.

Ist die Kommunikation über den Profibus gestört oder nicht vorhanden, wird die Fehlermeldung „ERR [PIOBUF] NO DATA EXCHANGE SPC3 - INTERRUPT“ generiert.


ASCII Deutsch PLLCOFFS

ASCII - Kommando | PLLCOFFS |
Syntax Senden | PLLCOFFS [Data] |
Syntax Empfangen | PLLCOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 20 | DPR | Nein
Default | 0 |
Opmode | all | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | PLL-Zähler außerhalb des Synchronisationsfensters

Beschreibung

Diese Variable gibt an, wie oft die Feldbus PLL-Routine hintereinander außerhalb des Synchronisationsfensters sein darf, bevor ein Synchronisationsfehler generiert wird. Dabei gilt Anzahl_OutOfSync = 1 + PLLCOFFS. D.h., bei PLLCOFFS = 4 darf die PLL 5 x hintereinander außerhalb des Synchronisationsfensters liegen, bevor ein Fehler (F28,F29) generiert wird.

Siehe auch ERRCODE *, PLLDOFFS, PLLWOFFS


ASCII Deutsch PLLDOFFS

ASCII - Kommando | PLLDOFFS |
Syntax Senden | PLLDOFFS [Data] |
Syntax Empfangen | PLLDOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | µs | PROFIBUS PNU | -
Bereich | 0 .. 1000 | DPR | Nein
Default | 0 |
Opmode | 5 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | verschieben der Synchronisationsroutine

Beschreibung

Mit dem Parammeter PLLDOFFS verschiebt man den Zeitpunkt der Synchronisationsroutine zeitlich gesehen um x[µs] weiter weg vom Sync.-Event (bei EtherCAT sind dies die zyklischen Sollwerte). Die Zeiteinheit dieses Kommandos ist [µs]. Dieser Wert addiert sich auf einen in der Software bereits fest kodierten Zeitabstand, welcher für verschiedene Feldbusse bzw. für verschiedene Zykluszeiten unterschiedliche Werte einnimmt.

Siehe auch ERRCODE *, PLLCOFFS, PLLWOFFS


ASCII Deutsch PLLHUB

ASCII - Kommando | PLLHUB |
Syntax Senden | PLLHUB [Data] |
Syntax Empfangen | PLLHUB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3921 (hex)
DIM | - | PROFIBUS PNU | 1857 (dec) IND = 33 (dec)
Bereich | 0 ... 6 | DPR | 1057 (dec)
Default | 1 |
Opmode |  | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Feldbus-Synchronisationsverhältnis

Beschreibung

Dieser Parameter legt fest, wie schnell der Antrieb mit der Feldbuskommunikation synchronisiert wird.
PLLHUB = 1 langsame Synchronisation
PLLHUB = 6 schnelle Synchronisation.

Anwendungen sollten möglichst mit kleinen Werten arbeiten (<3). Höhere Werte können Probleme mit der Feldbussynchronisation verursachen

Ab FW> = 6.02 steht der Parameter durch eine DPR Nummer für den Feldbuszugriff zur Verfügung.

siehe auch ERRCODE * = F28/F29


ASCII Deutsch PLLWOFFS

ASCII - Kommando | PLLWOFFS |
Syntax Senden | PLLWOFFS [Data] |
Syntax Empfangen | PLLWOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | µs | PROFIBUS PNU | -
Bereich | 0 .. 150 | DPR | Nein
Default | 0 |
Opmode | 5 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | Vergrößerung des Synchronisationsfensters

Beschreibung

Mit dem Parameter PLLWOFFS vergrößert man das Fenster, in dem die PLL-Routine als synchronisiert gilt. Die Zeiteinheit dieses Kommandos ist [µs]. Dieser Wert addiert sich auf eine in der Software bereits fest kodierten Fenstergröße, welche für verschiedene Feldbusse bzw. für verschiedene Zykluszeiten unterschiedliche Werte einnimmt.

Siehe auch ERRCODE *, PLLCOFFS, PLLDOFFS


ASCII Deutsch PMECH

ASCII - Kommando | PMECH |
Syntax Senden | P [Data] |
Syntax Empfangen | PMECH <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38D1 (hex)
DIM | Watt [W] | PROFIBUS PNU | 1777 (dec) IND = 33 (dec)
Bereich | - | DPR | 977 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.9
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | momentane mechanische Motorleistung (geschätzt)

Beschreibung

Aus Ist-Drehzahl und Ist-Strom zusammen mit der drehmomentkonstante MKT wird die momentane mechanische Leistung, die der Motor abgibt geschätzt.

Ab FW 5.68 mit DPR-Objekt-Nr 977


ASCII Deutsch PMODE

ASCII - Kommando | PMODE |
Syntax Senden | PMODE [Data] |
Syntax Empfangen | PMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CD (hex)
DIM | - | PROFIBUS PNU | 1805 (dec) IND = 1 (dec)
Bereich | 0 .. 8 | DPR | 205 (dec)
Default | (0) 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Netz-Phase Modus

Beschreibung

Der Parameter PMODE konfiguriert das Verhalten des Verstärkers am Netz

gilt nur beim S30x - diese Einstellung ist bei S34x nicht erlaubt!
PMODE=0 einphasiger Betrieb (Strombegrenzung)

gilt für S300/S700:
PMODE=1 dreiphasiger Betrieb, bei Netzphasenausfall wird der Strom begrenzt und die Warnung n05 generiert
PMODE=2 dreiphasiger Betrieb, bei Einbruch der Zwischenkreisspannung wird Fehlermeldung F19 generiert
PMODE=3 dreiphasiger Betrieb, bei Netzphasenausfall wird der Strom begrenzt und die Warnung n05 generiert
PMODE=4 Direkteinspeisung (DC)
PMODE=5 wie PMODE=1, die Warnung bzw. Fehler wird nur ausgegeben wenn die Endstufe enabeled wird
PMODE=6 wie PMODE=2, die Warnung bzw. Fehler wird nur ausgegeben wenn die Endstufe enabeled wird
PMODE=7 wie PMODE=3, die Warnung bzw. Fehler wird nur ausgegeben wenn die Endstufe enabeled wird
PMODE=8 reserveiert

Falls die Strombegrenzung aktiv wird, so gilt sie nur für die Beschleunigungsphasen. Ein Bremsvorgang kann weiterhin mit vollem Strom durchgeführt werden.


ASCII Deutsch PNOID

ASCII - Kommando | PNOID |
Syntax Senden | PNOID [Data] |
Syntax Empfangen | PNOID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CE (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 1 (dec)
Bereich | - | DPR | 206 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Profibus-Kennung (ID)

Beschreibung

Das Kommando PNOID liest die „Identnummer“ des Verstärkers aus. Anhand dieser Nummer ist der Verstärker im PROFIBUS Netz eindeutig als Teilnehmer zu identifizieren. Die Identnummer wird von der PROFIBUS - Nutzerorganisation vergeben und verwaltet.
Diese Gerätekennung ist auch Bestandteil der Gerätestammdaten (GSD).

PNOID liefert die Identnummer 045D hexadezimal.


ASCII Deutsch POSCNFG

ASCII - Kommando | POSCNFG |
Syntax Senden | POSCNFG [Data] |
Syntax Empfangen | POSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CF (hex)
DIM | - | PROFIBUS PNU | 1807 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 207 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Achsentyp

Beschreibung

Mit dem Parameter POSCNFG kann der Achsentype für die Lageregelung eingestellt werden. Es sind folgende Einstellungen möglich:
POSCNFG=0 Linearachse Achse mit begrenztem Verfahrbereich
Die Nullstellung für die Positionserfassung wird durch eine Referenzfahrt festgelegt. Bei dieser Einstellung ist das Setzen des Referenzpunktes die Voraussetzung für die Ausführung von Fahrsätzen.
Nachdem die Referenzfahrt (Setzen des Referenzpunktes) ausgeführt wurde, wird die Lagereglerposition laufend erfasst und behält bis zum Ausschalten des Verstärkers ihre Gültigkeit.
POSCNFG=1 Modulo-Achse Die Lagereglerposition wird auf den Bereich <SRND...ERND> beschränkt. Sobald das Ende dieses Bereiches (ERND-1) erreicht wird,
fängt die Position am Anfang (SRND) wieder an. Die absoluten Zielpositionen für die Fahrsätze müssen in dem gültigen Bereich liegen. Beim Versuch einen absoluten Fahrsatz zu starten dessen Zielposition außerhalb des Bereiches liegt, wird die Warnung n08
(fehlerhafter Fahrsatz) ausgegeben. Bei relativen Fahrsätzen wird die Zielposition so korrigiert, dass sie immer innerhalb des gültigen Bereiches liegt. Da beim Positionieren innerhalb des Modulo-Bereiches eine Zielposition von zwei Seiten angefahren werden kann, kann mit Hilfe der Variable DREF die Vorzugsrichtung für Absolutfahraufträge definiert werden.
Bezüglich des Referenzpunktes gelten die gleichen Einschränkungen wie bei POSCNFG=0 d.h. die Ausführung einer Referenzfahrt ist Voraussetzung für alle Positioniervorgänge.
Die Beschränkung auf den Modulo-Bereich gilt nicht während der Referenzfahrt d.h während der Referenzfahrt werden die Lagereglerpositionen ähnlich gehandhabt wie bei POSCNFG=0.
Erst nach Abschluß der Referenzfahrt,wird die Begrenzung auf den Modulo-Bereich aktiviert.
POSCNFG=2 Modulo-Achse mit zyklischem Speichern der 64bit Position entspricht POSCNFG=1 mit aktiviertem Abspeichern der 64 Bit-Position (siehe auch DRVCNFG2 Bit 22)


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Positionierdaten

einheiten

Hier passen Sie die Lagereglung den Bedingungen Ihrer Maschine an.

Bildschirmtext | ASCII-Parameter
Achsentyp | POSCNFG
Modulo-Fahrtrichtung | DREF
max.Schleppfehler | PEMAX
In-Position-Fenster | PEINPOS
Modulo-Start-Pos. | SRND
t | PTMIN
vmax (pos.) | PVMAXP
vmax (neg.) | PVMAXN
Modulo-End-Pos. | ERND
SW-Endschalter-Nr.1 (neg.) | SWCNFG
Position Nr.1 | SWE1
SW-Endschalter-Nr.2 (pos.) | SWCNFG
Position Nr.2 | SWE2

Die prinzipielle Position der Software-Endschalter sehen Sie in der Abbildung unten:

Legende

MA1: Maschinenanschlag links
HE1: Hardware-Endschalter links
NI: Nullpunkt-Initiator (Referenz)
SE1: Software-Endschalter 1
SE2: Software-Endschalter 2
HE2: Hardware-Endschalter rechts
MA2: Maschinenanschlag rechts
+: Zählrichtung positiv
–: Zählrichtung negativ


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Lageregler

einheiten

Einstellen der Lageregelung. Hier können Sie u.a. wählen, ob die Lageregelung mit einer externen Lagerückführung oder mit dem Feedbacksystem im Motor arbeiten soll. Im obigen Beispiel ist eine externe Lagerückführung angewählt.

Bildschirmtext | ASCII-Parameter
FF-Faktor v | GPFFV
Verstärkung (Kp_p) | GP
Integralzeit | GPTN
Externe Lagerückführung | EXTPOS
Zählrichtung | DIR
Striche pro Umdr. (Nur bei ext. Lagerückführung >0) | ENCLINES
Übersetzungsverhältnis (Zähler) (Nur bei ext. Lagerückführung >0) | EGEARO
Übersetzungsverhältnis (Nenner) (Nur bei ext. Lagerückführung >0) | EGEARI


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Lageregler Erweiterung

einheiten

Im oberen Diagramm stellen Sie eine geschwindigkeitsabhängige Lageregelung ein. Der Verstärkungsfaktor wird abhängig von der Geschwindigkeit verändert.

Das untere Diagramm erlaubt das Zuschalten eines Integralanteils für die Lageregelung abhängig von Schleppfehler und Geschwindigkeit.

Bildschirmtext | ASCII-Parameter
GP2 | GP2, Proportionalverstärkung 2, Lageregler
GP | GP, Proportionalverstärkung, Lageregler
GPS1 | GPS1, untere Geschwindigkeitsgrenze
GPS2 | GPS2, obere Geschwindigkeitsgrenze
GPeff | Effektivwert der Proportionalverstärkung GP
GPTN | GPTN, Integralanteil, Lageregler
MAXISETP | MAXISETP, maximaler Stromsollwert
PE | PE, Schleppfehler
V_CMD | V_CMD, bei OPMODEs 0, 1, 4, 5, 6, 7, 8 = Soll-Geschwindigkeit, bei OPMODEs 2, 3 = Ist-Geschwindigkeit
V_ACT | V_ACT, Ist-Geschwindigkeit


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Positionsregister

einheiten

Das Über- oder Unterschreiten von bis zu 16 Positionswerten innerhalb des Verfahrweges können Sie hier überwachen. Die aktuelle Position wird oben rechts angezeigt. Sie können den Zustand der Positionsregister über einen digitalen Ausgang melden (siehe Bildschirmseite I/O-digital)

Hinweise zum Einrichten eines Nockenschaltwerks finden Sie auf KDN Seite Nockenfunktion.

Bildschirmtext | ASCII-Parameter
Positions-Register | WPOS
Abfrage | WPOSX
Aktiv | WPOSE
Meldung | WPOSP
Pos. | P1...P16


ASCII Deutsch POSRSTAT

ASCII - Kommando | POSRSTAT |
Syntax Senden | POSRSTAT [Data] |
Syntax Empfangen | POSRSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3643 (hex)
DIM | - | PROFIBUS PNU | 1923 (dec) IND = 1 (dec)
Bereich | - | DPR | 323 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Status der schnellen Positionsregister 1...16

Beschreibung

Die Variable POSRSTAT liefert den aktuellen Status der schnellen Positionsregister.
Die Variable ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) als Statusinformation für Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

s. auch WPOS


ASCII Deutsch PPOTYP

ASCII - Kommando | PPOTYP |
Syntax Senden | PPOTYP [Data] |
Syntax Empfangen | PPOTYP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35D0 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 1 (dec)
Bereich | 2 | DPR | 208 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Profibus PPO-Typ

Beschreibung

Das Kommando PPOTYP liest den PROFIBUS DP Telegrammtyp aus. Der Verstärker unterstützt Telegrammtyp 2, d.h. das Telegramm besteht aus 10 Worte (20 Byte) und unterteilt sich in PKW – Teil (4 Worte) und PZD – Teil (6 Worte).

PPOTYP liefert den Wert 2.


ASCII Deutsch PRBASE

ASCII - Kommando | PRBASE |
Syntax Senden | PRBASE [Data] |
Syntax Empfangen | PRBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35D1 (hex)
DIM | - | PROFIBUS PNU | 1809 (dec) IND = 1 (dec)
Bereich | 1 ... 28 | DPR | 209 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | interne Lage-Auflösung

Beschreibung

Beschreibung:

Der Antrieb arbeitet intern mit einer 64 Bit Variablen um die Anzahl der Motorumdrehungen sowie die Lage der Motorwelle zu verarbeiten. Dabei dienen die oberen 32 Bit zum Zählen der Motorumdrehungen und die unteren 32 Bit zur Lageerfassung. Externe Steuerungen arbeiten allerdings meist nur mit einer 32Bit Variablen. Somit ist man gezwungen, 32Bit aus der 64Bit Variablen heraus zu kopieren und in einer zweiten Variablen abzuspeichern.

Mit PRBASE wird dieser internen 32Bit Variablen vorgegeben, wie viele Bits zur Lageauflösung zur Verfügung stehen. Die restlichen Bits dieser Variablen werden zum Zählen der Motorumdrehungen benutzt. Eine Änderung von PRBASE wird erst nach einem Neustart des Antriebs wirksam.

Achtung: Aus Kompatibilitätsgründen findet bei der Einstellung PGEARI=PGEARO*(2^PRBASE) keine Umrechnung der SI-Einheiten statt. In diesem Fall muss die Position/Geschwindigkeit in Inkrementen vorgegeben werden!

PRBASE=20:
20 Bits stehen zur Lageauflösung zur Verfügung. Mit den übrigen 12 Bits können maximal 2^12= 4096=+/-2047 Umdrehungen gezählt werden.

PRBASE=16:
16 Bits stehen zur Lageauflösung zur Verfügung. Mit den übrigen 16 Bits können maximal 2^16= 65536=+/-32767 Umdrehungen gezählt werden.

Beispiel:

Interne 64Bit Variable: 0x00000012 15E3A455
Umdrehungen Lage

Interne 32Bit Variable bei PRBASE=20 : 0x01215E3A

Interne 32Bit Variable bei PRBASE=16 : 0x001215E3


ASCII Deutsch PRD

ASCII - Kommando | PRD |
Syntax Senden | PRD [Data] |
Syntax Empfangen | PRD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D2 (hex)
DIM | Counts | PROFIBUS PNU | 1810 (dec) IND = 1 (dec)
Bereich | 0 .. 1048575 | DPR | 210 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | 20 Bit Feedback-Position

Beschreibung

Das Kommando PRD liefert eine 20 Bit-Position (absolut innerhalb einer Umdrehung), die anhand der Signale der Feedback-Einheit (FBTYPE) ermittelt wurde. Diese Position kann, im Gegensatz zu der Lagereglerposition PFB, nicht verändert werden.


ASCII Deutsch PRIOR1

ASCII - Kommando | PRIOR1 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 360C (hex)
DIM | - | PROFIBUS PNU | 1868 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch PRIOR2

ASCII - Kommando | PRIOR2 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 360D (hex)
DIM | - | PROFIBUS PNU | 1869 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch PRIOR3

ASCII - Kommando | PRIOR3 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3516 (hex)
DIM | - | PROFIBUS PNU | 1622 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch PRIOR4

ASCII - Kommando | PRIOR4 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3517 (hex)
DIM | - | PROFIBUS PNU | 1623 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch PRIOR5

ASCII - Kommando | PRIOR5 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351C (hex)
DIM | - | PROFIBUS PNU | 1628 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

PROFIBUS Erweiterungskarte

Diese Bildschirmseite erscheint nur, wenn eine PROFIBUS Erweiterungskarte in den Servoverstärker eingebaut ist.

Profibus1

Hier werden PROFIBUS-spezifische Parameter, der Busstatus und die Datenworte in Sende- und Empfangsrichtung, gesehen vom Bus-Master, angezeigt.

Diese Seite ist hilfreich bei der Fehlersuche und Inbetriebnahme der Bus-Kommunikation.

Baudrate | Hier wird die vom PROFIBUS-Master vorgegebene Baudrate angezeigt
PNO Identnr. | Die PNO-Identifikation ist die Nummer, die der Servoverstärker in der Liste der Ident-Nummern der PROFIBUS-Nutzerorganisation hat.
Adresse | Stationsadresse des Verstärkers (Einstellung siehe CAN/Feldbus)
PPO Typ | Der Servoverstärker unterstützt den PPO-Typ 2 des PROFIDRIVE-Profils.
Interface Zustände | Zeigt den aktuellen Status der Buskommunikation. Erst wenn die Meldung “Kommunikation OK” erscheint, können Daten über den PROFIBUS übertragen werden.
Eingang | das letzte vom Master empfangene Bus-Objekt
Ausgang | das letzte vom Master gesendete Bus-Objekt

Die Daten für Eingang/Ausgang werden nur übertragen, wenn bei der Hardware-Konfiguration im Master die Ansprechüberwachung für den Servoverstärker aktiviert wurde

Wichtige Konfigurationsparameter

Die folgenden Parameter konfigurieren den Servoverstärker für den PROFIBUS.

EXTWD (PNU 1658)
Mit dem Parameter EXTWD kann die Überwachungszeit (Watch-Dog) für die Feldbus/Slot-Kommunikation definiert werden (Einstellung siehe CAN/Feldbus). Die Überwachung ist nur dann aktiv, wenn der Parameter EXTWD einen Wert größer 0 enthält (EXTWD=0, Überwachung abgeschaltet) und die Endstufe freigegeben ist. Falls die eingestellte Zeit abgelaufen ist, ohne dass der Watchdog-Timer durch Eintreffen eines Telegramms neu getriggert wurde,so wird die Warnung n04 (Ansprechüberwachung) generiert und der Antrieb angehalten. Der Verstärker bleibt weiterhin betriebsbereit und die Endstufe freigegeben. Bevor ein neues Fahrkommando (Sollwert) akzeptiert wird, muss diese Warnung gelöscht werden (Funktion CLRFAULT oder INxMODE=14).

ADDR (PNU 918)
Mit dem Kommando ADDR wird die Feldbus-Adresse des Verstärkers definiert (Einstellung siehe CAN/Feldbus). Nach der Änderung der Adresse sollten alle Parameter im EEPROM abgespeichert werden und der Verstärker aus- und eingeschaltet werden.

AENA (PNU 1606)
Hiermit kann der Zustand des Software-Enable beim Einschalten des Verstärkers definiert werden (Einstellung siehe BASISEINSTELLUNGEN). Mit dem Software-Enable wird einer externen Steuerung die Möglichkeit gegeben die Endstufe softwareseitig zu sperren bzw. freizugeben. Bei Geräten, die mit einem analogen Sollwert arbeiten (OPMODE=1,3) wird beim Einschalten des Verstärkers das Software-Enable automatisch gesetzt, so dass diese Geräte sofort betriebsbereit sind (Hardware-Enable vorausgesetzt). Bei allen anderen Geräten wird beim Einschalten das Software-Enable auf den Wert von AENA gesetzt. Die Variable AENA hat auch eine Funktion beim Resettieren des Verstärkers nach einem Fehler (über digitalen Eingang 1 bzw. mit dem ASCII-Kommando CLRFAULT). Bei Fehlern, die softwaremässig zurückgesetzt werden können, wird, nachdem der Fehler gelöscht wurde, der Software-Enable auf den Zustand von AENA gesetzt. Auf diese Weise ist das Verhalten des Verstärkers beim Software-Reset analog zu dem Einschaltverhalten.

INPT0 (PNU 1904)
Das Kommando INPT0 definiert eine Verzögerungszeit für die In-Position-Meldung (Einstellung über TERMINAL). Beim Start eines Fahrsatzes wird die In-Position-Meldung zurückgenommen und erst nach Ablauf der eingestellten Zeit die Überwachung des In-Position-Fensters aktiviert. Diese Funktion ist besonders wichtig bei Positioniervorgängen innerhalb des In-Position-Fensters. In diesem Fall wird sichergestellt, dass die In-Position-Meldung für eine definierte Zeit zurückgenommen wird.

Zustandsmaschine

Auf dieser Bildschirmseite werden die Bit-Zustände des Steuerwortes (STW) und des Zustandswortes (ZSW) angezeigt. Der sich aus dem Zustandswort ergebende Gerätezustand wird in der Zustandsmaschine visualisiert. Der aktuelle Zustand wird schwarz dargestellt, alle anderen Zustände grau. Zusätzlich wird der vorherige Zustand durch Hervorhebung der Nummer des entsprechenden Pfeils visualisiert.


ASCII Deutsch PROMPT

ASCII - Kommando | PROMPT |
Syntax Senden | PROMPT [Data] |
Syntax Empfangen | PROMPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35D3 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 1 (dec)
Bereich | 0 .. 3 | DPR | 211 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | RS232 | EEPROM | Nein
Kurzbeschreibung | Vorwahl des RS232-Protokolls

Beschreibung

Mit dem Parameter PROMPT kann das Protokoll für die RS232-Übertragung festgelegt werden. Es sind folgende Einstellungen möglich:
PROMPT=0 | kein Echo | Die über die RS232-Schnittstelle empfangenen Daten werden nicht automatisch gespiegelt (gesendet). Es erfolgt keine Ausgabe des Prompt (-->) Zeichens.
PROMPT=1 | Prompt-Zeichen + Echo | Als Eingabenaufforderung wird das Prompt-Zeichen (-->) ausgegeben. Jedes Zeichen, das über die RS232-Schnittstelle empfangen wird, wird sofort zurückgesendet.
PROMPT=2 | Terminal-Mode | Einstellung entspricht der Einstellung PROMPT=1. Zusätzlich werden einige Hilfsfunktionen aktiviert. Dazu gehören: 1. Bei Eingabe eines CR (ENTER) am Anfang der Eingabezeile, wird das zuletzt eingegebene Kommando wiederholt. 2. Bei manchen Kommandos die eine Ausgabe liefern, die länger als eine Bildschirmseite ist, erfolgt die Ausgabe Seitenweise.
PROMPT=3 | Checksumme | Eine serielle Übertragung wird mit einer Checksumme versehen. Bei der Berechnung der Checksumme werden alle Zeichen einer Kommandofolge aufsummiert (Modulo 256 ohne CR). Die auf diese Weise berechnete Checksumme wird als 2-stellige Hex-Zahl (im ASCII-Format) am Ende einer Kommandofolge übertragen. Beispiel: Kommandofolge: ADDR 1<CR> Checksumme: „A“ = 0x41 „D“ = 0x44 „D“ = 0x44 „R“ = 0x52 „ „ = 0x20 „1“ = 0x31 Die Summe beträgt: 0x16C Modulo 256: 0x6c = 108 Das erste Zeichen der zu übertragenden Checksumme = 108/16 + 0x30 = 0x36 = „6“ Das zweite Zeichen der zu übertragenden Checksumme = 108%16 + 0x30 = 0x3c = „<“ Es wird folgende Kommandofolge übertragen: „ADDR 16<“<CR> Beim Empfang einer Kommandofolge wird die Checksumme auf die gleiche Art und Weise gebildet und mit den letzten beiden Zeichen vor dem <CR> verglichen. Bei Übereinstimmung wird das Zeichen ACK (0x06) gesendet, bei falscher Checksumme das Zeichen NACK (0x15).


ASCII Deutsch PSINUS

ASCII - Kommando | PSINUS |
Syntax Senden | PSINUS [Frequenz] [Amplitude] |
Syntax Empfangen |  | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | Frequency: 1 .. 100; Amplitude: | DPR | Nein
Default | Frequency: 5Hz; Amplitude: 2048 counts |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enable | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Sinus Service-Funktion

Beschreibung

Das Kommando PSINUS wird als Service-Funktion benutzt.

Man kann zwei Parameter übergeben:

PSINUS [Frequenz] [Amplitude]

Frequenz – Sinusfrequenz in Hz (Bereich 1 bis 100) (Default = 5 Hz)
Amplitude – Sinus-Auslenkung in Counts (2048 = +/- 2.8 Grad mechanisch, max. 8192) (Default 2048)

Falls PSINUS ohne Parameter aufgerufen wird, so gelten die Default-Werte.


ASCII Deutsch PSTATE

ASCII - Kommando | PSTATE |
Syntax Senden | PSTATE [Data] |
Syntax Empfangen | PSTATE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35D4 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 1 (dec)
Bereich | - | DPR | 212 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Profibus-Status

Beschreibung

Das Kommando PSTATE liest den aktuellen Status der PROFIBUS – Kommunikation aus. Der erste angezeigte Wert liefert den SPC3 WATCHDOG Status, der zweite angezeigte Wert liefert den PROFIBUS DP-Status.

SPC3 WATCHDOG Status
0 = Baudratensuche
1 = Überprüfung der Baudrate
2 = DP Mode, d.h. Buswatchtdog aktiviert

PROFIBUS DP-Status
0 = Warte auf Parametrierung, Erfolgt durch den Master
1 = Warte auf Konfigurierung, Erfolgt durch den Master
2 = Datenaustausch
3 = Fehler, Die Ursache kann z.B. ein fehlerhaftes Parametriertelegramm in der Datentransfer – Phase gewesen sein.

Erst wenn der SPC3 WATCHTDOG Status den Wert 2 und der PROFIBUS DP - Status den Wert 2 aufweist, können Produktivdaten empfangen werden, d. h . es können Daten über den PKW – Teil und PZD – Teil des Verstärkers ausgetauscht werden.


ASCII Deutsch PSTEP

ASCII - Kommando | PSTEP |
Syntax Senden | PSTEP [Data] |
Syntax Empfangen | PSTEP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 Integer32 Integer16 Integer32 | CANBus Objektnummer | -
DIM | ms (DurationN) / Velocity Units (velocityN) | PROFIBUS PNU | -
Bereich | Duration:0 to 32767; Velocity:-PVMAX to +PVMAX | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer16 Integer32 Integer16 Integer32
Verstärker Status | Enabled | Wichtung |
ab Firmware | 2.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | other commands | EEPROM | -
Kurzbeschreibung | Service-Betrieb

Beschreibung

S700 und S300 ab FW 2.32:

Mit dem PSTEP-Kommando kann eine Service-Funktion über die Betriebsart "Position Fahrsätze" (OPMODE=8) realisiert werden. Das Kommando kann in folgenden Formen benutzt werden:
1. PSTEP
Das Kommando liefert die aktuellen Einstellungen für die Service-Funktion
2. PSTEP T1 V1
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (VUNITs) vorgegeben. Nachdem die Zeit T1 verstrichen ist, wird der digitale Geschwindigkeitssollwert auf 0 gesetzt.
3. PSTEP T1 V1 T2 V2
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (VUNITs) vorgegeben. Nachdem die Zeit T1 abgelaufen ist, wird für die Dauer T2 (msek) der digitale Sollwert V2 (VUNITs) vorgegeben. Nachdem die Zeit T2 abgelaufen ist, fängt erneut der Zyklus T1/V1 an. Mit Hilfe dieses Kommando kann ein endloser Reversierbetrieb realisiert werden.
z.B: PSTEP 1000 10000 1000 -10000

Der Service-Betrieb kann immer mit dem STOP-Kommando abgebrochen werden.
Für diesen Service-Betrieb gelten die Beschleuniungs- und Bremsrampen ACCR und DECR.
Die Voraussetzung für die Ausführung des PSTEP-Kommandos ist die Betriebsart "Position Fahrsätze".


ASCII Deutsch PTARGET

ASCII - Kommando | PTARGET |
Syntax Senden | PTARGET [Data] |
Syntax Empfangen | PTARGET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3654 (hex)
DIM | - | PROFIBUS PNU | 1940 (dec) IND = 1 (dec)
Bereich | long int | DPR | 340 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | letzte Fahrsatzzielposition

Beschreibung

Mit dem Kommando PTARGET kann die Zielposition des zuletzt gestarteten (und ggf. bereits abgebrochenen) Fahrauftrages abgefragt werden. Diese Position wird als neue Zielposition übernommen, sobald das Kommando CONTINUE abgesetzt wird (Fortsetzen des letzten Fahrsatzes).


ASCII Deutsch PTARGOFFS

ASCII - Kommando | PTARGOFFS |
Syntax Senden | PTARGOFFS [Data] |
Syntax Empfangen | PTARGOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 389B (hex)
DIM |  | PROFIBUS PNU | 1723 (dec) IND = 33 (dec)
Bereich | -2147483647...2147483647 | DPR | 923 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.66 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.4
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Offset bei absoluten Fahraufträgen

Beschreibung

Der Parameter PTARGOFFS bietet die Möglichkeit, die Zielposition von absoluten Fahrsätzen um einen Offset zu verschieben. Der Wert von PTARGOFFS wird beim Start des Fahrsatzes zur Zielposition dazu addiert. Bei relativen Fahrsätzen hat dieser Parameter keinen Einfluß.


ASCII Deutsch PTBASE

ASCII - Kommando | PTBASE |
Syntax Senden | PTBASE [Data] |
Syntax Empfangen | PTBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35D5 (hex)
DIM | 1/4 ms | PROFIBUS PNU | 1813 (dec) IND = 1 (dec)
Bereich | 1 ... 127 | DPR | 213 (dec)
Default | 4 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Zeitbasis für die externe Trajektorie

Beschreibung

Mit dem Parameter PTBASE wird die Interpolationszeit für die externe Trajektorie (OPMODE=5) vorgegeben. Die Zeit wird in 250 µsek-Schritten eingestellt, und gibt den Zeitintervall vor, in dem der nächste Positionssollwert von dem Antrieb erreicht werden soll. Da der interne Lageregler mit einer Abtastzeit von 250 µsek arbeitet, erfolgt eine Interpolation des vorgegebenen Positionssollwertes (externe Trajektorie) in 250 µsek-Schritten.

Für SERCOS bedeutet PTBASE 2=500us, PTBASE 4 = 1000us…


ASCII Deutsch PTMIN

ASCII - Kommando | PTMIN |
Syntax Senden | PTMIN [Data] |
Syntax Empfangen | PTMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D6 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1814 (dec) IND = 1 (dec)
Bereich | 3 .. 126000 | DPR | 214 (dec)
Default | 3150 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Min. Beschleunigungsrampe

Beschreibung

Die minimale Beschleunigungsrampe PTMIN gibt die minimale Zeit vor, die für die Geschwindigkeitsänderung von 0 auf PVMAX zuläßig ist. Unabhängig von der Art der Beschleunigungsvorgabe (msek,SI-Einheiten) wird beim Start eines Fahrsatzes die gefahrene Beschleunigung durch PVMAX / PTMIN begrenzt.
Mit Hilfe der Parameter PVMAX, PTMIN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch PUNIT

ASCII - Kommando | PUNIT |
Syntax Senden | PUNIT [Data] |
Syntax Empfangen | PUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3660 (hex)
DIM | - | PROFIBUS PNU | 1952 (dec) IND = 1 (dec)
Bereich | 0 ... 15 | DPR | 352 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Vorgabe der Positionsauflösung

Beschreibung

Mit dem Kommando PUNIT kann die systemweite Einheit für alle positionsabhängige Parameter des Lagereglers definiert werden. Es sind folgende Einstellungen möglich:

PUNIT=0 interne Einheit (anwenderspezifisch)
PUNIT=1 1 dm (0.1 m)
PUNIT=2 1 cm (0.01 m)
PUNIT=3 1 mm
PUNIT=4 0.1 mm
PUNIT=5 0.01 mm
PUNIT=6 1 µm
PUNIT=7 0.1 µm
PUNIT=8 0.01 µm
PUNIT=9 1 nm
PUNIT=10 0.1 nm
PUNIT=11 inch.
PUNIT=12 °

Der Parameter PUNIT wird ausschließlich für die Darstellung der verwendeten Einheit im PC-Bedienprogramm (MMI) benutzt. Da sowohl die Lageregler-Auflösung (PGEARI) als auch alle Weg-Parameter in denselben Einheiten vorgegeben werden, hat die PUNIT-Einstellung keine Auswirkungen auf die Positionierung.

Bei der Einstellung PUNIT=0 wird keine Weg-Einheit angezeigt. In diesem Fall können anwenderspezifische Einheiten realisiert werden, die ausschließlich von der benutzten Auflösung (PGEARI) abhängig sind.

z.B: PGEARI=360 (Einheit = Grad)
PGEARI=3600 (Einheit= 0.1 Grad)


ASCII Deutsch PV

ASCII - Kommando | PV |
Syntax Senden | PV [Data] |
Syntax Empfangen | PV <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 35D7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1815 (dec) IND = 1 (dec)
Bereich | long int | DPR | 215 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Ist-Geschwindigkeit (Lageregler)

Beschreibung

Die aktuelle Lageregler-Geschwindigkeit kann mit dem Kommando PV abgefragt werden. Die Normierung der Geschwindigkeit hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch PVMAX

ASCII - Kommando | PVMAX |
Syntax Senden | PVMAX [Data] |
Syntax Empfangen | PVMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1816 (dec) IND = 1 (dec)
Bereich | 0 .. VLIM | DPR | 216 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler

Beschreibung

Der Parameter PVMAX gibt die maximale Geschwindigkeit an, die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAX begrenzt. Mit Hilfe der Parameter PVMAX, PTMIN kann das Verhalten des Antriebes besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müssen.

In Verbindung mit dem Parameter PVMAXN, kann eine drehrichtungsabhängige Geschwindigkeitbegrenzung realisiert werden. Das Kommando PVMAX bestimmt die maximale Geschwindigkeit für die positive und negative Drehrichtung. Durch eine anschließende Vorgabe von PVMAXN kann die Begrenzung für die negative Richtung separat eingestellt werden.

Der Parameter PVMAX ist weiterhin abhängig von den Einstellungen des Parameters VUNIT.

Siehe auch VLIM , PVMAXP, PVMAXN, VUNIT, PGEARI, PGEARO


ASCII Deutsch PVMAXN

ASCII - Kommando | PVMAXN |
Syntax Senden | PVMAXN [Data] |
Syntax Empfangen | PVMAXN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D9 (hex)
DIM | VUNIT | PROFIBUS PNU | 1817 (dec) IND = 1 (dec)
Bereich | 0 .. VLIM | DPR | 217 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler (negativ)

Beschreibung

Der Parameter PVMAXN gibt die maximale Geschwindigkeit an (negative Fahrtrichtung), die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAXN begrenzt.
Bei Vorgabe der max. Geschwindigkeit in der positiven Richtung (PVMAX) wird gleichzeitig der Parameter PVMAXN auf den Wert von PVMAX gesetzt. Falls eine separate Einstellung für die negative Fahrtrichtung gewünscht ist, so muß anschliessend der Wert für PVMAXN separat eingegeben werden.
Mit Hilfe der Parameter PVMAX, PTMIN, PVMAXN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch PVMAXP

ASCII - Kommando | PVMAXP |
Syntax Senden | PVMAX [Data] |
Syntax Empfangen | PVMAXP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35DB (hex)
DIM | VUNIT | PROFIBUS PNU | 1819 (dec) IND = 1 (dec)
Bereich | 0 .. VLIM | DPR | 219 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | max. positive Geschwindigkeit für den Lageregler

Beschreibung

Der Parameter PVMAXP gibt die maximale Geschwindigkeit an (positive Fahrtrichtung), die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAXP begrenzt.
Mit Hilfe der Parameter PVMAX, PTMIN, PVMAXN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch QCNFG

ASCII - Kommando | QCNFG |
Syntax Senden | QCNFG [Data] |
Syntax Empfangen | QCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38D7 (hex)
DIM |  | PROFIBUS PNU | 1783 (dec) IND = 33 (dec)
Bereich | -2147483647...2147483647 | DPR | 983 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Konfig.variable für den Durchfluss-/Druckregler

Beschreibung

Bei dem Parameter QCNFG handelt es sich um eine Bitvariable mit der man die servo pumpe konfigurieren kann

Bit 0 - Pumpenrichtung 0 = rechts, 1 = links
Bit 1 - Anpassung aktiv
Bit 2 - Wirkungsgradkompensation aktiv
Bit 3 - reserviert
Bit 4 - Konfiguration von SW2
Bit 5 - Konfiguration von SW2
Bit 6 - Konfiguration von SW2
Bit 7 - Konfiguration von SW2

SW2-Konfigurations-Bits:
Bit 4,5,6,7 = 0 SW2 deaktiviert
Bit 4,5,6,7 = 1 SW2 schaltbar über Eingang 1
Bit 4,5,6,7 = 2 SW2 schaltbar über Eingang 2
Bit 4,5,6,7 = 3 SW2 schaltbar über Eingang 3
Bit 4,5,6,7 = 4 SW2 schaltbar über Eingang 4
Bit 4,5,6,7 = 5 SW2 schaltbar über Eingang 5
Bit 4,5,6,7 = 6 SW2 schaltbar über Eingang 6
Bit 4,5,6,7 = 7 SW2 Lautstärkesollwert 10V = QFMAX
Bit 4,5,6,7 = 8 SW2 Drucksollwert 10V = QPRMAX


ASCII Deutsch QENA

ASCII - Kommando | QENA |
Syntax Senden | QFACTOR [Data] |
Syntax Empfangen | QENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3913 (hex)
DIM |  | PROFIBUS PNU | 1843 (dec) IND = 33 (dec)
Bereich | 0/1 | DPR | 1043 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Freigabe der Servopumpen-Funktion

Beschreibung

Mit QENA=1 wird die Servopumpenfunktion aktiviert.


ASCII Deutsch QFACT

ASCII - Kommando | QFACT |
Syntax Senden | QFACT |
Syntax Empfangen | QFACT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38DE (hex)
DIM | l/min | PROFIBUS PNU | 1790 (dec) IND = 33 (dec)
Bereich | - | DPR | 990 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Volumenstrom-Istwert (ohne Filter)

Beschreibung

Dieser Parameter QFACT zeigt den Volumenstrom-Istwert in l/min ohne Filter an.


ASCII Deutsch QFACTCOMP

ASCII - Kommando | QFACTCOMP |
Syntax Senden | QFACTCOMP |
Syntax Empfangen | QFACTCOMP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E2 (hex)
DIM | l/min | PROFIBUS PNU | 1794 (dec) IND = 33 (dec)
Bereich | - | DPR | 994 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Volumenstrom-Istwert (nach Kompensation)

Beschreibung

Dieser Parameter QFACTCOMP zeigt den Volumenstrom-Istwert in l / min nach der Kompensation an.


ASCII Deutsch QFACTFILT

ASCII - Kommando | QFACTFILT |
Syntax Senden | QFACTFILT [Data] |
Syntax Empfangen | QFACTFILT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38E3 (hex)
DIM | 1/min | PROFIBUS PNU | 1795 (dec) IND = 33 (dec)
Bereich | - | DPR | 995 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | gefilterter Sollwert für den Volumenstrom

Beschreibung

Der Parameter FCMDFILT gibt den aktuellen Volumenstrom-Sollwert hinter einem Tiefpaßfilter erster Ordnung an.

Die Filterzeitkonstante kann über den Parameter QT1 eingestellt werden.


ASCII Deutsch QFACTOR

ASCII - Kommando | QFACTOR |
Syntax Senden | QFACTOR [Data] |
Syntax Empfangen | QFACTOR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38D8 (hex)
DIM | cm3 | PROFIBUS PNU | 1784 (dec) IND = 33 (dec)
Bereich | 0 .. 2147480 | DPR | 984 (dec)
Default | 100 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Schluckvolumen

Beschreibung

Definition des Schluckvolumens in cm3 pro Motorumdrehung


ASCII Deutsch QFCFACT

ASCII - Kommando | QFCFACT |
Syntax Senden | QFCFACT |
Syntax Empfangen | QFCFACT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38D9 (hex)
DIM |  | PROFIBUS PNU | 1785 (dec) IND = 33 (dec)
Bereich | - | DPR | 985 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | aktueller Wirkungsgradfaktor

Beschreibung

Der Faktor wird der Wirkungsgradtabelle entnommen ändert sich abhängig von den aktuellen Druck-
/Drehzahl-IIst werten: 1000 = 1.000


ASCII Deutsch QFCMD

ASCII - Kommando | QFCMD |
Syntax Senden | QFACTOR [Data] |
Syntax Empfangen | QFCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3914 (hex)
DIM |  | PROFIBUS PNU | 1844 (dec) IND = 33 (dec)
Bereich | -214780 .. 2147480 | DPR | 1044 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Volumenstrom-Sollwert

Beschreibung

Mit diesem Parameter QFCMD konfiguriert man den Volumenstrom-Sollwert


ASCII Deutsch QFCMDFILT

ASCII - Kommando | QFCMDFILT |
Syntax Senden | QFACTOR [Data] |
Syntax Empfangen | QFCMDFILT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3915 (hex)
DIM |  | PROFIBUS PNU | 1845 (dec) IND = 33 (dec)
Bereich | - | DPR | 1045 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Gefilterter Sollwert für den Volumenstrom

Beschreibung

Der Parameter QFSET liefert den aktuellen Volumenstrom -Sollwert hinter einem Tiefpassfilter erster Ordnung. Die Filterzeitkonstante kann über den Parameter QT1 definiert werden


ASCII Deutsch QFMAX

ASCII - Kommando | QFMAX |
Syntax Senden | QFMAX [Data] |
Syntax Empfangen | QFMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E9 (hex)
DIM | 1/min | PROFIBUS PNU | 1801 (dec) IND = 33 (dec)
Bereich | 0 .. 2147480 | DPR | 1001 (dec)
Default | 10 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Max. Sollwert für den Volumenstromwert

Beschreibung

Der Parameter QFMAX definiert den maximalen Wert für den Volumenstromsollwert. Dieser Wert entspricht einer Vorgabe von 10V am analogen Eingang SW2


ASCII Deutsch QFSET

ASCII - Kommando | QFSET |
Syntax Senden | QFSET |
Syntax Empfangen | QFSET <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38DD (hex)
DIM | l/min | PROFIBUS PNU | 1789 (dec) IND = 33 (dec)
Bereich | - | DPR | 989 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | gefilterter Sollwert für den Volumenstrom

Beschreibung

Der Parameter QFSET liefert den aktuellen Volumenstrom-Sollwert hinter einem Tiefpassfilter erster Ordnung.
Die Filterzeitkonstante kann über den Parameter QT1 definiert werden.


ASCII Deutsch QKPEFF

ASCII - Kommando | QKPEFF |
Syntax Senden | QKPEFF |
Syntax Empfangen | QKPEFF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38FB (hex)
DIM |  | PROFIBUS PNU | 1819 (dec) IND = 33 (dec)
Bereich | - | DPR | 1019 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Reglerparameteradaption: aktiver KP-Wert

Beschreibung

Dieser Parameter gibt den aktiven KP-Wert der Reglerparameteradaption an.


ASCII Deutsch QMACT

ASCII - Kommando | QMACT |
Syntax Senden | QMACT |
Syntax Empfangen | QMACT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38DA (hex)
DIM |  | PROFIBUS PNU | 1786 (dec) IND = 33 (dec)
Bereich | - | DPR | 986 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Drehmoment Istwert

Beschreibung

Dieser Parameter QMACT zeit den Drehmoment Istwert an.


ASCII Deutsch QMCMD

ASCII - Kommando | QMCMD |
Syntax Senden | QMCMD |
Syntax Empfangen | QMCMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E1 (hex)
DIM |  | PROFIBUS PNU | 1793 (dec) IND = 33 (dec)
Bereich | - | DPR | 993 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | aktueller Drehmoment-Sollwert

Beschreibung

DIeser Parameter gibt den aktuellen Drehmoment-Sollwert vor der Drehmomentbegrenzung aus.


ASCII Deutsch QMCMDLIM

ASCII - Kommando | QMCMDLIM |
Syntax Senden | QMCMDLIM |
Syntax Empfangen | QMCMDLIM <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38E6 (hex)
DIM | Nm | PROFIBUS PNU | 1798 (dec) IND = 33 (dec)
Bereich | - | DPR | 998 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Aktueller Drehmoment-Sollwert

Beschreibung

Dieser Parameter gibt den aktuellen Drehmoment-Sollwert hinter der Drehmomentbegrenzung aus.


ASCII Deutsch QMLIMN

ASCII - Kommando | QMLIMN |
Syntax Senden | QMLIMN [Data] |
Syntax Empfangen | QMLIMN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3917 (hex)
DIM | Nm | PROFIBUS PNU | 1847 (dec) IND = 33 (dec)
Bereich | variable | DPR | 1047 (dec)
Default | variable |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Drehmomentbegrenzung vom Druckabbau

Beschreibung

Mit diesem Parameter QMLIMN wird die Drehmomentbegrenzung vom Druckabbau der Servopumpe festgelegt

Default-/Grenzwerte werden abhängig von MKT/IPEAKN berechnet
Minimalwert = 0
Maximalwert = MKT * Maximalwert von IPEAKN
Defaultwert = MKT * Defaultwert von IPEAKN


ASCII Deutsch QMLIMP

ASCII - Kommando | QMLIMP |
Syntax Senden | QMLIMP [Data] |
Syntax Empfangen | QMLIMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E7 (hex)
DIM | Nm | PROFIBUS PNU | 1799 (dec) IND = 33 (dec)
Bereich | variable | DPR | 999 (dec)
Default | variable |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Drehmomentbegrenzung vom Druckaufbau

Beschreibung

Mit diesem Parameter QMLIMPN wird die Drehmomentbegrenzung vom Druckaufbau der Servopumpe festgelegt

Default-/Grenzwerte werden abhängig von MKT/IPEAKP berechnet
Minimalwert = 0
Maximalwert = MKT * Maximalwert von IPEAKP
Defaultwert = MKT * Defaultwert von IPEAKP


ASCII Deutsch QPE

ASCII - Kommando | QPE |
Syntax Senden | QPE |
Syntax Empfangen | QPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38FA (hex)
DIM | bar | PROFIBUS PNU | 1818 (dec) IND = 33 (dec)
Bereich | -int32 ... +int32 | DPR | 1018 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Aktuelle Druck-Regelabweichung

Beschreibung

Dieser Parameter gibt die aktuelle Druck-Regelabweichung an.


ASCII Deutsch QPRACT

ASCII - Kommando | QPRACT |
Syntax Senden | QPRACT |
Syntax Empfangen | QPRACT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E0 (hex)
DIM |  | PROFIBUS PNU | 1792 (dec) IND = 33 (dec)
Bereich | - | DPR | 992 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Druckistwert

Beschreibung

Der Parameter QPRACT liefert den aktuellen Druckistwert in Bar. Der Druckistwert wird anhand der analogen Spannung am Eingang SW1 sowie der Drucksensor-Kalibrierungstabelle berechnet.


ASCII Deutsch QPRMAX

ASCII - Kommando | QPRMAX |
Syntax Senden | QPRMAX [Data] |
Syntax Empfangen | QPRMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38EA (hex)
DIM | bar | PROFIBUS PNU | 1802 (dec) IND = 33 (dec)
Bereich | 0 .. 2147480 | DPR | 1002 (dec)
Default | 200 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | maximaler Drucksollwert

Beschreibung

Mit dem Parameter QPRMAX wird der maximalen Wert für den Drucksollwert definiert. Dieser Wert entspricht einer Vorgabe von 10V am analogen Eingang SW2.


ASCII Deutsch QPRSET

ASCII - Kommando | QPRSET |
Syntax Senden | QPRSET [Data] |
Syntax Empfangen | QPRSET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38DF (hex)
DIM |  | PROFIBUS PNU | 1791 (dec) IND = 33 (dec)
Bereich | -2147480 .. 2147480 | DPR | 991 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Druck Sollwert

Beschreibung

Dieser Parameter QPRSET zeigt den Druck Sollwert an.


ASCII Deutsch QPRSETEFF

ASCII - Kommando | QPRSETEFF |
Syntax Senden | QPRSETEFF] |
Syntax Empfangen | QPRSETEFF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38E8 (hex)
DIM | bar | PROFIBUS PNU | 1800 (dec) IND = 33 (dec)
Bereich | - | DPR | 1000 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Druck Sollwert (effektiv)

Beschreibung

siehe QPRSET


ASCII Deutsch QT1

ASCII - Kommando | QT1 |
Syntax Senden | QT1 [Data] |
Syntax Empfangen | QT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3916 (hex)
DIM | msec | PROFIBUS PNU | 1846 (dec) IND = 33 (dec)
Bereich | - | DPR | 1046 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Konstante für den Volumenstrom-Sollwertfilter

Beschreibung

Mit dem Parameter QT1 wird die Filterzeitkonstante für den Volumenstrom-Sollwertfilter (Tiefpass erster Ordnung) eingestellt.


ASCII Deutsch QTAB1KP

ASCII - Kommando | QTAB1KP |
Syntax Senden | QTAB1KP [Data] |
Syntax Empfangen | QTAB1KP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38EB (hex)
DIM |  | PROFIBUS PNU | 1803 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1003 (dec)
Default | 0.1 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Verstärkung für QTAB1V

Beschreibung

Die Stützpunkte QTAB1KP...QTAB5KP werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB1TN

ASCII - Kommando | QTAB1TN |
Syntax Senden | QTAB1TN [Data] |
Syntax Empfangen | QTAB1TN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F5 (hex)
DIM | ms | PROFIBUS PNU | 1813 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 1013 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Nachstellzeit für QTAB1V

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB1TV

ASCII - Kommando | QTAB1TV |
Syntax Senden | QTAB1TV [Data] |
Syntax Empfangen | QTAB1TV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3901 (hex)
DIM |  | PROFIBUS PNU | 1825 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1025 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerp.adaption: TV - Vorhaltzeit für QTAB1V

Beschreibung

Die Stützpunkte QTAB1TV...QTAB5TV werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB1V

ASCII - Kommando | QTAB1V |
Syntax Senden | QTAB1V [Data] |
Syntax Empfangen | QTAB1V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F0 (hex)
DIM | Bar | PROFIBUS PNU | 1808 (dec) IND = 33 (dec)
Bereich | 0 .. int32 | DPR | 1008 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Drehzahl 1

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN, QTAB1TV...QTAB5TV und QTAB1KP...QTAB5KP werden in
Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB2KP

ASCII - Kommando | QTAB2KP |
Syntax Senden | QTAB2KP [Data] |
Syntax Empfangen | QTAB2KP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38EC (hex)
DIM |  | PROFIBUS PNU | 1804 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1004 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Verstärkung für QTAB2V

Beschreibung

Die Stützpunkte QTAB1KP...QTAB5KP werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB2TN

ASCII - Kommando | QTAB2TN |
Syntax Senden | QTAB2TN [Data] |
Syntax Empfangen | QTAB2TN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F6 (hex)
DIM | ms | PROFIBUS PNU | 1814 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 1014 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Nachstellzeit für QTAB2V

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB2TV

ASCII - Kommando | QTAB2TV |
Syntax Senden | QTAB2TV [Data] |
Syntax Empfangen | QTAB2TV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3902 (hex)
DIM |  | PROFIBUS PNU | 1826 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1026 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerp.adaption: TV - Vorhaltzeit für QTAB2V

Beschreibung

Die Stützpunkte QTAB1TV...QTAB5TV werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB2V

ASCII - Kommando | QTAB2V |
Syntax Senden | QTAB2V [Data] |
Syntax Empfangen | QTAB2V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F1 (hex)
DIM | Bar | PROFIBUS PNU | 1809 (dec) IND = 33 (dec)
Bereich | 0 .. int32 | DPR | 1009 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Drehzahl 2

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN, QTAB1TV...QTAB5TV und QTAB1KP...QTAB5KP werden in
Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB3KP

ASCII - Kommando | QTAB3KP |
Syntax Senden | QTAB3KP [Data] |
Syntax Empfangen | QTAB3KP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38ED (hex)
DIM |  | PROFIBUS PNU | 1805 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1005 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Verstärkung für QTAB3V

Beschreibung

Die Stützpunkte QTAB1KP...QTAB5KP werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB3TN

ASCII - Kommando | QTAB3TN |
Syntax Senden | QTAB3TN [Data] |
Syntax Empfangen | QTAB3TN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F7 (hex)
DIM | ms | PROFIBUS PNU | 1815 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 1015 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Nachstellzeit für QTAB3V

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB3TV

ASCII - Kommando | QTAB3TV |
Syntax Senden | QTAB3TV [Data] |
Syntax Empfangen | QTAB3TV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3903 (hex)
DIM |  | PROFIBUS PNU | 1827 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1027 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerp.adaption: TV - Vorhaltzeit für QTAB3V

Beschreibung

Die Stützpunkte QTAB1TV...QTAB5TV, werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB3V

ASCII - Kommando | QTAB3V |
Syntax Senden | QTAB3V [Data] |
Syntax Empfangen | QTAB3V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F2 (hex)
DIM | Bar | PROFIBUS PNU | 1810 (dec) IND = 33 (dec)
Bereich | 0 .. int32 | DPR | 1010 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Drehzahl 3

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN, QTAB1TV...QTAB5TV und QTAB1KP...QTAB5KP werden in
Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB4KP

ASCII - Kommando | QTAB4KP |
Syntax Senden | QTAB4KP [Data] |
Syntax Empfangen | QTAB4KP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38EE (hex)
DIM |  | PROFIBUS PNU | 1806 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1006 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Verstärkung für QTAB4V

Beschreibung

Die Stützpunkte QTAB1KP...QTAB5KPwerden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB4TN

ASCII - Kommando | QTAB4TN |
Syntax Senden | QTAB4TN [Data] |
Syntax Empfangen | QTAB4TN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F8 (hex)
DIM | ms | PROFIBUS PNU | 1816 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 1016 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Nachstellzeit für QTAB4V

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB4TV

ASCII - Kommando | QTAB4TV |
Syntax Senden | QTAB4TV [Data] |
Syntax Empfangen | QTAB4TV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3904 (hex)
DIM |  | PROFIBUS PNU | 1828 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1028 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerp.adaption: TV - Vorhaltzeit für QTAB4V

Beschreibung

Die Stützpunkte QTAB1TV...QTAB5TV, werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB4V

ASCII - Kommando | QTAB4V |
Syntax Senden | QTAB4V [Data] |
Syntax Empfangen | QTAB4V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F3 (hex)
DIM | Bar | PROFIBUS PNU | 1811 (dec) IND = 33 (dec)
Bereich | 0 .. int32 | DPR | 1011 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Drehzahl 4

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN, QTAB1TV...QTAB5TV und QTAB1KP...QTAB5KP werden in
Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB5KP

ASCII - Kommando | QTAB5KP |
Syntax Senden | QTAB5KP [Data] |
Syntax Empfangen | QTAB5KP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38EF (hex)
DIM |  | PROFIBUS PNU | 1807 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1007 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Verstärkung für QTAB5V

Beschreibung

Die Stützpunkte QTAB1KP...QTAB5KP werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB5TN

ASCII - Kommando | QTAB5TN |
Syntax Senden | QTAB5TN [Data] |
Syntax Empfangen | QTAB5TN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F9 (hex)
DIM | ms | PROFIBUS PNU | 1817 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 1017 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Nachstellzeit für QTAB5V

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB5TV

ASCII - Kommando | QTAB5TV |
Syntax Senden | QTAB5TV [Data] |
Syntax Empfangen | QTAB5TV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3905 (hex)
DIM |  | PROFIBUS PNU | 1829 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 1029 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerp.adaption: TV - Vorhaltzeit für QTAB5V

Beschreibung

Die Stützpunkte QTAB1TV...QTAB5TV, werden in Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTAB5V

ASCII - Kommando | QTAB5V |
Syntax Senden | QTAB5V [Data] |
Syntax Empfangen | QTAB5V <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38F4 (hex)
DIM | Bar | PROFIBUS PNU | 1812 (dec) IND = 33 (dec)
Bereich | 0 .. int32 | DPR | 1012 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: Drehzahl 5

Beschreibung

Die Stützpunkte QTAB1TN...QTAB5TN, QTAB1TV...QTAB5TV und QTAB1KP...QTAB5KP werden in
Verbindung mit den Werten QTAB1V...QTAB5V zur Berechnung einer Parameterumschalttabelle benutzt.

Abhängig von der aktuellen Motordrehzahl werden die entsprechenden Reglerparameter aktiviert.


ASCII Deutsch QTABID

ASCII - Kommando | QTABID |
Syntax Senden | QTABID |
Syntax Empfangen | QTABID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3900 (hex)
DIM |  | PROFIBUS PNU | 1824 (dec) IND = 33 (dec)
Bereich | 0 .. 5 | DPR | 1024 (dec)
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Reglerparameteradaption: aktueller Parameterindex

Beschreibung

Die QTABID zeigt den aktuellen Index auf die Reglerparametertabelle:

QTABID=0 keine Parameteradaption, QKP,QTV und QTN aktiv
QTABID=1 Drehzahl 1. QTAB1KP,QTAB1TV und QTAB1TN sind aktiv.
QTABID=2 Drehzahl 2. QTAB2KP,QTAB2TV und QTAB2TN sind aktiv.
QTABID=3 Drehzahl 3. QTAB3KP,QTAB3TV und QTAB3TN sind aktiv.
QTABID=4 Drehzahl 4. QTAB4KP,QTAB4TV und QTAB4TN sind aktiv.
QTABID=5 Drehzahl 5. QTAB5KP,QTAB5TV und QTAB5TN sind aktiv


ASCII Deutsch QTIMEKD

ASCII - Kommando | QTIMEKD |
Syntax Senden | QTIMEKD [Data] |
Syntax Empfangen | QTIMEKD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 38E4 (hex)
DIM | ms | PROFIBUS PNU | 1796 (dec) IND = 33 (dec)
Bereich | 0 .. 2147480 | DPR | 996 (dec)
Default | 1 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Zeitkonst. des D-Anteils für den Druckstromregler

Beschreibung

Mit diesem Parameter wird die Zeitkonstante des D-Anteils für den Druckstromregler (PID) eingestelllt.


ASCII Deutsch QTNEFF

ASCII - Kommando | QTNEFF |
Syntax Senden | QTNEFF |
Syntax Empfangen | QTNEFF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38FC (hex)
DIM |  | PROFIBUS PNU | 1820 (dec) IND = 33 (dec)
Bereich | - | DPR | 1020 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Nein
Kurzbeschreibung | Reglerparameteradaption: aktiver TN-Wert

Beschreibung

Dieser Parameter QTNEFF gibt den aktiven TN-Wert der Reglerparameteradaption an.


ASCII Deutsch QTVEFF

ASCII - Kommando | QTVEFF |
Syntax Senden | QTVEFF |
Syntax Empfangen | QTVEFF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38DB (hex)
DIM |  | PROFIBUS PNU | 1787 (dec) IND = 33 (dec)
Bereich | - | DPR | 987 (dec)
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Reglerparameteradaption: aktiver TV-Wert

Beschreibung

Dieser Parameter gibt den aktiven TV-Wert der Reglerparameteradaption an.


ASCII Deutsch QVAL

ASCII - Kommando | QVAL |
Syntax Senden | QVAL |
Syntax Empfangen | QVAL <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format |  | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode | all | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | intern | EEPROM | Nein
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch QVT1

ASCII - Kommando | QVT1 |
Syntax Senden | QVT1 [Data] |
Syntax Empfangen | QVT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38E5 (hex)
DIM |  | PROFIBUS PNU | 1797 (dec) IND = 33 (dec)
Bereich | 0 .. 1000 | DPR | 997 (dec)
Default | 1 |
Opmode | 0 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Glättungszeit-Istwert

Beschreibung

Dieser Parameter QVT1 konfiguriert die Filterzeitkonstante für den Volumenstrom-Istwertfilter (erstes Tiefpaßfilter).


ASCII Deutsch RDP

ASCII - Kommando | RDP |
Syntax Senden | RDP |
Syntax Empfangen | RDP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36B7 (hex)
DIM | - | PROFIBUS PNU | 2039 (dec) IND = 1 (dec)
Bereich | 0 .. 2 | DPR | 439 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | RDP Betriebsarten

Beschreibung

folgende RDP Betriebsarten können gewählt werden:

0: RDP deaktiviert, Normalbetrieb des S700
1: RDP-Betriebsart aktiviert, Freigabemodus = „Fehler deaktiviert anderen Antrieb“
2: RDP-Betriebsart aktiviert, Freigabemodus = „Fehler erzwingt anderen Antrieb von RDP


ASCII Deutsch RDPBIAS

ASCII - Kommando | RDPBIAS |
Syntax Senden | RDPBIAS [Data] |
Syntax Empfangen | RDPBIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B8 (hex)
DIM | Ampere | PROFIBUS PNU | 2040 (dec) IND = 1 (dec)
Bereich |  | DPR | 440 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | RDP Ruhestrom

Beschreibung

Mit RDPBIAS wird der RDP Ruhestrom eingestellt: typischer Wert liegt bei 10%-25% vom Dauerstrom DICONT.


ASCII Deutsch RDPBIAS2

ASCII - Kommando | RDPBIAS2 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch RDPCLAMP

ASCII - Kommando | RDPCLAMP |
Syntax Senden | RDPCLAMP [Data] |
Syntax Empfangen | RDPCLAMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B9 (hex)
DIM |  | PROFIBUS PNU | 2041 (dec) IND = 1 (dec)
Bereich |  | DPR | 441 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | maximaler Ausgabeausgleichsstrom

Beschreibung

Mit RDPCLAMB wird der maximale Ausgabeausgleichsstrom eingestellt: Der maximale Ausgabeausgleichsstrom liegt bei einem typischen Wert von 50 (in RPM)


ASCII Deutsch RDPINT

ASCII - Kommando | RDPINT |
Syntax Senden | RDPINT [Data] |
Syntax Empfangen | RDPINT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36BA (hex)
DIM |  | PROFIBUS PNU | 2042 (dec) IND = 1 (dec)
Bereich |  | DPR | 442 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Integralwert des RDP-Ausgleichsstroms

Beschreibung

RDPINT Entspricht dem Integralwert des RDP-Ausgleichsstros

Skaliert für 9.000.000 = 1 RPM (entspricht 9 Millionen = 1 RPM) und wird durch RDPCLAMP begrenzt.


ASCII Deutsch RDPKI

ASCII - Kommando | RDPKI |
Syntax Senden | RDPKI [Data] |
Syntax Empfangen | RDPKI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BB (hex)
DIM |  | PROFIBUS PNU | 2043 (dec) IND = 1 (dec)
Bereich |  | DPR | 443 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Integralverstärkung des Ausgleichsstroms

Beschreibung

RDPKI bestimmt die Integralverstärkung des Ausgleichsstroms und liegt bei einem typischen Wert von 13.


ASCII Deutsch RDPKP

ASCII - Kommando | RDPKP |
Syntax Senden | RDPKP [Data] |
Syntax Empfangen | RDPKP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BC (hex)
DIM |  | PROFIBUS PNU | 2044 (dec) IND = 1 (dec)
Bereich |  | DPR | 444 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Ausgleichsstroms

Beschreibung

RDPKP bestimmt die Proportionalverstärkung des Ausgleichsstroms liegt bei einem typischen Wert von 300.


ASCII Deutsch RDPON

ASCII - Kommando | RDPON |
Syntax Senden | RDPON [Data] |
Syntax Empfangen | RDPON <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36BD (hex)
DIM |  | PROFIBUS PNU | 2045 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 445 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM | Nein
Kurzbeschreibung | RDP Status

Beschreibung

Mit RDPON wird der Status der RDP Funktion angezeigt:

0: keine RDP Funktion (default)
1: RDP aktiv


ASCII Deutsch READY

ASCII - Kommando | READY |
Syntax Senden | READY |
Syntax Empfangen | READY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DD (hex)
DIM | - | PROFIBUS PNU | 1821 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 221 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Zustand von Software-Enable

Beschreibung

Mit dem READY-Kommando kann der Zustand des internen Software-Enable abgefragt werden.
READY = 0 Disabled
READY = 1 Enabled


ASCII Deutsch RECDONE

ASCII - Kommando | RECDONE |
Syntax Senden | RECDONE |
Syntax Empfangen | RECDONE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DE (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 222 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufnahme beendet

Beschreibung

Mit dem Kommando RECDONE kann der Zustand der SCOPE-Aufzeichnung abgefragt werden. Das Kommando liefert eine 1, wenn die Aufzeichnung abgeschlossen ist und die Daten mit dem GET-Kommando angefordert werden können.


ASCII Deutsch RECING

ASCII - Kommando | RECING |
Syntax Senden | RECING |
Syntax Empfangen | RECING <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DF (hex)
DIM | - | PROFIBUS PNU | 1823 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 223 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufzeichnung läuft

Beschreibung

Liefert eine 1 wenn Aufzeichnung aktiv. Am Ende einer Aufzeichnung bzw. wenn Aufzeichnung nicht gestartet, wird eine 0 geliefert.


ASCII Deutsch RECOFF

ASCII - Kommando | RECOFF |
Syntax Senden | RECOFF [Data] |
Syntax Empfangen | RECOFF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E0 (hex)
DIM | - | PROFIBUS PNU | 1824 (dec) IND = 1 (dec)
Bereich | - | DPR | 224 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Abbruch einer Scope-Aufzeichnung

Beschreibung

Das Kommando RECOFF bricht die ggf. gestartete Scope-Aufzeichnung ab.
Status nach RECOFF: RECRDY=1, RECING=0, RECDONE=0.


ASCII Deutsch RECORD

ASCII - Kommando | RECORD |
Syntax Senden | RECORD [Data] |
Syntax Empfangen | RECORD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 1 .. 10000 (=Time);1 .. 1024(=Points); ASCII String (=Var) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Definition der aufzuzeichnenden Daten

Beschreibung

Mit dem RECORD-Kommando können die Daten für den nächsten SCOPE-Aufzeichnungsvorgang definiert werden. Das Kommando wird in folgender Form benutzt:

RECORD zeit anzahl var1 [var2] [var3] [var4]

zeit: Abtastzeit in 250 µs-Schritten
anzahl: Anzahl der aufzuzeichnenden Abtastpunkte.
Die max. mögliche Anzahl hängt von der Anzahl und Größe der aufzuzeichnenden Variablen ab.
Bei Vorgabe einer zu großen Anzahl wird diese automatisch begrenzt (bei Aufzeichnung von Long/Float-Variablen können max. 512 Punkte aufgezeichnet werden).
var1,var2,var3 - Namen der aufzuzeichnenden Variablen. Außer den Namen von Makro-Variablen können folgende Namen benutzt werden:
I - Stromistwert
ICMDVAL - Stromsollwert
PE - Schleppfehler
V - Drehzahlistwert
VCMD - Drehzahlsollwert
VBUS - Zwischenkreisspannung
PFB - Positionsistwert


ASCII Deutsch RECRDY

ASCII - Kommando | RECRDY |
Syntax Senden | RECRDY [Data] |
Syntax Empfangen | RECRDY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E1 (hex)
DIM | - | PROFIBUS PNU | 1825 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 225 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Zustand der RECORD-Funktion

Beschreibung

Nachdem die Aufzeichnung mit RECORD / RECTRIG "scharf" gemacht wurde, gibt das RECRDY-Kommando eine 0 aus. Sobald, die mit RECRDY vorgegebene Trigger-Bedingung erfüllt ist und die Aufzeichnung gestartet wurde, liefert RECRDY eine 1. Nach dem Booten des Drives steht RECRDY ebenfalls auf 1.

(RECRDY=0 bedeutet "warten auf Trigger-Ereignis").


ASCII Deutsch RECTRIG

ASCII - Kommando | RECTRIG |
Syntax Senden | RECTRIG [Data] |
Syntax Empfangen | RECTRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | ASCII String (=Mode);Depends upon Mode (=Level);0 .. 1023 (=Loc.); 0, 1 (=Dir.) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | oscilloscope | EEPROM | Nein
Kurzbeschreibung | SCOPE: Aktivieren der Aufzeichnungsfunktion

Beschreibung

Das Kommando RECTRIG bereitet eine Datenaufzeichnung für die SCOPE-Funktion vor.
Das Kommando wird in folgender Form benutzt:

RECTRIG mode level location direction

mode: bezeichnet den Namen einer Variable, die für die Triggerung der Aufzeichnung benutzt werden soll. Bei Verwendung der Bezeichnung IMM wird die Aufzeichnung sofort gestartet. In diesem Fall brauchen die Parameter "level","location" und "direction" nicht angegeben zu werden.

level: spezifiziert den Wert der Variable, der erreicht werden muß, damit die Aufzeichnung aktiviert wird.

location: gibt die Anzahl der "Punkte" an, die vor dem Auftreten des Trigger-Ereignisses aufgezeichnet werden sollen.

direction: spezifiziert die Richtung in der der Wert "level" der Variable "mode" überschritten werden soll, damit die Aufzeichnung aktiviert wird.
direction=0 fallend (Variablenwert wird unterschritten)
direction=1 steigend (Variablenwert wird überschritten)


ASCII Deutsch REFIP

ASCII - Kommando | REFIP |
Syntax Senden | REFIP [Data] |
Syntax Empfangen | REFIP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35E2 (hex)
DIM | A | PROFIBUS PNU | 1826 (dec) IND = 1 (dec)
Bereich | 0.0 .. min(IPEAK,IPEAKN) | DPR | 226 (dec)
Default | min(IPEAK,IPEAKN,DICONT/2) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom für die Referenzfahrt 7

Beschreibung

Mit dem Parameter REFIP kann der Spitzenstrom für die Referenzfahrt auf Anschlag definiert werden. Beim Start der Referenzfahrt Nr 7 (auf Anschlag mit Nullpunktsuche) wird der aktuelle Wert des Spitzenstromes IPEAK auf den Wert REFIP gesetzt. Nachdem die Referenzfahrt abgeschlossen wurde, wird der Parameter IPEAK auf den ursprünglichen Wert gesetzt.

- - - - - - - - - - - - -

Der Parameter REFIP wird auch dazu benutzt, bei Wake&Shake-Modus (FBTYPE=7,8) den Strom für die erste Phase (grobe Winkelbestimmung) zu definieren. Die zweite Phase von Wake&Shake (Feinabstimmung) erfolgt mit dem Spitzenstrom IPEAK.

Beim Updaten der Firmware von der Version < 5.80 auf eine Version >=5.80 sollte die Einstellung von REFIP2 kontrolliert und ggf. auf den Wert von IPEAK gesetzt werden. Nur dann kann sichergestellt sein, daß das Wake&Shake-Verhalten unverändert bleibt.


ASCII Deutsch REFIP2

ASCII - Kommando | REFIP2 |
Syntax Senden |  |
Syntax Empfangen |  | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36E3 (hex)
DIM |  | PROFIBUS PNU | 1683 (dec) IND = 17 (dec)
Bereich | 0 ...IPEAK | DPR | 483 (dec)
Default | IPEAK |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom für die Kommutierungsfindung

Beschreibung

REFIP2 definiert den Spitzenstrom der für die Wake&Shake-Phase eingestellt wird.
Nachdem Wake&Shake abgeschlossen wurde, wird die ursprüngliche IPEAK -Einstellung wieder hergestellt.

>>> siehe auch REFIP


ASCII Deutsch REFLS

ASCII - Kommando | REFLS |
Syntax Senden | REFLS [Data] |
Syntax Empfangen | REFLS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365D (hex)
DIM | - | PROFIBUS PNU | 1949 (dec) IND = 1 (dec)
Bereich | 0, 1, 2, 3 | DPR | 349 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Reglerverh. auf HW-Endschalter bei Referenzfahrt

Beschreibung

Mit dem Parameter REFLS kann das Verhalten des Verstärkers beim
Aktivwerden eines Hardware-Endschalters während der Referenzfahrt
definiert werden:

REFLS=0 Umdrehen der Fahrtrichtung am NSTOP und PSTOP
REFLS=1 Umdrehen der Fahrtrichtung am PSTOP, NSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=2 Umdrehen der Fahrtrichtung am NSTOP, PSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=3 NSTOP und PSTOP generieren die Fehlermeldung F26 (Limit Switch)

Gilt bei Referenzfahrtarten 1 und 3


ASCII Deutsch REFMODE

ASCII - Kommando | REFMODE |
Syntax Senden | REFMODE [Data] |
Syntax Empfangen | REFMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 363C (hex)
DIM | - | PROFIBUS PNU | 1916 (dec) IND = 1 (dec)
Bereich | 0 .. 8 | DPR | 316 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.2
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Quelle des Nullimpulse bei Referenzfahrt

Beschreibung

Das Kommando REFMODE bestimmt die Quelle des Nullimpulses während der Ausführung einer Referenzfahrt.

REFMODE=0 Resolver- oder Encoder-Nulldurchgang

REFMODE=0 Resolver- oder Singleturn-Encoder-Nulldurchgang, Nulldurchgang pro Umdrehung bei Multiturn-Encoder bei EXTPOS=1 Data-Pin X1-Stecker

REFMODE=1 digitaler Eingang INPUT1

REFMODE=2 digitaler Eingang INPUT2

REFMODE=3 digitaler Eingang INPUT3

REFMODE=4 digitaler Eingang INPUT4

REFMODE=5 Data-Pin des X1-Steckers Beim Einsatz eines digitalen Gebers (ROD) an X1 (FBTYPE=15,17) kann der externe ROD-Nullimpuls
fürs Referenzieren (NREF 1,2,7) bzw für die ROD-Ausgabe benutzt werden. Dafür muß der Parameter REFMODE auf 5 gesetzt werden.

REFMODE=6 Nullimpuls des X5-Steckers bei ENCMODE=0

REFMODE=7 Nulldurchgang des Multiturn Absolutwertgebers (pro Umdrehung)

REFMODE=8 reserviert


ASCII Deutsch REFNOFFS

ASCII - Kommando | REFNOFFS |
Syntax Senden | REFNOFFS [Data] |
Syntax Empfangen | REFNOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 386D (hex)
DIM | - | PROFIBUS PNU | 1677 (dec) IND = 33 (dec)
Bereich | -360 ... 360 | DPR | 877 (dec)
Default | 90 |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.51 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Position des analog. Nullpunktes

Beschreibung

Um bei einer Referenzfahrt die Positioniergenauigkeit zu erhöhen, kann ein externer Nullimpuls ausgewertet werden. Die Vorwahl der Nullimpulsquelle erfolgt mit dem Parameter REFMODE.
Der Verstärker S300/S700 bietet zwei unterschiedliche Arten wie ein externer Nullimpuls berücksichtigt werden kann:

1. Flankenauswertung des Nullimpulses REFNOFFS=0
Bei Erkennung einer Nullimpulsflanke wird die Position zurückgesetzt (ROFFS), der Antrieb bremst ab und fährt zu der Position an der die Flanke erkannt wurde.
Diese Vorgehensweise hat den Nachteil, dass je nachdem wie steil die Nullimpulsflanke ist bzw. wie schnell die Referenzfahrt erfolgt, unterschiedliche Nullpositionen gesetzt werden. Diese Art der Nullimpuls-Auswertung kann sowohl bei analogen als auch bei digitalen Positionsgebern verwendet werden.

2. Flankenauswertung des Nullimpulses mit anschließender analoger Positionierung REFNOFFS=1...360
Diese Methode hat den Vorteil, dass die Abhängigkeit von der Referenzfahrt-Geschwindigkeit eliminiert wird. Der Nullimpuls dient lediglich als eine Art Kennung für den Sinus/Cosinus-Zyklus in dem die Nullmarke gesetzt werden soll. Die Lage der Nullmarke innerhalb des Sinus/Cosinus-Zyklus wird durch den Parameter REFNOFFS festgelegt. Der Nachteil dieser Methode liegt darin, dass sie nur bei Positionsgebern mit einer Analogspur (Sinus/Cosinus-Signal) angewendet werden kann.


ASCII Deutsch REFNPOS

ASCII - Kommando | REFNPOS |
Syntax Senden | REFNPOS [Data] |
Syntax Empfangen | REFNPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 386E (hex)
DIM |  | PROFIBUS PNU | 1678 (dec) IND = 33 (dec)
Bereich | 0 ... 359 | DPR | 878 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.51 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Externer Nullimpulsoffset im Sinus-Kosinus-Zyklus

Beschreibung

Nur S700

Position des externen Nullimpulses (REFMODE, REFNOFFS) innerhalb einer Encoderperiode. Bei der Flanke des Nullimpulses wird dieser Offset benutzt, um die Referenzposition zu optimieren (REFNOFFS).


ASCII Deutsch REFPOS

ASCII - Kommando | REFPOS |
Syntax Senden | REFPOS [Data] |
Syntax Empfangen | REFPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 35E3 (hex)
DIM | Counts | PROFIBUS PNU | 1827 (dec) IND = 1 (dec)
Bereich | 0 ... 1048576 | DPR | 227 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Referenzschalter Position

Beschreibung

Das Kommando REFPOS liefert die Position (20 Bit, innerhalb einer Umdrehung) an der während der Referenzfahrt das "Referenzkriterium" erkannt wurde. Das "Referenzkriterium" hängt von der Referenzfahrtart NREF ab.

NREF=0,5,6 REFPOS = Position an der die Referenzfahrt gestartet wurde
NREF=1,3 REFPOS = Position an der die steigende Flanke des Referenzschalters erkannt wurde
NREF=2,4 REFPOS = Position an der die fallende Flanke des Endschalters erkannt wurde
NREF=7 REFPOS = Position an der ein Anschlag erkannt wurde (PE>PEMAX / 2)
NREF=8 REFPOS wird nicht verändert


ASCII Deutsch RELTIME

ASCII - Kommando | RELTIME |
Syntax Senden | RELTIME [Data] |
Syntax Empfangen | RELTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 389E (hex)
DIM |  | PROFIBUS PNU | 1726 (dec) IND = 33 (dec)
Bereich | 0, 10000....100000 | DPR | 926 (dec)
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | drive configuration | EEPROM |
Kurzbeschreibung | maximale Einschaltzeit der Thyristoren

Beschreibung

Dieser Parameter bestimmt die maximale Zeit für das Einschalten der Thyristoren (nur bei S748/S772).
Nach dem Zuschalten der Netzspannung die Thyristoren werden zugeschaltet, nachdem die Zwischenkreisspannung von 350V erreicht wurde und die Zwischenkreisspannung konstant bleibt (Steigung < 1.5V/1msec). Bei schlechter Qualität der Netzspannung kann es passieren, dass aufgrund der unruhigen Zwischenkreisspannung das Zuschalten der Thyristoren für unbegrenzte Zeit verzögert wird. Mit dem Parameter RELTIME kann diese Verzögerung auf die eingestellte Zeit limitiert werden.

Die Einstellung RELTIME=0 schaltet die Zeitbegrenzung aus.


ASCII Deutsch REMOTE

ASCII - Kommando | REMOTE |
Syntax Senden | REMOTE |
Syntax Empfangen | REMOTE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E4 (hex)
DIM | - | PROFIBUS PNU | 1828 (dec) IND = 1 (dec)
Bereich | 0 .. 1 | DPR | 228 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Zustand des Hardware-Enable

Beschreibung

Das Kommando REMOTE spiegelt den Zustand des Hardware-Enable-Eingangs wieder. 1 bedeutet einen High-Zustand des Eingangs (Hardware-Enable gesetzt), eine 0 einen Low-Zustand.


ASCII Deutsch RESAMPL

ASCII - Kommando | RESAMPL |
Syntax Senden | RESAMPL [Data] |
Syntax Empfangen | RESAMPL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 8191 | DPR | Nein
Default | 1000 |
Opmode | all | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Kabelbruchüberwachung beim Resolver

Beschreibung

Mit dem Parameter RESAMPL wird die minimale Resolver Amplitude eingestellt. Dabei wird nicht nur die Amplitude, sondern auch Sinus/Cosinus-Phase wird überwacht. Diese Funktionalität kann über CPHASE mit gesetzen Bit 4 und Bit 5 aktiviert werden.


ASCII Deutsch RESOLVER

ASCII - Kommando | RESOLVER |
Syntax Senden | RESOLVER [Data] |
Syntax Empfangen | RESOLVER <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3520 (hex)
DIM |  | PROFIBUS PNU | 1632 (dec) IND = 1 (dec)
Bereich | 0 ... 2 | DPR | 32 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Justierung der Resolver Erregung +/- 20%

Beschreibung

RESOLVER 0 reduziert die Erregung um 20%.
RESOLVER 2 erhöht die Erregung um 20%.


ASCII Deutsch RESPHASE

ASCII - Kommando | RESPHASE |
Syntax Senden | RESPHASE [Data] |
Syntax Empfangen | RESPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E5 (hex)
DIM | - | PROFIBUS PNU | 1829 (dec) IND = 1 (dec)
Bereich | +/-90 bei S300 (+/-511 bei S700) | DPR | 229 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Resolverphase

Beschreibung

Siehe ASCII Kommando CALCRP.


ASCII Deutsch RK

ASCII - Kommando | RK |
Syntax Senden | RK [Data] |
Syntax Empfangen | RK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E6 (hex)
DIM | Counts | PROFIBUS PNU | 1830 (dec) IND = 1 (dec)
Bereich | 12000 ..19000 | DPR | 230 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Verstärkungsfaktor Resolver-Sinussignal

Beschreibung

Mit dem Parameter RK kann der ggf. vorhandene Amplitudenunterschied zwischen dem Sinus- und Cosinussignal des Resolvers ausgeglichen werden. Es gelten folgende Abhängigkeiten:
RK = 16384 keine Veränderung der Sinus-Amplitude
RK < 16384 Sinussignal wird abgeschwächt
RK > 16384 Sinussignal wird verstärkt

Eine falsche Einstellung dieses Korrekturfaktors führt zu Geschwindigkeitsschwankungen (Rippel) die stark positionsabhängig sind.
Das Kommando CALCRK ermöglicht eine automatische Ermittlung des Korrekturfaktors RK.

Dieser Wert wird bei einem Download von Parametern nicht verändert, da er nur geräteabhängig ist.


ASCII Deutsch ROFFS

ASCII - Kommando | ROFFS |
Syntax Senden | ROFFS [Data] |
Syntax Empfangen | ROFFS | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35E7 (hex)
DIM | µm | PROFIBUS PNU | 1831 (dec) IND = 1 (dec)
Bereich | long int | DPR | 231 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Referenzoffset

Beschreibung

ROFFS wirk bei Resolver oder Single-Turn-Geber (Referenzfahrt möglich)
Mit dem Parameter ROFFS kann der Referenzposition (Nullposition), die am Ende der Referenzfahrt erreicht wird, eine beliebige absolute Position zugeordnet werden.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab.
Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden grundsätzlich interne Einheiten (Counts) verwendet.

Wenn eine Referenzfahrt ausgeführt wird und die Feedback-Einheit ein Absolutwert-Geber ist, so berechnet der Antrieb nach Beendigung der Referenzfahrt einen Referenz-Offset und speichert diesen automatisch im seriellen Eeprom.


ASCII Deutsch ROFFSABS

ASCII - Kommando | ROFFSABS |
Syntax Senden | ROFFSABS [Data] |
Syntax Empfangen | ROFFSABS | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3656 (hex)
DIM | µm | PROFIBUS PNU | 1942 (dec) IND = 1 (dec)
Bereich | long int | DPR | 342 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 0.39 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Referenzoffset

Beschreibung

Der Parameter wird bei Absolutwertgebern (Multi-Turn, auch mit Referenzfahrt) genutzt.

Falls der Positionswert des Absolutwertgebers verändert werden muß, so kann dies mit Hilfe der Variable ROFFSABS erreicht werden. Beim Einschalten des Verstärkers wird der Wert der ROFFSABS-Variable einmalig zu dem Positionswert des Absolutwertgebers addiert. Da diese Korrektur nur beim Einschalten des Verstärkers durchgeführt wird, muß nach jeder Änderung der ROFFSABS-Variable, der Parameterwert im EEPROM abgespeichert (Kommando SAVE) und der Verstärker aus- und eingeschaltet werden (Kommando COLDSTART).

Beispiel:
Wenn beim Einschalten des Verstärkers und ROFFSABS=0 eine Position von 10000 angezeigt wird, so wird durch Eingabe von ROFFSABS –10000, die Position auf den Wert 0 verschoben.


ASCII Deutsch ROFFSSSI

ASCII - Kommando | ROFFSSSI |
Syntax Senden | ROFFSSSI [Data] |
Syntax Empfangen | ROFFSSSI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3864 (hex)
DIM | - | PROFIBUS PNU | 1668 (dec) IND = 33 (dec)
Bereich | INT32 | DPR | 868 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.28 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | SSI Positionsoffset

Beschreibung

Parameter ROFFSSSI definiert ein Positionsoffset für die Referenzfahrt NREF=8 „Fahren auf die absolute SSI-Position“.


ASCII Deutsch RS232T

ASCII - Kommando | RS232T |
Syntax Senden | RS232T [Data] |
Syntax Empfangen | RS232T <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E8 (hex)
DIM | ms | PROFIBUS PNU | 1832 (dec) IND = 1 (dec)
Bereich | 0 .. 10000 | DPR | 232 (dec)
Default | 2500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | RS232 | EEPROM | Ja
Kurzbeschreibung | Watch-Dog Zeit (RS232)

Beschreibung

Bei aktivierten Überwachung der seriellen Schnittstelle (RS232-Watchdog) kann mit dem Kommando RS232T die Watchdog-Überwachungszeit eingestellt werden.

siehe auch ACTRS232


ASCII Deutsch RSTVAR

ASCII - Kommando | RSTVAR |
Syntax Senden | RSTVAR |
Syntax Empfangen | RSTVAR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E9 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 1 (dec)
Bereich | - | DPR | 233 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Setzen aller Parameter auf Default-Werte

Beschreibung

Das Kommando RSTVAR setzt alle Parameter auf die internen Werkseinstellungen zurück. Die Parameter, die im EEPROM abgespeichert sind, werden davon zunächst nicht betroffen. Erst mit dem Kommando SAVE (abspeichern der Parameter im EEPROM) werden die Default-Einstellungen dauerhaft übernommen.
Falls Einstellungen von Konfigurationsvariablen verändert wurden ist ein SAVE und COLDSTART erforderlich.


ASCII Deutsch RSVERROFF

ASCII - Kommando | RSVERROFF |
Syntax Senden | RSVERROFF [Data] |
Syntax Empfangen | RSVERROFF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 389C (hex)
DIM |  | PROFIBUS PNU | 1724 (dec) IND = 33 (dec)
Bereich | 0 .. 1 | DPR | 924 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 3.66 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Abschalten der Überwachung vom Resolverfehler

Beschreibung

Mit RSVERROFF=1 wird die Überwachung vom Resolverfehler abgeschaltet. Dies gilt für folgende Fälle:

1. F04 Resolver Fehler
2. F06 Motortemperatur
3. F08 Überdrehzahl

Mit diese Funktion kann ein Drive ohne Resolvermotor betrieben werden, ohne dass ein Fehler generiert wird. Aus Sicherheitsgründen kann dieser Parameter nicht im Drive abgespeichert werden.


ASCII Deutsch RUNIN

ASCII - Kommando | RUNIN |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3756 (hex)
DIM | - | PROFIBUS PNU | 1798 (dec) IND = 17 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch S

ASCII - Kommando | S |
Syntax Senden | S |
Syntax Empfangen | S | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EA (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 1 (dec)
Bereich | - | DPR | 234 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Stopp und Disable

Beschreibung

Mit dem Kommando S wird der Antrieb angehalten (Bremsrampe DECSTOP). Sobald die Stillstandsschwelle (VEL0) unterschritten wurde, wird die Endstufe gesperrt.
Das Kommando S entspricht dem Kommando K (bzw. DIS) wenn die Option STOPMODE auf 1 steht.


ASCII Deutsch S1DLY

ASCII - Kommando | S1DLY |
Syntax Senden | S1DLY [Data] |
Syntax Empfangen | S1DLY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 38B9 (hex)
DIM | msec | PROFIBUS PNU | 1753 (dec) IND = 33 (dec)
Bereich | 0 .. 100000 | DPR | 953 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.17 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Einschaltverzögerung

Beschreibung

Mit dem Parameter S1DLY kann die Initialisierungsphase des S700 verzögert werden. Eine Verzögerung kann sinnvoll sein in Verbindung mit Optionskarten, die eine sehr lange Initialisierungsphase haben.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Safetykarte

Diese Bildschirmseite zeigt den Status der eingebauten Safetykarte an.

Profibus1

Der obere Bereich zeigt die Daten der eingebauten Karte und die aktuellen Zustände der Ein-/Ausgänge an. Der Fehler Stack zeigt eine Historie der aufgetretenen Safety Fehler bezogen auf den Betriebsstundenzähler des Servoverstärkers an. Hierbei bedeuten:

Zeit | Betriebsstundenzähler
Nr. | Safety Fehlercode (oXX siehe Datei S700 Safetykarte Fehlercodes im Dateiarchiv (Dokumenttyp: Safetyhandbuch)
Index | Safety Fehlersubindex (iYY siehe Datei S700 Safetykarte Fehlercodes im Dateiarchiv (Dokumenttyp: Safetyhandbuch)
Fehler | Fehlerbeschreibung
CPU, Par1, Par2, Par3 | interne Parameter


ASCII Deutsch SAVE

ASCII - Kommando | SAVE |
Syntax Senden | SAVE |
Syntax Empfangen | SAVE | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EB (hex)
DIM | - | PROFIBUS PNU | 1835 (dec) IND = 1 (dec)
Bereich | - | DPR | 235 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Speichern der Daten im EEPROM

Beschreibung

Mit dem Kommando SAVE werden die aktuellen Einstellungen der Verstärkerparameter im seriellen EEPROM abgespeichert. Gleichzeitig wird die Checksumme für das Parameterfeld aktualisiert und im seriellen EEPROM abgelegt. Der Speichervorgang dauert ca. 2 Sekunden. Während dieser Zeit darf die Versorgungsspannung (24 V) des Verstärkers nicht ausgeschaltet werden. Beim Ausschalten der Versorgungsspannung während des Speichervorganges werden u.U. keine gültigen Daten im seriellen EEPROM abgelegt. Beim nächsten Einschalten des Gerätes wird ein Checksummenfehler festgestellt und die Fehlermeldung F09 (EEPROM-Fehler) generiert.
Darüber hinaus werden alle Verstärkerparameter auf interne Default-Werte gesetzt. Um den Fehler F09 zurückzusetzen muß erneut das SAVE-Kommando ausgeführt und der Verstärker aus- und eingeschaltet werden.

Ein SAVE wird automatisch ausgeführt, wenn bei einem Absolutwert-Geber nachträglich eine Referenzfahrt ausgeführt wird. In diesem Fall wird zuerst ein Referenzoffset (siehe auch ROFFS) berechnet und anschließend das SAVE-Kommando automatisch abgesetzt.


ASCII Deutsch SBAUD

ASCII - Kommando | SBAUD |
Syntax Senden | SBAUD [Data] |
Syntax Empfangen | SBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35EC (hex)
DIM | MBaud | PROFIBUS PNU | 1836 (dec) IND = 1 (dec)
Bereich | 2, 4, 8, 16 | DPR | 236 (dec)
Default | 4 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.00 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | SERCOS: Baudrate

Beschreibung

Mit diesem Parameter wird die Sercos Übertragungsrate in MBAUD eingestellt.


ASCII Deutsch SCAN

ASCII - Kommando | SCAN |
Syntax Senden | SCAN |
Syntax Empfangen | SCAN <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35ED (hex)
DIM | - | PROFIBUS PNU | 1837 (dec) IND = 1 (dec)
Bereich | - | DPR | 237 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.6
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Erkennung der CAN-Stationen

Beschreibung

Bei einem CAN-Netzwerk an dem mehrere Verstärker angeschlossen sind, gibt es die Möglichkeit über eine serielle Verbindung zu einem der Geräte (Master), eine Kommunikation zu allen anderen Verstärkern herzustellen. Dazu wird mit dem Kommando SCAN am Master-Gerät eine automatische Erkennung aller angeschlossenen Verstärker eingeleitet. Die Antwort auf das SCAN-Kommando enthält die Anzahl sowie eine Adressenaufstellung aller erkannten Verstärker-Stationen.

Die Ausführungszeit für dieses Kommando hängt stark von der eingestellten CAN-Baudrate (CBAUD) ab und liegt im Bereich zwischen 1 Sek (1 MBaud) und 37 Sek (10 KBaud).


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Oszilloskop

oszilloskop

Hinweise zur Bedienung

Zoom

Diese Funktion ist unabhängig von der eingesetzten Firmware und kann sowohl im Online- als auch im Offline-Modus benutzt werden.

Im Kurven-Bereich kann bei gedrückter linker Maustaste ein Zoom-Rechteck „gezogen“ werden.

Nach dem Loslassen der Maustaste wird der ausgewählte Kurvenbereich auf den gesamten Anzeigebereich vergrößert Durch eine kurze Betätigung der rechten Maustaste wird die Zoom-Funktion abgeschaltet und die gesamte Kurve angezeigt. Wenn bei aktiver Zoom-Darstellung der Daten-Cursor im vergrößerten Bereich platziert wird, so kann mit den Pfeil-links/rechts-Tasten der Zoom-Bereich innerhalb der gesamten Kurve verschoben werden. Mit den Tasten Pfeil-unten/oben oder mit dem Maus-Rad kann der Bereich der Zeit-Achse um den Daten-Cursor gedehnt oder gestaucht werden.

Ausblenden/Einblenden von Kanälen

Durch die Betätigung der linken Maustaste auf dem Kanal-Text (z.B. Channel 2) kann die zugehörige Kurve ausgeblendet werden. Der Text „Channel 2“ wird durch die Anzeige „——-„ ersetzt. Ein erneuter Klick der linken Maustaste blendet die Kurven-Anzeige des zugehörigen Kanales wieder ein.

Durch die Betätigung der rechten Maustaste auf dem Kanal-Text werden alle Kanäle bis auf den angeklickten Kanal ausgeblendet (Solo-Anzeige). Ein erneuter Klick der rechten Maustaste auf den Solo-Kanal blendet alle Kurven wieder ein.

Kanäle

Nur die ersten 4 Kanäle können auf dem Bildschirm sichtbar gemacht werden. Bis zu 10 Kanäle können jedoch aufgezeichnet (siehe Registerkarte Extended Channels) und als Excel Datei gespeichert werden.

Zykluszeit der Messwertermittlung ³ 250 µs.

Auflösung
Anzahl der Abtastungen/Zeiteinheit (Speichertiefe). Einstellung: fein, normal, grob

Zeit/Div
Skalierung der Zeit-Achse. Wählen Sie die Zeit/Teileinheit.
Einstellung: 1.....5000 ms/Div, Gesamtlänge der Zeitachse: 8 * x ms/Div

Kanal 1 bis 4
Zuweisung der darzustellenden Größen zu den Kanälen.

I_ist | Drehmoment-(Strom-)istwert
I_soll | Drehmoment-(Strom-)sollwert
n_ist | Geschwindigkeitsistwert
n_soll | Geschwindigkeitssollwert
S_ist | Positionsistwert
S_soll | Positionssollwert
Sfehl | Schleppfehler
VBUS | Zwischenkreisspannung
Aus | Kanal wird nicht verwendet
Benutzerdefiniert | Makro-Variable

Bei der Wahl "Benutzerdefiniert" können Sie den Wert einer Makro-Variable darstellen. Für z.B. Kanal 4 öffnet sich ein Eingabefenster:

makro1

Geben Sie den Namen der Makro-Variablen ein (Liste ausgewählter Makros siehe unten).

Makro Variablen (Auswahl) | Kurzbeschreibung
ERRCODE | Fehlerstatus (siehe ERRCODE)
STATCODE | Verstärkerstatus (siehe STATCODE)
TRJSTAT | Status Trajektorie (siehe TRJSTAT)
ADVAL0…15 | Analoge Eingangswerte
ADVAL0 | Cosinus Resolver
ADVAL1 | Sinus Resolver
ADVAL2 | Motorstrom Ia
ADVAL3 | Motorstrom Ib
ADVAL4 | Sinus Encoder
ADVAL5 | Cosinus Encoder
ADVAL6 | Analog Sollwert 1
ADVAL7 | Analog Sollwert 2
ADVAL8 | Motortemperatur
ADVAL9 | Kühlkörpertemperatur
ADVAL10 | Umgebungstemperatur
ADVAL11 | Sense Spannung Encoder
ADVAL12 | n.c.
ADVAL13 | Zwischenkreisspannung
ADVAL14 | n.c.
ADVAL15 | n.c.
SIENC | Sinus Encoder normalisiert +/- 1350 <> 1Vss
COENC | Cosinus Encoder normalisiert +/- 1350 <> 1Vss
SR_RXDE | Nullimpulseingang bei NREF = 5
SR_HALL | Hall Segment Eingang
PFBL | Positionsrückführung 64 Bit. Die unteren 32 Bit beinhalten die Position innerhalb einer Umdrehung, die oberen 32 Bit die Anzahl der Umdrehungen.
S_SETL | Positionssollwert 64 Bit. Die unteren 32 Bit beinhalten die Position innerhalb einer Umdrehung, die oberen 32 Bit die Anzahl der Umdrehungen.
PFB | Positionsrückführung (PRBASE definiert Format)
S_SET | Positionssollwert (PRBASE definiert Format)
S_SETH | SERCOS Positionssollwert (1 Umdrehung = 2^20)
PTARGET | Zielposition für den letzten/aktuellen Fahrauftrag (PRBASE definiert Format)
PSPEED | Aktueller Drehzahlsollwert in counts/250µsec
PSPEEDMS | Aktueller Drehzahlsollwert in counts/250µsec für Master/Slave Trajektorie
PSPEED3 | Aktueller Drehzahlsollwert für interne Fahrsatz Trajektorie
PENDSPEED | Zielgeschwindigkeitssollwert des aktuellen Fahrauftrage
MOVEP_NR | Nummer des letzten/aktuellen Fahrauftrages
NIZFLAG | Status des externen Nullimpulses
PSTOP | Status des PSTOP Endschalters
NSTOP | Status des NSTOP Endschalters
INPUT1…20 | Status der Eingänge Input 1…20
OUTPUT1...18 | Status des Ausgänge Output 1..18
HARDENA | Status des Hardware Enable
EN_P_I | Status der Endstufe (1=enabled, 0=disabled)
NET_BTBI | Status des Netz-BTB
ENABLE_I | Status des internen Enable Signals
SOFTENABLE | Status des Software Enable
EN_BRAKE_I | Status der Haltebremse (1=open, 0=closed)
PRD | Position Rückführung innerhalb einer Umdrehung
IVORCMD | Stromvorsteuerung (3280 = DIPEAK)
PBAL | Aktueller Wert Bremsleistung
SR5VINCR | Impulszähler für X5 Master / Slave (5V)
SR24VINCR | Impulszähler für X3 Master / Slave (24V)

Autom. Skal.
Für jeden Kanal kann der Messbereich automatisch (Auto-Checkbox aktiv) oder manuell (Auto-Checkbox inaktiv und min-max-Werte eingetragen) gewählt werden.

Skalierungsart
Sie können zwischen Standard und Min-Max Skalierung wählen.

Trigger

einheiten3

Trigger-Modus
Die Messung wird einmalig getriggert bei der Einstellung Single-Shot. Die Einstellung Auto führt zu zyklischem Triggern.

Trigger-Signal
Strom- und Geschwindigkeitsgrößen oder I/Os können als Triggersignal verwendet werden. Zusätzlich kann mit "Direct" die Triggerung sofort (unabhängig) gestartet werden. Die Einstellung "user-defined" ermöglicht es, eine Makro-Variable über ASCII manuell einzugeben.

Trigger-Position
X-Wert für die Triggerung (Zeit-Achse)

Trigger-Level
Y-Wert für die Triggerung

Trigger-Flanke
Triggerung auf die steigende oder fallende Flanke

Aufzeichnung / Oszillogramme

einheiten31

Speichern
Speichern der erfassten Messwerte auf Datenträger in CSV Format (kann mit MS-Excel ausgewertet werden).

Laden
Laden einer CSV-Datei und Darstellung der Kurven im Diagramm.

Mem
Wenn diese Funktion aktiviert ist, wird bei einer neuen Aufzeichnung die Kurve der vorherigen Messung abgespeichert, um einen Vergleich zweier Messungen zu ermöglichen. Die alten Messkurven werden in einer dunkleren Farbe dargestellt als die aktuellen. Die Messbereichseinstellungen müssen bei beiden Messungen identisch sein. Andernfalls wird die "Mem"-Checkbox deaktiviert und gesperrt.

Interpolierte Werte
Bei markiertem Kontrollkästchen werden Zwischenwerte zwischen den Messwerten interpoliert.

Aktuelles Oszillogramm
Zeigt den Dateinamen sowie den Pfad einer geladenen CSV-Datei an.

Service-Funktionen

Sorgen Sie dafür, dass die aktuelle Position der Last die nachfolgenden Positioniervorgänge zulässt. Die parametrierten Software-Endschalter sind je nach Betriebsmodus unwirksam. Die Achse fährt eventuell auf den Hardware-Endschalter bzw. auf den mechanischen Anschlag. Es besteht die Gefahr von Beschädigungen.

einheiten32

Funktion

Wählen Sie eine der unten beschriebenen Servicefunktionen aus.

Klicken Sie auf den Button "Parameter" und stellen Sie die entsprechenden Parameter ein.

Starten Sie dann die Funktion über den Button START.

Die Funktion wird solange ausgeführt, bis Sie auf den Button STOP klicken oder die Funktionstaste F11 betätigen..

Gleichstrom | Bestromen des Motors mit einstellbarem konstantem Gleichstrom und elektrischem Feldwinkel. Die Umschaltung von Drehzahl- auf Strom-Regelung erfolgt automatisch, die Kommutierung erfolgt unabhängig von der Rückführung (Resolver o.ä.). Der Motor rastet in einer Vorzugsstellung.
Drehzahl | Fahren des Antriebs mit konstanter Drehzahl. Es erfolgt eine interne digitale Sollwertvorgabe (Geschwindigkeit einstellbar).
Drehmoment | Fahren des Antriebs mit konstantem Strom (konstante Beschleunigung). Es erfolgt eine interne digitale Sollwertvorgabe (Strom einstellbar). Die Umschaltung von Drehzahl- auf Strom-Regelung erfolgt automatisch, die Kommutierung erfolgt abhängig von der Rückführung (Resolver o.ä.).
Reversier | Fahren des Antriebs im Reversierbetrieb mit getrennt einstellbarer Geschwindigkeit und Reversierzeit für jede Drehrichtung.
Fahrauftrag | Starten des auf der Serviceparameter-Seite gewählten Fahrauftrages.
Zero | Funktion zur automatischen Einstellung der Motorgeberphase in Bezug zur Phasenlage des Motors. Der Betriebsmodus wird umgeschaltet in OPMODE 2 .

Bei den Funktionen "Gleichstrom" und "Zero" geht die Motorwelle in Vorzugsstellung. Sie kann eine ruckartige Bewegung ausführen, um dorthin zu gelangen

Start / Stop

Starten / Stoppen der ausgewählten Servicefunktion. Stopp ist auch mit F11 möglich.

Parameter

service2

Einstellen der Parameter für die Servicefunktionen.

Regler-Einstellung

einheiten33

Hier sind einige für das Regelverhalten wichtige Parameter zusammengefasst. Sie können hier das Regelverhalten des Servoverstärkers für Ihre Anwendung optimieren, ohne den Oszilloskopmodus zu verlassen.

Kp_v | GV
Tn_v | GVTN
TP Freq. | ARLPF
2. TP Freq. | ARLP2
HP Freq. | ARHPF
Kp_p | GP
Drehz.-Vorst. | GPFFV
Strom-Vorst | GPFFT
Res.-Bandbr. | MRESBW
Beob.-Vorst | VLO

Oszilloskop-Einstellung

Hier können die Grundeinstellungen für das Oszilloskop vorgenommen werden.

einheiten331

Für jeden Kanal, Vordergrund, Hintergrund und Cursor können die Farben definiert werden. Klicken auf die jeweilige Schaltfläche öffnet das Auswahlfenster für Farben:

farben

Die Schaltflächen "Mem. Kanal x Farbe..." definiert die Farbe der gespeicherten "alten" Vergleichskurven. Klicken auf Schaltfläche "Standardfarben" setzt die Farben auf die Werkseinstellung zurück.

Bildschirmtext | ASCII-Parameter
Oszilloskop-Abtastrate 4kHz/16kHz | DRVCNFG2

Extended Channels

Erweitert die Anzahl der Kanäle auf 10. Nur die ersten 4 Kanäle können auf dem Bildschirm sichtbar gemacht werden. Bis zu 10 Kanäle können jedoch aufgezeichnet und als Excel Datei gespeichert werden. Aktivieren Sie das Kontrollkästchen "Extended Channels" und definieren Sie die Kanäle 5 bis 10 wie in Kapitel Kanäle für die Kanäle 1 bis 4 beschrieben.

einheiten3312

WS Tuning

Diese Registerkarte erscheint nur, wenn die Wake&Shake Regelkreismethode gewählt wurde (siehe auch Kapitel Wake und Shake).

einheiten3311

Die Schaltfläche "Start CALCMP" startet die Wake&Shake Funktion.

Aufzeichnung

Cursor-Funktion

Bei der Anzeige eines Datensatzes (aus einer Datei oder durch Starten einer Aufzeichnung) werden durch einen Mausklick in das Koordinatensystem die Werte der gemessene Signale für den gewählten Zeitpunkt angezeigt. Durch einen Klick außerhalb des Koordinatensystems oder einen Mausklick bei gedrückter Shift-Taste werden die angezeigten Werte wieder ausgeblendet.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

SD Karte

Diese Bildschirmseite ermöglicht das Konfigurieren, Speichern und Laden von Dateien auf der Speicherkarte.

Profibus1

Während der Laden-/Speichern-Vorgänge wird der Servoverstärker gesperrt und wieder freigegeben. Je nach Funktion wird das Gerät zurückgesetzt und neu gestartet.

Stellen Sie sicher, dass gekoppelte Lasten gesichert sind, insbesondere hängende Lasten.

Der obere Bereich des Bildschirms ermöglicht die Konfiguration der zu übertragenen Daten. Die vordefinierten Konfigurationen sind sinnvoll für die häufigsten Aufgaben:

  • komplettes Servoverstärker Backup: vollständiger Datensatz inklusive Tuning und Fahrsatzdaten, zum Beispiel für ein identisches Austauschgerät an derselben Stelle.
  • Übertragbares Backup: Datensatz ohne Tuning und Fahrsatzdaten, kann zum Beispiel in einen Verstärker mit anderem Nennstrom übertragen werden.

Sie können auch selbst festlegen, welche Daten Sie speichern oder Laden wollen. Wählen Sie dazu aus den angebotenen Komponenten die gewünschten aus. Es gibt diverse vorgegebene erzwungene Verknüpfungen dieser Komponenten, um unerwünschte Inkompatibilitäten zu vermeiden.

Firmware | Betriebssystem des Servoverstärkers, siehe auch Dateiarchiv (Dokumenttyp: Firmware)
PLC | Makroprogramm, siehe auch KDN Seite Makro Programmierung
MDB | Motordatenbank, siehe auch Dateiarchiv (Dokumenttyp: Motordatenbank)
Profiltabellen | Kundenspezifische Profiltabellen, siehe auch KDN Seite Fahrprofiltabellen
Parameter | Parametersatz für die Regelkreise und Motor/Feedback Einstellungen
Fahrsätze | Definition der Fahraufträge
Cogging Tabelle | Daten für die Cogging Kompensation des angeschlossenen Motors. Diese Daten sind nur gültig für die Servoverstärker-Motor-Kombination, für die sie erstellt wurden.
Offset values | Offset Daten. Diese Daten sind nur gültig für die Servoverstärker-Motor-Kombination, für die sie erstellt wurden.
Safetykarten Einstellungen | Sicherheitsrelevante Parameter der Safetykarte. Diese Daten sind an die Seriennummer der eingebauten Safetykarte gebunden und können nicht mit anderen Karten verwendet werden.

Dateinamen Erweiterungen:

Backuptyp | Erweiterung
Firmware (FW), Motordatenbank (MDB), Profiltabellen (PT) | *.FMP
Parameters und Fahrsätze | *.PAR
Fahrsätze | *.MTS
Motordatenbank | *.MDB
Makros (PLC) | *.PLC
Cogging Tabelle | *.COG
Übertragbares Backup (FW, PLC, MDB, PT) | *.TBK
Komplettes Servoverstärker Backup | *.DBK

Datei Löschen

Das Fenster im unteren Bereich zeigt die auf der Speicherkarte verfügbaren Dateien. Sie können eine Datei löschen. Wählen Sie dazu die Datei im Fenster an und Klicken Sie auf die Schaltfläche "Löschen"

Laden

Die Schaltfläche "Laden von SD-Karte" wird erst freigegeben, wenn mindestens eine Komponente angewählt wurde. Klicken auf die Schaltfläche öffnet ein Fenster zur Dateiauswahl:

In diesem Beispiel wurde die Komponente MDB (Motordatenbank) gewählt, die Speicherkarte enthält jedoch keine Datei mit der Endung ".MDB".

Klappen Sie in solchen Fällen die Auswahlliste für den Dateityp heraus und wählen Sie "*.all*. Jetzt werden alle auf der Karte verfügbaren Dateien angezeigt.

Wählen Sie die gewünschte Datei an und Klicken Sie auf OK. Die Daten werden nun in den Servoverstärker geladen.

Werden keine Daten angezeigt, stellen Sie sicher, dass die Karte mit FAT32 Dateityp formatiert wurde.

Speichern

Die Schaltfläche "Speichern auf SD-Karte" wird erst freigegeben, wenn mindestens eine Komponente angewählt wurde. Klicken auf die Schaltfläche öffnet ein Speichern-Unter Fenster:

In diesem Beispiel wurde die Komponente MDB (Motordatenbank) gewählt.

Geben Sie einen Dateinamen ein und Klicken Sie auf OK. Die Daten werden nun auf der Speicherkarte gespeichert.

Verwendete ASCII Befehle

CARDINFO | CARDINFO, zeigt das Typenschild der Speicherkarte (FAT32)
CARDDIR | CARDDIR, zeigt das Root Inhaltsverzeichnis der Speicherkarte
CARDDEL | CARDDEL, löscht eine Datei aus dem Root Verzeichnis der Speicherkarte
CARDSAVE | CARDSAVE, zeigt das Root Inhaltsverzeichnis der Speicherkarte
CARDUPDATE | CARDUPDATE, Lädt eine Firmware-/Daten-Komponente von der Karte in den Flash Speicher des Verstärkers.


ASCII Deutsch SDLY

ASCII - Kommando | SDLY |
Syntax Senden | SDLY [Data] |
Syntax Empfangen | SDLY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3757 (hex)
DIM | - | PROFIBUS PNU | 1799 (dec) IND = 17 (dec)
Bereich | 0 ... 100 000 | DPR | 599 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.31 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Start Verzögerung

Beschreibung

SDLY definiert die Startverzögerung der Programmausführung.
Nach dem Hochfahren der Reglerfirmware werden das BTB Signal und die Überwachungsprogramme für die Zeit SDLY (in ms) verzögert.

Siehe auch ERRCODE * F10


ASCII Deutsch SERCERR

ASCII - Kommando | SERCERR |
Syntax Senden | SERCERR |
Syntax Empfangen | SERCERR <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 ... 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Fehlerhafter IDN Zugegriff

Beschreibung

Mit der dem Kommando SERCERR wird angezeigt, daß mit dem Kommando SERCOS fehlerhaft auf eine IDN zugegriffen wurde.

Siehe auch Kommando SERCOS.


ASCII Deutsch SERCLIST

ASCII - Kommando | SERCLIST |
Syntax Senden | SERCLIST [Data] |
Syntax Empfangen | SERCLIST <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 ... 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Zugriff auf IDN Liste

Beschreibung

Mit der dem Kommando SERCLIST kann auf ein bestimmtes Element einer IDN Liste gezeigt werden um mit dem Kommando SERCOS dieses Element zu lesen. Siehe auch Kommando SERCOS.


ASCII Deutsch SERCOFFS

ASCII - Kommando | SERCOFFS |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

SERCOS Erweiterungskarte

Diese Bildschirmseite erscheint nur, wenn eine SERCOS Erweiterungskarte in den Servoverstärker eingebaut ist.

Sercos

Konfigurieren der SERCOS Schnittstelle für einwandfreie Kommunikation mit dem Master. Geben Sie die Kabellänge ein (max. 45m, wichtig für die optische Leistung) und stellen Sie die Baudrate ein (siehe Installationshandbuch des Servoverstärkers oder SERCOS Dokumentation).

Wenn die optische Leistung nicht richtig eingestellt ist, treten Fehler in der Telegrammübertragung auf, und die rote LED am Antrieb leuchtet. Während der normalen Kommunikation blinken die grünen LEDs für Senden und Empfangen schnell, wodurch der Eindruck entsteht, dass die jeweilige LED leuchtet.

Weitere Informationen zur Einrichtung eines SERCOS Systems entnehmen Sie der SERCOS Dokumentation oder unseren Applikationshinweisen.

LWL-Kabellänge
Bei nicht korrekt eingestellte optischer Leistung kann die Kommunikation störanfällig sein. Sie können hier die Leitungslänge (in Meter) für ein standardisiertes 1 mm² Glasfaserkabel festlegen.

0 m | sehr kurze Verbindung
1 m…< 15 m | Länge der Verbindung mit einem 1 mm² Kunststoffkabel
15 m…<30 m | Länge der Verbindung mit einem 1 mm² Kunststoffkabel
³ 30 m | Länge der Verbindung mit einem 1 mm² Kunststoffkabel

Baudrate
Bei nicht korrekt eingestellter Baudrate kommt keine Kommunikation zustande. Stellen Sie hier die Baudrate in MBaud ein.

Adresse
Die aktuelle Adresse des Antriebs wird angezeigt (Einstellung siehe CAN/Feldbus).

Phase
Hier wird die aktuelle Phase der SERCOS-Übertragung angezeigt.

Zykluszeit
Hier wird die aktuelle Zykluszeit angezeigt.

Überwache IDN

Nr.
Tragen Sie hier eine IDN ein, die dann zyklisch erneuert wird (Beispiel: um IDNP 3036 zu betrachten, 3036 eingeben). Dies dient als interner „Service-Kanal“.

Wert
Der Wert der überwachten IDN. Bei IDNs, die Listen enthalten, wird nur die Listenlänge angezeigt.

SERCOS Produkteinstellungen

Fehler, wenn HW-Endschalter gemeldet wird (IDNP 3015)
Über diese Funktion wird das Verhalten beim Erreichen des Hardware-Endschalters eingestellt.

Fehler, die Coldstart erfordern, nicht löschen (IDNP 3016)
Hier kann eingestellt werden, dass Fehlermeldungen, die einen Kaltstart erfordern, bei einem Reset-Kommando nicht gelöscht werden.

SW-Enable vor HW-Enable zulassen (IDNP 3028)
Erlaubt das Setzen des Enables über Sercos vor dem HW-Enable. Sonst wird ein Fehler F29 generiert.

Beschleunigungs-Vorsteuerung aktivieren (IDNP 3052)
Über den ASCII-Parameter GPFFT oder IDN 348 kann die Stärke der vom Verstärker errechneten Vorsteuerung geändert werden.

SERCOS Standardeinstellungen

Lagesollwerte invertieren (IDN 55)
Über diese Funktion kann die Polarität der Lagesollwerte invertiert werden. Die Motorachse dreht im Uhrzeigersinn, wenn ein positiver Lagesollwert ohne Invertierung anliegt.

Lageistwert 1 invertieren (IDN 51)
Über diese Funktion kann die Polarität des internen Lageistwertes invertiert werden.

Lageistwert 2 invertieren (IDN 53)
Über diese Funktion kann die Polarität des externen Lageistwertes invertiert werden.

Lagegrenzwert aktivieren (IDN 55)
Aktiviert die Software-Endschalter. Ist bei linearer Lagewichtung immer aktiv.

Geschwindigkeits-Sollwert invertieren (IDN 44)
Über diese Funktion kann die Polarität des Drehzahlsollwertes invertiert werden. Die Motorachse dreht im Uhrzeigersinn, wenn ein positiver Drehzahlsollwert ohne Invertierung anliegt

Geschwindigkeits-Istwert invertieren (IDN 43)
Über diese Funktion kann die Polarität des Drehzahlistwertes invertiert werden.

Spline-Interpolation aktivieren (IDNP 3040)
Nur wenn eine Zykluszeit von 500µs gewählt ist, kann man statt der linearen Interpolation eine quadratische Interpolation wählen. Modulo darf nicht aktiv sein.

Wichtungsmethode
Rotatorisch oder Linear.

Standardwichtungsart
Default- oder Parameterwichtung.

Wichtungseinheiten
Einheiten der gewählten Wichtung.

Datenbezug
Der Datenbezug kann auf die Motorwelle (interner Geber) oder auf die Last (externer Geber) erfolgen.

Verarbeitungsformat
Moduloformat.

Bus-Parameter

Parameter "Telegrammart"
Die gewählte Telegrammart

Hauptbetriebsart
Lage-, Drehzahl-, oder Stromregelung.

Lageregelungs-Parameter

Motorgeber
Zu benutzender Geber.

externer Geber
Zu benutzender Geber.

Schleppfehler-Überwachung
Auswahl Betrieb mit (default) oder ohne interne Geschwindigkeitsvorsteuerung.

Lastgetriebe-Eingangsumdrehungen
Getriebefaktor IDN 121

Lastgetriebe-Ausgangsumdrehungen
Getriebefaktor IDN 122

Vorschubkonstante
Vorschub bei linearer Wichtung.

Rotations-Lageauflösung
Inkremente pro Umdrehung.

Rotationsgeber 2 - Auflösung
Auflösung externer Geber.


ASCII Deutsch SERCOS

ASCII - Kommando | SERCOS |
Syntax Senden | SERCOS [Data] |
Syntax Empfangen | SERCOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Lesen des Dateninhalts eines SERCOS IDN

Beschreibung

Mit dem Kommando SERCOS kann der Dateninhalt einer Sercos IDN gelesen werden. Beim Schreiben wird die Nummer der IDN abgesetzt und beim Lesen erhält man den aktuellen Wert dieser IDN zurück. Falls die gewünschte IDN eine Liste ist, so wird nur der Listenwert zurückgegeben auf den das Kommando SERCLIST zeigt. Erfolgt ein fehlerhafter Zugriff auf eine IDN, z.B. nicht vorhandene IDN, so wird das ASCII Kommando SERCERR auf 1 gesetzt und eine 0 als aktueller Wert der IDN, mit dem Kommando SERCOS zurückgegeben.


ASCII Deutsch SERCSET

ASCII - Kommando | SERCSET |
Syntax Senden | SERCSET [Data] |
Syntax Empfangen | SERCSET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3691 (hex)
DIM | - | PROFIBUS PNU | 2001 (dec) IND = 1 (dec)
Bereich | Long Int | DPR | 401 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | Setze SERCOS / EtherCAT Einstellungen

Beschreibung

Mit dem Kommando SERCSET können einige Sercos oder EtherCAT Einstellungen gesetzt und gelesen werden. Geänderte Einstellungen können im EEPROM abgespeichert werden und stehen nach dem nächsten Regler Reset zur Verfügung. In den hier nicht beschriebenen Bits werden andere busspezifische Sercos Einstellungen abgespeichert, aus diesem Grund sollte dieses Kommando nur über das Bedienprogramm abgesetzt werden. Siehe auch SERCOS IDN Handbuch.

Achtung: Falls der Feldbus gewechselt wird, müssen die nicht benötigten Bits gelöscht werden!

Unter EtherCAT haben die SERCSET Bits folgende Bedeutung:
Bit 0-15: Reserve
Bit 16 (0x0001 0000) = 1: Bootstrap durch Master löst einen Kaltstart des Reglers aus
Bit 17 (0x0002 0000) = 1: keine Überwachung für Warnung n17

Bit 18 (0x0004 0000) = 0: Falls Bit 17 gesetzt, müssen 10 Telegramme ausbleiben, bevor die Synchronisation als verloren gilt. Diese Überwachung ist nur im Zustand „Operational“ aktiv.
Bit 18 (0x0004 0000) = 1: Es werden keine EtherCAT-Interrupts überwacht

Bit 19 (0x0008 0000) = 1: bei Vorliegen eines Fehlers, der beim Rücksetzen zum Kaltstart führt, F29 gesetzt
Bit 20 (0x0010 0000) = 1: Es werden aktuelle Werte in 250 Mikrosekunden statt in Interrupt geschrieben (schneller)
Bit 21 (0x0020 0000) = 1: Es wird das Bit 5 im Statuswort auch bei anderen Schnellhaltquellen als dem Steuerwort bedient (also Hardware- und Softwareendschalter)
Bit 22-31: Reserve

Unter Sercos haben die SERCSET Bits folgende Bedeutung
Bit | Wertigkeit | Bedeutung
0 | 0x0000 0001 | = 1: IDN 3015 Endschalter Konsequenz
1 | 0x0000 0002 | = 1: IDN 3016 CLRFAULT Kommando Konsequenz
2 | 0x0000 0004 | = 1: IDN 3028 Reihenfolge HW & SW - Enable
3 | 0x0000 0008 | = 1: IDN 3052 Beschleunigungsvorsteuerung
4-11 | 0x0000 0FF0 | = 1: IDN 55 Positionssollwert Polarität, Bit 8: Softwareendschalter
12-15 | 0x0000 F000 | = 1: IDN 43 Geschwindigkeitssollwert Polarität
16 | 0x0001 0000 | = 1: SLEN binär
17 | 0x0002 0000 | = 1: MST Check für DMS
18 | 0x0004 0000 | = 1: IDN 3059 externe Vorsteuerung nur Strom
19 | 0x0008 0000 | = 1: IDN 3059 externe Vorsteuerung Drehzahl & Strom
20 | 0x0010 0000 | = 1: IDN 3040 Quadratische Interpolation
21 | 0x0020 0000 | = 1: Überwachung des OPMODE abschalten (ab FW 3.55)
22 | 0x0040 0000 | Reserve
23 | 0x0080 0000 | = 1: Schaltet Bit 3 im AT-Status aus
24-31 | 0xFF00 0000 | = 1: IDN 76


ASCII Deutsch SERIALNO

ASCII - Kommando | SERIALNO |
Syntax Senden | SERIALNO |
Syntax Empfangen | SERIALNO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35EF (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 1 (dec)
Bereich | 10 ASCII characters | DPR | 239 (dec)
Default | Factory default |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Seriennummer des Verstärkers

Beschreibung

Seriennummer des Verstärkers


ASCII Deutsch SETENCOFFS

ASCII - Kommando | SETENCOFFS |
Syntax Senden | SETENCOFFS [param1] [param2] [param3] |
Syntax Empfangen | - | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | -2147483648 .. 2147483647 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Interger32
Verstärker Status | - | Wichtung |
ab Firmware | 5.86 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | Feedback | EEPROM | Nein
Kurzbeschreibung | Funktion zur Nullpunkverschiebung

Beschreibung

Die Funktion SETENCOFFS unterstützt die Nullpunktverschiebung bei den Gebersystemen HIPERFACE (Sick,Stegmann) und ENDAT 2.1 & 2.2 (Heidenhain).

HIPERFACE:
Es sind zwei Parameter beim Aufruf erforderlich. Der Positionswert und das HW-Passwort. Es wird das HIPERFACE eigene Kommando „Position setzen“ (0x43) ausgeführt. Näheres siehe Hersteller spezifische Dokumentation.

EnDAT:
Es werden bis zu drei Parameter beim Aufruf erforderlich. Die Anzahl der Parameter ist abhängig vom Typ der Funktionsausführung. Folgende Funktionsaufrufe werden unterstützt:

1. Parameter Typ der Nullpunktverschiebung
0 – zurück auf den Auslieferungszustand
1 – elektronisches Nullsetzen
2 – auf eine bestimmte Position
3 – um einen bestimmten Wert

2. Paramet
Zahlenwert (nur erforderlich Typ 2 & 3)

3. Parameter
HW-Passwort: Näheres siehe Hersteller spezifische Dokumentation (D722024-03-A-01/Pkt.10 EnDAT Nullpunktverschiebung).


ASCII Deutsch SETREF

ASCII - Kommando | SETREF |
Syntax Senden | SETREF |
Syntax Empfangen | SETREF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 35F0 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 1 (dec)
Bereich | - | DPR | 240 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Setzen des Referenzpunktes

Beschreibung

Mit dem Kommando SETREF wird die aktuelle Position zum Referenzpunkt erklärt (d.h. die aktuelle Position wird auf den Wert ROFFS gesetzt) und das Bit welches ein Fahren von Fahrsätzen ermöglicht, wird gesetzt.
Das SETREF-Kommando entspricht der Ausführung einer Referenzfahrt mit NREF=0.


ASCII Deutsch Kurzbeschreibung

\ | Anwahl der Remote Adresse
ACC | Beschleunigungsrampe Drehzahlregelung
ACC_X | Beschleunigungsrampe Drehzahlr. 2. Parametersatz
ACCR | Beschleunigungsrampe Referenzfahrt/Tippbetrieb
ACCUNIT | Art der Beschleunigungsvorgabe im System
ACTFAULT | Fehler Stopp Modus
ACTIVE | Endstufe freigegeben/gesperrt
ACTRS232 | Freigabe des RS232-Watchdogs
ADC0_15 | interne Offsetwerte
ADDR | Stationsadresse
AENA | Initialisierungszustand der Software-Freigabe
ALIAS | Symbolischer Verstärker-Name
AN11NR | Nr. der INxTRIG Variable, bei analoger Vorgabe
AN11RANGE | Bereich für die analoge Änderung von INxTRIG
AN1TRIG | Skalierung des Analogausgangs 1
AN2TRIG | Skalierung des Analogausgangs 2
ANCNFG | Konfiguration der analogen Eingänge
ANDB | Totband für den analogen Drehzahlsollwert
ANHFACT1 | interner Parameter
ANHFACT2 | interner Parameter
ANIN1 | Spannung am Analog-Eingang SW1
ANIN2 | Spannung am Analog-Eingang SW2
ANIN3 | Spannung am Analog-Eingang SW3 (POS I/O)
ANIN4 | Spannung am Analog-Eingang SW4
ANOFF1 | Analogoffset für den Analogeingang analog input 1
ANOFF2 | Analogoffset für den Analogeingang SW2
ANOFF3 | Analogoffset für den Analogeingang SW3 (POS I/O)
ANOFF4 | Analogoffset für den Analogeingang SW4 (POS I/O)
ANOUT1 | Vorwahl für den Analogausgang 1
ANOUT2 | Vorwahl für den Analogausgang 2
ANZERO1 | Offsetabgleich für den Analogeingang 1
ANZERO2 | Offsetabgleich für den Analogeingang SW2
ANZERO3 | Offsetabgleich für den Analogeingang SW3 (POS I/O)
ANZERO4 | Offsetabgleich für den Analogeingang SW4 (POS I/O)
ARHPD | Dämpfung Hochpass
ARHPF | Grenzfrequenz Hochpass
ARLP2 | Tiefpass in Hz
ARLPD | Dämpfung Tiefpass
ARLPF | Grenzfrequenz Tiefpass
ASMWAIT | erzw. Verzögerung des Drehzahlsollwerts (Asynchr.)
AUTOHOME | Automatische Referenzfahrt
AVZ1 | Filter-Zeitkonstante für den Analogeingang 1
AVZ2 | Filter-Zeitkonstante für den Analogeingang 2
BCC | EEPROM-Checksumme
BCCOT | EEPROM-Checksumme ohne Betriebsstundenzähler
BISSCNFG | Konfigurationsparameter für BiSS-C
BISSREVOL | Anzahl der Multiturn-Bits bei einem BISS-C-Geber
BQMODE | Filterwahl
BTIME | Entladezeit des Zwischenkreises bei INxMODE 62
BUILDRK | automatische Ermittlung von RK
BUILDRP | interner Parameter
BUSP0 | Konfigurationsvariable für Feldbusse
BUSP1 | Konfig.variable für Feldbusse (CAN oder Sercos)
BUSP10 | Hilfsvariable für EtherCAT Feldbus
BUSP11 | Hilfsvariable für EtherCAT Feldbus
BUSP12 | Konfigurationsvariable für Feldbusse
BUSP13 | Konfigurationsvariable für Feldbusse
BUSP14 | Konfigurationsvariable für Feldbusse
BUSP15 | Konfigurationsvariable für Feldbusse
BUSP16 | Konfigurationsvariable für Feldbusse
BUSP2 | Konfigurationsvariable für Feldbusse
BUSP3 | Konfigurationsvariable für Feldbusse
BUSP4 | Konfigurationsvariable für Feldbusse
BUSP5 | Konfigurationsvariable für Feldbusse
BUSP6 | Konfigurationsvariable für Feldbusse
BUSP7 | Konfigurationsvariable für Feldbusse
BUSP8 | Konfigurationsvariable für Feldbusse
BUSP9 | Hilfsvariable für EtherCAT Feldbus
CALCCOG | Erzeugung einer Tabelle zur Coggingkompenation
CALCHP | Ermittlung der Sinus/Cosinus-Parameter
CALCMP | Meßzyklen für Kommutierungsfindung mit PID Regler
CALCPOSIO | Kalibrierung der POS I/O Karte
CALCRK | Ermittlung der Resolverparameter
CALCRP | Ermittlung der Resolverphase
CANDUMP | Liste der CANopen-Kommunikationsparameter
CANSDO | Zugriff auf ein CAN Service Data Object
CARDDEL | löscht eine Datei aus dem Root Verzeichnis
CARDDIR | gibt das Inhaltsverzeichnis der Root aus
CARDINFO | Information über die SD-Speicherkarte
CARDSAVE | Speichert Daten vom Drive auf der SD Speicherarte
CARDUPDATE | lädt daten von der SD Speicherkarte ins Drive
CBAUD | Übertragungsrate CAN-Bus
CCSAVE | CANopen Kommunikationsparameter speichern/reseten
CINPOS | Meldeschwelle vom Strom “In Pos” Fenster
CLRFAULT | Löschen des Verstärker-Fehlers
CLRHR | Löschen des Bit 5 im Statutsregister STAT
CLRORDER | Löschen eines Fahrsatzes
CLRWARN | Behandlung der Verstärker-Warnungen
CMDDLY | Kommandoverzögerungszeit der RS232
COGFILT | Bandbreitenfaktor des Cogginkkompensationsfilters
COGMODE | Coggingkompensation de-/aktiv
COGRED | Faktor der GV Senkung während der Coggingmessung
COLDSTART | Hardware-Reset des Verstärkers
CONTINUE | Fortsetzen des letzten Fahrauftrages
CPHASE | Einstellung der Fehlerüberwachung
CSCNFG | Konfigurationsvariable für die Sicherheitskarte
CSENID | Blindstromeinprägung
CSERR | Fehlernummern der Safety Optionskarte
CSIDMAX | Maximaler Wert für Blindstromeinprägung
CSIOSTAT | Ein- und Ausgangsstatus der Sicherheitskarte
CSSTAT | Status der Sicherheitskarte
CTUNE | Optimierung der Stromreglerparameter
CUPDATE | Programm-Update über CAN-Bus
DAOFFSET1 | Offsetwert für den Analogausgang 1
DAOFFSET2 | Offsetwert für den Analogausgang 2
DEC | Bremsrampe für den Drehzahlsollwert
DEC_X | Bremsrampe Drehzahlr. 2. Parametersatz
DECDIS | Drehzahl-Bremsrampe beim Sperren der Endstufe
DECR | Bremsrampe für Referenzfahrt/Tippbetrieb
DECSTOP | Bremsrampe in Nothaltsituation
DENA | DPR Software Disable Reset Modus
DI2T | Regler I2T Auslastung
DICONT | Geräte-Nennstrom
DIFVAR | Parameterunterschiede zu den Default-Einstellungen
DILIM | DPR Strombegrenzung aktivieren
DIPEAK | Geräte-Spitzenstrom
DIR | Zählrichtungen verschiedener Istwerte
DIRIN | Polarität für digitale Eingänge
DIROUT | Polarität für digitale Ausgänge
DIS | Software Disable der Endstufe
DISDPR | Disablen des DPR-Zugriffs für Schreibbefehle
DNBAUD | DeviceNet Baudrate
DNDUMP | Debugging Information DeviceNet
DNMACID | MACID (Addresse) für DeviceNet Karte
DOVRIDE | Vorgabe eines digitalen Override-Faktors
DPRILIMIT | Digitale Begrenzung des Spitzenstroms über DPR
DPRSTATE | DPR Status
DPRVAR1_16 | Macro Hilfsvariablen
DPV17_64 | Macro Hilfsvariablen
DPWM | PWM für Stromregler- und Positionsreglekreis
DR_TYPE | Liefert die Endstufenkennung
DREF | Fahrtrichtung für die Referenzfahrt
DRIVE | Hardware-Kennung des Servoverstärkers
DRVCNFG | Konfiguartions Parameter für Zusatzfunktionen
DRVCNFG2 | Konfiguartions Parameter für Zusatzfunktionen
DRVCNFG3 | Konfiguartions Parameter für Zusatzfunktionen
DRVCNFG4 | Konfiguartions Parameter für Zusatzfunktionen
DRVSTAT | Geräte-Statusinformation
DRVSTAT2 | interne Status Information
DUMP | Auflistung aller EEPROM-Variablen
DUMPEMAP | Kontrolle des freien Mappings unter EtherCat
DUMPSLNO | Auflistung der numerischen EEProm-Variablen
ECATCSA | speichert die "Configured Station Alias" Addresse
EGEARI | Getriebefaktor externen Lagegeber
EGEARO | Getriebefaktor externen Lagegeber
EMRGTO | definiert die Abschaltzeit im Fehlerfall
EN | Setzen des Software-Enable
EN22A1CNT | Endat2.2 Status der Zusatzinformationen 1
EN22A2CNT | Endat2.2 Status der Zusatzinformationen 2
EN22AI1 | Endat2.2 akt. Werte der Zusatzinformationen 1
EN22AI2 | Endat 2.2 akt. Werte der Zusatzinformationen 2
EN22CNFG | Konfig.parameter für ENDAT2.2-Zusatzinformationen
EN22DCNT | Endat2.2 Status der Diagnoseinformationen
EN22DIAG | Endat2.2 aktuellen Werte der Diagnoseinformationen
ENCDIV | Divisor für die Nachkommastellen von ENCLINES
ENCDIVD | Divisor für die Nachkommastellen von ENCIN
ENCFIX | Nachkommastellen für den ENCLINES-Parameters
ENCFIXD | Nachkommastellen für den ENCIN-Parameters
ENCIN | Auflösung digitales Messsystem
ENCLINES | Auflösung eines SinCos-Gebers
ENCMODE | Auswahl der Encoder-Emulation
ENCOUT | Auflösung für die Encoder-Emulation (ROD)
ENCTO | Einschaltverzögerung des Encoders
ENCVON | Geber-Versorgungsspannung über den Stecker X1
ENCZERO | Nullimpulsoffset (ROD-Ausgabe)
ENGAGE | Ein-/Ausschalten des Master/Slave-Betriebes
ERESMASK | Fehlerrücksetzverhalten
ERND | Endposition Modulo-Achse
ERRCNFG | Verhalten des Verstärkers im Fehlerfall
ERRCODE | Ausgabe der aktiven Fehlermeldungen
ERRCODE * | Ausgabe des Fehlerregisters
ERRCODE2 | Fehlercode Zusatzinformation
ERRMASK | Fehlerauswahlmaske um Verzögerungszeit zu aktiv.
ERRPARAM | Objektnummer falscher Parameter (Warnung n24)
ERRTIME | Fehler Verzögerungszeit
ESPEED | Maximale Drehzahl in Abhängigkeit vom Gebertyp
ETHMODE | Wählt das On-Board-Feldbus-Interface aus
EWH | Energieaufnahme in WattStunden
EXTBRAKE | Software Bremsensteuerung an / aus
EXTLATCH | Einstellung der Quellen für die Latch-Eingänge
EXTPOS | Positionsquelle der Lageregelung
EXTWD | Überwachungszeit für Feldbus-Befehle
FBGEARI | Kompensationsfaktor Motor/Getriebe
FBGEARO | Kompensationsfaktor Motor/Getriebe
FBTYPE | Vorwahl der Kommutierungs - Rückführeinheit
FBTYPEX | Anzeige der erkannten Rückführungsart
FFTSW | Konfiguration der Stromvorsteuerung
FHKP | interner Parameter
FHTN | interner Parameter
FILTMODE | Smith Predictor
FLTCNT | Fehlerstatistik: Fehleranzahl
FLTCNT * | Fehlerstatistik: Fehleranzahl
FLTHIST | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLTHIST * | Fehlerstatistik: Anzeige der letzten 10 Fehler
FW | Liefert die Versionsnummer der Firmware
GEARFILT | Tiefpaßfilter zweiter Ordnung (OPMODE=4)
GEARI | Eingangsfaktor "elektronisches Getriebe"
GEARMODE | Masterschnittstelle für "elektronisches Getriebe"
GEARO | Ausgangsfaktor "elektronisches Getriebe"
GET | Ausgabe der aufgezeichneten SCOPE-Daten
GF | Proportionalverstärkung des Flussreglers.
GFTN | Zeitkonstante vom Flussregler (Asynchronmaschine)
GP | Lageregler: Proportionalverstärkung
GP_X | Lageregler: Proportionalverstärkung 2
GP2 | Proport. bei Geschwindigkeiten höher als GPS2
GPDELAY | Verzögerung des externen Lagereglers
GPFFT | Stromvorsteuerung - Positionsregelkreis
GPFFT_X | Stromvorsteuerung - Positionsregelkreis 2
GPFFTV | Proportionalverst. für Geschwindigkeitsstromvorst.
GPFFV | Lageregler: Vorsteuerung Drehzahl
GPFFV_X | Lageregler: Vorsteuerung Drehzahl 2
GPFFVDELAY | interner Parameter
GPS1 | untere Drezhzahlschwelle (Lageregler)
GPS2 | obere Drezhzahlschwelle (Lageregler)
GPTN | Integralanteil des PI Lagereglers
GPTN_X | Integralanteil des PI Lagereglers
GPTNTH1 | Grenze des Integralanteil für den Drehzahlsollwert
GPTNTH2 | Grenze des Integralanteils für den Drehzahlistwert
GPTNTH3 | Grenze des Integralanteils für den Schleppfehler
GU | Proportionalverstärkung für Feldschwächung
GUTN | Zeitkonstante für Feldschwächung
GV | Drehzahlregler: Proportionalverstärkung
GV_X | Drehzahlregler: Proportionalverstärkung 2
GV2 | Proportinalanteil bei höherer Geschwind. als GVS2
GVFR | PI-PLUS Drehzahlistwertvorsteuerung
GVFR_X | PI-PLUS Drehzahlistwertvorsteuerung
GVS1 | untere Drhzahlschwelle (Drehzahlregler)
GVS2 | obere Drhzahlschwelle (Drehzahlregler)
GVTN | Drehzahlregler: Nachstellzeit
GVTN_X | Drehzahlregler: Nachstellzeit 2
GVTV | Vorhaltzeit des Volumenstromreglers
HALLDIR | Nummer für Hallelement - Tabelle
HALLENDIR | interner Parameter
HDSLLED | LED-Strom der opt Einheit im Hiperface DSL Encoder
HDSLPOS | Position gelesen aus dem Hiperace DSL-Encoder
HDSLRANGE | Hiperface DSL Geber-Grenzwerte
HDSLROTAT | Gesamtzahl der erfassten Geber-Umdrehungen
HDSLTEMP | Motor/Encoder-Temperatur vom Hiperface DSL-Encoder
HDSLTIME | Betriebsstunden des Hiperface DSL-Gebers
HDSLTYPE | Hiperface DSL Geberdaten (Typenschild)
HDSLVEL | Akt. Drehgeschwindigkeit des Hiperface DSL-Gebers
HDSLVOLT | Versorgungsspannung des Hiperface DSL-Gebers
HDUMP | Ausgabe aller SinCos Variablen
HELP | Ausgabe der Parameter-Hilfe-Information
HICOFFS | Hiperface: Cosinus-Offset (Inkrementalspur)
HIFACT1 | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)
HISOFFS | Hiperface: Sinus-Offset (Inkrementalspur)
HLIMIT1 | Software limit switch 1 bei der Referenzfahrt
HLIMIT2 | Software limit switch 2 bei der Referenzfahrt
HLIMIT3 | Software limit switch 3 bei der Referenzfahrt
HSAVE | Hiperface: Speichern der Parameter im Geber
HVER | Ausgabe der Hardware-Version
HWCNT | interner Parameter
I | Stromistwert
I2TLIM | I2t-Meldeschwelle
ICMD | Stromsollwert
ICMDVLIM | Drehzahlbegrenzung im Stromreglermode
ID | D-Anteil vom Strom-Istwert
IDDUMP | Ausgabe der Objektnummern
IEXTT | Haltemoment bei hängenden Achsen
IEXTTLIM | Unterstützung der vertikalen Achse
IN | Anzeige der A/D-Spannungen
IN1 | Zustand des digitalen Eingangs INPUT1
IN10 | Zustand des digitalen Eingangs
IN10MODE | Funktion des digitalen Eingangs
IN10TRIG | Hilfsvariable für digitalen Eingang
IN11 | Zustand des digitalen Eingangs
IN11MODE | Funktion des digitalen Eingangs
IN11TRIG | Hilfsvariable für digitalen Eingang
IN12 | Zustand des digitalen Eingangs
IN12MODE | Funktion des digitalen Eingangs
IN12TRIG | Hilfsvariable für digitalen Eingang
IN13 | Zustand des digitalen Eingangs
IN13MODE | Funktion des digitalen Eingangs
IN13TRIG | Hilfsvariable für digitalen Eingang1
IN14 | Zustand des digitalen Eingangs
IN14MODE | Funktion des digitalen Eingangs
IN14TRIG | Hilfsvariable für digitalen Eingang
IN15 | Zustand des digitalen Eingangs
IN15MODE | Funktion des digitalen Eingangs
IN15TRIG | Hilfsvariable für digitalen Eingang
IN16 | Zustand des digitalen Eingangs
IN16MODE | Funktion des digitalen Eingangs
IN16TRIG | Hilfsvariable für digitalen Eingang
IN17 | Zustand des digitalen Eingangs
IN17MODE | Funktion des digitalen Eingangs
IN17TRIG | Hilfsvariable für digitalen Eingang
IN18 | Zustand des digitalen Eingangs
IN18MODE | Funktion des digitalen Eingangs
IN18TRIG | Hilfsvariable für digitalen Eingang
IN19 | Zustand des digitalen Eingangs
IN19HCMD | Kommando-Buffer für High-Pegel
IN19LCMD | Kommando-Buffer für Low-Pegel
IN19MODE | Funktion des digitalen Eingangs
IN19TRIG | Hilfsvariable für digitalen Eingang
IN1HCMD | Kommando-Buffer für High-Pegel
IN1LCMD | Kommando-Buffer für Low-Pegel
IN1MODE | Funktion des digitalen Eingangs INPUT1
IN1TRIG | Hilfsvariable für IN1MODE
IN2 | Zustand des digitalen Eingangs INPUT2
IN20 | Zustand des digitalen Eingangs
IN20HCMD | Kommando-Buffer für High-Pegel
IN20LCMD | Kommando-Buffer für Low-Pegel
IN20MODE | Funktion des digitalen Eingangs
IN20TRIG | Zustand des digitalen Eingangs
IN21MODE | Funktion des digitalen Eingangs
IN21TRIG | Zustand des digitalen Eingangs
IN22MODE | Funktion des digitalen Eingangs
IN22TRIG | Zustand des digitalen Eingangs
IN2HCMD | Kommando-Buffer für High-Pegel
IN2LCMD | Kommando-Buffer für Low-Pegel
IN2MODE | Funktion des digitalen Eingangs INPUT2
IN2PM | Zustand des digitalen Eingangs
IN2TRIG | Hilfsvariable für IN2MODE
IN3 | Zustand des digitalen Eingangs INPUT3
IN3HCMD | Kommando-Buffer für High-Pegel
IN3LCMD | Kommando-Buffer für Low-Pegel
IN3MODE | Funktion des digitalen Eingangs INPUT3
IN3TRIG | Hilfsvariable für IN3MODE
IN4 | Zustand des digitalen Eingangs INPUT4
IN4HCMD | Kommando-Buffer für High-Pegel
IN4LCMD | Kommando-Buffer für Low-Pegel
IN4MODE | Funktion des digitalen Eingangs INPUT4
IN4TRIG | Hilfsvariable für IN4MODE
IN5 | Zustand des digitalen Eingangs
IN5_22 | Zustand der digitalen Eingänge 5 ... 22
IN5_22MODE | Funktion der digitalen Eingänge 5...22
IN5_22TRIG | Hilfsvariable der digitalen Eingänge 5 ... 22
IN5MODE | Funktion des digitalen Eingangs
IN5TRIG | Hilfsvariable für digitalen Eingang
IN6 | Zustand des digitalen Eingangs
IN6MODE | Funktion des digitalen Eingangs
IN6TRIG | Hilfsvariable für digitalen Eingang
IN7 | Zustand des digitalen Eingangs
IN7MODE | Funktion des digitalen Eingangs
IN7TRIG | Hilfsvariable für digitalen Eingang
IN8 | Zustand des digitalen Eingangs
IN8MODE | Funktion des digitalen Eingangs
IN8TRIG | Hilfsvariable für digitalen Eingang
IN9 | Zustand des digitalen Eingangs
IN9MODE | Funktion des digitalen Eingangs
IN9TRIG | Hilfsvariable für digitalen Eingang
INPOS | In-Position-Meldung
INPT0 | In-Position-Verzögerung
INPT1 | Verzögerungszeit für die "In Position" Meldung
INTERPOL | Interpolationsmethode bei OPMODE 5 und 6
IOLINK | Verbindung zwischen dig. Aus- sowie Eingang
IPEAK | Spitzenstrom
IPEAKN | Max.negativer Impulsstrom des Motors in A rms
IPEAKP | Max.positiver Impulsstrom des Motors in A rms
IQ | Q-Anteil des Stromistwertes
IQFILTK | Verstärkungsfaktor für die Schlupfkompensation
IQFILTTAU | Zeitkonstante zur Schlupfkompensation (Tiefpass)
ISCALE1 | Skalierungsfaktor für den analogen Stromsollwert 1
ISCALE2 | Skalierungsfaktor für den analogen Stromsollwert 2
ISTFR | Stromgrenze f. drehzahlabhängige. Reibungskomp.
IVTICK | interner Parameter
J | Service-Funktion "konstante Drehzahl"
JRATIO | interner Parameter
K | Software-Sperre der Endstufe
KC | Stromistwert-Vorsteuerung Stromregler
KC_X | Stromistwert-Vorsteuerung Stromregler 2
KEYLOCK | Sperre für die Tastenbedienung
KTN | Integralanteil des Stromreglers
KTN_X | Integralanteil des Stromreglers 2
LASTWMASK | Fehlerspeicher von WMASK
LATCH1N16 | Gelatchte 16 Bit-Position (negative Flanke)
LATCH1N32 | Gelatchte 32 Bit-Position (negative Flanke)
LATCH1P16 | Gelatchte 16 Bit-Position (positive Flanke)
LATCH1P32 | Gelatchte 32 Bit-Position (positive Flanke)
LATCH2N16 | Gelatchte 16 Bit-Position (negative Flanke)
LATCH2N32 | Gelatchte 32 Bit-Position (negative Flanke)
LATCH2P16 | Gelatchte 16 Bit-Position (positive Flanke)
LATCH2P32 | Gelatchte 32 Bit-Position (positive Flanke)
LDUMP | Parameterausgabe eines Motordatensatzes
LED1 | Anzeigestatus des LED1-Segmentes
LED2 | Anzeigestatus des LED2-Segmentes
LED3 | Anzeigestatus des LED3-Segmentes
LEDSTAT | Seitennummer für das LED-Display
LINRESOL | Umrechnungsfaktor bei linearen Messsystemen
LIST | Auflistung aller ASCII-Kommandos
LOAD | Laden der Parameter aus dem seriellen EEPROM
M | Lesen/Schreiben einer Macro-Variable
M_RESET | Neuübersetzung der Macro-Programme
MAXCMD | max. Anzahl der DPR-Objekte
MAXISETP | Begrenzung des Integralanteils des Lagereglers
MAXSUMME | interner Parameter
MAXTEMPE | Abschaltwert der Umgebungstemperatur
MAXTEMPH | Abschaltwert der Kühlkörpertemperatur
MAXTEMPM | Abschaltwert der Motortemperatur (Widerstand)
MAXVSETP | begrenzt den Proportinalanteil im Lageregler
MBPDRVSTAT | Zustand des Modbus+ Netzwerks
MBRAKE | Vorwahl für Motorbremse
MCFW | Korrekturfaktor für die Feldschwächung
MCOSPHI | Leistungsfaktor (cos phi) der Asynchronmaschine
MCTR | interner Parameter
MDBCNT | Anzahl der Motorsätze
MDBGET | Info-Zeile für einen Motordatensatz
MDBLIST | Inhaltsverzeichnis der Motordatenbank
MDBSET | Vorwahl eines Motordatensatzes
MDRV | Anwahl der Multidrive Funktionalität
MFR | Nennfrequenz der Asynchronmaschine
MH | Start der Referenzfahrt
MI2T | Motor I2T Auslastung
MICONT | Motor Nennstrom
MICONT_X | Motor Nennstrom
MIMR | Sollstrom in D-Richtung
MIMRQ | interner Parameter
MINSUMME | interner Parameter
MIPEAK | Motor Spitzenstrom
MIPEAK_X | Motor Spitzenstrom
MJ | Massenträgheitsmoment des Motors
MJ_X | Massenträgheitsmoment des Motors 2
MJOG | Start des Tippbetriebes
MKT | Motor KT
MKT_X | Motor KT
ML | Statorinduktivität des Motors
ML_X | Statorinduktivität des Motors
MLGC | Relative Stromreglerverstärkung bei Dauerstrom
MLGC_X | Relative Stromreglerverstärkung bei Dauerstrom
MLGD | Relative Stromreglerverstärkung des D-Stromreglers
MLGD_X | Relative Stromreglerverstärkung des D-Stromreglers
MLGP | Relative Stromreglerverstärkung bei Spitzenstrom
MLGP_X | Relative Stromreglerverstärkung bei Spitzenstrom
MLGQ | Absolute Verstärkung des Stromreglers
MLGQ_X | Absolute Verstärkung des Stromreglers
MNAME | Motor-Name
MNUMBER | Laden eines Motor-Datensatzes
MONITOR1 | Monitor1-Ausgangsspannung
MONITOR2 | Monitor2-Ausgangsspannung
MOVE | Starten eines Fahrsatzes
MPHASE | Phasenoffset zwischen Feedback und Motorwicklung
MPHASE2 | Kommutierungsfeinabstimmung
MPITCH | Linearmotor - Polpaarbreite
MPKD | D-Anteil für die Kommutierungsermittlung
MPKI | PID - Positionsregelung zur Kommutierungsfindung
MPKP | PID - Positionsregelung zur Kommutierungsfindung
MPOLES | Anzahl der Motorpole
MPOLES_X | Anzahl der Motorpole
MPR | Nennausgangsleistung des Motors
MPTIME | Ausrichtzeit für die Kommutierungsfindung
MRESBW | Resolver-Bandbreite
MRESPOLES | Anzahl der Resolverpole
MRS | Wicklungswiderstand des Stators Phase-Phase
MRS_X | Wicklungswiderstand des Stators Phase-Phase
MSERIALNO | Motorseriennummer bei Encoder mit Parameterkanal
MSG | RS232-Ausgabe der Warnungen/Fehlermeldungen
MSLBRAKE | Bremsrampe bei sensorlosem Nothalt
MSPEED | Motor Maximaldrehzahl
MTAB | Eingabe der KTY-Kennlinie
MTANGLP | Stromvoreilung
MTIME | Thermische Zeitkonstante des Motors
MTIME_X | Thermische Zeitkonstante des Motors
MTMUX | Voreinstellung für zu bearbeitenden Fahrsatz
MTR | Rotorzeitkonstante
MTYPE | Art des Motors
MUR | Nennspannung des Asynchronmotors
MVANGLB | Drehzahlabhängige Voreilung (Einsatz Phi)
MVANGLF | Drehzahlabhängige Voreilung (Endwert Phi)
MVANGLMODE | SR600 Kompat.mode für drehzahlabh. Phasenvoreilung
MVANGLP | Drehzahlabhängige Voreilung
MVER | Version der Motordatenbank
MVR | Nenndrehzahl der Asynchronmaschine
NONBTB | Netz-BTB-Überprüfung ein/aus
NREF | Referenzfahrtart
NREFG | interner Parameter
NREFMT | Referenzfahrt mit automatischem Folgefahrauftrag
O_ACC | Beschleunigungszeit für den Fahrsatz 0
O_C | Steuervariable für den Fahrsatz 0
O_DEC | Bremszeit für den Fahrsatz 0
O_FN | Folgefahrsatz-Nummer für den Fahrsatz 0
O_FT | Verzögerungszeit für den Folge-Fahrsatz
O_P | Zielposition/Verfahrstrecke für den Fahrsatz 0
O_TAB | Fahrprofiltabellen
O_V | Zielgeschwindigkeit für den Fahrsatz 0
O1 | Zustand des digitalen Ausgangs 1
O10 | Zustand des digitalen Ausgangs 10
O10MODE | Funktion des digitalen Ausgangs 10
O10TRIG | Hilfsvariable für digitalen Ausgang 10
O11 | Zustand des digitalen Ausgangs 11
O11MODE | Funktion des digitalen Ausgangs 11
O11TRIG | Hilfsvariable für digitalen Ausgang 11
O12 | Zustand des digitalen Ausgangs 12
O12MODE | Funktion des digitalen Ausgangs 12
O12TRIG | Hilfsvariable für digitalen Ausgang 12
O13 | Zustand des digitalen Ausgangs 13
O13MODE | Funktion des digitalen Ausgangs 13
O13TRIG | Hilfsvariable für digitalen Ausgang 13
O14 | Zustand des digitalen Ausgangs 14
O14MODE | Funktion des digitalen Ausgangs 14
O14TRIG | Hilfsvariable für digitalen Ausgang 14
O15 | Zustand des digitalen Ausgangs 15
O15MODE | Funktion des digitalen Ausgangs 15
O15TRIG | Hilfsvariable für digitalen Ausgang 15
O16 | Zustand des digitalen Ausgangs 16
O16MODE | Funktion des digitalen Ausgangs 16
O16TRIG | Hilfsvariable für digitalen Ausgang 16
O17 | Zustand des digitalen Ausgangs 17
O17MODE | Funktion des digitalen Ausgangs 17
O17TRIG | Hilfsvariable für digitalen Ausgang 17
O18 | Zustand des digitalen Ausgangs 18
O18MODE | Funktion des digitalen Ausgangs 18
O18TRIG | Hilfsvariable für digitalen Ausgang 18
O1MODE | Funktion des digitalen Ausgangs 1
O1TRIG | Hilfsvariable für O1MODE
O2 | Zustand des digitalen Ausgangs 2
O2MODE | Funktion des digitalen Ausgangs 2
O2TRIG | Hilfsvariable für O2MODE
O3 | Zustand des digitalen Ausgangs 3
O3_18 | Zustand des digitalen Ausgangs 3 bis 18
O3_18MODE | Funktion der digitalen Ausgänge 3 bis 18
O3_18TRIG | Hilfsvariable für OxMODE
O3MODE | Funktion des digitalen Ausgangs3
O3TRIG | Hilfsvariable für digitalen Ausgang 3
O4 | Zustand des digitalen Ausgangs 4
O4MODE | Funktion des digitalen Ausgangs 4
O4TRIG | Hilfsvariable für digitalen Ausgang 4
O5 | Zustand des digitalen Ausgangs 5
O5MODE | Funktion des digitalen Ausgangs 5
O5TRIG | Hilfsvariable für digitalen Ausgang 5
O6 | Zustand des digitalen Ausgangs 6
O6MODE | Funktion des digitalen Ausgangs 6
O6TRIG | Hilfsvariable für digitalen Ausgang 6
O7 | Zustand des digitalen Ausgangs 7
O7MODE | Funktion des digitalen Ausgangs 7
O7TRIG | Hilfsvariable für digitalen Ausgang 7
O8 | Zustand des digitalen Ausgangs 8
O8MODE | Funktion des digitalen Ausgangs 8
O8TRIG | Hilfsvariable für digitalen Ausgang 8
O9 | Zustand des digitalen Ausgangs 9
O9MODE | Funktion des digitalen Ausgangs 9
O9TRIG | Hilfsvariable für digitalen Ausgang 9
OCOPY | Speichern der Fahrsätze
OLIST | Ausgabe der Fahrsatzdaten
OPMODE | Betriebsart des Verstärkers
OPTION | Slotkarten-Kennung
OPTION2 | Slotkarten-Kennung
ORDER | Definition eines Fahrsatzes
OTUNE | Optimierungsfunktion VLO-Parameter
OVRIDE | Override-Funktion
P | aktuelle Wirkleistung (elektrisch)
P1 | schnelle Positionsschwelle
P1_P16 | schnelle Positionsschwelle 1...16
P10 | schnelle Positionsschwelle
P11 | schnelle Positionsschwelle
P12 | schnelle Positionsschwelle
P13 | schnelle Positionsschwelle
P14 | schnelle Positionsschwelle
P15 | schnelle Positionsschwelle
P16 | schnelle Positionsschwelle
P2 | schnelle Positionsschwelle
P3 | schnelle Positionsschwelle
P4 | schnelle Positionsschwelle
P5 | schnelle Positionsschwelle
P6 | schnelle Positionsschwelle
P7 | schnelle Positionsschwelle
P8 | schnelle Positionsschwelle
P9 | schnelle Positionsschwelle
PARCNFG | Parameter Umschaltbedingung
PARDUMP | Auflistung der umschaltbaren Parameter
PARRST | Basis parametersatz in 2. Parametersatz laden
PASS | Password Eingabe
PASSCNFG | Passwort Funktion
PASSPLC | Passwort für PLC Programm
PASSX | Passwort-Schutz aktivieren
PASSXPLC | Einstellung für Passwortschutz für PLC-Proframme
PBAL | Istwert der Ballastleistung
PBALMAX | Maximale Ballastleistung
PBALRES | Vorwahl des Ballastwiderstandes
PBAUD | Profibus-Baudrate
PE | Istwert des Schleppfehlers
PEINPOS | In-Position-Fenster
PEMAX | Max. Schleppfehler
PFB | aktuelle Lagereglerposition
PFB0 | Lagereglerposition über den externen Encoder
PFBHI | gibt die unteren 32 Bits der akt 64 Bit Position
PFBLO | gibt die unteren 32 Bits der akt 64 Bit Position
PGEARI | Lageregler-Auflösung (Zähler)
PGEARO | Lageregler-Auflösung (Nenner)
PIOBUF | Profibus-Daten
PLLCOFFS | PLL-Zähler außerhalb des Synchronisationsfensters
PLLDOFFS | verschieben der Synchronisationsroutine
PLLHUB | Feldbus-Synchronisationsverhältnis
PLLWOFFS | Vergrößerung des Synchronisationsfensters
PMECH | momentane mechanische Motorleistung (geschätzt)
PMODE | Netz-Phase Modus
PNOID | Profibus-Kennung (ID)
POSCNFG | Achsentyp
POSRSTAT | Status der schnellen Positionsregister 1...16
PPOTYP | Profibus PPO-Typ
PRBASE | interne Lage-Auflösung
PRD | 20 Bit Feedback-Position
PRIOR1 | interner Parameter
PRIOR2 | interner Parameter
PRIOR3 | interner Parameter
PRIOR4 | interner Parameter
PRIOR5 | interner Parameter
PROMPT | Vorwahl des RS232-Protokolls
PSINUS | Sinus Service-Funktion
PSTATE | Profibus-Status
PSTEP | Service-Betrieb
PTARGET | letzte Fahrsatzzielposition
PTARGOFFS | Offset bei absoluten Fahraufträgen
PTBASE | Zeitbasis für die externe Trajektorie
PTMIN | Min. Beschleunigungsrampe
PUNIT | Vorgabe der Positionsauflösung
PV | Ist-Geschwindigkeit (Lageregler)
PVMAX | max. Geschwindigkeit für den Lageregler
PVMAXN | max. Geschwindigkeit für den Lageregler (negativ)
PVMAXP | max. positive Geschwindigkeit für den Lageregler
QCNFG | Konfig.variable für den Durchfluss-/Druckregler
QENA | Freigabe der Servopumpen-Funktion
QFACT | Volumenstrom-Istwert (ohne Filter)
QFACTCOMP | Volumenstrom-Istwert (nach Kompensation)
QFACTFILT | gefilterter Sollwert für den Volumenstrom
QFACTOR | Schluckvolumen
QFCFACT | aktueller Wirkungsgradfaktor
QFCMD | Volumenstrom-Sollwert
QFCMDFILT | Gefilterter Sollwert für den Volumenstrom
QFMAX | Max. Sollwert für den Volumenstromwert
QFSET | gefilterter Sollwert für den Volumenstrom
QKPEFF | Reglerparameteradaption: aktiver KP-Wert
QMACT | Drehmoment Istwert
QMCMD | aktueller Drehmoment-Sollwert
QMCMDLIM | Aktueller Drehmoment-Sollwert
QMLIMN | Drehmomentbegrenzung vom Druckabbau
QMLIMP | Drehmomentbegrenzung vom Druckaufbau
QPE | Aktuelle Druck-Regelabweichung
QPRACT | Druckistwert
QPRMAX | maximaler Drucksollwert
QPRSET | Druck Sollwert
QPRSETEFF | Druck Sollwert (effektiv)
QT1 | Konstante für den Volumenstrom-Sollwertfilter
QTAB1KP | Reglerparameteradaption: Verstärkung für QTAB1V
QTAB1TN | Reglerparameteradaption: Nachstellzeit für QTAB1V
QTAB1TV | Reglerp.adaption: TV - Vorhaltzeit für QTAB1V
QTAB1V | Reglerparameteradaption: Drehzahl 1
QTAB2KP | Reglerparameteradaption: Verstärkung für QTAB2V
QTAB2TN | Reglerparameteradaption: Nachstellzeit für QTAB2V
QTAB2TV | Reglerp.adaption: TV - Vorhaltzeit für QTAB2V
QTAB2V | Reglerparameteradaption: Drehzahl 2
QTAB3KP | Reglerparameteradaption: Verstärkung für QTAB3V
QTAB3TN | Reglerparameteradaption: Nachstellzeit für QTAB3V
QTAB3TV | Reglerp.adaption: TV - Vorhaltzeit für QTAB3V
QTAB3V | Reglerparameteradaption: Drehzahl 3
QTAB4KP | Reglerparameteradaption: Verstärkung für QTAB4V
QTAB4TN | Reglerparameteradaption: Nachstellzeit für QTAB4V
QTAB4TV | Reglerp.adaption: TV - Vorhaltzeit für QTAB4V
QTAB4V | Reglerparameteradaption: Drehzahl 4
QTAB5KP | Reglerparameteradaption: Verstärkung für QTAB5V
QTAB5TN | Reglerparameteradaption: Nachstellzeit für QTAB5V
QTAB5TV | Reglerp.adaption: TV - Vorhaltzeit für QTAB5V
QTAB5V | Reglerparameteradaption: Drehzahl 5
QTABID | Reglerparameteradaption: aktueller Parameterindex
QTIMEKD | Zeitkonst. des D-Anteils für den Druckstromregler
QTNEFF | Reglerparameteradaption: aktiver TN-Wert
QTVEFF | Reglerparameteradaption: aktiver TV-Wert
QVAL | interner Parameter
QVT1 | Glättungszeit-Istwert
RDP | RDP Betriebsarten
RDPBIAS | RDP Ruhestrom
RDPBIAS2 | interner Parameter
RDPCLAMP | maximaler Ausgabeausgleichsstrom
RDPINT | Integralwert des RDP-Ausgleichsstroms
RDPKI | Integralverstärkung des Ausgleichsstroms
RDPKP | Proportionalverstärkung des Ausgleichsstroms
RDPON | RDP Status
READY | Zustand von Software-Enable
RECDONE | Scope: Aufnahme beendet
RECING | Scope: Aufzeichnung läuft
RECOFF | Scope: Abbruch einer Scope-Aufzeichnung
RECORD | Scope: Definition der aufzuzeichnenden Daten
RECRDY | Scope: Zustand der RECORD-Funktion
RECTRIG | SCOPE: Aktivieren der Aufzeichnungsfunktion
REFIP | Spitzenstrom für die Referenzfahrt 7
REFIP2 | Spitzenstrom für die Kommutierungsfindung
REFLS | Reglerverh. auf HW-Endschalter bei Referenzfahrt
REFMODE | Quelle des Nullimpulse bei Referenzfahrt
REFNOFFS | Position des analog. Nullpunktes
REFNPOS | Externer Nullimpulsoffset im Sinus-Kosinus-Zyklus
REFPOS | Referenzschalter Position
RELTIME | maximale Einschaltzeit der Thyristoren
REMOTE | Zustand des Hardware-Enable
RESAMPL | Kabelbruchüberwachung beim Resolver
RESOLVER | Justierung der Resolver Erregung +/- 20%
RESPHASE | Resolverphase
RK | Verstärkungsfaktor Resolver-Sinussignal
ROFFS | Referenzoffset
ROFFSABS | Referenzoffset
ROFFSSSI | SSI Positionsoffset
RS232T | Watch-Dog Zeit (RS232)
RSTVAR | Setzen aller Parameter auf Default-Werte
RSVERROFF | Abschalten der Überwachung vom Resolverfehler
RUNIN | interner Parameter
S | Stopp und Disable
S1DLY | Einschaltverzögerung
SAVE | Speichern der Daten im EEPROM
SBAUD | SERCOS: Baudrate
SCAN | Erkennung der CAN-Stationen
SDLY | Start Verzögerung
SERCERR | Fehlerhafter IDN Zugegriff
SERCLIST | Zugriff auf IDN Liste
SERCOFFS | interner Parameter
SERCOS | Lesen des Dateninhalts eines SERCOS IDN
SERCSET | Setze SERCOS / EtherCAT Einstellungen
SERIALNO | Seriennummer des Verstärkers
SETENCOFFS | Funktion zur Nullpunkverschiebung
SETREF | Setzen des Referenzpunktes
SKIP1SP | Skip Drehzahl 1
SKIP1W | Skip Drehzahl 1
SKIP2SP | Skip Drehzahl 2
SKIP2W | Skip Drehzahl 2
SLACCMAX | Rampe im Sensorless Mode
SLEN | Optische Ausgangsleistung bei SERCOS
SLIDK01 | Faktor (Gewichtung) von Ud
SLIMAX | interner Parameter
SLIQK | Faktor (Gewichtung) des Laststroms Iq
SLIQK1 | zweiter Faktor (Gewichtung) für Laststrom Iq
SLJSWITCH | Umschaltpunkt vom Stepper in den Sensorless Modus
SLMODE | Stepper Mode für Sensorless
SLOTIO | I/O-Erweiterungskarte: IN/OUT-Zustand
SLTEMPM | Überwachung des Temperaturfühler
SLTSWITCH | Übergangszeit von kleiner zum nominellen Drehzahl
SMNUMBER | Gespeicherte Motornummer im Geber
SOFTIN | Zustandsvariable der virtuellen digitalen Eingänge
SOFTOUT | Zustandsvariable der virtuellen digitalen Ausgänge
SPHAS | SERCOS-Phase
SRND | Startposition Modulo-Achse
SSIGRAY | SSI Formatwahl
SSIINV | Polarität des SSI-Clocks
SSIMASK | Filter-Maske für empfangene SSI-Daten
SSIRESOL | SSIRESOL wird die Auflösung des SSI-Linear-Gebers
SSIREVOL | Anzahl Bit für Multiurn (SSI)
SSIRXD | Anzahl der einzulesenden SSI-Bit’s
SSITIME | SSI Beruhigungszeit
SSITOUT | SSI Beruhigungszeit
SSTAT | aktuellen Status der Sercos Schnittstelle als Text
STAGECODE | Endstufenkennung
STAT | Verstärker-Statuswort
STATCODE | Anzeige der Warnungen in Klartext
STATCODE * | Statusvariable "Warnungen"
STATIO | Status der Ein/Ausgänge
STATUS | detaillierte Verstärker-Statusinformation
STEP | Schritt Service - Betrieb
STOP | Setzen des Sollwertes auf 0
STOPMODE | Bremsverhalten bei Disable
SWCNFG | Konfiguration der Software-Endschalter
SWE1 | Softwareendschalter (kleinste Position)
SWE2 | Softwareendschalter (größte Position)
SYNCSRC | Quelle der Synchronisation
T | Digitaler Stromsollwert
TASK | Task-Auslastung
TBRAKE | Disableverzögerungszeit bei Bremsenbetrieb
TBRAKE0 | Bremsen Lüftzeit
TEMPE | Istwert der Umgebungstemperatur
TEMPH | Istwert der Kühlkörpertemperatur
TEMPM | Istwert der Motortemperatur
TEMPMFILT | Zeitkonstante zur Filterung von Temp Motorsensoren
TEN | interner Parameter
TEST1 | interner Parameter
TESTENC | Feedback & Motortest
TRJSTAT | Status2-Information
TRUN | Betriebsstundenzähler in min
TRUNS | Betriebsstundenzähler in s
TSTEP | Service-Betrieb Dremomentschritte
UCOMP | Umkehrlose Kompensation
UID | Benutzerkennung
UMAX | maximale Ausgangsspannung bei Fledschwächung
UPDATE | Firmware-Update über RS232
UVLTMODE | Unterspannungsmodus
V | Aktuelle Drehzahl
VBUS | Zwischenkreisspannung
VBUSBAL | Maximale Netzspannung
VBUSBOFFS | Absenkung der Ballasteinschaltschwelle
VBUSCNTMAX | interner Parameter
VBUSFACT | Verstärkungsfaktor für die Bremsrampenregelung
VBUSLIM | Schwelle für die Netz-Phasenausfallüberwachung
VBUSMAX | Maximale Zwischenkreisspannung
VBUSMIN | Minimale Zwischenkreisspannung
VBUSOFFS | Korrekturwert für die Ballastschwelle S748/S772
VBUSRAMP | Einschaltschwelle für die Bremsrampenregelung
VBW | Ausgabe eines Bode-Diagramms
VCMD | interner Drehzahlsollwert in UPM
VCOMM | Drehzahlschwelle für Kommutierungsfehler
VCTIME | Kommutierungsfehler Toleranzzeit
VEL0 | Stillstandsschwelle
VER | Firmware-Version
VINPOS | Geschwindigkeit im In-Position-Fenster
VJOG | Tippbetrieb-Geschwindigkeit
VLIM | Max. Drehzahl
VLIMN | Max. negative Drehzahl
VLIMP | Max. Drehzahl
VLO | Software Resolver/Digital Wandler Vorsteuerung
VLO_X | Software Resolver/Digital Wandler Vorsteuerung
VMIX | Geschwindigkeitmix Feedback / externer Geber
VMUL | Geschwindigkeitsmultiplikator (Feldbus)
VOHPD | Hochpassdämpfung des Drehzahlbeobachters
VOHPF | Hochpassfrequenz des Drehzahlbeobachters
VOLPD | Tiefpassdämpfung des Drehzahlbeobachters
VOMODE | interner Parameter
VOMOPDE | interner Parameter
VOSPD | Überdrehzahl
VOSPDREF | Überdrehzahl-Schwelle für die Referenzfahrt
VOUTMAX | sensorless mode: maximale Ausgangsspannung
VREF | Referenzfahrt-Geschwindigkeit
VREF0 | Reduzierfaktor Referenzfahrgeschwindigkeit
VSCALE1 | SW1-Drehzahlskalierungsfaktor
VSCALE2 | SW2-Drehzahlskalierungsfaktor
VSTART | Startspannung für die U/f Steuerung
VSTFR | Drehzahleckpunkt bei Reibungskompensation
VTIMEKD | Zeitkonst vom D-Anteils für den Volumenstromregler
VTUNE | Autotuning Funktion für den Drehzahlregelkreis
VUNIT | Systemweite Definition der Drehzahl / Geschw.
VWM | Grenzwert für SinCos Spannung
WMASK | Warnung/Fehler-Maske
WPOS | Freigabe der schnellen Positionsregister
WPOSE | Freigabe der schnellen Positionsregister 1...16
WPOSP | Polarität der schnellen Positionsregister 1...16
WPOSX | Modus der schnellen Positionsregister 1...16
WSAMPL | Minimale Bewegung der W&S Funktion
WSCNFG | Typ der Kommutierungsfindung
WSLOOP | W&S Zyklen
WSRED | interner Parameter
WSTIME | Ausführungszeit der W&S - Funktion
WSTIME2 | W&S Verzögerungszeit
WSTIME3 | W&S Verzögerungszeit
ZERO | Automatische Kommutierungswinkelermittlung
ZEROTIME | Default Zeitwert für die ZERO-Funktion


ASCII Deutsch SKIP1SP

ASCII - Kommando | SKIP1SP |
Syntax Senden | SKIP1SP [Data] |
Syntax Empfangen | SKIP1SP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 388B (hex)
DIM | rpm | PROFIBUS PNU | 1707 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 907 (dec)
Default | 0 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Skip Drehzahl 1

Beschreibung

Skip Drehzahl 1.
Wird in der U/f Steuerung verwendet um den Betrieb in einem Drehzahlbereich (durch SKIP1W festgelegt) um diese Drehzahl zu vermeiden.
Resonanzen können so ausgeblendet werden.
Siehe auch SKIP1W, SKIP2SP, SKIP2W.


ASCII Deutsch SKIP1W

ASCII - Kommando | SKIP1W |
Syntax Senden | SKIP1SP [Data] |
Syntax Empfangen | SKIP1W <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 388C (hex)
DIM | rpm | PROFIBUS PNU | 1708 (dec) IND = 33 (dec)
Bereich | 0 .. 500 | DPR | 908 (dec)
Default | 0 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Skip Drehzahl 1

Beschreibung

Skip Weite 1.
Wird in der U/f Steuerung verwendet um den Betrieb in dem Drehzahlbereich (+/- 0.5 * SKIP1W) um SKIP1SP herum zu vermeiden.
Resonanzen können so ausgeblendet werden.
Siehe auch SKIP1SP, SKIP2SP, SKIP2W.


ASCII Deutsch SKIP2SP

ASCII - Kommando | SKIP2SP |
Syntax Senden | SKIP1SP [Data] |
Syntax Empfangen | SKIP2SP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 388D (hex)
DIM | rpm | PROFIBUS PNU | 1709 (dec) IND = 33 (dec)
Bereich | 0 .. 3000 | DPR | 909 (dec)
Default | 0 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Skip Drehzahl 2

Beschreibung

Skip Drehzahl 2.
Wird in der U/f Steuerung verwendet um den Betrieb in einem Drehzahlbereich (durch SKIP2W festgelegt) um diese Drehzahl zu vermeiden.
Resonanzen können so ausgeblendet werden.
Siehe auch SKIP2W, SKIP1SP, SKIP1W.


ASCII Deutsch SKIP2W

ASCII - Kommando | SKIP2W |
Syntax Senden | SKIP1SP [Data] |
Syntax Empfangen | SKIP2W <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 388E (hex)
DIM | rpm | PROFIBUS PNU | 1710 (dec) IND = 33 (dec)
Bereich | 0 .. 500 | DPR | 910 (dec)
Default | 0 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Skip Drehzahl 2

Beschreibung

Skip Weite 2.
Wird in der U/f Steuerung verwendet um den Betrieb in dem Drehzahlbereich (+/- 0.5 * SKIP2W) um SKIP2SP herum zu vermeiden.
Resonanzen können so ausgeblendet werden.
Siehe auch SKIP2SP, SKIP1SP, SKIP1W.


ASCII Deutsch SLACCMAX

ASCII - Kommando | SLACCMAX |
Syntax Senden | SLACCMAX [Data] |
Syntax Empfangen | SLACCMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 1 .. 268435455 | DPR | Nein
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | - |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | Rampe im Sensorless Mode

Beschreibung

Mit dem Parameter SLACCMAX werden die Rampe im Sensorless Mode eingestellt. Zu Beginn stellt man SLACCMAX = ACC = DEC. Wenn mit diesem Wert Probleme beim Übergangspunkt auftreten, stellen eine flachere Rampe ein.


ASCII Deutsch SLEN

ASCII - Kommando | SLEN |
Syntax Senden | SLEN [Data] |
Syntax Empfangen | SLEN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F2 (hex)
DIM | m | PROFIBUS PNU | 1842 (dec) IND = 1 (dec)
Bereich | 0 .. 45 | DPR | 242 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Optische Ausgangsleistung bei SERCOS

Beschreibung

Mit diesem Parameter kann man die optische Ausgangsleistung in Metern für eine genormte 1mm² Plastikfaserkabel einstellen.

minimale Ausgangsleistung bei 0
maximale Ausgangsleistung bei 45


ASCII Deutsch SLIDK01

ASCII - Kommando | SLIDK01 |
Syntax Senden | SLIDK01 [Data] |
Syntax Empfangen | SLIDK01 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | -5000 .. 5000 | DPR | Nein
Default | 1 |
Opmode | all | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | Faktor (Gewichtung) von Ud

Beschreibung

Der Parameter SLIDK01 is ein Faktor (Gewichtung) der "Spannung Ud" im sensoless Mode. Ein Wert von 0,23 wird empfohlen, kann aber in kleinen Schritten reduziert werden Ein zu kleinerer Wert kann aber zu Problemen führen.


ASCII Deutsch SLIMAX

ASCII - Kommando | SLIMAX |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch SLIQK

ASCII - Kommando | SLIQK |
Syntax Senden | SLIQK [Data] |
Syntax Empfangen | SLIQK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | -5000 .. 5000 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | Faktor (Gewichtung) des Laststroms Iq

Beschreibung

Der Parameter SLIQK is ein Faktor des Laststroms Iq in der Positionsberechnung im Sensorless Mode. Der Wert hängt von DIPEAK ab und sollte einen Wert nach folgender Tabelle haben:

S701; SLIQK = 1
S706: SLIQK = 4
S712: SLIQK = 8
S724: SLIQK = 10
S748: SLIQK = 20
S772: SLIQK = 30


ASCII Deutsch SLIQK1

ASCII - Kommando | SLIQK1 |
Syntax Senden | SLIQK1 [Data] |
Syntax Empfangen | SLIQK1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | -2 .. 2 | DPR | Nein
Default | 0 |
Opmode | all | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | - |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | zweiter Faktor (Gewichtung) für Laststrom Iq

Beschreibung

Mit dem Parameter SLIQK1 wird ein weiter Faktor (Gewichtung) für "Laststrom Iq" im Sensorless Mode eingestellt. Sein Wert sollte auf eins gesetzt werden.


ASCII Deutsch SLJSWITCH

ASCII - Kommando | SLJSWITCH |
Syntax Senden | SLJSWITCH [Data] |
Syntax Empfangen | SLJSWITCH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | rpm | PROFIBUS PNU | -
Bereich | 0 .. 599 (dual use: 72000) | DPR | Nein
Default | 500 |
Opmode | all | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | Umschaltpunkt vom Stepper in den Sensorless Modus

Beschreibung

SLJSWITCH gibt den Grenzwert an (in rpm) von Stepper zum Sensorless Modus an. Dieser Wert sollte mindestens 15% der Motornenndrehzahl sein.

Bei einer Frequenzbegrenzter Version (non-dual-use) wird die Schwelle abhängig von der Motorpolpaarzahl begrenzt.
Maximalwert = (599*60*2)/MPOLES

Bei einer nicht Frequenzbegrenzter Version (dual use)
Maximalwert = (72000*2)/MPOLES


ASCII Deutsch SLMODE

ASCII - Kommando | SLMODE |
Syntax Senden | SLMODE [Data] |
Syntax Empfangen | SLMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 5 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware |  |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | Stepper Mode für Sensorless

Beschreibung

Mit dem Parameter SLMODE wird der Stepper Mode ausgewählt.

Vorraussetzung FBTYPE=10 und MTYPE= 1


ASCII Deutsch SLOTIO

ASCII - Kommando | SLOTIO |
Syntax Senden | SLOTIO |
Syntax Empfangen | SLOTIO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35F3 (hex)
DIM | - | PROFIBUS PNU | 1843 (dec) IND = 1 (dec)
Bereich | - | DPR | 243 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | I/O-Erweiterungskarte: IN/OUT-Zustand

Beschreibung

Das Kommando SLOTIO liefert die Zustände der Ein-/Ausgänge der I/O-Erweiterungsplatine (Format Hxxxxxxxx).
Bit-Nummer Bitkombination Input/Output Beschreibung
0 0x00000001 Input Bit 0 Fahrsatznummer (A0)
1 0x00000002 Input Bit 1 Fahrsatznummer (A1)
2 0x00000004 Input Bit 2 Fahrsatznummer (A2)
3 0x00000008 Input Bit 3 Fahrsatznummer (A3)
4 0x00000010 Input Bit 4 Fahrsatznummer (A4)
5 0x00000020 Input Bit 5 Fahrsatznummer (A5)
6 0x00000040 Input Bit 6 Fahrsatznummer (A6)
7 0x00000080 Input Bit 7 Fahrsatznummer (A7)
8 0x00000100 Input Referenzschalter
9 0x00000200 Input Quittieren des Schleppfehlers
10 0x00000400 Input Starten des Folgefahrsatzes
11 0x00000800 Input Starten des Tippbetriebes
12 0x00001000 Input Fortsetzen eines Fahrsatzes
13 0x00002000 Input Starten des Fahrsatzes Nr. A0...A7
14 0x00004000 Output Meldung „In-Position“
15 0x00008000 Output Meldung „In-Position2“ (Folge)
16 0x00010000 Output Meldung „Schleppfehler“
17 0x00020000 Output Meldung „Positionsregister 1“
18 0x00040000 Output Meldung „Positionsregister 2“
19 0x00080000 Output Meldung „Positionsregister 3“
20 0x00100000 Output Meldung „Positionsregister 4“
21 0x00200000 Output Meldung „Positionsregister 5“
22 0x00400000 Status 24Volt - Ein
23 0x00800000 Status Slot-Fehler
24...31 Reserve


ASCII Deutsch SLTEMPM

ASCII - Kommando | SLTEMPM |
Syntax Senden | SLTEMPM [Data] |
Syntax Empfangen | SLTEMPM <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | temperatures | EEPROM |
Kurzbeschreibung | Überwachung des Temperaturfühler

Beschreibung

SLTEMPM=0 – Temperaturfühler wird im Sensorless Betrieb (FBTYPE=10 und 11) nicht überwacht.
SLTEMPM=1 – Temperaturfühler wird im Sensorless Betrieb (FBTYPE=10 und 11) überwacht.


ASCII Deutsch SLTSWITCH

ASCII - Kommando | SLTSWITCH |
Syntax Senden | SLTSWITCH [Data] |
Syntax Empfangen | SLTSWITCH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | -
DIM | ms | PROFIBUS PNU | -
Bereich | 0 .. 10000 | DPR | Nein
Default | 200 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Übergangszeit von kleiner zum nominellen Drehzahl

Beschreibung

SLTSWITCH definiert eine Zeit (in ms) bei der der Antrieb den Motor an einer Geschwindigkeitsschwelle konstant hält (SLJSWITCH). Das bedeutet, wenn SLTSWITCH 100ms ist, der Motor stoppt die Beschleunigung und dreht sich für 100 ms bei SLJSWITCH. Nach diesen 100 ms erfolgt eine weiter Bescheunigung des Motors. Ein Wert von Null bedeutet, dass es keine Verzögerung im Übergangsbereich gibt.


ASCII Deutsch SMNUMBER

ASCII - Kommando | SMNUMBER |
Syntax Senden | SMNUMBER |
Syntax Empfangen | SMNUMBER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3695 (hex)
DIM | - | PROFIBUS PNU | 2005 (dec) IND = 1 (dec)
Bereich | 0 .. 32767 | DPR | 405 (dec)
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Gespeicherte Motornummer im Geber

Beschreibung

Das Kommando SMNUMBER zeigt die im externen Geber (ENDAT/HIPERFACE) abgespeicherte Motornummer an.

Dieses Kommando ist nur bei Einstellungen FBTYPE=4 oder FBTYPE=2 sinnvoll. Bei anderen Einstellungen wird als Motornummer eine 0 ausgegeben.


ASCII Deutsch SOFTIN

ASCII - Kommando | SOFTIN |
Syntax Senden | SOFTIN [Data] |
Syntax Empfangen | SOFTIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 354E (hex)
DIM | - | PROFIBUS PNU | 1678 (dec) IND = 1 (dec)
Bereich | Integer32 | DPR | 78 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustandsvariable der virtuellen digitalen Eingänge

Beschreibung

Die Variable SOFTIN zeigt den Zustand der virtuellen digitalen Eingänge INPUT5 … INPUT20

Die Zuordnung ist dabei wie folgt:

Bit0 INPUT5
Bit1 INPUT6
….
Bit15 INPUT20

Der Schreibzugriff auf den Parameter SOFTIN hat direkte Auswirkung auf den Zustand des zugehörigen digitalen Eingangs.

Beispiel:

SOFTIN 5 : Die digitalen Eingänge INPUT5 und INPUT7 bekommen High - Pegel.

Die Funktion der virtuellen digitalen Eingänge können mit IN5MODE…IN20MODE eingestellt werden.

Falls eine externe I/O Einschubkarte benutzt wird ist nur eine begrenzte Anzahl von virtuellen Eingängen verfügbar (INPUT19…INPUT20)


ASCII Deutsch SOFTOUT

ASCII - Kommando | SOFTOUT |
Syntax Senden | SOFTOUT [Data] |
Syntax Empfangen | SOFTOUT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 354F (hex)
DIM | - | PROFIBUS PNU | 1679 (dec) IND = 1 (dec)
Bereich | Integer32 | DPR | 79 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustandsvariable der virtuellen digitalen Ausgänge

Beschreibung

Die Variable SOFTOUT zeigt den Zustand der virtuellen digitalen Ausgänge OUTPUT3 … OUTPUT18

Die Zuordnung ist dabei wie folgt:

Bit0 OUTPUT3
Bit1 OUTPUT4
….
BIT15 OUTPUT18

Die Funktion der virtuellen digitalen Ausgänge kann mit O3MODE…O18MODE eingestellt werden.


ASCII Deutsch SPHAS

ASCII - Kommando | SPHAS |
Syntax Senden | SPHAS |
Syntax Empfangen | SPHAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35F4 (hex)
DIM | - | PROFIBUS PNU | 1844 (dec) IND = 1 (dec)
Bereich | - | DPR | 244 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | SERCOS-Phase

Beschreibung

Gibt die aktuelle Sercosphase an.

Phase 0 Ring schließen und reset
Phase 1 Antriebsidentifikation
Phase 2 Kommunikationsinitialisierung
Phase 3 Parameterinitialisierung
Phase 4 Betriebsbereit


ASCII Deutsch SRND

ASCII - Kommando | SRND |
Syntax Senden | SRND [Data] |
Syntax Empfangen | SRND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3637 (hex)
DIM | - | PROFIBUS PNU | 1911 (dec) IND = 1 (dec)
Bereich |  | DPR | 311 (dec)
Default | -PGEARI/2 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Startposition Modulo-Achse

Beschreibung

Mit dem Parameter SRND wird der Anfang des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Das Ende des Bereiches kann mit dem Kommando ERND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für SRND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI, PGEARO).


ASCII Deutsch SSIGRAY

ASCII - Kommando | SSIGRAY |
Syntax Senden | SSIGRAY [Data] |
Syntax Empfangen | SSIGRAY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35F6 (hex)
DIM | - | PROFIBUS PNU | 1846 (dec) IND = 1 (dec)
Bereich | 0,1 | DPR | 246 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | SSI Formatwahl

Beschreibung

Das Kommando legt fest, in welchem Format das SSI - Datum ausgegeben wird.

SSIGRAY 0 = Binär
SSIGRAY 1 = Gray


ASCII Deutsch SSIINV

ASCII - Kommando | SSIINV |
Syntax Senden | SSIINV [Data] |
Syntax Empfangen | SSIINV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35F7 (hex)
DIM | - | PROFIBUS PNU | 1847 (dec) IND = 1 (dec)
Bereich | 0 .. 3 | DPR | 247 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 3.55 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Polarität des SSI-Clocks

Beschreibung

nur S300:

Verhalten der SSI - Schnittstelle an X5.
Abhängig davon ob SSI als Ausgabe oder Eingabe konfiguriert wurde, hat das Kommando SSIINV unterschiedliche Bedeutung:

1. SSI-Ausgabe
SSIINV = 0: Clock-Pegel normal
SSIINV = 1: Clock-Pegel invertiert
SSIINV = 2: Clock-Pegel normal, nur 12 Bit Auflösung
SSIINV = 3: Clock-Pegel invertiert, nur 12 Bit Auflösung

2. SSI-Einlesen
SSIINV = 0: Clock-Pegel normal
SSIINV = 1: Clock-Pegel invertiert
SSIINV = 2: nicht genutzt
SSIINV = 3: nicht genutzt


ASCII Deutsch SSIMASK

ASCII - Kommando | SSIMASK |
Syntax Senden | SSIMASK [Data] |
Syntax Empfangen | SSIMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 390C (hex)
DIM | - | PROFIBUS PNU | 1836 (dec) IND = 33 (dec)
Bereich | 0…0xFFFFFFFF (dec: -2147483648 .. 2147483647) | DPR | 1036 (dec)
Default | 0XFFFFFFFF (dec: -1) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.87 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Filter-Maske für empfangene SSI-Daten

Beschreibung

Mit Hilfe der Variable SSIMASK können die Warnungs-/Fehlerbits in den ankommenden SSI-Daten ausgefiltert werden. Da im SSI-Datum ausschliesslich die Positionsinformation erwartet wird, müssen die ggf. vorhandenen Statusinformationen durch Löschen des zugehörigen Bits in SSIMASK ausgeblendet werden.

Das empfangene SSI-Datum wird mit dem SSIMASK-Wert ver-undet (AND-Operation). Das Ergebnis wird als Positionsinformation weiterverarbeitet.


ASCII Deutsch SSIRESOL

ASCII - Kommando | SSIRESOL |
Syntax Senden | SSIRESOL [Data] |
Syntax Empfangen | SSIRESOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 387B (hex)
DIM | - | PROFIBUS PNU | 1691 (dec) IND = 33 (dec)
Bereich | 0 .. 32 Bits | DPR | 891 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.07 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | SSIRESOL wird die Auflösung des SSI-Linear-Gebers

Beschreibung

Mit dem Parameter SSIRESOL wird die Auflösung des SSI-Linear-Gebers (FBTYPE=26/28) festgelegt.
Der Parameter enthält die Anzahl der Counts die vom SSI-Geber pro Sinus-Periode geliefert werden.

z.B. SSI-Auflösung 1µm
Polpitch-Abstand 28 mm = 28000 µm
ENCLINES=1000
SSIRESOL=28


ASCII Deutsch SSIREVOL

ASCII - Kommando | SSIREVOL |
Syntax Senden | SSIREVOL [Data] |
Syntax Empfangen | SSIREVOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3619 (hex)
DIM | - | PROFIBUS PNU | 1881 (dec) IND = 1 (dec)
Bereich | 0 .. 16 | DPR | 281 (dec)
Default | 4 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.2
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl Bit für Multiurn (SSI)

Beschreibung

Das Kommando ‘SSIREVOL’ definiert die Anzahl der MultiTurn-Bits innerhalb einer SSI – Übertragung (Einlesen).
In Verbindung mit dem Kommando SSIRXD wird damit die Aufteilung der Bits innerhalb eines SSI-Telegrammes beschrieben.

SSIRXD – Gesamtzahl der einzulesenden SSI-Bits
SSIREVOL – Anzahl der Bits für die Multiturn-Information

Daraus ergibt sich: Anzahl der Bits pro Geberumdrehung = SSIRXD - SSIREVOL

Default Wert beim S700: 12


ASCII Deutsch SSIRXD

ASCII - Kommando | SSIRXD |
Syntax Senden | SSIRXD [Data] |
Syntax Empfangen | SSIRXD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 365E (hex)
DIM | - | PROFIBUS PNU | 1950 (dec) IND = 1 (dec)
Bereich | 1 ... 33 | DPR | Nein
Default | 24 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl der einzulesenden SSI-Bit’s

Beschreibung

Das Kommando ‘SSIRXD’ legt die Anzahl der einzulesenden SSI-Bit’s fest.

REGISTER max. 32 Bit

Anzahl der Bit’s:

1 => SSIRXD 1

2 => SSIRXD 2

…

32 => SSIRXD 32

33 => SSIRXD 33


ASCII Deutsch SSITIME

ASCII - Kommando | SSITIME |
Syntax Senden | SSITIME [Data] |
Syntax Empfangen | SSITIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 390B (hex)
DIM | µsec | PROFIBUS PNU | 1835 (dec) IND = 33 (dec)
Bereich | 1 ... 15 | DPR | 1035 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 5.87 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | SSI Beruhigungszeit

Beschreibung

Über diesen Parameter kann bei SSITOUT = 3 die SSI-Beruhigungszeit eingestellt werden


ASCII Deutsch SSITOUT

ASCII - Kommando | SSITOUT |
Syntax Senden | SSITOUT [Data] |
Syntax Empfangen | SSITOUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3661 (hex)
DIM | - | PROFIBUS PNU | 1953 (dec) IND = 1 (dec)
Bereich | 0 .. 3 | DPR | 353 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | SSI Beruhigungszeit

Beschreibung

Das Kommando ‘SSITOUT’ legt die Monoflop – Zeit bei der SSI – Übertragung fest.

SSI als Output:
SSITOUT 0 <= Beruhigungszeit von 13 µsec
SSITOUT 1 <= Beruhigungszeit von 3 µsec

ab FW 5.87:
SSITOUT 2 <= Beruhigungszeit von 8 µsec
SSITOUT 3 <= frei parametrierbare Beruhigungszeit (Eingabe über den Parameter SSITIME)

SSI als INPUT
Das Kommando definiert die Clock-Frequenz, die für das Einlesen des SSI-Datenwortes benutzt wird.

SSITOUT 0: 1MHz für 1. & 2. Feedback (FBTYPE, EXTPOS)
SSITOUT 1: 500 kHz für 1. & 2. Feedback (FBTYPE, EXTPOS)
SSITOUT 2: 250 kHz nur für den zweiten Feedback (EXTPOS)
SSITOUT 3: 125 kHz nur für den zweiten Feedback (EXTPOS))


ASCII Deutsch SSTAT

ASCII - Kommando | SSTAT |
Syntax Senden | SSTAT [Data] |
Syntax Empfangen | SSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 35FA (hex)
DIM | - | PROFIBUS PNU | 1850 (dec) IND = 1 (dec)
Bereich | - | DPR | 250 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Nein
Kurzbeschreibung | aktuellen Status der Sercos Schnittstelle als Text

Beschreibung

Gibt als Textstring den aktuellen Status der Sercos Schnittstelle an


ASCII Deutsch STAGECODE

ASCII - Kommando | STAGECODE |
Syntax Senden | - |
Syntax Empfangen | STAGECODE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3682 (hex)
DIM | - | PROFIBUS PNU | 1986 (dec) IND = 1 (dec)
Bereich | 1, 2, .., 19 | DPR | 386 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Endstufenkennung

Beschreibung

Mit dem Kommando STAGECODE kann die Kennung der Endstufe (Stromstärke) angezeigt werden.

STAGECODE=0 nicht zugelassen (Hardware-Fehler)
STAGECODE=1 S 303
STAGECODE=2 S 306
STAGECODE=3 S 310
STAGECODE=4 S 341
STAGECODE=5 S 343
STAGECODE=6 S 346
STAGECODE=7..9 reserviert
STAGECODE=10 S 701
STAGECODE=11 S 703
STAGECODE=12 S 706
STAGECODE=13 S 712
STAGECODE=14 S 724
STAGECODE=15 S 712P (30A/400V)
STAGECODE=16 S 724P (72A/400V)
STAGECODE=17 S 748
STAGECODE=18 S 772
STAGECODE=19..41 reserviert
STAGECODE=42 S 701
STAGECODE=43 S 703
STAGECODE=44 S 706
STAGECODE=45 S 712
STAGECODE=46 S 724
STAGECODE=47 S 721P (30A/230V)
STAGECODE=48 S 724P (72A/230V)


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Bedienung

Start der Software

Klicken Sie zum Start der Software auf Ihrem Windows Desktop auf das Icon

Online/Offline arbeiten

DRIVEGUI.EXE bietet die Möglichkeit, offline oder online zu arbeiten.

online: mit angeschlossenem / eingeschaltetem Servoverstärker (24V Hilfsspannung)
offline: ohne Verbindung zu einem eingeschalteten Servoverstärker

Online arbeiten

Der Maschinenhersteller muss eine Risikobeurteilung für die Maschine erstellen und geeignete Maßnahmen treffen, dass unvorhergesehene Bewegungen nicht zu Schäden an Personen oder Sachen führen können. Erst wenn diese Maßnahmen getroffen wurden, ist das Online Parametrieren eines laufenden Antriebs durch Fachpersonal erlaubt.

Die Software prüft die vorhandenen Schnittstellen. Wird ein angeschlossener Servoverstärker erkannt, startet die Software mit dem Startbildschirm. Wenn die Multilink Funktionalität eingeschaltet ist (MDRV=1) wird eine Liste der erkannten Servoverstärker im Mehrachsensystem angeboten. Weiter Informationen zu Multilink finden Sie im KDN auf der Seite Multilink mit Setup Software.

comnet

Wird erstmalig eine Kommunikation aufgebaut, werden Sie aufgefordert, die Kommunikationsparameter einzustellen.
Wählen Sie das Kommunikationssystem und die Schnittstelle (COM1 … COM10), an die der Servoverstärker angeschlossen ist, stellen Sie die gewünschte Baudrate sowie die Geschwindigkeit ein und Klicken Sie auf OK.
Die Software versucht nun, eine Verbindung zum Servoverstärker aufzubauen. Wenn keine Kommunikation zustande kommt, erhalten Sie diese Fehlermeldung.

Nach Bestätigen der Fehlermeldung schaltet die Software in den Offline-Modus um. Dies erfordert die manuelle Auswahl des Servoverstärkers. Brechen Sie die Auswahl ab indem Sie das Auswahlfenster schließen. Suchen und beseitigen Sie den Fehler, der die Kommunikation verhindert. Starten Sie die Software erneut im Online-Modus.

Offline arbeiten

Wenn Sie offline arbeiten, sind alle Funktionen, die eine Kommunikation zwischen Servoverstärker und Inbetriebnahmesoftware voraussetzen, inaktiv.

Die Software kann im Offline Modus nicht erkennen, für welchen Servoverstärkertyp Sie Parameter einstellen wollen.
Daher müssen Sie zunächst Ihren Verstärkertyp festlegen.

Wählen Sie aus der angezeigten Liste die Datenreihe, die für Ihr Gerät und die Netzsituation zutrifft. Alle sinnvollen Kombinationen aus Dauerstrom und Netzspannung sind vorgegeben. Klicken Sie danach auf OK.

Die nun geladenen Default-Daten können bearbeitet und in eine Datei abgespeichert werken.

Bildschirmaufbau

Titelleiste

In der Titelleiste des Hauptfensters wird der Programmname und der Name des jeweils aktuellen Datensatzes (Verstärkers) angezeigt.

Menüleiste

Datei | Neu | Ein neuer Defaultparametersatz wird erstellt zur weiteren Bearbeitung. Der aktuelle Datensatz wird geschlossen und nicht gespeichert.
 | Öffnen | Vom Datenträger wird ein Datensatz gelesen und aktuell. Der Servoverstärker muss disabled sein.
 | Speichern | Den aktuellen Datensatz des Servoverstärkers in eine Datei auf dem PC speichern
 | Drucken | Den aktuellen Datensatz des Servoverstärkers auf dem Windows Standarddrucker ausdrucken
 | restliche Funktionen | Windows Standard
Bearbeiten | alle Funktionen | Windows Standard
Kommunikation | Verbinden | Verbindung zum Servoverstärker herstellen
 | Trennen | Die aktive Verbindung wird getrennt und die Software wechselt in den Offline-Modus
 | Neu laden | Erneutes Laden aller Parameter und Fahraufträge
 | Seiteneinstellung aktualisieren | Wiederherstellung der ursprünglichen Daten der aktuell angezeigten Seite
 | Seiteneinstellung übernehmen | Speichern der Parameter in den flüchtigen Speicher (RAM) des Servoverstärkers.
 | Schnittstellen auswählen | Auswahl des Verbindungsnetzwerks
 | Schnittstellen Parameter | Einstellungen der COM-Schnittstelle
Verstärker | Stop | Stoppen der Bewegung bei OPMODE 0, 2, 8
 | Enable | Software Enable für die Leistungsendstufe
 | Disable | Software Disable für die Leistungsendstufe
 | Im EEPROM speichern | Die aktuellen Parameter werden im EEPROM des Servoverstärkers dauerhaft gesichert.
 | EEPROM löschen | Die werkseitigen Default Parameter werden in das EEPROM des Servoverstärkers geladen.
 | RESET | Ein Hardwarereset wird durchgeführt. (Kaltstart)
 | Fehler löschen | Anstehende Fehlermeldungen werden quittiert. Die Reaktion hängt vom aktuellen Fehler ab: sofortige Betriebsbereitschaft oder Neustart
 | OPMODE wählen | Festlegung der Betriebsart des Servoverstärkers OPMODE
Extras | Upgrade Tool | Start des Upgrade Tools, siehe auch Software Upgrade
 | CalcLK | Start des Konvertierungstools für Profiltabellendaten
 | SafetyGUI | Start der Inbetriebnahme Software SafetyGUI für eingebaute Safetykarten
 | MacroStar | Start des Makro Editors MacroStar, siehe auch Makroprogrammierung
 | Sprache einstellen | Sprachversion der Software wechseln
Ansicht | Symbolleiste | Sichtbarkeit der Symbolleiste
 | Statusleiste | Sichtbarkeit der Statusleiste
? | Inhalt | Startseite der Online Hilfe zur Software
 | Hilfe F1 | Zeigt Hilfeseite zum aktuellen Fenster an
 | Support | Kontaktinformationen für Rückfragen
 | Info | Version der Software

Symbolleiste

winmenu

Windows Standard

 | Verbinden | Enable (Shift+F12)
 | Trennen | Disable (F12)
 | Neu laden | Im EEPROM speichern
 | Aktualisieren | EEPROM löschen
 | Übernehmen | Fehler löschen
 | Stop (F11) | Reset
hilfeicon | Kontext-Hilfe | Software-Version
help | Hilfe für aktuelle Seite |

opmode

Betriebsart des Servoverstärkers OPMODE

Statusleiste

Links wird der Status der Kommunikation zwischen Servoverstärker und Inbetriebnahmesoftware angezeigt.
In der rechten Hälfte der Statuszeile werden der Betriebszustand der Software (Online/Offline) und verschiedene andere Zustände des Servoverstärkers gemeldet.

Navigationsfenster

navigation

In einer Windows-Explorer ähnlichen Struktur finden Sie Links zu allen Bildschirmseiten, die Sie für Inbetriebnahme, Optimierung und Beobachtung des Servoverstärkers benötigen. Die hier angewählte Seite wird im Hauptfenster dargestellt.

Die oberste Ebene des Verzeichnisbaumes trägt den Namen des Verstärkers (im Beispiel DRIVE0).

Hauptfenster

main

Im Hauptfenster (hier die Seite BASISEINSTELLUNGEN als Beispiel) können Sie verschiedene Parameter ändern, Istwerte des Servoverstärkers auslesen und Funktionen anwählen.

Hilfe Funktionen

Funktionstaste F1 | Startet die Online-Hilfe zur aktiven Bildschirmseite
help (2) | Schaltfläche in Symbolleiste, startet die Online-Hilfe zur aktiven Bildschirmseite
Menüleiste ? | Startet die Online-Hilfe mit ihrer Startseite
hilfeicon1 | Kontext-Hilfe. Klicken Sie zuerst auf des Hilfesymbol und anschließend auf die Funktion, zu der Sie Hilfe benötigen.

Integriert in die Online-Hilfe ist die Beschreibung aller Befehle und Parameter (ASCII Objektreferenz), die der Servoverstärker verarbeiten kann.

Hilfe und viele weitere Erklärungen finden Sie auch im KDN.


ASCII Deutsch Revision

ASCII Objekt Beschreibung
Ausgabe REV 2.14
Ausgabe | Bemerkung | Erstellt
REV 1.0 beta | Betaversion | 11.05.04
REV 1.0 | Erstausgabe | 03.05.05
REV 1.1 | Neue Befehle und Ergänzungen | 11.10.05
REV 1.2 | Neue Befehle und Ergänzungen | 02.02.06
REV 1.3 | Neue Befehle und Ergänzungen | 11.09.06
REV 1.4 | Neue Befehle und Ergänzungen | 23.10.06
REV 1.5 | Neue Befehle und Ergänzungen | 30.10.06
REV 1.6 | Neue Befehle und Ergänzungen | 03.11.06
REV 1.7 | Neue Befehle und Ergänzungen | 23.11.06
REV 1.8 | Neue Befehle und Ergänzungen | 15.03.07
REV 1.9 | Neue Befehle und Ergänzungen | 21.12.07
REV 2.0 | Neue Befehle und Ergänzungen | 30.01.08
REV 2.1 | Neue Befehle und Ergänzungen | 05.12.08
REV 2.2 | Neue Befehle und Ergänzungen | 18.06.09
REV 2.3 | Neue Befehle und Ergänzungen | 25.02.11
REV 2.4 | Neue Befehle und Ergänzungen | 21.02.11
REV 2.5 | Neue Befehle und Ergänzungen | 13.11.12
REV 2.6 | Neue Befehle und Ergänzungen | 13.06.13
REV 2.7 | Neue Befehle und Ergänzungen | 29.07.13
REV 2.8 | Neue Befehle und Ergänzungen | 08.11.13
REV 2.9 | Neue Befehle und Ergänzungen | 08.05.14
REV 2.10 | Neue Befehle und Ergänzungen | 28.10.15
REV 2.11 | Neue Befehle und Ergänzungen | 24.03.16
REV 2.12 | Neue Befehle und Ergänzungen | 05.12.16
REV 2.13 | Neue Befehle und Ergänzungen | 17.11.17
REV 2.14 | Neue Befehle und Ergänzungen | 15.05.18


ASCII Deutsch STAT

ASCII - Kommando | STAT |
Syntax Senden | STAT |
Syntax Empfangen | STAT | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35FB (hex)
DIM | - | PROFIBUS PNU | 1851 (dec) IND = 1 (dec)
Bereich | int (=Word) | DPR | 251 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Verstärker-Statuswort

Beschreibung

Das Kommando STAT liefert ein 16-Bit Statuswort im Hex-Format (Hxxxx).

Bit Wertigkeit Bedeutung
0 0x0001 =0 wenn Endstufe freigegeben
=1 Endstufe gesperrt
1 0x0002 =0 wenn Regler betriebsbereit (BTB)
=1 Fehler steht an
2 0x0004 =0 kein Password aktiv (PASSX=0)
=1 Password aktiv (PASSX>0)
3 0x0008 =0 keine Service-Funktion aktiv
=1 wenn Service-Funktion aktiv
4 0x0010 =0 kein PLC-Password aktiv (PASSXPLC=0)
=1 PLC-Password aktiv (PASSXPLC>0)
5 0x0020 =1 nach einem Hardware-Reset, wird gelöscht mit CLRHR
6 0x0040 =1 Konfigurationsvariable geändert (SAVE und COLDSTART)
=0 keine Konfigurationsvariable geändert
7 0x0080 =1 Sicherheitsrelais aktiv (AS-Option)
=0 Sicherheitsrelais nicht aktiv
8 0x0100 =1 RAM- und EEPROM-Parameter unterschiedlich (wird gelöscht mit SAVE-Kommando).
=0 RAM- und EEPROM-Parameter gleich
9 0x0200 =1 Slot-Erweiterungskarte vorhanden
=0 Slot-Erweiterungskarte nicht vorhanden
10 0x0400 =1 RAM-Parameter modifiziert (wird gelöscht mit DUMP-Kommando)
=0 seit dem letzten DUMP wurden keine RAM-Parameter geändert.
11...15 Reserve

Die Bits 5,6,8 und 10 werden benutzt um eine Änderung der internen Parameter nach Außen bekanntzugeben.

Bit 5 Hardware-Reset
Das Bit 5 wird gesetzt wenn die Parameter aus dem seriellen EEPROM ins RAM kopiert werden (geschieht nach einem Hardware-Reset bzw. beim LOAD-Kommando). Wenn das Bit gesetzt ist, sollte die Parametriersoftware alle Parameter anfordern (DUMP-Kommando) und mit dem Kommando CLRHR das Bit 5 löschen.

Bit 6 Konfigurationsvariable geändert
Bei jeder Änderung einer Konfigurationsvariable (Variablen, die eine Neuübersetzung der Makros erfordern d.h. Reset des Verstärkers), wird diese Bit auf 1 gesetzt. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine SAVE / COLDSTART-Aufforderung (Reset des Reglers) ausgeben. Das Bit 6 wird nur bei einem Hardware-Reset (COLDSTART) gelöscht.

Bit 8 EEPROM/RAM-Parameter unterschiedlich
Jede Änderung eines RAM-Parameters führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt (z.B. Verlassen des Programmes) eine SAVE-Aufforderung (Abspeichern der Daten im EEPROM) ausgeben. Das Bit wird nach einem SAVE-Kommando gelöscht.

Bit 10 RAM-Parameter modifiziert
Jede Änderung eines RAM-Parameters über einen anderen Parametrierkanal als RS232 führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine DUMP-Aufforderung (Einlesen aller Daten) ausgeben. Das Bit wird nach einem DUMP-Kommando gelöscht.


ASCII Deutsch STATCODE

ASCII - Kommando | STATCODE |
Syntax Senden | STATCODE |
Syntax Empfangen | STATCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 385E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 33 (dec)
Bereich | - | DPR | 862 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Anzeige der Warnungen in Klartext

Beschreibung

Anzeige der Warnungen in Klartext

Siehe auch STATCODE *


ASCII Deutsch STATCODE *

ASCII - Kommando | STATCODE * |
Syntax Senden | STATCODE * |
Syntax Empfangen | STATCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 .. 0xFFFFFFFF | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Statusvariable "Warnungen"

Beschreibung

Das Kommando STATCODE * liefert die internen Warnungen in Form einer Bit-Variable. Die Belegung der einzelnen Bits kann der nachfolgenden Tabelle entnommen werden.
Bit | Display-Anzeige | Bedeutung
0 / 0x00000001 | n01 | =1 I2T-Meldeschwelle überschritten wird gesetzt, wenn IRMS die eingestellte Schwelle I2TLIM überschreitet wird gelöscht sobald die Meldeschwelle unterschritten wird.
1 / 0x00000002 | n02 | =1 Ballast-Meldung wird gesetzt, wenn die eingestellte Ballastleistung PBALMAX überschritten wird. wird gelöscht, sobald die PBALMAX unterschritten wird.
2 / 0x00000004 | n03 | =1 Schleppfehler wird gesetzt sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
3 / 0x00000008 | n04 | =1 Ansprechüberwachung aktiv wird gesetzt, wenn die BUS/SLOT-Ansprechüberwachungszeit EXTWD überschritten wurde. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
4 / 0x00000010 | n05 | =1 Netzphase fehlt wird gesetzt sobald das Fehlen einer der 3 Netzphasen festgestellt wird. Wird gelöscht wenn alle 3 Netzphasen vorhanden.
5 / 0x00000020 | n06 | =1 Software-Endschalter 1 unterschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 1 SWE1 unterschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition unterhalb von SWE1 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE1 überschritten wird und ein positiver Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
6 / 0x00000040 | n07 | =1 Software-Endschalter 2 überschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 2 SWE2 überschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition oberhalb von SWE2 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE2 unterschritten wird und ein negativer Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
7 / 0x00000080 | n08 | =1 Fehlerhafter Fahrauftrag gestartet Das Bit wird gesetzt wenn versucht wurde einen nichtvorhandenen (fehlerhafte Checksumme) Fahrauftrag zu starten, die Zielposition außerhalb des zulässigen Bereiches (Software - Endschalter) liegt oder falsche Beschleunigungsgrößen ( ausserhalb des erlaubten Eingabebereiches) gewählt wurden. Ab der FW 2.31 ist die Überprüfung der Tabellen-Checksumme aktiv, d.h. nur mit dem Konvertierungstool 4.0 erstelle Tabellen können benutzt werden. Ein Tabellen-Fahrauftrag, der eine alte Tabelle benutzt, wird nicht gestartet. Es erscheint die Warnung 08. Wird gelöscht wenn ein gültiger Fahrsatz gestartet wird. Die Warnung wird auch aktiv, wenn AUTOHOME oder ein Digitaleingang als Referenzschalter z.B. IN1MODE 16 bei OPMODE <> 4 oder 8 gestartet wird. Das Starten eines nicht vorhandenen Tabellenfahrauftrages kann auch Ursache sein (ab FW 2.14)
8 / 0x00000100 | n09 | =1 Referenzpunkt nicht gesetzt wird gesetzt, wenn ein Fahrsatz gestartet wird, ohne dass zuvor eine Referenzfahrt durchgeführt wurde. Wird gelöscht nach einer abgeschlossenen Referenzfahrt.
9 / 0x00000200 | n10 | = 1 PSTOP aktiv ist gesetzt solange der Hardware-Endschalter PSTOP aktiv wird gelöscht sobald der Hardware-Endschalter PSTOP inaktiv wird.
10 / 0x00000400 | n11 | =1 NSTOP aktiv ist gesetzt solange der Hardware-Endschalter NSTOP aktiv wird gelöscht sobald der Hardware-Endschalter NSTOP inaktiv wird.
11 / 0x00000800 | n12 | =1 Default-Motordaten geladen wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem EnDAT- oder Hiperface-Geber unterschiedlich sind. Bei Eingabe einer gültigen Motornummer und Abspeichern der Daten im Geber HSAVE und im internen EEPROM SAVE wird beim nächsten Einschalten des Gebers diese Warnung nicht mehr ausgegeben.
12 / 0x00001000 | n13 | =1 Slot-Warnung (I/O-Karte) Bei fehlender 24V-Versorgungsspannung für die I/O-Karte wird die Warnung n13 generiert und einmalig ein Nothalt ausgeführt. Anschliessend kann aber der Antrieb auch ohne 24V I/O-Versorgung verfahren werden. Falls die Applikation es erfordert, kann der Anwender durch das Setzen des WMASK-Bits zusätzlich einen Fehler F24 generieren und dadurch jegliche Motor-Bewegung unterbinden. Die Überwachung der 24V Versorgungsspannung kann durch CPHASE konfiguriert werden.
13 / 0x00002000 | n14 | =1 Diese Warnung wird in folgenden Situationen ausgegeben: 1. Wake&Shake aktiv (z.B. bei FBTYPE=7,8…) Sobald die Endstufe freigegeben wurde und die Bestimmung der Motorphase beendet wurde, wird die Warnung gelöscht. 2. Sicherer Bremsentest (SBT) aktiv Diese Funktion kann nur bei Verwendung einer Safety-Karte (S700) aktiviert werden. Solange die Warnung n14 aktiv ist, werden die externen Sollwerte (z.B. vom Feldbus-Interface) ignoriert.
14 / 0x00004000 | n15 | reserviert
15 / 0x00008000 | n16 | Summenwarnung für Warnungen n17...n31
16 / 0x00010000 | n17 | Feldbus-Sync ist nicht eingelocked.
17 / 0x00020000 | n18 | Bei Multiturn-Geber Rückführung wurde ein Überlauf über die maximale Anzahl von Umdrehungen (+/-2048) festgestellt
18 / 0x00040000 | n19 | Rampe beim Fahrsatz wurde begrenzt (Wertebereichüberschreitung bei Fahrsatzdaten)
19 / 0x00080000 | n20 | Ungültiger Fahrsatz
20 / 0x00100000 | n21 | Warnung durch PLC Programm (Bedeutung geht aus Programm hervor )
21 / 0x00200000 | n22 | Motortemperatur überschritten (die Warnung gibt dem Anwender Reaktionsmöglichkeiten, bevor der Fehler "Motorübertemperatur" zur Reglerabschaltung führt)
22 / 0x00400000 | n23 | Sinus Kosinus Geber -Warnschwelle erreicht siehe auch VWM
23 / 0x00800000 | n24 | Das wird auf 1 gesetzt, wenn beim Einschalten ein Plausibilitätsproblem bei den abgespeicherten Parametern festgestellt . Siehe auch ERRPARAM
24...30 | n25 .. n31 | Reserve
31 / 0x80000000 | n32 | =1 ist gesetzt bei einer Beta-Version der Firmware.


ASCII Deutsch STATIO

ASCII - Kommando | STATIO |
Syntax Senden | STATIO |
Syntax Empfangen | STATIO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | 7 x Integer8 | CANBus Objektnummer | 35FC (hex)
DIM | - | PROFIBUS PNU | 1852 (dec) IND = 1 (dec)
Bereich | 0,1 (=State) | DPR | 252 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Status der Ein/Ausgänge

Beschreibung

Das Kommando STATIO liefert den aktuellen Zustand der digitalen Ein-/Ausgänge des Servoverstärkers in folgender Reihenfolge:
IN1 IN2 IN3 IN4 ENABLE OUT1 OUT2

Eine 0 an der entsprechender Stelle bedeutet, daß der zugehörige Ein-/Ausgang den Zustand LOW aufweist, bei einer 1 ist der Zustand High.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Status (Fehler/Warnungen)

status

Hier werden der aktuelle Fehlerstatus und der Betriebsstundenzähler des Servoverstärkers angezeigt. Im Vergleich zum aktuellen Stand des Betriebsstundenzählers können Sie leicht ermitteln, wann ein Fehler aufgetreten ist.

Oben links sehen Sie die Fehlerhistorie mit dem Zeitpunkt des Fehlerauftretens in Betriebsstunden.

Oben rechts erhalten Sie eine Aussage über die Häufigkeit des Auftretens eines jeden Fehlers.

In der Mitte werden aktuell vorhandene Fehler-/Warnmeldungen gelistet.

Unten erhalten Sie bei definierten Fehlern eine erweiterte Fehlerinformationen (siehe ERRCODE2).
Die Schaltfläche "Fehlerdiagnose" öffnet die Hilfeseite "Trouble shooting"
Im Anhang finden Sie eine Auflistung der Fehler- und Warnmeldungen.

Zuordnungen von Warnungen zum Fehler F24...

Zur Definition der Fehlermeldung F24 (Bitvariable WMASK, siehe auch Kapitel Warnungen und Fehlermeldungen ) klicken Sie auf die Schaltfläche "Zuordnen von Warnungen zum Fehler F24..."

basis-fehler-f242

Sofortige Endstufensperrung bei Fehlern Fxx...

Zur Festlegung, welche Fehlermeldung zum sofortigen Abschalten der Endstufe führen (Bitvariable ERRCNFG, siehe auch Kapitel Fehlermeldungen ) klicken Sie auf die Schaltfläche "Sofortige Endstufen-Sperrung bei Fehlern Fxx.."

basis-fehler-f241


ASCII Deutsch STATUS

ASCII - Kommando | STATUS |
Syntax Senden | STATUS |
Syntax Empfangen | STATUS <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | Integer16 Integer32 Integer16 Integer16 Integer16 | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | int (=Word); long int (=DoubleWord) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.13 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | detaillierte Verstärker-Statusinformation

Beschreibung

Das Kommando STATUS liefert die erweiterte Status-Informationen in Form von 5 Statusvariablen im Hex-Format.

Wort Nr. 1 Format Hxxxx
Bit 0 =0 wenn Hardware-Enable gesetzt (Eingang „ENABLE“ = 24V)
Bit 1 =0 wenn Software-Enable gesetzt
Bit 2 Reserve
Bit 3 =0 wenn Verstärker betriebsbereit (BTB/kein Fehler)

Wort Nr. 2 Format Hxxxxxxxx
Bits 0...31 Fehlervariable (s. ERRCODE)

Wort Nr. 3 Format Hxxxx (Reserve, immer 0)
Wort Nr. 4 Format Hxxxx
=0 keine Service-Funktion aktiv
=1 Service-Funktion „konstanter Strom/konstante Drehzahl“ aktiv
=2 Tippbetrieb MJOX aktiv

Wort Nr. 5 Format Hxxxx

Bit Wertigkeit Bedeutung
0 0x0001 =1 Fahrsatz/Referenzfahrt/Tippbetrieb aktiv
1 0x0002 =1 Referenzpunkt gesetzt
2 0x0004 =1 Referenzschalter belegt (Home-Position)
3 0x0008 =1 IN-POSITION-Meldung
4 0x0010 =1 Position wurde gelatcht (positive Flanke)
5 0x0020 =1 Referenzfahrt läuft
6 0x0040 =1 Tippbetrieb läuft
7 0x0080 =1 Position wurde gelatcht (negative Flanke)
8...15 Reserve


ASCII Deutsch STEP

ASCII - Kommando | STEP |
Syntax Senden | STEP [Data] |
Syntax Empfangen | STEP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 Float Integer16 Float | CANBus Objektnummer | -
DIM | ms (DurationN) / rpm (velocityN) | PROFIBUS PNU | -
Bereich | Duration:0 to 32767; velocity:-VLIM to +VLIM | DPR | Nein
Default | Duration:1000; velocity1/2: 100/-100 |
Opmode | 0 | Datentyp Bus/DPR | Integer16 Float Integer16 Float
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | velocity loop | EEPROM | -
Kurzbeschreibung | Schritt Service - Betrieb

Beschreibung

Nur S700:

Mit dem STEP-Kommando kann eine Service-Funktion über die Betriebsart "digitale Drehzahlregelung" (OPMODE=0) realisiert werden. Das Kommando kann in folgenden Formen benutzt werden:
1. STEP
Das Kommando liefert die aktuellen Einstellungen für die Service-Funktion
2. STEP T1 V1
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 verstrichen ist, wird der digitale Drehzahlsollwert auf 0 gesetzt.
3. STEP T1 V1 T2 V2
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 abgelaufen ist, wird für die Dauer T2 (msek) der digitale Sollwert V2 (UPM) vorgegeben. Nachdem die Zeit T2 abgelaufen ist, fängt erneut der Zyklus T1/V1 an. Mit Hilfe dieses Kommando kann ein endloser Reversierbetrieb realisiert werden.
z.B: STEP 1000 500 1000 -500

Der Service-Betrieb kann immer mit dem STOP-Kommando abgebrochen werden.
Die Voraussetzung für die Ausführung des STEP-Kommandos ist die Betriebsart "digitale Drehzahlvorgabe".


ASCII Deutsch STOP

ASCII - Kommando | STOP |
Syntax Senden | STOP |
Syntax Empfangen | STOP | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 35FE (hex)
DIM | - | PROFIBUS PNU | 1854 (dec) IND = 1 (dec)
Bereich | - | DPR | 254 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | control commands | EEPROM | Nein
Kurzbeschreibung | Setzen des Sollwertes auf 0

Beschreibung

Das STOP-Kommando bricht die Bewegung des Antriebes ab. Abhängig von der gerade aktiven Betriebsart ist das Verhalten des Antriebes unterschiedlich.

1. OPMODE=0 (digitale Drehzahlvorgabe)
Das STOP-Kommando bewirkt das Setzen des Drehzahlsollwertes auf 0. Der Antrieb bremst mit der eingestellten Bremsrampe des Drehzahlreglers (DEC).

2. <OPMODE=2 (digitale Stromvorgabe)
Das STOP-Kommando bewirkt das Setzen des Stromsollwertes auf 0. Der Antrieb trudelt aus.

3. OPMODE=8 (interne Fahrsätze)
Das STOP-Kommando bewirkt den Abbruch des aktuellen Fahrsatzes (Tippbetrieb/Referenzfahrt).
Der Antrieb bremst mit der innerhalb des Fahrsatzes definierten Bremsrampe.
Der Fahrauftrag kann durch das Kommando CONTINUE oder durch einen digitalen Eingang mit INxMODE=22 zu Ende gefahren werden.

Bei Betriebsarten OPMODE=1,3,4,5,6,7 hat das STOP-Kommando keine Funktion.


ASCII Deutsch STOPMODE

ASCII - Kommando | STOPMODE |
Syntax Senden | STOPMODE [Data] |
Syntax Empfangen | STOPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35FF (hex)
DIM | - | PROFIBUS PNU | 1855 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 255 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Bremsverhalten bei Disable

Beschreibung

STOPMODE legt das Verhalten des Antriebes beim Disablen der Endstufe fest.
Es sind folgende Einstellungen möglich:
STOPMODE=0 die Endstufe wird sofort gesperrt, der Antreib trudelt aus.

STOPMODE=1 Der Antrieb wird drehzahlgeregelt auf die Drehzahl 0 heruntergefahren (Rampe DECDIS). Beim Unterschreiten der Stillstandschwelle VEL0 wird die Endstufe gesperrt. Die Endstufe wird auch dann gesperrt, wenn die Drehzahl VEL0 nicht innerhalb von 5 Sek erreicht werden konnte (Time-Out von 5 Sekunden).

Achtung: Dadurch, dass im Sensorless-Betrieb (FBTYPE=10) die Geschwindigkeit-Schätzung bei kleinen Drehzahlen nicht möglich ist, wird als Kriterium nicht der Istwert sondern der Sollwert der Drehzahl benutzt.
Um aber sicher zu sein, dass der Antrieb tatsächlich steht, wird nach dem der Drehzahl-Sollwert die Schwelle VEL0 unterschritten hatte, eine Zeit gestartet. Erst wenn diese Zeit abgelaufen ist, geht man davon aus, dass der Antrieb tatsächlich steht und die Endstufe gesperrt werden kann. Die Verzögerungszeit leitet sich vom EMRGTO-Wert ab.


kms

Kundensupport

Wir wollen Ihnen einen optimalen und schnellen Service bieten. Nehmen Sie daher bitte Kontakt zu dem für Sie zuständigen Vertriebszentrum auf. Sollten Sie diese nicht kennen, kontaktieren Sie bitte den europäischen oder nordamerikanischen Kundendienst.

Hilfe und viele weitere Erklärungen finden Sie auch im Kollmorgen Developers Network (KDN): https://kdn.kollmorgen.com/

Aktuelle und historische Dokumente können Sie aus unserem Dokumentenarchiv herunterladen: http://www.wiki-kollmorgen.eu/wiki/tiki-index.php.

KOLLMORGEN Kundendienst - Europa

Internet | www.kollmorgen.com
E-Mail | technik@kollmorgen.com
Tel.: | +49(0)2102 - 9394 - 0
Fax: | +49(0)2102 - 9394 - 3155

KOLLMORGEN Customer Support North America

Internet | www.kollmorgen.com
E-Mail | support@kollmorgen.com
Tel.: | +1 - 540 - 633 - 3545
Fax: | +1 - 540 - 639 - 4162


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Firmware Upgrade

Upgrades des Servoverstärkers erfordern das Hilfsprogramm DriveUpgradeTool_....exe. Während der Installation der Inbetriebnahme-Software wird das Tool standardmäßig installiert (Aufruf über das Windows-Startmenü). Quelldateien für Firmware Upgrades sind auf der CDROM und Website vorhanden, ältere Firmware Versionen (sofern frei verfügbar) finden Sie im Europäischen Dateiarchiv.

Mit diesem Tool können Sie Firmware Upgrade, Motordatenbank Upgrade, Fahrprofiltabelle Upgrade und PLC (Makro) Programm Upgrade durchführen. Mögliche Schnittstellen sind Serielle PC Schnittstelle (COM1...10) mit seriellem Standard-Kabel (Null-Modem) oder mit USB-Seriell Wandler.

Vorausssetzung: Microsoft DotNet Version 3.5 oder höher muss installiert sein.

Vorbereitung für die serielle Übertragung

  • Leistungsspannung muss abgeschaltet sein.
  • Zwischenkreisspannung muss <100V sein.
  • 24 VDC Hilfsspannungsversorgung für den Servoverstärker muss eingeschaltet sein.
  • Eine serielle RS-232 Verbindung (null Modem) zwischen PC und Servoverstärker (X6) muss existieren.
  • Die verwendete RS232 Schnittstelle darf nicht gleichzeitig von einer anderen Software benutzt werden.
  • Das Hilfsprogramm DriveUpgradeTool und die Quelldatei, mit der der Servoverstärker aktualisiert werden soll, müssen auf Ihrem PC gespeichert sein.
  • Parameter und Fahrsätze müssen im EEPROM oder in externen Dateien gespeichert sein, das Flash EPROM wird gelöscht. Wenn Sie sich über die Sicherung der Parameter nicht sicher sind, starten Sie die Inbetriebnahme-Software des Servoverstärkers, speichern Sie Parameter und Fahrsätze im EEPROM, schließen Sie die Inbetriebnahme Software wieder.

Upgrade

Starten Sie das Programm DriveUpgradeTool.

screen300

1. Wählen Sie den Servoverstärkertyp aus (Drive Type).

2. Wählen Sie den Dateityp aus, die in den Verstärker geladen werden soll (Type of file to download).

3. Wählen Sie die Schnittstelle, an der der Servoverstärker angeschlossen ist.

4. Klicken Sie auf die Browse+Download Schaltfläche zur Auswahl der Datei.

Achtung! Verwenden Sie die korrekte Datei für Ihr Vorhaben.
Beispiel:
Verwenden Sie keine Motordatenbank für ein Firmware-Upgrade.

5. Der Download Prozess ist gestartet. Im Hinweisfenster können Sie den Vorgang verfolgen.

Das Hilfsprogramm startet nun die Initialisierung der Kommunikation und bereitet den Verstärker vor. Der Verstärker meldet diese Phase mit ‘-‘ in der ersten Stelle der LED Anzeige in der Frontplatte oder mit “del”. Nach Abschluss der Vorbereitungsphase wandert das ‘-‘ in die mittlere Position oder ein “Prg” erscheint in der LED Anzeige in der Frontplatte. Die Übertragung der Daten beginnt. Das Hilfsprogramm meldet mit einem Ladebalken den Status.

Wenn die Übertragung beendet ist, wird dies im Hilfsprogramm gemeldet:

upgrade2

Starten Sie den Servoverstärker neu (24V Versorgung aus und wieder einschalten). Schließen Sie das Hilfsprogramm und nehmen Sie den Servoverstärker wie gewohnt für Ihre Anwendung in Betrieb.


ASCII Deutsch SWCNFG

ASCII - Kommando | SWCNFG |
Syntax Senden | SWCNFG [Data] |
Syntax Empfangen | SWCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned16 | CANBus Objektnummer | 3600 (hex)
DIM | - | PROFIBUS PNU | 1856 (dec) IND = 1 (dec)
Bereich | 0 .. 65535 | DPR | 256 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Konfiguration der Software-Endschalter

Beschreibung

Konfiguration der Software-Endschalter

Die SWCNFG-Variable kann als eine Bit-Variable betrachtet werden. Die einzelnen Bits haben folgende Bedeutung:

Bit 0 =1 Software Endschalter 1 aktiv
Bit 1 =1 Software Endschalter 2 aktiv

Die Softwarendschalter wirken erst nach Setzen des Referenzpunktes.

siehe auch SWE1, SWE2


ASCII Deutsch SWE1

ASCII - Kommando | SWE1 |
Syntax Senden | SWE1 [Data] |
Syntax Empfangen | SWE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3604 (hex)
DIM | - | PROFIBUS PNU | 1860 (dec) IND = 1 (dec)
Bereich | long int | DPR | 260 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Softwareendschalter (kleinste Position)

Beschreibung

Die Variable SWE1 enthält den Positionswert für den Softwareendschalter
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE1[Inkremente] = SWE1[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

SWE1 < SWE2

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE2

ASCII - Kommando | SWE2 |
Syntax Senden | SWE2 [Data] |
Syntax Empfangen | SWE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3606 (hex)
DIM | - | PROFIBUS PNU | 1862 (dec) IND = 1 (dec)
Bereich | long int | DPR | 262 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Softwareendschalter (größte Position)

Beschreibung

Die Variable SWE2 enthält den Positionswert für den Softwareendschalter.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE2[Inkremente] = SWE2[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

SWE1 < SWE2

s. auch Beschreibung von SWCNFG


ASCII Deutsch SYNCSRC

ASCII - Kommando | SYNCSRC |
Syntax Senden | SYNCSRC [Data] |
Syntax Empfangen | SYNCSRC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3683 (hex)
DIM | - | PROFIBUS PNU | 1987 (dec) IND = 1 (dec)
Bereich | 0 .. 10 | DPR | 387 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Quelle der Synchronisation

Beschreibung

Dieser Parameter gibt die Quelle der Synchronisation an, falls die Regelkreise des Servoverstärkers über eine Interface synchronisiert wird. Der Parameter wird erst nach dem Speichern und einem Neustart des Reglers wirksam.

0: Keine Synchronisation
1: (reserviert) Synchronisation über Sercos
2: Synchronisation über KS3000 Fire-Wire Karte
3: Synchronisation über CANopen
4: Alte DPR Karte
5: Neue DPR Karte (z.B. EtherCAT Wire Karte)
6: Neue DPR Karten mit Aquarius Protokoll (EtherCat)


ASCII Deutsch T

ASCII - Kommando | T |
Syntax Senden | T [Data] |
Syntax Empfangen | T <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 360E (hex)
DIM | A | PROFIBUS PNU | 1870 (dec) IND = 1 (dec)
Bereich | -DIPEAK .. DIPEAK | DPR | 270 (dec)
Default | - |
Opmode | 2 | Datentyp Bus/DPR | Integer32
Verstärker Status | Enabled | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | current loop | EEPROM | Nein
Kurzbeschreibung | Digitaler Stromsollwert

Beschreibung

Mit dem Kommando "T <i>" kann ein konstanter Stromsollwert <i> (in A) vorgegeben werden.
Der vorgegeben Stromsollwert gilt solange, bis ein neues T / STOP / OPMODE-Kommando übertragen wird.


ASCII Deutsch TASK

ASCII - Kommando | TASK |
Syntax Senden | TASK |
Syntax Empfangen | TASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 360F (hex)
DIM | - | PROFIBUS PNU | 1871 (dec) IND = 1 (dec)
Bereich | max 80 ASCII Characters | DPR | 271 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Task-Auslastung

Beschreibung

Mit dem Kommando TASK wird die Auslastung der einzelnen Firmware-Tasks angezeigt.
Die Zahlen bedeuten Anzahl der Funktionsdurchläufe pro Sekunde.


ASCII Deutsch TBRAKE

ASCII - Kommando | TBRAKE |
Syntax Senden | TBRAKE [Data] |
Syntax Empfangen | TBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366E (hex)
DIM | ms | PROFIBUS PNU | 1966 (dec) IND = 1 (dec)
Bereich | 10 .. 10000 | DPR | 366 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Disableverzögerungszeit bei Bremsenbetrieb

Beschreibung

Der Parameter TBRAKE definiert eine Bremsen-Reaktionszeit.
Beim Disablen des Verstärkers (Hardware/Software-Disable) steuert der Verstärker die externe Bremse an. Nachdem der Antrieb gestoppt wurde, wird die Bremse ausgeschaltet. Gleichzeitig wird ein interner Timer mit der Zeit TBRAKE geladen. Erst nachdem die eingestellte Zeit abgelaufen ist, wird die Endstufe gesperrt.


ASCII Deutsch TBRAKE0

ASCII - Kommando | TBRAKE0 |
Syntax Senden | TBRAKE0 [Data] |
Syntax Empfangen | TBRAKE0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366F (hex)
DIM | ms | PROFIBUS PNU | 1967 (dec) IND = 1 (dec)
Bereich | -10 .. 10000 | DPR | 367 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | motor | EEPROM | Ja
Kurzbeschreibung | Bremsen Lüftzeit

Beschreibung

Der Parameter TBRAKE0 definiert eine Reaktionszeit der Bremse beim Lüft-Vorgang.
Beim Freigeben der Endstufe (Hardware/Software-Enable) steuert der Verstärker die externe Bremse an. Während der eingestellten Zeit TBRAKE0 wird der interne Sollwert auf 0 gehalten. Erst nachdem die eingestellte Zeit abgelaufen ist und die Bremse vollständig geöffnet ist, wird der Sollwert akzeptiert und der Antrieb kann bewegt werden.

Achtung:
Ein zu großer Wert für TBRAKE0 kann bei einer vertikalen Achse mit Last ein Absinken verursachen!

Bei Eingabe einer Zeit < 0 wird der Sollwert freigeschaltet, bevor die Bremse angesteuert wurde


ASCII Deutsch TEMPE

ASCII - Kommando | TEMPE |
Syntax Senden | TEMPE |
Syntax Empfangen | TEMPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3610 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1872 (dec) IND = 1 (dec)
Bereich | -20 .. 90 | DPR | 272 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | temperatures | EEPROM | Nein
Kurzbeschreibung | Istwert der Umgebungstemperatur

Beschreibung

Anzeige der aktuellen Innentemperatur in °C.


ASCII Deutsch TEMPH

ASCII - Kommando | TEMPH |
Syntax Senden | TEMPH |
Syntax Empfangen | TEMPH <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3611 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1873 (dec) IND = 1 (dec)
Bereich | -20 .. 90 | DPR | 273 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | temperatures | EEPROM | Nein
Kurzbeschreibung | Istwert der Kühlkörpertemperatur

Beschreibung

Anzeige der aktuellen Kühlkörpertemperatur in °C.


ASCII Deutsch TEMPM

ASCII - Kommando | TEMPM |
Syntax Senden | TEMPM |
Syntax Empfangen | TEMPM <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3612 (hex)
DIM | Ohms or [MTAB units] | PROFIBUS PNU | 1874 (dec) IND = 1 (dec)
Bereich | 0 .. 10000 | DPR | 274 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | temperatures | EEPROM | Nein
Kurzbeschreibung | Istwert der Motortemperatur

Beschreibung

Der Istwert der Motortemperatur als Widerstand des Temperaturfühlers (in Ohm) angezeigt. Bei vorhandener Temperarurkennlinie (siehe MTAB) ändern sich die Einheiten für die Parameter MAXTEMPM und TEMPM von Ohm auf die Einheit, die bei der Kennliniendefinition verwendet wurde.

siehe auch MAXTEMPM, MTAB


ASCII Deutsch TEMPMFILT

ASCII - Kommando | TEMPMFILT |
Syntax Senden | TEMPMFILT [Data] |
Syntax Empfangen | TEMPMFILT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38BB (hex)
DIM | ms | PROFIBUS PNU | 1755 (dec) IND = 33 (dec)
Bereich | 0 .. 50000 | DPR | 955 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.18 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | temperatures | EEPROM | Ja
Kurzbeschreibung | Zeitkonstante zur Filterung von Temp Motorsensoren

Beschreibung

Der Parameter TEMPMFILT beschreibt die Zeitkonstante zur Messwertfilterung bei Motortemperatur Sensoren. Damit werden Störungen auf der Messleitung unterdrückt. Der gefilterte Wert wird sowohl für die Motortemperatur Überwachung als auch für die Temperatur Anzeige genutzt.


ASCII Deutsch TEN

ASCII - Kommando | TEN |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | - |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Terminal

terminal

Kommunikation mit dem Servoverstärker über ASCII-Kommandos. Eine vollständige ASCII-Objektreferenz ist in der Online Hilfe, auf der Produkt-CDROM und als Download auf unserer Website zu finden.

An den Servoverstärker gesendete Kommandos werden mit dem Zeichen "-->" gekennzeichnet, die Antworten des Servoverstärkers erscheinen ohne vorangestelltes Zeichen. Dargestellt werden die letzten 2000 Zeilen.

Kommando
Geben Sie hier das ASCII Kommando mit Parametern ein. Beenden Sie die Eingabe mit RETURN oder betätigen Sie den Button ÜBERNEHMEN zum Start der Übertragung.

Das Terminal Programm sollte nur von Experten genutzt werden. Es erfolgt oft keine Sicherheitsabfrage.

Durch Betätigen der Funktionstaste F3 lassen sich die zuletzt eingegebenen Befehle (max. 100) erneut aufrufen.


ASCII Deutsch TEST1

ASCII - Kommando | TEST1 |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch TESTENC

ASCII - Kommando | TESTENC |
Syntax Senden | TESTENC |
Syntax Empfangen | TESTENC | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | - | DPR | Nein
Default | - |
Opmode | 2 | Datentyp Bus/DPR | Command
Verstärker Status | Enable | Wichtung |
ab Firmware | 5.90 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Feedback & Motortest

Beschreibung

Feedback-/Motortest bietet die Möglichkeit eines Verdrahtungstests für den Geber- bzw. Motoranschluss. Beim Starten der Funktion wird im Stromreglermode (OPMODE=2) bei freigegebener Endstufe eine langsame Bewegung des Motors initiiert. Die Bewegung erfolgt rein gesteuert ohne Beteiligung des Positionsgebers (U/F-Mode). Die eingelesene Geberposition wird lediglich für die Auswertungszwecke beobachtet und aufgezeichnet. Anhand der Positionsdaten kann die Geberauflösung, Zählrichtung sowie der Geberanschluss kontrolliert werden. Bei Gebern, die sowohl digitale als auch analoge Informationen liefern (Endat2.1, Hiperface, BiSS-B) kann es vorkommen, dass bei fehlerhaftem Anschluss der analogen Spuren, lediglich die Positioniergenauigkeit verloren geht. Der Antrieb kann trotzdem problemlos betrieben werden. Je nach Auflösung des Gebersystems lassen sich solche Verdrahtungsfehler schwer finden. Die vorliegende Testfunktion liest kontinuierlich sowohl die analogen (falls vorhanden) als auch die digitalen Positionsinformationen des Gebers und kontrolliert sie auf ihre Plausibilität. Bei Abweichungen versucht sie die Ursache des Problems zu ermitteln.

Folgende Parametrierungen sind notwendig damit der Test durchgeführt werden kann:
- Korrekter Feedbacktyp (FBTYPE)
- Korrekte Parametrierung des Stromreglers
- Positive Geber-Zählrichtung
(DIR=21)- Korrekte Motorpolpaarzahl (MPOLES)


ASCII English BQMODE

BQMODE=2

The transfer function is

           s
       ---------- + 1
       2*pi*ARHPF
G(s) = --------------
           s
       ---------- + 1

2*pi*ARLPF

T

BQMODE=3

The transfer function is

             s       2                   s
       ( ---------- )  + 2 * ARHPD * ---------- + 1
         2*pi*ARHPF                  2*pi*ARHPF
G(s) = --------------------------------------------
             s       2                   s
       ( ---------- )  + 2 * ARLPD * ---------- + 1

2*pi*ARLPF 2*pi*ARLPF

BQMODE=4

The transfer function is

                           1
G(s) = --------------------------------------------
             s       2                   s
       ( ---------- )  + 2 * ARLPD * ---------- + 1

2*pi*ARLPF 2*pi*ARLPF


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Onlinehilfe zur Inbetriebnahme-Software DriveGUI.exe

gültig für DRIVEGUI.EXE Version 3.3.2, Ausgabe Mai 2018

Dieses Dokument wurde als Original in deutscher Sprache erstellt.

Inhalt

Allgemeines | Bildschirmseiten
Einführung | Setup Wizard
Bedienung | — Basiseinstellungen, Parameterumschaltung
Sicherheitshinweise | — Einheiten
ASCII Objekt-Referenz | — CAN- / Feldbus-Einstellungen
Übersicht Servoantriebe | — U/f-Steuerung
 | — Motor / Feedback
Installation | — Feedback, Wake&Shake, Test&Diagnose
Hardware-Installation | — Motor, Feldschwächung, Cogging
Software-Installation | — Stromregler
Verstärker einschalten | — Drehzahlregler
 | — Lageregler, Erweiterung
Bedienung | — Positionierdaten
Start der Software | — Positionsregister
Online/Offline arbeiten | — Elektron. Getriebe
Bildschirmaufbau | — Encoder-Emulation
Hilfe Funktionen | — I/O analog
 | — I/O digital
Applikations-Hinweise | Service-Funktionen
Antriebsberechnung | Status (Fehler/Warnungen)
Servopumpe | Monitor
Makroprogrammierung | Einrichtbetrieb
Inbetriebnahme unbekannter Motoren | Fahraufträge
Software Upgrade | Oszilloskop
 | Bode-Plot
Anhang | Terminal
Glossar | I/O Erweiterungskarte
Weiterführende Dokumentationen | SERCOS
Fehlermeldungen | PROFIBUS
Warnungen | EtherCAT
Trouble Shooting | Autotuning
 | Safety Karte
 | SD Karte


ASCII Deutsch TRJSTAT

ASCII - Kommando | TRJSTAT |
Syntax Senden | TRJSTAT |
Syntax Empfangen | TRJSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3613 (hex)
DIM | - | PROFIBUS PNU | 1875 (dec) IND = 1 (dec)
Bereich | 0 .. 0xFFFFFFFF | DPR | 275 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Status2-Information

Beschreibung

Das Kommando TRJSTAT liefert die internen Status-Informationen in Form einer Bit-Variable. Die Statusinformationen werden vorwiegend für interne Funktionen benutzt. Ausschließlich Bits, die mit einem ´*´ markiert wurden, können für externe Funktionen (Steuerung) benutzt werden. Die Bits 16...20 werden zusätzlich in der Statusvariable DRVSTAT gespiegelt.
Bit | Wertigkeit | Bedeutung
0 | 0x00000001 | =1 innerhalb der nächsten msek wird der Ausgang INPOS2 aktualisiert.
1 | 0x00000002 | =1 Am Ende des aktuellen Fahrsatzes wird keine „In-Position“-Meldung ausgegeben (es ist ein Folgefahrsatz vorhanden).
2* | 0x00000004 | =1 Toggle Bit "Fahrsatz abgeschlossen" Wird am Ende eines Fahrsatzes invertiert. Im Gegensatz zu der "In-Position"-Meldung erfolgt das Invertieren des Bits nicht bereits beim Erreichen des In-Position-Fensters, sondern erst beim Erreichen der Zielposition und Abschalten des Trajektoriengenerators. Nach dem Einschalten des Verstärkers ist dieses Bit zunächst auf low.
3...15 |  | Reserve
16* | 0x00010000 | =1 Auftrag aktiv (Lageregelung) wird gesetzt sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt). Wird gelöscht wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
17* | 0x00020000 | =1 Referenzpunkt gesetzt gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn). Wird gelöscht beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt. Dieses Bit bedeutet NICHT: Referenzfahrt abgeschlossen. Siehe Bit 21
18* | 0x00040000 | =1 Home-Position ist gesetzt solange der Referenzschalter belegt ist. Wird gelöscht sobald der Referenzschalter nicht belegt.
19* | 0x00080000 | =1 In-Position wird gesetzt sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS. Wird gelöscht sobald der Abstand größer als PEINPOS. Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
20* | 0x00100000 | =1 Positionslatch erfolgte (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH2P16 / LATCH2P32)
21* | 0x00200000 | =1 Referenzfahrt läuft wird gesetzt sobald eine Referenzfahrt gestartet wurde. Wird gelöscht sobald die Referenzfahrt abgeschlossen bzw. abgebrochen (STOP) wurde.
22* | 0x00400000 | =1 Tippbetrieb läuft wird gesetzt sobald der Tippbetrieb gestartet wurde. Wird gelöscht sobald der Tippbetrieb abgebrochen (STOP) wurde.
23 | 0x00800000 | =1 Positionslatch erfolgte (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH2N16 / LATCH2N32)
24 | 0x01000000 | =1 Nothaltphase aktiv wird gesetzt, während der Nothalt-Prozedur (Bremsphase nach einem Fehler, bei aktiven Endschalter bzw. wenn der Eingang „Nothalt“ den Zustand 0 aufweist).
25 | 0x02000000 | =1 Positionslatch auf Input 1 (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCH1P16 / LATCH1P32)
26 | 0x04000000 | =1 Positionslatch auf Input 1 (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCH1N16N /
27 | 0x08000000 | Reserve
28 | 0x10000000 | = 1 (REFDONE) Dieses Bit wird gesetzt am Ende einer Referenzfahrt, d.h. nachdem der Referenzpunkt gesetzt wurde und der Stillstand erreicht wurde. = 0 Beim Starten eines Fahrsatzes bzw. einer Referenzfahrt/ Tippbetriebes.
29 | 0x20000000 | =1 Antrieb befindet sich in der Beschleunigungsphase eines Fahrsatzes
30 | 0x40000000 | =1 Antrieb befindet sich in der Bremsphase eines Fahrsatzes


ASCII Deutsch TRUN

ASCII - Kommando | TRUN |
Syntax Senden | TRUN |
Syntax Empfangen | TRUN <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | hhhhh:mm | PROFIBUS PNU | -
Bereich | 00000:00 to 99999:45 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Betriebsstundenzähler in min

Beschreibung

Der Betriebsstundenzähler zeigt die Lebens-Laufzeit des Verstärkers in Minuten an. Er wird hochgezählt, wenn die 24V - Versorgung eingeschaltet ist
Die interne Auflösung des Betriebsstundenzählers beträgt 1 Sekunde.
Da der Betriebsstundenzähler im seriellen EEPROM des Verstärkers untergebracht ist, wird er nur alle 8 Minuten ins EEPROM geschrieben. Durch Ausschalten der 24 Volt-Versorgung gehen maximal 8 Minuten verloren.


ASCII Deutsch TRUNS

ASCII - Kommando | TRUNS |
Syntax Senden | TRUN |
Syntax Empfangen | TRUNS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3614 (hex)
DIM | hhhhh:mm | PROFIBUS PNU | 1876 (dec) IND = 1 (dec)
Bereich | 00000:00 to 99999:45 | DPR | 276 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Betriebsstundenzähler in s

Beschreibung

FW >=1.61
Der Betriebsstundenzähler zeigt die Lebens-Laufzeit des Verstärkers in Sekunden an. Er wird hochgezählt, wenn die 24V - Versorgung eingeschaltet ist
Die interne Auflösung des Betriebsstundenzählers beträgt 1 Sekunde.
Da der Betriebsstundenzähler im seriellen EEPROM des Verstärkers untergebracht ist, wird er nur alle 8 Minuten ins EEPROM geschrieben. Durch Ausschalten der 24 Volt-Versorgung gehen maximal 8 Minuten verloren.


ASCII Deutsch TSTEP

ASCII - Kommando | TSTEP |
Syntax Senden | TSTEP [Data] |
Syntax Empfangen | TSTEP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 Float Integer16 Float | CANBus Objektnummer | -
DIM | ms (DurationN) / As (CurrentN) | PROFIBUS PNU | -
Bereich | Duration:0 to 32767; Current:IPEAKN to IPEAKP | DPR | Nein
Default | - |
Opmode | 2 | Datentyp Bus/DPR | Integer16 Float Integer16 Float
Verstärker Status | Enabled | Wichtung |
ab Firmware | 2.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | current loop | EEPROM | Nein
Kurzbeschreibung | Service-Betrieb Dremomentschritte

Beschreibung

S700 und S300 ab FW 2.32:

Mit dem TSTEP-Kommando kann eine Service-Funktion über die Betriebsart "digitale Drehmomentregelung" (OPMODE=2) realisiert werden. Das Kommando kann in folgenden Formen benutzt werden:
1. TSTEP
Das Kommando liefert die aktuellen Einstellungen für die Service-Funktion
2. TSTEP T1 C1
Für die Dauer T1 (msek) wird ein digitaler Sollwert C1 (A) vorgegeben. Nachdem die Zeit T1 verstrichen ist, wird der digitale Stromsollwert auf 0 gesetzt.
3. TSTEP T1 C1 T2 C2
Für die Dauer T1 (msek) wird ein digitaler Sollwert C1 (A) vorgegeben. Nachdem die Zeit T1 abgelaufen ist, wird für die Dauer T2 (msek) der digitale Sollwert C2 (A) vorgegeben. Nachdem die Zeit T2 abgelaufen ist, fängt erneut der Zyklus T1/C1 an. Mit Hilfe dieses Kommando kann ein endloser Reversierbetrieb realisiert werden (rechteckförmiger Drehmomentverlauf und dreieckförmiger Drehzahlverlauf; T1 und T2 müssen so kurz gewählt werden, dass der Motor nicht jenseits von +/-VOSPD beschleunigt werden kann, andernfalls wird der Fehler F08 augelöst).
z.B: TSTEP 100 0.5 100 -0.5

Der Service-Betrieb kann immer mit dem STOP-Kommando abgebrochen werden.
Die Voraussetzung für die Ausführung des TSTEP-Kommandos ist die Betriebsart "digitale Drehmomentvorgabe".


ASCII Deutsch UCOMP

ASCII - Kommando | UCOMP |
Syntax Senden | UCOMP [Data] |
Syntax Empfangen | UCOMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3631 (hex)
DIM | PUNIT | PROFIBUS PNU | 1905 (dec) IND = 1 (dec)
Bereich |  | DPR | 305 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.14 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Umkehrlose Kompensation

Beschreibung

Bei manchen Anwendungen ist es erforderlich, daß Fahrsatzpositionen immer nur von einer bestimmten Seite angefahren werden (Korrektur von Fehlern die im Zusammenspiel Zahnstange/ Zahnrad auftreten). Dazu wird beim Start eines Fahrsatzes je nach Fahrtrichtung die Zielposition des Fahrsatzes um einen Korrekturwert verschoben und erst nachdem diese korrigierte Zielposition erreicht wurde, ein Fahrsatz in die echte Zielposition gestartet. Das Verhalten dieser Funktion wird von dem Parameter UCOMP gesteuert. Der Betrag dieses Parameters gibt den Korrekturwert vor, das Vorzeichen: die Richtung bei der diese Korrektur vorgenommen werden soll. Bei einem positiven Vorzeichen erfolgt die Korrektur nur bei positiven Geschwindigkeiten (d.h. die Zielposition wird immer von Rechts angefahren), bei einem negativen Vorzeichen : nur bei negativen Geschwindigkeiten. Um diese Funktion abzuschalten muß der Parameter UCOMP auf 0 stehen (Defaultwert).
z.B.:
1. Istposition=0, Zielposition=1000, UCOMP =100 -> der Antrieb fährt in die Position 1100, dreht um und bleibt bei 1000 stehen.
2. Istposition=1000, Zielposition=0, UCOMP =100 -> der Antrieb fährt direkt in die Position 0
3. Istposition=1000, Zielposition=0, UCOMP= -100 -> der Antrieb fährt in die Position –100, dreht um und bleibt bei 0 stehen.


ASCII Deutsch UID

ASCII - Kommando | UID |
Syntax Senden | UID [Data] |
Syntax Empfangen | UID <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3616 (hex)
DIM | All | PROFIBUS PNU | 1878 (dec) IND = 1 (dec)
Bereich | -32768 .. 32767 | DPR | 278 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Benutzerkennung

Beschreibung

Die Variable UID dient zum Erkennen von Kunden. Manche Kunden haben bereits festgelegte Nummern.


ASCII Deutsch UMAX

ASCII - Kommando | UMAX |
Syntax Senden | UMAX [Data] |
Syntax Empfangen | UMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 2000 | DPR | Nein
Default | 1900 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | other commands | EEPROM |
Kurzbeschreibung | maximale Ausgangsspannung bei Fledschwächung

Beschreibung

UMAX ist ein Parameter zum Betrieb von Asynchronmaschinen und beschreibt die maximale Ausgangsspannung.

Nur bei Feldschwächung aktiv!


DriveGui Online Help

HilfeStartseite

Bewerten Sie uns

Einheiten

einheiten

Die Benutzer-Einheiten für alle Eingaben innerhalb der Inbetriebnahmesoftware werden hier vorgewählt.

Bildschirmtext | ASCII-Parameter
Lage | PUNIT
Geschwindigkeit | VUNIT
Beschleunigung | ACCUNIT
Lageregler-Auflösung (Zähler) | PGEARI
Lageregler-Auflösung (Nenner) | PGEARO

Die Einstellung der Auflösung hängt von der jeweiligen Anwendung ab.

Berechnung der Auflösung

Klicken Sie auf die große Schaltfläche, die das aktuelle Applikationmodell zeigt.

Sollte Ihre Applikation keinem der aufgeführten Beispiele entsprechen, geben Sie die erforderlichen Parameter direkt in die Felder der Bildschirmseite "Einheiten" ein.

Wählen Sie zunächst die Ihrer Applikation entsprechende Anwendung. Danach stellen Sie die Lage-Einheit ein. Wählen Sie die Lage-Einheit, mit der Sie die benötigte Genauigkeit Ihrer Applikation darstellen können.

Beispiel |
max. Genauigkeit | 50nm
Lage-Einheit | 10nm

Wenn Sie den Applikationstyp wechseln, kann es vorkommen, dass die gewählte Lage-Einheit nicht zulässig ist. In diesen Fällen bleibt das Eingabefenster Lage-Einheit leer und Sie müssen eine neue Einheit anwählen.

Spindel

Antrieb der Last über eine Gewindespindel.
Geben Sie die Steigung der Spindel ein. Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Förderband

Geben Sie den Durchmesser der Antriebswelle ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Riemenantrieb

Geben Sie die Durchmesser der Antriebs- und der Abtriebs-Riemenscheibe ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Zahnriemen

Geben Sie die Anzahl der Zähne pro Umdrehung des Antriebszahnrades und die Anzahl der Zähne pro Längeneinheit ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Zahnriemen2

Geben Sie die Anzahl der Zähne des Antriebs- und des Abtriebszahnrades ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Endlosband

Geben Sie den Durchmesser der Antriebswelle ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Rotatorischer Direktantrieb

Bei Auswahl einer Längen-Lage-Einheit geben Sie den relevanten Radius für die zu verfahrende Strecke an.
Bei der Lage-Einheit ° (Grad) ist keine weitere Eingabe erforderlich.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Linearer Direktantrieb

Die Polpaar-Breite und die Encoder-Signalperiode sind geräteabhängig und werden auf den Bidschirmseiten Motor bzw- Feedback eingestellt.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Zahnstange

Geben Sie die Anzahl der Zähne pro Umdrehung des Antriebszahnrades und die Anzahl der Zähne pro Längeneinheit ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".

Scheibe

Geben Sie den Radius der montierten Scheibe ein.

Wenn ein Getriebe am Motor angeflanscht ist, geben Sie zusätzlich die Getriebedaten ein, entweder die Anzahl der Zähne oder das Verhältnis der Umdrehungen.

Klicken Sie anschließend auf die Schaltfläche "Umrechnungsfaktoren berechnen und schließen".


ASCII Deutsch UPDATE

ASCII - Kommando | UPDATE |
Syntax Senden | UPDATE [Data] |
Syntax Empfangen | UPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | Name | PROFIBUS PNU | -
Bereich | ALL,USER,TABLE,PROG,PORDER,MBASE,Lookup | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Firmware-Update über RS232

Beschreibung

Das UPDATE-Kommando ermöglicht das Programmieren des internen Flash-EPROMS über die serielle Schnittstelle.

Vorgehensweise beim Software-Update:

1. Anschluß des Reglers an die serielle Schnittstelle eines PC´s
2. Starten des Terminalprogrammes HINT2.EXE COM2: 38400 (der Rechner sollte im DOS-Mode gestartet werden).
Damit wird die Verbindung zwischen dem PC und dem Kommandointerpreter des Verstärkers hergestellt. Um die Verbindung zu überprüfen, kann das Kommando LIST eingegeben werden. Als Antwort sollte auf dem Bildschirm eine Liste mit verfügbaren Kommandos erscheinen.
3. Eingabe des Kommandos UPDATE ALL xxxx in der Kommandozeile.
xxxx - Name der zu programmierenden Firmware-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name ALL benutzt.

Achtung !!! Beim Programmieren mit ALL werden auch die bereits gespeicherten Fahrsätze gelöscht. Diese müssen vor der Programmierung über das Bedienprogramm gerettet und nachher wieder eingespielt werden.

Das Programmieren dauert ca. 40 Minuten.

Während des Programmiervorganges werden die programmierten Adressen angezeigt. Falls die Anzeige stehenbleibt, ohne daß der download abgeschlossen wurde (dieses Problem wurde bei manchen PC´s beobachtet), sollte die ENTER-Taste betätigt werden. Danach wird das Programmieren fortgesetzt.
Falls der Programmiervorgang vorzeitig abgebrochen wird, so meldet sich der Verstärker beim nächsten Einschalten mit dem Monitorprogramm („-„ Zeichen auf der ersten Stelle des Displays).
In diesem Fall kann der Download mit folgender Kommandofolge neu gestartet werden:
X: xxxx
xxxx Name der zu programmierenden Firmware-Datei
Vorgehensweise beim Laden einer Motordatenbank:

Eine Standard-Motordatenbank ist ein Bestandteil der Firmware. Falls eine kundenspezifische Motordatenbank benötigt wird, so kann sie nach dem Programmieren der Firmware nachgeladen werden.
Dazu muß folgendes Kommando eingegeben werden:

UPDATE MBASE xxxx

xxxx - Name der zu programmierenden Motordatenbank-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name MBASE benutzt.


ASCII Deutsch UVLTMODE

ASCII - Kommando | UVLTMODE |
Syntax Senden | UVLTMODE [Data] |
Syntax Empfangen | UVLTMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3617 (hex)
DIM | - | PROFIBUS PNU | 1879 (dec) IND = 1 (dec)
Bereich | 0, 1 | DPR | 279 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Unterspannungsmodus

Beschreibung

Die Konfigurationsvariable UVLTMODE aktiviert bzw. sperrt die Unterspannungsüberwachung des Verstärkers. Bei aktivierter Überwachung (UVLTMODE=1) wird die Fehlermeldung F05 (Unterspannung) generiert, sobald die Zwischenkreisspannung die Unterspannungsschwelle VBUSMIN bei aktivierter Endstufe unterschreitet.


ASCII Deutsch V

ASCII - Kommando | V |
Syntax Senden | V |
Syntax Empfangen | V <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3618 (hex)
DIM | MSPEED | PROFIBUS PNU | 1880 (dec) IND = 1 (dec)
Bereich | -15000 .. 15000 | DPR | 280 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Aktuelle Drehzahl

Beschreibung

Die aktuelle Drehzahl des Motors.


ASCII Deutsch VBUS

ASCII - Kommando | VBUS |
Syntax Senden | VBUS |
Syntax Empfangen | VBUS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361A (hex)
DIM | V | PROFIBUS PNU | 1882 (dec) IND = 1 (dec)
Bereich | 0 .. 900 | DPR | 282 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | actual values | EEPROM | Nein
Kurzbeschreibung | Zwischenkreisspannung

Beschreibung

Die aktuelle Zwischenkreisspannung.


ASCII Deutsch VBUSBAL

ASCII - Kommando | VBUSBAL |
Syntax Senden | VBUSBAL [Data] |
Syntax Empfangen | VBUSBAL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361B (hex)
DIM | - / V | PROFIBUS PNU | 1883 (dec) IND = 1 (dec)
Bereich | 0, 1, 2, 3, 4, 40..750 | DPR | 283 (dec)
Default | depends on type of drive |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.8
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Maximale Netzspannung

Beschreibung

Mit dieser Einstellung wird die für die Motoren zulässige Netzspannung eingestellt. Wenn beispielsweise ein Motor, der für 400V Einspeisung ausgelegt ist, an den Verstärker angeschlossen wird, so sollte die Einstellung VBUSBAL = 2 (400V) sein. Damit wird die Ballast- und Überspannungsschwelle im Verstärker auf für den Motor verträgliche Werte eingestellt. Damit ist sichergestellt, dass der Motor keinen Wicklungsschaden erleidet.

VBUSBAL - Einstellungen von 40 ... 750 geben eine frei wählbare maximale Netzspannung vor.
In diesem Fall ist VBUSMAX = 1,2 x VBUSBAL

gilt nur für S300:
VBUSBAL=0 (115 V) VBUSMAX = 235V, Ballastschwelle = 200V

gilt für S300/S700:
VBUSBAL=1 (230 V) VBUSMAX = 455V, Ballastschwelle = 400V
VBUSBAL=2 (400 V) VBUSMAX = 800V, Ballastschwelle = 720V
VBUSBAL=3 (480 V) VBUSMAX = 900V, Ballastschwelle = 840V

gilt für S748/S772 ab der FW-Version 5.67
VBUSBAL=4 (480V) VBUSMAX = 900V, Ballastschwelle = 790V

Der Default-Wert für VBUSBAL hängt von dem Verstärkertyp ab:
S303,S306,S310 : VBUSBAL=2
S341,S343,S346 : VBUSBAL=3
S700: 230V-Versionen VBUSBAL=1
S700: 400V-Versionen VBUSBAL=3
S748/S772: ab der FW 5.67 VBUSBAL=4


ASCII Deutsch VBUSBOFFS

ASCII - Kommando | VBUSBOFFS |
Syntax Senden | VBUSBOFFS [Data] |
Syntax Empfangen | VBUSBOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 38BF (hex)
DIM | Volt | PROFIBUS PNU | 1759 (dec) IND = 33 (dec)
Bereich | 0 .. 83 | DPR | 959 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware | 5.19 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Absenkung der Ballasteinschaltschwelle

Beschreibung

Dieser Parameter bewirkt eine Absenkung der Ballasteinschaltschwelle um VBUSBOFFS Volt. Eine Erhöhung des Wertes bewirkt eine frühere Einschaltung des Ballastwiderstandes.


ASCII Deutsch VBUSCNTMAX

ASCII - Kommando | VBUSCNTMAX |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35EE (hex)
DIM | - | PROFIBUS PNU | 1838 (dec) IND = 1 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch VBUSFACT

ASCII - Kommando | VBUSFACT |
Syntax Senden | VBUSFACT [Data] |
Syntax Empfangen | VBUSFACT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38C2 (hex)
DIM |  | PROFIBUS PNU | 1762 (dec) IND = 33 (dec)
Bereich | 0.1 .. 10 | DPR | 962 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Verstärkungsfaktor für die Bremsrampenregelung

Beschreibung

Um den Zwischenkreisspannungsanstieg, der beim Abbremsen entsteht, zu begrenzen, wird die Steilheit der Bremsrampe abhängig von der Zwischenkreisspannung geregelt.

Beim Abbremsen des Motors, bedingt durch den generatorischen Betrieb, steigt die Zwischenkreisspannung an. Wenn die Zwischenkreisspannung die Ballastschwelle überschreitet, so wird die Ansteuerung des Ballastwiderstandes aktiviert. Bei weiterem Anstieg der Zwischenkreisspannung, wird beim Überschreiten der Überspannungsschwelle der Fehler F02 „Überspannung“ generiert. Um diesen Fehler zu vermeiden, muss der Anstieg der Zwischenkreisspannung begrenzt werden. Dies kann erreicht werden, indem die Bremsrampensteilheit abhängig von der Zwischenkreisspannung geregelt wird.

VBUSFACT: Verstärkungsfaktor für die Bremsrampenregelung

Bestimmt den Grad der Beeinflussung der Bremsrampe durch den Anstieg der Zwischenkreisspannung
Je größer dieser Wert umso flacher wird die Bremskurve.

Siehe auch VBUSRAMP


ASCII Deutsch VBUSLIM

ASCII - Kommando | VBUSLIM |
Syntax Senden | VBUSLIM [Data] |
Syntax Empfangen | VBUSLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35F5 (hex)
DIM | % | PROFIBUS PNU | 1845 (dec) IND = 1 (dec)
Bereich | 70...95 | DPR | 245 (dec)
Default | 90 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.6
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Schwelle für die Netz-Phasenausfallüberwachung

Beschreibung

Dieser Parameter beschreibt die Schwelle für die Netz-Phasenausfallüberwachung

Die Schwelle wird berechnet in % von der mittleren Zwischenkreisspannung. Falls die Zwischenkreisspannung die eingestellte Schwelle für mindestens 25 msec unterschreitet, so wird je nach PMODE-Einstellung entweder eine Warnung (n05) oder ein Fehler (F19) generiert.


ASCII Deutsch VBUSMAX

ASCII - Kommando | VBUSMAX |
Syntax Senden | VBUSMAX |
Syntax Empfangen | VBUSMAX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361C (hex)
DIM | V | PROFIBUS PNU | 1884 (dec) IND = 1 (dec)
Bereich | 235, 455, 800, 900 | DPR | 284 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Maximale Zwischenkreisspannung

Beschreibung

Der Parameter VBUSMAX zeigt den Wert der Überwachungsschwelle für die Fehlermeldung F02 (Überspannung). Die Fehlermeldung wird generiert sobald die Zwischenkreisspannung den Wert VBUSMAX überschreitet. Die Schwelle VBUSMAX hängt von der Einstellung VBUSBAL ab:

VBUSBAL=0 (115 V) VBUSMAX=235V
VBUSBAL=1 (230 V) VBUSMAX=455V
VBUSBAL=2 (400 V) VBUSMAX=800V
VBUSBAL=3 (480 V) VBUSMAX=900V
VBUSBAL=4 (480 V) VBUSMAX=900V (nur S748/S772 ab FW 5.67)


ASCII Deutsch VBUSMIN

ASCII - Kommando | VBUSMIN |
Syntax Senden | VBUSMIN [Data] |
Syntax Empfangen | VBUSMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361D (hex)
DIM | V | PROFIBUS PNU | 1885 (dec) IND = 1 (dec)
Bereich | 30 .. 800 | DPR | 285 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Minimale Zwischenkreisspannung

Beschreibung

VBUSMIN legt die untere Schwelle für die Überwachung der Zwischenkreisspannung. Sobald diese Schwelle unterschritten wird, wird die Fehlermeldung F05 (Unterspannung) generiert. Die Überwachung der Unterspannung ist nur unter folgenden Voraussetzungen aktiv:
1. Endstufe freigegeben
2. Überwachung aktiviert UVLTMODE=1
3. NETZBTB-Funktion nicht aktiv (OxMODE<>3)
4. Abschalten der Überwachungsfunktion über einen digitalen Eingang INxMODE=21 nicht aktiv.


ASCII Deutsch VBUSOFFS

ASCII - Kommando | VBUSOFFS |
Syntax Senden | VBUSOFFS [Data] |
Syntax Empfangen | VBUSOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38D0 (hex)
DIM | V | PROFIBUS PNU | 1776 (dec) IND = 33 (dec)
Bereich | -10 ... 10 | DPR | 976 (dec)
Default | 0 |
Opmode | all | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 5.65 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Korrekturwert für die Ballastschwelle S748/S772

Beschreibung

Dieser Parameter korrigiert Spannungoffsets zwischen den im DC-Verbund arbeitenden Verstärkern.
Falls die Ballastleistungen bei den gekoppelten Verstärkern nicht gleichmäßig aufgeteilt sind, so kann das durch Offsetwerte in der Spannungsmessung verursacht sein. Eine Erhöhung dieses Wertes verkleinert die Ballastleistung bei dem zugehörigen Verstärker.


ASCII Deutsch VBUSRAMP

ASCII - Kommando | VBUSRAMP |
Syntax Senden | VBUSRAMP |
Syntax Empfangen | VBUSRAMP | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 38C1 (hex)
DIM | % | PROFIBUS PNU | 1761 (dec) IND = 33 (dec)
Bereich | -100 .. 100 | DPR | 961 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.33 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | drive configuration | EEPROM | Ja
Kurzbeschreibung | Einschaltschwelle für die Bremsrampenregelung

Beschreibung

Um den Zwischenkreisspannungsanstieg, der beim Abbremsen entsteht, zu begrenzen, wird die Steilheit der Bremsrampe abhängig von der Zwischenkreisspannung geregelt.

Beim Abbremsen des Motors, bedingt durch den generatorischen Betrieb, steigt die Zwischenkreisspannung an. Wenn die Zwischenkreisspannung die Ballastschwelle überschreitet, so wird die Ansteuerung des Ballastwiderstandes aktiviert. Bei weiterem Anstieg der Zwischenkreisspannung, wird beim Überschreiten der Überspannungsschwelle der Fehler F02 „Überspannung“ generiert. Um diesen Fehler zu vermeiden, muss der Anstieg der Zwischenkreisspannung begrenzt werden. Dies kann erreicht werden, indem die Bremsrampensteilheit abhängig von der Zwischenkreisspannung geregelt wird.

VBUSRAMP: Bestimmung der Einschaltschwelle für die Bremsrampenregelung

Dieser Parameter beschreibt die Spannungsschwelle bei der die Rampenregelung einsetzt.Der Wert bezieht sich auf die Differenz zwischen der Ballasteinschaltschwelle und die Überspannungsschwelle.

VBUSRAMP=100% die Regelung setzt bei der Ballastschwelle ein (100% unterhalb der Überspannungsschwelle)
VBUSRAMP=20% die Regelung setzt bei einer Spannung ein, die 20% unter der Überspannungsschwelle liegt
VBUSRAMP=0 (Default) Regelung abgeschaltet

Die Bremsrampe wird linear zwischen der „Einschaltschwelle“ und der „Überspannungsschwelle“ skaliert.

Zwischenkreisspannung < Einschaltschwelle –> keine Rampenbegrenzung

Bei der Vorgabe eines negativen VBUSRAMP-Wertes kann anstelle einer linearen Skalierung eine quadratische Skalierung aktiviert werden.

z.B. VBUSRAMP = -100%

siehe auch VBUSFACT


ASCII Deutsch VBW

ASCII - Kommando | VBW |
Syntax Senden | VBW |
Syntax Empfangen | VBW | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | 0 | DPR | Nein
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Ausgabe eines Bode-Diagramms

Beschreibung

VBW [fmin] [fmax] [sample] [switch]

Velocity BandWidth

Mit der Funktion VBW wird vom Verstärker ein Bode Diagramm des Drehzahlregelkreises ermittelt. Standard sind 30 (sample) Messungen zwischen 20 Hz (fmin) und 800 Hz (fmax). Gemessen wird die Verstärkung in dB und die Phasenverschiebung in Grad vom offenen und vom geschlossenen Regelkreis. Bei MSG 2 werden die Ergebnisse sofort angezeigt, ansonsten können die Daten mit GET abgerufen werden. Zur Nutzung der Funktion VBW sollte der Verstärker Enabled und im OPMODE 0 sein.
Die Welle dreht sich zur Bestimmung nur um wenige Grad. Im Falle von starken Resonanzen können Überschwingungen Fehler auslösen, die das ungeregelte Auslaufen des Antriebs bewirken können.

Falls [switch] = 1: Filter ausschalten
GV auf 20% reduzieren
GVTN auf 50 ms reduzieren


ASCII Deutsch VCMD

ASCII - Kommando | VCMD |
Syntax Senden | VCMD |
Syntax Empfangen | VCMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 361E (hex)
DIM | MSPEED | PROFIBUS PNU | 1886 (dec) IND = 1 (dec)
Bereich | -VMAX .. VMAX | DPR | 286 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Nein
Kurzbeschreibung | interner Drehzahlsollwert in UPM

Beschreibung

Die Variable VCMD enthält den internen Drehzahlsollwert (hinter dem Rampengenerator) in UPM.
Je nach eingestellter Betriebsart (OPMODE=0) wird dieser Wert direkt digital vorgegeben (Feldbus,Slot-Karte) bzw. aus dem analogen Drehzahlsollwert (OPMODE=1) berechnet.
Bei den Betriebsarten, die keinen Drehzahlregler verwenden (OPMODE=2,3) enthält die Variable VCMD den Wert der Ist-Drehzahl V.


ASCII Deutsch VCOMM

ASCII - Kommando | VCOMM |
Syntax Senden | VCOMM [Data] |
Syntax Empfangen | VCOMM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 365A (hex)
DIM | [VUNIT] | PROFIBUS PNU | 1946 (dec) IND = 1 (dec)
Bereich | 0 .. 1.2 * MSPEED | DPR | 346 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Drehzahlschwelle für Kommutierungsfehler

Beschreibung

Mit dem Kommando VCOMM wird die Drehzahlschwelle für die Überwachung des Kommutierungsfehlers eingestellt.
Der Kommutierungsfehler liegt vor, wenn das Vorzeichen des Strom-Istwertes und das Vorzeichen der Geschwindigkeitsänderung nicht zueinander passen. Dies deutet auf das Durchgehen des Motors hin und wird durch sofortiges Sperren der Endstufe
unterbunden.

Der Kommutierungsfehler wird nur dann Überwacht, wenn die aktuelle Drehzahl die eingestellte Schwelle VCOMM überschreitet. Um die Überwachung abzuschalten, muß
der Schwellenwert VCOMM auf VLIM gesetzt werden.


ASCII Deutsch VCTIME

ASCII - Kommando | VCTIME |
Syntax Senden | VCTIME [Data] |
Syntax Empfangen | VCTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3867 (hex)
DIM | ms | PROFIBUS PNU | 1671 (dec) IND = 33 (dec)
Bereich | 0 ... 100 | DPR | 871 (dec)
Default | 24 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.31 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | velocity loop | EEPROM | Nein
Kurzbeschreibung | Kommutierungsfehler Toleranzzeit

Beschreibung

VCTIME definiert die Fehler Überwachungszeit.
Kommutierungsprobleme müssen länger als VCTIME in ms anstehen, bevor der Fehler F25 generiert wird.


ASCII Deutsch VEL0

ASCII - Kommando | VEL0 |
Syntax Senden | VEL0 [Data] |
Syntax Empfangen | VEL0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3620 (hex)
DIM | - | PROFIBUS PNU | 1888 (dec) IND = 1 (dec)
Bereich |  | DPR | 288 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Stillstandsschwelle

Beschreibung

Der Parameter VEL0 (Vel "0") legt die Drehzahlschwelle (in UPM) für die Stillstandsmeldung fest.
Die Stillstandsmeldung wird für folgende Funktionen gebraucht:
1. Stillstandsmeldung in dem Statusregister DRVSTAT.
2. Bei konfigurierter Bremse (MBRAKE=1) wird beim Disablen der Endstufe zunächst die Drehzahl auf 0 reduziert und erst nachdem die Drehzahl die Stillstandgrenze unterschritten hatte, die Bremse angesteuert.
3. Bei aktivierten ACTFAULT-Option (aktives Bremsen in Fehlerfall) bzw. STOPMODE-Option (aktives Bremsen beim Disablen der Endstufe), bestimmt die Stillstandsschwelle den Drehzahlwert, unterhalb dessen die Endstufe tatsächlich gesperrt wird.

Ab Firmware Version 2.14 ist der min. Eingabewert für VEL0 von 0 UPM auf 1 UPM geändert.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Drehzahlregler

einheiten

Parameter für die Optimierung des Drehzahlreglers. Änderungen sind meist nicht erforderlich, wenn die korrekten motorbezogenen Daten aus der Datenbank geladen wurden.

Bildschirmtext | ASCII-Parameter
Enddrehzahl (pos.) | VLIMP
Enddrehzahl (neg.) | VLIMN
Stillstandserkennung | VEL0
Überdrehzahl | VOSPD
Beschl.-Rampe | ACC
Bremsrampe | DEC
PI-Plus | GVFR
Verstärkung (Kp_v) | GV
Nachstellzeit (Tn_v) | GVTN
TP-Frequenz | ARLPF
TP-Frequenz | ARLP2
HP-Frequenz | ARHPF

Brems-/Disable-Verhalten

Bildschirmtext | ASCII-Parameter
Brems-/Disable-Verhalten (Fehler) - weitere Informationen zu einzelnen Fehlern siehe ERRCODES | ACTFAULT
Bremsrampe | DECSTOP
Brems-/Disable-Verhalten (Disable-Befehl) | STOPMODE
Bremsrampe | DECDIS


ASCII Deutsch VER

ASCII - Kommando | VER |
Syntax Senden | VER [*] |
Syntax Empfangen | VER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich | max 50 ASCII Characters | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Firmware-Version

Beschreibung

Das Kommando VER liefert die Versionsbezeichnung sowie das Erstellungsdatum der Firmware.
Die erweiterte Versione des Kommandos (VER *) liefert eine Version-Aufstellung der einzelnen Firmware/Hardware-Komponenten:
- Version der Basis-Firmware
- Hardware-Revision
- CPLD-Version
- CAN: Firmware-Version
- Version der Motor Daten Bank (MDB)
- Profibus/Sercos:Firmware-Version


ASCII Deutsch VINPOS

ASCII - Kommando | VINPOS |
Syntax Senden | VINPOS [Data] |
Syntax Empfangen | VINPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3856 (hex)
DIM |  | PROFIBUS PNU | 1654 (dec) IND = 33 (dec)
Bereich | 0 .. 120% of MSPEED | DPR | 854 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung | 1000
ab Firmware | 1.37 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeit im In-Position-Fenster

Beschreibung

VINPOS definiert die Größe der Geschwindigkeit im In-Position-Fenster für die VINPOS status Meldung (Bit 1 in DRVSTAT2).
Solange der Unterschied zwischen der letzten Sollgeschwindigkeit (VCMD) und der aktuellen Istgeschwindigkeit (V) innerhalb des In-Position Fenster (VINPOS) ist, wird eine 1 signalisiert, sonst eine 0.
Der Signalwechsel wird nicht angezeigt, wenn der Zustand nicht für die Zeit INPT0 anstand.


ASCII Deutsch VJOG

ASCII - Kommando | VJOG |
Syntax Senden | VJOG [Data] |
Syntax Empfangen | VJOG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3621 (hex)
DIM | see VUNIT | PROFIBUS PNU | 1889 (dec) IND = 1 (dec)
Bereich | -500008 ... 500008 | DPR | 289 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Tippbetrieb-Geschwindigkeit

Beschreibung

Der Tippbetrieb entspricht einem Endlos-Fahrsatz und wird über den internen Lageregler realisiert.
Das Vorzeichen der Geschwindigkeit gibt die Richtung für den Tippbetrieb an. Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VLIM

ASCII - Kommando | VLIM |
Syntax Senden | VLIM [Data] |
Syntax Empfangen | VLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358C (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1740 (dec) IND = 1 (dec)
Bereich | 0.0 .. MSPEED | DPR | 140 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Max. Drehzahl

Beschreibung

Der Parameter VLIM gibt die maximale Drehzahl (Drehzahlregler) in Einheiten an, die mit VUNIT festglegt werden.
Darüber hinaus wird VLIM für die Begrenzung von folgenden Parametern benutzt:
1. MVANGLB <= 0.9*VLIM
2. MSPEED >= VLIM
3. PVMAX <= (VLIM * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit den Parametern VLIMN und/oder VLIMP, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIM bestimmt die maximale Drehzahl für die positive und negative Drehrichtung.


ASCII Deutsch VLIMN

ASCII - Kommando | VLIMN |
Syntax Senden | VLIMN [Data] |
Syntax Empfangen | VLIMN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3623 (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1891 (dec) IND = 1 (dec)
Bereich | 0.0 .. MSPEED | DPR | 291 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Max. negative Drehzahl

Beschreibung

Der Parameter VLIMN gibt die maximale Drehzahl für die negative Drehrichtung (Drehzahlregler) in Einheiten an, die mit VUNIT festgelegt werden.
Darüber hinaus wird VLIMN für die Begrenzung von PVMAXN benutzt:
PVMAXN <= (VLIMN * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIMP, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIMP bestimmt die maximale Drehzahl für die positive Drehrichtung.


ASCII Deutsch VLIMP

ASCII - Kommando | VLIMP |
Syntax Senden | VLIM [Data] |
Syntax Empfangen | VLIMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3622 (hex)
DIM | ( > VUNIT) | PROFIBUS PNU | 1890 (dec) IND = 1 (dec)
Bereich | 0.0 .. MSPEED | DPR | 290 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.14
Funktionsgruppe | velocity loop | EEPROM | Ja
Kurzbeschreibung | Max. Drehzahl

Beschreibung

Der Parameter VLIMP gibt die maximale Drehzahl für die positive Drehrichtung (Drehzahlregler) in Einheiten an, die mit VUNIT festgelegt werden.
Darüber hinaus wird VLIMP für die Begrenzung von PVMAXP benutzt:
PVMAXP <= (VLIMP * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIMN, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIMN bestimmt die maximale Drehzahl für die negative Drehrichtung.


ASCII Deutsch VLO

ASCII - Kommando | VLO |
Syntax Senden | VLO [Data] |
Syntax Empfangen | VLO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 363D (hex)
DIM | - | PROFIBUS PNU | 1917 (dec) IND = 1 (dec)
Bereich | 0 ... 30 | DPR | 317 (dec)
Default | 0.5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Software Resolver/Digital Wandler Vorsteuerung

Beschreibung

VLO ist ein Parameter des Luenberger Drehzahl Beobachters. Um den Zeitverzug durch die Differentiation zu minimieren, kann dem Beobachter die drehmomentbildende Komponente des Stroms bereitgestellt werden. Das effektive Trägheitsmoment wird aus der Kreisverstärung des Drehzahlreglers abgeschätzt (GV). Bei VLO 0 ist die Beschleunigungsberücksichtigung ausgeschaltet. Bei VLO 1 wird sie zu 100 % berücksichtigt. Bei VLO 0.5 werden nur 50% der Beschleunigung berücksichtigt. Eine Verkleinerung von VLO kann die Stabilität des Drehzahlregelkreises gefährden.


ASCII Deutsch VLO_X

ASCII - Kommando | VLO_X |
Syntax Senden | VLO_X [Data] |
Syntax Empfangen | VLO_X <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38C0 (hex)
DIM | - | PROFIBUS PNU | 1760 (dec) IND = 33 (dec)
Bereich | 0 ... 30 | DPR | 960 (dec)
Default | 0.5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.7
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Software Resolver/Digital Wandler Vorsteuerung

Beschreibung

VLO_X ist ein Parameter des Luenberger Drehzahl Beobachters. Um den Zeitverzug durch die Differentiation zu minimieren, kann dem Beobachter die drehmomentbildende Komponente des Stroms bereitgestellt werden. Das effektive Trägheitsmoment wird aus der Kreisverstärung des Drehzahlreglers abgeschätzt (GV). Bei VLO_X 0 ist die Beschleunigungsberücksichtigung ausgeschaltet. Bei VLO_X 1 wird sie zu 100 % berücksichtigt. Bei VLO_X 0.5 werden nur 50% der Beschleunigung berücksichtigt. Eine Verkleinerung von VLO_X kann die Stabilität des Drehzahlregelkreises gefährden.

Das Umschalten von Parametersätzen wird mit Hilfe eines Zeigers realisiert, der immer auf eine der beiden Parameterstrukturen (Parametersatz 1: Default) oder (Parametersatz 2: Schattenparameter) zeigt. Durch das Umschalten des Zeigers zwischen den beiden Strukturen werden auch die innerhalb der Strukturen definierten Parameter schlagartig umgeschaltet. Dadurch, dass die Parameter innerhalb der Strukturen bereits umgerechnet sind, wird vermieden, dass undefinierte Zustände entstehen, wo Parameter nur teilweise mit den neuen und teilweise mit den alten Werten umgerechnet sind.

Die Parameter des zweiten Parametersatzes werden ähnlich wie beim Hauptparametersatz mit Hilfe von ASCII-Kommandos definiert. Um den zweiten Parametersatz zu beschreiben, muss dem ASCII-Kommando die Buchstabenfolge „_X“ hinzugefügt werden.

Beispiel:
Um die Verstärkung des Drehzahlreglers zu verändern, wird das Kommando „GV“ benutzt. Damit dieser Parameter im zweiten Parametersatz verändert werden kann, muss das Kommando GV_X benutzt werden.

Um den Parameterspeicher des Verstärkers zu schonen, werden nur die Parameter des zweiten Parametersatzes abgespeichert, die sich von dem Hauptparametersatz unterscheiden.Falls keine Parameter des zweiten Parametersatzes (PAR_X) vorgegeben werden, wird die zweite Parameterstruktur automatisch mit den gleichen Werten wie der Hauptparametersatz initialisiert. Der Anwender braucht also nicht alle Parameter des zweiten Parametersatzes zu initialisieren. Er muss lediglich die von ihm benötigten Parameter verändern.

Die automatische Initialisierung des Schattenparameters erfordert , dass bei jeder Änderung eines Hauptparameters auch der zugehörige Schattenparameter automatisch auf den gleichen Wert gesetzt wird. Damit der zuvor eingegebene Schattenparameter durch den Hauptparameter nicht überschrieben wird, muss die Parametrierung des zweiten Parametersatzes immer nach der Initialisierung des Hauptparametersatzes erfolgen.

Sobald der Parameter PAR_X einen anderen Wert als PAR bekommt, wird dieser Parameter im seriellen EEPROM abgespeichert. Der PAR_X-Wert erscheint dann auch in der DUMP-Ausgabe und zwar am Ende der Parameterliste.

Mit dem Kommando PARDUMP können alle umschaltbaren Parameter mit den aktuellen Einstellungen ausgegeben werden.


ASCII Deutsch VMIX

ASCII - Kommando | VMIX |
Syntax Senden | VMIX [Data] |
Syntax Empfangen | VMIX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3625 (hex)
DIM |  | PROFIBUS PNU | 1893 (dec) IND = 1 (dec)
Bereich | 0.0 .. 1.0 | DPR | Nein
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 5.92 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeitmix Feedback / externer Geber

Beschreibung

Beim Einsatz eines externen Gebers für die Lageregelung (EXTPOS=1) wird die Lageregelung über die Positionsinformation des externen Gebers, die Kommutierung und Geschwindigkeitsregelung über die Positionsinformation des über FBTYPE angewählten Gebers realisiert. Mit dem Parameter VMIX kann festgelegt werden, in welchem Verhältnis die Feedback-Einheit am Motor und der externe Geber für die Drehzahlregelung verwendet werden soll.

z.B:
VMIX=1.0 Geschwindigkeit ausschließlich über das mit FBTYPE angewählte Rückführungssystem (100 %)
VMIX=0.5 50 % über das mit FBTYPE angewählte Rückführungssystem/ 50 % externer Geber

VMIX ist nur bei FILTMODE = 0 oder 1 aktiv.
VMIX ist nur im Lagereglermodus OPMODE = 8 verfügbar.


ASCII Deutsch VMUL

ASCII - Kommando | VMUL |
Syntax Senden | VMUL [Data] |
Syntax Empfangen | VMUL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3626 (hex)
DIM | - | PROFIBUS PNU | 1894 (dec) IND = 1 (dec)
Bereich | 1 .. 65535 | DPR | 294 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | fieldbus | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeitsmultiplikator (Feldbus)

Beschreibung

Mit dem Parameter VMUL kann die Lageregler-Geschwindigkeit für den Tipp-/Fahrsatzbetrieb skaliert werden. Diese Skalierung ist bei vielen Feldbussen (PROFIBUS,CANBUS) notwendig, da verschiedene Feldbus-Protokolle nur Geschwindigkeitwerte im 16-Bit Format zulassen. Durch die Einführung dieses Skalierungsfaktores kann der 16-Bit Feldbus-Geschwindigkeitswert auf den internen 32-Bit Wert erweitert werden.
s.auch Handbuch PROFIBUS,CANBUS


ASCII Deutsch VOHPD

ASCII - Kommando | VOHPD |
Syntax Senden | VOLPD [Data] |
Syntax Empfangen | VOHPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 10 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Hochpassdämpfung des Drehzahlbeobachters

Beschreibung

Hochpassdämpfung des Drehzahlbeobachters höherer Ordnung

Siehe auch MRESBW, VOLPD, VOHPD.


ASCII Deutsch VOHPF

ASCII - Kommando | VOHPF |
Syntax Senden | VOHPF [Data] |
Syntax Empfangen | VOHPF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | Hz | PROFIBUS PNU | -
Bereich | 0 .. 10000 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Hochpassfrequenz des Drehzahlbeobachters

Beschreibung

Hochpassfrequenz des Drehzahlbeobachters höherer Ordnung

Siehe auch MRESBW, VOLPD, VOHPD.


ASCII Deutsch VOLPD

ASCII - Kommando | VOLPD |
Syntax Senden | VOLPD [Data] |
Syntax Empfangen | VOLPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | -
DIM |  | PROFIBUS PNU | -
Bereich | 0 .. 10 | DPR | Nein
Default | 0.5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.13
Funktionsgruppe | filter | EEPROM | Ja
Kurzbeschreibung | Tiefpassdämpfung des Drehzahlbeobachters

Beschreibung

Tiefpassdämpfung des Drehzahlbeobachters höherer Ordnung

Wenn VOLPF auf einen von Null verschiedenen Wert gesetzt wird, ist der Beobachter höherer Ordnung aktiv und wird anstelle des regulären Beobachters verwendet.
MRESBW legt dann die Tiefpass-Filterfrequenz fest und VOLPD die entsprechende Dämpfung.

Siehe auch MRESBW, VOHPF, VOHPD.


ASCII Deutsch VOMODE

ASCII - Kommando | VOMODE |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default | 4 |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch VOMOPDE

ASCII - Kommando | VOMOPDE |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | -
DIM | - | PROFIBUS PNU | -
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch VOSPD

ASCII - Kommando | VOSPD |
Syntax Senden | VOSPD [Data] |
Syntax Empfangen | VOSPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3627 (hex)
DIM | rpm | PROFIBUS PNU | 1895 (dec) IND = 1 (dec)
Bereich | 0.0 .. 1.2*MSPEED | DPR | 295 (dec)
Default | 3600 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Überdrehzahl

Beschreibung

Mit dem Parameter VOSPD kann die Abschaltschwelle für die Fehlermeldung F08 (Überdrehzahl) festgelegt werden. Sobald die aktuelle Drehzahl den eingestellten Schwellenwert überschreitet, so wird die Fehlermeldung F08 generiert und die Endstufe gesperrt.


ASCII Deutsch VOSPDREF

ASCII - Kommando | VOSPDREF |
Syntax Senden | VOSPDREF [Data] |
Syntax Empfangen | VOSPDREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | -
DIM | rpm | PROFIBUS PNU | -
Bereich | 0.0 .. 1.2 * MSPEED | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung | 1000
ab Firmware | 3.15 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Überdrehzahl-Schwelle für die Referenzfahrt

Beschreibung

Der Parameter VOSPDREF definiert eine Überdrehzahl-Schwelle für die Referenzfahrt.
Bei VOSPDREF=0 wird die allgemeine Einstellung VOSPD benutzt. Bei VOSPDREF>0 wird beim
Einschalten des Verstärkers die Überdrehzahl-Schwelle auf VOSPDREF gesetzt. Diese Schwelle bleibt aktiv bis eine Referenzfahrt ausgeführt wurde bzw. der Wert VOSPDREF auf 0 gesetzt wurde.
Bei FBTYPE-Einstellungen mit Wake&Shake-Funktionalität, kann dieser Parameter benutzt werden um eine erhöhte Sicherheit für die Wake&Shake-Phase zu gewährleisten.


ASCII Deutsch VOUTMAX

ASCII - Kommando | VOUTMAX |
Syntax Senden | VOUTMAX [Data] |
Syntax Empfangen | VOUTMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | -
DIM | % | PROFIBUS PNU | -
Bereich | 0 .. 1 | DPR | Nein
Default | 0.95 |
Opmode | all | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | - |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | sensorless | EEPROM | Ja
Kurzbeschreibung | sensorless mode: maximale Ausgangsspannung

Beschreibung

Der Parameter VOUTMAX gibt die maximale Ausgangsspannung im Sensorless Mode an: 1 = 100%


ASCII Deutsch VREF

ASCII - Kommando | VREF |
Syntax Senden | VREF [Data] |
Syntax Empfangen | VREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3628 (hex)
DIM | ( >VUNIT) | PROFIBUS PNU | 1896 (dec) IND = 1 (dec)
Bereich | 0 ... VLIM/VLIMN | DPR | 296 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Referenzfahrt-Geschwindigkeit

Beschreibung

Mit dem Parameter VREF wird der Geschwindigkeitsbetrag (VREF>0) für die Referenzfahrt vorgegeben. Die Referenzrichtung wird der Variable DREF entnommen.
Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VREF0

ASCII - Kommando | VREF0 |
Syntax Senden | VREF0 [Data] |
Syntax Empfangen | VREF0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3698 (hex)
DIM | - | PROFIBUS PNU | 2008 (dec) IND = 1 (dec)
Bereich | 0.01 .. 2.0 | DPR | 408 (dec)
Default | 0.125 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Ja
Kurzbeschreibung | Reduzierfaktor Referenzfahrgeschwindigkeit

Beschreibung

Mit dem Parameter VREF0 kann die Referenzfahrtgeschwindigkeit VREF
während der Suche eines externen Nullimpulses reduziert werden.
Bei Verwendung einer Referenzfahrt mit Nullpunktsuche, kann die Quelle des Nullimpulses mit dem Parameter REFMODE festgelegt werden. Bei REFMODE>0
wird der Nullimpuls auf dem vorgewählten Hardware-Eingang erwartet (s. REFMODE).
Da das Einlesen des Nullimpulses mit einer Abtastzeit von 250 µsek erfolgt,
ist es oft wünschenswert für die Suchphase eine geringere Referenzfahrtgeschwindigkeit als VREF zu benutzen.

Mit dem Parameter VREF0 kann die Geschwindigkeitreduzierung in % von VREF angegeben werden.

Beispiel 1:

REFMODE=1 Nullimpuls über digitalen Eingang 1
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche
VREF=10000 Referenzfahrtgeschwindigkeit 10000 µm/sek
VREF0=0.2 Reduktion der Geschwindigkeit auf 2000 µm/sek

Beim Start der Referenzfahrt fährt der Antrieb mit der Geschwindigkeit 10000 bis zu dem Referenzschalter. Nachdem der Referenzschalter erreicht wurde, wird die Geschwindigkeit auf 20% (2000) reduziert. Der Antrieb fährt mit reduzierter Geschwindigkeit bis ein Nullimpuls am digitalen Eingang 1 (High Pegel) erkannt wird.

Beispiel 2:

REFMODE=2 Nullimpuls über digitalen Eingang 2
NREF=5 Nullposition innerhalb einer Umdrehung
VREF=10000
VREF0=0.2

Da das Kriterium für die Suche des Nullimpulses sofort beim Start der Referenzfahrt erfüllt ist, so wird die Referenzfahrt sofort mit der reduzierten Geschwindigkeit 2000 µm/sek.


ASCII Deutsch VSCALE1

ASCII - Kommando | VSCALE1 |
Syntax Senden | VSCALE1 [Data] |
Syntax Empfangen | VSCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3629 (hex)
DIM | VUNIT / 10 V | PROFIBUS PNU | 1897 (dec) IND = 1 (dec)
Bereich | -16000 .. 16000 (for VUNIT=0) | DPR | 297 (dec)
Default | 3000 (for VUNIT=0) |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | SW1-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang 1 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE1 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang 1 stellt sich eine VSCALE1-Drehzahl ein.

Achtung: VSCALE1/VSCALE2 nicht kleiner als 2UPM eingestellt werden!


ASCII Deutsch VSCALE2

ASCII - Kommando | VSCALE2 |
Syntax Senden | VSCALE2 [Data] |
Syntax Empfangen | VSCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 362A (hex)
DIM | rpm / 10 V | PROFIBUS PNU | 1898 (dec) IND = 1 (dec)
Bereich | -16000 .. 16000 (for VUNIT=0) | DPR | 298 (dec)
Default | 3000 (for VUNIT=0) |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | analog I/O | EEPROM | Ja
Kurzbeschreibung | SW2-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang 2 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE2 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang 2 stellt sich eine VSCALE2-Drehzahl ein.

Achtung: VSCALE1/VSCALE2 nicht kleiner als 2UPM eingestellt werden!


ASCII Deutsch VSTART

ASCII - Kommando | VSTART |
Syntax Senden | VSTART [Data] |
Syntax Empfangen | VSTART <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3888 (hex)
DIM |  | PROFIBUS PNU | 1704 (dec) IND = 33 (dec)
Bereich | 0 .. 1 | DPR | 904 (dec)
Default | 0.05 |
Opmode | 1,2 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Startspannung für die U/f Steuerung

Beschreibung

Startspannung für die U/f Steuerung (Asynchronmaschine).
Als Bruchteil der Nennspannung angegeben.
Wird zur Berechnung des U/f Verlaufs im unteren Drehzahlbereich verwendet.
Spannung bei Solldrehzahl 0 (J = 0).


ASCII Deutsch VSTFR

ASCII - Kommando | VSTFR |
Syntax Senden | VSTFR [Data] |
Syntax Empfangen | VSTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A5 (hex)
DIM | VUNIT | PROFIBUS PNU | 2021 (dec) IND = 1 (dec)
Bereich | 0 ... 230 UPM | DPR | 421 (dec)
Default | 0 |
Opmode | 0, 1, 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.1
Funktionsgruppe | other commands | EEPROM | Ja
Kurzbeschreibung | Drehzahleckpunkt bei Reibungskompensation

Beschreibung

siehe ISTFR


ASCII Deutsch VTIMEKD

ASCII - Kommando | VTIMEKD |
Syntax Senden | VTIMEKD [Data] |
Syntax Empfangen | VTIMEKD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 38DC (hex)
DIM | ms | PROFIBUS PNU | 1788 (dec) IND = 33 (dec)
Bereich | -- | DPR | 988 (dec)
Default | 1 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 6.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.12
Funktionsgruppe | servo pump | EEPROM | Ja
Kurzbeschreibung | Zeitkonst vom D-Anteils für den Volumenstromregler

Beschreibung

Mit diesem Parameter kann die Zeitkonstante (in ms) des D-Anteils für den Volumenstromreglers konfiguriert werden.


ASCII Deutsch VTUNE

ASCII - Kommando | VTUNE |
Syntax Senden | VTUNE [Data] |
Syntax Empfangen | VTUNE <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer16 Float | CANBus Objektnummer | -
DIM | Ms (DurationN) / rpm (velocityN) | PROFIBUS PNU | -
Bereich | 0..32767 | DPR | Nein
Default |  |
Opmode | 0 | Datentyp Bus/DPR | Integer16 Float
Verstärker Status | Enable | Wichtung |
ab Firmware | 3.65 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.2
Funktionsgruppe | velocity loop | EEPROM | Nein
Kurzbeschreibung | Autotuning Funktion für den Drehzahlregelkreis

Beschreibung

Diese Funktion startet eine Bewegungsfolge ähnlich der STEP Funktion für die Achse.
Danach wird die Einstellung der Parameter des Drehzahlregelkreises anhand der Sprungantwort des Drehzahlreglers optimiert. Das bedeutet, dass die Funktion selbständig die Parameter des Drehzahlreglers (z.Zt. GV und GVTN) verändert.

Die Sprunghöhe und –dauer für den Drehzahlsollwert kann an die Maschine angepasst werden:

1. VTUNE
Ohne Parameter wechselt der Drehzahlsollwert alle 400ms zwischen +100rpm und -100rpm.

2. VTUNE T1 V1
Der Drehzahlsollwert wechselt zwischen +V1 und –V1 (rpm) jeweils für die Zeit T1 (in ms).

Die Flankensteilheit der Sprünge wird definiert durch ACC bzw. DEC.
Für gute Ergebnisse sollte eine möglichst große Flankensteilheit gewählt werden (Maschinenbeschränkungen beachten !).


ASCII Deutsch VUNIT

ASCII - Kommando | VUNIT |
Syntax Senden | VUNIT [Data] |
Syntax Empfangen | VUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 365F (hex)
DIM | - | PROFIBUS PNU | 1951 (dec) IND = 1 (dec)
Bereich | 0 .. 8 | DPR | 351 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | digital I/O | EEPROM | Ja
Kurzbeschreibung | Systemweite Definition der Drehzahl / Geschw.

Beschreibung

Mit dem Kommando VUNIT kann die systemweite Drehzahl- und Geschwindigkeiteinheit
definiert werden. Diese Einheit gilt für alle Drehzahl-/Geschwindigkeitabhängige Parameter des Drehzahl- und Lagereglers.

VUNIT = 0 Vorgabe der Drehzahl in UPM (z.B. OPMODE=0)
Vorgabe der Geschwindigkeit in PUNIT/sek (z.B. OPMODE=8)

VUNIT = 1 Einheit = UPM
VUNIT = 2 Einheit = Rad/Sec
VUNIT = 3 Einheit = Grad/Sec
VUNIT = 4 Einheit = Inkremente im PRBASE-Format / 250µs

Beispiel: PRBASE = 24
1500U/min = 25U/s = 25*2^24/4000 InkrPRBASE / 250µs = 104857 InkrPRBASE / 250µs

VUNIT = 5 Einheit = PUNIT/Sec
VUNIT = 6 Einheit = PUNIT/Min
VUNIT = 7 Einheit = 1000 * PUNIT / Sec
VUNIT = 8 Einheit = 1000 * PUNIT / Min

Anmerkung:
1. Alle drehzahlabhängige Parameter werden grundsätzlich als 32-Bit Fixpoint
Zahlen (3 Nachkommastellen) vorgegeben. Aus diesem Grund kann bei manchen VUNIT-Einstellungen (besonders VUNIT=6), abhängig von der eingestellten Auflösung PGEARI, nicht der gesamte Drehzahlbereich abgedeckt werden. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

2. Alle geschwindigkeitabhängige Parameter werden grundsätzlich als 32-Bit Integer-Zahlen vorgegeben. Aus diesem Grund ist es nicht möglich, insbesondere bei der Einstellung VUNIT=3, eine Geschwindigkeit mit Nachkommastellen einzugeben. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

Umrechnungsfaktoren für die Drehzahleinheiten

VUNIT=1 1 UPM = 1048576*32/(4000*60) =~ 139.8 Counts
VUNIT=2 1 Rad/sek = 1048576*32/(4000*2*PI) =~ 1335 Counts
VUNIT=3 1 Grad/sek = 1048576*32/(4000*360) =~ 23.3 Counts
VUNIT=4 1 Counts/250µs = 32 Counts
VUNIT=5 1 PUNIT / sec = PGEARO / (125 * PGEARI)
VUNIT=6 1 PUNIT / min = (PGEARO * 60) / (125 * PGEARI)
VUNIT=7 1000 PUNIT / sec = PGEARO / (125 * PGEARI * 1000)
VUNIT=8 1000 PUNIT / min = (PGEARO * 60) / (125 * PGEARI * 1000)


ASCII Deutsch VWM

ASCII - Kommando | VWM |
Syntax Senden | VWM [Data] |
Syntax Empfangen | VWM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3759 (hex)
DIM | - | PROFIBUS PNU | 1801 (dec) IND = 17 (dec)
Bereich | 0 ... 1500 | DPR | 601 (dec)
Default | 400 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.35 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.2
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Grenzwert für SinCos Spannung

Beschreibung

VWM definiert den Grenzwert für die n23 Warnung (SinCos Spannung zu gering). Diese Warnung kann genutzt werden, um eine Verschmutzung am SinCos Geber (Lineares Messsystem) zu erkennen.


DriveGui Online Help

ASCII Objekt Referenz

Startseite

Bewerten Sie uns

Bildschirmseiten

Setup Wizard

setupwizard

Der Setup-Wizard führt Sie durch die notwendigen Schritte bei der Konfiguration Ihres Servoverstärkers. Abhängig von der zu lösenden Aufgabe werden nur die Bildschirmseiten dargestellt, die benötigt werden.

Zum Start wählen Sie bitte den Setup-Typ für Ihre Anwendung aus:

— Schnelleinstellung (Motor-/Verstärker-Kombination)
— Analog-Anwendung
— Getriebe-Anwendung
— Fahrauftrags-Anwendung
— Vollständiges Setup
— Asynchronmotor-Setup (U/f-Steuerung)

Starten Sie den Wizard. Die erste für Ihre Anwendung relevante Setup-Seite wird angezeigt. Um zwischen den Setup-Seiten zu wechseln, können Sie entweder die Schaltflächen "Weiter" und "Zurück" betätigen oder jede Seite direkt durch einen Mausklick auf den entsprechenden Eintrag im Baumdiagramm links anwählen.

Durch Betätigung der Schaltfläche "Aktualisieren" in der Symbolleiste können die ursprünglichen Daten der aktuell angezeigten Seite wieder hergestellt werden.

Sie können die Setup-Wizard Einstellung jederzeit ändern und sich so zusätzliche oder alle Setup-Seiten anzeigen lassen. Die letzte Wizard Einstellung wird beim Verlassen der Software gespeichert und beim Neustart wieder hergestellt.


ASCII Deutsch WMASK

ASCII - Kommando | WMASK |
Syntax Senden | WMASK [Data] |
Syntax Empfangen | WMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 363E (hex)
DIM | - | PROFIBUS PNU | 1918 (dec) IND = 1 (dec)
Bereich | -21474836470 ... 21474836470 | DPR | 318 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | drive configuration | EEPROM | Nein
Kurzbeschreibung | Warnung/Fehler-Maske

Beschreibung

Mit dem Parameter WMASK kann eine Warnung in die Fehlermeldung F24 umkonfiguriert werden.
Der Parameter WMASK ist eine Bit-Variable deren Belegung der Statusvariable STATCODE * entspricht. Das gesetzte Bit innerhalb der WMASK-Variable bedeutet, daß das zugehörige Warnung-Bit in der STATCODE *-Variable außer einer Warnung auch die Fehlermeldung F24 generieren soll. Im Gegensatz zu den Warnungen führt eine Fehlermeldung zum Sperren der Endstufe und zum Öffnen des BTB-Kontaktes. Das Umkonfigurieren der Warnungen zu Fehlermeldungen kann besonders bei folgenden Warnungen sinnvoll sein: Schleppfehler, Ansprechüberwachung, Hardware-Endschalter. Die Eingabe muss in Decimal und nicht in Hex erfolgen.

Siehe auch LASTWMASK


ASCII Deutsch WPOS

ASCII - Kommando | WPOS |
Syntax Senden | WPOS |
Syntax Empfangen | WPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3636 (hex)
DIM | - | PROFIBUS PNU | 1910 (dec) IND = 1 (dec)
Bereich | 0, 1, 2 | DPR | 310 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister

Beschreibung

Das Überschreiten/Unterschreiten einer Position wird innerhalb 1 msek erkannt und gemeldet. Die Funktion kann dabei zwischen ständig oder einmalig gewählt werden.
Die schnellen Positionsregister werden mit Hilfe der Konfigurationsvariable WPOS freigegeben:
WPOS=0 Positionsregister gesperrt
WPOS=1 Positionsregister freigegeben, keine CAN-Spontanmeldung bei Statusänderung
WPOS=2 Positionsregister freigegeben, CAN-Spontanmeldung bei Statusänderung (diese Einstellung kann nur über den CAN-Bus erfolgen)

Die Änderung der Variable WPOS zwischen 0 und >0 kann nur Offline erfolgen (SAVE und COLDSTART), eine Änderung zwischen 1 und 2 kann auch online erfolgen.

Es gibt insgesamt 16 Positionsregister P1...P16, die mit Hilfe von 3 Steuervariablen konfiguriert werden können. Die Positionsmeldungen werden über eine Statusvariable gemeldet. Alle Steuer-/Statusvariablen sind als 32-Bit Variablen zu sehen bei denen die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16
benutzt werden.

Steuervariablen:
WPOSE Freigabe/Sperren eines Positionsregisters
Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht

WPOSP Polarität für die Positionsmeldung
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

WPOSX – Art der Positionsüberwachung
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit (WPOSE) auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

Statusvariable:
POSRSTAT (z_data.Posrstat) – Positionsmeldung
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

Positionsregister:
Die Positionsregsiter 1 bis 16 können mit dem ASCII-Kommando P1...P16 angesprochen werden. Die Positionswerte werden in den Einheiten des Lagereglers (PGEARI / PGEARO-Umrechnung) vorgegeben.
Die für die schnellen Positionsregister benötigten Variablen WPOSE, WPOSP, WPOSX, P1...P16 können mit dem SAVE-Kommando im seriellen EEPROM abgespeichert werden. Die Positionsregister P1...P16, die nicht benutzt werden, sollten auf 0 gesetzt werden (da der Positionsregister-Default-Wert 0 beträgt, so wird kein Speicher im seriellen EEPROM belegt).
Die einzelnen Positionsmeldungen aus dem Statusregister POSRSTAT können auf die digitalen Ausgänge der Basisplatine ausgegeben werden.

OxMODE=40
Mit Hilfe dieser Funktion wird das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.

OxMODE=41
Mit Hilfe dieser Funktion wird das Ergebnis einer UND Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.


ASCII Deutsch WPOSE

ASCII - Kommando | WPOSE |
Syntax Senden | WPOSE |
Syntax Empfangen | WPOSE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 363F (hex)
DIM | - | PROFIBUS PNU | 1919 (dec) IND = 1 (dec)
Bereich | 0 ..65535 | DPR | 319 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSE können die schnellen Positionsregister P1...P16 einzeln freigegeben oder gesperrt werden.Die Variable WPOSE ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.

Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht
s. auch WPOS


ASCII Deutsch WPOSP

ASCII - Kommando | WPOSP |
Syntax Senden | WPOSP [Data] |
Syntax Empfangen | WPOSP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3640 (hex)
DIM | - | PROFIBUS PNU | 1920 (dec) IND = 1 (dec)
Bereich | 0 .. 65535 | DPR | 320 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Polarität der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSP können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSP ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

s. auch WPOS


ASCII Deutsch WPOSX

ASCII - Kommando | WPOSX |
Syntax Senden | WPOSX [Data] |
Syntax Empfangen | WPOSX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3641 (hex)
DIM | - | PROFIBUS PNU | 1921 (dec) IND = 1 (dec)
Bereich | 0 ... 65535 | DPR | 321 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | position loop | EEPROM | Nein
Kurzbeschreibung | Modus der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSX können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSX ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit WPOSE auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

s. auch WPOS


ASCII Deutsch WSAMPL

ASCII - Kommando | WSAMPL |
Syntax Senden | WSAMPL [Data] |
Syntax Empfangen | WSAMPL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36D1 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 17 (dec)
Bereich | 0 ... 2^31-1 | DPR | 465 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | Minimale Bewegung der W&S Funktion

Beschreibung

Gibt an, welche minimale Bewegung für die W&S - Funktion bei FBTYPE = 7 und 8 benötigt wird. Die Amplitude wird in internen Counts angegeben.
Bei der Einstellung "0", wird die Amplitude automatisch mit ENCLINES angepasst.

Siehe auch WSLOOP


ASCII Deutsch WSCNFG

ASCII - Kommando | WSCNFG |
Syntax Senden | WSCNFG [Data] |
Syntax Empfangen | WSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3874 (hex)
DIM | - | PROFIBUS PNU | 1684 (dec) IND = 33 (dec)
Bereich | - | DPR | 884 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.53 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | Typ der Kommutierungsfindung

Beschreibung

Der Parameter definiert den Typ der Kommutierungsfindung für FBTYPE=7,8,16,17,19,21

WSCNFG=0 Methode 1: Standard Wake & Shake
WSCNFG=1 Methode 2: Kommutierungsfindung mit PID Positionsregelung (CALCMP)
WSCNFG=2 Methode 3: Kommutierungsfindung mit festem Wert (ZERO)


ASCII Deutsch WSLOOP

ASCII - Kommando | WSLOOP |
Syntax Senden | WSLOOP [Data] |
Syntax Empfangen | WSLOOP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36E2 (hex)
DIM | - | PROFIBUS PNU | 1682 (dec) IND = 17 (dec)
Bereich | 1 ... 50 | DPR | 482 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | W&S Zyklen

Beschreibung

WSLOOP beschreibt die Anzahl der Wiederholungen für die Wake & Shake Funktion.Der Mittelwert aller Messungen wird als MPHASE übernommen.

Siehe auch WSAMPL


ASCII Deutsch WSRED

ASCII - Kommando | WSRED |
Syntax Senden | - |
Syntax Empfangen | - | Vorhanden in |
Type | - | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 375C (hex)
DIM | - | PROFIBUS PNU | 1804 (dec) IND = 17 (dec)
Bereich |  | DPR | Nein
Default |  |
Opmode |  | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | intern | EEPROM | Ja
Kurzbeschreibung | interner Parameter

Beschreibung

Dieser Parameter ist intern und wird nicht dokumentiert. Dabei kann es sich um einen kundenspezifischen oder Test/Service-Parameter handeln.

Dieser Parameter darf nicht verändert werden!


ASCII Deutsch WSTIME

ASCII - Kommando | WSTIME |
Syntax Senden | WSTIME [Data] |
Syntax Empfangen | WSTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36D0 (hex)
DIM | ms | PROFIBUS PNU | 1664 (dec) IND = 17 (dec)
Bereich | 0 ... 100 | DPR | 464 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | Ausführungszeit der W&S - Funktion

Beschreibung

WSTIME gibt die Ausführungszeit der W&S - Funktion bei FBTYPE = 7 und 8 an. Die verschiedenen Stromvektoren werden für diese Zeit angelegt. Damit kann die entsprechende Bewegung vergrößert werden. Siehe auch WSAMPL.
Bei der Einstellung "0", wird die Zeit automatisch in Abhängigkeit von GV berechnet.


ASCII Deutsch WSTIME2

ASCII - Kommando | WSTIME2 |
Syntax Senden | WSTIME2 [Data] |
Syntax Empfangen | WSTIME2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3863 (hex)
DIM | ms | PROFIBUS PNU | 1667 (dec) IND = 33 (dec)
Bereich | 0 .. 500 | DPR | 867 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.26 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.1
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | W&S Verzögerungszeit

Beschreibung

WSTIME2 definiert die Verzögerungszeit bei der W&S - Function für FBTYPE = 7 oder 8. Diese Verzögerung wirkt zwischen den verschiedenen Strom Vektoren während der Wake & Shake Prozedure. Die Voreinstellung ist 1 msec (WSTIME2=0).
Diese Zeit sollte vergrößt werden, falls sich die einzelnen Stromvektors gegenseitig stören.


ASCII Deutsch WSTIME3

ASCII - Kommando | WSTIME3 |
Syntax Senden | WSTIME3 [Data] |
Syntax Empfangen | WSTIME3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3865 (hex)
DIM | ms | PROFIBUS PNU | 1669 (dec) IND = 33 (dec)
Bereich | 0 .. 500 | DPR | 869 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.31 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.3
Funktionsgruppe | wake&shake | EEPROM | Ja
Kurzbeschreibung | W&S Verzögerungszeit

Beschreibung

Mit diesem Parameter (Eingabe in msek) kann der Abstand zwischen der Grob- und Feinabstimmung des Kommutierungswinkels während der W&S-Phase vergrößert werden. Dieser Wert liegt defaultmäßig bei 0 msek. Um die gegenseitige Beeinflußung der beiden W&S-Phasen (grob/Stromregelung und fein/Drehzahlregelung) zu verhindern, kann dieser Wert vergrößert werden (bis ca. 100 msek). Bei zu langen Werten wird die W&S-Phase unnötig verlängert.


ASCII Deutsch ZERO

ASCII - Kommando | ZERO |
Syntax Senden | ZERO |
Syntax Empfangen | ZERO | Vorhanden in |
Type | Variable w | Setup Software | Ja
ASCII Format | Command | CANBus Objektnummer | 3857 (hex)
DIM |  | PROFIBUS PNU | 1657 (dec) IND = 33 (dec)
Bereich |  | DPR | 857 (dec)
Default | - |
Opmode | 2 | Datentyp Bus/DPR | -
Verstärker Status |  | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.10
Funktionsgruppe | feedback | EEPROM | Nein
Kurzbeschreibung | Automatische Kommutierungswinkelermittlung

Beschreibung

Mit dem Befehl ZERO wird die automatische Kommutierungswinkelermittlung gestartet.

Optional kann die Ausführungszeit (in ms) angegeben werden. Ohne Zeitangabe wird 1000 ms verwendet. Sinnvoller Zahlenbereich liegt zwischen 1000 und 20000 ms.Die Motorwelle sollte hierbei lastfrei drehen können.
Mit dem Wert REFIP2 kann der Wert für die Motorwicklungsbestromung vorgegeben werden.


ASCII Deutsch ZEROTIME

ASCII - Kommando | ZEROTIME |
Syntax Senden | ZEROTIME [Data] |
Syntax Empfangen | ZEROTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3912 (hex)
DIM | ms | PROFIBUS PNU | 1842 (dec) IND = 33 (dec)
Bereich | 100 .. 60000 | DPR | 1042 (dec)
Default | 10000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.90 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.11
Funktionsgruppe | feedback | EEPROM | Ja
Kurzbeschreibung | Default Zeitwert für die ZERO-Funktion

Beschreibung

Das Kommando ZEROTIME definiert die Bestromungszeit für die Kommutierungsfindung (s. Kommando ZERO). Falls das Kommando ZERO ohne Parameter aufgerufen wird, so wird die Bestromungszeit dem Parameter ZEROTIME entnommen. Dies ist besonders nützlich, wenn die ZERO-Funktion über Feldbus gestartet wird.